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1 Introduction

This is the User’s Guide for Viz Graphic Hub.

This section contains information on the following topics:

• About the Document

• Customer Feedback and Suggestions

1.1 About the Document
This User’s Guide covers the information needed to configure and operate the Viz
Graphic Hub (GH).

This section contains information on the following topics:

• Document Structure

• Related Documents

• Conventions

1.1.1 Document Structure

This document contains information on the following topics:

• Getting Started

• Configurations and Modes

• Viz Graphic Hub Terminal Workbench

• Viz Graphic Hub Manager Workbench

• Task Workflow

• Administrator Operations

• Viz Graphic Hub REST

• Troubleshooting

1.1.2 Related Documents

For complementary information, see the following documents:

• Viz Artist User’s Guide

• Viz Engine Administrator’s Guide

1.1.3 Conventions

The following typographic conventions are used in this document:

• Italic is used for non-hyperlink external references, such as related documents,
books, or Internet pages. Italic is also used to emphasize words.

• The color blue is used for hyperlinked external references, and also internal
references to sections or document elements (such as tables or figures) in the
current document.

• Bold refers to GUI components.
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1. Numbered paragraphs are used to show tasks that must be followed.

1.2 Customer Feedback and Suggestions
We encourage suggestions and feedback about our products and documentation. To
give feedback and, or suggestions, please identify your local Vizrt customer support
team at www.vizrt.com.

1. Go to www.vizrt.com.

2. Click on Contact (1).

3. The Vizrt office which is nearest to your location will be shown (2), or select from
the list of Vizrt offices.

4. Click on ‘Contact’.

5. Complete the required details in the window that opens.

Note: If this message is for Customer Support, and their is a Support
Contract in place, then click on the ‘For support requests, please visit our
support portal’ link in the message window.

6. Click on CONTACT ME.

A Vizrt representative will contact you as soon as possible.

1.3 Customer Support Request
Support Requests are supported by Vizrt if Customers have a valid Service Agreement
in operation. Customers who do not have a Service Agreement and would like to set up
a Service Agreement should contact their regional sales representative (see Customer
Feedback and Suggestions).
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When submitting a Support Request relevant and correct information should be given
to Vizrt Support, to make sure that Vizrt Support can give the quickest and best
solution to your Support Request.

This section contains information on the following topics:

• Before Submitting a Support Request

• Submitting a Support Request

• Viz Graphic Hub Log Files

1.3.1 Before Submitting a Support Request

Before a Support Request is submitted make sure that you:

Read:

• The relevant User Guide or Guides

• The release notes

and Check:

• That the system is configured correctly

• That you have the specified hardware, tested and recommended versions

Always refer to your Vizrt Service Level Agreement document.

See Also

• Customer Support Request

• Submitting a Support Request

• Viz Graphic Hub Log Files

1.3.2 Submitting a Support Request

When completing a Support Request, add as much information as possible.

This section contains information on the following topics:

• Content of a Support Request

• To submit a Support Request

Content of a Support Request

The report should contain information about these topics:

• General:

• Problem description: Include a good description of what the problem is and
how to reproduce it. Remember to use simple English.

• Screen shots and illustrations: Use to simplify the message.

• System network: Add a description of how the network, bandwidth, routers,
and switches are configured.

• System setup: Describe differences in the installation, if any, from the
recommended setup.
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• Viz Graphic Hub:

• System Reports: Export the System Report files thru the Viz GH Terminal (see
Reporting). If Viz Graphic Hub is running as a Viz GH Replication cluster export
the reports from Viz GH Main and Viz GH Replication.

• Viz GH Terminal:

• System Reports: Export the System Reports thru the Viz GH Terminal on the
tasks source and destination server (see Reporting).

• System Dump files: If Viz GH Terminal crashed the dump files can be found in
the Viz GH Terminal installation directory (VizGHTerminal_crashtime_.dmp).

• Viz GH Deploy Agent:

• System Reports: Export the System Reports thru the Viz GH Terminal on all
source and destination servers which the current Viz GH Deploy agent has tasks
deploying from and to (see Reporting).

• System Dump files: If the Viz GH Deploy Agent crashed the dump
files can be found in the Viz GH Deploy Agent installation directory
(VizGHDeployAgent_crashtime_.dmp).

If there is no Viz GH terminal running on the workstation where the Viz GH Deploy
Agent is running, also attach the information detailed below:

• Event logs: Send the system, application and vizrt event logs (see Viz Graphic
Hub Log Files).

• Viz GH Connection log: Send the Viz GH connection log files (see Viz Graphic
Hub Log Files).

• Software configuration: Add exact versions of software (-build) used.

• Hardware configuration: Add exact versions of hardware (-build) used.

• Viz GH Manager:

• System Reports: Export the reports thru the Viz GH Terminal on the
workstation where the Viz GH Manager was running (see Reporting).

• System Dump files: If the Viz GH Manager crashed the dump files can be found
in the Viz GH Manager installation directory (VizGHManager_crashtime_.dmp).

If there is no Viz GH Terminal running on the workstation where the Viz GH Manager
is running also attach the information detailed below:

• Event logs: Send the system and application event logs (see Viz Graphic Hub
Log Files).

• Viz GH Connection log: Send the Viz GH connection log files (see Viz Graphic
Hub Log Files).

• Software configuration: Add exact versions of software (-build) used.

• Hardware configuration: Add exact versions of hardware (-build) used.

• Viz GH REST:

• System Reports: Export the System Reports thru the Viz GH Terminal on the
configured Viz Graphic Hub (see Reporting).

• System Dump files: If the Viz GH REST crashed the dump files can be found in
the Viz GH REST installation directory (VizGHREST_crashtime_.dmp).

• Event logs: Send the system and application event logs (see Viz Graphic Hub
Log Files).

• Viz GH Connection log: Send the Viz GH connection log files (see Viz Graphic
Hub Log Files).
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• Viz GH REST logs: Send all Viz GH REST log files (see Viz Graphic Hub Log
Files).

• Software configuration: Add exact versions of software (-build) used.

• Hardware configuration: Add exact versions of hardware (-build) used.

To submit a Support Request

1. Go to Vizrt.com.

2. Click on Support (1).

3. Click on Report a case (2).

4. Click on LOG IN (3).

5. Login to the Customer and Partner portal.

6. Click on Report a Case (4).

7. In the online form complete the required minimum information (shown by a red
asterisk):

• Contact: Your name

• Account: Your account
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• Product: The product the support request refers to.

• Case Type: The type of support request required

8. Click SAVE.

9. In the saved Support Case that opens, complete the various text boxes and upload
any required documents, files, etc. (see Content of a Support Request).

Note: The entered text or uploaded documents / files are automatically added.

To track the status of open support tickets, login to the Customer and Partner portal.
Add information or communicate about the cases directly with the support team.

See Also

• Customer Support Request

• Before Submitting a Support Request

• Viz Graphic Hub Log Files

1.3.3 Viz Graphic Hub Log Files

Viz GH Reports

Generate a compressed log report thru the Viz GH Terminal (see Reporting).

• Purpose: All Viz Graphic Hub log files and additional system information.

If there is no Viz GH terminal running on the workstation where the Viz GH Deploy
Agent is running select and generate these log files:

• Viz GH Log files

• Location: <current Viz GH data directory>/LogFiles

• Purpose: Viz Graphic Hub runtime and error information.

• System Event Log

• Location: Start -> Run... -> eventvwr.exe -> Event Viewer -> Windows Logs

• Name: System

• Purpose: Information from the current windows system.

• To create: Right click on System and select Save all Events as...

• Application Event Log

• Location: Start -> Run... -> eventvwr.exe > Event Viewer -> Windows Logs

• Name: Application

• Purpose: Windows crash information of programs

• To create: Right click on Application and select Save all Events as...

• Vizrt Event Log

Viz GH Deploy Agent system log (only exists if Viz GH Deploy Agent is installed).

• Location: Start -> Run... -> eventvwr.exe > Event Viewer -> Applications and
Services Logs

• Name: Vizrt

• Purpose: Deploy agent event log.
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• To create: Right click on Vizrt and select Save all Events as...

Viz GH Connection Log

Viz GH Manager, Viz GH Terminal, Viz GH Rest and Viz GH Manager also log their
connection to their connected Viz Graphic hubs.

• Location: Application installation directory

• Name: VizGH<application>.log

• Purpose: Information on the Viz Graphic Hub database connection

Viz GH REST Log files

• Location: <Viz GH Rest Installation Directory>\logs\

• Purpose: Connection, error and event logs of the Viz GH REST.

1.4 Overview
This chapter contains information on the following topics:

• Application Overview

• General Database Information

• Viz Graphic Hub

• Viz Graphic Hub Namingservice

1.5 Application Overview
Viz Graphic Hub is the database solution where all Viz Artist items are taken care of.
Items can be scenes, geometry, images, materials, fonts, and so on.

To start Viz Artist successfully, you must log in to a running Viz Graphic Hub. The
database can either be a local instance, where only one user can log in, or it can be a
multi-user database.

The Viz Graphic Hub solution consists of various applications:

• Viz Graphic Hub

• Viz Graphic Hub Namingservice

• Viz Graphic Hub Terminal

• Viz Graphic Hub Manager

• Viz Graphic Hub Deploy Agent

• Viz Graphic Hub REST

The Viz Graphic Hub is the physical back-end server where the database content is
stored.

The Viz Graphic Hub Namingservice monitors all applied servers in the network. For
more information about this application, see Viz Graphic Hub Namingservice .

The Viz Graphic Hub Terminal provides a user interface to configure and start/stop
both the Viz Graphic Hub Namingservice and the Viz Graphic Hub Server. For more
information about this application, see Viz Graphic Hub Terminal Workbench .
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The Viz Graphic Hub Manager is used to administer one or more databases. For
example, the server items and access levels for users and groups can be managed
from this application. For more information, see Viz Graphic Hub Manager Workbench .

The Viz Graphic Hub Deploy Agent upgrades the Viz Graphic Hub solution with a
powerful service to copy directories/projects/files with all necessary data (referenced
directories/projects/files) from one server to another. For more information, see Direct
Deploy Copy (DDC).

The Viz Graphic Hub REST is a web-service for Viz Graphic Hub. Viz Graphic Hub
REST is an interface to retrieve and send data to and from Viz Graphic Hub thru HTTP
requests.

The Viz Graphic Hub Interface Agent provides easy access to all data on a Viz Graphic
Hub. Simply following a URL the client is able to retrieve any kind of data like scenes,
images, etc., and its metadata like owner, creation date, etc. What’s more, all
metadata like users, types, keywords can be retrieved. Any skilled web developer and
designer can build an application based upon the Viz Graphic Hub Interface Agent.

For example, if you have a scene from the Super Bowl which contains an image of
the quarterback, this image can be retrieved by an external application, like a blog,
by doing a search on the Viz Graphic Hub Interface Agent. The blogger is also able to
insert this in his article for publishing to the web.

1.6 General Database Information
The Viz 3 product family uses a database to store the items clients work with. The
items can be of the following types, among others:

• Scenes

• Objects

• Materials

• Advanced materials

• Images

• Fonts

• Audio files

For more information about the various item types, see the Viz Artist User’s Guide.

The individual items are stored in the Viz Graphic Hub data directory as file objects. The
database manages the items in terms of properties and Universally Unique Identifiers
(UUIDs). These are visualized in Viz Graphic Hub Manager as folders and projects.
These folders and projects are only virtual, and cannot be treated in the same way as
folders in Microsoft Windows.

Clients can work with and organize items through the Viz Artist GUI in a logical project
and folder structure provided by the database. Although each item can be listed in/
referenced from more than one project or folder, it will reside in the database in a
single instance. A checksum will be calculated for each item, so that duplicate items
can be easily found. For more information about finding duplicates, see Locating
Duplicates .

Item Properties

Various properties are associated to each individual item in the database:
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• Name

• Path

• Item type

• File size

• Checksum

• UUID

• Rights

• Keywords

• File-links

• References

• Etc.

For more information about the properties, see Item Properties .

Projects and Folders

The database is able to maintain a logical structure composed of projects and folders.
This helps Viz Artist users to keep an overview of the items they work on. The tree
of projects/folders is only virtual, the items are not actually stored on the hard disk
with such a structure. All the projects/folders an item is shown in, are stored in the
properties of the item. The main benefit of this virtual structure is that the item itself is
stored only once in the database, with links to it. The hard disk space is then kept low
and the administration of the items is much easier.

Links and References

In the database, items are linked and referenced. Every item “knows” which project or
folder it is placed in, which other items it uses, and also by which other items it is used.
For example, in a scene, fonts and images are used. If one of the items that are used in
the scene changes, the scene will use the item in its new state. Every item holds a list
of links and references in its properties. For more information, see References and Link
Properties .

Three types of links and references are handled by the database: folder-links, file-
references, and file-links.

Folder-Links

 Every item in the database holds information about the projects/folders it is placed
in. These entries are called folder-links. Each item can hold as many folder-links as
necessary. The item is physically stored in the database only once, but it can be
virtually available in various folders. The UUID of the item will be identical in all folders.

If an item is deleted within a project or folder, only the folder-link to this project or
folder will be removed. The item will remain in the database, unless every folder-link
is removed. When the last folder-link is removed, the item will be deleted from the
database.

 In the Explorer, an item that holds more than one folder-link will be shown as an icon
with an arrow.

File-References
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In everyday use, it is necessary for an item to reference other items. For example, a
scene can contain images. The root item must be linked to all the items it utilizes. The
file-reference feature keeps track of all other items being used by this item.

File-Links

In everyday use, it is also necessary for an item to be referenced by other items. The
root item must be linked to all the items it is utilized by. The file-links feature keeps
track of all other items the item is used by.

Keywords

To help users organize their work, keywords can be applied to items. Up to 20 keywords
can be applied to each item. Every item holds a list of keywords in its properties (see
Keywords).

Tip: Keywords can be used as a database search criteria.

Data Locking

Three different types of data locking exist within the database: session lock, check out,
and access rights.

Session Lock

As long as the session lock is active, only the user who has locked the item is able to
save it in the database. Other users can only view the item.

A locked item is marked in Viz Artist and Viz Graphic Hub Manager (if the files view type
is set to icons) with a keyhole icon.

A session lock is automatically applied to an item when a user opens it in Viz Artist. The
session lock is removed once the item is closed. A session lock is valid as long as the
user who has locked the item is connected to the server. When the user disconnects,
the lock is opened. To end a session lock, the user who locked it, or the administrator,
can manually unlock it.

Check Out

As long as the check out is active, only the user who has checked out the item is able
to save it in the database. Other users can just view the item.

A checked out item is marked in Viz Artist and Viz Graphic Hub Manager (if the files
view type is set to icons) with a stop icon.

Every item in the database can be checked out. The check out of an item is valid until it
is checked in again. Check in can be performed by the user who checked out the item,
or the check out can be cancelled by the administrator.

Access Rights

The database is able to maintain rights on items and projects/folders. Individual rights
for user, group, and world can be set either to allow or disallow reading and/or writing
rights.
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IMPORTANT! Viz Artist 3.3.x cannot handle access rights. It is strongly
inadvisable to make changes in the server that may impact work on the clients.

• User: Sets the rights for the owner of an item or project or folder.

• Group: Sets the rights for all the members of the group the owner belongs to.

• World: Sets the rights for all database users.

See Also

• Managing Users and Groups

• To set rights for a project or folder

1.7 Viz Graphic Hub
The Viz Graphic Hub makes the database available to clients in the network. To log in
to and work with Viz Artist, the user must connect to a running Viz Graphic Hub server
on a machine in the network. The server is started and shut down from the Viz Graphic
Hub Terminal.

Note: Servers in a replication configuration must be shut down from the Viz
Graphic Hub Manager (see Shutting Down a Server).

Various parameters can be defined in Viz Graphic Hub Terminal before startup, for
example the name and the data directory to where the database should have its root
folder (see Terminal Options ).

1.8 Viz Graphic Hub Namingservice
As there can be many Viz Graphic Hub Servers running on the same network, the Viz
Graphic Hub Namingservices monitor and keep track of all the servers. A Viz Graphic
Hub Server cannot run without a running namingservice. A namingservice can be
started together with a server, or a running namingservice in the network can be
applied.

When a server is started, the applied namingservice will be informed. The
namingservice then knows that the server is available for client connections.

The namingservice application is started and shut down from the Viz Graphic Hub
Terminal. The port used for the communication between the namingservice and the
clients can be defined in the terminal before startup.

To avoid having a single point of failure, for main and replication server configurations,
it is absolutely necessary that each instance to have its separate namingservice.

1.8.1 Supported Configurations

Both the Viz Graphic Hub Namingservice and Viz Graphic Hub Server can run
independently of each other, even on separate physical machines. The following two
configuration scenarios are supported.

Each Server Connecting to its own Namingservice
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In this type of configuration, the clients are able to connect to only one server. Such
a configuration is used when working in single-user mode. In single-user mode, the
server, namingservice, and all other Viz 3 products that connect to the database must
be installed on the same physical machine. As the server is working on the “localhost”
in this configuration, other clients cannot see the namingservice or server.

IMPORTANT! Although a localhost can never be accessed from client applications
such as Viz Artist, it is possible to monitor and start/stop localhost servers/
namingservices if enabling this in Viz Graphic Hub Manager.

This type of configuration is typically used when working on a stand-alone computer.

Multiple Servers Connecting to one Namingservice

In this type of configuration, the clients are able to connect to all servers managed by
the defined namingservice. In multi-user mode, the server and namingservice will be
available to all clients in the network. The namingservice will use the hostname of the
computer it runs on as its name. By default, the name of the server will be Viz Graphic
Hub, but this can be modified in Viz Graphic Hub Terminal before startup. For more
information, see Terminal Options .
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2 Getting Started

This section contains information on the following topics:

• System Prerequisites

• Normal Installation

• Installation for Replication

• Configuring Viz Graphic Hub Terminal

• Starting Viz Graphic Hub

• Starting the Viz Graphic Hub Manager

2.1 System Prerequisites
The system requirements depend on the type of installation:

• Minor Installations

• Major Installations

See Also

• Deploy Agent Requirements

• Viz Graphic Hub Rest Requirements

2.1.1 Minor Installations

Minor installations mean laptops and single workstations. The ideal configuration is Viz
Graphic Hub 5/4 Free and Viz Graphic Hub Localhost.

The following hardware is required:

• PC with Window XP, Vista or 7 installed

• Any network card

2.1.2 Major Installations

Major installations refer to servers that will handle multiple clients accessing the Viz
Graphic Hub.

The following hardware is required:

• PC with Windows 2003 Server SP2 or Windows 2008 Server 32/64 bit installed

• No other applications may be installed on the server machine!

• Anti-virus software without endpoint protection

Hardware specs at a glance

CPU1 Quad-Core Intel® Xeon® E5345 (2.33GHz, 1333MHz FSB, 80W)

CPU2 Quad-Core Intel® Xeon® E5345 (2.33GHz, 1333MHz FSB, 80W)
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Main memory 4GB consisting of 4x1GB FBD PC2-5300

Graphics Integrated ATI ES1000, 32MB video standard

16 bit color: maximum resolution of 1600 x 1200

32 bit color: maximum resolution of 1280 x 1024

HDD 4x HP 146GB Hot Plug 2.5 SAS 10.000 RPM, configured as
RAID5 leaving ~400GB of free disk space for data- and ~40 GB

for separate OS partition.

(customizable, up to 8x 146 GB SAS)

Optical drive HP 8X Slim DVD+RW Drive

Dimensions 3.38 x 17.54 x 26.01 in (8.59 x 44.54 x 66.07 cm)

Weight Min: 47.18 lb (20.41 kg) Max: 60 lb (27.22 kg)

OS Microsoft Windows 2003 Server Standard Edition (32bit)

Hardware specs at in details

Slots 4 available - 3 full, 1 low profile PCI-Express slots and optional
PCI-X slots (riser card required)

Network

(redundant)

2 Embedded NC373i Multifunction Gigabit Network

Adapters with TCP/IP Offload Engine.

Power supply

(redundant)

800W

Ports 1x Serial

1x Pointing Device (Mouse)

1x Graphics

1x Keyboard

2x VGA (1 front, 1 back)

2x Network RJ-45

1x iLO 2 remote management port

5x USB 2.0: 2 front, 2 back, 1 internal

Configuration Details

• RAID5 over all disks

• Disable indexing service for directory containing Viz Graphic Hub data

• Expand priority: medium

• Rebuild priority: high

• Cache Usage: 50% (read) - 50% (write)

2.1.3 Deploy Agent Requirements

The system requirements depend on the type of installation:
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• Major Installations

• Minor Installations

Major Installations

Major installations refer to servers that will handle large data transfers and/or multiple
tasks to several Viz Graphic Hubs.

The following hardware is required:

• PC with Windows 2003 Server SP2 or Windows 2008 Server 32/64 bit installed

• No other applications, including Viz Graphic Hub, may be installed on the server
machine!

• Anti-virus software without endpoint protection

Hardware specs at a glance

CPU Intel Core 2 Duo E7500, 2x 2.93GHz

Main memory 4GB consisting of 4x1GB

HDD ~80GB of free disk space for data- and ~40 GB for separate OS
partition.

OS Microsoft Windows 2003 Server Standard Edition (32bit)

Minor Installations

Minor installations mean laptops and single workstations. The ideal configuration is a
deploy agent that runs a tasks with moderate volumes of data transfers.

The following hardware is required:

• PC with Window XP, Vista or 7 installed

• 5 GB of free disk space

• Any network card

2.1.4 Viz Graphic Hub Rest Requirements

The system requirements depend on the type of installation:

• Major Installations

• Minor Installations

Major Installations

Major installations refer to servers that will handle lots of client calls to Viz Graphic Hub
Rest and/or having backend Viz Graphic Hub servers with a large number of files.

The following hardware is required:

• PC with Windows 2003 Server SP2 or Windows 2008 Server 32/64 bit installed

• No other applications, except for Viz Graphic Hub in 5/4 Free or Localhost
configuration, may be installed on the server machine!

• Anti-virus software without endpoint protection
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Hardware specs at a glance

CPU1 Quad-Core Intel® Xeon® E5345 (2.33GHz, 1333MHz FSB, 80W)

CPU2 Quad-Core Intel® Xeon® E5345 (2.33GHz, 1333MHz FSB, 80W)

Main memory 4GB consisting of 4x1GB FBD PC2-5300

HDD 4x HP 146GB Hot Plug 2.5 SAS 10.000 RPM, configured as
RAID5 leaving ~400GB of free disk space for data- and ~40 GB

for separate OS partition.

(customizable, up to 8x 146 GB SAS)

OS Microsoft Windows 2003 Server Standard Edition (32bit)

Note: If you also want to run this machine as your general web server, Vizrt
cannot make specific recommendations regarding hardware requirements.

Minor Installations

Minor installations mean workstations with moderate workloads. The following
hardware is required:

• PC with Windows 2003 Server SP2 or Windows 2008 Server 32/64 bit installed

• No other applications, except for Viz Graphic Hub in 5/4 Free or Localhost
configuration, may be installed on the server machine!

• Anti-virus software without endpoint protection

Hardware specs at a glance

CPU Intel Core 2 Duo E7500, 2x 2.93GHz

Main memory 4GB consisting of 4x1GB

HDD ~200GB of free disk space for data- and ~40 GB for separate
OS partition.

OS Microsoft Windows 2003 Server Standard Edition (32bit)

2.2 Normal Installation
The Viz Graphic Hub solution comes with an install wizard that helps to setup the
system. There are five system configurations. Check the System Configurations to see
if a dongle is necessary.

This section describes how to setup a single-database solution. To setup a cluster
solution that handles failover situations, a combination of the Main and Replication
system configurations must be setup. This is detailed in Installation for Replication.
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2.2.1 Important Before Installation

There are a few things that must be taken into notice before uninstalling/installing a Viz
Graphic Hub solution.

• When upgrading Viz Graphic Hub, make sure that there are no open transactions in
the existing system. Then remove the old version of the system before reinstalling
it.

• Do not use Windows Remote Desktop to install and/or work with Viz Graphic Hub.
Instead, use another remote tool, for example VNC.

• On the server machine, make sure that no other applications on the same
workstation can cause performance problems. Examples of situations when
databases should not be installed; the general CPU usage is above normal, Viz
Artist is used on the same machine, other databases run on the same machine, the
network traffic is extensive, and so on. Also note that running a virus scanner on the
Viz Graphic Hub machine can decrease the performance of the database.

• The performance of the database depends upon the performance of the physical
machine the database runs on. As system performance increases, so does the
database performance. This is why it is highly recommended to use a server with
high performance.

• The cluster solution is the only server setup with built-in backup. For all other
system configurations, it is imperative that other backup procedures are manually
applied. Note that backup operations can only be performed when the server is shut
down.

2.2.2 Running the Installation Wizards

You have the option of installing Viz Graphic Hub Terminal as a service. To do so, make
sure to perform the steps for custom installation indicated below.

To install Viz Graphic Hub Terminal

1. Double-click the VizGraphicHub.x.x.msi file.

The wizard launches

2. Click Next to proceed.
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The end user license agreement is shown.

3. Read the agreement, check the I agree check box, and click Next to proceed.

You are presented with your options for System Configurations.

4. Select the mode most suitable for your system configuration, and click Next to
proceed.



Viz Graphic Hub User Guide

Copyright © 2016 Vizrt Page 29

You are presented with setup type options. The recommended option is Typical,
unless you have chosen a mode above that required a Viz Graphic Hub dongle
and/or you want to install Viz Graphic Hub Terminal as a service.

5. If you opt for Custom installation, proceed with the following steps:

1. To install Viz Graphic Hub Terminal as a service, click Viz Graphic Hub
Startup Service and select Will be installed on local hard drive.

Note: This option does not work on all operating systems; consult the
release notes for details.

2. To manually set the data directory, click Data Directory and then click
Browse. Select a folder to be the data directory.

3. If you do not want the Viz Graphic Hub Terminal to start up automatically
when you start your machine, click Autostart and select Entire feature
will be unavailable.

4. The Dongle driver option is selected by default if the mode you selected
requires it. You have the option of deselecting it as well (in which case you
can update your drivers through Windows).

6. Select the setup type and click Next to proceed.
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Viz Graphic Hub is now ready for installation.

7. Click Install.

Viz Graphic Hub is installed on your machine.

When the installation is finished, the final screen is shown.
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8. Click Finish.

To install Viz Graphic Hub Manager

1. Double-click the VizGHManager.x.x.msi file.

The wizard launches.

2. Click Next to proceed.

3. In the End-User License Agreement panel that opens, select the I accept the
terms in the License Agreement check box.
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4. Click the Next to proceed.

5. Click Next to proceed.

Viz Graphic Hub Manager is ready to install;

6. Click Install.

The applications is installed on your machine.
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Installation finishes.

7. Click Finish.

2.3 Installation for Replication
Replications in Viz Graphic Hub means that every transaction performed on the primary
server is immediately mirrored on the replication server. In failover situations where the
main server becomes unavailable, the system will automatically redirect all clients from
the main server to the replication server.

A failover situation occurs when one of the servers become unavailable due to
hardware failure, software errors, power loss, etc. A main server crash results in a
failover situation, where the main server will switch to the replication server in real-
time. A regular Viz Artist user will not detect the server switch. On the main server
machine, the Viz Graphic Hub Terminal GUI will show the Cluster Not Connected status,
and if the e-mail functionality is enabled, one or more error e-mails will be sent.

Usually a Viz Graphic Hub Server in a cluster configuration is running in real-time
replication. In case of network overload, loss of another server in the cluster, or other
serious system instabilities, Viz Graphic Hub automatically switches to recovery mode.
This means that one server buffers all necessary transactions, for example saving
files. Then Viz Graphic Hub deploys these files to the other server in the cluster when
the resources are available again. After 15 seconds of no incoming transactions, Viz
Graphic Hub Server will switch to real-time replication again, and the data structure will
be updated so that it is reflected on both servers. If clients were directed to another
server than the primary during the down-time, the clients will be re-directed to the
primary server again.

2.3.1 Important Before Installation

There are a few issues that must be taken into notice before uninstalling/installing a Viz
Graphic Hub solution.

• When upgrading Viz Graphic Hub, make sure that there are no open transactions on
either of the existing systems. To check this, Perform the procedure To verify there
are no open transactions.
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Note: The Open Transactions setting is only available for servers in a cluster
environment.

• In a cluster configuration, the Viz Graphic Hub version number must be identical
on the Main and Replication machines. Mixed versions of Viz Graphic Hub are not
supported. Failure to heed this can lead to serious system failure and data loss. See
also Cluster Timeout Settings for Viz Graphic Hub Replication Server Mode.

• Make sure that the data directories of the main and replication servers are unique,
so that no other solutions share these directories.

• Do not use Windows Remote Desktop to install and/or work with Viz Graphic Hub.
Instead, use another remote tool, for example VNC.

• Make sure that no other applications on the server workstations can cause
performance problems. Examples of situations when databases should not
be installed; the general CPU usage is above normal, Viz Artist is used on the
same machine, other databases run on the same machine, the network traffic is
extensive, and so on. Also note that running a virus scanner on the Viz Graphic Hub
machine can decrease the performance of the database.

• The performance of the database depends upon the performance of the physical
machine the database runs on. As system performance increases, so does the
database performance. This is why it is highly recommended to use a server with
high performance.

To verify there are no open transactions

1. Open Viz Graphic Hub Manager on both the machines (main and replication).

2. From the main menu, select Tools -> Monitor Servers.

3. Verify that Open Transactions are zero.

4. Remove the old version of Viz Graphic Hub before reinstalling it.

2.3.2 Important Upgrade Information

Using the same content is essential. As such, the underlying data directory must be
available on both hosts as well as the server. The data directory must be copied first,
rather than two points accessing a single directory.

2.3.3 Installing the Replication

To setup a Viz Graphic Hub solution in replication mode, two separate workstations
must be available. Special Viz Graphic Hub dongles must be applied to each machine,
otherwise the installation will not be successful. On one machine, the Main server
will be installed and configured. On the other machine, the Replication server will be
installed and configured.

Installation for replication consists of the following tasks:

• Installing the Main Server

• Installing the Replication Server

• Testing a Replication

• Detecting and Solving Server Differences
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2.3.4 Installing the Main Server

To install the main server

1. Run the Viz Graphic Hub install wizard, and then in the Welcome panel, click the
Next button.

2. In the End-User License Agreement panel that opens, select the I accept the
terms in the License Agreement check box.

3. Click the Next to proceed.

4. In the Choose Viz Graphic Hub Mode panel that opens, select Viz GH Main
Server.

5. Click the Next to proceed.

6. In the Choose Setup Type panel that opens, select the Custom installation type.

7. In the Custom Setup panel that opens, select the Data Directory from the tree,
and then click the Browse button.

8. From the Change Destination panel that opens, define the location of the data
directory, and then click the Ok button.

Note: Make sure that the location of the data directory is unique, so that no
other data directory is pointed to the same folder.

9. Back in the Custom Setup panel, click the Next button.

10. In the Ready to Install Viz Graphic Hub panel that opens, click the Install button.

The setup wizard will then install Viz Graphic Hub on the main machine, and Viz
Graphic Hub Terminal will automatically be launched.

2.3.5 Installing the Replication Server

To install the replication server

1. Run the Viz Graphic Hub install wizard, and then in the Welcome panel, click the
Next button.

2. In the End-User License Agreement panel that opens, select the I accept the
terms in the License Agreement check box.

3. Then click the Next button.

4. In the Choose Viz Graphic Hub Mode panel that opens, select Viz GH Replication
Server.

5. Then click the Next button.

6. In the Choose Setup Type panel that opens, select the Custom installation type.

7. In the Custom Setup panel that opens, select the Data Directory from the tree,
and then click the Browse button.

8. From the Change Destination panel that opens, define the location of the data
directory, and then click the Ok button.

Note: Make sure that the location of the data directory is unique, so that no
other data directory is pointed to the same folder.

9. Back in the Custom Setup panel, click the Next button.

10. In the Ready to Install Viz Graphic Hub panel that opens, click the Install button.
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The setup wizard will then install Viz Graphic Hub on the replication machine, and Viz
Graphic Hub Terminal will automatically be launched.

Setup in Viz Graphic Hub Terminal

To setup a cluster configuration in Viz Graphic Hub Terminal

1. In Viz Graphic Hub Terminal on the main machine, make sure that the replication
machine is defined as the Viz GH Replication Server Host.

2. Verify that the server on the replication machine is defined as the Viz GH
Replication Server Name.

Note: For more information on user interface message color schemes, see
Main/Replication Colors.

3. If the system cannot detect the replication server automatically in the drop-down
list, try clicking Search to locate it. If no replication server is found through the
search, and Viz Graphic Hub Terminal is running on the Replication machine, see
Troubleshooting .

4. Double-check that the data directory is the same as the one defined in the
installation wizard.

Note: If a previous Viz Graphic Hub version has been installed on the
machine before, the system will remember the old data directory and use
this by default instead of the new one.

5. Select the Autostart Replication Server After Successful Start check box.

6. Next, click the Autoconfig button.

This will automatically configure the replication server so that it corresponds to
the settings of the main server.

7. To save the changes on the main machine, click either the Ok or Apply button.

8. To verify that the configuration has been auto-configured correctly on the
replication machine, view the Viz Graphic Hub Terminal settings on the replication
machine.
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The replication cluster is now ready to be started.

9. On the main machine, click the Start button.

IMPORTANT! Always make sure that the main server is started before the
replication server.

After a successful start on the main machine, the server on the replication machine
should start automatically in replication system configuration. During startup, when
only the main server is up and running, the status is Cluster Down. After a successful
startup, the status is changed to Cluster Running, and the server/namingservice icon
turns orange. The label on the Start button also switches to Shutdown. Clicking the
Shutdown button shuts down the server.

Main/Replication Colors

The labels related to the main/replication configuration in the Viz Graphic Hub Terminal
can be colored in various ways.

• Green (Valid) - Viz Graphic Hub Terminal is ready to start Viz Graphic Hub Server
with the current cluster configuration.

• Black (Incomplete Configuration) - One of the cluster machines has not selected
the other machine as its dependant, so the current cluster configuration cannot be
started. To verify the cluster configuration, click the Autoconfig button, or manually
select the server on the dependant terminal. Always remember to click the Ok or
Apply button in the main window to commit any changes.
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• Red (Invalid) - The main/replication server is already running in another cluster, so
it is not possible to start the current configuration.

• Orange (Connected in Running Cluster) - A replication server is configured and
running in the current cluster. The main server that is currently being configured is
not running. It is possible to start and modify some of the parameters, but it is not
possible to change for example the current server start up mode.

2.3.6 Testing a Replication

This section describes how to verify a running replication, including failover. It is
strongly recommended that you test the replication in a production environment.

IMPORTANT! Before testing, make sure that no clients are working on any of the
servers in the cluster. Also, verify that the Viz Graphic Hub solution is a fresh setup
a of a replication cluster, and that the data directories on both servers are empty.

To test a replication

1. On the main machine, start Viz Graphic Hub Manager, and log in as administrator.

2. On the replication machine, start Viz Graphic Hub Manager, and log in as
administrator.
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Note: Only the administrator can modify the settings for the replication
server.

3. Open the properties of the data directory on both machines (right-click the data
folder, and then from the menu that appears, select Properties), and make sure
that the UUIDs on both machines are identical. If they are not identical, shut down
the servers, and then log in the two Viz Graphic Hub Terminal applications, delete
the data directories and restart the cluster with Viz Graphic Hub Main Server first.

4. Logout from Viz Graphic Hub Manager on the replication machine.

5. In Viz Graphic Hub Manager on the main machine, from the main menu, select
Tools -> Monitor Servers. Verify that the Health LED is green.

6. From the main menu, select View -> Messages (Chat).

7. Unplug the network cable on the main machine, and then wait for a few seconds.
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The main server should now automatically shut down to prevent data loss and
corrupted configurations in the cluster environment.

The Viz Graphic Hub Manager chat panel should show that the main server is
down and that the replication server has automatically taken over.

The main server name in the Servers and Folders Panel should also be colored red.

8. Plug the network cable in on the main machine again, and then start the main
server from the Viz Graphic Hub Terminal.

9. If no users have been working with the system while the main server was down,
proceed to the next step. Otherwise, wait a minute or two for the system to
refresh.

The Viz Graphic Hub Manager chat panel should now show that the main server is
up and running again, and that the main server has automatically taken over as
the primary server in the cluster.

If the steps above have been carried through correctly, the cluster configuration
has been tested sufficiently and is ready to work in a real production environment.

10. Query the Journal log for replication-related errors. See Querying the Journal.

2.3.7 Detecting and Solving Server Differences

When Viz Graphic Hub is running in a cluster environment and switching from realtime
replication to recovery mode, or the replication server has been performing a cluster
rebuild, the data on the servers may differ. In such situations, Viz Graphic Hub may not
be able to perform an automatic rebuild.

To detect and solve server differences

1. Make sure that the replication and main servers are up and running.

2. On the main server machine, log in to Viz Graphic Hub Manager.

3. On the replication server machine, log in to Viz Graphic Hub Manager as
administrator.

4. From the main menu, select Server -> Differences.

The Server Diff window is shown.

5. In the Server Diff window, click the Diff All button.

This will scan all items on the selected servers.
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6. Sort the entries on both servers by size (click the Size columns), and then delete
all files with a size of 0.00 KB.

7. Click the Diff All button again.

8. Now sort the entries by type, and then select all entries of type Scene, where the
row on the opposite side is labelled missing.

9. Right-click the scene entries, and then from the menu that appears, select DDC
To.

10. In the Deploy Direct Copy window that opens, click the Continue button.

For more information about the deploy feature, see To replicate on multiple
servers .

11. The Action Log for deploying files is activated. In the resulting window that opens,
click the Do It button.

The entries are deployed from one server to the other.

12. Repeat steps 7-10, and this time sort the entries by type Geom.

13. Repeat steps 8-10 for all other entry types.

2.4 Configuring Viz Graphic Hub Terminal
This section contains information on the following topics:
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• Safe Mode

• Running Viz Graphic Hub as a Service

• Network Card Selection

• Setting the Namingservice Hostname

• Server Port Selection

2.4.1 Safe Mode

Launching Viz Graphic Hub Terminal in safe mode is done if the database has crashed
and needs to be restarted. Rebuilding the database in safe mode can take several
hours, as much data may need to be reconstructed. The resulting Recovered directory
cannot be seen in Viz Artist; only a system administrator can view it in the Viz Graphic
Hub Manager.

Caution: Do not use safe mode for valid data directories!

To prepare for database repair

1. Back up the current data directory.

2. Close all Viz Graphic Hub Deploy Agent connections to the server.

3. Close all Viz Graphic Hub Rest Agent connections to the server.

4. Make sure the instance is not part of a Viz Graphic Hub Cluster environment.

5. Make sure you have the latest release of Viz Graphic Hub installed.

To start Viz Graphic Hub Terminal in safe mode

1. Click Start -> Programs -> Vizrt -> Viz GH Terminal.

The application launches.

2. From the main menu, click Options.

The Options window is shown.

3. Check the Start in safe mode check box, and click OK.



Viz Graphic Hub User Guide

Copyright © 2016 Vizrt Page 43

The safe mode startup console is shown.

4. If you have completed all instructions shown, enter <Y> and press <ENTER>.
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The rebuild process begins. Depending on the size of the database, this may take
several hours. During the rebuild process, the following console window is shown.
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If successful, the console window will end up as follows.

Once you open the Viz Graphic Hub Manager after starting the Viz Graphic Hub
Terminal in safe mode, there is a ‘recovered’ folder. It is structured in such as way as to
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make clear when changes were made, by showing a folder named for the month and
year of last modification.

You know your database was successfully restored when:

1. In the red console window, you see that the server is up and running.

2. In the Reports, you see that the file have been processed.

3. You can view your files in the Viz Graphic Hub Manager.

IMPORTANT! Do not use this instance in a production environment. Safe mode is
only to restore a database. This instance can now serve as a source for rebuilding
an empty destination database through the DDC functionality in Direct Deploy
Copy (DDC).

2.4.2 Running Viz Graphic Hub as a Service

Viz Graphic Hub Service Starter is a service which starts and restarts Viz Graphic
Hub Terminal on boot up. Viz Graphic Hub Terminal is able to start and restart the Viz
Graphic Hub Server as well.

IMPORTANT! Stopping the Viz Graphic Hub Service Starters from the Services
panel will automatically shut down Viz Graphic Hub Terminal. This can lead to
corrupted data on Viz Graphic Hub Server if it is running at the time. Make sure Viz
Graphic Hub Terminal has been shut down first.

What Viz Graphic Hub Service Starter Can Do
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Running Viz Graphic Hub as a service will help you to:

• Start and use Viz Graphic Hub Server before the login of any user

• Windows Remote Desktop sessions

• Switch between different Windows user accounts.

What Viz Graphic Hub Service Starter Cannot Do

All “native” service operations are not be possible for Viz Graphic Hub Server:

• Configuring Viz Graphic Hub Server as a service

• Stop/pause/resume Viz Graphic Hub Server

• Restart Viz Graphic Hub Server if not running but Viz Graphic Hub Terminal is
running

To run Viz Graphic Hub as a service

1. Select the option to run Viz Graphic Hub as a service during the installation
process, as it requires a custom installation. See Running the Installation Wizards.

2. Enable the following Terminal Options:

• Allow system logoff when server is up & running

• Exit Terminal after server shutdown

IMPORTANT! Enabling the options above can lead to corrupted data in
Viz Graphic Hub Server if the server is not shut down properly from the
application.

3. Click OK.
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4. Expand the Server Configuration panel and enable the following server options:

• Autostart on boot

• Autostart replication server after successful start (on main server
machine)

5. Click OK.

6. Click Start.

See Also

• Running Terminal as a Service Troubleshooting

2.4.3 Network Card Selection

If you leave the default as set at installation, the Graphic Hub will connect to all
available network cards. However, in every connection mode you have the opportunity
to manually select the network card.

To manually select the network card

1. Open Viz Graphic Hub Terminal.
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2. Select your system configuration and click the arrows beside it to open the
settings window.

3. Click the Network button.

4. Uncheck Use all network interfaces.

5. From the drop down box, select one of the network cards available on your
computer.

Tip: Always choose the fastest network card available. Virtual connections
tend to be the slowest.

6. In the Network Mapping window, click OK.

7. In the settings window, click OK.

2.4.4 Setting the Namingservice Hostname

This is only required when working in Viz Graphic Hub Main Server mode. The exact
procedure to follow depends on, and is explained in GH Network Configurations.
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2.4.5 Server Port Selection

If you leave the default as set at installation, the Graphic Hub will connect to all
available server port. However, in every connection mode you have the opportunity
to manually select the server port. This may be necessary depending on your firewall
configuration.

To manually select the server port

1. Open Viz Graphic Hub Terminal.

2. In the main menu, click Options.

3. Enter the Server Port number in the requisite field.

Tip: Make sure that this port will not be used by any other application.

4. Click OK.

2.5 Starting Viz Graphic Hub

IMPORTANT! When starting Viz Graphic Hub in a cluster configuration, ALWAYS
start the main server first.

To start Viz Graphic Hub

1. Click Start -> All Programs -> Vizrt -> Viz GH -> Viz GH Terminal.
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2. Click the Start button.

2.6 Starting the Viz Graphic Hub Manager
Before the Viz Graphic Hub Manager is started make sure that the Viz Graphic Hub is
started first (see Starting Viz Graphic Hub).

Note: When in a multiuser environment, choose any up and running Viz Graphic
Hub instance in the Network.

This section contains information on the following topics:

• Start Up with a Single Server Login

• Start Up with a Multiple Server Login

• Replication Server Login

• Auto Login

• Shutting Down a Server

• Logout

2.6.1 Start Up with a Single Server Login

When the Viz Graphic Hub Manager starts up a User Login window opens. Use this to
login to a single server.
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Note: For start up with a single server login Auto Login must be disabled. If Auto
Login is enabled the start up login window will be for Start Up with a Multiple
Server Login.

When the Viz Graphic Hub Manager has started more servers can be logged into.

This section contains information on the following topics:

• To start the Viz Graphic Hub Manager with a Single Server Login

• To login to more servers

To start the Viz Graphic Hub Manager with a Single Server Login

1. Click Start -> All Programs -> Vizrt -> Viz GH -> Viz GH Manager -> Viz GH
Manager.

The single server login window opens.

2. From the Host drop down box, select the hostname of the machine where the
server or namingservice is up and running.

Note: Available Viz Graphic Hub servers are shown in white. Unavailable
Viz Graphic Hub servers (available servers on a different sub-net), which are
configured for auto-login, are shown in yellow.

3. From the Hub drop down box, select the name of the running server.

4. If Auto Login is required, check the Enable for Auto login check box (see Auto
Login).

5. From the Name drop down box, select a user from the list of users registered in
the database, on the selected server.

6. In the Password field, enter the correct password.

Note: The default password for administrators is VizDb.

7. Click LOGIN.

To login to more servers

After Viz Graphic Hub Manager Start Up, login to more servers, if required.

• Click Server -> Login...
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2.6.2 Start Up with a Multiple Server Login

When the Viz Graphic Hub Manager starts up a User Login window opens. Use this to
login to a single server or multiple servers.

Note: For start up with multiple servers (or a single server) login, Auto Login must
be enabled (see Login in Preferences). If Auto Login is disabled the start up login
window will be for Start Up with a Single Server Login.

When there are several Viz Graphic Hub servers configured in the Viz Graphic Hub
Manager, it is possible to login to:

• A single Viz Graphic Hub Server, or

• Several Viz Graphic Hub Servers at the same time

If there are Login Profiles defined, select a profile to have a defined subset of servers
and deploy agents to login to.

This section contains information on the following topics:

• To start Viz Graphic Hub Manager with a Multiple Server Login

• To login to more servers

To start Viz Graphic Hub Manager with a Multiple Server Login

1. Click Start -> All Programs -> Vizrt -> Viz GH -> Viz GH Manager -> Viz GH
Manager.

The multiple server login window opens.

Note: Available Viz Graphic Hub servers are shown in white. Unavailable
Viz Graphic Hub servers (available servers on a different sub-net), which are
configured for auto-login, are shown in yellow.

2. Select all the relevant servers:

• Click on each server to be opened, or

• Click the Use Login profile box to select a login profile.

3. Click Login.

To login to more servers

• Click Server -> Login -> to one server... or to multiple servers...
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2.6.3 Replication Server Login

When logged to the Replication server, the administrator has rights to login to the
Main server in the Cluster and to change the content of the host (see Installation for
Replication).

This is helpful to manually deal with synchronization issues in a Main/Replication server
(Cluster). But this can also create risks for synchronization between the servers in a
Cluster.

Caution: To avoid unwanted synchronization errors, leave the As system
administrator check box unchecked. Login as system administrator only when
absolutely necessary.

To start Viz Graphic Hub Manager in a Cluster on a replication server

1. Click Start -> All Programs -> Vizrt -> Viz GH -> Viz GH Manager -> Viz GH
Manager.

2. The Login window opens.

3. From the Host drop down box, select the hostname of the machine where the
server or namingservice is up and running.

4. From the Hub drop down box, select the name of the running server.

5. From the Name drop down box, select your user from the list of users registered
in the database on the selected server.

6. Enter the password in the Password field.

Note: The default password for administrators is VizDb.

7. To log in as system administrator, check the As system administrator check
box.

IMPORTANT! Use this feature sparingly and with caution.

8. If Auto Login is required, check the Enable for Auto login check box.

9. Click LOGIN.
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2.6.4 Auto Login

Auto login allows an automatic login to one or more Viz Graphic Hubs, with the option
of bypassing the credentials, as well as requiring a password for each and every server
in the network.

A global password can be set for all registered servers as well.

To enable Auto Login

1. Click Server -> Login.

2. Click Preferences... in the main Login window,

3. Click the Use Auto login box in the Login panel of the Preferences window that
opens.
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4. To set a global password, select the Protect Auto login with password
box, and click the Set password button. In the dialog box that opens, enter a
password, and then click the OK button.

5. Alternatively, with no global password set, select the Confirm Auto login box,
and then select the servers to include in the auto-login process.

When logging in, you will be prompted to confirm each server to be logged into. To
remove a server from the auto login process, right-click the server, and then from
the list that appears, select Remove selected.

6. Click the OK button.

To disable Auto Login

1. Click Server -> Login -> to one server...

2. Open the Login preferences window:

• Click Tools -> Edit Preferences..., or

• <CTRL+8>, or
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• <CTRL+F8>

Note: The Login preferences window can also be opened in the main Login
window. Click Preferences...

3. Clear the Use Auto login box (1), in the Login panel of the Preferences window
that opens.

4. Click OK.

2.6.5 Shutting Down a Server

Detailed below are the options for shut down of one or more servers, without logging
off completely or exiting Viz Graphic Hub Manager.

• Normal Shutdown

• Limiting and Shutting Down Sessions

• Scheduled Shutdown

• Emergency Shutdown

• Shutdown Cluster

Normal Shutdown
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Normal shutdown is done in the Shutdown window.

Note: Performing a normal shutdown operation takes much longer than an
Emergency Shutdown, but is far safer for your data.

To perform a normal shutdown

1. From the main menu, click Server -> Shutdown.

2. Click a server from the list.

3. In the Message field, optionally write a message to all users of this server
informing them that the server is about to be shut down. Click Send.

4. Click Shutdown.

5. Click Close.

Limiting and Shutting Down Sessions

You can limit the active session on the server by limiting the number and/or shutting
down individual sessions.

If you are shutting down the system, you can notify clients (message, email, walk-in,
etc.) and then not allow them to reconnect (no new connections = nobody is kicked
out, but nobody new can come in).

You can limit them to 1 connection, if you just want to use a deploy agent.

Disconnect kicks the clients out unceremoniously.

To limit the number of sessions
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1. From the main menu, click Server -> Shutdown.

2. Select one or more servers on the list, and click the Modify button.

You are prompted to select how to limit the sessions on the server in question.

3. Select one of the following options:

• System default

• User defined (and enter a numerical value)

• No new connections

• No new connections (except Viz Graphic Hub Deploy)

4. Click OK.

To disconnect a selected session

1. From the main menu, click Server -> Shutdown.

2. Select one or more servers on the list, right-click and select Disconnect selected
sessions.

Scheduled Shutdown

To schedule a server shutdown

1. Click Server -> Shutdown.

The Shutdown Server window is shown.
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2. Click the Schedule button.

The Schedule Shutdown window is shown.

3. From the Mode drop down box, select one of the following options:

• Once

• Recurring

• Recurring forever

4. In the Start at drop down box, click to select a date from the calendar, and if
necessary, adjust the time.

Note: You cannot schedule tasks to begin in the past.

5. If your mode is Recurring, in the End after drop down box, click to select a date
from the calendar, and if necessary, adjust the time.

6. Select a Message notification. Your options are:

• Do not notify at all

• Just notify 5 minutes before shutdown

• Notify 15 minutes before - every 5 minutes

• Notify 30 minutes before - every 10 minutes (but at least 5 min. before)

• Notify 60 minutes before - every 15 minutes (but at least 5 min. before)

7. Click OK.

Emergency Shutdown

An emergency shutdown terminates a server immediately. It can only be performed
from the Viz Graphic Hub Terminal. Use sparingly.

Note: If the Viz Graphic Hub server is a main server in a replication environment,
the emergency shutdown will cause a failover to the replication server.

To perform an emergency shutdown
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• In the Viz Graphic Hub Terminal main window, click Emergency Shutdown.

Shutdown Cluster

For system maintenance or network configuration work in a replication environment,
the best type of shutdown operation is to shut down the cluster.

To shut down a cluster

1. In Viz Graphic Hub Manager, log in to the main server.

2. Click Server -> Shutdown.

The shutdown window is shown for the replication environment.

3. Click Shutdown Cluster.

2.6.6 Logout

This section describes how to logout of one or all servers from Viz Graphic Hub
Manager.

Note: Click Server -> Exit, to logout of all servers and exit Viz Graphic Hub
Manager at the same time.

This section contains information on the following topics:

• To logout of one server

• To logout of all servers

To logout of one server

1. Open the logout window:

• Click Server -> Logout -> from one server... or

• Press <F8>, or
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• Press <CTRL+O>

2. Select the server from the drop down box.

3. Click OK.

To logout of all servers

1. Click Server -> Logout -> from all servers...

2. Click Yes.
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3 Configurations and Modes

Depending on how you choose to set up your overall system configuration, Viz Graphic
Hub offers the following setup options.

• System Configurations

• GH Network Configurations

3.1 System Configurations
The Viz Graphic Hub Terminal can operate in the following configurations:

• Viz Graphic Hub Localhost

• Viz Graphic Hub 5/4 Free

• Viz Graphic Hub Multiuser

• Viz Graphic Hub Main Server

• Viz Graphic Hub Replication Server

Viz Graphic Hub Localhost

The Localhost mode is a single connection Viz Graphic Hub installation. This mode
is aimed at local Viz Artist installations without permanent network connections. No
dongle required.

Viz Graphic Hub 5/4 Free

The 5/4 Free mode provides five concurrent TCP/IP connections to the Viz Graphic Hub
Server. This mode is aimed at sharing content in small Viz Artist workgroups. No dongle
required.

Viz Graphic Hub Multiuser

The Multiuser mode provides multiple concurrent connections to the Viz Graphic Hub
Server. This mode is recommended for all scalable Viz Artist workgroups. Dongle
required.

Viz Graphic Hub Main Server

The Main system configuration is similar to the Multiuser mode. The difference however
is that the main server provides mirroring to a running replication server. In failover
situations, the system automatically redirects all clients from the main server to the
replication server. Dongle required.

Viz Graphic Hub Replication Server

The Replication server is a duplication of the Main server.

See Also

• Installation for Replication

• Cluster Timeout Settings for Viz Graphic Hub Replication Server Mode
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3.2 GH Network Configurations
Viz Graphic Hub can be set up in two possible configurations, as described ahead.

Each server has its own namingservice

This configuration is valid for all System Configurations. This is the most standard
configuration.

One namingservice for all (or a group of) servers

This configuration is only valid for Viz Graphic Hub 5/4 Free and Viz Graphic Hub
Multiuser.
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Note: It is necessary to have separate machines for each configuration. In the
example above, three machines are required.

To set this up one Namingservice for all

1. Start Viz Graphic Hub Terminal in Viz Graphic Hub Namingservice Only Mode.

2. Start each of the connecting servers in Viz Graphic Hub Server Only Mode.

3.2.1 Viz Graphic Hub Namingservice Only Mode

To configure Namingservice Only mode

1. Launch Viz Graphic Hub Terminal.

2. From the main menu, click Options.

3. Under Start Mode, click the Namingservice only button.

4. Click OK.
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You can now start the Namingservice only.

5. Click Start.

3.2.2 Viz Graphic Hub Server Only Mode

To configure Server Only mode

1. Launch Viz Graphic Hub Terminal.

2. From the main menu, click Options.

3. Under Start Mode, click the Server only button.
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4. Click OK.

5. In the Name of host (Namingservice) field, enter the hostname of the up and
running Namingservice.

6. In the Server field, if you are not using the default server, enter the name of the
Graphic Hub that the Namingservice is registered under.

IMPORTANT! Unique names are required for each Graphic Hub server.

7. Click OK.

8. Click Start to start Viz Graphic Hub Terminal.
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4 Viz Graphic Hub Terminal Workbench

This section contains information on the following topics:

• Terminal Options

• Refresh

• Backup

• Report

4.1 Terminal Options
A number of important configurations are set from the Viz Graphic Hub Terminal’s
Options window.

To open the Options window

• On the Viz Graphic Hub Terminal’s main menu, click Options, or
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• Press <CTRL+O>.

The options in this window vary according to the System Configurations.

4.1.1 Options for all System Configurations

The following settings apply for all System Configurations.

• Start mode: When starting or shutting down the system, the mode can be
configured to start/shutdown the server, namingservice, or both.

• Server & Namingservice: When starting the system, both the server and
namingservice will be started.

• Namingservice only: If starting the namingservice only, the hostname of
this machine will be available to all clients, for example Viz Artist. This makes
it possible to connect one or more multi-user servers running in Server Only
mode with this machine that runs in Namingservice Only mode. Define the
namingservice accordingly for Viz Graphic Hub Namingservice Only Mode.

• Server only: If starting the server only, the namingservice must run on another
host. Define the namingservice accordingly for Viz Graphic Hub Server Only
Mode. If the remote namingservice is not running or configured properly, the
server cannot be started.

• Start in safe mode: Launching Viz Graphic Hub Terminal in Safe Mode is done if
the database has crashed and needs to be restarted.

• Viz GH Server port: If you leave the default as set at installation, the Graphic Hub
will connect to all available server port. However, in every connection mode you
have the opportunity to manually select the server port. This may be necessary
depending on your firewall configuration. See Server Port Selection.

• UDP port: Defines the UDP port number the namingservice uses to directly
communicate with the other applications in the network.

• TCP port: Defines the TCP port number, which can be used to start the Viz Graphic
Hub Server remotely from Viz Graphic Hub Manager.

• Global timeout (s): Global timeout for Viz GH Terminals connection to Viz Graphic
Hub. Default: 30 seconds

• Connect timeout (s): Global timeout for Viz GH Terminal to initialize the
Connection to Viz Graphic Hub. Default: 15 seconds

• Search instances: Set the number of instances available for Viz Graphic Hub to
execute a search (the range is 1 to the number of CPU cores in the system (default
value is the number of CPU cores in the system)). This will only take effect if the
server is started as a multiuser or main/replication.
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• Process priority: Defines Viz Graphic Hub’s Windows process priority level. You
have six options ranging from Low to Realtime.

Caution: Setting the process priority level above normal may cause system
stability issues.

• Windows shutdown when server is up & running (Kill Server): This feature
is disabled by default, so that Windows cannot shut down without Viz Graphic Hub
being properly terminated. If enabled, Windows can shut down and end all Viz
Graphic Hub related processes without warning.

Caution: Enabling this feature may lead to data corruption problems.

• Allow system logoff when server is up running: This feature is disabled by
default, so that Windows cannot log off without Viz Graphic Hub being properly
terminated. If enabled, Windows can log off and end all Viz Graphic Hub related
processes without warning.

Note: When Running Viz Graphic Hub as a Service, logging off from Windows will
not terminate the Viz Graphic Hub Server.

• Exit Terminal after server shutdown: Enabling this setting makes sure that your
server is kept alive all the time, even after Viz Graphic Hub crashes, provided that
you are Running Viz Graphic Hub as a Service.

• Show notification balloons: If enabled, balloon tips are shown in the notification
area, for example when the server is started or shut down.

Note: The Show notification balloons option should be disabled if Viz Artist is
running in on-air mode.

• Automatically export a report when Viz Graphic Hub Server has been
unexpectedly shut down: Enable this for the Automatic Exporting of Reports.

4.1.2 Options for System Configurations with Viz Graphic Hub Dongle

The following advanced settings only apply for the System Configurations that require
a special Viz Graphic Hub dongle, namely:

• Viz Graphic Hub Multiuser

• Viz Graphic Hub Main Server

• Viz Graphic Hub Replication Server

Viz Graphic Hub Journal settings

• Journal level: The journal level defines how the system writes journal entries and
which entries should be included when Configuring Email Notifications. Available log
levels:

• No Logging: Disables the logging functionality
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• All: Logs all the entries listed below

• Errors: Logs fatal errors, replication errors, and so on

• Warnings: Logs errors and warnings

• File news: Logs errors, warnings, and new file entries

• File updates: Logs errors, warnings, and updated file entries

• File deletes: Logs errors, warnings, and deleted file entries

Viz Graphic Hub Terminal: Mail settings

• Enable mail: You must enable email for Configuring Email Notifications. E-mails
can be sent to defined recipients when unexpected server shutdowns occur, or the
license is about to expire or is invalid. The system will also send e-mails according
to the defined log level.

• Mail server: Defines a valid SMTP server.

• Set Default: Sets the address to the predefined format
(VizGHTerminal@<HostName>).

• From: Defines the email account that the messages should be sent from.

• Test mail: Sends a test mail to the defined recipients.

• To: Defines the default email accounts that the messages should be sent to. To add
more than one recipient, insert a blank between the addresses.

• Send mail after successful server start: In addition to the default and log level
e-mails, notifications can be sent when the server is started successfully.

Viz Graphic Hub Terminal: Journal backup settings

• Enable journal backup: If enabled, allows you To automatically export journal
entries to an XML file. By default, the journal backup interval is set to once a week,
starting one week from 01.01.2007 at 00:00:00.

• File: Defines the file name and path to where the journal backup XML file should be
placed.

• Filemode:

• Open Truncate: Only one journal backup XML file exists. The first time this
operation is performed, a new file is created. Later, the system overwrites the
existing journal file.

• New By Date: Every journal backup generates a new separate XML file. The
current date is added to the file name.



Viz Graphic Hub User Guide

Copyright © 2016 Vizrt Page 73

4.1.3 Cluster Timeout Settings for Viz Graphic Hub Replication Server
Mode

The following settings only apply for the Viz Graphic Hub Replication Server mode.

When the connection between servers fails, the connections between servers and Viz
Artist clients fail, or the main server itself fails, you can enable timeout to stabilize the
network environment.

Cluster timeout settings

• Enable timeout settings: Enable this feature if you expect to experience network
problems in your replication setup. It must be enabled on both the Main and
Replication servers.

• Server to Client timeout (sec/10): The recommended setting is 2. This
represents 2/10 of a second.

• Cluster timeout (sec/10): The recommended setting is 300. This represents 30
seconds.

• Cluster idle switchback time (sec): Set the time Viz Graphic Hub waits for
no activity from clients to return from a failover or switchback. Range is 1 to 30
seconds. The default time is 15 seconds.

4.2 Refresh
The Refresh item in the main menu allows you to change System Configurations. It is
only enabled when the server is down.

4.3 Backup
The Backup item in the main menu allows you to launch backup and restore operations.

For information on backing up and restoring, see Back Up and Restore.
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4.4 Report
Clicking Report in the main menu opens up the report window.

Report Window

For information on generating reports, see Reporting.
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5 Viz Graphic Hub Manager Workbench

The Viz Graphic Hub Manager is the main administrative tool for the Viz Graphic Hub. It
enables you to administer files and folders over multiple Viz Graphic Hubs, performing
such tasks as searching, and working with deploy agents.

This section contains information on the following topics:

• Main Menu

• Search Window

• Preferences

• Explorer

• Servers and Folders Panel

• Add-ons Panel

• Journal Panel

• Action Log

• Customizing the Interface

• Importing and Exporting Viz Graphic Hub Manager Settings

5.1 Main Menu
At system startup, the main window shows on the screen. At the top of the main
window is the main menu.

The main menu contains the following items:

• Server

• View

• Tools

• Extra

• Info

5.1.1 Server

• Login: Opens the Login window. From this window it is possible to log in to one or
more Viz Graphic Hubs. For more information, see Start Up with a Single Server
Login .

• Logout: Opens the Logout window. From this window it is possible to logout from a
Viz Graphic Hub. For more information, see Logout .

• Terminals: Opens the Terminals Window. From this window it is possible to monitor
the available terminals in the network.

• Shutdown: Opens the Shutdown window. From this window it is possible to
remotely shut down a server. For more information, see Shutting Down a Server .

• Import:
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• Viz 2.x data: Opens the Import window. From this window it is possible to
import a Viz 2.x data folder to the selected database. For more information, see
Importing Data Directories .

• Viz 2.x archive(s): Opens the Import window. From this window it is possible to
import one or more Viz 2.x archives from a folder to the selected database. For
more information, see Importing Viz 2.x Archives .

• Manually selected Viz 2.x archive(s): Opens the Import window. From this
window it is possible to import one or more Viz 2.x archives to the selected
database. For more information, see Importing Viz 2.x Archives .

• Resume from canceled or crashed import: Opens the Import window.
From this window it is possible to resume from a failed import by using an
automatically created import backup file. For more information, see Resuming a
Cancelled/Crashed Import Operation .

• Edit preferences: Opens the Preferences window. From this window it is
possible to define various preferences for the import operation, for example the
root directory for import log files.

• Differences: Opens the Server Diff window. From this window it is possible
to detect differences between the servers in a cluster environment. For more
information, see Detecting and Solving Server Differences .

The Differences option is only available if logged in to a server in a cluster
configuration.

• Administer journal entries: Shows/hides the Administer Journal Entries panel in
the Main window. For more information, see Working with the Journal .

• Configure alerts: Opens the Alerts window. From this window it is possible to
define email notifications that should be sent when errors occur in the system. For
more information, see Configuring Email Notifications .

• Exit: Shuts down the Viz Graphic Hub Manager, and also automatically logs out
from all connected databases.

5.1.2 View

• Toolbars: Select which tool bars to view:

• Main

• Servers and Folders

• Folders and files

• Quick search

• Layout

• Panels: Select which Panels to view:
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• Servers and folders

• Search

• Add-ons

• Messages (Chat): Show/hide the chat panel in the main window (see Chatting with
Artists ).

• Duplicates: Open the duplicates window. From this window it is possible to locate
duplicate server items (see Locating Duplicates).

• Object types: Opens the Object Types window (see Monitoring Object Types ).

• Active sessions: Opens the Active Sessions window. From this window it is possible
to monitor all active sessions (see Monitoring Active Sessions).

• Layouts: Select, save and maintain layouts:

• Load layout: Select a layout to load

• Save current layout ‘xxx’:

• Save current layout ‘xxx’ as...: Save the current layout as a new layout

• Lock/Unlock current layout ‘xxx’: Lock or Unlock the current layout

• Maintain layouts: Opens the Maintenance of layouts window

• Refresh explorer: Refreshes the Explorer (see To refresh the explorer ).

5.1.3 Tools

• Monitor servers: Opens the Monitor Servers window. This window shows an
overview of all the servers Viz Graphic Hub Manager is logged in to (see Monitoring
Servers ).

• Administer users and groups: Opens the Administer Users and Groups window.
From this window it is possible to manage users and groups on the various servers
(see Managing Users and Groups).

• Administer keywords: Opens the Keywords window. From this window it is
possible to manage the Keywords in the database.

• Administer add-ons: Opens the Add-ons Panel.

• Administer tasks:

• Running deploy tasks: Shows/hides the Running Deploy Tasks panel in the
Main window (see To view running deploy tasks).

• Scheduled deploy tasks: Shows/hides the Scheduled Deploy Tasks panel in the
Main window (see To view scheduled deploy tasks).

• Finished deploy tasks: Shows/hides the Finished Deploy Tasks panel in the
Main window (see To view finished deploy tasks).

• Search: Opens the Search window. From this window it is possible to search for
items in the available databases (see Searching).

• Search by UUID: Opens the Search by UUID on server dialog box. From this
dialog box it is possible to search for items in the available databases based on
universally unique identifiers.

• Configure deploy agent: Opens the Properties of Deploy Agent dialog box.
From this dialog box it is possible to define various Viz Graphic Hub Deploy agent
settings (see Deploy Agent Behavior Overview). This menu-option is only available
in setups with an installed Viz Graphic Hub Deploy agent.

• Export settings (incl. layouts) to file: Opens a window, from where it is possible
to exportall the workstation-based customizations to the Viz Graphic Hub Manager,
such as changes to any of the panels, column layout and visibility, as well as the
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user interface in general (see Importing and Exporting Viz Graphic Hub Manager
Settings).

• Import settings (incl. layouts) from file: Opens a window, from where it is
possible to importall the workstation-based customizations to a Viz Graphic Hub
Manager, such as changes to any of the panels, column layout and visibility, as
well as the user interface in general (see Importing and Exporting Viz Graphic Hub
Manager Settings).

• Edit preferences: Opens the Preferences window. From this window it is possible
to define various system preferences.

5.1.4 Extra

• Viz VR Studio Setup: Allows you to import the enabling XML file so that Viz
Graphic Hub can support a virtual set environment (see Enabling Viz Graphic Hub
for a Virtual Studio).

5.1.5 Info

• License info: Opens the License Info window. From this window it is possible to
monitor the license information for the available servers.

• About: Shows the software version and build number of the Viz Graphic Hub
Manager.

• Help: Opens the Viz Graphic Hub online help file.



Viz Graphic Hub User Guide

Copyright © 2016 Vizrt Page 79

5.2 Search Window

The Search Window provides the following options:

• Free text: Allows you To search with Free text search.

• Search by advanced properties: Allows you to Search by advanced properties.

• Search in specified folder: Allows you Search by specified folder.

• Search by selected keywords: Allows you Search by selected keywords.

• Search by referenced/referencing files: Search by References.

5.3 Preferences
The Preferences window allows you to configure a series of system preferences. It has a
left panel with options that when selected are shown in the right panel.

To open the Preferences window

• From the main menu, click Tools -> Edit Preferences, or

• Press <CTRL+P>, or

• Press <CTRL+F8>.

Selecting a preference category from the list opens the respective panels:

• Login
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• Timeouts

• Deploy Direct Copy

• Startup

• Look

• Import

• Warnings

• Deploy

5.3.1 Login

In the Login panel set the Start-up and Login preferences.

Login Profiles

Click this tab to configure different Login Profiles.
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Each Login Profile can be configured to login to only the required servers and their
associated deploy agents.

5.3.2 Timeouts

From this panel it is possible to define various timeout values related to communication
with Viz Graphic Hubs.
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Timeouts preferences

5.3.3 Deploy Direct Copy

From this panel it is possible to define default behavior when deploying entries from
one server to another using the Direct Deploy Copy (DDC) functionality.
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DDC Preferences

5.3.4 Startup

From this panel it is possible to define the position and size of various GUI components
based on the settings in this session. It is also possible to open/show windows/panels at
system startup automatically.
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Startup Preferences

5.3.5 Look

The Look panel allows you to define the look-and-feel style of the Viz Graphic Hub
Manager’s user interface.
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Look Preferences

You have the following options:

• Visual Style: Sets the user interface look-and-feel.

• Docking Tab Colors: If you select this check box, when docking various user
interface panels as tabs, each will be assigned a unique color. See Customizing the
Interface.

5.3.6 Import

From this panel it is possible to define the data directory for log files and temporary
files used during Importing Viz 2.x Data and Archives. It is also possible to disable the
auto-import when Resuming a Cancelled/Crashed Import Operation.
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Import Preferences

5.3.7 Warnings

From this panel it is possible to define various disk and memory warnings, related
to free disk space/memory. It is also possible to define warnings when the license
expiration date approaches.

Warning Preferences
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5.3.8 Deploy

In this window you can set preferences for automatic updates on running deploy
agents.

Deploy Preferences

Configure the following settings to use for running deploy agents:

• UDP Ports

• Timeout for receiving answers from deploy agents

• Interval in seconds for getting updated info on running tasks

5.4 Explorer
Below the main menu is the Explorer of the Viz Graphic Hub Manager.

Explorer



Viz Graphic Hub User Guide

Page 88 Copyright © 2016 Vizrt

Tip: The panels in the Explorer are resizable, and they can be dragged around.
Also, it is possible to navigate through the trees in the Explorer with the mouse
pointer, arrow keys, or by typing the first character of the desired project or folder/
item.

The Explorer is automatically updated immediately after changes made to files and/or
folders, but a manual refresh of the Explorer is sometimes necessary, for example after
re-enabling columns.

To refresh the explorer

1. From the main menu, click View -> Refresh Explorer, or

2. Press <F5>.

This section contains information on the following topics:

• Icons

• Toolbar

• Displaying Items as Icons

5.4.1 Icons

The following icons are used in the Explorer:

Viz Graphic Hub Icons

Folder Image

Project Material

Audio Material advanced

Base font Scene

Font Video

Object/Geometry

5.4.2 Toolbar

At the top of the Explorer is the Toolbar. The Toolbar consists of:

•  Show Servers and folders: Show/hide the Servers and Folders Panel, or click View
->Servers and Folders.

•  Show search: Show/hide the Search Window.

•  Show add-ons: Show/hide the Add-ons Panel.
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•  One level up: Jump one level up in the Servers and Folders tree structure.

• Address: Shows the current folder path.

From the drop-down list, it is possible to see the history of all folders that have been
used within this session. To re-open to one of these folders, select it from the list.
The format in which the history is shown is <ServerNumber>:\data\<path>.

The history of a server that has been disconnected will no longer be available.

• Type: Filter object types. Click the arrow to the right to toggle between the
following options:

• All

• Base font

• Font

• Geometry

• Image

• Material

• Scene

•  Show/Hide project and folders: If enabled, the subprojects/subfolders of the
selected project or folder will show in the Explorer list.

•  Display icons/Details: Toggles between showing items in the Explorer with details
or as icons (see Displaying Items as Icons).

• Search in: Graphic Hub Quick Search function. Select a server to search in, enter

a search string and press <ENTER> or click on  to start a Free Text Search on the
selected server

• Layout: Select a Graphic Hub Manager layout:

• Layout: Click to load a saved layout. Pre loaded layouts are: System Clean
(Locked) (Basic standard layout) and System Default (as last saved (default
layout)).

• Save: Click to save the current layout.

• Save as...: Click to save as a new layout.

Note: A Layout is local for the current machine in use.

5.4.3 Displaying Items as Icons

By default, the items in the Explorer are presented with detailed information. To view

the items as icons, toggle the  (As Icons) button in the Toolbar.

Note: The icons can also be enabled from the shortcut menu of the Explorer.

When items are viewed as icons, in the lower right corner of the icon characters will
show the item type:
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Scene Font

Geometry Audio

Image Unknown

Material

Additional information may also be shown on the icon:

Item holds more than one folder-link Item is checked out

Item is session locked Item is both session locked and
checked out

See Also

• Item Properties

5.5 Servers and Folders Panel
In the Servers and Folders panel, the projects/folders, as well as the servers they are
on, are shown in a tree.

Servers and Folders Panel

By right-clicking a server or project or folder in the tree, a context menu will is shown.
From this menu it is possible to expand/collapse all branches in the tree, create new
folders/projects, or set access rights, among others.

You can move around the server order up and down with a drag and drop of the mouse.
The server order shown changes, but server numbers remain the same.
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Servers and Folders Context Menu

When the server items are shown in regular view, columns are used to show
information about the items.

The following columns are available:

• File: Shows the name of the item.

• Size: Shows the size of the item.

• Type: Shows the item type, for example material.

• Modified at: Shows the date and time when the item was modified the last time.

• Modified by: Shows the name of the user that modified the item the last time.

• Created at: Shows the date and time when the item was created.

• Owner: Shows the name of the user that owns the item.

• Checked out by: If the item is checked out, shows the name of the user that has
checked it out.

• Locked by: If the item is session locked, shows the name of the user that is
working on it.

• No. of folder links: Shows the number of folder-links (number of projects/folders
the item is placed in).

• Access rights: Shows the access rights for user, group, and world. For more
information, see Managing Users and Groups .

• Checksum: Shows the automatically calculated checksum, which is used to make
sure that all items in the database are unique.
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• UUID: Shows the automatically generated UUID of the item.

This section contains information on the following topics:

• Tree Structure

• Working with Projects and Folders

• Item Properties

See Also

• Customizing the Interface

5.5.1 Tree Structure

Within the database, the items are organized in a virtual structure of projects and
folders. This structure is shown as a tree in the Servers and Folders panel.

Tree Structure

In this panel, all connected servers are shown as root entries. These entries show the
name of the Viz Graphic Hub Server, the Viz Graphic Hub Namingservice the server is
registered on, and the current user name.

The level below the root entry contains the data project, which other clients refer to.
New projects/folders/items can be added under the data project.

Tip: It is possible to create projects/folders on the same hierarchy level as data,
but these projects/folders will not be accessible from client applications such as
Viz Artist. Into these projects/folders it is practical to move data that should not be
worked on anymore, yet is not ready to be deleted.

The data directory holds projects/folders that the server items are stored in.

To view the content of a project or folder

1. Click the project or folder in the tree.

Alternatively, double-click a subproject/subfolder in the Explorer;

Or right-click the project or folder, and select Open.

The server items in the selected project or folder will then be shown in the
Explorer.
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2. To jump one level up in the Servers and Folders tree structure, click the One level
Up button from the Toolbar.

5.5.2 Working with Projects and Folders

This section contains the following procedures:

• To expand projects or folders

• To collapse projects or folders

• To create a new project

• To create a new folder

• To rename a project or folder

• To move a project or folder

• To change the owner of projects or folders

• To set rights for a project or folder

• To view a project or folder properties

• To delete a project or folder

To expand projects or folders

• After logging in, the branch representing this database will be collapsed. To expand
the branches, use one of the following options:

• Click - to the left of the branch.

• Double-click the branch to be expanded.

• Right-click the desired branch and select Expand.

• Right-click the desired branch and select Expand Completely to expand the
branch and all its subbranches.

To collapse projects or folders

• Use one of the following options:

• Click - to the left of the branch.

• Double-click the branch to be collapsed.

• Right-click the desired branch and select Collapse.

• Right-click the desired branch and select Collapse Completely to collapse the
branch and all its subbranches.

To create a new project

• Right-click the parent node and select New -> Project.

Alternatively, open the parent node and right-click anywhere in the Explorer and
select New -> Project.

Note: It is not possible to create a project under a folder.

Note: Special characters, such as space, are not allowed in project names. Also,
project names must be unique.
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To create a new folder

• Right-click the parent node and select New -> Folder, or

• Open the parent node and right-click anywhere in the Explorer and select New ->
Folder.

Note: Special characters, such as space, are not allowed in folder names. Also,
folder names must be unique.

To rename a project or folder

• Right-click the project or folder and select Rename.

Note: The data project below the server root entry cannot be renamed. Also,
special characters, such as space, are not allowed in project or folder names, and
project or folder names must be unique.

To move a project or folder

1. Drag the project or folder from either the Servers and Folders Panel or Explorer
onto the target destination.

The Action Log for moving projects/folders is shown.

2. Click the Do It button.

Windows functions work, too: <CTRL+X>, <CTRL+V>; right-click Cut/Paste.

Note: This procedure only applies to moving projects/folders within a single
server. For information about moving projects/folders between multiple servers,
see Multi Server Deploy .

To change the owner of projects or folders

1. Right-click the project or folder and select Set Owner... to open the Set Owner
window.

2. Select the new owner from the drop down list

3. Click in the Apply to all subfolders and objects check box, if required.

4. Click the Set... button.

5. The Action Log opens (Setting owner... window).

6. Click the Set owner button.

7. Click on Close.
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The owner of a project or folder can also be assigned from the project or folder
Properties window (see To view a project or folder properties).

To set rights for a project or folder

1. Right-click the project or folder and select Set access. The Set access window
opens.

• User: the owner of the project or folder

• Group: all the members of the group the owner belongs to,

• World: all database users.

2. Define the new rights and click the Set button.

The Action Log for changing the rights is shown.

3. Click the Set access button.

The rights for a project or folder can also be assigned from the project or folder
Properties window. For more information, see To view a project or folder properties .

To view a project or folder properties

• Right-click a project or folder and select Properties.
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The following project or folder properties are available in the General panel:

• Name: Shows the name of the project or folder.

• Type: Shows if the folder is a regular folder or a project.

• UUID: Shows the automatically generated UUID of the project or folder.

• Path: Shows the path of the project or folder within the data directory of the
database.

• Name: Shows the name of the project or folder. To rename the project or folder,
type a new name in the box.

• Owner: Shows the user that owns the project or folder. To reassign the project or
folder to a new user, select a user from the list.

• Created: Shows the date and time when the project or folder was created.

• Contains: Show a summary of all objects within the selected projects/folders.

• Access Rights: Shows the access rights for the project or folder. To change the
rights, enable/disable one or more check boxes (see Managing Users and Groups).

Tip: The labels of settings that have been modified will be colored red.

The following project or folder properties are available in the Add-ons panel:

• Name: Project/folder name

• Type: Project or Folder

• UUID: Automatically generated UUID of the project or folder

• Text tab: Assigned add-ons as text

• Edit tab: Enables editing and assignment of add-ons
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• XML tab: Assigned add-ons as XML

• Search: Search text within assigned add-ons

See Also

• Add-ons

• Item Properties

To delete a project or folder

1. Select the project or folder

2. Delete the project or folder:

• Press <DELETE>, or

• Right-click the project or folder and select Delete...

The Action Log opens (Delete files... window).

3. Click Delete.

4. Click Close.

Note: Only empty projects or folders can be deleted. Also, by deleting a project
or folder from the Graphic Hub, the respective folder-links in the properties of the
items will be deleted too.

5.5.3 Working with Files

This section contains the following procedures:

• To create a linked file

• To create a duplicate file(s)

• To move a file(s)

• To overwrite a file

To create a linked file

1. Select the desired file(s)

2. Drag the file(s) to the target folder and release.

3. The Action Log opens (Duplicate, Link or Move... window).

4. Click Link.

5. Click Close.

or

1. Select the desired file(s)

2. Create a linked shortcut:

• Right-click and select Link (create shortcut), or

• Press <CTRL+Y>

3. Select the target folder.

4. Link the file(s):

• Right-click on the target folder and select Link here..., or
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• Right-click in the folder area and select Paste...

5. The Action Log opens (Duplicate, Link or Move... window).

6. Click Link.

7. Click Close.

A link to the file is created in the destination folder.

Linking files has the benefit of saving disk space and therefore enhancing system
performance. It is especially useful when a file is referenced in many places. For
example, a station logo is best to be referenced as a link rather than duplicated in
many locations.

To create a duplicate file(s)

1. Select the desired file(s)

2. Press <CTRL> and drag the file(s) to the target folder and release.

3. The Action Log opens (Duplicate, Link or Move... window).

4. Click Duplicate.

5. Click Close.

or

1. Select the desired file(s)

2. Copy the selected file(s):

• Right-click the file(s) and select Duplicate (copy), or

• Press <CTRL+C>.

3. Select the target folder.

4. Duplicate the file(s):

• Right-click on the target folder and select Duplicate here..., or

• Right-click in the folder area and select Paste...

5. The Action Log opens (Duplicate, Link or Move... window).

6. Click Duplicate.

7. Click Close.

To move a file(s)

1. Select the desired file(s)

2. Press <SHIFT> and drag the file(s) to the target folder.

3. The Action Log opens (Duplicate, Link or Move... window).

4. Click Move.

5. Click Close.

or

1. Select the desired file(s)

2. Cut the selected file(s):

• Right-click the file(s) and select Move (Cut), or

• Press <CTRL+X>.

3. Select the target folder.
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4. Move the file(s):

• Right-click on the target folder and select Move here..., or

• Right-click in the folder area and select Paste...

5. The Action Log opens (Duplicate, Link or Move... window).

6. Click Move.

7. Click Close.

To overwrite a file

A file can only be overwritten if it is in the same folder and of the same type.

1. Select the desired file.

2. Drag the file to the file to be overwritten and release.

Note: Source and target file must be of the same type.

3. The Action Log opens (Overwrite... window).

4. Click Overwrite.

5. Click Close.

5.5.4 Item Properties

This section describes the available properties of each item.

To view the properties assigned to an item

• Double-click an item in the Explorer, or

• Right-click an item and select Properties.

This section contains the following topics:

• General Properties

• Keyword Properties

• References and Link Properties

• Total Size Properties

• Advanced Properties

• Item History

• Item Availability

• Item Add-ons
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General Properties

• Name: Shows the name of the item.

• Type: Shows the item type, for example material.

• UUID: Shows the UUID of the item.

• Original name: Shows the name of the item. To rename the item, type a new name
in the box. If changing the name of an item that has more than one folder-link, only
the name of this link will be altered. In other projects/folders, the name will not be
changed.

• Owner: Shows the name of the user that owns the item. To reassign the item to a
new user, select a user from the list.

• Checked out by: If the item is checked out, shows the name of the user that has
checked it out. To check out the item, click the Check Out button. To check in the
item, click the Check In button.

• Locked by: If the item is session locked, shows the name of the user that is
working on it. To session lock the item, click the Lock button. To unlock the item,
click the Unlock button.

• Size: Shows the size of the item.

• Created at: Shows the date and time when the item was created.

• Modified at: Shows the date and time when the item was modified the last time.

• Modified by: Shows the name of the user that modified the item the last time.

• Folder links: Shows the number of folder-links (number of projects/folders the item
is placed in). The box below shows the paths to projects/folders where the item is
linked.

• Link name: Shows the name of the folder-link. By default, the folder-link name
automatically equals the item name.
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• Access rights: Shows the access rights for user, group, and world. User refers
to the owner of the item, group refers to all the members of the group the owner
belongs to, and world refers to all database users.

See Also

• Managing Users and Groups

Keyword Properties

• Name: Shows the name of the item.

• Type: Shows the item type, for example material.

• UUID: Shows the UUID of the item.

There is a search field for locating keywords and you can assign and remove keywords
from the selected item. For more information, see To assign a keyword(s) to an item.
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References and Link Properties

• Name: Shows the name of the item.

• Type: Shows the item type, for example material.

• UUID: Shows the UUID of the item.

• References: Shows the items which are contained in the current item. For example,
if you check the references for a scene, you will variously see images, geometries,
etc., that are used in this scene. Drilling down, the references of the images show
the images used in that item. And so on.

• File links: Shows the items where the current item is referenced. For example, with
an image used in different scenes, all those scene will appear as file links.

• Folder links: Shows all folders where the same file is linked, i.e. all shortcuts.
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Total Size Properties

• Name: Shows the name of the item.

• Type: Shows the item type, for example material.

• UUID: Shows the UUID of the item.

• Filters:

• View by Reference or View by Size

• Sort by Name, Size, Type and Name, Type and Size

The item’s total size in KB, MB or GB is shown. Using the tree, you can see all the
component parts and their respective sizes.
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Advanced Properties

• Name: Shows the name of the item.

• Type: Shows the item type, for example material.

• UUID: Shows the UUID of the item.

• Checksum: A server-generated value to detect duplicates and differences between
similar items. Useful for importing and replicating and deploying items; when two
items are very similar, you can use the checksum to determine whether to overwrite
or allow a parallel instance.

• Units: The component units of an item. An item consists of multiple units that form
part of the internal data. Used in troubleshooting.

• Attributes: Each unit has specific attributes describing it. Used in troubleshooting.
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Item History

• Name: Shows the name of the item.

• Type: Shows the item type, for example material.

• UUID: Shows the UUID of the item.

The item’s transaction history is shown with columns for date, user, changes and serial
number.

Item Availability
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If you are logged into multiple servers, you are able to check whether an item exists
and is identical among instances.

• Name: Shows the name of the item.

• Type: Shows the item type, for example material.

• UUID: Shows the UUID of the item.

• Modified at: Last date and time modified.

• Modified by: Last user to modify the item.

• Checksum: The checksum indicates whether the item is the identical on every
server.

• Availability on other servers where logged in: The availability of the same item
on other servers where you are logged in. Even if the filename is different, if the
UUID and checksum are the same, the item will figure in this panel, shown as OK.
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Item Add-ons

• Name: Shows the name of the item.

• Type: Shows the item type, for example material.

• UUID: Shows the UUID of the item.

• Text tab: Assigned add-ons as text

• Edit tab: Enables editing and assignment of add-ons

• XML tab: Assigned add-ons as XML

• Search: Search text within assigned add-ons

See Also

• Add-ons

5.6 Add-ons Panel
The add-ons panel shows the following properties for all published Add-ons.
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Add-ons Panel - Text Tab

In the Text Tab, you can search for text within published add-ons. This search facility
includes matching case and whole words. Text found is highlighted.
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Add-ons Panel - Edit Tab

From the Edit Tab, you can assign, unassaign and edit published add-ons for currently
selected and multiple items. For more information, see To assign an add-on.
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Add-ons Panel - XML Tab

In the XML tab, you can search for text within published add-ons. This search facility
includes matching case and whole words. Text found is highlighted.

5.7 Journal Panel
From the Journal panel it is possible to search for journal entries and view their details.
Journal entries are log files created according to various alert levels. The Journal is a
good place to start for troubleshooting problems encountered. in Viz Graphic Hub.
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Journal Panel

The Journal Toolbar presents you with the following options:

Journal Toolbar

• Search: Performs a search for journal entries based on the parameters defined in
the Journal Filter frame. See To search the journal with filter settings.

• Optimize search for export: If enabled, backup files with a huge number
of journal entries will be optimized for export, by not containing all available
information about these entries. See Exporting Journal Entries.

• Import journal entries: Opens a dialog box, from where it is possible to select an
XML journal backup file to import. See Importing Journal Entries.

• Export selected entries: Allows you to export only the entries that you choose.
See To manually export journal entries.

• Backup task: Opens the Configure Journal Backup Task window. See To
automatically export journal entries.

• Switch to feed mode: Allows you to receive journal updates in real time. See To
view a live feed of server activities.

• Show/hide entry properties: Shows/hides the Journal Entry Properties frame. See
To search the journal with filter settings.

• Show filter: Shows/hides the Journal Filter frame. See To search the journal with
filter settings.
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5.8 Action Log
The Action Log is automatically activated when performing certain operations in Viz
Graphic Hub Manager, for example duplicating/deleting items and projects/folders, or
changing user rights.

The action to be performed will be shown in the window title, and an icon symbolizing
the action will be shown below the file list. For example, a trash can icon is used if
items or projects/folders should be deleted.

This section contains information on the following topics:

• Action Log Options

• Adding Elements

• Performing the Operation

5.8.1 Action Log Options

Certain options can be set in the Action Log:

• Close this window automatically, if no problem occurred: If enabled, the
Action Log will be closed when the desired operation finishes successfully.

• Reuse this window for same actions: By dragging items or projects/folder onto
the Action Log, the action will be performed on these elements too.

• Do not insert entries that are already in the list: Prevents adding duplicate
entries.

Note: This option is only available if Reuse this Window for Same Actions is
enabled.

• Warn me about not inserted: If enabled, when trying to add duplicate entries, a
dialog box will notify that the duplicates will not be added.
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Note: This option is only available if both Reuse this Window for same Actions and
Do not Insert Entries that are Already in the List are enabled.

5.8.2 Adding Elements

To add additional items that the same action should be performed on, drag items from
the Explorer or the search results onto the list of elements in the Action Log.

5.8.3 Performing the Operation

When the desired items have been added to the Action Log, click the button
corresponding to the operation that should be performed.

When the operation has been performed, the Action Log will provide feedback. If the
operation has been successful, a check mark, is shown to the left of the item name. If
the operation has failed, an X will indicate this. Status information in text form will also
be shown in the Info column.

5.9 Customizing the Interface
The graphic user interface can be customized with your own layout in the workspace.
Furthermore if a second instance of Viz Graphic Hub Manager is open, the layout in
the first instance will not affect any others. The layout in every instance can be saved
independently.

To save a layout

• Do one of the following:

• Click View -> Layouts -> Save current layout.

• Click the Save (or Save as) button in the layout bar.

If you don't save a layout, it will still open in the next session. If you do save it, you will
have access to it from the drop-down/menu item should you make other changes and
wish to revert back.

To load a layout

• Do one of the following:

• Click View -> Layouts -> Load layout - >  <layout name>.

• In the Toolbar, click the Layout button and select the pre-saved layout you wish
to load.

To drag and drop a layout UI elements

1. Click the title bar of the element you want place and move it out by holding the
left mouse button down and in any free direction.
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Symbols indicating the possible target positions appear.

When a valid place is reached, that area is highlighted.

2. Drop the element in the desired target position.

To load a predefined look

1. Click Tools -> Edit Preferences.
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The Preferences window is shown.

2. In the left panel, click Look.

3. From the drop down box, select a visual style.

4. Click OK.

To add docking tab colors

1. Click Tools -> Edit Preferences.

The Preferences window is shown.

2. In the left panel, click Look.

3. Check the Docking Tab Color check box.
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4. Click OK.

When a series of elements are docked together, they appear as tabs.

To change the color of a server tree

1. Click Tools -> Edit Preferences.

The Preferences window is shown.

2. In the left panel, click Login.
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3. Right-click a server and select Text color in Explorer.

4. Select a color from the color picker and click OK.

5. In the Preferences window, click OK.

To customize column layouts

• To move columns, click and drag left or right to the desired location.

• The following column options are available by right-clicking a column itself, or just
to the right of all columns:

• Remove column

• Hide this column

• Hide column <indicate column>

• Display column <indicate column>

• Remove all non-mandatory columns

• Display all columns

• Size all visible columns

Column customization works for the Explorer, Search results, Journal, ServerDiff,
Scheduled tasks, Action Logs, Running tasks and Finished tasks.

5.10 Importing and Exporting Viz Graphic Hub Manager Settings
All workstation-based customizations to the Viz Graphic Hub Manager, such as changes
to any of the panels, column layout and visibility, as well as the user interface in
general can be exported (and subsequently re-imported on another machine).

To export local Viz Graphic Hub Manager settings

1. From the main menu, click Tools -> Export settings (incl. layouts) to file.

2. Select a file name and location and click Save.
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The settings are saved with a file extension of .vghms.

To import local Viz Graphic Hub Manager Settings from another machine

1. From the main menu, click Tools -> Import settings (incl. layouts) from file.

2. Select a file name a file extension of .vghms and click Open.
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6 Task Workflow

This section contains information on the following topics:

• Server Observation

• Working with the Journal

• Searching

• Importing External Images

• Exporting to a Viz 3.x Archive (*.via)

• Importing a Viz 3.x Archive (*.via)

• Importing Viz 2.x Data and Archives

• Locating Duplicates

• Metadata

• Replacing Item References

• Enabling Viz Graphic Hub for a Virtual Studio

6.1 Server Observation
• Viewing the Monitor

• Monitoring Active Sessions

• Monitoring Servers

• Server Properties

• Chatting with Artists

• Server Notifications

• Monitoring Object Types

• Reporting

6.1.1 Viewing the Monitor

The Terminals window provides an interface to view all online terminals within the
network. A terminal is the physical machine where the Viz Graphic Hub Terminal
application is running.
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Terminals Window

To open the Terminals window

• From the Main menu, select Server -> Terminals, or

• Press <F9>, or

• Press <CTRL+T>

The following columns are available:

• Terminal: Shows the hostname of the physical machine where the namingservice
and/or server are installed. An icon represents the status of the server and
namingservice:

•  Both the namingservice and server are down.

•  The namingservice is running, but the server is down.

•  The namingservice is down, but the server is running.

•  Both the namingservice and server are running.

• Server info: Shows <Viz GH Server>@<Viz Graphic Hub Namingservice>:<port
the naming service is listening to>. A plus sign “+” is added if you are logged into
the server shown.

• Namingservice info: Shows <Viz Graphic Hub Namingservice>:<port the naming
service is listening to>.

• Connection: Shows if Viz Graphic Hub Manager has a valid connection to the Viz
Graphic Hub Terminal.

• Server: Shows the name of the server.

• S. host: Shows the hostname of the physical machine where the server is installed.

• S. port: Shows the port number the server communicates through.

• S. up: Shows if the server is running. This is also indicated by the icon in the
Terminal column.

• S. in: Shows if you are logged into this server.

• Namingservice: Shows the name of the namingservice.

• Ns. port: Shows the port number the namingservice communicates through.
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• Ns. up: Shows if the namingservice is running. This is also indicated by the icon in
the Terminal column.

• T. TCP-port: Shows the TCP port number, which can be used to start the server
remotely from Viz Graphic Hub Manager.

• Terminal host network IP: Shows the IP address of the Terminal machine.

The following additional options are available:

• Show single user servers on other computers: If selected, also shows servers/
namingservices in the network that are running in single-user mode (localhost).

• Advanced options: Opens the Terminals Advanced Options window. Alternatively,
press <ALT+A>.

• UDP-Port: Defines the UDP port where Viz Graphic Hub Manager searches for
Terminals.

Note: The UDP port must be the same as the port the namingservice is
listening to. If no port number figures, go to the Viz Graphic Hub Terminal itself
and check in the Terminal Options which UDP port you set there; Change it
accordingly in the Manager’s Advanced Options.

• Timeout to receive answer from Viz Graphic Hub Terminals: Defines how
long the Viz Graphic Hub Manager should listen for Terminals before timing out.
The value is set in milliseconds.

• Refresh: Updates the list. Alternatively, press <ALT+R>.

• Login: To log in to a server, select the desired server from the list, and then click
the Login button. Alternatively, press <ALT+L>. This will open the Login window.
See Start Up with a Single Server Login .

Note: It is not possible to log into a Viz Graphic Hub installation by remote in
single-user mode (localhost) from other physical machines.

• Start server: If the server on a listed Terminal is not running, it is possible to start
the server from this window. To do so, select the desired server from the list, and
click the Start Server button. Alternatively, press <ALT+S>.

• Start namingservice: If the namingservice on a listed Terminal is not running, it
is possible to start the namingservice from this window. To do so, select the desired
server from the list, and click the Start Namingservice button. Alternatively, press
<ALT+N>.

6.1.2 Monitoring Active Sessions

From the Active Sessions window it is possible to monitor all logged in users and active
sessions. When faced with network or connection problems, checking active sessions
can provide important clues. Likewise, performance problems in general are easy to
spot in the Active Sessions window, since you can see hosts and servers. In sum, for a



Viz Graphic Hub User Guide

Page 122 Copyright © 2016 Vizrt

good clue as to where to find connection, network and performance problems, look in
the Active Sessions window.

To open the Active Sessions window

• In Viz Graphic Hub Manager, click View -> Active Sessions.

Alternatively, press <CTRL+E>.

The following options are available:

• Server: If logged in to more than one server, select which server to monitor from
the Server list.

• Running since: Shows how long the selected server has been running, counting
upwards in hours, minutes, and seconds.

Tip: The time relates to the system time on the server machine.

• Started at: Shows the time and date when the server was started.

• Refresh interval: Defines the interval for when information should be refreshed. It
can be set to a value between one and ten seconds.

• Message: To send a message to all clients that are logged in to the selected server,
type a text in the Message box, and then click the Send button.

The Sessions list shows detailed information about the sessions that are active on the
selected server. The following columns are available in the Sessions list:

• User: Shows the name of the user that activated the session.

• Host: Shows the hostname of the machine that the session was started from.

• Application: Describes the application and operation that the session belongs to.

• Logged in since: Shows how long the user has been logged in to the server,
counting upwards in hours, minutes, and seconds.

• Last activity before: Shows the last time an operation was performed in the
session.

• No. of open files: Shows the number of files that are open in the system.

• No. of locked files: Shows the number of items that are session locked.

• Login time: Shows the time and date when the user logged in to the server.

• Last activity: Shows the time and date of the last time an operation was
performed in the session.

• Priority: Set the priority of the sessions for the correct load balancing.

• Session rights: Shows the access (read/write) rights for the session.

• Notifications: Description used by the clients, for example to inform that items
have been created.
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6.1.3 Monitoring Servers

From the Monitor Servers window it is possible to view and analyze all servers that are
currently logged in to.

To open the Monitor Servers window

• Click Tools -> Monitor Servers, or

• Press <F4>, or

• Press <CTRL+M>.

The left part of the Monitor Servers window lists all available servers.

The right part of the window shows details about one or more selected servers. If
all the available servers are working within the desired parameters, this overview is
hidden. If one or more servers are in warning state, the overview for these servers will
open automatically.

To view server details

• Double-click the server in the Overview panel.

Alternatively, right-click the server, and select Open Overview.

• Select Open All Overviews to show details of all available servers.

Overview

The Overview frame shows a quick overview of all the parameters. A green light next
to the parameter indicates that all systems are normal. A yellow light indicates that
there are non-critical problems. A red light indicates that system limitations have been
reached or there are serious errors.

The overview shows this basic information for the following parameters:

• License

• Disk

• Memory

• Health
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• Cluster

• Activity

License

The License frame shows the status of the Viz Graphic Hub license.

The status shows license limitations or remaining number of days until the license
expires. If your license expires, you will receive instant chat messages with increasing
frequency to that effect.

Disk

The Disk frame shows the status of the currently used partition where the data
directory is located on the hard disk of the physical machine.

The status shows total, used, and free disk space, and also the warning limit. If the free
disk space reaches this limit, you will receive Server Notifications to this effect. The
warning will also be logged in the Journal Panel.

The warning limit is defined in the Preferences window.

Memory

The Memory frame shows an overview of the physical memory of the server both in
numeric values and over time.

Health

The Health frame shows various Viz Graphic Hub status parameters.

• Deadlocks: Shows the number of deadlocks in the system. Any deadlocks will
necessitate the restarting of Viz Graphic Hub.

• Active sessions: Shows the number of current sessions.

• Files open: Shows the number of files that are currently open.
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• Files: Shows the total number of files stored in the system.

• Files in memory: Under normal operating circumstances, this parameter should be
either 0 or 1. Greater than 1 indicates locked files. In this case, see the procedures:

• To restore corrupted files

• To restore Viz Artist after it crashes

• Open transactions: These are transactions that need to be deployed to the other
server in the replication environment. If the number is too high, stop working until it
is back to zero.

Cluster

If you are logged into both main and replication servers, you are presented with a
Monitor Servers screen that reflects this.

• Title bar: Each server’s title bar shows its current status.

• Cluster: Shows if the cluster is connected and healthy.

• Open transactions: These are transactions that need to be deployed to the other
server in the replication environment. If the number is too high, stop working until it
is back to zero.

Activity

The Activity frame shows an overview of the server activity both in numeric values and
over time.

• Calls: Shows the total number of calls made my any application to the Viz Graphic
Hub Server.
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• Calls/sec: Shows the average number of calls per second.

• Peak: Shows the highest amount of calls during one second.

• Ø calls/sec: Shows the average number of calls during one second for the total run
time of the server.

• Ø peak: Shows the highest amount of calls during one second for the total run time
of the server.

Server Details

This window shows information about the projects/folders and items stored in the Viz
Graphic Hub and loaded into the memory.

To view server details

• In the Monitoring Servers window, click the Details button.

Note: Only users with administrator rights can access this window.

• From the Refresh Rate drop down box it is possible to set the interval of when the
information should be updated.
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• Selecting the Show Functions check box will show additional information used for
debugging purposes.

The Total frame shows the following information:

• Projects: Shows the total number of projects in the Viz Graphic Hub.

• Folders: Shows the total number of folders in the Viz Graphic Hub.

• Files: Shows the total number of items in the Viz Graphic Hub.

6.1.4 Server Properties

The Server Properties window shows the following types of information:

• General Server Information

• Checksum Information

To view server properties
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• In the Servers and Folders panel, right-click the server and select Properties.

General Server Information

General Server Properties

In addition to the server’s name, type and version, general server information includes:
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• License

• Disk

• Memory

• Health

• Server Details

Checksum Information

View the checksum when you want to compare two or more Viz Graphic Hub servers to
see how identical they are. This is useful after having performed replication operations
or when you have a real-time deploy agent. Identical servers will have a checksum of
00.

Server Checksum Properties

In addition to the server’s name, type and version, checksum server information
includes:

• License

• Disk

• Memory

• Health

• Server Details

Use the Refresh button to update the checksum information for the servers you are
currently logged in to.

Checksum information includes:
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• Total server checksum

• Folder structure (including file data)

• File data only

• File references only

Identical servers will have a checksum of 00.

6.1.5 Chatting with Artists

Users can communicate with each other while logged in to Viz Graphic Hub. This chat
functionality is also used to receive global messages from Viz Graphic Hub, such as
information about a system shutdown. The messages that are sent and received are
saved throughout the session.

If your dongle expires or is otherwise invalid, you will receive messages in the chat
panel with increasing frequency until you renew it.

Tip: The chat feature is available from both Viz Graphic Hub Manager and Viz
Artist.

To open the chat panel

• Click View -> Messages (Chat).

• To hide the chat panel, perform repeat the step above, or

• Press <F6>, or

• Press <CTRL+H>.

Note: If receiving a message while the Chat panel is hidden, the panel will
automatically open.

To send an instant message

1. Perform the procedure To open the chat panel.

2. Select the recipient from the left panel.

3. Type a message text in the box, and then press <ENTER>.

The message will then be sent to the defined Viz Graphic Hub Manager and/or Viz
Artist user(s).
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Tip: Messages sent to Global Message are delivered to everyone. Messages sent
to a group are delivered to every group member currently logged in.

6.1.6 Server Notifications

The Viz Graphic Hub Server issues messages in the following scenarios:

• Viz GH needs administrative attention: If you get this message, see Monitoring
Servers.

• License errors or expiration: If you get this message, see License.

• Low memory: If you get this message, see Memory.

• Low disk space: If you get this message, see Disk.

6.1.7 Monitoring Object Types

From this window you can view at a glance the object types on a selected server.
Object types are scenes, images, geometry types, materials, fonts, etc.

To monitor item types

1. Click View -> Object Types, or press <CTRL+B>, or <CTRL+F6>.

The object types window is shown.

2. If logged in to more than one server, select which database to monitor from the
Server list.

Each object type is shown with its corresponding ID.
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6.1.8 Reporting

Reports can be generated manually or automatically.

• Manual Exporting of Reports

• Automatic Exporting of Reports

Manual Exporting of Reports

Reports are essential troubleshooting tools whenever there is any kind of system error.
Generating a report should be one of your first actions whenever you are engaged in
finding a solution to a problem in Viz Graphic Hub.

To this end, you can also configure Viz Graphic Hub for the Automatic Exporting of
Reports whenever there is an unexpected server shutdown.

IMPORTANT! In the reports folder, there is a file called SystemInfo.txt. Before
sending this file anywhere, be sure to read it and delete any information contained
therein that could compromise your company’s security policy and interests.

To manually generate a report

1. In the Viz Graphic Hub Terminal, from the main menu, click Report.

The report window is shown.

2. Click the Export button.
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The Report Export window is shown.

3. Click the Browse button if you want to redefine the reports’ destination folder.

4. Select one of the following options:

• Click Export to folder to simply place the report files in the destination folder.

• Click Export & Compress to zip the report files (for easier transferring) before
placing them in the destination folder.

5. Once the report has been exported, you have three options:

• Open Windows Explorer to view it.

• Compress the exported files (if you realize that they are too big).

• Do nothing - click OK.

Automatic Exporting of Reports

As well as the Manual Exporting of Reports containing errors, you have the option of
setting Viz Graphic Hub Terminal to automatically export reports whenever an defined
error occurs (such as unexpected server shut down).

To set up automatic exporting of reports

1. In Viz Graphic Hub Terminal, from the main menu, click Options.
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2. Under the Viz Graphic Hub Terminal: Start & Shutdown Settings, check the
Automatically export a report when Viz Graphic Hub Server has been
unexpectedly shut down check box.

3. Click OK.

6.2 Working with the Journal
The journal records all server activities. When faced with troubleshooting scenarios, the
journal is a good place to search for clues. The activities logged in the journal are the
creation, modification and deletion of objects in Viz Artist, as well as other information
messages, warnings, errors and deploy task information.

• Querying the Journal

• Exporting Journal Entries

• Importing Journal Entries

• Configuring Email Notifications

6.2.1 Querying the Journal

This section contains the following procedures:

• To view the journal

• To search the journal with filter settings

• To view a live feed of server activities

To view the journal

• Click Server -> Administer journal entries, or

• Press <CTRL+SHIFT+F6>.

The journal is shown in the bottom panel.
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Journal

To search the journal with filter settings

1. Perform the procedure To view the journal.

2. In the Journal filter, from the Server drop down box, select a server.

3. Select an application. Your options are:

• Any: Searches System and Viz GH Deploy.

• System: Viz Graphic Hub Server. Any work done on Viz Graphic Hub will be
logged in the system.

• Viz GH Deploy: All Direct Deploy Copy (DDC) tasks, successful or failed, plus
warnings and other pertinent information, are logged in the journal.

4. Optionally, enter a UUID of a folder or file.

Note: Adding a UUID to the search criteria may provide hints toward finding
and resolving corrupted files. See the troubleshooting procedure To restore
corrupted files.

5. From the Date drop down box, select one of the following options:

• Anytime

• From: Selecting this option will prompt you to also enter a beginning date and
time.

• Until: Selecting this option will prompt you to also enter an ending date and
time.

• Between: Selecting this option will prompt you to also enter a beginning and
ending date and time.

6. In the Details like field, enter free text like name of the task, name of the agent,
or any description that may figure in the task.

7. In the Details not like field, enter free text like name of the task, name of the
agent, or any description that you want to exclude from the task search.

8. Check the Alerts check box if you wish to filter by selected alerts.

There are various Action Logs, information messages, warnings and errors to
choose from.

9. Optionally, click the Optimize Search for Faster Export button.
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10. In the Journal, click the Search button.

The search results are shown in the panel below. When one is selected, the details are
shown in the panel to the right.

To view a live feed of server activities

1. Follow the procedure To search the journal with filter settings.

2. In the journal toolbar, click the Feed button.

The journal is now updated in real time.

• Green entries are new journal entries.

• Yellow entries are warnings.

• Red entries are errors.

• Only the Level and Subject columns are colored in red or yellow when there are
warnings and errors to report.

6.2.2 Exporting Journal Entries

There are two modes for exporting journal entries:

• To manually export journal entries

• To automatically export journal entries

To manually export journal entries

1. Follow the procedure To search the journal with filter settings.
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2. In the journal, select the entries you wish to export.

Tip: Press <CTRL+A> to select all entries.

3. Right-click the selection and select Export Selected.

Note: You can also select Export and Delete Selected which will also free
up disk space and increase performance.

You are prompted to select a location for the exported file.

4. Select the location, optionally enter a file name, and click Save.

To automatically export journal entries

1. Make sure that the Viz Graphic Hub Server is shut down via the Viz Graphic Hub
Terminal.
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2. In Viz Graphic Hub Terminal, click Options.

3. Check the Enable journal back up check box.

4. Click Browse and select a location for the exported files to be saved.

5. Select a File Mode. Your options are:

• Open Truncate - All entries are saved to a single file. Newest entries are at
the end.

• New by Date - A new file is created for each date.

• Click OK.

6. Restart the Viz Graphic Hub Server.

7. Start Viz Graphic Hub Manager and log into the required server.

8. Perform the procedure to To view the journal.

9. In the journal toolbar, click the button to show the backup task configuration.
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You are prompted to set the frequency of the automatic export.

10. Select the start date and time.

11. Select the frequency.

12. Click OK.

6.2.3 Importing Journal Entries

Exported journal entries can be reimported by other users for help with
troubleshooting.

To import journal entries

1. Perform the procedure To view the journal.

2. In the journal toolbar click the Import Journal Entries button.

You are prompted to select an XML file for import.

3. Select the desired file and click Open.

The file is loaded into the journal.

6.2.4 Configuring Email Notifications

You can arrange emails to be sent regarding specific types of journal entries. This type
of journal information includes:

• Action Log

• Information

• Warnings

• Errors

• Deploy task information
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The procedure involves enabling mail to be sent from the Viz Graphic Hub Terminal,
and then configuring the which messages are to be sent and when in the Viz Graphic
Hub Manager.

To enable email

1. If running, shut down the Viz Graphic Hub Server.

2. From the Viz Graphic Hub Terminal, click Options.

3. In Viz GH Journal settings, select All from the Journal level drop down box.

4. Check the Enable Mail check box.

5. In the Mail Server field, enter your SMTP mail server.

Note: Popmail servers do not work.

6. In the From field, enter an email address from which the mails are to be sent.

7. In the To field, enter a valid email address to which emails are to be sent.

8. Click OK.

9. Restart the Viz Graphic Hub Server.

To configure the sending of emails

1. In Viz Graphic Hub Manager, click Server - Configure alerts.
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The Alerts window is shown.

2. From the list, select one or more subjects about which you wish to be informed by
email.

3. Click the Configure button.

The Configure Email window is shown.

4. From the drop down box in the lower-right corner, enter or select the address(es)
to which the email alerts are to be sent.

5. At the bottom left, if you wish to override the default, enter an interval in minutes
or select a pre-defined interval from the drop down box. Data will be collected and
messages will be sent at this frequency.

6. Click OK.

Note: If you click Cancel, you can still save the mail for future use, without it
actually being sent.
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Messages to be sent now figure in the Alerts window.

6.3 Searching
The Viz Graphic Hub Manager’s Search functions can search for items, folders or project
on one or more servers.

There are two types of searches available in the GH Manager, To search with Free text
searchVizBold (which includes a  Quick SearchVizBold ) and Standard SearchVizBold
.

If the search panel is not open, see To view the Search panel. Search results are shown
in the Results panel and results can be filtered per server, if the search was over more
than one server.

To view the Search panel

1. In the main tool bar click on View -> Panes -> Search.

2. Click on Search to open or close the Search panel.

This section contains information on the following topics:

• Free Text Search

• Standard Search

• Search String Syntax
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• Best Practices for Searches

6.3.1 Free Text Search

The free text search searches for files, folders or projects and can include any or all of
the these search strings (see Search String Syntax):

• File names

• Folder names

• File owners

• File UUID (if enabled in Viz Graphic Hub)

• File type (geometry, font, images, etc.)

• Assigned keywords

This section contains information on the following procedures:

• To search with Free text search

• Search by checked servers only

To search with Free text search

1. In the Search panel (To view the Search panel) toggle the Name / Freetext field to
Freetext.

2. In the Freetext field enter the search parameters (for best results see Search
String Syntax).

3. In the Where drop down box, select where to search:

• Everywhere (objects and Add-ons)

• In objects (files and folders only)

• In add-ons (metadata only)

4. If more than one server is open, click in the Search by checked servers only box to
select the server or servers to be searched.

Note: If Search on checked servers only  is checked than at least one
server must be selected.

5. If only one server is open or selected, select which folder is to be searched, if
required:

1. Click in the Search in specified folder check box.

2. Select the folder to be searched.

3. Click in the Search in Sub-folders check box, if required.

6. Press <ENTER> or click on the search icon  .

Note: To open or hide search criteria click on the  icon, to the right of each
search criteria.
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Search by checked servers only

• If more than one server is open click in the Search on checked servers only  and
select the required server or servers to be searched.

Go to To search with Free text search.

Note: To search with all available search criteria, only one server can be searched
at a time.

Note: If Search on checked servers only  is checked than at least one
server must be selected.

Quick Search

The Quick Search function gives a quick means to search for a file, folder or project.

To view the Quick Search bar

1. In the main tool bar click on View -> Toolbars -> Quick search.

2. Click on Quick search to open or close the Quick search toolbar.

To use the Quick Search function

1. In the Quick search tool bar click in the Servers drop down box and select the
server or all servers to be searched.

2. In the text field enter the search string.

3. Press <ENTER> or click on the search icon  .

6.3.2 Standard Search

The Standard search searches for files with more detailed search options. Search by
one or a combination of different search criteria.

This section contains information on the following procedures:

• To search with Standard search

• Search by checked servers only

• Search by specified folder

• Search by advanced properties

• Search by selected keywords

• Search by References

• Search by checked servers only
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To search with Standard search

1. In the Search panel (To view the Search panel) toggle the Name / Freetext field to
Name.

2. In the Name field enter name search parameters, if required.

3. From the Type drop down box, select the item type to be searched for.

4. Click on the check boxes to add search criteria as required:

Note: If more than one server is open or selected, only the Search by
advanced properties criteria is available (see Search by checked servers
only).

• Search by checked servers only

• Search by specified folder

• Search by advanced properties

• Search by selected keywords

• Search by References

• Search by checked servers only

5. Press <ENTER> or click on the search icon  .

Note: To open or hide search criteria click on the  icon, to the right of each
search criteria.

Search by checked servers only

• If more than one server is open click in the Search on checked servers only  and
select the required server or servers to be searched.

Go to To search with Standard search.

Note: To search with all available search criteria, only one server can be searched
at a time.

Note: If Search on checked servers only  is checked than at least one
server must be selected.

Search by specified folder

1. Check the Search in specified folder check box.

2. Select a folder to search in.

3. If required, check the Search in subfolders check box.

4. If required, add more search criteria (To search with Standard search).

5. Press <ENTER> or click on the search icon  to search.
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Search by advanced properties

1. Check the Search by Advanced Properties check box.

2. Enter search parameters as required:

• Size: Searches for items that are either at least, at most, or between the
defined size(s) in KB.

• Created: Searches for items created either after, before, or between the
defined date(s).

• Modified: Searches for items modified either after, before, or between the
defined date(s).

• Use group instead of users: If selected, the next four options will apply to
groups instead of users.

Note: Only registered users/groups will be available from the lists.

• Owned by: Searches for items owned by user.

• Modified by: Searches for items that was last modified by the defined user.

• Checked out by: Searches for items checked out by the defined user.

• Search by access rights: If selected, searches for items that have write
permission either on user (UW), group (GW), or world (WW) level.

3. If required, add more search criteria (To search with Standard search).

4. Press <ENTER> or click on the search icon  to search.

Search by selected keywords

1. Check the Search by selected keywords check box.

2. In the upper field enter the first characters of the keyword, or enter * to list all
available keywords.

3. A list of available keywords that match the characters will then show in the
keywords list.

4. Select one or more keywords that match the search criteria.

5. Check or uncheck the All check box:

• Checked: Search for Scenes or Geometries which contain all search items.

• Not checked: Search for Scenes and Geometries which contain at least one of
the search items.

6. If required, add more search criteria (To search with Standard search).

7. Press <ENTER> or click on the search icon  to search.

Search by References
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1. Check the Search by Referenced/Referencing Files check box.

2. Drag and drop an item or items into the drop area.

3. Make sure that the Reference check box is checked.

4. Check or uncheck the All check box:

• Checked: Search for Scenes or Geometries which contain all search items.

• Not checked: Search for Scenes and Geometries which contain at least one of
the search items.

5. If required, add more search criteria (To search with Standard search).

6. Press <ENTER> or click on the search icon  to search.

Tip: To remove items from the drop area, right-click the item and select Remove
Selected.

Tip: To view a file in the drop area in the Explorer, right-click the desired item, and
select Open Containing Folder in Explorer.

Tip: To open the Properties window for an item, right-click the desired item, and
select Properties.

Tip: Use Search by References  to search and replace Images or Fonts
referenced by several Scenes or Geometries, with different Images or Fonts. For



Viz Graphic Hub User Guide

Page 148 Copyright © 2016 Vizrt

example, if a company logo changes, search for the image references, select each
required Scene and replace the image (see Replacing Item References).

6.3.3 Search String Syntax

Free text search string syntax is very similar to the search string syntax of other
comparable web search engines.

Example: zebra scene -project -folder

In the above example, the search will be conducted on any item names, item owners,
UUIDs, item types, and keywords that include the string zebra and scene. This search
excludes projects and folders, plus any of the other searched items that include the
words project and folder.

Example: giraffe -image -geometry

In the above example, the search will be conducted on any item names, item owners,
UUIDs, item types and keywords that include the string giraffe. This search excludes
images and geometries, plus any of the other searched items that include the words
image and geometry.

6.3.4 Best Practices for Searches

Viz Graphic Hub Manager’s search capabilities are powerful enough to replace the need
for browsing for items in the server tree. This is meant make your Graphic Hub work
faster and easier.

For example, if you have just created a scene on your design cluster, and you know the
scene name is soccer, just search for scene soccer. From the results, you can simply
drag and drop it to deploy it to your playout Engine.

Another example using the search feature for cleaning up a server. If you have a
complex tree structure, it may be cumbersome to find all the correct scenes you are
looking for. You could create a new and elegant tree structure and then find all the
scenes in the old one by searching by date and size. In this way, you can populate the
new structure with relevant objects in a logical order, and easily get rid of items that
are too old or too large, etc.

6.4 Importing External Images
You can import external images from Windows Explorer directly into the Viz Graphic
Hub Manager. These images will then be available on all connected Viz Graphic Hubs.

It is recommended that you import images of sufficient quality to be worked on in Viz
Artist. However, you do have the option to compress images when importing them.

To import external images

1. Select one or more images in Windows Explorer.
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2. Drag the selected images onto a folder in the right panel.

You are presented with the following options.

3. Select the image compression. Your options are:

• None

• Select automatically: If the source image has an alpha channel, DXT5 will be
used. If the source image does not have an alpha channel, DXT1 will be used.

• DXT1: Works best on images without an alpha channel.

• DXT5: Works best on images with an alpha channel.

4. If you wish to overwrite any existing images in the target director that have the
same name, check the Overwrite existing images check box.

Otherwise, an extension to the file name will be added to the newly imported
images.

5. Click Import.
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The Action Log appears.

6. Click Import.

7. In the Action Log, click Close.

6.5 Exporting to a Viz 3.x Archive (*.via)
You can export folders and/or files to Viz archive files (*.via). These can be
subsequently re-imported following the procedure for Importing a Viz 3.x Archive
(*.via).

To export to an archive



Viz Graphic Hub User Guide

Copyright © 2016 Vizrt Page 151

1. In the left panel, right-click the object to be exported and select Export to archive.

The following window is shown.

2. Click Browse to select a destination folder.

3. Enter a name for the archive.

4. Click Export.

6.6 Importing a Viz 3.x Archive (*.via)
You can import an archive file directly into Viz Graphic Hub.

To import an archive
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1. In the left panel, right-click the target server and select Import from archive.

The following window is shown.

2. Click Browse to select a source folder.

3. Select the archive.

4. To check for existing objects that exist with the same name (but a different UUID),
check Determine existing objects by same name instead of UUID.

5. To overwrite objects that exist with the same UUID, check Overwrite existing
objects.

6. Click Import.

6.7 Importing Viz 2.x Data and Archives
To use items from other data directories, they must be imported into the Viz Graphic
Hub. In Viz Graphic Hub Manager, you can import either data directories or archives
created with Viz Artist 2.x.
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Tip: When importing single items from a data directory or an archive, referenced
files will also be imported.

This section contains information on the following topics:

• Import Window

• Importing Data Directories

• Importing Viz 2.x Archives

• Resuming a Cancelled/Crashed Import Operation

6.7.1 Import Window

Import Window

6.7.2 Expert Settings

In the upper-right corner of the Import Window, there are a number of optional Expert
Settings that you can use during import operations.

Expert Settings

• Expert settings: Select to enable expert settings.

• No. of instances: Number of import threads allows to run asynchronously.

• Show instances: Select to show all current import threads.

• Overwrite existing files: Select this option before starting the import operation if
you want imported files to overwrite Viz 3.x files on the Viz Graphic Hub.
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• Restart after: Enter a value representing the number of objects after which the
import executable will restart.

• Timeout: If the import executable takes longer than the value specified here, the
import operation will restart.

6.7.3 Importing Data Directories

If you wish to overwrite existing directories, enable this first in the Expert Settings.

To import a Viz 2.x data directory

1. Click Server -> Import -> Viz 2.x data.

2. Select a Viz 2.x data folder to import from, and click Open.

The Import Window is shown.

3. Select the files you wish to import in the left panel.

4. Click the IMPORT button.

You are prompted to select a directory to store resulting log files.

5. Click Modify and select a directory.

6. Select the Convert all objects to lower case check box. This gives full Viz 3.x
compatibility with Viz Artist and Viz Trio.

7. Click OK.

Depending on the size of the directory, the import process may take some time. The
import window keeps you updated of progress.

6.7.4 Importing Viz 2.x Archives

You can import Viz Artist 2.x archive files (*.eva) into a Viz 3.x system using Viz
Graphic Hub Manager.

To import a Viz 2.x archive

1. Click Server -> Import -> Viz 2.x archive(s) to import entire archive(s);

Click Server -> Import -> Viz 2.x archive(s); click Server -> Import -> Manually
selected Viz 2.x archive(s) to import individual files from one or more archives.
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2. For automatic, select a folder housing archives to import, and click Open;

For manual, select an .eva archive file, and click Open.

The Import Window is shown.

3. Select the desired files from the left panel.

4. Click the IMPORT button.

You are prompted to select a directory to store resulting log files.

5. Click Modify and select a directory.

6. Select the Convert all objects to lower case check box. This gives full Viz 3.x
compatibility with Viz Artist and Viz Trio.

7. Click OK.

Depending on the size of the directory, the import process may take some time. The
import window keeps you updated of progress.

6.7.5 Resuming a Cancelled/Crashed Import Operation

If an error occurs and the import procedure crashes, or the import is cancelled, it is
possible to resume from where the import ended.

When an import operation is not carried through correctly, an import backup file will
automatically be created. This backup file is used to resume the import procedure.

Note: As the log file for an import is created on the hard disk of the physical
machine, the import can only be resumed on the machine it has been cancelled
on.

To resume a cancelled/crashed import operation

1. Click Server -> Import -> Resume from cancelled or crashed import.

2. Select a backup file to import, and click Open.

The Import Window is shown.

3. Click the IMPORT button.

4. Click OK.
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Depending on the size of the directory, the import process may take some time. The
import window keeps you updated of progress.

Tip: If resuming from a crashed import, check the selection of items to prevent
the crash from happening again. Also, it is possible to automatically start the
import when resuming, by enabling this option in the Preferences window.

6.8 Locating Duplicates
When items are copied from one project or folder to another (as occurs with the
procedures To create a linked file and To create a duplicate file(s)), the copy will exist
as a duplicate of the original item. As long as neither the original item nor the copy is
modified, they will remain duplicates, since the checksum of both objects is the same.

Tip: The items can be renamed, and still remain duplicates.

To locate the duplicates in Viz Graphic Hub

1. Click View -> Duplicates, or press <CTRL+N>, or <CTRL+F5>.

The duplicates window is shown.

The duplicates window lists all the duplicates in the selected server, sorted by the
names of the items. If duplicates carry different names, this will also be shown.

2. Right-click a duplicate for more information about it. This will open a menu with
the following options:

• Open Containing Folder in Explorer - Jumps to the project or folder in the
Servers and Folders Panel, where the selected item is placed.

• Properties - Opens the Item Properties window, which shows detailed
information about the selected item.

Caution: It is only possible to view the items in the Duplicates window, not
delete them. Delete duplicates with great caution as it will almost certainly bring
about the misplacement or loss of work of the various users on a server. It is
recommended that you only delete duplicates when you are the only user of a Viz
Graphic Hub on a localhost, to save disk space.
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6.9 Metadata
Viz Graphic Hub supports keywords and add-ons that work like metadata to help you to
dynamically organize your files better and enhance search capabilities.

This section contains information on the following topics:

• Keywords

• Add-ons

6.9.1 Keywords

Keywords can be assigned to files to enhance the search capability. Up to 20 keywords
can be assigned to a file. Keywords can be seen in the keyword window.

This section contains information on the following procedures:

• To open the Administer Keywords window

• To view files which use a selected keyword(s)

• To create a keyword

• To delete a keyword(s)

• To assign a keyword(s) to an item

• To assign a keyword(s) with the file context menu

• To remove a keyword(s) from an item

• To remove a keyword(s) with the item context menu

To open the Administer Keywords window

• Click Tools -> Administer Keywords, or

• <CTRL+K>, or
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• <CTRL+F10>

To view files which use a selected keyword(s)

1. Open the Administer Keywords... window (see To open the Administer
Keywords window).

2. Click on a keyword(s).

3. View the files which used the selected keywords:

• Click on Get files containing the selected keyword(s), or

• Right-click selected keywords and click on Get assigned files, or

• Double click a selected keyword

4. All files assigned with the selected keywords show in the right side panel.

To create a keyword

1. Open the Administer Keywords... window (see To open the Administer
Keywords window).
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2. Click the New button. In the left panel, a new keyword is created.

3. Enter a name for the new keyword.

Note: If the keyword name entered is not a valid name, a prompt window will
open to provide a valid name based on the entered name.

4. Press <ENTER>.

To delete a keyword(s)

A keyword can only be deleted if it is not assigned to a file or folder. Look in the No. of
Obj. field to see how many files or folders the keyword(s) are assigned to.

Note: If multiple keywords are selected, only the keywords with no assigned files
or folders will be deleted.

1. Open the Administer Keywords... window (see To open the Administer
Keywords window).

2. In the left panel, click on the keyword(s) to delete.

3. Click the Delete button.

4. Click Yes in the delete confirm window.

To assign a keyword(s) to an item

1. Right-click a file in the File panel to open the file context menu.
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2. Click Properties...

3. Click on Keywords, in the Properties for <file name> window that opens.

4. Select/find a keyword(s) to assign to the file:

1. Enter a keyword name in the search box.

2. Click on Search.



Viz Graphic Hub User Guide

Copyright © 2016 Vizrt Page 161

Tip: Wildcards such as * or ? can be used in the keywords search string.

or

• Click Show All to see all available keywords.

5. Click a keyword, in the Assignable keywords panel, to select it.

6. Click the < Add button.

Note: Up to 20 keywords can be assigned to one file.

7. Click OK.

To assign a keyword(s) with the file context menu

To assign a keyword(s) with the file context menu is better for on-the-fly keyword
additions, but does not show any other data about the keyword(s) which are assigned.

1. Right-click a file in the File panel to open the file context menu.

2. Click Add keywords...

3. Search for available keywords:

• Type the name of a keyword, or

Tip: As the keyword name is typed a list of keywords will show.

• Type * to show all available keywords

4. Click on the required keyword(s).

5. Click on Add...

6. Click Add in the Add keywords... window.

7. Click Close.

To remove a keyword(s) from an item

With this procedure a keyword(s) is first selected then the file(s). The advantage to that
method is greater visibility of information regarding each keyword and where it is used.

1. Open the Administer Keywords... window (see To open the Administer
Keywords window).

2. Click on a keyword(s) in the list of available keywords.

3. View the files which used the selected keywords:

• Click on Get files containing the selected keyword(s), or

• Right-click selected keywords and click on Get assigned files, or

• Double click a selected keyword

All files assigned with the selected keyword(s) show in the right side panel.

4. Right-click on the file(s) from which the keyword is to be removed.

5. Click Remove keyword(s).

6. Click Remove.... in the Remove keywords from <file name>... window.

7. Click Remove in the Remove keywords... window.
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8. Click Close.

To remove a keyword(s) with the item context menu

To remove a keyword(s) with the file context menu is better for on-the-fly keyword
removal, but does not show any other data about the keyword(s) which are to be
deleted.

1. Right-click a file in the File panel to open the file context menu.

2. Click Remove Keywords...

3. Select the keyword(s) to be removed

4. Click Remove....

5. Click Remove in the Remove keywords... window

6. Click Close
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6.9.2 Add-ons

Add-ons are a solution for creating templates to assign custom metadata to objects
in the Viz Graphic Hub. This provides another dimension to for searching, tagging
and organizing objects. Add-ons work similarly to Keywords but are actually more
extendible.

Add-ons are administered from the Add-ons window. They are assigned from the Add-
ons Panel.

Add-ons Window

Add-ons Panel

Each add-on can have several entries. Entries can be numbers, strings, UUID, date
and XML (for use by external applications). Each entry also has a Proposal, which will
set out the options for the add-on in an eventual drop down box. You can also add
informational text for a tool tip, which will be shown when you mouse over the region of
its name in the add-ons window.

One use case for add-ons is approval states. You can create an add-on with the
parameters of Draft, Pending, and Approved. If an art director does not want
any scene on the design cluster to be make it to the playout engine, he can use the
Searching functionality to take all new scenes, assign the add-on, and then only deploy
scenes that he has personally approved to the playout engine.

This section contains information on the following procedures:

• To create a new add-on

• To create an Add-on group
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• To publish an Add-on

• To filter add-ons by stage

• To Sort Add-ons and Add-on Groups

• To assign an add-on

• To retire an add-on

To create a new add-on

1. Open the Viz Graphic Hub Manager

2. Open the Administer add-ons window:

• Click Tools -> Administer add-ons..., or

• Press <CTRL+SHIFT+F8>

3. Open the Create add-on window:

• In the Administer add-ons window click the Create new add-on... button

 , or

• Right-click in the Add-ons quadrant and select Create new add-on...,  or

• Click in the Add-ons quadrant and press <CTRL+1>

4. In the Name field, enter a name for the add-on.

5. From the Group drop down box, select from:

• ungrouped: the new add-on will not be in a group.

• <group name>:  Select a group to put the new add-on.

6. Check the Allow transfer via DCC, if required (when checked, the add-on will be
transferred through DDC (Direct Deploy Copy)).

7. Check the Allow transfer via archive export/import, if required (when checked, the
add-on may be transferred via Archives (exported/imported)).
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8. Click the Add... button. The Create entry of add-on <add-on name> is
shown.

9. In the Name field, enter a name for the add-on entry.

10. From the Data Type drop down box, select one of the following options:

• Number: Only manual proposals supported.

• String: Supports manual proposals and having all registered users as a
proposal option.

• Date: No proposals supported, namely selecting a date from a calendar.

• UUID: No proposals supported.

• XML: No proposals supported.

11. Check the Mandatory check box for it to be mandatory for this entry to have a
value. Uncheck it for the entry to be optional.

12. From Proposal drop down box, make sure Manual is selected.

Note: If the Data Type is String, the option of selecting <all users> as
the Proposal is available. In this case, no further Proposal configuration is
required.

13. In the Add field, enter an option that will be available for selection and click the
Add button. Repeat for as many options as you want to have in your proposal.

You can also remove options by clicking the Remove button, as well as changing
the order in which options will appear by clicking the Up, Down, Top and Bottom
buttons.

14. Check the Restrict check box to restrict the proposal entries to what you have
added above. Uncheck it to allow user-defined entries in addition to your proposal
options.

15. From the Default value drop down box, select one of the following options:

• <none>: There will be no default value assigned. Not available if the entry is
restricted.

• <user defined>: The value will be defined when assigning the add-on. Not
available if the entry is restricted.

• <current user>: The logged-in user will be the default value. The other
proposal values will also be available.
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• <current time>: The current date and time will be the default value. Only
valid if the Data Type is Date.

• Any of the other proposals you have defined above.

16. In the Info field, enter any text that you wish to appear as a tool tip when
mousing over the add-on once it has been published.

Caution: Any text you enter in this field will be exposed to end users.

17. Click OK.

To create an Add-on group

1. Open the Viz Graphic Hub Manager.

2. Open the Administer add-ons window:

• Click Tools -> Administer add-ons..., or

• Press <CTRL+SHIFT+F8>

3. Open the Create add-on group window:

• In the Administer add-ons window click the Create new add-on group...

button  , or

• Right-click in the Add-ons quadrant and select Create new add-on group...,
or

• Click in the Add-ons quadrant and press <CTRL+2>

4. In the Name field, enter a name for the add-on group

Note: Make sure that the new Group name is unique.

5. Click the OK button. The new Add-on group will show in the Add-ons quadrant.

Note: Add-ons can be dragged from group to group as required.

To publish an Add-on

IMPORTANT! Add-ons are automatically saved during the creation process and
can be modified as required. But the Add-on cannot be assigned until it has been
published. As long as the Add-on is assigned to any item on the server, it cannot
be deleted. If the Add-on is not (no longer) assigned to any item on the server, it
can be deleted.

1. In the Add-ons quadrant of the Add-ons Window, right-click the add-on and select
Publish add-on.

You are queried if you are sure you want to publish this add-on.

2. If the add-on is ready for use, click Yes.

To filter add-ons by type
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• In the Add-ons quadrant of the Add-ons Window, from the Filter by type drop down
box, select one of the following options:

• All: All add-ons

• User-defined: All add-ons created by any users

• Viz: External metadata created by another Viz application

• System: All Viz Graphic Hub server-delivered add-ons

To filter add-ons by stage

• In the Add-ons quadrant of the Add-ons Window, from the Filter by stage drop
down box, select one of the following options:

• All: All add-ons

• Draft: Unpublished add-ons

• Published: Published add-ons

• Retired: Add-ons retired from active use (because they can be withdrawn from
service but not deleted from the system).

• Imported: Metadata exported to Viz Graphic Hub by other Viz applications.

• Copied: Transferred in a deploy operation.

• From archive: Add-ons exported by Viz Engine and re-imported from a Viz Artist
archive to the Viz Graphic Hub.

To Sort Add-ons and Add-on Groups

1. Open the Administer add-ons window:

• Click Tools -> Administer add-ons..., or

• Press <CTRL+SHIFT+F8>

2. In the Add-ons panel click on an Add-on or an Add-on Group.

3. Drag the Add-on or an Add-on Group to its new location.

To assign an add-on

1. Enable the Add-ons Panel.

2. Select one or more files and drag them into the add-ons header.

• To remove a file from the add-ons header, click it and press <DELETE>.

3. Click the Edit tab.
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Add-ons available for assignment are shown.

4. Click the button to the left of an add-on to expand it.

5. Check the check box beside the add-on to select it.

6. Do one of the following:

• Select a value from the proposals drop down box.

• Enter a value in the field (allowed only if the add-on is unrestricted).

• Click the E button to the right of the add-on to edit the proposals (allowed only
if the add-on is unrestricted).

• Select a date (allowed only if the add-on is for the Date data type).

Note: If you have selected multiple items and some already have add-ons
with different values, you are alerted to the fact by a square filling the check-
box. If you wish to override the existing values, un-check and check again for
the square to be replaced by a check mark.
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7. Click Apply.

To retire an add-on

1. In the Add-ons quadrant of the Add-ons Window, right-click the add-on and select
Retire add-on.

You are queried if you are sure you want to publish this add-on.

2. If the add-on is ready for use, click Yes.

The add-on is no longer available for use.

6.10 Replacing Item References
By replacing references it is possible to replace, for example, Images or Fonts
referenced by Scenes or Geometries, with different Images or Fonts. It is only possible
to replace an Image with an Image, or a Font with a Font.

To replace references is practical, for example, when rebranding a corporate identity.

Caution: Do not replace references at random. Make sure that the replacement
items are compatible in terms of size, scale, color, and other Viz Artist properties
used for playout. Research and test before replacing references.

Caution: Use the replace item references feature with care, it can be potentially
harmful. For example, if the image to be replaced is in a Scene which is currently
on-air.

IMPORTANT! There is no UNDO to this procedure. Be very careful, and try this
procedure first on one or two Scenes only.

This section contains information on the following procedures:

• To find items referenced by Scenes or Geometries

• To replace references

To find items referenced by Scenes or Geometries

• Go to To search with Standard search and do a Search by References.

To replace references

1. In the Viz Graphic Hub Manger, right-click the desired item or items and select
Replace References...
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The Replace References wizard opens.

2. Optional: In the Filter panel select which type of object to replace from the drop
down box. Options are:

• All

• Image

• Font

• Geometry

• Audio
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3. Click Next.

4. Drag replacement items onto the listed items of the same type.

5. Click Finish. The Action Log for replacing references is shown.

6. Click Replace.

6.11 Enabling Viz Graphic Hub for a Virtual Studio
The XML necessary to support a virtual set environment is generally obtained from
Vizrt Support. The following procedure indicates how to import that XML file.

To enable Viz Graphic Hub for a Virtual Studio

1. From the main menu, select Extra -> Viz VR Studio Setup.

The Viz VR Studio Setup window is shown.
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2. On the toolbar, click the Import button.

3. Select the XML file and click Open.

To export Viz Virtual Studio settings

1. From the main menu, select Extra -> Viz VR Studio Setup.

The Viz VR Studio Setup window is shown.

2. On the toolbar, click the Export button.

3. Name the XML file and click Save.
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7 Administrator Operations

This section contains information on the following topics:

• Back Up and Restore

• Direct Deploy Copy (DDC)

• Finding and Fixing Data Errors

• Managing Users and Groups

7.1 Back Up and Restore
The backup and restore operations in Viz Graphic Hub is an incremental process. If one
backup or restore operation succeeds, all subsequent operations copy the difference
from the successful backup/restore to the current operation. Restore points are created
to accomplish this process.

The first restore point holds information about the original data directory. The second
point holds information about changes from the startup to the first backup. The third
point holds information from the first to second backup, and so on. If no changes have
been made since the previous backup, Viz Graphic Hub will not create a new restore
point.

Example: The first backup finished successfully at 01.01.2009 00:00:10 and the
second at 01.01.2009 12:00:00. Between the backups, one scene was modified;
“MyScene”. The latest restore point would then only contain data regarding this
scene. If restoring to the previous point, only “MyScene” will reset to its status at
01.01.2009 00:00:10.

There are two kinds of backup: internal and external.

Internal backups are done via the Viz Graphic Hub Terminal and provide the option
of excluding informational data from the Journal. Although it reduces the amount of
restore points, it also vastly reduces the amount of space required on your machine’s
hard disk.

External backups are done via the command line. It is a full backup and requires you to
prepare a batch file for execution.

This section contains information on the following topics:

• Taking Backup

• Restoring Files

7.1.1 Taking Backup

To backup the database

1. Stop Viz Graphic Hub, if it is running.
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2. In Viz Graphic Hub Terminal’s main menu, click Backup.

The Data Directory Backup window is shown.

3. Check the Enable backup data check box.

4. If you want to back up every time the system is shut down, check the
Automatically backup after successful showdown check box.

5. For an internal backup, select the Enable Internal backup radio button.

• Click the Browse button, and set the backup directory.

• Optionally, check the Exclude informational data check box to reduce the
number of restore points and space taken by the backup on the machine’s hard
disk.

6. For an external backup, select the Enable External backup radio button.

• Click the Browse button, and select the *.bat file to be executed for the
backup operation.

7. Optionally, if backup should be performed automatically after a successful Viz
Graphic Hub Server shutdown, select the requisite check box.
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Note: This can be useful for taking regular backups - all you need to do is
shut down the server. If selected, every time you shut down Viz Graphic Hub,
a backup will be taken. Over time, this will take up a lot of hard disk space.

8. Click the Backup now button.

The back up operation is performed. The time required depends on how often
back up is taken, as well as the size of the data directory.

9. When the backup operation is finished, click the OK button to close the window.

7.1.2 Restoring Files

When restoring files, observe the following best practices:

• Data directories: It is not recommended to restore files to the existing data
directory. Instead, create a new directory and restore the files there. Then start the
Viz Graphic Hub Server with the restored data directory.

• Deleting restore points: When deleting a restore point, the selected point and
also all pending restore points (with later dates) will be deleted. To make sure that
the remaining backup data includes the latest files, execute the backup operation
one more time.

• The first restore point: Taking the first backup and restoring the oldest restore
point may take a long time, depending on the data directory size. Because of this,
the “Automatically backup after successful shutdown” check box should not be
selected before the first backup execution has been carried through successfully.

To restore previously backed up files

1. Stop Viz Graphic Hub, if it is running.



Viz Graphic Hub User Guide

Page 176 Copyright © 2016 Vizrt

2. In Viz Graphic Hub Terminal’s main menu, click Backup.

The Backup and Restore window is shown.

3. Wait until Viz Graphic Hub Terminal has loaded all available restore points from the
defined backup directory.

4. In the General Restore Options panel, click the Browse button next to the Restore
Directory to set it.

Caution: Do not restore files to an existing data directory. Instead, create a
new directory and restore the files there.

5. In the Max. restore points drop down box, either leave the default as Unlimited,
or select User defined.

• If you select user defined, enter the maximum number of restore points to be
allowed.

Tip: This options can save considerable hard disk space. When you select
a user-defined level of maximum restore points, Viz Graphic Hub Terminal
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will delete all other previous restore points (beyond the maximum). Also,
subsequent back-ups will overwrite the oldest one. You are prompted before
this happens (when changing the number of maximum restore points).

6. In the Available Restore Points list, click a restore point, and then press the
Restore now button.

A warning message will appear with details about the restore action that is about
to be performed. Read this message carefully to prevent data loss.

7. Click Yes.

The restore operation is executed.

8. Click the OK button to close the dialog.

9. Click the OK button to close the Backup and Restore window.

7.2 Direct Deploy Copy (DDC)
The method for replication and synchronization is the Deploy Direct Copy (DDC)
functionality.

The Viz Graphic Hub deploy solution makes it possible to copy folders/projects/items
with all necessary data (referenced folders/projects/items) from one server to another.
For example, if deploying a scene, all items that are referenced by this scene (images,
materials, and so on) will also be deployed.

This section contains information on the following topics:

• Deploy Agent Behavior Overview

• Global Viz Graphic Hub Deploy Properties
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• Rebuild Structure Under Target Folder

• Copy to target folder only

• Multi Server DeployVizBold

• Server to Server DeployVizBold

• Scheduling Deploy Tasks

• Maintaining Deploy Agents and Tasks

See Also

• Deploy Preferences

• Deploy Troubleshooting

7.2.1 Deploy Agent Behavior Overview

Standard Behavior

The standard behavior copies the whole folder structure from the source server to the
destination server, except when ‘copy to target folder’ only is selected. This behavior
makes sure that the folders on the source and destination servers have the same UUID.

Supported scheduling:

• Real-time

• Time steered

• User triggered

Supported data mode:

• Folder based (Only a single folder can be selected per task)

• File based: in ‘Copy to target folder only’ mode (Multiple files can be selected per
task, folders are not allowed)

• Search criteria based: in ‘Copy to target folder only’ mode (Copies all files that
result from executing the search criteria, folders are ignored)

Supported options:

• Real-time

Real-time is supported with:

• Rebuild original structure

• Rebuild structure under target folder

Real-time supports to:

• Remove deleted objects on target server(s)

• Synchronize users, groups, keywords, add on templates, etc.

• Time steered

Time steered is supported with:

• Copy to target folder only

• Rebuild original structure

• Rebuild structure under target folder

• User triggered
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User triggered is supported with

• Copy to target folder only

• Rebuild original structure

• Rebuild structure under target folder

DDC behavior

The DDC behavior creates only folders on the destination server which contain files
that have to be copied by the task. This behavior ignores the UUID of folders and
makes sure that all folders have the correct name in the structure. Real-time cannot be
supported in this mode.

Supported scheduling:

• Time steered

• User triggered

Supported data mode:

• Folder based (Only a single folder can be selected per task)

• File based (Multiple files can be selected per task, folders are not allowed)

• Search criteria based (Copies all files that result from executing the search criteria,
folders are ignored)

Supported options:

• Time steered

Time steered is supported with:

• Copy to target folder only

• Rebuild original structure

• Rebuild structure under target folder

• User triggered

User triggered is supported with:

• Copy to target folder only

• Rebuild original structure

• Rebuild structure under target folder

Additional information to data modes

• File based: The task will not be able to execute if the objects to deploy contain
folders

• Search criteria based: The task will ignore all folders that are contained in the
result of the search .

Standard and DDC Supported Options

Data Mode Options Standard
behavior

DDC
behavior

Folder based Copy to target folder only X X X X
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Data Mode Options Standard
behavior

DDC
behavior

Rebuild original structure X X X X X

Rebuild structure under
target folder

X X X X X

File based Copy to target folder only X X X X

Rebuild original structure X X

Rebuild structure under
target folder

X X

Search
criteria
based

Copy to target folder only X X X X

Rebuild original structure X X

Rebuild structure under
target folder

X X

X =
Supported
Options

Real-
time

Time
steered

User
triggered

Real-
time

Time
steered

User
triggered

Scheduling

Note: X = Supported Options

7.2.2 Global Viz Graphic Hub Deploy Properties

The Properties of Deploy Agent <Agent name> panel shows the properties and
configuration settings for global Viz Graphic Hub Deploy agent.

This section contains information on the following topics:

• To open the Properties of Deploy Agent

• Statistics Panel

• Configuration Panel

• Version info Panel

• High Availability Panel

To open the Properties of Deploy Agent

1. Click the Running deploy tasks tab.

2. Right click the deploy agent and click Properties of deploy agent <agent
name>...

3. The Properties of Deploy Agent <agent name> shows.

Statistics Panel
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In the Statistics panel Viz Graphic Hubs currently in use contains the Viz Graphic
Hubs currently used for Viz GH Deploy Agent. These Viz Graphic Hubs are the source
servers of one or multiple tasks. Viz GH Deploy Agent automatically removes all unused
Viz Graphic Hub source servers.

In certain cases a Viz Graphic Hub can be lost or cannot be contacted by Viz Graphic
Hub Deploy Agent. If this happens the add and remove can be done manually.

Note: A Viz Graphic Hub Deploy Agent which is configured in as high availability
partner originally cannot remove or add Viz Graphic Hubs.

To Add a Viz Graphic Hub

(Which is not registered in the Deploy Agent)

1. Open the Properties of Deploy Agent window (see To open the Properties of Deploy
Agent).

2. Open the Select Viz Graphic Hub to add window.

• Click Add... , or

• Right click in the Viz Graphic Hubs currently in use box, and click Add...

3. Select a Viz Graphic Hub to be added, from the drop down box.

4. Click OK or Apply.

Note: The added Viz Graphic Hub status will be ‘to be added’ until OK or Apply
has been clicked (when not highlighted, the ‘to be added’ Viz Graphic Hub will
show purple).

Note: If a Viz Graphic Hub added does not contain a valid task for the current
Viz Graphic Hub Deploy Agent the Viz Graphic Hub will be automatically removed
again. It is not possible to add or remove multiple Viz Graphic Hubs at once.
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Statistics Panel

To remove a Viz Graphic Hub

1. Open the Properties of Deploy Agent window (see To open the Properties of Deploy
Agent).

2. Click the Viz Graphic Hub to be removed.

3. Remove the Viz Graphic Hub:

• Click Remove, or

• Right click the selected Viz Graphic Hub and click Remove selected from the
context menu

4. Click OK or Apply.

Note: The selected Viz Graphic Hub status will be ‘to be removed’ until OK or
Apply has been clicked (when not highlighted, the ‘to be removed’ Viz Graphic
Hub will show red).

Note: If a Viz Graphic Hub removed contains any running tasks the remove will
not be successful. Either click Cancel or undo the change via the context menu.
If a removed Viz Graphic Hub is not reachable by Viz Graphic Hub Deploy Agent a
message will show where it is able to select a forced remove or cancel the action.
It is not possible to add or remove multiple Viz Graphic Hubs at once.
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Viz Graphic Hubs selected to be Added or Removed

Configuration Panel

• Logging of additional/advanced runtime information:
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• Log additional information to EventLog: Configures the Deploy Agent to log
warnings and errors to the event log of the source server of the task that caused
the issues.

• Log additional information to journal on dedicated Log-Server:
Configures the Deploy Agent to log warnings and errors of all tasks to the event
log of a specified server.

• Deploy agent work directory:

• Folder: Defines where the Deploy Agent will keep its configuration file and
temporary data.

• Timeouts (related to communication with Viz Graphic Hubs): Changing the
values of the timeout settings may have a significant impact on the behavior of
the deploy agent. The default values have been tested in a LAN setting as well as
for long range deploy tasks and should only be changed if the deploy agent has
problems with servers that are connected via a slow / congested network or have
a high server load. Increasing the timeout values may solve the problems in this
case, decreasing will not improve the general performance of the agent and is not
recommended.

• Establishing communication timeout (in seconds): Specifies the maximum
amount of time for a Deploy Agent is allowed to connect to a server. If the server
does not respond in this period due to network characteristics or server load, it
will be considered as offline.

• Communication roundtrip timeout (in seconds): Specifies the maximum
amount of time for the deploy agent to wait for a reply from the server. If the
server does not respond in this period due to network characteristics or server
load, the affected task may be paused by the agent.

• Cluster failover timeout (in seconds): This option is relevant for agents that
operate in a setting with a failover server. If a main server becomes unavailable,
this timeout specifies the period that a task is waiting for a notification from the
failover server to switch over. If this time exceeds, the agent will manually try to
connect to the failover server.

• Expert settings:

• No. of attempts to reconnect to Viz Graphic Hubs:  Set the number of
times the agent is to attempt to connect to Viz Graphic Hubs

• Time (in seconds) between attempts to reconnect: Set the time between each
attempt to reconnect to Viz Graphic Hubs

• Do emergency pausing of realtime tasks: Click in the box to do emergency
pausing of realtime tasks. Set the % of all objects or the number of objects.

• Use original DDC behavior for non realtime tasks: This option is set
globally for the deploy agent and affects all tasks. The major difference to the
normal mode is that the “deploy under target folder” restriction of having no
folder on source and destination that has the same UUID but an incompatible
path does not apply. If the Deploy Agent discovers a folder with the same UUID
but different path, a new folder with a new UUID is created in the expected
path. Additionally, this mode does not create the entire folder structure in the
target folder, but creates only the folders that need to exist to deploy referenced
files. This feature has a significant impact on the performance of the Deploy
Agent, and should be chosen wisely as it will affect all non-realtime tasks that
are executed by the agent

• Do not overwrite if destination file is newer: If set, the file on the
destination server will not be overwritten, if it has a modification date/time
newer than the source file. The default setting (=option is not checked) will
always overwrite the file with the source-file.
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• Communications ports:

• TCP port:  Set the port number

• UDP port: Set the port number

Version info Panel

Show version information for:

• The Deploy Agent

• The Tasks scheduler

• The Viz Graphic Hub interface

High Availability Panel

When a new High Availability Partner is configured, the configuration of these values
will automatically transfer to the High Availability Partner:

• Timeouts:

• Establishing communication timeout (in seconds)

• Communication roundtrip timeout (in seconds)

• Cluster failover timeout (in seconds)

• Expert settings:

• Do emergency pausing of realtime tasks

• Use the original DDC behavior for non realtime tasks.

IMPORTANT! When the High Availability Partner is disconnected the configuration
values return to their default values.

Note: From Deploy Agent version 1.4.1it is possible to configure high availability
partners using hostnames or IP addresses
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High Availability window

To configure a High Availability partner

1. Click in the Configure high availability partner check box.

2. Select the Deploy agent from the Partner drop down box.

3. Click the Use IP address instead of host name box if required.

Note: If the High Availability partner configuration is set to use IP addresses,
the clients need to have fix IP-addresses.

4. Click OK or Apply.

7.2.3 Rebuild Structure Under Target Folder

Creating a new file based deploy task
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The Options panel shows a deploy task configuration where the folder [B] of Server 1 is
deployed to Folder [U] of Server 2.

The Options panel offers various settings to configure the deploy task:

• Behavior options:

• Overwrite existing objects: If there is a file in folder [B] or any of its
subfolders and the same file exists on the destination server (a file with the
same UUID), then the file will be overwritten on the destination if the content is
different.

• Overwrite existing references: If there is a file [F] in folder [B] or any of its
subfolders with a reference to file R and file R exists on the destination server (a
file with the same UUID), then file R will be overwritten on the destination if the
content is different.

• Keep original owner: If there is a file in folder [B] or any of its subfolders and
the same file exists on the destination server (a file with the same UUID), then
the owner of the destination file won't be changed if it differs from the source
file.

• Processing options:

• Parallel: If multiple destinations are selected, the destinations will be
synchronized in parallel.

• Deploy all files to 1st target server and then to the next and so on...: If
multiple destinations are selected, the destinations will be fully synchronized one
at a time.

• Deploy one file to all target servers and then the next file and so
on...: If multiple destinations are selected, missing files will be copied to all
destinations one at a time.

The Schedule panel shows the settings that are available to schedule the new deploy
task.
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Apart from the general settings, Rebuild Structure Under Target Folder tasks also
supports the deletion of files on the target server. Files will only be deleted if they are
removed from the source folder [B] or any of its subfolders and the file also exists on
the destination server in folder [U] or any of its subfolders. If the file on the destination
also has folder links outside folder U, then only the folder links inside the target
structure are removed.

• Deploy agent: Select the Deploy Agent to be used. The version number and deploy
behavior of the selected Deploy Agent is shown below the drop down box.

• Task: Enter a name and description for the new deploy task.

• Schedule this task: Click to enable or disable the Schedule field.

• Schedule: Create a schedule for the new deploy task:

• Mode: Select either, Once, Recurring or Recurring forever

• Start at/End after: Options depend on the set Mode. Set the start and finish of
a new deploy task

• Each: Select how often the task should start from the drop down box.

• Realtime: Click to enable or disable the Realtime options field.

• Realtime options:

• Remove deleted objects on target server(s) as well: ???????

• Synchronize: Synchronize options can be chosen separately. Check each box as
required.
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The Data panel shows that folder [B] will be used as source for the new deploy task.

Behavior

Before and after deployment comparison shows the behavior of the deploy task.

Before and after deployment comparison

To create a consistent deployment, not only folder [B] and its subfolders but the
entire folder structure of the source server is created under the target folder on the
destination server. This means that there must not exist any folder / project on both
servers (apart from already synchronized folders with the correct path). The deploy
task will go out of sync such a configuration is discovered. This restriction does not
apply to files, but one needs to pay attention that content of files outside the target
structure may be changed by this task by this task.

Before and after DDC deployment shows an example deployment of the same deploy
task setup as described before, but the option “Use original DDC behavior for non-
realtime tasks” has been enabled and the schedule has been changed from realtime to
a recurring task (see section “Expert settings”).

Before and after DDC deployment
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This has the effect that only folders that are needed for deployment will be created, in
this case the task creates all folders on the path to folder [B] and additionally folder [C]
as it contains either a reference or a folder link from a file that is deployed. Folders [AB]
and [ABC] are skipped and not deployed to the destination server. Furthermore, folder
[X] on the destination server already contained folders LAA, [A] and B, which means
that the deploy agent had to create new folders with new UUIDs under folder [U].

7.2.4 Copy to target folder only

Copy to target folder only shows folder [A] being deployed from the source server to
folder [T] on the destination server in “Copy to target folder only” mode.

Copy to target folder only

In this case the structure of the source server is ignored and all files from folder [A] and
its subfolders are copied directly into folder [T].

Before copy to target folder only shows that only files were deployed to folder [T], but
no subfolders were created.
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Before copy to target folder only

After copy to target folder only

Note that referenced files outside the source structure will also be deployed into the
target folder. Since there might be files from multiple folders deployed into a single
folder, it is possible that the target folder will contain multiple files with the same
name.

7.2.5 Multi Server Deploy

Multi Server Deploy acts to deploy one or more folders/projects/items in exactly the
same folder structure to two or more selected servers.

To replicate on multiple servers
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1. In Viz Graphic Hub Manager, log in to two or more servers.

2. Right-click a folder/project/item in the Servers and Folders panel or Files panel,
and then from the menu that appears, select Deploy.

Alternatively, press <CTRL+D>.
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The Deploy Direct Copy window is shown, and the analysis process begins.

3. In the list, select the target servers where the folders/projects/items should be
deployed.

Tip: The servers can be sorted by clicking the Top, Up, Down, or Bottom
buttons. This will increase/decrease the priority level of a specific server.

4. Enable/disable the following behavior options:

• Overwrite existing objects (does not apply to referenced items)

• Overwrite existing references

• Keep original owner

5. Select one of the following processing options:

• Deploy all files to the first target server, then the next server in the queue, and
so on

• Deploy one file to all target servers, then the next file in the queue, and so on

Tip: You can predefine the options in Steps 4 and 5 by clicking Tools -> Edit
Preferences -> Deploy Direct Copy. Once defined, these preferences will be
set as defaults for every deploy operation you configure.

6. Click the Continue button.
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The Action Log for deleting files is activated.

7. Click the Do It button.

The folders/projects/items will then be deployed.

8. When the deploy process is finished, check the Action Log for possible errors, and
if necessary, attempt to redeploy any unsuccessful files.

7.2.6 Server to Server Deploy

Server to Server Deploy acts to deploy one or more folders/projects/items to one other
server. The original structure can be rebuilt, the folders/projects/items can be copied to
the target folder, or the structure can be rebuilt under the target folder.

To replicate on one target server

1. In Viz Graphic Hub Manager, log in to two servers.
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2. In the Servers and Folders panel, select source files/folders/items, and then drag
them to the target folder in the desired server.
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The Deploy Direct Copy window is shown, and the analysis process begins.

3. Select one of the following behavior options:

• Rebuild original structure: Copies an exact replicate of all selected folders/
projects/items and its references from source to destination server.

• Copy to target folder only: Copies all selected folders/projects/items and its
references from the source server to the destination folder on the destination
server.

• Rebuild structure under target folder: Copies an exact replicate of all
selected folders/projects/items and its references from the source server to the
destination folder on the destination server.

4. Enable/disable the following behavior options:

• Overwrite existing objects (does not apply to referenced items)

• Overwrite existing references

• Keep original owner

Tip: You can predefine the options in Steps 3 and 4 by clicking Tools -> Edit
Preferences -> Deploy Direct Copy. Once defined, these preferences will be
set as defaults for every deploy operation you configure.

5. Click the Continue button.
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The Action Log for deleting files is activated.

6. Click the Do It button.

The folders/projects/items will then be deployed.

7. When the deploy process is finished, check the Action Log for possible errors, and
if necessary, attempt to redeploy any unsuccessful files.

7.2.7 Scheduling Deploy Tasks

You have the option of scheduling deploy tasks at programmed intervals. This is useful
if you want to replicate data for safekeeping on a regular basis.

Note: As a prerequisite, you must have the Viz Graphic Hub Deploy Agent service
installed. See Deploy Agent Requirements before proceeding.

To install Viz Graphic Hub Deploy Agent

1. Double-click the VizGHDeployAgent.xx.xx.msi file.
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The installation wizard launches

2. Click Next to proceed.

The license agreement is shown.

3. Read the license agreement, check the I agree check box, and click Next to
proceed.
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The Custom Setup window is shown.

4. Click Next to proceed.

Viz Graphic Hub Deploy Agent is ready to be installed.

5. Click Install.

The application installs on your machine.
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The installation finishes.

6. Click Finish.

To schedule a deploy task

1. In Viz Graphic Hub Manager, log into two or more servers.

2. Right-click a folder/project/item in the Servers and Folders panel or Files panel,
and then from the menu that appears, select Create Deploy Task.
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The Create New Deploy Task window is shown.

3. Select one or more target servers.

4. Select one of the behavior options:

• Rebuild original structure: Copies an exact replicate of all selected folders/
projects/items and its references from source to destination server.

• Copy to target folder only: Copies all selected folders/projects/items and its
references from the source server to the destination folder on the destination
server.

• Rebuild structure under target folder: Copies an exact replicate of all
selected folders/projects/items and its references from the source server to the
destination folder on the destination server.
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Tip: For Copy to Target Folder Only and Rebuilt Structure Under Target
Folder, you can also drag folders or projects into the field beside the Behavior
Options drop down box.

5. Enable/disable the following behavior options:

• Overwrite existing objects (does not apply to referenced items)

• Overwrite existing references

• Keep original owner

6. Select one of the following processing options:

• Deploy all files to the first target server, then the next server in the queue, and
so on

• Deploy one file to all target servers, then the next file in the queue, and so on
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7. In the left panel, click Schedule.

8. From the Deploy Agent drop down box, select a deploy agent.

Tip: If you have several deploy agents installed on various machines, and
you intend to schedule many tasks, use a different deploy agent for each
task for the purpose of load balancing.

9. Name and describe the task in the fields provided.

10. Check the Schedule this task check box.

Note: If you uncheck this box, the deploy task will execute right away, rather
than wait for a scheduled time.

11. From the Mode drop down box, select one of the following options:

• Once

• Recurring

• Recurring forever

12. In the Start at drop down box, click to select a date from the calendar, and if
necessary, adjust the time.

Note: You cannot schedule tasks to begin in the past.

13. If your mode is Recurring, in the End after drop down box, click to select a date
from the calendar, and if necessary, adjust the time.

14. Select one of the following radio button options:

• Each - select an interval
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• Realtime - the deploy task will occur every time there is a change in the
database. With this selection, you can optionally Remove deleted objects on
the target server as well.

Note: Realtime tasks cannot be modified later.

15. In the left panel, click Data and drag any additional folders or files into the right
panel, as necessary.

Caution: Do not drag subfolders of any folders that are already in the right
panel.

Note: You cannot drag files into the right panel for Realtime tasks.

16. Click OK to create the deploy task.

7.2.8 Maintaining Deploy Agents and Tasks

You have the following options regarding your deploy tasks:

• To view running deploy tasks

• To view scheduled deploy tasks

• To view finished deploy tasks

• To modify a deploy task

• To search scheduled deploy tasks

• To search finished deploy tasks

• To maintain deploy agents



Viz Graphic Hub User Guide

Copyright © 2016 Vizrt Page 205

To view running deploy tasks

• In Viz Graphic Hub Manager, from the main menu, click Tools -> Administer Tasks ->
Running deploy tasks.

All running deploy agents and tasks are shown in the Journal.

To view scheduled deploy tasks

• In Viz Graphic Hub Manager, from the main menu, click Tools -> Administer Tasks ->
Scheduled deploy tasks.

All scheduled deploy tasks are shown in the Journal.

To view finished deploy tasks

• In Viz Graphic Hub Manager, from the main menu, click Tools -> Administer Tasks ->
Finished deploy tasks.

All finished deploy tasks are shown in the Journal.

To modify a deploy task

Note: Modifications will not affect tasks that are currently running. If you modify
such a task, the changes will only take place at the next interval.

1. Make sure you are logged into the source server for which you wish to modify the
deploy task.

2. Show the deploy tasks in the Journal, in accordance with one of the procedures
above.

3. Right-click the task and select Properties.

The Schedule Deploy Task window is shown.
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4. Continue with the procedure To schedule a deploy task from step 3 onward.

To search scheduled deploy tasks

1. Perform the procedure To view scheduled deploy tasks.

The Journal is enabled for searching scheduled deploy tasks.

2. From the Filter, using the Server drop down box, select a server.

3. In the Details like field, enter free text like name of the task, name of the agent,
or any description that may figure in the task.

4. In the Journal, click the Search button.

The search results are shown in the panel below. The Triggers in column shows
when the scheduled deploy task is set to run next.

When one is selected, the deploy task’s details are shown in the panel to the right.

5. To modify the deploy task, do one of the following:

• Right-click the deploy task in the results panel and select Properties.

• In the details panel, click the Properties button.

6. Continue with the procedure To schedule a deploy task from step 3 onward.

To search finished deploy tasks
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1. Perform the procedure To view finished deploy tasks.

The Journal is enabled for searching deploy tasks.

2. From the Filter, using the Server drop down box, select a server.

3. Select a task Status. Your options are:

• Only unsuccessful

• Only successful

• Both

4. From the Date drop down box, select one of the following options:

• Anytime

• From: Selecting this option will prompt you to also enter a beginning date and
time.

• Until: Selecting this option will prompt you to also enter an ending date and
time.

• Between: Selecting this option will prompt you to also enter a beginning and
ending date and time.

5. In the Details like field, enter free text like name of the task, name of the agent,
or any description that may figure in the task.

6. In the Details not like field, enter free text like name of the task, name of the
agent, or any description that you want to exclude from the task search.

7. In the Journal, click the Search button.

The search results are shown in the panel below. When one is selected, the
finished deploy task’s details are shown in the panel to the right. There are
general details as well as any errors and warnings.

To maintain deploy agents

1. Launch Viz Graphic Hub Manager on the machine where the deploy agent is
meant to run.

2. Log into the source server(s).
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3. Perform the procedure To view running deploy tasks.

4. In the left panel, right-click the relevant deploy agent and select Properties.

The deploy agent properties window is shown. The Statistics link is selected by
default. The data shown here is for information purposes only.
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5. Click the Configuration link.

6. Configure the following parameters as necessary:

• Log additional information to EventLog: Select this option to include
debugging information, as well as records of the start of tasks, in the Windows
event log.

• Log additional information to journal on dedicated log server: Select
this option to include debugging information, as well as records of the start of
tasks, in the Viz Graphic Hub server log, on one of the servers available in the
Dedicated Log Server drop down box.

• Deploy agent work directory: The path and folder which acts as the
temporary buffer for the deploy agent. Setting this to a different drive can
improve performance and can additionally put it where access rights may
differ. The deploy agent process must have full access rights on the selected
directory.

• Timeouts: Set the timeouts times for each item as required.

• Expert settings: Consult your Vizrt CA representative before changing any of
these settings:

• Do ‘emergency’ pausing of realtime tasks: In the event that there is a risk
of too many files being deleting on the destination server, select this option
and assign a threshold as a percentage or number of files beyond which the
deploy agent will pause the task. If such a task is paused, you will find it upon
performing the procedure To search finished deploy tasks. You are always able
to resume the task.

• TCP port: Default is 19393. Change only after consultation with your network
administrator, if there are firewall issues.

• UDP port: Default is 19392. Change only after consultation with your network
administrator, if there are firewall issues.



Viz Graphic Hub User Guide

Page 210 Copyright © 2016 Vizrt

Note: Changing TCP or UDP setting will require changes to the Viz Graphic
Hub Manager preferences: click Tools -> Edit preferences and in the left
panel select Deploy.

7. Click the Version Info link.

8. When reporting a problem, be sure to include this version information.

9. Click OK to dismiss the Deploy Agent Properties window.

10. Click the High Availability link.
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11. To configure a high availability partner, select the respective check box.

12. From the Partner drop down box, select the alternative to take over in case of
failover.

Note: In general, it is recommended that you use the default TCP port.

13. Click OK.

7.3 Finding and Fixing Data Errors
Much like the Check Disk feature in Windows, Viz Graphic Hub Manager allows you to
search for and fix data errors on the Viz Graphic Hub.

To find data errors
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1. In the left panel, right-click the server to be checked and select Check server 
<server name>.

The check server window is shown.

2. In the left panel, select all the options to check for. Your options are:

• Check folder links

• Check file links

• Check references

• Check folders

3. Click the Check! button.
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You are advised that checking for data errors can be time consuming and resource
heavy, and should not be done at peak hours.

4. Click Yes to proceed.

Any errors found are shown in the right panel. Clicking on an error shows more detailed
information in the bottom panel.

To fix data errors
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1. If you do not require a log of errors that have been fixed, check Automatically
remove fixed entries.

2. Click the Fix all! button.

Note: You also have the option of selecting only certain errors in the right
panel, right-clicking, and fixing only the selected entries.

3. Any errors that cannot be fixed will remain in the right panel. Click the entry and
follow the instructions in the bottom panel.

7.4 Managing Users and Groups
From the Administer Users and Administer Groups windows it is possible to manage all
the users and groups in Viz Graphic Hub.
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Every user that works with the Viz Graphic Hub, either directly or from a client
application, must:

• Have their own user profile

• Belong to a Group

The User and Group management system monitors who creates items, who owns
items, and who has rights to modify the various items in the Viz Graphic Hub.

The permission settings on group level are the default settings for all assigned users,
but it is possible to change the permission on user level afterwards. It is possible that
one specific user has more or less permissions as the original defined base permission
settings of the underlying group (like a super-user or restricted user).

User and Group permission settings are always related to a folder or file permission
setting.

Example: User 1 of Group A has, on User and Group level, ‘no world write rights’
activated. This means that it is not possible to override or delete a file or folder
which is owned by another User from a different Group.

Example: User 2 of Group A has, on Group level, 'group write rights' activated
but not on User level (restricted user). This means that User 2 is only permitted to
overwrite or delete their own files in their own folder structure.

This section contains information on the following topics:

• Groups

• Users

7.4.1 Groups

This section contains information on the following topics:

• To open the Administer Groups window

• To create a new group

• To edit a group

• To delete a group or groups

• To view a group

To open the Administer Groups window

• Click Tools -> Administer Users and Groups -> Administer groups

Note: All Viz Graphic Hub Manager users can view Users and Groups. Only an
administrator can create new Users or Groups, or modify existing ones.
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Groups window

To create a new group

1. Open the Administer Groups window (see To open the Administer Groups window).

2. Select either:

• New...  or

• Right click, and click Create new group... from the context menu, or
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• Press <F6>/<Insert>

3. Select the destination server from the Server drop down box.

Note: If the group-list is filtered, the server cannot be changed.

4. The new group ID value is automatically generated.

5. Check or un-check the Active box to make the new group active or inactive.

Note: If a group is inactive, no members can be added.

6. In the Name box give the new group a unique name.

7. Specify the user account access rights:

• User rights: User may overwrite their files and create files.

• Group rights: User can overwrite files which belong to the group, of which
they are a member of.

• World rights: User may overwrite files which belong to anyone.

8. Click OK.

To edit a group

Note: Only available with administrator privileges and with a single server
selected.

1. Open the Administer Groups window (see To open the Administer Groups window).
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2. Select either:

• Edit...  or

• Right click, and click Edit selected group... from the context menu, or

• Press <F4>

3. The server destination can not be changed.

4. The group ID value can not be changed.

5. Check the Active box to make the new group active, if required. If changed from
active to inactive or inactive to active the modified check box is checked. If the
modified check box is un-checked, the change will be ignored.

Note: If a group is inactive, no members can be added.

6. In the Name box enter a new unique group name, if required. If changes are
made in the text box the modified check box is checked. If the modified check box
is un-checked, the change will be ignored.

7. Specify the user account access rights, if required:

• User rights: User may overwrite their files and create files.

• Group rights: User can overwrite files which belong to the group, of which
they are a member of.

• World rights: User may overwrite files which belong to anyone.

8. Click the View member button to see all the group members

9. Click OK.

To delete a group or groups
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Note: Only available with administrator rights.

Note: Groups which contain members cannot be deleted.

1. Open the Administer Groups window (see To open the Administer Groups window).

2. Select the Group or Groups to be delete:

• Click on a Group, or

• Press <CTRL> and click on Groups to multi select

3. Select either:

• Delete...  or

• Right click on the selection and click Delete selected group... from the
context menu, or

• Press DELETE.

4. Click OK.

To view a group

Note: Only available if logged in with no Administration rights or if there are
multiple users, over different servers.

1. Open the Administer Groups window (see To open the Administer Groups window).

2. Click on the group or groups to be viewed.

3. Select either:

• View...  or

• Right click and select View selected group... from the context menu, or

• Click on a group and press <F4>

4. The Group window opens. No items can be edited.

5. Click the View member button to see all the group members

6. Click Close.

7.4.2 Users

This section contains information on the following topics:

• To open the Administer Users window

• Create a new user account

• To edit a User account

• To delete a User account(s)

• To view a user account

To open the Administer Users window

• Click Tools -> Administer Users and Groups -> Administer users... , or

• Press <CTRL+F9>, or

• Press <CTRL+U>
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The Users window shows all available users on all active servers.

Note: To narrow the users list first select a Server then select a Group from the
Server and Group drop down boxes.

Create a new user account

1. Open the Administer Users window (see To open the Administer Users window).

2. Select either:

• New...  or

• Right click, and click Create new user... from the context menu, or
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• Press <F6>/<Insert>

3. Select the destination server from the Server drop down box.

Note: If the user list shows users of one server only, the server will be preset
and cannot be changed.

4. The new group ID value is automatically generated.

5. Check or un-check the Active box to make the new user account active or
inactive.

Note: If the user account is inactive, the user cannot log in or work with the
items in the database.

6. In the Group box select which group the new user belong too.

Note: If user list is filtered to show only users of a specific group, this group
will be preset and cannot be changed.

7. In the Nickname box give the new user a unique nickname.

8. In the Fullname box enter the new user’s full name.
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9. Enter a user Password. Repeat the password in the Re-enter the password
box.

Note: Leave both the Password and Re-enter password boxes empty if no
password is required.

10. Specify the new user account access rights:

• User rights: User may overwrite their files and create files.

• Group rights: User can overwrite files which belong to the group, of which
they are a member of.

• World rights: User may overwrite files which belong to anyone.

11. Click OK.

To edit a User account

Note: Only available with administrator privileges.

1. Open the Administer Users window (see To open the Administer Users window).

2. Select either:

• Edit...  or

• Right click, and click Edit selected user... from the context menu, or
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• Press <F4>

3. The user account Server can not be changed.

4. The user account ID value can not be changed.

5. Check or un-check the Active box to make the new user account active or
inactive, if required.

Note: If user account is inactive, the user cannot log in or work with the
items in the database.

6. In the Group box select the group the user account belongs too, if required.

7. In the Nickname box give the user a new unique nickname, if required.

8. In the Fullname box change the user’s full name, if required.

9. Enter a new user Password, if required. Repeat the password in the Re-enter
the password box.

Note: Leave both the Password and Re-enter password boxes empty if no
password is required.

10. Change the user account access rights, if required:
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• User rights: User may overwrite their files and create files.

• Group rights: User can overwrite files which belong to the group, of which
they are a member of.

• World rights: User may overwrite files which belong to anyone.

11. If required, click the Delete viz user settings button to delete the user account
settings which are, by default, saved together with the user profile.

Note: Delete viz user settings is only available if one user is to be edited.
If more than one user is selected, this button will not show.

12. Click OK.

To delete a User account(s)

Note: Only available with administrator privileges.

Note: The built-in administrator can not be deleted.

1. Open the Administer Users window.

2. Click the User(s) to be deleted. Press <CTRL> and click to multi select.

Note: Users on multiple servers can not be deleted in one step.

3. Select either:

• Delete... or

• Right-click on the selection and click Delete selected users... , or

• Press <DEL>

4. Click OK.

A User can not be deleted if they own an object(s) in the Graphic Hub. If a User
to be deleted owns any objects the Choose user... window will open when OK is
clicked on. Use this window to transfer object ownership to another User.

5. In the Choose user... window select the User to be assigned the object(s), from
the drop down box.
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6. Click OK to open the Setting owner... window.

IMPORTANT! The Choose user... window puts all objects, of the selected
User, in an Action Log window (Setting owner...), where ownership
changes.

7. Click Set owner.

8. Click Close.

IMPORTANT! The owner change must be done before delete can continue. If the
User still owns an object(s), the delete will fail.

If the Users window is clicked on before Set Owner is clicked on, in the Setting
owner... window this message will show:

To view a user account

Note: Only available if logged in with no Administration rights or if there are
multiple users, over different servers.

1. Open the Administer user’s window.

2. Click on the user or user’s accounts to be viewed.

3. Select either:

• View...  or

• Right click and select View selected user... from the context menu, or

• Click on a user account and press <F4>

4. The User window opens. No items can be edited.

5. Click Close.
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8 Viz Graphic Hub REST

The Viz Graphic Hub REST is a web-service for Viz Graphic Hub. It is an interface to
retrieve and send data to and from Viz Graphic Hub via HTTP requests.

This section contains information on the following topics:

• Important Before Installation

• Installation

• Configuration

• Failover/Load Balancing

• Troubleshooting

• Installing Viz Graphic Hub REST Demo

8.1 Important Before Installation
• Viz Graphic Hub REST requires an up and running Viz Graphic Hub 2.3.1 or higher

during installation and configuration.

• In replication clusters, the Viz Graphic Hub REST cannot be installed on the host that
is running the Viz Graphic Hub Server.

• Vizrt recommends using Google Chrome version 21 or higher to configure Viz
Graphic Hub REST and view the demo page.

• Viz Graphic Hub REST also works together with:

• Opera version 15 and a higher

• Firefox version 5 or higher

• Safari version 5 or higher

• Internet Explorer version 8 or higher

Note: All other web browsers and versions older than the ones listed above are
untested and not officially supported.

8.2 Installation
This section describes how to install Viz Graphic Hub REST.

Note: For details on how to install Viz Graphic Hub REST Demo, see Installing Viz
Graphic Hub REST Demo.

To install Viz Graphic Hub REST



Viz Graphic Hub User Guide

Page 228 Copyright © 2016 Vizrt

1. Run the VizGraphicHubREST.x.x.msi file.

2. Click the Next button.

3. In the panel that appears, select the I accept the terms in the License
Agreement check box.

4. Click the Next button.
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5. In the panel that appears, click the Next button.

6. In the panel that appears, click the Install button.

The Viz Graphic Hub REST is then installed on the machine.

7. In the panel that appears, click the Finish button.
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When completing the installation process by clicking on the Finish button, the installer
will open the Viz Graphic Hub REST configuration page in your standard web browser.

Note: Please make sure that your browser type and version is supported by Viz
Graphic Hub REST, see Important Before Installation.

8.3 Configuration
The Viz Graphic Hub REST configuration tool is loaded automatically after installation.
To load the page manually, open a supported web browser and type http://127.0.0.1/
config.html in the address bar.

Note: Please make sure that your browser type and version is supported by Viz
Graphic Hub REST, see Important Before Installation. Also make sure that no other
server is running on port 80, see Troubleshooting.

The start page provides links to various configuration categories:

• Configure Viz Graphic Hub REST

• Maintain Viz Graphic Hub REST Bindings

• Shutdown Viz Graphic Hub REST

• Viz Graphic Hub REST Demo

• Viz Graphic Hub REST API Documentation

• Viz Graphic Hub User Guide
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8.3.1 Configure Viz Graphic Hub REST

This section describes how to configure Viz Graphic Hub REST.

To configure Viz Graphic Hub

1. Click the Configure Viz Graphic Hub REST button in the Configuration.

2. In the window that opens, enter the settings of the Viz Graphic Hub the Viz
Graphic Hub REST should be connected with:

• Viz Graphic Hub Namingservice

• Viz Graphic Hub Server

• Viz Graphic Hub Port

Tip: If the Viz Graphic Hub REST is running on the same host as the Viz
Graphic Hub Server, then the default settings can be left unchanged.

3. Click the Next button.

The Click the Next button window opens if you are logged out from the specified
Viz Graphic Hub Server.

4. In the Click the Next button window, enter administrative login credentials for the
specified Viz Graphic Hub Server:

• Nickname (default is Admin)

• Password (default is VizDb)
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Note: The login credentials are case sensitive.

After a successful login, the window above will open. This window allows you
to configure webserver and REST specific settings. In most cases, the default
settings can be left unchanged.

5. Enter various Webserver configuration settings:

• Port: The webserver port, see Troubleshooting for details

• Config dir: The directory where Viz Graphic Hub REST configuration files
reside

• Upload dir: A temporary directory for uploads

• Document root: The webserver home/root directory

• Error log: The webserver error log text file

• Access log: The webserver connection log text file

Note: Changing any of the webserver configuration values will require a
shutdown of Viz Graphic Hub REST.
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After the automatic shutdown has been initiated, a dialog will prompt the user to
manually restart Viz Graphic Hub REST. When restarted, the Viz Graphic Hub REST
configuration settings will be updated.

6. Enter various Viz Graphic Hub REST configuration settings:

• Request timeout (ms): Specifies after how many milliseconds Viz Graphic
Hub REST will stop a specific request. Changing this value could stop execution
of some or all requests to Viz Graphic Hub REST prematurely.

• Max Viz GH sessions used: Maximum amount of sessions per Viz Graphic
Hub user

• Default max search results: If not defined differently in the open search
parameter count, this value will be used as the maximum number of shown
search results.

• Max journals: Maximum number of journals retrievable by Viz Graphic Hub
REST. This value has a significant influence on the overall performance of a
system.

• Default image compression: Defines the compression quality of imported
images. Although DXT5 uses most space on Viz Graphic Hub, this image
compression quality is recommended, as it provides the highest quality.

• Hide console: Hides or shows the Viz Graphic Hub REST console. This is useful
when debugging.

• Trace requests: Whether or not to spend time evaluating requests through
the console output.

• Log level: Log levels for output to console and the Viz Graphic Hub REST log
file. Various log levels are; Debug, Trace, Information, Warning, Error, Critical,
and ACE.

7. Click the Ok button.

The Viz Graphic Hub REST configuration settings will then be applied, and Viz Graphic
Hub REST is ready to use.

8.3.2 Maintain Viz Graphic Hub REST Bindings

The Maintenance section of the Configuration shows information about the currently
configured Viz Graphic Hub connection, its bindings and failover Viz Graphic Hubs.

To open the Maintenance section, click the Maintain Viz GH REST Bindings button.

The Maintenance section contains various panels:

• Viz Graphic Hub Rest to Viz Graphic Hub Bindings

• Viz Graphic Hub Failover servers

• Viz Graphic Hub connection timeouts

Viz Graphic Hub Rest to Viz Graphic Hub Bindings

Viz Graphic Hub REST is automatically registered and the configuration is stored when
connecting to a Viz Graphic Hub for the first time.
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Viz Graphic Hub REST to Viz Graphic Hub bindings

The Viz Graphic Hub REST to Viz Graphic Hub bindings enable third party applications
to discover the currently connected Viz Graphic Hub REST servers on a Viz Graphic
Hub.

• Protocol: The protocol to reach the specified Viz Graphic Hub REST

• Hostname: The hostname (or IP address) to reach the specified Viz Graphic Hub
REST

Tip: The hostname can be changed to an IP address if Viz Graphic Hub REST is not
reachable through the hostname.

• Port: The webserver port to reach the specified Viz Graphic Hub REST

• Service doc path: The path where the service doc is configured on the specified
Viz Graphic Hub REST

• Service doc accept type: Defines the http request headers accept type to retrieve
the service document on the given service document path

Actions will be applied by clicking the Ok button.

If Viz Graphic Hub REST is running as a replication cluster (failover/load balanced) you
have to change the binding configuration to your Squid node, see Viz Graphic Hub
Failover servers.

To remove a Viz Graphic Hub REST binding from the list, select the Delete check box.
Accidentally deleted Viz Graphic Hub REST bindings can be re-applied by configuring
the deleted Viz Graphic Hub REST again.

Viz Graphic Hub Failover servers

A Viz Graphic Hub failover server can be added in addition to the currently connected
Viz Graphic Hub.

Viz Graphic Hub failover servers

Viz Graphic Hub failover servers must have fully synchronized content with the
currently configured Viz Graphic Hub.

Tip: Synchronizing the content between multiple Graphic Hubs can be achieved
by using the Viz Graphic Hub Deploy Agent.

• Namingservice: Failover Viz Graphic Hub namingservice

• Server: Failover Viz Graphic Hub server

• Port: Failover Viz Graphic Hub port
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Actions will be applied by clicking the Ok button.

To remove a failover server from the list, select the Delete check box.

To add a new failover server, click the Add failover server button, and enter the
Namingservice, Server and Port details.

You can test the failover servers by:

1. Performing a request to Viz Graphic Hub REST (for example http://127.0.0.1/
users/)

2. Shutting down the configured Viz Graphic Hub

3. Performing the same request to Viz Graphic Hub REST again

If the first failover server is configured correctly, the responses should match (error
code and content).

Viz Graphic Hub connection timeouts

The connection timeouts define the connectivity settings between Viz Graphic Hub
REST and Viz Graphic Hub.

Viz Graphic Hub connection timeouts

The Viz Graphic Hub connection timeouts values are configured in seconds. In an
unstable network environment, Viz Graphic Hub REST will benefit from increasing the
timeouts.

• Global timeout: Defines how long Viz Graphic Hub REST should wait for a request
to Viz Graphic Hub REST to return. Default is 30 seconds.

• Connect timeout: Defines how long Viz Graphic Hub REST should wait to connect
or re-connect to a Viz Graphic Hub. Default is 15 seconds.

Actions will be applied by clicking the Ok button.

8.3.3 Shutdown Viz Graphic Hub REST

To gracefully shutdown Viz Graphic Hub REST, click the Shutdown Viz GH REST
button in the Configuration.

8.3.4 Viz Graphic Hub REST Demo

The Viz Graphic Hub REST demo page is provided in a separate installer. After
installation, the demo can be accessed by clicking the Viz GH REST Demo link in the
Configuration, or entering http://127.0.0.1/demo.html in the web browser address bar.

8.3.5 Viz Graphic Hub REST API Documentation

The Viz Graphic Hub REST API documentation provides a programmer with the
necessary information to use the Viz Graphic Hub REST API. The API documentation
can be accessed by clicking the Viz GH REST API Documentation link in the
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Configuration, or entering http://127.0.0.1/doc/documentation.html in the web browser
address bar.

8.3.6 Viz Graphic Hub User Guide

The Viz Graphic Hub User Guide provides the full Viz Graphic Hub documentation. This
User’s Guide can be accessed by clicking the Viz Graphic Hub User’s Guide link
in the Configuration, or entering http://127.0.0.1/help/index.html in the web browser
address bar.

8.4 Failover/Load Balancing
Optionally it is possible to setup Viz Graphic Hub REST to support failover and load
balancing. Viz Graphic Hub REST is a standard HTTP server, so there is no need for
integrated failover or load balancing logic. This can easily be achieved by setting up
a failover and load balancing cluster. Vizrt recommends using Squid for this purpose.
Squid is a very powerful tool and it can be used in a variety of cases combined.
Therefore Vizrt recommends that your Squid proxy and the DNS failover is set up by
a network professional. Also note that intensive testing of all applications using Viz
Graphic Hub REST with every setup with Squid is required.

The following example shows how to set up Viz Graphic Hub REST using Squid as a
reverse proxy used as static cache, load balancer and failover. To successfully run and
configure this example, you need 3 separate servers and 1 Viz Graphic Hub running on
a 4th server. This is the minimal failover configuration for Viz Graphic Hub REST. The
Squid server will be mentioned as server3 in the example below. Server3 contains 2
NICs in the example below (not necessary). You do not have to install and configure Viz
Graphic Hub REST on server3.

8.4.1 Important Before Installation

Squid for Windows can be downloaded here: http://sourceforge.net/projects/
squidwindowsmsi/.

8.4.2 Installing and Configuring Squid

1. Install Viz Graphic Hub REST on 2 or more separate servers; server1, server2, and
server3 (optional).

2. Install Viz Graphic Hub REST Demo on all of the servers where Viz Graphic Hub
REST has been installed for testing purposes.

3. Configure all instances of Viz Graphic Hub REST to connect to the same Viz
Graphic Hub (server4).

4. If Viz Graphic Hub REST is installed on server3, configure server3 webserver
settings to use port 8080 instead of port 80.

5. Download the Squid installer for Windows, see Important Before Installation.

6. Install Squid on a third server (server3), using the default install location; C:
\squid\.

7. Configure Squid by editing C:\squid\etc\squid.conf. Replace the whole file
content with the following configuration text:

#
# squid config needed
#
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acl all src all
acl manager proto cache_object
#
http_port 80 accel defaultsite=server3.company.internal vhost
#
# all cache Viz GH REST
#
#
cache_peer 10.211.1.1 parent 80 0 no-query originserver round-robin
 login=PASS name=server1
cache_peer 10.211.1.2 parent 80 0 no-query originserver round-robin
 login=PASS name=server2
# 
cache_peer 10.211.1.3 parent 8080 0 no-query originserver round-robin
 login=PASS name=server3nic1
cache_peer 10.211.1.4 parent 8080 0 no-query originserver round-robin
 login=PASS name=server3nic2
#
# entry vhost declaration
#
acl registered_name_hostdomain dstdomain server3.company.internal
acl registered_name_host dstdomain server3
acl registered_name_ip dstdomain 10.211.1.3 
acl registered_name_ip2 dstdomain 10.211.1.4
#
# entry vhost registration and redirection allowance
#
http_access allow registered_name_hostdomain 
http_access allow registered_name_host 
http_access allow registered_name_ip 
http_access allow registered_name_ip2
http_access deny all
cache_peer_access server1 allow registered_name_hostdomain
cache_peer_access server1 allow registered_name_host 
cache_peer_access server1 allow registered_name_ip 
cache_peer_access server1 allow registered_name_ip2 
cache_peer_access server2 allow registered_name_hostdomain
cache_peer_access server2 allow registered_name_host 
cache_peer_access server2 allow registered_name_ip 
cache_peer_access server2 allow registered_name_ip2
cache_peer_access server3nic1 allow registered_name_hostdomain
cache_peer_access server3nic1 allow registered_name_host 
cache_peer_access server3nic1 allow registered_name_ip 
cache_peer_access server3nic1 allow registered_name_ip2
cache_peer_access server3nic2 allow registered_name_hostdomain
cache_peer_access server3nic2 allow registered_name_host 
cache_peer_access server3nic2 allow registered_name_ip 
cache_peer_access server3nic2 allow registered_name_ip2  
cache_peer_access server1 deny all 
cache_peer_access server2 deny all 
cache_peer_access server3nic1 deny all 
cache_peer_access server3nic2 deny all
never_direct allow all
#
# general settings
#
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forwarded_for on
connect_timeout 10.0
peer_connect_timeout 5.0
cache_mem 256 MB
#cache_dir ufs C://YOUR/CACHE/DIRECTORY/HERE 1000 16 256
maximum_object_size 512 MB
quick_abort_max 1 MB
refresh_pattern ^http: 1440 80% 10080 reload-into-ims

8. Install Squid as a service using the command line:

C:\squid\sbin\squid.exe -i

9. Start Squid via the command line:

net start squid

10. Open http://server3. company.internal:8080/config.html in your browser

11. Go to Maintenance.

12. Delete the binding entries for server1 and server2.

13. Modify the current binding hostname to server3.company.internal.

14. Modify the current binding port to 80.

15. Click the Ok button to save your modifications.

16. Test your failover/load balancer in your browser by entering http://server3.
company.internal/demo.html.

Important Notes

• Never call the configuration site through the cluster URL. Always use the direct
server configuration URL instead (http://10.211.1.1/config.html).

• All Viz Graphic Hub REST nodes in a failover/load balanced cluster should always be
configured to connect to the same Viz Graphic Hub.

• Running a Squid cache on the same server as Viz Graphic Hub REST (as shown in
the example above) could reduce the performance of both.

• If a server has multiple NICs installed, you can add their IP addresses as cache_peer
nodes in the Squid configuration.

• All clients should only connect to server3.company.internal from now on.

• Adding a DNS failover through the domain controller from server3.company.internal
to an exactly similar configured server will eliminate your single point of failure.

• Adding more cache_peer will increase the performance of the total cluster.

• To increase the performance of big Viz Graphic Hub REST Squid clusters it is
recommended to use multiple automatically synchronized Viz Graphic Hubs
(through the Viz Graphic Hub Deploy Agent).

• Some API calls will not work with a cluster configuration or multiple Viz Graphic
Hubs in a cluster. The REST resource monitoring and statistic will not work in a
cluster. The Viz Graphic Hub statistics, journals and sessions will not work in a
cluster with clustered Viz Graphic Hub REST connected to multiple Viz Graphic Hubs.
The API documentation will provide a hint to this topic for every call.

8.5 Troubleshooting
• If the REST agent is installed on a machine that is already hosting an application

on port 80, the agent fails to startup and terminates. To fix this issue you need to
manually change the port in the webserver configuration. The file can be found in
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the REST agent installation directory at .\config\rest.conf. After changing the
value of server.port = new_port please redirect your browser to the configuration
site http://127.0.0.1: new_port/config.html to configure Viz Graphic Hub REST.

• If the standard browser login appears, please close it. Click logout and login with
your Viz Graphic Hub administrator account. Verify the username and password
(case sensitive) through a login to your configured Viz Graphic Hub via Viz Graphic
Hub REST.

• For trouble related to setting up Squid, please refer to the official documentation
for Squid, which can be found here: http://www.squid-cache.org/Versions/v2/2.7/
cfgman/.

• If having trouble with the configuration page, please try to upgrade your web
browser.

• For details on how to install Viz Graphic Hub REST Demo, see Installing Viz Graphic
Hub REST Demo.

8.6 Installing Viz Graphic Hub REST Demo
1. Run the VizGraphicHubRESTDemo.x.x.msi file.

2. Click the Next button.
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3. In the panel that opens, select the I accept the terms in the License
Agreement check box.

4. Click the Next button.

5. In the panel that appears, click the Next button.

6. In the panel that appears, click the Install button.
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The application is installed on your machine.

The Viz Graphic Hub REST Demo is then installed on the machine.

7. In the panel that appears, click the Finish button.
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9 Troubleshooting

This section contains information on the following topics:

• Installation Fails

• Network Troubleshooting

• Restoring Corrupted Files

• Viz Graphic Hub Manager and Viz Artist Troubleshooting

• Replication Troubleshooting

• Deploy Troubleshooting

• Running Terminal as a Service Troubleshooting

• Dongle Troubleshooting

• FAQ

9.1 Installation Fails
Installation fails with a warning that says Drivers for HASP runtime cannot be
installed.

To start Sentinel HASP License Manager

1. On your Windows desktop, right-click My Computer and select Manage.

The Computer Management window appears.

2. In the left panel, expand the node Service and Applications.

3. Click Services.

4. In the right panel, right-click Sentinel HASP License Manager and select Start.

5. Install Viz Graphic Hub again.
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9.2 Network Troubleshooting
Some network settings can prevent the Viz Graphic Hub applications from finding other
running Viz Graphic Hub Terminals in the network.

To locate a machine that a Viz Graphic Hub Terminal is running on, try pinging that
machine. If the host is not reachable across the network, the Viz Graphic Hub Terminal
will not be reachable either.

It is necessary to run Viz Graphic Hub Terminal in a local network where the settings
shown below are identical on every workstation running the terminal application.

To verify network settings

1. On the server machine, click Start -> Run -> cmd.

2. In the console, enter ipconfig /all and press <ENTER>.

3. Browse to the current connected network adapter.

4. Check Subnet Mask and Default Gateway.

5. Repeat steps 1-3 on the client machine, and see that the Subnet Mask and Default
Gateway are identical between client and server.

To solve network and firewall problems

1. Make sure that the client can broadcast to other clients and to the Viz Graphic
Hub Server. This means all firewalls between server and clients need to allow
broadcast.

2. Make sure the following port settings for the Viz Graphic Hub Terminal, under
Options for all System Configurations, are open to firewall traffic in between all
clients and servers:

• TCP Port

• UDP Port

• Viz Graphic Hub Server Port

3. Make sure that local firewall applications allow traffic for all Viz products.

9.3 Restoring Corrupted Files
Any save operation from a client (e.g. Viz Artist) via Viz Engine triggers Viz Graphic Hub
to back up the old file and create a new one. The new file is streamed to the server
until the client informs the server that the operation is complete. After that, Viz Graphic
Hub Server deletes the back up file.

A file will be corrupted if Viz Graphic Hub does not get the message from the client
indicating that the save operation is done. For example, this can occur if the client
application crashes during the save operation.

To restore corrupted files

1. In Viz Graphic Hub Manager, log into the server where the corrupted file is
located. See Start Up with a Single Server Login.

2. Perform a search with filters in the Journal for Alert numbers 810 and 910. See To
search the journal with filter settings.

3. Browse through all the results and click the P button in the Details panel.



Viz Graphic Hub User Guide

Copyright © 2016 Vizrt Page 245

If a file has been corrupted, you will be prompted to restore it.

4. Click Restore.

5. Repeat steps 3 and 4 until all corrupted files have been restored.

6. To make sure that the file has been completely restored, you can do a search to
verify that the restored file’s checksum is not 0. See Searching.

9.4 Viz Graphic Hub Manager and Viz Artist Troubleshooting
This section contains information on the following topics:

• Viz Artist Does Not Respond

• Viz Graphic Hub Manager and/or Viz Artist Cannot Find Servers

• Viz Graphic Hub Manager or Viz Artist Does Not React In Server Tree

9.4.1 Viz Artist Does Not Respond

If Viz Artist does not respond, files that were open keep their locks. Viz Graphic Hub
usually releases the session within a certain interval, but you should check if Viz Artist
is responding to the session release attempt.

To restore Viz Artist after it crashes

1. In Viz Graphic Hub Manager, log into the server where the corrupted file is
located. See Start Up with a Single Server Login.

2. Check the Active Session to see how long it takes for the server to clean up the
session. See Monitoring Active Sessions.

3. Check the Application Name and the IP address in the Active Sessions window.

4. Once all processes are complete, all related files are unlocked and checked in, and
you should be able to perform the procedure To restore corrupted files.

9.4.2 Viz Graphic Hub Manager and/or Viz Artist Cannot Find Servers

When searching for servers, the system cannot detect any.

Solution

1. Disable all network blocking applications, like firewalls, antivirus software, VPNs,
virtual network adapters, etc.

2. Ask your system administrator to open necessary ports on the company’s firewall
between the Viz Graphic Hub Server, Viz Graphic Hub Manager and/or Viz Artist.

See Also

• Network Troubleshooting

9.4.3 Viz Graphic Hub Manager or Viz Artist Does Not React In Server
Tree

Sometimes you cannot get into the server tree. This is mostly due to a lost server
connection. If you suspect the server connection is lost, a good first step is to click
around the server tree. If it does not update, exit the application and log back in.
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See Also

• Network Troubleshooting

• Replication Troubleshooting

9.5 Replication Troubleshooting
Most problems with replications can be solved by having a stable network environment.
This means that applications which are causing drag on network performance, like
global network updates or global virus scans, should not be performed in a replication
environment.

To prevent data loss or conflicts between the main and replication servers, the server
checks the network card for timeouts. If the timeout is too long, the server shuts down.

This section contains information on the following topics:

• Main Server is Not Available

• Cluster Not Up and Running

• Cluster Configuration on Viz Graphic Hub Terminal

• Journal Log Flooded With Replication Error Messages

See Also

• System Prerequisites

• Detecting and Solving Server Differences

9.5.1 Main Server is Not Available

The main server often shuts down because network connections become unavailable. If
this is a common occurrence, perform the procedure below.

To solve cluster timeouts

1. Open Viz Graphic Hub Terminal.

2. Perform the procedure To open the Options window.

3. Configure the Cluster Timeout Settings for Viz Graphic Hub Replication Server
Mode, enabling the timeout settings and setting the cluster timeout to a higher
value.

Caution: Consult a Vizrt CA professional before enabling this functionality.

9.5.2 Cluster Not Up and Running

A server can become unavailable due to machine problems, network problems, etc.

To restore a healthy cluster environment

1. Open Viz Graphic Hub Terminal on the server that is not running.

2. Click Start.

3. Wait until the server resumes its former role.
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If it was the main server, it will take some time before it deploys all open
transactions and switches back to its original state.

4. Open Viz Graphic Hub Manager and log into the main and replication servers.

5. Open the Server Monitor. See Monitoring Servers.

6. See that the Cluster is up and running and has no open transactions.

7. Make sure that the main and replication servers have reassumed their assigned
roles as such.

8. Perform the procedure To detect and solve server differences.

9.5.3 Cluster Configuration on Viz Graphic Hub Terminal

In Viz Graphic Hub Terminal, the message You are already connected to a cluster
appears, even though the other server in the cluster is not running anymore. Viz
Graphic Hub Terminal has most likely not received an automatic update from the other
Terminal.

To refresh the connection settings

1. In Viz Graphic Hub Terminal, click Refresh.

2. Start the cluster. If it still does not work, exit Viz Graphic Hub Terminal and restart
it.

9.5.4 Journal Log Flooded With Replication Error Messages

This may occur if your data directories are not properly synchronized.

To synchronize data directories

1. Shut down the replication server. See Shutting Down a Server.

2. Back up then delete the replication server’s data directory.

3. On the main server, and check that there no users are currently working on it.

4. Copy the main server’s data directory to the replication server’s (now empty)
directory.

5. Start up the replication server.

6. Check the Journal for error messages. See Querying the Journal.

9.6 Deploy Troubleshooting
This section contains information on the following topics:

• DDC Data Does Not Transfer Correctly

• Deploy Agent Does Not Transfer All Data

• Deploy Agent Does Not Transfer All Data

• Deploy Task Runs for Too Long

9.6.1 DDC Data Does Not Transfer Correctly

DDC data may not be transferred correctly in the following cases, which are also visible
in the DDC Action Log:
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• The connection between servers is lost

• A file is locked or checked in

• In other cases, it is necessary to file a bug report. Make sure that you include the
exact error code and messages.

9.6.2 Deploy Agent Does Not Transfer All Data

A deploy agent task may not transfer all data correctly in the following cases, which
can be viewed after performing the procedure To search finished deploy tasks:

• A file is locked or checked in

• In other cases, review the unsuccessful task details and check all affected files.

9.6.3 Deploy Agent Does Not Run

To maintain the deploy agent service

1. On your Windows desktop of the machine where the deploy agent is installed,
right-click My Computer and select Manage.

The Computer Management window appears.

2. In the left panel, expand the node Service and Applications.

3. Click Services.

4. In the right panel, right-click Viz GH Deploy Agent and select Properties.

5. Click the General tab and then click the Start button.

6. If the deploy agent service still does not run, continue with the following steps.

7. Click the Log On tab.

8. Click the This account radio button.

9. Click Browse.

10. In the field Enter the object name to select, enter Administrator and click
OK.
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11. Enter and confirm the valid password for Administrator.

12. Click OK.

13. Start the Viz Graphic Hub deploy agent again.

14. If it still does not run, make sure the deploy agents have been stopped.

15. Browse to the deploy agent directory and delete the folder Open Tasks and the
deployagent.cfg file.

16. Start the Viz Graphic Hub deploy agent again.

9.6.4 Deploy Task Runs for Too Long

To release a hanging deploy task

1. In Viz Graphic Hub Manager, log into the source server.

2. Perform the procedure to To open the Active Sessions window.

3. Check the Viz Graphic Hub Deploy session for locked files.

4. If there are locked files, perform the procedure To view running deploy tasks and
cancel the affected task.

The task should restart on its own.

9.7 Running Terminal as a Service Troubleshooting
This section contains information on the following topics:

• Viz Graphic Hub Terminal Does Not Start the Server

• Viz Graphic Hub Terminal Service Does Not Start

9.7.1 Viz Graphic Hub Terminal Does Not Start the Server

This may occur if Viz Graphic Hub is installed as a service but not started as a service.

To start Viz Graphic Hub as a service

1. Exit Viz Graphic Hub Terminal.

2. Wait until Viz Graphic Hub Terminal starts itself automatically.

9.7.2 Viz Graphic Hub Terminal Service Does Not Start

To start the Viz Graphic Hub service

1. On your Windows desktop of the machine where the deploy agent is installed,
right-click My Computer and select Manage.
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The Computer Management window appears.

2. In the left panel, expand the node Service and Applications.

3. Click Services.

4. In the right panel, right-click Viz GH Terminal Service Properties and select
Start.

5. Wait for the Viz Graphic Hub Terminal to start up. If this does not occur, contact
Vizrt CA.

9.8 Dongle Troubleshooting
This section contains information on the following topics:

• Expired License

• Apparently Valid Dongle/License Does Not Work

• General Viz Artist and Viz Graphic Hub Dongle Issues

9.8.1 Expired License

If your license has expired, you can enter the new license string straight into Viz
Graphic Hub Manager.

To renew the license string

1. Log into a server in Viz Graphic Hub Manager.

2. From the main menu, click Info -> License info.
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The license info window is shown.

3. Enter the new license string from Vizrt in the field at the bottom and click Set.

9.8.2 Apparently Valid Dongle/License Does Not Work

• Close all time-sync programs, like NTP.

• Shut down your anti-virus applications.

• Make sure your dongle is properly connected and the HASP driver is installed and
running. See To start Sentinel HASP License Manager.

9.8.3 General Viz Artist and Viz Graphic Hub Dongle Issues

• A Viz Artist dongle does not work with Viz Graphic Hub.

• A Viz Graphic Hub dongle does not work with Viz Artist.

• Make sure you have only one Viz dongle connected to a machine running Viz
applications.

• If you do not have a Viz Graphic Hub-enabled dongle, make sure you run Viz Graphic
Hub 5/4 Free or Viz Graphic Hub Localhost modes.

9.9 FAQ
• Question: Can a Viz Graphic Hub deploy agent deploy outside local network

boundaries, i.e. different subnets and gateways?

• Answer: Yes. Log into Viz Graphic Hub Manager with the IP address instead of
the hostname. Continue with the procedure To schedule a deploy task.

• Question: Can Viz Graphic Hub Manager connect to servers outside local network
boundaries, i.e. different subnets and gateways?

• Answer: Yes. Log into Viz Graphic Hub Manager with the IP address instead of
the hostname.

• Question: Can a replication cluster work outside local network boundaries, if the
main and replication servers are not in the same local network?
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• Answer: No. Use the deploy agent instead.

• Question: Can I share a single data directory over multiple servers?

• Answer: No.

• Question: Can deleting or creating files within a data directory solve problems?

• Answer: No.

• Question: Can I do a backup of the data directory while the server is still running?

• Answer: Yes, but make sure there is no write access on that Viz Graphic Hub, i.e.
when nobody is working on it.

• Question: Can a localhost database be accessed from another machine?

• Answer: From Viz Artist, no. A single-user database is only available on the
machine it runs on.

• Question: Do all Viz Graphic Hub Namingservices on the network contain
information about all servers? Why is there a need for more than one namingservice
on the network?

• Answer: A Viz Graphic Hub Namingservice only contains information about
the servers that have been applied to it. Before a Viz Graphic Hub Server is
started, a Viz Graphic Hub Namingservice must be applied to it. Either a local
namingservice that is started together with the server can be applied, or another
available namingservice in the network is applied. A server cannot be started
without connecting to a running namingservice.

• Question: Can I kill the VizDb.exe process?

• Answer: No, never. Only use Viz Graphic Hub Terminal or Viz Graphic Hub
Manager to shut down a server.

• Question: Can I shut down Windows while VizDb.exe is still running?

• Answer: No. Use Viz Graphic Hub Terminal or Viz Graphic Hub Manager to shut
down a server before exiting Windows.

• Question: Why is the content of the selected project or folder not listed in the Viz
Graphic Hub Manager’s File panel?

• Answer: First, make sure that the selected project or folder contains items. Next,
make sure that All or the correct item type is selected from the Show drop-down
list in the Toolbar.


