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The Plug-ins User Guide provide details about various plug-in settings available through the 
configuration user interface within Viz Artist. 
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1 Related Documents
Viz Artist User Guide: Contains information on how to install Viz Engine and create graphics 
scenes in Viz Artist.

http://documentation.vizrt.com/viz-artist
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2 Feedback And Suggestions
We encourage suggestions and feedback about our products and documentation. To give feedback 
and/or suggestions, please contact your local Vizrt customer support team at www.vizrt.com.

http://www.vizrt.com/
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3 Introduction
The Viz Plugins User Guide provides details about settings available through its configuration user 
interface within Viz Artist or Viz Engine. 

3.1 Related Documents
Viz Artist User Guide: Contains information on how to install Viz Engine and create graphics 
scenes in Viz Artist.
Viz Engine Administrator Guide: Contains information on how to install the Viz Engine 
software and supported hardware.
Viz Ticker User Guide: How to install, configure and use the Viz Ticker client, and configure 
the output channels.
Viz Trio User Guide: How to install, configure and use the Viz Trio client, and configure the 
output channels.
Viz Pilot User Guide: How to install, configure and use Viz Pilot.
Viz Multichannel User Guide: How to install, configure and use Viz Multichannel.
Viz World Classic User Guide: Contains information on creating 2D maps and geographic 
animations.
Viz World User Guide: Contains information on creating real-time 3D maps and using the 
client-server solution.

For more information about all of the Vizrt products, visit:

www.vizrt.com
Vizrt Documentation Center
Vizrt Training Center
Vizrt Forum

3.2 Feedback And Suggestions
We encourage suggestions and feedback about our products and documentation. To give feedback 
and/or suggestions, please contact your local Vizrt customer support team at www.vizrt.com.

Note: The Viz World plug-in package is released separately from the Viz World Client. Some 
of the functionality of these plug-ins are still intended to be used with the Viz World Client.



http://documentation.vizrt.com/viz-artist
http://docs.vizrt.com/viz-engine.html
http://docs.vizrt.com/viz-ticker.html
http://docs.vizrt.com/viz-trio.html
http://docs.vizrt.com/viz-pilot.html
http://docs.vizrt.com/viz-multichannel.html
http://docs.vizrt.internal/viz-world
http://docs.vizrt.internal/viz-world
http://www.vizrt.com/
http://documentation.vizrt.com/
http://www.vizrt.com/training/
http://forum.vizrt.com/
http://www.vizrt.com/
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4 Basic Plug-Ins
The Basic Plug-ins provide details about settings available through its configuration user 
interface within Viz Artist. 

4.1 Related Documents
Viz Artist User Guide: Contains information on how to install Viz Engine and create graphics 
scenes in Viz Artist.

4.2 Feedback And Suggestions
We encourage suggestions and feedback about our products and documentation. To give feedback 
and/or suggestions, please contact your local Vizrt customer support team at www.vizrt.com.

4.3 Geometry Plug-Ins
The default path for the Geometry plug-ins is: <viz install folder>\plug-in\<plug-in name.vip>

4.3.1 Dynamics
The following Geometry plug-ins are located in the Dynamics folder:

Cloth
Cloth Flag
Flag

Cloth

The Cloth plug-in provides a simulation of an elastic vertex system. The vertex system can be 
configured with many different parameters. Most of the parameters depend on each other, and 
some must be set in conjunction with others. The stress of the system is mentioned below, and 
the rule is that the greater the stress is the greater the chance the system becomes unstable. With 
low stress factors the system is completely stable.

Adding the Cloth plug-in to a container also adds the Expert plug-in.

This page contains the following topics and procedures:

Note: This plug-in is located in: Plugins -> Geom plug-ins -> Dynamics

http://documentation.vizrt.com/viz-artist
http://www.vizrt.com/
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1.
2.

3.

4.

•

Cloth Properties
To Create a Cloth Effect

Cloth Properties
Reinitialize: Restarts rendering of the object.

Elastic: Changes the elastic properties of the object. If set it to  0.1 , the object behavior 

resembles that of latex, and at  1.0  more like cloth.

DampingFct: Specifies how much speed each vertex should loose. The lower this factor is 
the less speed the object loses.
Pause: Pauses all calculations and freezes the system’s animation.
Tessellation direction U and V: Sets the tessellation in the two directions on the objects’ 
surface. The calculation time needed increases with more vertices.
Speed: Determines how many calculations are needed per frame. The less calculation done 
the slower the object moves. If the number of calculations are increased, the object moves 
faster.
Wind X, Y and Z: Gives the speed and direction of the wind affecting the object.
TurbulenceSpeed: Gives the speed and direction of the wind turbulence affecting the object.
TurbulenceFactor: Multiplies the wind speed.
Gravity X, Y and Z: Defines gravity affecting all vertices of the object.
Scaling u (width): Changes the width of the rectangle which is including the animated cloth 
without increasing the number of triangles.
Scaling v (height): Changes the height of the animated rectangle which is including the 
animated cloth without increasing the number of triangles.
Draw normals: Shows the normals for each triangle.
Draw force: Shows the appealing wind in color.

To Create a Cloth Effect

Add the Cloth plug-in to a Container.
Add a material to the same Container.

Set WindX to 2.0 .

Click the Reinitialize button to see the result.

See Also

Expert
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Cloth Flag

The Cloth Flag plug-in provides a simulation of an elastic vertex object. The vertex object can be 
configured with many different parameters. Most of the parameters depend on each other, and 
some must be set in conjunction with others. Adding the Cloth Flag plug-in to a container also 
adds the Expert plug-in.

This page contains the following topics and procedures:

Cloth Flag General Properties
Cloth Flag Geometry Settings
Cloth Flag Move Settings
Cloth Flag Advanced Settings

Cloth Flag General Properties
Wind Rotation, Elevation and Force: These three factors combined gives the speed and 
direction of the wind affecting the flag. The allowed values are:

Wind Rotation: From  -720.0  to  720.0

Wind Elevation: From  -90.0  to  90.0

Wind Force: From  0.0001  to  100.0
Gravity Direction: Vectors that define in which direction gravity is affecting the vertices of 
the flag:

U: Horizontal.
V: Vertical.
None: Gravity is not applied.

Pause: Setting Pause to  On  pauses all calculations performed and the animation in both the 

scene editor and On Air output.
Reinitialize: Restarts rendering of the object.

Cloth Flag Geometry Settings
Tessellation direction U and V: Sets the tessellation in the two directions on the systems 
surface. Calculation time increases with more vertices.
Scaling U (width): Changes the width of the rectangle which is including the animated cloth 
without increasing the number of triangles.
Scaling V (height): Changes the height of the animated rectangle which is including the 
animated cloth without increasing the number of triangles.
Reinitialize: Restarts rendering of the object.

Note: This plug-in is located in: Plugins -> Geom plug-ins -> Dynamics



Plug-ins User Guide -  5.0

Copyright © 2022  Vizrt Page  18

•

•
•
•

•
•

•

•
•

•
•
•
•

•

•

•

•

•

Cloth Flag Move Settings
Translate X, Y and Z: Offsets the position output using the position values set for the 
container.
Rotate X, Y and Z: Offsets the rotation output using the rotation values set for the container.
Scale: Offsets the scale output using the scale value set for the container.
Reinitialize: Restarts rendering of the object.

Cloth Flag Advanced Settings
Turbulence Speed: Determines how fast the direction of speed oscillates.
Turbulence Factor: Multiplies wind speed.

Elastic: Changes the elastic properties of the system. If set to  0.1 , the rendered output has 

properties resembling latex, and at  1.0  more like cloth.

Damping: Specifies how much speed each vertex should lose.
Simulation Quality: Reduces or increases the number of calculations performed for the plug-
in, for performance reasons.
Wireframe: Shows the wireframe for the plug-in.
Draw normals: Shows the normals for each triangle.
Draw force: Shows the appealing wind in color.
Reinitialize: Restarts rendering of the object.

See Also

Expert

Flag

The Flag plug-in provides a simpler simulation of an elastic vertex object than the Cloth Flag plug-
in.

Flag General Properties

Width: Defines the width of the object. Accepted values are from  0.0  to  200 .

Height: Defines the height of the object. Accepted values are from  0.0  to  200 .

Amount: Sets the intensity of the effect. Accepted values are from  0.0  to  200 .

Wavelength: Defines the length between the animated waves. Accepted values are 

from  0.0  to  200 .

Note: This plug-in is located in: Plugins -> Geom plug-ins -> Dynamics
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Wave Speed: Defines the speed of the animated waves. Accepted values are 

from  -100  to  100 .

Turbulence Speed: Defines the speed of the turbulence in the animation. Accepted values 

are from  -100  to  100 .

Y Stretch: Defines the anisotropic value of the Y-axis. Accepted values are 

from  0.2  to  100 .

Tessellation X: Defines the amount of tessellation on the X-axis. Accepted values are 

from  1  to  100 .

Tessellation Y: Defines the amount of tessellation on the Y-axis. Accepted values are 

from  1  to  100 .

Plane: Selects the dimensional plane for the rendered object.
Fixed Edge: Selects which edge should be fixed, or none. The fixed edge acts as a boundary 
for the animation.

Direction: Automates the animation direction angle if set to  Auto   (default).

Dir Angle: If Direction is set to  Custom , provides the designer with the option of defining 

the animation direction angle. Accepted values are from  -720  to  720 .

4.3.2 Visual Data Tools Geometry

Overview
Visual Data Tools (VDT) show any kind of statistic data. All the VDT plug-ins use the Shared 
Memory transport channel.

Shared Memory is a map which has user defined variables, indexed by a string, also known as a 
key-value pair. There are three types of Shared Memory Maps.

For more information about Shared Memory see the Shared Memory (SHM) section of the Viz Artist 
User Guide.

The VDT plug-in suite consists of:

Geometry plug-ins: Used to draw the chart (detailed in this section).
Container Plug-ins: Used to label, data scale, etc., the chart.

To learn more about the use of Visual Data Tools, download a tutorial on www.vizrt.com under the 
Training section.

The following Geometry plug-ins are located in the Visual Data Tools folder:

Advanced Bar Chart Creation
Area Chart
Bar Chart
Line Chart
Pie Chart
Scatter Chart

http://documentation.vizrt.com/viz-artist
http://www.vizrt.com
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1.

2.

Stock Chart

See Also

Container Plug-ins
Geometry Plug-ins
Advanced Bar Chart Creation
Area Stack
Bar Stack
Data Fit
Data Import
Data Label
Data Storage
Line Stack
Scripting section of the Viz Artist User Guide.
Tutorial on Viz University

Advanced Bar Chart Creation
This section outlines some of the more advanced features of the Bar Chart geometry plug-in. The 
example provided is aimed at designers familiar with the Viz Artist user interface and prior 
knowledge of advanced scene design techniques, such as the use of control plug-ins and scripting.

This brief tutorial consists of the following sections and procedures:

Establishing the Basic Bar Chart
Adding a Script to Control Data
Calculating Scale Manually for External Applications or for Scripts
Adding Labels to the Bars
Animating the Bars
Animating the Labels
Adding Color

Establishing the Basic Bar Chart
In this first section, the basic bar chart is established and set up to be controlled by an External 
Control Application, such as Viz Trio or Viz Pilot. In an environment where the data is modified 
directly through the plug-in, there is no need for the shared memory or script as outlined below.

Create a new scene and add an empty container. This container is used as the parent 

container. Rename the container to  object .

Add the Bar Chart plug-in to a sub-container in the scene tree and name it  BarChart , then 

open the plug-in properties.

http://documentation.vizrt.com/viz-artist
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In the Data field, add a series of comma-separated values. Here, the 

values  10,70,20,30  are used.

Currently, the Shared Mem. parameter is set to  Inactive . This means that the data used 

by the plug-in is being read from the Data field, as set in step 2. However, in most cases 
some sort of shared memory would be used in order to share the same data with other plug-
ins, in particular the Data Label plug-in that is introduced in a later step.

In this example, the Scene shared memory is used. This Shared Memory setting does not 
interfere with any other scene(s) or machine, only the local scene. By clicking 

the  Scene  button, the field Key Data becomes available, where the name of the shared 

memory used for the bar data must be specified. An external control application, such as Viz 
Pilot or Viz Trio, can now be used to set the values that are to be represented by the bar 

chart. Enter  barData  as the shared memory name.

Add an empty container to the scene tree, and then the Control 
Parameter and Script container plug-ins to the newly created container. Rename the 

container to  ValuesControl  and open the Script plug-in properties.

Adding a Script to Control Data
Next, a script allowing the data to be controlled with the Control Parameter plug-in needs to 
be added:

Dim oldKey As String = ""

Note: By using the Data Delim. field, the data delimiter can be changed from comma 

to any other delimiter, for example the pipe character ( |  ), to suit the needs of the 

production environment the scene is used in.
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Sub OnInitParameters()
RegisterParameterString("barsValues", "Bar Values", "1,2,3,4,5,6", 40, 1000, "")
RegisterParameterString("barsSMName", "Shared Mem Name", "barData", 40, 1000, 
"")
End Sub

Sub OnParameterChanged(parameterName As String)
If parameterName = "barsSMName" Then
If oldKey <> "" Then Scene.Map.DeleteKey(oldKey)
Scene.Map.CreateKey(GetParameterString("barsSMName"))
oldKey = GetParameterString("barsSMName")
Else
Scene.Map[GetParameterString("barsSMName")] = GetParameterString("barsValues")
End If
End Sub

Sub OnInit()
Scene.Map.CreateKey(GetParameterString("barsSMName"))
Scene.Map[GetParameterString("barsSMName")] = GetParameterString("barsValues")
End Sub

Tip: As alternative to a string with a data delimiter, the data source could also be a 

Double-Array. This can be achieved by selecting Array  as Transfer Mode in the 

Data Bar plug-in properties. In that case, instead of assigning a string, an 

Array[Double]  data type would have been assigned in the example script above. 

This can be convenient if the data is provided by an external source, for instance a 
database or as the result of parsing a text file.
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After entering the above script into the script editor, click the Compile & Run button. The 
scene tree should now look like this:

Open the Control Parameter plug-in properties. Change the Field Identifier to  1001 , set 

the Data Type to  Text , and enter  SCRIPT*INSTANCE*barsValues  in the Parameter field. 

By opening the Control Objects tab in the Control area, the Bar Values can now be changed 
directly. Any changes here should be reflected immediately on the rendered output in 

the Preview window when pressing  Enter .

Apply a material on the BarChart container. The shape of the rendered bars can be 
controlled by adjusting the Corners, Tesselation Length, and Bevel parameters in the Bar 

Chart plug-in properties. For a classic 2-dimensional bar, use a Corners value of  2 . For a 
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smooth cylinder shape, the corners value can be increased up to a maximum of  1000 . 

Activate Wireframe rendering mode in the preview window by clicking the  W  button in the 

scene editor to get a better understanding of these parameters. This is how it may look with 

Corners set to  25 , a Tesselation Length of  20 , with Bevel, Bevel Top and Bevel Bottom set 

to  On , Bevel size (%) to  15  and Bevel Steps to  10 :

Drag a Rectangle container plug-in to the scene tree to create a new container, and add 
the Expert container plug-in. In the Expert plug-in properties, 

select  Outline  as Drawmode to create a bounding box.

Often, it is useful to fit the entire data into a given screen bounding box. This can be 
achieved positioning the newly added rectangle on the screen, representing the area where 

the graph should be drawn. Here, the rectangle has width of  500  and a height of  300 . It is 

positioned at  0.0  in Z-space, as is also the container holding the Bar Chart itself. 

Open the rectangle container’s Transformation Editor and check the effective width and 
height of the boundary rectangle:

To match the width of the graph to the bounding box, open the Bar Chart plug-in properties 

and change the Chart Width to  Total  and the Bar Width to that of the bounding rectangle 
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( 500.0 ). Then set Horizontal Alignment to  Center .

Mapping the graph to fit the whole height of the bounding area is done by enabling some of 
the properties inherent of the Bar Chart plug-in. In the property panel, set Data Fit and Data 

Auto Scale to  On , then set Data Fit Size to  Current . Then either type in, or click and drag, 

the Data Start and Data Stop values as required. The sum of these two should equal the 
height of the bounding box.

Open the Control Object tab in the Object area, and enter the values used for the example 

data scale calculation above,  -14, 70, -30, 12, 15, 20, 5,  as values for the Bar 

Values object. The preview is automatically updated. The result should look like this, with 
the Bars perfectly matching the bounding area:

Tip: The Max. Width parameter defines how thick a bar can become. If the number of 
input values are reduced, the bars width increases within the defined Bar Width area. 
If there are only two bars left, they look really big. The Max. Width parameter is 
useful to limit the impact of this behavior.





Plug-ins User Guide -  5.0

Copyright © 2022  Vizrt Page  26



Plug-ins User Guide -  5.0

Copyright © 2022  Vizrt Page  27

Please go to straight to Advanced Bar Chart Creation to continue with the tutorial. The following 
section is intended as reference for users wanting to perform this scaling manually, or by an 
external application or a script.

Calculating Scale Manually for External Applications or for Scripts
The minimum and maximum values of the data needs to be known to be able to calculate the 

required scale value. For example, if using the values  -14, 70, -30, 12, 15, 20, 5  as input 
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data, the minimum value is  -30  and the maximum value is  70 . If negative values are not used, 

set the minimum value to minimum to  0.0  (more mathematically speaking;  min=minimum(0.0, 

minimum(inputdata)) ). For the example values above, this results in a range of 100 (from min to 

max). These 100 units must be matched to the bounding box height, which is 300. 

Dividing  300  by  100  returns a scale value of  3.0 .

Set Data Fit to  On  and enter this value in the Data Scale field (1):

Open the Control Object tab in the Object area, and enter the values used for the example data 

scale calculation above,  -14, 70, -30, 12, 15, 20, 5,  as values for the Bar Values object. 

The preview is automatically updated. Notice how the graph aligns to the bounding box size, 
however, it is not centered in the middle.

To center the graph within the bounding box, a data offset translation value must be calculated. 
The formula for calculating this value is:

where dataScale is the value calculated in the previous step, and height is the bounding height 

(here:  300 ). Using the values in this example, the formula would be

Set Data Origin Offset to  On  and enter the resulting value,  -60 , in the Data Offset field. The 

result should look like in step 11, with the bars perfectly matching the bounding area.
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Adding Labels to the Bars
In order to have labels representing the bar value above each bar, the Data Label container plug-in 
is used.

Add the Data Label plug-in to the BarChart container and open the plug-in properties. 

Select  Scene  as Shared Mem. and enter  barData  in the Key Data field, then set the Copy 

Container parameter to  On .

Create a new container as a child of the BarChart container, and add a font and a material to 

the new container. Rename the container to  label . Set the size and text parameters as 

desired. Here, the font container’s Scaling is  .25 , and the font orientations are set 

to Orientation center and Vertical orientation first line.

Open the Bar Chart plug-in properties and set Pos. Container to  On . Combined with 

the Copy Container parameter set in step 13, the parameter Pos Container lets Viz copy 
the label container for each label value and position the sub-containers of the BarChart 
container in relation to the respective bar representing the value. Container offsets can also 
be defined if desired.

Open the Control Area and change one of the bar values in the Control Object tab, in order 
to trigger a refresh. This should create the new label containers and populate them with 
data. If modifications are required on the label prototype (the first child container), delete all 
other siblings and alter one or more of the data input values, in order to trigger a new 
refresh and thus a re-creation of the sibling containers.

Tip: When creating 3D bars where the Corner value is set to more than 2 , the label 

needs to be offset in Z-space. A way to circumvent this is to add the Expert container 

plug-in, and setting Z-Buffer Ignore to On .
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Animating the Bars
Basic animation of the bars is typically controlled by the Bar Chart’s Stop% parameter, with values 

from  0.0  to  100.0 . For a basic animation, set Stop% to  0  and add a key-frame at frame  0 , 

then set the Stop% value to  100  and add another key-frame.

There are various other parameters that further influence the animation:

By activating the Const. Speed setting, animation of each bar has the same duration.
The Relative Length setting gives each bar its own 100 percent length, meaning seven bars 
equal 700 percent.

When Progress Mode is set to  Bars , each bar subsequently grows to its value; and when set 

to  Chart  X  or  Y , the whole chart grows horizontally or vertically, respectively, with the 

incoming bars already at their final height.

Animating the Labels
The labels can be animated in a similar fashion, as the Data Label plug-in have the 
same Stop%, Relative Length and Const. Speed parameters. Additionally, the values can be 

animated while the bars grow by setting Animate Values to  On . By adding an Alpha plug-in to the 

label containers, and activating the setting Use Alpha, the labels fade in as the bars appear.

The parameter Use Scale is used when an interpolation on the scale value of each label 

between  0.0  and  1.0  is required. As a result of the fact that the scaling interpolates to the fixed 

value of  1.0 , combined with the fact that the font label in most cases is somehow scaled, fonts 

often appear too big. This problem can be overcome by adding a parent container to the font. 
The Data Label plug-in puts the text into the first child container containing a Text Geometry plug-
in, so the label content is preserved.

Adding Color
Colors can be assigned to each individual bar, by setting the Map parameter of the Bar Chart plug-
in to Color. RGB and alpha values can be set by adjusting the Color ID. However, Viz Trio and Viz 
Pilot are not able to control the colors, there is no control plug-in capable to do so. This can be 
resolved by using a script and to expose the script parameters to the control application. The 
following script example allows to set a clear color for all bars, and it has a button that calculates 
the min/max bar and assigns different colors to those bars:

Sub calcMinMax()
Dim chart As Container = GetParameterContainer("bars")
If chart = null Then Exit Sub
Dim valueString As String = Scene.map[GetParameterString("barsSMName")]
Dim values as Array[String]

Note: When Progress Mode is set to Chart Y , columns representing negative values 

are not visible.
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Dim minValue As Double = 1000000
Dim maxValue As Double = -100000
Dim minIndex As Integer = -1
Dim maxIndex As Integer = -1
Dim i As Integer = 0
valueString.split(",", values)

For Each str In values
If str.length <> 0 Then
If CDbl(str) < minValue Then
minValue = CDbl(str)
minIndex = i
End If

If CDbl(str) > maxValue Then
maxValue = CDbl(str)
maxIndex = i
End If
End If
i = i + 1
Next
Dim col As Color
Dim clearColor As Color = GetParameterColor("clearColor")

For i = 0 To values.Size
If i = maxIndex Then
col.Red = 0.317
col.Green = 0.71
col.Blue = 0.0
ElseIf i = minIndex Then
col.Red = 1.0
col.Green = 0.14
col.Blue = 0.0
Else
col = clearColor
End If

chart.Geometry.SetParameterInt("ColorID", i)
chart.Geometry.SetParameterColor("Color", col)
Next
End Sub

Sub resetColors()

Dim chart As Container = GetParameterContainer("bars")

If chart = null Then Exit Sub

Dim valueString As String = Scene.map[GetParameterString("barsSMName")]
Dim values as Array[String]

Dim i As Integer = 0
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valueString.split(",", values)

Dim col As Color = GetParameterColor("clearColor")

For i = 0 To values.Size
chart.Geometry.SetParameterInt("ColorID", i)
chart.Geometry.SetParameterColor("Color", col)
Next
End Sub

Sub OnExecAction(buttonId As Integer)
If buttonId = 0 Then calcMinMax()
If buttonId = 1 Then resetColors()
End Sub

Sub OnInitParameters()
RegisterParameterContainer("bars", "Bar Chart")
RegisterParameterString("barsSMName", "Shared Mem Name", "bars", 40, 1000, "")
RegisterPushButton("minmax", "Calc Min/Max", 0)

Dim clearColor As Color

clearColor.Red = 1
clearColor.Green = 1
clearColor.Blue = 1

RegisterParameterColor("clearColor", "Clear Color", clearColor)
RegisterPushButton("reset", "Reset Colors", 1)
End Sub

Sub OnInit()
resetColors()
End Sub

The ControlParameter is set to Text, and the parameter to control 

is  SCRIPT*INSTANCE*clearColor .

See Also

Control Chart
Data Fit
Data Import
Data Label
Data Storage
Presenter
Bar Stack
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Area Chart

The Area Chart plug-in draws an area chart, filled with data out of a Shared Memory Map. You can 
use delimited strings or arrays for data transfer via Scene, Global or Distributed Shared Memory.

Supported Pipelines

Classic Render Pipeline

Viz Engine Render Pipeline

This page contains the following topics and procedures:

Area Chart Properties
To Create a Scene with Area Chart
To Create a Scene with Area Chart and Data Storage
To Create a Area Chart with Data Animation

Chart Animation Using Data Import
Chart Animation Using Control Chart

Area Chart Properties
Shared Mem.: Changes between Scene, Global and Distributed Shared Memory. 
Use Inactive memory to not forward any values via Shared Memory.
Specify X Values: Enables DataX input.

Key DataX: Defines Shared Memory key name for X values.
DataX: Defines parameter for X values if Shared Memory is set to Inactive.

Key DataY: Defines Shared Memory key name for Y values.
DataY: Defines parameter for Y values if Shared Memory is set to Inactive.
Transfer Mode: Sets string or array based data transfer (not available when set shared 
memory is set to Inactive).
Data Delim.: Defines the value separator sign(s).

Number Format: Defines if Viz should get the decimal point separator from the  System 

Locale  or  Custom  settings. If Custom is enabled:

Decimal Symbol: Defines which symbol is used as decimal point when Custom Number 
Format is set.

Note: If the Area Stack plug-in is used, the following Area Chart properties 
need to be defined in the Area Stack plug-in.
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DataX, Y Fit: Enables data normalization.
DataX, Y Scale: Scales input by the selected factor.
DataX, Y Offset: Adds an offset to the incoming data.
DataX, Y Auto Scale: Enables automatic data normalization.
DataX, Y Fit Size: Total: Scales the whole chart to the defined borders. Current scales 
the current chart segment to the set borders.
DataX, Y Detect Limits: Detects minimum and maximum of all values and scales them 
to adjusted Start and Stop. This option is used to upscale the interesting part of the 
chart - especially if there are only little changes between the data values.
DataX, Y Threshold: Adds a definable offset to the detected limit.
DataX, Y Start: Lower Auto Scale edge.
DataX, Y Stop: Upper Auto Scale edge.

Values Animation: Sets the vertical animation type to be created when data values change, 
but the number of nodes is still the same.   

Disable: No animation.
Timer: Creates data transition animation (from an old set of data to a new set) 
within the specified time set in Duration sec. Also select an Animation Mode.
Director: Creates data transition animation with the Stage Director, that controls 
the Animation Progress parameter from 0.0% (old data) to 100.0% (new data). 
Also select an Animation Mode.

Animation Mode:
Concurrent: Changes all nodes concurrently.
Left to Right: Transitions from left to right.
Right to Left: Transitions from right to left.

Balance Speed: Relates node values to the position of transformed data when set 

to  On  and Animation Mode is set to Left to Right or Right to Left.

Duration sec.: Sets the duration of the animation in seconds for Timer mode.
Data Nodes Animation: Sets the horizontal animation type to be created when number of 
data nodes change is detected.   

Disable: No animation.

•

•

•

Example:
Balance Speed: If the values of four nodes change from 0,0,0,0 to 
1,9,90,900 in Left to Right mode at 50% of the transformation.
Balance Speed Off: Only the first two nodes are transformed to new 
values.
Balance Speed On: The first three nodes are already transformed to new 
values, and the last node also transformed to 44% of the new values, 
because the data change from 0 (0+0+0+0) to 1000 (1+9+90+900), at 
50% of transformation (in this case the values is changed for 500 of 
1000), the first three nodes are already finished and the last node is 
changed to 400.
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Timer: Creates data transition animation (from an old set of data to a new set) 
within the specified time set in Duration sec.

Duration sec.: Sets the duration of the animation in seconds for Timer mode.

Horizontal Alignment: Sets horizontal orientation to left, center or right.
Type: Creates different graph looks. Available options are Normal, Spline, Staircase and 
Constrained Spline.

Normal: Enables direct connections between entered values.
Spline: Interpolates extra values to chamfer the graph.
Staircase: Creates a staircase look.
Constrained Spline: Same as Spline mode but with a different algorithm to prevent 
overshooting.

Stair Width: Defines width for a single stair or for all stairs if Specify X Values is activated.
Chart Width: Adjusts the chart width.
Chart Depth: Adjusts extrusion.

Tesselation Width: Sets tessellation in Spline mode.
Selection: Specifies Start and Stop type.

Relative: 0%: 100%
Absolute: Depends on the specified data.
ID: Value ID starting from 0.

Start%, abs,: Graph starting point.
Stop%, abs,: Graph stopping point.
Reposition Start: Translates the whole chart always to the same starting point independent 
of varying Start and Stop positions.
Bevel: Activates Bevel mode.

Bevel Bottom: Chamfers the chart’s bottom
Bevel Size: Adjusts bevel’s size
Bevel Steps: Sets roundness via the number of segmentation steps

RelativeMapping: Stretches texture to fit graph width.
Pos. Container: Translates every child container to a bar’s top.

Container Offset: Adds a certain offset to each container.
Container Offset Z: Adds a Z Axis offset to each container.
Center Container: Centers each translated container.

Pointers Shared Mem.: Selects the map where the pointer values should be distributed to.
Key Data Pointers: Defines Shared Memory Keyname.
Pointer: Activates the Pointer.

Container: Defines Container which should be used as pointer.
Selection: Selects the navigation type.
Position%, abs,: Sets pointer position in dependency of the selected navigation type.

Note: When number of nodes is changes, area chart looks for added and 
removed nodes from their values, adds new nodes to the chart from zero 
width and resizes all nodes to their new size, specified in duration.



Note: A chamfer is a beveled edge connecting two surfaces.
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Offset: Defines pointer offset from the chart.
Normal Offset: Rotates offset to the direction of the current surface normal.
Rotate: Rotates the pointer to the direction of the current surface normal.
Offset Z: Adds an additional Z offset to the pointer container.
Center Container: Centers Container - useful for varying pointer sizes.

Pointers: Activates each pointer as required:
Low Pointer / High Pointer / Start Pointer / Stop Pointer
Container: Selects a container for the pointer.

To Create a Scene with Area Chart

Create a new Container.
Add the Area Chart plug-in.
Open the Transformation Editor.
Set these parameters:

Position X: -100.0 .

Position Y: -100.0 .

Rotation Y: -25.0 .

Add a Material and/or a Texture.
Open the Area Chart editor.
Enter these parameters:

Set DataY values: 10,20,30,20,50,60,80,45,20 .

Set Type to Spline .

Set Chart Width to 200.0 .

Set Chart Depth to 30.0 .

To Create a Scene with Area Chart and Data Storage
Create a new Container.
Add the Area Chart plug-in.
Add the Data Storage plug-in to Area Chart Container.
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Select the Area Chart plug-in.

Set SharedMem. to Scene .

Rename the Key DataY to  MyDataY .

Open the Data Storage editor.

Enter  MyDataY  in the Key Data1 field.

Set the SharedMem. to Scene .

In Data1 enter: 10,40,50,20,80,90,60,50 .

To Create a Area Chart with Data Animation

Chart Animation Using Data Import

The following steps are to prepare data sets for animation in Excel file.

Start Microsoft Excel.
Enter ExcelData1 into cell A1.

Add some sample values in the cells below ( A2-A8: 80, 35, 45, 75, 85, 55, 60 ).

Enter ExcelData2 into cell A2.

Add some sample values in the cells below ( B2-B9: 80, 35, 45, 75, 40, 85, 55, 60 ).

Enter ExcelData3 into cell A3.

Add some sample values in the cells below ( C2-C9: 40, 60, 75, 85, 80, 55, 45, 35 ).

Enter ExcelData4 into cell A4.

Add some sample values in the cells below ( D2-D8: 60, 75, 85, 80, 55, 45, 35 ).

Rename this first sheet to MyTable (can be done with a double click on the sheet name at 
the bottom).
Follow one of the following methods to make Viz Engine can read this Excel data file:

Save and close the Excel document.
Share the Excel document.

On the Review tab, in the Changes group, click the Share Workbook button.
The Share Workbook dialog box appears, and you select the Allow changes by 
more than one user at the same time. check box on the Editing tab.
Click Ok button of the dialog.
Save the Excel document.

After the data sets are created, the following steps are to create a Data Animation scene.

Follow the "To create a Area Chart" instruction.
Modify the following parameters of Area Chart plug-in.

Change Shared Mem. to Scene.
Set Kay DataY to DataY.
Set Data Delim. to #.
Set Values Animation to Timer.
Set Data Nodes Animation to Timer.

Add Data Import plug-in into the same container.
Set File to above prepared Excel file.
Set Table / Sheet to MyTable.

IMPORTANT! You must use the same platform (x64/x86) of Microsoft Excel and Viz Engine.
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Set Column(,Col...) to ExcelData1.
Set Data Delim. to #.
Set Shared Mem. to Scene.
Set Key to DataY.

Click the GetIt button and animation chart shows from zero to seven nodes.
Add one data node in the middle of chart.

Set Column(,Col...) to ExcelData2.
Click the GetIt button.

Change values of eight data nodes.
Set Column(,Col...) to ExcelData3.
Click the GetIt button.

Remove the first data node.
Set Column(,Col...) to ExcelData4.
Click the GetIt button.

Chart Animation Using Control Chart

Follow the "To create a Area Chart" instruction.
Modify the following parameters of Area Chart plug-in.

Set Values Animation to Timer.
Set Data Nodes Animation to Timer.

Add Control Chart plug-in into the same container and save the scene.
Open Viz Trio.

Import the scene.
Click "1 (AreaChart)" in Tab Fields.
Edit values in Editing Template.

See Also

Control Chart
Data Fit
Data Import
Data Label
Data Storage
Area Stack

Bar Chart

The Bar Chart plug-in draws a bar chart, filled with data out of a Shared Memory Map. You can use 
delimited strings or arrays for data transfer via Scene-, Global- or Distributed-Shared Memory.

Note: You can add more data columns and play with animation on data change.



Plug-ins User Guide -  5.0

Copyright © 2022  Vizrt Page  40

•
•
•

•
•

•

•
•

•
•

•

•

•
•
•
•
•

•
•

•
•
•
•
•

Supported Pipelines

Classic Render Pipeline

Viz Engine Render Pipeline

This page contains the following topics and procedures:

Bar Chart Properties
To Create a Bar Chart
To Create a Bar Chart with Data Animation

Chart Animation Using Data Import
Chart Animation Using Control Chart

Bar Chart Properties
Shared Mem.: Changes between Scene, Global and Distributed Shared Memory. 
Use Inactive memory to not forward any values via Shared Memory and the data is taken 
from the Data field.
Data: Inputs chart data (available when Inactive is selected).
Key Data: Determines shared Memory key name (available 
when Scene, Global or Distributed is selected).
Transfer Mode: Sets String or Array based data transfer.
Data Delim.: Defines the value separator sign(s).

Number Format: Defines if Viz should get the decimal point separator from the  System 

Locale  or  Custom  settings. If Custom is enabled:

Decimal Symbol: Defines which symbol is used as decimal point when Custom Number 
Format is set.

DataX Fit: Enables data normalization on the horizontal:
DataX Scale: Scales input by the selected factor.
DataX Offset: Adds an offset to the incoming data.
DataX Auto Scale: Enables automatic data normalization.
DataX Fit Size: 

Total: Scales complete chart as per the defined Start and Stop settings.
Current: Scales the current chart segment to the set borders.

Data Fit: Enables data normalization:
Data Scale: Scales input by the selected factor.
Data Offset: Adds an offset to the incoming data.
Data Origin Offset: Adds an offset to the smallest/minimum value.
Data Auto Scale: Enables automatic data normalization.

Note: If the Bar Stack plug-in is used, the following Bar Chart properties need 
to be defined in the Bar Stack plug-in.





Plug-ins User Guide -  5.0

Copyright © 2022  Vizrt Page  41

•

•

•
•
•

•

•

• •
•

•

•
•
•
•

•

•

•

• • •
•

•

Data Fit Size: Scales complete chart in dependency of the defined Start and Stop 
settings (Total) or scales the Current chart segment to the set borders.
Data Detect Limits: Detects minimum and maximum of all values and scales them to 
adjusted Start and Stop.
Data Threshold: Adds a definable offset to the detected limit.
Data Start: Lower Auto Scale edge.
Data Stop: Upper Auto Scale edge.

Compare: Specifies another BarChart for comparison. You have to set this parameter also in 
the other chart(s) so that each chart can react on changes of the other(s).
Value Animation:  Sets the vertical animation type to be created when data change is 
detected:

Disable: No animation.
Timer: Creates data transition animation (from an old set of data to a new set) 
within the specified time set in Duration sec.. Also select an Animation Mode.
Director: Creates data transition animation with the Stage Director, that controls 
the Animation Progress parameter from 0.0% (old data) to 100.0% (new data). 
Also select an Animation Mode.

Animation Mode:
Concurrent: Changes all nodes concurrently.
Left to Right: Transitions from left to right.
Right to Left: Transitions from right to left.

Balance Speed:Relates node values to the position of transformed data when set 

to  On  and Animation Mode is set to Left to Right or Right to Left.

Duration sec.: Sets the duration of the animation in seconds for Timer mode.

Data Nodes Animation: Sets the horizontal animation type to be created when number of 
data nodes change is detected.

Disable: No animation.
Timer: Creates data transition animation (from an old set of data to a new set) 
within the specified time set in Duration sec.

Duration sec.:  Sets the duration of the animation in seconds for Timer mode.

•

•

•

Example:
Balance Speed: If the values of four nodes change from 0,0,0,0 to 
1,9,90,900 in Left to Right mode at 50% of the transformation.
Balance Speed Off: Only the first two nodes are transformed to new 
values.
Balance Speed On: The first three nodes are already transformed to new 
values, and the last node also transformed to 44% of the new values, 
because the data change from 0 (0+0+0+0) to 1000 (1+9+90+900), at 
50% of transformation (in this case the values is changed for 500 of 
1000), the first three nodes are already finished and the last node is 
changed to 400.
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Horizontal alignment: Sets horizontal orientation to left, center or right.
Corners: Sets the bar’s corners.
Chart Width: Defines width for a single bar or for all bars.
Bar Width: Value of the previous parameter.
Max Width: Allows bars to grow only to a certain width.
Bar Gap Ratio: Adjusts the gap between the single bars. 0% means no gap.
Depth: Defines if the bar depth should equal its width or lets you set a custom depth.
Bar Depth: Adjusts bar depth in custom depth mode.

Draw Zero: If the Bar value is equivalent to  0 , then a very flat bar is drawn instead of 

nothing.
Tessellation Length: Tessellates bar length.
Progress Mode:

Bars: Allows each bar grows to its value.
Chart X: The chart grows horizontally. Each bar comes in at its final height.
Chart Y: The chart grows vertically. All bars grow together to their final height.

Relative Length: If activated, each bar has its own 100% length (e.g. seven bars equal 700%).
Const. Speed: Sets the same animation duration for each bar.
Start%: Determines starting point of the graph.
Stop%: Determines stop point of the graph.
Bevel: Activates Bevel mode.

Bevel Top: Chamfers bar’s top.
Bevel Bottom: Chamfers bar’s bottom.
Bevel Size%: Adjusts bevel’s size from 0 to 100.
Bevel Steps: Sets roundness via the number of segmentation steps.

Pos. Container: Translates every child container to a bar’s top.
Container Offset: Adds a certain offset to each container.
Container Offset X: Adds a X Axis offset to each container.
Container Offset Y: Adds a Y Axis offset to each container.
Container Offset Z: Adds a Z Axis offset to each container.
Center Container: Centers each translated container.
Size Compensation: Repositions containers if they can change their size. E.g. Text 
geometries used as chart labels. The labels vary in their width which requires a 
repositioning if a horizontal BarChart (rotated 90 deg) is used.
None: Deactivates container size compensation.
Width: Compensates width changes.
Height: Compensates height changes.

Note: When the number of nodes is changed, bar chart looks for added and 
removed nodes from their values, adds new nodes to the chart from zero 
width and resizes all nodes to their new size, specified in duration.



Note: A chamfer is a beveled edge connecting two surfaces.
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Map: Calculates texture coordinates for all bars, a single bar or defines vertex colors 
instead. Colors can be set individually for each bar or value dependent (+/- color). In the 
Color +/- mode you can override value dependent colors.

Color ID: Moves between the available vertex colors.
Color: Chooses color for the current ID.
Positive: Chooses color for positive values.
Negative: Chooses color for negative values.
Color Override: Activates or deactivates overriding of a positive or negative color with 
a defined alternative color.

To Create a Bar Chart

Create a new group and add the Bar Chart plug-in to it.

Open the Transformation Editor and set Position X and Y to -100.0  and Rotation Y to 

-25.0 .

Add a material and/or a texture to it.
Open the Bar Chart editor and set the following parameters:

Set the following DataY values: 10,20,30,20,50,60,80,45,20 .

Set Corners to 3 .

Set Bar Width to 20.0 .

Set Bar Gap Ratio[%] to 10.0 .

To Create a Bar Chart with Data Animation

Chart Animation Using Data Import

The following steps are to prepare data sets for animation in Excel file.

Start Microsoft Excel.
Enter ExcelData1 into cell A1.

Add some sample values in the cells below ( A2-A8: 80, 35, 45, 75, 85, 55, 60 ).

Enter ExcelData2 into cell A2.

Add some sample values in the cells below ( B2-B9: 80, 35, 45, 75, 40, 85, 55, 60 ).

Enter ExcelData3 into cell A3.

Add some sample values in the cells below ( C2-C9: 40, 60, 75, 85, 80, 55, 45, 35 ).

Enter ExcelData4 into cell A4.

Add some sample values in the cells below ( D2-D8: 60, 75, 85, 80, 55, 45, 35 ).
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Rename this first sheet to MyTable (can be done with a double click on the sheet name at 
the bottom).
Follow one of the following methods to make Viz Engine can read this Excel data file

Save and close the Excel document.
Share the Excel document.

On the Review tab, in the Changes group, click the Share Workbook button.
The Share Workbook dialog box appears, and you select the Allow changes by 
more than one user at the same time. check box on the Editing tab.
Click Ok button of the dialog
Save the Excel document.

After the data sets are created, the following steps are to create a Data Animation scene.

Follow the "To create a Bar Chart" instruction.
Modify the following parameters of Bar Chart plug-in.

Change Shared Mem. to Scene.

Set Kay Data to  Data .

Set Data Delim. to  # .

Set Values Animation to  Timer .

Set Data Nodes Animation to  Timer .

Add Data Import plug-in into the same container.
Set File to above prepared Excel file.

Set Table / Sheet to  MyTable .

Set Column(,Col...) to  ExcelData1 .

Set Data Delim. to  # .

Set Shared Mem. to  Scene .

Set Key to  Data .

Click the GetIt button and animation chart shows from zero to seven nodes.
Add one data node in the middle of chart (Horizontal Animation).

Set Column(,Col...) to ExcelData2.
Click the GetIt button.

Change values of eight data nodes (Vertical Animation).
Set Column(,Col...) to ExcelData3.
Click the GetIt button.

Remove the first data node (Horizontal Animation).
Set Column(,Col...) to ExcelData4.
Click the GetIt button.

Chart Animation Using Control Chart

Follow the "To create a Bar Chart" instruction.
Modify the following parameters of Bar Chart plug-in.

Set Values Animation to Timer.

IMPORTANT! You must use the same platform (x64/x86) of Microsoft Excel and Viz Engine.

Note: You can add more data columns and play with animation on difference data change.
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Set Data Nodes Animation to Timer.
Add Control Chart plug-in into the same container and save the scene.
Open Viz Trio.

Import the scene.
Click "1 (BarChart)" in Tab Fields.
Edit values in Editing Template.

See Also

Control Chart
Data Fit
Data Import
Data Label
Data Storage
Presenter
Bar Stack
Advanced Bar Chart Creation

Line Chart

The Line Chart plug-in draws a line chart, filled with data out of a Shared Memory Map. You can 
use delimited strings or arrays for data transfer via Scene-, Global- or Distributed-Shared Memory.

Supported Pipelines

Classic Render Pipeline

Viz Engine Render Pipeline

This page contains the following topics and procedures:

Line Chart Properties
To Create a Line Chart
To Create a Line Chart with Data Animation

Chart Animation Using Data Import
Chart Animation Using Control Chart

Line Chart Properties
Shared Mem.: Changes between Scene, Global and Distributed Shared Memory. Use Inactive 
memory to not forward any values via Shared Memory.
Specify X Values: Enables DataX input.

DataX: Determines Shared Memory key name for X values. DataX is the default input 
parameter for X values.
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Key DataX: Determines Shared Memory key name for X values.
DataY: Determines Shared Memory key name for Y values. DataY is the default input 
parameter for Y values.
Key DataY: Determines Shared Memory key name for Y values.
Transfer Mode: Sets string- or array-based data transfer.
Data Delim.: Defines the value separator sign(s).

Number Format: Defines if Viz should get the decimal point separator from the  System 

Locale  or  Custom  settings. If Custom is enabled:

Decimal Symbol: Defines which symbol is used as decimal point when Custom Number 
Format is set.

DataX, -Y Fit: Enables data normalization.
DataX, -Y Scale: Scales input by the selected factor.
DataX, -Y Offset: Adds an offset to the incoming data.
DataX, -Y Auto Scale: Enables automatic data normalization.
DataX, -Y Fit Size: 

Total: Scales the whole chart to the defined borders. 
Current: Scales the current chart segment to the set borders.

DataX, -Y Detect Limits: Detects minimum and maximum of all values and scales them 
to adjusted Start and Stop. This option is used to upscale the interesting part of a 
chart - especially if there are only little changes between the data values.
DataX, -Y Threshold: Adds a definable offset to the detected limit.
DataX, -Y Start: Lower Auto Scale edge.
DataX, -Y Stop: Upper Auto Scale edge.

Values Animation: Sets the vertical animation type to be created when data change is 
detected:

Disable: Does not create an animation.
Timer: Creates data transition animation (from an old set of data to a new set) 
within the specified time set in Duration sec.. Also select an Animation Mode.
Director: Creates data transition animation with the Stage Director, that controls 
the Animation Progress parameter from 0.0% (old data) to 100.0% (new data). 
Also select an Animation Mode.

Animation Mode
Concurrent: Changes all nodes concurrently.
Left to Right: Transitions from left to right.
Right to Left: Transitions from right to left.

Balance Speed: Relates node values to the position of transformed data when set 

to  On  and Animation Mode is set to Left to Right or Right to Left.

Note: If the Line Stack plug-in is used, the following Line Chart properties need 
to be defined in the Line Stack plug-in.



Example:
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Duration sec.: Sets the duration of the animation in seconds for Timer mode.
Data Nodes Animation: Sets the horizontal animation type to be created when number of 
data nodes change is detected:

Disable: No animation.
Timer: Creates data transition animation (from an old set of data to a new set) 
within the specified time set in Duration sec.. Also select an Animation Mode

Duration sec.: Sets the duration of the animation in seconds for Timer mode.

Horizontal Alignment: Sets horizontal orientation to left, center or right. 
Line Type:

Normal: Direct connections between entered values.
Spline: Interpolates extra values to chamfer the graph.
Constrained Spline: Same as Spline mode but with a different algorithm to prevent 
overshooting.

Chart Width: Adjusts line width ( 0  for 2D mode).

Tessellation Width: Sets tessellation length in spline modes.

Thickness: Adjusts line thickness ( 0  for 2D mode).

Depth: Adjusts line depth ( 0  for 2D mode).

Tessellation Thickness: Tessellates line thickness.
Tessellation Depth: Tessellates line depth.
Const. Thickness: Builds the geometry with a constant width.

Miter: Applies a miter cut-off to avoid huge peaks for small data point angles.
Selection: Specifies the Start- and Stop-type. Relative: 0%: 100%. Absolute: depends on your 
specified data. ID: Value ID starting from 0.
Start%, abs,: Determines starting point of the graph.
Stop%, abs,: Determines stop point of the graph.
Reposition Start: Translates the whole chart always to the same starting point.
Bevel: Activates Bevel mode.

Bevel Start: Chamfer start.

•

•

•

Balance Speed: If the values of four nodes change from 0,0,0,0 to 
1,9,90,900 in Left to Right mode at 50% of the transformation.
Balance Speed Off: Only the first two nodes are transformed to new 
values.
Balance Speed On: The first three nodes are already transformed to new 
values, and the last node also transformed to 44% of the new values, 
because the data change from 0 (0+0+0+0) to 1000 (1+9+90+900), at 
50% of transformation (in this case the values is changed for 500 of 
1000), the first three nodes are already finished and the last node is 
changed to 400.

Note: When number of nodes is changes, line chart looks for added and 
removed nodes from their values, add new nodes to the chart from zero width 
and resize all nodes to their new size in specified duration.
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Bevel Stop: Chamfer stop.
Bevel Size%: Adjusts bevel’s size from 0 to 100.
Bevel Steps: Sets roundness via the number of segmentation steps.

RelativeMapping: Stretches texture to fit graph length.
Pos. Container: Translates every child container to a bar’s top.

Container Offset: Adds a certain offset to each container.
Value Dependent Pos.: Translates the container above or below the line in dependency 
on the data values.
Container Offset Z: Adds a Z axis offset to each container.
Center Container: Centers each translated container.

Pointer: You can use a container as a pointer and move it along the chart’s shape.
Container: This container represents your pointer.
Selection: Specifies the position-type. Relative: 0%: 100%. Absolute: depends on your 
specified data. ID: Value ID starting from 0.
Position%, abs,: Translates pointer by this parameter.
Offset: Adds an offset to the container’s position.
Normal Offset: Rotates the offset so that it is perpendicular to the chart’s surface.
Rotate: Rotates the container in dependency on the chart’s shape.
Offset Z: Adds a Z axis offset to the pointer.
Center Container: Uses the container’s center for translation and rotation.

Low Pointer: Activates the low pointer.
Container: Chooses a container for the pointer.

High Pointer: Activates the high pointer.
Container: Chooses a container for the pointer.

Start Pointer: Activates the Start Pointer.
Container: Chooses a container for the pointer.

Stop Pointer: Activates the stop pointer.
Container: Chooses a container for the pointer.

To Create a Line Chart

Create a new group and add the Line Chart plug-in to it.

Open the Transformation Editor and set Position X and Y to  -100.0  and Rotation 

Y to  -25.0 .

Note: A chamfer is a beveled edge connecting two surfaces.
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Add a material and/or a texture to it.
Open the Line Chart editor and set the following parameters:

Set Shared Mem. to Inactive

Set the following DataY values:  10,20,30,20,50,60,80,45,20 .

Set Line Type to Spline.

Set Chart Width to  250.0 .

Set Depth to  10.0 .

Enable Bevel, Bevel Start, Bevel Stop.

Set Bevel Size% to  100.0 .

Set Bevel Steps to  10.0 .|

To Create a Line Chart with Data Animation

Chart Animation Using Data Import

The following steps are to prepare data sets for animation in Excel file.

Start Microsoft Excel.
Enter ExcelData1 into cell A1.

Add some sample values in the cells below ( A2-A8: 80, 35, 45, 75, 85, 55, 60 ).

Enter ExcelData2 into cell A2.

Add some sample values in the cells below ( B2-B9: 80, 35, 45, 75, 40, 85, 55, 60 ).

Enter ExcelData3 into cell A3.

Add some sample values in the cells below ( C2-C9: 40, 60, 75, 85, 80, 55, 45, 35 ).

Enter ExcelData4 into cell A4.

Add some sample values in the cells below ( D2-D8: 60, 75, 85, 80, 55, 45, 35 ).

Rename this first sheet to MyTable (can be done with a double click on the sheet name at 
the bottom).
Follow one of the following methods to make Viz Engine can read this Excel data file

Save and close the Excel document.
Share the Excel document.

On the Review tab, in the Changes group, click the Share Workbook button.
The Share Workbook dialog box appears, and you select the Allow changes by 
more than one user at the same time. check box on the Editing tab.
Click Ok button of the dialog
Save the Excel document.

After the data sets are created, the following steps are to create a Data Animation scene.

Follow the "To create a Line Chart" instruction.
Modify the following parameters of Line Chart plug-in.

Change Shared Mem. to Scene.

Set Kay DataY to DataY .

Set Data Delim. to # .

Set Values Animation to Timer .

IMPORTANT! You must use the same platform (x64/x86) of Microsoft Excel and Viz Engine.
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Set Data Nodes Animation to Timer .

Add Data Import plug-in into the same container.
Set File to above prepared Excel file.

Set Table / Sheet to MyTable .

Set Column(,Col...) to ExcelData1 .

Set Data Delim. to # .

Set Shared Mem. to Scene.
Set Key to DataY.

Click the GetIt button and animation chart shows from zero to seven nodes.
Add one data node in the middle of chart.

Set Column(,Col...) to ExcelData2.
Click the GetIt button.

Change values of eight data nodes.

Set Column(,Col...) to  ExcelData3 .

Click the GetIt button.
Remove the first data node.

Set Column(,Col...) to  ExcelData4 .

Click the GetIt button.

Chart Animation Using Control Chart

Follow the "To create a Line Chart" instruction.
Modify the following parameters of Line Chart plug-in.

Set Values Animation to Timer.
Set Data Nodes Animation to Timer.

Add Control Chart plug-in into the same container and save the scene.
Open Viz Trio.

Import the scene.
Click "1 (LineChart)" in Tab Fields.
Edit values in Editing Template.

See Also

Control Chart
Data Fit
Data Import
Data Label
Data Storage
Line Stack

Note: You can add more data columns and play with animation on difference data change.
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Pie Chart

The Pie Chart plug-in draws a pie chart, filled with data out of a Shared Memory Map. You can use 
delimited strings or arrays for data transfer via Scene-, Global- or Distributed-Shared Memory.

Supported Pipelines

Classic Render Pipeline

Viz Engine Render Pipeline

This page contains the following topics and procedures:

Pie Chart Properties
To Create a Pie Chart
To Create a Pie Chart with Data Animation

Chart Animation Using Data Import
Create a Data Animation scene
Chart Animation Using Control Chart

Pie Chart Properties
Shared Mem.: Changes between Scene, Global and Distributed Shared Memory. 
Use Inactive memory to not forward any values via Shared Memory and the data is taken 
from the Data field.
Data: Determines Shared Memory key name. Data is the default input parameter.
Transfer Mode: Sets string- or array-based data transfer.
Data Delim.: Defines the value separator sign(s).

Number Format: Defines if Viz should get the decimal point separator from the  System 

Locale  or  Custom  settings. If Custom is enabled:

Decimal Symbol: Defines which symbol is used as decimal point when Custom Number 
Format is set.

Data Fit: Enables data normalization.
Data Offset: Adds an offset to the incoming data.

Values Animation: Sets the animation type to be created when data change is detected.

Disable: No animation.
Timer: Creates data transition animation (from an old set of data to a new set) 
within the specified time set in Duration sec.. Also select an Animation Mode.
Director: Creates data transition animation with the Stage Director, that controls 
the Animation Progress parameter from 0.0% (old data) to 100.0% (new data). 
Also select an Animation Mode.
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Animation Mode:
Concurrent: Changes all nodes concurrently.
Left to Right: Transitions from left to right.
Right to Left: Transitions from right to left.

Balance Speed: Relates node values to the position of transformed data when set 

to  On  and Animation Mode is set to Left to Right or Right to Left.

Duration sec.: Sets the duration of the animation in seconds for Timer mode.
Diameter: Sets size of pie chart.
Total Segmentdeg: Sets the pie chart’s maximum angle in degrees (default: 100% equals 360 
degrees).
Inner Cutoff: Cuts off a round piece from the cake’s center.
Height: Adjusts height.
Corners: Defines the minimum amount of corners at the pie’s edge. In dependency on the 
number of pieces an algorithm adds corners to always give the pie chart the same 
appearance.
Keep Proportions: If enabled, the pie chart would look real. Otherwise each piece’s radius is 
recalculated.
Const. Offset: Sets a constant gap width.
Center Offset: Determines each pieces’ distance from the pie’s center.
Piece Scaling:

All: All pieces equal 100%. 
Single: Every piece’s size is described by its own 100%(e.g. three pieces mean 300%). 
Fit: All pieces equal 100%, but they are scaled relatively to fit their new area with the 
correct values.

Piece Size%: Parameter for the previous option.
Bevel: Activates Bevel mode.

Bevel Top: Chamfers cake’s top.
Bevel Bottom: Chamfers pie’s bottom.
Bevel Size%: Adjusts bevel’s size from 0 to 100.
Bevel Steps: Sets roundness via the number of segmentation steps.

Move Piece: Defines the piece for the next parameter operation. Starts with 0, -1 means 
nothing selected.

•

•

•

Example:
Balance Speed: If the values of four nodes change from 0,0,0,0 to 
1,9,90,900 in Left to Right mode at 50% of the transformation.
Balance Speed Off: Only the first two nodes are transformed to new 
values.
Balance Speed On: The first three nodes are already transformed to new 
values, and the last node also transformed to 44% of the new values, 
because the data change from 0 (0+0+0+0) to 1000 (1+9+90+900), at 
50% of transformation (in this case the values is changed for 500 of 
1000), the first three nodes are already finished and the last node is 
changed to 400.
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Center Offset: Offsets center for a certain piece.
Height Offset: Offsets height for a certain piece.
Effect Range: Sets the range of pieces to move.
Effect Distribution: Sets the distribution of the effect range.

Pos. Container: Translates every child container to a piece of cake.
Container Offset: Adds a certain center offset to each container.
Center Container: Centers each translated container.
PosX, Y, Z: Activates container translation on the particular axis.
Container Pos. Z%: Sets the relative position on the z axis for each child container.

Map: 
Color Bar: Sets a single color (V texture coordinate) for a certain piece(e.g. three 

pieces: V = 0.0 , V = 0.5  and V = 1.0 ).

Vertex: Uses vertex colors for each piece starting with ID 0. Color ID moves between 
the available vertex colors. Color lets you choose color for the current ID.

To Create a Pie Chart

Create a new group and add the Pie Chart plug-in to it.
Open the Transformation Editor and set Position X and Y to -100.0 and Rotation Y to 

-25.0 .

Add a material and/or a texture to it.
Open the Pie Chart editor and set the following parameters:

Set the following DataY values: 10,20,30,20,50,60,80,45,20 .

Enable Keep Proportions.

Set Center Offset to 6.0 .

Set Move Piece to 1 .

Set Center and Height Offset to 20.0 .

Enable Vertex and set different colors for all Color IDs.

To Create a Pie Chart with Data Animation

Chart Animation Using Data Import

Prepare data sets for animation in Excel file.

Start Microsoft Excel.

Note: A chamfer is a beveled edge connecting two surfaces.
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Enter ExcelData1 into cell A1.

Add some sample values in the cells below ( A2-A8: 80, 35, 45, 75, 85, 55, 60 ).

Enter ExcelData2 into cell A2.

Add some sample values in the cells below ( B2-B9: 80, 35, 45, 75, 40, 85, 55, 60 ).

Enter ExcelData3 into cell A3.

Add some sample values in the cells below ( C2-C9: 40, 60, 75, 85, 80, 55, 45, 35 ).

Enter ExcelData4 into cell A4.

Add some sample values in the cells below ( D2-D8: 60, 75, 85, 80, 55, 45, 35 ).

Rename this first sheet to MyTable (can be done with a double click on the sheet name at 
the bottom).
Follow one of the following methods to make Viz Engine can read this Excel data file

Save and close the Excel document.
Share the Excel document.

On the Review tab, in the Changes group, click the Share Workbook button.
The Share Workbook dialog box appears, and you select the Allow changes by 
more than one user at the same time. check box on the Editing tab.
Click Ok button of the dialog
Save the Excel document.

Create A Data Animation Scene

Follow the "To create a Pie Chart" instruction.
Modify the following parameters of Pie Chart plug-in.

Change Shared Mem. to  Scene .

Set Data Delim. to  # .

Set Values Animation to  Timer .

Add Data Import plug-in into the same container.
Set File to above prepared Excel file.

Set Table / Sheet to  MyTable .

Set Column(,Col...) to  ExcelData1 .

Set Data Delim. to  # .

Set Shared Mem. to  Scene .

Set Key to  Data .

Click the GetIt button and chart shows from zero to seven nodes.
Change to the another data set.

Set Column(,Col...) to ExcelData2 or ExcelData3 or ExcelData4.
Click the GetIt button.

Repeat step 5 with another data set including ExcelData1.

IMPORTANT! You must use the same platform (x64/x86) of Microsoft Excel and Viz Engine.

Note: You can add more data columns and play with animation on difference data change.
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Chart Animation Using Control Chart

Follow the "To create a Pie Chart" instruction.
Modify the following parameters of Pie Chart plug-in.
Change Values Animation property to Timer.
Add Control Chart plug-in into the same container and save the scene.
Open Viz Trio.

Import the scene.
Click "1 (PieChart)" in Tab Fields.
Edit values in Editing Template.

See Also

Control Pie
Data Fit
Data Import
Data Label
Data Storage
Presenter

Scatter Chart

The Scatter Chart plug-in draws a scatter chart, filled with data out of a Shared Memory Map. You 
can use delimited strings or arrays for data transfer via Scene-, Global- or Distributed-Shared 
Memory.

Supported Pipelines

Classic Render Pipeline

Viz Engine Render Pipeline

This page contains the following topics and procedures:

Scatter Chart Properties
To Create a Scatter Chart
To Create a Scatter Chart with Data Animation

Chart Animation Using Data Import
Create a Data Animation Scene
Chart Animation Using Control Chart
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Scatter Chart Properties
Shared Mem.: Changes between Scene, Global and Distributed Shared Memory. 
Use Inactive memory to not forward any values via Shared Memory and the data is taken 
from the Data field.
Key DataX: Determines Shared Memory key name for X values. DataX is the default input 
parameter for X values.
Key DataY: Determines Shared Memory key name for Y values. DataY is the default input 
parameter for Y values.
DataZ Position: Uses DataZ for Z-axis positioning.
Key DataZ: Determines Shared Memory key name for Z values. DataZ is the default input 
parameter for Z values.
Transfer Mode: Sets string- or array-based data transfer.
Data Delim.: Defines the value separator sign(s).

Number Format: Defines if Viz should get the decimal point separator from the  System 

Locale  or  Custom  settings. If Custom is enabled:

Decimal Symbol: Defines which symbol is used as decimal point when Custom Number 
Format is set.

DataX, -Y, -Z Fit: Enables data normalization.
DataX, -Y, -Z Scale: Scales input by the selected factor.
DataX, -Y, -Z Offset: Adds an offset to the incoming data.
DataX, -Y, -Z Auto Scale: Enables automatic data normalization.
DataX, -Y, -Z Detect Limits: Detects minimum and maximum of all values and scales them to 
adjusted Start and Stop.
DataX, -Y, -Z Threshold: Adds a definable offset to the detected limit.
DataX, -Y, -Z Start: Determines lower Auto Scale edge.
DataX, -Y, -Z Stop: Determines upper Auto Scale edge.
Values Animation: Sets the vertical animation type to be created when data change is 
detected:

Disable: Does not create an animation.
Timer: Creates data transition animation (from an old set of data to a new set) 
within the specified time set in Duration sec.. Also select an Animation Mode.
Director: Creates data transition animation with the Stage Director, that controls 
the Animation Progress parameter from 0.0% (old data) to 100.0% (new data). 
Also select an Animation Mode.

Animation Mode:
Concurrent: Changes all nodes concurrently.
Left to Right: Transitions from left to right.
Right to Left: Transitions from right to left.

Balance Speed: Relates node values to the position of transformed data when set 

to  On  and Animation Mode is set to Left to Right or Right to Left.

Example:
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Duration sec.: Sets the duration of the animation in seconds for Timer mode. 
Data Nodes Animation: Sets the horizontal animation type to be created when number of 
data nodes change is detected.

Disable: Does not create an animation.
Timer: Creates data transition animation (from an old set of data to a new set) 
within the specified time set in Duration sec.

Duration sec.: Sets the duration of the animation in seconds for Timer mode.

Horizontal Alignment: Sets horizontal orientation to left, center or right.
Chart Width: Adjusts the chart width.
Container: Determines the container used for the scatter nodes.
DataZ SizeX: Allows Z Values to influence X scaling.
DataZ SizeY: Allows Z Values to influence Y scaling.
DataZ SizeZ: Allows Z Values to influence Z scaling.
Center Container: Centers each translated container.
Fit Width: Considers the width of the scatter node containers which means that the 
containers do not reach outside of the specified range.
Animate Position: Sets the translation type: None: no animation, Y: animates the container 
along the Y axis (suggestion: Scale Y + DataLabel for BarChart alike labeling).
Animate Scaling: Sets the scaling type: None: no scaling at all, XYZ: linear scaling in all 
directions, Y: scales in y direction only (->BarChart).

Relative Length: Provides each scatter node with its own 100% size (e.g. seven nodes 
equal 700%).
Const. Speed: Sets the same animation duration for each bar.
Total Length%: Sets the accumulated size of all scatter nodes in percent.

•

•

•

Balance Speed: If the values of four nodes change from 0,0,0,0 to 
1,9,90,900 in Left to Right mode at 50% of the transformation.
Balance Speed Off: Only the first two nodes are transformed to new 
values.
Balance Speed On: The first three nodes are already transformed to new 
values, and the last node also transformed to 44% of the new values, 
because the data change from 0 (0+0+0+0) to 1000 (1+9+90+900), at 
50% of transformation (in this case the values is changed for 500 of 
1000), the first three nodes are already finished and the last node is 
changed to 400.

Note: When number of nodes is changes, scatter chart looks for added and 
removed nodes from their values, adds new nodes to the chart from zero 
width and resizes all nodes to their new size in specified duration.
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To Create a Scatter Chart

Create a group and add the Sphere plug-in to it.

Open the transformation editor and set the Scaling (locked) to 0.2 .

Add a material and/or a texture to the sphere.
Set the group with the sphere to hidden.
Create a new group and add the Scatter Chart plug-in to it.

Open the Transformation Editor and set Position X and Y to -100.0 .

Open the Scatter Chart editor and set the following parameters:

Set the following DataY values: 10,20,30,20,50,60,80,45,20 .

Set Width to 250.0 .

Drag and drop the container with the Sphere to the Container placeholder.

To Create a Scatter Chart with Data Animation

Chart Animation Using Data Import

Prepare data sets for animation in Excel file.

Start Microsoft Excel.
Enter ExcelData1 into cell A1.

Add some sample values in the cells below ( A2-A8: 80, 35, 45, 75, 85, 55, 60 ).

Enter ExcelData2 into cell A2.

Add some sample values in the cells below ( B2-B9: 80, 35, 45, 75, 40, 85, 55, 60 ).

Enter ExcelData3 into cell A3.

Add some sample values in the cells below ( C2-C9: 40, 60, 75, 85, 80, 55, 45, 35 ).

Enter ExcelData4 into cell A4.

Add some sample values in the cells below ( D2-D8: 60, 75, 85, 80, 55, 45, 35 ).

Rename this first sheet to MyTable (can be done with a double click on the sheet name at 
the bottom).
Follow one of the following methods to make Viz Engine can read this Excel data file

Save and close the Excel document.
Share the Excel document.

On the Review tab, in the Changes group, click the Share Workbook button.
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The Share Workbook dialog box appears, and you select the Allow changes by 
more than one user at the same time. check box on the Editing tab.
Click Ok button of the dialog
Save the Excel document.

Create A Data Animation Scene

Follow the "To create a Scatter Chart" instruction.
Modify the following parameters of Scatter Chart plug-in.

Change Shared Mem. to  Scene .

Set Key DataY to  DataY .

Set Data Delim. to  # .

Set Values Animation to  Timer .

Set Data Nodes Animation to  Timer .

Add Data Import plug-in into the same container.
Set File to above prepared Excel file.

Set Table / Sheet to  MyTable .

Set Column(,Col...) to  ExcelData1 .

Set Data Delim. to  # .

Set Shared Mem. to  Scene .

Set Key to  DataY .

Click the GetIt button and animation chart shows from zero to seven nodes.
Add one data node in the middle of chart.

Set Column(,Col...) to  ExcelData2 .

Click the GetIt button.
Change values of eight data nodes.

Set Column(,Col...) to  ExcelData3 .

Click the GetIt button.
Remove the first data node.

Set Column(,Col...) to  ExcelData4 .

Click the GetIt button.

Chart Animation Using Control Chart

Follow the "To create a Scatter Chart" instruction.
Modify the following parameters of Scatter Chart plug-in.

Set Values Animation to Timer.
Set Data Nodes Animation to Timer.

Add Control Chart plug-in into the same container and save the scene.
Open Viz Trio.

Import the scene.

IMPORTANT! You must use the same platform (x64/x86) of Microsoft Excel and Viz Engine.

Note: You can add more data columns and play with animation on difference data change.
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Click "1 (ScatterChart)" in Tab Fields.
Edit values in Editing Template.

See Also

Control Chart
Data Fit
Data Import
Data Label
Data Storage

Stock Chart

The Stock Chart plug-in draws a stock chart, filled with data out of a Shared Memory Map. You can 
use delimited strings or arrays for data transfer via Scene-, Global- or Distributed-Shared Memory.

Supported Pipelines

Classic Render Pipeline

Viz Engine Render Pipeline

This page contains the following topics and procedures:

Stock Chart Properties
To Create a Stock Chart
To Create a Stock Chart with Data Animation

Chart Animation using Data Storage
Chart Animation Using Control Chart

Stock Chart Properties
Shared Mem.: Changes between Scene-, Global- and Distributed-Shared Memory. Use Inactive 
memory to not forward any values via Shared Memory.
Key Open: Determines Shared Memory key name for open values. DataOpen is the default 
input parameter for open values.
Key Close: Determines Shared Memory key name for close values. DataClose is the default 
input parameter for close values.
Key High: Determines Shared Memory key name for high values. DataHigh is the default 
input parameter for high values.
Key Low: Determines Shared Memory key name for low values. DataLow is the default input 
parameter for low values.
Transfer Mode: Sets string- or array-based data transfer.
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Data Delim.: Defines the value separator sign(s).

Number Format: Defines if Viz should get the decimal point separator from the  System 

Locale  or  Custom  settings. If Custom is enabled:

Decimal Symbol: Defines which symbol is used as decimal point when Custom Number 
Format is set.

Data Open, -Close, -High, -Low Fit: Enables data normalization.
Data Open, -Close, -High, -Low Scale: Scales input by the selected factor.
Data Open, -Close, -High, -Low Offset: Adds an offset to the incoming data.
Data Auto Scale: Enables automatic data normalization.

Value Animation: Sets the vertical animation type to be created when data change is 
detected:

Disable: No animation.
Timer: Creates data transition animation (from an old set of data to a new set) 
within the specified time set in Duration sec.. Also select an Animation Mode.
Director: Creates data transition animation with the Stage Director, that controls 
the Animation Progress parameter from 0.0% (old data) to 100.0% (new data). 
Also select an Animation Mode.

Animation Mode:
Concurrent: Changes all nodes concurrently.
Left to Right: Transitions from left to right.
Right to Left: Transitions from right to left.

Balance Speed: Relates node values to the position of transformed data when set 

to  On  and Animation Mode is set to Left to Right or Right to Left.

Duration sec.: Sets the duration of the animation in seconds for Timer mode.
Data Nodes Animation: Sets the horizontal animation type to be created when number of 
data nodes change is detected.

Disable: No animation.
Timer: Creates data transition animation (from an old set of data to a new set) 
within the specified time set in Duration sec.

Duration sec.: Sets the duration of the animation in seconds for Timer mode.

•

•

•

Example:
Balance Speed: If the values of four nodes change from 0,0,0,0 to 
1,9,90,900 in Left to Right mode at 50% of the transformation.
Balance Speed Off: Only the first two nodes are transformed to new 
values.
Balance Speed On: The first three nodes are already transformed to new 
values, and the last node also transformed to 44% of the new values, 
because the data change from 0 (0+0+0+0) to 1000 (1+9+90+900), at 
50% of transformation (in this case the values is changed for 500 of 
1000), the first three nodes are already finished and the last node is 
changed to 400.
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Data Detect Limits: Detects minimum and maximum of all values and scales them to 
adjusted Start and Stop.
Data Start: Determines lower auto scale edge.
Data Stop: Determines upper auto scale edge.
Draw Open: Draws open data.
Draw Close: Draws close data.
Draw High: Draws high data.
Draw Low: Draws low data.
Candle Corners: Sets candle segments.
Wick Corners: Sets wick corners.
Width Scaling

Single Candle: Adjusts size for a single candle. 
Fit: Adjusts all candles to fit a certain width.

Candle Width: Value for the previous parameter.
Candle Gap Ratio%: 100% means that the gaps have the same size as the candles.
Candle Wick Ratio%: 100% means that the wicks have the same size as the candles.
Bevel Candle: Activates Bevel mode for the candle geometry.

Bevel Candle Top: Chamfers candle’s top.
Bevel Candle Bottom: Chamfers candle’s bottom.
Bevel Candle Size%: Adjusts bevel’s size from 0 to 100.
Bevel Candle Steps: Sets roundness via the number of segmentation steps.

Bevel Wick: Activates Bevel mode for the wick geometry.
Bevel Wick Top: Chamfers wick’s top.
Bevel Wick Bottom: Chamfers wick’s bottom.
Bevel Wick Size%: Adjusts bevel’s size from 0 to 100.
Bevel Wick Steps: Sets roundness via the number of segmentation steps.

Relative Length
On: Sets all accumulated candle lengths to equal 100%. 
Off: Sets each candle to its own 100% (e.g. three candles: 300%).

Total Length: Value for the previous parameter.
Use Vertex Colors: Activates the following parameters.

Bull Candle Color: Defines the color for all candles where the close value is higher than 
the open value.
Bear Candle Color: Defines the color for all candles where the close value is lower than 
the open value.
High Wick Color: Sets high wick’s color.
Low Wick Color: Sets low wick’s color.

Note: When number of nodes is changes, stack chart looks for added and 
removed nodes from their values, adds new nodes to the chart from zero 
width and resizes all nodes to their new size in specified duration.



Note: A chamfer is a beveled edge connecting two surfaces.
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To Create a Stock Chart

Create a new group and add the Stock Chart plug-in to it.

Open the Transformation Editor and set Position X and Y to -100.0 .

Open the Stock Chart editor and set the following parameters:
Set the Data Open parameter to the following values: 

10,20,30,40,50,40,30,40,50 .

Set the Data Close parameter to the following values: 

20,15,35,45,40,60,45,20,20 .

Set the Data High parameter to the following values: 

25,20,40,50,55,60,50,40,50 .

Set the Data Low parameter to the following values: 10,15,30,30,25,30,30,20,15 .

Set Candle and Wick Corners to 10 .

Set Candle Width to 25.0 .

To Create a Stock Chart with Data Animation

Chart Animation Using Data Storage

Follow the "To create a Stock Chart" instruction.
Modify the following parameters of Stock Chart plug-in.

Change Shared Mem. to  Scene .

Set Values Animation to  Timer .

Set Data Nodes Animation to  Timer .

Set Width Scaling to Fit .

Set Candle Width to 325 .

Add Data Storage plug-in into the same container.
Set Key Data1 to DataOpen.

Set Data1 to  10,20,30,40,40,30,40,50 .

Set Key Data2 to DataClose.

Set Data2 to  20,15,35,45,60,45,20,20 .

Set Key Data3 to DataHigh.

Set Data3 to  25,20,40,50,60,50,40,50 .

Set Key Data4 to DataLow.

Set Data4 to  10,15,30,30,30,30,20,15 .

Change Shared Mem. to Scene and animation chart shows from nine to eight nodes.
Update data with the same number of nodes.

Change Shared Mem. to Inactive.
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Set Data1 to  40,30,50,25,20,40,55,45 .

Set Data2 to  25,45,20,20,30,45,50,40 .

Set Data3 to  55,50,50,40,40,55,55,50 .

Set Data4 to  10,15,10,15,15,20,40,30 .

Change Shared Mem. to Scene and values of nodes change in the animation.
Update data by adding two nodes.

Change Shared Mem. to Inactive.

Set Data1 to  40,30,20,50,25,20,40,30,55,45 .

Set Data2 to  25,45,45,20,20,30,45,45,50,40 .

Set Data3 to  55,50,50,50,40,40,55,55,55,50 .

Set Data4 to  10,15,20,10,15,15,20,25,40,30 .

Change Shared Mem. to Scene and animation chart shows from eight to ten nodes.

Chart Animation Using Control Chart

Follow the "To create a Stock Chart" instruction.
Modify the following parameters of Stock Chart plug-in.

Set Values Animation to  Timer .

Set Data Nodes Animation to  Timer .

Set Width Scaling to  Fit .

Set Candle Width to 325 .

Add Control Chart plug-in into the same container and save the scene.
Open Viz Trio.

Import the scene.
Click "1 (StockChart)" in Tab Fields.
Edit values in Editing Template.

See Also

Control Chart
Data Fit
Data Import
Data Label
Data Storage

4.3.3 Default
The following Geometry plug-ins are located in the Default folder:

2D Line
2D Patch
2D Ribbon
Alpha Map

IMPORTANT! You must use the same platform (x64/x86) of Microsoft Excel and Viz Engine.
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Arrow
Circle
Cog Wheel
Cone
Connector
Cube
Cycloid
Cylinder
Cylinder3
Cyclotron
DisplacementMap
Eclipse
Fade Rectangle
Filecard
Graph
Graph2D
Icosahedron
Image FX
Noggi
Pointer
Polygon
Quad
Rectangle
Ring
Roll
Sphere
Spline Path
Spline Strip
Spring
Star
Torus
Triangle
Wall
Wave

2D Line

The 2D Line plug-in draws a simple 2D line through given 2D coordinates, respectively point 
values.

Note: This plug-in is located in: Plugins -> Geom plug-ins -> Default
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2D Line Properties

use LOD: Enables level of detail. Range: On - Off . Default: On .

Enable Outline: Enables drawing of an outline. Range: On - Off . Default: On .

Width: Defines the width of the drawn line. Range: 0.0 - 500.0 . Default: 5.0
Point values: Lists x,y pairs separated by ‘:’ character. x and y values are separated by 

blanks. Example: 0 0: 100 100: 200 70: 300 240: 400 280: 500 240: 600 400 .

New Line: Press before values are entered (i.e. Point values), or else the line is rendered as 
invisible.
Clear All: Deletes all line-segments.

To Create 2D Lines

Enter the Point Values. For example: 0 0 : 200 45  entered in the Point Values field 

creates a line that starts at the point X1(0), Y1(0) and ends at point X2(200), Y2(45).
Click the New Line button to create the line.

2D Patch

The 2D Patch plug-in is a two dimensional planar curved grid of polygons. The grid is defined by 
control points that are located on the perimeter of the grid. The parameters of each one of the 
control points is the location X and Y, and the assigned texture coordinates U and V. The 
calculation of the internal grid points is done with a mix of a one-dimensional cubic spline and a 
two dimensional bi-linear interpolation.

It is possible to specify the interpolation direction to be just in one direction, or in both. 
Depending on the shape that should be created, it is important to choose the right direction (for 
example it is not too difficult to create an annulus with this plug-in, after choosing the right 
interpolation direction along the radius).

This page contains the following topics:

Note: This plug-in is located in: Plugins -> Geom plug-ins -> Default
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2D Patch Properties
2D Patch Workflow
2D Patch Tips
2D Patch Known Limitations

2D Patch Properties
use LOD: Enables/disables dynamic level of detail.
Geo: 
X and Y Number of Intervals: Sets the number of intervals between the control points in the 
X and Y direction respectively. Parameter name: NX/NY.
Interpolation Direction: Defines the direction of interpolation from the control points on the 
perimeter to the internal grid points. Parameter name: interDirect.
X Size, Y Size, Reset XY (button) and Reset UV (button): Gives initial values for the control 
points. The values of X and Y-Size takes effect just after hitting the Reset XY button. The 
Reset UV button sets default values to the texture coordinates. Parameter name: SX/SY, 
resetXY/resetUV.
X Resolution and Y Resolution: Defines the number of subdivisions to polygons between the 
control points in the X- and Y-direction respectively.Parameter name: MX/MY.
Interactive mode: A toggle to enable or disable the interactive mode of direction 
manipulation with the mouse. Parameter name: interactive.

Editing Range %: Sets the amount of effect the movement of one point (move with 
SHIFT pressed) should have on the neighboring points. Parameter name: EditingRange.
Editing Mode: When moving a point, it is possible, by pressing SHIFT, to move the 
other points simultaneously. How the points move depends on the editing mode that 
is chosen. Parameter name: EditingMode.
Constant (button): The other points move their positions exactly equal to the one you 
move.
Linear (button): The other points move in a linear way, based on the distance from the 
point that is being moved.
Exponential (button): The other points move in an exponential way, based on the 
distance from the point it is being moved.

Draw Control Points: A toggle to draw or not to draw the control points. Enables the Control 
Point Size parameter. Parameter name: drawControlPoints.

Control Point Size: Sets the control point size.
Show Control Points Values: Enables the manipulation of the control points in the rendering 
window. Parameter name: controlPointSize.
New edit mode: When enabled, and you press down CTRL, you can see the control points 
and also you have the opportunity to move the control points. The “Interactive mode” and 
the handle “script/plug-ins event mode” must be enabled.
X, Y, U and V: Sets position and texture coordinates for each of the control points. These 
values are typically changed in the rendering window only with the mouse.

Note: There are 12 control points that each have their own X,Y,U and V parameters.
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2D Patch Workflow
Set the right number of control points, according to your estimation of how complex the 
patch is you are going to create. This number can be changed at any time. The plug-in 
redistributes the new points along the already defined patch.
Estimate the final length and width of the patch.
Move the patch to the right place in your scene. If it is going to be on some horizontal plane, 
it might be easier first to edit it in the default orientation, and afterwards rotate it to the 
right place. There is no problem to continue working on it after the rotation has been made, 
but because of the perspective, it might be less straightforward.
Turn on the Draw Control Points toggle and the Interactive toggle. While working with the 
cursor, you do not have to be very close to the control point that you would like to 
manipulate. The plug-in finds by itself the nearest control point to where is your cursor is. 
The selected control point gets yellow color, as compared to all the rest that are white, to 
indicate that it has been selected for editing.

With the left button, according to the selection roles above, you can change the X and Y 
location of each of the control points.
Once the shape of the patch is more or less defined, it is a advisable to set the resolution 
parameter. Performance wise you should set it as low as possible, but it should be high 
enough to guarantee a smooth enough look.
Choose an image and drag it on the patch in the usual way. After doing it open the image 
texture editor and set the Mapping property to Vertex, and the Wrap property to Clamp.
The next step is to map more accurately the image on the patch. Set first the Texture Length 
according to your estimation, then choose the Texture Direction, and then play with the 
Texture Head Location to see the texture flowing along the patch. This is a good point to 
review again all the parameters you set before.
The last step is to define an animation if necessary. Typically with the patch, the animation 
is just on the Texture Head Location. To learn more about animation, see the Create 
Animations section of the Viz Artist User Guide.

2D Patch Tips
It is sometimes useful to work with 2D Patch while in wireframe mode. If you have a texture 
with alpha, to see it correctly, you need to turn the image off with the small enable/disable 
button near the image icon.
Remember that if the 2D Patch is not selected, the interactive mode is not active. As result 
of this, the first click with the mouse on unselected object is always with the normal Viz 
Artist functionality of the cursor, of moving, rotating and so on the object.

Note: You are able to do the direct manipulation just if the object is the selected 
object in the Viz Artist container tree. Remember also, that regardless of the 
position of your cursor, if the patch is the selected object, and the interactive toggle 
is on, always one control point becomes selected and is changed while working with 
the cursor. Hitting the space key on the keyboard cancels the current selection. The 
cursor then returns to normal functionality until the patch object is selected again.



Caution: While defining an animation on the parameters of a 2D Patch, you must 
make sure that the right window is open in Viz Artist. Without it, the changes that 
you are doing with the cursor does not take effect with regard to the animation.



http://docs.vizrt.com/viz-artist
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If you are done with the interactive session of defining a 2D Patch, turn 

the Interactive toggle  Off .

While working on a 2D Patch in the interactive mode, it is not possible to select another 
object with the cursor in the Viz Artist Scene Editor. The way to select another object is first 
to hit SPACE, and thereafter select the other object.
Doing animation on the 2D Patch is quite expensive performance wise. Be aware to it, and 
try to use as much as possible a small number of control points and polygons.
For the texture used for the 2D Patch, make sure that along the flow direction, you have on 

both texture edges a clean line with alpha equal to 0 . Otherwise, you get a wake of the 

image edges in front or behind it.
Do not change the number of control point along an animation. It is possible, if necessary, 
to change the resolution number.
While defining an animation, make sure to remove from it, if necessary, the toggle values of 
Show Control Points, Interactive Mode and so on.

2D Patch Known Limitations
When you use 2D Patch in a scene, by choosing an object in the Viz Artist rendering window, 
the Viz Artist user interface is not updated automatically.
While copying a 2D Patch, to make it work in the interactive mode, it is necessary to save the 
scene first.
If the texture coordinates on the control points are getting outside the [0,1] range artifacts 
may show. Be aware to keep it within the [0,1] range.

2D Ribbon

The 2D Ribbon plug-in is a curved strip. It is ideal to make customized curves to symbolize, for 
example, frontiers on a map or similar. The way the object is curved is easily edited in the 2D 
Ribbon property editor. It is possible to enable inter activity so that counterpoints of the ribbon 
can be dragged with the cursor.

The 2D Ribbon can be used in Ribbon (1), Filled Area (2) or Double Outline (3) modes:

Note: This plug-in is located in: Plugins -> Geom plug-ins -> Default
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This page contains the following topics and procedures:

2D Ribbon Properties
Ribbon Mode Properties
Filled Area Mode Properties
Double Outline Mode Properties

To Create a 2D Ribbon
2D Ribbon Tips
2D Ribbon Known Limitations

2D Ribbon Properties
The properties of the 2D Ribbon plug-in are different for each selected mode.

Ribbon Mode Properties

Use LOD: Enables or disables the dynamic Level of Detail (LOD)
Geo: TBA
Working Mode: Available modes are Ribbon, Filled Area and Double Outline. Default is the 
Ribbon mode.
Number of Control Points: Sets the number of control points along the ribbon 

(when Slave mode is set to  Off ).

Resolution: Defines the number of subdivisions to polygons between the control points.
Closed Curve: Creates a closed a curve like a circle. The forward end touches the backward 
end.
Constant Width:

Set to on: Any width modification is along all of the 2D Ribbon.
Set to off: Any width modification is around the nearest Control Point.

Note: Preserve Constant Width While Possible is not available when this is 
selected.
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Add Caps: Shows the Begin and End cap parameters when set to On . Removes the Begin and 

End caps when set to  Off , even if they are set to On  in the two parameters:

Begin Caps: Applies a cap at the start of the 2D Ribbon when set to On  . Also sets the 

resolution of the start cap.

End Caps: Applies a cap at the end of the 2D Ribbon when set to On . Also sets the 

resolution of the end cap.
Preserve Constant Width While Possible: Makes the 2D Ribbon try and maintain its set width 

when modified (available when Constant Width is set to  Off ) when set to On  .

Interactive Mode: Enables or disables the interactive mode of direction manipulation with the 
cursor:

Editing Range %: Sets the amount of effect the movement of one point (move with 
SHIFT) should have on the neighboring points.
Editing Mode: When moving a point, press SHIFT to move the other points 
simultaneously. How the points move depends on the editing mode that is 
chosen, Constant, Linear or Exponential.
Constant: The other points move their positions exactly equal to the one you move.
Linear: The other points move in a linear way, based on the distance from the point 
that is being moved.
Exponential: The other points move in an exponential way, based on the distance from 
the point it is being moved.

Reset Options: Sets the 2D Ribbon to initial values for the Control Points and ribbon size. 

Changed values of Ribbon Length and Ribbon Width take effect after   has been 
clicked.

 Reset: Resets all created curves but does not delete the existing control 
points.

Texture Options: Enables 2D Ribbon Texture options when set to On  :

Texture Direction: Shows the texture in different directions. For example, if a pointer 
right-shows used as texture, the pointer shows to the right side if 
the Horizontal option is activated. Otherwise, to the left side if the 
-Horizontal option is set. Same for the Vertical and -Vertical option. The rendered
pointer shows to the top or to the bottom side.
Texture Head Location: Moves the texture either to top or bottom direction.
Texture Length: Stretches the texture.

Use Texture Factor: Enables the texture factor parameter when set to On  .

Rotate Around X Axis: Rotates the created 2D Ribbon around the X axis when set to On  .

Show Spline: Shows the spline of the 2D Ribbon when set to On  .

Use Progressive Visualization: When set to On  the activated parameters affect the 

rendering:
Progress Mode: Slices the curve in the x-direction by length or by the control point 
index. Select from two options, By Length and By Control Points.
Path Position: Limits the workspace so there are less control points to prepare.

Render Bumps: The curves are top-barbed which is useful for weather broadcasting.
Warm: Gives a rounded edge to the bumps.
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Cold: Gives a sharper edge to the bumps.
Occluded: Gives alternating warm and cold bumps.

Slave Mode: Enables one ribbon to act as the master and the other as the slave. The slave 
ribbon uses the Number of Control Points and Resolution set for the master.
Show Control Points Values: Enables the manipulation of the Control Points in the render 
window. X, Y, and W values set the X/Y position and the width of the curve at the different 
Control Points. These values are typically be changed when edited directly in the Scene 
Editor.

Filled Area Mode Properties

For details see Ribbon Mode Properties.

Double Outline Mode Properties

For details see Ribbon Mode Properties.

To Create a 2D Ribbon
Add the 2D Ribbon plug-in to the Scene Tree.

Set Interactive Mode to On .

Set the Number of Control Points.

Open Reset Options:
Enter (estimate) the Ribbon Length and Ribbon Width (enter a new figure and press 
ENTER).

Click   to activate the settings.
Toggle the Constant Width, as required.
Position the 2D Ribbon in the Scene.

Click the   (Events) button in the Scene Editor.
Modify the 2D Ribbon shape, either:

Use the mouse cursor to modify the Control Points. Click on or near the Control Point. 
The selected control point shows yellow (1).
Left button: Click and drag the nearest Control Point.
Right button: Modifies the 2D Ribbon width.

or

Note: This number can be changed at any time. New points are distributed along the 
already defined ribbon (2).



Note: If the 2D Ribbon is to be on some horizontal plane, it might be easier first to 
edit it in the default orientation, and afterwards rotate it to the right place. There is 
no problem to continue work on it after the rotation has been made, but because of 
the perspective, it might be less straightforward.



Note: If the Container, which contains the 2D Ribbon plug-in, is selected, and 

Interactive Mode is set to On , one Control Point is always active.
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Set Show Control Points Values to on. Modify the Control Points as required.

Set the Resolution. For best performance set the resolution as low as possible, but high 
enough to guarantee a smooth enough look in the corners of the 2D Ribbon, and also a 
smooth enough mapping of the image/texture on the 2D Ribbon.
Choose an image and drag it on the 2D Ribbon. Open the Image texture editor and set:

Mapping to Vertex
Wrap to Clamp

Map the image more accurately on the 2D Ribbon. Set Texture Options to  On :

Set the Texture Length as required.
Set the Texture Direction as required.



Plug-ins User Guide -  5.0

Copyright © 2022  Vizrt Page  74

c.

12.
13.

•
•

•

•

•

•

•

•

Set the Texture Head Location to see the texture flowing along the 2D Ribbon.

This is a good point to review again all set parameters.
Define an animation, if required. Typically with the 2D Ribbon the animation is just on the 
Texture Head Location.

2D Ribbon Tips
It is sometimes useful to work with 2D Ribbon with use LOD set to on.
If you have a texture with alpha, to see it correctly set the image to off with the small 
enable/disable button near the image icon.
When finished with the creation of a 2D Ribbon, make sure that Interactive Mode is set to 

Off .

When the 2D Ribbon Interactive mode is set to on, and the Scene Editor   is active, it is 
not possible to select another object with the cursor in the Scene Editor. To select another 

object make sure that Interactive mode is set to off and the Scene Editor   is inactive
Animation on the 2D Ribbon is quite heavy on performance. Try to keep the number of 
Control Points and Polygons as low as possible.
When a texture is used with a 2D Ribbon, make sure that, along the flow direction, on the 

texture edges there is a clean line with alpha equal to 0 . If not there is a wake of the image 

edges in front or behind it.
Do not change the number of Control Point along an animation. It is possible, if necessary, 
to change the resolution number.
While defining an animation, make sure to remove from it, if necessary, the toggle values of 
Show Control Points, Interactive Mode and so on.

IMPORTANT! While defining an animation on the parameters of a 2D Ribbon, make 
sure that the right window is open in Viz Artist. Without it the changes that are made 
with the cursor do not take effect, with regard to the animation.
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2D Ribbon Known Limitations
When you have in the scene a 2D Ribbon, by choosing an object in the Viz Artist Scene 
Editor, the Viz Artist user interface is not updated automatically.
While copying a 2D Ribbon, to make it work in the interactive mode, it is necessary to save 
the scene first.
If the texture coordinates on a Control Point are close to or outside the [0,1] range, artifacts 
may show. Keep it within the [0,1] range.

See Also

2D Follow
Create Animations section of the Viz Artist User Guide

Alpha Map

The Alpha Map plug-in enables the creation of an alpha map from a grayscale image by translating 
the intensity of the grayscale image to an opacity (alpha) value. This is useful for entities which do 
not directly support an image as their alpha channel.

The plug-in does not accept an arbitrary image even if it only contains grayscale values. The image 
format must be luminance, for example, a single channel containing intensity values.

If a RGB image in dropped onto the plug-in, an error message is generated:

ERROR in plug-in AlphaMap: Image <8AFD1E04-B938-41D1-A743CF251028403B> not a valid 
luminance or alpha image

Alpha Map Properties
Detail: Sets the detail level of the map, the lower the value the higher the level of detail.
Image: Drag the image to create the map to the drop zone. The image must be a valid alpha 
image.
X-size: Sets the size of the map along the X-axis.
Y-size: Sets the size of the map along the Y-axis.
Texture X Offset %: Sets the offset of the texture in the X-axis.
Texture Y Offset %: Sets the offset of the texture in the Y-axis.
Texture X Width %: Stretches or compresses the texture in the X-axis.
Texture Y Width %: Stretches or compresses the texture in the Y-axis.
Patch mode:

Triangle Strip: Uses the same size of triangle polygon on the whole surface.

Note: This plug-in is located in: Plugins -> Geom plug-ins -> Default

http://documentation.vizrt.com/viz-artist
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Optimized Quads: Uses bigger triangle polygons, where the surface of the 
displacement map is flat (reduce the total number of polygons and improve 
performance).

Inverse: Mirror all coordinates.
Texture Coordinates: Draws the texture over again when set to Repeat or stretches the 
texture to fit when the texture is to small to fit onto the Alpha Map rectangle when Clamp is 
selected.
Texel Precision: Uses Subtexel for better texture image quality:

Texel: No sub-pixel or sub-texel corrections are made.
Subtexel: There is a limited number of pixels available on the screen, if a line does not 
run through a real pixel, it must be moved to the nearest one, this introduces a 
positional error. If Subtexel is selected Viz Artist breaks up pixels into smaller sub 
pixels in memory, so that the line can be drawn to the nearest sub pixel.

Smooth: Creates a smooth look of the map, without the reduction of the polygon details of 
the map. In some cases the number of polygons are required to obtain the correct lightning.
Texture Coordinates: Decides if texture coordinates are to be created, and to which level. 
Select from None, Full or Part (partial). This is required if a texture is applied with a vertex 
mapping. Texture mapping consumes resources, if not needed select None.
Color: Sets the color of the alpha map rectangle.

To Add an Alpha Map
Drag the Alpha Map plug-in to the Scene Tree.
Add an alpha (must be luminance only) image to the Alpha Map editor Image drop zone.
Drag a video source icon onto the alpha map’s container.

Arrow

The Arrow plug-in allows you to create and customize an arrow geometry. The arrow is a 2D 
object. By clicking on the arrow icon in a container, the arrow editor opens. The default arrow has 
two heads. At the tip of each arrowhead the reference points are placed. The left point is 1 and the 
right is 2.

Arrow Properties
Use LOD: Enables/disables dynamic level of detail.
Point 1X/1Y/1Z/2X/2Y/2Z: Sets the point offsets.
Width: Sets the width of the arrow shaft.
Style 1: Determines whether the arrow end at point 1 should have a head.
Style 2: Determines whether the arrow end at point 2 should have a head.

Note: This plug-in is located in: Plugins -> Geom plug-ins -> Default
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Arrow Width: Sets the width of the arrow heads.
Arrow Length: Sets the length of the arrow head.
Percent: Scales the arrow in percent of the size defined by X-, Y- and Z-values.
Mode: Defines if the arrow lies in an XY, XZ or YZ plane.

To Create an Arrow

Create a group and add the Arrow plug-in to it.
Add a material and/or an image to the same container as the arrow plug-in to add color 
and/or texture to it.

Circle

The Circle plug-in creates a circle with different corner levels.

Circle Properties
Use LOD: Enables/disables dynamic level of detail.
Radius: Sets the radius of the circle.
Corners: Sets the number of corners the circle is to be constructed of. The circle is set 
together by tiled triangles and the higher the number of corners is set, the more triangles 
are used to construct the circle. The higher the value set, the more rendering performance 
used.
Mode: Changes the space perspective.

XY (front view)
XZ (bottom view)
YZ (left view)

To Create a Circle

Note: This plug-in is located in: Plugins -> Geom plug-ins -> Default
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Create a group and add the Circle plug-in to it.
Add a material and/or an image to the same container as the circle plug-in to add color and/
or texture to it.
Set the circle radius.
Set the number of corners.

Cog Wheel

The Cog Wheel plug-in creates a cog wheel. It has a range of properties to adjust the look of the 
cog wheel.

To avoid decreasing the system performance, set the tessellation to a lower value since it does not 
make much difference in quality.

Cog Wheel Properties
Use LOD: Enables/disables dynamic level of detail.
Tesselation: Sets the level of detail.
Corners: Sets the number of corners the cogwheel is to be constructed of. The cog wheel 
gets one tooth for each corner, so the number of teeth changes correspondingly.
Height: Sets the height or width of the cog wheel.
Tooth height: Sets the height of the cog wheel teeth.
Diameter: Sets the diameter of the cog wheel.
Hole: Creates and sets the size of a hole in the cog wheel.
Bevel: Sets the degree of bevel at the cog wheel.
Inner Bevel: Enables or disables bevel in the cog wheel hole.
Show Top: Enables or disables visualization of the top.
Show Bottom: Enables or disables visualization of bottom.
Center: Allows you to select where the geometrical center should be placed on the cog 
wheel: Either Center, Bottom or Top.

Note: This plug-in is located in: Plugins -> Geom plug-ins -> Default
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To Create a Cogwheel

Add the Cog Wheel plug-in to a container.
Add a material to the same container.

Set Hole parameter to 50.0 .

Set the transformation parameters for the container to: R otation  X: 90.0  , Y: 45.0  and Z: 

-45.0  .

Cone

The Cone plug-in creates a cone geometry. Set the tessellation to a reasonable value since it does 
not make a great difference in quality.

Cone Properties
Use LOD: Enables or disables dynamic level of detail.
Tessellation: Sets the degree of detail.
Height: Sets the height of the cone.
Diameter: Sets the diameter of the cone.
Corners: Allows you to decide the number of corners the cone is to be constructed of.
Show Bottom: Enables or disables visualization of the cone bottom.
Center: Allows you to select where the geometrical center should be placed on the cone: 
Either Center, Bottom or Top.
Smooth: Enables a smoothing of the cone edges.

Note: This plug-in is located in: Plugins -> Geom plug-ins -> Default
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Rounded Tip: Enables the user to adjust the roundness of the cone’s tip.
Rounded Tip Height: Sets the parameter for the roundness of the tip. The angle of the 
cone’s side does not change, the rounded tip is created by ‘taking away’ from the pointed 
tip. Therefore the cone does not have the full height.

To Create a Cone

Add the Cone plug-in to a container.
Add a Material to the same container.

Connector

The Connector plug-in connects two objects with a line of a required color and width.

Connector Properties
Use LOD: Enables/disables dynamic level of detail.
Container 1 and 2: Placeholder for container 1 and 2. Drag the container onto the drop 
zone. Click R to remove the container.
Connection Point 1 and 2 By X, Y and Z Axis: Sets the X, Y and Z-value of container 1 and 2 
where the line should start. Can be set to Min, Center, Max, CenterBB or Origin.
Line Width: Sets the width of the connecting line.
Drawing Mode: Available options are Line, Mesh and Viz Engine.

Note: This plug-in is located in: Plugins -> Geom plug-ins -> Default
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Line Color: Defines the color of the line.
Border Thickness: Applies a border with the thickness determined by the value.
Border Color: Defines a border color.

To Connect Two Objects

Create a new group and add the Connector plug-in to it.
Create two new group containers and add a geometry object (e.g. Cylinder and Cone) to 
each group.
Open each container’s transformation editor and move the objects a part.
Add a material and/or an image to the geometry objects.
Open the connector plug-in editor and drag and drop the two containers to the Container 1 
and Container 2 placeholders, respectively.
Adjust the color line.
Open the Connector plug-in editor and play with the settings.
Add more objects to Container 2 and animate it.

See Also

BoundingBox plug-in

Cube

The Cube plug-in creates cubes with particular widths, heights, depths and other attributes.

Note: To use the plug-in in the Viz Engine Render Pipeline, the Viz Engine option is 
mandatory.



Note: This plug-in is located in: Plugins -> Geom plug-ins -> Default
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Cube Properties
Use LOD: Enables/disables dynamic level of detail.
Size X: Sets the size of the cube in the X-axis. Parameter name: size_X.
Size Y: Sets the size of the cube in the Y-axis. Parameter name: size_Y.
Size Z: Sets the size of the cube in the Z-axis. Parameter name: size_Z.
Center Y: Sets the position of the cube center along the Y-axis. You can choose between 
Center, Bottom or Top.
Tessellation: Sets the degree of detail.
Adaptive Tessellation: Adjusts tessellation on each axis separately, depending on the 

extension of the cube on that axis. The reference value is an extension of 100 . For a face of 

size 200 , the tessellation-parameter is doubled, for a face of size 50 , the tessellation is 

halved. The automatically adapted tessellation still never exceeds its maximum value of 

100 . 

Bevel: Adds a bevel of the given size to corners and edges of the cube. The size of the bevel 
reduces the size of the cube’s axis-aligned faces which: in the case ‘Adaptive tessellation’ is 
enabled causes them to become less tessellated accordingly. Tessellation of the bevel itself 
is affected by ‘adaptive tessellation’ too. 

Rounded Bevel: Rounds the beveled edges and corners when set to On . The roundness of 

the bevel is tessellated is affected by adaptive tessellation. 
Show Top, Bottom, Front, Back, Left, Right: Shows or hides the cube’s face and adjacent 
corners and edges.

Show Size 0: Enables/disables display of the cube at axis value zero ( 0 ). If one of the axis 

values are set to 0 , the cube remains visible if the setting is enabled ( On ). Disabling ( Off ) 

it makes the cube become invisible as long as one of the axis values are 0 . A situation 

where this parameter is useful is when creating bar chart animations. In such animations it is 

possible to hide the bar at value 0  by disabling this setting.
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To Create a Cube

Create a new group container and add the Cube plug-in to it.
Add a material and/or an image to the same container.

Open the cube editor and set Rotation Y and Z values to 45.0 .

Cycloid

The Cycloid plug-in creates a Cycloid geometry. The path traced by a point on a wheel as the wheel 
rolls, without slipping, along a flat surface.

Cycloid Properties
Shape

EpiCycloid: A plane curve produced by tracing the path of a chosen point of a circle 
which rolls without slipping around a fixed circle
Hypo Cycloid: A special plane curve generated by the trace of a fixed point on a small 
circle that rolls within a larger circle.

Corners: Sets the number of corners the Cycloid is to be made up of.
Hole: Creates a hole in the Cycloid.
Radius: Sets the radius of the hole.
Factor Outer: Sets the outer factor of the Cycloid.

Factor Inner: Sets the inner factor of the Cycloid (when Hole is set to On ).

Note: This plug-in is located in: Plugins -> Geom plug-ins -> Default
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To Create a Cycloid

Create a new container.
Add the Cycloid plug-in to it (1 (default Hypo Cycloid)).
Open the Cycloid editor.
Modify the Cycloid parameters, for example (2).

Corners:  8 .

Hole:  On .

Radius:  20 .

Factor Outer:  10 .

Factor Inner:  10 .

Slice: 5 .

If required, add a material and/or a texture.

Cylinder

The Cylinder plug-in creates cylinders with different heights, widths and depths and other 
attributes.

Cylinder Properties
Use LOD: Enables/disables dynamic level of detail.
Height: Sets the height of the cylinder.
Diameter: Sets the diameter of the cylinder

Note: This plug-in is located in: Plugins -> Geom plug-ins -> Default
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Rotation: Sets the rotation around X-axis.
Angle: Sets the opening angle from 0-360°. As the value decreases below 360° an increasing 
angle opens in the cylinder.
Corners: Sets the number of corners the cylinder is to be made up from.
Hole: Creates a hole in the cylinder, making it into a tube.
Center: Sets the position for the center. You can choose between Center, Bottom or Top.
Bevel: Sets the size of bevel at the cylinder.
Inner Bevel: Enables/disables bevel in the cylinder hole if bevel is set at the bevel parameter.
Show Top: Turns off/on visualization of cylinder top.
Show Bottom: Turns off/on visualization of cylinder bottom.

Show size 0: Enables/disables display of the cylinder at height value 0 . If you set height to 

zero, the cylinder is visible by default. If you disable this option, the cylinder becomes 
invisible.

To Create a Cylinder

Create a new group container.
Add the Cylinder or Cylinder3 plug-in.
Open the Cylinder editor.

Set Hole to 50.0 .

Add a material and/or an image to the same Container.
Open the cylinder editor.

Set Rotation Y to 75.0  and Z to 90.0 .

Cylinder3

The Cylinder3 plug-in creates cylinders. Compared to the Cylinder plug-in, Cylinder3 provides the 
designer with more advanced options and settings.
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Cylinder3 Properties
Use LOD: Enables/disables dynamic level of detail.
Height: Sets the height of the cylinder.
Diameter: Sets the diameter of the cylinder
Rotation: Sets the rotation around X-axis.
Angle: Sets the opening angle from 0-360°. As the value decreases below 360° an increasing 
angle opens in the cylinder.
Opening Mode: Describes in which direction the cylinder is opened when adjusting the Angle 
parameter:

CW: Opens the cylinder in a clockwise direction.
CCW: Opens the cylinder in a counter-clockwise direction.
Center: Opens the cylinder in clockwise and counter-clockwise directions 
simultaneously.

Corners: Adjusts the resolution of the cylinder by setting the number of corners the cylinder 
is to be made up from.
Hole: Creates a hole in the cylinder, creating a tube.
Center: Sets the center position of the cylinder to Center, Bottom or Top.
Bevel: Adjusts the bevel size of the cylinder.
Inner Bevel: Enables or disables bevel in the cylinder hole if a value is given for the bevel 

parameter, even if Hole is set to  0.0 . When creating a cylinder with an outer bevel and flat 

top and bottom surfaces, this setting must be set to  Off .

Show Top: Turns visualization of the cylinder top surface on or off.
Show Bottom: Turns visualization of cylinder bottom surface on or off.

Show size 0: Enables or disables display of the cylinder when the value of Height is set to  0 . 

By default, the cylinder is visible when Height is set to  0 . By disabling this option, the 

cylinder becomes invisible. This is useful when designing pie chart visualizations.
Show inner bevel: If this toggle is off, the inner bevel, respectively the inner cylinder is not 
rendered.
Show outer bevel: If this toggle is off, the outer bevel, respectively the outer cylinder is not 
rendered.
Show caps: Applicable only to cylinders with an opening angle. This setting determines 
whether a surface, or cap, should be added to the angle’s sides. This setting only affects the 
geometry object if the angle is less than 360°. In combination with the Back Face setting of 
the Expert container plug-in, this setting allows for the design of cylinders with a cut out 
section exposing the cylinder’s inside.
Static texture: If the texture mapping of the texture is set to Vertex mode, this setting 
defines whether the texture bends around the object.
Texture anchor: Changes the texture orientation in X-direction to left or right. Requires the 
angle to be less than 360°.

Note: This plug-in is located in: Plugins -> Geom plug-ins -> Default
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To Create a Cylinder

Create a new group container.
Add the Cylinder3 plug-in and open the Cylinder plug-in editor.
Add a material or an image to the Container.
Open the Cylinder plug-in editor and set the desired parameters.
Use the transformation editor to set the container’s position and rotation.

Cyclotron

The Cyclotron (Cyc) plug-in was introduced in Viz Artist 4.0.

There is no need for a designer to change parameters within this plug-in, as it is mainly used in 
combination with Viz Studio Manager and Tracking Hub.

For a detailed explanation on how to use this plug-in, please refer to Working with Holdout and 
Trash Mattes in the Viz Artist User Guide.

DisplacementMap

The DisplacementMap plug-in enables you to create topographical (height) maps by means of a 
grey scale image. The intensity value of the gray scale image is translated to a height value.

Note: This plug-in is located in: Plugins -> Geom plug-ins -> Default

Note: This plug-in is located in: Plugins -> Geom plug-ins -> Default

http://documentation.vizrt.com/viz-artist
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DisplacementMap Properties
Detail: Sets the detail level of the map, the lower the value the higher the level of detail.
Image: Drag the image you want to use creating the map, onto the placeholder. The image 
must be a valid luminance or alpha image.
X-size: Sets the size of the map along the X-axis.
Y-size: Sets the size of the map along the Y-axes.
Height: Sets the height of the map.
Texture X Offset %: Sets the offset of the texture in the X-axis.
Texture Y Offset %: Sets the offset of the texture in the Y-axis.

Texture X Width %: Stretches or compresses the texture in the X-axis ( 0  is not supported, 

instead the default value will be used).

Texture Y Width %: Stretches or compresses the texture in the Y-axis ( 0  is not supported, 

instead the default value will be used).
Patch Mode

Triangle Strip: Uses the same size of triangle polygon on the whole surface.
Optimized Quads: Uses bigger triangle polygons where the surface of the 
displacement map is flat, thereby reducing the total number of polygons and 
improving performance.

Inverse: Mirrors all topographic coordinates through the zero level. This makes a mountain 
top to a crater.
Texture Coordinates: Repeat/Clamp sets if the texture is the be repeated or clamped if it is 
too small to fit onto the displacement maps rectangle. Clamp stretches the texture to make 
it fit, Repeat starts drawing the texture over again when it reaches the end.
Texel Precision

Texel: No subpixel/subtexel correction is made.
Subtexel: There is a limited number of pixels available on the screen, if a line does not 
run through a real pixel, it must be moved to the nearest one, this introduces a 
positional error. If subtexel is selected Viz Artist breaks up pixels into smaller sub 
pixels in memory so that the line can be drawn to the nearest sub pixel.

Smooth: Use this parameter to smooth the look of the map, without reducing the polygon 
details of the map. In some cases you need the number of polygons you have to obtain the 
correct lightning.
Texture Coordinates: Decides if texture coordinates are to be created, and to which level, 
either None, Full or Partially. You need this enabled to some level, if a texture is applied 
using a vertex mapping. Texture mapping is resource consuming, so if you do not need it, 
keep it off.

Note: Please be aware not to increase to number of polygons in detail not too much, 
as this is a common mistake.
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To Create a Displacement Map

Create a new group and add the displacement plug-in to it.
Add material to the group container.
Open the displacement plug-in editor, and drag and drop a gray-scaled image onto the 
image placeholder.
Open the group container’s transformation editor and adjust the Rotation values.

Eclipse

The Eclipse plug-in enables you to create an eclipse shape.

Eclipse Properties
Use LOD: Enables/disables dynamic level of detail.
Corners: Changes the number of triangles the object has. If you want good quality, increase 

the value. A value of 40  is a reasonable value.

Inner Radius 1 and 2: Changes the inner radius in X-Position (1) and the inner radius in Y-
Position (2).
Outer Radius 1 and 2: Changes the outer radius in X-Position (1) and the outer radius in Y-
Position (2).
Hole Offset X, Y and Z: Moves the inner hole to X, Y, Z-position. With this parameter you can 
shape great objects like a volcano.
Rotation: Rotates the eclipse. The result is visible if you change the angle less than 360°.
Angle: Change this to create a view like a cake respectively a divided circle.
Create Uniform Normals: Adapts the varying normals to the majority of normals in same 
direction.

Note: An RGB or similar image does not work, and you get an information in the log 
field. The image must be a valid luminance or alpha image.



Note: This plug-in is located in: Plugins -> Geom plug-ins -> Default
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To Create an Eclipse

Create a new group and add the eclipse plug-in to it.
Add material to the group container.
Open the eclipse plug-in editor, and adjust the following values:

Set Inner Radius 1 and 2 to 40.0 .

Set Hole Offset X to 20.0 .

Open the group container’s transformation editor and adjust the Rotation values.

Fade Rectangle

The Fade Rectangle plug-in creates a rectangle with four sides that can be set to fade in a user-
specified way. Both the degree of fading and the area influenced by the fading can be customized.

Fade Rectangle Properties
Use LOD: Enables/disables dynamic level of detail.
Tesselation: Sets the degree of detail.
Width: Sets the width of the fade rectangle.
Height: Sets the height of the fade rectangle.
Lock Blend: Allows you to decide whether to adjust the blending looked for both the X- and 
Y-axis or single (each axis separately).
Blend Range: Allows you to set the blend range if looked mode is selected.
Blend Range X and Y: Sets the blend range of the X and/or Y axis if single blend is selected.
Blend Factor: Sets the alpha ramp of the fade rectangle. To see the effect set the alpha value

to 0  and adjust the blend factor.

Color: Shows the color of the rectangle. Set the color either in the editor below or drag a 
material from the Server Panel onto the color icon.
Mode: Changes the space perspective.

Note: This plug-in is located in: Plugins -> Geom plug-ins -> Default
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XY (front view)
XZ (bottom view)
YZ (left view)

To Create a Faded Rectangle

Create a new group and add the fade rectangle plug-in onto it.
Add an image to this group.
Open the fade rectangle editor and change the required color through the color parameter 
and adjust the width and the height.

Filecard

The Filecard plug-in creates file cards with different widths and heights and other attributes.

Filecard Properties
use LOD: Enables/disables dynamic level of detail.
Width: Sets the width of the file card.
Height: Sets the height of the file card.
Tab Position X and Y: Sets the tab position in x-direction and y-direction.
Tab Angle: Reduces/increases the size of the curve.
Bevel: Reduces/increases edge softness. Increase this value to get a softer edge.
Tesselation: Changes the number of triangles of the rendered file card to increase the visual 
quality. Please consider that the number of triangles affects the performance of the system.

Note: This plug-in is located in: Plugins -> Geom plug-ins -> Default
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To Create a Filecard

Create a new group and add the file card plug-in to it.
Add a material and/or a texture to the group.
Open the file card editor and set the following parameters:

Set Width to 700.0 .

Set Tab Position X to 70.0 , and Tab Position Y to 60.0 .

Set Tab Angle to 45.0 .

Set Bevel to 25.0 .

Graph

The Graph plug-in allows you to create a 2D or 3D graph with up to 50 values.

Graph Properties
Use LOD: Enables/disables dynamic level of detail.
Width: Sets the width of the graph.
Height: Sets the height of the graph.
Start: Sets the starting point of the graph.
End: Sets the ending point of the graph.
Line Width: Defines the line width.
1st/last segment interpolation: Switches the interpolation of the first and last segment on or 
off.
3D: Enables/disables 3D visualization of the graph.
Extrusion depth: Sets the graph’s extrusion depth.
Add backside: Enables/disables visualization of the graph backside.
Use vertex color: Enables a base color for the graph. Set the values in the color editor or 
drag a material onto the small square below the parameter.
Line color: Enables the use of a vertex color.
X0/Y0 to X49/Y49: Enables up to 50 different value points of the graph by giving 
coordinates on the X- and Y-axis.

Note: This plug-in is located in: Plugins -> Geom plug-ins -> Default
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To Create a Graph

Create a new group and add the graph plug-in to it.
Add a material and/or a texture to the group, or open the graph editor and enable Use 
Vertexcolor and set the Line Color.
Open the graph editor and set the Start and End points.

Enable 3D and set Extrusion Depth to 30.0 .

Add points for the X- and Y-directions (i.e. X0/Y0, X1/Y1 and so on).

Graph2D

The Graph2D plug-in creates 2D and 3D graphs, lines and bars from imported files.

This page contains the following topics and procedures:

Graph2D Properties
To Create a Channel File for a Graph2D
To Create a 2D Graph

Graph2D Properties
use LOD: Renders higher or lower detail for the object. This setting depends on the camera/
object distance, and renders with marginal quality casualties if this toggle is switched on. 
LOD stands for Level of Detail. 
Channel: Affects the Channel File to search for. The file holds the vertex and other data to 
define the whole graph.
Use: Loads the file through a Channel File or remote access.

Note: This plug-in is located in: Plugins -> Geom plug-ins -> Default



Plug-ins User Guide -  5.0

Copyright © 2022  Vizrt Page  94

•

•
•

•

•

•
•
•
•

•
•
•

•

•
•
•

1.

2.

•
•

3.

1.
2.
3.
4.

Max (%): Sets the rage for rendering. For example, if the range is set to 50% the graph is cut 
50% in width.
3D: Enables 3D rendering of the graph, and the Show Back option.

Show Back: Enables the object to show the back in case the object is rotated.
Type: Following types are available: Graph, Line and Bars. Take a change if you want another 
visual depiction. Graph enables the Reduction and Minimum Points settings. Line enables the 
Constant Width, Line Width (%), Reduction (%) and Minimum Points settings. Bars enables the 
Bars Width (%) and Bar Animation settings.

Reduction (%): Reduces points by the Douglas-Peucker algorithm. The Douglas-Peucker 
algorithm is an algorithm for reducing the number of points in a curve that is 
approximated by a series of points.
Minimum Points: Changes the number of points for rendering the graph.
Constant Width: Sets a constant width.
Line Width (%): Changes the width of the line.
Reduction (%): Reduces points by the Douglas-Peucker algorithm. The Douglas-Peucker 
algorithm is an algorithm for reducing the number of points in a curve that is 
approximated by a series of points.
Minimum Points: Changes the number of points for rendering the graph.
Bar Width (%): Changes the width of all bars.
Bar Animation: Renders each bar separately when One by One is selected. Renders all 
bars at the same time when All together is selected.

Use Colors: Sets the color for positive and negative values. This setting is only available for 
graphs and bars (not line).
Show Frame: Shows the frame around the graph. Useful for orientation.
Aspect Ratio: Stretches the graph evenly in x-direction.
Refresh Data File: Reloads the Channel File, which holds the data value for the x- and y-
points.

To Create a Channel File for a Graph2D
Create a text file (for example, CHANNEL2), with no file extension.

Add this data: 5 0 0 10 20 20 0 30 20 40 0 .

The first number (5) holds the number of points available in the file.
The other definitions are the X and Y points -> (0/0), (10/20), (20/0) etc.

Create this directory: <viz data folder>\plug-in\graph2D. and place the channel file in it.

To Create a 2D Graph
Create a new Container.
Add the Graph2D plug-in.
Add a Material and/or a Texture.
Set the Channel parameter to the Channel file (for example: 2 for CHANNEL2).

IMPORTANT! The channel file must always be named CHANNEL<Channel number>.
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Click Refresh data file if the Channel file contents have been modified.

Icosahedron

The Icosahedron plug-in creates a Platonic solid composed of twenty faces that span twelve 
vertices, each face of which is an equilateral triangle. An icosahedron can be considered a rough 
approximation for a sphere.

Icosahedron Properties
Use LOD: Enables/disables dynamic level of detail.
Smooth: Enables smoothing of edges.
Depth: Sets the number of planes at the icosahedron. The more planes you set the more it 
looks like a sphere.
Tesselation: Allows you to choose level of detail setting between Low, Middle and High.

Note: This plug-in is located in: Plugins -> Geom plug-ins -> Default
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To Create an Icosahedron

Create a new group and add the Icosahedron plug-in to it.
Add a material and/or a texture to the group.

Open the Icosahedron editor and disable the Smooth option, set Depth to 3  and Tesselation 

to Middle .

Image FX

The Image FX plug-in enables you to create a wide variety of transitions between one or more 
images. The plug-in uses many different effect models that can be customized through 
parameters. Some properties use advanced mathematical formulas to create the effects, and not 
all of them can be explained meaningfully in normal words. Because of this, not all properties can 
be explained completely here, you need to play with some properties to see the effects they create 
in a given situation (what some properties are set to has impact on the effect that other properties 
give).

The images are split into a number of user-defined sections and every section is controlled 
independently based on progress maps. Any number of images of any Viz Artist supported format 
can be controlled using ImageFx. All images are resized (if needed) to the first image size. The 
image transition order can be modified on the fly and images may be added to the sequence using 
external commands.

Image FX Properties
At the top of the editor you find a set of buttons to switch the properties.

Note: This plug-in is located in: Plugins -> Geom plug-ins -> Default
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Image

Add and Remove: Images dropped onto the Add/Remove drop zone are added/removed as 
sub-containers of the plug-in container in the scene tree.
Load from Scenetree: Loads images that are added directly as sub-containers to the ImageFX 
plug-in container.
Clear all: Removes all sub-containers to the ImageFX plug-in container.

Geometry

The image is split into a number of stand-alone sections that can be modified independently.

Geometry Type: Selects which kind of geometry the images are split up into.
Tiles: GL quads, the number of quads are X tessellation times Y tessellation.
Mesh: (vertices) GL quad strip, the number of vertices are (X tessellation +1) times (Y 
tessellation +1). Modification can apply to every vertex in the mesh.
Triangles: GL triangles, the number of triangles are X tessellation times Y tessellation 
times 2. Modification can apply to one triangle (3 vertices).
Random Triangles: GL triangles, triangles are generated using random points. Number 
of triangles is a minimum of X tessellation times the Y tessellation. Modification can 
apply to one triangle (three vertices).
Random Seed: Is relevant if you have chosen random triangles. It specifies a seed for 
the random number generator. Even though Viz Artist use random numbers, the 
layout of a specific random seed always looks the same. Press the wireframe button 
and click the new random seed button to see the effect.

Tessellation: Sets the degree of detail (enable wireframe to view the effect).
Spacing: Sets a spacing between the geometrical parts in the image.
Border: Draws a border with the width defined here between single sections if spacing has a 
value.
Crop: Enables/disables cropping of the border.
Alpha: Sets an alpha value for the border.
Color: Sets a color for the border.

Trigger

In the trigger section, you can select between different progress maps that defines how every 
section of the image is to be triggered by the global progress. Each section of the image receives 
its base value, the global progress is a value that changes as you animate by using one of the 
options in the control menu. Since every section gets a different base value, it is triggered 
differently by the global progress.

Example: In a domino effect which starts at the bottom left the section at the bottom left 
receives a value of 100 and the section at the top right receives a value of 1. As the 
progress moves, sections with high values are influenced, fast then sections with low 
values. If we continue with the above example with a fade effect, the bottom left section 
fades out when progress is 20, but the top right section only fades out when progress is 
100.
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The options for progress maps are:

Clock: Sets the values for the sections that are computed based on a clock hand movement. 
It has the following properties:

Center: Sets the center for the clock hand movement.
Start Angle: Sets the starting angle for the clock hand.
Whirl: Applies a whirl effect to the movement.
Direction: Sets the direction for the clock hand movement.

Domino: Sets the values for the sections that are computed based on a domino movement. It 
has the following options:

Order: Sets the order in which the tiles are moved. Choose between Lines (Line by line 
movement), Columns (Column by column movement, Center (From center and 
outwards movement), Bottom Left (Bottom left tiles first and then diagonal movement 
towards top right corner) or Top Left (Top left tiles first and then diagonal movement 
towards bottom right).
Direction: Sets the starting point of the movement.

Noise: Sets the values for the sections that are computed based on user-defined noise map 
created using noise algorithms (perlin noise).

The settings create a noise texture and the image transformations are based on this 
image.
When you edit the noise properties it is a good idea to enable the show button. This 
lets you see the images that are created and see changes instantly.
Wave, Cloud, Marble and Noise are predefined noise parameter settings. It is normally 
a good idea to start with one of these and thereafter edit until you get the required 
effect. The four images below show how the four noise parameters look like when the 
show option is enabled:

Turbulence 1 to 3: Sets the noise level. The settings must be played with to see what 
kind of effect you get as they influence each other. So what effect one gives depends 
on the state of the other.
Frequency: Defines something that can be described as the “wave length” of the noise 
function. A large number gives a small wave length which creates a lot of changes to 
the image, while a small number creates a smoother image.
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Exponent: Controls the ratio between the white areas and the black areas without 
changing the shape significantly. Exponent zero give a full white picture, and as the 
value grows, the black area becomes larger and larger.
Scale X/Y: Are quite similar to the usual texture scale, but they are working with 
reverse logic. In the usual texture scaling, increasing the scale is like zooming into the 
image, but in Image FX it works like zooming out. Also the units are different, but 
beside this, they are quite similar.

Random: Computes the values for the sections randomly.
Image: Computes the values for the sections based on pixel values of an image you drag 
onto the drop zone. What the function does is to create links between the animated image 
tiles and the pixels of the image and then use the luminance level of each pixel to set the 
base value for the tiles. By default 100% luminance sets high base value and 0% sets a low 
base value. This option allows you to generate any progress map you want by using other 
tools.
Static: Gives all sections the same value. The complete image moves out and the other 
moves in.
Random Seed: Specifies a seed for the random number generator. Is relevant if you have 
chosen random order. Even though Viz Artist uses random numbers, the animation for a 
specific random seed always looks the same.

Effect

The trigger section defined the order in which the tiles would be influenced by the global process. 
The effect section allows you define what kind of effect/transition that is used.

Target Image
Static: The target image is not effected at all the by the effect. A typical example 
would be a reveal effect where target image is “hidden” behind main image and a 
transition effect on the main image reveals the target image.
Dynamic: The target image is controlled by the effect. A typical example would be 
main image flying out of the frame and at the same time target image flying in. If a 
dynamic target image is used, its effect can be either being the invert of main image 
or can be defined separately.

Interpolate
Linear: A linear interpolation is used for the transformations.
Smooth: A smooth interpolation is used for the transformations.

Position > Move: You can specify a position for the source image, for the target image and a 
random position.

For the source image, which is the image that is currently shown, you specify a source 
position. This is the position that the image tiles move to when the animation runs.
If no target position is specified, the target image animates from the source position 
to the initial position of the source image.
If you specify a target value the target image moves from that position and onto the 
initial position of the source image.
Switch on X, Y and Z to alter the values.
Absolute: All sections move to the same end position.
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Relative: The sections maintain their original relationship.
Position > Explode: Final positions for the sections are calculated based on a user-controlled 
explode algorithm. The tiles of the image are treated as particles in an explosion and they 
are moved in one to three axis depending on what you specify. All tiles are thrown out of a 
emitter that can be defined to have any opening angle, so the particles can be sent within a 
narrow angle, like a canon fire, or in all direction like a explosion. The parameters are:

Duration: Sets the duration for the movement of the tiles/particles.
Opening Angle: Sets the opening angle for the emitter. Remember to choose more 
than one axis to get any clear effect.
Angle Rotate X: Rotates the emitter hole on the X-axis.
Angle Rotate Y: Rotates the emitter hole on the Y-axis.
Force sets the degree of force that throws the particles out in space.
Force Spread %: Randomizes the initial impels of the tiles. Spread 0 % means all items 
have the same impulse, 100% means a high degree of randomness.
Gravity: Sets a gravity force for the environment.
Use Axis: Selects which axes or axis to use.

Rotation: Rotates the sections.
Scaling: Scales the sections.
Alpha: Changes the alpha value of the sections from Alpha Start to Alpha End.
To all options (except alpha) a certain degree of user-controlled randomness can be added.

Random Seed: Specifies a seed for the random number generator. Is relevant if you have a 
random property. Even though Viz Artist uses random numbers, the animation for a specific 
random seed always looks the same. 
The final effect of transformation can be a combination of effects where the timing between 
the different effects can be tuned using the mini-stage. Move the start and end Key Frames 
to time the effects.

The pivot properties have relevance when you use rotation on the tiles. The settings decide where 
the rotation center should be on the tiles. To see the effect, create a low tessellation transition 
with tiles and a 180 degree X or Y rotation. Change the pivot properties for Y pivot if you have an 
X rotation or the X pivot if you have an Y rotation and see the effect.

Control

The global progress value that is used to animate the sections can be controlled in different ways:

Auto: When using auto mode, ImageFx starts the effect as soon as the Take button is 
pressed. Useful for external control to run a sequence of images.
Animation: The global progress value is animated and the effect follows the stage progress. 
In this mode you can combine the effect animation with other animations.
Global Animation: When using a sequence of images, the complete progress animates all 
images.

Example: A position explode effect can be combined with a rotation effect so the sections 
rotate as they explode. An alpha effect can be added to fade out the sections at the end.
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To Add, Load and Remove Images
Add the images you want to create transitions between by dragging them from the Server 
Panel and dropping them onto the Add drop zone.

The added images are visible in the scene tree as sub-containers of the ImageFX plug-
in container.

To add images directly as sub-containers to the plug-in container you must click the Load 
from Scenetree button to make the plug-in recognize the added images.
Remove images by dragging them from the Server Panel and onto the Remove drop zone, or 
simply remove them directly from the scene tree.
To remove all, click the Clear all button.

Noggi

The Noggi plug-in creates geometry objects of beveled rectangles with some attributes.

Noggi Properties
Width: Changes the width in X-direction.
Height: Changes the height in Y-direction.
Bevel (top/right, top/left, bottom/left and bottom/right): Changes the bevel on each corner.
Stretch: The result is an object like a parallelogram. Stretch is in percent (= tan(alpha)). If 
Geometry Type is Outline.
Horizontal Alignment: Changes the object alignment to left, center or right. This change 
affects the y-rotation.
Vertical Alignment: Changes the object alignment to bottom, middle or top. This change 
affects the x-rotation.
Geometry Type: Renders the object as area- or with outline look.
Inner Outline: Changes the vertex sequence in outline mode. Inner Outline is important for 
face orientation when extruding the geometry.
Outline Width: Changes the thickness of the rendered outline.
Edge Points: Change the number of triangles to render a beveled corner. Increasing the 
number increases the bevel resolution.
Crop: Enables/disables cropping of the object. Cropping and vertex texture are only 
available if Geometry Type is Area.

Crop Face (Left, Right, Bottom and Top): Crops the object on each given side.

Note: This plug-in is located in: Plugins -> Geom plug-ins -> Default
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To Create a Noggi

Create a new group and add the Noggi plug-in to it.
Add a material and/or a texture to the group.

Open the transformation editor and set Position X to -150.0 .

Open the Noggi editor and set the following parameters:

Set Width and Height to 600.0  and 100.0 .

Set Bevel top/right and bottom/left to 0.0 .

Set Bevel top/left and bottom/right to 20.0 .

Pointer

The Pointer plug-in is similar to the Arrow plug-in. The main difference is that the pointer has a 
joint link, so it looks more like a bend arrow. The pointer has two reference points which controls 
the pointer’s position. The first point is in the joint link and the second point is at the arrow’s 
head.

Pointer Properties
Use LOD: Enables/disables dynamic level of detail.
Point 1 X: Sets the position of point 1 on the X-axis.
Point 1 Y: Sets the position of point 1 on the Y-axis.
Point 2 X: Sets the position of point 2 on the X-axis.
Point 2 Y: Sets the position of point 2 on the Y-axis.
Width: Sets the width of the pointer shaft.

Note: This plug-in is located in: Plugins -> Geom plug-ins -> Default
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Cap Style Begin: Allows you to select the style on the pointers beginning. The options 
are Flat, Circle or Arrow.
Cap Style End: Allows you to select the style on the pointers end. The options 
are Flat, Circle or Arrow.
Arrow Length: Sets the length of the arrow head.
Arrow Width: Sets the width of the arrow head.
Circle Radius: Sets the radius of the circle, if cap style is selected.
Circle Segments: Sets the resolution of the outer side of the pointer angle. Switch to 
wireframe to see the effect as you change the value.
Joint Style: Sets the style of the pointer joint, either Round or Miter.

To Create a Pointer

Create a new Container.
Add the Pointer plug-in to it.
Add a material and/or a texture to the group.
Open the Pointer editor and set the following parameters:

Set Point 1 X and Y to 50.0 .

Set Point 2 X and Y to 75.0 .

Set Width to 20.0 .

Set Cap Style Begin and End to Circle  and Arrow , respectively.

Set Arrow Length, Width and Radius to 50.0 .

Polygon

The Polygon plug-in enables the creation of user-defined polygon geometry shapes. The polygons 
are drawn and edited directly in the Scene Editor. Created Polygons can also be rotated to create a 
3D object (see Revolve: Spline Rotation in 3D).

To create a Polygon, add the Polygon plug-in to a container and start drawing by clicking in the 
Scene Editor to create polygon nodes. A click, hold and drag converts the node into a spline handle 
for drawing curves. If an existing node is clicked on it removes the node, and if a line or spline is 
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clicked on, between two nodes, it inserts a new node at this location. There are several Polygon 
plug-in Editor Shortcuts, documented in the Viz Artist User Guide. If more than one polygon is 
created, in the same container, and if they overlap each other, they act as masks.

Instead of drawing polygons manually, they can be imported as Adobe Illustrator files (*.ai) as well. 
If your external design tool does not support the *.ai format, consider importing your polygon as a 
geometry (see Geometry Import in Viz Artist User Guide).

This page contains the following topics and procedures:

Polygon Properties
Polygon Scene Editor Context Menu
To Select an Option from the Context Menu
Create a Polygon

Polygon Properties
Precision: Sets the precision of the spline calculation.
Import: Imports Adobe illustrator files. Opens a window to select a file and import. Only 
Adobe Illustrator AI 88 format files are supported.
Revolve: See Revolve: Spline Rotation in 3D.
Storage: Creates a Spline with coordinates. Press ENTER to apply.

To Toggle Between Polygon And Container Properties

Click the Polygon or Transformation icon in the:
Scene Tree Container, or
The Properties panel

Note: Only Adobe Illustrator AI 88 format files are supported.

Note: This plug-in is located in: Plugins -> Geom plug-ins -> Default

http://documentation.vizrt.com/viz-artist
http://documentation.vizrt.com/viz-artist
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In the Scene Editor:
Outside the polygon bounding box: Right click and select Properties > Geometry.
Inside the polygon bounding box: Right click and select Edit container.

Polygon Scene Editor Context Menu
Right-click, and hold, in the polygon green bounding box, in the Scene Editor, to open the polygon 
context menu. To select a menu option see To Select an Option from the Context Menu.

New spline: Creates a new polygon in the same container.
Close/Open: Opens or closes a polygon.
Cut: Cuts the selected polygon or spline nodes.
Copy: Copies the selected polygon or spline nodes.
Paste: Pastes the selected polygon or spline nodes.
Mirror X/Mirror Y: Mirrors the created shape in the X or Y axis.
Flip x/Flip y: Flips the created shape in the X or Y axis.
Edit container: Opens the Container editor and exit polygon edit mode. To edit the polygon 
again, click on the polygon icon in the properties editor or the Scene Tree.

To Select an Option from the Context Menu
Right-click and hold.
Move the cursor to the required option.
Release to select.

Note: The right-click must be inside the created polygon shape box. If a click is outside the 
bounding box then the standard Scene Editor menu is shown.
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Create a Polygon
This section contains the following procedures:

To Create A Simple Spline

Create a Container.
Add the Polygon plug-in.
Click on the Polygon icon (in the Container or the Properties editor).
The polygon splines are created by each click in the Scene Editor:

Click in the Scene Editor to create a spline point
Click and drag in the Scene Editor to create a spline node, complete with handles 
(continue the drag to increase the length of the handles)

While the polygon plug-in is active, each click in the Scene Editor creates more polygon 
points, and creates the polygon shape.

Once the spline has been created it can be modified, as required, with various shortcuts 
(see Polygon plug-in Editor Shortcuts in the Viz Artist User Guide). List below are some 
common examples:

Tip: At any time press and release DELETE to remove the last created point. Press 
and hold DELETE to remove more than one spline, or remove the whole polygon.



http://documentation.vizrt.com/viz-artist
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To Draw A New Spline

Right-click in an existing spline.
Click New Spline.
Add intersections as detailed in To Create a Simple Spline.

To Move A Spline

Select the spline to be moved:
Press S and click on a spline.

Press ALT and drag.

To Move More Than One Spline

Select the splines to be moved:
Press S and drag around the splines.

Press ALT + S and drag.

To Add Or Delete A Spline Point

Click anywhere on a spline to add another spline point.
Click on a spline point to delete it.

To Move Spline Points

Press and hold CTRL.
Click on a spline point and drag. When CTRL is pressed move any spline points as required.

To Create Or Delete A Spline Point Handle

Press SHIFT:
Create: Click on a spline point and drag.
Delete: Click on a spline point with a handle.

To Resize A Spline Point Left Or Right Handle

Press SHIFT.
Click on a spline point handle and drag. Only the selected handle moves.

To Resize A Spline Point Handle

Press CTRL.
Click on a spline point handle and drag. The left and right handles move as one handle.

Tip: If there is only one spline in the Container, press ALT and drag.

Note: The handle clicked on can be lengthened as required. The other handle 
remains the same length.
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To Mirror Spline Sections

Right-click on a spline, or select particular nodes of it with S.
Select either:

Mirror X: Mirrors whole spline along the X axis.
Mirror y: Mirrors whole spline along Y axis.

To Flip A Spline

Right-click on a spline.
Select either:

Flip x: Flips whole spline over X-axis.
Flip y: Flips whole spline over Y-axis.

Scene Editor Grid

The Scene Editor Grid Tool-bar can be used as a great tool to help draw polygons. Together with 
the grid snap option polygon points can positioned, simply and accurately, in the 3D space.

Make sure that the polygon is aligned with the grid for the grid snap to work.

To Create A Spline In The Scene Editor Grid Snap

In the Scene Editor click   (Grid).

Click   (Plane Type).

Click   (Free Grid).

Click   (Snap to Grid).
Create a spline. Each spline point snaps to the nearest cross hairs on the grid.

To Move A Spline In The Grid With Snap

In the Scene Editor click   (Grid).

Click   (Plane Type).

Click   (Free Grid).

Note: If either the left or right handle has been moved individually, this sets the two 
handles together again.
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Click on   (Move Object to Plane).
Press ALT.
Click on the Spline and drag.

The Spline snaps to the next set of cross hairs, and so on, as it is dragged.

Revolve: Spline Rotation In 3D

The Spline rotation creates a 3D mesh by rotating the created spline.

Use the Polygon Revolve Properties panel to modify the Spline as required.

Polygon Revolve Properties

The Polygon Revolve properties are available after the first spline point has been added to the 
Scene Editor. Click on Rotate to activate.

Precision: Sets the precision of the spline calculation.
Import: Imports Adobe illustrator files. Opens a window to select a file and import. Only 
Adobe Illustrator AI 88 format files are supported.
Rotate: Creates the revolve mesh and activate all its settings.

Rotate in degrees box: Sets the degree of rotation.
Tessellation: Sets the degree of detail for the mesh.
Shading Angle: Defines how the shading normal are aligned on the revolve object surface.
Culling: Sets which side of the spline to view:

Back: View the back side of the spline.
Front: View the front side of the spline.

Revolve Around: Sets the axis to rotate the spline around.

Note: If there is more than one Spline to be moved see Polygon.

Note: To view both sides at the same time, add the Expert plug-in to the 
Container and active Back Face.
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Local Axis: Calculates the rotation around the Container axis when the Rotation angle 
is changed.
First to Last: Rotates around the first and last spline point (Revolve Axis is grayed 
out) when the Rotation angle is changed.

Revolve Axis: Sets which axis to rotate around:
Y: Rotates around the Y axis.
X: Rotates around the X axis.

Direction: Sets which direction to view the rotation:
Right-hand: View from the right hand side.
Left-hand: View from the left hand side.

Show Hull: Shows the rotated shape (1 and 2).
Show Caps: Shows the original polygon shape at the beginning and end of the rotation (1 
and 3).

To Rotate A Spline

Create a spline.
Click on Rotate.
Modify the created 3D object with the Polygon Revolve Properties.
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See Also

Revolve: Spline Rotation in 3D

Quad

Quad is a very efficient basic 1x1 geometry used mainly for holding textures. It only renders a 
basic set of vertices and texture coordinates, nonormals, binormals, tangents. Its main purpose is 
to hold basic images with Phong Materials. By default, it renders a 1x1 pixel surface and need to 
be scaled up correctly.

Rectangle

The Rectangle plug-in creates a 2D rectangle with some attributes.

Rectangle Properties
Use LOD: Enables/disables dynamic level of detail.
Tessellation: Sets the degree of detail.
Bevel: Enables and sets the degree of bevel at the rectangle edges. Bevel may have an effect 

on the height of the rectangle. For example, if Height is set to 100.0  and Bevel is set to 

51.0 , the effective height is 102.0 .

Width: Sets the width of the rectangle.
Height: Sets the height of the rectangle.
Corners: Sets the number of corners the rectangle is build up from, it become visible, when 
you set a bevel on the rectangle.
Use Vertexcolors: Enables you to set the four color parameters below. If this option is set, 
the rectangle does not respond to container color anymore.
Upper Left: Sets the color and alpha of the upper left section of the rectangle. Press the 
colored button to enable color editing on that section and change the color in the color 
editor below. You can also drag a material from the Server Panel and onto the color icon.
Lower left: Sets the color and alpha of the lower left section of the rectangle. Press the 
colored button to enable color editing on that section and change the color in the color 
editor below. You can also drag a material from the Server Panel and onto the color icon.

Note: This plug-in is located in: Plugins -> Geom plug-ins -> Default

Note: This plug-in is located in: Plugins -> Geom plug-ins -> Default
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Upper Right: Sets the color and alpha of the upper right section of the rectangle. Press the 
colored button to enable color editing on that section and change the color in the color 
editor below. You can also drag a material from the Server Panel and onto the color icon.
Lower Right: Sets the color and alpha of the lower right section of the rectangle. Press the 
colored button to enable color editing on that section and change the color in the color 
editor below. You can also drag a material from the Server Panel and onto the color icon.

Mode: Sets the orientation of the plane to XY, XZ or YZ.

To Create a Rectangle

Create a new group and add the Rectangle plug-in to it.
Add a material and/or a texture to the group, and/or open the Rectangle plug-in editor and 
enable and set the vertex colors.

Open the transformation editor and set Position Y to -150.0 .

Open the Rectangle editor and set the following parameters:

Set Bevel to 15.0 .

Set Width to 600.0 .

Set Height to 30.0 .

Ring

The Ring plug-in creates an open or closed ring with some attributes.

Ring Properties
Use LOD: Enables/disables dynamic level of detail.
Corners: Sets the number of corners on the ring.
Inner Radius: Sets the size of the inner radius.
Outer Radius: Sets the size of the outer radius.

Note: This plug-in is located in: Plugins -> Geom plug-ins -> Default
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Rotation: Rotates the ring like a “turning wheel”. This is typically used in combination with 
an open angle, to place the angle at the required point.
Angle: Defines an open angle on the ring.
Mode: Changes the object view coordinate. Available options are XY, XZ and YZ.

To Create a Ring

Create a new group and add the Ring plug-in to it.
Add a material and/or a texture to the group.
Open the Ring plug-in editor and animate the Angle.

Set Angle to 0.0  (60/50 fps).

Set Angle to 360.0  (120/100 fps).

Roll

The Roll plug-in allows you to create a rectangle that rolls up in different ways. This is typically 
used for different kinds of unveiling. To make the roll look realistic, the expert plug-in must be 
added to the container to enable visualization of backface and two-sided lightening.

Roll Properties
Use LOD: Enables/disables dynamic level of detail.
Size X: Sets the size of the rectangle on the X-axis.
Size Y: Sets the size of the rectangle on the Y-axis.
Tesselation: Sets the level of detail.
Angle: Sets the angle of the rolling up.
Diameter: Sets the diameter of the roll.
Helix factor: Defines how tight the roll is to be rolled up. With a high helix factor, there is 
space between the layers of the roll.
Drawing: Selects how the roll rectangle is to be drawn up. If you switch to wireframe mode 
and toggle between the two settings you see the difference:

Segments: Draws the rectangle up by using many long lines stretching from edge to 
edge. This mode does not look as good as Mesh but it demands less performance of 
the render engine.

Note: This plug-in is located in: Plugins -> Geom plug-ins -> Default
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Mesh: Draws the rectangle using many small equally sized triangles. The number and 
size depends on the level of tessellation selected. This drawing mode can be heavy to 
render if the tessellation is set high. Mesh creates a better lightning of the roll 
rectangle.

Style: Sets the style of the roll:
Cigar roll: Makes the rectangle roll up in a normal manner.
Wipe: Rolls the carpet up without creating a roll.

Outline: Enables an outline view for the roll. You must in addition add the expert plug-in and 
enable the outline setting there.
Time: Sets the time for the roll sequence. Animate this value to create an animation of the 
roll object. To learn more about animation, see the Create Animations section of the Viz 
Artist User Guide.

To Create a Roll

Create a new group and add the Roll plug-in to it.
Add the Expert plug-in to the group.

Open the Expert editor and enable ( On ) the Back Face property.

Add a material and/or a texture to the group.
Open the Roll editor and set the following parameters:

Set Size X to 150.0 .

Set Size Y to 20.0 .

Set Angle to 10.0 .

Adjust the Time parameter to see the roll effect.

Sphere

The Sphere plug-in creates a simple sphere with some attributes.

Sphere Properties
Use LOD: Enables/disables dynamic level of detail.
Tessellation: Sets the degree of detail for the sphere.

Note: This plug-in is located in: Plugins -> Geom plug-ins -> Default

http://documentation.vizrt.com/viz-artist
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Rotation: Allows you to rotate the sphere around its Y-axis.
Open Angle: Allows you to create an open angle in the sphere.
Texture: Allows you to select between three different positions of the texture mapping 
coordinates when a vertex texture is mapped onto the sphere. To visualize the effect of the 
different settings, add a plain texture onto the sphere, like a chessboard image and set the 
texture mapping to vertex in the texture editor. Create an opening in the sphere and change 
the sphere texture parameters. Increase and decrease the opening angle with the different 
settings enabled and the effect should be visible.

Absolute: Compresses and expands the texture mapping coordinates as the opening 
of the sphere changes.
Relative: Cuts/adds texture coordinates as the opening changes. The cut/add is done 
on the one side of the opening angle. The coordinates are anchored at the other side.
Centered: Does the same as the relative mapping, but cuts/adds coordinates from 
both sides. The texture is anchored in a centered position on the sphere. The center 
of the sphere is 180° from the point where the opening angle starts.

Spline Path

The Spline Path plug-in creates complex paths with an arrow look.

Spline Path Properties
use LOD: Enables/disables dynamic level of detail.
Node: Defines the node index. For example, node 3 or node 25.
X, Y and Z: Sets the 3D point to define a node.
Length: Stretches the entire path in X-direction.
Width: Stretches the entire path in Y-direction.
Threshold: Increase this value if you do not need a high path accuracy but more 
performance.
Add, Move, Remove and Clear: Add adds a new node with an specific index. Move moves an 
existing node to another X, Y or Z-point. Remove removes an existing node. Clear clears all 
nodes.
Mode: The following options are available:

Tube: Renders the entire object.
Band XY: Renders only the front side.
Band XZ: Renders only the top side.
Band YZ: Renders only the left side.

Arrow: Creates an array look.

Arrow Length: Sets the arrow length (only when Arrow is set to On ).

Note: This plug-in is located in: Plugins -> Geom plug-ins -> Default



Plug-ins User Guide -  5.0

Copyright © 2022  Vizrt Page  116

•

•

1.
2.
3.
4.
5.
6.
7.

8.

9.

10.

11.

12.

13.

14.

15.

•

•

Arrow Width: Sets the arrow width (only when Arrow is set to On ).

Texture Stretching Mode: 

To Create a Spline Path

Create a new group container.
Add the Spline Path plug-in.
Add the Expert plug-in.
Open the Expert editor.
Set Back Face to On.
Add a Material and/or a Texture to the group.
Open the Spline Path editor.

Set Node to 0  / X to 50.0  / Y to 50.0 .

Click Add.

Set Node to 1  / X to 150.0  / Y to 25.0 .

Click Add.

Set Node to 2  / X to 250.0  / Y to 10.0 .

Click Add.

Set Node to 3 , X to 350.0 , Y to 45.0 .

Click Add.

Spline Strip

The Spline Strip plug-in creates 3D interactive loft extrusions which are able to be animated in 
their length and surface. You can use modifiable lines, circles or rectangles for the extrusion. 
Arrows and terrain alignment are also supported.

Spline Strip Properties
Path Node Index: Defines where Path Nodes get added, moved or removed. The first node 
within a path owns the index 0. If you add nodes at the end, then the Path Node Index is 
increased automatically to provide a simple path generation.
X, Y and Z: Sets the Path Node’s X, Y and Z-position.

Note: This plug-in is located in: Plugins -> Geom plug-ins -> Default
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TC: Sets the Path Node’s TC-position.
Add Node: Adds a path node at the current Path Node Index with position X, Y, Z and TC.
Move Node: Moves the current path node to your required X, Y, Z and TC position.
Remove Node: Removes a path node at the current Path Node Index.
Interactive Mode: If you have finished the process of setting path nodes then you are able to 
edit it simpler by mouse. Just drag and drop the shown nodes to a new position. Left Mouse 
Button: move node in XY. Middle Mouse Button: move node in XZ.
Interactive Orientation: World, Local, View. Move nodes interactive with world-, local-, or 
viewpoint- coordinates.
Node Size: Sets the interactive node’s size.
Storage: Is used for storing your defined path nodes in a #-separated string. It is possible to 
edit nodes directly in the Storage Text field.
Clear Storage: Clears the spline strip object and its storage.
Use Time Code: Activates Time Code functionality.
TC Current: Contains the current Time Code of an external Time Code source.
TC Start: Sets the starting point of your Time Code animation.
TC Reference: If you are using more than one spline strip then they probably won’t start all 
at the same Time Code position. But you can change that by a simple time shift with the 
Help of TC Reference.
Path Steps: Defines SplineStrip tessellation.
Use Threshold: You can optimize your spline strip with that option. Path Steps are added at 
necessary positions only. So the number of Path Steps increases with a decreasing 
Threshold.
Threshold: Sets the Threshold for Path Steps generation.
Path Start: Sets the starting point of the path geometry.
Path Length: It defines the length of our spline strip object. Feel free to animate that value!
Path Alignment: Fits the spline strip to Terrain plug-ins in Viz Artist/Engine. (e.g. use Terrain 
for drawing paths over a mountain). Available options are; Free and Topography.
Surface Offset: Shifts Path on Y axis.
Use Surface Normal: If activated then the surface offset is computed via terrain normals.
Show Path: Shows the Path which you have defined at the beginning. This option is quite 
helpful when you are editing Path Nodes.
Shape Type: If you activate the Organic Mode, your spline strip starts to wobble in 
dependency of the adjusted Organic Amplitude, Organic Speed, and Organic Period’s 
Length. Available options are; Static and Organic.
Shape: Defines the shape used for the loft extrusion. Available options are; Line, Circle and 
Rectangle.
Shape Width: Sets the shape’s width.
Shape Height: Sets the shape’s height.
Shape Tesselation: Defines how many steps are used to draw the required shape.
Shape Rotation: You are able to move the spline strip shape up to 360 degrees.
Shape Orientation: When set to Free, shapes are rotated in dependency of the adjusted 
Shape Rotation value. When set to XZ, YZ or YX, shapes are auto rotated to obtain a constant 
SplineStrip width in the required aspect. When set to Terrain, shapes are rotated to fit the 
terrain beneath them.
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Translate Vertices To Terrain: Moves every single vertex to fit the terrain. This mode only 
makes sense if you are using Line extrusion.
Flip Normals: Flips spline strip normals.
Backface Culling: Switch off drawing spline strip’s backside.
Organic Amplitude: Adjusts the animated diameter reduction from 0% to 100%.
Organic Speed: Changes speed of organic mode animation. Also negative values are allowed.
Organic Period’s Length: Sets the diameter reduction function’s period length.
Termination: Closes our spline strip object at the Beginning, End or at Both sides. Available 
options are; None, Beginning, End and Both.
Arrow: Puts an Arrow to the Beginning, End or Both sides. Available options are; None, 
Beginning, End, Both
Object Width: Changes arrow width.
Object Height: Changes arrow height.
Object Length: Changes arrow length.
Object Tesselation: Changes arrow tessellation.
Generate Texture Coordinates: Activate this function if you are using vertex maps on your 
spline strip.
Stretch Texture to Path Length: If activated then the map is stretched to the actual path 
length.
Draw Mode: Switch between fill- and wire-frame mode. Available options are; Fill and Wire.
Buffer Geometry: The whole spline strip data is buffered to memory. If you use spline strips 
with a huge number of vertices then Buffer Geometry is able to improve performance. 
Activate this mode only if you do not use any kind of animation in your current spline strip.
Color: Defines path’s and interactive-mode-node’s color. Color is also used if Wire is 
activated and no maps are applied onto your spline strip object.
Child Distance: Defines distance between path end and child container.
Rotate Child: Activates child container rotation.

To Create a Simple Spline Strip
Create a new Container.
Add the Spline Strip plug-in.
Open the Spline Strip editor.
Use all default values.
Click Add Node.

Change X to  100.0 .

Click Add Node.

Change X to  200.0 , Y to  50.0 .

Click Add Node.

Set Shape Width and Shape Height to  50.0 .

Set Shape to Circle.

Set Shape Tesselation to  20 .



Plug-ins User Guide -  5.0

Copyright © 2022  Vizrt Page  119

13.

14.

15.

16.
17.

•
•
•
•
•
•
•
•
•

Set Path Length to  150 .

Optionally, click Interactive Mode.

Change Node Size to for example  15.0 .

Activate script and plug-in events in the Scene Editor by clicking the E button.
Drag and drop the small Cubes as required.

Spring

The Spring plug-in creates a spiral spring geometry. Be aware this object can easily be very heavy 
to render if a high level of tessellation and corners are selected.

Spring Properties
Use LOD: Enables/disables dynamic level of detail.
Tessellation: Sets the degree of detail for the spring.
Corners: Sets the number of corners the spring should have.
Gradient: Sets the size of the spring gradient.
Diameter torus: Sets the diameter of the springs.
Diameter cross section: Sets the diameter of the spring cord.
Show Bottom: Shows/hides bottom of the spring.
Show Top: Shows/hides Top.
Center: Sets the location of the spring center: Either Center, Bottom or Top.

Note: This plug-in is located in: Plugins -> Geom plug-ins -> Default
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To Create a Spring

Create a new group and add the Spring plug-in to it.
Open the Spring editor and set the following parameters:

Set Turns to 6.0 .

Set Gradient to 20.0 .

Set Diameter torus to 200.0 .

Set Diameter cross section to 100.0 .

Set Center to Center .

Add a material and/or a texture to it.

Star

The Star plug-in creates a star with different attributes.

Star Properties
Corners/Tips: Sets the number of corners on the inner circle of the star (equals the number 
of tips on the outer circle of the Star). Default: 5, Min: 3, Max: 300.
Star Radius: Sets the radius of the outer circle (where the tips of the star are located). 
Default: 50, Min: 1, Max: 200.
Star Inner Radius Factor: Determines the factor of the outer radius to the inner radius of the 
star. A value of 1.0 means that the inner radius of the star is identical to the Star 
Radius value. Default: 2, Min: 0.25, Max: 50.

Note: This plug-in is located in: Plugins -> Geom plug-ins -> Default
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Hole: Places a hole in the Star geometry. Default: 0 ( Off ).

Hole Radius: Sets the radius of the outer circle where the tips of the hole are located. 
Default: 25, Min: 1, Max: 200.
Hole Inner Radius Factor: Determines the ratio of the outer radius to the inner radius of the 
hole. A value of 1.0 means that the inner radius of the hole is identical to the Hole Radius. 
Default: 2, Min: 1, Max: 50.

To Create a Star

Create a new container.
Add the Star plug-in to it (1 (default Star)).
Open the Star editor.
Modify the Star parameters, for example (2).

Corners: 10 .

Star Radius: 60 .

Star Inner Radius Factor: 6.0 .

Hole: On .

Hole radius: 50 .

Hole Inner Radius Factor: 9.0 .

If required, add a material and/or a texture.

Torus

The Torus plug-in creates a torus with different attributes.

Note: This plug-in is located in: Plugins -> Geom plug-ins -> Default
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Torus Properties
Use LOD: Enables/disables dynamic level of detail.
Tesselation: Sets the degree of detail for the torus.
Corners: Sets the number of corners on the torus.
Radius: Sets the radius of the torus from its center in the middle of the hole.
Radius cross section: Sets the radius of the torus cross section or “tube”.

To Create a Torus

Create a new group and add the Torus plug-in to it.
Open the Torus editor and set the following parameters:

Set Radius to 50.0 .

Set Radius cross section 20.0 .

Add a material and/or a texture to it.

Triangle

The Triangle plug-in creates a simple 2D triangle with some attributes.

Triangle Properties
Use LOD: Enables/disables dynamic level of detail.
X1: Sets the x-coordinate for the first corner of the triangle.
Y1: Sets the y-coordinate for the first corner of the triangle.

Note: This plug-in is located in: Plugins -> Geom plug-ins -> Default
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X2: Sets the x-coordinate for the second corner of the triangle.
Y2:  Sets the y-coordinate for the second corner of the triangle. 
X3:  Sets the x-coordinate for the third corner of the triangle. 
Y3:  Sets the x-coordinate for the third corner of the triangle.
X1=X2: Sets the same x-coordinate for the first and second corners of the triangle.
Y1=Y2:Sets the same y-coordinate for the first and second corners of the triangle.
Y1=Y3: Sets the same y-coordinate for the first and third corners of the triangle.
Y2=Y3: Sets the same y-coordinate for the second and third corners of the triangle.
Use Vertexcolors: Enables/disables setting color parameters for the corners of the triangle. If 
this option is set, the triangle does not respond to container color anymore.

Color 1: Sets the color and alpha of the first corner of the triangle. Press the colored 
button to enable color editing on that section and change the color in the color editor 
below. You can also drag a material from the Server Panel and onto the color icon.
Color 2: Sets the color and alpha of the second corner of the triangle. Press the 
colored button to enable color editing on that section and change the color in the 
color editor below. You can also drag a material from the Server Panel and onto the 
color icon.
Color 3: Sets the color and alpha of the third corner of the triangle. Press the colored 
button to enable color editing on that section and change the color in the color editor 
below. You can also drag a material from the Server Panel and onto the color icon.

To Create a Triangle

Create a new group and add the Triangle plug-in to it.
Add a material and/or a texture to the group, and/or open the Rectangle plug-in editor and 
enable and set the vertex colors.

Open the transformation editor and set Position Y to -150.0 .

Open the Triangle editor and set the following parameters:

Wall

The Wall plug-in creates a curved wall object. The size and curving of the wall can be customized.
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Wall Properties
Use LOD: Enables/disables dynamic level of detail.
Height: Sets the height of the wall.
Width: Sets the width of the wall.
Depth: Sets the depth of the wall curving. The higher this value is set, the more curved the 
wall is.
Angle: Sets the angle of the walls curving. Use this parameter together with Depth to achieve 
the desired curving of the wall.
Corners: Sets the number of internal corners the wall should be built up from.
Center: Sets the center axis of the object. Choose between Center, Bottom or Top.
Front: Lets you switch between front and back.

To Create a Wall

Create a new group and add the Wall plug-in to it.
Open the Wall editor and set the following parameters:

Set Height to 200.0 .

Set Width to 400.0 .

Set Depth to 400.0 .

Set Center to Center .

Add a material and/or a texture to it.

Open the Transformation Editor and set Rotation Y to -45.0 .

Note: This plug-in is located in: Plugins -> Geom plug-ins -> Default
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Wave

The Wave plug-in allows you to create a wave sequence on a flat surface. The properties of the 
sequence are visualized in a graphical display in the wave editor.

Wave Properties
Size X and Y: Sets the size of the rectangle where the waves show.
Geom Type: Allows you to select between Circular and Linear waves.
Stretch: Allows you to customize the form of the circular waves. By altering the 
stretch X and Y values, you can for instance obtain an oval or a compressed form of the 
waves.
Time: Is the time-line for a wave sequence. You see a thin red vertical line moving in the 
graphical display as you alter the time value. You can also alter the value by dragging the 
red line.
Tess.: Sets the tessellation / level of detail.
Angle: Sets the angle of the waves when a linear mode is chosen.
Ref.Pnt X and Y: Sets the position of the waves starting point.
W. Length: Sets the length of the waves.
Damp. mode: Enables damping of the waves. The amplitude of the wave is reduced by the
damp length calculated from the center of the wave.
Damp. Length: Sets the length the distance that is used to damp the waves in the Damp.
mode function.
Offset: Sets an offset value of the Ref.Pnt.
Ampl: Amplifies the waves, resulting in both bigger and higher waves.
Inverse OFF/ON: Inverts the wave curves.
Envelope Generator: Draws the wave manually when enabled. When disabled the wave is
built by a sine wave function.
Position X and Y: Allows you to edit the position values of the wave control points. Select a
point by clicking on it. Its color changes to red to show that it is selected. Now you can drag
it around.
Lock: Allows you to decide whether the points controlling the crest of the waves should be
edited in a locked manner, with the points controlling the troughs of the waves or
conversely, if they are to be edited separately.
Spline Curve: The control points of the spline curve, that shows the wave sequence, can be
edited by using the cursor. Click on a point and drag it to the required position.

Note: This plug-in is located in: Plugins -> Geom plug-ins -> Default
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To Create a Wave

Create a new group and add the Wave plug-in to it.

Open the Transformation Editor and set Rotation X to -75.0 .

Add a material and/or a texture to it.
Open the Wave editor and set the following parameters:

Set Size X and Y to 350.0 .

Set W.-Length to 8.0 .

Click the Lock button to unlock the spline curve editor.
Play with the spline curve handles, Time, Position X and Y values to see how the wave 
behaves with different settings.

4.3.4 Primitives
The following Geometry plug-ins are located in the Primitives folder:

N Quad

N Quad

The N Quad plug-in creates a rectangle with different attributes.

N Quad Properties
Use LOD: Enables/disables dynamic level of detail.

Note: This plug-in is located in: Plugins -> Geom plug-ins -> Primitives
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Tessellation U: Sets the degree of detail.
Tessellation V: Sets the degree of detail.
Orientation: Switches the orientation from Top Bottom to Left Right.
Top/Left Width: Sets the width.
Bottom/Right Width: Sets the width.
Height/Width: Sets the height.
Depth: Sets the depth.
Center X: Switches the center in X between Center, Top and Bottom.
Center Y: Switches the center in Y between Center, Left and Right.
Shearing: Sets the shearing value, so the bottom is shifted.
Image Mapping: May be set to Stretch or Tile.
Crop Top/Left: Crops the top.
Crop Bottom/Right: Crops the bottom.
Border Geometry: Enables/disables the top and bottom border width parameters. When 
enabled, only the border outline is visible.
Top Border Width: Sets the width of the top border.
Bottom Border Width: Sets the width of the bottom border.

To Create an N Quad

Create a new group and add the N Quad plug-in to it.
Add a material and/or a texture to the group.

Open the transformation editor and set Rotation X and Z to -45.0 .

Open the N Quad editor and set the following parameters:
Set Orientation to Left-Right.

Set Top/Left Width to 200.0 .

Set Bottom/Right Width to 0.0 .

Set Height/Width to 300.0 .

Set Depth to 100.0 .

Set Center X and Y to Center  and Bottom , respectively.
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4.3.5 RealFX plug-ins
The RealFX plug-in set enables you to create particle effects in Viz Artist.

Particle systems are a computer graphics technique to simulate certain physics-based effects, 
which are otherwise very hard to reproduce with conventional rendering techniques. Examples of 
such effects which are commonly replicated using particle systems include fire, explosions, smoke, 
weather effects, sparks, falling leaves, dust, meteor tails, or abstract visual effects like glowing 
trails, magic spells, etc.

The particle effects in Viz Artist/Engine run in real-time, meaning that there are a few inherent 
constraints that must be taken into account when considering best practices for employing this 
plug-in set. For example, there is a trade-off between the number of particles and performance 
optimization; more generally there needs to be a considered balance between performance and 
visual quality.

RFxSmoke is the baseline plug-in within the RealFX plug-in set. The remaining plug-ins in this set 
are applied on top of RFxSmoke in any given container. RFxSmoke includes built-in functionality 
and the ability to host the additional functionality contained in the other plug-ins in this set. Part 
of the built-in functionality, e.g. turbulence, is kept for compatibility with previous version of Viz 
Artist.

There are three categories of additional plug-ins:

Birth plug-ins: Refers to where the particles are spawned.
Motion control plug-ins: Governs the position, direction, velocity, size and color of each 
particle.
Texture control plug-ins: Affects the texture mapping and the “look” of each particle by 
using pixel shader technology.
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The following Geometry plug-ins are located in the RealFX folder:

RFxSmoke

See Also

RealFX in Shader Plug-ins
pxColorWorks in Container Plug-ins

RFxSmoke

The RFxSmoke plug-in is the baseline plug-in within the RealFX plug-in set, which creates realistic 
visualization of smoke, fire, explosions and much more (the level of creative skill is the only 
limitation).

The basic function of the object is that it emits particles from a point and moves them in some 
direction until they die or fade away. With the use of different texture mappings and settings, 
many effects can be achieved.

This page contains the following topics:

RFxSmoke Properties
Spawn
Impulse
Forces
Size
Rotation
Color
Alpha

RFxSmoke Properties
Number of particles: Sets the number of particles to be active at the same time. The number 
of required particles is calculated by the Birth Rate multiplied by the Life Span. If this is 
lower or equal, the number of particles present is a constant flow of particles, otherwise the 
plug-in collects particles until the minimum number of particles has been reached and then 
spawns them.
Birth Rate: Sets the birth rate of particles per second.
Life Span: Sets the life span of the objects in seconds. In the field to the right of Life Span, 
set a percentage over which the life span of the particles varies. If Life Span is set to three 
and the variation to 50%, the life span of particles vary randomly between 1,5 and 4,5 
seconds. This creates more realism, since particles in real smoke or fire does not have equal 
life span.

Note: This plug-in is located in: Plugins -> Geom plug-ins -> RealFX
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Preroll (fields): Sets the amount of fields to calculate before RFxSmoke goes On Air.
Reference: Sets the particles reference to either Container or World. If Container is selected, 
after emitted the particles relate their position to the containers position. If the emitter 
object is moved, the particles alter their position correspondingly. If World is chosen, the 
particles maintain their position and path even if the emitter is moved, they have their own 
world coordinates.
Billboard: If Particle is selected, the particles maintain a frontal position against the camera 
when the camera moves.
Sort: Enables/disables sorting.
Array: Enables/disables the use of array.
Reset Particles: Removes all already emitted particles.
Show Forces: Show help lines that show the forced settings of some of the parameters.
Freeze Motion: Halts the emitting process.

Spawn
Spawn parameters are related to the position of the smoke emitter. In the Spawn panel define the 
shape and size of the area in which the emitter should emit the particles.

Type: Defines the shape or type of spawn area. Click Cube, Sphere, Container and Image to 
set if the spawn area should be shaped as a Cube or a Sphere, or if a container or image 
should be used.
Size: Sets the size, selected from the X, Y and Z values. If Sphere is selected and only 
the X value is set, the emitter creates particles while it moves randomly along a line. If 
a Y value is also set, the emitter moves within a circle. If a Z value is set, the emitter moves 
within a sphere. If Cube is selected the same applies, but the stages would then be a line, a 
rectangle and a Cube.
Spawn Range: Sets the range, within the Sphere or Cube, the emitter should use to distribute 
the particles. Default is 100%, where it uses the whole spawn area. If the value is reduced, a 
section, which starts from the middle of the spawn area where no particles are being 

emitted, increases correspondingly. If the value is set to 1% , the emitter only emits particles 

at the outer edge or surface of the cube or sphere.

Impulse
In the Impulse panel set the parameters for how particles are emitted.

Speed: Sets the speed the particles have when they are emitted. In the field to the right 
of Speed, set a percentage over which the particle speed varies.

Tip: Container is especially valuable when animating a Scene, as the smoke is 
emitted from the outline of an animated Container. To set the Container, which the 
smoke should emit from, drag the Container from the Scene Tree onto the drop 
zone.



Note: A Container must be 2D, such as a rectangle, circle, square, etc.
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Rot X: Sets the X axis angle of the opening in the emitter, the emitter hole.
Rot Z: Sets the Z axis angle of the opening in the emitter, the emitter hole.
Angle X: Sets the X axis opening angle of the emitter hole. It can be done locked with the Z 
axis, or independently. Click Lock X/Y to The button to the right of the value field to lock or 
unlock the axes.
Angle Z: Sets the Z axis opening angle of the emitter hole.
Twist: Creates a twist of the opening angels of the emitter hole. It can also be described as a 
rotation of the emitter around the Y axis.
Align to Center: Disables all the above impulse parameters and aligns the particles above the 
emitter.

Forces
In the Forces panel are the parameters to create environmental effects, like wind, gravity and air 
resistance.

Gravity: Sets the degree of gravity, which affects the path of the particles. If set high, the 
smoke moves downwards. With a negative gravity, the particles rise faster.
Air Resistance: Sets the degree of air resistance to creates a force that prevents the particles 
from rising.
Turbulence X, Y and Z: Defines a simulation of turbulence on the particles as they rise. The 
turbulence effect is achieved through a jittering of the particles. The X, Y and Z values set 
the axis of the jittering movement.
Wind:

Force: Sets a level cross wind. A positive value blows from the left to towards the 
right, a negative the other way around. For example: If a horizontal wind force is not 
required, use the two next parameters to adjust the angle of the wind.
Rot X/Z: Sets the rotation of the wind force on the X and Z axis. Modify these values to 
change the direction of the wind defined in the Wind Force.

Size
In the Size panel are the parameters to the size of the particles at the moment of their birth and 
death. Between the time of birth and death, the size is a product of a linear interpolation.

Birth X/Y: Sets the size of each particle at the time it is being emitted.
Death X/Y: Sets the size of each of the particle at the time it fades away and dies.
Lock X/Y: Locks or unlocks the axes.

Rotation
In the Rotation panel, you can define a static rotated position or a spin of the particles. Both the 
static rotated position and the spin can either be set as an offset equal on all particles or as a 
range where the particles are rotated or span randomly. To see the effect, set the number of 
particles to a very low value and alter the rotation parameters.

Initial
Offset: Sets the degree of rotation the particles should have. This rotated position is 
static and remains throughout the life of each particle.
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Range: Sets a degree range of rotation the particles should have. This rotated position 
is static and remains throughout the life of each particle. If for example the value is 

set to 30 , the static rotated position of the particles varies randomly between 30° and 

-30°.
Spin

Offset: Sets the degree of spin each particle should have throughout its life time. The 
higher the value, the higher the number of spins. A positive value creates an 
counterclockwise rotation, a negative creates a clockwise.
Range: Sets a spin degree range for the particles. They spin randomly between the 
parameter value and the same value mirrored through zero.

Follow Path: If the RFxSmoke object is animated, enable this option to make the particles 
align their position to the animation path in the same way as is the case with the follow path 
option in the transformation editor.

Color
In the Color panel set the color of the particles throughout their life cycle. The particles can be set 
to change their color through stages from their birth to their death by the addition of more Key 
Frames (single click the color stage).

The left side of the color stage is at birth time and the right is at death time. By default there are 
two color Key Frames at each end, that can be clicked on, to set their color. The color range 
between two Key Frames is an interpolated transformation. More Key Frames can be added to 
create a more complex color transformation between particles birth and death. 

To delete color Key Frames, select them and press DELETE or BACKSPACE, on the keyboard.

Alpha
In the Alpha panel set the alpha values of the particles throughout their life cycle. The alpha editor 
contains a curve with points that can be moved, in both X and Y directions, to change the form of 
the curve. The X axis is the life time of the particles and the Y axis is the alpha value.

To select a point, or create a new one, left-click on the graph and drag the point to the required X 
and Y position. To delete a point, select it and press DELETE on the keyboard.

See Also

Create Animations section of the Viz Artist User Guide.

http://documentation.vizrt.com/viz-artist
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4.3.6 Ticker
The following Geometry plug-ins are located in the Ticker folder:

Trio Scroll
Dexter
Scroller

Trio Scroll

The Trio Scroll plug-in is essentially a Geometry plug-in for positioning and scrolling a fixed set of 
items in a specified direction, often used for credit lists or crawls.

Scrolling templates can be built in Viz Trio using the Create New Scroll feature. The scroll scene 
that is automatically created by Viz Trio can be edited in Viz Artist, but it is also possible to build 
them manually.

Some of the supported features are:

Scrolls can be created by receiving item data from Viz Trio’s XML format.
Fine-tuned control of spacing between individual items.
Easepoints (ease in and out) on particular items.

Scrolls are usually built in Viz Trio, but it is possible to add items in Viz Artist by adding merged 
objects under the base_elements group and clicking the Initialize button.

Adding the Trio Scroll plug-in to the scene tree automatically adds the Control Object plug-in (if it 
is not present).

Trio Scroll Properties
Field Identifier: When making templates for Viz Trio, this should be a numeric value, Range: 
1-n. For Viz Pilot and Viz Ticker, this can also be a descriptive text string. This value is used
by the control clients to identify the editable item in the scene. In Viz Trio, the numbers
from the control plug-ins are used to create the tab-order between the editable items.
Description: A description of the tab field or editable object. This is used as a description for
the items when used in the control clients.
Show only in Expert Mode: If Viz Trio is connected, changes are possible if this toggle is set
to Off.
Mode: Selects the direction the scroller should move across the screen.
Scroll area width: Selects the area in width the scroller should use.
Scroll area height: Selects the area in height the scroller should use.
Scroll speed: Sets the scroller speed.

Note: This plug-in is located in: Plugins -> Geom plug-ins -> Default
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Wanted total scroll time: Sets the scroll time.
Actual total scroll time: Sets the scroll time.
Global spacing: Sets spacing between the pages.

Loop: Enables looping. When set to Off , looping does not stop the playlist from being 

played until the end.
Show bounds: Enables and shows the scroll’s bounding-box on the preview and program 
renderer.
Auto-start scroll: Enables the Auto-scroll on take property.
Start position: Sets the start position for the scroll. This setting affects the total scroll time.
Alignment: Sets the alignment of the scroll. The position is relative to the position of the 
scene design. Available options are: None, Left/Bottom, Center and Right/Top.
End-of-scroll director: Triggers a Continue on a specified end director. The director is 
triggered when the scroll leaves the scroll area. It is only supported in normal mode (real-
time), not in post rendering or NLE mode.
Show Advanced: All parameters under the Advanced section are for debugging, by Vizrt 
developers or very advanced users only. For more information contact Vizrt support.
The nameless text parameter with the value <entry></entry> shows the contents of the 
scroll items in the internal VDOM format. It contains the scroll items that can dragged into a 
scroll page in the Trio client with drag and drop

Current position: Scrubs the scroller position.
Command: Executes various scroller commands. After setting its value the click 
on Execute Command. If a command has a result it is reflected in Command result. 
The following commands are used from the Trio client:

Note: To avoid flickering, a roll rate that is aligned with your output frequency 
should be used. When the roll rate is twice the field rate, things look fine. This 
relationship holds for all integer multiples:  roll rates that are odd multiples of the 
field rate look awful. Even multiples look great. For 59.94 Hz video, good roll rates 
are 120, 240, 360, and the like. In 50 Hz, the good ones are 100, 200, 300, 400, 
and so on.



Example: SET_FOCUS [<item name> [<tab-field name>]]  – This is for 

example used if you double click in Trio on a scroll item to highlight it in the 
preview.



Example: MOVE_ELEMENT <from item name> <to item name> - This is used 

when changing the order of scroll items by drag and drop.


Example: REMOVE_ELEMENT <item name> - This is used to remove a scroll 

item.
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Command result: See Command.
Reload prototypes: Updates the scroll items due to changes in their templates (scenes) 
- use a context menu action in Viz Trio to do this (see the Viz Trio User Guide).
Start/Stop/Continue: Controls the scroll (used in the local preview and the live
controls for playback).
Execute command: See Command.

See Also

Create New Scroll in the Viz Trio User Guide.
Control Object plug-in
Trio Scroll Element plug-in

Dexter

The Dexter plug-in is a macro-based text-ticker tool that generates static horizontal text crawl and 
vertical text rolls. The Dexter editor is organized in five sections, Control, Design, Text, Trigger 
and Stopper. When adding the plug-in, two sub-containers are also added; Animation (visible) and 
Templates (hidden). In addition, it has a set of scripting possibilities.

This page contains the following topics and procedures:

Example: UPDATE_TOTAL_TIME  – This commands the plug-in to recalculate its 

total time, typically after adding a new scroll item.


Example: SET_TEMP_EASEPOINT_VALUE  – Gets used when editing the 

Easepoint values.


Note: This plug-in is located in: Plugins -> Geom plug-ins -> Default

http://documentation.vizrt.com/viz-trio
http://documentation.vizrt.com/viz-trio
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Common Parameters
Control Parameters
Design Parameters
Text Parameters
Trigger Parameters
Stopper Parameters
Dexter Parameters
Script Programming Parameters
Script Programming Tokens
Script Programming Syntax
Script Programming Templates
Script Programming Newline Logic
Script Programming Triggers

Common Parameters
These buttons are found top right of the Dexter editor and are not active in control mode.

Control: See Control Parameters.
Design: See Design Parameters.
Text: See Dexter.
Trigger: See Trigger Parameters.
Stopper: See Stopper Parameters.
Info: Shows the delimited borders defined by the mark settings.
Update: Applies the changes on the already existing containers.
Build: Rebuilds all objects.
Clear: Clears the text objects.

Control Parameters
Use the Control section to start, stop, continue and reset the scroll/roll. It also contains buttons to 
select the velocity mode and speed of the ticker.

Start: Starts the animation.
Stop: Stops the animation.
Reset: Resets the animation.
Cont: Continues the animation.
Loop: Loops the scroller/crawl.

The velocity control defines how the speed of the crawl/roll is to be calculated.

Duration (all groups same): Makes all group use the same amount of time to crawl/scroll 
from start to end. The duration is measured at the group containing the longest text string.
Duration (for each group): Makes all groups use exactly the same time. As a consequence, 
longer text strings scroll faster than shorter ones.
Speed: Makes all groups scroll at the same speed, as a consequence long message takes 
longer to scroll than shorter messages. The speed unit is pixels per frame divided by ten.
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Design Parameters
In the Design section of the Dexter editor, the range of parameters determines how the text 
shows:

Screen width: Sets the width of the screen used for placing the text objects and culling. 

Possible values range from 20  to 4000 .

Screen height: Sets the height of the screen used for placing the text objects and culling.

Loop kerning: Defines the spacing between two loops. Possible values range from 0  to 

1000 .

Group kerning: Sets the vertical distance between group items.
Crawl mode: Creates a normal horizontal scrolling text.
Roll mode: Creates a vertical scroll.
Default Font: Shows the default font. To load a font, drag it from the Server Panel and onto 
the font drop zone. To unload a font, simply drag it to the trashcan. This must be set to get 
any text unless you specify a font in the macro and all text are executed with macros.
Autosplit text: Splits long text objects into smaller text objects for better performance when 
enabled.
Corr. val.: Adds the correction value to the gap between two new objects created when the 
autosplit feature splits a text object. Although it reads the length of a space character from 
the font to make a proper placing of the objects, there is a slight difference in length 
between a split and a non-split text. Therefore, the correction value is inserted to correct 
text that does not look good because of incorrect placing when the objects are split.
Min. object length: Sets the minimum object length for an auto-split object.
Col1: Sets the default color 1. To set it, either drag a material from the Server Panel onto the 
col1 icon, or use the color editor below.
Col2: Sets the default color 2. To set it, either drag a material from the Server Panel onto the 
col1 icon, or use the color editor below.
Col3: Sets the default color 3. To set it, either drag a material from the Server Panel onto the 
col1 icon, or use the color editor below.

Text Parameters
The Text Editor contains the text area where you enter the script commands. It also contains a list 
of all tokens and parameters. By clicking on a token or parameter, you automatically insert it into 
the script text at cursor position.

Space=Text: Forces the parser to interpret spaces at the beginning of a line/after a token 
has ended as legal text (in its default state those spaces are abandoned).
Load File: Allows you to browse for a script file. The default extension for the file is .edx. The 
script file must contain a macro script with standard syntax. When the file loads, the 
contents are written onto the text field.

Trigger Parameters

Act.: Evaluates the marker when set to On .
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Mark: Determines the name of the marker for orientation.
Position: Sets the marker position where an event should occur.
Command: Runs the Viz command at the determined place.

The concept of marks and triggers allows you to send commands to Viz Artist/Engine when the 
animation reaches a certain position. To make it work you need to define two items:

First of all, mark the trigger positions in the text crawl/roll. This is done using the token  <MARK> .

Animation starts<MARK A>here.

There are six marks, named A, B, C, D, E and F, that can be put wherever desired in the text. 
If Info is enabled, a representation of the mark is visible on-screen.

In addition to the six user-definable marks, there are two marks that are created automatically, 
named BEGIN and END. They are located at the beginning and end of the crawl/roll. Please keep in 
mind that the END mark is located before all the containers created for the loop feature and that 
marks are not looped.

After setting marks and building the crawl/roll, trigger actions must be specified. All eight marks 
are listed in the trigger section of the editor. The on/off switch left to the mark name is used to 
set that mark active/inactive. The position value right to the mark name sets the position where 

the triggering should occur (value  0  is at the end of Dexter’s bounding box. When animation is 

running and the mark in the text reaches this position, the specified command is triggered. If you 
switch on Info you see a line representing the trigger position. Switch it on and watch the marks 
and lines interacting to see how this works. Right to the trigger position you find a text field where 
you can enter the command which should be sent to Viz Artist when a mark triggers. You may use 
every command available via external control, for example you may change values in Viz Artist, 
start animations, execute plug-ins, and so on.

First you may issue two or more commands when a mark reaches its trigger position. Simply split 

them using a  ;  character (semi-colon). Also you may use the DEXTER location to send pseudo-

commands to Dexter.

Currently two such pseudo-commands are implemented: The first one is DEXTER*STOP, which 
stops Dexter’s animation, the second one is DEXTER*PAUSE X, where Dexter stops the animation 
for X seconds (of course this is a floating point value, so DEXTER*PAUSE 0.5 is also possible) and 
continue with the same speed as before.

Stopper Parameters

Enable: Evaluates the markers when set to  On .

Use Mark: Uses the given position.

Position: Sets the position of the Ease-Out  and Ease-In  range.

Ease Out: Determines the last position of a text object during movement.
Continue

Wait for "Cont": Makes the text object wait until an  continue  Viz command is sent.

Note: These two pseudo-commands are not supported by Viz Artist command interface; 
they are only available using Dexter’s trigger feature. Dexter supports the THIS_SCENE 
pseudo location as well; you may want to use this to refer to objects/animations in the 
local scene.
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Wait Nr Fields: Makes the text object wait for a specified number of fields. Consider 
that two fields comply one frame.

Ease In: Slows down the text object and waits for a continue signal or until the number of 
fields are reached.
Global: Stops global or local to a certain group.

The Stopper is an extension to the triggering ability of Dexter. It allows you to create ease in/out 
animations at defined points along the crawl/roll.First you need to create a set of marks using the 
<MARK> token to define the stop points in your text. Then open the Stopper page in the Dexter 
editor and check the Enable button.

Select which marks to use. If you have defined your stop points using the <MARK C> token you 
need to select C here. If you enable Info you see a representation of the animation curve in the 
editor. Using the position, ease in and ease out slider you can move and alter that animation like 
you need. (Please keep in mind that the ease out part of the animation is executed before the ease 
in part: although usually it is the other way round. But here we do not want to start an animation 
smoothly and then stop it, we want to stop it first and then restart it again).

Using the continue switch you can select what Dexter should do after the animation has stopped: 
Either wait a certain number of fields or wait until the Continue button in the Control section is 
pressed. If you have more than one group in crawl mode you may want to check the Global as well. 
If it is checked, all groups halt as soon as a marker in any group reaches the stopper position. If it 
is unchecked only the group that contains this marker is stopped.

Dexter Parameters

Name Type Function

text string This is the script Dexter uses for building 
the text.

screenw float Screen width (used for placing the text 
objects and culling) 20/4000.

screenh float Screen height (used for placing the text 
objects and culling) 20/4000.

time float Animation length (in seconds) or 
animation speed 1/500.

file string File name (default extension .*).

loopmode bool Loop on or off.

loopkern float Defines the spacing between two loops 
(global) 0/1000.

groupkern float Defines the spacing between two groups 
(global) 0/1000.
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Name Type Function

showarea bool View the culling area on or off.

doautosplit bool If on, it splits text objects into pieces.

autosplitcorr float Correction value for autosplit feature 
-1e6/+1e6.

autosplitmin int Minimum number of characters for split 
text objects 0/100000.

time-line float Value for preview control (works if 
animation is stopped) 0/1000.

deffont string Default font (e.g. Peak/AvantGarde/
AvantGarde-Book).

col1 unsigned long Default color value.

col2 unsigned long Color value #2.

col3 unsigned long Color value #3.

durmode int Selects animation mode (duration/speed) 
0/2.

roll bool Switches between vertical (0) and 
horizontal (1) animation.

trigonbegin bool Turns on/off trigger BEGIN (see 2.6).

trigona bool Turns on/off trigger A.

trigonb bool Turns on/off trigger B.

trigonc bool Turns on/off trigger C.

trigond bool Turns on/off trigger D.

trigone bool Turns on/off trigger E.

trigonf bool Turns on/off trigger F.
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trigonend bool Turns on/off trigger END.

trigposbegin float Position of trigger BEGIN 
-100000/100000.

trigposa float Position of trigger A -100000/100000.

trigposb float Position of trigger B -100000/100000.

trigposc float Position of trigger C -100000/100000.

trigposd float Position of trigger D -100000/100000.

trigpose float Position of trigger E -100000/100000.

trigposf float Position of trigger F -100000/100000.

trigposend float Position of trigger END -100000/100000.

trigcombegin string Command for trigger BEGIN.

trigcoma string Command for trigger A.

trigcomb string Command for trigger B.

trigcomc string Command for trigger C.

trigcomd string Command for trigger D.

trigcome string Command for trigger E.

trigcomf string Command for trigger F.

trigcomend string Command for trigger END.

status bool While animation is running, this parameter 
is set to 1 (read-only).

Boolean values can either be 1 (on) or 0 (off). Color values are four byte unsigned integers, byte 0 
= red, 1 = green, 2 = blue, 3 = alpha.
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Script Programming Parameters

Name Default Value Function

AnchorX, AnchorY, AnchorZ 0 X, Y and Z position of a new text 
object.

AnimDirection Default Animation direction, set to anything 
but “Default” to reverse animation

AutoSplitCorr 0 Correction value for autosplit feature

AutoSplitMin 20 Minimum number of characters for 
split text objects

Col1, Col2, Col3 255/255/255/255 Holds the color value from the gui/
external control (parameter Col1)

Command - Sends a command to Viz Artist/Engine.

Detail Auto Sets detail/fontstyle of text objects (see 
above).

DoAutoSplit 0 Enables/disables auto-split feature.

Enlighted 0 Set to 1 if you want enlighted text.

FontStyle - Sets the font used to create text 
objects (e.g. Vizrt/AvantGarde/
AvantGarde-Book).

GroupKerning - Sets horizontal spacing between 
groups (like Jump).

Jump 0 Sets horizontal spacing between 
groups.

LastContainer - Holds the container number of the last 
created container.

LastX, LastY 0 If a new text object is created, the last 
X and Y position are stored here.

MarkOffsX, MarkOffsY 0 X and Y offset for marks (see Script 
Programming Tokens).
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Name Default Value Function

Material 255/255/255/255 The material used for creating text 
objects.

ObjectKerning 5 Sets spacing between two text objects.

RollAlign C Align groups in roll mode. values are 
R/r (right), L/l (left) and C/c (center).

RollBorder 0 Sets left/right border for groups (if 
aligned left or right in roll mode).

Scaling 20 Sets scaling in percent (20 means a 
scaling of 0.2).

ShadowDirection 320 Direction of shadow.

ShadowDistance 10 Distance of shadow

ShadowMaterial 204/204/204/204 Material of shadow.

ShadowSharpen 0 Controls Sharpen parameter for the 
shadow of the selected font.

ShadowZOffset -1 Z offset of shadow.

Sharpen 0 Control Sharpen parameter of selected 
font.

SoftShadowLevel 1 Level of soft shadow (1-4).

Step 15 Sets the amount AnchorX is increased 
on a newline (see newline logic).

Template - Sets template to be used for creating 
text objects (see Script Programming: 
Templates).

TextKerning 0 Adjusts text kerning (in text object).

UseShadow 0 Set to 1 to enable shadow.

UseSoftShadow 0 Set to 1 to enable soft shadow.
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Name Default Value Function

WordSpacing 0 Adjusts word spacing (in text object).

XScaling, YScaling, ZScaling 20 Scaling value for X, Y and Z axes.

Color values are described in the form r/g/b/a with decimal numbers (base 10). Col1 is also used 
as the default color value (Material is initialized with this value). Material can also hold an existing 
material in the material pool, e.g. “Vizrt/Artdeco/artdeco.0” (see Col1, Col2, Col3 in Script 
Programming Parameters).

Detail can have one of the following values: 1, 2, 3, 4, 5, 6 or T. 1 through 6 are detail levels, T 
means texture font. Every other value (like the default “Auto” is interpreted as detail level auto) 
(see Detail in Script Programming Parameters).

Script Programming Tokens

Name Syntax Function

ADD <ADD Parameter Value> Adds Value to Parameter (see example 
below).

CLEAR <CLEAR Parameter> Clears Parameter (sets it to "").

CONTAINER <CONTAINER Path> Inserts a container into the text (see 
example below).

ENDMAC <ENDMAC> Ends macro definition (nested macros 
are not allowed).

EXEC <EXEC Name> Executes the macro Name.

GROUP <GROUP> Begins a new group of containers.

IMAGE <IMAGE name> Inserts an image in the text.

MACRO <MACRO Name> Defines the macro Name.

MARK <MARK Type> Sets a mark (see Script Programming 
Triggers).

MAX <MAX Parameter Value> If Value is higher than Parameter then 
Parameter = Value.

MIN <MIN Parameter Value> Works like MAX but takes the smaller 
value.
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Name Syntax Function

NEWLINE <NEWLINE> See Script Programming Newline Logic .

NOTEXT <NOTEXT> See Script Programming Newline Logic.

SET <SET Parameter Value> Sets Parameter to Value.

The ADD token adds either a string or a float to one. If either Parameter or Value are strings, the 
two strings can be combined to one. If both are floats, an arithmetic addition is done.

For example:

<SET Test Vi><ADD Test zrt>

results in “Vizrt”, but:

<SET Test 5><ADD Test 6.3>

results in Test holding the value 11.3.

The CONTAINER token is used to define a container path for inserting a container into the text. A 
container path may either look like “1/3/2/3/1” (the same system as used in the GUI), 
“$Containername” or “#Containernumber”.

<CONTAINER 1/3/2/4> <CONTAINER $$Sphere> (or: <CONTAINER “$Sphere”>) <CONTAINER #307>

The MARK token sets a mark that can be A, B, C, D, E or F.

The GROUP token begins a new group of containers. Instead of writing <GROUP> you may leave 
one line empty as this has the same effect. Use groups for making lines in roll mode.

Script Programming Syntax
The syntax consists of tokens and text. <tokens> are surrounded by <>, e.g. <ENDMAC>. Spaces 
are used to separate tokens and arguments. Text is everything that is not bracketed. Tokens can 
be everywhere in the text, e.g. Viz is <SET Material 234/34/58/114>great is valid. You do not need 
to write every token in a new line. Nested tokens are not allowed. A macro cannot execute itself.

In addition to the tokens, there is the escape character $:

$Parameter inserts the value of Parameter in the text
$_ inserts a space character in the text (for use in tokens)
$< inserts a < character
$> inserts a > character
$$ inserts a $ character
The $ character can be placed in tokens and in the text, e.g. $<Dexter$> says:
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<SET Text Hello><ADD Text $_World>$Text

Inside tokens you may use double quote characters to insert text.

<SET Text “This is a text”>

Any $ characters and spaces within two double quote characters are ignored from parsing and 
executing. Two double quote characters are interpreted as one:

 <SET Name ""Harry"">

Script Programming Templates
You can define templates for the creation of text objects. Under the Dexter container you find a 
container named “Templates”. Under this container you can create a set of template containers. 
These can hold animations, plug-ins, key, alpha, etc. Give every template container a unique name. 
To access it in the script, you need to set the Template parameter to the name of the template you 
want to use:

<SET Template AlphaKey1>

After you set the Template parameter, Dexter uses this template container as basis for every text 
object. To switch this behavior off set Template to its default value (which is ""):

<CLEAR Template>

Script Programming Newline Logic
The token <NEWLINE> (see Script Programming Tokens) describes a new text object, which is 
separated from the previous one. Every newline moves AnchorX (see AnchorX, AnchorY, 
AnchorZ in Script Programming Parameters) a bit further, depending on the value of Step. This 
token is inserted internally to prevent you from typing <NEWLINE> over and over again.

The following text

One Two

is converted to

Caution: Certain parameters (like material) are overwritten by Dexter after the container 
has been created from the template.
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One <NEWLINE> Two

No newlines:

From the beginning of the script until the first occurrence of text.
After a line that doesn’t contain text (if the line is empty a new group is created).
After the tokens MACRO, ENDMAC and NOTEXT, and the last newline before those tokens 
are deleted.

For example:

Lines Explanation

No new lines because no text occurred.

<SET Camera Bobby> No text, no new line.

Return of the Here is the first new line.

Killer Tomatoes II No new line because of token MACRO in the next line. 
From here on there are no new lines until the end of the 
MACRO.

<MACRO SetDir> No new line because there is no text in the line.

<SET Director Jimmy>

<ENDMAC>

<EXEC SetDir>

Director: New line.

$Director New line.

<SET FontStyle Arial> No new line because there is no text in the line.

Camera: New line.

$Camera

<NOTEXT> The <NOTEXT> token does not add new lines before the 
next text item occurs (see Script Programming: Tokens).

x New line.
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Lines Explanation

y New line.

<SET Material $Col2> No new line because there is no text in the line.

z New line.

1<NEWLINE>2 New line for 1 and 2.

The macro SetDir in the example above can be used as follows without creating a newline:

Hello<EXEC SetDir>World

The same rules applies to automatically inserted GROUP tokens (see Script Programming Tokens).

Script Programming Triggers
The concept of marks and triggers allows you to send commands to Viz Artist/Engine when the 
animation reaches a certain position. Therefore you need to define two items:

First is setting a mark in the text. You have six different marks to place wherever you think 
they are useful, together with the automatically created BEGIN and END mark this gives you a 
total of eight marks.
The second items are the triggers, where you have as well eight different triggers. While 
marks are set with a token in the text, triggers can be defined in the trigger section of the 
Dexter editor or using external control. You can define a position and a command for every 
trigger. When the corresponding mark reaches the trigger position, the command is issued 
to Viz Artist/Engine.

Marks are set using the MARK token, for example: Animation starts exactly{{<MARK D>}}
here!

User defined marks are numbered A through F and are color coded in the trigger editor and as 
graphical symbols when show area is turned on. In addition to the user defined marks there are 
the automatically created marks BEGIN and END, which are inserted at the beginning and ending of 
the crawl/roll. The commands being issued do not have to be numbered, this is optional. If you do 
not provide a number, -1 is added before the command is sent to Viz Artist/Engine. you can as 
well define more than one command, separate them by a semicolon character.

You may invoke two internal commands using the trigger function with the  DEXTER*  location: 

stop and pause.

Note: Only marks and triggers of the same type work together! If for example mark B 
reaches the position of trigger D, nothing happens.
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DEXTER*STOP DEXTER*PAUSE X

Scroller

The Scroller plug-in generates a dynamic line of scrolling items, mostly used for creating scrolling 
tickers.

When used with Viz Ticker the scene is designed as a transition logic scene where each data item 
is an instance of a scene template designed as part of the background scene. This is unlike 
traditional transition logic scenes where each data item would be based on a specific foreground 
scene controlled by the background scene. Based on the scene template that resides with the 
background scene the Scroller is able to construct and configure the scene templates on demand 
for Viz Ticker that manages and reuses them.

To design a scrolling carousel, the Scroller and one or more scene templates must be added to the 
background scene. The scene templates serve as prototypes for the containers that the Scroller 
plug-in generates. Alignment of the generated containers is done by editing the alignment of the 
scene templates.

Scroller Properties
Element Source: Element descriptions are added here. Descriptions must be entered in the 
element source syntax, or in the name of a Shared Memory segment that uses the Shared 
Memory protocol. When designing and testing a scene, the element source syntax is used to 
make the system scroll instances of the design containers.

Show Advanced: Shows additional parameters. Defaults to  Off .

Layer: Defines the layer name for the scroller. The layer name must be identical to the name 
of the director that holds the in and out stop points for the carousel.
Mode: Defines if elements should be shown as scrolling or flipping elements for scrolling 
and flipping carousels, respectively.
Direction: Defines the direction of the scroller.
Scroll Region Width: Defines the width of the scroller. This option is only relevant for left-to-
right/right-to-left scrollers.
Scroll Region Height: Defines the height of the scroller. This option is only relevant for up-
down/down-up scrollers.

Note: X  is the time in seconds.

Tip: When saving a Scroller scene, remember to hide the scene template containers. This 
prevents the scene template from being shown on-screen.



Note: This plug-in is located in: Plugins -> Geom plug-ins -> Ticker
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Scroll Speed: Defines the speed of the scroller. The x position of the scrolling items are 
decremented with this value for each frame that passes.
Minimum spacing: The minimum spacing between scrolling elements.
Padding: Defines an extra padding value that is added to the width of the bounding box of 
an item when calculating the spacing between the items. Negative padding can be used to 
make items overlap.

Start Position: Set the initial position as a percentage value in the range  0-100 . A value of 

100  means the scroller starts fully populated with content. The default value is  0 .

Played Out: Tracks movement of scrolling element and notify ticker service on specified 
position.

Element: Position of the scrolling element to be checked with the marker. When set 

to  Beginning hits , notify when beginning of element hits the marker. When set 

to  End leaves , notify when end of element leaves the marker.

Marker: Position of the marker related to side of Scroll region.
Show Bounds: If enabled, the area in which the scroller tries to maintain the illusion of a 
continuously scrolling flow of items is visible on-screen.
Active: Scrolling or flipping is available when enabled.
Preload Cache: Use this on configurations with no ringbuffer, to move all spike-load related 
to item creation to the initialization phase. Designs 

named  DESIGN_designname_Xnnn  have  nnn  instances created in advance, where  nnn  is 

an integer.
Trigger Director: Director to be triggered when the Trigger button is pressed.
Start with padding: Sets padding for the first scrolling item, for example when Start 

Position is set to  100%  or the scroller container is hidden at the beginning.

No Padding On Empty: Does not create any extra spacing between elements for elements 
with zero bounding box.
Reinitialize: Reinitializes the plug-in by deleting all cached objects and reconstructing the 
initial node structure. This parameter can be used to update the scroller after changing for 
example the item source.
Clear: Clears all current ticker items in the rendering window.
Trigger: Triggers the director named in the Trigger Director field provided that there are 
items in queue to be scrolled in. If no director is specified, the scroller is activated.

See Also

Viz Ticker User Guide
Control plug-ins
Toggle plug-in

Tip: The Viz Ticker User Guide contains information on design conventions when 
using the Scroller plug-in.



http://documentation.vizrt.com/viz-ticker
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4.3.7 Topo
The following Geometry plug-ins are located in the Topo folder:

Topo Arrow
Topography
Topo Rect
Topo Ring

Topo Arrow

The Topo Arrow plug-in creates an arrow geometry. The arrow behaves like it is cut out from cloth 
and smoothed over the geometry provided by the topography plugin. This is needed if the arrow is 
used on a surface which is not 100% planar to prevent parts of the geometry from appearing to be 
floating above the ground. Ski jumps and golf greens are examples where this should be used.

Topo Arrow Properties
Use LOD: Enables/disables dynamic level of detail.
Point 1 x: Determines x-coordinate of starting tip of arrow.
Point 1 y: Determines y-coordinate of starting tip of arrow.
Point 1 z: Determines z-coordinate of starting tip of arrow.
Point 2 x: Determines x-coordinate of ending tip of arrow.
Point 2 y: Determines y-coordinate of ending tip of arrow.
Point 2 z: Determines z-coordinate of ending tip of arrow.
Width: Determines width of the arrow beam.
Style 1: Sets start tip to flat or arrowhead.
Style 2: Sets end tip to flat or arrowhead.
Arrow Width: Determines width of arrowheads. This has no affect on flat ends.
Arrow Length: Determines length of arrowheads. This has no affect on flat ends.
Percent: Sets total arrow-length (tip to tip) to a percentage of length defined by points 1 and 
point 2. If less than 100%, point 2 is moved accordingly.
Mode: Sets plane in which the arrow is created.

XY: Creates arrow in XY plane.
XZ: Creates arrow in XZ plane.
YZ: Creates arrow in YZ plane.

Alignment: Projects the geometry of the arrow along the y-axis on the geometry provided by 
a topography plug-in in the same scene if set to Topography. This only makes sense for 
mode XZ.

Note: This plug-in is located in: Plugins -> Geom plug-ins -> Topo
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Topography

The Topography plug-in is the user interface for the topology in a scene. It is used to either load or 
build a topology from scratch which can be used by topology aware plug-ins like Topo 
Arrow, Topo Rect or Topo Ring. Areas where these plug-ins can be of use are for example ski 
jumps, golf greens or other surfaces which are not 100% planar.

Adding virtual elements which should not float above the ground require the knowledge of the 
terrain or topographical relief. Geometry plug-ins can make use of this knowledge and act like a 
cloth where the deformation along the vertical axis  is defined by gravity and the topographic 
relief. 

Topography Properties
Use LOD: Enables/disables dynamic level of detail.
Files: Shows a list of topography files.
Name: Shows the current file name.
Load: Loads the topography from the currently selected file.
Save: Saves the topography to the current file name.
VertexX: Determines the X coordinate of a vertex to add to the topology.
VertexY: Determines the Y coordinate of a vertex to add to the topology.
VertexZ: Determines the Z coordinate of a vertex to add to the topology.
NormalX: Determines the X component of the normal vector for the vertex.
NormalY: Determines the Y component of the normal vector for the vertex.
NormalZ: Determines the Z component of the normal vector for the vertex.
AddVertex: Adds a new vertex to the topology.
iA: Determines the first index of a vertex of a triangular face.
iB: Determines the second index of a vertex of a triangular face.
iC: Determines the third index of a vertex of a triangular face.
AddFace: Adds a new triangular face to the topology using ia, ib and ic.
Build: Attempts to automatically triangulate the vertices which have been added to the 
topology.
Clear: Deletes all vertices and faces from the topology.

Topo Rect

Note: This plug-in is located in: Plugins -> Geom plug-ins -> Topo



Plug-ins User Guide -  5.0

Copyright © 2022  Vizrt Page  153

•
•
•
•
•
•

•
•
•

•
•
•
•

•

The Topo Rect plug-in creates a 3D rectangle geometry. The rectangle behaves like it is cut out 
from cloth and smoothed over the geometry provided by the topography plugin. This is needed if 
the rectangle should be used on a surface which is not 100% planar to prevent parts of the 
geometry appearing to be floating above the ground. Ski jumps and golf greens are examples 
where this should be used.

The tessellation needs to be set according to the detail in the topography to eliminate surfaces 
cutting to the topography or floating above it.

Topo Rect 3D Properties
Use LOD: Enables/disables dynamic level of detail.
Width: Determines the width of the rectangle.
Height: Determines the height of the rectangle.
Offset: Offsets each individual vertex from the topography.
Tessellation: Determines the amount of vertices used for the rectangular surface.
Plane 

XY: Creates rectangle in XY plane.
XZ: Creates rectangle in XZ plane.
YZ: Creates rectangle in YZ plane.

Topo Ring

The Topo Ring plug-in creates a 3D ring geometry. The ring behaves like it is cut out from cloth 
and smoothed over the geometry provided by the topography plugin. This is needed if the ring 
should be used on a surface which is not 100% planar to prevent parts of the geometry from 
appearing to be floating above the ground. Ski jumps and golf greens are examples where this 
should be used.

The tessellation needs to be set according to the detail in the topography to eliminate surfaces 
cutting to the topography or floating above it.

Topo Ring Properties
Use LOD: Enables/disables dynamic level of detail.
X: Determines the X coordinate of the ring's center.
Y: Determines the Y coordinate of the ring's center.
Z: Determines the Z coordinate of the ring's center.

Inner Radius: Sets the inner radius of the ring. If set to 0 , this becomes a disc.

Note: This plug-in is located in: Plugins -> Geom plug-ins -> Topo

Note: This plug-in is located in: Plugins -> Geom plug-ins -> Topo
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Outer Radius: Sets the outer radius of the ring. The Outer Radius must be larger than the 
Inner Radius.
Plane 

XZ: Creates a ring in the XZ plane.
XY: Creates a ring in the XY plane.
YZ: Creates a ring in the YZ plane.

Segments: Determines the number of segments along the ring.

Slice: Opens the ring when set to less than 360 .

Rotation: Rotates the ring around the center point.
Tessellation:  Determines the amount of vertices used for the ring surface.

4.4 Container Plug-Ins
The default path for Container plug-ins is: <viz install folder>\plugin.

Arrange
Container
Default
Container FX
Control
Feed
Global
MultiTouch Plug-ins
Presenter
RealFX
Script
Sounds
SplineFX
TextFX
Texture
Ticker
Time
Tools
Transformation
Visual Data Tools

4.4.1 Arrange
The following Container plug-ins are located in the Arrange folder:

Circle Arrange
Grid Arrange
Time Displacement
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Circle Arrange

Circle Arrange is a tool for arranging a set of containers into a circular structure.

Circle Arrange Properties
Number of items: Allows you to define how many items the structure is to made up of.
Number of Rows: Sets the number of rows/rings for the circular structure.
Distribution: Allows you to define how the containers are to distributed in the circular shape.

Monospace: Sets the same number of items in each circle row. The spacing between 
objects in the outer rows is then bigger than in the inner rows.
Equal: Distributes the objects between the rows so the distance between the objects in 
the different rows are equal. The number of containers is larger in the outer rows.

Inner Radius: Sets the radius from the center to the first container ring.
Outer Radius: Sets the radius from the center to the outer ring.
Start Angle: Setting this above -180° creates an open section in the circle structure. The 
opening is created in a clockwise direction.
End Angle: Setting this below 180 creates an open section in the circle structure. The 
opening is created in a counterclockwise direction.
Orientate: Orients the containers with their bottom towards the center of the circular 
structure when enabled.
Rebuild Containerlist: Rebuilds the structure after having added or removed containers form 
the group.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Arrange
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To Arrange Containers in a Circle

Create a group container, and name it  Circle .

Add a Sphere as a Sub-Container to the Circle container.
Add a material and/or a texture to the Sphere container.

Open the Transformation Editor for the Sphere container, and set Scaling (locked) to  0.2 .

Optional: Animate the Sphere object.
Make 15 copies of the Sub-Container, totaling the number of Sphere containers to 16. All 
copies should be placed as Sub-Containers of the Circle container and have the same 
position as the original.
Add the Circle Arrange container plug-in to the Circle container.
Open the Circle Arrange editor and do the following:

Set Number of items to  16 .

Set Number of Rows to  2 .

Click the Rebuild Container list button. The plug-in positions all Sub-Containers in a circular 
structure. The order of the containers in the group decides their placing in the circular 
structure. If more than one row is selected, the first containers end up in the outer circle and 
the last containers in the inner circle.

See Also

Grid Arrange

Grid Arrange

The Grid function is an effective tool for arranging a set of containers into a grid or tabular 
structure.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Arrange
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Grid Arrange Properties
Number of Rows: Sets the number of rows the containers are to be distributed over.
Number of Columns: Sets the number of columns the containers are to be distributed over.
Row Offset: Sets the distance between the rows.
Column Offset: Sets the distance between the columns.
Start In Corner: Selects which corner to start the arrangement.

To Arrange Containers in a Grid

Add container to the Scene Tree.

Name it  Grid .

Add a Sphere as a Sub-Container to the Grid container.
Add a material and/or a texture to the Sphere container.
Open the Transformation Editor for the Sphere container.

Set Scaling (locked) to  0.2 .

Optional: Animate the Sphere object.
Create 15 copies of the Sub-Container (total of 16 Sphere containers). All copies should be 
placed as Sub-Containers of the Grid container and have the same position as the original.
Add the Grid Arrange plug-in to the Grid container.
Open the Grid Arrange editor and set these parameters:

Number of Rows: 4 .

Number of Columns:  4 .

Row Offset: 40.0 .

Column Offset:  40.0 .

Note: The product of number of rows and number of columns should normally be 
equal number of containers. If it is higher, all rows are not equal, if it is lower, some 
containers are not shown, but they are still rendered.
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The plug-in positions all Sub-Containers in a grid structure. The order of the containers in the 
group decides their placing in the grid structure. If more than one row is selected, the first 
containers end up in the first row(s) and the last containers in the last row(s).

See Also

Circle Arrange

Time Displacement

Time Displacement allows you to use a gray-scaled alpha image for setting animation time offsets 
for all the objects in a group container. This is typically useful if you want to create some kind of 
randomized animation effect or that should follow a certain pattern.

What the function does is to create links between the animated containers and the pixels of the 
gray-scale image and then use the alpha level of each pixel to set the offset of the containers. The 
range from 100% alpha to 0% alpha on the pixels sets the offset level. By default 100% alpha sets 
no offset and 0% sets maximum offset.

Time Displacement Properties
Image: Drag the alpha image you want to use for creating the containers offsets onto the 
drop zone here.
Invert: Inverts the link between the image pixels and offsets. 0% gives no offset and 100% 
gives maximum.
Image Width: Sets the height of the alpha image.
Image Height: Sets the height of the alpha image. The product of Image Width multiplied 
with Image Height should normally be the same as the number of containers that are to be 
used in the function.
Pixel Reference: Defines the way the pixels should be associated to the animated containers. 
You can choose between:

Order in Tree: Decides how the pixels should be associated.
Name of Container: Sets the order in which the containers are associated with the 
pixels.

Search Tree: Sets the search level of the function, when it decides which Sub-Containers to 
include in the function:

One Level: Includes only the first level of sub-containers in the function.
Recursive: Includes all levels of sub-containers in the function.

Threshold Action: Executes if the pixel value is lower than the threshold value.
None: Does not perform an action.
Skip Pixel: Skips the pixel in the offset process.
Visible- Makes objects visible when the pixel value is lower than the threshold value.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Arrange
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Invisible- Makes objects invisible when the pixel value is lower than the threshold 
value.

Threshold: Sets the threshold value where one of the above selected actions are performed.
Stage Range (frames): Sets the range of the offset distribution. A high value results in bigger 
differences in offset between containers that are associated with different pixel alpha values.
Stage Offset (frames): Adds a static offset value to all containers.
Filter Type- Filters the containers in or out. Available options 
are; None, Including and Excluding.
Filter String- Sets the name of the containers that are to be included in the filter. Use of 
asterisks is supported.
Execute: Starts the operation.

To Set Animation Time Offsets with a Grayscaled Alpha Image

Add a group to the scene tree and name it TimeDisplace , and the TimeDisplace plug-in to 

it.

Create a Sub-Container of the TimeDisplace container and name it Sphere .

Create a new group container as a Sub-Container of Sphere.
Add a Sphere geometry plug-in and material to the group container.

Animate the group container from Position X -200.0  to 200.0 .

Make six copies of the Sphere container under the TimeDisplace container.
Add the Grid Arrange plug-in to the TimeDisplace container.

Open the Grid Arrange editor and set Number of Rows to 6  and Row Offset to 30.0 .

Optional: Remove the Grid Arrange plug-in.

Add the Corena plug-in and rename the containers to Sphere, starting at index 0 . This 

allows you to filter out specific containers using the TimeDisplace filter.
Optional: Remove the Corena plug-in.
Open the  TimeDisplace editor and add an alpha image to the Image drop zone.
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Click Execute.

Click the Stage to see the offsets being added to the containers.
Run the animation to see the time offset in action!

See Also

Grid Arrange
Corena

4.4.2 Container
The following Container plug-ins are located in the Container folder:

BoundingBox
Cobra
Coco
Colin
Cora
Corena
Talent Tracker
Toggle

BoundingBox

This plug-in allows to override the standard Bounding Box of containers independently of the type 
of the container.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Container
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BoundingBox Properties
X Left Bottom Back: Changes the dimension in X-direction starting from left.
Left Bottom Back: Changes the dimension in Y-direction starting from bottom.
Left Bottom Back: Changes the dimension in Z-direction starting from flipside.
Right Top Front: Changes the dimension in X-direction starting from right.
Right Top Front: Changes the dimension in Y-direction starting from top.
Right Top Front: Changes the dimension in Z-direction starting from front.
Set to Standard: Initializes values to enclose the entire container object.

Cobra

The Cobra function is an easy to use function replace (parts) of container names. Enter a search 
pattern and a string the search should be replaced with and execute.

Cobra Properties
Search pattern: Sets the text string to be replaced.
Search pattern position: Defines the position within the string. It can be set to Begin, End 
and Any.
Replace with: Sets the text string to be used instead of the search pattern.
Search level:

Same: Affects only containers on the same hierarchy level.
Down: Affects only Sub-Containers of the current container.
Tree: Searches the whole Scene Tree.

Add Index: Adds a numerical index to the new name when set to  On .

Starting Index: Sets the number to start the index.

Reverse Index: Uses a reverse index list when set to  On .

Replace: Starts the replace process.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Container
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To Rename Container(s)

Add the Cobra plug-in to a container that, for example, has Sub-Containers that need be 
renamed.
Open the Cobra editor.
Enter a Search pattern text string (e.g. Copy)
Set the Search pattern position to Begin.
Enter the Replace with text string (e.g. Sphere).
Set the Search level to Down.
Click Replace.

See Also

Coco
Corena

Coco

The Coco plug-in allows you to create copies of a container with great ease. This function is 
typically used together with the Arrange plug-ins.

Coco Properties
Number of Copies: Sets the number of copies to be created when the function is executed.
Scene Tree Level: Allows you to select the hierarchic position of the copies.

same: Sets the copies on the same level as the source container.
down: Sets the copies as Sub-Containers to the source container.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Container
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Clear Transformation: Sets all transformation values on the new copies, like scaling, position 
and rotation, back to zero. All copies are stacked at a initial position with all transformation 
values set to zero.
Starting Index: Allows you to alter the starting point of the index numbering of the copies. 

By default, the numbering starts on 1 .

Container Name: Allows you to change the name the containers that is given by default.
Execute: After having set the required parameters, click this button to execute the 
duplicating process.

To Create Copies of Containers

Add the Coco plug-in to the container you want to copy.

Open the Coco editor and enter the Number of Copies (e.g. 10 )

Set Scene Tree Level to down.
Click the Execute button.

See Also

Arrange
Cobra

Colin

The Colin plug-in allows you to align a container in the scene using two other containers as 
reference. This makes it easy to maintain a good and controlled symmetry in the scene.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Container
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Colin Properties
Container 1: Is the drop zone for the first referential container.
Container 2: Is the drop zone for the second referential container.
HOffset %: Sets the horizontal offset between the referential containers in percent. 
Horizontal means here an invisible line between the referential containers regardless of the 
actual boning of the line.
VOffset: Sets the vertical offset from the horizontal line.
ZOffset: Sets the Z offset from the line between the referential containers.
Align container rotation

2D: Positions and rotates the container in the X- and Y-axis to keep itself aligned on 
the invisible line between the referential containers as they move when enabled.
3D: Positions and rotates the container in the X-, Y- and Z-axis to keep itself aligned 
on the invisible line between the referential containers as they move when enabled.

Automatic label orientation: Adapts the rotation angles automatically. This parameter only 
works if the Align container rotation parameter is switched to 2D or 3D.
Autoscale object: Unlocks the Scaling value.
Scaling: Scales the container to the provided value.

To Align Containers

Add the Cube, Sphere and Icosahedron geometries to the scene tree.
Open the transformation editor for Cube and Icosahedron and set them to Position X 

-200.0  and 200.0 , respectively, and Position Y 100.0 .

Add the Colin plug-in to the Sphere container.
Open the Colin editor and drag and drop the Cube and Icosahedron containers onto the
Container1 (left) and Container2 (right), respectively. The container is then aligned between
the two referential containers.
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Cora

The Cora plug-in allows you to sort a set of Sub-Containers based on multiple criteria. It is a useful 
tool when your scene starts getting complex and it is difficult to maintain the overview. To make 
sorts by different criteria it can help you reorganize the scene tree structure. It works on all 
containers under the container it is added to.

The plug-in is often used together with the Time Displacement plug-in which enables many 
creative possibilities.

Cora Properties
Criteria: Selects the wanted sort criteria.

Name: Performs a case sensitive sort. In normal sort order, capitalized letters are 
listed first. Be aware, use letter case consistently if you want to have a correct result 
when you perform a sort by name.
X: Sorts by X-values.
Y: Sorts by Y-values.
Z: Sorts by Z-values.
Vis: Sorts all the visible containers first.
Alpha: Sorts by the alpha value among those containers who have an alpha function 
attached. Alpha values set on the material of a container are ignored.
Key: Sorts containers by key function. Among those with key signal attached, the key 
alpha value is used for the further sorting.
Rand: Sorts by random.

Mode: Sets the order of the sorting. Choose between setting the Highest or 
the Lowest values.
Random Seed: Is relevant if you have chosen random as your sort criteria. It specifies a seed 
for the random number generator. Even though Viz Artist use random numbers, the 
animation for a specific random seed always looks the same.

Random Weight: Defines how random the randomize function sorts. Random 1.0  means 

random, random 0.0  does nothing and random 0.5  gives you a 50% chance if a container 

is resorted or stays in place.
Execute: Starts the operation.

To Organize the Scene Tree
Add the Cora plug-in to the container that holds the Sub-Containers you want to sort, select the 
sort criteria and press the Execute button.

See Also

Note: This plug-in is located in: Plugins -> Container plug-ins -> Container
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Time Displacement

Corena

The Corena plug-in renames all Sub-Containers of the container you apply it to. The plug-in is 
often used together with the Time Displacement plug-in which enables many creative possibilities.

Corena Properties
Name: Sets the name you want to rename the Sub-Containers to. You can define the number 
format of the new names by entering a hash in addition to the name for each digit you want 
in the numbering. If you enter ###newname, the containers are named: 001newname, 
002newname, and so on.
Add Index: Enables/disables creation of a numbering index.
Starting Index: Sets the number you want the numbering index to start from.
Reverse Index: Creates the index in a reversed order when enabled.
Execute: Starts the operation.

To Rename Container(s)
Add the Corena plug-in to the container that holds the containers you want to rename.
Enter the new name, set the indexing parameters and click Execute.

See Also

Cobra

Talent Tracker

The Talent Tracker plug-in reads the talent position corresponding to a Person ID from shared 
memory and sets the container position according to the talent position. To use the plug-in, drag 
the Talent Tracking plug-in onto a desired container. 

Information: This plugin is not needed anymore and is only available for compatibility 
reasons. Renaming containers is a built-in function of the Scene Tree.



Note: This plug-in is located in: Plugins -> Container plug-ins -> Container
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Talent Tracker Properties
Person ID: Sets the container position to the position of a specific talent.

The container position is updated according to the position of the talent in the live input.

Talent Tracking
The talent tracking functionality is used to find the talent in live input provided to the Engine. The 
talent tracking functionality relies on the Precision keyer, for it analyses the Precision keyer matte 
for acquiring the talent position. Currently a maximum of one person can be tracked.

The positions resulting from the talent tracking analysis is available in shared memory through 
keys starting with TRACKING_PERSON. The value stored along with these keys is a four-
dimensional vector of integer values, containing respectively, the X-coordinate and Y-
coordinate with respect to the width and height of the live input. Such that the format of the value 
becomes {x, y, width, height}.

As the currently supported maximum number of persons tracked is  1 , and shared memory entry 

besides index  0  should be discarded.

To Enable Talent Tracking

Since the talent tracking functionality relies on the color difference Keyer to be enabled on a 
provided live input, make sure that the Precision Keyer is enabled on the live input media asset.

The tracking functionality can be enabled by enabling Talent Reflections on the media asset.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Container

Note: Currently, there is a maximum of one trackable talent, therefore setting the 
Person ID parameter to anything above 1 is undesired.
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After enabling the talent tracking functionality, the talent positions can be accessed via shared 
memory, or used directly with a container by utilizing the Talent Tracker plug-in.

Toggle

Toggle is used to toggle between two objects. The plug-in is most commonly used with Transition 
Logic scenes.

This page contains the following topics and procedures:

Description and Methodological Considerations
Toggle Placeholder Containers
Toggle Directors and Key Frames

Toggle Properties

Description and Methodological Considerations
Toggle plug-in is one of the main building blocks of Transition Logic, and it is in general a 
relatively simple plug-in. When the Toggle plug-in is added to a container, it creates two child 
containers that act as placeholder containers for objects that can toggle on and off screen. In 
addition, it also creates some utility directors in the stage.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Container
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Toggle Placeholder Containers

The two placeholder containers correspond to an A-side and a B-side. Each of the placeholders 
again have a child container; one named current the other named other. The current is typically 
the visible container, while the other is not visible. At the time of a switch, these containers switch 
names. This means that at any given time it is not possible to know if the current parent is 
the A side or the B side. It is the responsibility of the Toggle plug-in to keep track of this.

Toggle Directors And Key Frames

The Toggle plug-in creates two directors each containing a default one second cross fade 
animation. These animations are placed in the AX and BX directors. AX can be interpreted as 
the A-side cross fade. The animations can be modified to show any kind of transition, but it is 
important that the AX and BX are the same.



Plug-ins User Guide -  5.0

Copyright © 2022  Vizrt Page  170

1.

2.

In addition to the cross fade directors the Toggle plug-in also creates placeholder directors for 
the object animations. Merged objects that are loaded into these placeholder containers during 
playback may contain animations embedded in the geometry object. The object animations are 
automatically added as a sub-director to the AO or BO director depending on if the object is being 
loaded on the A-side or B-side.

There are two different scenarios of when the utility directors are triggered:

When there is a state change. When there is a state change, the Toggle-Layer director is 
animated from the current state to the required next state. In this scenario, the utility 
directors are triggered according to the toggle Key Frames in the stage. This means that it is 
the position of these Key Frames that determine the timing of when the utility directors are 
triggered.
No state change, only changing the current object. When there is no state change, there is 
no movement of the Toggle-Layer director. In this case, the Toggle switch action is 
triggered, which animates the utility directors at the same time; animating the current object 
out and the next object in at the same time.

The plug-in has a built-in support for object loading. Enter the path to an object (e.g. 
GEOM*myfolder/myobject) into the Object field, and the plug-in loads this object on 
the other container. The object is by default invisible and can be loaded with data, before 
activating the Switch action to show the object.

An object loaded this way is cached, so that requesting the same object again does not trigger 
loading again. The object cache can also be preloaded by specifying all the geometries that should 
be preloaded before initializing the Toggle plug-in. Preloading of the objects needed by the Toggle 
plug-in is done when a playlist is initialized. For this reason the Preload Object text field should 
normally not be manually modified in Viz Artist.

Before adding the plug-in to a container in a scene, please make sure that:

Caution: It is NOT recommended to manually adjust the AO and BO directors.

Note: Placeholder containers and directors are only generated if none exists from before.
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You give the container a unique and sensible name. This name becomes the Toggle-
Layer name. Also, as the Toggle plug-in automatically generates directors, which are named 
based on the container name and its parents names, it is worth considering if the location of 
the container that hosts the Toggle plug-in is in the correct position in the scene tree.
The container the Toggle plug-in is added to must not have any child containers.
A director with the same name as the container (Toggle-Layer name) is created.
The director has a minimum of two stop points and that these stop points are named 
correctly. The names must correspond with the Toggle-Layer states.

After the Toggle plug-in has been added to the container, the plug-in icon can be clicked to 
see its properties. Clicking the Default Key Frames button creates the most commonly used 
Key Frames for triggering the toggling between the current and the other objects. Adjusting 
the timing can easily be done by moving the Key Frames in the stage.

Toggle Properties
Object: Shows the name of the currently loaded object (front scene GEOM). This field 
changes depending on the object loaded in the layer the toggle plug-in resides.
Show advanced: Shows the advanced parameters.

Auto-continue other object on Switch: Toggles a continue action to the other 
placeholder when a switch action is triggered when enabled.
State control only: Ignores all commands sent to the Toggle is ignored when enabled. 
This means that no object is loaded and only state changes on the layer director are 
run.
Controls video: Controls the toggling of video channel 3 and 4. This applies when 
using the Control Video plug-in.
Preload objects: Specifies the objects that are to be pre-loaded on initialization.
Director commands: Forms parameters into a valid set-director-position command, 
and applies them to either current or other placeholder object director. This field can 
be filled with certain director command parameters like for instance: SHOW 0.5, SHOW 
50f, SHOW $pilot1. 
Run director command on current and Run director command on other: Forms and 
applies a director command based on the director_commands field as described 
above.

Switch without animation: Switches the visible container without running any of the (A|
B)X directors or starting the object animation. The AX and BX directors are set to the
correct in/out positions.
Dummy: Is animated to create an animation that spans all the other toggle Key
Frames. In some cases, this solves problems with toggle Key Frames not being
triggered correctly.

Switch: Animates out the current placeholder, then switches the other placeholder to current 
and animates it in.

IMPORTANT! One of the Transition Logic requirements is to have a stop point named 
“O”. Best practice is to always name the first stop point “O” (frame 0).



Note: These options will be deprecated in future versions.
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Out: Animates out the current placeholder.
In: Animates in the current placeholder.
Switch in: Switches the other placeholder to current and animates it in.
Switch in preview: Hides the current placeholder without animating it, then switches the 
other placeholder to current. Afterwards it shows the new current placeholder by jumping to 
a director state suitable for generating a still preview.
Default Key Frames: Inserts default Toggle Key Frames to invoke the toggles utility directors.
Continue: Sends a continue action to the current object animation director.
Delete default Key Frames: Removes the default Key Frames that were generated by the 
Default Key Frames button.
Initialize: Clears the cache, and reloads pre-loaded geometries.
Position object director at preview location: Positions the object director at given preview 
location in position field when enabled.
Move object director to next stop: Moves the stage position to the next director stop point 
on a loaded object.
Delete containers for cached object: Deletes all the containers used as the Toggles object 
cache.

See Also

Transition Logic section of the Viz Artist User Guide.

4.4.3 Default
The following Container plug-ins are located in the Default folder:

Global Magnifier Controller
Screen2World
Trio Scroll Element

Global Magnifier Controller

The Global Magnifier Controller plug-in gives control over the global magnifier from inside a plug-
in. When the controller is assigned to a container, the global magnifier is applied to this container. 
The magnifier is positioned and scaled according to the positional and scale values of the host 
container. The plug-in additionally provides access to the global magnifier 
properties Scale, Ellipsis and Alpha.

Please observe that only one Magnifier Control plug-in may be active within a scene at any given 
time. Because of this, if there are several instances of the Global Magnifier Controller, the global 
magnifier is only applied to the last instance activated. However, when the currently applied 
controller is deactivated, the plug-in automatically applies the global magnifier to the next 
container with an active controller plug-in. The global magnifier is fully deactivated only when 
there are no active controllers left.

http://documentation.vizrt.com/viz-artist
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Global Magnifier Controller Properties

Scale: Sets the scale of magnification. The minimum value is  1.0 , the maximum value 

is  100.0 . The default value is  2.0 .

Ellipsis: Creates an ellipsis effect, mimicking the distortion created by a concave or convex 

lens. The minimum value is  -10.0 , the maximum value is  10.0 . The default value is  0.0 .

Alpha: Sets the alpha value for the magnification. The minimum value is  0.0 , the maximum 

value is  100.0 . The default value is  100.0 .

Active: Enables or disables magnification. Can be set to  On  or  Off . By default, this is set 

to  On .

Screen2World

The Screen2World plug-in converts the passed screen positions X and Y to world positions X, Y and 
Z, and sets them for the container the plug-in is applied to.

Screen2World Properties
Screen Position X: Sets the X value for the screen position. Accepted values are floating point 

numbers ranging from  -100000.0  to  100000.0 . The default value is  0.0 .

Screen Position Y: Sets the Y value for the screen position. Accepted values are floating point 

numbers ranging from  -100000.0  to  100000.0 . The default value is  0.0 .

Trio Scroll Element

The Trio Scroll Element plug-in is used for data storage by the Trio Scroll Geometry plug-in. It is 
automatically added to each base element of a Viz Trio scroll scene.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Default

Note: This plug-in is located in: Plugins -> Container plug-ins -> Default

Note: This plug-in is located in: Plugins -> Container plug-ins -> Default



Plug-ins User Guide -  5.0

Copyright © 2022  Vizrt Page  174

•
•
•
•

•
•

•

•

•

•

•
•

Trio Scroll Element Properties
Prototype: Sets the path and the name of the scene.
Extra space before element: Sets the space before the element.
Extra space after element: Sets the space after the element.
Easepoint 0-4 enabled: Enables the easepoint(s).

Identifier: Sets the identifier for the easepoint.
Slow down length (EaseOut): Sets the size in pixels that is used to ease out the scroll 
element.
Speed up length (EaseIn): Sets the size in pixels that is used to ease in the scroll 
element.
Pause time in seconds, or -1 (indefinitely): Sets the time in seconds for how long the 
scroll should wait before continuing the scroll.

Element alignment (0.5 for center): Sets the alignment of the element relative to the 

height of the element. 0.5  (equal to 50%) is the default value and represents the 

middle of the element’s bounding box area.
Scroll area alignment (0.5 for center): Sets the scroll alignment for the element in the 

scroll area. 0.5  (equal to 50%) is the default value and represents the middle of the 

scroll’s bounding box area.

See Also

Create New Scroll in the Viz Trio User Guide
Trio Scroll Geometry plug-in

4.4.4 Container FX
Container FX is much like TextFX, except that instead of text, a set of containers are added under 
the plug-in. Instead of animating the containers, Container FX animates the containers below (aka 
the container-Set). Those containers can be circles and so on. Most of the Container FX plug-ins 
share a set of Common Properties.

Like Text FX plug-ins use containers, a Container FX plug-in uses a set of containers under the 
plug-in and change their position like Text FX does. It is recommended to be familiar with Text FX 
before designing with Container FX to understand the idea. You can also use the Cloner plug-in to 
create the necessary containers under the plug-in.

Note: This affects the total time the scroll is scheduled to use.

http://documentation.vizrt.com/viz-trio
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In the above example, the containers under the group container with the Sphere names is the 
container-set, and is animated here. 

The following Container plug-ins are in the Container FX folder:

Common Container FX Properties
CFX 2D Follow
CFX Alpha
CFX Arrange
CFX Color
CFX Explode
CFX Jitter Alpha
CFX Jitter Color
CFX Jitter Position
CFX Jitter Scale
CFX Plus Plus
CFX Rotate
CFX Scale

Common Container FX Properties
The following properties are common to most of the Container FX plug-ins:

Progress %: 0% progress is the beginning of the effect, 100% the end. Animate this value 
from 0% to 100% to see the effect or from 100% to 0% to animate the effect backwards.
Progress Type

Absolute: 100% progress animates all container’s set, regardless of how many 
containers it has.
Relative: 100% progress animates ten containers. This is needed to adjust the timing 
of several containers with different sizes. The effect speed should be for example five 
containers per second, so the animation must be from 0% to 100% in two seconds. 
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This works for with ten containers or less. If you want to use more containers, animate 
the progress value over 100% (10% for each container).

Direction: Sets the direction of the effect sequence, you can choose between the following 
options:

Left: Starts with the first container in the containers-set.
Right: Starts with the last container in the containers-set.
Random: Uses a random order.
Static: Processes all containers at the same time.
Wave: Starts with the first container, animates the effect from zero: 100% and then 
down again to 0%.
Center: Starts the effect from the center of the containers-set.
2 Center: Starts the effect at the same time from the beginning and the end of the 
containers-set. They meet at the center.

Interpolate: Chooses between a soft or a linear interpolation of the transition from container 
to container.
Effect Range: Defines how many containers are processed at the same time. If for example 

the Effect Range is set to  4 , and you manually increase the progress value, you see that 

when the fifth container starts to be processed, the first is finished, when the sixth starts, 
the second is finished, and so on.
Random Seed: Specifies a seed for the random number generator when a random direction 
is chosen. Even though Viz Artist uses random numbers, the animation for a specific random 
seed always looks the same. This is typically useful if you combine two different container 
effects.
Container Order: Sets the container order for the effect. Available options are As Is, 
Horizontal or Vertical. Horizontal and Vertical enables the containers -set Direction options.
Direction: Sets the horizontal and vertical container-set direction (see Container Order). 
When the containers-set order is set to Horizontal, the container-set direction must be set to 
Left to Right or Right to Left. When the container order is set to Vertical, the containers-set 
direction must be set to Up to Down or Down to Up.

CFX 2D Follow

The Container FX 2D Follow plug-in creates an animation of geometry containers following a path 
defined by the 2D Ribbon geometry plug-in. The 2D Ribbon plug-in must be added as a parent 
container to the container holding the Container FX 2D Follow plug-in. The geometries that are to 
be animated needs to be added as sub-containers to the container holding the Container FX 2D 
Follow plug-in.

Note: This plug-in is located in: Plugins -> Container plug-ins -> ContainerFx
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CFX 2D Follow Properties
Positioning: Absolute positioning evenly distributes the followers across the entire length of 
the spline. Relative means that the followers are added from left to right along the spline.
Path Position: Moves the followers along the 2D Ribbon shape.
Position Wrap: Interpolate means that text continues in the direction set by the last section 
of the spline; Clamp stops the string on the spline end-point; Repeat causes the string to 
move to the other spline end-point as soon as it moves over the end-point.
Kerning Scale: Scales the kerning of the spline.
Align: Rotates the followers by Z to align the X-Axis with the tangent of the spline at the 
followers’ position.
Translation offset: Moves the followers from the spline in the XY plane.
Rotation: Rotates the followers using the spline as a rotation axis.

To Set Up the CFX 2D Follow Plug-in
Add the 2D Ribbon geometry to the scene tree, then open the 2D Ribbon editor and 
enable Show Control Point Values.

Set alternating values of  30.0  and  -30.0  to the Y axis values, creating a wave shape.

Add a sub-container to the 2D Ribbon container, and add the Container FX 2D Follow plug-in 
to the newly created container.
Add the geometries that are to be animated along the 2D Ribbon’s path as sub-containers to 
the Container FX 2D Follow container.
Open the Container FX 2D Follow editor and animate its Path Position value 

from  0.0  to  100.0 .

See Also

Common Container FX Properties
2D Ribbon

CFX Alpha

The Container FX Alpha plug-in is a container-set effect that creates a fade in effect for the 
containers in the set. The effect sequence can be set to go many different ways. A fade in and out 
effect can also be achieved.

CFX Alpha Properties
Alpha Begin %: Sets the alpha level of the containers at 0% effect.
Alpha End %: Sets the alpha level of the containers at 100% effect.

Note: This plug-in is located in: Plugins -> Container plug-ins -> ContainerFx
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See Also 

Common Container FX Properties

CFX Arrange

The CFX Arrange plug-in arranges containers in either a circular or a wave shape. The containers 
can be animated on the selected shape by animating the offset value.

CFX Arrange Properties
Offset %: Moves the containers on the shape. 100% means one full rotation of the containers-
set on the circle.
Scale %: Sets the container-set on the shape. The parameter does not scale the containers, 
but the center of the bounding box of the containers.
Shape: Changes the shape of the container layout. The options are Circle or Wave.
Diameter: Sets the diameter of the circular shape.
Positioning: Defines the position of the container-set on the circular shape. Relative means 
that the spacing of the container-set is maintained. Absolute means that the container-set is 
evenly distributed out on the circle.
Direction: Sets the direction of the container-set on the circle to either Clockwise or 
Counterclockwise.
Rotation: Rotates the container-set on the X-axis.
Align: Aligns the container along the curve.

See Also 

Common Container FX Properties

CFX Color

The CFX Color plug-in adds a color effect to the containers-set.

CFX Color Properties
Color Start: Sets the initial color before applying the effect.

Note: This plug-in is located in: Plugins -> Container plug-ins -> ContainerFx

Note: This plug-in is located in: Plugins -> Container plug-ins -> ContainerFx
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Color End: Sets the color the effect should apply.

See Also 

Common Container FX Properties

CFX Explode

The CFX Explode plug-in creates an explosion like function where the containers get thrown away 
from their initial position. The speed, direction and spread of the moving containers can be altered 
with parameters.

CFX Explode Properties
Duration: Defines the duration of the progress for each of the containers. Simply increase 
the value if you want it last longer. You could achieve the same by making the gravity 
stronger and animating the progress slower, but it is easier to increase the duration instead 
if your explode effect is too short.

Opening Angle: Sets the angle for the spread of the containers. 0  sends them straight up, 

360  spreads them in a circular shape.

Angle Rotate X: Rotates the opening angle around the X-axis.
Angle Rotate Y: Rotates the opening angle around the Y-axis.
Force: Sets the force that throws away the containers. A high force makes them go far away, 
conversely a low force creates only a small motion of the containers.
Force Spread %: Sets a variation of the force among the containers.
Use Axis: Allows you to select on which axis or combination of axes the containers are to 
spread along.
Gravity: Sets a gravity force that influences the path of the containers to end up going 
downwards. The higher the value is set, the faster each container diverts from its initial path 
and starts going downwards.
Use Rotation: Rotates the container as they are being thrown away from their initial position 

when set to On .

Rotation Force: Sets the degree of rotation as the containers are being thrown away.
Show Force: Shows lines showing the containers path and speed in the Scene Editor when set 

to  On .

See Also

Common Container FX Properties

Note: Works only if the containers-set is set to texture.

Note: This plug-in is located in: Plugins -> Container plug-ins -> ContainerFx
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CFX Jitter Alpha

The CFX Jitter Alpha plug-in creates a jittering motion of the containers by randomly changing the 
alpha value of each container. The degree of change and the start sequence of the jittering can be 
altered. To use the plug-in, add it onto a container with a font. To create an animation, animate 
the progress. Other values can of course be animated as well.

CFX Jitter Alpha Properties
Effect What: Defines where the effect should have an effect. Available options are 
background (BG), foreground (FG) or both.
Alpha Begin: Sets the alpha level of the container at 0% effect.
Alpha End: Sets the alpha level of the container at 100% effect.
Randomness: Sets the intensity of the jittering alpha changes.

See Also

Common Container FX Properties

CFX Jitter Color

The CFX Jitter Color plug-in animates a jittering effect on the color of the container.

CFX Jitter Color Properties
Anchor Horizontal: Sets the anchor point for the containers on the horizontal plane.
Anchor vertical: Sets the anchor point for the containers on the vertical plane.
Use Axis: Defines on which axis or axes the containers scale to create the jittering effect.
Lock Axis: Applies the same Min, Max and Randomness settings to all axes when enabled. If 
you disable randomness, these parameters are visible for each of the axes and must be set 
individually.
Min: Sets the minimum scaling for the containers.
Max: Sets the maximum scaling for the containers.
Randomness: Sets the intensity of the jittering movement.

Note: This plug-in is located in: Plugins -> Container plug-ins -> ContainerFx

Note: This plug-in is located in: Plugins -> Container plug-ins -> ContainerFx
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See Also

Common Container FX Properties

CFX Jitter Position

The CFX Jitter Position plug-in creates a jittering motion of the containers by randomly changing 
the position of each container. The degree of position change and the starting sequence of the 
jittering can be altered. To create an animation, animate the progress. Other values can of course 
be animated as well.

CFX Jitter Position Properties
Use Axis: Defines on which axis or axes the containers moves to create the jittering effect.
Lock Axis: Gives the same values for Range and Randomness for all axes when enabled. If 
you disable it, Range and Randomness for each of the axes is shown and can be set 
individually.
Range: Sets the range of the jittering movement.
Randomness: Sets the intensity of the jittering movement.

See Also 

Common Container FX Properties

CFX Jitter Scale

The CFX Jitter Scale plug-in animates a jittering effect on the scale of the container.

CFX Jitter Scale Properties
Anchor Horizontal: Sets the anchor point for the containers on the horizontal plane.
Anchor vertical: Sets the anchor point for the containers on the vertical plane.
Use Axis: Defines on which axis or axes the containers scale to create the jittering effect.
Lock Axis: Gives all axes get the same Min, Max and Randomness settings when enabled. If 
you disable randomness, these parameters are visible for each of the axes and must be set 
individually.

Note: This plug-in is located in: Plugins -> Container plug-ins -> ContainerFx

Note: This plug-in is located in: Plugins -> Container plug-ins -> ContainerFx
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Min: Sets the minimum scaling for the containers.
Max: Sets the maximum scaling for the containers.
Randomness: Sets the intensity of the jittering movement.

See Also 

Common Container FX Properties

CFX Plus Plus

The Container FX Plus Plus plug-in allows you to set a number of effects on a container’s set.

CFX Plus Plus Properties
Position Wrap

Extrapolate: Continues the direction of the spline when set above 100% or below 0% of 
Path Position.
Clamp: Stops the string on the spline endpoints.
Repeat: Causes the string to move to the other spline endpoint as soon as it moves 
over the endpoint.
ContainerFx: Positions containers by the relative spline of each container using the 
ContainerFx parameters.

Scheme Type: Defines how the container-set looks at 0% and 100% progress.
In -> In: at 0% first container is at the beginning of the spline, at 100% last container is 
at the end of the spline.
In -> Out: at 0% first container is at the beginning of the spline, at 100% first container 
is at the end of the spline.
Out -> In: at 0% last container is at the beginning of the spline, at 100% first container 
is at the end of the spline.
Out -> Out: at 0% last container is at the beginning of the spline, at 100% last 
container is at the end of the spline.

Progress (%): Animates the progress of the effect(s).

See Also

Common Container FX Properties

Note: This plug-in is located in: Plugins -> Container plug-ins -> ContainerFx
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CFX Rotate

The CFX Rotate plug-in allows you to create an effect where the containers rotate on the X-, Y- or Z-
axis.

CFX Rotate Properties
Anchor Horizontal: Sets the anchor point for the containers on the horizontal plane.
Anchor Vertical: Sets the anchor point for the containers on the vertical plane.
Use Axis: Defines on which axis the containers rotate.
Begin: Sets the initial rotated position of the containers.
End: Sets the ending rotated position of the containers.

See Also

Expert
Common Container FX Properties

CFX Scale

The CFX Scale plug-in allows you to create a scaling animation of the containers.

CFX Scale Properties
Anchor Horizontal: Sets the anchor point for the containers on the horizontal plane.
Anchor Vertical: Sets the anchor point for the containers on the vertical plane.
Use Axis: Defines on which axis or axes the containers scale.
Lock Axis: Scales the Begin- and End the same way for all the axes when enabled. If you 
disable the option, Begin and End must be set for all axes individually.
Begin: Sets the initial size of the containers.
End: Sets the ending size of the containers.

See Also 

Common Container FX Properties

Note: This plug-in is located in: Plugins -> Container plug-ins -> ContainerFx

Note: This plug-in is located in: Plugins -> Container plug-ins -> ContainerFx
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4.4.5 Control
The following Container plug-ins are located in the Control folder:

Apply Shared Memory
Control Action
Control Action Table
Control Audio
Control Bars
Control Chart
Control Clip
Control Clock
Control Condition
Control Container
Control Data Action
Control Datapool
Control DP Object
Control FeedView
Control Text
Control Geom
Control Hide in Range
Control Hide on Empty
Control Image
Control Key Frame
Control List
Control Map
Control Material
Control Multihop
Control NDI
Control Num
Control Object
Control Omo
Control Parameter
Control Payload
Control Pie
Control Scaling
Control Sign Container
Control SoftClip
Control Stoppoint
Control VBI
Control Video
Control World
Control Field Renamer
Placeholder
Common Control Properties
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Apply Shared Memory

The Apply Shared Memory plug-in allows values to be transferred into Viz Engine using 
mechanisms provided by shared memory maps that can be applied to control plug-ins such 
as Control Text. Just as Control Object acts as a distribution hub for content provided by control 
applications, the Apply Shared Memory plug-in acts as a distribution hub for content provided by 
external systems feeding real-time data through the shared memory maps.

The control plug-ins that the Apply Shared Memory plug-in can apply content to resides in the 
same folder.

Just like the Control Object plug-in, the Apply Shared Memory plug-in only applies values to control 
plug-ins residing in the subtree of the scene tree where the Apply Shared Memory plug-in resides. 
Also like the Control Object plug-in, it matches the keys of incoming content with the field 
identifiers of individual control plug-ins to determine where to apply which incoming content 
value.

This page contains the following topics and procedures:

Apply Shared Memory Properties
Visualize Composite Data Structures
How Shared Memory Keys are Determined
To Visualize Stock Data from Shared Memory
To Test Stock Visualization

Apply Shared Memory Properties
Shared Memory Source: Specifies which shared memory map to apply values from. 
The Scene, Global and Distributed choices select the shared memory maps that are referred 
to as Scene.Map, System.Map and VizCommunication.Map respectively in the section.
Memory Base Key: Provides the key prefix path to combine with the field identifiers of 
control plug-ins to determine the key to look up in the chosen shared memory map when 
applying values to a particular field exposed by a control plug-in.
Expose Base Key: Exposes the Memory Base Key property as a controllable field. Once this 
option is turned on the properties Field Identifier and Description as described in 
the Common Control Properties section can be specified.
The Expose Base Key property is typically used to allow a control application to control the 
base key which determines where in the shared memory map to pull values from. However, 
since the exposed property is an exposed control field like any other, a parent Apply Shared 
Memory plug-in can be used to make the shared Memory Base Key property controllable by 
external systems through a shared memory map.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Control
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Choosing whether to allow the exposed field to be controlled by control applications or external 
systems feeding the shared memory map is done by placing either a Control Object or another 
Apply Shared Memory plug-in on a parent container, respectively.

Visualize Composite Data Structures
The Memory Base Key property combined with the field identifiers exposed by control plug-ins can 
be seen as a way to visualize sets of related key-value pairs stored in shared memory maps. While 
the Memory Base Key property specifies where in the shared memory map to locate the set of 
related key-value pairs, the exposed field identifiers specify which of the related key-value pairs 
from the selected set to visualize in a particular way in the scene subtree.

For example, the Memory Base Key property can specify a shared memory path representing a 
particular stock symbol, while the field identifiers of control plug-ins picks out particular values 
such as stock name, value and change from that location in the shared memory map.

Since the Apply Shared Memory plug-in only affects the scene subtree it is placed on, visualizing 
multiple composite data structure instances sharing the same structure and presentation can 
easily be achieved by copying subtrees and only change the Memory Base Key property.

For example, design a stock presentation design once, and copy it many times to create a scene 
showing several distinct stocks using the same visual style. Turning on the Expose Base 
Key property gives users of control applications control of which stocks to show in each 
presentation copy, while the data content for each stock is still supplied in real-time through the 
shared memory map.

How Shared Memory Keys are Determined
The shared memory keys used to look up values in a shared memory map is constructed by the 
combination of an absolute path specified in Memory Base Key property and an either relative or 
absolute path consisting of the field identifier of an exposed field. Any path starting with a slash 
(/) is considered an absolute path, while all other paths are considered relative.

If the field identifier is an absolute path, then that absolute path alone is the result of the resulting 
shared memory key used. For example, the field identifier /weather/norway/bergen/
temperature results in the shared memory key /weather/norway/bergen/temperature regardless 
of what the Memory Base Key property is.

If the field identifier is a relative path, the path is interpreted relative to the absolute base path 
provided in the Memory Base Key property, and the absolute path resulting from that 
interpretation is used as the shared memory key. For example, a Memory Base Key property of /
weather/sweden/stockholm and a field identifier of temperature results in the shared memory key 
/weather/sweden/stockholm/temperature.

Like file system paths, a path segment consisting of a single dot (.) is considered referring to the 
current directory, while two dots (..) is considered referring to the parent directory. This notation is 
resolved to a regular absolute path before using the result as a shared memory key. For example, 
a Memory Base Key property of /weather/./norway/trondheim and a field identifier of ../bergen/
windspeed resolves to the shared memory key /weather/norway/bergen/windspeed.
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To Visualize Stock Data from Shared Memory

This procedure visualizes composite content fed through a shared memory map to the control 
plug-ins Control Text, Control Num and Control Sign Container.

Create a new container.
Drag and drop a Apply Shared Memory plug-in into this container.

Set the Memory Base Key property of the Apply Shared Memory plug-in to /stocks/nyse/

ibm .

Create two text geometries as children of this container.
Drag and drop a Control Text plug-in into the first text geometry container.

Set the Field Identifier property of the Control Text plug-in to name .

Turn off Use formatted text property of the Control Text plug-in.
Drag and drop a Control Num plug-in into the second text geometry container.

Set the Field Identifier property of the of the Control Num plug-in to value .

Create a third container as a child of the Apply Shared Memory plug-in container.
Drag and drop a Control Sign Container plug-in into this container.

Set the Field Identifier property of the of the Control Sign Container plug-in to value .

Create three text geometries as children of the Control Sign Container plug-in container.
Drag and drop a Control Num plug-in into each of these three text geometry containers.

For each of these three Control Num plug-ins set the Field Identifier property to change .

Arrange the layout of the text geometries, and apply materials for styling.
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To Test Stock Visualization

To test that stock visualization commands can be sent to populate the global shared memory map, 
see the descriptions in the section.

While these commands are suitable for testing the designs, a real external system that feeds the 
Viz Engine with data would use a more efficient data transfer protocols to populate the shared 
memory map. See the External Data Input section of the Viz Artist User Guide for information 
about sending data efficiently using UDP.

When changing a value in the shared memory map that is visualized by a control plug-in the scene 
updates immediately to reflect the new value. The shared memory map can be populated with 
stock values for many stock symbols, including stocks that are not visualized at the moment. As 
soon as the Memory Base Key property of the Apply Shared Memory plug-in is changed to visualize 
the values for a different stock symbol, and the scene updates immediately to reflect the value 
previously populated into the shared memory map for that stock symbol.

Control Action

The Control Action plug-in executes an action, for example Viz Engine commands or Control 
Object commands, when receiving input on the input field.

The action can contain more than one command to be called, and the commands must be 
separated by semicolons. When Notify Only When Value Change is checked the actions are only 
triggered if the input value differs from the one already stored on the “input” field from previous 
invocations.

http://documentation.vizrt.com/viz-artist
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Control Action Properties
Input Value: Specifies the value input to compare against.
Notify Only When Value Change: Triggers a command when a value is changed.
Action Type:

Viz Command: Triggers an internal Viz Engine command (e.g. 

" THIS_SCENE*STAGE*DIRECTOR*Audio START" ).

ControlObject Command: Triggers a ControlObject command (e.g.  "ON 1 SET 

abc" ).

Action: Actions to execute if values match.

See Also

Common Control Properties
Control Object

Control Action Table

The Control Action Table plug-in allows defining a table of actions similar to Control Action. The 
actions are associated with a given value. When Control Action Table receives input, it compares 
the received data to each of the values. If the data matches one of the values the plug-in starts the 
corresponding action.

Control Action Table Properties
Input Value: Specifies the value input to compare against.
Notify Only When Value Change: Triggers a command when a value is changed.
Value 1/2: The value that the given action should be associated with.
Action 1/2: Actions to execute if value match.
Default Action: Executes if the input does not match any of the specified values.

See Also

Common Control Properties
Control Object

Note: This plug-in is located in: Plugins -> Container plug-ins -> Control

Note: This plug-in is located in: Plugins -> Container plug-ins -> Control
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Control Audio

The Control Audio plug-in enables the operator of a control application to choose a sound clip.

To expose the different properties, and change the audio file in one of the control applications, 
simply add the Control Audio plug-in to the same container as the Audio plug-in.

Control Audio Properties
Director: Sets the name of the stage director the audio channel is located below.
Audio Key Frame: Sets the ID/name of the audio clip Key Frame.

Important: Make sure the audio clip name does not contain any white spaces.

See Also

Common Control Properties
Control Object
Audio

Control Bars

The Control Bars plug-in allows binding of tab field values to the Bar Value fields in the Bar values 
presenter plug-in. Each bar value property in the Bar Values editor is presented as a separate tab 
field in Viz Trio.

Control Bars Properties
First Bar Field ID: Sets the tab-field ID for the first Bar value.
Last Bar Field ID: Sets the tab-field ID for the Last Bar value.
Expose Bars Max/Total Value: Exposes the Bars Max/Total value as a separate tab field when 
enabled.

See Also

Note: This plug-in is located in: Plugins -> Container plug-ins -> Control

Note: It is mandatory to add Director and Audio Keyframe name.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Control
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Common Control Properties
Control Object

Control Chart

The Control Chart plug-in binds control of chart data to a Control Object. It currently supports the 
graph geometry plug-in and the bar values, pie values and Visual Data Tools Geometry plug-ins. It 
serves the purpose to interface all kind of chart data. It covers graph charts, bar charts, pie charts, 
area charts and generally all kind of plug-in data, which has a table-like representation.

Control chart offers the same kind of interface like control list. That means it delivers a schema 
specification as type encoding. The chart data is communicated as an XML table value fully 
compatible to control list values. The supported control chart commands mimic the control list 
commands.

Control Chart Properties
Custom Number of Exposed Rows: Enables the Number of exposed Rows setting.

Number of exposed rows: Sets the default number of exposed rows for the scene 
when the number of rows can be changed by the operator. If the number of rows 
cannot be changed the number of exposed rows is fixed.

Mutable Number of Rows: Allows the operator can add or delete rows if set to on.
Custom minimum and maximum Number of Rows: Enables the Minimum and 
Maximum Number of Rows settings. To the operator, the number of fields can only be 
added or deleted when inside the range (e.g. greater than two and less than ten).

See Also

Common Control Properties
Control Object
Visual Data Tools Geometry

Note: This plug-in is located in: Plugins -> Container plug-ins -> Control

IMPORTANT! If Control Chart is used in combination with Visual Data Tools Geometry plug-

ins, make sure the Visual Data Tools plug-in Shared Memory is set to Inactive .
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Control Clip

The Control Clip plug-in binds control of an AVI clip played by MoViz or SoftClip to a Control 
Object. With the Control Clip plug-in the clips may be changed within the control application.

The MoViz plug-in enables the user to play media files or media streams inside Viz Engine. MoViz 
uses the Microsoft DirectShow Filtergraph framework to render the media. Therefore it is possible 
to play for example MPEG and QuickTime files or streams from a server. For the latter to work, the 
system must be appropriately equipped.

SoftClip is a Viz Artist/Engine plug-in that can show AVI clips, either projected on a texture, or 
rendered directly.

Control Clip Properties
This plug-in does not have any properties or parameters except those that are common to all plug-
ins.

See Also

Common Control Properties
Control Object

Control Clock

The Control Clock plug-in allows the user to set time for a clock as well as controlling several clock 
functions. The clock object is a text container in the scene with the clock function enabled.

Control Clock Properties
Expose Limit: Enables the user set a limit for the clock.
Expose Direction: Enables the user to choose the direction for the clock.
Action: Sets the clock action that is the default value in the control client’s clock editor.
Input Value: Shows the current value for the plug-in. It is not necessary to set any value here. 
It is normally only used for debugging purposes.

See Also

Note: This plug-in is located in: Plugins -> Container plug-ins -> Control

Note: This plug-in is located in: Plugins -> Container plug-ins -> Control
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Common Control Properties
Control Object

Control Condition

The Control Condition plug-in triggers actions based on the input given in a tab-field with the 
same field identifier.

Control Condition Properties
Input Value: Shows the current input value to the plug-in.
Format: Sets the format for the input value that it should conditionally trigger on.

Condition: Sets the type of condition if Format is set to number.
Arguments: Sets the arguments for the conditional operation.
Action Type / Action: Sets the action that is to be performed when the condition is met. It 

can be a control object command like “ON 2 SET mytext”  or a Viz Engine command 

prefixed by a zero and a space.
Use Else Commands:  Triggers an else action when the input data falls within the conditions 
when enabled.

Else Action: Sets the else action that is triggered when the input data does not fall 
within the conditions.

Example Actions
Actions can be Control Object commands in the form like this:

“ON 2 SET Mike Johnson”

or commands like:

0 RENDERER*STAGE START

Viz Engine commands must be prefixed with a zero followed by a space. This is to enable the plug-
in to recognize that the command should be interpreted as a Viz Engine command.

See Also

Common Control Properties
Control Object

Note: This plug-in is located in: Plugins -> Container plug-ins -> Control
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Control Container

The Control Container plug-in exposes a range of different transformation properties for a 
container.

Control Container Properties
The following properties can be exposed:

Visibility
Object
X/Y/Z position
X/Y/Z rotation
X/Y/Z scaling
For position, rotation, and scaling a stop point Key Frame can be specified. This enables the 
user to control a Key Frame in an animation, for instance the end Key Frame in a position 
animation.

See Also

Common Control Properties
Control Object

Control Data Action

The Control Data Action plug-in binds control of a control parameter to a Data Action.

Control Data Action Properties
Input value: Shows the current input value.
Prefix: Adds a prefix, if required.
Postfix: Adds a postfix, if required.

See Also

Note: This plug-in is located in: Plugins -> Container plug-ins -> Control

Note: This plug-in is located in: Plugins -> Container plug-ins -> Control
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Common Control Properties
Control Object

Control Datapool

The Control Datapool plug-in is used with the DataPool plug-in repository, available separately. 
The plug-in is used to bind a tab field value to a DataPool plug-in variable. Any DataPool plug-in 
used in a scene must have its variable listed in the DataPool scene plug-in. Control Datapool links 
a tab-field to these variables.

For more information about the DataPool plug-ins, refer to the DataPool documentation.

Control Datapool Properties
DataPool Variable: The DataPool variable can be controlled by the user.
Input Value: Shows the current input value.
Control Type: Specifies if the tab-field value should be controlled through a DataPool 
variable or a field name.
Variable Type: Allows the user to define the kind of data the referenced variable is linked to. 
The type selected here decides what kind of editor is opened in a Viz Trio client.

See Also

Common Control Properties
Control Object

Control DP Object

The Control DP Object allows copying or linking of Data Pool objects.

Control DP Object Properties
Input value is: Select from Object to COPY, Object to LINK or Direct VALUES
Input value: Shows the current input value.

See Also

Common Control Properties

Note: This plug-in is located in: Plugins -> Container plug-ins -> Control

Note: This plug-in is located in: Plugins -> Container plug-ins -> Control
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Control Object

Control FeedView

The Control FeedView plug-in sets the Feed View locator to a given value.

Control FeedView Properties
Locator: Sets the FeedView locator to a given value.
Prefix: Sets prefix to add to the front of the locator key.

Example Input Values

/nyse/nasdaq/cisco /nyse/nasdaq/intc

If a prefix is set, it is added to the front of the locator key, a prefix of:

/nyse/nasdaq

With an input of:

IBM

Resolves to:

/nyse/nasdaq/IBM

The locator field is the value as received from ControlObject. It is trimmed of CR/LF before 
concatenated into a FeedView key.

See Also

Common Control Properties
Control Object

Note: This plug-in is located in: Plugins -> Container plug-ins -> Control
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Control Text

The Control Text plug-in binds the control of Text or Classic Text to a Control Object depending 
on the container geometry. If neither Text or Classic Text is in the container, the Control Text 
plug-in uses the scene setting to determine which render engine to use.

This plug-in expects the input value in UTF-8 encoding.

Control Text Properties

This plug-in is located in: Plugins -> Container plug-ins -> Control
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Maximal characters: Sets the maximum number of characters which can be typed into the 
text field.

Upper Case: Converts lower case input into upper case when set to  On .

Expose kerning*1: Allows changes to the kerning parameters and sets the minimum and 

maximum value when set to  On .

Expose line spacing*1: Allows changes to the line spacing parameters and set the minimum 

and maximum value when set to  On .

Expose Font: Allows selection of different Font when set to  On .

The exposed field is .font on Classic Text.
The exposed field is .font_face on Text.

Expose justification*1: Allows changes to the text justification when set to  On .

Single Line: Converts multi-line input into a single line when set to  On .

Use Formatted Text: Enables use of character specific formatting in supported client 
applications. Character specific formatting includes bold, italic, subscript, superscript, 
kerning, position, rotation, scaling, alpha, and color(RGB) in Classic Text, modifier, font size, 
color(ARGB) in Text. Formatted text cannot be used together with the Text FX Write plug-in.

To use the characters <   and >  correctly in Viz Multichannel, make sure that Use 

Formatted Text is set to  OFF .

Character specific formatting is not supported for Viz Pilot.
In Viz Trio, the operator enter a required formatting mode via an assigned shortcut 
key. To change the format of one or more characters, hold down ALT and toggle the 
right and left arrow keys to shift mode. See the Viz Trio User Guide for more 
information on Character Formatting.

Escape formatted text:Simplifies formatted text output. Use XML escape characters instead 

of XML <![CDATA[]]> and not add an XML root element. Use  <fo:wrapper/>  element only 

with formatted words and characters. Control Text still accepts both full formatted and 
escape formatted text input independent of this property.
Include default property values: Add all available properties of formatted text output even all 
values are defaults. This can guarantee all supported formats by Control Text can be 
transferred to another Text via XML.

Input Value*1: Shows the current value for the plug-in. It is not necessary to set any value 
here. It is used for debugging purposes.

Input Value(UTF8)*2: Shows the current value for the plug-in. It is not necessary to set any 
value here. It is used for debugging purposes.

Simulate classic commands*2: Allow Viz Trio uses Classic Text commands via Control Object 
to control styles of new Text in Viz Engine Renderer.

*1: only available with Classic Text

*2: only available with Text

http://documentation.vizrt.com/viz-trio
http://documentation.vizrt.com/viz-trio
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Shared Memory Placeholders

The Control Text plug-in supports Shared Memory placeholders. Placeholders can be described by 
${shm_key}, where shm_key is the name of a Global Shared Memory Map. You can also define a 
default value by adding a pipe and the value. For example: ${shm_key,Default}, where Default is 
used as default value if the Shared Memory Map is empty or does not exist.

Shared Memory maps can be accessed and changed in various ways, like an external command, 
script etc...

Example

This shows "Hello world" by default. By sending GLOBAL*MAP SET_STRING_ELEMENT test This is my 
new value from a shared memory the text changes to the new value.

Formatted Text Wrapper

Format single or multiple characters by cover them with <fo:wrapper /> element and add any or 
multiple of these attribute attributes.

All available formatters

XML 
Attribute

Data 
Type

Min Max Note Example

kerning letter-
spacing

float - - Existing value of 
text is not 
changed if no 
new value of 
these modifiers is 
specified.
This formatter 
affects space 
between covered 
and next and all 
followed 
characters.

From this 
example. 
"END" is 
moved to 
the left side 
of another 
("TEST").

<fo:wrapper 
letter-
spacing="80"
>T</
fo:wrapper>
<fo:wrapper
letter-
spacing="40"
>E</
fo:wrapper>
<fo:wrapper
letter-
spacing="10"
>S</
fo:wrapper>
<fo:wrapper
letter-
spacing="-360"
>T</
fo:wrapper>END
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XML 
Attribute

Data 
Type

Min Max Note Example

color color 3 of ubyte #00000
0

#FFFFFF Contains value of 
red, green and blue 
in hexadecimal from 
00 to FF lead by #:

#FF0000: 
brightest red
#00FF00: 
brightest green
#0000FF: 
brightest blue

<fo:wrapper 
color=
"#FF0000">T</
fo:wrapper>
<fo:wrapper 
color=
"#00FF00">E</
fo:wrapper>
<fo:wrapper 
color=
"#0000FF">S</
fo:wrapper>
<fo:wrapper 
color=
"#000000">T</
fo:wrapper>

underli
ne

underline boolean true/false Existing value of 
text is not 
changed if no 
new value of 
these modifiers is 
specified.

<fo:wrapper 
underline="true
">TEST</
fo:wrapper>

Available Classic Text formatters
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XML 
Attribute

Data 
Type

Min Ma
x

Note Example

scale scale-x float 0.0 - Should be only 
positive value 
otherwise the backface 
is on the front side 
and be invisible until 
enable "Back-Face" 
drawing in Expert 
plug-in.

<fo:wrapper 
scale-x="3.0"
 scale-
y="3.0">T</
fo:wrapper>
<fo:wrapper 
scale-x="2.0"
 scale-
y="2.0">E</
fo:wrapper>
<fo:wrapper 
scale-x="1.0"
 scale-
y="1.0">S</
fo:wrapper>
<fo:wrapper 
scale-x="0.4"
 scale-
y="0.4">T</
fo:wrapper>

scale-y float 0.0 -

scale-z float 0.0 -

position pos-x float - - Relates to default 
position of each 
character.

<fo:wrapper 
pos-y="-30">T
</fo:wrapper>
<fo:wrapper 
pos-y="-10">E
</fo:wrapper>
<fo:wrapper 
pos-y="10">S<
/fo:wrapper>
<fo:wrapper 
pos-y="30">T<
/fo:wrapper>

pos-y float - -

pos-z float - -
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XML 
Attribute

Data 
Type

Min Ma
x

Note Example

rotation rotate-x float - - 1 round rotation is 
360 (counterclockwise) 
or -360 (clockwise).

<fo:wrapper 
rotate-
x="15">T</
fo:wrapper>
<fo:wrapper 
rotate-
x="30">E</
fo:wrapper>
<fo:wrapper 
rotate-
x="45">S</
fo:wrapper>
<fo:wrapper 
rotate-
x="60">T</
fo:wrapper>

rotate-y float - -

rotate-z float - -

alpha opacity float 0 100 Existing value of text 
is not changed if no 
new value of these 
modifiers is specified.
Subscript and 
superscript cannot be 
true at the same time.

<fo:wrapper 
opacity="80"
>T</
fo:wrapper>
<fo:wrapper
opacity="60"
>E</
fo:wrapper>
<fo:wrapper
opacity="40"
>S</
fo:wrapper>
<fo:wrapper
opacity="20"
>T</
fo:wrapper>

bold boolean true/false <fo:wrapper 
bold="true"
>TEST</
fo:wrapper>

italic boolean true/false <fo:wrapper 
italic="true"
>TEST</
fo:wrapper>
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XML 
Attribute

Data 
Type

Min Ma
x

Note Example

subscript boolean true/false <fo:wrapper 
subscript="
true"

superscript="
false">TEST</
fo:wrapper>

superscript boolean true/false <fo:wrapper 
subscript="
false"

superscript="
true">TEST</
fo:wrapper>

font font FONT <fo:wrapper 
font=
"<00AF0E0D-62
5C-184B-98AE5
4ADA55B6239>"
>TEST</
fo:wrapper>
<fo:wrapper
font=
"FONT*Fonts/
JS-Wansika-
Italic"
>TEST</
fo:wrapper>
<fo:wrapper
font="Fonts/
JS-Wansika-
Italic"
>TEST</
fo:wrapper>

Available Text formatters
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XML 
Attribute

Data Type Min Max Note Example

color color 3-4 of
ubyte

#000000
00

#FFFFFFF
F

Contains value of 
alpha (optional), red, 
green and blue in 
hexadecimal from 00 
to FF lead by #:

#FF0000: 
brightest red
#00FF00: 
brightest green
#0000FF: 
brightest blue
#00000000: 
transparent (zero 
alpha)
#FF000000: 
opaque (highest 
alpha)

Default alpha value is 
#FF if not specified

<fo:wrapper 
color=
"#FF0000"
>T</
fo:wrapper>
<fo:wrapper
color=
"#00FF00"
>E</
fo:wrapper>
<fo:wrapper
color=
"#0000FF"
>S</
fo:wrapper>
<fo:wrapper
color=
"#000000"
>T</
fo:wrapper>

<fo:wrapper 
color="
#40808080
">O</
fo:wrapper>
<fo:wrapper 
color="
#80808080
">P</
fo:wrapper>
<fo:wrapper 
color="
#B0808080
">A</
fo:wrapper>
<fo:wrapper 
color="
#D0808080
">Q</
fo:wrapper>
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XML 
Attribute

Data Type Min Max Note Example

modif
ier

modifier modifier subscript/
superscript/none

Existing value of 
text is not 
changed if no new 
value of these 
modifiers is 
specified.

<fo:wrapper 
modifier=
"subscript"
>TEST</
fo:wrapper>
<fo:wrapper
modifier=
"superscript
">TEST</
fo:wrapper>
<fo:wrapper
modifier=
"none"
>TEST</
fo:wrapper>

font font FONT_FAC
E

<fo:wrapper 
font=
"<41E57305-1
205-4742-96D
A817BCA63272
9>">TEST</
fo:wrapper>
<fo:wrapper
font=
"FONT_FACE*F
onts/
JS_Wansika_I
talic"
>TEST</
fo:wrapper>
<fo:wrapper
font="Fonts/
JS_Wansika_I
talic"
>TEST</
fo:wrapper>

<fo:wrapper /> element can be covered by another such as:

Formatters <fo:wrapper bold="true" color="#ff0000"> Th<fo:wrapper 
color="#ffffff">a<fo:wrapper color="#0000ff">il</
fo:wrapper>a</fo:wrapper>nd </fo:wrapper>

Result Th a il a nd

Entities

Support three entities in formatted text for preventing broken formatter XML.
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Character Entity

Character Entity

< &lt;

> &gt;

& &amp;

Example

Formatter <fo:wrapper color="#FF0000">&lt;sender&gt;John  &amp; 
 Smith&lt;/sender&gt;</fo:wrapper>

Result <sender>John & Smith</sender>

CDATA section

CData section can be used for preventing broken formatter XML too, but with more readable text.

Can be used to send plain text into Control Classic Text plug-in with enabled "Use formatted text" 
but many existing formats such as bold, italic, underline subscript and superscript in current text 
still are kept.

Example

Formatter <fo:wrapper color="#ff0000"><![CDATA[<sender>John & 
Smith</sender>]]></fo:wrapper>

Result <sender>John & Smith</sender>

Can rest all existing formats by assigning those new values, but the plain text should not contain 
"]]>".

Example

With Classic Text

<fo:wrapper letter-spacing="0" color="#000000" opacity="1 0 0"  bold=" false " italic=" false" 
underline=" false " subscript=" false " superscript=" false " 
font="<00AF0E0D-625C-184B-98AE54ADA55B6239>" ><![CDATA[Any plain text]]></fo:wrapper>

With Text

<fo:wrapper letter-spacing="0" color="#000000" underline=" false " modifier="none" 
font="<41E57305-1205-4742-96DA817BCA632729> " ><![CDATA[Any plain text]]></
fo:wrapper>
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See Also

Common Control Properties
Control Object

Control Geom

The Control Geom plug-in exposes the control of geometry objects to the user.

Control Geom Properties
Geom location Prefix: Sets a path to a folder. The geometry location exposed to the control 
client can be a simple string, instead of a full path. This is relevant if connected to a 
newsroom system. For example if a user wants to edit a text and geometry on the same tab-
field by just entering a text string. If for instance the user have a folder of weather symbols 
and the control client receives “sunny” from the external system it loads the geometry object 
with the path: “geom location prefix + sunny”, which then typically would be an image of a 
shining sun.
Input Value: Shows the current input value. Enter a value to test the relation of max/min. 
input and scale values.
Deny Browsing Upwards: Restricts the user from browsing for objects in folders other than 
the selected folder and its sub-folders when enabled.

See Also

Common Control Properties
Control Object

Control Hide in Range

The Control Hide in Range plug-in hides or shows a container if the input value given by the user is 
within or outside a specified value range. The input value must be from a font container that holds 
a numeric value, typically with a Control Num plug-in.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Control

Note: This plug-in is located in: Plugins -> Container plug-ins -> Control
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Control Hide in Range Properties
Input Value: Shows the current input value.
Lower Range Bound: Sets the upper bound for the range.
Upper Range Bound: Sets the lower bound for the range.
Visibility in Range: Sets whether the container should be visible or hidden when the input 
value is within the range.

See Also

Common Control Properties
Control Object

Control Hide on Empty

The Control Hide on Empty plug-in performs a very simple function: It hides the container it sits on 
if the input value is blank (text) or zero (numbers). Use this plug-in to hide the graphics items if 
the user does not enter any value in the connected tab-field. Together with the Autofollow plug-in, 
the plug-in can be used to make intelligent scenes that hide objects that receive no value from the 
Viz Trio user and also rearrange those items that have a value or text and are visible. For example 
when using a lower third scene with a bug and a breaking news bar, the bug and the breaking 
news bar should not be shown all the time. So instead of having to make several explicit variants 
simply make one scene and use the plug-in to hide the bug and the breaking news only if the page 
in Viz Trio have no value in those tab-fields.

Control Hide on Empty Properties
Input Value: Shows the current input value

Treat Input as Numerical: Hides the containers with an input value of 0  or 0.0  when 

enabled.

See Also

Common Control Properties
Control Object

Control Image

The Control Image plug-in creates an image control in the control clients. The plug-in must be 

Note: This plug-in is located in: Plugins -> Container plug-ins -> Control
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placed on the container that holds the image/texture. If an image/texture is invalid or Viz Engine 
for some reason cannot load it, then the current image/texture remains visible.

Control Image Properties
Expose Image Position: Allows the user to change the position of the image/texture.
Expose Image Scaling: Allows the user to change the scaling of the image/texture.
Set MaterialDefinition BaseColor: Sets the given image as BaseColor channel on a PBR or 
Phong Material.
Set MaterialDefinition Emissive: Sets the given image as Emissive channel on a PBR or Phong 
Material.
Deny Browsing Upwards- Restricts the user from browsing for images/textures in folders 
other than the selected folder and its sub-folders when enabled.
Image location Prefix: If the full path to a folder is entered, the image/texture location 
exposed to the control clients can be a simple string, instead of a full path. This is relevant if 
connected to a newsroom system. For example if a user wants edit a text and an image/
texture on the same tab-field by just entering a text string. This is relevant if a user has a 
folder containing flag images/textures, and the control client receives “US” from the external 
system it loads the image/texture with the path: “image location prefix + US”, which then 
typically would be the “Stars and stripes” (flag of the U.S.A).
Input Value: Shows the current value for the plug-in. It is not necessary to set any value here. 
It is used for debugging purposes.

Shared Memory Placeholders

The Control Image plug-in supports Shared Memory placeholders. Placeholders can be described 
by ${shm_key}, where shm_key is the name of a Global Shared Memory Map. You can also define a 
default value by adding a pipe and the value. For example: ${shm_key,Default} where Default is 
used as default value if the Shared Memory Map is empty or does not exist.

Shared memory maps can be accessed and changed in various ways, like an external command, 
script etc...

Example

Note: This plug-in is located in: Plugins -> Container plug-ins -> Control
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This show load a certain image one the shared memory variable myimage has been changed. 
otherwise it falls back to the given default image. By sending GLOBAL*MAP SET_STRING_ELEMENT 
myimage <any_uuid> the text changes to the new value. 

When using the image location prefix, be sure to have the value set correctly, e.g. IMAGE*/Vizrt-
Quality_Assurance/Engine/Standard_Library/ControlImage/.

You can then invoke a change of the SHM variable by sending e.g. GLOBAL*MAP 
SET_STRING_ELEMENT myimage testimage. This forces the image /Vizrt-Quality_Assurance/
Engine/Standard_Library/ControlImage/testimage to be loaded and set.

See Also

Common Control Properties
Control Object

Control Key Frame

The Control Key Frame plug-in can be used to give the user control over the value of a “single 
value Key Frame” unlike position values for instance where all three axes must be specified. Create 
an animation, for instance an alpha animation, and give the Key Frame to control a name. Put the 
Control Key Frame plug-in on the object’s container and set the parameters.

Control Key Frame Properties
Expose Time: Enables the user to adjust the Key Frame along the time-line.

Information: This feature is available in Viz Plugins for Viz Engine 4.4.1 or later.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Control
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Control Parent: When enabled, this option allows for two Control Key Frame plug-ins to be 
within one container.

Minimum Input: Sets the minimum allowed input value.
Maximum Input: Sets the maximum allowed input value.
Minimum Value: Sets the minimum value, which is set relative to the minimum input value.
Maximum Value: Sets the maximum value, which is set relative to the maximum input value.
Input Value: Shows the current input value. Enter a value to test the relation of max/min. 
input and scale values.
Key Frame Time: Sets the time value of the Key Frame.
Key Frame: Sets the name of the Key Frame that is to receive a value by the control client 
user.

Input Value Example
Example for the input values: If the Key Frame is an alpha Key Frame which in Viz Artist can be 

float values from 0  to 100 , and the following values are set:

Minimum input = 1 .

Maximum input = 10 .

Minimum value = 10 .

Maximum value = 90 .

This means that if the user gives the following input:

1 , which is the lowest input value allowed, the alpha value in Viz Artist is set to 10 .

4 , which is somewhere in between, the relative alpha value is  36,666 ... .

10 , which is the highest value allowed, the alpha value is set to 90 .

See Also

Common Control Properties
Control Object

Control List

The Control List plug-in allows creation of table controls. By following some design conventions 
when designing the table in Viz Artist, Viz Trio shows a table editor to the user. This editor 
supplies a more effective way for filling tables than having one tab field for each table cell.

Note: In this case the control Key Frame plug-ins must be added as Sub-Containers 
of the container.



Note: This plug-in is located in: Plugins -> Container plug-ins -> Control



Plug-ins User Guide -  5.0

Copyright © 2022  Vizrt Page  212

•
•
•

•

•

•

•

•

This page contains the following topics and procedures:

Control List Properties
Tables and Preview Points
To Design a Table Scene

Control List Properties
Number of exposed rows: Sets the default number of exposed rows for the scene when the 
number of rows can be changed by the operator. If the number of rows cannot be changed 
the number of exposed rows is fixed.

Mutable Number of Rows: Allows the operator to add or delete rows when set to On .

Minimum and Maximum Number of Rows: Sets the minimum and maximum number of rows. 
To the operator, the number of fields can only be added or deleted when inside the range 
(for example greater than two and less than ten).

Tables and Preview Points
A table scene might be hard to read if you need to show a large table with many rows (e.g. 20) 
and/or columns. In such cases it is not uncommon to only show a subset of the information (e.g. 
five rows), and rather animate the scene to show the next five rows and so on.

However, in such a situation, while editing table data in Viz Trio, you cannot use a basic jump to 
Key Frame event for preview, as this only shows the Key Frame that relates to the table’s Field 
identifier (e.g. 3), and not the rows or columns of the table.

To enable operators to preview the data in the scene, it is therefore possible to add a preview 
point that extends to the next starting point (for example, the next five rows of the table), using 
the table’s (Control List) Field identifier in addition to the row number.

So, if the identifier of Control List is 03, you have to define tags with names 03.0, 03.5, 03.10 and 
03.15 (zero based row index) for Viz Trio to detect the tags and jump to them on focusing the 
according rows in Viz Trio’s Control List table editor.

Basic jump to Key Frame: When adding Key Frame events (stop points, tags,...) and giving 
them the name of a control plug-in identifier, Viz Trio jumps the time-line to that Key Frame 
event when selecting the tab field with that identifier.

Extended jump to Key Frame: If the Key Frame event name is  3_005  and there is a control 

list with identifier  3 , then Viz Trio jumps the time-line to that Key Frame event. In this case 

when the sixth row of the table is focused.
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To Design a Table Scene

To design a table scene that is correctly interpreted by the Control List plug-in there are some 
design conventions that need to be followed:

Add a group as the root container for the table. Give it a descriptive name such as table .

Add the Control List plug-in to the table group container.
Add a new group as a Sub-Container to the table container. This container is the design for 

the rows in the table. Give it a name such as row_1 .

Add a Control Object plug-in to the newly added row container.
As Sub-Containers of the row container, add text containers with backgrounds to form the 
design for a single table row with the required number of columns.

Each of the text containers must get a Control Text plug-in and the field identifiers for 
each must be set from 1-n depending on how many columns the table should have.
The Description property in the ControlText plug-ins are picked up by the Control List 
plug-in and used as column headers.

When the single row looks as it should, duplicate it to make the needed total number of 
table rows.

The container plug-in Coco can be used to automate this task.
Add the Coco plug-in to the row container, and set the number of copies, for example 
9 (1+9=10), and click Execute.

Arrange the rows
The arrange plug-in Grid Arrange can be used to automate this task.
Add the Grid Arrange plug-in to the table container, and set the number of rows to the 
same as above and press ENTER.
Set the row offset and press ENTER.

The table item of the scene is ready and when imported into Viz Trio and read, the table tab-field 
is shown with a special table editor. When imported into Viz Template Wizard, a template with a 
custom table editor is generated.

See Also

Common Control Properties
Control Object
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Control Map

The Control Map plug-in binds the control of the Viz World Client plug-in XML property to a 
ControlObject which allows an operator to use the Viz World Client Editor to select maps.

Control Map Properties
This plug-in does not have any properties or parameters except those that are common to all plug-
ins.

See Also

Common Control Properties
Control Object

Control Material

The Control Material plug-in exposes the material control to the Viz Trio user.

Control Material Properties
Material: Sets the path to the material that should be used when the page is imported into 
the control client.
Deny Browsing Upwards: Restricts the user from browsing for materials in folders other than 
the selected folder and its sub-folders when enabled.

See Also

Common Control Properties
Control Object

Note: This plug-in is located in: Plugins -> Container plug-ins -> Control

Note: This plug-in is located in: Plugins -> Container plug-ins -> Control
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Control Multihop

The Control Multihop plug-in works with the Multihop Editor (within the World Map Editor) to edit 
hops on a scene containing the Control Multihop plug-in within Viz Trio or Viz Pilot.

The Control Multihop plug-in should be placed next to the HopsManager plug-in.

Control Multihop Properties
This plug-in does not have any properties or parameters except those that are common to all plug-
ins.

See Also

Common Control Properties

Control NDI

The Control NDI plug-in allows to select and activate a certain NDI source available in your network 
from within Viz Artist or from a control application like Viz Trio.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Control

Note: This plug-in is located in: Plugins -> Container plug-ins -> Control
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Control NDI exposes the NDI source selector to external applications like Viz Trio or Viz Pilot. An 
operator can set a new NDI available within the network which is then taken by the plug-in and set 
for the live input source. It also offers basic testing possibilities for the designer by providing a list 
of discovered sources. To switch to a new NDI source, copy the source from the NDI sources list 
and paste it into the Set Source field.

Please use the Refresh Button, if NDI sources do not show up immediately.

To Use with Viz Trio

You need to manually enter a NDI source into the control field.

See Also

Common Control Properties
Control Object

Information: Due some limitations on the Viz Trio side, it is currently not possible to do a 
discovery of sources and to provide a dropdown list.
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Control Num

The Control Number plug-in (also known as Control Num) is used to be able to decide how a 
number input is to be formatted. It can be a value given by the control client user or by any 
external source. It should be used instead of Control Text when numbers are to be the input value. 
To make it work, add the plug-in to the container that holds the text object.

Control Num Properties
Minimum Input: Sets the minimum allowed input value.
Maximum Input: Sets the maximum allowed input value.
Input Value: Shows the current input value. Enter a value to test the number formatting.
Show Verbatim: Disables all formatting when enabled.
Thousand Separator: Sets the required thousand separator for the output.
Plus Prefix: Applies the prefix entered here in front of positive values.
Minus Prefix: Applies the prefix entered here in front of negative values.
Suffix: Applies the string entered here after all values.
Decimal Point: Defines the decimal point for the output.
Decimal Places: Sets the number of decimals that are shown by the output.

Leading Zero: Places a zero in front of decimal values between 1  and -1  when enabled.

Zero Replacement: Sets the string to show instead of zero values.

See Also

Common Control Properties
Control Object

Control Object

The Control Object plug-in provides control channels for subtrees of Viz Scenes.

To create a Viz Trio page template, a Viz Pilot template or a Viz Ticker template; each Scene must 
have at least one instance of the Control Object plug-in. The control channel information is stored 
in the subtree itself, so the Scene subtree can be merged and stored as objects in the object pool. 
When a Control plug-in is added to a Scene, a control object plug-in is automatically added to the 
root container of the scene subtree to be controlled. The plug-in stores and gathers field 
definitions which describe how values are processed and applied to various properties of the 
subtree. The easiest way to define fields is to place one or more Control plug-ins on containers 

Note: This plug-in is located in: Plugins -> Container plug-ins -> Control
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within the subtree. These Control plug-ins find the Control Object and register properties related 
to the container they are placed on.

This page contains information on the following topics:

Control Object without Transition Logic
Control Object with Transition Logic Enabled
Control Object Properties

Transition Logic Off
Transition Logic On

Control Object Advanced Properties

Control Object without Transition Logic
In the simple scene based mode, the plug-in should be put on the root container for the page tab-
field containers. A description, which is used as template description in the control clients, should 
also be entered. To load the graphics in another rendering layer than the Middle (default), choose 
Front or Back. By using different layers up to three items can be on screen simultaneously without 
having to design a Transition Logic setup.

Control Object with Transition Logic Enabled
With Transition Logic enabled, logical layer and state can be defined for the scene. These are used 
by the control clients to find out which transitions and animations to trigger when a page is put On 
Air or Off Air. These transitions and layers must all be defined in the background scene. A 
background scene name can also be set if a background scene other than the default (named 
default) is used.

Control Object Properties

Transition Logic Off

Description: Provides the description of the object the scene subtree represents. This 
description is typically presented to users in GUI applications that allow the user to fill in 
data that should be presented by the controlled object.
Transition Logic: Specifies whether the controlled object uses transition logic. Transition 
logic loads objects onto layers in a background scene, and runs animations to change the 
background scene layer into a required state.

Note: For Viz Ticker it is possible to have more than one Control Object plug-in. It should 
be on the root container for the tab objects in the scene.



Note: This plug-in is located in: Plugins -> Container plug-ins -> Control

Note: Objects in the Back layer are rendered behind objects in the Middle and Front layer 
and so on, so the scenes must then be designed with that in mind.
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Viz Layer: Determines the Viz layer to load the scene which contains the scene tree which 
contains this Control Object. This parameter is only used when transition logic is set to 

Off .

Use All Directors: Controls whether to play every director or only the default director in a 
non-transition logic scene, and takes effect when the Vizrt Media Sequencer triggers 

the  TAKE  command. When loading the scene into a control application such as Viz Trio, all 

directors in the stage start automatically when the scene is taken in. By changing this 

to  Off , only directors with  Auto Start  enabled in the Director Editor start when the 

scene is taken in. This parameter is only used when Transition Logic is set to  Off .

Show advanced: See Control Object Advanced Properties.

Transition Logic On

Layer identifier: Selects the layer the controlled object should be loaded onto in the 

background scene. This parameter is only used when transition logic is set to On . For the 

transition logic to work, the identifier given here must be identical to the names of the 
following components of the background scene:

A container with a Toggle plug-in: The transition logic uses the toggle plug-in on this 
layer-container to load the object.
A director: The transition logic animates this layer-director into the state requested by 
the object.

State identifier: Determines the state which the layer-director of the background scene 
should be animated to, when the object is loaded into its target layer. The identifier given 
here must be identical to one or more stop-points defined on the time-line of the layer-
director of the background scene. This parameter is only used when transition logic is set to 

On .

Background scene: Sets which scene has the layer-container and layer-director needed by the 
transition logic to load and animate in the object. This parameter is only used when 

transition logic is set to On .

Filter Continues: Stops the Toggle plug-in from executing Continue action.
Store Stop Points: Does not discard stop points when sub-trees are merged into objects (the 
default behavior of Viz Artist). It stores information about the stop-points of directors used 
by the sub- tree in a way that survives when merging the sub-tree into an object stored in 
the object pool.
Restore Stop Points: Recreates the stop-points used by the director of an object that has 
been loaded from the object pool. This uses the information previously stored by Store Stop 
Points. When used in conjunction with the Toggle plug-in, it operates on the object’s 
animation director.

Example: The scene design incorporates an animated background which starts 
automatically when the scene is loaded. To avoid the background animation 

restarting when the scene is played out, set Use All Directors to Off  .





Plug-ins User Guide -  5.0

Copyright © 2022  Vizrt Page  220

•

•

•

•
•

•

•

•
•

Control Object Advanced Properties

When the Show Advanced button is set to On , a channel property is shown as well as a text box 

for manual field definitions. Most of these parameters are used for system integration purposes 
and are rarely relevant in a normal scene design for Viz Trio, Viz Pilot and Viz Ticker.

Enable GFX subscene:  Includes the control field definition from the plug-ins inside the GFX 
subscenes as part of the main scene's control field definition when enabled for 
ControlObject of the main scene. 

Subscene field definition: Chooses how the control fields of the subscene are included 
in the main scene's control field definition.

Option Result

Merge All subscene control fields are merged with main scene control field at 
the same level. For example, the field 1.name in a subscene is shown as 
is in the control application.

Merged 
subfiel
d

All subscene control fields are merged together and put under a specified 
field identified with the value in Subscene field id/prefix option . For 
example, the field 1.name of a subscene assigned to any GFX channel is 
shown as gfx.1.name in the control application.

Subfiel
ds

All subscene control fields of each scene are separately put under 
subfield with identifier prefixed with the value in Subscene field id/prefix
option . For example, the field 1.name of a subscene assigned to GFX 
channel 5 is shown as gfx5.1.name in the control application.

Subscene field id/prefix: Names the subfield identifier for the subscene's merged 
subfields, or the prefix for the subfield of each subscene. 

Use custom duration: Sets the duration parameter:
Duration: Determines the amount of time the graphics should be shown when 
triggered as an interstitial item, such as sponsor items in a ticker.

Namespace prefix: Allows the fields defined by control plug-ins below, to propagate to 
control objects further up the Scene Tree. When definitions are propagated upwards, the 
field identifier is prefixed with the name prefix.
Script (deprecated): Identifies the name of a script that contains functions to execute when 
various operations are completed in Viz Trio.
Channel: Sets the name of the default playback channel for the template.
Manual field definitions: Defines custom fields in the text box, using a fixed syntax. Each 
entry is a line of text consisting of colon (:) separated fields. The fields for each entry are:

Field description Example

Field identifier/key votes

Property location $top$label*GEOM*TEXT
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Field description Example

Type There are many type identifiers and are used by the 
control applications to determine which content editor 
control to show for a given field (for example: integer, 
bool, float, text, richtext, duplet, triplet)

Minimum value 0

Maximum value 100

Maximum number of characters 8

Field description Percentage of votes

Auxiliary field Conveys various type specific type constraints and 
auxiliary information needed by the control application 
to provide a convenient editing experience (for 
example, limiting text to a single text line, allowing 
only upper case characters, or limiting images to only 
images found in a certain image pool folder)

Remap fields: Gives the control clients the list of entries in a map. For use in scenes with 
nested control object plug-ins. This feature is mainly for advanced integration use. When 

On , Control Object gives the control clients the list of entries in map, rather than the list of 

entries registered by control plug-ins below the Control Object in the scene tree, and 
manually entered entries from entries. When actions are performed on fields, the Control 
Object uses map to rename the field identifier before dispatching the action.
Input command/request: Receives commands and requests actions. When this parameter is 
changed, the command described by the new value of the parameter is executed. Return 
values for requests are stored in the Result parameter.
Result: Stores the result of requests given through the Input command/request parameter. 
Applications which complete the requests typically read the result text from parameter 
immediately after setting the request text in the Input command/request parameter.
Error: Stores the error message that is shown in the event of the Input command/
request returning an error. This is read by the control application, which then presents the 
user with an appropriate error message.

Pending Result Chunks: Splits information into chunks to allow more information to be 
passed through several transactions if the contents of the Result or Error fields exceeds the 
size allowed. This field is automatically updated by the plug-in itself.

Note: The API requires the Control Application to request the contents from both the 
Result and Error fields when sending an Input command/request. However, the plug-
in only populates one of the fields, depending on the returned result. This means 
that one of the fields is always empty.
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See Also

Common Control Properties
Toggle

Control Omo

The Control Object Moving (Omo) plug-in gives the possibility to add a group of containers and 
reveal one at the time. This is done by adding an Omo plug-in on the root container and in its 
editor specify which of the Sub-Containers to show. The Omo value can be made accessible for the 
control client by adding the Control Omo plug-in on the same container as the Omo plug-in.

Control Omo Properties
Minimum Value: Sets the minimum input value.
Maximum Value: Sets the maximum input value.

See Also

Common Control Properties
Control Object
Omo

Control Parameter

The Control Parameter plug-in works with function plug-ins, and is a very flexible plug-in that can 
be used to control properties that are not exposed in a specific plug-in, and requires some 
knowledge in the Viz Artist command language. The parameter to control must be identified by its 
command path relative to the container the plug-in is located at. To find the correct command 
path, open the Show Commands window (button in the lower left corner in Viz Artist) and make 
changes to the parameter to control. The command path is shown among the commands. For 
instance if the value to be changed is the alpha value in an alpha editor the command 
window shows the following:

receive <-1 SCENE*noname*TREE*#805*ALPHA*ALPHA SET 99.0>

#805 is the internal name for the container and the part needed to expose the alpha parameter 
(ALPHA * ALPHA). The SET part is added by the plug-in. To expose the alpha parameter for a 

Note: This plug-in is located in: Plugins -> Container plug-ins -> Control
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container write ALPHA * ALPHA in the Parameter section in the plug-in and then set the correct 
data type which in this case is “Float”.

Another example would be to use Control Parameter to expose and control additional values like 
controlling both Pie Max and Max Value. These parameters are dependent on each other, but both 
values are not exposed unless the Control Parameter is used. Adjusting the Pie Max value gives the 
following:

receive <5679 SCENE*noname*TREE*#378*FUNCTION*PieValues*DATA GET>

In this case, the FUNCTION*PieValues*DATA is the parameter that exposes the object property Pie 
Max such that it can be controlled through a template.

Control Parameter Properties
Parameter: Sets the parameter path to the property to enable control for.
Input Value: Shows the current input value.
Data Type: Sets correct data type depending on the type of parameter to enable control for.
Normalize: Enables normalization options, to normalize the input range for the Viz Trio 
user.
Minimum Input: Sets the minimum allowed input value.
Maximum Input: Sets the maximum allowed input value.
Minimum Value: Sets the minimum value, which is set relative to the minimum input value.
Maximum Value: Sets the maximum value, which is set relative to the maximum input value.
Prefix: Adds a prefix to all values that are sent to the renderer. This can be used to show 
specific text or it can be used to add a path to an object pool for instance.
Control Parent: Controls the parent container when enabled.

Shared Memory Placeholders

The Control Parameter plug-in supports Shared Memory placeholders. Placeholders can be 
described by ${shm_key}, where shm_key is the name of a Global Shared Memory Map. You can 
also define a default value by adding a pipe and the value. For example: ${shm_key,1.0}  where 
"1.0" is used as default value if the Shared Memory Map is empty or does not exist.

Shared memory maps can be accessed and changed in various ways, like an external command, 
script etc...

Example

Note: This plug-in is located in: Plugins -> Container plug-ins -> Control



Plug-ins User Guide -  5.0

Copyright © 2022  Vizrt Page  224

•
•

•

This applies a value to the Y scaling of the container with 1.0 as default value. By 
sending GLOBAL*MAP SET_DOUBLE_ELEMENT my_scale 2.0,the scaling changes to 2.0.

See Also

Common Control Properties
Control Object

Control Payload

The Control Payload plug-in distributes a whole payload to children Control plug-ins.

If the payload value is empty, the Container is hidden.

Control Payload Properties
Text Entry Box: Data from external application (for example Viz Trio, Social TV (Feed 
Streamer)) to send the payload.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Control

Example: Social TV (Feed Streamer) uses this plug-in to send payload fields from a Data 
Hub to Viz Engine.



Example: 
<payload xmlns="http://www.vizrt.com/types"> 

<field name="topic"> 
<value>It\qs Valentine\qs Day, how you doin\q? </value> 

</field> 
<field name="option"> 

<value>Hate it! Worst holiday ever|Love it! Wish it were every day|





Plug-ins User Guide -  5.0

Copyright © 2022  Vizrt Page  225

•

•

•

•

1.

See Also

Common Control Properties

Control Pie

The Control Pie plug-in is able to bind a tab-field to values from PieSlice plug-ins.

Control Pie Properties
First slice ID: Sets the tab-field number for the first slice (the first container below the group 
that holds the ControlPie plug-in).
Last Slice ID: Sets the tab-field number for the last slice (the difference between Last and 
First should correspond to the total number of slices in the pie chart).
Expose Pie Max/Total Value: Allows a Viz Trio user to set Max value for a pie slice and Max/
Total value for the whole pie chart when enabled.

To Build a Pie Chart

Add a group container and name it, for instance pie . Add the presenter plug-in Pie 

Values and the control plug-in Control Pie to the group.

Thanks for the reminder, need to buy roses</value> 
</field> 
<field name="count"> 

<value>238|189|46</value> 
</field> 

</payload>

Note: This plug-in is located in: Plugins -> Container plug-ins -> Control
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Add a Cylinder object as a Sub-Container to the group. Add material and the presenter plug-

in Pie Slice to the new container. Name the container slice  or similar. The Cylinder object 

is not visible.
Open the Pie Values editor and increase the Value0 property a bit. The cylinder becomes 
visible and its size changes.

Open the Cylinder editor and set Center to Top .

Open the Transformation Editor for the pie group, and rotate the pie group around 90 
degrees on the X-axis to make the cylinder top face the camera.
Add a font as Sub-Container to the slice container, and add a material to make it visible 
against the background.
Open the Text Editor and set the horizontal justification to Center. Open the Transformation 

Editor and rotate the font around the X-axis to -90 degrees and set Y position to 1.0 .

Scale the font down a bit so it fits over the slice (for example  0.2 ).

On the slice container, open the PieSlice editor and set Control Text Values to a data 
type(e.g. None, Integer, Float or Formatted). By choosing Integer or Float the slice text 
changes, which shows the value for the slice.
In the pie slice editor, adjust the Text Offset to position the value label relative to the center 

of the pie (for example  70.0 ).

A single pie slice should be ready. Make the number of slices needed by making copies of 
the slice container and change their material so they can be differentiated from each other.
Set the different values in the PieValues editor to test.

See Also

Control Object
Pie Slice
Pie Values
Common Control Properties

Control Scaling

The Control Scaling plug-in enables the Viz Trio user to edit transformation scaling values for 
objects. Normalization between input and output values can be set by parameters.

Control Scaling Properties
Minimum & Maximum Input: Sets minimum and maximum allowed input values.
Minimum Scaling: Sets the minimum transformation value which is set relative to the 
minimum input value.
Maximum Scaling: Sets the maximum transformation value which is set relative to the 
maximum input value.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Control
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Control X, Y, Z- Controls the X, Y, and Z-axis independently when enabled. The Viz Template 
Wizard TripletEditor component has three onChange events available that accommodates for 
these parameters.
Input Value: Shows the current input value. Enter a value to test the relation of max/min. 
input and scale values.
Stop Key Frame: Forces the scaling values entered to be put into the end Key Frame for the 
animation if the scaled object is animated. For instance if a user is to create a bar graph that 
animates from zero to a value specified, then this is the case. Name the end Key Frame in 
the Viz Artist stage and enter that name in the “stop Key Frame” field in the control scaling 
plug-in.

See Also

Common Control Properties
Control Object

Control Sign Container

The Control Sign Container plug-in value can show one of three containers based on the value of a 
numerical input. The container that holds the plug-in must have three Sub-Containers:

A negative value triggers to show the first container.
A positive value triggers to show the second container.
A zero value triggers to show the third container.

Control Sign Container Properties
Input Value: Shows the current input value. Enter a value here to test that the correct Sub-
Container is shown.

See Also

Common Control Properties
Control Object

Control SoftClip

The Control SoftClip plug-in allows the user to control and browse for video clips played in Viz 

Note: This plug-in is located in: Plugins -> Container plug-ins -> Control
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Artist using the Soft Clip plug-in. Simply add the control plug-in to the same container as the 
SoftClip plug-in. Further, specify a Field Identifier and a Description.

Control SoftClip Properties
This plug-in does not have any properties or parameters except those that are common to all plug-
ins.

See Also

Common Control Properties
Control Object

Control Stoppoint

The Control Stoppoint plug-in enables control of the time value on a stop point. This can typically 
be used for setting the length of an animation.

Control Stoppoint Properties
Stoppoint: Sets the name of the stop point to control.
Director: Sets the name of the animation director where the stop point is placed.
Stop Time: Sets the stop time in seconds. This is the value that is set by the Trio operator.

See Also

Common Control Properties
Control Object

Control VBI

The Control VBI plug-in binds control of scene VBI source to a ControlObject.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Control

Note: This plug-in is located in: Plugins -> Container plug-ins -> Control

Note: This Control plug-in does not work with transition logic based scenes.
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Control VBI Properties
VBI Source: Determines the VBI source to bind.

See Also

Common Control Properties

Control Video

The Control Video plug-in exposes control over a video codec channel. Add this plug-in to give the 
Client Application operator an editor, such as the Media Search in Viz Trio or Viz Pilot, in which to 
search Viz One for video clips.

The plug-in works in combination with the Video Clip plug-in. This allows you to merge Key Frames 
with the object for Transition Logic scenes.

Control Video Properties
Loop Clip: Enables or disables continuous looping for a video clip in graphics.
Auto Play: Starts playout on scene load.
Toggle Channel: Enables toggling between two clips in a Transition Logic scene. Enable to 
create a smooth transition between two clips when loading a new clip. 

Codec Channel: Sets the codec channel for the video board in use:
1: Is normally used as the default codec channel for full screen video.
2: Is normally used as the default codec channel for video in graphics.

Global Clip: Plays the selected clip as a Media Asset, instead of adding the clip to the stage 

when set to  On .

Director: Specifies the name of the director that the clip loads to.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Control

Note: This plug-in is located in: Plugins -> Container plug-ins -> Control

a.
b.

•
•

Information: To use the Toggle Channel option in Control Video plug-in, several 
options in other plug-ins need to be enabled:

In the master scene, turn on "Control video" in Toggle plug-in.
In the object scene:

Add a Video Clip plug-in and select Texture target.
Add a Control Video plug-in and turn on Toggle Channel.



Tip: Set Global Clip to Off  to access the Director and Clip Key Frame fields.
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Clip Key Frame: Specifies the name of the Key Frame the clip loads to.
Viz One: Transfers Clips From Viz One.
Use CUE: Cues up clips by name only, and does not affect the involved clip channel. 

Requires Global Clip to be  Off .

Expose cuing field: Setting this to  On  lets client applications control the Use CUE option 

through the sub-field  cue . Requires Global Clip to be  Off .

To Run the Clip at a Specific Key Frame on a Specific Director

Set Global Clip to  Off .

Enter the name of the director that controls playout of the clip in the Director field.
In the Key Frame field, enter the name of the Key Frame that triggers playout.

See Also

Common Control Properties
Control Object
Video Clip

Control World

The ControlWoC plug-in allows you to expose a set of properties to the operator. The control is a 
replacement for the Control Map plug-in with much more options and on-the-fly feedback from Viz 
Artist/Engine.

The control can expose different fields based on the container it resides on. When tabbing to the 
control (in a navigator scene) the camera jumps to map location and all feedback (exact camera 
position) is immediate.

Control World Properties
Client Mode: Sets the client mode to Full or Simple. When selecting a map, this opens the full 
or simple map client in the control application.
Input: Sets the exposed properties. The field is based on the input from the NavFinder plug-
in; however, you may also manually change this field.

See Also

Common Control Properties

Note: ControlWoC and Control Map plug-ins are not compatible. In Template Wizard 
versions 8.6 and lower, an error message pops up the first time you browse for a map set 
up with ControlWoC plug-in.



Note: This plug-in is located in: Plugins -> Container plug-ins -> Control
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1.

2.

3.
4.
5.

Control Object

Control Field Renamer

The Field Renamer plug-in allows for renaming the field identifier of multiple control plug-ins in a 
single operation.

Control Field Renamer Properties
Begin from ID: Enter the numeric value of the first ID in the renaming range.
End at ID: Enter the numeric value of the last ID in the renaming range.

Follow Changes: Changes the Begin and End IDs if set to On .

Padding: Sets the zero padding for the desired output. Zero padding adds one or more 
prefixing zeros if the ID consists of fewer digits than specified.

Method: Choose the renaming method: 
Set: In the field Set lowest ID to, enter the desired value to change all IDs in the 
specified range by the same value
Shift: Shifts all the IDs in the specified range by the provided amount

Execute: Click the Execute button to execute the rename process.

To Rename Control Fields
Drag the Field Renamer plug-in onto a container. When executing the renaming process, all 
control plug-ins in that container and all of its child containers are affected.

Set the range of IDs to be changed in Begin from ID and End at ID.

Use Padding to set the length for zero padding. Set to zero for no padding.
Choose the renaming Method.
Click Execute to execute renaming.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Control

Example: If Padding is set to 4 , the ID ‘14’ is changed to 0014 , and the ID ‘103’ is 

changed to 0103 .



Tip: To rename all field identifiers of an entire scene, place all containers in the 
scene inside a parent container and add the Control Field Renamer plug-in to that 
parent container.



Note: If the Follow Changes option is set to on, the above two range fields are also 
changed.
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See Also

Common Control Properties
Control Object

Placeholder

The Placeholder plug-in is used to mark placeholder containers when designing library objects for 
Viz Trio compositing. A placeholder container is available as a parent to other compositing objects 
in the scene tree.

Placeholder Properties
Sort Order: Integral sorting order identifier (lower number is sorted first).
Description: A description of the tab field or editable object. This is used as a description for 
the items when used in the control clients.

See Also

Common Control Properties
Control Object

Common Control Properties
Most control plug-ins have a set of common properties:

Field Identifier: Used by the control client applications to identify the editable item in the 
scene. Only English characters (A-Z, a-z), numeric digits (0-1), dot ( . ) and dash ( - ) are 
allowed. When a dot is used in the identifier, e.g. "1.score", it means this is a sub-field. Multi-
level sub-field is allowed. When making templates for Viz Trio, this should be a numeric 
value, starting at 1. The numbers are used to create the tab-order between the editable 
items. For Viz Pilot and Viz Ticker, this can also be a descriptive text string.
Description: Describes the tab field or editable object. This is used as a description for the 
items when used in the control clients.
Show only in Expert Mode: Hides the tab-field properties for the user if Expert Mode is 
enabled in Viz Trio. For more information, read about Viz Trio’s macro commands, and the 
command set_expert_mode_enabled.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Control
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4.4.6 Feed
The purpose of the Feed plug-ins is to receive real-time data and apply it to the state of a Viz Artist 
Scene in various ways. They are mostly used to create Scenes for use in financial data and stock 
feed visualizations.

The method of use for the plug-ins is as follows:

Identify text geometry, or container visibility in a scene that an external real-time data feed 
source is to control.
Apply the appropriate Feed plug-in to the container of the identified property.
In the plug-in properties, specify a data feed key to look for in the incoming data feed.
Send UDP messages to carry the content of the data feed in a YAML format which carries 
key-value pairs to a specific port on the Viz Engine host, which the plug-in infrastructure 
listens to.

The following Container plug-ins are located in the Feed folder:

Feed Activate
Hide in Range
Feed View

Feed Activate

The Feed Activate plug-in activates and deactivates plug-ins based on a given value in a FeedRelay 
hierarchy.

Feed Activate Properties
Is active: Updates visibility of sub-containers based on container name and value retrieved 
location.
Locator: Gets data for text from this location.
Sub-Locator: Appends this to locator path when retrieving text.
Update Interval: Determines how often (in number of fields) an update occurs (increase to 
gain performance).

Note: They are now mostly replaced by a combination of the shared memory map, Viz 
scripting, Control plug-ins and the Apply Shared Memory plug-in as the preferred way to 
bring real-time data into Viz Artist Scenes.



Note: This plug-in is located in: Plugins -> Container plug-ins -> Feed
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Hide in Range

The Hide in Range plug-in makes container either visible or invisible depending on whether value 
from real-time feed is within a specified range of numerical values.

Hide in Range Properties
Is active: Updates text geometry of container.
Locator: Gets data for text from this location.
Sub-Locator: Appends this to locator path when retrieving text.
Update Interval: Determines how often (in number of fields) an update occurs.

Feed View

The Feed View plug-in applies value from a real-time feed onto text geometry with various forms of 
optional formatting.

Feed View Properties
Is active: Updates text geometry of container.
Locator: Gets data for text from this location.
Sub-Locator: Appends this to locator path when retrieving text.
Update Interval: Determines how often (in number of fields) an update occurs.
Show verbatim: Shows data as given, does not interpret and reformat.
Plus prefix: Uses this prefix for positive values.
Minus prefix: Uses this prefix for negative values.
Suffix: Appends this suffix.
Decimal point: Uses these characters as a decimal point.
Leading zero: Uses leading zero for values less than one.
Zero replacement: Uses this string when value is zero.
Show message when no data: Sets the contents of the ’Empty Message’ field as text if the 
locator is not found in the cache if checked. If this is unchecked, the text geometry is left 
unmodified.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Feed

Note: This plug-in is located in: Plugins -> Container plug-ins -> Feed
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Empty Message: Sets text if the locator is unregistered.

4.4.7 Global
The following Container plug-ins are located in the Global folder:

Alpha
Audio
Average Texture
Clipper
Expert
Extrude
Global Illumination Settings
Glow
HDR
Infotext
Instancing Plugins
Key
Lighting
Light Layer
Light V4
Look-At
Magnifier
Masking
Mask Source and Mask Target
Projector Source and Projector Target
Script
Shadow Caster and Shadow Receiver
Synchronized Properties
Talent Reflection
Texture Slot
Video Clip
Window Mask
Z-Sort

Alpha

The Alpha plug-in adds an alpha channel to the container. The alpha channel defines the degree of 
transparency for the container and its Sub-Containers. This feature can be used to easily fade in or 
out a complete part of the scene-tree.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Global
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Alpha Properties
Alpha: Sets the alpha value for the container.

Audio

The Audio plug-in allows a designer to configure audio channels. The Audio plug-in can be applied 
to any Container. The plug-in has three different audio clip mixing modes, and each mode panel 
has a test function.

This page contains the following topics and procedures:

Default Mode
FX Mode
Manual Mode
To Configure Audio Channel Aliases
To Test Audio Channel Setup

Default Mode
The Default mode uses the Channel settings stored in the clip. For example FrontLeft and 
FrontRight are mixed to the aliases FRONT_LEFT, FRONT_RIGHT and so on.

If Viz Engine is configured with fewer channels, Viz Engine mixes the remaining clip channels 
according to the channel geometry. For example if Viz Engine only has stereo configured, but the 
clip used has 7.1 surround sound, Viz Engine mixes LeftBack and LeftMiddle to FRONT_LEFT and 
so on.

The Pan slider uses audio aliases when adjusting the volume of the left and right speakers. This is 
valid for multichannel configurations as well. If the slider is moved to the right in a 7.1 
configuration LeftBack, LeftMiddle and LeftFront are muted. The Volume field controls the overall 
audio volume of all clip channels.

FX Mode
In the FX mixing mode Viz Engine mixes the clip in relation to the listener position which can be 
defined in the fields X and Y. Viz Engine takes the channel geometry into account. 
The Volume field controls the overall audio volume of all clip channels.

Manual Mode
In Manual mixing mode it is possible to enter the Out Channel alias for every clip channel. The 
mask can hold more than one channel. This allows the mix of every clip channel to an arbitrary 
amount of out channels. The Volume field controls the overall audio volume of all clip channels.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Global
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The syntax for the string is as follows:

CHANNEL_ALIAS%VOLUME+CHANNEL_ALIAS%VOLUME…

or

[CHANNEL_ALIAS%VOLOUME]+

To Configure Audio Channel Aliases
Add an Audio clip to a Scene. 
Click the Audio plug-in icon (opens the Audio plug-in editor).
Click Manual.
Enter these channel configurations (as entered in Audio Settings in Viz Configuration (see 
the Viz Engine Administrator Guide):

Out Channel 0: FRONT_LEFT
Out Channel 1: FRONT_RIGHT
Out Channel 2: FRONT_CENTER
Out Channel 3: LOW_FREQUENCY
Out Channel 4: BACK_LEFT
Out Channel 5: BACK_RIGHT
Out Channel 6: SIDE_LEFT
Out Channel 7: SIDE_RIGHT

Save the scene. Depending on the settings in the channel configuration a clip now plays the 
different languages.

To Test Audio Channel Setup
Add a group container to the scene tree.
Add the Audio plug-in to the group container.
Open the Audio plug-in editor, and add an audio clip to the Audio Clip drop-zone, and click 
Play.

See Also

Audio Settings (see the Configuring Viz section of the Viz Engine Administrator Guide)

Example: [FRONT_LEFT%0.5]+

Note: You can use aliases as configured in the Channels tab (see the Audio 
Settings page in the Configuring Viz section of the Viz Engine Administrator 
Guide.



Tip: Always have a set of test clips that provide audio for the different channel 
setups.



http://documentation.vizrt.com/viz-engine
http://documentation.vizrt.com/viz-engine
http://documentation.vizrt.com/viz-engine
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Average Texture

The Average Texture plug-in takes an image or a media asset as a parameter and populates its 
average RGB color onto several places. 

For example, you can use this plug-in to set the light color based on the average color of your live 
video signal. 

Average Texture Properties
Target Type: Specifies where the average color gets applied to. This requires, that the same 
container also holds either a Viz 4 Light object or a Viz 4 Material Definition.

Light Color: Forwards the RGB value to the container light.
Material Color: The container's Viz 4 material tint receives the new color value.
None: Disables any forwarding.

Submit: Enables Shared Memory Support. Once this is turned on, every change calculated by 
this plug-in is submitted to Viz Engine's shared memory interface. 

Target Type: Defines which shared memory Map to use. 
Scene: The local scene shared memory map is used.
Global: This is needed if several scenes on the same Viz Instances (for example, 
GFX channels, etc) need to be notified about changes.
Distributed: If multiple Engines need to get these RGB changes. Changes are 
distributed via all connected Viz Engines on the same Graphic Hub.

Key: A unique key used to receive the changes.

The following script shows an example on how to use the Shared Memory Interface via Viz Script:

sub updateSHM()
  dim c as Container
  dim sourceName as String
  dim avg as Color
  avg =(Color)Scene.Map["average_texture_color"]
  c = Scene.findContainer("shm_color_text")
c.Material.Color = avg
println avg

end sub

sub OnSharedMemoryVariableChanged(map As SharedMemory, mapKey As String)
  if mapkey="average_texture_color" Then

Note: This plug-in is located in: Plugins -> Container plug-ins -> Global

Compatibility Info: This plug-in works in the Viz Engine Render Pipeline only!
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    println("SHM change: " & mapKey)
    updateSHM()
  end If
end sub

sub OnInit()
  scene.map.RegisterChangedCallback("average_texture_color")
end sub

Clipper

The Clipper plug-in is an alternative to the mask function. Objects with the clipper plug-in attached 
that are placed behind the clipper plane and are masked/clipped. If an object is only partially 
behind a clipper plane, only the parts of the object that are behind the plane are clipped out, since 
the clipping is done in true 3D space. The function uses the OpenGL clipping planes. Up to six of 
them may be used. To define a clipper plane use the Properties Panel.

All the containers that you want to be affected by the clipping plane, you must have the clipper 
plug-in applied and thereafter in the editor specify which of the clipping plane is to mask out/clip 
the container. It is possible to let a container be affected by multiple clipping planes.

The clipper plug-in can replace mask in many situations. Some of the advantages are compared to 
normal mask are:

Clipping is done in true 3D space, while masking is done in 2D (although the 2D mask is 
created by a 3D object).
There is no performance hit. In fact there is even a performance gain if parts of the object 
are clipped. Regular masks have a quite high performance cost.

Information: This plug-in doesn't work with DXT compressed images. It is mainly used for 
Media Assets like Live Input feeds.
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Clipper Properties
Planes: Enables the planes. By default, 1 is enabled.

To Create a Clipping Plane Effect

Add two group containers to the scene tree (same level) and name 

them  Cylinder  and  ClipperRectangle .

Add the following to the Cylinder container:
Cylinder geometry plug-in
Clipper container plug-in
Material
Optional: Expert container plug-in

Add the following to the ClipperRectangle container:
Rectangle geometry plug-in
Material
Optional: Expert container plug-in

Open the editor for the Cylinder container and set Scaling (locked) to 2.0 .

Open the Cylinder editor and set Hole to 45.0 .

Open the Clipper editor and enable Plane 1 (enabled by default).
Optional: Open the Expert editor(s) and enable Back Face (On) and Twosided Lighting.
Open the editor for the ClipperRectangle and set the following parameters for the following 
properties:

Set Position Y to 45.0 .

Set Rotation X to -45.0 .

Set Rotation Y to 45.0 .

Note: This plug-in is located in: Plugins -> Container plug-ins -> Global
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Set Scaling (locked) to 2.0 .

Open Scene Settings, and select the Clipper Panel tab.
Enable State 1, and Reverse.

Drag and drop the ClipperRectangle container onto the Tracking Object drop zone.

Expert

The Expert plug-in sets some special properties and adds some advanced functions to a Container.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Global
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Expert Properties
Draw Mode: Selects how to have the container drawn:

Normal: Shows the rendered object with material and/or textures.
Wireframe: Shows the polygons that are drawn to create the object.
Outline (Classic Render Pipeline only): Shows the outline of the object.

Width: Sets the width of the wires if Wireframe or Outline draw mode is selected.
Back Face: Renders the back face of a geometry. This can be useful when rendering 
transparent objects.
Two-sided Lighting (Classic Render Pipeline only): Enables two-sided lighting for a single 
container instead for a whole scene.
Z-Buffer Draw: Defines if the depth buffer is used for rendering or not.

Z-Buffer Ignore: Ignores the OpenGL Z-buffer draw option when set to Off , and draws the

object no matter if it is in the back or not.
Line Anti-aliasing (Classic Render Pipeline only): Renders an anti-aliased outline for 2D
objects on machines that do not have anti-aliasing with multi-sampling. This extra outline
can be removed by disabling this option.
Exact Picking (Classic Render Pipeline only): Exact Picking is usually a bit slower, as it uses
pixel values instead of using the bounding box dimension.
Separate Specular (Classic Render Pipeline only): Enables specular highlights for textured
geometry.
Mirror: Enables you to mirror the object over the X-, Y- and Z-axis.
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Enable Render Mode: This is for the Viz Engine Render Pipeline only. An export plug-in 
automatically adds transparency to the object. To disable this transparency in the Viz Engine 
Render Pipeline, disable Enable Render Mode. 

Render Mode:
Add: Symbolically: C*A + FC. The source color gets added to the target color. The 
amount of color that is added depends, as we see from the formula, on the alpha 
value. However, it is always an addition, so the end result is always a lighter color than 
the initial frame content. If the frame color has high values on all three color channels 
(RGB), you might experience that the addition of the new color takes all channels to 

values above 255  (saturation). The values are clamped at 255 , which is white.

Blend: Symbolically: C*A+(1-A)*FC. The new color value gets created as a weighted 
average of the source and the target. The weight factor is the alpha value of the 
rendered color. That means that if the incoming color has a very low alpha value, its 
influence on the new color is small, and conversely, if the new color has a high alpha 
value, its influence on the new color is larger.
Subtract: Symbolically: FC-C*A. The new color is the result of the incoming color being 
subtracted from the color in the frame buffer and the result is written back into the 
frame buffer. The alpha value of the incoming color decides how much who gets 
subtracted. If the incoming color has high values on all three color channels (RGB), you 

might experience that the subtraction of the new color takes all channel values to 0 , 

and the result is a black color.
Rev-Subtract: Symbolically: C*A-FC. This is a reversed version of subtractive. The color 
in the frame buffer gets subtracted from the incoming color and the result is written 
back into the frame buffer.
Multiply: Symbolically: CA*FC. The new color and alpha get multiplied with the 
existing values in the frame buffer. The formula presupposes that the colors and 

alpha re described as values between 0  and 1 . A color rendered with multiply always 

results in a darker color than both the color being rendered and the color in the frame 
buffer.
Rev-Multiply: This is a reversed version of multiply.
Max: Higher color values overwrite lower color values (for example, white draws over 
black - independently from the Z-Sort).

Shade Model (Classic Render Pipeline only)
Flat: Shows the single polygons the object is made of. Lighting is only applied per face 
and not per vertex.
Smooth: Calculates a smooth surface.

Transparency Mode (Classic Render Pipeline only)
Blend: Is the standard option.
Mask: Uses a raster.
Fastest: Uses the transparency mode which takes the least time to render.
High Quality: Uses the transparency mode which delivers the best looking result.

Draw Layer (Classic Render Pipeline only): Defines if the objects are drawn in all layers or 
only if it shows in a certain layer:

Any: The object is always drawn.
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Main: The object is drawn only if it is in a scene, located in the Main Layer.
Back: The object is drawn only if it sits in the Back Layer.
Front: The object is drawn only if it is in the Front Layer.

Extrude

The Extrude plug-in sweeps a 2D item through space along its Z-axis. The sweeping path the item 
is followed during this process is used to create a surface. A a result a 3D item with front, back 
and sides is created from the 2D item.

Extrude Properties
Bevel Types: The buttons marked with different bevel types are used to set the type of bevel 
to use on the figure.
Extrusion Depth: Sets the extrusion depth on the Z-axis.
Bevel Size: Sets the size of the bevel. This must be set to some value to enable the selection 
of bevel type.
Shading Angle: Sets the angle of the shading function. To “erase out” unevenness, try 
increasing the shading angle.
Bevel Detail: Sets the degree of detail of the bevel. The lower the value is set the more 
detailed the bevel is constructed. The more detailed the bevel is, the smaller tilings its 
constructed from.
Backface: Allows you to enable or disable visualization of the backface.

If colors are set to Active, you can edit the items Front, Back and Side color by using the sliders or 
changing the values.

Note: The Draw Layer option can be used, for example, for a menu in a Scene 
which should be only visible if it is loaded in the front layer.



Note: This plug-in is located in: Plugins -> Container plug-ins -> Global

Note: Adding the Extrude plug-in to a font sets the font’s quality to Normal  and disables 

the Quality selector in the Text Editor.
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To Extrude a 2D object

Create a group and add the Circle geometry plug-in and material to it.
Add the Extrude plug-in to the same container.
Open the Extrude editor and select one of the bevel effects, and set Extrusion depth to 

100.0  and Bevel Size to 10.0 .

Global Illumination Settings

The Global Illumination Settings plug-in defines how Global Illumination is applied to this and all 
subcontainers.

A detailed chapter on how Global Illumination works, as well as the properties of this plug-in can 
be found in the Global Illumination page in the Viz Artist User Guide.

Glow

The Glow plug-in makes the lit faces of objects glow.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Global

Compatibility Info: This plug-in works in Viz Engine Render Pipeline only!

http://documentation.vizrt.com/viz-artist
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Glow Properties
Blur Width: Sets the width of the blur (the size of the glow).
Strength: Sets the intensity/strength of the glow.
Object Strength: Sets the intensity/strength of the glow on the faces of the object.
Draw Texture: Uses the selected Texture for the Glow Effect. When a multi-textured object is 
used, use the Unit drop down box to select which of the textures to use.

Use Color: Changes the color of the glow when set to  On . If set to  Off , the glow is based 

on the Color (Material and Texture) of the Object.
Textured: Applies the Texture, or Textures, of the object on the glow.

To Add a Glow

Add a Sphere plug-in to the Scene Tree.
Add a Material and a Texture to the Sphere container.
Add the Glow plug-in.
Open the Glow editor and set these parameters:

Blur Width: 50.0 .

Strength: 8.0 .

Object Strength: 0.0 .

Enable Use Color and set the color parameter.

Examples with the same parameters and:

Draw Texture set to  On  (1)

Texture set to  On  (2)

Note: This plug-in is located in: Plugins -> Container plug-ins -> Global

Compatibility Note: This plug-in has been deprecated in the Viz Engine Render Pipeline. It 
can be replaced with emissive colors and blooming effects.
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HDR

The HDR plug-in enables High Dynamic Range Rendering/Imaging for the selected container. This 
improves the contrast of the generated scene in a much more realistic way.

HDR Properties
This plug-in does not have any properties or parameters.

To Add HDR
Drag the plug-in on a container and modify the HDR settings under Scene settings > HDR. Specify a 
diffuse and a Cubic Reflection image, as required.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Global

Compatibility Note: This plug-in has been deprecated in the Viz Engine Render Pipeline.
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Infotext

The Infotext plug-in allows to add some additional information to a certain container (for example, 
file history on a top container or instructions how to use a certain script, etc.).

Infotext Properties
This plug-in does not have any properties or parameters.

To Add Infotext
Drag the plug-in on a container and enter any additional text into the text box in the plug-in 
properties.

Instancing Plugins

Instance and Instance producer plugins are required for a special way of efficient rendering of 
multiple objects. For details on this feature, please see Introduction to Viz Engine Rendering > 
Instancing in the Viz Artist User Guide. 

To define the source of your instance, place the Instance plug-in on a container and assign a 
Target container hosting a Producer plug-in in the UI.

This renders copies of the instance container underneath the producer container.

Key

The Key plug-in adds a Key signal to a container.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Global

Note: These plug-in are located in: Plugins -> Container plug-ins -> Global

Compatibility Information: This plug-in works in the Viz Engine Render Pipeline only!

http://documentation.vizrt.com/viz-artist
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Key Properties
Draw RGB: Enables or disables the graphical object.
Draw Key: Enables or disables the key signal.

Automatic Alpha: Calculates the alpha value automatically when set to On . Takes the alpha 

value entered when set to Off . This is normally done to obtain some level of transparency 

so that, for example, video background is visible through the key object.
Alpha as Key Only: Takes the alpha value of the object and renders the key with this alpha 
instead of the alpha value of the key function attached. The object itself is rendered opaque. 
This is usually used to render transparent objects for keyed graphics. The color mixing of 
the object in the scene and the, for example, video background is done by the external 
Keyer so the object must be rendered non transparent.
Render Mode: Sets the mode in which the alpha values of the key item to be rendered should 
be mixed with the alpha values already existing in the frame buffer.

The mixing is done on a per pixel basis (in the formulas the range of the alpha values is 

from 0-1 , instead of 0-100  as in the value field).

If A is the current source alpha value being rendered now and FA is the alpha of the frame 
buffer contents (target), the different modes can be explained as following:

Add: (A + FA) The source alpha gets added to the target alpha. As the formula shows it 
is an addition, so the end result is always a higher alpha value than the initial frame 
content. If the frame alpha has a high value, you might experience that the addition 

gives a total value above 1. This is clamped at 1 , which is opaque.

Blend: (A+(1-A)*FA) The new alpha value gets created as a weighted average of the 
source and the target. If we as an example say that the key being rendered has alpha 

1  and the frame alpha has 0.5 , the formula is: 1+(1-0.5)*0.5 = 0.75.

Subtract: (FA-A) The new alpha value is the result of the incoming alpha being 
subtracted from the alpha in the frame buffer and the result is written back into the 
frame buffer.
Rev-Subtract: (A-FA) This is a reversed version of subtractive. The alpha in the frame 
buffer gets subtracted from the incoming alpha and the result is written back into the 
frame buffer.
Max: Uses the maximum of all key signals.
Combine with BG chroma key: Combines the alpha of the Container with the alpha of 
the background, before blending the foreground with the background (active in a 

virtual sports render sequence only) when set to  On .

Depth information only: Occludes depth only for rendering with live video. Containers 
which are marked for Depth Only are rendered before Containers which are marked 
for chroma or linear keying. This could be useful for sports, where real objects should 

Note: This plug-in is located in: Plugins -> Container plug-ins -> Global

Note: Be aware that with the subtractive and the rev-subtractive, mode the order in 
which the objects are being rendered then is crucial. Make sure the z-sort is correct.
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occlude virtual items of the scene. This setting requires the Render Sequence to be set 

to  Arena  in the scene’s Global Settings Panel.

Separate Depth Render Pass: Only necessary for Libero render sequence. Renders 
containers in a second pass after merging depth information. Useful if a container 
should be always rendered on top (for example, a beam).

To Add Key
Open a Scene.
Add an object.
Add Key plug-in.

Click the Key button on the left side of the Scene Editor.

Lighting

The Lighting plug-in adds individual lighting per object. This affects the containers only, whereas 
global lights affect the whole scene.
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Lighting Properties
Type: Determines the light source type:

Local: The Local light source is a positional light. It is near or within the scene, and the 
direction of its rays is taken into account in lighting calculations. Local lights have a 
greater performance cost than directional lights, due to the additional calculations. A 
real life equivalent to a local light source is a light bulb. The Local light source has 
properties for color and position.
Spot: The Spot light source emits a cone of light. The only objects that are illuminated 
are those within the cone. The Spot light source has properties for color, position, 
rotation, and attenuation.
Infinite: The Infinite light source is a directional light. It is considered to be an infinite 
distance away from the objects in the scene. Because of the distance, the rays of light 
are considered parallel by the time they reach the object. A real life equivalent to an 
infinite light source is sunlight. The Infinite light source has properties for color, 
position, and rotation. Infinite is selected by default.

Shadow: Turns shadows on or off.

Smoothness: Affects how shadows blend. Value from 1  to 10 . The smoother, the more 

blended (soft) the shadows are.
Shadow Color: Selects the color and alpha value of the shadow.
Color: Sets the light source color.
Position: Sets the position of the light source along the X, Y, and Z axis.
Rotation: Sets the values for Pan, Tilt, and Twist for Spot or Infinite light sources.
Cascaded Shadow Mask: Determines the frustum distances affected by shadows (i.e. the 
three-dimensional region with shadow effects specified as Near, Middle and Far regions).
Spot: Sets the concentration of the light within the light cone of the Spot light source. When 
set to zero, the whole light cone has the same intensity. If set greater than zero, the 
intensity decreases away from the center.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Global

Compatibility Note: This plug-in has been deprecated in the Viz Engine Render Pipeline.
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To Add Light

Open the Light Editor, and disable global light settings.
Add a Sphere geometry to the scene tree, and add material and the Lighting plug-in to it.
Duplicate the Sphere container and place it at the same level (root) as the other container.

Open the transformation editor and set Position X to -100.0  for the first container and 

Position X to 100.0  for the second.

Open the Lighting editors the first container one and set the following parameters:

Set Type to Spot .

Set Light Color to 0,255,0 .

Open the Lighting editors the second container one and set the following parameters:
Set Type to Spot.

Set Light Color to 0,255,0 .

Set Position X and Y to 650.0  and -850.0 , respectively.

Set Rotation X and Y to -650.0  and 850.0 , respectively.

Light Layer

The Light Layer plug-in applies lighting to a certain group of containers.  Every light has a light 
layer property, the light with its corresponding bit-wise layer number is only applied to the light 
layer group.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Global
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Light Layer Properties
Mask (1-8): Selects a bit-wise mask on what lights are being applied to this container. If you 
have two spotlights within your scene, a layer can be set for each single light. You can 
choose if your geometry is lit by Light 1, Light 2 or both.

Light V4

The Light (V4) plug-in adds a new Viz Engine light onto a container.

More detailed information about how to use Lights in Viz is available at Light and Shadows in Viz 
in the Viz Artist User Guide.

Light (V4) Properties
Light Type: Selects what kind of light is applied to your container. 

Directional
Point
Spot 
Area

Color: Selects the color the light source emits. 
Intensity: Determines the strength of the light source.
Diffuse Intensity: Determines how much light diffuse areas emit.
Specular Intensity: Determines how much specular areas of the source are affected. This is 
also important for Blooming Effects.
Radius: Defines the active area of a Point or Spotlight.
Outer and Inner Cone Angle: Defines the angle of a spot light’s beam (available to spot 
lights only).
Layer: Defines the layer, this light is active. See Light Layer plug-in.

Compatibility Info: This plug-in works in the Viz Engine Render Pipeline only!

Note: Light layers are counted from 0  (Light UI), whereas in the Light Layer plug-in they 

start from 1 .



Note: This plug-in is located in: Plugins -> Container plug-ins -> Global

Compatibility Info: This plug-in works in the Viz Engine Render Pipeline only!

http://documentation.vizrt.com/viz-artist


Plug-ins User Guide -  5.0

Copyright © 2022  Vizrt Page  254

•

•
•
•

•

•
•

•
•
•
•

•
•

•
•
•

•

•

Shadow Settings

Shadow On/Off: Generates shadows from the lights when set to On  (this setting is not 

available on Area Lights).
Offset Factor: Defines the polygon offset factor for shadow rendering.
Offset Units: Defines the polygon offset units for shadow rendering.
Split Lambda: The value to blend between log and uniform cascade splitting.

Global Illumination Properties

Directional Spread: Influences the strength of your Global Illumination effect for this light 
source.
Radiosity Multiplier: Determines how strongly your Ambient Occlusion settings are applied. 
Bake: Defines if your light is used as a real-time light or as a baked Global Illumination light.

Look-At

The Look-At plug-in is used to rotate a Container so that it faces a defined direction (billboarding). 
This is especially valuable in animations, it ensures that a geometry always faces towards the 
camera.

Look-At Properties
Auto Rotation

None: Does not rotate.
Billboard: Rotates the container to face the camera.
Follow Path: Rotates the container to justify at the animation path.

Keep Size: 
Billboard Axis: Only with Billboard:

X: Rotates the container around the X-axis to face the camera, even if camera moves.
Y: Rotates the container around the Y-axis to face the camera, even if camera moves.
XY Camera: Rotates the container around the X- and Y-axis to face the camera, even if 
it moves.
XY Screen: Rotates the container around the X and Y-axis to face the camera, if the 
camera orbits the container only.

See Also

Create Animations section of the Viz Artist User Guide.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Global

http://documentation.vizrt.com/viz-artist
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Magnifier

The Magnifier plug-in enlarges certain areas of the render output. This plug-in magnifies all 
underlying graphics. Create a container and drag the Magnifier plug-in on it. It automatically 
magnifies the underlying parts. It can be used multiple times (in contrast to the scene magnifier 
functionality).

Compatibility Info: This plug-in works in the Viz Classic Render Pipeline only and only is 
available if the Render mode is set to Classic.



Note: This plug-in is located in: Plugins -> Container plug-ins -> Global
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Magnifier Properties

Type: Defines the basic shape of your loupe. It can be either a rounded circle or a square 
rectangle shape.
Position: Defines the location of the maginfication. This can be either defined in the plug-in 
itself by modifying the x and y parameters or you use the attached containers position by 
activating the Use container position option. 
Size: Defines the location of the maginfication. This can be either defined in the plug-in itself 
or you use the attached containers scale by activating the Use container scale option. 
Scale: Determines the magnification level. 
Ellipsis: Defines how much distortion the lens has. 

Alpha: Gives your magnifier a smooth border. A value of 1  gives a sharp edge and the lower 

the value, the smoother the edges are.

Tesselation: Defines how exact the loupe is build. A value higher than 20  does not make 

any sense and provides no visual improvement. 

Masking

The Masking plug-in provides a simple masking functionality for your Tonemapping effects. 

This plug-in can be used to turn off Tonemapping and Gamma correction for containers. 

This could be used for example on live sources, if Post Processing Effects should not be applied. 

Compatibility Info: This plug-in works in the Viz Engine Render Pipeline only!

Note: This plug-in is located in: Plugins -> Container plug-ins -> Global
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For example if a live input should not be affected by tonemapping or gamma correction:

Create a container and add a PBR material.
Drag a live source onto the emissive part of the PBR material.
Apply the masking plugin and turn off tonemapping and gamma correction.

Mask Source and Mask Target

The Mask (Source and Target) plug-ins allow one Container to act as a mask for other Containers. 
The Mask Container is called the source and the Containers which are affected by the source mask 
are called targets. A Container affected by a mask becomes transparent where the mask covers it.

Due to graphics hardware limitations, currently Viz Artist supports a maximum of eight different 
target and source layers for one object. This means that any target within a layer is affected by all 
masks for the same layer. For example, if a mask has the layers 1, 2 and 3 selected, it affects all 
targets that have 1, 2 or 3 selected.

Enable shadows in the Global Settings Panel. 

Layers 7 and 8 may not be available because global shadow settings are enabled by default. 

Shadows use two layers of the mask plug-in, but can be set to  Off  in Global Settings Panel, to use 

all eight layers.

In the Global Settings Panel, define if a mask layer is to be drawn inverted. Normally the mask cuts 
a hole in the mask target where it covers it. If a layer is selected to be drawn inverted the opposite 
situation is the case. Only where the mask covers the mask target is target be visible.

Mask Source and Mask Target Properties
Layer: Sets the layer the mask should have an effect on. This allows the creation of more 
than one mask that has an effect on the target.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Global
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Inherited: (Mask Source Only) When enabled ( On ), all Sub-Containers of the mask source 

mask the target. If disabled ( Off ) all Sub-Containers of the mask source does not mask the 

target as it no longer inherits the mask properties.

Force Visible: (Mask Source Only) When enabled ( On ), the geometry serving as mask source 

is rendered in the scene editor, even when not selected. When disabled ( Off ), the mask 

source geometry is only rendered when selected. This enables the designer to work more 
efficiently with multiple mask sources when designing the scene. The mask source geometry 
never gets rendered on the output.

To Add a Mask

Add three Containers to the Scene Tree.

Name them  source_1 ,  source_2  and  target .

Add a Font and the Mask Source plug-in to the source_1 Container.
Add a Rectangle and the Mask Source plug-in to the source_2 group.
Add a Rectangle, material (e.g. red) and the Mask Target plug-in to the target Container.
Open the source_1 Transformation Editor:

Set Axis Center X and Y to C .

Reset Position X and Y to 0.0 .

Open the source_1  Text Editor: Enter some text (e.g. Vizrt).

Open the source_1 Mask Source editor: Set Layer to 1 .

Open the source_2 Transformation Editor: Set Position X to -120.0  and Y to -70.0 .

Open the source_2 Rectangle editor: Set Width and Height to 50.0 .

Open the source_2 Mask Source editor: Set Layer to 2 .

Open the target Rectangle editor: Set Width to 300.0  and Height to 200.0 .

Open the target Mask Target editor. Enable Layer 1 and Layer 2.
Add a Container as a Sub-Container of source_2.

Name it  source_inherited .

Add a Circle to the source_inherited Container.

Open the source_inherited Transformation Editor: Set Position X to 240.0 .

Open the source_inherited Circle editor: Set Radius to 25.0 .

Open the source_2 Mask Source editor

Disable Inherited ( Off ). This should make the Circle disappear as it no longer inherits 

the Mask Source properties.
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Projector Source and Projector Target

The Projector Source and the Projector Target plug-ins are used to project something on 
something else (for example, an image onto a geometry).

A projector container creates a planar projection of their texture onto container(s) with the 
projection target function attached. In principle it works similar to a slide-projector. For objects 
that do not have texture coordinates, the projector function can be used to apply texture to such 
objects. It also gives the possibility to have two textures on a single object, the objects own 
texture and the projected texture.

The projector and the projection target can be set up to react on different layers similar to 
shadows and masks.

This page contains the following topics and procedures:

Note: The projector plug-in does not work on text.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Global

Compatibility Note: This plug-in has been deprecated in the Viz Engine Render Pipeline.
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Projector Source Properties
Projector Target Properties
To Project a Texture onto an Object

Projector Source Properties
fovy: Sets the field of view for the projector container. The higher the fovy is set, the larger 
the projected texture on the receiver is. You can picture it as the zoom function of a slide 
projector.
Show: Allows you to hide/show the projector object.
Layer: Lets you select by which layers the projector and receiver are to perform the function. 
You can use up to eight different projector layers and source layers for one object. This 
means that targets with the layer 1 set is affected by all projectors which have the 
corresponding layer selected. If a projector has the layers 1, 2 and 3 selected it affects all 
targets with 1, 2 or 3 selected.

Projector Target Properties
Layer: Lets you select by which layers the projector and receiver are to perform the function. 
You can use up to 8 different projector layers and source layers for one object. This means 
that targets with the layer 1 set is affected by all projectors which have the corresponding 
layer selected. If a projector has the layers 1, 2 and 3 selected it affects all targets with 1, 2 
or 3 selected.

To Project a Texture onto an Object

Add a group container to the scene tree, add the Projector and Alpha plug-in to it, an image/

texture, and name it  Source .

Open the Alpha editor and set the alpha value to 50.0% .

Open the transformation editor for the Source container and set Rotation Y to 135.0 .

Add another group to the scene tree, and name it  Target .

Open the transformation editor for the Target container, and set Position X to 130.0 .

Add the Sphere geometry plug-in, material, image/texture and the Projector Target plug-in 
to the Target container.
Optional: Animate the sphere.
Open the Projector editor and disable the Show property.
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Script

The Script plug-in allows adding scripts to a Container and storing them with the Scene. It is 
possible to archive and import scripts as part of a Scene Archive as with any other plug-in.

A script can also be saved as its own script plug-in, and used in future Scenes (). To save a script 
as a script plug-in, drag a compiled script into the Script folder. The Script plug-ins folder is a 
special folder that lets users create and name plug-ins.

There is an important difference between a script that is not converted into a plug-in, and a script 
that is. As long as it is not converted the content of the script code is data within the Script plug-
in, just like the width property is data within for example a geometry plug-in. Once the script is 
converted to a plug-in it is a plug-in itself, like any other plug-in.

See Also

Scripting section of the Viz Artist User Guide

Shadow Caster and Shadow Receiver

The Shadow Caster and Receiver plug-ins enable an object’s shadow to reflect on another object. 
To create a shadow item in a scene, two containers at a minimum must be used. The caster plug-in 
must be attached to one container and the receiver function to the other. The container acting as 
the caster must be positioned between the receiver container and a light source. For correct 
lighting calculation, a material is also required on the container. Objects that can function as a 
shadow receiver should be a built in 2D geometry or a font. An imported 2D geometry does not 
work.

This page contains the following topics and procedures:

Shadow Caster Properties
Shadow Receiver Properties

Note: This plug-in is located in: Plugins -> Container plug-ins -> Global

Note: Script plug-ins are saved to <viz data folder>\Scriptplug-ins.

WARNING: A script plug-in is not stored in the database, and is not distributed with an 
archive, because it is code and not data.



Note: This plug-in is located in: Plugins -> Container plug-ins -> Global

http://documentation.vizrt.com/viz-artist
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To Cast a Shadow
Shadow Receiver Known Limitations

Shadow Caster Properties
Lights: Allows you to select which light sources are to shine on the caster object and thereby 
producing the shadow/shadows.
Alpha: Sets the alpha value and hence the transparency of the shadow being cast on the 
receiver objects.
Color: Allows you to define the shadows color.
Auto-Fading: With this option enabled, if you fade out a caster object either by using the 
alpha function or by adding a material with a low alpha value, the shadows created by the 
caster fades correspondingly. The option is enabled by default, since it looks right that the 
shadow fades out when the caster object fades out.
Layer: Allows you to select by which layer(s) the caster casts a shadow. You can select up to 
eight layers. Each layer corresponds to the layer selected in the Receiver objects. If you want 
all shadow casters to cast shadow on all receivers, you can set all layers on all casters and 

receivers to 1 . If you want one caster to create shadow on some receivers and another 

caster to create shadow on different receivers, you select different layers for the sets of 
casters and corresponding receivers. Casters and receivers can have multiple layers enabled 
at the same time so you can set up a great number of combinations of caster/receiver 
combinations.

Shadow Receiver Properties
Alpha: Sets the alpha value.

Clipping: Cuts the shadow on the border of the object when set to On . When set to Off , 

the shadow is rendered onto the background outside the object, which normally looks 
wrong. Rendering with the clipping options set takes more resources than without. If you for 
instance have an infinite floor or a room with walls, you can switch of clipping without 
seeing the “false” shadows, and thereby save some rendering performance.
Culling: Decides in advance of the rendering process if the shadow is visible or if it is hidden 
by other objects. If that is the case, it skips it in the rendering process. If you know for sure 
that the shadow for an object in a scene should be rendered visible for the whole object, you 
can disable culling to save some rendering time, but the effect is marginal.
Show Receiver: Hides or shows the receiver object. If it is hidden, the shadow is still visible.
Draw Key: Adds key to the shadow. When enabled, the receiver must be hidden for the key 
to be drawn.
Key Value: Sets the key value.

Layer: Allows you to select by which layers the receiver receives shadow. You can select up 
to eight layers. Each layer corresponds to the layer selected in the caster objects. If you want 
all shadow casters to cast shadow on all receivers, you can set all layers on all casters and 

Note: The Key Value setting is not available when Shadow Type in the Global Settings 
Panel is set to Shadow Map.
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receivers to 1. If you want one caster to create shadow on some receivers and another caster 
to create shadow on different receivers, you select different layers for the sets of casters and 
corresponding receivers. Casters and receivers can have multiple layers enabled at the same 
time so you can set up a great number of combinations of caster- and receiver 
combinations.

To Cast a Shadow

Add a group container to the Scene Tree

Name it  Sources .

Add a Fontstyle and the Sphere and Cylinder Geometries as Sub-Containers of Sources.
Add a Material and the Shadow Caster plug-in to each Sub-Container.
Add a Group Container at the same level as the Sources Container
Add a Rectangle Geometry, a Material and the Receiver plug-in to it.

Position the Rectangle and the other objects such that the Sphere, Cylinder and text casts a 
shadow on the rectangular surface.

Caution: Containers are rendered twice when shadows are used.
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Shadow Receiver Known Limitations
With shadows in Stencil Mode, the current implementation of the shadow receiver assumes that 
the receiving surface is flat and a standard geometry object, such as a rectangle, orientated on the 
XY plane. Non-flat geometries, and planes which are not extending in the XY plane, does not 
produce a properly casted shadow. However, by activating Shadow Map for the desired light 
source, shadows render correctly. Always make sure that the receiving object has a material.

Synchronized Properties

The Synchronized Properties plug-in can be used to synchronize container property changes within 
the same scene loaded on a cluster of Viz Engines. Synchronization needs to be configured for 
each Viz Engine taking part in the clustered setup. This plug-in works on a per container basis, 
which keeps network traffic low. Child containers do not inherit the plug-in, and requires their own 
instance of the plug-in if they are to be synchronized. A scene plug-in is available for use-cases 
where the entire scene is to be synchronized.

This feature works for all container properties and plug-in parameters, and requires that the 
Engines render the same scene, referencing the same UUIDs. This allows designers to work with 
different versions of the same scene, without any need to update the changed IDs in external 
applications. If a parameter change is transferred to another Engine, then the container UUID of 
the last loaded scene is used for the update. If new UUIDs are required, a new scene has to be 
created, either from scratch, or by merging the complete scene into a container which is then split 
into a new scene.

To Synchronize Plug-in Property Changes on Multiple Viz Engines

Configure the involved Engines for synchronization.
Create the scene that should be synchronized.
Add the Synchronize Properties plug-in to those containers that should be synchronized. No 
scripting is required for the synchronization.

See Also

For more information about how to synchronize multiple Viz Engines, see the Global 
Input page in the Configuring Viz section of the Viz Engine Administrator Guide.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Global

Example: A renderer with touch screen controls a stereoscopic interactive scene which is 
rendered on two other Engines. All three Engines need to perform all property or 
transformation changes at the same time.



http://documentation.vizrt.com/viz-engine
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Talent Reflection

The Talent Reflection plug-in is used to render imaginary talent at a given depth only visible in 
reflections. With this method, it is possible to render reflections of any live video input on 
Augmented Reality objects. Below is an example of a rendered scene with talent reflections, 
a simple checkerboard texture is used as talent reflection input source.

Talent Reflection Properties
Source: Determines talent input source (Live input, Clip input, Image...).
Downscale: Scales down rendered talent reflection to prevent ghosting artifacts.

Usage
Enabling post-processing is required to see the effect in the Scene Editor.
Create at least one container with geometry and reflective material. 

Note: This plug-in is located in: Plugins -> Container plug-ins -> Global

Compatibility Info: This plug-in works in the Viz Engine Render Pipeline only!
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Drag the plug-in to a new container. This container is used for positioning. The distance 
from the container to the camera defines the position where the talent reflections are 
drawn. 
Add any geometry as sub-container to see where its positioned inside the scene. This 
container can be hidden for final rendering. 
Next, drag any image source (Live input, Clip input, Image...) into the Source placeholder.

Limitations
Normal Screen Space Reflections are not visible behind the talent reflection plane.

Texture Slot

The Texture Slot plug-in allows multi-texturing like in the Classic Render Pipeline for Phong and 
PBR Materials.

You can create as many slots as you want and use the textures in these slots to blend with a PBR 
or Phong material. It can be blended with all available textures in either the Phong or the PBR 
materials.

Plug-in Settings
To create a new Texture Slot, give it a unique name and hit the + button. The new slot is put on 
top of the existing ones. To reorder your slots, use the up and down arrows. To delete your slot, 
press the trash icon.

sRGB Enabled: Provides support for extended colorspace when enabled.

Blend Settings

The Target defines which texture unit you want to blend with. 

Note: This plug-in is located in: Plugins > Container plug-ins > Global.

Compatibility Info: This plug-in works in the Viz Engine Render Pipeline only!

Note: Slots can not be renamed after creation.
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Target Available in

BaseColor PBR/Phong

Ambient Phong

Diffuse Phong

Specular Phong

Emissive Phong

Normal PBR

Roughness PBR

Metallic PBR

Height PBR

You can simulate an animated height effect if you, for example, blend an additional normal map to 
an existing one. The Color Blend mode defines how your image is blended with the Target image. 

Target Slot

Operatio
n

Explanation Samp
le

Basic Operations

Information: The Ambient Occlusion texture is not accessible through the Texture Slot 
plug-in by design.
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Keep Keeps the Target image.

Replace Replaces the Target with the Slot image.

Average Uses the average pixel values of both images.

Normal Replaces the Target with the Slot image. Same as Replace

Lightening Operations

Add Adds the Slot image to the Target image.

Lighten Uses the lighter pixel value of both images.

Screen With Screen blend mode, the values of the pixels in the two layers are 
inverted, multiplied, and then inverted again. The result is the opposite of 
Multiply: wherever either layer was darker than white, the composite is 
brighter.

ColorDod
ge

The Color Dodge blend mode divides the Target by the inverted Slot. This 
lightens the Target layer depending on the value of the Slot layer: the 
brighter the Slot, the more its color affects the Target. Blending any color 
with white gives white. Blending with black does not change the image.

LinearDo
dge

Brightens the Target color to reflect the Slot color by increasing the 
brightness. Blending with black does not have any influence - See 
LinearBurn

Reflect This mode is useful when adding shining objects or light zones to images.

Glow This mode is a variation of reflect mode (base and blend color swapped).

Darkening Operations

Subtract Subtracts the Slot image from the Target Image.

Darken Uses the darker pixel value of both images

Multiply Multiplies the Slot image with the Target image.
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ColorBurn The Color Burn mode divides the inverted Target by the Slot image, and 
then inverts the result. 
This darkens the Slot image increasing the contrast to reflect the color of 
the Target image. The darker the Target layer, the more its color is used. 
Blending with white produces no difference. 

LinearBur
n

Darkens the Target color to reflect the Slot color by decreasing the 
brightness. Blending with white does not have any influence - See 
LinearDodge

Contrast Effects

Overlay Uses Screen blending on lighter pixels and Multiply mode on darker pixels. 
It is the opposite operation to the Hard Light blending.

SoftLight Similar to Overlay, but appears softer. 

HardLight Uses Linear-Doge on lighter pixels and Linear Burn on on darker pixels. It is 
more intense than the Overlay and results in harsher lights.

VividLight Uses Color Doge on lighter pixels and Color Burn on on darker pixels. It 
appears more extreme than the Hard Mix Effect.

LinearLig
ht

Uses Linear Dodge blend mode on the lighter pixels and the Linear Burn 
blend mode on the darker pixels. Similar to the Vivid Light blend mode in 
overdrive, and typically results in a more extreme effect.

HardMix Uses Linear Light as threshold. It is recommended to adjust the Blend 
Factor to achieve some great results.

PinLight Lightens lighter pixels and darkens darker pixels. This is a wild blend mode 
that can result in patches or blotches (large noise), and it completely 
removes all mid-tones.

Inversion Effects

Differenc
e

Difference subtracts the Target from the Slot or the other way around, to 
always get a non-negative value. Blending with black produces no change, 
as values for all colors are 0. Blending with white inverts the picture.

Exclusion This mode is basically the same as the Difference blend mode, except when 
similar colors cancel each other, the resulting color is gray instead of black.

Phoenix This subtracts the lighter pixel from the darker pixel, and adds 255, giving 
a bright result.
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Negation

Alpha Blend mode defines how the Alpha Channel of the Slot image will be used:

Keep: Keeps the Target Alpha.
Replace: Uses the Slot Alpha.
Add: Adds both Slot and Target Alpha channel.
Multiply: Multiplies both Alpha channels..
Subtract: Subtracts the Slot Alpha Channel from the Target Channel.
Reverse Subtract: Like subtract, but inverted afterwards.
Negate: 

Blend effect defines how strongly the operation is applied to the Target image. This is defined 
from 0 (no effect at all) to fully (1).

Swizzle

The Swizzle part allows to exchange the various color channels. You can for instance ignore an 
alpha channel or fill it completely white (1) or black (1).

Texture Coordinates

This defines how the final composition will be applied to the Target Texture. Usually this is done in 
Vertex mode, but you can also overwrite it, for example to use the Slot Image as Reflection map. 
Additional mapping options can be achieved by using offset, scaling and rotation.

Video Clip

The Video Clip plug-in works in combination with the Control Video plug-in. It allows you to use 
clip Key Frames in the stage for clip playback. When used with Transition Logic, the Key Frames 
can be merged with the object.

When Video Clip is used in Transition Logic scenes, it allows a Toggle between the two clip 
channels. A single object playbacks any clip. In a Transition Logic scene, the Toggle plug-in makes 
sure that the channels toggle correctly, which allows for transitions between two running clips. 
The plug-in also toggles the clip texture if texture mode is selected.

The plug-in is commonly used in a video workflow with Viz One. It automatically adds a Clip 
Channel plug-in. The clip channel has to be activated using the Video Input in Viz 
Configuration (see the Viz Engine Administrator Guide).

Video Clip Properties
Channel: Sets the clip channel to be used. Available options are; Clip channel 1 and 2.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Global

http://documentation.vizrt.com/viz-engine
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Target: Sets the clip mode. Setting target to DVE adds default Key Frames to the stage. 
Setting target to Texture adds the Live Video Media Asset texture plug-in and default Key 
Frames to the stage. Available options are; Inactive, DVE or Texture.
Volume: Sets the clip volume in percentage.

To Add a Video Clip
Check the Viz Configuration to see if clip channels are activated.
Add the Video Clip plug-in to a geometry (e.g. a rectangle).
Select Clip Channel 1 and Type Texture.
Switch to the Stage and select the Clip under VideoClip.

On the right side the clip to be played can be selected.
Additional Key Frames can be added to play different clips.

See Also

Toggle
Control Video

Window Mask

The Window Mask plug-in limits the area into which a Sub-Container of the Window Mask plug-in is 
rendered to a user-defined rectangular section of the output. It is possible to add a tracking 
object. If a tracking object is used, it’s bounding box is projected onto the screen and the 
resulting rectangle is used as a mask.

Window Mask Properties
Position X, Position Y: Specifies the upper left corner of the rectangle. The values are scaled 

in such a way that (0,0)  refers to the upper left and (100,100)  to the bottom right 

corner of the screen.
Width, Height: Specifies the dimensions of the rectangle in percentages of the screen 
dimensions.
Tracking Object: Provides an alternative to setting the position and dimensions manually. 
When you drag a container from the scene tree onto this drop zone, the rectangle is 
automatically adjusted to match the position and size of that container. Inactive toggles 
tracking on and off. To remove the container click on Reset.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Global

Note: The underlying mask operation is integral. Use other masks like Mask Source / Mask 
Target if you need subpixel accuracy.
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To Use the Window Mask

Add a Rectangle geometry to the scene tree, and add material to it.

Open the Rectangle editor and set Width to 200.0 .

Open the transformation editor and set Position Y to -36 .

Add a new group, and add the Window Mask plug-in to it.
Add a Sphere geometry as a Sub-Container of the group container, and add material to it.
Open the Window Mask editor and drag and drop the Rectangle container onto the Tracking 
Object drop zone. This should give you a sphere that is partly masked due to the rectangle 
object.

Z-Sort

The Z-Sort plug-in disables back to front automatic sorting for the immediate children of that 
group when applied to a group. This enables designers to set the rendering order manually.

Z-Sort Description
To sort objects of a Scene on the Z-axis is essential for any 3D program to render correctly. The 
renderer starts by rendering the object furthest behind, and then mixing in objects closer and 
closer to the camera. Sometimes the machine gets “confused” with what should be rendered first 
and last because it calculates this from what is the center of the object’s Z position.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Global
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A typical example of a Z sort problem is when two colored objects have rotated their Y axis to for 

example -12.0 . In this case the default behavior for a render engine is to render the first object 

(green) with a Z position 0.0  first, and then the second object (red) with Z position 1.0  last.

When objects are rotated, the output is wrong because the red object should be rendered before 
the green due to the rotation of the objects. This can be corrected by adding the Z-Sort plug-in, 
which lets users manually sort objects using the logic of the tree structure. Hence, what is placed 
at the top of a group in the scene tree gets rendered first, and what is placed below is rendered 
after.

Sorting is solved by rendering the second (red) object first, and then the first (green) last. Be aware 

that although the red object has a Z position of 1.0  and the green 0.0 , the red object must be 

rendered before the green because of the overlapping rotation (Y -12.0 ). Normally objects that 

are furthest behind should be placed at the top in the scene tree.

The Z-Sort plug-in disables the automatic Z-sort for a Container. How the items in the Container 
get sorted in the Z-buffer is then dictated by the order of the objects in the scene tree.



Plug-ins User Guide -  5.0

Copyright © 2022  Vizrt Page  274

•
•
•

1.
2.
3.

•
•

•

•

Transparency, Rendering Order Logic and Priority

Questions

Why does a scene look different when a parent container is set to 99% transparency?
Why are do some Containers disappear?
When should the Z-Sort Off Plug-In be used? 

Explanation

The explanation to why changing an alpha plug-in to 99% on a parent container, which affects the 
way objects are rendered, is the Rendering Order. When rendering polygonal Scenes with 
transparencies (like those created in Viz Artist) the rendering order is important with the current 
architecture of graphics cards.

The common practice for 3D applications is to render semi-transparent objects from back to front 
(or rather from far to near).

To avoid this undesirable result, Viz Artist splits the rendering of the containers in the Scene into 
three parts:

The mask objects are rendered first to ‘mark’ the areas of masking on the screen.
The opaque objects are rendered front to back.
The transparent objects are rendered back to front.

Viz Artist/Engine decides whether an object is transparent based on some criteria, for example:

If the texture of the object has an alpha channel.
If the material of the object has an alpha value less than 100%.

If the object has an inherited ALPHA function with an alpha value less than 100 .

and more...

With all this said, rendering back to front is not perfect because the rendering order is not done 
per pixel; rendering is not even done per polygon. Viz Artist/Engine renders a scene per complete 
container; container order is based on the center of the container.

Example: Think of a scene that shows a city skyline through of a semi-transparent window. 
Lets assume that the window is rendered before the skyline. Some background color is 
applied to the screen, then the window is rendered. The graphics card blends the color of 
the window with the background color (say, blue). In addition to color, the graphics card 
also marks the distance of the window’s pixels from the camera for each pixel, so that 
farther away pixels do not obstruct the window. This technique for achieving obstruction 
between objects on per-pixel basis is called Depth-Buffer or Z-Buffer. Now render the 
skyline. The color of the skyline should have been blended with the color of the window, 
but it does not. The graphics card rejects every skyline pixel because its distance from the 
camera is farther away than the distance of the window pixels. This is a case where the 
positive role of the Depth-Buffer produces undesirable results.
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Solution

This behavior can be fine-tuned using the Z-Sort Off Plug-In. When this plug-in is applied to a 
group, it disables back to front automatic sorting for the immediate children of that group. This 
enables designers to set the rendering order manually.

Examples

The following shows an incorrect rendering of a transparent object on a cube. The Z-ordering is 
wrong, therefore the transparent parts on the cube appears incorrectly (black). This might only 
happen when flying around it.
When adding the Z-Sort plug-in to the parent container and reordering the tree, the cube is to be 
rendered first and the dragon afterwards, the transparency issues are fixed and the dragon 
appears correctly on the cube, even when rotating.

Incorrect Fixed

Example: Take a tilted flat map with icons. The map container is large, and its center is in 
front of some of the icons, but in the back of other icons. Assuming the icons have 
transparency, the map is actually rendered in between the icons. This behavior is visually 
incorrect as the map should be rendered first, then all the icons.
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Notes/Exceptions
If an alpha plug-in at 99% is applied on the top container it can force the whole collection of 
containers to be sorted back to front, and can solve the problem, but this is not a best 
practice. There is much more overhead rendering a scene like this. A more permanent 
solution would be to optimize the scene with the Z-Sort Off plug-in.
Opaque objects are better rendered from front to back because there is some performance 
gain for each obstructed pixel (it is not being processed after being rejected). With that 
being said opaque objects can be rendered at any order.

4.4.8 MultiTouch Plug-ins
The MultiTouch plug-ins are used to take incoming touch events, process them and then trigger 
events, perform transformations on objects, telestrate, or trigger script events. The idea behind 
these plug-ins is to bundle often used or needed functionality and eliminate the need to write your 
own scripts or plug-ins for that. They are great tools to bring MultiTouch interactively fast and 
easily into a Scene. The Container plug-ins require the MtSensor to be available to work. If a 
MultiTouch plug-in is added to a Scene it automatically adds the MtSensor to the Scene if it is not 
there.

The MultiTouch plug-ins can communicate with Viz scripts, either through event handlers, Shared 
Memory variables, or Data Pool variables. The plug-ins can also be controlled by triggering the 
‘push buttons’ and/or setting the ‘parameter’ variables exposed by the plug-in. Specifics on what 
features are available for each plug-in are documented in the plug-in specific sections below.

In the Viz Artist editor interface, the  button toggles between enabling and disabling emulated 
sensor input using the mouse as well as direct input from a sensor. The plug-ins work with 
multiple layers. Each Scene layer with MultiTouch objects installed in it should also have an 
instance of the MtSensor automatically installed.

The following Container plug-ins are located in the MultiTouchComp folder:

Mt2D Control
Mt3D Control
MtButton
MtNavigator
MtTelestrator
Plug-in Event and Notification System

Make sure you also read up on the Plug-in Event and Notification System.

Information: Do not place the Z-Sort plug-in on top of your scene. Adding Z-Sort disables 
sorting and optimizing the geometry for rendering and can have a negative impact to your 
render performance. Please use Z-Sort only where absolutely needed as it disables 
performance optimizations. A common solution for Z-Sort related issues could also be to 
change the center point of your geometry.
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Mt2D Control

The Mt2D Control plug-in moves, scales, and rotates an object in 2D. The Mt2D Control plug 
allows multi-finger 2D manipulation of an object in the scene. When the object is touched, it 
translates, rotates, and scales to keep the object underneath the user’s fingers as closely as 
possible. It moves within the screen relative 2D plane through the object’s center position defined 
by the objects orientation axes.

The container being manipulated must not have any local non-uniform scale. The plug-in forces y 
and z scale so they are equal to x scale when the object is touched. If non uniform scaling is 
required on object in the container, put the object’s container in a group and scale the parent. Or 
put the plug-in on an identity group and insert the object to be moved as a child container. All 
transformations set on the manipulated container’s parents are preserved.

This page contains the following topics and procedures:

Mt2D Control Configuration
Events and Notifications
To Create a Simple Scene with the Mt2D Control Plug-in

Mt2D Control Configuration
Momentum: Enables movement or rotation with momentum after the object is released.

Friction: Sets the amount of friction used when momentum is enabled.

Lock Translation: Allows only rotation and scaling of the object.
Lock Translation (Screen X): Prevents movement left-to-right on the screen.
Lock Translation (Screen Y): Prevents movement up-and-down on the screen.
Lock Translation (Object X): Prevents movement along the object’s local X axis.
Lock Translation (Object Y): Prevents movement along the object’s local Y axis.
Lock Rotation: Prevents rotation of the object.
Lock Scale: Prevents resizing of the object.
Limit Position: Limits the maximum and minimum position of the X and Y axis.
Limit Rotation: Limits the maximum and minimum rotation of the X and Y axis.
Limit Scale: Limits the maximum and minimum scale.
Id: Gives additional context in the handler script, specify a string that identifies any 
notifications dispatched by this plug-in. This is often included as an argument for the event 
so a common script may handle events from a number of plug-ins.

Note: This plug-in is located in: Plugins -> Container plug-ins -> MultiTouchComp

Note: Using this feature conflicts with any externally scripted or other 
animations applied to the container.
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Set Shared Memory: Enables shared memory to be updated for the plug-in notifications when 

set to On .

Shared Memory Prefix: This sets a ‘prefix name’ to be prepended to the shared 
memory variables maintained by the plug-ins notifications. For plug-ins that maintain 
multiple fields each field name has the prefix prepended to it followed by a dot ‘.’ so 
as to mimic member access to an object, i.e: if the prefix is ‘Obj’ the fields ‘field1’ and 
‘field2’ would be identified with the strings ‘Obj.field1’ and ‘Obj.field2’. The shared 
memory field ‘Obj’ is also maintained and is simply an integer that is modified every 
time any of its ‘subfields’ is updated.
Shared Memory Type: Click either Global, Scene, or Distributed. This selects the 
shared memory area to update.

Set Data Pool: Shows ‘you wish’ plug-in notifications to set a Data Pool variable.
Data Pool Variable: Shows the name of the Data Pool variable to have set.

Active during screen wide telestration?: If the button to is to stay active when the screen-
wide telestrator is on, set to On. The default is off, which means the button cannot be 
triggered when telestration is on.
Hit Coordinate Type: Selects the Coordinate system to use.Click either Local, World or 
Screen. 
Produce delta values, don’t move object: Does not alter transform of object with attached 
controller, but instead provide ‘deltas’ in the event notifications.

Events and Notifications
The events dispatched by Mt2D Control are:

OnGrab (when object is ‘grabbed’):

sub ONGrab (HitContainer as String, Id as String, HitPoint as Vertex, plug-inContainer as String, 
FirstChildContainer as String)

end sub

HitContainer as String
Id as String
HitPoint as Vertex
plug-inContainer as String
FirstChildContainer as String 
OnGrabUpdate (when object is moved):

sub OnGrabUpdate (HitContainer as String, Id as String, Position as Vertex, Rotation as Vertex, 
Scale as Vertex, Pressure as Double)

end sub

HitContainer as String
Id as String
Position as Vertex
Rotation as Vertex

Note: Rotation scale or position constraints do not operate in this mode.
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Scale as Vertex
Pressure as Double

OnAnimation (dispatched when post grab animation (momentum) is started, followed by 
OnGrabUpdates):

sub OnAnimation (HitContainer as String, Id as String)

end sub

HitContainer as String
Id as String 
OnGrabRelease (when both touch grab and momentum animation are complete):

sub OnAnimation (HitContainer as String, Id as String)

end sub

HitContainer as String
Id as String

The Shared Memory Field names updated are:

HitContainer (the name of the container that was ‘hit’)
Id (the user ID string entered in the notification interface)
HitPoint
plug-inContainer
FirstChildContainer
Position
Rotation
Scale
Pressure
State

The Data Pool structure updated is:

Mt2D Control:
string HitContainer
string Id
string HitPoint
string plug-inContainer
string FirstChildContainer
string Position
string Rotation
string Scale
string Pressure
string State

To Create a Simple Scene with the Mt2D Control Plug-in

Note: If a touch screen is not available, set Multi Touch input to Mouse in the 
Communication section of Viz Configuration (see the Viz Engine Administrator Guide).



http://documentation.vizrt.com/viz-engine
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Create a new Scene.
Add a new group Container.
Add a Cube Geometry to the Container.
Add the Mt2DControl plug-in to the Container.
Open the Scene in On Air. Move, rotate or scale the Rectangle with the touch input device.
Use the Mt2DControl plug-in editor to modify the plug-in behavior as required.

Mt3D Control

The Mt3D Control plug-in moves, scales, and rotates an object in 3D.

The Mt3D Control plug-in provides an arc ball-like controller for the object it is attached to. When 
used with one finger, the object can be rotated. When multiple fingers are used, the object can be 
moved, rotated and scaled in a 2D plane (the same as the Mt2D Control).

This page contains the following topics and procedures:

Mt3D Configuration
2D Configuration
Output Configuration
Events and Notifications
To Create a Simple Scene with the Mt3D Control Plug-in

Mt3D Configuration
Config: Selects 3D Config
Axis Lock: Constrains the rotation to a specific axis, or allow free rotation. Options are:

Off
X Axis
Y Axis
Z Axis

Axis Lock Local: Uses the local axis instead of the world axis if axis lock is on.
Active during screen wide telestration?: If the button to is to stay active when the screen-
wide telestrator is on, set to On. The default is off, which means the button cannot be 
triggered when telestration is on.
Hit Coordinate Type: Selects the Coordinate system to use. Click either Local, World or 
Screen. 

2D Configuration
Config: Selects configuration.
Momentum: Enables movement or rotation with momentum after the object is released.

Note: This plug-in is located in: Plugins -> Container plug-ins -> MultiTouchComp
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Friction: Sets the amount of friction used when momentum is enabled

Lock Translation: Allows only rotation and scaling of the object
Lock Translation (Screen X): Prevents movement left-to-right on the screen
Lock Translation (Screen Y): Prevents movement up-and-down on the screen
Lock Translation (Object X): Prevents movement along the object’s local X axis
Lock Translation (Object Y): Prevents movement along the object’s local Y axis
Lock Rotation: Prevents rotation of the object
Lock Scale: Prevents resizing of the object.
Active during screen wide telestration?: Determines whether the button to stays active when 

the screen-wide telestrator is on, when set to On . The default is Off , which means the 

button cannot be triggered when telestration is on.
Hit Coordinate Type: Selects the Coordinate system to use.Click either Local, World or 
Screen. 

Output Configuration
Config: Selects configuration.
Id: Gives additional context in the handler script, specify a string that identifies any 
notifications dispatched by this plug-in. This is often included as an argument for the event 
so a common script may handle events from a number of plug-ins.
Set Shared Memory: Enables shared memory to be updated for the plug-in notifications when 

set to On .

Shared Memory Prefix: This sets a ‘prefix name’ to be prepended to the shared 
memory variables maintained by the plug-ins notifications. For plug-ins that maintain 
multiple fields each field name has the prefix prepended to it followed by a dot ‘.’ so 
as to mimic member access to an object, i.e: if the prefix is ‘Obj’ the fields ‘field1’ and 
‘field2’ would be identified with the strings ‘Obj.field1’ and ‘Obj.field2’. The shared 
memory field ‘Obj’ is also maintained and is simply an integer that is modified every 
time any of its ‘subfields’ is updated.
Shared Memory Type: Click either Global, Scene, or Distributed. This selects the 
shared memory area to update.

Set Data Pool: Shows ‘you wish’ plug-in notifications to set a Data Pool variable
Data Pool Variable: Shows the name of the Data Pool variable to have set.

Active during screen wide telestration?: Determines whether the button stays active when 

the screen-wide telestrator is on, when set to On . The default is Off , which means the 

button cannot be triggered when telestration is on.
Hit Coordinate Type: Selects the Coordinate system to use.Click either Local, World or 
Screen. 

Events and Notifications
The events dispatched by Mt3dControl are:

Note: Using this feature conflicts with any externally scripted or other 
animations applied to the container.
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OnGrab (when object is ‘grabbed’):

sub OnGrab (HitContainer as String, Id as String, HitPoint as Vertex, plug-inContainer as String, 
FirstChildContainer as String)

end sub

HitContainer as String
Id as String
HitPoint as Vertex
plug-inContainer as String
FirstChildContainer as String 
OnGrabUpdate (when object is moved):

sub OnGrabUpdate (HitContainer as String, Id as String, Position as Vertex, Rotation as Vertex, 
Scale as Vertex, Pressure as Double)

end sub

HitContainer as String
Id as String
Position as Vertex
Rotation as Vertex
Scale as Vertex
Pressure as Double 
OnGrabRelease (when object is “released”):

sub OnGrabRelease (HitContainer as String, Id as String)

end sub

HitContainer as String
Id as String

The Shared Memory Field names updated are:

HitContainer (the name of the container that was “hit”)
Id (the user ID string entered in the notification interface)
HitPoint
plug-inContainer
FirstChildContainer
Position
Rotation
Scale
Pressure
State

The Data Pool structure updated is:

Mt3dControl:
string HitContainer
string Id
string HitPoint
string plug-inContainer
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string FirstChildContainer
string Position
string Rotation
string Scale
string Pressure
string State

To Create a Simple Scene with the Mt3D Control Plug-in

Create a new Scene.
Add a new group Container.
Add a Cube Geometry to the Container.
Add the Mt3D Control plug-in to the Container.
Open the Scene in On Air. Use the touch input device to transform the object.
Use the Mt3D Control plug-in editor to modify the plug-in behavior, as required.

MtButton

The MtButton plug-in triggers an action when tapped or pressed. The MtButton plug-in makes a 
container or its immediate children act as buttons. Several methods may be used to trigger the 
buttons. They are selected in the Viz Artist UI with the ‘Trigger Type’ radio button. The MtButton 
can be enabled or disabled. When the button is disabled, any tap or stroke input it receives does 
not trigger the associated events. The button can be enabled or disabled through the plug-in 
parameters, or through a command. A button which is disabled after a stroke has pressed on a 
button does NOT prevent generation of events for a stroke that is currently active.

This page contains the following topics and procedures:

MtButton Configuration
Events and Notifications
To Create a Simple Scene with the MtButton Plug-in

MtButton Configuration
Id: Gives additional context in the handler script, specify a string that identifies any 
notifications dispatched by this plug-in. This is often included as an argument for the event 
so a common script may handle events from a number of plug-ins.

Note: If a touch screen is not available, set Multi Touch input to Mouse in the 
Communication section of Viz Configuration (see the Viz Engine Administrator Guide ).



Note: This plug-in is located in: Plugins -> Container plug-ins -> MultiTouchComp

http://documentation.vizrt.com/viz-engine
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Set Shared Memory: Enables shared memory to be updated for the plug-in notifications when 

set to On .

Shared Memory Prefix: Sets a ‘prefix name’ to be prepended to the shared memory 
variables maintained by the plug-ins notifications. For plug-ins that maintain multiple 
fields each field name has the prefix prepended to it followed by a dot (.) so as to 
mimic member access to an object (i.e. if the prefix is ‘Obj’ the fields field1 and field2
would be identified with the strings Obj.field1 and Obj.field2. The shared memory 
field ‘Obj’ is also maintained and is simply an integer that is modified every time any 
of its ‘subfields’ is updated).
Shared Memory Type: Selects the shared memory area to update. Click either Global, 
Scene, or Distributed. 

Set Data Pool: Shows ‘you wish’ plug-in notifications to set a Data Pool variable.
Data Pool Variable: Shows the name of the Data Pool variable to have set.

Active during screen wide telestration?: Determines whether the button remains active when 

the screen-wide telestrator is on, when set to On . The default is Off , which means the 

button cannot be triggered when telestration is on.
Trigger type:

On Touch: Sets the buttons to generate an onTrigger event immediately when they are 
touched. No other events are generated in this mode.
On Release: Sets the buttons to generate an onTrigger event when the last stroke 
present over a button is released. onStrokeEnter() and onStrokeLeave() events are 
generated as strokes enter and leave the button (see protocol below).
On Tap: Sets the buttons to generate an onTrigger event when strokes recognized as 
‘taps’ occur after a button is quickly pressed and released without movement or a 
finger is held down on a key on an object. onStrokeEnter() and onStrokeLeave() events 
are also generated in this mode.
Taps Only: Sets the buttons to emit an onTap event when stokes recognized as a 
‘taps’ occur. No other events are generated in this mode.

Hit Coordinate Type: Selects the Coordinate system to use. Click either Local, World or 
Screen. 

Events and Notifications
The MtButton generates an OnTap event when it is tapped in ‘Taps Only’ mode:

sub OnTap(HitContainer as String, Id as StringHit, Point as VertexTaps as Integer, plug-inContainer 
as String, FirstChildContainer as String)

end sub
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HitContainer as String: The name of the container that was ‘hit’.
Id as String: The user ID string entered in the notification interface.
HitPoint as Vertex: The Point where the object was tapped in local coordinates.
Taps as Integer: The number of taps (i.e. 2 == double tap).
plug-inContainer as String: Name of the container the plug-in is attached to.
FirstChildContainer as String: Direct (first level) child container of the plug-in, that is a 
(indirect or direct) parent of the tapped container. If the plug-in container itself is tapped, 
the plug-in container is returned.

The MtButton generates an OnTrigger event when it is triggered in any other mode than ‘Taps 
Only’:

sub OnTrigger(HitContainer as String, Id as String, HitPoint as Vertex, Taps as Integer, plug-
inContainer as String, FirstChildContainer as String, StrokeId as Integer)

end sub

HitContainer as String: The name of the leaf container that was ‘hit’.
Id as String: The user ID string entered in the notification interface.
HitPoint as Vertex: The Point where the object was tapped in local coordinates.
Taps as Integer: The number of taps if tapped (i.e: 2 == double tap).
plug-inContainer as String: Name of the container the plug-in is attached to.
FirstChildContainer as String: First child container below the plug-in the trigger occurred on 
or below.
StrokeId as Integer: Unique ID of stroke causing this event.

The MtButton generates an OnStrokeEnter event when it is triggered in any other mode than ‘Taps 
Only’:

sub OnStrokeEnter(Id as String, plug-inContainer as String, FirstChildContainer as String, StrokeId 
as Integer, StrokeCount as Integer, Active as Integer)

end sub

Id as String: The user ID string entered in the notification interface.
plug-inContainer as String: Name of the container the plug-in is attached to.
FirstChildContainer as String: First child container below the plug-in the stroke entered.
StrokeId as Integer: Unique ID of stroke causing this event. Only valid from initial enter to 
final leave.

StrokeCount as Integer: Count of stroke on the button after entry. Is 1  when the first stroke 

enters.

Active as Integer: This parameter is deprecated and always returns 0 .

The MtButton generates an OnStrokeLeave event when it is triggered in any other mode than ‘Taps 
Only’:

sub OnLeave(Id as String, plug-inContainer as String, FirstChildContainer as String, StrokeId as 
Integer, StrokeCount as Integer, Active as Integer)

end sub

Id as String: The user ID string entered in the notification interface.
plug-inContainer as String: Name of the container the plug-in is attached to.
FirstChildContainer as String: First child container below the plug-in the stroke exited.
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StrokeId as Integer: Unique ID of stroke causing this event. Only valid from initial enter to 
final leave.

StrokeCount as Integer: Count of stroke on the button after exit. Is 0  when the last stroke 

exits.

Active as Integer: This parameter is deprecated and always returns 0 .

The shared memory field names are:

HitContainer: The name of the container that was ‘hit’.
Id: The user ID string entered in the notification interface.
HitPoint: The Point where the object was tapped in the selected coordinate type.
Taps: The number of taps (i.e. 2 = double tap).
plug-inContainer: Name of the container the plug-in is attached to.
FirstChildContainer: First child container below the plug-in that tap occurred on or below.
StrokeId: Unique ID of last trigger or tap.

The Data Pool structure updated is:

MtButton:
string Id
string HitPoint
string HitContainer
string Taps
string plug-inContainer
string FirstChildContainer
string StrokeId

To Create a Simple Scene with the MtButton Plug-in

Create a new Scene.
Add a new group Container.
Name the group Container ButtonScript.
Add the Script plug-in to the ButtonScript Container (Container plug-ins > Global).
Open the Script Editor and type this script:

sub OnTap(HitContainer as String, Id as String,    HitPoint as Vertex,    Taps 
as Integer,    plug-inContainer as String,    FirstChildContainer as String)     
    dim bt as Container     
    dim text as String     
    bt = FindSubContainer("ButtonText")     
text = "OnTap(\n   HitContainer = " & HitContainer     
text &= "\n   Id = " & Id      
text &= "\n   HitPoint = " & HitPoint     
text &= "\n   Taps = " & Taps      
text &= "\n   plug-inContainer = " & plug-inContainer     

Note: If a touch screen is not available, set Multi Touch input to Mouse in the 
Communication section of Viz Configuration (see the Viz Engine Administrator Guide ).



http://documentation.vizrt.com/viz-engine
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text &= "\n   FirstChildContainer = " & FirstChildContainer & "\n)"     
    bt.Geometry.Text = text 
end sub

Click Compile and Run.
Add three Sub-containers. Name them, in order:

Button1
Button2
ButtonText

Add a Circle Geometry to the Button1 and Button2 Containers.
Use the Circle Geometry Transformation editors to move the two circles so that both can be 
seen.
Right-click the Button1 and Button2 Containers, in turn, and select Add Material… from the 
context-menu. Open the Material Editor and define a color for both Containers.
Add the MtButton plug-in to the Button1 and Button2 Containers.

In the MtButton plug-in editor:

Type myButton1  in the Button1 Id field

Type myButton2  in the Button2 Id field

In Trigger Type field click On Tap for both containers
Add a Font to the ButtonText Container.
Open the Scene in On Air.
Click on each button, in turn, and see the text change with each selection.
Use the MtButton plug-in editor to modify the button’s actions, as required.
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MtNavigator

The MtNavigator plug-in controls the Viz World Navigator plug-in.

The MtNavigator plug-in allows MultiTouch free navigation over a map generated by the Curious 
World Maps plug-ins. Currently it only supports the ‘Flat’ map model, and not the globe or other 
3D models. It sends commands to the Navigator plug-in to change the position and distance of the 
map based on MultiTouch input.

MtNavigator Configuration
Georeference Container: Specifies the container which owns the Navigator plug-in.
Momentum: Enables movement or rotation with momentum after the object is released.

Friction: Sets the amount of friction used when momentum is enabled.
Limit Camera Distance: Limits the maximum and minimum camera distance.
Is free navigation allowed: Activates or deactivates navigation.
Id: Gives additional context in the handler script, specify a string that identifies any 
notifications dispatched by this plug-in. This is often included as an argument for the event 
so a common script may handle events from a number of plug-ins.
Set Shared Memory: Enables shared memory to be updated for the plug-in notifications when 

set to On .

Shared Memory Prefix: This sets a ‘prefix name’ to be prepended to the shared 
memory variables maintained by the plug-ins notifications. For plug-ins that maintain 
multiple fields each field name has the prefix prepended to it followed by a dot (.) so 
as to mimic member access to an object (i.e. if the prefix is Obj the fields field1 and 
field2 would be identified with the strings Obj.field1 and Obj.field2. The shared 
memory field Obj is also maintained and is simply an integer that is modified every 
time any of its subfields is updated).
Shared Memory Type: Selects the shared memory area to update. Click either Global, 
Scene, or Distributed. 

Set Data Pool: Shows ‘you wish’ plug-in notifications to set a Data Pool variable.
Data Pool Variable: Shows the name of the Data Pool variable to have set.

Events and Notifications
The events dispatched by MtNavigator are:

OnNavGrab (when navigable object is ‘grabbed’):

sub OnNavGrab (HitContainer as String, Id as String, Offset as Vertex, Distance as Double, plug-
inContainer as String)

Note: This plug-in is located in: Plugins -> Container plug-ins -> MultiTouchComp
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end sub

HitContainer as String
Id as String
Offset as Vertex
Distance as Double
plug-inContainer as String 
OnNavGrabUpdate (when navigable object is moved):

sub OnNavGrabUpdate (HitContainer as String, Id as String, Offset as Vertex, Distance as Double, 
plug-inContainer as String)

end sub

HitContainer as String
Id as String
Offset as Vertex
Distance as Double
plug-inContainer as String
OnNavGrabRelease (when navigable object is released):

HitContainer as String
Id as String

The Shared Memory Field names updated are:

HitContainer: The name of the container that was ‘hit’
Id: The user ID string entered in the notification interface
Offset: The current lon/lat position in the Navigator
Distance: The current distance in the Navigator
plug-inContainer: The name of the container this plug-in is attached to

Active: Set to  1  if ‘grabbed’, 0  if ‘released’

The Data Pool structure updated is:

MtNavigator:
string Id
string HitContainer
string Offset
string Scale
string plug-inContainer
string Active

Basic Scene Design
Follow these steps to create a minimal scene which uses the MtNavigator plug-in:

Add to a new container named Nav to a GeoImage plug-in and set:

Set Use Base Map to  Off .

Set Map Size to  700.0 .

Add the CWMClient plug-in to the container Nav.
Add the Navigator plug-in to the container Nav.
Add MTNavigator to the container Nav and set Nav as Georeference Container.
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Add the NavFinder plug-in to the container Nav and select Map-Start as Hop Point.
Add a new container Atlas as child of Nav and add the Atlas plug-in to it.

MtTelestrator

The MtTelestrator plug-in is used to do telestration on a Container level (used with 
the GraffitiTex plug-in (added automatically to the same Container)).

For scene-wide telestration the MtSensor has a telestration feature.

This page contains the following topics and procedures:

MtTelestrator Configuration
Events and Notifications
To Create a Simple Scene with Telestration

MtTelestrator Configuration
Active: Enables or disables telestration input from the user.
Minimum Telestration Width: Determines minimum brush width to assign based on pressure 
applied to sensor.
Maximum Telestration Width: Determines maximum brush width to assign based on 
pressure applied to sensor.
Color: Assigns the color for subsequent telestration drawing.
Id: Gives additional context in the handler script, specify a string that identifies any 
notifications dispatched by this plug-in. This is often included as an argument for the event 
so a common script may handle events from a number of plug-ins.
Set Shared Memory: Enables shared memory to be updated for the plug-in notifications when 

set to On .

Shared Memory Prefix: This sets a ‘prefix name’ to be prepended to the shared 
memory variables maintained by the plug-ins notifications. For plug-ins that maintain 
multiple fields each field name has the prefix prepended to it followed by a dot ‘.’ so 
as to mimic member access to an object, i.e: if the prefix is ‘Obj’ the fields ‘field1’ and 
‘field2’ would be identified with the strings ‘Obj.field1’ and ‘Obj.field2’. The shared 
memory field ‘Obj’ is also maintained and is simply an integer that is modified every 
time any of its ‘subfields’ is updated.
Shared Memory Type: Selects the shared memory area to update. Click either Global, 
Scene, or Distributed. 

Set Data Pool: Shows ‘you wish’ plug-in notifications to set a Data Pool variable.
Data Pool Variable: Shows the name of the Data Pool variable to have set.

Init: Clears current telestration and make Telestration active.

Note: This plug-in is located in: Plugins -> Container plug-ins -> MultiTouchComp
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Clear: Clears the contents of the attached telestration.

Events and Notifications
The events dispatched by MtTelestrator are:

OnTelestrationStateChange  (sent when telestration is activated or deactivated):

plug-inContainer  as String

Id  as String

TelestrationOn  as Boolean

OnTelestrationColorChange  (sent when telestration is activated or deactivated):

plug-inContainer  as String

Id  as String

PenColor  as Color

OnTelestrationClear  (sent when telestration is cleared):

plug-inContainer  as String

Id  as String

TelestrationOn  as Boolean

The shared memory field names are:

plug-inContainer: The name of the plug-ins container or ‘’ if attached to a scene
Id: The user ID string entered in the notification interface
PenColor: The current pen color

Active: Is set to 1  if telestration is active, 0  if not.

The Data Pool structure updated is:

MtTelestrator:
string plug-inContainer
string Id
string PenColor
string Active

To Create a Simple Scene with Telestration

Create a new Scene.
Add a new group Container.
Add a Rectangle Geometry to the Container.
Add the MtTelestrator plug-in to the container. This automatically adds the GraffitiTex plug-
in to the container.

Set the Active parameter for the MtTelestrator and GraffitiTex to  On  in the Properties Panel.

Open the Scene in On Air. Use the touch input device to create freehand drawing.

Note: If a touch screen is not available, set Multi Touch input to Mouse in the 
Communication section of Viz Configuration (see the Viz Engine Administrator Guide ).



http://documentation.vizrt.com/viz-engine
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Use the MtTelestrator and GraffitiTex plug-in editors to modify the telestration affect as 
required.

See Also

GraffitiTex plug-in

Plug-in Event and Notification System
All the MultiTouch (Mt) plug-ins share a common event notification module and associated 
configuration interface. For all plug-ins that generate events, events are dispatched up the 
Container hierarchy from the plug-in Container to the first script found with a handler present for 
the event being generated.

For plug-ins that optional update values in Shared Memory, select which one of the three maps to 
update:

System
Scene
Distributed

Each shared memory area updated by a plug-in is composed of one root variable specified in the 
‘Shared Memory Prefix’ field in the plug-ins user interface. This ‘root’ variable is updated if any of 
its additional sub-fields are updated. The root variable contains an integer or update ID. Sub-fields 
are identified by adding ‘dot delimited’ suffix on the root name. For example, if ‘Shared Memory 
Prefix’ is set to ‘Name’, the sub-field ‘field’ would be identified as ‘Name.field’ in a Viz script.

For all plug-ins that can set a Data Pool variable, each has a ‘structure’ defined in a .dp file. There 
is one such file for each plug-in. Both the file and the name of the structure defined by it are the 
same as the name of the plug-in. For example, in the case of an MtButton, the file 
is MtButton.dp and the name of the structure for sub-item access is MtButton.

4.4.9 Presenter
The following Container plug-ins are located in the Presenter folder:

Bar
Bar Value
Bar Values
Pie Slice
Pie Values

Bar

The Bar plug-in tells the Bar Values plug-in that the container is part of the bar chart and it also 
tells which items of the geometry on the container to control. Each container that is to be a bar, 
must hold a geometry and a Bar plug-in. Bar can be used as a standalone plug-in.
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Bar Properties
Standalone: If the Bar plug-in is going to be used without a Pie Values plug-in to set the 
values, enable this button. It enables you to set the value directly on the plug-in and you can 
define normalization factors between the input values and the value that is being set on the 
geometry.
Bar Min / Max: If in standalone, these values set the minimum and maximum values for the 
bar. These values are connected to the Obj Min/Max values and by adjusting these together 
you can get the required effect between input values and visual effect.
Value: Sets the scaling value of the object.
Obj Min / Max: Maps the input values to the native values on the object being controlled by 
the plug-in. Adjust these together with Bar Max/Min on the Bar Values plug-in or on the Bar 
plug-in itself if in standalone mode, to get the required effect between input values and 
visual effect.
Param Type: Sets the type of value to control on the object.

Param: Controls a named parameter on the object. Use the console to find the correct 
name for the parameter: Enable Show commands, Open the object’s editor, change 
the parameter and see in the console what the parameter name is.
Position: Position values can be set to control the X, Y or Z axis.
Rotation: Rotation values can be set to control the X, Y or Z axis.
Scale: Scale values can be set to control All, X, Y or Z axis.
Text: Text values can be shown as Integer, Float or Formatted text.

Initialize: Enables the plug-in to initialize and gain control of the parameters.

See Also

Bar Value
Bar Values
Visual Data Tools Geometry

Bar Value

The Bar Value plug-in controls the value of all Bar plug-ins and Counters of its child nodes. In 
addition a set of commands can be specified that are executed when the value passes certain 
thresholds.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Presenter

Note: This plug-in is located in: Plugins -> Container plug-ins -> Presenter
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Bar Value Properties
Bar Min: Minimum Value of the bar.
Bar Max: Maximum Value of the bar.
Value: The actual value of the bar.
control counters: States if counters should be affected. If this is checked, Value is shown in 
all Sub-Containers with Counter plug-ins.
Type: Determines whether the command should fire if the threshold is passed from below, 
or from above. Off does not execute the command at all. Available options are Off, Up and 
Down.
Threshold: Compares the value against the threshold.
Command: Executes a Viz Artist/Engine command when the threshold is passed.

To Create a Bar that Shows Its Value
Create a Container and add the Bar Value plug-in to it.
Open the Bar Value editor, and check control counters.

Set Threshold to 20 , Type to Up and set a command (e.g.  MAIN*ONAIR GET_INFO ).

Add two Sub-Containers.
Add a Font and a Counter plug-in to the first Sub-Container.
Add a Cube and a Bar plug-in to the second Sub-Container.

Set the Cube’s Y-Axis Center to (B)ottom .

Open the Bar plug-in editor and set Param Type to Scale and Scale to Y .

Modify Bar Value’s Value field. If the value exceeds 20  the information is written to the 

console.

See Also

Bar
Bar Values
Visual Data Tools Geometry

Bar Values

The Bar Values plug-in communicates with all Sub-Containers that hold a Bar plug-in and lets you 
set values for each of them.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Presenter
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Bar Values Properties
Num Bars: Sets the number of bars to be controlled by the Bar Values plug-in. Maximum 
number of bars is 25.
Auto Max: Allows the user to switch between Manual and Auto mode. Auto mode disables 
the Bar Max value.
Bar Max: Sets the maximum values of the bar.
Bar Min: Sets the minimum value of the bar.
Scale: Sets the scale of the object.
Bar Animation: Sets the number of bars to be animated.
Bar Value 1-25: Sets the value for the bar(s).

To Create a Bar Chart with the Bar Values Plug-in

Add a group container to the scene tree, and add the Bar Values and Grid Arrange plug-in to 
it.

Add a group container as a Sub-Container to the first, and name it  Bar .

Add material, the Cylinder and Bar plug-in to the Bar container.

Open the Cylinder editor and set Center to  Bottom .

Open the Bar editor, set Param Type to Scale and Scale to  Y , and click Initialize.

Create and place a number of copies of the Bar container (e.g. 5 ) at the same level as the 

Bar container.

Open the Grid Arrange editor and set Number of Columns to 6 and Column offset to  30.0 .

Open the Bar Values editor and set Num Bars to  6  and Bar Animation to  6 .

See Also

Visual Data Tools Geometry
Control Bars
Bar
Bar Value
Pie Slice
Pie Values
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Pie Slice

The Pie Slice plug-in is used with the Pie Values plug-in to create and animate a pie chart of up to 
20 slices.

Pie Slice Properties
Obj Min / Max: Maps the input values to the values on the cylinder object. Adjust these 
together with Bar Max/Min on the Pie Values plug-in to get the required effect between input 
values and visual effect.
Offset: Offsets the slice from the center of the pie chart.
Text Offset: Offsets the text label from the center of the pie chart.
Control Text Values: Sets the type of text. Available options are No, Integer, Float and 
Formatted.
Initialize: Initializes the value of the pie slice.

See Also

Visual Data Tools Geometry
Control Bars
Bar
Bar Value
Bar Values
Pie Values

Pie Values

The Pie Values plug-in is used with the Pie Slice plug-in to create and animate a pie chart of up to 
20 slices.

Pie Values Properties
Pie Min and Max: Sets the minimum and maximum values for the pie size and the range of 
the size.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Presenter

Note: This plug-in is located in: Plugins -> Container plug-ins -> Presenter
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Min and Max Value: Sets the range of the shown pie.

Scale: Sets the scale of the pie. Default is 1 .

Slice: Sets the number of slices to be shown as part of the pie.

Value 0 - 19: Sets the slice value. Available number of slices is 20 .

To Create a Pie Chart with the Pie Values Plug-in

Add a group container to the scene tree, and name it  Pie .

Open the transformation editor and set Rotation X to  45.0 , and Scaling Y (single) to  0.2 .

Add the Pie Values plug-in to the Pie container.

Open the Pie Values editor and set Slice to  6.0 , and enter the following values in Value 

0 to  5 ; 10.0, 20.0, 20.0, 10.0, 20.0, 20.0 .

Add a Sub-Container to the Pie container and name it Slice.
Add the Cylinder geometry plug-in, material and PieSlice plug-in to the Slice container.

Open the PieSlice editor and set Offset to 10.0  and Text Offset to 80.0 .

Add a Sub-Container to the Slice container and name it  Text .

Open the transformation editor for the Text container and set Scaling (locked) 

to  0.2  and Rotation X to -90.0 .

Add a font, material and the Extrude plug-in to the Text container.

Open the Extrude editor and set Extrusion Depth to  100.0 .

Create and place a number of copies of the Slice container (e.g. 5 ) at the same level as the 

Slice container.
Change the colors of the pie slices to distinguish each slice.

See Also
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Visual Data Tools Geometry
Control Pie
Bar
Bar Value
Bar Values
Pie Slice

4.4.10 RealFX
The RealFX plug-in set enables you to create particle effects in Viz Artist.

Particle systems are a computer graphics technique to simulate certain physics-based effects, 
which are otherwise very hard to reproduce with conventional rendering techniques. Examples of 
such effects which are commonly replicated using particle systems include fire, explosions, smoke, 
weather effects, sparks, falling leaves, dust, meteor tails, or abstract visual effects like glowing 
trails, magic spells, etc.

The particle effects in Viz Artist/Engine run in real-time, meaning that there are a few inherent 
constraints that must be taken into account when considering best practices for employing this 
plug-in set. For example, there is a trade-off between the number of particles and performance 
optimization; more generally there needs to be a considered balance between performance and 
visual quality.

RFxSmoke is the baseline plug-in within the RealFX plug-in set. The remaining plug-ins in this set 
are applied on top of RFxSmoke in any given Container. RFxSmoke includes built-in functionality 
and the ability to host the additional functionality contained in the other plug-ins in this set. Part 
of the built-in functionality (for example, Turbulence) is kept for compatibility with previous 
versions of Viz Artist.

There are three categories of additional plug-ins:

Birth plug-ins: Refers to where the particles are spawned.
Motion control plug-ins: Governs the position, direction, velocity, size and color of each 
particle.
Texture control plug-ins: Affects the texture mapping and the “look” of each particle by 
using pixel shader technology.
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RealFX Architecture

The following Container plug-ins are located in the RealFX folder:

RFxColliderSrc
RFxColliderTgt
RFxLatLong
RFxMagnet
RFxTurb
RFxVortex

See Also

RealFX in Shader Plug-ins
RealFX plug-ins in Geometry Plug-ins

RFxColliderSrc

The RFxColliderSrc plug-in is used in conjunction with RFxColliderTgt to create a collision and 
collision detection system. For example the source could be a notional wall or floor, whereas the 
target would be the particles themselves. The particle target can work with a number of sources.
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RFxColliderSrc Properties
Adjust the following parameters as required to achieve the required effect:

Object Type (Auto, Sphere, Box)
Bounce
Random
Flag 1-8 (on/off)

See Also

RFxSmoke
RFxColliderTgt

RFxColliderTgt

The RFxColliderTgt plug-in is used in conjunction with RFxTurb to create a collision and collision 
detection system. For example the source could be a notional wall or floor, whereas the target 
would be the particles themselves. The particle target can work with a number of sources.

RFxColliderTgt Properties
Adjust the following parameters as required to achieve the required effect:

Flag 1-8 (on/off)
Proximity Fade and Fade Range: Allows you to fade particles based on their proximity to 
other objects (only spheres and boxes).

See Also

RFxSmoke
RFxTurb

Note: When RFxColliderSrc is added to a container, the RFxCollisionManager plug-in is 
automatically added at the scene level. This plug-in is used internally and not configurable.



Note: This plug-in is located in: Plugins -> Container plug-ins -> RealFX

Note: This plug-in is located in: Plugins -> Container plug-ins -> RealFX
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RFxLatLong

The RFxLatLong plug-in fits any other RealFX motion onto a globe surface. The effects are mainly 
geographic and large-scale.

RFxLatLong Properties
Adjust the following parameters as required to achieve the required effect:

Radius
Spawn Min Long
Spawn Max Long
Spawn Min Lat
Spawn Max Lat
Update from Globe (on/off)
Spawn Min Alt
Spawn Max Alt
Orientation (Horizontal/Radial)
Trim Radius

See Also

pxColorWorks

RFxMagnet

The RFxMagnet plug-in creates motion patterns that resemble a magnetic field.

RFxMagnet Properties
Adjust the following parameters as required to achieve the required effect:

Amount
Center X
Center Y
Center Z

Note: This plug-in is located in: Plugins -> Container plug-ins -> RealFX

Note: This plug-in is located in: Plugins -> Container plug-ins -> RealFX
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Power Law
Min Distance Clamp

See Also

RFxSmoke

RFxTurb

The RFxTurb plug-in applies turbulence-like forces to particles. It can be used to create the effect 
of random changes in wind force and direction.

RFxTurb Properties
Adjust the following parameters as required to achieve the required effect:

Amount
Inertia
Wavelength
Update Rate

See Also

RFxSmoke
RFxVortex

RFxVortex

The RFxVortex plug-in applies vortex-like forces to particles. It can be used to create the effect of a 
tornado-like twister.

RFxVortex Properties
Adjust the following parameters as required to achieve the required effect:

Amount

Note: This plug-in is located in: Plugins -> Container plug-ins -> RealFX

Note: RFxTurb requires to have RFxSmoke on the same container.

Note: This plug-in is located in: Plugins -> Container plug-ins -> RealFX
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Inertia
Center X
Center Y
Center Z
Rot X
Rot Y

See Also

RFxSmoke

4.4.11 Script
The Script plug-ins is a folder to save created Container Script plug-ins.

A script can be saved as its own script plug-in, and used in future Scenes (see the Scripting section 
of the Viz Artist User Guide). To save a Script plug-in, drag a compiled script into the Script plug-
ins folder.

See Also

Script plug-in

4.4.12 Sounds
The following Container plug-ins are located in the Sounds folder:

Text2Speech

Text2Speech

The Text2Speech plug-in is used to create speech from text.

Text2Speech Properties
Output:

Video: Plays the output to the video out. 
Speakers: Plays the output to the computer speakers. 
Both: Plays the output to both the video out and computer speakers. If running 
without a video card, this causes double playback.

Note: Script plug-ins are saved to <viz data folder>\Scriptplug-ins.

Note: This plug-in is located in: Plugins -> Container Plug-ins -> Sounds

http://documentation.vizrt.com/viz-artist
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Configuration: Selects predefined configurations for the Speaker, Rate, 
and Pitch parameters. This section is only visible when a profile file is located.

Custom: Sets the plug-in parameters manually. This is disabled if Configuration is set 

to  Profile.
Profile: Sets the plug-in parameters based on the profile file selected in 
the Profiles pane. This pane is only visible when a profile file is located. If 

Configuration is set to  Custom , the Profile button is disabled.

Speakers: Shows all speakers present in the system.
Lists all of the speakers currently present in the system, and allows the user to select 
one. Disabled if Custom configuration is selected.

Volume: Sets the desired output volume.
Rate: Sets the desired output rate.
Pitch: Selects the output pitch. The available settings are:

X-Low
Low
Medium
High
X-High

Text: Changes made to a text is played out immediately when in On Air mode. Play-out of 
changes to text during scene design in Viz Artist requires pressing the Play button.
Let Me Finish: Defines the behavior when a new text triggers play-out. Used in On air mode 
only.

Off: New text stops the current output and start playing the new text. When set 

to  Off , Queue Intermission and Minimal Queue Intermission is disabled.

On: When text is playing out, adding new text adds this to a queue and play out 
automatically when the previous text is done, adjusted for the intermission value. 

When set to  On , Queue Intermission is enabled.

Speed Up (1): When there is a play-out queue, the output Rate is increased by one, and 
the Intermission Minimal Value is used.
Speed Up (2): When there is a play-out queue, the output Rate is increased by one. 
Depending on the queue size, the output rate can be increased by two. In both cases, 
the Intermission Minimal Value is used.
Shorten: As when set to On, adding new text adds this to a queue to be played out 
automatically when the previous text is done, adjusted for the intermission value. 
However, the text is shortened.

Queue Intermission (ms): Defines the pause in milliseconds between text play-out when 

there is a text queue. The default value is  1000  (one second). This parameter is disabled 

when Let Me Finish is set to  Off.
Minimal Queue Intermission (ms): Defines the minimum pause in milliseconds between text 

play-out when there is a text queue and Let Me Finish is set to  Speed Up  or  Shorten . The 

default value is  1000  (one second).

Play: Starts play-out of the current text.
Pause: Pauses the on-going audio play-out on the video out output.
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Stop: Stops play-out.
Read Languages: Reads the Languages files from %Programdata%
\vizrt\VizEngine\TextToSpeech.

Language files are used to improve the pronunciation of words. The Text2Speech 
plug-in utilizes the Universal Phone Set (UPS) machine-readable phonetic alphabet 
created by Microsoft for this purpose. The language files are also used to replace 
defined abbreviations, for example replacing Av with Avenue.

Read Profiles: Reads profiles file from %Programdata%\Vizrt\VizEngine.

4.4.13 SplineFX
The following Container plug-ins are located in the SplineFX folder:

2D Follow

2D Follow

The 2D Follow plug-in works together with the 2D Ribbon. What the plug-in basically does is to 
automatically create an animation path that follows the form of a 2D Ribbon. The 2DRibbon must 
be created first.

2D Follow Properties
Path Position: Sets the position for the object along the path of the 2D Ribbon object. 
Animate this value to get an animation in the stage.
Position Wrap: Can be set to Interpolate, Clamp or Repeat.
Translation Offset: Sets an offset between the object and the 2D Ribbon path.
Keep Orientation: Keeps the orientation between the object and the 2D Ribbon path as the 
object moves along the path when enabled.
Orientation Offset: Offsets the orientation between the object and the 2D Ribbon path.

Note: This plug-in is located in: Plugins -> Container plug-ins -> SplineFX
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To Set up the 2D Follow Plug-in

Add the 2D Ribbon geometry to the scene tree.
Open the 2D Ribbon editor and enable Show Control Point Values.

Set alternating values of 30.0  and -30.0  to the Y axis values, creating a wave shape.

Add the item(s) (e.g. a Sphere) you want to animate along the 2D Ribbon’s path as a Sub-
Container to the 2D Ribbon container.
Add the 2D Follow plug-in to the container.

Open the 2D Follow editor and animate its Path Position value from 0.0  to 100.0 .

See Also

2D Ribbon
Create Animations section of the Viz Artist User Guide.

4.4.14 TextFX
The following Container plug-ins are located in the TextFX folder:

Common Text FX Properties
Convert Case
Mark Text
Text FX Alpha
Text FX Arrange
Text FX Color
Text FX Color Per Vertex
Text FX Emoticons
Text FX Explode
Text FX Jitter Alpha
Text FX Jitter Position
Text FX Jitter Scale
Text FX Plus Plus
Text FX Rotate
Text FX Scale
Text FX Size
Text FX Slide
Text FX Vertex Explode
Text FX Write

http://documentation.vizrt.com/viz-artist
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Common Text FX Properties
When in text editing mode, any TextFX effects are automatically deactivated to allow text input. As 
soon as the text editing is deactivated, either by selecting another container, or by just selecting a 
different container property within the selected container, such as transformation, the TextFX 
effect is applied again in the scene preview.

The following properties are common to most of the Text FX plug-ins:

Progress %: 0 percent progress represents the beginning of the effect, 100 percent the end. 

Animate this value from  0  to  100  to see the effect or from  100  to  0  to animate the 

effect backwards.
Progress Type

Absolute: 100 percent progress animates all characters of a text, regardless how many 
characters it has.
Relative: 100 percent progress animates ten characters. This is needed to adjust the 
timing of several text objects with different sizes. The effect speed should be for 
example five characters per second, so the animation must be from 0 to 100 in two 
seconds. This works for text with ten characters or less. If you want to use longer 
texts, animate the progress value over 100 percent (ten percent for each character).

Direction: Sets the direction of the text effect sequence, you can choose between the 
following options:

Left: Starts with the first character.
Right: Starts with the last character
Random: Uses a random order.
Static: All characters are processed at the same time.
Wave: Starts with the first character, animates the effect from 0 to 100 and then down 
again to 0.
Center: Starts the effect from the center of the text.
2 Center: Starts the effect at the same time from the beginning and the end of the 
text. They meet at the center.

Interpolate: Choose between a soft or a linear interpolation of the transition from character 
to character.
Effect Range: Defines how many characters are processed at the same time. If for example 

the Effect Range is set to 4 , and you manually increase the progress value, you see that 

when the fifth character starts to be processed, the first is finished, when the sixth starts, 
the second is finished, and so on.
Random Seed: Specifies a seed for the random number generator when a random direction 
is chosen. Even though Viz Artist uses random numbers, the animation for a specific random 
seed always looks the same. This is typically useful if you combine two different text effects.
Ignore Space: Ignores space when animating the effect.
Ignore Newline: Ignores new lines when animating the effect.
Text Order: Sets the text order for the effect. Available options are As Is, Horizontal or 
Vertical. Horizontal and Vertical enables the Text Direction options.
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Convert Case

The Convert Case plug-in converts ASCII strings to upper or lower case. Current container must 
hold a string.

This page contains the following topics and procedures:

Convert Case Properties
To Convert a String to Upper or Lower Case

Convert Case Properties
Upper/Lower: Converts the text for the specific container to upper or lower case.

FUNCTION*ConvertCase*text_case - int; 0: upper, 1: lower 
FUNCTION*ConvertCase*text - string

To Convert a String to Upper or Lower Case
Add a group to the scene tree, and add a font to it.
Add the Convert Case plug-in to the same container.
Open the Convert Case editor, and enter text in the editor.
Click the Upper button to convert to upper case text, or click the Lower button to convert to 
lower case text.

Mark Text

The Mark Text plug-in allows you to highlight or underline words in a text string.

Mark Text Properties
Text to Mark: Sets the text that should be highlighted. The text is case sensitive.
Marks spaces: Also allows to put the marker between words.

Note: This plug-in is located in: Plugins -> Container plug-ins -> TextFx

Note: This plug-in is located in: Plugins -> Container plug-ins -> TextFX
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Please verify your scene when using the Mark Space option on single words located at 
the end of the textbox. In some rare conditions, it may happen that the selection does 
not match the expected result.

Multiple marks: Highlights all matched text.
Use regular expression: Allows regex to be used for more sophisticated highlighting. 

Only matched group: Highlights only on capture-groups (value) , other matched 

texts outside capture-groups or inside non-capture-groups (?:value)  are not.

Case insensitive: Matches both upper and lower case.
Grammar: Selects one of the following supported grammars:

ECMA
Basic
Extended
Awk
Grep
Egrep

Mark: Selects which text should be highlighted. Available options are foreground (Front), 
background (Shadow), Both and None. Background highlights the text’s shadow.
Size: Sets the thickness of the highlight.
Position: Sets the y-position of the highlight in relation to the text.
Depth: Sets the z-position of the highlight in relation to the text. This allows the highlight to 
move behind the text.
Foreground Color: Sets the color and alpha value of the highlight.

To Mark Text

Add a group container to the scene tree and name it Text .

Add a font to the Text container.
Open the font editor and enter a text string.
Add the Mark Text plug-in to the Text container.
Open the Mark Text Editor and enter a word from your text string or regex if enabled.

Note: Do not change the font type between texture and geometry as this does not affect 
the whole string when using the Mark Text plug-in.



Note: Overlapping marks could occur with narrow character spacing or kerning. This would 
be visible in case of transparent marks.
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Text FX Alpha

The Text FX Alpha plug-in is a text effect that creates a fade in effect for the text characters. The 
effect sequence can be set to go many different ways. A fade in and out effect can also be 
achieved.

Supported Pipelines

Classic Render Pipeline

Viz Engine Render Pipeline

Text FX Alpha Properties
Alpha Begin %: Sets the alpha level of the character at 0% effect.
Alpha End %: Sets the alpha level of the character at 100% effect.

See Also

Common Text FX Properties

Text FX Arrange

The Text FX Arrange plug-in allows you to arrange characters in either a circular or a wave shape. 
The characters can be animated on the selected shape by animating the offset value.

Supported Pipelines

Classic Render Pipeline

Viz Engine Render Pipeline

This page contains the following topics and procedures:

Text FX Arrange Properties

Note: This plug-in is located in: Plugins -> Container plug-ins -> TextFX

Note: This plug-in is located in: Plugins -> Container plug-ins -> TextFX
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Circle Parameters
Wave Parameters

Text FX Arrange Properties
Offset %: Moves the characters on the shape. 100% means one full rotation of the text on the 
circle.
Scale %: Sets the text on the shape. The parameter does not scale the characters itself, but 
the kerning of the characters.
Shape: Changes the shape of the character layout to Circle or Wave.

Circle Parameters

Diameter: Sets the diameter of the circular shape.
Positioning: Defines the position of the text on the circular shape:

Relative: Maintains the text spacing of the text object.
Absolute: Distributes the text evenly onto the circle.

Direction: Sets the direction of the text on the circle to either Clockwise
or Counterclockwise.
Rotation: Rotates the characters on the X-axis.
Align: Rotates the characters on the Z-axis to align the X-axis with the tangent of the shape 
at the characters position.

Wave Parameters

Length: Sets the wave length. A high value creates many and small waves, a low value 
creates fewer and bigger waves.
Width: Sets the width of the wave.
Height: Sets the height of the waves without altering the number of waves as 
the Length does.

Shift %: The wave usually starts at the height 0 . The shift value moves that point, thereby 

moving the texts position on the wave structure. Setting Shift % to 100% brings you back to 
the beginning.
Damping: Modifies the amplitude of the wave curves.
Rotation: Rotates the characters on the X-axis.
Align: Rotates the characters on the Z-axis to align the X-axis with the tangent of the shape 
at the characters position.

Note: The shape of the text transformation is not visible in the Scene Editor while the 
Text Editor is active.
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Text FX Color

The Text FX Color plug-in adds a color effect to the text.

Supported Pipelines

Classic Render Pipeline

Viz Engine Render Pipeline

Text FX Color Properties
Color Begin: Sets the initial color before applying the effect.
Color End: Sets the color the effect should apply.

See Also

Common Text FX Properties

Text FX Color Per Vertex

The Text FX Color Per Vertex plug-in adds a color per vertex effect to the text.

Supported Pipelines

Classic Render Pipeline

Viz Engine Render Pipeline

Note: This plug-in is located in: Plugins -> Container plug-ins -> TextFX

Note: Works only if the text is set to texture (does not work with geometry text).

Note: This plug-in is located in: Plugins -> Container plug-ins -> TextFX
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Text FX Color Per Vertex Properties
Color Bbox: Defines the reference bounding box, global for the entire text, or local for each 
character.
Color Direction: Defines the color gradient shape. Available options are; top left to bottom 
left, top right to bottom right, top left to top right, bottom left to bottom right, top right to 
bottom left and four corners.

Color Level: Sets the level of the color ( 0.1  to 1.9 ). Default is 1.0 .

Top and Bottom Left and Right: Sets the color and alpha value for each edge.
Color use Alpha: Enables alpha.

See Also

Common Text FX Properties

Text FX Emoticons

The Text FX Emoticons plug-in allows you to create an emoticon container, add it to the Emoticons 
plug-in and replace characters (tokens) in a text string with an assigned container.

Supported Pipelines

Classic Render Pipeline

Viz Engine Render Pipeline

Text FX Emoticons Properties
Autoscale: Scales the emoticon containers so their height above the baseline (0) is identical 
to the height of character A.
UTF-8 Encoding: Enables UTF-8 encoding for the text effect.
Token 1 - n: Sets the placeholder for an emoticon.
Container 1 - n: References the container holding the emoticon. The container should be 
similar to the layout of a glyph.
Precache 1-n:- Enables Viz Artist/Engine to cache the objects.

Note: This plug-in is located in: Plugins -> Container plug-ins -> TextFX
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Text FX Explode

The Text FX Explode plug-in creates an explosion like function where the characters get thrown 
away from their initial position. The speed, direction and spread of the moving characters can be 
altered with parameters.

Supported Pipelines

Classic Render Pipeline

Viz Engine Render Pipeline

Text FX Explode Properties
Duration: Defines the duration of the progressing for each of the characters. If you want a 
longer progressing, increase this value. You could achieve the same by making the gravity 
stronger and animating the progress slower, but it is more easy to increase the duration 
instead if your explode effect is too short.

Opening Angle: Sets the angle for the spread of the characters. 0  sends them straight up, 

360  spreads them in a circular shape.

Angle Rotate X: Rotates the opening angle around the X-axis.
Angle Rotate Y: Rotates the opening angle around the Y-axis.
Force: Sets the force that throws away the characters. A high force makes them go far away, 
conversely a low force creates only a small motion of the characters.
Force Spread %: Sets a variation of the force among the characters.
Use Axis: Allows you to select on which axis or combination of axes the characters are to 
spread along.
Gravity: Sets a gravity force that influence the path of the characters to end up going 
downwards. The higher the value is set, the faster each character diverts from its initial path 
and starts going downwards.
Use Rotation: Rotates characters as they are being thrown away from their initial position 
when enabled.
Rotation Force: Sets the degree of rotation as the characters are being thrown away.
Show Force: Shows lines showing the characters path and speed in the Scene Editor when 
enabled. 

Note for the Classic Render Pipeline: Works only if the text is set to texture (does not work 
with geometry text).



Note: This plug-in is located in: Plugins -> Container plug-ins -> TextFX
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See Also

Text FX Vertex Explode
Common Text FX Properties

Text FX Jitter Alpha

The Text FX Jitter Alpha plug-in creates a jittering motion of the characters by randomly changing 
the alpha value of each character. The degree of change and the start sequence of the jittering can 
be altered. To use the plug-in, add it onto a container with a font. To create an animation, animate 
the progress. Other values can of course be animated as well.

Supported Pipelines

Classic Render Pipeline

Viz Engine Render Pipeline

Text FX Jitter Alpha Properties
Effect What: Defines where the effect should have an effect. Available options are 
background (BG), foreground (FG) or both.
Alpha Begin: Sets the alpha level of the character at 0% effect.
Alpha End: Sets the alpha level of the character at 100% effect.
Randomness: sets the intensity of the jittering alpha changes.

Text FX Jitter Position

The Text FX Jitter Position plug-in creates an jittering motion of the characters by randomly 
changing the position of each character. The degree of position change and the starting sequence 
of the jittering can be altered. To use the function add it onto a container which holds a font. To 
create an animation, animate the progress. Other values can of course be animated as well.

Note: Show Force is not available in the Viz Engine Render Pipeline.

Note: This plug-in is located in: Plugins -> Container plug-ins -> TextFX
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Supported Pipelines

Classic Render Pipeline

Viz Engine Render Pipeline

Text FX Jitter Position Properties
Use Axis: Defines on which axis or axes the characters moves to create the jittering effect.
Lock Axis: Sets Range and Randomness to the same value for all axes when enabled. If you 
disable it, Range and Randomness for each of the axes are shown and you can set them 
individually.
Range: Sets the range of the jittering movement.
Randomness: Sets the intensity of the jittering movement.

See Also

Common Text FX Properties

Text FX Jitter Scale

The Text FX Jitter Scale plug-in animates a jittering effect on the scale of the character.

Supported Pipelines

Classic Render Pipeline

Viz Engine Render Pipeline

Text FX Jitter Scale Properties
Anchor Horizontal: Sets the anchor point for the characters on the horizontal plane.
Anchor vertical: Sets the anchor point for the characters on the vertical plane.
Use Axis: Defines on which axis or axes the characters scale to create the jittering effect.
Lock Axis: Gives all the axes get the same Min, Max and Randomness settings when 
enabled. If you disable randomness, these parameters are visible for each of the axes and 
must be set individually.

Note: This plug-in is located in: Plugins -> Container plug-ins -> TextFX

Note: This plug-in is located in: Plugins -> Container plug-ins -> TextFX
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Min: Sets the minimum scaling for the characters.
Max: Sets the maximum scaling for the characters.
Randomness: Sets the intensity of the jittering movement.

See Also

Common Text FX Properties

Text FX Plus Plus

The Text FX Plus Plus plug-in works in combination with the Pathfinder plug-in and allows to 
arrange a text among a defined spline.

Supported Pipelines

Classic Render Pipeline

Viz Engine Render Pipeline

Text FX Plus Plus Properties
Position Wrap

Extrapolate: Above 100% or below 0% of Path Position continues the direction of the 
spline.
Clamp: Stops the string on the spline endpoints.
Repeat: Causes the string to move to the other spline endpoint as soon as it moves 
over the endpoint.
TextFx: Positions characters by the relative spline of each character using the common 
TextFx parameters.

Scheme Type: Defines how the text looks at 0% and 100% progress.
In -> In: at 0% first character is at the beginning of the spline, at 100% last character is 
at the end of the spline.
In -> Out: at 0% first character is at the beginning of the spline, at 100% first character 
is at the end of the spline.
Out -> In: at 0% last character is at the beginning of the spline, at 100% first character 
is at the end of the spline.
Out -> Out: at 0% last character is at the beginning of the spline, at 100% last 
character is at the end of the spline.

Progress (%): Animates the progress of the effect(s).
Position: Positions the characters using the spline as a position axis.

Note: This plug-in is located in: Plugins -> Container plug-ins -> TextFX
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Rotation: Rotates the characters using the spline as a rotation axis.
Scale: Scales the character’s X, Y and Z-axis using the spline as a scaling graph.
Color: Applies Color Change on character.
Alpha: Applies Alpha on the characters using the spline as a alpha graph.
General: Enables rotation, offset and align properties.

Rotate X/Y/Z: Adds extra Rotation to each character.
Text Offset: Sets the text offset.
Align: Rotates the characters to follow the spline movements.

TextFX: See Common Text FX Properties.
Direction: Sets the direction of the text effect sequence. Normal starts with the first 
character (e.g. left). Opposite starts with the last character (e.g. right). Random uses a 
random order (see Random Seed). Static means that all characters are processed at the 
same time. Wave starts with the first character, animates the effect from 0 to 100% 
and then down again to 0%. Center starts the effect from the center of the text. 2 
Center starts the effect at the same time from the beginning and the end of the text. 
They meet at the center.

Scale: Defines the scale graph to apply on the characters for each axis.
Rotation: Defines the rotation effect to apply on the characters for each axis.
Color: Defines the color gradient effect to apply on the characters.
Alpha: Defines the alpha effect to apply on the characters.

See Also

Common Text FX Properties

Text FX Rotate

The Text FX Rotate plug-in allows you to create an effect where the characters rotate on the X-, Y- 
or Z-axis.

Supported Pipelines

Classic Render Pipeline

Viz Engine Render Pipeline

Text FX Rotate Properties
Anchor Horizontal: Sets the anchor point for the characters on the horizontal plane.
Anchor Vertical: Sets the anchor point for the characters on the vertical plane.

Note: This plug-in is located in: Plugins -> Container plug-ins -> TextFX
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Use Axis: Defines on which axis the characters rotate.
Begin: Sets the initial rotated position of the characters.
End: Sets the ending rotated position of the characters.

See Also

Expert
Common Text FX Properties

Text FX Scale

The Text FX Scale plug-in allows you to create a scaling animation of the characters.

Supported Pipelines

Classic Render Pipeline

Viz Engine Render Pipeline

Text FX Scale Properties
Anchor Horizontal: Sets the anchor point for the characters on the horizontal plane.
Anchor Vertical: Sets the anchor point for the characters on the vertical plane.
Use Axis: Defines on which axis or axes the characters scale.
Lock Axis: Scales the Begin- and End the same for all the axes when enabled. If you disable 
the parameter, Begin and End must be set for all the axes individually.
Begin: Sets the initial size of the characters.
End: Sets the ending size of the characters.

See Also

Text FX Size
Common Text FX Properties

Text FX Size

The Text FX Scale plug-in allows you to create a sizing animation of the characters.

Note: This plug-in is located in: Plugins -> Container plug-ins -> TextFX
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Supported Pipelines

Classic Render Pipeline

Viz Engine Render Pipeline

Text FX Size Properties
Begin: Sets the initial scale of the text before the effect.
End: Sets the final scale of the text after the effect.

See Also

Text FX Scale
Common Text FX Properties

Text FX Slide

The Text FX Slide plug-in allows you to create a sliding animation of the characters on the X, Y and 
Z-axis.

Supported Pipelines

Classic Render Pipeline

Viz Engine Render Pipeline

Text FX Slide Properties
X, Y and Z Distance: Defines direction and distance of moved text.
Show Direction: Enables and disables view of movement vector.

See Also

Common Text FX Properties 

Note: This plug-in is located in: Plugins -> Container plug-ins -> TextFX

Note: This plug-in is located in: Plugins -> Container plug-ins -> TextFX
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Text FX Vertex Explode

The Text FX Vertex Explode plug-in allows you to create an effect where text characters are 
exploded with a vertex effect.

Supported Pipelines

Classic Render Pipeline

Viz Engine Render Pipeline

Text FX Vertex Explode Properties
X, Y and Z Distance: Defines direction and distance of moved text.
Show Direction: Enables and disables view of movement vector.

See Also

Text FX Explode
Common Text FX Properties

Text FX Write

The Text FX Write plug-in allows you to create an effect where text characters get shown as if they 
were written by the keyboard in real-time, a sort of Typewriter effect.

Supported Pipelines

Classic Render Pipeline

Viz Engine Render Pipeline

The text field in the font editor does not need to contain any text, as the text for this plug-in is 
entered in the plug-in editor. Text FX Write expects UTF-8 encoded text as input, if a font encoding 
other than Default is selected (see the Font/Text Options page in the Configuring Viz section of 
the Viz Engine Administrator Guide).

Note: This plug-in is located in: Plugins -> Container plug-ins -> TextFX

http://documentation.vizrt.com/viz-engine
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Text FX Write Properties
Fill with Space: Adds a space for every character not yet written when enabled. The bounding 
box of the text is then sized correctly from the start. If you use an Auto Follow function 
connected to the text, enabling this option creates a better result.
Effect: Allows you to select an effect to be executed as each character gets written on the 
screen. There are four effects to choose from and they have in addition their own 
parameters.

Pop: Creates the basic effect where the characters just pop up on the screen without 
any other sign being shown.
Count: Creates a counting sequence by showing a random symbol before showing the 
character to be shown.
Random: Writes random characters before the final character is shown (in combination 
with effect range). Use a non proportional font when you use this function to get the 
better looking effect.
Cursor: Shows a cursor that writes the characters. When you select this option, a text 
field opens below where you can choose which symbol to use as cursor.

Effect Speed: Sets the speed of the effect that shows the preceding symbol. This is an 
additional parameter that is visible if you have selected Count or Random. 
Selection: Allows you to select between some preset character ranges to use for the effect. 
This is an additional parameter to the Random effect. 
Cursor: Allows you to enter the character which is to be used as a cursor.

See Also

Common Text FX Properties

4.4.15 Texture
The following Container plug-ins are located in the Texture folder:

Browser
Grabbit
GraffitiTex
Image Clip
ImageProportion
Light Blur
MoViz
Noise
SoftClip
Tex Component
VLC

Note: This plug-in is located in: Plugins -> Container plug-ins -> TextFX
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Browser

The Browser plug-in gives the ability to stream browser content on a Texture.

This page contains the following topics and procedures:

Browser Properties
To Create a Simple Scene with Browser
Interact with a Scene with JavaScript
Example HTML Document
Browser Status Notifications
Limitations

Browser Properties
URL: Determines the URL address to be opened.
Texture Width: Determines the width in pixels of the browser window.
Texture Height: Determines the height in pixels of the browser window.
Allow Popups: Allows the browser to render popup windows. The popup renders into the 
current texture. Close the popup by navigating back.
Disable JavaScript: Disables JavaScript execution.

Generate Mipmaps: Generates all mipmap levels. Set to Off  for more performance. Set to 

On  for more quality when the texture is rendered on a smaller area on the screen than the 

width/height of the browser itself.
Alpha: Enables a transparent browser window.
Snapshot Filename: Saves a snapshot at the location (full path) entered here. The location 
can be either a local file or on the Graphic Hub, and must be specified as a Uniform 
Resource Identifier (URI), for example:

File: file:///c:/temp/Browser/example.png
Graphic Hub:  vizgh:///Browser/example.png
Graphic Hub UUID: vizgh:///<F3F3F087-B85A-4AEE-B5019F78CB6AE5EC>/
example.png

Snapshot: Takes a snapshot of the current browser texture. The snapshot is saved as a file 
or to the Graphic Hub, as specified in Snapshot Filename.
Navigate Back: Navigates back to the previous page.
Navigate Forward: Navigates forward to the next page.
Reload Page: Reloads the current page.
Zoom In: Zooms into the page, incrementing per click.

Note: Vizrt is not responsible for the content displayed or the technology used to display 
this content.
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Zoom Out: Zooms out of the page, incrementing per click.
Zoom Reset: Resets zoom to default value.
Zoom: Determines the desired zoom value. The fields supported range is 

from  -10.0  to  10.0 . The default value is  0.0 . Like any other parameter, the value of this 

field can be controlled from a ControlObject. Please enable Show Advanced and then add the 
parameter under Channel:

ScrollBy X: Sets the scroll in the horizontal axis.
ScrollBy Y: Sets the scroll in the vertical axis.
ScrollBy: Executes ScrollBy X and Y values.
Execute: Executes the code entered in the code entry field.
Disable Native Mouse Events: Disables all mouse events, such as move, click and wheel 
events. Useful to control mouse events from outside, for example in scripts; or if it 
interferes with other plug-ins, such as Graffiti.
Mouse Position X and Y: Controls the position of the mouse cursor with the u/v parameters. 
The coordinates are normalized in [0,1], being (0,0) the lower left corner and (1,1) the upper 
right corner of the browser window. All mouse click and move events described below relate 
to this coordinate:

Left Click: Emulates a click (both mouse down and mouse up events) of the left mouse 
button.
Left Mouse Down: Emulates a left mouse button down event.
Left Mouse Up: Emulates a left mouse button up event.
Right Mouse Down: Emulates a right mouse button down event.
Right Mouse Up: Emulates a right mouse button up event.
Mouse Move: Emulates a mouse move event (might be triggered after the u/v 
coordinate has been changed.
Wheel Up: Emulates a mouse wheel up event.
Wheel Down: Emulates a mouse wheel down event.
Wheel Left: Emulates a mouse wheel left event.
Wheel Right: Emulates a mouse wheel right event.

ControlObject Exposure with Direct Address

zoom:MAIN_SCENE*TREE*$Browser*FUNCTION*Browser*zoom:float:0.0:-10.0:10.0
:zoom level



ControlObject Exposure with Control Channel Address

zoom:MAIN_SCENE*TREE*@zoom:float:0.0:-10.0:10.0:zoom level



Note: The Browser plug-in works asynchronously. Therefore, the zoom value needs 
to be applied after a successful load of an URL. This means that the value stored in 
the plug-in may not be the currently active zoom value until it has been applied.
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5.

Proxy User: Provides the user name in case the system’s HTTP proxy requires authentication.
Proxy Password: Provides the user name password in case the system’s HTTP proxy requires 
authentication.
Read Events From Shared Memory: Enables the browser to receive events from shared 
memory callbacks.
Input Events from Shared Memory: Prefix key for global shared memory. Valid commands 
are:

WB_TEXT : Can be used to emulate string input like ‘Hello World!’

WB_KEY : Can be used for special key strokes. Possible values are ENTER, RETURN, 

BACKSPACE, DELETE, HOME, END, LEFT, RIGHT, UP, DOWN, PAGE_UP, PAGE_DOWN.
Sample for viz-scripting supposing ShmemVarName is WB_EVENTS:

System.map["WB_EVENTS"] = "WB_TEXT Hello World!"
System.map["WB_EVENTS"] = "WB_KEY ENTER"

Note that a Shared Memory change event only occurs if the memory actually changes. 
Sending the same text twice, for example, does not trigger a Shared Memory event.

Enable Multitouch Events: Enables native multitouch events (scroll, pinch to zoom, double 
tap).
Texture Sharing: Is needed if the whole content of a page needs t be updated. This makes 
pages to be much more responsive, but takes more performance.

To Create a Simple Scene with Browser

Add a new Container to the Scene tree.
Add a rectangle geometry to the Container
Add the Browser plug-in.
Open the Browser properties and enter a valid URL.

Click on   (enable the handling of interactive script/plug-in events (Scene Editor)).

Note: Special characters (non ASCII) like umlauts, etc. are not supported.
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6. Use the mouse or controls to navigate the web site.

Interact with a Scene with JavaScript
It is possible to interact with a Scene from within the JavaScript of a HTML document 
(e.g. colorpicker.html).

In the JavaScript section of a HTML document interact with the Scene with the window.vizrt object. 
Append any function name on this object, for example, window.vizrt.colorChange( "255 100 
100" ). The function colorChange must be defined in the JavaScript function section of the Browser
plug-in. 

To add more functions, add them in this GUI section, separated by new lines: 

Only one argument is supported for each function, to add more arguments to a function use 
separators and encode all arguments into one string.

Calls from JavaScript are translated into Viz Shared Memory variable changes, on the system.map. 
To register these changes use the Shared Memory variable composed by the Container ID of the 

Browser plug-in and the string, for example,  "BROWSER STATUS" .

Script Example: When the script sits on the same Container:

sub OnInit()   
    System.map.RegisterChangedCallback( this.VizId & " BROWSER STATUS" ) 
end sub 

sub OnSharedMemoryVariableChanged(map As SharedMemory, mapKey As String)   
    println( "shared map changed: " & map[mapKey] )   

    Dim str As String = map[mapKey]   
    Dim strstr As array[String]   

IMPORTANT! There must be a space between the double quotation mark ( " ) and 

BROWSER{{: " BROWSER STATUS"}}.
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    str.split(" ", strstr)   
    if strstr[1] = "javascript" then

if strstr[2] = "colorChange" then
scene.findContainer("iso").Material.diffuse.red = cDbl(strstr[3])/255.0
scene.findContainer("iso").Material.diffuse.green = cDbl(strstr[4])/255.0
scene.findContainer("iso").Material.diffuse.blue = cDbl(strstr[5])/255.0

end if
    end if
end sub

Example string passed to Shared Memory:

"0 JavaScript colorChange 0 53 4"

The first number, either  0  or  1 , can be ignored

JavaScript , shows that a JavaScript function was invoked

The function name ( colorChange ) itself followed by the argument(s).

Example call in the HTML document:

window.vizrt.colorChange(r + " " + g  + " " + b);

Example HTML Document
Entered in URL: file:///C:/test/colorpicker.htm (see Browser Properties):

<script type="text/javascript">
function colorAnim() 
{   
    window.vizrt.colorAnim() 
} 

function objectmove(x, y) 
{   
    PositionX.value = x;   
    PositionY.value = y; 
}
</script> 

<!DOCTYPE html> 
<html lang="en">
    <head>

<title id='Description'>The jqxColorPicker widget allows you to easily pick a 
color.</title>     

<link rel="stylesheet" href="http://www.jqwidgets.com/jquery-widgets-demo/
jqwidgets/styles/jqx.base.css" type="text/css" />     

<script type="text/javascript" src="http://www.jqwidgets.com/jquery-widgets-
demo/scripts/jquery-1.11.1.min.js"></script>     

file:/C:/test/colorpicker.htm
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<script type="text/javascript" src="http://www.jqwidgets.com/jquery-widgets-
demo/scripts/demos.js"></script>     

<script type="text/javascript" src="http://www.jqwidgets.com/jquery-widgets-
demo/jqwidgets/jqxcore.js"></script>    

<script type="text/javascript" src="http://www.jqwidgets.com/jquery-widgets-
demo/jqwidgets/jqxcolorpicker.js"></script>     

<script type="text/javascript" src="http://www.jqwidgets.com/jquery-widgets-
demo/jqwidgets/jqxradiobutton.js"></script> 
    </head>  
    <body class='default'>     

<div id='content'>
<script type="text/javascript">

$(document).ready(function () 
{   

// Create jqxColorPicker widgets.
$("#jqxColorPicker").jqxColorPicker({ width: '250', height: '250'}

);
$("#hueMode").jqxRadioButton({ width: '150', height: '25'});
$("#saturationMode").jqxRadioButton({ checked: true, width: '180',

 height: '25'});
$("#hueMode").on('change', function (event) 
{

if (event.args.checked) 
{

$("#jqxColorPicker").jqxColorPicker({ colorMode: 'hue' })
;

}
else {

$("#jqxColorPicker").jqxColorPicker({ colorMode: 
'saturation' });

}
});

$("#jqxColorPicker").on('colorchange', function (event) 
{

//console.log(event.args.color.r);
window.vizrt.colorChange(event.args.color.r + " " + 

event.args.color.g + " " + event.args.color.b);
$("#colorlog").html("<div>Color: #" + event.args.color.hex + 

"</div>");
});

});
</script>
<div id='jqxWidget'>

<div id="jqxColorPicker"></div>
<div style="font-size: 13px; font-family: verdana; margin-top: 10px;">

<div style="margin-bottom: 5px;">Color Modes</div>
<div id="saturationMode">Saturation Color Mode</div>
<div id="hueMode">Hue Color Mode</div>

</div>
<div style="font-family: Verdana; font-size:13px;" id="colorlog"></

div>
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</div>
</div>

    </body> 
</html>

Browser Status Notifications
The browser plug-in writes the following status updates into the System Shared Memory Map:

address <uri>: Called when the browser URL changes.
title <title>: Called when the browser title changed.
loadstate <started|stopped>: Called when loading of a page started or stopped.

Use the container ID where the plug-in resides concatenated with the string BROWSER STATUS on 
the System Map to register for all Browser related events.

sub OnInit()   
    System.map.RegisterChangedCallback( this.VizId & " BROWSER STATUS" ) 
end sub 

sub OnSharedMemoryVariableChanged(map As SharedMemory, mapKey As String)   
    if mapKey = this.VizId & " BROWSER STATUS" then

println( "New status: " & map[mapKey] )   
    end if
end sub

Limitations
Because of licensing issues, some features are not enabled in the Browser plug-in. This 
affects for example the support for H.264/H.265 video, used by some streaming platforms.
Visit https://html5test.com/ to verify whether features are available.
The 32-bit version of the Browser plug-in relies on an older version and will not be updated. 
Therefore, not all features of the 64-bit version are supported. 

Grabbit

The Grabbit plug-in gives the ability to use captured video inside Viz Engine. Grabbit uses the 
Microsoft DirectShow Filter graph framework to capture the video.

Devices which are supported by DirectShow and are self-contained such as capture cards or web 
cameras, can be used. Self-contained means the capture device does not need any further input.

This page contains the following topics and procedures:

Note: This plug-in is located in: Plugins -> Container plug-ins -> Texture

https://html5test.com/
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Grabbit Properties
Required Software
Best Practices
Known Limitations
To Capture a Video Stream with Grabbit
To Capture a Video Stream with Grabbit and a VfW Supported Device

Grabbit Properties
Following is a list of all parameters of the plug-in. Depending on the state of the plug-in, they may 
be hidden. Some of them are not visible at all.

Available Devices: Decides which video capture device to use. This list is created when the 
plug-in loads. That means if you have a capture device which is not known at startup of the 
renderer, it does not show up. On the other hand, it does not know if a capture device is 
already in use by some other plug-in. Since the list is static, it just shows all capture devices 
which were available at startup. If the parameter is changed and the plug-in is already 
started, it stops capturing before loading the new capture device. Changes are effective 
immediately.

Parameter name:  CaptureDevices (list) .

Selected Capture Device: Contains the simple name for the chosen capture device from the 
list. This parameter decides which DirectShow Device is taken for capturing. If the parameter 
is changed and the plug-in is already started, it stops the capturing before loading the new 
capture device.

Parameter name:  CaptureDevice (string) .

Capture Format: Represents the current capturing format as a human readable string. It 
shows the width by height, frame rate, video subtype, and bit depth. It is a read only 
resource and is changed with the configuration dialogs below. This should really be an 
opaque data type.

Parameter name:  CaptureFormat (string) . Parameters are shown if the filter 

supports the ProcAmp interface.

Brightness: Changes the brightness. The range is relative and the value is re-calculated 
internally according to the possibilities (min/max/stepping) of the device. Changes are 
effective immediately but not for already captured video.

Parameter Name:  Brightness .

Type: float. Range: [ 0-100 ]. Default: 50 .

Contrast: Changes the contrast. The range is relative and the value is re-calculated internally 
according to the possibilities (min/max/stepping) of the device. Changes are effective 
immediately but not for already captured video.

Note: This parameter is hidden from the user interface.

Note: This parameter is hidden from the user interface.
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Parameter Name:  Contrast .

Type: float. Range: [ 0-100 ]. Default: 50 .

Hue: Changes the hue. The range is relative and the value is re-calculated internally 
according to the possibilities (min/max/stepping) of the device. Changes are effective 
immediately but not for already captured video.

Parameter Name:  Hue .

Type: float. Range: [ 0-100 ]. Default: 50 .

Saturation: Changes the saturation. The range is relative and the value is re-calculated 
internally according to the possibilities (min/max/stepping) of the device. Changes are 
effective immediately but not for already captured video.

Parameter Name:  Saturation .

Type: float. Range: [ 0-100 ]. Default: 50 .

Sharpness: Changes the sharpness. The range is relative and the value is re-calculated 
internally according to the possibilities (min/max/stepping) of the device. Changes are 
effective immediately but not for already captured video.

Parameter Name:  Sharpness .

Type: float. Range: [ 0-100 ]. Default: 50 .

Gamma: Changes the gamma. The range is relative and the value is re-calculated internally 
according to the possibilities (min/max/stepping) of the device. Changes are effective 
immediately but not for already captured video.

Parameter Name:  Gamma .

Type: float. Range: [ 0-100 ]. Default: 50 .

Colorenable: Enables or disables color. Changes are effective immediately but not for 
already captured video.

Parameter Name:  Colorenable .

Type: toggle button. Default: on .

Whitebalance: Changes the white balance. The range is relative and the value is re-calculated 
internally according to the possibilities (min/max/stepping) of the device. Changes are 
effective immediately but not for already captured video.

Parameter Name:  Whitebalance .

Type: float. Range: [ 0-100 ]. Default: 50 .

Backlight Compensation: Enables or disables the back light compensation. Changes are 
effective immediately but not for already captured video.

Parameter Name:  BacklightComp .

Type: toggle button. Default: on .

Gain: Changes the gain. The range is relative and the value is re-calculated internally 
according to the possibilities (min/max/stepping) of the device. Changes are effective 
immediately but not for already captured video.

Parameter Name:  Gain .

Type: float. Range: [ 0-100 ]. Default: 50 .

Parameters are shown if the filter supports the DirectShow dialog interface. Since the 
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dialogs are handled by Windows and not the Viz Artist GUI they may open in the 
background. If so please bring the dialog to the front and make your settings. Make 
sure that the dialog is closed before you change anything in the Viz Artist GUI.

The buttons are disabled if there is no such dialog. Some implementations hint that a dialog is 
available even if it is not. In that case the button is not disabled but no dialog window shows.

Video Filter: The dialog window may be behind the renderer GUI after activation. Please be 
careful to close the dialog window. Otherwise the renderer and the GUI may lock up. 
Changes are effective immediately.

Parameter Name:  ButtonVideoFilter .

Type: push button.
Video Capture Pin: If available choose RGB24 or UYV as format. Other settings may not work. 
The dialog window may be behind the renderer GUI after activation. Please be careful to 
close the dialog window. Otherwise the renderer and the GUI may lock up. Changes are 
effective immediately.

Parameter Name:  ButtonVideoCapPin .

Type: push button.
Audio Filter: The dialog window may be behind the renderer GUI after activation. Please be 
careful to close the dialog window. Otherwise the renderer and the GUI may lock up. 
Changes are effective immediately.

Parameter Name:  ButtonAudioFilter .

Type: push button.
Audio Capture Pin: The dialog window may be behind the renderer GUI after activation. 
Please be careful to close the dialog window. Otherwise the renderer and the GUI may lock 
up. Changes are effective immediately.

Parameter Name:  ButtonAudioCapPin .

Type: push button.
Crossbar 1: The dialog window may be behind the renderer GUI after activation. Please be 
careful to close the dialog window. Otherwise the renderer and the GUI may lock up.

Parameter Name:  ButtonCrossbar1 .

Type: push button.
Crossbar 2: The dialog window may be behind the renderer GUI after activation. Please be 
careful to close the dialog window. Otherwise the renderer and the GUI may lock up.

Parameter Name:  ButtonCrossbar2 .

Type: push button.
TV-Tuner Video: The dialog window may be behind the renderer GUI after activation. Please 
be careful to close the dialog window. Otherwise the renderer and the GUI may lock up.

Parameter Name:  ButtonTvVideo .

Type: push button.
TV-Tuner Audio: The dialog window may be behind the renderer GUI after activation. Please 
be careful to close the dialog window. Otherwise the renderer and the GUI may lock up.

Parameter Name:  ButtonTvAudio .

Type: push button.
Video for Windows Dialogs:
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Parameters are shown if the filter supports the Video for Windows (VfW) dialog interface. Since the 
dialogs are handled by Windows and not the Viz Artist GUI they may open in the background. If so 
please bring the dialog to the front and make your settings. Make sure that the dialog is closed 
before you change anything in the Viz Artist GUI.

Buttons are disabled if there is no such dialog. Some implementations hint that a dialog is 
available even if it is not. In that case the button is not disabled but no dialog window shows.

Cap Source: If the filter supports the VfW Source dialog this button is present. It can be 
activated if the capturing is stopped otherwise the button is grayed out. The dialog window 
may be behind the renderer GUI after activation. please be careful to close the dialog 
window. otherwise the renderer and the GUI may act in a strange way. Changes are effective 
immediately.

Parameter Name:  ButtonCaptureSource .

Type: push button.
Cap Format: If the filter supports the VfW Format dialog this button is present. It can be 
activated if the capturing is stopped otherwise the button is greyed out. The dialog window 
may be behind the renderer GUI after activation. please be careful to close the dialog 
window. otherwise the renderer and the GUI may act in a strange way. Changes are effective 
immediately.

Parameter Name:  ButtonCaptureFormat .

Type: push button.
Cap Display: If the filter supports the VfW Display dialog this button is present. It can be 
activated if the capturing is stopped otherwise the button is grayed out. The dialog window 
may be behind the renderer GUI after activation. please be careful to close the dialog 
window. otherwise the renderer and the GUI may act in a strange way. Changes are effective 
immediately.

Parameter Name:  ButtonCaptureDisplay .

Type: push button.
Auto Scale Texture: If enabled the captured video is scaled according to the underlying 
geometry. Changes are effective immediately but not for already captured video.

Parameter Name:  AutoScale .

Type: toggle button. Default: on .

Border Crop Width: Crop pixels on the horizontal sides of the video. This parameter is 
shown only if Auto Scale Texture is enabled. Changes are effective immediately but not for 
already captured video.

Parameter Name:  BorderCrop_x .

Type: integer. Range: [0-0x7fff]. Default: 0.
Border Crop Height: Crop pixels on the vertical sides of the video. This parameter is shown 
only if Auto Scale Texture is enabled. Changes are effective immediately but not for already 
captured video.

Parameter Name:  BorderCrop_y .

Type: integer. Range: [0-0x7fff]. Default: 0.
Status Opened: Shows if the capture graph has been built successfully.

Parameter Name:  StatusOpened .
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Type: toggle button (show only).
Status Started: Shows if the capture graph has been started.

Parameter Name:  StatusStarted .

Type: toggle button (show only).
Status Stream Width: Shows the captured video width.

Parameter Name:  StatusStream_x .

Type: integer (show only).
Status Stream Height: Shows the captured video height.

Parameter Name:  StatusStream_y .

Type: integer (show only).
Start: Starts capturing. Feedback is given through Status Started and Status Stream Width/
Height. If capturing does not start check the Status Opened and Connected. Capturing 
cannot commence if the filter graph is not connected. Changes are effective immediately.

Parameter Name:  ButtonStart .

Type: push button.
Stop: Stops capturing. You need to do this to select the Vfw Dialog buttons. Changes are 
effective immediately.

Parameter Name:  ButtonStop .

Type: push button.
Clear: Clears the texture to opaque white. You may need to hit the button twice for the 
change to show. Changes are effective immediately.

Parameter Name:  ButtonClear .

Type: push button.

Required Software
DirectShow version 9.0c. It is strongly recommended to have a clean DirectShow installation 
to start with. Additional source filters may be added later. Find more Information at the
DirectShow of VfW compatible capture card.

Best Practices
GraphEdit is a tool from the Microsoft DirectShow SDK that allows you to visualize the default 
Filtergraph that DirectShow builds to render the Media. If you can render the Media inside 
GraphEdit it should play in Viz Engine, too. If it does not play in GraphEdit, it does not play in Viz 
Engine.

Known Limitations
Dynamic listbox for capture devices.
Handle the capture device list dynamically.
ProcAmp settings should be updated from dialog settings as well.
Query for availability in the various ProcAmps.
The Capture Device must be known to the system at application start. When using USB 
devices this means they must be connected before Viz Engine is started.



Plug-ins User Guide -  5.0

Copyright © 2022  Vizrt Page  335

1.
2.
3.

•

4.

5.

6.

7.

8.

1.
•

•

•

2.

•

3.

To Capture a Video Stream with Grabbit
Add the Rectangle geometry to the Scene Tree.
Add the Grabbit plug-in to it.
Select the capture device to work with from the Available Capture Devices list.

You should get a positive Status Opened feedback.

If you have a device that supports the capture format enumeration and the ProcAmp 
interface you get a screen similar to the following.
Set the Capture Format by using the dialogs behind the configuration buttons Video Filter, 
and so on.
Select Auto Scale Texture if you want the texture position and scaling set by this plug-in so 
that the video fills out the entire geometry. If you have selected this feature you may want to 
crop something on the horizontal or vertical sides of the video. Use the Border Crop Width 
and Border Crop Height for this effect.
Click the Start button to start capturing. You should get a positive Status Started feedback. 
In addition, the Status Stream Width and Status Stream Height should reflect the 
dimensions of the captured video.
Adjust the effect settings. You might want to experiment with them. Some parameters have 
discreet values as for example the Gamma parameter.

To Capture a Video Stream with Grabbit and a VfW Supported Device

Once you have selected the capture device it needs to be configured. You do this by clicking the 
buttons that leads to the VfW dialog windows.

Click Cap Source and Cap Format and set the parameters according to your needs.
The values you set here cannot be changed via the usual control mechanism. You 
need to pay close attention that the dialog window may open in the behind the Viz 
Artist GUI.
Make sure that each dialog window is closed before any other changes are made in the 
Viz Artist GUI.
You should get a positive Status Connected feedback. If you want to go back to 
change something here the graph must be in Stopped mode.

Select Auto Scale Texture if you want the texture position and scaling set by this plug-in so 
that the video fills out the entire geometry.

If you have selected this feature you can use the Border Crop Width and Border Crop 
Height to crop something on the horizontal or vertical sides of the video.

Click the Start button to start capturing.

Note: Do not select a device which is currently in use (either by another 
instance of this plug-in or by another application).



Note: The effect settings are highly dependent on the selected device.

Note: If you have a device which supports the VfW Dialogs interface, you should see that 
your device is tagged with VfW.
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You should get a positive Status Started feedback. In addition the Status Stream 
Width and Status Stream Height should reflect the dimensions of the captured video.

Click the Stop button to stop the capturing.
This sets it back to Stopped mode.
You should see the feedback in the Status Started toggle.
Once the capturing is stopped you can use the Clear button to set the underlying 
texture to opaque white.

GraffitiTex

The Graffiti Texture plug-in gives the ability to draw freehand on top of flat containers, such as 
rectangles. The freehand draw is created with a brush shape, used with a mouse, 6DOF device, or 
multi touch device. The plug-in can also recognize some rendered shapes, such as circles, ellipses, 
crosses, and arrows, and replaces the hand-drawn item with the recognized shape.

6DOF (6 Degrees of Freedom) events are triggered for all layers, but the Main Layer (see Layer 
Manager) has priority over the Front and Back Layers. This means that if the Front Layer scene grid 
is to be used for 6DOF, then the grid in the Front Layer must be set to active, and the grid in the 
Main Layer must to be set to inactive. If there is no grid defined in any of the three Layers, an 
orthogonal XY 2D grid is used (see Grid Tool-bar).

The plug-in can either work in combination with Viz Engine’s multi-texturing technology or can 
add a standalone texture.

There are two graffiti plug-ins; the scene plug-in Graffiti which is used globally for the scene, and 
this one which is applied on the container level.

This page contains the following topics and procedures:

GraffitiTex Properties
To Create a Container Level Graffiti Effect

GraffitiTex Properties
Active: Enables/disables drawing.
Multi Telestration: Allows handling of multiple touch events for multi-touch devices. Some 
devices incorporate a pressure factor; this influences the width of the brush:

Pressure Min %: Sets the minimum width of the brush.
Pressure Max %: Sets the maximum width of the brush.

I6DOF: Specifies whether input comes from mouse of 6DOF.
Transparent Base: Specifies whether the base color of the container is the background of the 
rendered brush or whether the brush is drawn on a transparent background.
Texture Width, Texture Height: Sets dimensions of the texture used for drawing canvas.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Texture
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Brush Type: Selects color or eraser brush.
Brush Image: Determines the shape of the brush using an image. If empty, a round brush is 
used.
Brush Width: Sets the width of the brush in pixels. Visible only if the color brush is selected.
Eraser Brush Width: Sets the width of the eraser in pixels. Visible only if the eraser brush is 
selected.
Brush Color: Selects the color of the brush.
Recognize Shapes: Toggles shape recognition mode on or off.

Recognize Ellipse: Specifies whether shape recognition tries to recognize ellipse 
shape.
Recognize Circle: Specifies whether shape recognition tries to recognize circle shape.
Recognize Cross: Specifies whether shape recognition tries to recognize cross shape.
Shape Delay: Determines the number of frames to wait from mouse up before trying 
to recognize shapes.
Draw Arrow: Specifies whether non-recognizable shapes are converted to an arrow.
Arrow Length: Sets the length of an arrow head.
Arrow Width: Sets the width of an arrow head.
Circle Rad: Determines the radius of the circle replacing a recognized circle. If zero, 
the radius of the recognized circle is used.
Cross Width: Determines the width of the cross replacing the recognized cross shape. 
If zero, the width of the recognized cross shape is used.

Enable Undo After Clear: Enables undo after the Clear button has been used.
Clear (button): Clears the canvas.
Undo (button): Undoes an action.

To Create a Container Level Graffiti Effect

First, add the plug-in to the container and set the plug-in properties.
Then set Viz Artist in On Air Mode, and start drawing.

Image Clip

The Image Clip plug-in is designed to play back a sequence of still images (e.g. TGA or TIFF) rather 
than playing a movie file. It also supports alpha channel and various play modes (looping, swing, 
etc). The plug-in loads all images to RAM, then loads only one image at a time to texture memory. 
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The download time is almost linear to the size of each frame. Preparation for this plug-in should 
be uncomplicated as most video applications has support for saving out TIFF. Since it plays the 
sequence from memory, one obvious benefit is that once loaded into memory it does not access 
the hard drive at all. So if it is needed to play back ten different sequences at once, ImageClip is 
pretty much the only solution. It is ideal for looping small animations such as logos. The drawback 
is that it consumes system memory.

Remember to keep track of how much memory each sequence needs, to avoid running out of 
memory on the Viz Engine machine. Running low on memory makes the system start caching parts 
of memory to the hard drive and it may not play the sequence and graphics in real-time.

Image clip should not be used with very large clips in Continuous and Array mode. Since all images 
are loaded into memory a large number of images or a large image size would require large 
amounts of memory.

Memory can be calculated as follows:

Number of images * Image width * Image height * 3 (or 4 when using alpha)
The use of Thread mode solves the memory issue, but it takes longer to request a frame. 
Therefore it should be used only in a slow motion image clip.

Images for an image sequence should be placed in specific folders. For example if you out many 
flag image sequences, you would have a separate folder for each flag image sequence. Make sure 
that the images are named sequentially (e.g. england001.tif, england002.tif, england003.tif etc).

This page contains the following topics and procedures:

Image Clip Properties
To Add an Image Clip

Image Clip Properties
Image: Sets the image path and the first image you would like to use in the animation. Do 
not use clip names with numbers (except the counter (e.g. 000, 001, 002, etc.)).
Play Mode: Sets the play mode:

Once
Loop
Swing
Animation
Anim-Dissolve

Reverse: Reverses the animation (not in Animation play mode).

Note: This plug-in is located in: Plugins -> Container plug-ins -> Texture

Known Issue: If the Image Clip plug-in is used to display compressed image sequences like
.vbn, please be aware that any image operation like resizing (keep under option) or format 
conversations (for example, to luminance) will fail because of the missing original data. 
This is a known limitation.
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Animation Position: Sets the animation position (e.g. where to start and stop the animation). 
The position is a counter for the number of images in the folder referenced by the Image 
setting. This setting is enabled when Play Mode is set to Animation.
Play Speed: Sets the speed of the animation.
Advanced: Enables the advanced settings (see below).
Time Mode: Enables time specific settings.
Stand Alone Image: Enables the same clip to be played in different speeds.
First Image: Defines the first image of the animation.
Nof Image: Defines the number of images, relative to the First Image, that should be part of 
the animation.
Geo Ref:

Crop: Crops the image (by percentage) from the left, right, bottom and top side.
Scale By: Enables the scale setting.

Scale: Scales all images to the closest power of two. When not selected, automatic 
texture coordinates are applied so the image fits the texture.

Keep Under: Forces the image size. For example if you have selected 64, the image is 
trimmed to the size 64 x 64.
Base Path:
Format:
Weather:
Blend Images:

Dissolve Speed:
Control Texture Map:
Memory Type: Sets the memory type.

Continuous: Uses one big chunk of memory to store all images.
Array: Uses divided chunks of memory to store all images.
Thread: Loads only requested frame on-the-fly, with [n] frames loading time limit.

Mapping:
Play (button): Plays the animation.
Stop (button): Stops the animation.
Reinitialize (button): Reinitializes all settings.

To Add an Image Clip
Add a Container to the Scene Tree.
Add the Image Clip plug-in to it.

In the Image Clip properties click the   (Browse) button to locate the folder that has the 
required images.
Select the first image in the sequence.
Click OK. The image sequence now loads into the ImageClip plug-in, and is visible in the 
scene.

Info: When changing the Crop or Scale By parameters, Reinitialization is needed.
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Click Play to test the image sequence. If you change the image sequence and you need to 
reload it, click the Reinitialize button.
Change the Play Mode to Loop to play the image sequence continuously. The image 
sequence starts playing automatically.
Change the Play Mode to Animation to animate the image sequence frame position to 
control the sequence within the Stage Editor. The image sequence now stops playing and a 
new property is revealed that is called Animation Position. This refers to the frame number 
that is currently shown for the image sequence.
Animate the Animation Position value.The Animation Position maximum value is restricted 
to the number of images.
Another possibility is to create a file with a .vln extension. This file includes the base path 
and also the names of the images to load. In this case the images must not have a counter 
number in their filename. You can handle this file as an ordinary text file.
Load the .vln file instead of loading an image file located in a directory.
Example:

BASE_PATH 'C:/clip/images' {  'radar_200504110800.png' 2005_04_11_10:00  
'radar_200504110815.png' 2005_04_11_10:15  'radar_200504110830.png' 2005_04_11_10:30  
'radar_200504110845.png' 2005_04_11_10:45  'radar_200504110900.png' 2005_04_11_11:00  
'radar_200504110915.png' 2005_04_11_11:15  'radar_200504110930.png' 2005_04_11_11:30  
'radar_200504110945.png' 2005_04_11_11:45 }

See Also

MoViz
SoftClip

ImageProportion

The ImageProportion plug-in maps an image to a container, maintaining the correct aspect ratio 
and allowing some constraints, such as whether the entire image should be visible, or the entire 
container should be filled.

The plug-in takes into account the container geometry's dimensions, which means it needs a 
geometry other than the standard image geometry, as the image geometry automatically takes the 
proportions of the image itself.

Note: Viz Engine does not interpret between Key Frames, so if you choose to slow down an 
animation then the motion is not smooth.



Note: This plug-in is obsolete as the functionality is now within Image Channels / Super 
Channels.



Note: This plug-in is located in: Plugins -> Container plug-ins -> Texture
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ImageProportion Properties
Border Color: Adds a border color to the container.
Show Entire Image: Determines whether the entire image is shown.
Allow Stretch: Permits stretching the image to fill the container.
Auto convert to RGBA: Ensures border colors and transparency can be applied independent 
of the texture format when enabled. This is an expensive operation and causes jittering 
when an image with another format is put on the same container during playout.

Light Blur

The Light Blur plug-in allows the user to configure and create a light blurred image.

Light Blur Properties

Width and Height: Sets the width and height of the blurred light. Available options are 2  to 

2048 .

Format: Sets the image format. Options are:
RGB
RGBA
Alpha
Luminance
Luminance Alpha

Save: Saves the blur as an image.
X and Y (%): Sets the position of the blur on the X and Y axis (50% places the blur at the 
origin).
Spread (%): Sets the spread of the blur.
Start: Sets the start color of the blur.
End: Sets the end color of the blur.

IMPORTANT! The light blur functionality is now a built in feature of the Viz Artist/Engine 
core. For future use it is therefore recommended to use the Dynamic Texture Media Asset.



Note: This plug-in is located in: Plugins -> Container plug-ins -> Texture



Plug-ins User Guide -  5.0

Copyright © 2022  Vizrt Page  342

•

•

•

•

MoViz

With the MoViz plug-in media files or streams can be played inside the Viz Engine.

MoViz is not a QuickTime player or an AVI player. It uses the Microsoft DirectShow Filter Graph 
framework to play the media files, which means it can play both types, but only certain installed 
Filter Graphs (some of the QuickTime and some AVI).

MoViz is not natively QuickTime, it uses the AVI wrappers and filters for QuickTime and AVIs. This 
means that not all QuickTime codecs can be used, only the ones that are supported within DirectX 
wrappers and filters.

MoViz Properties

Clip URI: Click the Browse button ( ) to load clips from the file system (or enter the 
location directly). It takes the form of a valid URI (e.g. http://... or mms://...). If the 
parameter is changed and the plug-in is already started it stops the playback before loading 
a new clip. Changes are effective immediately.

Clip URI Stereo: Path to Clip that is loaded for the right eye camera in a stereo configuration 
with Stereo Mode = Right Eye. You can load clips from the file system by using 
the Browse button, or by typing the path location directly. It takes the form of a valid URI. 
(e.g. http://... or mms://...). If you change the parameter after starting the plug-in, it stops 
the playback before loading the new clip. Changes are effective immediately.
Autoplay: Sets the automatic start of the clip after it has loaded, to On or Off. Changes are 
effective immediately (Default is off).
Loop Clip: Sets looped playback to On or Off. If the clip position is at the clip out position or 
EOF it rewinds to the clip in position. Changes are effective for the next EOF, clip out 

position (Default is Off ).

Note: Throughout this plug-in documentation, media file and media stream is referred to 
as media and may be used interchangeably unless stated otherwise.



Note: This plug-in is located in: Plugins -> Container plug-ins -> Texture

Warning: Always make sure to install the required codecs for used media files. Missing 
codecs can lead to engine crashes.



IMPORTANT! All video clips from the file system should be stored locally on the D:\
drive of the machine that is used to play out the graphics. Remember to save the clip 
locally on the client machines with preview (e.g. Viz Trio) and use the same D:\ drive 
so that the clip can be seen in preview.
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Sync to Video Counter: Enables or disables the use of the system retrace counter. If enabled, 
the clip is played back with the speed of Viz's internal retrace counter. This is the tick count 
of the SDI output. If disabled, the clip plays back at the speed of its own internal clock.
Clip Duration (ms): Shows the duration of the clip in milliseconds (read only). This parameter 
makes only sense with media that supports this kind of information.
Clip Position (ms): Gives the current position of the clip in milliseconds. When in pause mode 
this parameter may be changed to seek to the gives time. Do not change this parameter 
when not in pause mode. The position may be changed between Clip Position IN and Clip 
Position OUT. This parameter makes only sense with media that supports this kind of 
information. Changes are effective immediately.
Clip Position IN (ms): Gives the first frame where the clip should start in milliseconds. This 
parameter makes only sense with media that supports this kind of information. Changes are 
effective immediately.
Clip Position OUT (ms): Gives the last frame where the clip should stop in milliseconds. This 
parameter makes only sense with media that supports this kind of information. Changes are 
effective immediately.
Video Device Format: Selects a video format for rendering. Changes are effective at load 
time.

None: Does not render the video portion.
RGB24: Delivers the video portion to Viz Artist/Engine with the RGB24 format. This 
format uses eight bits per Red, Green and Blue component, hence the name RGB24.
ARGB32: Delivers the video portion to Viz Artist/Engine with the ARGB32 format. This 
format uses eight bits per Red, Green and Blue component and in addition eight bits 
for Alpha (8-bits * 4 components), hence the name ARGB32 indicating RGB with Alpha. 
This format is often referred to as RGBA.

Force Opaque: (ARGB32 only) Sets the alpha value to 100% opaque (if required) if the clip 
has an alpha channel. Changes are effective for each frame delivered.
Auto Scale Texture: Scales captured video according to underlying geometry when 
enabled.Changes are effective immediately but not for already delivered video.

Border Crop Width: Crops pixels on the horizontal sides of the video. Changes are 
effective immediately but not for already delivered video.
Border Crop Height: Crops pixels on the vertical sides of the video. Changes are 
effective immediately but not for already delivered video.

Audio Device/Format: Selects which audio device/format to use for rendering. Changes are 

effective immediately but not for already delivered audio. For performance reasons,  None  is 

the recommended setting.
None: Does not render the audio portion.
Default Device: Renders the audio portion using the default DirectShow renderer.

Status Loaded: Shows if the clip has loaded.
Status EOF: Shows if the clip is at EndOfFile. Status EOF allows user defined actions upon 
registering for change requests in a script. Whenever a change in the 

parameter  StatusEof  is happening and a Viz System Shared Memory (SHM) variable 

named  MoViz[A,B]_eof  exists, this variable is set to 1  when Status EOF is  On , and to 0

when Status EOF is  Off . The variable’s parameter  A  is the hexadecimal value of the scene 
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ID in uppercase A-F range. The variable’s parameter  B  is the hexadecimal value of 

the  Container ID  in uppercase A-F range.

Status Clip Width: Shows the video width.
Status Clip Height: Shows the video height.
Status Video: Shows if the clip has a usable video component.
Status Audio: Shows if the clip has a usable audio component.
Seek Timeout: Specifies the timeout for seeking to a position in the movie file. Higher values 
can prevent jump back to the expected position when clip playback takes longer to start 
then expected. However, the playback time may not be as exact.
Eject: Unloads the clip and destroy the graph. Changes are effective immediately.
Load: Loads the given clip and builds the graph. Changes are effective immediately.
Rewind: Rewinds the clip to the start, when supported. Changes are effective immediately.
Stop: Puts the graph in stop mode. Changes are effective immediately.
Play: Puts the graph in play mode (i.e. start playback). Changes are effective immediately.
Pause: Puts the graph in pause mode. Changes are effective immediately.
Play From Start: Rewinds the clip to the start before playback. Changes are effective 
immediately.
Clear: Clears the texture to opaque white.

See Also

Image Clip
SoftClip

Noise

The Noise plug-in allows the user to configure and create a noise image.

Note: Since Viz Engine 3.8.1, this is supported for MoViz Version 2.20.0 onwards.

Note: Moviz handles videos with alpha, but the codecs in use must provide a valid 
ARGB32 stream and Containers you want visible should use the KEY Function, 
otherwise the alpha channel is blank, making the whole video totally transparent. 
See also Advanced Issues with Video Codecs in the Viz Artist User Guide.



IMPORTANT! The noise functionality is now a built in feature of the Viz Artist/Engine core. 
For future use it is therefore recommended to use the Dynamic Texture Media Asset.



Note: This plug-in is located in: Plugins -> Container plug-ins -> Texture

http://documentation.vizrt.com/viz-artist


Plug-ins User Guide -  5.0

Copyright © 2022  Vizrt Page  345

•

•

•

•

•
•
•
•
•
•

•

Noise Properties

Width and Height: Sets the width and height of the noise. Available options are 2  to 2048 .

Format: Sets the image format. Available options are RGB, RGBA, Alpha, Luminance and 
Luminance Alpha.
Save (button): Saves the noise as an image.

Factor X and Y: Sets the noise factor on the X and Y axis (range is from 0.000  to 

1000.000 ).

Turbulence 1, 2 and 3: Sets the turbulence of the noise.
Frequency: Sets the frequency of the noise.
Exponent: Sets the exponent of the noise.
Fg: Sets the foreground color.
Bg: Sets the background color.
Wave, Clouds, Marble and Noise (buttons): Allows the user to select between four different 
presets.
Randomize (button): Sets random factor, turbulence and frequency. Randomize works 
together with the Wave, Clouds, Marble and Noise selections.

SoftClip

The SoftClip plug-in is used for playing video clips projected on a texture, and supports AVI files 
only. This format supports RGB and RGBA (alpha channel).

In its simplest form, the SoftClip plug-in can exist on an empty container to play back a video clip 
in Viz Artist/Engine. Other plug-ins can be mixed with SoftClip to obtain different results. For 
example you can apply a SoftClip plug-in to a Sphere and add a Material to affect the overall 
shape, color and shading of the video clip.

With SoftClip you are able to control the video clip within the stage, unlike with the Live 
Video Media Asset method. The video clip size can also be whatever you decide, however, it is 
recommended that you keep the dimensions in multiples of 8 (e.g. 128x128 or 256x512) for 
performance purposes.

Use of the SoftClip plug-in might have an affect on performance and quality, hence, it is 
recommended to use the Performance Editor when working with the SoftClip plug-in.

IMPORTANT! Viz Engine keeps all designer, operator and automation loaded scenes and 
plug-ins in memory. As a consequence, if 30 different templates that load 30 different 
scenes are loaded, that each has a single SoftClip plug-in on it, Viz Engine has thirty 
SoftClip plug-ins with 30 threads activated in memory. If every plug-in has specified that it 
should have ten preloaded frames, then Viz Engine has 300 uncompressed decoded 
frames preloaded in memory. This can take a substantial amount of memory, and the 
combination of having that much data loaded and that many threads running is likely to 
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This page contains the following topics and procedures:

SoftClip Properties
To Use SoftClip

SoftClip Properties
Clip file: Use this function to browse for the clip to be played out.

Clip length (frames): Shows the number of frames for the clip.
Live Play: Makes sure that the clip is played and synchronized to the frame rate of the Viz 
Engine. This is set in the Output Format section of Viz Configuration (see the Configuring 
Viz section of the Viz Engine Administrator Guide). Disable the Live Play to allow the clip 
playback to be Key Frame animated.
Play mode:

Synchronized: Runs the clip synchronized with the scene playback. This is set in 
the Output Format section of Viz Configuration.
Frames per second: Adjusts for different speeds, set in the next parameter.

Frame number: Enables the frame numbers to be manually animated. This is an alternative 

to playing the whole clip (available when Live Play is set to Off ).

Frames per second: Sets the frame rate (available when Play mode is Frames per second.

Loop Video: Loops the video automatically when enabled.
Use decode thread: Enables split processing of the clip evenly between the machine’s 

processors. It is recommended to have this  On  (default). On multi-processor machines this 

gains performance, but threading makes scheduling less predictable and may cause the Viz 
Engine frame rate to be less stable on a single CPU machine.

Preload frame count: Works as a buffer to enable smoother playback of the clip. If using Live 
Play, the Preload frame count can help reducing spike-loads and avoid dropped frames.

affect performance. This workflow situation has to be taken into consideration when 
designing and testing the design. Therefore, unloading scenes and cleaning up the Viz 
Engine renderer, a function in many Vizrt control client programs, should be used.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Texture

Note: It is important that all video clips are stored locally on the D: drive of the 
machine used to play out the graphics. Remember to save the clip locally on the 
client machines with preview (e.g. Viz Trio) and use the same D: drive so that the clip 
can be seen in preview.



Note: There is no frame interpolation done when you change the frame rate from the 
default specified.



Tip: If Priority is set to High , for best results set Use Decode Thread to off .

http://documentation.vizrt.com/viz-engine
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Frame skipping: With frame skipping enabled, Viz Engine skips frames if it needs, to try and 
maintain real-time graphics playback. With frame skipping disabled, the clip plays out in full, 
as fast as possible but does not try to maintain real-time playback. (Graphics stagger on the 
output if the renderer drops out of real-time.) When using the video card’s ringbuffer 
functionality the SoftClip frame skipping should be turned off.
Force Opaque: Fills the alpha channel, thus making the video completely opaque. When 
running videos where the codec leaves the alpha channel blank, the video rendering may 
become completely transparent. 
Preferred CPU: Enables the User to specify a particular processor to handle video play out. 
The recommended CPU value is based on the specifications of the running machine:

If it is a quad core processor the CPU value can be set to 4 , but to avoid errors it is 

recommended to set the value to 2 .

If it is a machine with lower specifications then the recommended value is 1 .

The value -1  enables the machine operating system to select which CPU to use.

Priority: Sets the priority of drawing the video to a custom level in Viz Engine giving it more 
or less processor priority.
Clear before playback: Clears the image before playback when set to On. Live Play must be 
set to Synchronized and the Frame number to be shown from the clip is smaller than the 
current frame number +1 (available when Live Play is set to Off).
Auto scale texture: Scales the video clip to the size of the underlying rectangle on which the 
video is placed in the container.
Border crop: Determines how much of the border to crop when using the auto scaling over. 
Due to bilinear texture interpolation, you might see that color from the underlying texture is 
bleeding into the video texture area. Use this parameter to crop away the affected border 
pixels.

To Use SoftClip
Add a group container to the Scene Tree.
Add the SoftClip plug-in.
Open the SoftClip editor.
Click the Browse... button to select and load a clip. Loading a clip makes it visible in the 
scene. By default, the SoftClip plug-in has the Live Play and Loop video settings enabled, 
hence, the clip instantly starts playing (and looping) in the render window.
Optional: Enable the Use decode thread option.
Disable the Live Play option to enable the Frame number setting.
Animate the Frame number setting (e.g. from frame ten to 30).

See Also

Image Clip
MoViz

Note: Viz Engine does not interpret between Key Frames, so if you choose to slow 
down an animation then the motion is not smooth.
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Tex Component

The Tex Component plug-in selects which component of a texture is used for the texture mapping 
process.

Tex Component Properties
Use Component: Determines whether to use alpha, color, or both.

Alpha: Uses only the alpha of the texture. The RGB color of the texture is set to a 
constant color specified by the Constant Color parameter.
Color: Uses only the RGB color of the texture. The alpha is set to a constant value 
specified by the Constant Alpha parameter.
Alpha+Color: Uses both the alpha and the RGB color of the texture (default setting).

Constant Color: Sets the constant RGB color of the texture when Alpha is selected.
Constant Alpha: Sets the constant alpha value when Color is selected.

VLC

The VLC plug-in is a media player plug-in that makes use of VLC media player technology. VLC 
should be placed on a group container for playing the media over a rectangle or on a geometry 
object, as it is a function plug-in. The plug-in requires a VLC media player 3.0.11 for 64-bit 
Windows to be installed on the machine.

Download VLC media player 3.0.11 for 64-bit Windows from videolan.org then put plugins and lua
folders in <VizDirectory>. See more information at <Viz4Directory>\VLC_README.rtf

VLC Properties
Media: Name of the media to be played. It can be a file supported by VLC player.

Loop: Plays media on repeat when set to  On .

Note: This plug-in is a legacy plug-in and the functionality is now incorporated into the 
Texture Editor.



Note: This plug-in is located in: Plugins -> Container plug-ins -> Texture

Note: Do not apply a texture to a VLC plug-in container.

http://videolan.org
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Audio Enabled: Plays sound from the selected media during playback when set to  On . When 

set to  Off , the sound is muted.

Volume: Controls the volume level if Audio is enabled.
Logging: Writes log information into a file named vlc.log, residing in the %ProgramData%
\vizrt\VizEngine folder.
Set Clip Time: Seeks the playing or paused clip to specified time (in milliseconds). It is not 
possible on a clip with some video codec.

Play on Load: Plays the clip automatically when loading the scene when set to  On . When set 

to  Off , the clip does not play until clicking the Play button.

Use Proxy: Determines whether to use a proxy. When set to  On , additional parameters are 

enabled:
Proxy Host: The name of the proxy machine.
Proxy Port: Proxy port, as defined on the proxy machine.
Proxy User: User name with permission to access the network via the proxy machine.
Proxy Password: Password for the proxy user.

Play: Plays the media from the beginning.
Stop: Stops playing the media. The current frame is displayed. It is not possible to resume 
playing the media after has been stopped.
Pause: Pauses the playing clip at the current frame.
Continue: Continues playing the media from the current frame after it was paused.

4.4.16 Ticker
The following Container plug-ins are located in the Ticker folder:

Scroller Action

Scroller Action

The Scroller Action plug-in makes it possible to design scrolling tickers that trigger actions when 
scroller items are played out. Actions can be triggered both before and after reading the next item 
from the input source, as well as delaying the reading of the next item a certain number of frames.

A scrolling carousel scene must have a Scroller plug-in attached to a container and be configured 
to receive items from an external source. In most cases this external source is Viz Ticker’s Ticker 
Service running on the same machine. During scene design, it is useful to use a debugging syntax 
to specify a fake source that refers to graphics templates located directly in the scene.

Info: The VLC player is not a replacement for the Matrox clip player!

Note: This plug-in is located in: Plugins -> Container plug-ins -> Ticker
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This page contains the following topics and procedures:

Scroller Action Properties
Controlling the Progression
To Control the Progression

Scroller Action Properties
Delay (Frames): Adds a delay after the current item is fully inside the scroller, so that 
insertion of the next item is postponed the given number of frames.
On Inside: Defines if the item should trigger anything after it fully enters the scroller.

Action
None: Does nothing. 
Animate: Allows a director to be triggered and defines the start and stop point 
of the director animation.

Director: Defines the director to run when On Inside is triggered.
From Tag: Defines where to start the director animation.
To Tag: Defines where to stop the director animation.

After Delay: Defines if the item should trigger anything after the scroller has finished 
delaying the next item.

Action
None: Does nothing. 
Animate: Allows a director to be triggered and defines the start and stop point 
of the director animation.

Director: Defines the director to run when After Delay is triggered.
From Tag: Defines where to start the director animation.
To Tag: Defines where to stop the director animation.
The source syntax (separator) (text) creates a scroller showing an endless stream of 
items alternating between a separator and a text graphics design. The scroller 
searches through the scene tree for containers named separator and text, use the 
graphics template found there, and then copies them to create the item instances that 
are being scrolled.

Controlling the Progression
A typical example of when the Scroller Action plug-in is necessary, is when text messages (SMS) 
should scroll into the screen, animate to a halt, wait a few seconds, and then restore the scroll 
speed whenever new text messages are available.

This paragraph provides guidance on how to create an upwards scroll to show text messages, 
where the scroller should pause for a while after playing out each message to the screen. The 
scroller should not immediately follow the text design with the next separator design. Instead, the 
text design should enter the screen fully, and then the scroller should smoothly slow down to a 
halt. The scroller should wait a given number of frames before slowly starting the scroller again 
and pushing the next separator item onto the screen. If an external source is used, the scroller 
should not start again until there is a new item available from the source.
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To Control the Progression

Create a director named  scroller . This director animates the scroller speed.

On this director, create a stop point, and call it  stop .

Set the stop scroll speed to  0 .

Create another stop point, and call it  play.
Set the play scroll speed to a suitable speed. The actual names that are used here are not 
important, but they must match the names specified in step 8.
Add the Scroller Action plug-in to the text template top node (the container holding 
the Control Object plug-in).
In the Scroller Action plug-in editor, define the Delay frame count. This setting adds a delay 
after the current item, so that the insertion of the next item is postponed the given number 
of frames. The delay counter starts to count from the time the previous item has fully 
entered the screen, which is a few frames after it would normally try to insert a new item. 

When delay is set to  0 , the scroller performs as normal, and does not wait until the 

previous item has fully entered the scroller before inserting a new item. The delay parameter 
specifies the minimum amount of time that must pass between pushing out the current 
item, which is based on the template graphics with the Scroller Action plug-in, and the next 
item. The actual amount of time might be greater if there are no new items available after 
the delay frame count has expired. Setting this parameter does not affect the speed of the 
scroller, it only delays the inserting of the next item, in effect increasing the resulting gap 
between the previous item and the next. The default value of the delay frame count 

parameter is 0 , which means that the scroller attempts to insert the next item immediately 

after the previous item.
In the Scroller Action plug-in editor, click the On Inside: action 
Animate button. When animate is selected, three additional on inside related parameters 
become available:

On Inside: director (default value is scroller)
On Inside: from tag (default value is play)
On Inside: to tag (default value is stop)
The parameters should remain at the default values. When the current item has fully 
entered the screen, the scroller starts to animate the scroller director from a play tag 
to a stop tag. The rules of the GOTO_TRIO director command defines this behavior.

In the Scroller Action plug-in editor, click the After Delay: action 
Animate button. When animate is selected, three additional after delay related parameters 
become available:

After Delay: director (default value is  scroller )

After Delay: from tag (default value is  stop )

After delay: to tag (default value is  play )

The parameters should remain at the default values. When the delay frame count 
expires, the scroller starts to animate the scroller director from a stop tag to 
a play tag. The rules of the GOTO_TRIO director command defines this behavior.

See Also

Transition Logic section of the Viz Artist User Guide.

http://documentation.vizrt.com/viz-artist


Plug-ins User Guide -  5.0

Copyright © 2022  Vizrt Page  352

•
•

•
•

•
•

•
•
•
•
•

1.

4.4.17 Time
The following Container plug-ins are located in the Time folder:

Analog Watch
Clock Rotation

Analog Watch

The Analog Watch plug-in lets you create a real-time animated clock of objects.

This page contains the following topics and procedures:

Analog Watch Properties
To Create an Analog Watch

Analog Watch Properties
Mode: Sets the mode. Available options are Hour24, Hour12, Minute, Second and Off.
Smooth: Ensures the clock hands rotate smoothly. Check this button to enable smooth 
rotation. Hour hands always rotate smoothly, so this switch is inactive if the plug-in is set to 
Hour24 or Hour12 mode.
Offset: Changes the rotation offset. 1200 usually is equal to a rotation of 0 degrees. 

1 hour in Hour24 mode: 15 degrees.
1 hour in Hour12 mode: 30 degrees.
1 minute in Minute mode: 6 degrees.
1 second in Second mode: 6 degrees.

To Create an Analog Watch

Add a Circle geometry to the scene tree, add material to it, and name it Clock.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Time
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Open the Circle editor and set scaling to  2.0 .

Add three Arrow geometries as Sub-Containers of the Clock container, add material to them, 
and name the first Hours, the second Minutes, and the third as Seconds.
Open the Arrow editor for Hours and set the following properties:

Style1 to Flat .

Width and Arrow Width to 4.0 .

Percent to 30.0 .

Open the Arrow editor for Minutes and set the following properties:

Style1 to Flat .

Width and Arrow Width to 3.0 .

Percent to 40.0 .

Open the Arrow editor for Seconds and set the following properties:

Style1 to Flat .

Width and Arrow Width to 2.0 .

Percent to 50.0 .

Add the Analog Watch plug-in to the Hours, Minutes and Seconds containers.
Open the Analog Watch editor for the Hours container and set it to Hour24 or Hour12.
Open the Analog Watch editor for the Minutes container and set it to Minute.
Open the Analog Watch editor for the Seconds container and set it to Second.

See Also

Clock Rotation
System Time

Clock Rotation

Animates any object as a rotating clock.

Clock Rotation Properties
Clock Unit: Sets the units for the rotation of the object. Available options are Seconds, 
Minutes and Hours.
Rotation axis: Sets the axis for the rotation of the object. Available options are X, Y and Z.
Motion type: Sets the motion type for the rotated object. Digital shows a ticking motion, and 
Chrono a smooth motion.

Reverse: Sets the direction of the rotation. When set to Off , the rotation is clockwise, and 

when set to On , the rotation is counter-clockwise.

See Also

Note: This plug-in is located in: Plugins -> Container plug-ins -> Tools
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Analog Watch
System Time

4.4.18 Tools
The following Container plug-ins are located in the Tools folder:

Advanced Counter
Align Text by Character
Autofollow
Autorotate
Bounding Actions
Cloner
Colorize
Counter
DVE Follow
Heartbeat
Hide On Empty
Image Link
Jack
Level of Detail
Magnify
Match It
Max Size
Max Size Lines
Object Zoom
Omo
Parliament
PathFinder
Rotations Order
Slide Show
System Time
Temo
Text Auto Scale
TextBG
Text Link
Text Parameters
Texture Fit
TransitionLayers
VCF Parameter
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Advanced Counter

The Advanced Counter plug-in allows you to easily create an animated counting sequence. It shows 
values with decimals and it has the possibility to create a user defined format mask. Furthermore it 
can have prefixed values.

This page contains the following topics and procedures:

Advanced Counter Properties
To Create an Advanced Counter

Advanced Counter Properties
Use Integers: Enables the use of integers only.
Value (Dec.), Value (Int.): Sets the current value of the counter. Animate this value to create 
the counting sequence.
Leading blanks: Selects what the counter does with leading blanks. They can either 
be Cut away or put in as Blank, asterisk, hash, dot or zeros.
Force prefix: Enables both positive and negative values to have a prefix, not only negative 
values as is the default (+/-).
Delete unnecessary commas: Removes superfluous commas when a specified format mask 
has more commas than the number needs. If for instance the 

mask  $###,###,###,###.##  is defined, and the number  4120.37  is entered, it is output 

as $,,4,120.37. If by enabling this option, the number gets a correct format: $4,120.37.
Decimal separator: Switches the decimal separator between point and comma.
Format mask: Allows format mask definition. Each hash symbolizes an item of the total 
number. To alter, add or remove hashes. You can also add constant values, for example DM, 
NOK etc.
Initialize: Starts the counter.

To Create an Advanced Counter
Add a group container to the scene tree.
Add a font and material to the group container.
Add the Advanced Counter plug-in to the group container.
Open the Advanced Counter editor and animate the parameters.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Tools
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Align Text by Character

The Align Text by Character plug-in aligns the text content by centering the text in each line to the 
specified token. If the token is found multiple times on the same line, only the first one is used.

Properties
Token: The character to be used as the token to center the text.

Example

Text aligned on the colon (:) character:

Autofollow

The Autofollow plug-in connects one object with another. This object is from then on dependent 
on the connected plug-in. Depending on the axis of your Object to follow, the bounding-box grows 
in the reverse direction.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Tools

Note: This plug-in only works with the Text plug-in in the Viz Engine Render Pipeline.
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If you want to follow for example a text object, which writes from left to right, you have to set the 
axis of your text object to the left side, because the bounding box grows to the right side. You can 
select for the following object either one axis (X,Y,Z) or two (XY, XZ, YZ).

Drag the Autofollow plug-in over the object container which should be dependent. It automatically 
follows the previous object in the scene tree. You may also set this to be the first object or select 
one specific object by adding it to the object placeholder exposed when selecting the Other 
option.

Autofollow Properties
X Previous Center: Defines the alignment of your related object.
Default Distance (Min): Allows you to set a distance from the object to the related one. This 
is a relative value that is dependent on the size of the related container.
Progress (%): Allows you to animate the related object. In this case you can set a default 
distance value and a maximum distance. What you need to do is just set Key Frames on the 
progress. At the beginning of the animation you can for example have 100%, and at the end 
0%. The object runs from the maximum to the default distance value.
Maximum Distance: Allows you to set the maximum distance from the object to the related 
one. This is an absolute value, which is independent of the size of the related container.
Reference Container: With these buttons (PREV, FIRST, OTHER) you can change the related 
object. The default preference is ‘Previous’, where the previous container in the scene-tree is 
selected. If you choose Other, you have to drag your wished reference-container onto the 
empty button, which shows when you select Other.
Direction: Allows you to choose in which axes there should be a dependency on. Options 
are: X, Y, Z, XY, XZ or YZ.
Follow Negative: If you select this feature, all numerical values are negated. For example 
when you change ‘Default Distance (Min)’ to a positive value your object is positioned in 
negative direction of the selected axis or axes.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Tools
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Ignore hidden containers: If the reference container is hidden, search for the next visible 
container depending on the reference container setting (only if set to Previous or First).
Ignore default distance on hide: Allows you to hide the reference container if you do not 
want the default distance to be considered. In this case, it is null. If you make the reference 
container visible, the default distance shows again.
X Local Center: Allows you to select your alignment for the local center in X-direction.

Autorotate

The Autorotate plug-in rotates a container continuously around one of its axes.

Autorotate Properties
Axis: Selects the rotation axis either X, Y or Z.
Direction: Selects the direction of the rotation, either Right or Left.
Velocity: Sets the speed of the rotation. The unit is degrees per frame.
Ease In (frames): Sets the number of frames the object uses to accelerate smoothly from no 
motion to the speed set in Velocity.
Ease Out (frames): Sets the number of frames the object uses to retard from the rotation 
speed to a stop.
Starting Angle: Sets the angle from the objects current position, from which the object is to 
start from.
Ping Pong: Enables a ping pong motion where the object rotates forward and backward 
between two angles on the axis.
Ping Pong Angle 1: Sets angle 1 for Ping Pong Mode.
Ping Pong Angle 2: Sets angle 2 for Ping Pong Mode.
Ease in: Initializes the rotation from the starting angle selected and with the Ease in value 
selected.
Ease out: Stops the rotation. The stop motion is influenced by the Ease out parameter.
Continue: Starts the rotation from the point where it was halted. The value of Ease in is 
disregarded.
Halt: Stops the rotation without regard to Ease out.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Tools
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Bounding Actions

The Bounding Actions plug-in enables you to run Viz Artist/Engine actions depending on the size 
of the bounding box.

This page contains the following topics and procedures:

Bounding Actions Properties
Syntax

To Use Bounding Actions

Bounding Actions Properties
Text box: Executes the command every time the bounding box changes.
Scale X, Y and Z: Applies a scaling to the values %dx %dy %dz.
Offset X, Y and Z: Adds an offset to the values %dx %dy %dz.

Syntax

%dx: Substitutes the width of the bounding box.
%dy: Substitutes the height of the bounding box.
%dz: Substitutes the depth of the bounding box.
%xbool: 0 if dx <= 0 else 1.
%ybool: 0 if dy <= 0 else 1.
%zbool: 0 if dz <= 0 else 1.
%container: Path of the container the bounding action is applied to.
%container[path]: Relative path of the container the bounding action is applied to.

To Use Bounding Actions
Drag the plug-in onto a container.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Tools

Example:
THIS_SCENE*TREE*#297*TRANSFORMATION*POSITION SET %dx %dy %dz



Example:
%container[$textnode1$textnode2]*GEOM*TEXT SET %xbool
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Insert a command in the Text box (see examples above). Now every time the bounding box 
changes (a Sub-Container is moved outside the current bounding box or the bounding box 
plug-in is used to modify it), this command is executed.

Cloner

The Cloner plug-in creates a number of clones of a given container (target).

This page contains the following topics and procedures:

Cloner Properties
To Clone a Container

Cloner Properties
Clones Count: Specifies the maximum number of clones to be created.
Clones Rows: Defines, together with Clones Cols, how clones are being laid out. Layout 
depends on the Shape parameter which can be Matrix (grid), Ellipse and Sphere.
Clones Cols: See Clones Rows description above.
Shape: Sets the different shapes. Available options are Matrix, Ellipse and Sphere.
Rename Subtrees: Clones are labeled "group_x_y" per default. If this flag is set, clones are 
labeled "<name of target>_x_y". Only takes effect upon future changes in the subtree.
Rename Excess Containers: Suppose a matrix of 10x10 clones. If you now change the matrix 
to be made of 5x5 clones, you are left with 75 orphans, which are removed if this flag is set. 
Only takes effect upon future changes in the subtree.
Remove All (button): Removes all clones immediately.
Remove Only Excess (button): Removes excess clones immediately.

Matrix and Ellipse shape specific settings:

Plane: Specifies along which axes, newly generated clones are going to be laid out. Default is 
XY, alternatives are XZ and YZ.
Delta X, Y and Z: Specifies an relative offset in X,Y and Z axis between each clone. Actually 
defines how closely clones are being packed into the matrix or ellipse.
Delta represents: Step directly affects the translation matrix of the clones 1:1. For example a 
value of 200 for Delta X means that clone A (located at position 0) is followed by clone B 
translated 200 units in X. The container’s transformation matrix is being modified 
accordingly. Bounding Box does not affect the clones transformation matrix 1:1, but instead 
applies the transformation relative to the bottom-left edge of the target’s bounding box in 
matrix mode. Suppose a rectangle of 100x100 is used as target. Delta X of 100 in Step 

Note: This plug-in is located in: Plugins -> Container plug-ins -> Tools
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mode causes all clones to be positioned with an offset of 100 units in X. In Bounding Box 
mode a value of 100 produces an effective offset of only 50.
R1 and R2: Specifies values of radius 1 and radius 2, defining the ellipse. Used in ellipse 
mode.
Min and Max Angle: Specifies an open ellipse from for example 45° to 175° instead of 0° to 
360°. Used in ellipse mode.
Offset Angle: Rotates the individual clones along the axis. This is not affected by setting of 
Plane. If the ellipse is laid out in XY this parameter affects the Z-axis. Used in ellipse mode.

Sphere shape specific settings:

Radius: Specifies the radius of the sphere composed by the given number clones.
Min and Max Azimuth: Same as Min and Max angle for the ellipse.
Min and Max Pitch: Specifies the position of the poles of the sphere. The poles can only be 
shifted towards the center of the sphere. This actually results in a sphere with its poles 
being cropped.

To Clone a Container
Add a new group to the scene tree, and add the Cloner plug-in to it.
Add the object (target) to be cloned as the first child of this group.

By modifying parameters Clones Count, Rows and Cols a corresponding number of 
clones are created.
Operating in shape mode Matrix you can alter Delta X, Y and Z parameters to create a 
layout for the newly generated clones.

Colorize

The Colorize plug-in allows you to transform the colors of containers within a container group. If 
you for instance have 15 Sub-Containers in a group, the colorize plug-in assign numbers to each 
container by the order they have in the group. You can then define for each Sub-Container which 
color it should have to start with and which color it should change to.

The plug-in can define up to ten colors. Each color is able to influence more than one container. 
The Num Color1-10 parameters allow you to link multiple containers to one color in the colorize 
plug-in. Each of the Sub-Containers must have its own material for the plug-in to work.

Colorize Properties
Colorize: Runs the color transformation. One number corresponds to one container.
Animation Start: Allows you to select the starting point for the color change.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Tools
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Default Color: Sets the color for containers in the group which are not selected for color 
transformation. To set it, use the color editor below or drag a material from the Server Panel 
onto the small square.
Num Color1 A to 10 A: Assigns the starting colors to containers, from which the color 
change starts. The value sets the number of containers to be linked with the corresponding 
color in the Color1 A: 10 A parameters. The function starts counting from the first undefined 
container. This means that, if color 1 A has the value 2, color 2 A has the value 3 and 3 A 
has the value 1, the two first containers get the properties of color 1 A, container 3: 5 get 
the properties of color 2 A and container 6 gets the properties for color 3 A.
Color1 A to 10 A: Sets the colors for 1 A: 10 A. You can set each color using two methods:

Either select the color by clicking the color icon and then set the color properties at 
the color editor at the bottom, or
Drag a material from the Server Panel onto the color icon of the color you want to set.

Num Color1 B to 10 B: Assigns the ending color to containers, to which the color change 
ends. The value sets the number of containers to be linked with the corresponding color in 
the Color 1 B: 10 B parameters. The function starts counting from the first undefined 
container. This means that, if color 1 B has the value 2, color 2 B has the value 3 and 3 B has 
the value 1, the two first containers get the properties of color 1 A, container 3: 5 get the 
properties of color 2 B and container 6 gets the properties for color 3 B.
Color1 B to 10 B: Sets the color for 1 B: 10 B. You can set each color using two methods:

Either select the color by clicking the color icon and then set the color properties at 
the color editor at the bottom, or
Drag a material from the Server Panel onto the color icon of the color you want to set.

Rebuild: After having made changes to colors and assigning containers, click rebuild to 
apply the changes.

Counter

The Counter plug-in creates a count up or count down at any given range and at any given speed. 
It shows integral numbers.

This page contains the following topics and procedures:

Counter Properties
To Use the Counter

Counter Properties
Number: Sets the current number of the counter. Animate this value to create the wanted 
count-up or count-down.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Tools
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Initialize: Starts the operation.

To Use the Counter
Add the Counter plug-in to a container with a font, and click Initialize.

DVE Follow

The DVE Follow plug-in connects a video input channel or a clip channel of the containing Scene 
with the bounding box of a Container. When connected the channel, if set to DVE, follows the 
bounding box of the Container. The plug-in does not actively set the channel to DVE.

DVE Follow Properties
Channel Type: Type of channel to manipulate:

Video Channel
Clip Channel

Video/Clip Channel Number: The plug-in supports a maximum of eight video channels and 
16 clip channels.
Layer: Selects the layer which contains the Scene in which the DVE is located.
Video Width: Sets the width of the containers bounding box.
Video Height: Sets the height of the containers bounding box.
Alpha: Sets the alpha value of the DVE channel.
Priority: Sets the priority value of the DVE channel.
Crop: Sets the left, right, top and bottom crop value of the DVE channel.

Heartbeat

The Heartbeat plug-in creates a heart beat animation. Includes animation of:

Size, along different axes, axis-pairs or all axes
Rotation, around three main axes
Alpha

IMPORTANT! Be aware of the fact that the DVE animation is done on the video board while 
the animation of the ruling container is done together with all other graphics on the GPU. 
The output delays of the graphics and the DVE animation are different and this can lead to 
notable offsets between graphics and DVE (especially notable with fast animations).



Note: This plug-in is located in: Plugins -> Container plug-ins -> Tools
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Color

Heartbeat Properties
Animation Length: Sets the length of the animation. Parameter Name: animLength.
Swing: Enables the object to have a swinging action (back and forth). Parameter 
Name: swing.
Pause: Enables the object to pause before repeating the action. Parameter Name: pause.

Pause Length: Sets the length of the pause. Parameter Name: pauseLength.
Change Size: Enables the change size parameters for changing the vector(s), initial and final 
weight of the object’s animation. Parameter Name: changeSize.

X, Y, Z, XY, XZ, YZ, XYZ: Sets animation vector(s). Parameter Name: changeVector.
Initial Weight: Sets the initial weight of the object. The higher the value, the slower the 
animation at first. Parameter Name: initialWeight.
Final Weight: Sets the final weight of the object. See also Initial Weight. Parameter 
Name: finalWeight.

Change Rotation: Enables the rotation parameters changing the rotation axes, initial and 
final angles. Parameter Name: changeRotation.

X, Y, Z: Rotates the object on the X, Y or Z axis. Parameter Name: rotAxes.
Initial Angle: Sets the initial angle of the object. Parameter Name: initialAngle.
Final Angle: Sets the final angle of the object. Parameter Name: finalAngle.

Change Alpha: Enables the alpha parameters changing the initial and final alpha values. 
Parameter Name: changeAlpha.

Initial Alpha: Sets the initial alpha value. Parameter Name: initialAlpha.
Final Alpha: Sets the final alpha value. Parameter Name: finalAlpha.

Change Color: Enables the color parameters changing the color of the object. Parameter 
Name: changeColor.

Source Color: Sets the source color. Parameter Name: sourceColor.
Target Color: Sets the target color. Parameter Name: targetColor.

Hide On Empty

The Hide On Empty plug-in hides its container when a target text geometry matches a given 

condition. The condition may be an empty text, or text displaying a zero value, such as 0  or 

0.0 , depending on the plug-in parameters.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Tools

Note: This plug-in is located in: Plugins -> Container plug-ins -> Tools
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Hide On Empty Properties
Text container: Specifies the container of text of which to check the content.

Self: The text geometry is in the same container as the plug-in is applied to.
First child: The text geometry is in the first child container of the container the plug-in 
is applied to.
Other: Enables the Other text container drop area.

Other text container: Drag the container containing the text geometry to set the target. 
Enable by selecting Other as Text container.

Treat as numerical: Hides the target container if the specified text is  0  or 0.0 , in addition 

to empty text.
Invert visibility: Displays the container when the condition is satisfied instead of hiding the 
target container when the condition matches.
Update Geometry: Updates the visibility state of the container holding the plug-in after 
changes, removal, or assignment of target text geometry, during the design process.

Image Link

The Image Link plug-in copies the image/texture from the source container to up to ten linked 
containers. The image you load in the source container is repeated in all the linked containers.

This page contains the following topics and procedures:

Image Link Properties
To Link an Image to Multiple Containers

Image Link Properties
Container 1: 10: Drop zones for the containers you want to link.
Initialize: Initializes the plug-in.
Do it now: Performs the operation immediately.

To Link an Image to Multiple Containers
Add a group container to the scene tree.
Add the Image Link plug-in and the source image to the group container.

Note: You cannot use the control plug-in Control Hide on Empty in conjunction with 
Control Text using the same field identifier. In such a case, use the Hide On Empty
property in the TextBG plug-in.



Note: This plug-in is located in: Plugins -> Container plug-ins -> Tools
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Add a number of containers to the scene tree with a dummy image on each.
Open the Image Link editor.
Drag and drop the containers with the dummy images onto the Container 1-n drop zones.
Click Initialize to apply change.

See Also

Text Link

Jack

The Jack plug-in shows a digital clock and date. The plug-in is highly customizable allowing you to 
set your own time and date formats and correction values.

Jack Properties
Time mode has the following properties:

Hour format: Sets how to show hours (either off, on or with a leading zero if the value is less 
than ten).
Min format: Sets how to show minutes (see Hour format).
Sec format: Sets how to show seconds (see Hour format).
Hour/Min separator: Sets character separation for hours and minutes.

Blink mode: Blinks the separator between hours and minutes when set to On . This means 

every odd second it turns off.
Min/Sec separator: Sets a separator for minutes and seconds.

am/pm or 24 hours: Switches between the am/pm and 24 hour format.
Time/meridian separator: Sets a separator for the am/pm hour format.
am/pm format: Sets the case of am/pm to upper or lower.
Hour correction: Enables you to correct the hour value of the system time. Useful to show 
the local time of a location in a different time zone.
Min correction: Sets correction value for minutes (see Hour correction).
Sec correction: Sets correction value for seconds (see Hour correction).

Date mode has the following properties:

Year format: Sets how to show the year format (off, two digits or four digits, please keep in 
mind that in the year 10000 this is three digits or five digits, due to the algorithm used).
Month format: Sets how the month is shown, either off, on or with a leading zero from 
January to September.
Day format: Sets how the day is shown (see Month format).

Note: This plug-in is located in: Plugins -> Container plug-ins -> Tools

Note: Although a format is switched off, the separator is still shown.
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First separator: Sets the separator character for the first two items of the date. If the dot 
value is selected, an additional blank character is inserted automatically.
Second separator: Sets the separator character for the last two items of the date.
Order: Sets the order of the items of the date.
Year correction: Sets a correction value for the year.
Month correction: Sets a correction value for the month.
Day correction: Sets a correction value for the day.

Level of Detail

The Level Of Detail (LOD) plug-in is a mechanism for controlling the level of complexity of a 3D 
object, depending on camera position and object size. As an object becomes smaller on the 
screen, the objects polygons become smaller. At a certain size those polygons are small enough to 
be replaced by a lower number of larger polygons, without loosing realism. The goal is to maintain 
the overall shape of the object so it does not change significantly, when the number of polygons 
are changing.

Viz Artist has a built-in LOD mechanism for text objects and internal objects, such as Sphere, 
Cylinder and so on. This mechanism changes the tessellation of the object, based on its size on 
screen. However, there is no LOD mechanism for imported objects and models. This is where the 
LOD plug-in can be used. The LOD plug-in enables switching between different representations 
(levels) of the same object, based on its distance from the camera and on the zoom level of the 
camera. A switching range is assigned to each representation: to determine the specific distance 
from camera in which it is replaced by the next representation.

In addition to that, the zoom of the camera is taken into consideration; objects that are far away 
from the camera appear closer (and larger) at a narrow zoom position, or smaller at wide zoom. To 
accommodate for different zoom values, the LOD plug-in assumes that the switching ranges are 
correlative to a reference zoom value. When the actual zoom value differs from the reference zoom 
value, the switching ranges are automatically adjusted.

To use the LOD plug-in on an object, you have to import several representations of that object 
from an external source. The different representations of the object have to be placed under a 
group node, in the order of detail, this means the most detailed level is on the top of the group. 
When the LOD plug-in is placed on the group container it makes only one of its children (levels) 
visible at a given time, based on the distance between the center of the object and the camera, as 
well as the current zoom value, and other selectable parameters of the plug-in.

Note: The order when using multiple date corrections is Day → Month → Year.
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The LOD container plug-in works in conjunction with the LOD Manager scene plug-in that controls 
all the LOD plug-ins in the scene.

LOD Properties
Lock: Disables distance switching. In certain cases, it is desirable to disable the distance 
switching and lock the LOD plug-in to show one of the levels.

Lock On Index: Shows index of the selected level when Lock is  On .

Center: Defines whether the distance from the camera is measured from the origin of the 
object (Automatic) or from a specific point in the object, for example one of the corners 
(Manual)
Center X, Y and Z: Sets the point from which the distance from the camera is measured (in 
object coordinates), if the Center parameter is set to Manual.
Range Scale: Sets a scale factor on the switching ranges. This scale factor allows shortening 
or lengthening the distance at which object representations are switched.
Range 0: Sets the switching ranges. Those are the distances at which object representations 

are switched. The number of entries is n+1  where n  is the number of children in the group 

on which the LOD plug-in is assigned
Initialize: Re-initializes the LOD plug-in. This is required if the number of children of the LOD 
group has changed after the LOD plug-in was assigned to the group.

See Also

LOD Manager

Magnify

The Magnify plug-in offers the possibility to create a simulation of a looking glass and other 
similar effects. At an area defined by an overlying object an image can be shown in a magnified 
way.

This page contains the following topics and procedures:

Magnify Properties
To Magnify a Texture

Magnify Properties
Scale: Sets the scaling of the magnifying effect.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Tools

Note: This plug-in is located in: Plugins -> Container plug-ins -> Tools
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Effect Type: Adds an extra effect, either Blur or Pixel. This only works on onux.
Effect Value: Sets the value for the selected extra effect.
Alpha: Sets the alpha value for the container.
Rebuild: Applies the changes to the texture.

To Magnify a Texture

Add a Container to the Scene Tree.

Name it  source .

Add the image or texture that is to be magnified to the source Container.
Add a Sub-Container to the source Container

Name it  magnify .

Add the same image or texture to the magnify Container that was used in 
the source container.
Add the Circle geometry to the magnify Container.
Open the transformation editor for the magnify Container.

Set Position Z to 1.0 .

Add the Magnify plug-in to the magnify container.
Open the Magnify editor.

Set Scale to 2.0 .

Match It

The Match It plug-in sets the axis center (i.e. center for rotations) to the camera and moves the 
object away from the camera by the specified amount of units. By setting an arbitrary camera 
distance and initializing the plug-in, the container with the Match It plug-in is positioned in the 
specified distance and any rotation is done with respect to the camera position. The container’s 
axis center parameter can also be edited for a more flexible configuration.

Note: Keep in mind that you have to re-initialize the plug-in if the camera is moved.
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Match It Properties
Initialize: Resets the pivot to the camera and places the object ‘CamDistance in Z’ units 
away.
CamDistance in Z: The distance from the camera on the z axis.

Max Size

The Max Size plug-in is used to set max size parameters for text objects. This allows you to have 
control over the space the text should use so it does not ‘overflow’ the designated text area.

This page contains the following topics and procedures:

Max Size Properties
To Set Maximum size

Max Size Properties
Default x-scale: Sets the default x-scale.
Default y-scale: Sets the default y-scale.
Max size: Sets the direction of the size to be controlled:

x: Controls the width.
y: Controls the height.

Max width/height: Sets the maximum width or height, depending on whether x or y is 
selected for Max size.
Scale y/x: Scales the y or x value accordingly when maximum width or height is reached, 
respectively.
Initialize text scale: Initializes the plug-in parameters.

To Set Maximum size

Add a group container to the scene tree.

Add a group container as a Sub-Container of the first (scaled to 1,1,1) and name it  text .

Note: This plug-in is located in: Plugins -> Container plug-ins -> Tools

Note: This plug-in is located in: Plugins -> Container plug-ins -> Tools
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Add a font (e.g. Georgia Regular) to the text container.
Add the MaxSize plug-in to the text container.

Click the MaxSize plug-in and set Max width to  200.0 .

Click the font and type Create.
Now type Create more. This automatically scales the font’s X value as it limits itself to the 
Max width.

Optional: Click the MaxSize plug-in and enable the Scale Y parameter to automatically scale 
the font’s Y value.
When working with scenes that includes vertically aligned text direction, such as East Asian 
languages where top to bottom columns of text can be desirable, please pay attention to the 
vertical orientation selected in the Text editor. When the text scale is adjusted with Max 
size, the selected vertical orientation can affect the position of the text geometry:

Top: Centers the geometry at the top of the boundary. Changes to the text scale do 
not change the geometry position.
First Line: Centers the geometry at the base of the first line. Because of this, changes 
to the text scale also move boundary of the geometry.
Center: Moves the boundary when the text scale changes because the center of the 
geometry is not the same as the center of the boundary, the boundary is moved 
slightly when the text scale is changed.
Bottom: Centers the geometry at the base of the last line of text, but this is not the 
same as the bottom boundary. This results in the boundary being moved when the 
text scale is changed. This allows for more flexible choices when designing a scene, 
and should be selected based on the desired result.

See Also

Max Size Lines

Max Size Lines

The Max Size Lines plug-in adds multi-line support for TextFX with right-to-left languages. Each 
line of text must be in separate containers, and organized as a sub group of the container holding 
the Max Size Lines plug-in.
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Max Size Lines Properties
Default x-scale: Sets the default x-scale.
Default y-scale: Sets the default y-scale.
Max width: Sets the max width.
Scale y: Scales the y-value accordingly when max width is reached.
Initialize text scale: Initializes the plug-in parameters.

See Also

Max Size

Object Zoom

The Object Zoom plug-in lets an object follow the camera and match its orientation. This creates 
an effect as if the camera would smoothly zoom to the object.

This page contains the following topics and procedures:

Object Zoom Properties
To Zoom an Object Towards the Camera

Object Zoom Properties

Counter: Determines the speed of the zoom operation. Use values from 1-1000 .

Dest. Object: Identifies the name of the container that is affected by this plug-in.
Dest. Dist.: Determines the distance from the camera at which the object stops.
Dest. Size %: Determines the scaling of the object.
Path HOffset: Determines the horizontal offset in camera space.
Path VOffset: Determines the vertical offset in camera space.
Initialize (button): Starts the zoom.

To Zoom an Object Towards the Camera
Add the Object Zoom plug-in to a container.
Set the Dest. Object parameter to match the containers name.

Set the counter to at least  1 .

Click Initialize.
Go to Views and move the camera to see the container zooming towards the camera.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Tools

Note: This plug-in is located in: Plugins -> Container plug-ins -> Default
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The Object moving (Omo) plug-in gives the user the possibility to create a very realistic animation 
of a complex imported 3D object, where the object not just changes position or rotates, but where 
it changes form and moves in a realistic way, like a man walking or a fish swimming.

The plug-in can also create animation sequences with other sorts of objects. Anything you can put 
in a container can be used as an item in an Omo animation process.

The plug-in hides all Sub-Containers and shows them one by one. The one to be shown is 
controlled by the Visible Container parameter. By animating this value an animation sequence of 
all the containers is made. The plug-in can also be used to show one group at a time.

Omo Properties
Visible Container: Allows you to select which container that is to be visible.
Keep Visible: Enables you to keep containers visible after they have been revealed one by 
one.
Initialize: Initializes the Omo plug-in. All containers in the group are then hidden, except the 
one selected by the Visible Container parameter.

To Animate One Object at a Time

Note: This plug-in is located in: Plugins -> Container plug-ins -> Tools
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Create a group and add the Omo plug-in to it.
Create a number of Sub-Containers to the root container.
Add a Sphere geometry and material to each Sub-Container.
Optional: Animate the sphere.
Open the Omo editor, click the Initialize button, and animate the Visible Container 
parameter.

See Also

Control Omo

Parliament

The Parliament plug-in is specially developed for creating visualizations of parliament seats in 
graphics designed for election programs, but it can of course be used in other ways. The plug-in 
creates a “parliament like” seating structure using an object of your selection.

This page contains the following topics and procedures:

Parliament Properties
To Create a Parliament Shape

Parliament Properties
Number of items: Allows you to set the number of seats to be created in the parliament 
structure.
Number of Rows: Allows you to decide how many rows the parliament seats should be 
distributed over.

Scale: Sets the Scaling (locked) of the generated Sub-Containers. Default is 1.0 .

Rebuild Geometry: After having made changes to either Number of items or Number of rows, 
you must click on this button to apply the changes.
Inner Radius: Sets the inner radius of the parliament.
Outer Radius: Sets the outer radius.
Start Angle: Sets the starting angle which by default is -90° from the Y-axis.
End Angle: Sets the ending angle, default 90°.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Tools
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To Create a Parliament Shape

Add a group to the scene tree, add material, rotate and set parameters (except Position and 
Scaling).
Add the Parliament plug-in to the container, and click the Initialize button. By default, the 
seating is created with 40 seats in three rows. The plug-in then by default creates 40 Sub-
Containers that are copies of the core-object. All the newly created Sub-Containers have the 
same properties as the source object, except from Position and Scaling (if set). Position is 
set by the plug-in to create the parliament structure.

Open the transformation editor for the first Sub-Container and set Scaling (locked) to 0.2 .

Still having the transformation editor open for the first Sub-Container, select all other Sub-
Containers and drag and drop the Scaling property onto on of the selected Sub-Containers. 
This sets the same Scaling parameters for all selected Sub-Containers.

PathFinder

The PathFinder plug-in creates an animation path based on predefined shapes.

PathFinder Properties
The properties of the PathFinder plug-in are different for each selected mode:

Common Properties
Circle Properties
Wave Properties
Spring Properties
Line Properties

Common Properties

Shape Type:

Note: If the object you used for creating the seats contains many polygons, the total 
product of the parliament container can quickly be too heavy to render.



Note: This plug-in is located in: Plugins -> Container plug-ins -> Tools
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Circle: Uses an existing 2D Circle geometry for the animation path. 
Wave: Uses an existing 2D Wave geometry for the animation path.
Spring: Uses an existing 3D Spring geometry for the animation path.
Line: Uses an existing 2D Line geometry for the animation path.

KeyFrame Smooth Level: Defines how smooth the spline is.
Linear: Does not add smoothing.
1-6: Determines the level of smoothing. 

Direction: Determines the direction the spline is built.
Clock: Builds the spline in a clockwise direction.
Counter Clock: Builds the spline in a counter clockwise direction.

Axis: Determines the axis orientation.
XY: Builds over the X and Y axes (facing up).
YZ: Builds over the Y and Z axes (facing the screen).

Circle Properties

Radius: Determines the radius of the circle.
Resolution: Determines the number of key frames on the circle.

Start Point: Defines the starting angle for the circle. This value can be less than 0  and more 

than 360 , but the value always corresponds to the degree value of a circle.

Wave Properties

Wave Length: Determines the length of each wave.
Wave Amplitude: Determines the height of each wave.
Resolution: Determines the number of key frames on each wave count.
Count: Determines the number waves to create.

Start Point: Determines how the wave begins. A value of 0  starts at the bottom, while a 

value of 100  starts at the top.

Spring Properties

Spring Type: Determines the type of spring path.
Slalom: Creates a smooth shape.
Steps: Creates a shape more like circles connect to one another.

Radius: Determines the radius of the spring.
Radius Change %: Increases/decreases the radius size. The spring shape turns into a cone 
when the radius is decreased.
Distance: Determines the height of the spring.
Resolution: Determines the number of key frames on each spring count.
Count: Determines the number of spring iterations.

Line Properties

Axis: Builds line on X, Y or Z axis.
Length: Determines the length of the line.
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Resolution: Determines the number of key frames on the line.

Rotations Order

The Rotations Order plug-in changes the rotation order of a container in Viz Artist to match the 
Softimage XSI rotation order. This plug-in is automatically added to some containers when 
Softimage XSI scenes are imported into Viz Artist.

Rotations Order Properties
Rotation Order: Sets the order of rotation to either:

XYZ
ZYX
ZXY
YXZ

Slide Show

The Slide Show plug-in allows you to create a sequence where a group of containers fade in and 
out one by one in the same manner as a normal slide show.

This page contains the following topics and procedures:

Slide Show Properties
To Create a Slide Show

Slide Show Properties
Blend Value: Controls the slide show sequence. Animate this value to create the change from 
slide to slide.
Use Offset: Enable this option if the slides have the same initial position and you want them 
to move along some of the axes as the slides are being shown.
X, Y and Z Offset: Sets the offset values of each slide calculated form the one previously 
shown.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Tools

Note: This plug-in is located in: Plugins -> Container plug-ins -> Tools
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Fade Out: May be set Off, On (every slide) or Last (last slide only)
Start with: Sets what should be visible if slide show is not started.

To Create a Slide Show

Add a group to the scene tree, and name it  slideshow .

Add a number of Sub-Containers that are used to house the slide(s).
Add the Slide Show plug-in to the slideshow container.
Position the Sub-Containers in advance using the transformation editors for each container, 
or open the Slide Show editor and offset them to create a moving sequence.
Animate the blend value to create the slide show sequence.
Click the Initialize button to initialize the plug-in. Each of the Sub-Containers automatically 
get an alpha icon.

System Time

The System Time plug-in creates a variety of time and date settings based on the system time. This 
plug-in adheres to the standard  IEEE Std 1003.1, 2004 Ed.

System Time Properties
format (aAbBcdDHIijlmMpSUwWxXyYzZ/:,.): Sets the format of the system time.
Language: Sets the language format of the system time. Options:

Default (system specific)
English
German
Norwegian

Seconds offset from system clock: Sets the number of seconds the system clock should be 

offset (default is 0 ).

Hours offset from system clock: Sets the number of hours the system clock should be offset 

(default is 0 ).

System time zone: Sets the system time zone.
Show Time Zone: Shows the result of the system time zone.
Lower Case Text: Shows all text in lower case.

Time Zone: tzn[+|-] hh[:mm[:ss] ] [dzn]

Note: This plug-in is located in: Plugins -> Container plug-ins -> Tools
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tzn: Time zone name, e.g. PST
hh,mm,ss: Offsets from the local timezone to UTC (not the reverse).

For time zones ahead of the set one, the time difference is negative.
For time zones behind the set one, the time difference is positive.

dzn: Daylight-saving-time zone, e.g. PDT

See Also

Analog Watch
Clock Rotation

Temo

The Temo plug-in gives the user the possibility to create an image animation sequence, using a 
method much like the one used for making a cartoon film. The basic input for the plug-in is a 
single image consisting of many tiled and equally sized squares set up in a matrix.

Each square of the image is made up to be a snapshot of an animation sequence, just like each 
picture frame is on a normal film. The image must be made up in advance with the aid of a image 
editing tool. In the property editor, you tell the Temo plug-in how many tiled squares there are in 
the X- and the Y-axis. The plug-in is then able to show the tiles of the image one by one. By 
animating this, a “film like” sequence is created. The plug-in has only a small influence on the 
rendering performance.

Temo Properties
Number of tiles horizontal: Defines the number of tiles in the X-axis of the source image.
Number of tiles vertical: Defines the number of tiles in the Y-axis of the source image.
Show Tile Number: Selects the tile to be shown. The range of tile numbers is the product of 
the two above parameters. If there are three in the horizontal and four in the vertical plane, 
the total is of course 12. The tile with the coordinates X1Y1 is shown first, then X2Y1 and so 
on. By animating the whole range of this value, a “film animation” can be created. The 
quality of the animation depends of course on the number of tiles and on the degree of 
transformation from one tile to the next throughout the whole sequence.

Examples: EST5EDT, PST5PDT, GST-1GDT

Note: This plug-in is located in: Plugins -> Container plug-ins -> Tools
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Text Auto Scale

The Text Auto Scale plug-in automatically scales text within a Text Box area as defined in the Text 
Editor.

Text Auto Scale Properties
Enabled: The plug-in is enabled by default when added to a container. Click the button to 
disable.
Default x-scale: Sets the default scale value for the X-axis.
Default y-scale: Sets the default scale value for the Y-axis.

TextBG

The TextBG plug-in creates a dynamically sized background for text, images or video. For 
example, you can use it to create a background that expands as text is entered in the Text Editor. 
The plug-in must be added to a container that also holds a Rectangle, Noggi, Fade 
Rectangle or Cube geometry plug-in. To use the plug-in with anything other than fonts, set 
the Text Parameter option to Scale.

TextBG Properties
Size Parameter: Sets the size of the background to adjust to:

W/H (width/height): Adjusts the width and height of the background geometry to the 
size of the typed text.
Scale: Scales the background to the size of the target container.

Text Container: Sets the inputs source for the TextBG plug-in:
PREV (previous): Applies the background geometry to the container previous to the 
TextBG container.
PARENT: Applies the background geometry on the parent container.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Tools

Tip: When using the Text Auto Scale plug-in, Text Box scaling should be set to Off  to 

avoid conflict in scaling operations.


Note: This plug-in is located in: Plugins -> Container plug-ins -> Tools
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NEXT: Applies the background geometry to the next container from the TextBG 
container.
OTHER: Enables the Other container field.

Other container: Available when OTHER is selected. Drag a container from the same group to 
the drop area. Click on R to remove the Container.
Direction: Sets the direction in the background grows when adjusting itself to the text. 
Available options are X, Y, or the XY-axes in combination.

Hide On Empty: Hides the background container if there is no text. Set to  off  to 

enable Always Keep Margins.
Always Keep Margins: Makes the background geometry retain the defined margins as 
minimum width and height, even when the text container is empty. Enabled by setting 

Hide On Empty to  off .

High Precision: Adds one decimal point precision to the Margin fields.
Right, Left, Bottom and Top Margin: Sets the margin between the text and the background in 

centimeters. Accepts values in the range  -1000.0  to  1000.0 .

Lock Margins: Sets the margin to be the same for all.
Enable Substring: Enables the First and Last Character options. Substring cannot be used 
with multiple texts.

First Character: Sets on which character the background should start animating.
Last Character: Sets on which character the background should stop animating.

To Add Background to the Previous or Next Containers

Add a group container to the Scene Tree.

Add two sub-containers to the  group  container:

Name the top one  Text1 .

Name the bottom one  Background .

Add a font to the Text1 container.
Open the Transformation Editor of the Text1 container.

Set Position Z to 1.0 .

Enter some text. In this example, the text is  More Control .

Copy the Text1 container and place the copy below the  Background  container in the scene 

tree. Move the container so that both texts are visible, as seen in the screenshot above.

Rename the new container to  Text2 .
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Add a geometry, for example the Noggi, a material, and the TextBG plug-in to 

the  Background  container.

Open the TextBG editor.
Toggle the Text Container property from PREV to NEXT. The background geometry moves 
from Text1, or the previous container, to Text2, the next container. If you resize the text in 
the Text2 container, the background geometry automatically resizes to fit the text.

To use TextBG to apply a background to the parent container, which is  group  in this 

example, select PARENT as Text Container. This requires that the parent container contains 
a text, image or video object working with TextBG.

Text Link

The Text Link plug-in copies the text from the source container to up to ten linked containers. The 
text you enter in the source container is repeated in all the linked containers. The linked 
containers must contain a font.

Text Link Properties
Container 1: 10: Drop zones for the containers you want to link.
Initialize: Initializes the plug-in.
Do it now: Preforms the operation immediately.

To Link Text to Multiple Containers
Add a group container to the scene tree.
Add the Text Link plug-in and a font to the group container.
Add a number of containers to the scene tree with a font on each.
Open the Text Link editor.
Drag and drop the containers with the fonts onto the Container 1-n drop zones.
Click Initialize to apply change.

See Also

Image Link

Tip: To apply a background to a different container, select OTHER as Text Container
and drag the desired container to the drop area.



Note: This plug-in is located in: Plugins -> Container plug-ins -> Tools
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Text Parameters

The Text Parameters plug-in offers the designer the possibility to animate text parameters, as 
standard text parameters in the Text Editor cannot be animated. The parameters for the Text 
Parameters can only be used for animation.

The settings are not visible on the text until an animation update has been made.

Text Parameters Properties
Use Kerning: Enables or disables the use of Kerning.
Tracking: Sets the space between each letter.
Leading: Sets the space between each line of text.
Word Spacing: Sets the space between each word.
Use Soft Shadow: Enables the use of Soft Shadow. Level 4 is the most blurred, softest 
shadow. The Drop Shadow option must be enabled for the Soft Shadow to be visible.
Use Drop Shadow: Enables or disables Drop Shadow.
Direction: Sets the direction of the Drop Shadow in degrees.
Distance: Sets the distance of the Drop Shadow.
Z Offset: Sets the offset of the Drop Shadow in the Z-axis.
Color: Sets the color of the shadow.

Texture Fit

The Texture Fit plug-in works in combination with the Box Transformation and Flexbox Plug-ins, 
providing advanced control of how images are displayed. Various formats and aspect ratios require 
images to be displayed in different ways. While on a classic 16:9 aspect ratio an image can be 
shown as it is, it requires some cropping when showed in portrait mode.

Texture Fit requires a Flexbox plug-in. It uses the calculated box to display the image (for 
example, defined by a Phong material) in a perfect way. There are three modes for how an image 
is displayed.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Tools

Note: This plug-in is located in: Plugins -> Container plug-ins -> Tools
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Contains
Contains places the image 1:1 as it is. 

There can be an offset to the mapped image (Offset U and V).

Cover
Cover fills the whole available space. It displays an image to always fill the whole available space, 
without leaving anything blank.

The image can be scaled by modifying the Scale U and V parameter, based on the scale Pivot.

Region of Interest
Defines a rectangle of that area, that must always be visible. The Texture Fit plug-in ensures, that 
no matter of how the source rectangle is defined, the selected area is always visible. It starts 
cropping other parts of the image, but the defined rectangle is always visible.

To define your rectangle, use the X and Y minimum and maximum values. The range goes from 0 
(left, top) to 1 (right, bottom).
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Example

The Region of  Interest is defined like this:

The image shown in a landscape and in a portrait situation:

Image Credits: dezistyle.com

TransitionLayers

The TransitionLayers plug-in enables a new way to define the two dynamic images of a scene-
transition scene, using the Dynamic Scene Media Asset.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Tools

http://dezistyle.com
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TransitionLayers Properties
Layer1 Container: Container holding the scene to transition from. The referenced containers’ 
name is shown to the far right.
Layer2 Container: Container holding the scene to transition to. The referenced containers’ 
name is shown to the far right.
Reset buttons: Each layer container has a reset button, which empties the container 
reference.

When adding the TransitionLayers plug-in to a container, the plug-in automatically creates 
the two sub-containers required and adds these to the plug-in properties:

Parent container holding the TransitionLayers plug-in.
Sub-container holding the scene to transition from, or Layer1 Container.
Sub-container holding the scene to transition to, or Layer2 Container. In addition, a default 
two second alpha in animation is added for the Layer2 Container to the Default director in 
the Stage. This default animation can of course be changed as desired.

VCF Parameter

The VCF (Virtual Camera Flight) Parameter container plug-in works in conjunction with 
the VCF scene plug-in. They allow you to create a seamless interpolated transition from a VCF to a 
real camera: and vice versa. This is only a relevant function to set up, if you have purchased the 
virtual studio expansion components.

You must have a real camera with data tracking enabled, which is set in remote mode in the 
camera editor. In case you have several tracked cameras, the virtual camera interpolates its 
position to the real camera that is selected On Air.

Tip: By pressing the group button for the source or destination layers, the 
corresponding container is selected in the scene tree.



Tip: Containers holding the dynamic images for the transition scene can also be dragged 
onto the desired Layer container in the plug-in properties pane.



Note: This plug-in is located in: Plugins -> Container plug-ins -> Tools
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This page contains the following topics and procedures:

VCF Parameter Properties
To Use the Virtual Camera Flight

VCF Parameter Properties
Real Camera %: Defines the percentage the real camera influences the position of the virtual 
camera.
Real Camera Deformation %: Defines the percentage the real camera influences the lens 
distortion.
Zoom: Sets the actual zoom (FOV-Y) value of the virtual camera

To Use the Virtual Camera Flight
Add the VCF scene plug-in to the scene setup plug-ins drop zone.
Create a new group in your scene and add two new containers under it. These are to be the 
objects that defines the virtual camera flight. One defines the position, the other the 
direction.
Name the containers according to the names you entered in the VCF scene plug-in (e.g. 

T_POS  and T_ROT ).

Click Initialize to finish.
Add the VCF Parameter container plug-in to the container that holds the position object.
Animate your virtual camera flight using the two objects to define position, and direction. 
Do not switch the whole container invisible or else the animation does not run. You may 
switch the objects to be invisible, at any time.
Animate the Real Camera % and Real Camera Deformation % parameters in what frame you 
want to have the real camera at 0% visibility and when at 100% visibility (the longer the 
animation is, the smoother the interpolation is: 100 F should be good).

If you start with a virtual camera the first Key Frame (0) should have 0% of the real 
camera, and the last should be 100% of the real camera.
The virtual camera generates a full key (masking the FG), if you choose virtual studio 
in the scene setup: background.

Make sure your FG object/talent are not seen while switching to the real camera. They 
should show in the frame after the switch.

4.4.19 Transformation
The following Container plug-ins are located in the Transformation folder:

Justifier
VertexBone_VertexSkin

Note: It is not possible to animate the roll of the camera.
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Justifier

The Justifier plug-in enables you to animate the justification of an object using the object’s height, 
width or depth as its coordinate system rather than using the Viz Artist/Engine coordinate system.

This plug-in acts on the local space of the container it is attached to. So a parent container can be 
used to rotate the container for use of arbitrary (world space) axes.

This section contains information on the following topics:

Justifier Properties
To Justify an Object

Justifier Properties
Align on X, Y and Z: Aligns the position. Left, Right and Center enables the Anchor option(s). 
Adv (advanced) enables the Anchor and Shift option(s).

X, Y and Z Anchor: Sets the offset for the alignment.
X, Y and Z Shift (%): Sets the shift of the position values to specify alignment between 

left/right, top/bottom and front/back (e.g. an Anchor at 50.0 , Shift at -10% , gives 

an Anchor at 45.0 .). Range is -100  to 100 .

Use rotated edges: If this is set to true and the container has been rotated, a new axis 
aligned bounding box is used to compute the alignment. (I.e. a non rotated bounding box 
completely containing the rotated container).

To Justify an Object
Create a container that can only move up and down.
Add the Justify plug-in on the container.

Set Align on X to Center .

Set Align on Z to Center . Now the container can only be moved along its y axis.

Use the X Anchor and Z Anchor to move it along the respective axis.

VertexBone_VertexSkin

Introduction
Vertex skinning describes the technique of using rigs (consisting of auxiliary objects called bones) 
to animate meshes. Instead of animating each vertex (shape animation or morphing) bones are 
animated and deform the mesh accordingly. This saves time during animation and memory. The 
process of defining which vertices are deformed by a given bone is called weight painting. A vertex 

Note: This plug-in is located in: Plugins -> Container plug-ins -> Transformation
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can be influenced by more than one bone to guaranty smoother animation around joints. As the 
mesh stretches around a joint like skin, this functionality is commonly called vertex skinning.

Quick Steps

Step-by-step

Preparation

Load a character (or any other model) in the Digital Content Creator (DCC) of choice (Maya, 
Cinema4D, Blender, 3dsMax etc).
Create a skeleton (armature). Normally, this is a hierarchy of bones so when the spine 
rotates the whole upper body rotates with it. T his should look something like the skeleton 
in Illustration 1. These bones later become containers in the imported Viz scene.
Apply the weight painting. Most DCC programs can this automatically with pretty goods 
results for most meshes (e.g. Maya). Other programs offer only a good starting point that 
needs further refinement. Illustration 1 shows a selected bone (outlined in cyan) and a mesh 

with weight paints (blue: weight = 0.0 , red: weight = 1.0 ).

Animate the character using the bones created earlier.
Export the scene from the DCC. Remember to check that bones and animations are 
exported.
Switch to Viz Artist.
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Illustration 1: Weight Painting

Viz Artist

Import the .fbx file of your scene in Viz Artist.
Enable the import skinned animations option (as shown in Illustration 2).
Play the scene using the default director after the scene is loaded.

Important: Do not change the hierarchy of the containers with VertexBone plug-ins! 
Containers can be added, but the parent-child relationship of bones should not be 
altered.
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Illustration 2: Viz import screen

Capabilities of Viz Artist VertexSkinning
Viz Artist can:

Import skinned meshes via .fbx files.
Playback animations.

As the skeleton is represented via Containers marked by a VertexBone plug-in new animations 
could be created in VizEngine but for now there are is no functionality to properly support this 
(like inverse kinematic or movement constraints on bones).

Viz Artist cannot:

Perform inverse kinematics.
Perform rigging or skinning.
Handle multiple animations (currently only the first animation, called the Default Take 
in .fbx terms).
Allow VertexSkin and VertexBone plug-ins to be placed by hand. There are hidden 
parameters imported from the .fbx file that cannot be edited or generated inside Viz Artist.
Provide compatability with external shader packages (e.g. RTT shaders) with Vertex Skinning 
in Viz.
Support cubemaps in VertexSkinning.

Role of Plug-ins

VertexSkin

VertexSkin is the main plug-in that marks a mesh that uses Vertex Skinning.

If you want some additional skinning debug information, you can activate:

Note: Do not remove this plug-in as this would need a clean, new import (not re-import) to 
get the scene running again.
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Show bones: Verifies the location of each bone visually. 
Show the weight of a bone: Visualizes the influence of the selected bone container on the 
target mesh. Only usable with no other shader present.

Motion Capture Live Tracking

To apply live motion capturing data to a Viz geometry, the following steps are required:

Setup Viz Tracking Hub for Motion Analysis Motion Capturing (See the Motion Analysis 
Integration page in the Appendices section of the Tracking Hub User Guide). 

Load motion capture data in Motion Analysis Cortex control application.
Run Viz Artist with activated Tracking Hub usage.
Load the imported mesh and navigate to the first VertexSkin plug-in instance in your scene.
Activate Shared Mem Tracking with the key name set in Cortex. You should see all available 
tracking bones in the VertexSkin plug-in's textbox below. This indicates that the information 
flows correctly from Cortex to Tracking Hub to the Viz Engine.
Due to accuracy issues of the motion capture system, it could make sense to 
activate Position Root Bone only. This translates only the root bone and all related child 
bones are rotated.

VertexBone

VertexBone is used to tell Viz which containers act as bones.

Common Pitfalls
Watch out that containers hosting the meshes and the root container of the bone containers 
(which should be on the same level) have the same scaling (ideally 1.0/1.0/1.0).

Note: Requires Tracking Hub 1.1.2. or newer

Note: Do not remove this plug-in as this would need a clean, new import (not re-import) to 
get the scene running again.



http://docs.vizrt.com/tracking-hub
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Illustration 3: Skeleton and meshes
Transformations on the mesh parent container, and the mesh container are ignored. You can 
disable this via the VertexSkin plug-in (uncheck Ignore transformation on mesh container) 
although this is not advised . Transformation of the skinned mesh should only be done via 
the skeleton.
mesh_group is no longer the parent of the mesh containers (in Illustration 3) but 
Character1_Reference is. Therefore, mesh_group should be devoid of all transformations if 
VertexSkinning is to be used.
You cannot add the vertex skinning plug-ins to containers and generate a skinned mesh 
inside Viz. The plug-ins hold private data, that is extracted from the .fbx file during impo r t.
To use the show weight of a bone, no shader plug-in can be present on the mesh 
(deactivating the plug-in is sufficient).
VertexSkinning only works properly if VBOs are used for drawing.

External References
Here you can find a small list of introduction videos for character rigging within multiple DCCs. As 
rigging is not a precise science with one correct way to do everything, it might be useful to watch 
as many videos on the topic (even the ones using software you might not be familiar with).

Maya Quick Rigging and Skinning a character in Maya

Rigging and Animating a DOTA 2 Courier Playlist

Cinema4D Character Animation In Cinema 4D

3Ds MAX Rigging a Character in 3Ds Max Playlist

Blender Character Rigging - Blender Fundamentals

https://www.youtube.com/watch?v=c538zkwxgTQ&list=PL8hZ6hQCGHMUGuDqcLp44A7BfEpRZbwgM
https://www.youtube.com/watch?v=mPFasKnbSFc&list=PLTjhBiJe1i2GlZ96fHMj7aQO_YlsZFBBW
https://www.youtube.com/watch?v=pBbb_lNXmyc
https://www.youtube.com/watch?v=_gm_g8do32k&list=PLnKw1txyYzRlxh1-BT4CifPXC5TBg2vUd
https://www.youtube.com/watch?v=vMGTQFOgV_0
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Glossary
Vertex Skinning: The process of using an armature to deform a mesh instead of using key 
frames for each vertex (Morphing).
Rigging: The act of defining a skeleton that is used to deform a mesh. This might include 
setting constraints on the rotation of bones or defining IK.
Bone: A node (container in Viz) that is part of a kinematic chain used for mesh deformation.
Weight Painting: The process of defining the amount by which each vertex is affected by a 
given bone. This can be done in a DCC via directly painting on a mesh.
DCC: Digital Content Creation (program). Software used to create digital media like 3D 
models, textures or the like.
Armature: A set of kinematic chains of nodes used to simulate a skeleton for mesh 
deformation.
Bind Pose: The deformation a model has when it is bound to its skeleton.
IK: Inverse kinematics are used to compute how a set of bones should be rotated so that the 
leaf ends up at a certain position. IKs are defined in chains (e.g. from foot to hip).

4.4.20 Visual Data Tools
The following container plug-ins are located in the Visual Data Tools folder:

Area Stack
Bar Stack
Data Fit
Data Import
Data Label
Data Storage
Line Stack

See Also

Visual Data Tools Geometry Geometry Plug-ins, which offer an overview of the Visual Data 
Tools.
Area Chart
Bar Chart
Line Chart
Pie Chart
Scatter Chart
Stock Chart
Tutorial on www.vizrt.com under the Training section.

http://www.vizrt.com/
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Area Stack

Create a stacked chart consisting of several Area Charts.

This page contains the following topics and procedures:

Area Stack Properties
To Create a Scene with Area Stack

Area Stack Properties
Initialize stacked chart: Refreshes the stacked chart, based on the Area Chart plug-ins in the 
sub-containers. The stacked chart detects when a chart is added/removed from the stack, 
and updates the chart accordingly. However, some actions, such as re-ordering the charts 
within a stack, are not updated automatically. In these cases, press Initialize stacked chart to 
update the stack.
Stack Gap: Adds space between each chart.

To Create a Scene with Area Stack

Note: This plug-in is located in: Plugins -> Container plug-ins -> VisualDataTools

Note: The remaining properties in the Line Stack plug-in are the same as used in the Area 
Chart plug-in. The Area Chart features Specify X Values, DataY Compare, and Bevel, are 
disabled in stacked charts.
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Create a new container.
Add an Area Stack plug-in into this container.
Add two or more Area Chart plug-ins to become children of this container.
Add Data Y into each chart. They should have the same number of nodes.
In the settings of the Area Stack plug-in, press Initialize Stacked Chart to refresh the chart.
Use the Area Stack plug-in to set the chart parameters that are common for all charts in the 
stack.

Bar Stack

Create a stacked chart consisting of several Bar Charts.

This page contains the following topics and procedures:

Bar Stack Properties
To Create a Scene with Bar Stack

Bar Stack Properties
Initialize stacked chart: Refreshes the stacked chart, based on the Bar Chart plug-ins in the 
sub-containers. The stacked chart detects when a chart is added/removed from the stack, 
and updates the chart accordingly. However, some actions, such as re-ordering the charts 
within a stack, are not updated automatically. In these cases, press Initialize stacked chart to 
update the stack.
Stack Gap: Adds space between each chart.

Note: This plug-in is located in: Plugins -> Container plug-ins -> VisualDataTools

Note: The remaining properties in the Line Stack plug-in are the same as used in the Bar 
Chart plug-in. The Bar Chart features Specify X Values, DataY Compare, and Bevel, are 
disabled in stacked charts.
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To Create a Scene with Bar Stack

Create a new container.
Add a Bar Stack plug-in into this container.
Add two or more Bar Chart plug-ins to become children of this container.
Add Data Y into each chart. They should have the same number of nodes.
In the settings of the Bar Stack plug-in, press Initialize Stacked Chart to refresh the chart.
Use the Bar Stack plug-in to set the chart parameters that are common for all charts in the 
stack.

Data Fit

Data Fit listens for incoming data and modifies and redistributes it to another Shared Memory key.

This page contains the following topics and procedures:

Data Fit Properties
To Create a Scene with Data Fit

Data Fit Properties
Shared Mem: Changes between Scene-, Global- and Distributed-Shared Memory. Use Inactive 
memory to not forward any values via Shared Memory.
Transfer Mode: Sets string- or array-based data transfer.
Data Delim. Src.: Defines the value separator sign(s) for all data sources.
Data Delim. Dest.: Defines the value separator sign(s) for all data destinations.
Key Data Src.1-5: Shared Memory key name for input 1-5.
Key Data Dest.1-5: Shared Memory key name for output 1-5.
Scale: Scales each incoming value by that factor.
Offset: Adds an Offset to each incoming value.

Note: This plug-in is located in: Plugins -> Container plug-ins -> VisualDataTools
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Autoscale: Activates automatic scaling mode. Now all data is scaled to a certain range 
defined by the following two parameters:

Start: Determines autoscale starting range.
Stop: Determines autoscale stopping range.

To Create a Scene with Data Fit

This procedure feeds two charts with data. One with the original and the other with the modified 
data from Data Fit.

Create a new container.
Drag and drop a Data Storage and a Data Fit plug-in into this container.
Drag and drop two Bar Chart plug-ins to become children of this container.
Open the plug-in editor of the first Bar Chart and set Shared Mem. to Scene and KeyData to 

MyData .

Do the same for the second Bar Chart but use MyDataFit as the key name.
Go to the DataFit plug-in and set its Shared Mem. type also to Scene

Set Key Data Src.1 to MyData and Key Data Dest.1 to MyDataFit > set Scale to 2.0 . The 

input Shared Mem key is specified with Key Data Src. and the output with Key Data Dest.
Now edit Data Storage for the input values: set Shared Mem. to Scene, Key Data1 to MyData 

and type in some example values for Data1: 80,40,50,70,80,60,80 . As soon as you start 

typing you see both charts building up with the different values from Data Fit.

Data Import

This plug-in enables Microsoft Excel (.xls and .xlsx) and Microsoft Access (.mdb) file import via 
ADO, and distributes it to a text field or a shared memory map. The plug-in supports reading both 
numbers and text.
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To access Excel or Access data using this plug-in, you must first install the Microsoft Access 
Database Engine 2010 Redistributable .

This page contains the following topics and procedures:

Data Import Properties
To Create a Scene with Data Import

Data Import Properties
File: Chooses the required document.
Table / Sheet: Defines the name of the sheet or table.
Column(,Col...): Sets one or more column names to use (comma separated).
Area Input: Uses area information.
Column Input: Uses column information.
Row Input: Uses row information.
Data Delim.: Includes delimiter after each row.
Column Delim.: Includes delimiter for column separator sign(s).
Shared Mem.: Sets Scene-, Global- or Distributed-Shared Memory for data transport. Use 
Inactive memory to not forward any values via Shared Memory.
Key: Determines Shared Memory key name.
GetIt: Reads the document, sends the required data and shows it in the text box.

To Create a Scene with Data Import

This procedure imports data from an Microsoft Excel sheet and feed the Line Chart plug-in with 
data through Shared Memory.

Start Microsoft Excel.
Enter ExcelDataY into cell A1.

Add some sample values in the cells below (A2-A8:  80,40,50,70,80,60,80 ).

Note: This plug-in is located in: Plugins -> Container plug-ins -> VisualDataTools

http://www.microsoft.com/download/en/details.aspx?id=13255
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Rename this first sheet to MyTable (can be done with a double click on the sheet name at 
the bottom).
Save and close the Excel document.

Start Viz Artist and create a new scene. 

Add a group container to the scene tree.
Drag and drop the Line Chart and Data Import plug-in to the group container.
Add a material to the same group container.

Open the Transformation Editor and set Position X to  -200.0  and Position Y to  -100.0 .

Set Shared Mem. to Scene with MyDataY as Key name for both plug-ins.
Set Data Delim. to # for both plug-ins.

For the Line Chart plug-in set ChartWidth to  500.0 .

Activate DataY Fit, DataY Auto Scale and DataY Detect Limits.

Adjust DataY Stop to  200.0 .

Activate Const. Thickness to give the chart a constant line width.
For the Data Import plug-in, set the stored Excel file as the File parameter.
Enter MyTable for the Table/Sheet parameter and ExcelDataY for Column (,Col…).
Click the GetIt button and the chart shows.

Data Label

This plug-in enables graph labeling for all Financial plug-ins. All containers beneath the current 
container get labeled with the values from your Shared Memory variables.

This page contains the following topics and procedures:

Data Label Properties
To Create a Scene with Data Label
To Create Data Label on VDT Chart

For Area Chart, Bar Char, Line Chart and Pie Chart
For Scatter Chart
For Stock Chart

Data Label Properties
Shared Mem.: Changes between Scene, Global and Distributed Shared Memory. 
Use Inactive memory to not forward any values via Shared Memory.

IMPORTANT! You must close the document before importing it to Viz Artist.

Note: This plug-in is located in: Plugins -> Container plug-ins -> VisualDataTools
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Key Data: Determines Shared Memory key name.
Data: Input Parameter for data.
Transfer Mode: Sets string- or array-based data transfer.
Data Delim.: Defines the value separator sign(s).
Label Type: Sets the label type to numeric values (default) or alphabetic labels (to show 
weekdays, months, etc.).
Data Fit: Enables data normalization.

Data Threshold: Adds a definable offset to the detected limit.
Data Scale: Scales input by the selected factor.
Data Offset: Adds an offset to the incoming data.
Data Auto Scale: Enables automatic data normalization.
Data Detect Limits: Detects minimum and maximum of all values and scales them to 
adjusted Start and Stop.
Data Start: Lower Auto Scale edge.
Data Stop: Upper Auto Scale edge.
Nice Numbers: Rounds to the best fitting next number.
Remove Multiples: Removes multiple values.
Sort: Sorts data items in ascending or descending order.
Draw Zero: Shows or hides zero values.
Decimals: Adjusts decimal digits of all labels.
Custom Decimal Symbol: Enables a custom decimal symbol to be set.

Decimal Symbol: Specifies the decimal symbol.
Prefix: Adds a label prefix.
Unit: Defines a custom unit for your data values.
PosX, Y, Z: Positions container along the adjusted distance or uses numeric data value input 
to translate the label containers.
OffsetX, Y, Z: Translates the label container on the current axis.
DistanceX, Y, Z: Sets whole positioning distance for the containers on the current axis.
Copy Container: Adds new containers if there are fewer containers than values.
Use Alpha: Uses input data for alpha scaling.
Use Scaling: Uses input data for alpha scaling.
Animate Values: Lets the current number run from 0 to the defined end value.
Relative Length: If activated, each label has its own 100% (e.g. seven labels equal 700%).
Const. Speed: Sets the same animation duration for each label.
Total Length%: Sets the accumulated value of all labels in percent.
Alpha max.: Limits maximum alpha value.
Copy Container: Limits maximum scaling value.
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To Create a Scene with Data Label

Add an empty container to the scene.
Start with an empty scene and drag and drop a DataLabel and a DataStorage plug-in on a 
container in the scene-tree.
Add a Text child container

Go to the DataLabel plug-in, set Shared Mem. to Scene and KeyData to MyData .

In DataStorage also set Shared Mem. to Scene, Key Data1 to “MyData” and Data1 to e.g.: 

80,40,50,70,80,60,80 .

Go back to the DataLabel plug-in and activate Copy Container to create multiple instances of 
the text containers automatically. You see all labels located on the same position now. In the 
previous examples always the chart plug-in was responsible for the label positioning. In this 
example, we want to move that responsibility to the DataLabel plug-in itself.

Switch PosX to Range, DistanceX to 500.0  and OffsetX to -250.0 . We want to position the 

labels over a certain X, Y or Z range in space.

Set PosY to Range, OffsetY to -75.0  and DistanceY to 150.0 .

You can also do a value dependent translation by setting PosX, Y, or Z to Data

Set Sort to Ascending to sort the labels. You see that there are labels with the same values. 
We want to get rid of them and activate Remove Multiples for that. You can also try the Nice 
Numbers option now which searches for the next logarithmic style labels. But we continue 
with deactivated Nice Numbers parameter now.

Activate Animate Values and turn down Total Length[%] to 0.0 . Create a Key Frame, set 

Total Length[%] back to 100.0  and create another Key Frame.
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This creates an animation where the label values should count up to their final value.
Start the animation and see the labels counting and distributing over the specified XY 
range.

To Create Data Label on VDT Chart
When we put Data Label in the same container of Area Chart, Bar Char, Line Chart, Pie Chart and 
Scatter, Pos, Offset and Distance X, Y Z properties of Data Label can be controlled by VDT Chart

For Area Chart, Bar Char, Line Chart And Pie Chart

Go to VDT Chart plug-in and enable Pos. Container property.
By default, all position axes, X, Y and Z are enabled with Pos. Container property properties. 
These properties of Data Label are disabled and be controlled by VDT Chart with 
enabled Pos. Container property. 

For Scatter Chart

Add a sub container to the template container of Scatter Chart.
Add the font to be used as label to the new sub container and modify to proper size and 
position, text orientation and another properties.
Refresh scatter containers by dropping the template container into Container property of 
Scatter Chart.
Add a Data Label to the same container of Scatter Chart.
Update Data or Shared Mem. Key Data, Transfer Mode and Data Delim of Data Label plug-in 
to the same as the Scatter Chart plug-in.
Click Resend Data in the Data Storage plug-in if enabled.
Pos X, Pos Y and Pos Z properties of Data Label are disabled and are controlled by Scatter 
Chart.

For Stock Chart

Follow instructions of To Create a Scene with Data Label and set Key Data to the same as Key 
Open, Key Close, Key High or Key Low.
To set multiple Data Labels, each Data Label has to be in separate container, all of them can 
be children of the Stock chart.

Data Storage

The Data Storage plug-in stores data in the current Scene and sends it to the other plug-ins on 
startup. This plug-in helps artists during Scene design if there is no data source available, and to 
hold data within, for example, the Scene.

This page contains the following topics and procedures:

Note: This plug-in is located in: Plugins -> Container plug-ins -> VisualDataTools
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Data Storage Properties
To Store and Send Data
To Enable Data Input from External Sources

Data Storage Properties
Shared Mem.: Changes between Scene, Global and Distributed Shared Memory. 
Use Inactive memory to not forward any values via Shared Memory.
Key Data 1-5: Determines Shared Memory key name.
Data 1-5: Contains (separated) data.
Resend Data: Resends the actual values.

To Store and Send Data
Create a chart scene (e.g. using the Line Chart plug-in) and set Shared Mem. to Scene.
Add the Data Storage plug-in to the scene and set Shared Mem. to Scene.
Open the DataStorage editor and set the following parameters:

Shared Mem. to Scene.

Key Data1 to  Data1.

Data1 to  10, 20, 15, 30, 25, 40, 20.

Open the Chart plug-in editor and set the Key DataY value (e.g.  Data1 ) using the Key Data1 

value you set for the DataStorage plug-in.

Open the DataStorage editor and click the Resend Data button.

To Enable Data Input from External Sources
The following example builds on the previous example.

Add the Control Parameter to the scene tree. The Control Object plug-in is automatically 
added.

Note: The chart plug-ins have different property names (e.g. Data and Key Data). 
Also, some have X, Y or Z appended at the end, defining the axis.
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Open the Control Parameter editor.

Enter  FUNCTION*DataStorage*Data1  into the Parameter field.

Set Data Type to Text. This allows you to pass a string of numbers to the Control Parameter 
plug-in that are stored in the shared memory. It also allows your template designer or 
operator to further extend/enhance the input methods (e.g. through scripting).

Line Stack

Create a stacked chart consisting of several Line Charts.

This page contains the following topics and procedures:

Line Stack Properties
To Create a Scene with Line Stack

Line Stack Properties
Initialize stacked chart: Refreshes the stacked chart, based on the Line Chart plug-ins in the 
sub-containers. The stacked chart detects when a chart is added/removed from the stack, 
and updates the chart accordingly. However, some actions, such as re-ordering the charts 
within a stack, are not updated automatically. In these cases, press Initialize stacked chart to 
update the stack.
Stack Gap: Adds space between each chart.

To Create a Scene with Line Stack

Create a new container.

Note: This plug-in is located in: Plugins -> Container plug-ins -> VisualDataTools

Note: The remaining properties in the Line Stack plug-in are the same as used in the Line 
Chart plug-in. The Line Chart features Specify X Values, DataY Compare, and Bevel, are 
disabled in stacked charts.
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Add a Line Stack plug-in into this container.
Add two or more Line Chart plug-ins to become children of this container.
Add Data Y into each chart. They should have the same number of nodes.
In the settings of the Line Stack plug-in, press Initialize Stacked Chart to refresh the chart.
Use the Line Stack plug-in to set the chart parameters that are common for all charts in the 
stack.

4.5 Shader Plug-Ins
The default path for the Shader plug-ins is: <viz install folder>\plug-in.

4.5.1 Default
This folder is empty and reserved for custom Shader plug-ins.

4.5.2 Filter
The following Shader plug-ins are located in the Filter folder:

Blend Image
Blur
Color Balance
Radial Blur
Sepia
Sharpen

Blend Image

The Blend Image plug-in blends two images in different ways.

Tip: Most shaders also work on video clips.
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Blend Image Properties
Image: Image placeholder. Reset removes the image.
Mode: Available blend modes are:

Blend: Ordinary picture blending.
Darken: Uses the base or blend color, whichever is darker, as the destination color.
Lighten: Uses the base or blend color, whichever is lighter, as the destination color.
Multiply: Multiplies the base color with the blend color. The result color is always a 
darker color.
Screen: Multiplies the inverse of the base and blend color. The result color is always a 
lighter color.
Color Burn: Darkens the base color to reflect the blend color by increasing the 
contrast of the base and blend color.
Color Dodge: Brightens the base color to reflect the blend color by decreasing the 
contrast of the base and blend color.
Overlay: Screens or multiplies the colors depending of the base color.
Soft Light: Darkens or lightens the colors, depending on the blend color.
Hard Light: Multiplies or screens the colors, depending on the blend color.
Add: Brightens the base color to reflect the blend color by increasing the brightness.
Subtract: Subtracts the base and blend colors.
Inverse Subtract: Same as subtract but inverses the base and blend colors.
Difference: Subtracts either the base color from the blend color or the blend color 
from the base color depending on which color has the greater brightness value.
Inverse Difference: Same as difference but inverses the base and blend color.
Exclusion: Similar to the Difference mode, but lower in contrast.

Blend: Blends the image with the object.
Position X and Y %: Positions the image on the object.
Scale X and Y %: Scales the image.
Wrap: Wraps the object with the image. Available options are:

Repeat: Repeats the image.
Clamp: Clamps the image (no repeat).

Blur

The Blur plug-in blurs an object with an image texture and/or a material on it. Values can be 
animated. You also have a blur plug-in directly on the image editor, but that only works on one 
image, using the shader all images within a group can be blurred.

Note: This plug-in is located in: Plugins -> Shader -> Filter
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The samples above depict the same image with blur quality set to Low, Normal and High with a 
range of 100.0. The last is the original (reference) with no blur filter.

Blur Properties
Quality: Sets the quality of the blur filter. Low is more pixelated, whereas high is smooth. 
Available options are Low, Normal and High.

Range: Sets the range of the blur. Range is from 0.0  to 100.0 .

See Also

Radial Blur

Color Balance

The Color Balance plug-in determines brightness, contrast, saturation and hue.

Color Balance Properties

Brightness: Sets the brightness of the object. Range is 0.0  to 1000.0 .

Contrast: Sets the contrast of the object. Range is -1000.0  to 1000.0 .

Saturation: Sets the saturation of the object. Range is -1000.0  to 1000.0 .

Hue: Sets the hue of the object. Range is 0.0  to 360.0 .

Note: This plug-in is located in: Plugins -> Shader -> Filter

Note: This plug-in is located in: Plugins -> Shader -> Filter
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Radial Blur

The Radial Blur plug-in blurs objects in different ways.

The samples above depict the same image with radial blur quality set to Low, Normal, High and 

Very High with Center X and Y set to -25.0  and 25.0 , Inner Range and Scale set to 25.0  and 

50.0 , respectively.

Radial Blur Properties
Quality: Sets the quality of the blur filter. Low is more pixelated, whereas very high is 
smooth. Available options are Low, Normal, High and Very High.
Center X and Y: Sets the position of the object’s radial blur.
Inner Range: Sets the inner range of the blur.
Scale: Sets the scale of the object’s blur.

See Also

Blur

Sepia

The Sepia plug-in generates a sepia effect using two colors, and to adjust the desaturation and 
tone of the color for example to blend the image with the color scheme of the overall scene. Sepia 
is similar to what is known as duo tone in most photo editing suites.

Note: Radial blur does not clamp the object.

Note: This plug-in is located in: Plugins -> Shader -> Filter
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The samples above depict the same image with tone levels set to 100.0 , 50.0  and 0.0 . All 

other values are set to default. The last image is the original (reference) without the sepia plug-in.

Sepia Properties

Desaturation: Sets the saturation level. Range is 0.000  (color) to 100.000  (black & white).

Tone: Sets the color tone. Range is 0.000  to 100.000 .

Light Color: Specifies the light color and the strength of it. Range is 0.000  to 100.000 .

Dark Color: Specifies the dark color and the strength of it. Range is 0.000  to 100.000 .

Sharpen

The Sharpen plug-in sharpens the given images on objects.

The samples above depict the same image with Quality set to High, and Scale values at 0.0 , 

100.0 , 200.0  and 300.0 , respectively. Range is set to 25.0  (default). The first image is the 

original (reference) with Scale set to 0.0 .

Sharpen Properties
Quality: Sets the quality of the sharpen filter. Low is more pixelated, whereas high is 
smooth. Available options are Low, Normal and High.
Range: Includes more more pixels in the operation when the value is increased.

Note: The color range is from 0.0 - 100.0  divided by 255 (0.392, 0.784 etc.).

Note: This plug-in is located in: Plugins -> Shader -> Filter

Note: This plug-in is located in: Plugins -> Shader -> Filter
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Scale: Sharpens the image when the value is increased.

4.5.3 Material
The following Shader plug-ins are located in the Material folder:

Anisotropic Light
Bump Map
Cartoon
Gooch
Lighting Shader
Simple Bump Map

Anisotropic Light

The Anisotropic Light plug-in uses a lookup texture to compute the distribution of the specular 
component. All the shader properties are defined by the material of the container. Only Light 
number 1 is used and the light is always treated as a local light source.

In the figure below, the left image is with anisotropic light and the right image is with a regular 
material.

Anisotropic Light Properties
This plug-in does not have any properties or parameters.

Bump Map

The Bump Map plug-in simulates complex surface structures. Instead of using many triangles to 
render a 3D object with many structures on its surface, use bump mapping to get a similar result.

Note: This plug-in is located in: Plugins -> Shader -> Material
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Use plug-ins for Adobe Photoshop, Gimp, built-in functions of your modeling package or Nvidia’s 
tool called Melody.

Bump Map Properties
NormalMap: Stores a direction of normals directly in the RGB data. Move an normal map via 
drag and drop onto this field.
HeightMap: Move an height map via drag and drop onto this field. The Height Map file is 
only visible and used when parallax mapping is enabled.
Light Source: Selects the light source in the range 1-8. Please consider that only one light 
source is possible. By default, the first light source is used.
Position X and Y: Defines the position of the normal map in X-direction and Y-direction.
Scale X and Y: Scales the normal map, respectively changes the width and height size of the 
image.
Wrap: Repeats or clamps the bump map for the image.
Toggle X and Y: Changes the direction of the normals stored in the normal map image.
Scale Height: Changes the intensity of the bump map effect. Scale Height is visible when 
parallax mapping is enabled.
Parallax Mapping: Provides an additional map to the texture for more apparent depth and 
the object is more realism.

See Also

Simple Bump Map

Cartoon

The Cartoon plug-in renders objects in a cartoon like manner. Shading is done in steps and you 
can define number of steps, the brightest color and the darkest color. Edge width allows you to 

Note: Make sure the geometry supports tangent space vectors. Otherwise, use the Simple 
Bump Map shader.



Note: This plug-in is located in: Plugins -> Shader -> Material
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blend between the steps. Material and texture of the container are ignored. Only Light number 1 is 
used and the light is always treated as local light source.

Cartoon Properties
Shades: Defines number of shade levels.
Edge Width: Creates a smooth effect. The transitions are more hard or more soft.
Silhouette Width: Sets the width of the contours around the rendered objects.
Silhouette Color: Sets the color of the contours around the rendered objects. Additionally, 

you can select the alpha value if you want transparent areas. 0%  (Invisible) - 100%  (Visible).

Surface High: Sets the color in the broad range. Additionally, you can select the alpha value 

if you want transparent areas.  0%  (Invisible) -  100%  (Visible).

Surface Low: Sets the color in the dark range. Additionally, you can select the alpha value if 

you want transparent areas.  0%  (Invisible) -  100%  (Visible).

Gooch

The Gooch plug-in is a per pixel light with a reflective high light. Material of the container is 
ignored, only the shader parameters are used to define the surface color. Texture mapping works 
as usual, but the texture can be blended with the surface color using the Texture Alpha parameter. 
Only Light number 1 is used and the light is always treated as local light source.

In the figure below, the left image is with Gooch and the right image is with a regular material.

Note: This plug-in is located in: Plugins -> Shader -> Material
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Gooch Properties
Surface: Describes the intensity of color like the ambient color of a material.
Cool: Defines the cool color. Both colors cool and warm are merged. The result is a color 
gradient.
Warm: Defines the warm color.
Highlight: Sets the diameter of the highlight.
Highlight Alpha: Sets the alpha or transparent value of the highlight.

Texture Alpha: Describes the visible value of the texture image in percent.  0%  (Invisible) -

100%  (Visible).

Lighting Shader

The Lighting Shader plug-in performs per-pixel lighting, as opposed to default per-vertex lighting 
in Viz.

Lighting Properties
Specular Type:  Shows the color that appears when light comes from a particular direction 
and bounces back from the surface in a mirrored direction. The specular color is the direct 
reflection of a directional light source. This is the typical effect of shiny metal and plastic. 
Specular color can be understood as a kind of shininess of color.

Note: This plug-in is located in: Plugins -> Shader -> Material

Note: This plug-in is located in: Plugins -> Shader -> Material
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Simple Bump Map

The Simple Bump Map plug-in simulates complex surface structures. Instead of many triangles to 
render a 3D object with many structures on its surface you can use bump mapping to get a similar 
result.

You can only use a gray scaled image as normal map. If you want a more accurate result and better 
effects please use the Bump Map plug-in instead which is using an RGB normal map image.

To generate a Simple Bump Map you can use the plug-ins for Photoshop, Gimp, the built-in 
functions of your modeling package or NVIDIA’s tool Melody. The Height Map (used for parallax 
mapping) should be a grayscaled image (white -> highest, black -> lowest bumps).

Simple Bump Map Properties
NormalMap: Stores a direction of normals directly in the RGB data. Move an normal map via 
drag and drop onto this field.
HeightMap: Move an height map via drag and drop onto this field. The Height Map file is 
only visible and used when parallax mapping is enabled.
Light Source: Selects the light source in the range 1-8. Please consider that only one light 
source is possible. By default the first light source is used.
Position X and Y: Defines the position of the normal map in X-direction and Y-direction.
Scale X and Y: Scales the normal map, respectively changes the width and height size of the 
image.
Wrap: Repeats or clamps the bump map for the image.
Toggle X and Y: Changes the direction of the normals stored in the normal map image.
Scale Height: Changes the intensity of the bump map effect. Scale Height is visible when 
parallax mapping is enabled.
Parallax Mapping: Provides an additional map to the texture for more apparent depth and 
the object is more realism.

Note: All calculations are done in object space.

Note: This plug-in is located in: Plugins -> Shader -> Material
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See Also

Bump Map

4.5.4 RealFX
The RealFX plug-in set enables you to create particle effects in Viz Artist.

Particle systems are a computer graphics technique to simulate certain physics-based effects, 
which are otherwise very hard to reproduce with conventional rendering techniques. Examples of 
such effects which are commonly replicated using particle systems include fire, explosions, smoke, 
weather effects, sparks, falling leaves, dust, meteor tails, or abstract visual effects like glowing 
trails, magic spells, etc.

The particle effects in Viz Artist run in real-time, meaning that there are a few inherent constraints 
that must be taken into account when considering best practices for employing this plug-in set. 
For example, there is a trade-off between the number of particles and performance optimization; 
more generally there needs to be a considered balance between performance and visual quality.

RFxSmoke is the baseline plug-in within the RealFX plug-in set. The remaining plug-ins in this set 
are applied on top of RFxSmoke in any given container. RFxSmoke includes built-in functionality 
and the ability to host the additional functionality contained in the other plug-ins in this set. Part 
of the built-in functionality (for example, Turbulence) is kept for compatibility with previous 
versions of Viz Artist.

There are three categories of additional plug-ins:

Birth plug-ins: Refers to where the particles are spawned.
Motion control plug-ins: Governs the position, direction, velocity, size and color of each 
particle.



Plug-ins User Guide -  5.0

Copyright © 2022  Vizrt Page  417

•

•
•
•

•
•
•

Texture control plug-ins: Affects the texture mapping and the “look” of each particle by 
using pixel shader technology.

This section contains information on the following topics:

RFx2DSphere
RFxClouds
RFxFlame

See Also

RealFX plug-ins in Geometry Plug-ins
pxColorWorks in Container Plug-ins
RFxSmoke

RFx2DSphere

The RFx2DSphere plug-in creates a 2D sphere-like look on each particle. The sphere is affected by 
light sources.

Note: This plug-in is located in: Plugins -> Shader -> RealFX



Plug-ins User Guide -  5.0

Copyright © 2022  Vizrt Page  418

•
•
•

•
•
•
•

RFx2DSphere Properties
Adjust the following parameters as required to achieve the required effect:

Color Mode (Material, Color, Color-Material)
Radius
Blend

RFxClouds

RFxClouds

The RFxClouds plug-in creates a dynamic plume-like texture on each particle, and changes 
randomly for each particle over time. It can be used on clouds and smoke.

RFxClouds Properties
Adjust the following parameters as required to achieve the required effect:

Brightness
Turb Scale X
Turb Scale Y
Turb Speed

RFxFlame

The RFxFlame plug-in creates a dynamic flame-like texture on each particle, and changes randomly 
for each particle over time.

RFxFlame Properties
This plug-in has no editable parameters.

Note: This plug-in is located in: Plugins -> Shader -> RealFX

Note: This plug-in is located in: Plugins -> Shader -> RealFX
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4.5.5 Texture
The following Shader plug-ins are located in the Texture folder:

Drop Shadow
Emboss
MultiTexture
Substance

Drop Shadow

The Drop Shadow plug-in generates 2D shadow of a texture.

Drop Shadow Properties
Distance: Sets the distance of the shadow.
Direction: Sets the direction of the shadow in degrees.
Threshold: Sets the shadow threshold.
Soft Shadow: Enables the Soft Distance parameter for applying a soft shadow.

Soft Distance: Sets the distance of the soft shadow.
Color: Sets the color of the shadow.

Emboss

The Emboss plug-in allows you to raise highlighted surfaces and lower shadows of textures and 
images creating an embossed look.

Note: This plug-in is located in: Plugins -> Shader -> Texture

Note: This plug-in is located in: Plugins -> Shader -> Texture
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4.
5.

6.
•

7.
8.

Emboss Properties
Direction: Sets the direction of the emboss. Options are:

None
South-East
South-West
North-East
North-West

Emboss: Sets the Emboss level, in percentage.

MultiTexture

The MultiTexture plug-in blends (linear) two textures together.

To Create a Simple Blended Image Scene
Create a new Container.
Add an image to the new Container.
In the Image Editor set the image to:

Unit: Level one
Inheritable

Create a Sub Container.
Add an image to the Sub Container.

In the Image Editor set the image to:
Unit: Level two

Add the MultiTexture plug-in to the Sub Container.
Click on the MultiTexture plug-in.

Note: This plug-in is located in: Plugins -> Shader -> Texture
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9. Adjust the image blend as required.

Blended Images Example

Substance

The Substance Shader plug-in renders Allegorithmic PBR (Physically Based Rendering) substances 
in Viz Engine. The plug-in takes into account the position, color and enabled/disabled state of the 
first eight Lights in the Scene. It also supports materials with alpha properties.

Note: This plug-in is located in: Plugins -> Shader -> Texture
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Substance Properties

The following options are available in the Basic Tab of the Substance Shader. The substance 
settings depend on the settings the creator of the material has exposed:

Substance: Uses a PBR Substances item (.sbsar file). Drag to the drop zone.
Environment Map: Uses a latitude/longitude panorama environment map image. Drag to the 
drop zone.

Anisotropic Filtering: Sets the image quality. The default value is  4X .

Relief Amount: Sets the relief amount that the shader applies.
Tiling: Sets the tiling.
Emissive Intensity: Sets the intensity of the emissive properties (if the substance has any).
Ambient Intensity: Sets the ambient light taken into account by the shader.
sRGB Base Color: Converts the base color map to sRGB (default: on).
Texture Rotation: Sets the rotation of the texture on the geometry.
Texture Scaling X/Y: Sets the scaling of the texture on the geometry.
Texture Position X/Y: Sets the position of the texture on the geometry.

To Create a Substance Shader Effect
Create a new Container.
Add a Cube geometry.
Add the Substance Shader.

Note: The Substance properties panel parameters are different for each selected 
Substance.
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Drag a Substance to the Substance drop zone.
Drag a latitude/longitude panorama image to the Environment Map drop zone.
Use the Substance Shader properties to modify the result, if required.
Click Substance Settings to adjust the properties in the Substance properties panel.

Substances use two different file extensions, .sbs and .sbsar:

.sbs files are editable substance source files. Use Substance Designer with these files. 

.sbsar files are performance optimized, published substances.

You can import .sbsar files into Viz Artist. They must be Physically Based Rendering (PBR) 
materials to work correctly in Viz Artist. Make sure you create the correct material type when 
creating Substance shaders in Substance Designer.

To create a .sbsar file, first create a Shader with Substance Designer, and then publish this shader 
for import to Viz Artist. To view and adjust the parameters of a shader, switch to the Substance 
Settings panel. The parameters in the settings panel are different for each loaded substance, 
depending on the type of shader. The only supported type of shader in Viz Artist is PBR Metallic/
Roughness.

Substance Basic
Here you can adjust the basic settings of your Substance Shader.

Note: The import and use of Substances in Viz Artist requires a separate license. You 
obtain this license, as well as a license for the Allegorithmic Substance Designer and the 
Substance PBR database, from your local Vizrt representative.



Tip: If you get the error message This is not a valid Substance when you apply the shader 
in Viz Artist, you need to make sure you have a PBR Metallic/Roughness material created in 
Substance Designer.
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Substance: Drag the desired Substance shader from the Viz database section to this drop-
field.
Environment Map: Drag any RGB or HDR environment map that should be reflected on the 
surface to this drop-field. The strength is controlled by the Ambient Intensity and by the 
metallic setting exposed individually in a Substance shader.
Anisotropic Filtering: Increases the load on the GPU during shader calculation at higher 

settings. This is usually set between 0-4 .

Relief Amount: You only need to adjust this setting for relief shaders.
Tiling: Lets you specify the number of tiles.
Emissive Intensity: Change this setting for a higher emission rate of your shader.
Ambient Intensity: Controls the blending when you have an Environment texture applied to 
your Substance shader.
sRGB Base Color: Uses the sRGB color space model when enabled.
Texture Rotation: Rotates the texture applied to your geometry. This rotation has a 
limitation in the rotation degree of freedom, If the limit is reached, you need to change the 
rotation in your Substance shader.
Texture Scaling X: Scales the applied texture/shader on the x axis.
Texture Scaling Y: Scales the applied texture/shader on the y axis.
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Texture Position X: Changes the X  position of the applied texture/shader on the x axis.

Texture Position Y: Changes the Y  position of the applied texture/shader on the y axis.

Substance Settings
The settings of each Substance Shader are different, depending on the material itself. All 
Substance shaders have in common that they need to generate a texture from the procedural 
shader description created in Substance Designer. If you are creating texture based shaders, you 
need to ensure that your base texture has enough resolution. All other settings and sliders in the 
Substance shaders vary with each different shader, depending on which features are exposed in 
each individual shader. Some settings are exposed for almost any existing shader from the 
Substance PBR library. These include Hue Shift, Saturation, Luminosity, Contrast, Normal Format, 
Output Size and $randomseed. If you create your own shaders in Substance Designer, you must 
expose the modifiers manually from Substance Designer if they are to be editable in Viz Artist.
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How to Create Substance Shaders with Substance Designer
This section gives you a brief introduction on how to create a PBR Metallic/Roughness material in 
Substance Designer. Substance Designer allows you to create procedural materials as well as 
texture/scan based materials. Please see the Allegorithmic website and their Youtube channel for 
more detailed information on how to work with Substance Designer: https://
www.allegorithmic.com/.

Tip: Check the Nvidia GPU meter to see performance used by the shaders.

https://www.allegorithmic.com/
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When you create a new Substance in Substance Designer, you need to select the Physically Based 
(Metallic/Roughness) Graph Template. Otherwise, this shader does not work properly in Viz Artist, 
causing the error message This is not a valid Substance. When saving a Substance shader/material, 
it is saved as an .sbs file. These files cannot be imported into Viz Artist. To import Substance 
shaders in Viz, you need to publish the material to an .sbsar file.

The shader graph of each material looks different. Here are a few examples for different shader 
graphs with PBR Metallic/Roughness materials, reaching from simple texture shader graphs to 
complex procedural shader graphs.
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Simple Texture Shader

In the shader graph, you see the five Output channels for the PBR material: Base color, Normal, 
Roughness, Metallic, and Height. All outputs are generated automatically from a simple input 
texture.
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Basic Procedural Shader

In the shader graph, you see the four Output channels for the PBR material: Base color, Normal, 
Roughness, and Metallic. All outputs are generated and mapped manually.
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Complex Procedural Shader

Here you see a very complex procedural shader graph, constructed with different modifiers and 
functions, generating the necessary output for Base Color, Normal, Roughness, Metallic and 
Height.

Publishing Shaders
When you want to import the Substance shaders in Viz Artist, you need to publish them from 
Substance Designer instead of saving them. The difference between publishing and saving is that 
the shader is performance optimized when published. Published shaders cannot be opened by 
Substance Designer, so it is important to keep your .sbs files and .sbsar files together in case you 
need to make changes to your shader later on.

To publish the shader, right click the shader/package and select Publish .sbsar file.

Tip: Only PBR Metallic/Roughness materials from Substance Designer are supported in Viz 
Artist.
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Substances Performance
Substance shaders are computed on your GPU. Vizrt recommends an Nvidia M-series graphics card 
or higher to work efficiently with Substances. Since Substances run exclusively on the GPU, you 
should check the Nvidia GPU meter when working with Substances inside Viz to have full overview 
of the rendering performance. There should be a section called Manage GPU Utilization in your 
Nvidia Control Panel. Check the performance of the Substance shaders here.

Tip: You can find documentation and training with Substance Designer on https://
www.allegorithmic.com/ as well as on the Allegorithmic Youtube channel.



https://www.allegorithmic.com/
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4.5.6 Effects
The following Shader plug-ins are located in the Effects folder:

Chroma Keyer
Fluid
Frame Mask
Image Mask
LED Panel
Soft Mask
Water Shader
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Chroma Keyer

The Chroma Keyer plug-in clears regions in a video defined by a color. The color-space of this 
Shader is YUV, which is defined as following:

The luminance (Y) component determines the brightness of the color, while the U and V 

components determine the color itself (the chroma). Luminance (Y) ranges from 0.0  (dark) to 

1.0  (bright). U and V ranges from -0.5  to 0.5 .

Chroma Keyer Properties
Video: Sets the input video channel for keying. Be sure that for the set video channel the 
Keying Mode has been set to M-Zone.
Blend: Sets the alpha for the key signal.
Fit: Alters size to fit Screen or Object.
Invert: Flips the key signal.
Sampling Filter:

Nearest: Takes color information from one pixel.
1D-Filter: Takes color information after applying a 1D-linear filter.
2D-Filter: Takes color information after applying a 2D-linear filter.

Luminance: Sets the luminance.

Basic parameters for first method:

HueAngle: Selects the color to key in YUV space.
OpeningAngle: Determines tolerance for the color in YUV space.

KeyGain: Determines gradient for borders to neighboring colors ( 1 =soft, 10 =sharp).

Note: This plug-in is located in: Plugins -> Shader -> Effects
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SatMin: Determines lower saturation limit for keyed colors.

SatMinGrad: Determines gradient for lower saturation limit ( 0 =sharp,  1 =soft).

SatMax: Determines upper saturation limit for keyed colors.

SatMaxGrad: Determines gradient for upper saturation limit ( 0 =sharp,  1 =soft).

Basic parameters for second method:

U-Color: Determines U-value for color keying.
V-Color: Determines V-value for color keying.
UV-Diameter: Removes all colors between the reference UV and this diameter.

UVGradient: Determines gradient for fade out at diameter border ( 0 =sharp,  1 =soft).

Removing keying from Highlights and Shadows:

LumMin: Sets lower luminance limit for keyed colors.

LumMinGrad: Sets gradient for lower luminance limit ( 0 =sharp, 1 =soft).

LumMax: Sets upper luminance limit for keyed colors.

LumMaxGrad: Sets gradient for upper luminance limit ( 0 =sharp,  1 =soft).

Sampling reference point:

UVRangeCheck: Obtains information about the sampled color.
URangeMin: Defines the minimum UColor that should be accepted.
URangeMax: Defines the minimum UColor that should be accepted.
VRangeMin: Defines the minimum UColor that should be accepted.
VRangeMax: Defines the minimum UColor that should be accepted.
SampleTrustiness: Determines percentage of samples in the limited UV-Color space.
Pos. X: Deternines X-coordinate for sampling.
Pos. Y: Deternines Y-coordinate for sampling.

Width: Sets number of pixels in x-direction.
Height: Sets number of pixels in y-direction.
Sample at Pos: Replaces XY-coordinates of the object center if Pos. X and Pos. Y are enabled. 
If disabled, the XY-coordinates are set by values in the interface.
Get Sample: Samples another time the reference point.

Fluid

The Fluid plug-in provides a geometry mesh with some elasticity during animation.

Note: The origin of the coordinate system is in the upper left corner.
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Fluid Properties
Inertia: Sets the inertia of the motion.
Strength: Sets the strength of the motion.

Frame Mask

The Frame Mask plug-in adds a framed mask around an object (e.g. image or geometry). In the 
properties, the aspect ratio can also be set.

Frame Mask Properties
Left, Right, Top and Bottom Edge: Sets the tracked borders (see also Tracking).
Left, Right, Top and Bottom Gradient: Sets the gradient from the edge of the frame to the 
edge of the object.

Aspect Ratio: Sets the aspect ratio (16:9, 4:3 or Custom), if required (default is  Off ).

Custom: Uses to set a custom aspect ratio (e.g. 1.85:1 or 2.39:1).

Note: This plug-in is located in: Plugins -> Shader -> Effects

Note: This plug-in is located in: Plugins -> Shader -> Effects
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Tracking: Uses a Container to track the location of the actual frame mask instead of 
animating all tracked borders manually. Drag a Container to the drop zone (1):

Image Mask

The Image Mask plug-in applies a mask to an image using other images (e.g. an alpha image).

Image Mask Properties
Image: Placeholder for image.
Blend: Blends the image with the object.
Position X, Y %: Sets the position of the mask in percentage for the screen or object.
Scale X, Y %: Sets the size of the mask in percentage for the screen or object.
Fit: Selects the size of the image mask to the screen or the object:

Note: This plug-in is located in: Plugins -> Shader -> Effects
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Screen: Sizes the image mask to the screen. If the object is moved, it moves while the 
image mask stays fixed.
Object: Sizes the image mask to the object. If the object is moved, the image mask 
moves with it.

Wrap:
Repeat: Applies the image mask multiple times on the screen or object.
Clamp: Applies the image mask once on the screen or object.

Mask Aspect: Sets the aspect of the image mask to the screen or the object.
Invert: Inverts the image.
Alpha only: Enables the alpha channel for the image (for example, an RGBA image).
Soft Mask: Applies a soft mask (available when Fit is set to Screen).

LED Panel

The LED Panel plug-in creates an LED panel style texture.

LED Panel Properties
Pixel Size: Determines the size of pixels in the LED board.

Billboard Size X: Determines the width of the LED board (e.g. using a Pixel Size of 1  and a 

Billboard Size of 10  shows ten LEDs).

Billboard Size Y: Determines the height of the LED board.
Tolerance: Threshold that defines which pixels belong to an LED.
Pixel Radius: Sets the maximum size/radius of the LED.
Luminance Steps: Determines number of discrete luminance steps the LED panel is able to 
show.
Luminance Boost: Determines factor to increase luminance.
Color Boost: Enhances the RGB values of the image.
Noise: Defines texture where LEDs are already burnt out or damaged (white is interpreted as 
functional, black is treated as damaged).
Wrap: Sets whether to use texture repeat or clamping mode.
Burnt Out Percent: Determines the percentage of pixels that appear to be broken or burnt 
out.
Background Color: Determines the background color of the LED board.

Note: This plug-in is located in: Plugins -> Shader -> Effects
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Soft Mask

The Soft Mask plug-in applies a soft mask to an object (e.g. image or geometry).

Soft Mask Properties

Progress: Moves the mask perpendicular to the mask direction. Default is 0.0  and is based 

on the configured center position.
Rotation: Rotates the mask around the center.
Keep Aspect: 
Center X and Y: Defines the X and Y position of the center of the mask.
Gradient Width: Sets the size of the gradient.
Invert: Inverts the mask.
Mirror Gradient: Mirrors the mask on both axis.
Blank: Offsets the area that should not be affected by the mask.
Tracking: Allows the progress to be controlled by a tracked Container to build the progress 
animation easier. Drag a Container to the drop zone.

Water Shader

The Water Shader plug-in simulates a water surface.

Note: This plug-in is located in: Plugins -> Shader -> Effects



Plug-ins User Guide -  5.0

Copyright © 2022  Vizrt Page  439

•
•
•
•
•
•

•

•
•
•

•
•
•

Water Shader Properties
Bump Height: Sets the height of the bump map.
Bump Speed: Moves the bump map of the surface. Useful to simulate a current.
Bump Scale: Scales the bump map.
Wave Frequency: Sets the frequency of the wave.
Wave Amplitude: Sets the amplitude of the wave.
Wave Speed: Defines the big waves of the water. You need geometry with many vertices to 
get smooth waves.
Environment Map: Defines the texture which is reflected in the water. If no texture is 
applied, the shader uses a default texture. The size of the environment map should be kept 
low (512x512 max), because it can consume a lot of texture memory.
Deep Water: Sets the color of deep water.
Shallow Water: Sets the color of shallow water.
Reflection: Sets the color of the reflections.

Water Amount: Controls how the deep and shallow color affects the look of the water.
Reflection Amount, Bias, Power and Multiplier: Controls the reflection.
Blend Texture: Allows you to blend the texture of the container into the water.

4.5.7 RTT Advanced Materials
RTT Advanced Materials plug-ins allow you to create a number of high-quality materials using 
state-of-the art shader technology. Using the plug-ins is very easy. Simply drag the shader plug-in 
of your choice onto selected geometry, assign a material and set up the additional parameters as 

Note: This plug-in is located in: Plugins -> Shader -> Effects

Note: The blending of deep and shallow water depends on the angle of the camera 
and how it looks at the water.
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shown by the shader in its own editor. Some plug-ins remain inactive until you have applied all 
necessary textures, depending on the shader plug-in. This may include a basic texture on your 
container and/or additional textures to be dropped in the plug-in interface. You can modify all 
parameters of the applied material on your object, such as Ambient Color, Diffuse, Specular and 
Emission, Shininess and Alpha. All these parameters also affect the shader.

All RTT Advanced Materials plug-ins (except the Bump Optimized Shader) allow manipulating the 
texture mapping of each texture map individually. This means you can use a different position, 
rotation and scaling for each texture. As for the mapping of additional textures inside the Shader, 
the same mapping method as being assigned to the texture on your container is used. It is also 
possible to change the alignment of the environment textures to achieve the correct reflections on 
the respective object surface.

If you do not want to use individual texture transformations, you may switch the option off. Each 
additional texture (except the environment texture) offers the button Enable Individual Transform. 

With the button turned Off , the texture mapping coordinates of the base texture is used.

RTT Shaders support up to eight light sources. The supported light types are infinite and local 
lights; also the light color of these lights is supported.

If you import the Viz Artist/Engine archive RTT_ShaderPresets_V1, you obtain about 60 sample 
scenes which are meant to give you an idea how to work with the Shaders. These presets are free 
to use, but in general, they are thought as a guideline for how to work with textures and the 
Shaders. Correctly working with the textures dramatically improves the look of your Shader. The 
Shaders use color maps, bump maps (in the normal map format), specular maps and cubic 
environment maps in HDR and LDR formats.

Creating color maps is straightforward. They are regular RGB textures that you can use either on 
the container or inside the Shader, depending on the Shader you are using.

Creating specular maps is also straightforward. They are grayscale textures where you define, 
through a gradient from white to black, where light is reflected or not.

Creating normal maps for the bump inside your Shader is not complicated either; just go to 
Nvidia's corporate web page and download the relevant Nvidia Photoshop plug-ins, or use this link 
Nvidia Texture Tools for Adobe Photoshop.

After installing the filter in question, you have a new section in the filter category in Adobe 
Photoshop. By applying this filter, you are shown a window with various settings (Please read the 
corresponding Nvidia User’s Guide); yet there is not much work involved. Just have a look at the 
settings in the Nvidia Photoshop plug-in Image below and start exploring them on your own.

http://developer.nvidia.com/object/photoshop_dds_plugins.html
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Creating Cubic Environment maps is no secret either. Cubic Environment Maps can be rendered 
either with a preferred Render Engine (Mental Ray, V-Ray, etc.), if it should be a 3D generated 
environment map, or they can be created with HDR Images, which are then transformed with HDR 
Shop.

If you do not have a license for the RTT Advanced Materials plug-ins, you may contact either one of 
your local Vizrt Support people or you can send an e-mail to license@vizrt.com to obtain either a 
time-limited demo license or a full license. Without a license, you can load the preset scenes, but 
you cannot modify them; only a few parameters are adjustable.

This section also contains information on the following topics:

Cube Map
HDR
Normal Map

Note: HDR Shop has a menu for panoramic transformations, here you can create a cubic 
environment image by transforming it from latitude/longitude to an cubic environment by 
just a few mouse clicks (see instructional video).



Note: Creating Cubic Environment Maps (HDR or LDR) is a well known technique for 3D 
experts. This Viz Artist User Guide does not explain the creation of these Environment 
Maps in detail, as there are numerous tutorials on the web for this texture creation 
procedure.



http://hdrshop.com/
mailto:license@vizrt.com
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Fresnel
RTT

Cube Map
Cube map textures are typically used for approximated environmental reflection and refraction. 
They consist of a set of six two-dimensional textures that form a textured cube centered at the 
origin. Unlike 2D sphere maps, they grant higher details for the whole environment. The RTT 
Advanced Materials plug-ins accept only cube maps as reflection textures and require them to be 
stored in a vertical cross layout. Cube maps can soon be created easily by using the Dynamic 
Texture plug-in. To achieve the best results with the Shaders we strongly recommend to create 
your cube maps in HDR format.

HDR
HDR (High Dynamic Range) images can store a much wider range of brightness values than 
common (i.e. low dynamic range) images. Therefore, it is possible to create more brilliant 
highlights and reflections when using HDR images. HDR images can be shot by using special 
spherical cameras, or created with the aid of HDR image processing tools. Furthermore ready-to-
use HDR cube maps are available as DVD collections. All plug-ins with environmental reflections 
support HDR cube maps. .hdr format images are supported.

Normal Map
Normal maps are textures used to calculate bump mapping. They encode surface details (i.e. the 
normals of a surface) as RGB color values and therefore show usually in some shades of blue. They 
can be created easily from (grayscale) height maps with plug-ins for Adobe Photoshop or Gimp.

Fresnel
The Fresnel effect describes how much light is reflected on a surface and how much light is 
refracted through this surface. At shallow angles the reflection is strong while there is almost no 
refraction.

RTT
All RTT Advanced Materials are developed by Realtime Technology AG. Realtime Technology AG is 
a worldwide leading supplier of 3D real-time visualization technologies and services for industrial 
applications in the automotive, aircraft and consumer goods industries.

Note: The vertical cross cubemap size is required to be one of the following: 192 by 256, 
384 by 512, 768 by 1024, 1536 by 2048 or 3072 by 4096 pixels, where a higher 
resolution indicates higher image quality. The general rule of thumb is that the contained 
six images need to have power-of-2 resolution.



Note: All RTT shaders can be uninstalled from the Viz Artist/Engine program menu.
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Anisotropic Light Shader

The Anisotropic Light Shader plug-in calculates a highlight to simulate advanced surfaces. The 
highlight can be controlled in using two parameters. In addition, a color texture can be used to 
add more details. This shader is particularly useful when no surrounding reflection is required.

Anisotropic Light Shader Properties
Roughness X and Y: Controls the width and height of the anisotropic highlight.
Color Map 2: Offers the possibility to assign a second diffuse color texture that is blended 
with the first color texture (according to the chosen technique)
Enable Individualized Transform: Activates the option to define an independent 
transformation (Position, Rotation and Scale values next to the Image Parameter) for Normal- 
and/or Bumpmaps instead of using the regular texture coordinates.
Technique: Shows a list of available techniques.

Standard: Is a technique that creates an anisotropic highlight (to be used with 
geometry that has no texture coordinates and normals).
Standard_Texture: Is a technique that mixes a diffuse texture color into the material 
color.
Standard_MultiTexture_Add: Is a technique to additively blend Color Map 2 with the 
texture.
Standard_MultiTexture_Blend: Is a technique to blend Color Map 2 with the texture 
according to their alpha values.
Standard_MultiTexture_Subtract: Is a technique to subtractively blend Color Map 2 
with the texture.

Note: This plug-in is located in: Plugins -> Shader -> RTTAdvancedMaterials
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Standard_MultiTexture_Modulate: Is a technique to blend Color Map 2 by multiplying 
it by the texture.
Binormal: Is a technique to create an anisotropic highlight using binormals and 
tangents of the geometry (to be used with geometry having texture coordinates and 
normals).
Binormal_Texture: Is a technique to mix a diffuse texture color into the material color.
Binormal_MultiTexture_Add: Is a technique additively blend Color Map 2 with the 
texture.
Binormal_MultiTexture_Blend: Is a technique to blend Color Map 2 with the texture 
according to their alpha values.
Binormal_MultiTexture_Subtract: Is a technique to subtractively blend Color Map 2 
with the texture.
Binormal_MultiTexture_Modulate: Is a technique to blend Color Map 2 by multiplying it 
by the texture.

Best Practices
Apart from the parameters in the plug-in container, it is necessary to assign a material. When 
applying a texture technique it is compulsory to assign a texture as a color/basic texture. In case 
of multi texturing, an additional second texture must be assigned in the corresponding Shader 
rollout. Therefore, do not forget to adjust material parameters in addition, such as ambient, 
diffuse, specular color and shininess.

Brushed Metal Shader

The Brushed Metal Shader plug-in uses bump mapping and reflections from a cube map, the 
impression of more sophisticated metal surfaces, such as brushed metals, is created. The surface 
is lit by an anisotropic highlight. To describe the surface structure, a normal map is used.
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Brushed Metal Shader Properties
Roughness X and Y: Controls width and height of the anisotropic highlight.
Bump Height: Affects the height of the created bumps and wrinkles on the surface.
Environment Reflectivity: Manipulates the influence of the reflection color from the 
environment map on the resulting color.
Reflection Multiplier / Exposure: Affects the exposure of the environment map. This is 
especially helpful when working with HDR images.
Gamma of EnvMaps: Controls the gamma correction of the environment map. This is once 
again particularly helpful when working with HDR images.
Bump Map / Normal Map: Is the texture that defines the surface structure with encoded 
normals.
Enable Individualized Transform: Activates the option to define an independent 
transformation (Position, Rotation and Scale values next to the Image Parameter) for Normal- 
and/or Bumpmaps instead of using the regular texture coordinates.
Environment Map: Is a vertical cross cube map that describes the environmental surrounding 
used to calculate reflections.
Technique: Shows a list of available techniques.

Standard Bump: Is a technique that should be used with geometry that has no 
standard UV texture coordinates and normals.
Binormal Bump: Is a technique that should be used with geometry having texture 
coordinates and normals.

Best Practices
The Brushed Metal Shader should be preferred to Anisotropic Light Shader whenever you want to 
create highly detailed metal surfaces. However, the shader is more complex and requires more 
rendering time. Therefore, it may be unsuitable, depending on the complexity of the other parts of 
the scene and also on the graphics hardware available.

Apart from the parameters in the plug-in container, it is necessary to assign a texture as a color/
basic texture and a material. Do not forget to adjust material parameters in addition, such as 
ambient, diffuse, specular color and shininess, to achieve the required look for your surface.

Bump Optimized Shader

The Bump Optimized Shader plug-in uses bump mapping, the impression of detailed surface 
structures is created while the structures are defined by normal maps. In addition to a highlight, 
the reflection of the surrounding is calculated (from a cube map). It is possible to add blurriness to 
the reflection to create rougher surfaces. A parameter is available to modulate whether the 
reflections follow the surface structures or behave like a clear coat layer on the top of it. The 

Note: This plug-in is located in: Plugins -> Shader -> RTTAdvancedMaterials
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specular map describes where on the surface highlight and reflections are shown and where the 
surface shows only diffuse lighting.

This plug-in offers the same functionality as the Bump Shader plug-in, but as an optimization, it 
does not allow separate texture mapping for bump and specular maps. It consequently requires 
less rendering time and should be used whenever additional parameters are not required, i.e. you 
have matching sets of textures that can be used with the shader or you do not need to animate the 
textures. This shader should be preferred especially in complex scenes.

Bump Optimized Shader Properties
Bump Height: Manipulates the height of the created bump on the surface.
Modulate Bumpy Reflection: Controls whether the environment reflection is smooth or 
influenced by surface details. To calculate reflections on a smooth clear coat layer, value 

0.0  is set by default. On the other hand, value 1.0  is used to incorporate surface details.

Environment Reflectivity: Manipulates the influence of the reflection color from the 
environment map on the resulting color.
Reflection Multiplier/Exposure: Affects the exposure of the environment map. This is 
especially helpful when working with HDR images.
Gamma of EnvMaps: Controls the gamma correction of the environment map. This is once 
again particularly helpful when working with HDR images.
Blur Reflection: States how much the environment reflection is blurred to create the 
impression of a rougher surface.
Fresnel Minimum, Fresnel Scale and Fresnel Exponent: Affect the Fresnel effect upon the 
reflection.
Bump Map/Normal Map: Is the texture that defines the surface structure/bump with 
encoded normals.

Note: All RTT shaders can be uninstalled from the Viz Artist/Engine program menu.

Note: This plug-in is located in: Plugins -> Shader -> RTTAdvancedMaterials
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Specular Map: Is the texture that defines where the surface is lit by specular highlight and 
reflection.
Environment Map: Is a cube map that describes the environmental surrounding used to 
calculate reflections.
Technique: Shows a list of available techniques.

Standard Bump: Is a technique to be used with geometry that has no standard UV 
texture coordinates and normals.
Binormal Bump: Is a technique to be used with geometry having texture coordinates 
and normals.

Bump Shader

The Bump Shader plug-in uses bump mapping, the impression of detailed surface structures is 
created while the structures are defined by normal maps. In addition to a highlight, the reflection 
of the surrounding is calculated (from a cube map). It is possible to add blurriness to the reflection 
to create rougher surfaces. A parameter is available to modulate whether the reflections follow the 
surface structures or behave like a clear coat layer on the top of it. The specular map describes 
where on the surface highlight and reflections are shown and where the surface shows only diffuse 
lighting.

Bump Shader Properties
Bump Height: Manipulates the height of the created bump on the surface.
Modulate Bumpy Reflection: Controls whether the environment reflection is smooth or 
influenced by surface details. To calculate reflections on a smooth clear coat layer, value 

0.0  is set by default. On the other hand, value 1.0  is used to incorporate surface details.

Note: This plug-in is located in: Plugins -> Shader -> RTTAdvancedMaterials
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Environment Reflectivity: Manipulates the influence of the reflection color from the 
environment map on the resulting color.
Reflection Multiplier/Exposure: Affects the exposure of the environment map. This is 
especially helpful when working with HDR images.
Gamma of EnvMaps: Controls the gamma correction of the environment map. This is once 
again particularly helpful when working with HDR images.
Blur Reflection: States how much the environment reflection is blurred to create the 
impression of a rougher surface.
Fresnel Minimum, Fresnel Scale and Fresnel Exponent: Affect the Fresnel effect upon the 
reflection.
Bump Map/Normal Map: Is the texture that defines the surface structure/bump with 
encoded normals.
Specular Map: Is the texture that defines where the surface is lit by specular highlight and 
reflection.
Environment Map: Is a cube map that describes the environmental surrounding used to 
calculate reflections.
Technique: Shows a list of available techniques.

Standard Bump: Is a technique to be used with geometry that has no standard UV 
texture coordinates and normals.
Binormal Bump: Is a technique to be used with geometry having texture coordinates 
and normals.

Best Practices
If you use this shader in complex scenes, you should favor the Bump Optimized Shader. The 
difference between the Bump Shader and the Bump Optimized Shader is that you can modify the 
texture coordinates inside the Bump Shader, which, however, needs more rendering performance. 
If you do not have to adjust the texture coordinates individually, or animate them separately, you 
should use the BumpOptimizedShader to save rendering performance.

Apart from the parameters in the plug-in container, it is necessary to assign a texture as a color 
texture and a material.

Fabric Shader

The Fabric Shader plug-in creates the impression of detailed surface structure on a dull surface by 
using bump mapping. The structure is defined by a normal map. A highlight is placed along the 
edges of the object to increase the impression of fabric surfaces.
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Fabric Shader Properties
Velvety (Limb) Parameter: Controls the strength of the velvety effect at grazing angles of 
view.
Bump Height: Manipulates the height of the created bumps and wrinkles on the surface.
Bump Map/Normal Map: Is the texture that defines the surface structure with encoded 
normals.
Technique: Shows a list of available techniques.

Standard_Bump: Is a technique has to be used with geometry that has no standard UV 
texture coordinates and normals.
Binormal_Bump: Is a technique should be used with geometry having texture 
coordinates and normals.

Glass Shader

The Glass Shader plug-in takes refraction and reflection properties from the surroundings (cube 
map) and blends them to create the dielectric effect of glass.

Apart from the parameters in the plug-in container, it is necessary to assign a texture as a color/
basic texture and a material. Do not forget to adjust material parameters in addition, such as 
ambient, diffuse, specular color and shininess, to achieve the required look for your surface.

In addition, lighting by a highlight and a color texture are used to describe the material in detail. 
The opacity of the object can be controlled to modulate between the solidly lit surface and the 
transparent impression of glass.

Note: This plug-in is located in: Plugins -> Shader -> RTTAdvancedMaterials
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Glass Shader Properties
Refraction Index: Controls the refraction index of the material, and accordingly the strength 
of the refraction.
Fresnel Minimum, Fresnel Scale and Fresnel Exponent: Affects the Fresnel effect upon the 
reflection.
Environment Reflectivity: Manipulates the influence of the reflection color from the 
environment map on the resulting color.
Bump Height: Manipulates the height of the created bumps on the surface.
Reflection Multiplier/Exposure: Affects the exposure of the environment map.
Gamma of EnvMaps: Controls the gamma correction of the environment map. This is 
particularly helpful when working with HDR images.
Blur Reflection: States to which extent the environment reflection and refraction are blurred 
to create the impression of a rougher surface.
Opacity: Influences the mixing of the solid material color and the dielectric glass effect 
(reflection and refraction).
Bump Map/Normal Map: Is the texture that defines the surface structure with encoded 
normals.
Environment Map: Is a cube map that describes the environmental surrounding used to 
calculate reflections and refractions.
Technique: Shows a list of available techniques.

Glass: Is a technique to be used for plain glass.
Glass_Texture: Is a technique to mix a diffuse texture color into the material color.
Glass_BumpStandard: Is a technique to create bump mapping with the given normal 
map on the surface of the geometry that has no standard UV texture coordinates and 
normals.
Glass_BumpStandard_Texture: Is a technique to use a diffuse color texture and bump 
mapping on the surface of the geometry that has no texture coordinates and normals.
Glass_BumpBinormal: Is a technique to create bump mapping for geometry with 
texture coordinates and normals.
Glass_BumpBinormal_Texture: Is a technique to use a diffuse color texture and bump 
mapping on the surface of geometry with texture coordinates and normals.

Note: This plug-in is located in: Plugins -> Shader -> RTTAdvancedMaterials
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Glass Shader Best Practices
Apart from the parameters in the plug-in container, it is necessary to assign a material and a 
texture as a color/basic texture. Do not forget to adjust material parameters in addition, such as 
ambient, diffuse, specular color and shininess, to achieve the required look for your surface.

Gooch Shader

The Gooch Shader plug-in is used to calculate the lighting of the surface. Accordingly, a warm 
color is shown in lit areas while a cold color is used in unlit areas. A highlight is further added. 
Besides, a color texture may be used to add more details. This shader is particularly useful when 
no surrounding reflection is required.

Gooch Shader Properties
Cold Color: Assigns the color used for unlit surfaces.
Warm Color: Assigns the color used for lit surfaces.
Back Splash: Controls a factor to increase the perception of curvature on grazing angles. The 
resulting color is weighted according to the back splash factor.
Texture Alpha: Defines to which amount the diffuse color texture is blended into the 
resulting color.
Highlight Alpha: Defines to which extent the calculated highlight is blended into the 
resulting color.
Color Map 2: Offers the possibility to assign a second diffuse color texture that is blended 
with the first color texture (according to the chosen technique).
Technique: Shows a list of available techniques.

Note: This plug-in is located in: Plugins -> Shader -> RTTAdvancedMaterials
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GoochShading: Is a technique to use Gooch shading.
GoochShading_Texture: Is a technique to mix a diffuse texture color into the material 
color.
GoochShading_MultiTexture_Add: Is a technique to additively blend Color Map 2 with 
the texture.
GoochShading_MultiTexture_Blend: Is a technique to blend Color Map 2 with the 
texture according to their alpha values.
GoochShading_MultiTexture_Subtract: Is a technique to subtractively blend Color Map 
2 with the texture.
GoochShading_MultiTexture_Modulate: Is a technique to blend Color Map 2 by 
multiplying it by the texture.

Gooch Shader Best Practices
Apart from the parameters in the plug-in container, it is necessary to assign a material. Therefore, 
do not forget to adjust material parameters in addition, such as ambient, diffuse, specular color 
and shininess. When applying a texture technique it is compulsory to assign an texture as a color/
basic texture. In case of multi texturing an additional, second texture must be assigned in the 
corresponding Shader rollout.

Lacquered Surfaces Shader

The Lacquered Surface Shader plug-in simulates smooth lacquered surfaces lit by a highlight. On 
the clear coat layer, the surrounding is reflected (from a cube map). The reflection blurriness can 
be controlled to create the appearance of a rougher surface.

Note: This plug-in is located in: Plugins -> Shader -> RTTAdvancedMaterials
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Lacquered Surfaces Shader Properties
Environment Reflectivity: Manipulates the influence of the reflection color from the 
environment map on the resulting color.
Reflection Multiplier/Exposure: Affects the exposure of the environment map. This is 
especially helpful when working with HDR images.
Gamma of EnvMaps: Controls the gamma correction of the environment map. This is once 
again particularly helpful when working with HDR images.
Blur Reflection: States how much the environment reflection is blurred to create the 
impression of a rougher surface.
Fresnel Minimum, Fresnel Scale and Fresnel Exponent: Affects the Fresnel effect upon the 
reflection.
Environment Map: Is a cube map that describes the environmental surrounding used to 
calculate reflections.
Technique: Shows a list of available techniques.

PixelShading: Is a technique to be used for finer details on the surface.
VertexShading: Is a technique to be used for objects in the distance or for highly 
tessellated objects.

Lacquered Surfaces Shader Best Practices
Apart from the parameters in the plug-in container, it is necessary to assign a material and a 
texture as a color/basic texture. Do not forget to adjust material parameters in addition, such as 
ambient, diffuse, specular color and shininess, to achieve the required look for your surface.

Metal Reflection Shader

The Metal Reflection Shader plug-in lights objects with a highlight and by the reflection of the 
surrounding (from a cube map). Both highlight and reflection take into account the material color 
of the object to generate a realistic metal effect.
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Metal Reflection Shader Properties
Environment Reflectivity: Manipulates the influence of the reflection color from the 
environment map on the resulting color.
Reflection Multiplier/Exposure: Affects the exposure of the environment map. This is 
especially helpful when working with HDR images.
Gamma of EnvMaps: Controls the gamma correction of the environment map. This is once 
again particularly helpful when working with HDR images.
Environment Map: Is a cube map that describes the environmental surrounding used to 
calculate reflections.

Metal Reflection Shader Best Practices
Apart from the parameters in the plug-in container, it is necessary to assign a material and a 
texture as a color/basic texture. Do not forget to adjust material parameters in addition, such as 
ambient, diffuse, specular color and shininess, to achieve the required look for your surface. To 
achieve a photo realistic, metallic look, it is recommended to assign any color but white as a 
specular color.

Microstructure Shader

The Microstructure Shader plug-in simulates a detailed surface structure by bump mapping and 
lights it with the aid of a highlight. Additionally, a clear coat layer reflects the surrounding (from a 
cube map). A normal map is used to define the surface structure.

Note: This plug-in is located in: Plugins -> Shader -> RTTAdvancedMaterials
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Microstructure Shader Properties
Environment Reflectivity: Manipulates the influence of the reflection color from the 
environment map on the resulting color.
Reflection Multiplier/Exposure: Affects the exposure of the environment map. This is 
especially helpful when working with HDR images.
Gamma of EnvMaps: Controls the gamma correction of the environment map. This is once 
again particularly helpful when working with HDR images.
Bump Map / Normal Map: Is the texture that defines the surface structure with encoded 
normals.
Environment Map: Is a cube map that describes the environmental surrounding used to 
calculate reflections.
Technique: Shows a list of available techniques.

Standard_Bump: Is a technique to be used with geometry that has no standard UV 
texture coordinates and normals.
Binormal_Bump: Is a technique to be used with geometry having texture coordinates 
and normals.

Microstructure Shader Best Practices
Apart from the parameters in the plug-in container, it is necessary to assign a material and a 
texture as a color/basic texture. Do not forget to adjust also the material parameters like ambient, 
diffuse, specular color and shininess, to achieve the required look for your surface

Monitor Shader

The Monitor Shader plug-in simulates the appearance of a flat screen display where saturation 
decreases at grazing angles of view. Therefore, the shown color texture blends into the diffuse 
color of the material. In addition, a reflection from the surrounding (from a cube map) is added, 
increasing in strength towards more acute angles of view.

Note: This plug-in is located in: Plugins -> Shader -> RTTAdvancedMaterials
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Monitor Shader Properties
Saturation/Reflection/Color Gradient: Defines to which amount the material’s diffuse color is 
mixed into the resulting color at grazing angles.
Environment Reflectivity: Manipulates the influence of the reflection color from the 
environment map on the resulting color.
Reflection Multiplier/Exposure: Affects the exposure of the environment map. This is 
especially helpful when working with HDR images.
Gamma of EnvMaps: Controls the gamma correction of the environment map. This is once 
again particularly helpful when working with HDR images.
Environment Map: is a cube map that describes the environmental surrounding used to 
calculate reflections.
Technique: Shows a list of available techniques.

Saturation_and_Reflection_Gradient: Is a technique to influence saturation and 
reflection appearance alike.
Reflection_Gradient: Is a technique to influence only the reflection appearance.

Monitor Shader Best Practices
Apart from the parameters in the plug-in container, it is necessary to assign a material and a 
texture as a color/basic texture. For this shader, a background image should be selected as the 
basic texture to achieve a highly realistic monitor effect. Do not forget to adjust material 
parameters in addition, such as ambient, diffuse, specular color and shininess, to achieve the 
required look for your surface.

Velvet Shader

The Velvet Shader plug-in creates a highlight along the edges of the surface is created to generate 
velvety impression. The highlight is controlled in using two parameters that describe the transition 
towards diffuse lighting. Furthermore, a surface color can be added to brighten the barely lit areas. 
A color texture may be used to add more surface details. This shader is particularly useful when 
no surrounding reflection is required.

Note: This plug-in is located in: Plugins -> Shader -> RTTAdvancedMaterials
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Velvet Shader Properties
Surface-Color: Assigns the color of the surface (underneath the velvety hairs).
Specular-Color: Assigns the specular color of the material.
Edge Rolloff: Defines how much of the surface color is to be seen in barely lit areas.
Specular low-cut and specular high-cut: Defines the sharpness of the velvety highlight.
Color Map 2: Offers the possibility to assign a second diffuse color texture that is blended 
with the first color texture.
Technique: Shows a list of available techniques.

Velvet: Is a technique to use velvety shading,
Velvet_Texture: Is a technique to mix a diffuse texture color into the material color.
Velvet_MultiTexture_Add: Is a technique to additively blend Color Map 2 with the 
texture.
Velvet_MultiTexture_Blend: Is a technique to blend Color Map 2 with the texture 
according to their alpha values.
Velvet_MultiTexture_Subtract: Is a technique to subtractively blend Color Map 2 with 
the texture.
Velvet_MultiTexture_Modulate: Is a technique to blend Color Map 2 by multiplying it 
by the texture.

Velvet Shader Best Practices
Apart from the parameters in the plug-in container, it is necessary to assign a material. Therefore, 
do not forget to adjust material parameters in addition, such as ambient, diffuse, specular color 
and shininess. When applying a texture technique it is compulsory to assign an texture as a color/
basic texture. In case of multi texturing an additional, second texture must be assigned in the 
corresponding Shader rollout.

4.6 Scene Plug-Ins
Scene plug-ins are global functions that have influence on the whole Scene. They are mainly used 
when external programs interface with Viz Artist.

The default path for the Scene plug-ins is <viz install folder>\plug-in.

Note: This plug-in is located in: Plugins -> Shader -> RTTAdvancedMaterials
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4.6.1 Default
The following Scene plug-in is located in the Default folder:

VCF

VCF

The VCF scene plug-in works in conjunction with the VCF Parameter plug-in that allows you to 
create a seamless interpolated transition from a virtual camera flight (VCF) to a real camera - and 
conversely. This is only a relevant plug-in to set up if you have purchased the virtual studio 
expansion components.

You must have a real camera with data tracking enabled which is set in remote mode in the camera 
editor. In case you have several tracked cameras, the virtual camera interpolates its position to the 
real camera that is selected On Air.

This page contains the following topics and procedures:

Properties
To Animate a Virtual Camera Flight

Properties
Tracking Object (POS): Defines the position or eye-point of the virtual camera flight. Use the 
name of the container in which center the camera should be placed.
Tracking Object (ROT): Defines the direction of the virtual camera flight. Use the name of the 
container the camera is looking at.
Initialize (button): Places the camera in position and sets the direction.

To Animate a Virtual Camera Flight
Start by adding the VCF scene plug-in under the Video Clip Playback Considerations plug-in 
tab.
Create a new group in your scene and add two new containers under it. These are to be the 
objects that define the virtual camera flight. One defines the position, the other the 
direction.
Name the containers according to the names you entered in the VCF scene plug-in (for 

example T_POS  and T_ROT ).

Click Initialize to finish.
Add the VCF Parameter plug-in onto the container that holds the position object.
Animate your virtual camera flight using the two objects to define position and direction.

Note: This plug-in is located in: Plugins -> Scene plug-ins -> Default
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Do not switch the whole container invisible because the animation does not run.
You may switch the objects to be invisible at any time.
It is not possible to animate the roll of the camera.

4.6.2 Image
The following Scene plug-in is located in the Image folder:

Background Clip

Background Clip

This plug-in plays back a sequence of still images (tga, tiff, etc.) in the background of your scene 
rather than playing an AVI-file.

Since it plays the sequence from memory, the scene has a higher loading time and the drawback is 
that it consumes system memory which can influence the system stability. So keep track of how 
much memory each sequence needs so you do not run out of memory on the render engine. Scene 
plug-ins are added under the Scene Settings plug-in tab.

Since all images are loaded into memory a large number of images or a large image size would 
require large amounts of memory. Memory can be calculated as follows:

number of images * image width * image height * 3 (or 4 for alpha).

Background Clip Properties
Image: Allows you to enter the name of the image sequence or browse for it. Select the first 
image you would like to use in your clip. Do not use clip names with numbers (except the 
counter).
Play Mode: Determines the method of playback. Can be set to:

Once: Plays the clip once. 
Loop: Repeats the clip over and over again.
Swing: Plays the clip forwards and backwards in a loop.

Reverse: Plays the clip backward when enabled.
Play speed: Lets you alter the speed in percent.
Advanced: Opens advanced parameters if set.
Stand alone image: Plays the same clip at different speeds.
First image: Select the number of the image which you want to start with.

Note: This plug-in is located in: Plugins -> Scene plug-ins -> Image
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Nof images: Determines the number of images to be played in a clip, otherwise all images 
are played back. Nof stands for “number of images”.
Crop: Crops the image in percent from the left, right, bottom and top side.
Scale: Scales all images to the closest power of two. When not selected an automatic 
textures coordinates are applied so the image fits the texture.
Keep under: Forces the image size. For example, if you have selected 64, the image is 
trimmed to the size 64 x 64.
Format: Loads the file in original condition if Image format is selected. Please select another 
format if you want load a black and white image (“Alpha”) or full color image (“RGB”, “RGBA”: 
with alpha value).
Play, Stop and Reinitialize: Enables you to play, stop and reinitialize the clip.

To Add a Background Image Clip
Create a directory and populate it with image files, for 

instance  abc001.png ,  abc002.png ,  abc003.png , etc.

The images are played as a sequence based on the filename including numbers.
After you have created the images, load the first image of the sequence and the clip is now 
visible in the Scene Editor.

Another possibility is to create a file with a "*.vln" extension. This file includes the base path 
and also the names of the images to load. In this case the images must not have a counter 
number in their filename. You can handle this file as an ordinary text file.
Load the vln-file instead of loading an image file located in a directory.

Example

BASE_PATH ‘C:/clip/images' { 
‘radar_200504110800.png’ 2005_04_11_10:00 
‘radar_200504110815.png’ 2005_04_11_10:15 
‘radar_200504110830.png’ 2005_04_11_10:30 
‘radar_200504110845.png’ 2005_04_11_10:45 
‘radar_200504110900.png’ 2005_04_11_11:00 
‘radar_200504110915.png’ 2005_04_11_11:15 
‘radar_200504110930.png’ 2005_04_11_11:30 
‘radar_200504110945.png’ 2005_04_11_11:45 
}

See Also

Image Clip

4.6.3 Lineup
The following Scene plug-in is located in the Lineup folder:

Tree Status
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Tree Status

The Tree Status plug-in is needed by the Lineup template in Viz Pilot to collect information about 
the scene hierarchy.

The Tree Props container plug-in is required for use of the Tree Status plug-in. Move the Tree 
Props plug-in onto the group holding the transformation which is to be controlled by Viz Pilot. Viz 
Pilot is then able to build its own internal tree properties list.

Tree Status Properties
Result: Contains the entire information about the complete scene tree.
S2VResult: Holds the information X-, Y-, Z-translation and the Y-rotation given in the card file 
virtual Studio. S2V stands for scene to virtual. 
Command: Allows a Viz command to take place.
Initialize (button): Initializes the Result field.
InitializeS2V (button): Initializes the S2VResult field.

4.6.4 Control
The following scene plug-in is located in the Control folder:

Presets

Presets

The Presets scene plug-in manages superchannel-based preset master scenes. It has functionality 
for creating, updating and removing named presets, as well as the ability to transition between 
such presets. The presets define different layouts of the superchannels in the scene. Preset state 
and the transition animations between presets are represented by directors in the stage. The 
Presets plug-in also provides a command interface that is utilized by the Media Sequencer Engine 
for management and playout of named presets.

Note: This plug-in is located in: Plugins -> Scene plug-ins -> Lineup

Note: This plug-in is located in: Plugins -> Scene plug-ins -> Control
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Presets Properties
Show advanced: Toggles advanced properties.

Current preset: The last preset taken, cut or selected in the dropdown.
Command in: Receives commands in order to perform an operation on the preset 
master scene.
Command result: Returns a result using the result parameter when a command is 
successfully executed.
Command error: Sets an error message using the error parameter on invalid 
commands or command failure.

Add superchannel: Adds a superchannel and a default content transition director to the 
scene, and applies superchannel settings needed for playout from the Media Sequencer.
Preset name: Specifies the name of a new preset.
No layout transitions (new preset): Specifies whether the new preset should be 
transitionless. When selected, new presets added do not support layout transitions to and 
from other presets. When transitioning to and from such presets, the plug-in always falls 
back to cut (immediately applies the layout without animation).
Add preset: Adds a new preset with the name specified by the preset name parameter. The 
layout of the new preset is determined by the layout of superchannels in the scene at the 
moment of adding the preset. This does not overwrite existing presets.
Preset: Determines the preset for editing.
Discard changes: Discards the changes made to the superchannel layout and shows the 
layout for the preset currently selected in the dropdown list.
Apply changes: Applies changes to the preset currently selected in the dropdown list. This 
updates the preset director and preset transition directors with the layout currently visible in 
the editor.
Remove preset: Removes the preset currently selected in the dropdown list from the scene.

Creating a Preset Master Scene
This section describes how to create a preset master scene from scratch with Viz Artist. Start with 
an empty scene.

Adding The Presets Scene Plug-In

The first step is to add the Presets scene plug-in to the scene.

Adding Superchannels

The preset scene manages named presets that define layouts of superchannels. We need to add 
superchannels to the scene. Superchannels can be added to the scene one by one with the plug-in:
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It is possible to add superchannels to the scene manually in the DVE media assets tab, however 
this is discouraged because the default superchannel configuration does not support playout from 
the Media Sequencer. The following settings are set when adding superchannels with the Presets 
plug-in:

Superchannel asset type is set to Texture.
Superchannel start mode is set to Loaded / Cleared.
Directors for transitioning from subchannels A to B and from B to A are set to content 
transition directors generated by the plug-in.
Start mode for superchannel subchannels are set to Transition Start.
Image zoom mode is set to Scale to fit min for superchannel subchannels.
Image border color is set to transparent (alpha 0%).

Creating Presets

When the Presets plug-in and superchannels are added to the scene, we can create presets, 
defining different layouts of superchannels.

To create a new preset, first arrange the superchannels to the desired layout and set the desired 
superchannel properties:
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When the desired layout is set, use the Presets plug-in interface to add a new preset:

Specify a unique name for the new preset before pressing the Add preset button. Existing presets 
are not overwritten. For adding more presets to the scene, repeat the process of adjusting the 
superchannel layout, choosing a new preset name and pressing the Add preset button. If it is 
desired to add a preset without layout transitions to and from other presets, the option No layout 
transitions (new preset) should be enabled before pressing the Add preset button.

The presets and transitions between presets are now represented by directors in the stage, created 
by the plug-in:
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Editing Presets

To edit a preset, first make sure it is selected in the dropdown list:
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Now you can rearrange the superchannels to the desired layout. Note that selecting a different 
preset discards any unapplied changes currently made in the editor. Changes can be applied to the 
selected preset with the Apply changes button, or discarded with the Discard changes button.

4.6.5 MultiTouch
The following Scene plug-ins are located in the MultiTouchComp folder:

MtSensor

All the MultiTouch Plug-ins Container plug-ins require the MtSensor to be available. If a MultiTouch 
Plug-ins Container plug-in is added to a Scene it automatically adds the MtSensor to the Scene if it 
is not there.

The plug-ins in this folder are inactive by default. To view the folder and use the plug-ins, set all 
plug-ins to active in Plug-ins (see the Configuring Viz section of the Viz Engine Administrator 
Guide).

MtSensor

The MtSensor plug-in manages global telestration and plug-in settings. The MtSensor plug-in is the 
scene plug-in that must be available for any MultiTouch feature to work. It is automatically added 
to the Scene if any of the Container or Geometry plug-ins that require it are inserted in the Scene. 
It can also be dragged from the Server Panel under Plugins > SP > MultiTouchComp, to the plug-in 
tab under Scene Settings.

The MtSensor plug-in also provides a screen-wide telestration facility. It can be controller through 
plug-in parameters and buttons that are available for scripting.

Note: This plug-in is located in: Plugins -> Scene plug-ins -> MultiTouchComp

http://documentation.vizrt.com/viz-engine
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This page contains the following topics and procedures:

MtSensor Configuration
Events

MtSensor Configuration
Active: Enables/disables telestration input from user.
Minimum Telestration Width: Assigns minimum brush width based on pressure applied to 
sensor.
Maximum Telestration Width: Assigns maximum brush width based on pressure applied to 
sensor.
Color: Assigns a color for subsequent telestration drawing.
Id: Provides additional context in the handler script, specify a string that identifies any 
notifications dispatched by this plug-in. This is often included as an argument for the event 
so a common script may handle events from a number of plug-ins.
Set Shared Memory: Enables shared memory to be updated for the plug-in notifications if set 

to On .

Shared Memory Prefix: Sets a ‘prefix name’ to be prepended to the shared memory variables 
maintained by the plug-ins notifications. For plug-ins that maintain multiple fields each field 
name has the prefix prepended to it followed by a dot, so as to mimic member access to an 
object. For example, if the prefix is Obj, the fields field1 and field2 would be identified with 
the strings Obj.field1 and Obj.field2. The shared memory field ‘Obj’ is also maintained and 
is simply an integer that is modified every time any of its subfields is updated.
Shared Memory Type: Selects the shared memory area to update. Can be either Global, 
Scene, or Distributed. 
SetDataPool: Shows ‘you wish’ plug-in notifications to set a DataPool variable.
DataPoolVariable: Shows the name of the DataPool variable one wishes to have set.
Init: Clears current telestration and make Telestration active.
Clear: Clears the contents of the attached telestration.

Events
The MtSensor plug-in does not generate any events for the scripting engine. The scene-wide 
telestration feature emits the same events that the MtTelestrator plug-in emits.

4.6.6 Script
The Script plug-ins is a folder to save created Scene Script plug-ins.

A script can be saved as its own script plug-in, and used in future Scenes (see Create Script-based 
plug-ins in the Viz Artist User Guide). To save a Script plug-in, drag a compiled script into the 
Script plug-ins folder.

Note: Script plug-ins are saved to <viz data folder>\Scriptplug-ins.

http://documentation.vizrt.com/viz-artist
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4.6.7 Texture
The following Scene plug-in is located in the Texture folder:

Graffiti

Graffiti

The Graffiti scene plug-in allows telestration on top of scenes in the screen space. Telestration is 
done by drawing with a brush shape using a mouse or a 6DOF interface. The plug-in can also 
recognize some rendered shapes and replace the hand-drawn items with the recognized shapes 
(e.g. circle, ellipse, cross, arrow).

The graffiti scene plug-in is not intended for use on video output. To use graffiti textures on video 
output, use the GraffitiTex container plug-in.

This page contains the following topics and procedures:

Graffiti Properties
To Create a Scene Level Graffiti Effect
6DOF (6 Degrees of Freedom)

Graffiti Properties
Active: Enables/disables drawing.
Multi Telestration:
Stylus:
Pressure Min [%]:
Pressure Max [%]:
Pointer Source: Supports input from the mouse, or from another plug-in via a dispatcher 
interface. This button selects whether the plug-in listens to the mouse or the dispatcher for 
input.
Mask Container: Points to either a container or a group of containers. These containers mask 
the area over which the brush is rendered.
Alpha: Adds transparency to the brush.
Key: Selects whether the brush is rendered in the key signal
Brush Type: Selects color or eraser brush.
Brush Image: Determines the shape of the brush using an image (optional). If empty, a 
round brush is used.

Note: This plug-in is located in: Plugins -> Scene plug-ins -> Texture
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Brush Width: Determines width of the brush in pixels. Visible only if the color brush is 
selected.
Eraser Brush Width: Determines width of the eraser in pixels. Visible only if the eraser brush 
is selected.
Brush Color: Selects the color of the brush.
Recognize Shapes: Enables/disables shape recognition mode.
Recognize Ellipse: Specifies whether shape recognition tries to recognize ellipse shape.
Recognize Circle: Specifies whether shape recognition tries to recognize circle shape.
Recognize Cross: Specifies whether shape recognition tries to recognize cross shape.
Shape Delay: Sets number of frames to wait from mouse up before trying to recognize 
shapes.
Draw Arrow: Specifies whether non-recognizable shapes are converted to an arrow.
Arrow Length: Determines length of arrow head.
Arrow Width: Determines width of arrow head.
Circle Rad: Sets radius of the circle replacing a recognized circle. If zero, the radius of the 
recognized circle is used.
Cross Width: Sets width of the cross replacing the recognized cross shape. If zero, the width 
of the recognized cross shape is used.
Max. Undos: Sets maximum number of undo operations.
Clear (button): Clears the canvas.
Undo (button): Undoes an operation.

To Create a Scene Level Graffiti Effect

Add the plug-in to the Plug-in Panel in Scene Settings, set the plug-in properties, set Viz Artist 
in On Air Mode and start drawing.

6DOF (6 Degrees of Freedom)
6DOF is a tool for artists, script writers and plug-in developers to position and orientate objects in 
the 3D space (three translation and three rotation axes => 6DOF).
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6DOF works directly with the built in Scene-Grids (see Grid Tool-bar) and uses them to calculate 
the intersection of the projected user input (mouse or touchscreen position) with the current grid 
plane. As soon as a touch or click input is detected, it triggers the corresponding 6DOF callbacks 
(OnButtonDown6DOF, OnMove6DOF, etc...) and passes the calculated position and rotation.

For example: This could be used to move players on a football field interactively without doing any 
math at all.

Additionally, 6DOF has a distribution mechanism which can send the user input to multiple 
engines, at the same time. This is configured in the Global Input of the Viz Configuration (see 
the Viz Engine Administrator Guide)

See Also

GraffitiTex (container plug-in)

4.6.8 Tools
The following Scene plug-ins are located in the Tools folder:

LOD Manager
Scene Synchronized Properties

LOD Manager

The LOD Manager scene plug-in works in conjunction with the Level of Detail container plug-in 
which is rendering objects with different details depending on the camera range; however, an 
integration with the LOD Manager is not required as the LOD plug-in is capable of initializing the 
parameter values by itself. The LOD Manager plug-in is used to change the visual view of the 
complete scene during rendering depending on the camera and scale settings.

This page contains the following topics and procedures:

Level Of Detail (LOD) Manager Properties
To Use the LOD Manager Plug-in

Note: This plug-in is located in: Plugins -> Scene plug-ins -> Tools

http://documentation.vizrt.com/viz-engine
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Level Of Detail (LOD) Manager Properties
Reference Zoom: Sets the reference zoom that is used to correlate switching ranges based 
on the actual camera zoom value.
Range Scale: Sets the global range scale which is used to scale all LOD ranges on all LOD 
plug-ins in the scene.
Reference Width: Not used.
Reference Height: Not used.

To Use the LOD Manager Plug-in

Start by adding the LOD Manager scene plug-in under the Scene Settings’ plug-in tab.
Add a group container to your scene tree and add at least two new sub containers of the 
group container.
Add a sphere geometry to the sub containers as it has many triangles.
Add a material to each sub container.
Open the Sphere editor for the all sub containers and set different Tesselation values for 
each to change the number of triangles and therefore the level of detail of an object.

Add the Level of Detail plug-in to the group container.
Open the LOD editor and change the Range parameter values provided by the LOD plug-in. 

For example set Range 0 to 500 , Range 1 to 1000  and so on.

These settings affects the instant of time when an object 1, object 2 is rendered, 
which you have placed in step 3.
The high resolution object is rendered at first and if the camera to object distance is 
increasing, the next object is rendered because now a low-resolution object has near 
the same visual quality despite fewer triangles. Consider that the visual quality 
depends on your settings and object graduation.

Finally, change the LOD Manager parameters Reference Zoom and Range Scale to adjust the 
scene view additionally.

Note: All spheres should, for the sake of example, be placed in the same position.
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Scene Synchronized Properties

The Scene Synchronized Properties plug-in can be used to synchronize all property changes within 
the same scene loaded on a cluster of Viz Engines. Synchronization needs to be configured for 
each Viz Engine taking part in the clustered setup. This plug-in works on a per scene basis. A 
container plug-in is available, allowing synchronization to take place on a per container basis.

This feature works for all container properties and plug-in parameters, and requires that the 
Engines render the same scene, referencing the same UUIDs. This allows designers to work with 
different versions of the same scene, without any need to update the changed IDs in external 
applications. If a parameter change is transferred to another engine then the container UUID of the 
last loaded scene is used for the update. If new UUIDs are required, a new scene needs to be 
created, either from scratch, or by merging the complete scene into a container which is then split 
into a new scene.

To Synchronize Scene Property Changes on Multiple Viz Engines
Configure the involved Engines for synchronization. 
Create the scene that should be synchronized.
Add the Scene Synchronize Properties plug-in to the Scene Setting’s Plug-in Panel. No 
scripting is required for synchronization.

See Also

Synchronized Properties Container plug-in
For more information about how to synchronize multiple Viz Engines, see the Global Input
page in the Configuring Viz section of the Viz Engine Administrator Guide.

Note: This plug-in is located in: Plugins -> Scene plug-ins -> Tools

http://documentation.vizrt.com/viz-engine
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5 Extension Plug-Ins
Extension plug-ins provide details about settings available through Viz Engine and Viz 
Script. Extension plug-ins are similar to normal plug-ins, but they are loaded during Viz Engine 
startup and are alive until shutdown (where regular plug-ins are bound to the scene lifetime). It is 
possible to provide data or services for scripts and plug-ins or control Viz Engine.

This section contains information on the following topics:

Plug-in API
Script API
Plug-ins

viz_command_over_websocket
viz_probel
viz_sealevel
viz_tally_tsl

5.1 Lifecycle
The extension plug-ins have a different lifecycle then normal plug-ins. They are loaded on startup 
and life until Viz Engine shuts down. This allows extension plug-ins to provide all kind of services 
which are not necessarily bound to a scene.
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5.2 Communication
There are many ways to communicate with an Extension. One of the most common ways is to use 
SHM. The extension can provide data by reading/writing the key/values of Viz Engine SHM.

Another method introduced with these Extensions is the Message API which is described 
below. SHM API and Message API are provided by Viz Engine, but there are many other methods 
like using a socket connection.

5.3 Message API
The Message API is similar to a REST API. A service/extension can provide multiple endpoints and 
clients can request data by sending requests to such endpoints. Like the REST API, such endpoints 
are described by a path. Extension endpoints are prefixed with /Extensions/<extension-name>. For 
example, the extension named Greetings could have an endpoint greet which could be requested 
with /Extensions/Greetings/greet.
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A message request can be sent from plug-ins or extensions and consists of the endpoint and a 
message body (which can be empty). Viz Engine then dispatches those messages to the 
corresponding extensions. The extension then responds with a message which is dispatched by 
Viz Engine back to the plug-in/script.

The whole communication is asynchronous. Requests can be sent from any thread. 
PLUGIN_REQUEST/PLUGIN_RESPONSE callbacks are always called on the main thread. This way of 
communicating also allows extensions to not immediately respond to requests. Furthermore, it is 
possible to send a response without receiving requests. This is useful to provide some kind of 
notification mechanism.

5.4 Sample Extension
The simple extension plug-in with Message support to greet. This plug-in responds to any Message 
received with "Hello <request-message>".

#include <PluginLib/evPlugin_PLUGINEXTERN.h>
#include <PluginLib/evPlugin_Extensions.h>
#include <Pluginlib/evPlugin_PLUGINFUNC.h>
#include <Pluginlib/evPlugin_DynInterface.h>
#include <Pluginlib/api_functions.h>

struct PLUGIN_DATA
{
};

VIZPLUGIN_API int
PLUGIN_INIT_EX()
{
    // Register plugin
    evRegisterPlugin("SampleExtension");
    evRegisterPluginFolder("Extension");
    evRegisterPluginType(EV_EXTENSION);

    evRegisterPluginUACfolders();

    evRegisterTotalSize(sizeof(PLUGIN_DATA));

    return 0;
}

VIZPLUGIN_API void
PLUGIN_INIT_FUNCTION(void* pvDataPtr)
{
    new (pvDataPtr)(PLUGIN_DATA)();
}

VIZPLUGIN_API void
PLUGIN_CLEANUP_FUNCTION(void* pvDataPtr)
{
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    auto pluginPtr = reinterpret_cast<PLUGIN_DATA*>(pvDataPtr);
    pluginPtr->~PLUGIN_DATA();
}

VIZPLUGIN_API
void PLUGIN_REQUEST(void* pvDataPtr, int senderId, const char* location, const char* 
msg)
{
    auto pluginPtr = reinterpret_cast<PLUGIN_DATA*>(pvDataPtr);
    std::string response = std::string("Hello ") + msg;
    _api__respond(senderId, location, response.c_str());
}

5.5 Sample Plug-In
A Viz Engine plug-in that communicates with the Sample Extension above. On initialization, a 
message request is sent to the extension and the response set to the plug-in parameter Output, 
which can be viewed in Viz Artist.

The output is "Hello Plugin".

struct PLUGIN_DATA
{
    char* output;
};

VIZPLUGIN_API void PLUGIN_INIT()
{
    evRegisterPlugin( "SamplePlugin" );
    evRegisterPluginFolder( "Sample" );
    evRegisterPluginType( EV_FUNCTION_CONTAINER );
    evRegisterPluginUACfolders();

    evRegisterParameterText("Output", "", 400, 600);
    evRegisterTotalSize(sizeof(PLUGIN_DATA));
}

VIZPLUGIN_API void PLUGIN_INIT_FUNCTION(void *dataptr)
{
    // cast dataptr to our parameter structure
    auto data = (struct PLUGIN_DATA*)dataptr;
    new (data) PLUGIN_DATA;

    auto pluginObjectId = _api__get_plugin_objectid();
    _api__request(pluginObjectId, "/Extensions/SampleExtension", "Plugin");
}

VIZPLUGIN_API void PLUGIN_RESPONSE(void* pvDataPtr, const char* location, const char* 
msg)
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{
    struct PLUGIN_DATA* data = (struct PLUGIN_DATA*)pvDataPtr;
    std::strcpy(data->output, msg);
    evSendGuiRefresh();
}

5.6 Sample Script
Similar to the Sample plug-in, this script sends a message request to the extension.

The output is:

"/Extensions/SampleExtension"

"Hello Script"

Request("/Extensions/SampleExtension", "Script")

sub OnResponse(location as string, message as string)
    Println(location)
    Println(message)
end sub

5.7 Related Documents
Viz Engine Administrator Guide : Contains information on how to install the Viz Engine 
software and supported hardware.

5.8 Feedback And Suggestions
We encourage suggestions and feedback about our products and documentation. To give feedback 
and/or suggestions, please contact your local Vizrt customer support team at www.vizrt.com.

http://docs.vizrt.com/viz-engine.html
http://www.vizrt.com/
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5.9 Plug-In API

5.9.1 Callbacks

PLUGIN_EXTENSION_CONFIGURE

Signature
int PLUGIN_EXTENSION_CONFIGURE(void* pvDataPtr, const char* configStr)

Required
No

Description
Called to configure the extension plug-in. This function is called if a configuration file for this 
extension exists with a <configStr> parameter.

PLUGIN_EXTENSION_CONFIG_GET

Signature
const char* PLUGIN_EXTENSION_CONFIG_GET(void* pvDataPtr)

Required
No

Description
Called to get the current configuration of the extension plug-in. The return value is expected to be 
the content of the serialized configuration.

PLUGIN_REQUEST

Signature
void PLUGIN_REQUEST(void* pvDataPtr, int connection, const char* location, const char* msg)

Required
No
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Description
Called whenever a message is received for this extension.

connection: object-id of sender (must be used for _api__respond)
location: message endpoint
msg: message payload

PLUGIN_RESPONSE

Signature
void PLUGIN_RESPONSE(void* pvDataPtr, const char* location, const char* msg)

Required
No

Description
Callback for incoming responses [Messages].

After calling _api__request this function is called with the response message.

location: message endpoint
msg: message payload

5.9.2 Functions

_api__get_plugin_objectid

Signature
int _api__get_plugin_objectid();

Description
Returns the object ID of the current plug-in. Can be used for _api__request.

Note: This function is always called on the main thread.

Note: This function is always called on the main thread.
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_api__request

Signature
void _api__request(int iObjectID, const char* location, const char* msg)

Description
Sends a message request.

iObjectID: object-id of the current plug-in. Can be retrieved by calling 
_api__get_plugin_objectid.
location: Message endpoint
msg: optional message payload

_api__respond

Signature
void _api__respond(int iObjectID, const char* location, const char* msg);

Description
Can be used to respond to a message request. If a message is received by getting 
PLUGIN_REQUEST called. You can respond with this function (immediately or at another time).

iObjectID: object-id which got passed by PLUGIN_REQUEST
location: location which got passed by PLUGIN_REQUEST
msg: the response message body

Note: Function can be called at any time and is thread-safe.

Example: If an extension provides a message endpoint of "/Extensions/Sample/greet".
You could make a requests with _api__request(myObjectId, "/Extensions/Sample/greet", "")



Note: Function can be called at any time and is thread-safe.
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5.10 Script API

5.10.1 Functions

Signature
Request(location as String, message as String)

Description
Sends a message request. On response the callback, OnResponse is called.

5.10.2 Callbacks

Signature
sub OnResponse(location as string, message as string)

Description
Response callback which gets called for each message request issued by this script.

5.11 Plug-Ins
The default path for the Extension plug-ins is:  <viz install folder>\plug-in\<plug-in name.vip>

The following Extension plug-ins are located in the Default folder:

viz_command_over_websocket
viz_probel
viz_sealevel
viz_tally_tsl

5.11.1 viz_command_over_websocket
The viz_command_over_websocket plug-in allows  Viz Engine to interpret websocket messages as 
Viz Engine commands. 

Open a websocket connection and send for each command one message. The extension then 
responds with the corresponding command response from Viz Engine. The command can be 
prepended with an integral number which is used as Command ID. This way the response can be 
associated with the request message. If left empty, the config parameter default-id is used instead.
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Configuration
To Configure this plugin create a file called {VizEngine-Config-dir}/extensions/
CommandOverWebsocket.json. This file is used for every running instance of Viz Engine. To have a 
specific config for a running instance, you can create configuration files like {VizEngine-Config-
dir}/extensions/CommandOverWebsocket-{Instance-Number}.json. For this extension, this is 
required if multiple instances are started, as it is not possible to open multiple websocket servers 
on the same port.

Supported config parameters:

port: Port where the websocket server will listen.
default-id: Default Command-ID used if the incoming message does not include it.

The CommandOverWebsocket.json file could then look like this:

{
    "default-id": "-1",
    "port": 6900
}

Limitations
Currently, the websocket server uses the ws protocol which is not protected. Using this extension 
in OEM versions is not possible.

5.11.2 viz_probel
The viz_probel plug-in allows the dynamic assignment of IP streams (2110) to the Viz Engine input 
channel.

Viz Engine manages a number of external sources to map them to a smaller number of available 
input channels. Viz Engine maintains control over which input channels have fixed sources from 
startup and which input channels can request a new source. The viz_probel plug-in maintains a 
table that maps a source to the Viz Engine input channel. Since each input channel in the Viz 
Engine corresponds to a physical Matrox connection. The plug-in effectively maps external sources 
to a particular Matrox physical connection.

The external component that communicates with viz_probel plug-in is usually a Virtual Studio 
Monitor (VSM) which communicates with the viz_probel plug-in via SW-P-08 general remote 
protocol.

VSM has a matrix composed of the sources and its corresponding output. This matrix state is 
saved in the viz_probel plug-in.

The viz_probel plug-in has the following tables:

VSM output and corresponding sources.
VSM output and corresponding Viz Engine input channel.
Matrox physical connection and Viz Engine input channel. Configured by the user.
Matrox physical connection and VSM output. Configured by the user.
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Message Interface
Communication via message passing is supported which is similar to a REST API. Messages can be 

sent via  Request(location, message)  in the Viz Script.

The response is asynchronous and is only given to the plug-in user when there is change in the 
internal mappings.

Register
The following must be called at least once to be able to connect to the VSM.

Location: /Extensions/Probel/register

Response:

[{"error": false}]

Unregister
The following must be called to disconnect from VSM.

Location: /Extensions/Probel/unregister

Response:

[{"error": false}]

Sources
The following returns the corresponding Viz Engine input channel. This generally changes the 
matrix in VSM but not always. {} can also be releaseall or requestall.

releaseall attempts to release all sources while requestall attempts to request all available sources.

Location: /Extensions/Probel/sources/{}

Response:

[{"error": false}]

The following releases a channel in the matrix in VSM.

Location: /Extensions/Probel/sources/{}/release

Response:

[{"error": false}]
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The following releases an all channel in the matrix in VSM except a few of them. {} can have 
multiple sources separated by "-". Example /Extensions/Probel/sources/releaseall/except/3-4-5-6

Location: /Extensions/Probel/sources/releaseall/except/{}

Response:

[{"error": false}]

Debug

The following is used for debugging SW-P-08 implementation. If {} is 0 , it sends an 

ImplementationRequest. If {} is 1 , it sends a CrossPointTallyDumpRequest.

Location: /Extensions/Probel/debug/{}

Response:

[{"error": false}]

The following is used for debugging SW-P-08 implementation. If {} is 0 , it sends a 

CrossPointInterrogate, the next {} is a parameter indicating the output. If {} is 1 , it sends a 

AllSourceNamesRequest, the next {} is a parameter indicating the names length.

Location: /Extensions/Probel/debug/{}/{}

Response:

[{"error": false}]

The following is used for debugging SW-P-08 implementation. If {} is 0 , it sends a 

CrossPointConnect, the next {} are parameters indicating the output and source. If {} is 1 , it sends 

a SingleSourceNameRequest, the next {} are parameters indicating the names length and source.

Location: /Extensions/Probel/debug/{}/{}/{}

Response:

[{"error": false}]

Response
The following is how the asynchronous response looks like. {} corresponds to the source.

Location: /Extensions/Probel/sources/{}/change

Response:
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[
    {
    "channelId": 0,
    "sourceId": 0
    }
]

Configuration
To Configure this plug-in create a file called  {VizEngine-Config-dir}/extensions/Probel.json. This 
file is used for every running instance of Viz Engine. To have a specific configuration for a running 
instance you can create configuration files like  {VizEngine-Config-dir}/extensions/Probel-
{Instance-Number}.json.

Supported config parameters:

address: Defines the port that should be used in VSM if connection mode is configured as 
server (depending on the connection-mode configuration), or the address and port of VSM if 
configured as client.
backup-address: Defines the port that should be used in VSM backup if connection mode is 
configured as server (depending on the connection-mode configuration), or the address and 
port of VSM backup if configured as client.

connection-mode: Determines whether the plug-in should act as a server or client. 0  for 

server or 1  for client.

fixed-entry-offset: Sources that should not be changed. This sources can not be released by 
plug-in the user.
delay-in-fields: Sets the field delay before giving the response to the plug-in user.
disconnected: Defines what should be considered as disconnected sources. Several sources 
can be defined separated by comma. 
range: Limits the range at which the plug-in user can operate. This is used in the event 
multiple Viz Engine instances are operating using the same VSM server but must operate 
only on a subset of sources.
vizch-vsmout: Shows which Viz Engine input channel corresponds to which VSM output.
vizch-matroxch: Shows which Viz Engine input channel corresponds to which Matrox 
physical connector. This should match with the configuration in the usual Viz Engine 
configuration file.
extended-message: Enables extended support for Probel which adds support for a large 
matrix with more than 1024 sources.

The Probel .json file could then look like this:

{
    "address": "10.29.39.11:4211",
    "backup-address": "0.0.0.0:27015",
    "connection-mode": "1",
    "delay-in-fields": "10",
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    "disconnected": "1022,65535",
    "fixed-entry-offset": "4",
    "range": "0-15",
    "vizch-matroxch": 
"0,1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,26,27,28,29,30,31",
    "vizch-vsmout": 
"0,1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30,3
1"
}

Sample Script
The following is an example of most of the functionality presented above:
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sub OnInitParameters()
RegisterParameterInt("req", "ReqSource", 1, 1, 1023)
RegisterPushButton("request", "Request Source", 1)
RegisterPushButton("release", "Release Source", 2)
RegisterPushButton("releaseall", "Release All", 3)
RegisterPushButton("requestall", "Request All", 4)
RegisterPushButton("register", "Register", 5)
RegisterPushButton("unregister", "Unregister", 6)
end sub

sub OnResponse(location as string, message as string)
    PrintLn "OnResponse triggered..."
    Println location
    Println message
end sub

sub OnExecAction(buttonId As Integer)
if buttonId = 1 Then
Request("/Extensions/Probel/sources/"&cstr(getParameterInt("req")-1), "")
elseif buttonid = 2 Then
Request("/Extensions/Probel/sources/"&cstr(getParameterInt("req")-1)&"/release", "")
elseif buttonid = 3 Then
for x = 0 to 31
println "Release : "&x
Request("/Extensions/Probel/sources/"&cstr(x)&"/release", "")
next
elseif buttonid = 4 Then
for x = 0 to 32
println "Request : "&(x mod 32)
Request("/Extensions/Probel/sources/"&cstr((x mod 32)), "")
next
elseif buttonid = 5 Then
Request("/Extensions/Probel/register", "")
elseif buttonid = 6 Then
Request("/Extensions/Probel/unregister", "")
end if
end sub

As per the documentation, the user needs to call first register to be able to use the other 
functions.

Debug
To enable debug logs go to the usual Viz Engine configuration file and enable ACE logging:

ACELogParams = -f OSTREAM|STDERR|VERBOSE_LITE|VERBOSE -p STARTUP|SHUTDOWN|~TRACE|
DEBUG|INFO|WARNING|NOTICE|ERROR|CRITICAL|ALERT|EMERGENCY

This allows for the user to see the raw messages that are being sent and received between the VSM 
and the plug-in.
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Troubleshooting
To be able to troubleshoot it is important to understand the console log messages.

Suppose we have the following tables:

(MatroxCh#, VSMOut#): (0, 15), (1, 0), (2, 3), (3, 12), (4, 4), (5, 5), (6, 6), (7, 7).
(MatroxCh#, VizCh#): (0, 1), (1, 0), (2, 3), (3, 2), (4, 4), (5, 5), (6, 6), (7, 7).
(VSMOut#, VizCh#): (0, 0), (3, 3), (4, 4), (5, 5), (6, 6), (7, 7), (12, 2), (15, 1).
(VSMOut#, SourceId#): (0, 3), (1, 2), (2, -1), (3, 10), (4, 0), (5, 12), (6, 8), (7, 5), (8, 0), (9, -1), (10, 
-1), (11, -1), (12, 11), (13, -1), (14, -1), (15, 4).

All operations are done only with the tables (VSMOut#, VizCh#)  and (VSMOut#, 
SourceId#). (MatroxCh#, VSMOut#)  and (MatroxCh#, VizCh#)  are redundant.

First case: Requested SourceId# has a VSMOut# that is associated with VizCh#: 

INFO: VizEngine-0[15996]:viz::swp08::Probel_SWP08_Handler::PrintMap: (MatroxCh#, 
VSMOut#): (0, 15), (1, 0), (2, 3), (3, 12), (4, 4), (5, 5), (6, 6), (7, 7).
INFO: VizEngine-0[15996]:viz::swp08::Probel_SWP08_Handler::PrintMap: (MatroxCh#, 
VizCh#): (0, 1), (1, 0), (2, 3), (3, 2), (4, 4), (5, 5), (6, 6), (7, 7).
INFO: VizEngine-0[15996]:viz::swp08::Probel_SWP08_Handler::PrintMap: (VSMOut#, 
VizCh#): (0, 0), (3, 3), (4, 4), (5, 5), (6, 6), (7, 7), (12, 2), (15, 1).
INFO: VizEngine-0[15996]:viz::swp08::Probel_SWP08_Handler::PrintMap: (VSMOut#, 
SourceId#): (0, 3), (1, 2), (2, -1), (3, 10), (4, 0), (5, 12), (6, 8), (7, 5), (8, 0)
, (9, -1), (10, -1), (11, -1), (12, 11), (13, -1), (14, -1), (15, 4).
INFO: VizEngine-0[15996]:viz::swp08::Probel_SWP08_Handler::RequestChannelFromSourceId
: found vsmout (0) in (VSMOut#, SourceId#) that has an associated vizch (0) in 
(VSMOut#, VizCh#) with given sourceId (3).
INFO: VizEngine-0[15996]:viz::swp08::Probel_SWP08_Handler::RequestChannelFromSourceId
: (VSMOut#, SourceId#) = (0, 3) (VSMOut#, VizCh#) = (0, 0). 

Second case: Requested SourceId# does not have a VSMOut# that is associated with VizCh#. In this 
case we need to do a CrossPointConnect using VSMOut that is both associated with a non-used 
SourceId# and is also associated with VizCh#. In this case we could not find it: None of the VSMOut 
in (VSMOut#, VizCh#) has a SourceId# = -1 in (VSMOut#, SourceId#). A release is needed first.
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INFO: VizEngine-0[16012]:viz::swp08::Probel_SWP08_Handler::PrintMap: (MatroxCh#, 
VSMOut#): (0, 15), (1, 0), (2, 3), (3, 12), (4, 4), (5, 5), (6, 6), (7, 7).
INFO: VizEngine-0[16012]:viz::swp08::Probel_SWP08_Handler::PrintMap: (MatroxCh#, 
VizCh#): (0, 1), (1, 0), (2, 3), (3, 2), (4, 4), (5, 5), (6, 6), (7, 7).
INFO: VizEngine-0[16012]:viz::swp08::Probel_SWP08_Handler::PrintMap: (VSMOut#, 
VizCh#): (0, 0), (3, 3), (4, 4), (5, 5), (6, 6), (7, 7), (12, 2), (15, 1).
INFO: VizEngine-0[16012]:viz::swp08::Probel_SWP08_Handler::PrintMap: (VSMOut#, 
SourceId#): (0, 3), (1, 2), (2, -1), (3, 10), (4, 0), (5, 4), (6, 8), (7, 5), (8, 0), 
(9, -1), (10, -1), (11, -1), (12, 3), (13, -1), (14, -1), (15, 4).
INFO: VizEngine-0[16012]:viz::swp08::Probel_SWP08_Handler::RequestChannelFromSourceId
: vsmout NOT found in (VSMOut#, SourceId#) that has an associated vizch in (VSMOut#, 
VizCh#) with given sourceId (12).
INFO: VizEngine-0[16012]:viz::swp08::Probel_SWP08_Handler::RequestChannelFromSourceId
: could not find first vsmout in (VSMOut#, VizCh#) with sourceId (-1) in (VSMOut#, 
SourceId#).

Third case: From the above state, after releasing we can request again.

INFO: VizEngine-0[16012]:viz::swp08::Probel_SWP08_Handler::PrintMap: (MatroxCh#, 
VSMOut#): (0, 15), (1, 0), (2, 3), (3, 12), (4, 4), (5, 5), (6, 6), (7, 7).
INFO: VizEngine-0[16012]:viz::swp08::Probel_SWP08_Handler::PrintMap: (MatroxCh#, 
VizCh#): (0, 1), (1, 0), (2, 3), (3, 2), (4, 4), (5, 5), (6, 6), (7, 7).
INFO: VizEngine-0[16012]:viz::swp08::Probel_SWP08_Handler::PrintMap: (VSMOut#, 
VizCh#): (0, 0), (3, 3), (4, 4), (5, 5), (6, 6), (7, 7), (12, 2), (15, 1).
INFO: VizEngine-0[16012]:viz::swp08::Probel_SWP08_Handler::PrintMap: (VSMOut#, 
SourceId#): (0, -1), (1, 2), (2, -1), (3, 10), (4, 0), (5, 4), (6, 8), (7, 5), (8, 0)
, (9, -1), (10, -1), (11, -1), (12, -1), (13, -1), (14, -1), (15, 4).
INFO: VizEngine-0[16012]:viz::swp08::Probel_SWP08_Handler::RequestChannelFromSourceId
: vsmout NOT found in (VSMOut#, SourceId#) that has an associated vizch in (VSMOut#, 
VizCh#) with given sourceId (12).
INFO: VizEngine-0[16012]:viz::swp08::Probel_SWP08_Handler::RequestChannelFromSourceId
: found first vsmout (0) in (VSMOut#, VizCh#) with sourceId (-1) in (VSMOut#, 
SourceId#).
INFO: VizEngine-0[16012]:viz::swp08::Probel_SWP08_Handler::RequestChannelFromSourceId
: (VSMOut#, VizCh#) = (0, 0) (VSMOut#, SourceId#) = (0, 12).

5.11.3 viz_sealevel
The viz_sealevel plug-in allows  Viz Engine to provide GPIO data coming from SeaLevel Devices for 
plug-ins and scripts. 

Both SeaLevel PCI and ethernet Devices are supported. The GPIO data is provided in via SHM key/
values and via message passing.

SHM Interface
Each GPIO pin is mapped to a SHM key.
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Format
The pins are mapped with following format:

Inputs:  Sealevel::<device-id>::I<pin-id>::<0 or 1>

Outputs:  Sealevel::<device-id>::O<pin-id>::<0 or 1>

SMM Values in Viz Engine REST Interface

Inputs

These SHM values are only for reading and are updated when a input pin changes. By registering 
to SHM changes this can then be used to perform tasks in scripting or plug-ins.

Outputs

These values are meant to set from inside scripts or plug-ins (for example to switch lights on and 
off).

Message Interface
The Viz Engine plug-in API supports communication via message passing which is similar to a REST 

API. Messages can be send via Request(location, message)  in Viz Script.

List Devices
Location: /Extensions/Sealevel/devices 
Response:

[
    {

"id": "1",
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"name": "410io_",
"status": "connected",
"status-description": "Connected"

    }
]

Get Device Info
Location: /Extensions/Sealevel/devices/1 
Response:

{
    "id": "1",
    "name": "410io_",
    "status": "connected",
    "status-description": "Connected",
    "pins": [

{
"id": "0",
"is-input": true,
"value": 0

},
{

"id": "1",
"is-input": true,
"value": 0

},
{

"id": "2",
"is-input": true,
"value": 0

},
{

"id": "3",
"is-input": true,
"value": 0

},...
    ]
}

Register for Pin Changes
Location: /Extensions/Sealevel/devices/1/register 
Response:

{
    "error": false
}
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If then a pin changes the script or plug-in would receive such a response:
Location: /Extensions/Sealevel/devices/1/change 
Response:

{
    "device": 1,
    "pin": 1,
    "value": true
}

Get All Pin Data for a Given Device
Location: /Extensions/Sealevel/devices/1/pins
Response:

[
    {

"id": "0",
"is-input": true,
"value": 0

    },
    {

"id": "1",
"is-input": true,
"value": 0

    },
    {

"id": "2",
"is-input": true,
"value": 0

    }, ...
]

Get Pin Data for a Given Device and Pin
Location: /Extensions/Sealevel/devices/1/pins/0 
Response:

{
    "id": "0",
    "is-input": true,
    "value": 0
}
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Set Pin Data for a Given Device and Pin
Location: /Extensions/Sealevel/devices/1/pins/0 
Message:

{
    "value": 1
}

Response:

{
    "id": "0",
    "is-input": true,
    "value": 1
}

Configuration
To Configure this plugin create a file called {VizEngine-Config-dir}/extensions/Sealevel.json. This 
file is used for every running instance of Viz Engine. To have a specific config for a running 
instance you can create config files like {VizEngine-Config-dir}/extensions/Sealevel-{Instance-
Number}.json.

Supported config parameters:

auto-reconnect: Automatically reconnect to device.
reconnect-interval: Interval for reconnecting.
discover-ethernet-devices: Automatically detect SeaLevel network devices.
ethernet-devices: Array of SeaMax devices connected via Ethernet.

address: IP address.
name: Assocciated name for this Card.

seaio-devices: Array of SeaIO device (PCI-Cards).
adapter: Adapter number for PCI-Card (For two installed PCI-Cards possible adapters 
would be 0 and 1).
name: Assocciated name for this Card.

serial-devices: Array of SeaMax devices connected via serial interface.
port: COM port for this device.
name: Assocciated name for this Card.

The Sealevel.json file would then look like this:

{
    "auto-reconnect": true,
    "discover-ethernet-devices": true
    "ethernet-devices": [
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{
"port": "COM1",
"name": "serial_card_0"

}
    ],
    "reconnect-interval": 60000,
    "seaio-devices": [

{
"adapter": 0,
"name": "pci_card_0"

}
    ],
    "serial-devices": [

{
"port": "COM1",
"name": "serial_card_0"

}
    ]
}

Sample Scripts

List Devices

sub getDevices()
    Request("/Extensions/Sealevel/devices", "")
end sub

sub onDevices(devices as Json)
    if devices.Size == 0 Then

exit sub
    end if

    dim devCount as Integer = devices.Size - 1
    for i = 0 to devCount

dim deviceObj as Json = devices.At(i)
Println(deviceObj.Dump())

    Next

end sub

sub OnResponse(location as string, message as string)
    if location == "/Extensions/Sealevel/devices" Then

dim j as Json
j.Load(message)
onDevices(j)

    end if
end sub
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getDevices()

Get Pin Values

sub getPinValue(devId as String, pinId as String)
    Request("/Extensions/Sealevel/devices/" & devId & "/pins/" & pinId, "")
end sub

sub OnResponse(location as string, message as string)
    dim j as Json

j.Load(message)

    onPinValue(j.GetString("id"), j.GetInteger("value"))
end sub

sub onPinValue(pinId as String, value as Integer)
    Println("Pin " & pinId & " value = " & value)
end sub

' Inputs
for i = 0 to 15
    getPinValue("0", "" & i)
next

' Outputs
for i = 16 to 31
    getPinValue("0", "" & i)
next

Set Output Pins

sub getPinValue(devId as String, pinId as String)
    Request("/Extensions/Sealevel/devices/" & devId & "/pins/" & pinId, "")
end sub

sub setPinValue(devId as String, pinId as String, value as Integer)
    dim payload as String = "{\"value\": " & value & "}"
    Request("/Extensions/Sealevel/devices/" & devId & "/pins/" & pinId, payload)
end sub

sub OnResponse(location as string, message as string)
    dim j as Json

j.Load(message)

    onPinValue(j.GetString("id"), j.GetInteger("value"))
end sub
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sub onPinValue(pinId as String, value as Integer)
    Println("Pin " & pinId & " value = " & value)
end sub

setPinValue("0", "16", 1)
setPinValue("0", "18", 1)

' Outputs
for i = 16 to 31
    getPinValue("0", "" & i)
next

Listen for Pin Changes

sub OnResponse(location as string, message as string)

    if location.StartsWith("/Extensions/Sealevel/devices") and location.EndsWith("cha
nge") Then

dim j as Json
j.load(message)
onPinChanged(j.GetInteger("pin"), j.GetInteger("value"))

    end if
end sub

sub onPinChanged(pinId as Integer, value as Integer)
    Println("Pin " & pinId &  " changed to " & value)
end sub

Request("/Extensions/Sealevel/devices/0/register", "")

5.11.4 viz_tally_tsl
The viz_tally_tsl plug-in allows Viz Engine to control tallies via message passing from plug-ins and 
scripts using the TSL UMD Protocol Specification.

The extension acts as client and connects to an TSL server. Currently only V3.1 of TSL UMD 
Protocol is implemented for both TCP and UDP. The communication for TSL UMD Protocol is 
unidirectional. So its not possible to get the current status from the Server. Therefore, the 
extensions keeps record of the current state. On startup, the extensions assumes that all tallies 
are off. From this point on, the extensions stores which tallies were enabled. If the server 
connection is lost, then the extension attempts to reconnect. As soon as it is reconnected, it 
resends all tally states to the server.

Message Interface
The Viz Engine Plug-in API now supports communication via message passing which is similar to a 

REST API. Messages can be sent via Request(location, message)  in the Viz Script.
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List Servers
Location: /Extensions/Tsl_Tally/servers 
Response:

[
    {

"host": "120.120.120.120",
"id": 0,
"links": [

"self",
{

"href": "/Extensions/Tsl_Tally/servers/0"
},
"tally",
{

"href": "/Extensions/Tsl_Tally/servers/0/tally"
}

],
"name": "tsm_test_server",
"port": 6112,
"status": "disconnected"

    },
    {

"host": "localhost",
"id": 1,
"links": [

"self",
{

"href": "/Extensions/Tsl_Tally/servers/1"
},
"tally",
{

"href": "/Extensions/Tsl_Tally/servers/1/tally"
}

],
"name": "local",
"port": 34567,
"status": "connected"

    }
]

Get Tally Status for a Given Server and Address
Location: /Extensions/Tsl_Tally/servers/:server-id/tally/:address 
Response:

[
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    {
"active": false,
"brightness": 1.0

    },
    {

"active": false,
"brightness": 1.0

    },
    {

"active": false,
"brightness": 1.0

    },
    {

"active": false,
"brightness": 1.0

    }
]

Get Tally Status for a Given Server and Address
Location: /Extensions/Tsl_Tally/servers/:server-id/tally/:address
Message:

[
    {

"active": true,
"brightness": 1.0

    },
    {

"active": true,
"brightness": 1.0

    },
    {

"active": false,
"brightness": 1.0

    },
    {

"active": false,
"brightness": 1.0

    }
]

Response:

[
    {

"active": true,
"brightness": 1.0

    },
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    {
"active": true,
"brightness": 1.0

    },
    {

"active": false,
"brightness": 1.0

    },
    {

"active": false,
"brightness": 1.0

    }
]

Get Tally Status for a Given Server, Address and Tally
Location: /Extensions/Tsl_Tally/servers/:server-id/tally/:address/:tally-index 
Response:

{
    "active": false,
    "brightness": 1.0
}

Set Tally Status for a Given Server, Address and Tally
Location: /Extensions/Tsl_Tally/servers/:server-id/tally/:address/:tally-index 
Message:

{
    "active": true,
    "brightness": 1.0
}

Response:

{
    "active": true,
    "brightness": 1.0
}

Configuration
To Configure this plugin create a file called {VizEngine-Config-dir}/extensions/Tsl_Tally.json. This 
file is used for every running instance of Viz Engine. To have a specific configuration for a running 
instance you can create configuration files like {VizEngine-Config-dir}/extensions/Tsl_Tally-
{Instance-Number}.json.
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Supported config parameters:

reconnect-interval-seconds: Interval in seconds to reconnect to a disconnected server.
servers: Array of TSM servers.

host: Hostname of the TSM server.
port: Port of the TSM server.
name: Assocciated name for this server.

The Tsl_Tally.json file could then look like this:

{
    "reconnect-interval-seconds": 60,
    "servers": [

{
"host": "10.211.1.153",
"name": "tsm_adrian",
"port": 6112

},
{

"host": "localhost",
"name": "local",
"port": 34567

}
    ]
}

Sample Scripts

Switch Tally on

sub turnOnTally(serverId as Integer, address as Integer, tally as Integer)
    Request("/Extensions/Tsl_Tally/servers/"&serverId&"/tally/"&address&"/"&tally&"", 
"{\"active\": true}")
end sub

sub turnOffTally(serverId as Integer, address as Integer, tally as Integer)
    Request("/Extensions/Tsl_Tally/servers/"&serverId&"/tally/"&address&"/"&tally&"", 
"{\"active\": true}")
end sub

turnOnTally(0, 0, 0)
turnOffTally(0, 0, 0)
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Switch Tally on with Brightness to 0.4

sub setTally(serverId as Integer, address as Integer, tally as Integer)
    Request("/Extensions/Tsl_Tally/servers/"&serverId&"/tally/"&address&"/"&tally&"", 
"{\"active\": true, \"brightness\": 0.4}")
end sub

setTally(0, 0, 0)
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6 DataPool Plug-Ins

The DataPool Plug-ins provide details about settings available through its configuration user 
interface within Viz Artist. 

6.1 Related Documents
Viz Artist User Guide: Contains information on how to install Viz Engine and create graphics 
scenes in Viz Artist.

6.2 Feedback And Suggestions
We encourage suggestions and feedback about our products and documentation. To give feedback 
and/or suggestions, please contact your local Vizrt customer support team at www.vizrt.com.

6.3 DataPool
DataPool is a mechanism for managing data in Viz. The mechanism is implemented through a 
group of container function plug-ins and a group of scene plug-ins added to the Viz installation.

DataPool implementation allows Viz to keep information in named cells called DataFields. The data 
is managed at a separated, virtual, work space, linked to the graphics thru a set of plug-ins that 
make the connection between the DataFields and the graphic objects.

http://documentation.vizrt.com/viz-artist
http://www.vizrt.com/
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Some of the DataPool plug-ins have no effect over the graphics and are used only for managing 
and manipulating data. Some DataPool plug-ins are used for assigning data to DataFields and 
some plug-ins control Viz behavior upon changes in DataField values, affecting the graphic 
objects.

The native communication protocol to Viz is command oriented. Any change of the graphic 
objects, requires a separate command that is sent to the renderer. Each command includes the 
path to the container and the operation performed on the container.

6.3.1 Example
In a scene with a cube object, the cube can be scaled, moved, its bevel parameter changed, etc.

This is done by sending a command to Viz that specifies the name of the cube, its location in the 
Viz scene tree, the parameter to be changed and the new value for the parameter. If we add a font 
object to the same scene, we would be able to modify different parameters of the object, like 
setting its font, contents, kerning and so on.

If we want to implement a histogram of one single bar formed by the cube and the text object, 

setting the bar to the value  10 , we need to send Viz the following commands:

Set the font object to display the string  10  (maybe add a suffix or prefix like a dollar 

sign:  $10 ).

Calculate the size of the cube and send the correct scaling value command Viz.

To change the value of the bar, two commands were sent, containing a different format for 

displaying the same graphic information: setting the bar to the value  10 .

Another issue is that each external command sent to Viz contains the address of the container to 
which it is addressed. If a software program needs to send the two commands to Viz, it has to 
know the names of the containers and their location in the scene hierarchy. If an external 
application is written controlling a scene, the scene hierarchy and container names cannot be 
changed in the scene.

All these issues mentioned previously create difficult maintenance problems. DataPool is designed 
to solve these problems. It extends the external command mechanism of Viz, allowing the user, or 
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the controlling software, to send data rather than container specific operations. The data is 
addressed to named fields (DataFields). The scene designer uses special purpose plug-ins, used 
for processing and handling the incoming data.

If we modify the previous example to use the DataPool mechanism, a DataText plug-in is added to 
the text object and a DataScale plug-in is added to the cube object. Both plug-ins are registered to 
receive data from the same DataField named Bar Value. As soon as Bar Value changes both plug-
ins react, the first changing the string of the text object and the second scaling the cube. The data 
is sent to the scene through a scene plug-in called DataPool. This plug-in is just an interface to 
enter the data. Once this plug-in is defined in the scene, any external software can address it 
without the need of knowing the scene hierarchy or the container names.

6.4 Installation
DataPool is installed into the plugin directory under the last Viz installation. The plugins are 
installed according to the version found on the machine. The plugins are divided into four Plug-in 
Groups.

This section contains information on the following topics:

Plug-in Groups
Installing DataPool
Silent Installation

6.4.1 Plug-in Groups
The plug-ins are divided into four groups:

DataPool
Interactive
Project Specific
Script

For most users, installing the DataPool group is sufficient. For advanced applications install other 
plug-in groups as well.

The installation includes the DataPoolLib.dll and an empty config.dp file which are installed in the 
Viz directory. When installing the DataScript plug-in, js32.dll is also installed to the Viz directory.

DataPool
Main plug-in group (default). Includes most of the plug-ins:

Data3DObject
DataAction
DataActionTable
DataAlpha
DataAnim
DataArray
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DataArrow
DataClock
DataCondition
DataCountDown
DataCounter
DataDevice (not installed for Viz 3.X)
DataDirector
DataFeedback
DataGeom
DataGraph
DataGraphPoint
DataImage
DataKey
DataKeyFrame
DataKeyFrame2
DataKeyTime
DataLUImage
DataMaterial
DataMaterialGradiant
DataMaterialIndex
DataMaterialTable
DataMath
DataMinMax
DataMultiParam
DataNumber
DataObject
DataObjectTracker
DataParameter
DataParamTracker
DataPool
DataPosition
DataReader
DataRotation
DataScale
DataSelector
DataSHM (Viz Engine 3.X only)
DataSHMTracker (Viz Engine 3.X only)
DataStructure
DataSwitch
DataSystem
DataTable
DataText
DataTextKerning
DataTexture
DataTime
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2.

DataTimer
DataViz3Script (Viz Engine 3.X only)

Interactive
All plug-ins that are based on mouse/keyboard events:

DataClick
DataFeedBack
DataHyperLink
DataInteractive
DataKeyText
DataManipulate
DataMouseAction
DataMousePosition
DataMouseSensor

Project Specific
Plug-ins written for specific projects but can be used in other applications.

DataCamera
DataDispatcher
DataDrawMask
DataScreen

Script
Contains the DataScript plug-in and the script library.

DataScript (Viz Engine 2.X only)

6.4.2 Installing DataPool

First-time Installation
Run the installation file and follow the instructions. When installing DataPool for the first 
time three installation types are available:

Typical: Installs only the DataPool plug-in group.
Custom: Installs the plug-in groups that the user selects.
Full: Installs all the DataPool plug-ins (all the groups).

Select the installation type and continue. An information window displays the path of the 
installation and selected plug-in groups.

Note: The plug-ins are installed to the plug-in directory under the latest Viz 
installation.
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To Upgrade an Existing Installation
When upgrading the installation three options are displayed:

Modify: Changes the installed groups on the machine.
Repair: Reinstalls the installed groups (*.dp files are not overwritten).
Remove: Uninstalls DataPool.

Select one of the options and click the next button.

6.4.3 Silent Installation
The silent installation enables the user to install Viz DataPool without using the installer GUI. This 
option is used when a large number of machines require the software to be installed. To use the 
silent installation mode:

Examples
In a command shell, run the following command:

To install DataPool from the .msi located in path C:\temp\VizPlugins-

DataPool-4.2.0.msi without GUI (for progress installation progress GUI /qn  should be 

replaced with /qb ) and create a log file for the installation steps in path C:

\temp\install.log and deploy the DataPool plug-ins in the plugin folder under C:\program 
files\vizrt\VizEngine:

msiexec /i "c:\temp\VizPlugins-DataPool-4.2.0.msi" /qn /log c:\temp\install.log 
VIZ_ENGINE_INSTALL_DIR="c:\program files\vizrt\VizEngine"

To uninstall installed DataPool without GUI and create a log file for the uninstallation steps 
in C:\temp\uninstall.log:

msiexec /x "c:\temp\VizPlugins-DataPool-4.2.0.90.msi" /qn /log c:\temp\uninstall.log

6.5 Architecture
This section describes the architecture of DataPool and contains information on the following 
topics:

Overview
DataPool Hierarchy
Data Objects
Arrays of Data Objects

Note: This User Guide is installed with the DataPool group.
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Tables of Data Objects
DataPool Variables Scope
DataPool Configuration Files
External Interface

6.5.1 Overview

DataPool implements a table of DataFields. Each DataField has a unique name by which it is 
accessed, a value (data) and a list of data changes handlers. The handlers are implemented as 
plug-ins in Viz, where each plug-in affects specific parameters of a container in Viz. The plug-in 
instances are registered to DataFields when attached to a container in the scene. The plug-in 
modifies the container parameters when the value of the DataField changes. It doesn’t do anything 
unless it is called.

The external software sends the data to the DataPool through the DataPool plug-in. In the sent 
message, the application specifies which data should be assigned to which DataField. The 
DataPool plug-in accesses the DataFields table using the name of the field to be accessed, gets the 
relevant field and assigns the data to it.

This assignment invokes a series of triggers to all the plug-ins (handlers) registered to the field.

DataFields
As stated before, the DataField is a cell formed by three elements:

Name (or address).
Data.
A list of handlers. The name is a zero terminated ASCII string.

The data is a vector of strings. The DataField can host one string of data, or a series of strings. 
The user can set the size (the number of items) of the DataField. Each one of the DataField items 
can be accessed separately or they can be accessed as a group, altogether.

The process of creation of the DataField is as follows: When a DataPool plug-in is specified to 
register to a certain DataField the plug-in looks for the specific DataField in the DataFields table. If 
the field doesn’t exist the plug-in creates it and registers itself to the DataField. In order to send 
data to a certain DataField, at least one plug-in has to be registered to that DataField.
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6.5.2 DataPool Hierarchy

DataNodes and DataFields
DataPool is a hierarchical data structure composed of DataFields and nodes. DataFields are the 
lowest level of the hierarchy. The DataFields don’t have children. Nodes are groups of DataFields. 
The DataPool hierarchy has a root node. Each of the DataFields in the hierarchy has a parent node, 
either the root node or any other sub-level node.

Example 1
The following example shows a hierarchy with a root, two nodes (NA and NB) and six DataFields. 
As can be seen each of the DataFields reside below a node. Setting the value of the DataField FA 
under the node NA follows the hierarchical structure to the required DataField:

NA/FA=<some information>; 

In the case of field FC under NB:

NB/FC=<some other information>; 

To set the data of all DataFields under the node NB, the following commands are sent:

NB/FA=<info for A>; 
NB/FB=<info for B>;  
NB/FC=<info for C>; 

Note that there is a certain amount of redundancy because NB appears three times. To avoid using 
the node name every time, the following alternative format is used:

NB={
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    FA=<info for A>; 
    FB=<info for B>; 
    FC=<info for C>; 
}; 

The brackets determine the scope of the contained statements. In the above command the 
statement "FA=<info for A>;" is in the scope of object NB.

Example 2
Consider the following example:

In this example NB has a child node called NC. To set data to the field FB under NC the following 
command is sent:

NB/NC/FB = <info for B>; 

In order to populate all the fields in NC:

NB/NC= {
    FA = <info for A>; 
    FB = <info for B>;
}; 

If we want to populate the whole hierarchy with data in one command:

NA = {
    FA =<info for A>; 
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    FB=<info for B>; 
    FC=<info for C>;
};  
NB = {
    FA =<info for A>; 
    FB=<info for B>;  
    NC = {

FA=<info for A>; 
FB=<info for B>;

    };
}; 

6.5.3 Data Objects
Data objects use the structure of DataNodes and DataFields to describe properties of objects used 
for displaying information in Viz scenes.

An example of such an object is a stock. A stock object can be represented in the following way:

The DataPool representation of this stock object would be:

Stock={
    string Ticker; 
    string Name; 
    string Price; 
    string Volume;
}; 

The meaning of this definition is: A Stock object is defined by four fields: Ticker, Name, Price and 
Volume.

The type string preceding each property of the stock means that incoming data is a text string and 
should be handled as such by the DataPool plug-ins.

To send information to an object called MyStock, defined as a Stock object, the following format is 
used:

MyStock={     
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    Ticker=IBM;     
    Name=International Business Machines;     
    Price=85.26;     
    Volume= 5,188,500;
};

This information is sent to the DataPool plug-in and used by the different DataPool plug-ins in the 
scene. Other examples for objects are cities weather conditions, election results, etc.

DataPool object definitions are saved in configuration files with the special suffix .dp, saved under 
Viz folder. DataPool loads all the objects defined in all of the .dp files, and makes the object types 
defined available to DataPool plug-ins such as DataObject or DataArray.

The default configuration file is called config.dp and it is installed empty during DataPool 
installation. When upgrading DataPool, the config.dp file is never overwritten. Multiple 
configuration files can be used to define various objects. All files must be saved with 
the .dp suffix.

6.5.4 Arrays of Data Objects
When dealing with multiple instances of the object type, an array of object types can be defined. 
Defining an array of objects simplifies data management when sending the information to the 
different objects.

Sometimes there is a need to maintain lists of objects. An example could be the display of a 
histogram of stocks. Each Viz object is attributed a DataPool object. But in this case, it would be 
very unwise to give a name to each of the objects because the number of the objects may be 
unknown. DataPool solves this problem by providing with a means of array of objects. Like in the 
case of the single object, the array has an object type. When defined the array builds a set of 
objects as its children. This scheme is shown in the following figure:

In the figure, an array of stocks of size four is shown. As can be seen each of its children are 
named Stocks[0], Stocks[1], and so on. To enter data to the array element number 2:

Stocks[2]/Price=85.3; 

If we want to enter information to the whole array:



Plug-ins User Guide -  5.0

Copyright © 2022  Vizrt Page  513

Stocks[0-3]={     
    {Ticker=IBM;Price=85.26;},     
    {Ticker=SGI;Price=1.09;},     
    {Ticker=AOL;Price=14.71;},     
    {Ticker=AA;Price=23.85;},  
}; 

6.5.5 Tables of Data Objects
In the DataArray plug-in, we can organize the objects in an array structure and refer to the whole 
array or to single objects within the array using the array name and an index.

Sometimes it is useful to organize the objects and keep the object’s names. For example, rather 
than keeping a list of stocks we could keep a table in which IBM’s stock is stored under the name 
IBM, SGI’s stock under the name SGI and so on. As in the array, the table has an object type, but 
unlike the array the table doesn’t have a size. Every time an object is inserted in the table the table 
grows. The DataTable plug-in stores the data sent to it and it is able to recall this data when 
requested. That data can later be used with the copy functionality of DataPool, to effect the 
graphic objects thru the DataFields.

A typical table of stocks could look as follows:

In the above figure a table of stocks named "Stocks" can be seen.

The children objects are called "Stocks[IBM]", "Stocks[SGI]", etc…

To send information to the stock IBM:

Stocks[IBM]/Price = 85.26;

or

Note: There are two sets of brackets in the above statement: One for the array itself and a 
second for the objects themselves. Also note that because this is an array, the objects are 
separated by commas rather than by semicolons.
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Stocks[IBM]={ 
    {

Volume=5,188,500; 
Price=85.26

    ;} 
}; 

To enter information to a number of stocks:

Stocks[IBM, AOL]={
    {

Ticker=IBM;
Price=85.26;

    },
    {

Ticker=AOL;
Price=14.71;

    }  
}; 

6.5.6 DataPool Variables Scope
When referring to DataPool variables, the common and wide spread meaning is addressing global 
variables by their name and addressing structured variables by specifying the full path to the 
variable (i.e. <structure name>/../<variable name>).

In some DataPool plug-ins (where applicable), one of the parameters defines the DataPool variable 
scope. The options are Local and Global:

Local Variables: When referring to Local DataPool Variables, the meaning is variables within a 
DataPool object/data structure. When the scope is set to Local, the DataPool variable is 
addressed by its name only, even when it is a part of a DataPool structure.
Global Variables: When referring to Global DataPool Variables, the meaning is variables that 
are not defined as part of a DataPool structure.

Example
The following definitions are set in the config.dp file:

string MyText; 
MyObject{   
    string MyText;   
    string TextLength;   

Note: This parameter only has an effect on DataPool expressions and variables that 
reside under the DataObject container, i.e. child containers within the object’s 
hierarchy.
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};

When addressing the variable MyText:

MyText="This Text"; → the Global variable MyText is set to This Text.
MyObject/MyText="This Text"; → The variable MyText in the MyObject structure is set
to This Text.
When the scope parameter is set to Local and setting the following assignment in one of the 
structure’s children MyText="This Text"; then the effect is like defining the full path: 
MyObject/MyText="This Text";.

6.5.7 DataPool Configuration Files
This page contains information on the following topics:

DP Configuration Files
Example Configuration File

DataPool.ini File
Conversion Table

File syntax

DP Configuration Files
DataPool data fields and objects are used across scenes and engine machines to support Viz 
scenes and data distribution. The DataPool configuration files, used to define DataPool structures 
and DataPool variables, use the suffix .dp. All files with .dp suffix are loaded during Viz load and 
the data fields and structures are defined in the DataPool memory. The configuration files can be 
copied to all relevant Viz machines or saved in a common folder and defined in 
the DataPool.ini file.

When installing DataPool, the file datapool.dp is installed to the Viz Program Files folder and 
copied to %ProgramData%/vizrt/VizEngine. This file is an example and the users can modify the 
file to define data fields. Additional .dp files can be used to organize the DataPool variables and 
data structures.

Example Configuration File

Example_STOCK = {   
    string Example_ID;   
    string Example_Name;   
    string Example_symbol;   
    string Example_Open;   

Warning: If using Viz Engine 4 or newer: When editing DataPool configuration files, always 
modify the files located in %ProgramData%/vizrt/VizEngine! The files in \Program Files\
are just templates which are copied to %ProgramData% at installation time. The Engine 
reads the files from %ProgramData%.
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    string Example_Close;   
    string Example_High;   
    string Example_Low;   
    string Example_Volume;   
    string Example_Price;   
    string Example_TimeRange;   
}; 
Example_RESULTS = {   
    string Example_NAME;
    string Example_SCORE;
    string Example_COLOR;   
}; 

The file shows two DataPool structures.

DataPool.ini File
The DataPool.ini file is installed to the Viz Program Files folder and copied to %ProgramData%/
vizrt/VizEngine. It contains the following parameters:

ConfigurationFolder: Defines the location of the .dp files to be loaded. If omitted, the default 
path is set to .\ (i.e. Viz folder).
MultiDatapool: Defines if a separate Viz DataPool segment is assigned to each scene loaded 
to Viz.

Conversion Table
The conversion tables file is a comma separated file installed in the Viz Program Files folder and 
copied to %ProgramData%/vizrt/VizEngine. All the conversion tables are defined in this file name, 
using a fixed format. The tables are used to convert input data values to another value defined in 
the table. The first column in the table is the input value and the second column is the converted 
value (output).

File syntax
The file contains a few reserved tokens used for defining conversion tables and other parameters:

__VERSION__: This entry is used for future file support and version compatibility issues.
__DELIMITER__: This entry is used to define a different file delimiter (other than comma). If 
omitted comma is used.
__TABLE__: This entry defines the beginning of a conversion table. The table end is defined 
by another table entry or end of file.
Table example:

When using multiple configuration files, make sure your data structures are unique. 
Multiple structures with the same name are not supported



Note: The file name is hard coded: DP_ConvTable.csv.
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__TABLE__,colors, 
red,255 0 0 
green,0 255 0 
blue,0 0 255 
yellow,255 255 0 
cyan,0 255 255 
purple,255 0 255 
__DEFAULT__, 0 0 0 
,

In the example, a table called colors is defined. When the conversion table is used in a plug-

in, an input string red is converted to the output string  255 0 0  and sent back to the plug-

in for processing.
__DEFAULT__: This token is used in any of the conversion tables as a default conversion 
value (any value not found in the table is converted to the default value).

6.5.8 External Interface
The external interface to DataPool is based on Viz messages sent to the DataPool plug-in. Each 
message contains a series of data assignments to different DataFields.

The structure of the message is:

command1 command2 command3 ...

The structure of each command is as follows:

<Name>[items range] = datum1, datum2, datum3, ...; 

Where  name  is the name of the DataField to assign data to and  items range  is a description of 

items to which the data is addressed.

The item ranges are a comma-separated list of indexes, or a from-to index.

Examples
Send data to a field named VALUE:

VALUE=30; 

Send data to the first five values of a field called VALUES:

Note: The semicolon is part of the command and should be added at all times. It is used to 
define the end of the command.
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VALUES[0-4] = 0, 1, 2, 3, 4; 

The above is equivalent to sending:

VALUES[0]=0; VALUES[1]=1; VALUES[2]=2; VALUES[3]=3; VALUES[4]=4; 

Send data to the items 1-3, 55-57 and 101:

VALUES[1-3,55-57, 101] = 0, 1, 2, 3, 4, 5, 6; 

This is equivalent to sending:

VALUES[1]=0; VALUES[2]=1; VALUES[3]=2; VALUES[55]=3; VALUES[56]=4; VALUES[57]=5;
 VALUES[101]=6; 

6.6 DataPool Plug-Ins
The DataPool plug-ins in Viz are responsible for handling incoming data and for affecting the 
objects in the scene according to the DataFields values.

6.6.1 Overview
The DataPool plug-ins are found in Viz in the Function plug-ins pool, under a folder called Data. 
There are DataPool Container Plug-ins and DataPool Scene Plug-ins. The scene plug-ins manage 
incoming data from different sources, inserting it to DataFields and maintain the DataFields Table. 
For example, the DataPool plug-in receives information from external sources and inserts it to the 
different DataFields. The DataMouseSensor senses mouse position and events and stores them in 
predefined DataFields.

The container DataPool plug-ins trigger graphic changes in the container they are attached to, 
when the DataField registered to them changes. Most of the container plug-ins have an argument 
called Field Name. The field name value is the name of the DataField to which the plug-in is 
registered to. The Field Name can take the following forms:

<name> 
<name>[number of items] 

If the field name is VALUE then the DataField is defined as a single datum field. However, if the 

field name is  VALUE [100]  then the name of the DataField is VALUE and it has 100 data items 

(values). The field name, scene hierarchy and the way the information is sent to the DataPool plug-
in determine the container plug-in behavior.

Note: The indexes of the items are zero-based (start from 0).
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6.6.2 Example
This is a hierarchy of a graph scene:

The above figure shows a container A with three children 1, 2, and 3. A DataScale plug-in is 
attached to A. The DataScale plug-in controls the scaling of the container according to the data it 
receives.

If the Field Name in the DataScale plug-in is defined to be  VALUES[3]  (a vector of 3 items named 

VALUES), DataScale acts in two different ways:

If the data is entered without specifying an item index, DataScale affects container A.

If the data specifies an item index, DataScale works on the respective child container of A.

6.7 Expressions
An expression is a text parameter combining constant strings and references to DataPool 

variable’s (DataField’s) value. The reference syntax is  $(DataField) . When using the expression, 

the string  $(DataField)  is replaced by the value of the DataField specified in the parentheses. 

For example, suppose we need to run different animation directors in Viz and we want to send the 
name of the director as a parameter. The command in Viz to run a director is:

0 RENDERER*STAGE*DIRECTOR*<name> START 

Example: If the data is entered as VALUES=0.5 0.5 0.5; then the container A is scaled 

by 0.5  in each axis.


Example: If the data is entered as VALUES[2] = 0.1 0.1 0.1; , then container3 is

scaled by 0.1  in each axis (Note that the index value is zero based).





Plug-ins User Guide -  5.0

Copyright © 2022  Vizrt Page  520

•
•

•
•

•
•
•
•

So we need to send the entire command for each director that we want to run. By using 
expressions, only the name of the director to be run is sent to Viz. We define a DataField called 
DIR that contains the name of the director to run.

Now we can use the following syntax for running the animations:

0 RENDERER*STAGE*DIRECTOR*$(DIR) START

$(DIR) is replaced by the incoming data, so if the data was DIR=mydirector; the whole expression 
is interpreted to be:

0 RENDERER*STAGE*DIRECTOR*mydirector START

A common DataPool variable is $(INDEX). This variable is used to access the full index range of a 
DataField. For example, if we have two DataFields called DST[10] and SRC[10] and we want to copy 

all the values from vector SRC to vector DST, the expression should state  DST[$(INDEX)]=SRC[$

(INDEX)] . A useful DataPool special command is $(REFRESH). The effect of having an expression 

like  $(REFRESH) $(VALUE)  is to trigger all the plug-ins registered to the DataField called VALUE 

without having to receive external data. Each data plug-in has its own set of special purpose 
variables. They are explained in the explanation of each plug-in.

6.8 Special DataPool Variables
$(INDEX): Returns the indexes of sub-containers of the selected container.
$(REFRESH) $(DataField_Name): Triggers all plug-ins registered to DataField_Name as if the 
DataField DataField_Name was changed.
$(SCENE), $(THIS_SCENE): Returns the name of the current scene.
$(CONTAINER): Returns the container ID of the container that the DataPool plug-in is 
attached to.
$(CONTNAME): Returns the name of the container hosting the DataPool plug-in.
$(CHILD): Returns the index of the selected child.
$(DATA): Returns the string value of a text object.
$(PARENT): Represents the parent DataPool object/structure of the current DataPool field. 
This variable enables the user to change the values of its "brother" data fields. This special 
variable is applicable only in plug-ins that have an Action parameter.

Example: In the given structure

Note: Predefined DataFields are defined in the config.dp file, residing in the Viz folder.

Note: The string enclosed between the parentheses is considered to be either a DataPool 
variable, a special DataPool command or a special DataPool variable.
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DEMO={
    string Field1    
    string Field2
};

If a DataPool plug-in, with an Action parameter, on the Field1 container refers to $(PARENT)/
Field2, it sets the value of Field2 in the same structure:

$(PARENT)/Field2="This is the Field1" $(Field1)

The result of this action is that Field2 contains the quoted text and the content 
of Field1 data field.

$(PARENT_NAME): This special variable is applicable only in plug-ins that have an Action 
parameter. The $(PARENT_NAME) returns the parent DataPool object/structure name, of the 
current DataPool field.

See $(PARENT) description for additional details.
$(PARENT_FULL_NAME): Returns the full hierarchy string of the parent DataPool object/
structure, of the current DataPool field. If the structure/object has only one level of variables 
in the hierarchy, then the $(PARENT_FULL_NAME) and the $(PARENT_NAME) returns the same 
value. If the structure/object has more than one level, the $(PARENT_FULL_NAME) returns the 
entire path of the structure from the requested level. The full name is returned in the format 
of: xx/yy/zz/. This special variable is applicable only in plug-ins that have an Action 
parameter.

See $(PARENT) description for additional details.

IMPORTANT! When working with DataPool structures/objects, the $(PARENT) is the 
recommended way of addressing other data fields in the DataPool structure/object.



Note: Using the $(PARENT) variable is similar to using the Global/Local parameter in 
some of the DataPool plug-ins. Both make the distinction between a DataPool 
variable that is part of a data structure/object and a DataPool variable that is used 
not a part of a structure/object.



Note: The Field Name parameter (i.e. the DataPool variable that triggers the action 
should be a part of the structure. The $(PARENT) value is defined according to this 
data field.



Note: The Field Name parameter (i.e. the DataPool variable that triggers the action 
should be a part of the structure. The $(PARENT_NAME) value is defined according to 
this data field.



Note: The Field Name parameter (i.e. the DataPool variable that triggers the action 
should be a part of the structure. The $(PARENT_FULL_NAME) value is defined 
according to this data field.
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$(FIELD_NAME): Returns the name of the DataField when used in a child container.
$(FIELD_FULL_NAME): Returns the full name of the DataField when used in a child container.
$(FIELD_DATA): Returns the value of a DataField.
$(SCENE_FULL_NAME): Returns the full path and scene name.

6.9 Common DataPool Parameters
Field Name: Defines the name of the DataField from which the plug-in receives the data.
Data Min and Data Max: Specifies value mapping between incoming data and a Viz value. 
These parameters are always used in conjunction with two parameters representing Viz 
values (usually named Value Min and Value Max). The Data Min value is converted to a 
minimum Viz value and the Max Data is converted to a maximum Viz value. All incoming 

values are converted respectively to Viz values. When the Clamp parameter is set  On , Values 

out of this range (smaller than Data Min or larger than Data Max) is cropped to the Min/Max 

values. When Clamp is  Off , incoming values are divided by the range between Data Min 

and Data Max and the resulting value is used as the incoming value and interpolated to Viz 
values.

## Example
Data Min is 0 
Data Max is 100 
Viz Min is 0 
Viz Max is 200
Sent value is 125

If Clamp is On the Viz value is set to 200  (all values above Data Max (100) are cropped to 

the Data Max Value and interpolated to Viz Values)

If Clamp is Off, Viz value is set to 250 .

Prefix: Specifies a prefix string that is added in front of the incoming data string.
Suffix: Specifies a suffix string that is added at the end of the incoming data string.

Clamp: Clamps the incoming data values to the data min/max range when set to  On . All 

DataPool plug-ins that use the Data Min and Data Max parameters have a clamp button. 
Values out of this range (smaller than Data Min or larger than Data Max) are cropped to the 

Min/Max values when the Clamp parameter is set  On .

Notify only on value change: Triggers all DataPool plug-ins registered to that DataField when 
a DataField value is changed. This happens also if the DataField was set to the same values. 
Notifies the data plug-ins only if the field value was actually changed when enabled. The 

default behavior is  Off  (as it was in previous DP releases, before adding this feature).

Use Other Container: Allows one container to affect another container, or allows another 
instance of the same plug-in to be used on the same container. DataPool container plug-ins 
affect the containers they are attached to, and cannot affect other containers directly. A 
common example of using this parameter is changing multiple keyframes in an animation. 
Since only one plug-in can be attached to the container, dummy containers 
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with DataKeyFrame plug-in, using this parameter can be used to affect the remaining 
keyframes (This parameter makes the DataKeyFrame2 plug-in unnecessary. The plug-in is 
installed for backwards compatibility only). When enabled, additional options are also 
enabled:

PARENT: The DataPool plug-in affects the parent container (the container residing 
above the current container in the scene hierarchy).
GrParent: The DataPool plug-in affects the grandparent container (the container 
residing two levels above the current container in the scene hierarchy).
GrGrParent: The DataPool plug-in affects the great grandparent container (the 
container residing three levels above the current container in the scene hierarchy).
REMOTE: When remote is selected another parameter, Remote Container, is enabled. 
Drag the container to be effected to the container place holder.

Incremental Change: Specifies if the incoming data is added to the current value of the data 

field ( On ) or replaces the current value of the data field ( Off ).

Use Conversion Table: Enables a Conversion Table Name parameter when enabled. Enter the 
table name as it appears in the DP_ConvTable.csv file, without the proceedings leading and 
proceeding underscore characters.

6.10 Container Plug-Ins
The container plugins are listed in this section in alphabetic order.

Data3DObject
DataAction
DataActionTable
DataAlpha
DataAnim
DataArray
DataArrow
DataCamera
DataCenter
DataClick
DataCondition
DataCountdown

Note: When using the Parent, GrParent or GrGrParent options, the link to the 
other container is relative. When using the Remote option the link to the other 
container is absolute. Using the relative options is recommended when using 
object designs that are duplicated in the scene and controlling containers 
within the object hierarchy (like in Viz Curious Maps Client labels or Viz 
Weather objects).



Note: The REMOTE option maintains compatibility with previous versions of 
DataPool using the Use Remote Container option.
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DataCounter
DataDirector
DataDispatcher
DataDrawMask
DataFeedback
DataGeom
DataGraph
DataGraphPoint
DataHyperlink
DataImage
DataInRange
DataInterpolate
DataKey
DataKeyFrame
DataKeyFrame2
DataKeyText
DataKeyTime
DataLookup
DataLUImage
DataManipulate
DataMaterial
DataMaterialGradient
DataMaterialIndex
DataMath
DataMathObject
DataMinMax
DataMouseAction
DataMousePosition
DataMultiParam
DataNumber
DataObject
DataObjectTracker
DataParameter
DataParamTracker
DataPosition
DataReader
DataRotation
DataScale
DataScreen
DataSelector
DataSHM
DataSHMTracker
DataStructure
DataSwitch
DataSystem
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DataTable
DataText
DataTextKerning
DataTexture
DataTime
DataTimer
DataViz3Script
DataWPosition

6.10.1 Data3DObject

The Data3DObject plug-in receives a name of an object from the Viz object library, and it loads it 
to the container it is placed on.

Prefix is used to add a Viz object path to a folder where the objects are stored.

For example: If the FieldName is AAA and the object is spaceship then the command is:

AAA=spaceship;

6.10.2 DataAction

The DataAction plug-in executes an action (Viz commands or DataPool commands) when the 
DataField registered to it changes.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.



Note: Built in objects cannot be used.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.
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DataAction Properties

Action: Specifies the action to be invoked. If the action string begins with  0 , then the 

command is handled as a Viz command, otherwise it is considered to be a DataPool 
command. The action can contain more than one command to be called. The commands 
must be separated by semicolons (;). Expressions can be used in the action utilizing the 
special DataPool variables.
Set to Mute: Specifies if the action is triggered when the data field changes.

6.10.3 DataActionTable

The DataActionTable plug-in allows defining a table of actions (as described in 
the DataAction plug-in page). Each of these actions is identified by a value of the FieldName
variable. When DataActionTable receives data (a value of the FieldName variable) it compares the 
data to each of the values. If the data matches one of the values, the plug-in invokes the 
corresponding action.

DataActionTable Properties
Numeric Values Only: Enforces the plug-in to use only numeric values received as the Field 

Name value, and uses only numeric values in the  Value<i>  parameters, when set to  On .

Value<i>: Specifies the value of the FieldName variable that invokes the Action specified 

in  Action<i> .

Action<i>: Specifies the action to call in the case the data matches  Value<i> .

Default Action: Specifies the action to invoke if the data doesn’t match any of the specified 
values.

6.10.4 DataAlpha

The DataAlpha plug-in controls the value of the Alpha function plug-in.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.
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Values are between  0  and  100  ( 0 =transparent,  100 =opaque).

6.10.5 DataAnim

The DataAnim plug-in animates a value and sends the data of this value, every field, to the 
DataField that is defined in the Output Field Name. This plug-in is different from other DataPool 
plug-ins since it is not triggered by a change of a DataField. It is activated from the animation 
director it is located in, and plays a predefined animation. This plug-in acts as a data generator for 
the specified output DataField.

DataAnim Properties
Output Field Name: Defines the name of the DataField that receives the animated value of 
the Value parameter every video field.
Animation Type: Defines the type of value that is sent to the Output Field Name. Value types 
are integer or float.
Value: Generates and sends the data (the animated parameter of the plug-in) to the 
DataField defined in Output Field Name.

Example

Define the Output Filed Name as  AAA , and create an animation of the Value parameter 

from  0  to  10 . When running the animation,  AAA  is changed every field as the animation 

progresses from  0  to  10 . All DataPool plug-ins registered to the DataField  AAA  is then triggered 

every field and set to the current value of the Value parameter.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.



Note: An Alpha plug-in must be assigned on the controlled container.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.
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6.10.6 DataArray

The DataArray plug-in enables a simpler way of controlling a complex structure of objects that are 
defined in the config.dp file (See DataObject for detailed information about defining object 
structures and using the config.dp file). The plug-in defines the size of the array (the number of its 
child objects) and manages the data flowing to the objects.

DataArray Properties
Field Name: Defines the name and size of the array.
Type: Defines the type of the array objects. The list of types is created from the types 
defined in the configuration files (.dp files).

Example

The Field Name  Stocks[32]  defines an array named Stocks that has 32 objects of the type Stock 

selected in the Type parameter.

6.10.7 DataArrow

The DataArrow plug-in works specifically on the Arrow geometry plug-in in Viz. It controls the start 
and end points of the arrow object, enabling incoming data to control the arrow object.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.



Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.
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DataArrow Properties
Format: Specifies the format of the expected data. The plug-in processes the data according 
to the selected format. The options are Point1 (start point), Point2 (end point) 
or Point1&2 (both end points).

6.10.8 DataCamera

The DataCamera plug-in controls camera position and target according to the incoming data.

If the container that the plug-in controls has child containers, then the specified camera locks its 
position to the first child container and the destination of the camera is locked to the second child 
container. In this case, the data should be of the following format:

DATA=<camera> <x position> <y position> <z position> <x target> <y target> <z 
target>;

If the container doesn’t have any child containers then the data should be of the following format:

DATA=<camera> <x position> <y position> <z position> <pan> <tilt> <twist>; 

The plug-in works in two different modes: First, the data contains both the camera ID, the position 
and target of the camera and second, the data contains just the camera ID and the position and 
the target of the camera are calculated from the center of the first two children of the container. In 
the second mode, the container must have two children. The center of the first child determines 
the center of the camera and the center of the second child determines the target of the camera.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.



Note: Position and target values are used as offsets from the child containers location.

Note: Camera position change is relative to the container that the plug-in works on.
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DataCamera Properties
Set Current: Defines whether a camera switch in the render window occurs if the incoming 

data refers to a different camera than the current camera. If set to  On , then when incoming 

data refers to a camera other than the current camera selected in the render window, the 

camera switches to the camera defined in the incoming data. When set to  Off , the camera 

defined in the incoming data is moved, but the current camera remains the same.
Function: This parameter is inactive. The parameter is kept for backwards compatibility and 
should not be used.

6.10.9 DataCenter

The DataCenter plug-in changes the axis of the container according to the received data.

DataCenter Properties
Format: Specifies the format of the incoming data. Format options specify the axis which the 
data relates to.

Incremental Change: Adds incoming data to the current value of the data when set to  On . 

When set  Off , the data replaces the existing value of the data field.

Example

If Field Name is  VALUE  and the format is  X , the data sent is  VALUE=10.5 . The container moves 

the X axis to a position of  10.5 .

6.10.10 DataClick

The DataClick plug-in triggers an action when the mouse is clicked within the drawn area of the 
container it is assigned to or on any of its child containers.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.
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DataClick Properties
Settings: Defines the displayed editor type. When set to Advanced, every click triggers two 
events: mouse down (mouse button pressed) and mouse up (mouse button released). When 
set to Simple, only mouse click is used.
On Click: Triggers a DataPool action when the mouse is clicked within the container’s drawn 
area and any of its child containers.
On Click Child: Triggers a DataPool action when the mouse is clicked within the drawn area 
of a child container under the container affected by the DataClick plug-in.
On Mouse Down: Triggers a DataPool action when the mouse button is pressed within the 
container’s drawn area and any of its child containers.
On Mouse Down Child: Triggers a DataPool action when the mouse button is pressed within 
the drawn area of a child container under the container affected by the DataClick plug-in.
On Mouse Up: Triggers a DataPool action when the mouse button is released within the 
container’s drawn area and any of its child containers.
On Mouse Down Child: Triggers a DataPool action when the mouse button is released within 
the drawn area of a child container under the container affected by the DataClick plug-in.
On Enter: Triggers a DataPool action when the mouse enters the container’s drawn area and 
any of its child containers.
On Enter Child: Triggers a DataPool action when the mouse enters the drawn area of a child 
container under the container affected by the DataClick plug-in.
On Leave: Triggers a DataPool action when the mouse leaves the container’s drawn area.
On Leave Child: Triggers a DataPool action when the mouse leaves the drawn area of a child 
container under the container affected by the DataClick plug-in.
Behavior: Defines in what way the mouse events trigger the actions or cause the DataField to 
change. When set to On Click, only the on click events are enabled. When set to On Click and 
Move additional action (On Enter and On Leave) fields are enabled.

6.10.11 DataCondition

The DataCondition plug-in evaluates the value of the DataField it is registered to using a defined 
comparison function and executes an action accordingly.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.



Note: This plug-in is located in: Plugins -> Container plug-ins -> Data
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DataCondition Properties
Format: Defines the way incoming data is handled. Data can be used as a number, string, a 
set of X Y values or a set of X Y Z values. The following table shows how the different 

formats are evaluated. Cells filled with  EVAL  are evaluated by the selected operator. Cells 

filled with  TRUE  always return true. Cells filled with  FALSE  always return false. Other text 

in a cell shows the behavior of the chosen operator.
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Number: Performs a simple numeric evaluation.
Text: Performs an alphanumeric evaluation.
X Y: Calculates the sum of the absolute value of the difference between the first and 
second values of the arguments and compares it to the precision value multiplied by 
two: |x1 - x2| + |y1 - y2| < 2 * precision.
X Y Z: Calculates the sum of the absolute value of the difference between the first, the 
second and the third values of the arguments and compares it to the precision value 
multiplied by three: |x1 - x2| + |y1 - y2| + |z1 - z2| < 3 * precision.

Condition: Specifies the evaluation function to apply. Evaluation is done left to right 

(incoming data is placed at the left side of the comparison operator).  True  always runs the 

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.



Note: The X Y and X Y Z formats only support equal to (=) and not equal to (!=). 
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action and  False  always runs the else action (if enabled). The If option evaluates the 

DataField value: i.e. all values other than zero runs the action, zero runs 

the else action.  Between  checks if the value is greater or equal (>=) than the first and lower 

(<) than the second argument.
Arguments: Defines the expression that is compared to the incoming data. An argument can 
be a constant (i.e. a fixed number/text) or a data field value. To specify a data field value as 

an argument, use the following syntax:  $(DataFieldName) .

Compare Vectors: Defines incoming data as a vector (an array of DataFields with definition 
of the number of items) and the argument expression is taken to be a vector of data when 

set to  On . The comparison is then done item by item and the action is executed accordingly 

on each of the children. If this parameter is  Off  then each item in the incoming data is 

compared against one single argument.
Precision: Affects the evaluation of X Y and X Y Z formats only. It defines the margin in which 
the evaluation results as true (see X Y or X Y Z format explanation).

Do Once On Change: Triggers an Else action. When set  ON , only if the condition result was 

changed, i.e. if it was changed from true to false or vice versa, the action (or Else action) is 

triggered. When set  Off , every time the condition is checked the action (or Else action) is 

triggered accordingly.

Action: Specifies the action to invoke. If the action string begins with  0 , then the command 

is handled as a Viz command and sent directly to Viz Engine, otherwise it is considered to be 
a DataPool command. The action can contain more than one command to be called. The 
commands must be separated by semicolons (;). Expressions can be used in the action 
utilizing the special DataPool variables.

Else: Enables the Else action when set to  On . When an else action is defined it is executed if 

the evaluation result is false. When set  Off , the Else action field is disabled and no action is 

executed when the evaluation result is false.
Else Action: Defines the action to execute if the evaluation result is false.

6.10.12 DataCountdown

The DataCountdown plug-in counts up or down to a defined target time. Target time is an absolute 
time (future or past).

Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.
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DataCountdown Properties
DP variables Prefix: Variable prefix is added to a set of fixed names, based on time scale, for 
different time variables. The prefix is used to distinguish one set of time parameters from 
the other. The default prefix is CD1. For example, if Prefix is set to DDay, the corresponding 
variables are:

DDay_DAYS
DDay_HOURS
DDay_HOURS_TOTAL
DDay_MINS
DDay_MINS_TOTAL
DDay_SECS
DDay_SECS_TOTAL
DDay_SIGN (i.e + for future and: for past) 

Target Day in month: Defines the countdown target day. Values are  1-31 .

Target Month: Defines the countdown target month. Values are  1-12 .

Target Year: Defines the countdown target year. Values are  1970-2050 .

Target Hour: Defines the countdown target hour. Values are  0-23 .

Target Minute: Defines the countdown target year. Values are  0-59 .

Target Second: Defines the countdown target year. Values are  0-59 .

Leading Zero All: Adds a leading zero to all the single digit numbers ( 0-9 ) when set to  On .

Leading Zero Minutes, Seconds: Adds a leading zero to the single digit numbers ( 0-9 ) of 

the minutes values and the seconds values when set to  On . Others are displayed as a single 

digit.
Action On Time: Defines an action that is executed when the counter reaches the target 

time. If the action string begins with  0  then the command is handled as a Viz command, 

otherwise it is considered to be a DataPool command. The action can contain more than one 
command to be called. The commands must be separated by semicolons (;). Expressions can 
be used in the action utilizing the special DataPool variables.
Action On T-offset: Defines the action that is executed when the counter reaches an offset 
point from the target time.
Offset (Seconds): Defines the offset from the target time that triggers the action on t-offset 
(in seconds).
Set Target to NOW: Sets the current system time as the target time when pressed.
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6.10.13 DataCounter

The DataCounter plug-in increases/decreases its value every time the DataField changes (if set to 

begin counting at  1  with an incremental value of  1 , the plug-in counts the number of times that 

the DataField changed). The plug-in starts counting at the From parameter value, adding 
the Step parameter value to counter every time the DataField defined in Field Name changes, until 
the value To is reached. When the To value is reached, the counter starts over again from the 
beginning.

DataCounter Properties
From: Defines the initial value of the counter.
To: Defines the ending value of the counter.
Step: Defines the value to increment.
Output Field: Defines a DataPool variable that the counter value is assigned to.
Output Scope: Defines whether the DataPool variable defined in the output field is a global 
variable or a local variable.

6.10.14 DataDirector

The DataDirector plug-in enables the control of an animation director by assigning stage 
commands to the DataField it is registered to.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.



Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.
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DataDirector Properties
Use Other Container: Defines if the plug-in controls the director of a different container 
(available options: parent, grand parent, grand grand parent, remote).
Use the container’s director: Defines if the plug-in controls the director for the animation in 
a container.

If none is enabled, then the default director is controlled.

Stage Commands

The stage commands that can be assigned to the DataField: START , CONT , START_REV  (v5.0 

only), CONT_REV  (v5.0 only), STOP .

Example
Create an animation for a container (for example, a rectangle). Add the DataDirector plug-in to the 

container. Set the Field Name of the plug-in to AAA . Send the command:  AAA=START; .

6.10.15 DataDispatcher

The DataDispatcher plug-in enables data transfer between plug-ins. DataDispatcher calls the 
dispatcher of a plug-in in the controlled container, and transfers data via DataPool variables.

DataDispatcher Properties
Parameter Type: Defines destination plug-in type. Data is formatted accordingly.
Function Name: Defines the name of the plug-in whose dispatcher is to be called.

Data Format
The data should arrive in the following format:

Note: If animation of a remote Container is used (by checking Use Other Container-
>Remote ), then the animation director in the remote container is triggered.



Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.
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<dispatcher message ID> <dispatcher message body>

6.10.16 DataDrawMask

The DataDrawMask plug-in is used when using viewports (multiple camera windows in Viz render 
window). The plug-in defines the mask type of the container it controls and the way it is rendered 
in each of the viewports. The DataField (defined in Field Name) value contains this information.

6.10.17 DataFeedback

The DataFeedBack plug-in sends information from the DataPool to a specific UDP socket in a 
remote host.

DataFeedback Properties
Destination Host: Defines the hostname to which the data is sent to.
Destination Port: Defines the socket number to which the data is sent to.
Connect: Initializes the connection after the host and port are defined.
Connection Type: Defines the connection type to open: UDP or TCP.
Message: Defines the expression to send to the remote socket when the plug-in is triggered.
Add EOL (CR &LF) to TCP: Defines if new line and line feed characters to add to the TCP 
message.
Add Delimiter to TCP: Defines if a delimiting character to add to the message.
Char Of TCP Delimiter: Defines the character to use as a delimiter and add to the message.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.



Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.
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6.10.18 DataGeom

The DataGeom plug-in sets the geometry of the container it is assigned to according to the 
received data. A group with child geometry containers is defined in the scene tree and the 
DataField receives the index of the selected geometry (index is zero based). The same result can 
be achieved by using the Data3DObject plug-in, but Data3DObject plug-in accesses the disk when 
used. To avoid real time rendering problems in heavy scenes, it is better to use the DataGeom 
since it does not access the disk.

DataGeom Properties
Group Parent: Defines the parent container of the geometries in the scene tree. The 
container is dragged to the container area in the DataGeom editor.
Copy Container: Defines if the geometry is copied as a child container to the DataGeom 
controlled container when sent.

Example
Given the following scene tree:

The DataPool assignment  Geom=0 ; changes the geometry of the GEOM container to 

sphere,  Geom=1 ; changes it to cube and so on.

6.10.19 DataGraph

The DataGraph plug-in works on the Graph geometry plug-in in Viz. It enables controlling the 
values of the graph points. Incoming data value of the DataField must contain all the point values 
according to the selected format, separated by spaces.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.



Note: If an index value that does not exist is sent, then zero value is used (the first 
geometry under the group).
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DataGraph Properties
Format: Defines the axis that is controlled by the plug-in. If one axis is selected (X or Y) then 
the data should contain one value per point, if X Y is selected, then two values should be 
sent per point.
Normalize: Forces the graph points to use the entire height range (the range between 
Position Min and Position Max parameter) according to the minimum and maximum values 

received when set to  On . The minimum value is used as the Data Min value and the 

maximum value is used as the Data Max, using the entire graph range for the received 
values.

Example
If format is set to X Y, then for drawing four point of the graph, eight numbers should be sent:

Abc=0 0 10 5 12 10 8 15;

The first point is located at  X=0 ,  Y=0 .

The second point is located at  X=10 ,  Y=5 .

The third point is located at  X=12 ,  Y=10 .

The fourth point is located at  X=8 ,  Y=15 .

6.10.20 DataGraphPoint

The DataGraphPoint plug-in enables to control values of a selected point in a Graph 
object, 2DRibbon object and 2DPatch object.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.



Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.
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DataGraphPoint Properties
Use DataPool Container: Replaces the Graph Container parameter with the Container Field 

parameter when set to  On . This enables a dynamic control of different graph objects 

defined in the Container Field parameter.
Container Field: Defines a DataPool variable which contains a container name, replacing the 
Graph Container parameter placeholder. This parameter is used from external applications 
sending data to DataPool enabling the application to change the controlled graph object.
Graph container: Defines the container to be controlled. Drag the geometry object from the 
Viz tree to the container area.

Graph Point ID: Defines the point to control. ID is the index of the point in the geometry 
plug-in. ID 1 refers to the first point and so on.
Point Offset: Defines an offset of the point index from the first point. The actual point ID is 
the sum of Graph Point ID and Point offset.
Format: Defines the axis or width to be controlled by the plug-in. If one axis is selected (X or 
Y) or if width is selected (W), then the data should contain one value. If X Y is selected, then
two values should be sent. If X Y W are selected, three values should be sent.

6.10.21 DataHyperlink

The DataHyperlink plug-in receives mouse events and triggers actions accordingly. The actions are 
Viz and DataPool commands.

This plug-in gets the mouse events from Viz and it does not require the DataMouseSensor plug-in 
added to the scene. When a DataHyperlink plug-in is used in a scene, a set of predefined DataPool 
variables is created and updated on every change in the scene. These variables contain information 
about the mouse cursor location and other mouse events:

MX: Defines cursor location on the X axis.
MY: Defines cursor location on the Y axis.
MXY: Defines cursor location on the X axis and Y axis.
MXYZ: Defines cursor location on the X axis, Y axis and Z axis.

Note: Graph Container and Container Field parameters operate the same as the Use 
Remote Container parameter. The Use Remote Container parameter has no effect in 
the plug-in.



Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.
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MOUSE_DRAG: Indicates whether a mouse drag is performed.
MOUSE_CLICK: Indicates whether a mouse button is currently pressed.
DRAGGED_CONT: Returns the ID of the currently dragged container
DROPPED_CONT: Returns the ID of the container that was dropped on the container hosting 
the DataHyperlink plug-in
DROP_TYPE: Defines the type of object that was dropped on the container: No object, 
geometry, image.

DataHyperlink Properties
Search Children: Triggers actions defined on the container that has the plug-in attached to it 

on mouse events of child containers when set to  On . When set to  Off , only mouse events 

on the container that has the plug-in attached to it trigger the actions.
Pick Button: Defines which mouse button (Left, Middle or Right) triggers the Press and 
Release events.
On Press: Defines the action that is triggered when the selected button is pressed and the 
cursor is within the container area.
On Release: Defines the action that is triggered when the selected button is released and the 
cursor is within the container area.
On Enter: Defines the action that is triggered when the cursor enters the container area.
On Leave: Defines the action that is triggered when the cursor leaves the container area.
On Mouse Move: To be implemented.
On Mouse Over: Defines the action that is triggered while the cursor hovers within the 
container area.
On Mouse Drag: Defines the action that is triggered while the container is dragged.
On Mouse Drop: Defines the action that is triggered when another object is dropped within 
the container area.

Delay Click: Delays actions triggered by the mouse by five fields when set to  On . When set 

to  Off , no delay is used.

Drag For Position: Enables to container to be dragged and re-positioned in the render 
window when in On Air mode. Positioning occurs when the left mouse button is pressed and 
the mouse is dragged in the render window when the related container is selected. When set 

to  Yes , additional parameters are enabled.

Use Drop Z-Buffer Value: Changes perspective and container area when dragging an object 
around. This parameter defines whether the cursor location follows the container area 
through out the dragging of the object or the object moves according to the mouse 
movements. Due to perspective changes, the cursor might exit the container area while 
dragging.

Note: When using DataHyperlink in a scene and no other data is sent externally, 
adding the DataPool scene plug-in is unnecessary.
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Limit X Position: Defines whether to limit the movement of the object on the X axis while 

dragging. When set to  Yes , Min X Position and Max X Position are enabled, defining the 

minimum/maximum position on the X axis that the object can be dragged to.
Limit Y Position: Defines whether to limit the movement of the object on the Y axis while 

dragging. When set to  Yes , Min Y Position and Max Y Position are enabled.

Limit Z Position: Defines whether to limit the movement of the object on the Z axis while 

dragging. When set to  Yes , Min Z Position and Max Z Position are enabled.

Drag For Rotation: Enables container to be dragged and rotated in the render window when 
in On Air mode. Rotation occurs when the center mouse button is pressed and the mouse is 

dragged in the render window when the related container is selected. When set to  Yes , 

additional parameters are enabled.
Limit X Rotation: Defines whether to limit the rotation of the object on the X axis while 

dragging. When set to  Yes , Min X Rotation and Max X Rotation are enabled.

Limit Y Rotation: Defines whether to limit the rotation of the object on the Y axis while 

dragging. When set to  Yes , Min Y Rotation and Max Y Rotation are enabled.

Limit Z Rotation: Defines whether to limit the rotation of the object on the Z axis while 

dragging. When set to  Yes , Min Z Rotation and Max Z Rotation are enabled.

Rotation Sensitivity: Defines the relation between the mouse movement and the object’s 
rotation. The higher the sensitivity is, the larger mouse movements required to rotate the 
object to the same point.
Drag For Scale: Enables to container to be scaled when the mouse is dragged in the render 
window when in On Air mode. Scaling occurs when the right mouse button is pressed and 
the mouse is dragged in the render window when the related container is selected. When set 

to  Yes , additional parameters are enabled.

Limit Scale: Defines whether to limit the scaling of the object while dragging. When set 

to  Yes , Min Scale and Max Scale are enabled.

Scaling Sensitivity: Defines the relation between the mouse movement and the object’s scale. 
The higher the sensitivity, the larger mouse movements required to scale the object to the 
same size.
Use Another Container Bounding Box: Enables Container For Bounding Box parameter when 

set to  Yes . When set to  No , the container’s bounding box is used to capture mouse 

events. 
Container For Bounding Box: References this container's bounding box for events when a 
container is dragged to the placeholder.
Drop Type: Defines which drop action triggers an event.

NONE: Does not trigger an event.
Cont Geom: Triggers a drag event for a dropped geometry.
Cont Image: Triggers a drag event for a dropped image.
Other Cont Geom: Enables a Dropped Container parameter when selected. When a 
container is dropped in the defined Dropped Container parameter, it triggers a drop 
event.
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Other Cont Image: Enables a Dropped Container parameter when selected. When an 
Image is dropped in the defined Dropped Container parameter, it triggers a drop 
event.

Use Viewports: Enables a Camera Number parameter when set to  Yes . Set the number of 

camera. The viewport area of the selected camera triggers the events.

Force Scene Redraw: Redraws the render window every field when set to  Yes . When set 

to  Off , Viz renders the graphics normally.

6.10.22 DataImage

The DataImage plug-in changes the image or texture applied to the container. 

The data specifies the name of the image applied to the container.

DataImage Properties
Set MaterialDefinition BaseColor: Sets the given image as BaseColor channel on a V4 PBR 
Material.
Set MaterialDefinition Emissive: Sets the given image as Emissive channel on a V4 PBR 
Material.

Format
Image names should have the format:

IMAGE*<name>: Where  <name>  is the full path to an image in Viz images library. The 

prefix  IMAGE*  can be omitted from the name.

BUILT_IN*IMAGE*<name>: For special built-in images like VIDEO1, VIDEO2…

Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.



Note: The container must have an initial image attached to it for the plug-in to take 
effect.
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Example
A container with three children and with a DataImage plug-in attached to it. If the Field Name 

is  IMAGES[3]  and the data is entered as  IMAGES[0-2]=IMAGE*image1, IMAGE*image2, 

BUILT_IN*IMAGE*VIDEO1;  then the first child shows image1, the second image2 and the third 

shows VIDEO1.

6.10.23 DataInRange

The DataInRange plug-in converts a range of values into a single value. The value in the Field name 
parameter is compared to the defined values in the Range Descriptions parameter. If the input 
value is found in one of the ranges, it is converted to the value assigned to the range and the 
result is set in the Result Field Name.

DataInRange Properties
Result Field Name: Defines the name of the DataPool variable that the result of the range 
conversion is assigned to.

Result Field Scope: Defines the scope of result field. If set to  Local , the Result Filed Name 

value is defined as part of a DataPool structure used in an object. If defined as  Global , the 

Result field is defined as a regular data field.
Range Descriptions: This parameter contains the different ranges. A range is defined inside 
brackets, with minimum and maximum values separated by comma. When a round bracket 
(opening or closing the range), the value next to it is not included in the range (but limiting 
the range). When square brackets are used the values are included in the range.

Example
In the following line the range of numbers between 1 and 10, excluding 1 and including 10, is 
converted to the text Little Numbers:

(1,10] = Little Numbers;

Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.



Note: Range values must be numeric values.
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6.10.24 DataInterpolate

The DataInterpolate plug-in copies a numeric value to another field. The value in the Field Name 
parameter is multiplied with the defined value in the Type parameter.

DataInterpolate Properties
Result Field Name: Defines the name of the DataPool variable that the result of the range 
conversion is assigned to.
Result Field Scope

Local: Defines the result field as part of a DataPool structure used in an object. 
Global: Defines the result field as a regular data field.

Range Descriptions: Unused parameter.
Type

Two: Multiplies input value by two.
Ten: Multiplies input value by ten.

6.10.25 DataKey

The DataKey plug-in toggles the Key function plug-in.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.



Note: This is an experimental plug-in.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.
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DataKey Properties

0: Sets the key to  Off .

Any other Value: Sets the key to  On .

6.10.26 DataKeyFrame

The DataKeyFrame plug-in affects a named keyframe of an animation defined on the container the 
plug-in is attached to. Keyframe name must be unique. When the FieldName changes, the plug-in 
looks for the keyframe and assigns new values to it.

DataKeyFrame Properties
KeyFrame Name: Defines the name of the keyframe the plug-in works on. The keyframe 
name must be unique.
Reset KeyFrame: Defines the name of a keyframe containing initial parameters to be used 

when a  RESET  string is received. If a  RESET  data is accepted, the keyframe values are set 

to the values of the Reset KeyFrame. The keyframe name must be unique.
Value Format: Defines the format of the received data. 

6.10.27 DataKeyFrame2

The DataKeyFrame2 plug-in behavior is the same as DataKeyFrame behavior, with the same 
parameters. The plug-in was created because it is not possible to add the same function plug-in 
twice to the same container.

Note: Key function plug-in must be assigned to the container.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.



Note: If data format is not as defined in the Value Format parameter, unpredictable 
behavior occurs.
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6.10.28 DataKeyText

The DataKeyText plug-in allows entering text to a container with text geometry using the 
keyboard. It allows defining actions to be taken as soon as the data arrives. In order for the data to 
arrive, the container must be in focus. The container is in focus when it is selected using the 
mouse.

DataKeyText Properties
Click To Focus: Specifies whether the container is always in focus or just when the mouse 
selects it.
On Focus: Defines what to do when the container has focus. There are three options: First, 
nothing happens (no effect). Second, a Viz Action is invoked, or third, a DataPool Action is 
executed. DataPool Action is a series of commands in the same format as entered in the 
DataPool plug-in.
On Defocus: Defines what to do when the container loses focus. There are three options: 
First, nothing happens (no effect). Second, a Viz Action is invoked, or third, a DataPool 
Action is executed. DataPool Action is a series of commands in the same format as entered 
in the DataPool plug-in.
On Enter: Defines what to do when the container is in focus and the Carriage Return 
or ENTER button is clicked. There are three options: First, nothing happens (no effect). 
Second, a Viz Action is invoked. Third, a DataPool Action is executed, or fourth, the new line 
is started in the text.
Defocus on Enter: Removes container focus when a Carriage Return or ENTER button is 
pressed and the On Defocus action is invoked.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.



Note: This plug-in is deprecated. DataKeyFrame2 became obsolete when the parameter Use 
Remote Container was added to the DataPool plug-in. The is continued for backwards 
compatibility only, to support scene already using this. When creating new scenes, use the 

DataKeyFrame with the Use Remote Container option set to On .



Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.
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On Change: An action that is invoked every time a character is entered to the container. The 
options are No Effect, Viz Action or DataPool Action.

6.10.29 DataKeyTime

The DataKeyTime plug-in moves a defined keyframe on the animation timeline to the time 
specified by the value of the DataField. The keyframe must have a unique name assigned to it. 
When used with the Remote Container option, multiple keyframes of the same animation can be 
manipulated by multiple DataKeyTime plug-ins.

DataKeyTime Properties
Keyframe Type: Defines the type of animation property to affect: Keyframe, Stop or Pause 
point, or Action tag.

Director Name: Defines the name of the director containing the stop point or pause point to 
affect. The name is defined in the stage editor of Viz. This parameter is enabled when Key 
Frame Type is Stop/Pause Point or Action.
Channel Name: Defines the name of the channel containing the action tag to affect. The 
name is defined in the stage editor of Viz. This parameter is enabled when Key Frame Type 
is Action.
Keyframe Name: Defines the keyframe that is controlled by the plug-in. The name is defined 
in the stage editor of Viz and it must be unique.
Time Format: Defines if incoming data value is processed as Frame units (video frames) or 
seconds.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.



Note: Any property selected must be named uniquely. Otherwise the plug-in does 
not affect the selected point.



Note: Key Frames are moved to the absolute time value in the timeline. Abnormal 
behavior might occur when moving key frames on the timeline, since key frames can 
change their sequential order in the animation.
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6.10.30 DataLookup

The DataLookup plug-in searches data inside complex data objects using index and field name.

DataLookup Properties
Source: Defines the Data Object to be searching.
Attribute: Defines the field name of Data Table inside Data Object after selected by index or 
hash key and get only value of this field.
Target: Defines the DataField that receives the result of the operation.
Find Until: Use when Source parameter assigned to DataHashTable with ordered numeric key 
and searching for element with maximum key value less than value of hash key
Return Key: Use with Find Until parameter to get only the matched key value, not 
use Attribute parameter to get the field value inside.

6.10.31 DataLUImage

The DataLUImage plug-in defines a table of aliases which link to images in the Viz Images folders. 
The value sent in the DataField is one of the alias names. When the plug-in receives the data, it 
compares the value to all the aliases defined in the table. If an alias matches the value sent, the 
plug-in replaces the image on the controlled container to that image.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.



Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.
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DataLUImage Properties
Image0..Image19: Defines image placeholders for defining the images in the table. The 
images are dragged from the image library in Viz to the image place holders. To remove an 
image from the table, press the Reset button or drag a new image to it.
Value0..Value19: Contains the aliases for each of the images.

Example
If Field Name is set to MyImage, then to change the image on the container, use the following 

command:  MyImage=Value1;  (Or any other value assigned to an image).

6.10.32 DataManipulate

The DataManipulate plug-in enables interactive manipulation of the object that the plug-in is 
placed on, when in On Air mode. The left mouse button controls position manipulation, center 
Mouse button affects rotation and the right mouse button affects scaling.

DataManipulate Properties
Virtual Manipulation: Defines if object manipulation is based on Data Fields values. When set 

to  On , additional parameters are enabled:

Virtual Position FieldName: Defines a DataPool variable that controls the position of 
the manipulated container. The value of the variable defines the delta of the object 
position from the current position.
Virtual Rotation FieldName: Defines a DataPool variable that controls the rotation of 
the manipulated container. The value of the variable defines the delta of the object 
rotation from the current rotation value.
Virtual Scale FieldName: Defines a DataPool variable that controls the scale of the 
manipulated container. The value of the variable defines the delta of the object scale 
from the current scale.

Single Button: Allows all mouse buttons to control one property of the object when set 

to  On . An additional parameter is enabled, setting the controlled attribute of the object:

Single Button Mode: Selects the control mode of the mouse.
Navigation Model: Selects the type of axis used to manipulate the object.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.
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Cartesian: Uses the Cartesian coordinate system to calculate object movement.
Polar: Uses the Polar coordinate system to calculate object movement.
Navigation Model: Selects the type of axis used to manipulate the object.

Other Container is Hot Area: Defines a remote container as the hot area instead of the 

container the plug-in is attached to. When set to  On , an additional parameter is enabled: 

Hot Area Container, and a container placeholder is added.
Is Moveable: Moves the object when selected and dragged while the left mouse button is 

pressed, when set to  On . When set  Off  the object does not move when dragged. 

Additional parameters are enabled when set to  On :

Movement: Determines how the selected object can move. When 2D is selected, the 
object can move only on the X and Y axes. When 3D is selected, the object can be 
moved in all three axes.
Limit Move X: Limits the object’s position values according to the values set in the 

Move Min X and Move Max X when set to  On . When set to  Off  the object can be 

dragged all over the render window. 
Limit Move Y: Limits the object’s position values according to the values set in the 

Move Min Y and Move Max Y when set to  On . When set to  Off  the object can be 

dragged all over the render window. 
Limit Move Z: Limits the object’s position values according to the values set in the 

Move Min Z and Move Max Z when set to  On . When set to  Off  the object can be 

dragged all over the render window. 
Is Rotation able: Rotates the object when selected and dragged while the center mouse 

button is pressed, when set to  On . When set  Off  the object does not rotate when dragged. 

Additional parameters are enabled when set to  On :

Limit Rotate X: Limits the object’s rotation values according to the values set in the 

Rotate Min X and Rotate Max X when set to  On . When set to  Off  the object can be 

rotated to any angle.
Limit Rotate Y: Limits the object’s rotation values according to the values set in 

the Rotate Min Y and Rotate Max Y when set to  On . When set to  Off  the object can 

be rotated to any angle.
Limit Rotate Z: Limits the object’s rotation values according to the values set in 

the Rotate Min Z and Rotate Max Z when set to  On . When set to  Off  the object can 

be rotated to any angle.
Rotation Sensitivity: Defines the relation between the mouse movement size and the 
rotation size.

Is Scaleable: Scales the object when selected and dragged while the right mouse button is 

pressed, when set to  On . When set  Off  the object does not scale when dragged. 

Additional parameters are enabled when set to  On :

Limit Scale: Limits the object’s scaling values according to the values set in the Min 

Scale and Max Scale, when set to  On . When set to  Off  the object can be scaled to 

any size.
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Scale Sensitivity: Defines the relation between the mouse movement size and the 
scaling size.

Writeable: Controls a text object. If the plug-in is controlling a text object and writable 

is  On , when selecting the object the user can type and change the content of the text value. 

When set to  Off , the text object cannot be modified.

Show Bounding Box: Toggles visibility for the object's bounding box. When set to  On , the 

object’s bounding box is visible when the object is selected (in On Air mode). When set 

to  Off , the bounding box is not visible when the object is selected.

6.10.33 DataMaterial

The DataMaterial plug-in changes the material parameters of the controlled container.

The data specifies any combination of the ambient, diffuse, specular, emission and alpha 
parameters of the material. The data format is:

[AMBIENT r g b] [DIFFUSE r g b] [SPECULAR r g b] [EMISSION r g b] [ALPHA a] 

This format can specify new values for separate material components.

[COLOR r g b]: Specifies a color using red green and blue values.

[MATERIAL name]: Specifies a material name from the Viz material library. The message 

format is:  MATERIAL MATERIAL*<name> , where  <name>  is the full path to a material in Viz 

material library. 

Note: DataManipulate plug-in does not work if the scene has a DataInteractive plug-
in added.



Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.



Note: All color values (r g b) are numbers between 0  and 255 . Alpha values are 

float numbers between 0  and 100 .





Plug-ins User Guide -  5.0

Copyright © 2022  Vizrt Page  553

•

•

•

•

•

•

Example

If the received data is  MAT[0-3]=DIFFUSE 255 0 0, DIFFUSE 0 255 0, DIFFUSE 0 0 

255;  then the diffuse component of the material of the first child is red, the diffuse 

component of the material of the second child is green and, the diffuse component of the 
material of the third child is blue.

If the data received is  MAT=COLOR 255 0 0;  then all the container materials are set to red.

If the data received is MAT=MATERIAL MATERIAL*blue;  then the material is set to the blue 

material in Viz material library.

If the data received is MAT=MATERIAL MATERIAL*<UUID>;  then the material is set to the 

material of the given UUID.

Advanced Color Control
The Advanced Color Control simplifies the way to set the DataMaterial field.

Color Property Mode

If the Advanced Color Control option is set to On , the drop-down list Color Property Mode is 

shown. The list shows all available modes:

COLOR, AMBIENT, DIFFUSE, SPECULAR, EMISSION, ALPHA, MATERIAL.

The effect when using the Advanced Color Control is that the needed Prefix for DataPool is set 
automatically by the plug-in.

Color Property Example

On a container with a geometry, a material and the plug-in DataMaterial with field set to "mat", 
these are the DataPool settings:

With Advanced Color Control set to Off : mat=MATERIAL MATERIAL*GLOBALS/

redMaterial

With Advanced Color Control set to On  and Color Property Mode set to MATERIAL: 

mat=MATERIAL*GLOBALS/redMaterial

Note: DataMaterial plug-in does not work unless the controlled containers have a 
material on them. If controlling child containers from a top node, each of the 
controlled child containers must have a material attached to it. The top container 
hosting the DataMaterial plug-in doesn’t need to have a material attached to it.



Note: Only first level of child containers with materials are affected, grandchildren 
containers with materials are not affected.
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Color Format

This parameter provides multiple input formats for colors. Supported are following formats:

Format Range RGB Range Alpha Example

R G B (int) 0 - 255 - 236 132 39

R G B (float) 0.0 - 1.0 - 0.9255 0.5176 0.1529

RGBA (hex) 00 - FF 00 - FF EC84277F

ARGB (hex) 00 - FF 00 - FF 7FEC8427

RGB (hex) 00 - FF - EC8427

R G B A (int) 0 - 255 0 - 100 236 132 39 50

R G B A (float) 0.0 - 1.0 0.0 - 1.0 0.9255 0.5176 0.1529 0.5

A R G B (int) 0 - 255 0 - 100 50 236 132 39

A R G B (float) 0.0 - 1.0 0.0 - 1.0 0.5 0.9255 0.5176 0.1529

6.10.34 DataMaterialGradient

The DataMaterialGradient plug-in changes the material color of the controlled container to a color 
within a predefined spectrum (the plug-in changes the hue of the material). A minimum value is 
assigned to one color and a maximum value is assigned to another color. Any value between the 
minimum and maximum values is translated to a color, and affects the container’s material.

Note: The Color Format is not enabled for ALPHA and MATERIAL.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.
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DataMaterialGradient Properties
Source material: Assigns the Data Min value to the material/alpha.
Target material: Assigns the Data Max value to the material/alpha.

Example

Data Min is  0  and Data Max is  100 . Source material is red and Target material is green. If the 

received data is  50  the material that is set on the container is yellow.

6.10.35 DataMaterialIndex

The DataMaterialIndex plug-in changes the material of the controlled container. The scene must 
have a DataMaterialTable scene plug-in with a defined material table. 

The DataMaterialIndex plug-in uses the indexes of the defined materials in the 
DataMaterialTable to change the material on the containers. Data format is an index number 
(integer). The DataMaterialIndex plug-in copies the material related to the given index from the 
table to the controlled container. The controlled container must have material attached to it.

Example
To apply the index to a series of subcontainers, place the DatamaterialIndex plugin on the parent 
container and use e.g. matindex[0-9] as Field Name. This means it changes the material color of 
the first ten containers to the given values (1-7).

MatIndex[0-9]=1,2,3,4,5,6,7;

The material on the first child is changed to the material defined in entry 1 in the material table, 
the second is changed to the material defined in entry 2 of the material table, and so on. The last 
containers (index 7-9) are set to the material defined in index 7 of the table.

Note: DataMaterialGradient plug-in does not work unless the controlled containers have a 
material on them. If controlling child containers from a top node, each of the controlled 
child containers must have a material attached to it. The top container hosting the 
DataMaterialGradient plug-in doesn’t need to have a material attached to it.



Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.
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6.10.36 DataMath

The DataMath plug-in performs mathematical calculations with DataPool variables and writes the 
result to a specified DataField.

DataMath Properties
Argument 1 and Argument 2: Defines the arguments used for the mathematical 
operation. argument1 is used at the left hand side of the operator. Both arguments must be 
DataPool variables (DataFields) or constants. If the operation is unitary, only argument1 is 
used.

Result: Defines the DataField that receives the result of the operation.
Operation: Defines the operator that is used for the calculation.

+ - *: Adds/subtracts/multiplies the arguments.
/: Divides argument1 by argument2.
Div: Provides integral part of the division of argument1 by argument2.
Mod: Gives the remainder of the division of argument1 by argument2.
^: Raises argument1 to the power of argument2.
AND: Performs a logical AND of the arguments: If both are different than zero the

result is  1 .

OR: Performs a logical OR of the arguments: If both are zero the result is  0 .

Cos / Sin: Determines cosines/sines of argument1.
Rnd: Gives a random value between the two values.
Time ++/--: Increases/decreases argument1 by one.
Min/Max: Performs a numeric comparison of the arguments and returns the lower/
higher value.
Avrg: Calculates the average of the arguments.

Decimal Places: Determines the number of decimal places for the result of the operation.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.



Note: Both arguments (DataFields) trigger the DataMath plug-in and the result is 
calculated.
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6.10.37 DataMathObject

The DataMathObject plug-in performs mathematical calculations with DataPool objects and 
variables and writes the result to a specified result.

DataMathObject Properties
Field Name: Defines the first argument for the mathematical operation. This argument is a 
DataPool variable or a DataPool Object.
Second Argument: Defines the second argument used for the mathematical operation. The 
order of the arguments in the mathematical expression is defined in the Operation Order 
argument.
Second Argument Scope: Defines the scope of the second argument, i.e. whether the 
argument is a local variable (part of an object) or a global DataPool variable.
Result: Defines the DataField that receives the result of the mathematical operation.
Result Scope: Defines the scope of the result, i.e. whether the argument is a local variable 
(part of an object) or a global DataPool variable.
Operation Type: Defines type of operation to perform. According to the selected operation 
type, a list of operations are displayed. The selected operator is used in the mathematical 
expression.
Operation Order: Defines the order of the arguments in the mathematical expression.
Decimal Places: Determines the number of decimal places for the result of the operation.

Notes
If the operation is unitary, only argument1 is used.
Only the Field Name parameter triggers the DataMathObject plug-in and the result is 
calculated.
If one of the variables is not defined it is ignored (it is not created automatically like in other 
DataPool plug-ins).

Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.
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6.10.38 DataMinMax

The DataMinMax plug-in receives a DataPool array name and returns two DataFields: One 
containing the minimum value of the array and the other containing the maximum value of the 
array.

DataMinMax Properties
Field Name: Defines the name of the array to be checked.
Min Destination Field: Assigns the minimum value of the array into a DataField.
Max Destination Field: Assigns the maximum value of the array into a DataField.

6.10.39 DataMouseAction

The DataMouseAction plug-in receives mouse events from the DataMouseSensor plug-in and runs 
Viz actions accordingly. This plug-in is not registered to a DataField. It is attached to a container 
and it is triggered by the mouse actions when the cursor is within the container area in the render 
window.

DataMouseAction Properties
Click To Activate: Determines whether the user has to select the container in order to 

activate the actions. If set to  On , it is selected when the first action that is executed (the 

Mouse Down action).

Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.



Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.



Note: DataPool commands cannot be used.
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Mouse Threshold: Determines the minimum number of pixels that the mouse arrow has to 
be moved before a movement is recognized.
Mouse Down: Calls a Viz action as soon as a mouse button is pressed on top of the 
container the plug-in is attached to.
Mouse Up: Calls a Viz action when a mouse button is released and the container the plug-in 
is attached to is the previously selected container.
Drag Left: Calls a Viz action when the selected container is dragged (moved) to the left and 
the movement is larger then the Mouse Threshold value.
Drag Right: Calls a Viz action when the selected container is dragged (moved) to the right 
and the movement is larger then the Mouse Threshold value.
Stop Horizontal Drag: Calls a Viz action when a horizontal mouse dragging movement stops 
or the mouse button that started all the drag movement stops. 
Drag Down: Calls a Viz action when the selected container is dragged (moved) down and the 
movement is larger then the Mouse Threshold value.
Drag Up: Calls a Viz action when the selected container is dragged (moved) up and the 
movement is larger then the Mouse Threshold value.
Stop Vertical Drag: Calls a Viz action when a vertical mouse dragging movement stops or the 
mouse button that started all the drag movements stop.

6.10.40 DataMousePosition

The DataMousePosition plug-in receives mouse events from the DataMouseSensor plug-in and 
enables dragging the container to attach it to, when in On Air mode. This plug-in is not registered 
to a DataField. It’s attached to a container and it is triggered by the mouse actions when the 
container is in focus (selected).

DataMousePosition Properties
Format: Specifies in which axis or plane the container moves.
X Sensibility: Defines the sensibility of the mouse movement in the X-axis.
Y Sensibility: Defines the sensibility of the mouse movement in the Y-axis.
Click To Activate: Defines whether the user must click on the container in order to activate 
it.
Snap To Grid: Specifies whether the object snaps to an imaginary grid whenever the 
movement is over.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.
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Origin X, Y and Z: Defines the origin of the imaginary grid to be used when Snap To Grid is 
on.
Size X, Y and Z: Defines the dimensions of the cells of the imaginary grid to be used when 
Snap To Grid is on.

6.10.41 DataMultiParam

The DataMultiParam plug-in extends the DataParameter plug-in options. It enables DataPool to 
control multiple parameters. Incoming data contains all the values for the defined parameters.

DataMultiParam Properties
Format: Defines the container parameters to be controlled by incoming data. The format is 
specified in lines, each containing the following information: 

<Plug-in Type> <Plug-in Name> <Parameter Name>

<Plug-in Type>  is either GEOMETRY or FUNCTION.

<Plug-in Name>  is the name of the plug-in that is controlled.

<Parameter Name>  is the name of the parameter in the specified plug-in to control.

Separator: Defines a character in the incoming data that separates between the values of the 
defined parameters. Default separator is a pipe character (|).

Example
If the DataMultiParam plug-in is attached to a cylinder object, with an AutoRotate function plug-in, 
Field name is VALUE and the controlled parameters are:

GEOMETRY Cylinder angle
GEOMETRY Cylinder hole
FUNCTION AutoRotate rotspeed

Using the default separator, incoming data is  VALUE=90 | 100 | 230 . The result is:

Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.



Note: Plug-in name and parameter name must be identical to the names used 
in Viz (names are case sensitive). To find out the correct names, open the Viz 
command console and change the parameter required. The correct spelling is 
displayed in the command console as part of the messages sent from Viz.
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Parameter angle of the Cylinder is set to the value  90 .

Parameter hole of the Cylinder is set to the value  100 .

Parameter rotspeed of the AutoRotate plug-in is set to the value  230 .

6.10.42 DataNumber

The DataNumber plug-in works on containers with text geometry. The plug-in formats the display 
of numeric values according to the parameters set in the plug-in.

DataNumber Properties
Negative Numbers: Defines whether to show a negative number with a minus prefix -123,0 
or use the parenthesis format (123).
Decimal Separator: Defines which character to use as a decimal separator: a comma or a dot.
Replace Zero: Defines whether to replace a zero value with the string defined in the Replace 
Zero By parameter.
Replace Zero By: Defines a string that is displayed when the numeric value equals zero.
Decimal Places: Defines how many digits are displayed on the right side of the decimal 
separator.
Force Fraction: Shows a fraction with the defined decimal places even though the value is an 
integer or has a fraction with less digits than defined when enabled.
Use Thousand Separator: Defines whether a thousand separator is displayed.
Thousand Separator: Defines which character to use as a thousand separator: A comma or a 
dot.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.



Note: When displaying accounting information it is common to use the parenthesis 
to show negative numbers.



Note: The fraction is rounded according to the value defined in the Decimal places 
parameter.
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6.10.43 DataObject

The DataObject plug-in allows to create a new typed object and link it to a Viz hierarchy. When a 
DataObject plug-in is attached to a container, a field name and an object type is specified the 
DataObject plug-in searches Viz hierarchy to look for a parent for the object and children 
underneath. Every Data plug-in found under the container where the DataObject is found is tested 
to see whether it’s a field of the object. If it is so, it is attached as a child of the object.

DataObject Properties
Type: Defines the type of the object. The list of the types is taken from the configuration 
file.

6.10.44 DataObjectTracker

The DataObjectTracker plug-in tracks the controlled container and sends the selected attribute 
values to a defined DataPool variable (DataField).

DataObjectTracker Properties
Destination Field: Assigns container values to DataObjectTracker from the named DataField.
Track Type: Defines which container attributes are tracked by the DataObjectTracker.
Format: Defines the format by which the attribute values are sent to the Destination Field.
Track when hidden: Defines if the object tracks when it is hidden.
Offset X/Y/Z: Adds a fixed value to the current values of the container, in the X/Y/Z axis, 
before setting the values in the Destination Field.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.



Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.
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Scale X/Y/Z: Multiplies a fixed value by the current values of the container’s scale, in the X/
Y/Z axis, before setting the values in the Destination Field.
Absolute Position: Refers all read values from the container in relation to its top parent node 
(i.e. the returned values include all position, rotation or scaling values of all parent 

containers of the controlled container) when set to  On . When set to  Off , all values read 

from the container refer to the container itself in relation to its position, rotation or scaling.

6.10.45 DataParameter

The DataParameter plug-in controls other plug-ins (geometry or function plug-ins) parameter 
values.

DataParameter Properties
Parameter Type: Defines the controlled plug-in type. The options 

are  GEOMETRY ,  FUNCTION  or  SCENE . If Function or Scene is selected, the Function Name 

parameter is enabled.
Function Name: Sets the name of the function (or scene) plug-in that the DataParameter 
plug-in controls.
Parameter Name: Defines the parameter that is controlled. The parameter name must be 
identical to the name used by Viz (case sensitive). To find the exact parameter name use the 
show command option and change the parameter from the user interface. The name of the 
parameter is printed by Viz in the commands console.

Example
Suppose a group has three children, each child is a cube. If we want to change the height 

parameter of each cube according to a certain value received from the field  VALUES[3] .  Field 

Name = VALUES[3] ,  Parameter Type = GEOMETRY  (cube is a geometry plug-in),  Function 

Name = Cube  and  Parameter Name=size_Y  (name of the parameter in the cube plug-in that 

changes the height of the cube) If the data is  VALUES[0-2]=1, 2, 3;  the cube's heights 

becomes 1, 2 and 3 respectively.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.
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6.10.46 DataParamTracker

The DataParamTracker plug-in tracks the controlled container and sends the defined parameter 
values to a defined DataPool variable (DataField).

DataParamTracker Properties
Destination Field: Assigns container parameter values to DataParamTracker according to 
the name of the DataField.
Parameter Type: Defines the type of the tracked plug-in.
Function Name: Defines what function plug-in is tracked. The function plug-in name must be 
identical to the name used by Viz (case sensitive). To find the exact parameter name use the 
show commands console.
Parameter Name: Defines the parameter that is tracked. The parameter name must be 
identical to the name used by Viz (case sensitive). To find the exact parameter name use 

the  SHOW COMMAND  option and change the parameter from the user interface. The name of 

the parameter is printed by Viz in the command console.

6.10.47 DataPosition

The DataPosition plug-in changes the position of the container according to the received data.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.



Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.
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DataPosition Properties
Format: Specifies the format of the incoming data. Format options specify the axis which the 
data relates to.
Incremental change: Defines if the received data is added to the current value of the data 

field. When set to  On  the received data is added to the data field. When set to  Off  the 

received data replaces the value of the data field.

Separate Parameters: Enables additional parameters when set to  On , allowing the user to 

define minimum and maximum values to all parameters separately:
X Min/Max: Defines a minimum/maximum value for the received X position of the 
object.
X Position Min/Max: Defines a minimum/maximum Viz value for the received X 
position of the object.

Example

If Field Name is  VALUE  and the format is X, the data sent is  VALUE=10.5; . The container moves 

on the X axis to a position of  10.5 .

6.10.48 DataReader

The DataReader plug-in allows for reading feeds of information from several different types of 
sources of information. The plug-in supports reading Excel files, databases using SQL, feeds using 
XML and JSON. The plug-in also supports different types of outputs.

The plug-in shows different arguments depending on the inputs and the outputs used:

Functionality
Input Type - Excel
Example

Preparation
Debug Information

Note: (Y and Z axis have the same parameters. The parameters are enabled 
according to the selected format)



Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.
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Data Source
DataPool Type

Setup
DataReader
DataArray
DataTable
DataStructure
DataFieldArray
Shared Memory

Input Type - SQL
Input Type - XML
Input Type - JSON

Functionality
All of the different sources of information behave the same way: They all search for records and 
translate the records fields to a certain format according to the requested output type. In the case 
of DataPool output types, the plug-in converts each incoming record to a DataPool command and 
executes it. In the case of Shared Memory, the plug-in creates a character separated string of fields 
and pushes to shared memory.

Input Type - Excel
In this mode the plug-in reads a sheet from an Excel file. The parameters in this mode are:

File Name: Determines the name of the file to be read.
Table/Sheet: Determines the name of the sheet to be read from within the file.
Key: Determines the name of the column in the Excel file from which the keys to the 
DataTable should be taken.
From row: Determines the row number in the Excel sheet from where to start reading the 
records.
Number of rows: Determines the maximum number of records to read, starting from the row 
stated in From row.
Fields to Read: Specifies by name the columns to read.
DP Field Name: Specifies the field name in DataPool where to write the output.
Field is a: Specifies the type of the target. In case of Shared Memory, the following 
parameters are changed:

DP Field Name: Hidden.
Shared Memory Variable: The variable for Shared Memory to be used.
Fields Delimiter: The delimiter to use for different fields.
Rows Delimiter: The delimiter to use for different rows.

Important! To read from Microsoft Excel files, Microsoft Access Database Engine is 
necessary. If the Microsoft Office installer did not install Microsoft Access Database Engine, 
it needs to be installed with the same software architecture (x64 or x86) as Microsoft 
Office.
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Post Update Action: Specifies commands (either DataPool or Viz commands) to be executed 
right after the data is read and sent to the target.
Show Data: Dumps the data the plug-in reads to a DataPool variable 

called  READER_CONSOLE  when set to  On . This is extremely useful for development and 

debugging purposes. This dump includes error messages too.
Return Variables Prefix: Specifies a prefix to add to the name of the DataPool variables that 

the plug-in uses. For example, if the prefix is  STV_ , then the plug-in dumps the debug 

information to  STV_READER_CONSOLE .

Load Automatically: Reads the information automatically every certain amount of time. This 
amount of time is defined in Automatic Load Period (in seconds).
Automatic Load Period (in seconds): Specifies the period of time between consecutive 
automatic reads.
Load: Invokes the action of reading the data.

Example

Preparation

Debug Information

For these examples, we want to see if any errors occur or if the data is correct. To prepare this 
debug mode, create a container with a Font and a DataText plug-in. Set the Field Name of the 
DataText plug-in to READER_CONSOLE.

Data Source

The following is a typical example of a table in an Excel sheet we would be interested in reading 
from using DataReader. Create a similar file (the headings have to match) and save it under C:
\temp\Indexes.xlsx.
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DataPool Type

A matching DataPool type is needed for this example. Create a file %PROGRAMDATA%
\Vizrt\VizEngine\DataPool\Stocks.dp with following content:

Stocks.dp

Stocks = {
    string Prices;
    string Volumes;
    string Name;
};

Setup

DataReader

Create a container with a DataReader plug-in on it. In this case, configure the DataReader plug-in 
as following:

Query type = EXCEL
File name = C:\temp\Indexes.xlsx
Table/Sheet = Stocks
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Key = Name
From Row = 5
Number of Rows = 4
Fields To Read = Prices,Volumes,Name
DP Field Name = Indexes
Show Data = On

DataArray

Set the DataReader parameter Field is a: to DataArray.

Create a new container with a DataArray plug-in and set following configuration:

Field Name = Indexes[4]
Type = Stocks

Now click the Load button in the DataReader plug-in to load the data into the DataArray. You 
should see the results on the DataText container:

READER_CONSOLE

Indexes[0]={
    {

Prices=""579,43"";
Volumes=""4"";
Name=""Intuitive Surgical Inc"";

    };
};

Indexes[1]={
    {

Prices=""82,85"";
Volumes=""254"";
Name=""Axon Enterprise Inc"";

    };
};

Indexes[2]={
    {

Prices=""38,45"";
Volumes=""4593"";
Name=""AT&T Inc"";

    };
};

Indexes[3]={
    {

Prices=""59,94"";
Volumes=""1369"";
Name=""Verizon Communications Inc"";
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    };
};

READER_NUM_RECORDS=9;

Click the Dump button on the scene plug-in DataPool and the console prints your DataPool data:

DataPool Dump

Indexes[0-3]={
    {

Name=Intuitive Surgical Inc;
Prices=579,43;
Volumes=4;

    },
    {

Name=Axon Enterprise Inc;
Prices=82,85;
Volumes=254;

    },
    {

Name=AT&T Inc;
Prices=38,45;
Volumes=4593;

    },
    {

Name=Verizon Communications Inc;
Prices=59,94;
Volumes=1369;

    }
};

DataTable

Set the DataReader parameter Field is a: to DataTable. Create a new container with a DataTable 
plug-in and set following configuration:

Field Name = Indexes
Type = Stocks

Now click the Load button in the DataReader plug-in to load the data into the DataArray. You 
should see the results on the DataText container:

READER_CONSOLE

Indexes[Intuitive Surgical Inc]={
    {

Prices=""579,43"";
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Volumes=""4"";
Name=""Intuitive Surgical Inc"";

    };
};

Indexes[Axon Enterprise Inc]={
    {

Prices=""82,85"";
Volumes=""254"";
Name=""Axon Enterprise Inc"";

    };
};

Indexes[AT&T Inc]={
    {

Prices=""38,45"";
Volumes=""4593"";
Name=""AT&T Inc"";

    };
};

Indexes[Verizon Communications Inc]={
    {

Prices=""59,94"";
Volumes=""1369"";
Name=""Verizon Communications Inc"";

    };
};

Click the Dump button on the scene plug-in DataPool and the console prints your DataPool data 
(note that the Key parameter in the DataReader plug-in is used to obtain the column from the 
indexes of the table):

DataPool Dump

Indexes[Axon Enterprise Inc,Intuitive Surgical Inc,AT&T Inc,Verizon Communications 
Inc]={

{
Name=Axon Enterprise Inc;
Prices=82,85;
Volumes=254;

},
{

Name=Intuitive Surgical Inc;
Prices=579,43;
Volumes=4;

},
{

Name=AT&T Inc;
Prices=38,45;
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Volumes=4593;
},
{

Name=Verizon Communications Inc;
Prices=59,94;
Volumes=1369;

}
};

DataStructure

Set the DataReader parameter Field is a: to DataStructure and remove the DP Field Name. Create a 
new container with a DataStructure plug-in and set following configuration:

Field Name = Axon Enterprise Inc

Create three containers under the DataStructure container level and add a font and DataText to 
every of them. Set the Field Names of the three DataTexts to Prices, Volumes and Name. Now click 
the Load button in the DataReader plug-in to load the data into the DataArray. You should see the 
results on the DataText container:

READER_CONSOLE

Intuitive Surgical Inc={
    Prices=""579,43"";
    Volumes=""4"";
    Name=""Intuitive Surgical Inc"";
};

Axon Enterprise Inc={
    Prices=""82,85"";
    Volumes=""254"";
    Name=""Axon Enterprise Inc"";
};

AT&T Inc={
    Prices=""38,45"";
    Volumes=""4593"";
    Name=""AT&T Inc"";
};

Verizon Communications Inc={
    Prices=""59,94"";
    Volumes=""1369"";
    Name=""Verizon Communications Inc"";
};

Click the Dump button on the scene plug-in DataPool and the console prints your DataPool data 
(note that the Key parameter in the DataReader plug-in is used to obtain the column from the 
indexes of the table):
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DataPool Dump

Axon Enterprise Inc ={
    Name=Axon Enterprise Inc;
    Prices=82,85;
    Volumes=254;
}

DataFieldArray

Set the DataReader parameter Field is a: to Data Field Array. Create a new container with a 
DataText plug-in and set following configuration:

Field Name = Indexes[2-3]
This fetches a sub array from the Indexes Data Field Array starting with index 2 (3rd 
element).

Create a containers under the DataText container level and add a font to it.

Now click the Load button in the DataReader plug-in to load the data into the Data Field Array and 
display the third value in the DataText's sub container. You should see the results on the DataText 
container:

READER_CONSOLE

DFA[0-8]=""Axon Enterprise Inc"",""AT&T Inc"",""Verizon Communications Inc"",""Ford 
Motor Co"";READER_NUM_RECORDS=9;

Click the Dump button on the scene plug-in DataPool and the console prints your DataPool data 
(note that the Key parameter in the DataReader plug-in is used to specify the column from the 
values):

DataPool Dump

DFA[0-2]=Axon Enterprise Inc,AT&T Inc,Verizon Communications Inc

Shared Memory

Set the DataReader parameters:

Field is a: = Shared Memory
Shared Memory Variable = Indexes

Info: We could use multiple sub containers to show multiple values of the created sub array 
(Indexes[2-3]). This array has two values, so we could create two font containers below the 
DataText container to display them.
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Create a new container with a DataText plug-in, a SHMTracker plug-in and a font and set following 
configuration:

DataText plug-in:
Field Name = Output

SHMTracker plug-in:
Output Field Name = Output
Shared Memory Key Name = Indexes

Now click the Load button in the DataReader plug-in to load the data into the Shared Memory. You 
should see the results on the debug DataText container and the Output DataText container:

READER_CONSOLE

579,43|4|Intuitive Surgical Inc|82,85|254|Axon Enterprise Inc|38,45|4593|AT&T Inc|59,9
4|1369|Verizon Communications Inc|

Input Type - SQL
In this mode, the plug-in reads a sheet from a database that supports SQL. The parameters in this 
mode are:

Connection String: Connects to the database using the connection string. Each type of 
database has a different connection string. A good reference on connection strings for 
several different databases can be found in http://www.connectionstrings.com/.
SQL Query: Queries the database using SQL command.
Key: Determines the name of the column in the read query or table from which the keys to 
the DataTable should be taken.
From row: Determines the row number in the query/table from where to start reading the 
records.
Number of rows: Determines the maximum number of records to read, starting from the row 
stated in From row.
Fields to Read: Specifies by name the columns to read.
DP Field Name: Specifies the field name in DataPool where to write the output.
Field is a: Specifies the type of the target. In case of Shared Memory following parameters 
are changed:

DP Field Name: Hidden.
Shared Memory Variable: The variable for Shared Memory to be used.
Fields Delimiter: The delimiter to use for different fields.
Rows Delimiter: The delimiter to use for different rows.

Post Update Action: Specifies commands (either DataPool or Viz commands) to be executed 
right after the data is read and sent to the target.
Show Data: Dumps the data the plug-in reads to a DataPool variable 

called  READER_CONSOLE  when set to  On . This is extremely useful for development and 

debugging purposes. This dump includes error messages too.

http://www.connectionstrings.com/
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Return Variables Prefix: Specifies a prefix to add to the name of the DataPool variables that 

the plug-in uses. For example, if the prefix is  STV_ , then the plug-in dumps the debug 

information to  STV_READER_CONSOLE .

Load Automatically: Reads the information automatically every certain amount of time. This 
amount of time is defined in Automatic Load Period (in seconds).
Automatic Load Period (in seconds): Specifies the period of time between consecutive 
automatic reads.
Load: Invokes the action of reading the data. The different types of outputs are exactly as in 
the case of Excel.

Input Type - XML
This mode allows for reading XML feeds. These can be read from a remote server or from a local 
file.

These can be read from a remote server or from a local file.

The parameters in this mode are:

File Name: Shows the full name of a file or a URI to a remote file to be read.
Use Authentication: Allows entering a user name and password In the case the File Name is a 
URI and the remote server requires Basic Authentication.
Avoid Cache: Avoids using cache mechanisms that avoid the refresh of data changing in the 
server side in the case of a remote file. This is useful when reading information that 
changes. The caching mechanism avoids the plug-in to get the updates. When “Avoid Cache” 
is on the plug-in gets the freshest information.
XPath: States what records to search for. For an explanation of the XPath syntax please refer 
to http://www.w3.org/TR/xpath/. For examples of how to use XPath please refer to https://
msdn.microsoft.com/en-us/library/ms256086.
Namespaces: Specifies namespaces for use in XPath expressions when it is necessary to 
define new namespaces externally. Namespaces are defined in the XML style, as a space-
separated list of namespace declaration attributes. You can use this property to set the 
default namespace as well. An example of the definition of namespaces could 

be:  xmlns:na=' http://myserver.com' xmlns:nb=' http://yourserver.com '
Key: Determines the name of the field in the read records from which the keys to the 
DataTable should be taken.
From row: Determines he row number in the read record from where to start reading the 
records.
Number of rows: Determines the maximum number of records to read, starting from the row 
stated in From row.
Fields to Read: Specifies by name the fields to read from the records.
DP Field Name: Specifies the field name in DataPool where to write the output.
Field is a: Specifies the type of the target. In case of Shared Memory following parameters 
are changed:

DP Field Name: Hidden.
Shared Memory Variable: The variable for Shared Memory to be used.
Fields Delimiter: The delimiter to use for different fields.

http://www.w3.org/TR/xpath/
https://msdn.microsoft.com/en-us/library/ms256086
http://myserver.com
http://yourserver.com
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Rows Delimiter: The delimiter to use for different rows.
Post Update Action: Specifies commands (either DataPool or Viz commands) to be executed 
right after the data is read and sent to the target.
Input Format: Specifies the format of the XML file.
Output Format: Specifies the format for the DataPool output.
Show Data: Dumps the data the plug-in reads to a DataPool variable called 

READER_CONSOLE when set to  ON . This is extremely useful for development and debugging 

purposes. This includes error messages too.
Return Variables Prefix: Specifies a prefix to add to the name of the DataPool variables that 

the plug-in uses. For example, if the prefix is  STV_ , then the plug-in dumps the debug 

information to  STV_READER_CONSOLE .

Load Automatically: Reads the information automatically every certain amount of time. This 
amount of time is defined in Automatic Load Period (in seconds).
Automatic Load Period (in seconds): Specifies the period of time between consecutive 
automatic reads.
Load: Invokes the action of reading the data.
Use Custom Headers: Adds custom HTTP headers to the request. For example, this can be 
used to specify an API token for web services.

Input Type - JSON
This mode allows for reading JSON feeds. These can be read from a remote server or from a local 
file.

The parameters in this mode are:

File Name: Shows the full name of a file or a URI to a remote file to be read.
XPath: States what records to search for. This is a subset of the standard XPath.
Key: Determines the name of the field in the read records from which the keys to the 
DataTable should be taken.
From row: Determines the row number in the read record from where to start reading the 
records.
Number of rows: Determines the maximum number of records to read, starting from the row 
stated in From row.
Fields to Read: Specifies by name the fields to read from the records.
DP Field Name: Specifies the field name in DataPool where to write the output.
Field is a: Specifies the type of the target. In case of Shared Memory following parameters 
are changed:

DP Field Name: Hidden.
Shared Memory Variable: The variable for Shared Memory to be used.
Fields Delimiter: The delimiter to use for different fields.
Rows Delimiter: The delimiter to use for different rows.

Post Update Action: Specifies commands (either DataPool or Viz commands) to be executed 
right after the data is read and sent to the target.
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Show Data: Dumps the data the plug-in reads to a DataPool variable 

called  READER_CONSOLE  when set to  On . This is extremely useful for development and 

debugging purposes. This dump includes error messages too.
Return Variables Prefix: Specifies a prefix to add to the name of the DataPool variables that 

the plug-in uses. For example, if the prefix is  STV_ , then the plug-in dumps the debug 

information to  STV_READER_CONSOLE .

Load Automatically: Reads the information automatically every certain amount of time. This 
amount of time is defined in Automatic Load Period (in seconds).
Automatic Load Period (in seconds): Specifies the period of time between consecutive 
automatic reads.
Load: Invokes the action of reading the data.
Proxy on/off

Proxy Mode:
Auto Detect: Detects if there is a proxy set in the system or Engine.
System Settings: Sets the proxy for HTTP requests to the system proxy.
Manual Configuration: Configures a proxy manually with a Proxy URL, Proxy 
User Name and Proxy Password.

Use Custom Headers: Adds custom HTTP headers to the request. This can for example be 
used to specify an API token for web services.

6.10.49 DataRotation

The DataRotation plug-in rotates the container according to the received data.

DataRotation Properties
Format: Specifies the format of the incoming data. Format options specify the axis which the 
data relates to.
Incremental change: Defines if the received data is added to the current value of the data 

field. When set to  On  the received data is added to the data field. When set to  Off , the 

received data replaces the value of the data field.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.
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Example

If Field Name is  VALUE  and the format is XY, the data sent is  VALUE=10.5 5.0; . The container 

rotates around the X axis to an angle of  10.5  and around the Y axis to an angle of  5.0 .

6.10.50 DataScale

The DataScale plug-in scales the container according to the received data.

DataScale Properties
Format: Specifies the format of the incoming data. Format options specify the axis which the 
data relates to.
Incremental change: Defines if the received data is added to the current value of the data 

field. When set to  On  the received data is added to the data field. When set to  Off  the 

received data replaces the value of the data field.

Example

The current scaling values of the container are  2.0 3.0 4.0 . If the parameters are:  Field 

Name: VALUE ,  Format: Y ,  Data Min: -100 ,  Data Max: 100 ,  Scale Min: 0  and  Scale 

Max: 1  and the data entered is  VALUE=0; . The resulting scaling values of the container are  2.0 

0.5 4.0

6.10.51 DataScreen

The DataScreen plug-in is used to control screen coordinates transformations of objects.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.



Note: This plug-in is located in: Plugins -> Container plug-ins -> Data



Plug-ins User Guide -  5.0

Copyright © 2022  Vizrt Page  579

•

•

•

•

•

•

DataScreen Properties
Position Format: Defines if the object’s position is affected by incoming data and the format 
the data. Data is used as screen coordinate values, where the top left corner of the render 
window is the 0 0 position and the bottom right corner of the render window is 720 576 
position.
Size Format: Defines if the object’s scaling is affected by incoming data and the format of 
the data.

6.10.52 DataSelector

The DataSelector plug-in receives the number of a child container as data. The plug-in toggles 
visibility for all the child containers of the controlled container and activates only the n-th child 
container, as received in the data.

DataSelector Properties

First Container Is: Select  0  or  1  as the first container index. Incoming data is applied 

accordingly.
Value ReScaling: Disables First Container is parameter and enables additional parameters 

when set to  On , allowing rescaling of incoming data to the defined values. All incoming 

data exceeding the Data Min or Data Max is cropped.
Switch all on until value: Switches on visibility for all child containers until the first value is 

accepted in the DataField when set to  On . After the first value is set, the DataSelector only 

switches one child container at a time. When set to  Off , child containers keep their current 

status until the first value is accepted in the DataField.
Enable Dissolve: Uses a fade transition between the current container and the next 
container.

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.



Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.
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Example

Field Name=VALUE . If the data entered is  VALUE=3  then all the children containers are invisible 

out of the fourth (0-3) child.

6.10.53 DataSHM

The DataSHM (Shared Memory) plug-in uses a defined data field or a DataPool expression to 
update a string type shared memory entry.

DataSHM Properties
Shares Memory Type: Selects the shared memory in Viz 3 that the memory key is defined in. 
For additional information about Shared Memory, refer to Viz Artist User Guide.
Shares Memory Key Name: Defines the shared memory key name that receives the data field 
value or DataPool expression.
Transferred Argument: Selects the argument type that is sent to the shared memory key. 
Select Variable Value to set the data field value to the memory key. Select DP Expression to 
send a DataPool expression to the shared memory key. When DP Expression is selected, an 
additional parameter is enabled: Expression String. Define the DataPool expression that 
results in a string. The resulting string is sent to the shared memory key.

6.10.54 DataSHMTracker

The DataSHMTracker plug-in monitors a string type shared memory entry. When the shared 
memory entry is changed, the plug-in uses the updated value to update the related DataPool 
variable.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.



Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

http://documentation.vizrt.com/viz-artist
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DataSHMTracker Properties
Shares Memory Type: Selects the shared memory in Viz 3 that the memory key is defined in. 
For additional information about Viz 3 shared memory, refer to Viz 3 user guide.
Shares Memory Key Name: Defines the tracked shared memory key name. Whenever the 
shared memory key changes, its value is copied to the defined data field.

6.10.55 DataStructure

The DataStructure plug-in uses structures that were defined in the DataPool scene plug-in. The 
structure format is the same as in the config.dp file but the structure is defined in the scene 
making it available only to variables in the scene (Unlike structures defined in the config.dp file 
which are available for all scenes to use). The Field name relates to a variable defined as the type 
of a structure.

6.10.56 DataSwitch

The DataSwitch plug-in toggles the visibility of the container according to the incoming data. Any 

value other than zero sets the container’s visibility to  On , zero sets the visibility to  Off .

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.



Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.



Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.
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Field Name=VALUES[3] . If the data entered is  VALUES[0-2]=0, 1, 0; , then the first and third 

children of the container the plug-in is attached to is deactivated and the second child is activated. 

If the data entered is  VALUES=0 , the container itself is deactivated. If the data is  VALUES=1 , the 

container itself is activated.

6.10.57 DataSystem

The DataSystem plug-in enables running external applications/commands. Incoming data contains 
the command to run.

DataSystem Properties
No Wait: Defines whether Viz waits for the launched application to finish its run.

Example

Field Name is CMD. Incoming data is CMD= calc ;. The result is that the windows 

calculator opens.

6.10.58 DataTable

The DataTable plug-in defines a table of typed objects.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.



Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.
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DataTable Properties
Table Name: Defines the name of the table.
Type: Defines the type of the objects in the table. The list of the types is taken from the 
configuration file.

6.10.59 DataText

The DataText plug-in controls text objects. The plug-in receives incoming data, adds a defined 
prefix and a defined suffix to the data, and changes the text value (string) to the result.

DataText Properties

Trim Option: Enables/disables trimming. When set to  Off , incoming data is not trimmed. 

When set to  On , additional trim options for incoming data are added:

Remove Prefix Until: Removes all characters from the beginning of the string to the 

defined delimiting substring (including) when set to  On . An additional parameter is 

enabled: Sub String, to define a limiting substring.
Remove Sufix From: Removes all characters from the defined substring (inclusive) to 

the end of the string when set to  On . An additional parameter is enabled: Sub String, 

to define the substring.

Choose an entry: Enables additional parameters when set to  On .

Delimiter: Defines a delimiting character.
Number: Defines the entry number of the beginning with the delimiter character. The 
incoming string is split into substrings, using delimiter Y as the split point (end of sub 
string), and substring X is used as the data (delimiting characters are not included in 
the substrings).

Choose Characters: Enables the Range parameter when set to  On . The data used by 

the plug-in is a simple range of bytes X-Y defined in Range (zero is not a valid value as 
a character number).

Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.
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Replace backslash n by EOL: Enables/disables replacement of control characters. When set 

to  Off , incoming data is not changed. when set to  On , all  \n  (backslash n) control 

characters are replaced with the End Of Line control character.
Convert Case: Selects the required option for data case conversion:

None: Does not change any data strings.
Lower: Converts all data strings to lower case only.
Upper: Converts all data strings to upper case only.
Word: Converts the first letter of every word to upper case.
Sentence: Converts the first letter of every sentence to upper case.

Example

Field Name= PRICE

Prefix=  $

Suffix=  is the price .

If the data is PRICE=123 then the result is:  $123 is the price.

6.10.60 DataTextKerning

The DataTextKerning plug-in sets the kerning of a text object.

Note: When using more than one trim option the AND operator is used. If all 
options are used the following result is used: Remove prefix AND remove 
suffix AND split data AND select substring number X AND select bytes number 
X-Y.



Note: When sending special characters, or characters used as DataPool separator 
characters, to DataText plug-in, use double-double quotes at the beginning and ending of 
the string: ""What’s the frequency, Kenneth?"" If the quotes are omitted, the string is not 
displayed correctly.



Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.
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Example

Field Name=VALUE. If the entered data is VALUE= 12 ; then the kerning of the text object is 

assigned the value  12 .

6.10.61 DataTexture

The DataTexture plug-in controls various texture attributes such as mapping, scaling, etc.

Incoming data contains the parameter name of the texture and the value.

DataTexture Properties

TEXT: Creates a texture on the controlled container. Value is  IMAGE*<image name>  where 

image name is a full path to an image in Viz images library.
MAPT: Defines the mapping type of the texture. Values 

are  1  (LINEAR),  2  (VERTEX),  3  (REFLECT).

ENVT: Defines the environment type of the texture. Values are  3042  (blend),  8449  (decal) 

or  8448  (modulate).

QUAL: Defines the texture quality type. Values 

are  1  (PIXEL),  2  (LINEAR),  3  (MIPMAP),  4  (SHARPEN).

COLO: Defines the color quality of the texture. Values are  1  (32 bits),  2  (16 bits).

EFFT: Defines an effect type used on the image. Values are  0  (Smooth),  1  (Mosaic).

WRAP: Defines the wrapping type of the texture. Values 

are  10497  (REPEAT),  10496  (CLAMP).

POSX: Position of the texture on the X axis of the container. Value should be a float number.
POSY: Position of the texture on the Y axis of the container. Value should be a float number.
ROTZ: Rotation of the texture around the Z axis. Value should be float number.
SCAX: Scales texture on the X axis. Value should be float number.
SCAY: Scales texture on the Y axis. Value should be float number.
BLEN: Provides blend value of the texture. Value should be a float number.

EFFV: Defines the amount of the effect defined in the  EFFT  (effect type) that is applied to 

the texture. Value should be a float number.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.
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IMGS: Changes the image of a given container. Value is  <Xvalue> <Yvalue> .

SETI: Replaces the image on the container. Data format is  IMAGE*<image Name>  where 

image name is the full path to an image in the Viz images library.
DRAW: Sets the scale and bias values of the texture. Values are <texcoord scale> <float bias 
s> <float bias t>. all values are float numbers.

6.10.62 DataTime

The DataTime plug-in translates the value of the incoming data into date/time elements and stores 
these values to a set of predefined DataPool variables.

Predefined Variables
The predefined variables are:

_DAY: Day of the month ( 1-31 ).

_DAYNAME: Name of the day in the week. Names are defined in the Day Names parameter.

_FHOUR: Hours/min/sec described in floating point number (decimal) i.e.  6:30  is converted 

to  6.5 .

_HOUR: Hour of the day ( 0-23 ).

_HOURNAME: Set of name description for the hours of the day. Names are defined in the 
Hour Names parameter.
_MIN: Minute of the hour.

_MONTH: Month number in the year ( 1-12 ).

_MONTHNAME: Name of the month. Names are defined in the Month Names parameter.

_MSEC: One thousandth of a second in the second ( 0-999 ). This variable is used only when 

the Resolution parameter is set to milliseconds.

_SEC: Second number in a minute ( 0-59 ).

_WEEKDAY: Number of the day in the week ( 1-7 ).

_YEAR: Number of the year using four digits.

_RELDAY: Relative day number, where  0  (zero) is today. This variable returns an integer 

value only (the difference between the received data and the current system time).

Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.
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_RELDAYNAME: Relative day name, where yesterday, today and tomorrow are used 

for  -1 ,  0 ,  1  values received in the  RELDAY  variable. All other days are displayed by name 

(Sunday, etc.).
_HOURS_SHORT: Show 12 hour clock time.

_AMPM: Display AM or PM (used with  HOURS_SHORT ).

DataTime Properties
DP variables Prefix: Defines a prefix that is added to the DataTime variables. The prefix is 
used to distinguish one set of time parameters from the other, enabling the usage of 

multiple time values. Default is  T1 . If the prefix is set to  T1 , the corresponding variables 

are:
T1_DAY
T1_DAYNAME
T1_FHOUR
T1_HOUR
T1_HOURNAME
T1_MIN
T1_MONTH
T1_MONTHNAME
T1_MSEC
T1_SEC
T1_WEEKDAY
T1_YEAR

DP variables Scope: Uses data variables as part of the structure the variables were defined in 

when set to  Local . When set to  Global , the time data variables are used as global 

DataPool variables.
Input is Machine Time: Defines if the time is read from the machine’s clock or from the data 

field. If set to  On , the Field Name parameter is disabled and additional parameters are 

enabled:
Input Field Format: Selects the input field units.
Output Field Time Zone: 

As Is: Leaves timezone data as set.
UTC -> Local: Converts UTC timezone to local timezone.
Local -> UTC: Converts local timezone to UTC.

Offset Field: Defines the offset units.
Offset: Defines the number of offset units from the current machine time.

Leading Zero: Defines if the zero character is added to the single digit values ( 0-9 ). This 

option is useful when formatting the time display.
Day Names: Defines a set of names for the days of the week, to be used by 

the  _DAYNAME  variable. The parameter should contain seven names, comma separated. If 

the parameter is left blank, DataTime uses the default of Sunday, Monday, Tuesday, 
Wednesday, Thursday, Friday, Saturday.
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Month Names: Defines a set of names for the months of the year, to be used by 

the  _MONTHNAME  variable. The parameter should contain twelve names, comma separated. 

If the parameter is left blank, DataTime uses the default of January, February, etc.
Hour Names: Defines a set of names for the hours of the day, to be used by 

the  _HOURNAME  variable. The parameter should contain twenty four names, comma 

separated. If the parameter is left blank, DataTime uses the default of Midnight, 1, 2, 3, 4, 
5, 6, 7, 8, 9, 10, 11, Noon, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22, 23.
Replace Yesterday By: Allows the replacement of the term yesterday for another one. This 
feature is useful when working on a language other than English.
Replace Today By: Allows the replacement of the term today for another one. This feature is 
useful when working on a language other than English.
Replace Tomorrow By: Allows the replacement of the term tomorrow for another one. This 
feature is useful when working on a language other than English.
Initialize: Calculates variable values now.
Reset: Recalculates variable values now.
Week Director: Specify a Director that is controlled by the DataTime value. The Director's 
animations start on a new week and ends with that week.

6.10.63 DataTimer

The DataTimer plug-in runs an action (Viz action or DataPool action) at a fixed time interval.

DataTimer Properties
Action: Defines the action that is executed at the interval time.

Enabled: Executes the action at the defined time intervals when set to  On . When set 

to  Off  the plug-in is disabled and the action is not executed.

Interval: Defines the time length, in milliseconds, between executions of the action.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.
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6.10.64 DataViz3Script

The DataViz3Script plug-in invokes a predefined Viz 3 scripting subroutine or function, with the 
updated value of its defined data field (DataPool variable) or with a DataPool expression as an 
argument. In the case of a function, the returned value of the function can be assigned to a 
DataPool variable.

DataViz3Script Properties
Script Type: Defines the location of the script, containing the requested function/procedure. 
Select Container to use a function in a container script or Scene to use a function in the 
scene setting script module.
Function Name: Sets the name of the function/procedure to be called when the data field 
changes.
Transferred Argument: Selects the argument that is sent to the function/procedure. 
Select Variable Value to set the data field value to the memory key and to use the data field 
value as the function argument. Select DP Expression to send a DataPool expression to the 
function/procedure. When DP Expression is selected, an additional parameter is enabled: 
Expression String. Define the DataPool expression that results in a string. The resulting 
string is sent as an argument (or arguments) to the function/procedure.
Use Return Value: Defines if the returned value from the defined function is re-used by the 

plug-in. When set to  Off , no return value is used. When set to  On , additional parameters 

are enabled:
Output Field: Sets the data field name that the returned value is assigned to.
Output Scope: Defines the output field scope: Local or global. The value returned from 
the function is assigned to the defined output field.

6.10.65 DataWPosition

The DataWPosition plug-in affects the WPosition plug-in (a Viz Weather plug-in) attached to the 
controlled plug-in. The DataPool variable defined in the Field Name should contain the values of 
the Longitude, Latitude and Altitude to be sent to the WPosition plug-in.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.
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6.11 Scene Plug-Ins
The scene plug-ins are listed in alphabetical order:

DataClock
DataInteractive
DataMaterialTable
DataMouseSensor
DataPool Plugin

6.11.1 DataClock

DataClock plug-in is a scene plug-in that sends the current system time to predefined DataPool 
DataFields.

DataClock Properties
Leading Zero on All: Adds a leading zero to all the single digit numbers (0-9) of hours, 
minutes and seconds.
Leading Zero on MINS, SECS: Adds a leading zero to the single digit numbers (0-9) of 
minutes and seconds only.

Fields
The fields DataClock generates are:

DAY: Current day ( 1-31 ).

MONTH: Current month ( 1-12 ).

YEAR: Current year (four digits).

Note: This plug-in is located in: Plugins -> Container plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.



Note: This plug-in is located in: Plugins -> Scene plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.
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WEEKDAY: The day of the week ( 1-7 ). The week starts with Sunday (1) and ends with 

Saturday (7).
DAY_NAME: The textual name of the day.
MONTH_NAME: The textual name of the month.

HOURS: Hour of the day ( 0-23 ).

MINS: Minute of the hour ( 0-59 ).

SECS: Second of the minute.
AMPM: AM or PM.
COUNTER: A running counter of seconds. Its value is equal to 60*60*HOURS + 60*MINS + 
SECS.

6.11.2 DataInteractive

DataInteractive plug-in receives mouse and keyboard events and triggers actions accordingly. The 
actions are DataPool commands. This plug-in is a scene plug-in and it gets the mouse events from 
Viz (DataMouseSensor is not required).

Notes
The interactive events are sent only when Viz is in On Air mode.
When using DataInteractive in a scene and no other data is sent externally, adding 
the DataPool plug-in scene plug-in is unnecessary.
When using DataInteractive plug-in, DataManipulate and DataClick cannot be used.

DataInteractive Properties
Click Type Left: Executes the action defined in the Click Action Left Mouse parameter every 

time the left mouse button is clicked when set to  Always . When set to  Clear Area Only , 

the action is triggered if the mouse is clicked on the background (not on any container area). 

When set to  Never , the action is disabled.

Click Action Left Mouse: Defines a DataPool action that is performed when the mouse is 
clicked.
Click Type Middle: Executes the action defined in the Click Action Middle Mouse parameter 

every time the left mouse button is clicked when set to  Always . When set to  Clear Area 

Note: This plug-in is located in: Plugins -> Scene plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.
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Only , the action is triggered if the mouse is clicked on the background (not on any 

container area). When set to  Never , the action is disabled.

Click Action Middle Mouse: Defines a DataPool action that is performed when the mouse is 
clicked.
Click Type Right: Executes the action defined in the Click Action Right Mouse parameter 

every time the left mouse button is clicked when set to  Always . When set to  Clear Area 

Only , the action is triggered if the mouse is clicked on the background (not on any 

container area). When set to  Never , the action is disabled.

Click Action Right Mouse: Defines a DataPool action that is performed when the mouse is 
clicked.

Mouse Action 0 (to 9) Active: Enables additional parameters when set to  On . The action is 

disabled when set to  Off .

Alt For Action 0 (to 9): Defines if the ALT button must be pressed in conjunction with 
the defined key in the parameter Key For Action 0 (to 9).
Ctrl For Action 0 (to 9): Defines if the CTRL button must be pressed in conjunction 
with the defined key in the parameter Key For Action 0 (to 9).
Shift For Action 0 (to 9): Defines if the SHIFT button must be pressed in conjunction 
with the defined key in the parameter Key For Action 0 (to 9).

6.11.3 DataMaterialTable

The DataMaterialTable plug-in enables the user to create a table of materials and store this table to 
a file, enabling the same table to be used in different scenes. When a table is defined at the scene 
level (by loading a table from a file or defining material entries) it is accessible by the 
DataMaterialIndex plug-in.

DataMaterialTable Properties
Save Table to File: Saves table data to the defined file (in the Table File Name parameter) 
when pressed.

Note: This plug-in is located in: Plugins -> Scene plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.



Note: The material table has a maximum of 256 entries. Index range is 0-255 . When 

saving/reading the material table file all the entries are saved/read.
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Load Table from File: Loads table data to the defined file (in the Table File Name parameter) 
when pressed.
Table File Name: Defines the name of a file for storing/reading the material table. Suffix for 
DataMaterialTable files is .dmt.

Auto Load Table File: Loads the color table file during scene load when set to  On . When set 

to  Off , the scene loads without reloading the color table file.

Per Scene Table: Loads and stores the color table used in the scene in a separate area from 

the common color table when set to  On . When set  Off , the scene uses a common color 

table defined in the table file. 

Index: Defines the entry in the material table (index) to be edited. Index is zero based (the 

first entry is  0 , the second is  1 , and so on).

Enlighted: Defines whether the material in the entry index is lit.
Ambient: Defines the ambient component of the material in the entry index of the table.
Diffuse: Defines the diffuse component of the material defined in the current index of the 
table.
Specular: Defines the specular component of the material defined in the current index of the 
table.
Emission: Defines the emission component of the material defined in the current index of 
the table.
Shininess: Defines the shininess component of the material defined in the current index of 
the table.
Copy from container: Allows copying a material from a given container to the material table. 
The material parameters are set when the container is dragged to the container place holder, 
in the plug-in editor. The material table is not changed if the material of the container is 
changed.

6.11.4 DataMouseSensor

The DataMouseSensor plug-in receives mouse events and keyboard events from Viz and stores the 
events in special DataPool Variables, making this information accessible to other DataPool plug-
ins.

Note: When using the common color table, every time the color table is loaded it 
overwrites the existing table. When using the Per Scene Table option, a color table is 
created for each scene.



Note: This plug-in is located in: Plugins -> Scene plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.
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The variables that it creates are:

MPOS: Returns the mouse position when a button is clicked. If a button is pressed while 
moving the cursor MPOS updates dynamically. When the button is released the mouse 
position value is stored in MPOS. The position is displayed in X Y values.

MBUT: Returns the number of the last clicked mouse button ( 1 =left), whether the button is 

currently pressed or released, and the X Y values like in MPOS.
MSELCONT: Returns the ID of the selected container.
KEY: Returns the ASCII code of the last pressed key on the keyboard and whether it is 

currently pressed (pressed= 1 , released= 0 ).

MONOFF: Indicates whether a mouse button is currently clicked or released.

MBUTTON: Returns the number of the last clicked mouse button.  1 =left button,  2 =center 

button,  3 =right button.

The DataMouseSensor is a scene plug-in and it should be used in scenes that use mouse/keyboard 
DataPool plug-ins.

The DataMouseSensor plug-in has no parameters.

6.11.5 DataPool Plugin

The DataPool plug-in is a scene plug-in that manages the DataPool mechanism and data transfer in 
the scene level (i.e. manages the DataFields/values/registered plug-ins table).

DataPool Properties
Data: Allows the user or external software to define new DataFields and assign data to 
DataFields. The field content is saved with the scene when the scene is saved in Viz. Data is 
a text parameter. All commands/assignments should be semicolon separated. For example:

A=5; B=3; aa[0..2]=1,3,5;  Stocks[1]={Name=TEST, Value=4.5}; 

Note: Not all keyboard buttons are displayed when using the KEY variable.

Note: This plug-in is located in: Plugins -> Scene plug-ins -> Data

Information: DataPool plug-ins only work properly on a single channel on the same 
machine.
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Data1: Sends information from external applications to the DataPool mechanism. 
The Data1 field has a larger size and can accept larger information blocks than the Data 
parameter. This parameter is hidden. The data that is sent is not saved with the scene.
DataRequest: Requests data from the DataPool (DataRequest is a text parameter). The user 
or external software can query DataFields by name using this parameter. The format of the 
query is as follows:

fieldname[indexes-range]; fieldname[indexes-range]….

The result of the query appears in the DataOutput parameter.
DataOutput: Contains the data returned as a result of a query entered 
in DataRequest (DataOutput is a string parameter ). The user or external software can use 
the returned information for manipulating the graphics. For example: External usage 
of DataRequest and DataOutput.

Enter data to the vectors VALUE and AAA: 
0 RENDERER*FUNCTION*DataPool*Data SET VALUE[0-3]=V0, V1,  V2,V3; 
AAA[0-5]=A0, A1, A2, A3, A4, A5; 

Request the last two items of VALUE and the third value of AAA: 
0 RENDERER*FUNCTION*DataPool*DataRequest SET VALUE[2-3];  AAA[3];

Read the requested information: 
0 RENDERER*FUNCTION*DataPool*DataOutput GET  

Viz replies: 
0 VALUE[2-3]=A2, A3; AAA[3]=A3;

DataCopy: Copies data from one DataPool variable or structure to another. For example:
a=b; is assigned the value of b to a.
Or, if Stock1 and Stock2 is of Stocks type then:
Stock2=Stock1; assigns all the values from Stock1 to the values of Stock2.

DataLink: Links one DataPool variable or structure to another. For example:
a=b; links the value of a to b.
or, if Stock1 and Stock2 is of Stocks type then:
Stock2->Stock1; links Stock2 to Stock1.

Dump: Triggers a printout of all DataPool variables, structures and their values to the Viz 
console and to the file datapool_dump.txt located in %ProgramData%\Vizrt\VizEngine\.
Dump Spec: Triggers a printout of all DataPool variables and structures to the Viz console.

Note: The copy action does not take place unless the Copy Automatically 

parameter is set On , or the Execute Copy button is pressed.


Note: The link action does not take place unless the Link Automatically 

parameter is set On , or the Execute Link button is pressed.
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a.

b.

c.

Initialize: Triggers a rebuild of the DataPool hierarchy in the scene and the assignment of 
values to the DataPool variables.
Execute Copy: Triggers an immediate copy of the variables or structures defined in 
the DataCopy field.
Execute Link: Triggers an immediate link of the variables or structures defined in 
the DataLink field.
Reload Configuration Files: Allows reloading all the *.dp files.
Reload Conversion Tables: Allows reloading all the conversion tables.
Copy Automatically: Defines if the copy of the values, defined in the DataCopy field, 

is triggered automatically when the DataCopy parameter is changed. When set  OFF  the 

copy operation does not happen until the Execute Copy button is pressed. When set to  On , 

every time the DataCopy parameter changes or any of the copied DataPool variables defined 
in the DataCopy field is modified, DataPool copies the values as defined in 
the DataCopy parameter.
Link Automatically: Defines if the link of the values, defined in the DataLink field, 

is triggered automatically when the DataLink parameter is changed. When set to  Off  the 

copy operation does not happen until the Execute Link button is pressed. When set to  On , 

every time the DataLink parameter changes or the linked DataPool variables are modified, 
DataPool executes the link as defined in the DataLink parameter.
Update DataPool On Load: Loads and initializes the data stored in the Data parameter when 

set to  On .

Enable UDP: Enables external applications to control the DataPool via UDP when set to  On . 

When set to  On  additional parameters are enabled.

Show UDP Messages: Defines whether to display incoming UDP messages in the Viz console.
UDP Host Name: Defines the name of the machine that the UDP messages should arrive 
from.
UDP Port: Defines the port number that DataPool listens for UDP messages.
Enable Multicast: Enables external applications to control the DataPool via MULTICAST when 

set to  On . When set to  On  additional parameters are enabled.

Show Multicast Messages: Defines whether to display incoming MULTICAST messages in the 
Viz console.
Multicast Port: Defines the port number that DataPool listens for MULTICAST messages.
Multicast Address: Defines the address of the machine sending the MULTICAST messages.

Track DP_COMMAND in Scene SHM: Tracks a reserved shared memory key  DP_COMMAND  in 

the scene shared memory when set to  On . When the key is changed its content is parsed 

and interpreted as one of the following commands:

If  DP_COPY  prefix is used, the remaining string is used as a DataPool copy command, 

copying one or multiple DataPool fields.

If  DP_LINK  prefix is used, the remaining string is used as a DataPool link command, 

linking one or multiple DataPool fields.

If  DP_SET  prefix is used, the remaining string is used to set the value of DataPool 

fields.
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When none of the above options are detected, the content of  DP_COMMAND  is used to 

set the value of DataPool fields.

Track DP_COMMAND in Global SHM: Tracks a reserved shared memory key  DP_COMMAND  in 

the scene shared memory when set to  On . The same as the above section, regarding Viz 3 

Global shared memory.
Track DP_COMMAND in Distributed SHM: Tracks a reserved shared memory 

key  DP_COMMAND  in the scene shared memory when set to  On . The same as the above 

section, regarding Viz 3 Distributed shared memory.
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7 Viz World Plug-Ins

The World Plug-ins provide details about settings available through its configuration user 
interface within Viz Artist. 

7.1 Related Documents
Viz Artist User Guide: Contains information on how to install Viz Engine and create graphics 
scenes in Viz Artist.
Viz World Classic User Guide: Contains information on creating 2D maps and geographic 
animations.
Viz World User Guide: Contains information on creating real-time 3D maps and using the 
client-server solution.

7.2 Feedback And Suggestions
We encourage suggestions and feedback about our products and documentation. To give feedback 
and/or suggestions, please contact your local Vizrt customer support team at www.vizrt.com.

7.3 Geometry Plug-Ins
This chapter describes geometry plug-ins. The geometry plug-ins are found in three plug-in 
folders:

Maps: Contains standard plug-ins.
Maps-Adv: Contains advanced plug-ins.
Maps-Lab: Contains experimental plug-ins. Since these plug-ins are experimental and not 
supported, they are not documented here.

Note: This plug-in package is released separately from the Viz World Client. Some of the 
functionality of these plug-ins are still intended to be used with the Viz World Client.



http://documentation.vizrt.com/viz-artist
http://docs.vizrt.internal/viz-world
http://docs.vizrt.internal/viz-world
http://www.vizrt.com/
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Maps-Obs: Contains obsolete plug-ins, installed only for backward compatibility. These plug-
ins should not be used when designing new scenes. Since these plug-ins are obsolete and 
not supported, they are not documented here.

See the following sections for more information:

2D Label
3D Border
3D Line
3D Line Control
3D Models
3D Region
3D Region Control
3D Roads
Atlas
C3D Terrain
GeoChart
GeoImage
Globe
Label and Go
MapScale
Pyramid Control
Shadow Agent
WindFlows

7.3.1 2D Label

The 2D Label plug-in creates two dimensional labels on the map, based on labels received from 
the selected map or automatically generated labels generated by the Label Manager according to 
the map information received from the Navigator plug-in. It must have a container with text 
content as a child to work properly.
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2D Label Properties

Label
The Label tab contains general geometric properties for label such as margins (geometry length or 
width around the bounding box of the text), outline width and colors.

Margin Options
Equal Spaced: Uses equal spacing for the side margins and top/bottom margins.
Separate: Uses different margins for each side of the labels.

Width Margins, Left/Right Margins: Sets the margin between the sides of the text and the 
label background edges.
Height Margins, Top/Bottom Margins: Sets the margin between the top and bottom of the 
text and the label background edges.
Outline Width: Sets the width of the label’s background outline.
Label Color: Sets the color of the label’s background fill.
Outline Color: Sets the color of the label’s background outline.
Offset X: Defines an additional offset in Viz units in the X-axis where the Label is drawn.
Offset Y: Defines an additional offset in Viz units in the Y-axis where the Label is drawn.

Note: When adding a 2D Label plug-in to a container, a World Position plug-in and an Alpha 
plug-in is added automatically to the same container. The Label Manager scene plug-in has 
to be added manually to the scene when using the 2D Label plug-in without a Navigator
plug-in.



Note: This plug-in is located in: Plugins -> Geometry plug-ins -> Maps

Note: The numeric values next to the color parameters are the alpha values of the 
label and the label outline.
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Bevel
The Bevel tab contains options dealing with rounding of corners.

Bevel: Defines the bevel value of the label’s background corners.
Roundness: Defines whether the background corners is rounded.
Detail: Defines the quality of the label object (when a higher value is selected, more 
polygons are used to build the label object).
Lock Aspect: Applies the bevel and roundness parameters to the corners of the label object 

equally when set to  On . When set to  Off , the bevel and roundness parameters are applied 

to the corners using the object’s height and width ratio.

Caption
The Caption tab defines the position of the label.

Pivot: Defines the label’s object shape and location in relation to the label’s geographic 
location:

Pointer: Includes a pointer going out of the label background in the label object and 
points at the label’s geographical position. When selected, additional parameters are 
enabled: Width and Connection Bevel.
Outline: Gives the label object a rectangular shape and the outline of the shape is on 
the label’s geographical position.
Center: Places the center of the label over the label’s geographical position.
Offset: Places the label at the defined offset from the label’s geographical position.
Position: Suggests a few possible locations to Auto Street Labels for the label 
(positions along the street) so that Label Manager can pick one of them.

Width Type: Defines whether the (strap) width should change as the caption is moving away 
from the tip or stay fixed.
Width: Defines the width of the pointer’s base overlapping the label background. This 
parameter is only enabled when Pointer is selected.
Connection Bevel: Defines whether the area connecting between the pointer and the label 
background is to be rounded or sharp. This parameter is only enabled when Pointer is 
selected.
Rotate Labels: Defines whether labels, created in Viz (3D labels), are rotated like the labels 

in World Map Editor or Map Editor Classic (WME). If set to  Off , all labels display 

horizontally. If set to  On , labels that were rotated in Map Editor are rotated in Viz.

Caption Source

The options Default Position, WME Directions and Label Manager Presets include the properties 
described below.

Note: The color palette effects only the selected color parameter (label or outline), 
and it appears when one of the color parameter is selected (Viz 3).
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Default Position

Default Position is used when adding labels in WME when no direction is selected.

Direction (deg): Sets the angle of the label in relation to its geographic position.
Distance (cm): Sets the distance of the label from its geographical position.

WME Offsets Distance: Enables the WME to offset the distance (default  On ). When disabled 

( Off ) only the direction offsets from WME is used and the distance ignored.

WME Compass Rose

This allows you to set and fine tune offsets for every direction available in WME. When selected, the 
labels are placed as they were placed on the map in the Map Editor. When manually set inside WME 
they always take priority over the presets and Default Position settings.

Presets: Corresponds to the available directions inside the WME.
Direction Offset (Degrees): Defines values for fine-tuning the position of the label.
Distance (Viz units): Defines the distance offset for fine-tuning the position of the label.

Label Manger Presets

When this is selected, the Label Manager plug-in uses the defined presets to place the labels over 
the map. The Label Manager plug-in optimizes the label position such that the labels do not 
overlap.

Number of Presets: Defines the number of label position presets available to the user (one to 
four presets).
Current Preset: Selects the preset number to be configured, using the Direction and Distance 
parameters. Each preset should be selected and the label position should be adjusted.
Direction (deg): Sets the angle of the label in relation to its geographic position.
Distance (cm): Sets the distance of the label from its geographical position.

Special
The Special tab defines special options for the pointer.

Shape: Defines the pointer shape:
None: Gives the pointer a sharp point shape.
Circle: Gives the pointer a circle at the tip of the pointer.
Square: Gives the pointer a circle at the tip of the pointer.
Straight: Gives the pointer straight lines at the tip of the pointer.
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Size: Defines the size of the shape at the tip of the pointer. The parameter is only enabled if 
the pointer is selected and a tip shape is set.
Navigator Overlay: Defines how the label is displayed over the map. Available options are 
Disabled, Fixed, Scaling, Near Scale and Far Scale.

Disabled: Places the label on the map using its geographical referencing.
Fixed: Places the label by keeping its geographical referencing but using a different 
camera (either with dynamic image or with a front layer). The label size remains fixed.
Scaling: Places the label by keeping its geographical referencing but using a different 
camera (either with dynamic image or with a front layer). The Label scales trying to 
imitate the camera movement.
Near Scale: Defines the maximum size of the label on the screen (the final size of the 
label when zooming in).
Far Scale: Defines the minimum size of the label on the screen (the final size of the 
label when zooming out).

Static Map Scale: Defines whether scaling of the label is performed over a static map (no 

Navigator plug-in used). When disabled ( Off ), no scaling is applied to the labels. When 

enabled ( On ), an additional parameter is enabled:

Scale: Sets the scaling factor of the labels when used over a static map (no Navigator 
plug-in).

Collision Mode: Defines how the labels are placed when an overlap or collision between two 
labels occur.

Tip Based: Allows the pointers of overlapping labels can cross or touch, but no overlap 
of label bodies are allowed.
BBox Based: Calculates a bounding box around the entire label (label body and 
pointer). Overlap between a label’s bounding box is not allowed.

Hide if Empty: Hides the container of the label if the Label text is empty.
Enable Overlay: Renders label geometry on different camera.

Fade
The Fade tab defines the fade effect parameters to be used with the duplicated labels. Fade has 
two fade modes: Stand Alone and Controlled.

Stand Alone: Defines the label appearance manually with the additionally enabled 
parameters:

Fade On Time: Defines a label fade effect, beginning at a relative point to the defined 
hop duration. An additional parameter is enabled, Time To Hop, defining when the 
fade occurs.
Fade On Distance: Defines a label fade effect, beginning at a relative distance from the 
hop final location.

Note: The Fade On Distance parameter is only enabled if Navigator Overlay is 

set to Scaling . See the plug-in section 2D Label.
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Fade On Lat/Long: Defines a label fade effect, beginning at a Longitude and Latitude 
offset from the hop final location. An additional parameter is enabled, Lat/Long, 
defining the offset from in degrees.

Controlled: Sets label appearance automatically with the 2D Label plug-in. It can also be 
based on the Label Manager plug-in settings and the Navigator plug-in animation (hops). 

Step: Controls when the label fades in and out in relation to an animation. In general, 
the fade can be based on the camera distance (For example: Capitals are in view when 
distance is below 1000 kilometers) or on timing in relation to the hop:

Auto: Fades in and out based on distance to hop when a label is of type point 
(added by the user). If the label is of type place/region it fades in and out based 
on the distance set in Label Manager plug-in. If the hop is not close enough for 
the label to show and the label was added by the user, it fades in based on hop 
timing and not distance.
On Hop: Links the fade to the hop timing.
Point 1/Point 2: These are reserved for labels where the distance is configured 
by the Label Manager plug-in.
Hop and Above: Turns on at the hop and stays on thereafter.

Selected Label Timing: Sets the time in relation to the hop time if the label’s fading is 
based on hop timing. It is disabled if Step is set to Point 1 or Point 2. Since the label 
appearance is automatically calculated, this timing offset is used in the calculation. 
Select one of the options:

At End: Places labels at the end of the animation.
Close to End: Places labels just before the end of the animation.
Ahead: Places labels before the end of the animation.
Well Ahead: Places labels well before the end of the animation.

Label Priority: Defines the priority of the currently edited label in relation to other 
labels when a conflict between label positions occurs. The highest priority is preferred 
when displaying the labels.

Auto: Sets the label priority using the Label Manager plug-in.
Normal, High: Allows the Label Manager plug-in decides which label to show 
when there is a conflict between two normal (or high) priority labels.
Always: Displays the label even if it conflicts with another label (with any 
priority).

7.3.2 3D Border

The 3D Border plug-in draws the borders with fixed/scaling width options. Controlled mode refers 
to the 3D Border Control plug-in, turn on this option to allow 3D Border Control to take effect.

Note: The 3D Border Control plug-in has been deprecated.
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This plug-in is used for applying graphic designs to the border data retrieved by the 3D Map 
Setting scene plug-in. Each 3D Border plug-in is used to filter and define which borders are drawn.

The Data tab is used for defining which borders are displayed by the plug-in. The Width tab is used 
for defining the border width and other graphical related attributes. The Outline tab is used for 
adding an outline to the borders. The Effect tab is used for defining an animation of the border. 
The Advanced tab is used for defining general parameters of the border.

3D Border Properties

Data
Draw: Sets the border type drawn by the plug-in. Available options are Country, Region and 
All.

Country: Draws country borders only. When Country is selected, additional options are 
made available: Country, Coastline and Both (see Select).
Region: Draws region borders only. When Region is selected, additional options are 
made available: Region, Sub Region and Both (see Select).
All: Draws all available borders retrieved by the 3D Map Setting plug-in.

Select: Displays the available Country or Region options when either of those two options is 
selected.

Country: Draws inland country borders only.
Coastline: Draws country coastline borders only.
Both (Country & Coastline): Draws both inland and country coastline borders.

Note: When adding a 3D Border plug-in to a container, a 3D Line Shader plug-in is added 
automatically to the same container. The 3D Map Setting plug-in must be manually added 
when using the 3D Border plug-in.



Note: This plug-in is located in: Plugins -> Geometry plug-ins -> Maps



Plug-ins User Guide -  5.0

Copyright © 2022  Vizrt Page  606

•
•
•

•

•

•
•

•

•

•

•

•

•

•

•
•

•

•

Region: Draws region borders only.
Sub Region: Draws sub region borders only.
Both (Region & Sub Region): Draw both region and sub region borders.

Selection: Defines whether the plug-in uses the selected regions in the map (received from 
the CWMClient plug-in). If enabled, only the borders of the selected regions in the map are 
drawn. If disabled, all borders are drawn according to the plug-in settings (country, region, 
and so on).

Width
Fixed (Pixels)– Uses a fixed width when drawing the line. This parameter causes the line to 
maintain the same width regardless of camera position/distance. Available parameters are 
Width and Fade Edge.

Width (Pixels): Sets the line width in pixels.
Fade Edge (%): Sets the percentage of softness added to the edges of the line. When 

set to 0% , the line edges are sharp and when set to 100% , the edges are soft.

Scaling: Varies the line width according to the camera distance from the map when selected. 
Available parameters that allow the user to set the line attributes are Width, Minimum Width, 
Maximum Width, Minimum Draw Width and Fade Edge.

Width (km): Sets the line width in meters on the map. The closer the camera to the 
map, the wider the line drawn.
Minimum Width (px): Sets the minimum line width in pixels. If the calculated line width 
(according to the Width parameter) is smaller than the Minimum Width value, then the 
Minimum Width value is used.
Maximum Width (px): Sets the maximum line width in pixels. This value is used when 
the camera distance is small and the line width should have been larger than the 
Maximum Width value (in pixels).
Minimum Draw Width (px): Sets the minimum line width in pixels. If the calculated line 
width (according to the Width parameter) is smaller than the Minimum Draw Width 
value, and larger than the Minimum Width parameter, then the line is not drawn.
Fade Edge (%): Sets the percentage of softness added to the edges of the line. When 

set to  0% , the line edges are sharp and when set to  100% , the edges are soft.

Fixed (Mm)– Uses a fixed width, in Viz units, when drawing the line. This parameter causes 
the line to maintain the same width regardless of camera position/distance. Available 
parameters are Width and Fade Edge.

Width: Sets the line width in pixels.
Fade Edge (%): Sets the percentage of softness added to the edges of the line. When 

set to  0% , the line edges are sharp and when set to  100% , the edges are soft.

See Me Now: Calculates (when width is set to scaling) the width needed for the line to be 
visible at a given distance.

Outline
None: Does not draw an outline to the borders.
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Master: Acts as the master plug-in for outline behavior. Other 3D Border plug-ins can be set 
as clients of this plug-in. The same outline attributes are applied to borders drawn by the 
master plug-in and by all other slave plug-ins. When selected, the Outline Width (%), Outline 
Fade (%) and Outline Color parameters are also available.
Slave: Draws the outline according to the defined outline in the master plug-in above it in 
the scene hierarchy. All other parameters are disabled, displaying the master’s values.
Stand Alone: Defines the outline parameters for the borders drawn by this 2D Label plug-in 
only. When selected, the Outline Width (%), Outline Fade (%) and Outline Color fields are also 
available.
Outline Width (%): Sets the width of the outline, as a percentage of the border width, where 

0%  is the border width.

Outline Fade (%): Sets the percentage of softness applied to the outline edges.
Outline Color: Sets the color of the outline and the alpha value of the outline.

Effect
The Effect tab is used for creating an animation on the line size. After the line object is created, it 
can be animated by setting keyframes of the length parameter.

Border Length: Sets the line length, where the value 100  represents 100% of the line length.

Fade: Defines the softness that is added to the line edge as the length animation advances. 

When the length is 100 , the end of the line is not affected by the Fade parameter.

Advanced
The Advanced tab is used for defining general parameters for the 3D Border object.

Height Offset: Offsets the borders from the map (on the fly).
Border Quality: Selects the quality of the border line:

Controlled: Calculates border quality by the navigator distance from the border object.
High: Uses high quality when drawing the border line (performance is slower).
Medium: Uses medium quality when drawing the border line.
Low: Uses low quality when drawing the border line. The border line looks pixelized 
when zooming into the map.

Add Level Down (Shape File): Defines whether the sub region borders are drawn with the 
region borders, or if regions are drawn with countries.
Control Mode: Defines whether the 3D Border object is externally controlled by the 3D 
Border Control plug-in or not. Border objects are controlled by groups.
Set Groups: Set the group number for the object.

Note: The hierarchy structure is important when using the master/slave outline 
configuration. The master plug-in should always reside as the first container in the 
group of 3D Border containers. An Expert plug-in should be added to the map (above 

the 3D Roads containers) and Z-Buffer Draw should be set to Off .
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Line Shader: Line shader has two variants. The first is Simple with less options (and better 
performance), while the second is more Advanced and allows for more options (but at the 
cost of performance).
Update Texture Mapping: Determines whether the texture coordinates should be updated 
based on line width.
Low Angle Compensation: Compensates for perspective distortion. Lines become too thin at 
low camera angles as a result of the perspective distortion. When that happens, there are 
not enough pixels to support a smooth, anti-aliased line, and the lines look jagged and 
aliased. This mode compensates for that by both widening the lines and applying 
transparency when they are viewed at too low angles.
Debug: Enables debug messages in the console.
Min Angle: Does not change line width and transparency if the angle between the camera 
and the ground below the line is lower than Min Angle.
Max Angle: Increases the line width by the Width Factor and scales the transparency by 
the Alpha Factor if the angle between the camera and the ground below the line is higher 
than Max Angle. If the angle is between Min Angle and Max Angle then the width and 
transparency are interpolated.
Outline Angle Offset: Applies an offset to the angle calculation for outline width in order to 
make the outlines affected at higher angles than the lines themselves.
Width Factor (%): Determines the factor for modifying line width when applicable.
Alpha Factor (%): Determines the factor for modifying line alpha when applicable.
Wireframe: Shows the border object as a wireframe.
Print Sub Area Data: Prints to the console all the sub regions in the plug-in (used for 
elections).

Rebuild
The Rebuild button triggers the plug-in to redraw the borders according to the plug-in parameters. 
Some parameters are updated as the parameters are changed and do not require a rebuild 
command, but it is good practice to rebuild the borders after setting the parameters.

7.3.3 3D Line

The 3D Line plug-in has several graphic uses for drawing lines:

Drawing shape lines created in the Map Editor (WME) when selecting a map. A line design is 
created in the hierarchy and defined in the CWMClient plug-in (see 3D Objects and Shapes).
Drawing a line between label locations, defined in the WME, from the first label in the list to 
the last label in the list. Labels in the CWMClient plug-in must be enabled when using this 
mode.
Drawing a line along hop points defined in a Navigator scene. The line follows the path of 
the Navigator animation between the hops.



Plug-ins User Guide -  5.0

Copyright © 2022  Vizrt Page  609

•

•
•
•
•
•
•
•

Drawing a line using a Long/Lat coordinates list. The line is drawn from the first Long/Lat 
pair to the last.

This plug-in also works together with plug-ins such as: Trace It.

This section contains information on the following topics:

3D Line Properties
Width
Outline
Effect
Control
Advanced
Rebuild

Note: When adding a 3D Line plug-in to a container, a 3D Line Shader plug-in is 
added automatically to the same container. The 3D Map Setting plug-in has to be 
added manually when using the 3D Line plug-in with the Navigator plug-in. The 3D 
Line Manager plug-in is used for controlling and creating 3D Line objects.



Note: Some of the uses of 3D Line plug-in as described above requires the use of the 
Label Manager plug-in in the scene.



Note: This plug-in is located in: Plugins -> Geometry plug-ins -> Maps
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3D Line Properties

Width

Fixed (px): Uses a fixed width when drawing the line. This parameter causes the line to 
maintain the same width regardless of camera position/distance. Available parameters are 
Width and Fade Edge.

Width (px): Sets the line width in pixels.
Fade Edge (%): Sets the percentage of softness added to the edges of the line. When 

set to 0% , the line edges are sharp. When set to 100% , the edges are soft.

Scaling: Varies line width according to the camera distance from the map when selected. 
Available parameters that allow the user to set the line attributes are Width, Minimum Width, 
Maximum Width, Minimum Draw Width and Fade Edge.

Width (m): Sets the line width in meters on the map. The closer the camera to the 
map, the wider the line drawn.
Minimum Width (px): Sets the minimum line width in pixels. If the calculated line width 
(according to the Width parameter) is smaller than the Minimum Width value, then the 
Minimum Width value is used.
Maximum Width (px): Sets the maximum line width in pixels. This value is used when 
the camera distance is small and the line width should have been larger than the 
Maximum Width value (in pixels).
Minimum Draw Width (px): Sets the minimum line width in pixels. If the calculated line 
width (according to the Width parameter) is smaller than the Minimum Draw Width 
value, and larger than the Minimum Width parameter, then the line is not drawn.
Fade Edge (%): Sets the percentage of softness added to the edges of the line. When 

set to  0% , the line edges are sharp. When set to  100% , the edges are soft.

Fixed (mm)– Uses a fixed width, in viz units, when drawing the line. This parameter causes 
the line to maintain the same width regardless of camera position/distance. Available 
parameters are Width and Fade Edge.

Width: Sets the line width in pixels.
Fade Edge (%): Sets the percentage of softness added to the edges of the line. When 

set to  0% , the line edges are sharp. When set to  100% , the edges are soft.

See Me Now: Calculates (when width is set to scaling) the width needed for the line to be 
visible at a given distance.

Outline

Outline: Enables ( On ) or disables ( Off ) outline.

Outline Width (%): Sets the width of the outline, as a percentage of the border width.
Outline Fade (%): Sets the percentage of softness applied to the outline edges.

Note: Width parameters, Fixed (px) and Scaling, affects the line object only if the scene 
uses a Navigator plug-in. In case of a static map, use the Fixed (mm) to set the line width.





Plug-ins User Guide -  5.0

Copyright © 2022  Vizrt Page  611

•

•

•

•

•

•

•
•

•

•

•
•
•
•
•

•

•

Outline Color: Sets the color of the outline and the alpha value of the outline.

Effect
The Effect tab is used for creating an animation on the line size. After the line object is created it 
can be animated by setting keyframes on the length parameter.

Length: Sets line length, where 100  is 100% of the line length.

Fade: Defines the softness added to the line edge as the length animation advances. When 

length is 100 , the end of the line is not affected by the Fade parameter.

Animation Length (frames): Sets the default length of the reveal animation in frames (relates 
to the Run Animation option) and allows you to run a simple reveal animation by pressing 
the Run Animation button (used by 3D Map Telestrator).
Lock To Navigator: Animates the line with the Navigator animation when using the 3D 
Line plug-in with a Navigator plug-in. The starting point of the line is the first hop location 
and the ending point of the line is the last hop position. The line animates as the hop 
animations are playing.
Run Animation button: Plays the animation of that particular line.

Control
The Control tab is used for defining external control parameters. External control is done by the 
3D Line Control plug-in.

Control Mode: Defines whether the object is externally controlled or not.
Set Groups: Defines the groups that the current 3D Line object is a member of. The same 
group names should be used in the 3D Line Control.
Shared Memory: Determines the type of shared memory that can be used to control the 
lines.
Identifier: Determines the shared memory name and general purpose identifier for this line. 
Can be used to control the line or to share a display list data between scenes.

Advanced
Cap Edges: Sets the line’s cap shape.

None: Does not change the line edges.
Round: Adds a filled round shape to the line caps.
Square: Adds a filled square shape to the line caps.
Feather: Adds a feather shape to the line caps. An additional parameter is enabled 
when Feather is selected: Cap Fade Size.

Length Effect: Determines whether the separate polygons in the line animate at the same 
time (Per Polygon) or one after another (Continuous).

Wireframe: Draws the 3D Line object as a wireframe when enabled ( On ).

Note: The color palette is visible in all tabs of the editor, but it only affects the 
outline color.
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Height Offset: Sets the height offset for the 3D Line object on the map (on the fly).
Line Offset: Sets the line offset for the 3D Line object on the map (on the fly).
Enable World Periodicity: Determines how line objects that cross the date line act. When 

enabled ( On ), a line object that crosses the date line continues from the other side of the 

map. When disabled ( Off ), it continues across the date line.

Update Texture Mapping: Determines if the texture coordinates are updated based on line 
width. You have the following options: Disabled, Always or Stationary. Stationary only 
updates the texture mapping when navigator is moving.

Low Angle Compensation: Compensates for perspective distortion. Lines become too thin at 
low camera angles as a result of the perspective distortion. When that happens, there are 
not enough pixels to support a smooth, anti-aliased line, and the lines look jagged and 
aliased. This mode compensates for that by both widening the lines and applying 
transparency when they are viewed at too low angles. When set to Advanced, the following 
additional parameters are available:

Debug: Enables debug messages in the console.
Min Angle: Does not change line width and transparency if the angle between the 
camera and the ground below the line is lower than Min Angle.
Max Angle: Increases the line width by the Width Factor and scales the transparency 
by the Alpha Factor if the angle between the camera and the ground below the line is 
higher than Max Angle. If the angle is between Min Angle and Max Angle then the 
width and transparency are interpolated. 
Outline Angle Offset: Applies an offset to the angle calculation for outline width to 
make the outlines affected at higher angles than the lines themselves.
Width Factor (%): Determines the factor for modifying line width when applicable.
Alpha Factor (%): Determines the factor for modifying line alpha when applicable.

Rebuild
The Rebuild button triggers the plug-in to redraw the lines according to the plug-in parameters. 
Some parameters are updated as the parameters are changed and do not require a rebuild 
command, but it is good practice to rebuild the lines after setting the parameters.

7.3.4 3D Line Control

The 3D Line Control plug-in controls 3D Line object groups. The Groups are then controlled in 
terms of width and color. The groups are derived from the settings in the 3D Line objects.

Note: When enabled, symbols are easier to control, but as line width changes the 
cause texture changes which might be disturbing.



Note: This plug-in is located in: Plugins -> Geometry plug-ins -> Maps_Adv
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3D Line Control Properties

Control
Container: Sets the top container above the controlled 3D Line objects.
Group: Defines the controlled group number. A group is defined in every 3D Line object.

Width
Width: Selects options to control the line width, Fixed (in pixels or in mm), or Scaling.

Width: Sets the width value when fixed width is selected (pixels or mm). Fixed width 
the line maintains the width value through all camera zoom range. When Scaling is 
selected, width is set in actual kilometers and the line width is calculated according to 
the camera zoom.
Minimum Width (px): Sets the minimum value of line width in pixels. this value is used 
if the calculated width according to the width parameter is smaller than the minimum 
width value (when zooming far out).
Maximum Width (px): Sets the maximum value of line width in pixels. this value is 
used if the calculated width according to the width parameter is larger than the 
maximum width value (when zooming in).
Minimum Draw Width (px): Defines the minimum line width drawn.
Fade Edge (%): Defines the edge fade width as a percentage of the line width.

7.3.5 3D Models

The 3D Models plug-in adds 3D models to a graphics scene. As the models also contain 
geographical referencing, you may also place the model on a map.
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The images above show a 3D model of Mont Saint-Michel in Normandy, France. The model was 
downloaded from http://sketchup.google.com/3dwarehouse and then placed on a satellite image 
from Digital Globe.

3D Models Properties

General
File: Selects the file to load. Capable of loading files in Collada format with the *.dae 
extension or *.kml/*.kmz extension (which has geographic information for the model and a 
link to a *.dae file inside).
Fill Mode: Selects the rendering mode; solid, wireframe or dotted.
One Size: Recalls the loaded model to a fixed size. Useful in non-georeferenced mode.
Automatic Fetch: Enables fetching pieces of the city as you move around the map 
(Interactive) or animate (Streaming). Used when loading 3D Cities rather than single models.

Advanced
The Advanced tab is more suitable for a streaming mode of the plug-in, when the plug-in loads/
streams data out of a large data bank which cannot be loaded entirely due to its size.

GPU Cache Size: Limits the amount of data that is loaded to the GPU (loaded data may 
consume more size than expected on GPU).
Model Index: Enables to run through loaded models (mostly for debug purposes) when 
multiple models are loaded. When a specific index is set, the model is in focus, so the 
bounding box is shown and Fly To and Info buttons can be used on that model.
Level of Detail: Defines how many of the largest levels of the texture pyramid (.dxt format) 
can be neglected during loading. May be useful in cases where the texture data is heavy and 
presents a higher resolution than that required to be shown.
Height Offset: Height offset during fetch of the models.

Note: This plug-in is located in: Plugins -> Geometry plug-ins -> Maps

http://sketchup.google.com/3dwarehouse
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Show Coverage: Shows the total available geo coverage in green color and currently loaded 
coverage in orange when models are loaded/streamed from the large database.
Fetch Method: Attempts to load as much data around the fetch point as possible (the 
amount is limited by the GPU Cache Size parameter) when models are fetched either by 
pressing the Fetch Locally button or in streaming mode. 

Navigator: Defines the fetch point as the current Navigator position. 
Manual: Enables manual definition of the fetch point. 

Loading Type: Determines how to load multiple models. The Serial mode may be preferred 
for recording (using Viz Post), when you have to be sure that all the models were loaded up 
until the next frame.
Fade Time (sec): Defines the time period during which a new model fades from transparent 
to opaque, to create a more pleasant looking effect on load.

Consolidation
The Consolidation tab is used for compiling a binary format of the plug-in out of Collada files.

Model Optimization: Defines the level of optimization for the model while the model is 
loading. More optimization may increase loading time while improving rendering 
performance in some models.
Downscale Textures: Defines how much the first levels of a texture pyramid may be skipped.

Buttons
Fly To: Used to take the camera to the model, if it is georeferenced (i.e. if the original 
Collada file had *.kml or *.kmz files containing the geolocation). Requires the presence of 
the NavFinder plug-in on the container in order to work.
Reload: Reloads the model.
Info: Prints information about the model to the console. It prints information about the 
dataset in the case when more than one model is loaded, and prints information regarding a 
specific model if only one model is loaded or when the Model index parameter is not zero.
Fetch Locally: Fetches models around the fetch point (defined manually with Fetch 
Method parameter). The number of models that are fetched is limited either by dataset or by 
the GPU Cache Size parameter.

Working with 3D Models
This section provides a quick introduction on how to add a 3D model to your scene, and also how 
to place the model on a map or satellite imagery.

To Add 3D Models to a Scene

Tip: Download models for testing from http://sketchup.google.com/3dwarehouse.

http://sketchup.google.com/3dwarehouse
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Start Viz Artist.
Add the 3D models plug-in to an empty scene tree.
Open the 3D models plug-in editor and load a KMZ file.

To Add 3D Models to a Map

Start Viz Artist.
Add the Navigator to an empty scene tree.
Add the Atlas plug-in to the GeoReferenceMap container.
Open the Atlas editor and set it to use Mercator projection.
Add a new group as a sub-container of the first container and name it position.
Add the World Position plug-in to the position group.
Add a new group as a sub-container of the position group and name it model.
Add the 3D models, Expert and NavFinder plug-in to the model group.
Open the 3D models plug-in editor and load a KMZ file (e.g. Tower Bridge in London).
Click Go To Model. This should bring the model into view.

Open the Navigator editor, select Advanced, and then enable ( On ) the Pan and Tilt 

Animation option.
Open the 3D models plug-in editor again and click Go To Model.
Open the transformation editor for the model container.
Open the NavFinder editor in order to adjust the distance, pan and tilt of the map.

See Also

Viz Artist User Guide for information on the Expert plug-in.

7.3.6 3D Region

The 3D Region plug-in applies a graphic design to selected regions of the map. The designs are 
defined in the scene and linked in the CWMClient plug-in to create the regions received from the 
maps server.

Tip: Press Shift+CTRL while adjusting the Distance, and Shift while adjusting the Pan
and Tilt.



Note: This plug-in is located in: Plugins -> Geometry plug-ins -> Maps

http://docs.vizrt.com/viz-artist.html
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The plug-in has the following four editor views:

General: Quality and performance parameters.
Region: The object’s graphic properties.
Sub Regions: The object’s sub regions graphic properties. This tab is enabled when the Sub 

Regions parameter, under the Advanced tab’s Data settings, is enabled ( On ).

Advanced: Defines plug-in behavior in special operation scenarios.

3D Region Properties

General
LOD mode: Sets the level of detail (LOD). When set to auto, the plug-in manages the level of 
details according to the camera distance from the region object. When set to manual, the 
level of details do not change when the camera moves, and remain fixed. When set to 
Manual, the Polygon Quality parameter is enabled.
Polygon Quality: Sets the quality of the generated region object. The Highest setting uses 
more polygons to build the region object, but affects performance when many regions are 
selected. The Lowest setting enables better performance when adding a lot of regions, but 
looks poor when moving the camera closer to the region objects.
Geo Reference: References the region object to the map above 3DRegion container when set 

to  On . When set to Off , the longitude and latitude numbers are transferred to the Viz 

Artist position X, Y values. The object can still be georeferenced using for example 
the Locator Control or World Position plug-ins.
Auto Rescale: Scales all regions to the same size. Can be used when the region is not 
geographically referenced (on screen normal) and you want all regions to be the same size 
(e.g. Israel uses the same screen real estate as a map of America) in Viz units.
Copy Map to Region: Copies overlay the map texture on top of the region geometry.
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Center X Y: Defines where the axis of the region object is placed: if Region is selected, the 
axis center is the middle of the region object. If Map is selected, the axis is placed in the 
middle of the reference map.
Sensible Culling: Defines whether to cut off areas that belong to the selected region but are 

geographically remote. If set to  Off , all marked regions are built. Use this feature to 

improve performance (usually set to  On ).

Culling Threshold: Defines the level of details displayed in the regions. A higher threshold 
value draws fewer details (that is small islands, small regions, and so on).

Use Cache: Saves the objects to a cache folder when set to  On . When using cache, the 

generated objects and parameters are saved in a cache folder and when switching between 
parameters the regions are not rebuilt, but taken from the cache (if they exist). If no cache 

( Off ) is used, every change in the plug-in interface triggers a rebuild of the region objects.

Region

Fill

Fill: Adds a region object to the map, and if fill is applied, how regions are built on the map 
(either flat on the map (no width) or extruded).

None: Does not add a region object to the map.
Extrude: Adds and extrudes regions over the map. When extrude is used, additional 
parameters are enabled.

Flat: Adds a flat object (Extrude= 0 ).

Include Bottom: Builds the bottom of the region when extruded.
Center Z: Sets the Z axis location of the region object, with relation to the map: bottom, 
center or top.
Type: Defines how the Height parameter is calculated.

Absolute Height: Defines the regions extrusion height value as Viz units.
Relative Height: Defines the regions extrusion height value as a percentage of the 
regions size.

Show Terrain: Enables 3D Region to take into account any terrain data for a selected region. 
Adjust the Terrain Height Scale parameter. For this to work you need to enable the Fetch 
Terrain Data option in the CWMClient.

Terrain Height Scale: Adjusts the terrain height.

Border

The border parameters define whether a border is drawn around the region objects, border color, 
width and the alpha. If the 3D Region object is in Controlled Mode (On) the border properties 
parameters are disabled.

Borders: Defines whether the object is drawn with a border. When enabled (On), the border 
is drawn and the border properties parameters are enabled.
Line Width: Sets the number of GL lines for the border width.
Line Color: Uses the color pallet to set the border color.
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Alpha: Sets the alpha value for the border. This value is controlled by the number to the 
right of the Line Color selection.

Sub Regions
The Sub Regions tab has the same fields as the Region tab, except that Sub Regions does not have 
the Show Terrain and Terrain Height Scale fields. It also has the following field:

Sub Regions: Defines whether the object uses the sub regions data in the drawn object. 
When enabled (On), the sub regions data are reflected in the geometry and the Sub Regions 
tab displays the sub regions parameters.

Advanced

Common Parameters

Freeze: Enables the designer to freeze the region object to Viz data folders (the region is 
saved as an image containing the region’s information).
Wireframe: Draws a wireframe of the object.

Data

The Data tab defines how data is processed.

Controlled Mode: Defines whether the 3D Region object is controlled by 
a 3DRegionControl plug-in in the hierarchy or not.

Election

All options work together with the 3D Region Control plug-in.

Command: Contains the text with region information used for elections.
Selection Data: Since the region data can be shared between scenes, setting the Selection 
Data to Local means you only influence the local scene whereas with Global you influence all 
scenes.

If Sub Regions is enabled ( On ), additional parameters are enabled.

Print Sub Region Data: Prints the data in the Viz console.
Save Sub Regions Strings: Saves back the sub regions data to the file.
Save Sub Region: Saves the current specific sub region information back to the file.
Convert Names: Converts the names in the plug-in to a different set of names.

Note: The color palette is visible in all 3D Region editors but it only affects the 
border color.



Note: Multiple parameters in Election and Alpha tabs are unavailable if Sub Regions are not 
enabled.
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Rebuild: Rebuilds the region objects from the file.

Alpha

The Alpha tab is an advanced tab used mainly for elections. Alpha tab parameters are enabled 
when the Sub Regions parameter is enabled (On). The parameters affect the object only when an 
Alpha plug-in is added to the object and the 3D Region plug-in is in Controlled Mode. These 
parameters define what part of the region data is affected by the alpha plug-in.

Draw: Defines what part of the object is affected by the alpha settings.
All: Draws both region and sub regions in the object.
Region: Draws only the region.
Sub Region: Draws only the sub regions.
None: Sets region and sub regions to be transparent.

Region Alpha Mode: Defines what part of the data is affected by the alpha plug-in.
Region: Affects only the region areas.
Sub Regions: Affects only sub region areas.
None: Does not affect data when using the alpha plug-in.

Border Alpha Mode: Defines what part of the border data is affected by the alpha plug-in.
Region: Affects only the region borders.
Sub Regions: Affects only sub region borders.
None: Does not affect data when using the alpha plug-in.

Create Alpha Channel: Creates an alpha channel animation automatically.
Length: Determines the length of alpha channel animation

Extrude Length (F): Animates sub regions height (extrude). This parameter sets the time for 
the animation.

Draw

The Draw tab defines advanced parameters for drawing the region objects.

International Date Line: Relates to countries that reside on the 180 and -180 longitude line 
when using flat maps.

None: Draws the regions on both sides of the map.
United: Draws the regions together.

Border Data: Defines the source data of the borders.
Polygon: Draws borders using polygon data.
Border: Draws borders using border data (higher memory consumption).

Border Quality: Sets the required border quality.
Morphing: (Off, Start, End, Start & End)

Start: Allows multiple start shapes to be used to create multiple region morphing 
shapes. You must also design a separate region using End in order to define how the 
shape should end.
Start & End: Allows setting two shapes (start and end), and the region morphs between 
the two shapes.

Morphing Samples: Determines the number of data samples between the start and end 
animation.
Morphing Value (%): Used to animate between the first and last frame of the shape.
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7.3.7 3D Region Control

The 3D Region Control plug-in controls one or more 3D Region objects by changing and applying 
graphic properties to the objects. The 3D Region Control plug-in is typically used for producing 
election graphics where it is useful to distinguish regions by, for example, color.

3D Region Control Properties
3D Regions Parent Container: Container placeholder for the container holding the region 
objects.
Control Mode:  Defines the data segment of the object to be controlled. Select Region or Sub 
Region and then select what part of the region/sub-region to control:

Fill: Enables control of the region/subregion’s fill properties.
Border: Enables control of the region/subregion’s border properties.

Fill Mode:  Defines the fill of the regions.
Interpolate 3: Sets three colors that define the region's color range. The region's color 
is derived from the range of colors and the number of regions.
Interpolate 2: Sets two colors that define the region's color range. The region's color is 
derived from the range of colors and the number of regions.
Group: Controls the fill of all the 3D Region objects under the defined 3D Regions 
Container (apply the material added to the 3D Region Control container).
Highlighted: Controls the selected regions on the map only.
Not Default: Allows 3D Region Control to draw any sub region in the target 3D 
Region which is not in group one.

Apply Sender Matrix: Applies a matrix to the regions. Available options are None, Multiply, 
Translate, Scale and Full.

None: Uses the 3D Region matrix.
Multiply: Uses the 3D Region matrix multiplied by the 3D Region Control matrix.
Translate: Uses only the translated part (x, y and z position) of the 3D Region Control 
matrix.
Scale: Uses the scale part (x, y and z scaling) of the 3D Region Control matrix.
Full: Uses the 3D Region Control matrix.

Apply Sender Matrix: Applies a matrix to the regions. Available options are None, Multiply, 
Translate, Scale and Full.

Note: The color palette is visible in all 3D Region editors but it only affects the 
border color.



Note: This plug-in is located in: Plugins -> Geometry plug-ins -> Maps_Adv
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Apply On: Applies the sent matrix on all regions or only the selected sub regions.

7.3.8 3D Roads

The 3D Roads plug-in overlays road data onto a map. This plug-in is mainly used with a 3D Line 
Shader plug-in.  

The plug-in has three different editor views:

Data: Defines what type of roads are drawn by the selected 3D Roads object. Select one or 
more types of roads to be displayed, using the plug-in graphic properties.
Width: Defines the width of the roads drawn by the plug-in.
Outline: Defines the objects outline properties and behavior.
Advanced: Defines extra settings on how to handle texture mapping and low angle 
compensation when drawing streets.

3D Roads Properties

Data
Freeways/Motorways, Primary, Main, Secondary and Other Roads: Draws roads rated 

according to the selection in the loaded roads data when enabled ( On ).

Major and Other Railways: Draws railways rated according to the selection in the loaded 

railways data when enabled ( On ).

Width
Selects how the road width is calculated.

Fixed (Pixels): When set to Fixed the road maintains a fixed width during camera zoom 
movements. Available options are Width (pixels) and Fade Edge (%).

Note: This plug-in is located in: Plugins -> Geometry plug-ins -> Maps
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Width (Pixels): Sets the width of the roads in number of pixels.
Fade Edge (%): Sets the percentage of softness applied to the road edges.
Height Offset: Offsets the borders from the map (on the fly).

Scaling: When set to Scaling the road width varies according to the camera zoom 
movements. When selected, the following parameters are available:

Width (Meters): Sets the physical road width (in Meters). This value is translated into 
drawn pixels according to the camera zoom position and the size of the map.
Minimum Width (Pixels): Sets the minimum size of the roads drawn. If the calculated 
road size in pixels is lower than the minimum width, the road is not drawn.
Maximum Width (Pixels): Sets the maximum size of the roads drawn. If the calculated 
road size in pixels is higher than the maximum width, the road width is set to the 
maximum width.
Minimum Draw Width (Pixels): Sets the minimum size of the roads drawn. When 
zooming into an area, this is the point where the roads begin to fade in and are drawn 
over the map.
Fade Edge (%): Sets the percentage of softness applied to the road edges.
See Me Now: Calculates (when width is set to scaling) the width needed for the line to 
be visible at a given distance.

Fixed (mm): When set to Fixed (mm) the road maintains a fixed width during camera zoom 
movements. When selected, the Width (mm) and Fade Edge (%) parameters are available.

Outline
Outline: Selects one of the options for adding outline to the roads. Available options are 
None, Master, Slave and Stand Alone.

None: Does not add an outline to the roads drawn by the plug-in.
Master: Controls other 3D Roads plug-ins which are in slave mode. The same outline 
attributes are applied to roads drawn by the master plug-in and by all its slave plug-
ins. When selected, additional parameters are Outline Width (%), Outline Fade (%) and 
Outline Color. 

Slave: Draws the outline according to the defined outline in the master plug-in above it 
in the scene hierarchy. All other parameters are disabled, displaying the master’s 
values.
Stand Alone: Defines the outline parameters for the roads drawn by this 3D 
Roads plug-in only. When selected, available additional parameters are Outline Width 
(%), Outline Fade (%) and Outline Color.

Outline Width (%): Sets the width of the outline, as a percentage of the road width, where 0%
is the road width.
Outline Fade (%): Sets the percentage of softness applied to the outline edges.
Outline Color: Sets the color of the outline and the alpha value of the outline.

Note: The master setting ONLY controls other plug-ins, it does not draw any 
outlines itself. If there are no slave plug-ins, then no outlines are visible.
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Advanced
Line Shader: Line shader has two variants. The first is Simple with fewer options (and better 
performance), while the second is more Advanced and allows for more options (but at the 
cost of performance).
Update Texture Mapping: Defines when to update the mapping of textures applied in the 
container:

Disabled: Does not ever update the mapping of the texture.
Always: Updates the mapping of the texture while animating.
Stationary: Updates the mapping of the texture only when the scene is stationary or 
not an animation.

Low Angle Compensation: Used when creating graphics that have a low angle point of view 
or tilt in order to remove aliasing on lines far away from the camera.

Wireframe: Displays the roads as wireframe.
Debug: Enables debug messages in the console.
Min Angle: If the angle between the camera and the ground below the line is lower 
than Min Angle, then line width and transparency are not changed.
Max Angle: If the angle between the camera and the ground below the line is higher 
than Max Angle, then the line width is increased by the Width Factor and the 
transparency is scaled by the Alpha Factor. If the angle is between Min Angle and Max 
Angle then the width and transparency are interpolated.
Outline Angle Offset: For outline width, apply an offset to the angle calculation in 
order to make the outlines affected at higher angles than the lines themselves.
Width Factor (%): Determines the factor for modifying line width when applicable. 
Percentage value for the width of the line far away from the camera. For example, 
400% thicker than when it is close to the camera.
Alpha Factor (%): Determines the factor for modifying line alpha when applicable. 
Percentage value for the alpha of the line far away from the camera.

7.3.9 Atlas

Note: The hierarchy structure is important when using the master/slave outline 
configuration. The master plug-in should always reside as the first container in the 
group of 3D Roads containers. An Expert plug-in should be added to the map (above 

the 3D Roads containers) and Z-Buffer Draw should be set to Off .



Note: Road data should be loaded (using the CWMClient plug-in) before working on 
roads design.
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The Atlas plug-in displays satellite imagery from Microsoft Bing, Maxar (formerly Digital Globe), 
Google and other providers. This object plug-in is used with a navigator plug-in, enabling 
interactive navigation to any location on Earth. The plug-in can be used to display imagery for a 
Navigator animation (Hops), while creating the required image tiles for a smooth and complete 
camera movement. It can also be used with the Globe plug-in.

To create an interactive Touchscreen Application, the Atlas plug-in must be used together with 
the Navigator.

The plug-in has the following editor tabs:

Atlas Properties
Data

Bing
CMR
Maxar
WMS
Nokia
Map Server
Google

General
Advanced
Communication
Animation

Atlas Properties
Pre-Fill Texture Cache Option: Fully initialize GPU Memory for tiles rendering. This ensures that no 
textures are created at playout. This increases texture memory usage, because it allocates textures 
for tiles that might never be rendered.

Data
The Data tab is used to define imagery parameters.

Data Source: Sets the data provider. Available providers are:
Microsoft Bing
Vizrt’s CMR (Curious Multi Resolution)
Maxar (Digital Globe)
WMS (Web Map Service) geo server
Nokia
Map Server

IMPORTANT! To ensure that image tiles appear correctly, use a base map with the correct 
projection.



Note: This plug-in is located in: Plugins -> Geometry plug-ins -> Maps
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Google

Hide Attribution: Hides the provider's attribution. Some data sources provide the possibility, 
but this is different for every data source. Some provide a separate license to enable this 
feature.

Bing

Legacy Protocol: Allows using the Data Type parameter to choose between satellite imagery, 
road and border maps with labels or a combination of the two. If you combine the two road 
and border maps with labels they are imposed over the satellite imagery. The API used in 
previous versions of Viz World are used. 

Satellite: Displays ONLY satellite imagery.

Map: Displays the map using the hybrid styling and also displays labels.

Note: Bing, Maxar, WMS and Google require an internet connection. Bing and 
Google does not work without a license. Maxar does, but shows a watermark. 
My Radar, WDT and Blom are removed, existing Scenes now fall back to Maxar.
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Combined: Displays a mix of Satellite imagery and Labels.

Traffic: Draws a traffic layer. 
New Protocol: Allows selecting whether to include labels in the map, and what language to 
use for those labels. A new API is used, which gives you more control over what to display in 
the map. The following parameters are available:

Map: Displays Satellite imagery, or displays the Map using the hybrid styling.
Labels: Turns the labels in the Map on/off.
Culture: Selects the language of the labels.
Vector: Determines whether the map includes vector data (streets/ borders) with the 
satellite imagery.
Hills: Determines whether the synthetic map includes hills topography.

CMR

CMR File: Sets the path to the CMR file.
CMR Data Status: Indicates whether the file was loaded correctly.

Maxar

Projection: Defines the projection of the map, either Unprojected or Mercator.
Digital Globe Profile: Enables you to select from the most common profiles of Digital Globe 
maps (Note that imagery from different profiles may differ in some places and be the same 
in others).

In addition, the following parameters can be configured in the VizWorld.ini configuration file (by 
default located at %ProgramData%\vizrt\VizEngine\Maps):

DigitalGlobePrefix
FirstLookPrefix

If these parameters are used (i.e. present and not commented with hash) then Atlas uses these 
strings as the basic connection string. The license key, projection, tile coordinates and additional 
parameters like profile or header are added in Atlas itself.

WMS

Projection: Defines the projection of the map, either Unprojected or Mercator.
URL: Sets the URL of the WMS geo server.
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Layer: Comma-separated list of one or more map layers. Values in list correspond to the 
layer <Name> values by the geo server’s Capabilities file. Layer list is optional if the Styled 
Layer Descriptor (SLD) parameter is present in the request.
Free text: Sets optional parameters like transparency and background color 

(e.g.  TRANSPARENT=TRUE&BGCOLOR=#E98300& ). For more information on how to set 

optional parameters in the free text field, see the WMS specification documentation.

Version: Request version. Valid values are 1.0.0 , 1.1.0 , or 1.1.1 .

Nokia

Data Type: Sets how the map is displayed. For more information, see the description of the 
Data Type parameter in the Bing tab.

Map Server

This allows the use of the TPLs and stylesheets in an available map server.

Server Configuration:
Default: Uses the default server configured in the engine (see the Configuring 
Viz section of the Viz Engine Administrator Guide).
Manual: Allows using a different server than what is configured in the Viz Engine.

Projects: Lists all TPLs that are available in the map server.
Project: Displays the selected TPL.
Pick Style: Shows available style sheets in the selected TPL by numerical index .
Layer: Shows the name of the selected style sheet.

Google

Profile XML Status: Shows if the file GoogleMaps_Profiles.xml (by default located 
at %ProgramData%\vizrt\VizEngine\Maps) was read correctly.
Google Profile: Lists all found profiles from the file GoogleMaps_Profiles.xml.

General
Use Base Map: Uses base map. This option is used when working with a base map above the 
Atlas container, and the base map is projected. Note that Microsoft Bing imagery is 
unprojected, so in order to have the images positioned correctly over the map set this 
parameter to On. The same applies if you use the Globe plug-in.
Map Size: Defines the size of the Atlas image.
Fade Time: Defines the duration of the transition between tile resolutions when zooming in/
out of the image.

Note: In the Viz Artist interface, a maximum of 256 TPLs can be displayed.

Note: To add or modify Google profiles, edit the file GoogleMaps_Profiles.xml. The 
Google Maps Tile documentation lists all possible configurations.



http://webhelp.esri.com/arcims/9.3/general/mergedprojects/wms_connect/wms_connector/get_map.htm
http://documentation.vizrt.com/viz-engine
https://developers.google.com/maps/documentation/tile/#session_token_request
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Advanced
The Advanced tab is used for configuring connection and operation parameters.

Temp Folder: Defines a specific cache folder for the retrieved imagery.
Mode: Defines the mode of retrieving the tiles from Microsoft Bing server. When set to Serial, 
and new image tiles are required, Atlas plug-in sends a request to the server and waits for a 
reply. Only after the reply, another tile is requested, and so on. During the time that the 
plug-in as waiting for a replay the UI is locked the user cannot perform other operations. 
When set to Multithreaded, the images are requested by a thread of the plug-in and the UI is 
not locked.
Requests per Frame: Defines the maximum image requests from the server in a frame.
Layers: Defines the number of images (with different resolution) per one area.
Texture Compression: Selects one of the required compression modes for the images.
Texture Quality:

Linear: Performs a linear interpolation to smooth the texture when being magnified or 
shrunk. The texture looks good, but some distortions can be visible when the textured 
object is animated further away on the Z axis. As the object then gets smaller and 
smaller, the shrinking and interpolation of the texture creates a lot of "noise" on the 
texture. As a consequence, the linear quality is appropriate when the objects that have 
the texture do not change their size much.
Mipmap: Performs a linear interpolation to smooth the texture. In addition, it offers a 
solution to the problem that appears on the two other qualities when the object is 
being moved away along the Z axis or shrunk. To avoid the "noise" that we see when a 
texture constantly scales to try to fit.

Quality: Defines the quality of the images requested from the server.
Memory Buffer Size: Controls memory buffer used by Atlas. Useful for scenes with multiple 
Atlas plug-ins.
Layer Type: Maintains transparency while stacking multiple layers on top of each other when 
a transparent layer type is selected. Selecting opaque consequently blocks anything below it. 
WMS layers tend to be transparent (e.g. power lines or flood area). This parameter is only 
visible when the Data Source is set to WMS.
Stop Support Margins: Retrieves additional image tiles surrounding the displayed area to 
enable immediate display of high resolution images when the user moves the image when 

set to On .

Limit Disk Read Time (ms): Specifies the maximum time period for the plug-in to be 
occupied with loading. If while loading the tiles for the current frame, the plug-in recognizes 
that loading is taking too much time, it stops loading and renders the frame.
Use Hysteresis: Resolves the ’flickering problem’ that may occur if the Navigator position 
moves back and forth around a point where the plug-in decides to change resolution levels. 
Hysteresis uses history data in the calculation of a point where the level should be changed, 
such that the switch for zoom in and zoom out does not happen in the same point, thus 
avoiding the flickering. If enabled, set the Hysteresis size.
Tessellation: Increases tessellation of each tile in the Atlas plug-in. This may be useful when 
projection of the basemap differs from the projection of Atlas data source (and one of the 
projections is not linear). By using tessellation, the tile fits more accurately to the basemap 
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(less distortion). Raising this parameter affects performance, so only use when distortion 
due to a difference of projections is visible and unacceptable. Only visible when Atlas is used 
under basemap. 

Communication

Use Proxy: Enables proxy configuration parameters when set to On . Use this option when 

working an a network with proxy:
IP: Determines proxy server IP number.
Port: Determines proxy port number.
Username/Password: Sets the username and password.

Bind to IP Address: Forces the plug-in to use the IP address of a specific network card in the 
computer (used when multiple network cards are part of the computer) when set. When not 
set, it defaults to the first network connection.

Animation
The animation properties are only valid if the Data Source is set either to My Radar or to Weather 
Decision Technologies. It gives access to advanced options on how different animation slides are 
being displayed.

7.3.10 C3D Terrain

The C3D Terrain plug-in displays terrain objects. The terrain is retrieved from the Viz World Server 
(WoS) when a CWMClient plug-in is added to a C3D Terrain object. When the CWMClient plug-in is 
added to the C3D Terrain plug-in, terrain tessellation parameters are enabled in 
the Miscellaneous tab of the CWMClient plug-in.

The plug-in has three views:

C3D Terrain Properties
Terrain
Pyramid
Advanced

Buttons

Note: This plug-in is located in: Plugins -> Geometry plug-ins -> Maps
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C3D Terrain Properties

Terrain
Height Scale Mode: Sets the height scaling option for the terrain:

Manual: Sets the height scale manually by changing the Height Scale parameter. When 
selected, additional parameters are enabled:
Soft: Sets the terrain surface to be softened by interpolating points over the terrain. 
This option prevents the sharp edges over the terrain surface.
Normal: Uses the same terrain elevation values received from the server.
Exaggerate: Applies a large scaling factor to the terrain height differences, 
exaggerating the terrain surface.
Tiling: Does not take the terrain height into account for the map size. Setting Height 

Scale Mode to Absolute  may therefore be needed for the terrain tiling, or else the 

tiles might not connect properly (due to height differences).
Globe: Draws the terrain as part of a globe and enables the Globe Radius parameter when 

set to On .

Globe Radius: Sets the size of the globe used for drawing the terrain.

Height Scale: Sets the scaling value for the terrain elevation. Using a low value flattens the 
terrain surface.
Delta Z: Sets the Z axis offset for the terrain (mainly used when using the base map).

Pyramid
A Pyramid is a set of map textures in different resolutions, used for zooming into a defined area. 
When the camera is far from the map, a low resolution map texture is used (covering a wide area). 
As the camera zooms into the map, it zooms into an area with higher resolution texture, until the 
final map, with the highest resolution, is used. In order to enable the Atlas Pyramid parameters 
a CWMClient plug-in must be attached to its container. Note that this disables Atlas Terrain File 
Name parameter. See the Terrain editor view.

Pyramid: Defines whether a pyramid of map textures is created for the terrain area. When 

enabled ( On ) the Max Height and 3D Levels parameters are enabled.

Max Height: Defines the number of textures that are created.
3D Levels: Defines the number of terrain objects that are created.

Blend Textures: Defines whether the edges of the maps are soft, blending into the larger 

map of the pyramid. When enabled ( On ), the edges are softened and the Blend 

Amount parameter is enabled.
Blend Amount: Defines the amount of softness added to the map edges.

Rebuild Pyramid: Builds the pyramid levels.

Note: The Globe and the Globe Radius parameters are disabled if Use Base Map is 

enabled ( On ).




Plug-ins User Guide -  5.0

Copyright © 2022  Vizrt Page  632

•

•

•

•
•

•

•

•

•

•

•

Advanced
Sampling Resolution: Defines the number of points used to calculate the terrain. The higher 

the sampling resolution, the less detail shown. When Pyramid mode is enabled ( On ), this 

parameter is disabled.
Use Base Map: Defines the geographical referencing of the terrain. If Use Base Map is 

enabled ( On ), the terrain moves to its geographic location on the base map, and the Base 

Container parameter is enabled.
Base Container: Uses the first map above the C3D Terrain container in the hierarchy as 

the base map if empty and Use Base Map is set to  On . To use a specific map as the 

base map, drag a map container to the Base Container place holder. If Use Base Map is 

set to  Off , the Globe parameter is enabled and the terrain is drawn as part of a 

globe. Set the Globe Radius to modify the terrain size and curve.
Wireframe: Displays the terrain as wireframe.
Sides Smoothing: Draws the edges of the terrain as flat lines (height is zero) when 

enabled ( On ). This option is useful when using the terrain object over the base map. When 

enabled ( On ), additional parameters are enabled:

Sides Smoothing Factor: Defines the width of the area, close to the edges, that is 
interpolated to create the smooth transition from terrain info to a flat edge.
Uniform Smoothing: Applies smoothing for all sides. Enabling Uniform smoothing 

( On ), sets smoothing for all sides, and hides the individual parameters. Available 

individual parameters are; Left, Right, Top and Bottom smoothing.
Texture Compression: Sets the compression level for the texture (DTX5 is the highest 
compression level; hence, less texture quality).
Terrain Status: Displays the terrain object status. If the terrain object was rebuilt 
successfully, the indicator displays OK, otherwise, the indicator displays Not Built.

Buttons
Rebuild: Forces a rebuild of the geometry, which is necessary when changing parameters 
that cannot be updated in real time.
Freeze Terrain: Saves the terrain image and data as Viz images for faster loading and for 
archiving.

Note: The parameter Rebuild Pyramid is enabled only if Pyramid is enabled ( On ) and 

it is visible in all tabs.
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7.3.11 GeoChart

The GeoChart plug-in represents geo-located values as 3D bars on a map. The data format can be 
a grid of geo positions (locations with constant distances from one another) or a list of 
coordinates. In addition, data may be split by timeframes and the plug-in is able to animate the 
data chart throughout the frames.

In order to use GeoChart, it should be put beneath the geo reference and load data (see Supported 
Formats). GeoChart adds the GeoChart Shader plug-in to the container automatically.

GeoChart Properties

General
Load Data: Selects the data file to be loaded.
Frame Number: Allows selecting the desired timeframe with this control when data comes in 
frames (see Supported Formats).
Please note that although it is possible to animate data through the Frame Number 
parameter it is not recommended because when the frame is switched the data is read from 
the hard disk such that such an animation is more performance consuming. Moreover there 
is no interpolation between frames such that the animation jumps from timeframe to 
timeframe. Use Animation Timeline instead.
Animation Mode: Analyzes the whole frame sequence and builds an animation if the data 
has timeframes. The data is interpolated smoothly between the frames such that the 
animation looks smooth.
Animation Timeline: Animates data through timeframes when an animation is built.
Animation Buffer Size: Defines the size of the memory buffer in which the created animation 
is stored. If the buffer size is less than that required to build the animation from all the 
available frames, then not all of the frames are included (You can check the total available 
frames by dragging the Frame Number parameter to the right and seeing the largest frame 
shown, and the frames included in the animation by dragging the Animation Timeline 
parameters to the far right).
Bar Type: Defines the geometry of the bar. Please note that Cylinder geometry is the most 
performance consuming while Prism is the lightest.
Bevel Bars: Bevels bars edges.
Bar Height: Scales the height of the bars.
Bar Width: Scales the width of the bars.
Bar Length: Alters bar’s length starting from the bottom.

Note: This plug-in is located in: Plugins -> Geometry plug-ins -> Maps_Adv
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Mask Source: Clips data to a specific region such that only bars inside the region are seen. 
For this purpose a mask image is required. You can drag the image into the Mask rectangle 
in the Image option or specify a container with a mask image in the Container option. 
See GeoChart.
Rebuild: Reloads the parameter values after a change. Only three parameters of the 
GeoChart plug-in can be changed on the fly: Bar Height, Bar Width and Bar Length. Altering 
other parameters requires a Rebuild.

Color
Logarithmic Color: Applies logarithmic scale to a color transform. This may be used when 
the data has dramatic differences between low and high values (in such cases the high 
values are red by default and all the low values are blue). Logarithmic scale makes this 
difference less dramatic, such that more in-between colors appear on lower values. An 
example of such data may be world population density. In large cities this value is 
considerably higher than in its surroundings, making it difficult to see less dramatic 
differences in low population areas.
Set Input Range: Constrains input range to a specified Input Minimum and Input 
Maximum value. All values below the minimum are interpreted as lowest possible bar height 
(zero by default) and all values higher than the maximum are interpreted as a maximum bar 
height. Note that when Set Input Range is pressed the actual minimum and maximum data 
values from the loaded data are seen.
Colors: Defines the color map by choosing colors and a number of in-between color ramp 
stages.
Color Image: Uses an image to define the color map. The image must be dragged to this 
control. An example of an image defining color map:

Posterization: Enables a continuous color map to be split into a desired number of discreet 
colors.

Advanced
Bar Response: Defines which property of the bar is affected by the value it represents.
Logarithmic Data: Puts the values that the bars represent on the logarithmic scale. This gives 
a better indication of differences between low values, and makes the difference between low 
and high values less dramatic. May be useful in cases where there is a large difference 
between low and high values. (e.g. world population density). Consider using this option in 
combination with the Logarithmic Color option under the GeoChart tab.
Data Simplification: Resamples the data and create different resolution levels to show lower 
resolution from farther distance. Moreover, data is spit into tiles by a culling mechanism. 
The data file that is being loaded to a plug-in may contain a huge amount of data and can 
become very performance intensive during rendering. This parameter defines how may 
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resolution levels are created out of the original data, and therefore effects loading time and 
the animation built process.
Fix To Resolution Level: Uses a fixed resolution level, selected by the Resolution 
Level parameter. In some cases you would not like the data to be resampled, since this 
means a loss of some information. A zero value means that raw data is used. Raw data is not 
resampled and not split to tiles.
Invert Output: Gives maximum values the lowest bar heights and vice versa.
Output Minimum: Defines the height of the bar representing the minimum found value.
Output Maximum: Defines the height of the bar representing the maximum found value.
Use Input Range: Defines the input range such that values lower than Input Minimum are 
considered as having the Input Minimum value, and values higher than Input Maximum are 
considered as having the Input Maximum value. This may be useful when focusing on a 
specific range in values.
Clip Data: Enables clipping the bars representing values lower or higher than defined in 

the Clip Bottom and Clip Top parameters. Note that when this button is switched to On , the 

Clip Bottom and Clip Top controls appear with values corresponding to the actual minimum 
and maximum found values in the data.

Supported Formats
The following formats are supported:

ASC File
Viz Weather Data Format
GeoChart

ASC File
In the *.asc format, the ascii file represents a grid of values in defined geographic range, defining 
the number of rows and columns of such data. For example, the following shows a part of a file 
showing a grid of world values:

ncols 360 
nrows 180 
xllcorner     -180.0
yllcorner     -90.0
cellsize      1.000000000000 
NODATA_value  -9999 
-9999 -9999 -9999 0.1252774 0.1192886 …

Note: Unlike using input range, the clipped bars are not seen at all rather than just 
representing minimum and maximum values defined in clipping.
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Viz Weather Data Format
The data is contained in one *.ini file and a corresponding list of binary files representing each 
timeframe. This data format enables the creation of an animation through timeframes. The .ini file 
defines what to expect from the binaries, including the region, projection and resolution (distance 
between samples of a grid data). The binaries are a list of values corresponding to one timeframe 
in float precision. Example of *.ini file:

[Grid] 
ModelType=GFS 
ModelName=GFS 
DataName=Temperature 
DataType=TEMPERATURE 
FileType=BINARY 
FromTime=201204102100 
ToTime=201204132100 
TimeStep=180 
Region=-180.000000/180.000000/-90.000000/90.000000 
Resolution=1 
Compression=UNCOMPRESSED 
[Projection] 
Type=UNPROJECTED 
[Files] 
File0=grid_0.b 
File1=grid_1.b 
File2=grid_2.b 
[Times] 
Time0=201204102100 
Time1=201204110000 
Time2=201204110300 
[Mins,Maxs] 
Vals0=-64.059998,37.739994 
Vals1=-63.859997,35.239994 
Vals2=-64.260010,36.139988

TAB File
The *.tab format is used for non-grid type data. It contains a list of data samples defining the date, 
hour, coordinate and value of each. The first time such data is read, it is processed such that all 
the samples corresponding to the same hour represent one timeframe, and the processed data 
is saved as a cache (in the same folder where the *.tab file is located) containing a *.bin header file 
and numerous *.dat files each corresponding to one frame. (The filenames of *.dat files define the 
date and hour they represent). For example:

2013-06-29 00 -90.087890625 179.912109375 112 
2013-06-29 00 -41.30859375 174.7265625 1 
2013-06-29 01 -40.95703125 174.814453125 1 
2013-06-29 01 -39.0234375 -68.115234375 2 
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2013-06-29 01 -38.759765625 -72.685546875 1 
2013-06-29 02 -38.49609375 -63.6328125 1 
2013-06-29 02 -38.232421875 144.31640625 7 
2013-06-29 02 -37.96875 145.107421875 1 
2013-06-29 02 -37.880859375 144.931640625 32

Creating Mask Images
A mask image is created with the help of the CWMClient plug-in.

The image should correspond exactly to a georeference on which GeoChart is placed, so the 
basemap region must be defined in the CWM plug-in. In the case when Atlas is used as 
georeference, put it beneath the CWM so that it corresponds exactly.

Go to the CWM plug-in defining the georeference and change the Texture Compression

parameter to None . You can find it under the Texture tab.

Open Viz World Map Editor and select the desired region.
Put the Map Layers Control plug-in on a container with CWM (the georeference).

In the Map Layers Control plug-in, switch Control to Enable  and deselect all of the options 

except the Selected Regions, and press Refresh Map.
Go to CWM Client’s Miscellaneous tab and press Freeze.
Drag the resulting image from the container to the image pool. You can now use it as a 
mask for the selected region. You can unfreeze the CWM, remove Map Layers Control and 
change back the texture compression, but be careful not to change the size and range of the 
georeference map.

Examples

Example Description

Weather precipitation data.

Weather precipitation data clipped to a region.
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Example Description

Social TV scene showing population of a particular word in 
Twitter.

Weather precipitation data on the globe.

World temperature values.

7.3.12 GeoImage

The GeoImage plug-in enables geographic referencing options. The plug-in is used as a base 
object with maps. GeoImage is short for Geographical Reference Image.

The plug-in has three views:

GeoImage Properties
Basic
Pyramid
Advanced

Note: This plug-in is located in: Plugins -> Geometry plug-ins -> Maps
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GeoImage Properties

Basic
Use Base Map: Defines the geographical referencing of the GeoImage. If Use Base Map is 

enabled ( On ), the GeoImage moves to its geographic location on the base map and resizes 

accordingly.

Map Size: Sets the size of the GeoImage geometry if Use Base Map is set to  Off .

Tessellation: Changes the number of triangles of the rendered filecard to increase the visual 
quality.

Base Container: Uses the first geo-referenced map above the GeoImage container in the 
hierarchy as the base map if empty. To use a specific map as the base map, drag a map 
container to the Base Container place holder.
Delta Z: Sets a Z offset for the GeoImage geometry.
Map Status: Displays the status of the imagery and whether the imagery contains geo-
referencing.
Apply Fade Plugin: Applies a Fade Texture plug-in to the container when clicked.

Pyramid
Pyramid: Uses local parameters when to set to None or Local. When set to Global, it uses the 
parameters as defined in the HopsManager.
Map Style: Defines the map style to be used for the pyramid maps:

Source: Uses the top CWMClient container (Map Tiler) style selection when creating the 
pyramid maps.
Target: Uses the hop CWMClient style selection when creating the pyramid maps.
Split: Splits the pyramid layers style, based on image latitude and longitude size. If the 
image size is smaller then the threshold the target style is used, if larger then the 
source style is used. Additionally, it is possible to turn on the color correction option 
in Pyramid Control which color corrects the target image to match the source images. 
Set the Satellite Threshold (deg).

Max Pyramid Height: Defines the maximum number of maps that are created in the pyramid. 
The optimal number of pyramid maps is calculated by the Map Pyramid plug-in. If the 
optimal number exceeds the Max Pyramid Height value, then the plug-in generates the 
maximum number defined.
Pyramid Factor: Calculates the number of maps required defining the size factor between 
the maps of the pyramid.
Pyramid Steps: Defines how the map coverage area grows from pyramid to pyramid:

Equal: The size factor is based on map pyramid height, pyramid factor and the 
resolution difference between the base map and the final map. The actual number 

Note: The number of triangles affect the performance of the system.
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might be different than the pyramid factor. The number of levels might also be 
smaller than the max pyramid height
Constant: Uses the value of the pyramid factor as is, with the value of max pyramid 
height.

Create Hole: Creates a hole on each pyramid tile.
Image Aspect: Calculates the closest power of two size, based on the selected image size of 
the CWMClient plug-in texture size. Target uses exactly the same size as 
the CWMClient plug-in texture size.
Note: It is recommended to use this setting to improve performance.
Apply Fade: Defines whether the maps used in the pyramid uses soft edges. Available 
options are Off, Target and Pyramid.

Off: Does not use soft edges. The transition between the maps is visible (the maps 
have sharp edges).
Target: Sets the last map (target) to have soft edges only.
Pyramid: Sets all maps in the pyramid to have soft edges.

Fade Range: Sets the fade level (the area of the image that the fade is applied to) when 
the Apply Fade parameter is used.
Texture Compression: Selects one of the required compression modes for the images.
Hide Lower Resolution: Defines whether the map created by the CWMClient plug-in, located 
on the Map Pyramid container, is turned off when the texture resolution of that map is lower 

than the Globe or GeoImage map tiles resolution. If it is enabled ( On ), the maps with lower 

resolution is turned off automatically by the Map Pyramid plug-in. If it is disabled ( Off ), the 

Map Pyramid does not turn off the low resolution maps.
Map Status: Determines the status of the map.

Advanced
When the Use Base Map option on the Basic tab is turned on, the Advanced tab displays 
parameters for cropping the imagery applied on this container.

Crop Mode: Defines whether the GeoImage is cropped:
None: Does not crop the map.
Manual: Sets the crop values using manual values for the map: West and East set the 
Longitude value for the western and eastern edge of the GeoImage 
map. North and South and set the Latitude value for the northern and southern edge 
of the GeoImage map.
Base Map: Crops the GeoImage according to the base map, that is, if the GeoImage 
exceeds the base map edges, it is cropped accordingly.

7.3.13 Globe
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The Globe plug-in enables geographic referencing options over a globe. The plug-in is used as a 
base object with maps. The globe object geographically references the map at the correct location 
over the globe.

This page contains information on the following topics:

Globe Properties
Basic
Pyramid
Advanced

Buttons

Globe Properties

Basic
Tessellation: Defines the number of polygons used to create the Globe geometry.
Radius: Defines the radius of the globe.
Map Status: Reports if the map was loaded as expected (Ok), geographic referencing of the 
map, and so on.

Pyramid
Pyramid: Uses local parameters when to set to None or Local. When set to Global, it uses the 
parameters as defined in the Hops Manager.
Map Style: Defines the map style to be used for the pyramid maps:

Source: Uses the top CWMClient container (Map Tiler) style selection when creating the 
pyramid maps.
Target: Uses the hop CWMClient style selection when creating the pyramid maps.

Note: This plug-in is located in: Plugins -> Geometry plug-ins -> Maps



Plug-ins User Guide -  5.0

Copyright © 2022  Vizrt Page  642

•

•

•

•
•

•

•
•

•

•

•
•

•

•
•

•

•

Split: Splits the pyramid layers style, based on image latitude and longitude size. If the 
image size is smaller then the threshold the target style is used, if larger then the 
source style is used. Additionally, it is possible to turn on the color correction option 
in Pyramid Control which color corrects the target image to match the source images. 
Set the Satellite Threshold (deg).

Max Pyramid Height: Defines the maximum number of maps that are created in the pyramid. 
The optimal number of pyramid maps is calculated by the Map Pyramid plug-in. If the 
optimal number exceeds the Max Pyramid Height value, then the plug-in generates the 
maximum number defined.
Pyramid Factor: Calculates the number of maps required defining the size factor between 
the maps of the pyramid.
Pyramid Steps: Defines how the map coverage area grows from pyramid to pyramid:

Equal: The size factor is based on map pyramid height, pyramid factor and the 
resolution difference between the base map and the final map. The actual number 
might be different than the pyramid factor. The number of levels might also be 
smaller than the max pyramid height
Constant: Uses the value of the pyramid factor as is, with the value of max pyramid 
height.

Create Hole: Creates a hole on each pyramid tile.
Image Aspect: Calculates the closest power of two size, based on the selected image size of 
the CWMClient plug-in texture size. Target uses exactly the same size as the 
CWMClient plug-in texture size.

Apply Fade: Defines whether the maps used in the pyramid uses soft edges. Available 
options are Off, Target and Pyramid.

Off: Does not use soft edges. The transition between the maps is visible (the maps 
have sharp edges).
Target: Sets the last map (target) to have soft edges only.
Pyramid: Sets all maps in the pyramid to have soft edges.

Fade Range: Sets the fade level (the area of the image that the fade is applied to) when the 
Apply Fade parameter is used.
Texture Compression: Selects one of the required compression modes for the images.
Hide Lower Resolution: Defines whether the map created by the CWMClient plug-in, located 
on the Map Pyramid container, is turned off when the texture resolution of that map is lower 

than the Globe or GeoImage map tiles resolution. If it is enabled ( On ), the maps with lower 

resolution is turned off automatically by the Map Pyramid plug-in. If it is disabled ( Off ), the 

Map Pyramid does not turn off the low resolution maps.
Map Status: Determines the status of the map.

Advanced
Sub Tessellation: Divides each of the Globe flat areas, to increase texture coordinates and 
improve the way the textures look on a globe.

Note: It is recommended to use this setting to improve performance.



Plug-ins User Guide -  5.0

Copyright © 2022  Vizrt Page  643

•
•

•

•
•

•

•

•

•

•

•

•

•

•
•

Texture Mapping: Defines how the texture (map) is mapped over the Globe:
Absolute: Crops the globe object according to the values set in the West, East, South 
and North parameters.
Relative: Crops the globe object according to the geographical properties of the map 
applied to the Globe.
GeoRef: Maps the map over the globe object according to its geographical properties.

West/East: Sets the Longitude value for the western/eastern edge of the Globe. The globe 
object is cropped at that Longitude.
South/North: Sets the Latitude value for the southern/northern edge of the Globe. The globe 
object is cropped at that Latitude.
Enable Hole: Saves performance when building pyramids using globe objects. When the 
globe objects for the pyramid layers are created, a hole is created where the higher 
resolution maps are, to avoid rendering multiple pixel layers (and to save performance). It 
can be used manually to create a hole in a globe object by setting values which are in the 

area of the map in use. When enabled ( On ) additional parameters are enabled:

Hole West (From lon): Defines an inner Longitude in the map area where the hole 
begins (West side).
Hole East (To lon): Defines an inner Longitude in the map area where the hole begins 
(East side).
Hole South (From lat): Defines an inner Latitude in the map area where the hole begins 
(South side).
Hole North (To lat): Defines an inner Latitude in the map area where the hole begins 
(North side).

Avoid Radius Cheat: Contains a Radius setting that can be avoided if required.

Buttons
Build Pyramid: Rebuilds the pyramids. 

If Pyramid is set to None in the Pyramid tab, then the available buttons are:

Apply Fade Plugin: Applies a Fade Texture plug-in to the container when clicked.
Face Z Axis: Rotates and centers the globe object facing the Z-axis. This button can be used 
when not a full globe is rendered (for example only Asia). Do not use this feature with 
the Navigator plug-in, as it assumes no rotation.

7.3.14 Label and Go

The Label and Go plug-in draws multiple labels on screen. It is mainly used for interactive scenes, 
but it can also be used for regular scene design. Traditionally, label drawing has been done by 

Note: This is a very advanced feature which should be used with caution.
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repeatedly copying a design. This method gives you full control over the look of the label, but 
limits the number of labels which can be used as every label has at least two containers. Also, if 
the number of labels exceed 500 containers, it may cause a performance issue.

Label and Go gives fewer options for design, but since all design is done for one container 
performance is still good using 70,000 labels.

This page contains information on the following topics and procedures:

Label and Go Properties
Global
Design

Caption
Background
Pointer

Communication
Shared Memory Communication with Label and Go
Example

Working with Label and Go
To Create a Label and Go Scene
To Use Viz Config for Interactive Communication
Notes

Label and Go Properties

Global
Data source: Defines the type of source the plug-in should render. Label and Go supports 
the following data sources:

Auto labels: Uses labels of the entire world.
CWM labels: Uses labels created by the CWMClient plug-in.
Streets: Uses street labels (created by the 3D Road Manager or CWMClient plug-in).
Other: Uses other labels. Currently Viz World supports the KML plug-in.
Local file: Determines the shape file that contains names and geo positions.
Shields: Allows the designer to set designs for road types such as highways, 
interstates, etc., and to use an iconic representation of the street instead of the street 
name. This is based on street data and currently only supports Tom-Tom data for the 
USA. During import of the street data, a CSV file is created 
under plugin\data\maps\DesignMappings, which contains all the types of shields 
found in the data. The Mapping column in this file can be edited to map the shield 
types to specific user designs, and then the Label and Go plug-in is used to read the 
file.

Labels Draw Style

Note: This plug-in is located in: Plugins -> Geometry plug-ins -> Maps
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On Map: Places the labels on the same camera as the navigator camera.
Overlay: Places the labels on the second camera (normally front layer).

Alpha fade time: Determines the amount of time (fields) for new labels to appear or 
disappear.
Max number of labels: Determines the maximum number of label to render including all the 
labels so far (other Label and Go are taken into account as well).
Culling bounding box: Scales the real bounding box to avoid too many labels on screen.
Line spacing: Determines line spacing when using two lines.

Design
Font: Sets the font used by all labels.
Label Type: Selects from the default types of labels when using auto-labels on Data Source 
(Country, Capital, etc). Using POI-1, POI-2 and so on, allows definition of the name of the 
style, for example: Earthquake, Explosion, etc.
Render: Renders the selected label design type (e.g. Country, POI-1 and so on) when set 

to  On .

View Distance: Sets the distance from where the label style should be visible.
Set Distance: Sets the View Distance property based on the current distance of the map.
Priority: Overwrites the default priority which is based on type and town size.
Caption/Background/Pointer: The Caption, Background and Pointer properties are different 
for each type of design, and are described below.
Buttons

All Off: Turns off all labels, except the one currently being edited.
All On: Turns on all labels.
Copy setting from type above/below: Copies the settings from the label type above/
below.

Outline Quality: Determines the quality when background is set to outline.
Outline Quality Mask: Selects the mask to use so it does not interfere with the scene regular 
makes.
Debug: Draws a green rectangle around all/current labels. (useful to see the bounding box).

Caption

Caption
Hide: Displays only the pointer of each label.
Show: Displays both the pointer and the text of each label.

Text color: Sets the color of the text.
Text Size: Sets the size of the text. Text size influences all sizes.
Max size: Limits the size of the text on either X or X/Y axis when set to either Scale X or 
ScaleX/Y.
Max width: Sets the maximum width the text should take and scales the text either on X or 
XY based on the Max Size setting.
X/Y Offset: Offsets the text on X/Y from its latitude and longitude.
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Rotate: Rotates labels to follow the street when set to  On . When set to  Off  they are not 

rotated.

Background

Background: Defines the background type for the text (none/rectangle/image/outline).
Size: Sets the size of the background in relation to the text in percent (%).
Image: Sets a background image for the text.
Background color: Sets the background color.
Outline color: Sets the outline color.
Outline width: Sets the outline width.
Background Fixed Size, Background X, Background Y: Defines the X/Y size of the 
background when set to fixed size.

Pointer

Point: Sets the type of point.
Caption position: Sets the position of the label in relation to the point.
Point Color: Sets the color of the point.
Point Size: Sets the size of the point.
Point Distance (%): Sets the distance of the label in relation to the point in percent (%).

Point BG: Enables ( On ) or disables ( Off ) the Point BG properties.

Point BG Color: Sets the points background color.
Point BG Size (%): Sets the points background size in percent (%).

Communication
Interactive Mode: This property is here for backwards compatibility only. The recommended 
way is to use the MTButton plug-in instead. (For more information on MTButton, see the Viz 
Artist User Guide).
Shared Memory Type: Changes between Scene-, Global- and Distributed-Shared Memory.
Shared Memory Identifier: Sets the Shared Memory key name.
Set Data Pool: Enables the distribution of the data to a DataPool structure using the same 
name as the Shared Memory Identifier.

Shared Memory Communication with Label and Go
To send labels via shared memory to Label and Go, you need to send:

Id,Label,long,
lat style ( optional )

Each label must start with  id .

http://docs.vizrt.internal/viz-artist
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Example

dim Variable as string 
dim array as Array[string] 
\qMy data separated my new line 
dim data as String = GetParameterString("Data") 
data.Split("\n\r", array) 
\qDepending on label@Go setting 
Variable = "LABELANDGO_" 
Variable.Append("ADDLABELS")
Scene.Map[Variable] = array

Working with Label and Go

To Create a Label and Go Scene

Add the Atlas plug-in to your scene tree.
Add the Navigator plug-in to the same container as the Atlas plug-in.
Open the Navigator editor, click Miscellaneous and set Interactive Mode to Always.
Add a sub container to the GeoReferenceMap.
Add the Label and Go plug-in to the new container.

Click the Scene Editor’s E button. E enables the handling of interactive script/plug-in events. 
Interactive scripts and plug-ins are those related to mouse or keyboard actions.
Click the scene and zoom in and out with your mouse to see the labels appear.
Open the Label and Go editor to test the settings.
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To Use Viz Config for Interactive Communication
When using MTButton for interactivity together with Label and Go:

The input method from Viz Config is used (e.g. Win 7, PPI, TUIO, mouse).
The clicked label on the map is published to shared memory.

Notes
All data sources may select from ten different designs.
There are currently no limits as to how many Label and Go plug-ins can be used by one 
scene.
Label collision is calculated and taken into account. Other types of labels (e.g. design using 
the Street Labels plug-in) are not taken into account.
Label and Go currently works on flat maps only.

7.3.15 MapScale

The MapScale plug-in displays the scale factor of the map.

MapScale Properties

General
Geo Source: Bases the scale or zoom factor data on the navigator plug-in, when set to 
Navigator. When set to Map, the values are based on the defined Map container.
Screen Size (%): Defines the screen geometry size, measured as percentage of the screen on 
the X axis.
Height (%):  Defines the height geometry, measured as percentage of the screen on the Y 
axis.
Units: Displays units in Kilometers or Miles.
Labeling Mode: The Large/Small Limps options try to find the closest round number in the 
visible range. While gradually zooming in or out, the rectangle containing the map scale is 
scaled according to a visible number. When the range limit is reached, the number changes 
and the rectangle jumps to a new range. This may result in an unpleasant visual effect, so 

Note: For more information on MTButton, see the Viz Artist User Guide.

Note: This plug-in is located in: Plugins -> Geometry plug-ins -> Maps

http://docs.vizrt.internal/viz-artist


Plug-ins User Guide -  5.0

Copyright © 2022  Vizrt Page  649

•

•

•
•

•

•
•

•

•

•
•

•

•

•

the Continuous mode is used where the rectangle showing the scale remains unchanged and 
the numbers showing the range change continuously without jumps.

Large Limps: Changes the text display when the scale factor changes significantly (e.g. 
1000KM, and next limp 500KM).
Small Limps: Changes the text display when the scale factor is a smaller change (e.g. 
1000KM, and next limp 900KM).
Continuous: Provides an exact number of the coverage area of the geometry.
Ruler: Combines Continuous and Limps modes. While the total width of the rectangle 
remains unchanged, notches are added showing the rounded range.

Shape: Determines the shape of the edges: Rectangular edges, Rounded Edges or Notched 
left and right. When using Notched, an additional parameter is visible for the direction for 
the notches (Up/Down/Both and the height and width of each notch).
Expansion:
Outline: Toggles the outline of the geometry.

Outline Width: Defines the width of the outline when outline is enabled ( On ).

Outline Color: Defines the color of the outline when outline is enabled ( On ).

Advanced
Camera: Determines the camera for placing the geometry.
Centimeter/Meter/Kilometers/Feet/Miles Label: Defines the suffix for each unit.

7.3.16 Pyramid Control

The Pyramid Control plug-in sorts overlapped layers of the pyramids in the scene such that tiles 
with higher resolution are not hidden by tiles with lower resolution.

Pyramid Control Properties
Fade Tiles: Applies a fade animation to each tile level based on the distance to the hop when 
enabled.
Start/End Fade (%): Sets the distance (percentage) to the hop for starting and ending the fade 
when Fade Tiles is enabled.
Bind to Hop: Synchronizes the visibility of pyramids based on the hop that they belong to 
when enabled. When disabled (default), the pyramids are shown based on the highest 
resolution available throughout the entire scene.

Note: The plug-in must be located in the hierarchy of the Map Tiler plug-in.

Note: This plug-in is located in: Plugins -> Geometry plug-ins -> Maps



Plug-ins User Guide -  5.0

Copyright © 2022  Vizrt Page  650

•

•

•

•

•

•

•
•

•
•
•
•
•

Pyramid Fade Start (%): Determines the duration that the pyramids are fully visible, in 
percentage of total hop time.
Target Fade Start (%): Determines the duration that the target image are fully visible, in 
percentage of total hop time.
Pyramid Fade Length (%): Determines the time taken for pyramids to fade, in percentage of 
total hop time.
Target Fade Length (%): Determines the time taken for target to fade, in percentage of total 
hop time.
RenderTile: Selects which pyramid image to display, from all the pyramid levels. Used mainly 
for debugging the graphics.
Wire Frame: Shows the pyramids in wire frame mode, to help understand the coverage of the 
pyramids. Used mainly for debugging the graphics.
Show Bounding Boxes: Renders the bounding box of the pyramids.
Refresh All Pyramids (button): Forces a refresh of all pyramids for all hops in the scene.

7.3.17 Shadow Agent

The Shadow Agent plug-in is an agent for the Shadows parameters covered by the scene plug-
in Label Manager.

Shadow Agent Properties
Render With Camera: Defines for which camera shadows apply.

All: Renders shadows on all cameras (Compatible with previous versions).
Label: Renders shadows only for the defined off screen labels camera.
Map: Renders shadows only for the defined map camera.
Shadow: Renders shadows only for the defined shadows camera, as defined in the 
Label Manager plug-in (Shadows tab).

7.3.18 WindFlows

Note: When using Control MultiHop, the Bind To Hop Property is set to Enabled by 
default.



Note: This plug-in is located in: Plugins -> Geometry plug-ins -> Maps_Adv
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The WindFlows plug-in visualizes geo-located winds by representing it as running flows of various 
length and colors on top of a map. The flow direction corresponds to the wind direction. The plug-
in can load multiple time frames of wind velocities and directions, and produce a smooth 
animation over time.

This section contains the following information:

WindFlows Properties
General
Color
Advanced

Appendix A - Showing Winds on Top of Color Heat Map
Appendix B - Example of Masking to Desired Region

Note: This plug-in is located in: Plugins -> Geometry plug-ins -> Maps_Adv
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WindFlows Properties

General
Data Path: Specifies data files or relevant data (comes in u and v components). This should 
be a weather grid model data of type Wind. An hours folder of windU or windV component 
should be specified as input. 

Example:  W:\DemoData\WindSpeed\EC025\windU\contourdata\hours
Start Time / End Time: Loads only relevant data for that time frame if time frame is 
specified.
Frame Number: Selects time frame of data. 
Frame Interpolation Mode: Loads all available frames of animation to produce a smooth 
animation between time frames. 

Timeline (frames): Control time progress between frames while in interpolation mode. Only 
this parameter and not Frame Number should be animated.
Flows: Determines the number of flows representing wind. Flows are randomly distributed 
across the canvas.
Line Width: Defines width of strokes. Width is specified in pixels of canvas, changing canvas 
size causes flows to look as if their width was changed.
Max Age: Defines maximum age in frames of the flows. The age (length) of each stroke is a 
random quantity; however, flows presented in area of strong winds move faster and those 
appear longer. 
Speed: Controls general speed level of flows, although faster winds always result in faster 
flows. 
Fade Rate (frames): Determines the number of frames it takes to completely fade out the 
stroke. 
Canvas Resolution: Renders flows to a canvas and then this canvas is applied to map like a 
texture. This parameter allows changing the size of the canvas. Large canvases are useful 
when small zoom-ins are required without losing the resolution. Flows widths, however, are 
affected by canvas size. When using Dynamic mode, there is no reason to go 
beyond Normal canvas size.

Normal: Corresponds to HD resolution (1920X1080). 
High: Corresponds to 4K (3840x2160).
Ultra High: Corresponds to 7680x4320. 

Color
Color Source: Defines whether color presets are taken from image or a manual preset.
Color Presets: Predefines color presets to start with. Every change sets the position to 
custom.
Colors: Defines number of colors to be used in color-map, as well as their values.

The Data Buffer Size [mb] parameter under the Advanced options limits the number 
of time frames that is being loaded to animation according to desired size. 
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Color Image: Uses an image to define the color map. Image should be dragged to this 
control.  An example of an image defining color map: 

Posterization: Splits a continuous color map to a desired number of discreet colors.
Color Levels: Defines number of desired levels for posterization.

Use Flows Alpha: Allows wind strength to affect flow transparency when set to  On . 

Advanced
Wireframe: Displays a wireframe of the canvas geometry (may be useful for globe 
geography).
Data Buffer Size (mb): Defines limit for the amount of data to be loaded to the plug-in, used 
to limit number of frames in animation.
Invert Depth Test: Masks the desired area and shows winds only above that area. A masking 
image should be put on top of wind flows and this option enabled. See example of the result 
in WindFlows. 
Canvas Positioning: Defines canvas coverage behavior. Flows are actually rendered to 
canvas, and then this canvas is placed on top of geo geometry. 

Dynamic: Calculates canvas size in each frame. Canvas is of the size of the visible 
geographic area. 
Static: Covers basemap/data range and stays in place. As a result, if you zoom-in in 
static mode the resolution of flows deteriorates. 
Use Window: Limits the visualization area to a specific geographic region 
manually defined by west/east/north/south borders. Enabled only in Static mode.

Autodetect Max Value: Detects maximum value of loaded data and normalizes the 

visualization accordingly when set to On . When set to Off , it enables manual setting of the 

maximum value for normalization. All data larger than maximum defined value obtains 
maximum value for visualization (maximum alpha and color representing strongest wind).
Clip Data: Discards flows larger or smaller of specified clipping values.
Clip Bottom: Discards flows smaller of specified clipping value.
Clip Top:Discards flows larger of specified clipping value.
Adaptive Density: Reduces the number of flows dynamically according to the zoom 

level such that there are fewer flows as you zoom-in when set to On .

Density Upper Bound/Density Lower Bound: Defines percentage of flows (out of the number 
defined in WindFlows tab) for the current visible geographic range (When value is set, the 
visible geo area at that moment is considered). Any zoom-in level below the one saved for 
the lower bound or zoom-out above the one saved for the upper bound has lower/upper 
amount of flows correspondingly. In between, the number is interpolated. 
Render On Move: Defines behavior of the rendering during movement in dynamic canvas 
positioning mode. Since it is problematic to move canvas with already rendered data 
dynamically, add new data and still look correct a number of behaviors were defined: 
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None: Shows nothing during movement.
Defer: Preserves the previous canvas state until movement stops.
One Frame: Renders only one frame of flows, with the canvas being reset after each 
frame.
Continuous: Produces a spread-blur effect. 

Smooth: Defines smoothing quality of the flows. Be careful with Multisample HQ, as it can be 
very expensive performance-wise.

Appendix A - Showing Winds on Top of Color Heat Map
It is possible to show flows on top of Color heat-map representing wind strength. The IsoGrid 
plug-in is used to show heat-map and WindFlows shows flows on top of it. Some change is 
required in configuration of the fetch to produce another folder with wind data representing wind 
strength (instead of just one vector component). This folder is called windS and it should be 
loaded to IsoGrid in order to show the heat map.

Open WD Administration Tool, go to Providers Info and add the following line for each provider:

<entry name="isoScriptOutput">contours.log &amp; WindSpeed.py --dataset 
&quot;PATH_TO_DATA_FOLDER&quot; -R_MODEL_GEO_BOUNDS –I_MODEL_RESOLUTION</entry>

PATH_TO_DATA_FOLDER  is a path to folder containing WindU and WindV folders.

MODEL_GEO_BOUNDS  are the bounds found in config.ini file of each model under ‘Region’ 

section.

MODEL_RESOLUTION  – resolution of data in degrees, also found in config.ini file. 

Example of such a line for GFSX model (0.5 degrees resolution):

<entry name="isoScriptOutput">contours.log &amp; WindSpeed.py --dataset &quot;C:
\Program Files (x86)\vizrt\vizWeather2\SharedData\FetchData\Wind\GFSX&quot; 
-R-180.000000/180.000000/-90.000000/90.000000 -I0.5</entry>

As mentioned above, after adding this line fetch application should fetch three folders for wind 
data – WindU, WindV and WindS representing strength.
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Appendix B - Example of Masking to Desired Region

Mask image is created with the help of CWM client plug-in. The image should correspond exactly 
to a georeference on which GeoChart is placed, so make sure the basemap region is defined in 
CWM plug-in (in a case when Atlas is used as georeference put it beneath the CWM to correspond 
exactly).

Go to CWM plug-in defining the georeference and change the Texture Compression

parameter to None . You can find it under the Texture tab.

Open Viz World Map Editor and select desired region.
Put the Map Layers Ctrl plug-in on a container with CWM (the georeference).

In the Map Layers Ctrl plug-in, switch Control to Enable  and deselect all options except the 

Selected Regions and press Refresh Map.
Go to CWM client's Miscellaneous tab and press Freeze.
Drag the result image from container to the image pool. You can now use it as a mask for 
the selected region. You can unfreeze the CWM, remove Map Layers Ctrl and change back 
texture compression, but be careful not to change the size and range of georeference map.

7.4 Container Plug-Ins
This chapter describes container plug-ins. The container plug-ins are found in five plug-in folders:

Maps: Contains standard plug-ins.
Maps-Adv: Contains advanced plug-ins.
Maps-Lab: Contains experimental plug-ins. Since these plug-ins are experimental and not 
supported, they are not documented here.
Maps-Man: Contains a set of Manager plug-ins used for batch creation of 3D Objects such as 
regions, borders, and so on.
Maps-Obs: Contains obsolete plug-ins, installed only for backward compatibility. These plug-
ins should not be used when designing new scenes. Since these plug-ins are obsolete and 
not supported, they are not documented here.
Tools: Contains tool plug-ins.
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See the following sections for more information:

3D Border Manager
3D Line Manager
3D Line Tracer
3D Map Telestrator
3D Map Telestrator Design
3D Region Manager
3D Roads Manager
Center Map
CWMClient
Focus On Map
GeoDataReader
Geo Text
Hop It
Hops Manager
Hop Sync
KML Reader
Label AddOn
Label and Go Assistant
Label It
LatLongGrid
Locator Control
Map Layers
Map Layers Control
Map Tiler
Map Zoom
Mouse2Memory
Mute
NavCom
NavFade
NavFinder
Navigator
NavScale
NavSlave
Place Finder
Publish To Design
Region To Texture
Trace It
World Position
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7.4.1 3D Border Manager

The 3D Border Manager plug-in creates 3D Border objects based on shape files. The plug-in uses 
a 3D Border design to create borders according to the defined settings.

3D Border Manager Properties
Design: Sets the 3D Border design container that is used for building lines. The design 
container should be built with a 3D Border object and a material. No special naming 
convention is required.
Target: Defines the container to be used as the parent container for the border containers:

Me: Builds 3D Border objects under the current container (holding the 3D Border 
Manager plug-in).
Next: Builds 3D Border Objects under the next container (next container in the tree 
and at the same level as the 3D Border Manager container).
Down: Builds 3D Border objects under the first child container.
Container: Builds 3D Border objects under the container dragged into 
the Target container place holder.

Target Container: Specifies the container that holds all the 3D Border objects.
Shape File: Defines a path to the shape file (.shp), containing the border definitions. Shape 
files are bought from vendors specialized in Geographic Information System (GIS) and holds 
the actual shape data; polygons, splines, and others.

Simplify Threshold: Sets the detail reduction factor for the shape borders.
Persistent Data: Defines whether the data is removed from Viz memory when the scene is 
closed or not. When enabled references are kept, and load time is quicker.
Border Type: Defines which border type associated with the created objects. If Advanced is 
selected, additional parameters are enabled allowing the configuration of border type 
according to the data associated with the shape file.

Borders Type: Specifies the column name that holds each border type. Country ID, 
Region ID, Sub Region ID and Coastline ID: Specifies the string in the database file 
(.dbf) that matches to each type (e.g. Country, Region and so on).

Clear and Build: Removes all child objects of the target container and rebuilds the objects, 
using the plug-in settings.
Clear Target Tree: Removes all child objects of the target container.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Maps_Man

Note: Shape files must be stored in individual folders.
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7.4.2 3D Line Manager

The 3D Line Manager plug-in controls and creates 3D Line objects. The plug-in uses a 3D 
Line design to create lines according to the defined settings. The plug-in allows you to build 3D 
Line in four different modes: Navigator, Command, from WME and from a Shape file.

3D Line Manager Properties
Selecting the Data Source defines how the 3D Line objects are created:

Navigator
Creates a 3D Line object using the hop locations defined in the Navigator plug-in. The line starts at 
the first hop location and end at the last hop location. Note that when using the Navigator as the 
data source, the 3D Line Manager should reside under the Navigator container.

Design: Sets the region design container that is used for building sub-regions. The design 
container should be built with a 3D Line object and a material. No special naming 
convention is required.
Target: Defines the container to be used as the parent container for the sub regions 
containers:

Me: Builds the 3D Line objects under the current container (holding the 3D Line 
Manager plug-in).
Next: Builds the 3D Line objects under the next container (next container in the tree 
and at the same level as the 3D Line Manager container).
Down: Builds the 3D Line objects under the first child container.
Container: Builds the 3D Line objects under the container dragged into 
the Target container place holder.

Simplify Threshold (m): Sets the detail reduction factor for the shape of the lines.
Spline: Determines how to display the spline.
Tessellation: Sets the degree of detail for use with spline.
Start Hop: Determines the starting point for the hop.
Number of Hops: Determines the number of hop points to use.
Rebuild: Forces a rebuild on the cache files generated for the selected shape file.

Command

Creates the 3D Line object from a list of Long/Lat pairs defined by the user, for example:  MyLine: 

0,0 0,50 30,30 .

Note: This plug-in is located in: Plugins -> Container plug-ins -> Maps_Man
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Design: Sets the region design container that is used for building sub-regions. The design 
container should be built with a 3D Line object and a material. No special naming 
convention is required.
Target: Defines the container to be used as the parent container for the sub regions 
containers:

Me: Builds the 3D Line objects under the current container (holding the 3D Line 
Manager plug-in).
Next: Builds the 3D Line objects under the next container (next container in the tree 
and at the same level as the 3D Line Manager container).
Down: Builds the 3D Line objects under the first child container.
Container: Builds the 3D Line objects under the container dragged into 
the Target container place holder.

Simplify Threshold (m): Sets the detail reduction factor for the shape of the lines.
Spline: Determines how to display the spline.
Tessellation: Sets the degree of detail for use with spline.
Rebuild: Forces a rebuild on the cache files generated for the selected shape file.

WME Labels
Allows you to build a line between locations chosen in Map Editor Classic (WME) as WME labels (no 
line is built if WME labels are not defined). Also, the WME source container must be specified and 
refresh should be applied by clicking the Refresh button in CWMClient (Rebuild button is disabled 
in this mode). The line between the labels starts and ends in the order they where added (as seen 
in WME’s Map Details list). The first label location is the label at the top of the list, and the last is 
at the bottom of the list. Rearrange the list to create a new order.

Design: Sets the region design container that is used for building sub-regions. The design 
container should be built with a 3D Line object and a material. No special naming 
convention is required.
Target: Defines the container to be used as the parent container for the sub regions 
containers:

Me: Builds the 3D Line objects under the current container (holding the 3D Line 
Manager plug-in).
Next: Builds the 3D Line objects under the next container (next container in the tree 
and at the same level as the 3D Line Manager container).
Down: Builds the 3D Line objects under the first child container.
Container: Builds the 3D Line objects under the container dragged into 
the Target container place holder.

Simplify Threshold (m): Sets the detail reduction factor for the shape of the lines.
Spline: Determines how to display the spline.
Tessellation: Sets the degree of detail for use with spline.
Set Navigator Hops: Enables the scene to do a hop animation between the lines.
Exclude Hops: Excludes the hop animation for the following labels; None, First, Last, or First 
and Last. Manual Shift allows you to define which destination is the starting point (limited to 
a selection of 30 destinations).
Set Hops Height: Determines the height of the hops.



Plug-ins User Guide -  5.0

Copyright © 2022  Vizrt Page  660

•

•

•

•

•
•

•

•
•

•

•
•
•
•
•
•

•

•
•

Shape File
Uses a shape file as data source.

Design: Sets the region design container that is used for building sub-regions. The design 
container should be built with a 3D Line object and a material. No special naming 
convention is required.
Target: Defines the container to be used as the parent container for the sub regions 
containers:

Me: Builds the 3D Line objects under the current container (holding the 3D Line 
Manager plug-in).
Next: Builds the 3D Line objects under the next container (next container in the tree 
and at the same level as the 3D Line Manager container).
Down: Builds the 3D Line objects under the first child container.
Container: Builds the 3D Line objects under the container dragged into 
the Target container place holder.

Shape File: Defines a path to the shape file (*.shp), containing the line definitions. Shape 
files are bought from vendors specialized in Geographic Information System (GIS) and holds 
the actual shape data; polygons, splines, and others. Note that shape files must be stored in 
individual folders.
Name Column: Determines the column to search for names in the shape file.
ID Column: Determines the column to search for IDs in the shape file.

Compare as: Compares line types as strings or numbers. Numbers allow for a range to 
be entered.

Line Type Column: Determines the column to search for line types in the shape file.
Line Types: Determines line type to use when importing shape files. 
Simplify Threshold (m): Sets the detail reduction factor for the shape of the lines.
Spline: Determines how to display the spline.
Tessellation: Sets the degree of detail for use with spline.
Rebuild: Forces a rebuild on the cache files generated for the selected shape file.

Flow and Routing
Defines the Simplify Threshold and FRC level for the selected data source. Simplify 
Threshold reduces the resolution of the data from the shape file selected. FRC level (High/
Medium/Low) sets the FRC level, for example, High would draw highways and major roads.

Shape File: Defines a path to the shape file (*.shp), containing the line definitions. Shape 
files are bought from vendors specialized in Geographic Information System (GIS) and holds 
the actual shape data; polygons, splines, and others. Note that shape files must be stored in 
individual folders.
Simplify Threshold (m): Sets the detail reduction factor for the shape of the lines.
Level Target: Container placeholder for selected level of roads.

Note: In WME Labels option, the 3DLineManager should be attached to the CWMClient 
plug-in container. The Labels in the CWMClient plug-in must be enabled.
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Motorway/Freeway, Major Road, Other Major Road, Secondary Road, Local Connecting Road, 
Local Road of High Importance: When enabled (On), the plugin draws roads rated according 
to the selection in the loaded roads data.
Rebuild: Forces a rebuild on the cache files generated for the selected shape file.
Build Hierarchy and Data: Builds base scene hierarchy for traffic flows scene type and 
generate needed cache data from the selected shape file.

7.4.3 3D Line Tracer

The 3D Line Tracer plug-in works in conjunction with the 3D Line Manager, it allows to trace lines, 
build Routes of one point or two points, when the Data Source is in Flow and Routing and you have 
the correct shape file (TomTom TMC Data).

3D Line Tracer Properties
Tracing

None: No tracing.
One Line: Traces one line. A mouse click selects a line.
Two Points: Traces two points. The first mouse click starts and the second mouse click 
ends. 
Continuous: Traces continuously. Hold down mouse button and drag.

Shortest Line Holder: Container holding 3D Line to show the shortest route.
Fastest Line Holder: Container holding 3D Line to show the fastest route.
Picking Threshold (px): Determines the distance (in pixels) from line for picking to capture.
Max Junctions: Determines the maximum number of junctions to pass when calculating 
shortest route before giving up (due to performance).
Set Data Pool: Sends output to DataPool.
Use Only TMC: Uses TomTom shape file data only.
Shared Memory Type: Selects the shared memory area to update. Click either None, Global, 
Scene, or Distributed.
Field Name Prefix: Determines the shared memory field name to use with DataPool.
Start Building Route: Starts building (and recording) a route with many clicks for better 
control on the selected route.
Pause Building Route: Pauses building (for example, to move the map) the route.
Continue Building Route:  Continues building the route.
End Building Route:  Stops building the route.
Rebuild from Saved Data:  Rebuilds the line form the data saved in the command box above.
Clear:  Clears the contents of the line tracer.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Maps_Adv
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Picking Active:  Specifies the place on the screen where can routes can be selected.  There 
are three options:

All:  Allows selecting routes anywhere on the screen.
Inside Rectangle:  Allows selecting routes anywhere inside the rectangle.
Outside Rectangle :  Allows selecting routes anywhere outside the rectangle.

How to Create a Scene Showing Flow and Routing
Create a base map using the Atlas plug-in, add a Navigator plug-in.

Add a 3D Line Manager to the Hierarchy. Set the Data Source to be Flow and Routing, Load 
the correct Shape File (TomTom TMC Data) and Click Build Flow Hierarchy, Viz builds the 
data for Routing.
After Building this adds three containers: Flow-Data, Flow-Draw and Routing-Lines.

Flow - Data: The 3DLine Tracer plug-in and the .VWBReader vmaps are added to the 
container. Underneath it adds three containers with three types of Roads: Low, Medium and 
High.

In the 3D Line Manager plug-in, you can set the types of Roads that enter in each group, you 
can change the Roads according to your selection.
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In the Flow-Draw container: This are the painters that draw the data. 

When there is no data, all the lines are in Group number 1 and has a light pink color.

How to Load the Traffic Data

In the .VWBReader vmaps plug-in, c hange the data type to  Custom , Load the VWB File  (file 

that is created with the Feedstreemer -this file is updated constantly with the traffic) and 
Click  Build. 
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It draws all the data:  Free flow  to  green,  Jam to  Yellow,  Heavy Jam to  Orange ... 

How to Trace the Lines Using the 3D Line Tracer Plug-in
To make a selection with the mouse the Viz configuration should be  Communication - Multi 
Touch input - Mouse. 

Enter the 3D Line Tracer plug-in.  Select the  Tracing  mode:  One Line : One Segment. 
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When one of the segments is selected you can see the name and ID number. 

How to Show the Route Information
Add the  Routing Item object to the yourscene, y ou can find it in the server under:  Global 
Designs. 

Routing folder.  You find two Routing items:  
- GeoLocated.
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- Non GeoLocated.

Drop the Geolocated under the Map so it gets all the geo-information. 

Works with Datapool plug-ins.
By selecting a segment, it updates the Shortest panel showing the distance, the time, the 
speed and the flow type. 
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Tracing Two Points

Change the  Tracing to  Two Points , s elect one Point on the Map. That is the s tart point 

and select another point to be the e nd point. 

It gives you two routes:  One Fastest and another  Shortest. 

Continuous Tracing
You can use this option to select a Route by dragging and hold the mouse 

How to Build a Specific Route
Click  Start Building Route, s elect the Route in the Map.

Note : Every click selects a segment of the Road. 
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Here you can see the route information. It can be saved into a text document and then you can 
send the information.  The  Clear  option is to Clear from the Scene and the  Rebuild  option 
rebuilds the route from saved data.

The  Picking Active  option specifies  the place on the screen where can routes can be selected.  
There are three options:

All : All Screen.
Inside Rect:  Inside the Rectangle.
Outside: Outside the Rectangle.
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7.4.4 3D Map Telestrator

The 3D Map Telestrator plug-in enables you to draw strokes on maps (including globes) and 
arbitrary flat objects using screen input interface like a mouse or touch screen. The strokes, 
whether with geo or non-geo coordinates, may be passed to other scenes on distant computers 
through the mechanism of shared memory. 3D Map Telestrator uses 3DLine for strokes 
visualization and thus it benefits from the rich design capabilities of this plug-in. The obtained 
strokes may be smoothed to an arbitrary degree to obtain better looking final result of the 
drawing.

This section contains information on the following topics:

3D Map Telestrator Properties
General
Shape Recognition
Examples

Creating a 3D Map Telestrator Scene
To Create a 3D Map Telestrator Scene

Non Geo-Reference Telestration
Shared Memory Mechanism
Using Multitouch Interface
Using Perceptive Pixel Interface
Brush Design Using 3D Line

Width
Outline
Effect
Advanced

3D Map Telestrator Properties

General
Camera: Defines working camera to accept screen input (which is useful in a scene with 
layers where more than one camera is used).
Line Pixel Resolution: Defines the required resolution of line during drawing, such that for 

example if resolution of 5  is set strokes less than five pixel size is disregarded.

Designs Holder: Searches beneath the selected container for the required design.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Maps
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Design Name: Selects the design to implement in the scene. A couple of designs may be 
implemented in the scene and here the desired one for current use is set. If the required 
design does not exist, the first one found is used.
Target: Defines where to build line strokes. If the Container option is used, the desired 
container should be specified in Target Container section.
Active: Defines when the plug-in is active. It may be switched off, active always or only be 
activated while pressing P button on the keyboard. This is useful when other interactive 
capabilities are used in the scene (for example interactive navigation) and care should be 
taken not to interfere with these modes.
Spline: Smoothens the final result for a better look. The three spline types define three 
different methods for smoothing.

Control Points: Uses a spline that paths between the points of the original curve. This 
results in the smooth nice curve, but may be not accurate enough since the line 
doesn’t actually follow the original path and may deviate from it.
Curve Points: Makes the spline path through points of interest of the original curves. 
This method may result in some artifacts causing the route to deform between points 
of interest due to the constraint that the curve must be smooth.
Combined: Compromises between Control and Curve points (see 3D Map Telestrator).

Smoothness: Allows the smoothness to define the threshold if spline is used in order to 
obtain smooth results. The higher the threshold the softer the curve is (see the examples at 
the end of this section).

Close Stroke: Closes strokes automatically when set to On .

Control Mode: Evokes a shared memory mechanism to send and receive strokes to and from 

other 3D Map Telestrator plug-ins when set to On . 

Shared Memory: Defines the type of shared memory:
Global: Shares memory within the region of computer.
Scene: Shares memory within the region of current scene only.
Distributed: Shares memory between all the scenes and computers in the network.

Shared Memory Name: Defines the name for connection, such that only 3D Map Telestrators 
with the same name shares data between them.
Input Interface: Selects interface type for line creation. See further remarks about 3D Map 
Telestrator and Multitouch use.
Animation Control: Runs animation that is located on design container after line is created 
(mouse button released).
Build on Load: Determines whether the lines created when the scene was saved are built 
when the scene is loaded.
Clear/Undo/Redo: Clears the whole drawing or undoes/redoes last strokes.

Shape Recognition
Build on Load: Determines whether the lines created when the scene was saved are built 
when the scene is loaded.
Recognize Ellipse, Square, Triangle and Line: Recognizes four shapes: ellipse (including 
circle), square, triangle and line. When the plug-in recognizes a shape it rebuilds it to be of 
ideal shape (i.e. a hand-drawn circle is replaced by a perfect circle of the same size). The Try 
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Harder option means that there is more probability to recognize the requested shape (for 
example the circle may be less ideal and still be recognized) running the risk that it might 
replace shapes that are not e.g. circles. When Try Harder is enabled only one shape can be 
recognized as opposed to the Try option which enables the plug-in to recognize multiple 
shapes simultaneously.

Examples
Influence of the curves parameter set to original, control points, curve points and combined:

Influence of the curves parameter set to original, control points, curve points and combined:
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Influence of the smoothness parameter set to original, low, medium and high:
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Creating a 3D Map Telestrator Scene

To Create a 3D Map Telestrator Scene

Prepare a blank workspace for the new scene, go to Geom Plugins > Maps and drag an Atlas 
plug-in to the scene.
Open the Atlas plug-in editor, and in under Data Source switch to CMR (Curious Multi 
Resolution), and in the CMR File locator locate the CMR with the desired map. This creates a 
map to draw on. If you have an Internet connection and license for Microsoft Bing maps you 
see the world map as soon as you drop Atlas and there is no need to load CMR.
Go to Container Plugins -> Maps and drop the Navigator plug-in onto the same container as 
the Atlas plug-in. Remember to enable interactivity by pressing the E button (to the left of 
the scene editor). Navigation through the map is possible by pressing i button and using the 
mouse. If the map suddenly disappears after dropping the Navigator plug-in, click 
the Center Map button on the bottom of it.
Add a container above the one just prepared and name it LineDesigns.
Add a new container as a child of LineDesigns and name it Red.
Add the 3DLine plug-in to the Red container.
Open the 3D Line plug-in editor and set the Width parameter to Fixed (Pixels).

Set the Width’s sliding parameter to 4 .

Switch to the Outline option on the topmost radio button row and set Outline to On and give 

it a width of 50  (Outline Width (%) parameter).

Add material to the container and make it red. This creates the first design for the line.
Add another container beneath the Red container and name it Green.
Add the 3DLine plug-in to the Green container.
Open the 3D Line plug-in editor and set the Width parameter to Fixed (Pixels).
Add a material with a green color to the container. This defines the second design for the 
line named Green.
Add a new container as a child of the Atlas container and name it Telestrator and add the 3D 
Map Telestrator plug-in to it.
Open the 3D Map Telestrator plug-in editor and drag the LineDesigns container onto 
the Designs Holder placeholder.
Set the Design Name parameter to Red (in order to choose red design).
Set the Active parameter to the On P position.
Set Shared Memory parameter to Distributed.
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Save the scene.

You can draw on the map by pressing the P key on the keyboard while holding the left 
mouse button down. If you open the same scene on another computer in the network, you 
should see the same drawings appearing on it too.

Non Geo-Reference Telestration
In the procedure on how to create a 3D map telestrator scene, the drawing was done on the map 
(the path has geographic coordinates and as such, it is placed on the same geographical route 
when sent to other computers via the 3D Map Telestrator). The other map in the other scene may 
have different style and projection. It may also have globe geometry, and the path is still 
geographically correct.

There is an option to use 3D Map Telestrator without map and geographic coordinates. To use this 
option two conditions must be met:

The plug-in must not be located under geo-reference (in the example scene the Atlas was 
used as geo-reference).
The flat geometry about to be drawn on must be placed on the same container with 3D Map 
Telestrator plug-in.

Shared Memory Mechanism
As explained in the 3D Map Telestrator 3D Map Telestrator section, the plug-in uses a shared 
memory mechanism in order to send and receive strokes to and from other 3D Map 
Telestrator plug-ins. For the two plug-ins to connect, they should have the same name for the 
shared memory data they are listening to. The given name should have a prefix of 

Telestrator_ , such that when a user enters the name alpha for the group of 3D Map Telestrator 

plug-ins, the actual name of the shared memory parameter is: Telestrator_alpha .

The format of data consists of a unique ID that each stroke receives, name of required design and 
data path that comes as a sequence of pairs of numbers representing longitude and latitude (when 
non-geo-reference mode is used the flat geometry’s bounding box is treated as if having the lat/
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long coordinates of full world). All components of the data including design name and unique ID 
are separated by commas.

Using Multitouch Interface
This interface uses touch screen of Multitouch type. For the plug-in to receive information from the 
screen, the Input Interface button should be switched to Multitouch mode and a container with the 
plug-in should contain a geometry. Screen touches outside of this geometry are disregarded. If the 
plug-in is used in a non-georeference mode, there is no problem since it already contains 
geometry for drawing on. If it is used in a georeference mode, the best practice is to place the 3D 
Map Telestrator plug-in on the container with the map.

Using Perceptive Pixel Interface
In a case of using a Perceptive Pixel Interface (PPI) screen, the setup requires a couple of additional 
things. A special plug-in named Mt2dControl, that is a part of the PPI plug-in package, accepts and 
processes the inputs from the touch screen and the processed data is sent to the 3D Map 
Telestrator plug-in through a shared memory mechanism.

Continuing the procedure above on how to create a 3D map telestrator scene, you can add multi-
touch capabilities to your graphics scene. The procedure and example scene tree below expands 
on the aforementioned procedure.

Open the 3D Map Telestrator plug-in editor and set Input Interface to PPI (see 3D Map 
Telestrator) and chose a name for a shared memory connection with the PPI interface (i.e. a 
PPI variable name). Note that this must differ from shared memory connections with 
other 3D Map Telestrator plug-ins.
Add the container somewhere in the scene which is not a part of any hierarchy.
Add a rectangle to the container and scale it to the maximum possible size.
Add a Mute plug-in on the container to avoid rendering it.
Add a Multi-touch 2D control (Mt2dControl) plug-in on the container.
Open the Mt2dControl plug-in editor and set the following parameters:

Lock Rotation to On .

Lock Scale to  On .
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Shared Memory to  On .

Shared Memory Type to Scene .

Shared Memory Prefix should be the same as the PPI variable name in the 
3DMapTelestrator plug-in.

Hit Coordinate Type to World .

Save the scene. Now you can draw lines by touching the screen.

Brush Design Using 3D Line
The 3D Line plug-in is used by the 3D Map Telestrator to visualize the strokes. The desired look of 
the line is set by various parameters in the design (inside the 3D Line plug-in) and it is important 
to understand these parameters to get the desired look and behavior for the line.

The following are the most important parameters:

Width
The options for the Width tab defines the width behavior of the line. Three options may be used to 
define width behavior:

Fixed (pixels): Defines constant width of line measured in pixels.
Scaling: Varies line width according to zoom and the minimum/maximum parameters set.
Fixed (mm): Sets a fixed width in geographic units.
Fade Edge (%): Applies a fade effect to the side-edges.

Outline
By using these options an outline of arbitrary width, fade amount and color can be set to a line.

Effect
When a line comes to a 3D Map Telestrator plug-in, it plays an animation running from single point 
to a full path by default. The attributes of such an animation can be set beneath this tab. The 

length of animation in time is controlled by the Animation Length parameter and if it is set to 0 , 

no animation is played. A fade effect to a running edge of the line can be set by the Fade 
parameter.

Advanced
A couple of options are available for this tab, the most important of which are:

Cap edges: Defines shape for the beginning and end edge of the curve.
Height Offset: Defines an offset line from surface it is put on.
Update Texture Mapping: Updates line width during zooms according to the setting we 
made in Width tab, while line length remains unchanged (texture mapped on the line may 
deform). To keep same aspect ratio for the texture this option must be enabled.

See Also

3D Map Telestrator Design
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3D Map Telestrator

7.4.5 3D Map Telestrator Design

The 3D Map Telestrator Design plug-in controls 3D Map Telestrator options through design setup. 
When this plug-in is added to the design its setup is imposed on the 3D Map Telestrator (i.e. 
parameters set in 3D Map Telestrator Design plug-in overrides parameters set for the 3D Map 
Telestrator), and thus it is possible to control spline type and smoothness, close option and shape 
recognition setup from a design perspective.

3D Map Telestrator Design Properties
Smoothness: Allows the smoothness to define the threshold if spline is used in order to 
obtain smooth results. The higher the threshold the softer the curve is (see the examples in 
the 3D Map Telestrator Properties).

Close Stroke: Closes strokes automatically when set to On .

Recognize Ellipse, Square, Triangle and Line: Recognizes four shapes: Ellipse (including 
circle), square, triangle and line. When the plug-in recognizes a shape it rebuilds it to the 
ideal shape (i.e. a hand-drawn circle is replaced by a perfect circle of the same size). The Try 
Harder option means that there is more probability to recognize the requested shape (for 
example the circle may be less ideal and still be recognized) running the risk that it might 
replace shapes that are not e.g. circles. When Try Harder is enabled, only one shape can be 
recognized as opposed to the Try option which enables the plug-in to recognize multiple 
shapes simultaneously.

7.4.6 3D Region Manager

The 3D Region Manager plug-in creates sub regions of a selected region on the map, using a 3D 
Region design. The plug-in receives the region name and gets all the sub regions of that region 
from the server or a shape file. The 3D Region design is duplicated for each sub region and 
displayed on the map.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Maps_Adv
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3D Region Manager Properties

Common
Design: Sets the region design container that is used for building sub-regions. The design 
container should be built with a 3D Region object and a material. No special naming 
convention is required.
Target: Defines the container to be used as the parent container for the sub regions 
containers:

Me: Builds the 3D Region objects under the current container (holding the 3D Region 
Manager plug-in).
Next: Builds the 3D Region objects under the next container (next container in the tree 
and at the same level as the 3D Region Manager container).
Down: Builds the 3D Region objects under the first child container.
Container: Builds the 3D Region objects under the container dragged into 
the Target container place holder.

Build Region
Build Region: Defines the source for which the 3D Region objects are created.

Local: Builds the 3D Region objects for the container that the 3D Region Manager is 
applied to. The container must be a 3D Region object for the sub regions to be built 
for the defined region.
WME: Enables the user to select the regions or sub-regions inside the WME.
Shape File: Allows the user to select a shape file that contains the regions to be 
created.
Command: Allows the user to set a command with the parameters of the regions to 
build.
Region ID: Enables the user to show a specific region by region ID after having 
prepared the cache files.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Maps_Man
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Local

3D Border Visible Filter: Sets which borders should be cropped to map. Any border lower or 
equal to the selection is cropped to the map. Available options are Country, Region and 
None.

WME

3D Border Visible Filter: Sets which borders should be cropped to map. Any border lower or 
equal to the selection is cropped to the map. Available options are Country, Region and 
None.
Scan: Defines what regions to display.

Selected: Displays only the selected regions, selected by pressing the Select Region
button.
Recursive: Displays all selected regions and their sub regions.

Select Region (WME): Opens the World Map Editor, enabling the selection of regions to be 
used in Selection mode. Press the Select Region button to select the regions to be built.
Select Region (Classic): Opens the Map Editor Classic, enabling the selection of regions to be 
used in Selection mode.

Shape File

Shape Regions: Defines how the regions are built. Available options are Merge, Split and 
Advanced.

Merge: Creates all regions in the file as one object.
Split: Creates all regions in the file as separate objects.
Advanced: Enables the additional parameters Conversion File, State Column and Name 
Column. Conversion File defines a text file for converting regions indexes into region 
names. Parent Id Column, Parent Name Column and Names Column refer to columns 
in the database (*.dbf) file that comes with the shape file. The database files describes 
what is attached on the shape file. Note that database files can be opened with 
Microsoft Office Excel.

Shape File: Defines a path to the shape file (*.shp), containing the region definitions. Shape 
files are bought from vendors specialized in Geographic Information System (GIS) and hold 
the actual shape data (polygons, splines, and others) for the container that the 3D Region 
Manager is applied to. The container must be a 3D Region object for the sub-regions to be 
built for the defined region. Note that shape files must be stored in individual folders.
Conversion File: Determines files used to convert IDs in the file to Viz World IDs.
Parent ID/Name Column: Determines which column which holds the ID/Name of the parent 
of the region.

Parent Name Length: Truncates the parent name ( 0 = no truncation).

IDs/Names Column: Determines which column which holds the ID/Name of the region.
Prepare Cache Files: Minimizes memory use by pre-creating of the cache files and then 
building the required regions only (directly from the cache files), instead of building large 
amounts of regions from a shape file (which may overload the system). Only prepare Cache 
Files (without loading the data to Viz) the files can be used later in Viz, based on the ID.
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Command

Command: Builds a 3D Region object from the specified command. The command defines 
the region coordinates using pairs of longitude and latitude values. The command format is 
as follows:

<3D RegionContainerName>: Long1,Lat1 Long2,Lat2...

Region ID

Shape File: Defines a path to the shape file (*.shp), containing the region definitions. Shape 
files are bought from vendors specialized in Geographic Information System (GIS) and hold 
the actual shape data; polygons, splines, and others for the container that the 3D Region 
Manager is applied to. The container must be a 3D Region object for the sub regions to be 
built for the defined region. Note that shape files must be stored in individual folders.
Region ID: Sets the region’s ID for the required region.

Common
Design: Sets the region design container that is used for building sub -regions. The design 
container should be built with a 3D Region object and a material. No special naming 
convention is required.
Target: Defines the container to be used as the parent container for the sub regions 
containers:

Me: Builds the 3D Region objects under the current container (holding the 3D Region 
Manager plug-in).
Next: Builds the 3D Region objects under the next container (next container in the tree 
and at the same level as the 3D Region Manager container).
Down: Builds the 3D Region objects under the first child container.
Container: Builds the 3D Region objects under the container dragged into 
the Target container place holder.

Buttons
Clear and Build: Deletes all previously built objects and rebuilds the regions according to the 
current settings.
Add to Existing: Builds the new objects without deleting the old 3D Region objects from the 
hierarchy.
Clear Target Tree: Removes all objects built by the plug-in from the Viz scene hierarchy.
Freeze All: Freezes the regions to the scene instead of recreating them on load.
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7.4.7 3D Roads Manager

The 3D Roads Manager plug-in creates 3D Roads objects. The plug-in uses a shape file design to 
create roads according to the defined settings.

3D Roads Manager Properties
Roads Mode

Global: Applies one set of road designs for all roads.
Design: Uses a design per CWMClient. The Design field sets the roads design 
container that is used for building border data from a shape file. The design container 
should be built with a 3D Roads object and a material. No special naming convention 
is required.

Target: Defines the container to be used as the parent container for the road designs when 
Roads Mode is set to Design.

Me: Builds the 3D Roads objects under the current container (holding the 3D Roads 
Manager plug-in).
Next: Builds the 3D Roads objects under the next container (next container in the tree 
and at the same level as the 3D Roads Manager container).
Down: Builds the 3D Roads objects under the first child container.
Container: Builds the 3D Roads objects under the container dragged into the Target 
container place holder. The Target Container specifies the container that holds all the 
3D Roads objects.

Source: Selects street/road source.
WME: Uses Viz World Map Editor (WME) using the CWM client plug-in to connect to the 
map server.
Shape File: Determines the shape file that contains street data to use.
Cloud Made: Loads street data from Cloud Made. This is a web service which requires 
a license.
Data Set: Loads street data from the converted data supplied by an external provider 
into Viz World format

WME
Simplify Threshold: Sets the detail reduction factor for the shape of the roads.
Select Streets (WME): Opens the World Map Editor.
Select Streets (Classic): Opens Map Editor Classic.
Labels Mode: Determines how labels are created.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Maps_Man
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None: Does not create labels.
Partial: Creates labels only visible on the view.
All: Creates all labels.

Labels Only: Creates labels only, not the roads when set to On .

Cloud Made
Simplify Threshold: Sets the detail reduction factor for the shape of the roads.
Labels Mode: Determines how labels are created.

None: Does not create labels.
Partial: Creates labels only visible on the view.
All: Creates all labels.

Labels Only: Creates only labels, but not roads when set to On.

Data Set
Data Set: Location of data
Simplify Threshold: Sets the detail reduction factor for the shape of the roads.
Labels Mode: Determines how labels are created.

None: Does not create labels.
Partial: Creates labels only visible on the view.
All: Creates all labels.
Label & Go: Uses the Label and Go plug-in.

Labels Only: Creates only labels, but not roads when set to  On .

Shape File
Shape File: Defines a path to the shape file (*.shp), containing the border definitions. Shape 
files are bought from vendors specialized in Geographic Information System (GIS) and holds 
the actual shape data; polygons, splines, and others. Note that shape files must be stored in 
individual folders.
Sort Roads By: Sets the loaded roads from the shape file in a category.

Category: Enables the user to select one predefined category of street data. 
Available Road Types are Freeways, Primary, Main, Secondary and Other.
Advanced: Splits the data into different categories using specific string types. Road 
Type Column specifies a column name that holds each road category. Freeways/
Motorways, Primary Roads, Main Roads, Secondary Roads and Other Roads specify 
what string in the database file (*.dbf) that matches the road type.

Persistent Roads: Defines whether the roads data is removed from Viz memory when the 
scene is closed or not.
Sort Roads by: Defines which road type is associated with created objects. If Advanced is 
selected, additional parameters are enabled allowing the configuration of road types 
according to the data associated to the shape file.

Category: Enables the selection of road types. Available options are: Freeways, Primary 
Main, Secondary, Other.
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Advanced: Sets parameters according to the data in the files associated with the shape 
file. Defines the road type column and the specific road type ID in the file.

Road Name/ID Column: Determines which column which holds the Name/ID of the road.

Buttons
Rebuild All: Rebuilds all data. If Roads mode is set to Design, 3D Roads objects are created 
from design. If Roads mode is set to Global, global 3D Roads renders built data.
Rebuild All (force): Deletes any cache and force a rebuild of the cache as well as rebuilding 
the Viz geometry.
Rebuild Labels: Rebuilds only the labels, but does not affect already built streets.
Clean All: Cleans Target container from subcontainers.

7.4.8 Center Map

The Center Map plug-in is used with map objects to keep a point on the map in the center of the 
map object. The map is moved while the defined point remains centered. With a Flat map, the map 
is moved, but with a Globe map the globe is rotated. See also Map Tiler for more information on 
Flat and Globe maps.

Center Map Properties
Position: Defines how the map is centered.

User: Enables the user to manually define a center point by setting Map Center 
Longitude and Map Center Latitude values.
WPosition: Centers the map at the location of a WPosition container dragged into 
the Remote Container place holder.
Navigator: Centers the map at the location of a Navigator container dragged into 
the Remote Container place holder.
WPoint: Centers the map at the location of a WPoint container dragged into 
the Remote Container place holder.
Map: Centers the map at the center of a dragged map into the Remote Container map.
Frame:

Remote Container: When Position is set to WPosition, you must drag the container that holds 
the World Position plug-in to this field in order to get the information.
Map Center Longitude/Latitude: Defines information for when Position is set to User.

Note: The Center Map plug-in should only be applied to map objects.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Maps
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Local Scale: Sets the scale parameter for the map.
Animate to Target: Animates the map whenever the longitude/latitude value changes when 
enabled. This is either with a fixed defined time or using length time, it is relative to the 
distance it has to travel to the new value.
Animation Time: Target value (in fields) for the animation.
Shared Memory: Writes the longitude/latitude values to the shared memory variable defined 

in the Identifier field when set to Master . When set to Client  it listens for values in the 

shared memory key.
Type: Determines the type of shared memory to use (for more information on Shared 
Memory see the Viz Artist User Guide):

Global: Scene.Map: This is the map local to the current Scene. Every scene has one 
map that can be used to exchange data among the scripts in the Scene.
Scene: System.Map: The system-wide map allows for data sharing among the scenes 
currently loaded into memory.
Distributed: VizCommunication.Map: A distributed map that enables data sharing 
among the computers connected to one Viz Graphic Hub.

Identifier: Identifier to be used for shared memory communication.

7.4.9 CWMClient

The CWMClient plug-in is the main plug-in for Viz World Client (WoC). The CWMClient plug-in 
launches the World Map Editor (WME) and retrieves the map from the Viz World Server (WoS) after 
the user has applied the changes to the map in WME.

CWMClient Properties

Texture
The texture section defines the geo map image parameters.

Lock Aspect Ratio: Affects texture height and texture width parameters. When enabled ( On ) 

any change in the texture height or width affects both parameters. When disabled ( Off ), 

each parameter is controlled separately.
Texture Size: Presets for texture sizes.

Auto Adjust To Globe: Defines whether the texture size is modified when mapped on a 
globe if texture size is set to a setting other than manual. This option is used when 
displaying maps that are close to Earth’s poles.

Adjust for Globe (advanced): Adjusts a 2D selection in WME converting it to 3D.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Maps

http://docs.vizrt.com/viz-artist.html
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Adjust for Zoom (advanced): Fetches a wider map when enabled. Normally, the selected map 
is zoomed in by approximately ten percent in order to avoid the fade area.
Texture Width: Defines the number of pixels in the map width. When aspect ratio is locked, 
changing the texture width automatically changes the Texture Height parameter.
Texture Height: Defines the number of pixels in the map height. When aspect ratio is locked, 
changing the texture width automatically changes the Texture Width parameter.
Texture Compression: Sets the compression level for the texture (DTX5 is the highest 
compression level, i.e. less texture quality).
Texture Quality

Linear: Uses the same image resolution in the entire zoom range.
Mipmap: Changes resolution according to the distance from the image (managed 
automatically in Viz Artist).

Texture Anisotropic Filter: Turns on the relevant anisotropic in the image on the same 

container with CWMClient (similar to Mipmap, above). Available settings are Off / 2x / 4x /

8x / 16x . 

Labels
3D Designs & Holder: Defines the labels usage and behavior over the map, and has three 
available options:

Disabled: Displays labels as part of the map texture. No manual definitions are 
required.
Local: Requires manual definition of the 3D Designs & Holder path (e.g. On Map 

Designs:  Vizrt/VizWorld/GlobalDesigns/Regions/ )

Global: Enables you to use a global design defined by the 3D Map Setting scene plug-
in.

Local And Global

Visible Filter: Select All to build all labels defined in WoC. Select Visible to build only labels 
that are shown on the selected map.
Backslash as New Line: When Enabled you can add labels with more than one line typing 
backslash (\) as a separator for each new line.
Labels Type: Defines the source of the label designs. Available options are Dynamic and 
Scene. Selecting Viz-DB or Scene defines where the label designs are stored.

Dynamic: Creates new labels dynamically based on label designs created in the scene 
itself or fetched from the Viz Graphic Hub (Viz DB). All designs are referenced by the 
On-Map Designs placeholder. When selecting labels in the Map Editor (WME), all labels 
are dynamically added underneath the CWMClient’s container and receive the correct 
label type (provided it is defined by your label design). Note that this approach does 
not allow you to use control plug-ins. As the number of labels are dynamic this 
approach does not allow you to use control plug-ins.

IMPORTANT! Global labels do not work with on screen labels so you still need 
to configure them (if needed).
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Static: Does not create new labels underneath the CWMClient’s container, but instead 
uses the number of labels already defined by the designer (achieved by adding copies 
of the label designs as sub containers of the CWMClient’s container). As the number of 
labels and label types are static, this approach allows use of control plug-ins.
Viz-DB: Uses label source from a merged object from the Viz objects library containing 
the label designs.
Scene: Uses label source from a group container in the scene hierarchy containing the 
label designs.

On-Map Designs: Defines the source of the labels that are displayed on the map (Local only). 
When Viz DB (Viz Graphic Hub) is selected, define the path to a merged object, containing 
the label designs, in Viz object library. When Scene is selected, drag a group container with 
the label designs to the container place holder.
On Screen Designs: Defines the source of the labels that are displayed on a plane in front of 
the screen. When Viz DB is selected, define the path to a merged object, containing the label 
designs, in Viz object library. When Scene is selected, drag a group container with the label 
designs to the container place holder.
On-Map Holder: Uses this container for grouping all the generated labels on the map (Local 
only). When a map with labels is selected, the plug-in duplicates the label designs and 
creates the labels. The duplicated labels are placed under the On Map Holder container.
On Screen Holder: Uses this container for grouping all the on screen labels (labels that are 
not geo-referenced) used in the map (Local only). When a map with on screen labels is used 
and Viz is selected, the on screen label designs are copied to the holder container and the 
label information is sent to the copied designs.

3D Objects
The 3D Objects section defines the other 3D properties of objects on the map, other than labels 
(regions, roads and so on).

3D Objects And Regions

3D Designs & Holder: Defines whether the regions are part of the received texture or 3D 
objects. When set to Disabled, regions are displayed as part of the texture. When set 
to Local or Global the Viz-DB and Scene parameters are made available. Also, when set to 
Global, the global region designs and holder are used to create the on map 3D 
Region objects. On Screen parameters are enabled to define the on screen region designs 
and holder.

Viz-DB: Sets region source to be a merged object from the Viz objects library, 
containing the region designs.
Scene: Sets region source to be a group container in the scene hierarchy, containing 
the region designs.

Note: Back slash (/) in label names are treated as a new line (carriage return).

Note: The global designs and holder are defined in the 3D Map Setting scene plug-in.
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On-Map Designs: Defines the source of the 3D Region objects that are displayed on the map. 
When Viz DB is selected, define the path to a merged object, containing the region designs, 
in Viz object library. When Scene is selected, drag a group container with the region designs 
to the container place holder.
On Screen Designs: Defines the source of the 3D Region objects that are displayed on a 
plane in front of the screen. When Viz DB is selected, define the path to a merged object, 
containing the region designs, in Viz object library. When Scene is selected, drag a group 
container with the region designs to the container place holder.
On-Map Holder: Uses this container for grouping all the generated 3D Region objects on the 
map. When a map with regions is selected, the plug-in duplicates the region designs and 
create the 3D Region objects. The duplicated regions are placed under the On Map 
Holder container.
On Screen Holder: Uses this container for grouping all the on screen regions (regions that 
are not geo-referenced) used in the map. When a map with on screen regions is used 
and Viz is selected, the on screen region designs are copied to the holder container and the 
region information is sent to the copied designs.

3D Objects And Borders

3D Designs & Holder: Defines whether the border line is part of the received texture or 
drawn as a 3D object. When set to Disabled, borders are displayed as part of the map 
texture. When set to Local the Viz-DB and Scene parameters are made available and the 
shapes added in the WME are drawn as a 3D object by Viz. When set to Global, the global 
border designs and holder are used to create the 3D Border objects.

Recursive level: Sets the filter level for border details. If None is selected, all border data is 
drawn. If Region is selected, Sub Region data is not drawn. If Country is selected, region and 
sub-region borders are not drawn.

Viz-DB: Sets the border source to be a merged object from Viz objects library, 
containing the border designs.
Scene: Sets the border source to be a group container in the scene hierarchy, 
containing the border designs.

On-Map Designs: Defines the source of the 3D Line objects that are displayed on the map. 
When Viz DB is selected, define the path to a merged object, containing the border designs, 
in Viz object library. When Scene is selected, drag a group container with the border designs 
to the container place holder.
On-Map Holder: Uses this container for grouping all the generated 3D Border objects on the 
map. When a map with borders is selected, the plug-in duplicates the border designs and 
create the 3D Line objects. The duplicated borders are placed under the On Map 
Holder container.

Note: The global designs and holder are defined in the 3D Map Setting scene plug-in.
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3D Objects And Shapes

3D Designs & Holder: Defines whether the shapes are part of the received texture or drawn 
as a 3D object. When set to Disabled, shapes are displayed as part of the map texture. When 
set to Enabled the Viz-DB and Scene parameters are made available and the shapes added in 
the WME are drawn as a 3D object by Viz. When set to Global, the global shape designs and 
holder are used to create the 3D shape objects.

Viz-DB: Sets the shape source to be a merged object from Viz objects library, 
containing the shape designs.
Scene: Sets the shape source to be a group container in the scene hierarchy, 
containing the shape designs.

On-Map Line Designs: Enables the user to add vector line data to the map. Either by using 
the draw option in the WME (Add Shape), or from selecting an existing line data (e.g. street).
On-Map Area Designs: Enables vector area designs. This option has support for the area 
draw option in the WME.
On-Map Line Holder: Defines the source of the 3D Region objects that are displayed on the 
map. When Viz DB is selected, define the path to a merged object, containing the shape 
designs, in Viz object library. When Scene is selected, drag a group container with the shape 
designs to the container place holder.
On-Map Area Holder: Uses this container for grouping all the generated 3D shape objects on 
the map. When a map with shapes is selected, the plug-in duplicates the shape designs and 
create the 3D Region objects. The duplicated shapes are placed under the On Map 
Holder container.

3D Objects And Roads

3D Roads: Defines whether the road data is drawn on the map and the way the roads are 
drawn. Available options are None, Crop To Map and All.

None: The roads data is not available to be drawn on the map.
Crop To Map: Enables the Visibility Filter and Visibility Factor (%) settings, limiting the 
roads data.
All: Loads the selected road data.
Labels Only: Draws only the road labels.

Crop Visibility Filter: Sets the highest level of road type that is cropped. Available options are 
Freeway, Primary, Main, Secondary and Other.

Freeway: Crops all roads rated as freeways and lower (that is all roads) using 
the Visibility Factor.
Primary: Crops all roads rated as primary roads and lower (that is primary, main, 
secondary and other) using the Visibility Factor.
Main: Crops all roads rated as main roads and lower (that is main, secondary and 
other) using the Visibility Factor.
Secondary: Crops all roads rated as secondary roads and lower (that is secondary and 
other) using the Visibility Factor.

Note: The global designs and holder are defined in the 3D Map Setting scene plug-in.



Plug-ins User Guide -  5.0

Copyright © 2022  Vizrt Page  689

•

•

•

•

•

•

•

•

•

•
•

•

•

•
•

•
•

•

Other: Crops all roads rated as other roads (that is none of the above) using 
the Visibility Factor.

Visibility Factor (%): Defines the cropping area of the roads on the map. 100% means the 
roads are cropped at the map edges and cover the entire map area. A lower value causes the 
selected road types in the Visibility Filter to be cropped (evenly from the map edges).
Simplify Threshold (m): Applies a simplifying algorithm on road data. The number 
represents the biggest allowed error.
Ignore Filter: Disables creation of roads that are lower or equal to the selection (i.e. Freeway, 
Primary, Main, Secondary, and Other).
Roads Mode: Applies one set of road design for all roads (Global), or uses a design per 
CWMClient (Design).

Source: Sets the source for road designs. Available options are Viz-DB and Scene. Viz-
DB sets road source to be a merged object from Viz objects library, containing the 
road designs. Scene sets road source to be a group container in the scene hierarchy, 
containing the road designs.
On-Map Designs: Defines the source of the 3D Roads objects that are displayed on the 
map. When Viz-DB is selected, define the path to a merged object, containing the road 
designs, in Viz object library. When Scene is selected, drag a group container with the 
road designs to the container place holder.
On-Map Holder: Uses this container for grouping all the generated 3D Roads objects 
on the map. When a map with roads is selected, the plug-in duplicates the road 
designs and create the 3D Roads objects. The duplicated roads are placed under 
the On Map Holder container.

3D Objects And Advanced

Regions Visible Filter: Defines whether all the selected regions are created (when using 3D 
regions) or only the regions that are visible on the selected map.
Sort Regions: Defines how the labels and 3D objects are duplicated in the scene tree.

No: Creates the duplicated labels and 3D objects in the scene tree grouped by 
geographic levels that is for each country, first the country, then the regions, then the 
sub regions, and so on.
Ascending: Creates the duplicated labels and 3D objects created in the scene tree 
sorted by ascending geographic levels, that is first the sub regions, then the regions, 
then the country container.
Descending: Creates the duplicated labels and 3D objects in the scene tree sorted by 
descending geographic levels, that is first the sub regions, then the regions, then the 
country container.

Copy Map to Region: Sets if a map of the region is applied to the 3D Region object.
Auto Borders: Defines whether borders are added automatically to the map and the level of 
the borders:

Off: Does not add borders.
Highest: Draws country borders for the selected area (or region borders if only a 
region was selected).
Intermediate: Draws region borders (or sub-regions if only a region was selected).
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Lowest: Draws sub-region borders.
Auto Regions: Automatically adds region designs based on location.

Off: Does not add regions.
On Screen: Adds region on screen automatically.
On Map: Adds adds region on map automatically.

Auto Regions Level: Determines the level when creating auto 3D Regions.
Set 3D Models: Determines whether the 3D models plug-in is called to generate 3D buildings 
in the selected map area.

Miscellaneous
The Miscellaneous section includes additional general parameters of the map.

WME Aspect– Defines the aspect of the map in the WME window:
Image: Sets the aspect by the texture size defined in the texture screen of the 
CWMClient plug-in when selected.
User: Allows manual setting of the aspect when selected. When selected, 
the Aspect parameter is enabled. The aspect is modified by changing the aspect value.
Camera: Sets the aspect to be the same as the current camera in use. Selecting this 
option opens the WME in the same aspect as the current camera.
Auto: Looks for a Navigator plug-in in the hierarchy, above the CWMClient plug-in 
when selected. If a Navigator is found, the camera aspect is used. If 
the Navigator plug-in was not found, the image aspect is used.

Freeze: Retrieves the map from from the server and saves it as an image in the Viz image 

library and used as a static geo-referenced image when set to On . All map dynamic 

parameters are hidden.

Obey Hops Manager: Uses settings of labels/regions/3D Objects as defined in the Hop 

Manager plug-in when set to On . When set to Off , settings are local to this CWMClient 

plug-in.
Transition Logic Mode: Requests the map from the server or cache when the scene is loading 

when set to Off . When set to  On , the scene loads without requesting a map since the 

control application (e.g. Viz Trio or another external application) sends the parameters for a 
map to use. This option saves time during initialization of scenes using a dynamic map.
Lock Project & Style: Locks the CWMClient plug-in to only use the selected TPL and style 
sheet and ignores any changes made from the WME.
Is Linked to Master Map: Permits the CWMClient (slave) to be controlled by another 

CWMClient (master) when set to On . To control another CWMClient, drag and drop a 

container with a CWMClient (slave) plug-in onto the CWMClient (master) plug-in's Linked Map 
placeholder (see next parameter).
Linked Map: Defines the map (slave) that is linked to the current map (master) in a container 
placeholder when set. The linked map is another CWMClient container that receives the 
same map as the map selected from the WME.

Note: When freezing a map, Hop scenes with pyramids will no longer work. This is a 
known limitation.





Plug-ins User Guide -  5.0

Copyright © 2022  Vizrt Page  691

•

•

•

•
•

•

•

•
•

•
•

•

•

•

•
•
•

•

•

•

Linked Map Size (%): Defines the size of the linked map as a percentage from the main map, 
that is if 50% is defined the linked map shows half of the area defined in the main map.
Linked Type (advanced): Determines if the link type only include bounding box or should it 
include all the data (regions, labels etc.).
Shared Memory Link: Defines which is the master (source) and client (target) when the same 
Shared Memory Identifier is used.
Shared Memory Type: Defines the accessibility of the shared memory.

Global: Makes shared memory accessible to all scenes currently loaded in memory. 
This is useful when working with Transition Logic scenes where your Viz World map 
can be one scene and the locator a different one and data can easily be transferred 
between the two.
Scene: Makes shared memory accessible only locally and to the current scene. Every 
scene has one shared memory map that can be used to exchange data among the 
scripts in the scene.
Distributed: Makes shared memory accessible to all computers connected to one Viz 
Graphic Hub.

Shared Memory Identifier: Defines the identifier for the shared memory map.
URL Images: Container holding the URL Image manager which is invoked when the map 
changes.
Always Fetch Terrain Data: Fetches terrain data always when enabled.
Terrain Tessellation Locked: Appears when a C3D Terrain plug-in is combined with the 
CWMClient plug-in. Tessellation is the terrain resolution, which is the number of polygons 
used to build the terrain object. The higher the tessellation, the more detailed the terrain is. 
Use the Width Tessellation and Height Tessellation parameters to fine tune the quality versus 
the performance of the scene.

When set to  On , only the Width Tessellation parameter can be changed; hence, the 

setting applies for both Width and Height.

When set to  Off , the parameters can be set individually.

Imagery
The Imagery section includes multiple imagery configuration options.

Data Source: Defines the source of the imagery. Available options are Bing (MIcrosoft Bing 
server), CMR (Curious Multi-Resolution imagery), Digital Globe (DG) or Blom.
When enabled (On) additional parameters are made available, and the WME button is 
disabled.

Data Resolution: Available resolutions in pixels (i.e. width).
Temp Folder: Sets a temporary download folder.
Data Type: (Visible when Data Source is Bing). Available data types are satellite, map 
or a combined type of imagery.
CMR: (Visible when Data Source is CMR). Defines a CMR file to be used as a source for 
the map.
Digital Globe Projection: (Visible when Data Source is DG). Allows you to select the DG 
project. Currently available as Mercator and Unprojected.

Longitude: Sets the map longitude.
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Latitude: Sets the map Latitude.
CMR Units: Sets the Curious-Multi Resolution imagery’s units to degrees, kilometers, miles 
or nautical miles.
Width (deg): Sets the area width in degrees, kilometers, miles or nautical miles.
Status: Displays the current CMR operation status.
Get Image: Retrieves the defined imagery (of the area defined by Lon, Lat and Width 
parameters).
Center Longitude Latitude: When clicked, the CMR is created with the longitude and latitude 
values as the center of the CMR.

Buttons
The following default buttons apply to the plug-in as a whole.

Viz World Map Editor (WME): Opens the WME. WME connects to Viz World Server that is 
defined in Viz Config, and retrieves the current map or opens the defined default project if 
no map exists (fresh plug-in instance).
Refresh Map: Re-draws the map and refreshes the related Viz objects using Viz World Client 
(WoC) plug-ins in the scene hierarchy. For example if a label design has been changed in Viz 
Artist, clicking Refresh Map redraws the map with the new label design without opening 
WME.
Refresh Map (Force New): Recreates the map on the server and saves it to the cache. This 
operation forces the map creation, even if the map exists in the cache folder.
WME (Classic): Opens WME Classic interface instead of the new WME

Search Order
The CWMClient can hold designs for labels and 3D objects such as regions, borders and shapes. 
As the designs can be stored in the scene or on the Viz Graphic Hub (i.e. Viz-DB), you need to 
understand the order in which these designs are searched for. The following rules apply when 
searching for designs under the Design holders.

Note: The longitude and latitude values must be within the CMR area. If the values 
are not within the CMR area no map is created.
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Example I - Add Label Map Tool Bar

If, when using the World Map Editor or Map Editor Classic, you add a label and set the style to 
be Traffic_Accident, the search order is based on the following rules:

Search the Scene - that may have multiple designs where each design has a name that 
corresponds to its design.
Search Viz Graphic Hub (i.e. Viz-DB) - that may have multiple designs stored in a design 
folder where each design is a merged object with a name that corresponds to the design.

First, the Scene design holder is searched (if used) in the following order:

By Style
By Design (Point_Label)
By Default Design (Default_Design)

This means that it searches for and uses:

Traffic_Accident, and if not found then
Point_Label, and if not found then
Default_Design
If none were found, the Viz-DB design holder is searched in the same order.

Example II - Add label Search Tab

If, when using the World Map Editor or Map Editor Classic, you search for and add a Town with 
more than one million (Towns > 1m) inhabitants as a label to the map and for the CWMClient set 
the style to Bigtown the search order is based on the following rules:
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Search by style only if different than Place
By detail (Capital / Town_1m / Town_100k / Town_10k / Town_1k / Town)
By default town design (Default_Town)
By style (if = Place)
By default design (Default_Design)

This means that a search searches for and uses:

Bigtown, and if not found then
Town_1m, and if not found then
Default_Town, and if not found then
Place,
Default_Design

Naming Conventions

As there are several types of labels the following is the search order for each label type:

Capital
Town 1M
Town 100K
Town 10K
Town 1K
Town

Search by style only if different than Place
By detail (Capital / Town_1m / Town_100k / Town_10k / Town_1k / Town)
By default town design (Default_Town)
By style (if = Place)
By default design (Default_Design)

Region:
By style
By region level (Country / Region / Sub_Region)
By detail (Region)
By default design (Default_Design)

Point Label:
By style
By design (Point_Label)
By default design (Default_Design)

None of the above:
Search by style only if different than Place
By default design (Default_Design)

All Others:
Search by style only if different than Place
By detail (Region / Region_Name / River_Name ...)
By style (if = Place)
By default design (Default_Design)
List of details name:

Capital

Note: Names using letters other than [a-z A-Z 0-9] are converted to _ (underscore).



Plug-ins User Guide -  5.0

Copyright © 2022  Vizrt Page  695

•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•

•
•
•
•

Town_1m
Town_100k
Town_10k
Town_1k
Town
Tourist_Attraction
Reserve_Or_Park
Region_Name
Physical_Area_Name
Physical_Water_Name
River_Name
Mountain_Name
Label
Street_Address
Intersection
Traffic_Incident
Traffic_Accident
Traffic_Construction
Traffic_Speed
Point_Label
None_Of_The_Above
Region

7.4.10 Focus On Map

The Focus On Map plug-in creates a single hop (high resolution map over a large referencing map) 
without using a navigator plug-in or animation. This plug-in is used when creating a large map 
(reference map) with 3D Objects over it (roads, shapes, and so on). It enables the user to display a 
high resolution area of the large map without recreating the 3D objects when changing the 
displayed area.

Focus On Map Properties

Common Properties
Geometry Offset X/Y (%): Offsets from the true position of the geometry in geometry units.
Min/Max Distance: Sets the minimum/maximum distance from the camera to the map.
Get Map: When clicked, the camera jumps to the defined area.
?: Displays help.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Maps
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Position
The Position Tab enables the parameters for the requested map area where the Position Source 
defines the source of the viewed area.

Map: Fits the selected map in the Focus On Map container to the screen according to the Fit 
To Screen By selection.

Fit To Screen By: Sets the map attribute that is used to fit the map to the screen: 
Width, Height, Min (the minimum value of the map’s width and height), Max (the 
maximum value of the map’s width and height), Average (the average of the map’s 
width and height).
Longitude Offset: Sets a longitude offset from the center of the selected map.
Latitude Offset: Sets a latitude offset from the center of the selected map.
Distance Offset: Sets a distance offset from the center of the selected map.
Pan: Sets a pan value for the camera.
Tilt: Sets a tilt value for the camera.

Absolute: Enables the user to manually set the parameters for the viewed area.
Longitude: Sets the Longitude of the viewed area (center).
Latitude: Sets the Latitude of the viewed area (center).
Distance offset: Sets a fixed distance offset from the selected map.
Distance: Sets a distance from the map.
Diameter: Sets the desired view as Diameter (and not distance).
Pan: Sets a pan value for the camera.
Tilt: Sets a tilt value for the camera.

Geometry: The selected map in the Focus On Map container is fitted to the screen according 
to the Fit To Screen By selection.

Fit To Screen By: Select the 3D Region attribute that is used to fit the map to the 
screen: Width, Height, Min (the minimum value of the map’s width and height), Max 
(the maximum value of the map’s width and height), Average (the average of the 
map’s width and height).
Longitude Offset: Sets a longitude offset from the center of the selected 3D Region.
Latitude Offset: Sets a latitude offset from the center of the selected 3D Region.
Distance Offset: Sets a distance offset from the center of the selected 3D Region.
Pan: Sets a pan value for the camera.
Tilt: Sets a tilt value for the camera.

Camera
The Camera Tab defines the camera parameters such as camera number and minimum and 
maximum distance of the camera from the map.

Camera: Defines the camera number that is affected by the position parameters.

Note: Pan and Tilt parameters are disabled unless the Pan and Tilt 

Animation parameter in the Navigator plug-in is enabled ( On ).




Plug-ins User Guide -  5.0

Copyright © 2022  Vizrt Page  697

•

•

•

•
•

•

•
•

•
•

•

•
•

Navigation Method: Allows you to select whether the camera or the container should also 
move when a map changes position. 

Camera: Moves the camera when the map is repositioned, potentially moving other 
objects out of frame. 
Container: Moves the container instead of the camera, keeping other objects in view 
as the camera is still. In other words, moving the base map instead of the camera to 
see other parts of the map. This setting also means you do not have to use the front 
layer using two cameras to achieve the same effect as when moving the container. 
Borders and other elements on the map can be preloaded once for the base map, but 
this can only be done with a flat map (not a globe).

Clipping Plane Control: Defines the selected camera’s clipping plane. 
Static (Viz): Draws objects within the clipping plane values defined in Viz. For Viz 3.x 
see Scene Settings > Renderer > Camera Clipping Plane. 
Focus On Map: Adjusts the clipping plane values according to the camera position. 
This is automatically done by based on the Near Distance and Far 
Distance parameters.
Near distance (%): Defines the minimum distance of the camera from the map.
Far Distance (%): Defines the maximum distance of the camera from the map.

If Position Source is set to Absolute then the parameter Diameter can also be set here. If Position 
Source is set to Geometry then the parameters Geometry Offset X/Y and Min/Max Distance can 
also be set here.

Labels
The Labels Tab defines label parameters for how labels should be displayed.

Labels: Defines how the labels are displayed:
Overlay: Displays labels as a layer on the screen, but the layer is not affected by the 
camera movement when a new area is selected.
On Map: Displays labels on the map, moving with the map as the selected area is 
changed.
On Map Scaling: Displays labels on the map

Label Camera: Defines the camera number used for displaying the on screen labels.

If Position Source is set to Absolute then the parameter Diameter can also be set here. If Position 
Source is set to Geometry then the parameters Geometry Offset X/Y and Min/Max Distance can 
also be set here.

7.4.11 GeoDataReader

The GeoDataReader plug-in gets a geodata stream or file (.shp/.kml/.kmz/.gdb/.mdb) and inserts 
the data into Viz. The plug-in can use local scene containers or the global ones that were defined 
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in the 3D Map Setting for the design and data. The shapes can be grouped into different 
containers, by their geometry, or grouped together in one container.

The names of the available services can be found inside the  Name  tag under  FeatureType :

<FeatureType> <Name>glacier_outlines</Name> ... </FeatureType>

For example:

http://nsidc.org/cgi-bin/atlas_south?
service=WFS&version=1.1.0&request=GetFeature&typename=glacier_outlines

GeoDataReader Properties

General
Source Type: Sets whether the source is a local file or a web stream.
<Geometry> Design and Holder

Disabled: Does not add this type.
Local: Takes the design and the holder containers locally.
Global: Takes the design from Graphic Hub.

Designs Path: Sets the path to a design folder that is placed inside the Graphic Hub.
<Geometry> Styles Field Name: Determines the name of the field that contains the style 
name that each feature has.
<Geometry> Split

Disabled: Groups all features in one container.
On: Gives each feature its own container.
By Style: Groups features by the style name.

Clear Existing Features on Read

Note: This plug-in is located in: Plugins -> Container plug-ins -> Maps_Adv
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Disable: Adds the features on each Read command.
Enable: Erases the container that holds the source features, then adds the new 
features.

Proxy

Use Proxy: Enables proxy configuration parameters when set to  On . Use this option when 

working an a network with proxy:
IP: Determines proxy server IP number.
Port: Determines proxy port number.
Username/Password: Sets the username and password.

Read: Adds the features from the proxy.
Read and Save As Viz World Binary (VWB): Adds the features from the proxy and saves them.

7.4.12 Geo Text

The Geo Text plug-in displays the longitude and latitude values received from a variety of sources. 
The geographic data is displayed in two text objects (or one) defined by the longitude and latitude 
containers.

Geo Text Properties
The Source defines the source of the geographic data that is displayed in the defined containers 
under the Containers tab.

Source: Defines the source of the geographic data that is displayed in the defined containers 
under the Containers tab.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Maps
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User: Sets the value manually in the Compass, Longitude and Latitude parameters for 
the position and range values. The Compass, Longitude and Latitude parameters are 
enabled only when Position is set to User.
WPosition: Displays the values received from the World Position plug-in on the same 
container as the Geo Text plug-in in the defined Containers.
Navigator: Receives the geographic data from the Navigator plug-in in the scene. The 
received data from the Navigator plug-in is the location of the center of the 
Navigator point of view and the difference between the edges of the current 
Navigator map. The Geo Text plug-in also has placeholders (all requiring a running Viz 
World server) for defining the administration levels:

Country: Gets the current Country
Admin 1: Gets the current administration level 1 (e.g. Region)
Admin 2: Gets the current administration level 2 (e.g. Town)
Location: Gets the lowest administration level (e.g. Place)

WPoint: Displays the value received from the WPosition vmaps plug-in on the same 
container as the Geo Text plug-in in the defined Containers.
Map: Sends the center of the map data to the Longitude and Latitude containers and 
the difference between the edges of the map to the range containers when placed on a 
map container.
Line: Sends the center of the line data to the defined containers in the Containers tab 
when placed on a 3D Line container.
Position: Defines the position text format. Select the required format from the Degrees 
Format list.
Range: Defines the range text format. Select the units for the displayed values and 
select the required format from the Degrees Format list. If Kilometers, Miles or 
Nautical Miles are selected, Dot or Comma can be selected as a separator with a fixed 
decimal point.
Containers: Defines the font objects that display the longitude and latitude values of 
the position and range:

Longitude Position: Links to the text object displaying the longitude position 
data received from the Geo Text plug-in.
Latitude Position: Links to the text object displaying the latitude position data 
received from the Geo Text plug-in.
Compass: Links to an object that is rotated to show the North (based on 
navigator direction).
Longitude Range: Links to the text object displaying the longitude range data 
received from the Geo Text plug-in.
Latitude Position: Links to the text object displaying the latitude range data 
received from the Geo Text plug-in.
Legend: Scales view width and view height values based on the object used for 
the legend.
Length: Links to the text object displaying the length of the line object as 
received from the Geo Text plug-in.
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7.4.13 Hop It

The Hop It plug-in is a utility plug-in which connects the specific design with a hop. It is used when 
the designs (e.g. labels, regions etc) were not generated from the hop you want to connect them to 
(or from no hop at all).

Hop It Properties
Hop Mode

Automatic: Sets hop points automatically (based on searching all hops locations and 
connecting to the one which is closest).
Manual: Sets hop points using the Hop Point parameter.

Hop Point:  Sets the hop point in the hop sequence. Note that the animation is built in the 
same sequential order as the list of Hop Points (Map-Start, Destination-1, Destination-2, and 
so on). If two hops use the same Hop Point, the animation does not work properly.

The three plug-ins that are influenced are Hop Sync, 2D Label and Label It.

7.4.14 Hops Manager

The Hops Manager plug-in controls multiple instances of several plug-ins from one interface. The 
plug-in should only be used if all parameters for the control plug-ins are the same. If for any 
reason different values are needed, the plug-in should not be used.

The plug-in controls the CWMClient plug-in, Map Pyramid plug-in and NavFinder plug-in; however, 
only instances which are part of a hop are controlled. The plug-in has two main options; global 
values and hops.

Hops Manager Properties

Global Values
Global values are used in order to update values globally on all control plug-ins.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Maps_Adv

Note: This plug-in is located in: Plugins -> Container plug-ins -> Maps_Man
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Under the global values tab all parameters are the same as those found in the actual plug-ins you 
want to control. For more information see:

CWMClient
NavFinder

Hops
Hops are used to jump to a specific hop. From this tab you can select and refresh a map and fine 
tune pan values from NavFinder.

Multi Hop: Opens the Multihop Editor in the World Map Editor when the Multihop button is 
pressed.

7.4.15 Hop Sync

The Hop Sync plug-in coordinates between labels and other 3D objects with built-in animations 
and hop animations. The Hop Sync plug-in is applied to the same container as the Label It plug-in, 
or to a container above the label design containers but below the top design container which is 
used to create the label merged object. To use Hop Sync plug-in, the label designs must include a 
merged object containing the design. The plug-in defines a point in the label animation that is 
matched with the hop point in the Navigator animation.

Hop Sync Properties
Director: Defines to which director the label animation is copied to.

Navigator: Copies the label animation to the Navigator director. This option is used 
when the label animation should end before or at the time the Navigator animation 
has reached a hop point. When the Navigator director reaches a hop point and 
Continue is pressed (or pause time ends) the label animation also continues, causing 
the label to disappear.
Hop Director: Copies the label animation to a new director. This option is used when 
the label animation should end after the hops animation has stopped (or paused). If 
the label animation is copied to the Navigator director, the label animation stops 
before the entire label is revealed.
Separate: Copies the label animation to a new director (not the Hop or 
Navigator director) to give you more options. Note that it does not perform animation 
offsets.

Animation Start Time: Defines the point in the label animation that is matched to the hop 
point in the Navigator animation. The value is set by typing in a number (in seconds), or 
clicking and sliding the mouse over the parameter until the animation point is reached. 

Note: This plug-in is located in: Plugins -> Container plug-ins -> Maps
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Another option is to use the Set Highlight Time button. Play the animation and when 
reaching the requested point in the label animation, stop and click the Set Highlight Time. 
The current label animation value is copied to the Animation Start Time field.
Order Offset: Enables/disables an offset between the animation of the objects.

Animation Order Offset Time: Determines the offset for the animation, e.g when 

setting this value to 1.2 , the third detail animation starts after 2.4 seconds after the 

animation has reached the destination.

7.4.16 KML Reader

The KML Reader plug-in adds objects from KML files to the scene. KML files are XML formatted files 
containing information about geographic objects: Labels, shapes, lines. The KML Reader plug-in 
reads the files and generates objects according to the file’s content.

KML Reader Properties

General
KML File: Defines the path to the KML file.
Line Designs and Holder: Defines the graphic designs for lines.

Disabled: Does not use line designs. Lines found in the file are not drawn.
Local: Uses specific line design containers and holder container. When selected 
additional parameters are enabled: Line Designs and Line Holder. Assign the required 
designs and holder to the plug-in.
Global: Uses the global line designs and holder container. The global designs and 
holder are defined in the 3D Map Setting plug-in.

Line Split
Off: Places all lines go into one container.
On: Places every line into its own container.
By style: Places lines that share a style together in a container

Connect Labels to Line: Creates a line by connecting all labels into a line.
Update on Load: Sets whether the data is read when the scene is loaded.
Label Designs and Holder: Defines the graphic designs for labels.

Disabled: Does not use label designs. Labels found in the file are not drawn.
Local: Uses specific label design containers and holder container. When selected 
additional parameters are enabled: Label Designs and Label Holder. Assign the 
required designs and holder to the plug-in.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Maps_Man
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Global: Uses the global label designs and holder container. The global designs and 
holder are defined in the 3D Map Setting plug-in.

Shape Designs and Holder: Defines the graphic designs for shapes.
Disabled: Does not use shape designs. Shapes found in the file are not drawn.
Local: Uses specific shape design containers and holder container. When selected, 
additional parameters are enabled: Shape Designs and Shape Holder. Assign the 
required designs and holder to the plug-in.
Global: Uses the global Shape designs and holder container. The global designs and 
holder are defined in the 3D Map Setting plug-in.

Maximum Number of Shapes:
Georef Images: Defines whether georef images found in the KML file are used.

Disabled: Does not draw images found in the file.
Enabled: Draws images defined in the file and geographically references them. When 
selected an additional parameter is enabled: Georef Images Holder. Assign the 
required holder to the plug-in.

Maximum Number of Labels:

Hop Control
Set Navigator Hops: Creates hop points based on the information in the KML file. Selects 
which information to use (line, shape, etc.).
Exclude Hops: Excludes the hop animation for the following labels; None, First, Last, or First 
and Last. Manual Shift allows you to define which destination is the starting point (limited to 
a selection of 30 destinations).
Start Hop: Determines the starting point for the hop.
Point Data Diameter (km): Sets the diameter used for each hop point when creating hops 
based on labels.
Set Navigator Hops: Enables the scene to do a hop animation between the labels.

Print Debug Information: Prints debug messages to the Viz console when set to On .

Read File: Triggers the plug-in to read the files and re-draw the objects.

Proxy

Use Proxy: Defines the network uses a proxy server. When set to On , additional parameters 

are enabled:
IP: Sets the IP address of the proxy server.
Port: Sets the port number to be used.
Username, Password: Sets the login credentials.

7.4.17 Label AddOn
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The Label AddOn plug-in assigns images, geometries and text based on label parameters. Labels 
can have up to four extra parameters.

Label parents: Country, Admin1, Admin2 (see also Place Finder plug-in)
Label type: Type

Based on the container name (case sensitive), the CWMClient plug-in updates the Value field in the 
plug-in with the correct value. For example, if you have selected London and you have a Label 

AddOn plug-in on a container named Country it receives the value of United Kingdom  and if you 

have another Label AddOn plug-in on a container named Type It receives the value of Capital . A 

use case for this plug-in is whenever you want to have flags for all countries in the world in a 
folder and use the right flag based on the country. Another use case is having different images for 
different types and using the correct image based on the type.

Label AddOn Properties
Type

Images: Can be applied from the database on a local container.
Geometries: Can be applied from the database on a local container.
Text: Can be changed on the local container.

Value: Provides values used to seraph the object or set the text. Can be edited for testing.

Prefix: Sets the prefix used for searching the database. For example  MyImages/Flags/

Suffix  or  _small.
Hide if Empty: Hides the container if an object/image is not found.
Update: Tests the prefix and suffix.

7.4.18 Label and Go Assistant

The Label and Go Assistant plug-in works in conjunction with the Label and Go plug-in to add or 
delete new labels. When working with streets it allows editing labels and replacing names and 
styles of roads. Changes can be saved in a .csv file that can be read afterwards by the Label and 
Go plug-in.

Label and Go Assistant Properties
Label: Names the new label.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Maps_Adv

Note: This plug-in is located in: Plugins -> Container plug-ins -> Maps_Adv
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Input Interface: Toggles whether to use interactive input (combined supports touch) or 
mouse only.
Interactive Input: Toggles revert or replace (in roads mode).
Action: Selects whether to replace name, style or both.
Select Labels (WME): Adds user label from server (WPF).
Select Labels (Classic): Adds user label from server (classic). 

Adding User Labels
Add the Label and Go plug-in to the new container under the hierarchy. 

In the Label and Go plug-in set: Data source to Local File, Edit Mode to be Stand by. 

There are three modes:
Stand by: Allows you to select the place where you want to add or remove your labels.
Active: Allows to add or remove labels depending in your selection.
Modify: Allows you select a label and then you can move it or rename it.

Add the Label and Go Assistant plug-in in the same container that reside the Label and 
Go plug-in.

Tip: You can toggle between the Stand by Mode and the Active Mode by 
pressing E on the keyboard.
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Select PQI-1 for Label number 1 Write the name of the Label. Select PQI-2 for Label number 2 
and change the name. You can create up to 20 Labels.  

Active set to On '0-9' means that hitting the actual number on the keyboard adds labels. You 
can toggle from 0-9 or from 10-20 by pressing control.

Set the Input Interface: Combined - Touch screen and Mouse - Only Mouse.

Set the Interactive input: To Add labels, set to Add. To Delete Labels, set to Delete.
To Add Labels from group number 1: Navigate to the specific area, press 1 on the keyboard 
and click the left button on the mouse. Every time you click a label appears. To change to 
group 2: Press 2 and click on the mouse.
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Deleting User Labels
Set the Interactive input to Delete.
Select the group label and then select the Label that you want to remove.

In order to delete a group of Labels: Press the Label group number in the keyboard to select 
the all group,  Press Shift to draw a rectangle around the labels that you want to remove.

Saving New Labels to a File
Enter to Folder: %ProgramData%\vizrt\VizEngine\Maps\L&GoAssistant/
Create a .txt document and change it to .csv.
In File select the file in the folder and click Save To File. This file can be read by Label and 
Go plug-in. 

Tip: By pressing E in the keyboard you can switch from edit mode to none to see the actual 
results.
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Editing a Label Using the Label and Go Assistant Plug-in
We can change a name of a Road or a street. In the Label and Go plug-in set the Data Source 
to Streets. Set the Edit Mode to Stand By. Zoom to the area that you want to edit the Labels. 

Change the Edit Mode to Active.
Select the Interactive Input: Replace Segment, Select the Action: Replace Name: Name of the 
segment, Replace Style: Primary, Main,Secondary, Replace Name & Style. 

Tip: You can toggle between the options pressing A in the keyboard.
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When you are in Active mode you have an information panel on the left side of the screen.

To revert the changes press Revert Segment Changes. 

Saving the Label Changes to a File
Enter to Folder: %ProgramData%\vizrt\VizEngine\Maps\L&GoAssistant/.
Create a text file and rename it to .csv.
In the Label Changes File, select the file in the folder and click Save Label Changes. 

By pressing the Clear All Label Changes, all changes are cleared, you can Load the file by 
pressing Read Label Changes.
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7.4.19 Label It

The Label It plug-in manages 3D labels and place indicators. The plug-in creates a hierarchy under 
its container for adding a caption, body and pointer objects.

Label It Properties

Caption
Caption defines the relation between the label components (text and pointer). When disabled, 
duplicated labels use the label design exactly. When enabled, the labels use the following options:

Caption Pivot: Defines the connection point between the caption and the body when the 
caption is moved (rotated along the tip). There are two options, Fixed and Edge. 

Fixed: Sets the connection point at the center of the caption. 
Edge: Sets the connection point depending on the correct rotation. If the caption is 
above the tip, the connection point is at the middle lower side of the caption. If the 
caption is on the right side of the tip, it is on the left side of the caption. For example: 
A line moving from the tip to the center of the caption and where it crosses the 
caption bounding box is the connection point.

Rotate Labels: Defines whether labels, created in Viz (3D labels), are rotated like the labels in 

the Map Editor. When set to Off , all labels are displayed horizontally. When set to  On , 

labels that were rotated in the Map Editor are also rotated in Viz.
Caption Source: The options Default Position, WME Directions, and Label Manager 
Presets include the properties described below.

Default Position

This is used when adding labels in WME when no direction is selected.

Direction (deg): Sets the angle of the label in relation to its geographic position.
Distance (cm): Sets the distance of the label from its geographical position.

WME Offsets Distance: Enables the WME to offset the distance when set to On  (default). 

When set to  Off , only the direction offsets from WME are used and the distance is ignored.

WME Directions

This allows you to set and fine tune offsets for every direction available in WME. When selected, the 
labels are placed as they were placed on the map in the Map Editor. When manually set inside WME 
they always take priority over the presets and Default Position settings. The default pointer 

Note: This plug-in is located in: Plugins -> Container plug-ins -> Maps
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direction (angle) and default distance between the pointer and the label is set by the map label 
parameters and used by the Map Editor (WME). If the direction and distance are changed while 
using the WME, the Default Direction and Default Distance values are ignored.

WME Compass Rose: Corresponds to the available directions inside the WME, as shown in the 
following image.

Direction Offset (Degrees): Determines direction offset for fine-tuning the position of the 
label.
Distance (Viz units): Determines the distance offset for fine-tuning the position of the label.

Label Manger Presets

When this is selected, the Label Manager plug-in uses the defined presets to place the labels over 
the map. The Label Manager plug-in optimizes the label position such that the labels do not 
overlap.

Number of Presets: Defines the number of label position presets available to the user (one to 
four presets). This parameter is only enabled when Caption Mode is set to Controlled.
Current Preset: Selects the preset number to be configured, using the Direction and Distance 
parameters. Each preset should be selected and the label position should be adjusted.
Direction (deg): Sets the angle of the label in relation to its geographic position.
Distance (cm): Sets the distance of the label from its geographical position.
Collision Mode: Defines how the labels are placed when an overlap or collision between two 
labels occur. With Tip, the pointers of overlapping labels can cross or touch, but no overlap 
of label bodies are allowed. With Bounding Box, a bounding box is calculated around the 
entire label (label body and pointer). An overlap between labels bounding boxes is not 
allowed.

Overlay
Navigator Overlay defines how the label is displayed over the map. Available options are Disabled, 
Fixed, Scaling, Near Scale and Far Scale.

Disabled: Places the label on the map using its geographical referencing.
Fixed: Places the label by keeping its geographical referencing, but using a different camera 
(either with dynamic image or with a front layer). The label size remains fixed.
Scaling: Places the label by keeping its geographical referencing, but using a different 
camera (either with dynamic image or with a front layer). The label scales to imitate the 
camera movement.

Near Scale: Defines the maximum size of the label on the screen (the final size of the 
label when zooming in).
Far Scale: Defines the minimum size of the label on the screen (the final size of the 
label when zooming out).
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On Map Scale
Static Map Scale: Defines a scaling factor for the duplicated labels on a static map without 

camera movement when set to On . When set to  Off , no scaling is used.

Fade

Stand Alone

Fade: Defines the fade effect parameters to be used with the duplicated labels. Available 
options are Stand Alone and Controlled. Stand Alone enables the user to define the fade 
parameters of the labels, while Controlled can be enabled to define the fade parameters 
when working with the Label Manager plug-in.
Fade on Time: Defines a label fade effect, beginning at a relative point to the defined hop 
duration. An additional parameter is enabled, Time to Hop, defining when the fade occurs.
Fade on Distance: Defines a label fade effect, beginning at a relative distance from the hop 
final location.

Fade on Lat/Long: Defines a label fade effect, beginning at a Longitude and Latitude offset 
from the hop final location. An additional parameter is enabled, Lat/Long, defining the 
offset from in degrees.

Controlled

Step: Controls when the label fades in and out in relation to an animation. In general the 
fade can be based on the camera distance (for example; capitals are in view when distance is 
below 1000KM) or on timing in relation to the hop:

Auto: Fades in and out based on distance to hop when a label is of type point (added 
by the user). If the label is of type place/region, it fades in and out based on the 
distance set in the Label Manager plug-in. If the hop is not close enough for the label 
to show and the label was added by the user, it fades in based on hop timing and not 
distance.
On Hop: Links the fade to the hop timing.
Point 1/Point 2: Reserves labels where the distance is configured by the Label 
Manager plug-in.
Hop and Above: Turns on at the hop and stays on thereafter.

Selected Label Timings: Sets one of the timing options for the fade to occur:
At End: Fades the label after the animation stops and before it continues.
Close To End: Fades the label just before the animation stops and just after the 
animation continues.
Ahead: Fades the label before the animation stops and after the animation continues.
Well Ahead: Fades the label long before the animation stops and long after the 
animation continues.

Note: The Fade On Distance parameter is enabled only if Overlay is set to Scaling.
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Label Priority: Sets the duplicated labels priority. This parameter is useful for a large number 
of onscreen labels and not all can be displayed. The priority levels define which labels are 
displayed and which labels are hidden.

Auto: Allows the Label Manager plug-in to set priorities.
Normal, High: Sets priorities to normal and high.
Always: Displays labels every time.

Practical Use
When adding a Label It plug-in, three containers are added under the Label It container: CAPTION, 
BODY and TIP. Drag a text object under the CAPTION container. The BODY container is the 
pointer’s body and the TIP is the pointer’s end.

7.4.20 LatLongGrid

The LatLongGrid plug-in draws latitude and longitude lines on the map. The lines are generated 
using the 3D Line plug-in.

LatLongGrid Properties
Spacing

20/10/5 Degrees: Spacing in degrees for each line in the grid.
Manual: Defines the Spacing Units (Degrees or Meters) using manual input and defines 
separate spacing for longitude and latitude lines and the Origin Latitude/
Longitude (starting point for the grid).

Prune Longitude Lines at Pole: Continues to draw lines at the poles instead of pruning 
(cropping) the geometry at the poles when Disabled.
Latitude/Longitude Designs: When set to Single, both longitude and latitude lines are drawn 
using the same 3D Line plug-in. When set to Separate it allows using separate 3D Line plug-
ins for each to achieve a different look for latitude and longitude lines.

IMPORTANT! A text object under the label design must be named label to receive the name 
of the object from the CWMClient plug-in.



Note: This plug-in is located in: Plugins -> Container plug-ins -> Maps
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7.4.21 Locator Control

The Locator Control plug-in links an object positioned on one map to another map, showing its 
position. The object marking the point on the linked map must reside under a geographically 
referenced map. The linked object shows the position of the linked map or object on the map its 
parent map.

Locator Control Properties
Position Type: Defines the link between the object and the map. Available options 
are Map, Navigator, WPosition, WPoint and User.

Map
Map links the object to a map, showing its entire area over the parent map.

Remote Container: Defines the linked map container.
Control Size: Marks the entire area of the linked map on the parent map when set to 

Off . When set to  On , the size of the marked area can be controlled.

Basic Size: Defines the percentage of the linked map area to be marked.
Min Size: Defines the minimum size of the linked map area to be marked.
Max Size: Defines the maximum size of the linked map area to be marked.
Shared Memory Link: Defines which is the master (source) and client (target) when the same 
Shared Memory Identifier is used.
Type: Defines the accessibility of the shared memory.

Global: Makes shared memory accessible to all scenes currently loaded in memory. 
This is useful when working with Transition Logic scenes where your Viz World map 
can be one scene and the locator a different one and data can easily be transferred 
between the two.
Scene: Makes shared memory accessible locally and to the current scene. Every scene 
has one shared memory map that can be used to exchange data among the scripts in 
the scene.
Distributed: Makes shared memory accessible to all computers connected to one Viz 
Graphic Hub.

Identifier: Defines the identifier for the shared memory map.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Maps
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Navigator
Navigator links the object to a Navigator plug-in, showing its position on the parent map. The 
plug-in locates the navigator container above it in the scene tree. The Navigator tab displays the 
same settings as Map with the exception of the Remote Container setting.

WPosition
WPosition links the object to a World Position plug-in, showing its position on the parent 
map. Remote Container defines the linked World Position container.

WPoint
WPoint links the object to a WPoint plug-in, showing its position on the parent map (the WPoint 
plug-in is used in Viz Weather). Remote Container defines the linked WPoint container.

User
User enables the user to position the object on the map.

Map Center Longitude: Defines a Longitude value for the object.
Map Center Latitude: Defines a Latitude value for the object.

Tangent To Globe: Rotates the controlled object to match the globe surface when set to On .

7.4.22 Map Layers

The Map Layers plug-in exposes map layers to an external application. Map layers are labels, 
regions, and so on.

Map Layers Properties
Mode: Defines the layer maps mode Static and Dynamic.

Static: Enables maps to be imported to Viz Artist’s image library and saved with the 
scene.
Dynamic: Enables pyramid maps to be loaded from the cache and temporary folder. 
When the CWMClient plug-in receives a new map, all layers are updated.

Note: Tangent To Globe is only visible when the locator is under a globe object.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Maps
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Texture Compression: Sets the compression level for the texture (DTX5 is the highest 
compression level, which is less texture quality).
Texture Quality: Sets linear for using the same image resolution in the entire zoom range, or 
Mipmap to change resolution according to the distance from the image (managed 
automatically in Viz Artist).
Texture Mapping: Defines how the texture (map) is mapped.
Texture Anisotropic Filter: Turns on the relevant anisotropic in the image on the same 

container with CWMClient (similar to Mipmap, above). Available settings are Off / 2x / 4x /

8x / 16x .

Edited Layer: Sets the layer number for editing. Each layer is then assigned map properties 
to display.
Active: Activates or disables the selected layer.
Container: Assigns the container for holding the created layer map.

Flags:  Enables ( On ) the requested property to expose the map property or feature in the 

selected layer. Flags refer to all the settings from Base Map to Overlay Data.
Build Tiles: Builds the map layers.

7.4.23 Map Layers Control

The Map Layers Control plug-in controls map layers in an individual map and in map tiles (Pyramid 
or Map Tiler tiles). The plug-in should reside on the CWMClient container which generates the 
maps and tiles.

Map Layers Control Properties
Select an option to configure: Map or Tiles. Each can be enabled and configured separately.

Control: Enables layer parameters when enabled. See Map Layers plug-in for the layers 
description.

7.4.24 Map Tiler

The Map Tiler plug-in builds a set of map tiles for displaying an area in high resolution. The maps 
are created as GeoImage (flat map) or Globe objects and placed under a low resolution map of the 

Note: This plug-in is located in: Plugins -> Container plug-ins -> Maps
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entire area for geographical referencing. The Map Tiler plug-in is also used for managing Pyramid 
object maps when used in a scene.

Map Tiler Properties

Default
Selected Region: Defines the area of the map for which the tiles are created.

World: Creates tiles for the entire world.
Selected Map: Creates tiles for the area of the selected map in the CWMClient plug-in 
attached to the Map Tiler container.
Region List: Displays a list of regions. An item from the list can be selected to create 
map tiles for the selected area.
Long Lat: Sets the Longitude and Latitude minimum and maximum values. The map 
tiles are created for the defined area. When Long Lat option is selected, additional 
fields are enabled.

Map Status: Displays plug-in status messages. When configuring the tiles, the Map Status 
field displays the number of tiles required and tile size according to the current plug-in 
setup.
Requested Number of Tiles (2K2K): Allows the user to set the number of tiles to create.
Geometry Type: Selects the object type of the created tiles.

Globe: Creates the tiles using the Globe plug-in.
Flat: Creates the tiles the GeoImage plug-in.

Selected Map

Texture Compression: Sets the compression level for the texture (DTX5 is the highest 
compression level which is less texture quality).
Get Map Resolution/(Classic): Uses the WME Editor to zoom to the closest level you want the 
tiles to support. If you change the extent (in Selected Map mode) you need to set the 
resolution again.

Region List

Region Area: Selects the region you want to build tiles for.

Long Lat

West: Sets the Longitude value for the western edge of the map.
East: Sets the Longitude value for the eastern edge of the map.
South: Sets the Latitude value for the southern edge of the map.
North: Sets the Latitude value for the northern edge of the map.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Maps
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Custom
The following additional parameters are available:

Radius/Map Size: Sets the size (in Viz units) of the globe or map tiles (all together).
Tessellation: Determines the number of polygons used in the object. The higher the number 
is, the smoother the object is drawn.
Texture Quality: Uses the same image resolution in the entire zoom range when set to 
Linear. When set to Mipmap the resolution is changed according to the distance from the 
image (managed automatically in Viz Artist).
Overlap (%): Determines the overlapping percentage for each tile.
Build Terrain: Builds terrain data for the created tiles.
Smooth Terrain: Smoothens terrain edges so they blend with the base map surface. When set 

to  On , the Terrain Smoothing Factor is enabled.

Terrain Smoothing Factor: Sets the percentage of the smoothed area.
Terrain Height Scale: Sets the scaling factor for terrain height. The higher the factor is, the 
more extreme the terrain is.
Terrain Resolution: Sets the total terrain resolution for all tiles. A high resolution 
value results in a more detailed terrain (affecting performance).

Buttons
Build Tiles: Builds the geo-reference map and tiles.
Change All Maps: Builds the geographical reference map, tiles and applies style changes 
made in the CWMClient plug-in to all child containers (recursively) under the Map Tiler 
container.
Build Tiles (Force New): Builds the geographical reference map and tiles without checking the 
cache for existing maps (from the server).
Change All Maps (Force New): Builds the geographical reference map, tiles and applies style 
changes made in the CWMClient plug-in to all child containers (recursively) under the Map 
Tiler container, without checking the cache for existing maps (from the server).
Calculate Tiles Info: Calculates the tiles information, without building the tiles, and displays 
it in the Map Status field.

7.4.25 Map Zoom

The Map Zoom plug-in builds single destination animated scenes. Because the scene is treated as 
an independent Map Object it can be added into any graphic including Transition Logic scenes. 
The map is created as GeoImage (flat map) and adds all necessary plug-ins to the hierarchy.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Maps
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Map Zoom Properties

Zoom: Defines the zoom in percent ( 0-100% ), in order to animate to the final destination.

Labels: Takes the size of the label from the original design when set to Fixed. When set 
to Auto Scale, the size is calculated based on the size of the map.

7.4.26 Mouse2Memory

The Mouse2Memory plug-in sends mouse events to shared memory.

Mouse2Memory Properties

Shared Memory
Map Type: Defines the accessibility of the shared memory.

Global: Makes shared memory accessible to all scenes currently loaded in memory. 
This is useful when working with Transition Logic scenes where your Viz World map 
can be one scene and the locator a different one and data can easily be transferred 
between the two.
Scene: Makes shared memory accessible locally and to the current scene. Every scene 
has one shared memory map that can be used to exchange data among the scripts in 
the scene.
Distributed: Makes shared memory accessible to all computers connected to one Viz 
Graphic Hub.

Reset Before Change: Resets the data before sending (ensures the same data is not sent 
twice due to shared memory blocking it).
Key: Defines the shared memory key name that receives the data field value.
Value: Defines the data field value for the shared memory key.
Execute: Sends data to shared memory.

Picking
Camera: Determines the camera to use for the projection.
Picking Active: Limits picking to a rectangle.
Position X (%): Determines X value of rectangle.
Position Y (%): Determines Y value of rectangle.
Width (%): Determines width of rectangle.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Tools
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Height (%): Determines height of rectangle.
Preview: Displays the rectangle.
Execute: Sends data.

7.4.27 Mute

The Mute plug-in determines if a container is drawn or not.  The difference between using the 
Mute plug-in and setting the visibility off is that when using the plug-in only containers with the 
plug-in are not drawn, but all child objects are drawn and the geometry properties are used in the 
hierarchy (geographical reference, and so on). When setting the visibility off, the entire container 
and its child containers are disabled and not used in any way.

Mute Properties

Draw Geometry: Draws geometry when enabled ( On ). When disabled ( Off ), the geometry is 

not drawn, but its child containers are drawn.

7.4.28 NavCom

The NavCom plug-in controls the Navigator plug-in. The plug-in is an example showing how to 
externally control the Navigator plug-in when special applications should be used to control the 
scene. An example for a special case where external control of the Navigator plug-in is required is 
Elections. When using Viz 3.x scripting, complicated logic and commands can be used with the 
NavCom plug-in.

NavCom Properties

Commands
The Commands tab is used for communicating with the Navigator plug-in in means of sending 
formatted commands and receiving formatted responses from the Navigator plug-in.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Tools

Note: This plug-in is located in: Plugins -> Container plug-ins -> Maps_Adv
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The Command text field is where you enter the command. The NavCom plug-in receives 
predefined, fixed syntax, commands and returns a reply from the Navigator plug-in. The Response 
field contains the reply returned from the Navigator plug-in. The format of the reply is defined in 
the Advanced tab. The Immediate Response option defines whether the command is sent while 
typing (every change to the command field sends the command to Navigator), or only after 
pressing the Execute Command button.

The following is a list of commands, example commands and return values:

Mouse To Lon Lat: Converts screen coordinates to Long/Lat values from the map. This needs 
the Navigator plug-in.

Command:  MTLL x y

Response:  lon lat

MTLL 360 288 -116.998 38.088

Mouse To Region: Returns the region name in which the given screen coordinates reside. 
This command requires the Navigator plug-in.

Command:  MTR x y

Response:  CountryID  " Country Name "  RegionID  " Region 

Name "  SubRegionID  " Sub Region Name "

MTR 360 288 1000000000003600 "United States of America" 1000000000038901 
"Texas" 1000000000111302 "Atascosa County"

All Fly To commands require the Navigator and the NavFinder plug-in. Also set the 

Navigator plug-in’s Interactive Anim setting to On .

Fly To Region ID: Triggers a Navigator animation from the current location to the sent region 
(RegionID).

Command:  FTRID RegionID

FTRID 81000000000F8285

Fly To Country: Triggers a Navigator animation from the current location to the sent country 
(country name).

Command:  FTC "country name"

FTC "united states of America"

Fly To Region: Triggers a Navigator animation from the current location to the sent region 
(Region name).

Command:  FTR "country" "Region"
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FTR "united states of America" "Texas"

Fly To Sub Region: Triggers a Navigator animation from the current location to the sent sub 
region (by name).

Command:  FTSR "country" "Region" "Sub Region"

FTSR "united states of America" "Texas" "young county"

Fly To Lon Lat Level: Triggers a Navigator animation from the current location to the sent 
level area (country, region, or sub region) that the long/lat data resides in.

Command:  FTLLL lon lat level

FTLLL -116.998 38.088 1

Search database: Searches the map database and as a response generates an XML. This 
command requires a running Viz World server.

Command:  SMDB <query>
Search web: Searches the web and as a response generates an XML. This command requires 
a running Viz World server.

Command:  SWEB <query>
Search All: Searches both resources (map database and web) and as a response generates an 
XML. This command requires a running Viz World server.

Command:  SALL <query>

Shared memory reply:  WS_REPLY
Nearby: Searches locations in the vicinity of the coordinates of your “mouse” and as a 
response generates an XML. This command requires a running Viz World server. This 
command requires the Navigator plug-in.

Command:  NEARBY [mouse-x] [mouse-y]

Shared memory reply:  NAV_NEARBY_REPLY

Shared Navigation memory of the Navigator plug-in can be activated by setting Publish 
Geo Data to Bounding box or Location. If Bounding box is selected you get, in addition 
to Bounding box data, Center and Distance data. If Location is selected you get, in 
addition to the Location data, all the others. If None is selected, no data is shared. All 
can be used with scripting to define e.g. the administration levels the script should 
fetch from the shared data and consequently display it on screen. For interactive 
scenes such as touch screens this can be used for adding graphics to maps based on 

Note: Levels are: 0 = Country, 1 = Region, 2 = Sub Region
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your selection (thereby avoiding over-populating the map with information). For 
testing you can enable the interactive mode by clicking the E button in Viz Artist’s 
Scene Editor.

Navigation location: Shared data holding the current geographic location(s) of the Navigator 
plug-in. To enable it, select Publish Geo Data’s Location option. The data is updated when 
the camera is not moving. Navigation location also generates an XML with the current 

geographic location(s) (in the same format as  SMDB ,  SWEB ,  SALL  and  NEARBY ). This 

requires a running Viz World Server.

Name:  NAV_LOCATION_DATA
Navigation bounding box: Shared memory data holding the current (frame by frame) 
geographic bounding box (lat lon) of the Navigator plug-in. To enable it, select Publish Geo 
Data’s Bounding box or Location option.

Reply:  NAV_BB_DATA
Navigation center: Shared memory data holding the current (frame by frame) geographic 
center of the Navigator plug-in. To enable it, select Publish Geo Data’s Bounding box or 
Location option.

Reply:  NAV_CENTER_DATA
Navigation distance: Shared memory with the current distance to world of 
the Navigator plug-in. To enable it, select Publish Geo Data’s Bounding box or Location 
option.

Reply:  NAV_DISTANCE_DATA
Navigation direction: Shared memory with the current pan and tilt direction of 
the Navigator plug-in. To enable it, select Publish Geo Data’s Bounding box or Location 
option.

Reply:  NAV_DIRECTION_DATA

Control
The Control tab is used to directly control the Navigator plug-in by changing the values of the 
parameters.

Longitude: Sets the longitude value for the Navigator plug-in. The Navigator camera moves 
to the specified longitude value.
Latitude: Sets the latitude value for the Navigator plug-in. The Navigator camera moves to 
the specified latitude value.
Distance: Sets the Navigator distance from the map. The Navigator camera moves to the 
specified distance value.
Pan: Sets the pan value of the Navigator camera.
Tilt: Sets the tilt value of the Navigator camera.
Interactive Mode: Defines the interactive behavior of Viz. 

None: Disables interactive mode.
Editor: Enables interactive mode during scene editing.
On Air: Enables interactive mode when Viz Engine is in On Air mode.
Always: Enables interactive mode during scene editing and when Viz Engine is in On 
Air mode.
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Minimum Distance: Sets the minimum distance from the map in Viz units.
Zoom Center: Used in interactive mode.

Position: Zooms the map to center on the position of the fingers.
Center: Zooms to the center of the map.

Momentum Mode: Sets how much friction should be applied to the momentum when set to 
Linear.

Advanced
The Advanced tab is used for defining the NavCom plug-in’s general behavior patterns.

Shape File Support: Defines whether the NavCom plug-in includes shape objects information 
in the response. The Shape objects must reside under the NavCom container. 

Disabled: Does not return shape object information.
Limited: Scans the shape files below the container. When a command is received, the 
NavCom plug-in returns information about the shapes that overlap the requested data 
in the command in the response string. 
Only: Scans the shape files below the container. When a command is received, the 
NavCom plug-in returns only the information about the shapes that overlap the 
requested data in the command in the response string.

Limit Picking: Limits the geographical area that the NavCom plug-in performs any of the 
commands on. When Limit Picking is enabled the Limit to Country parameter is enabled.

Limit to Country: Sets the country name. If the requested data in the command does 
not exist for the defined country area, the command is not executed. Only commands 
relating to points within the country area are executed.

Shared Memory Prefix: Distinguishes between the data sent to each plug-in when using more 
than one NavCom plug-in in the scene, and when using scripting to send and receive 
information from these plug-ins. In each NavCom plug-in, set the Shared Memory Prefix to a 
different prefix (up to four).
Protocol Mode: Defines the data displayed in the Response field.

Full: Includes data on names and IDs for countries, regions and sub-regions.
Name: Includes data on names for the countries, regions and sub-regions.
ID: Includes only ID data (as defined in the Viz World Server) for the countries, regions 
and sub-regions.

Protocol Separator: Defines the separating character between the Response data. The 
defined separator is used between country and region, region and sub-region, and so on.
Use Quotes: Defines whether the response string is quoted or not.
Suffix FIPS: Used for USA regions and sub-regions.
Publish Geo Data: Allows you to publish navigation data to shared memory based on your 
interaction with the graphics scene (e.g. touchscreen or mouse). Shared Navigation memory 
can be activated by setting to Bounding box or Location. See the available Navigation data 
under the Commands section.

Bounding box: Sends Center and Distance data in addition to Bounding box data. 

Note: The Navigator control parameters affect the Navigator immediately.
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Location: Sends all the others in addition to the Location data. 
None: Does not share data.

Execute Command: Executes the defined command when pressed.
Initialize: Rescans the shape objects if the shape objects under the NavCom container are 
changed. This button is used when using shape file support.

NavCom Scripting
Viz 3.X scripting ability is a powerful tool for implementing complex logic into a scene. In a 
Navigator scene, NavCom can be used in the scripts to enable such advanced 
Navigator operations. The following script example demonstrates how to send and receive data 
from the Navigator plug-in through to the NavCom plug-in.

dim level as Integer
dim ignore as Integer
dim CurCountry as string
dim CurCountryId as string
dim CurState as string
dim CurStateId as string
dim CurCounty as string
dim CurCountyId as string

Sub UpdateCurrent(temp As String)
    dim position as Integer
    dim temp2 as String
    println temp
    CurCountryId = temp.left(16)
    position = temp.Find("\"")
    temp = temp.GetSubstring(position+1,temp.Length-(position+1) )
    temp2 = temp    position = temp2.Find("\"")
    CurCountry = temp2.Left(position)
    println "<" & CurCountryId & "><" & CurCountry & ">"
    position = temp.Find("\"")
    temp = temp.GetSubstring(position+2,temp.Length-(position+2) )
    CurStateId = temp.left(16)
    position = temp.Find("\"")
    temp = temp.GetSubstring(position+1,temp.Length-(position+1) )
    temp2 = temp
    position = temp2.Find("\"")
    CurState = temp2.Left(position)
    println "<" & CurStateId & "><" & CurState & ">"
     position = temp.Find("\"")
    temp = temp.GetSubstring(position+2,temp.Length-(position+2) )
    CurCountyId = temp.left(16)
    position = temp.Find("\"")
    temp = temp.GetSubstring(position+1,temp.Length-(position+1) )
    temp2 = temp
    position = temp2.Find("\"")

Example: Script example: main.txt
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    CurCounty = temp2.Left(position)
    println "<" & CurCountyId & "><" & CurCounty & ">"
End Sub

Sub OnInit()
    ignore = 0
     level = 1
     if Scene.Map.ContainsKey("MTR") = false Then

Scene.Map.CreateKey("MTR")
    End If
    if Scene.Map.ContainsKey("FTRID") = false Then

Scene.Map.CreateKey("FTRID")
    End If
    if Scene.Map.ContainsKey("FTC") = false Then

Scene.Map.CreateKey("FTC")
    End If
    if Scene.Map.ContainsKey("FTR") = false Then

Scene.Map.CreateKey("FTR")
    End If
    if Scene.Map.ContainsKey("FTSR") = false Then

Scene.Map.CreateKey("FTSR")
    End If
    if Scene.Map.ContainsKey("FTLLL") = false Then

Scene.Map.CreateKey("FTLLL")
    End If
    if Scene.Map.ContainsKey("MTR_REPLY") = false Then

Scene.Map.CreateKey("MTR_REPLY")
    End If
    if Scene.Map.ContainsKey("FTRID_REPLY") = false Then

Scene.Map.CreateKey("FTRID_REPLY")
    End If
    Scene.Map.RegisterChangedCallback("MTR_REPLY")
    System.Map.RegisterChangedCallback("REGION_L")
 End Sub

Sub OnSharedMemoryVariableChanged(map As SharedMemory, mapKey As String)
     println mapKey
    dim temp as String
    If mapKey = "REGION_L" Then

println "ignore pre"
ignore = 1

    else If mapKey = "MTR_REPLY" Then
temp = Scene.Map["MTR_REPLY"]
UpdateCurrent(temp)
println System.Map["REGION_L"]

if System.Map["REGION_L"] = "1" then
Scene.Map["FTRID"] = CurCountryId

elseif System.Map["REGION_L"] = "2" then
Scene.Map["FTRID"] = CurStateId

elseif System.Map["REGION_L"] = "3" then
Scene.Map["FTRID"] = CurCountyId

End If
    End If



Plug-ins User Guide -  5.0

Copyright © 2022  Vizrt Page  729

•

•
•

•

•

•

    If mapKey = "MTLL_REPLY" Then
println    Scene.Map["MTLL_REPLY"]

    End If
 End Sub

sub OnLButtonDown()
    dim temp as String
    if System.MouseX < (System.RenderWindowWidth: 120 ) then

Scene.Map["MTR"] = (String)
 System.MouseX & " " & (String)System.MouseY
    end if
end sub

7.4.29 NavFade

The NavFade plug-in defines the visibility of an object that the NavFade is attached to in 
a Navigator scene. The Navigator point of view (distance from the map) determines when the 
object becomes visible. The NavFade uses an alpha plug-in to control the object’s appearance. The 
alpha plug-in is added automatically when adding NavFade to the container.

NavFade Properties

Height
The object fades in or out depending on camera height (above the map).

Fade Invert: Fades starting at 100% alpha to 0% alpha, instead of from 0% alpha to 100% 

when set to On .

Fade Time: Defines the fade transition duration in fields.
Visibility Range: Defines how the fade point is calculated.

Below: Makes the object visible when the defined height is higher than the 
current Navigator distance from the map.
Above: Makes the object visible when the defined height is lower than the current 
Navigator distance from the map.
Range: Makes the object visible when the defined height is between the defined low 
and high values.

Below Or Above

When Visibility Range parameter is set to Below or Above:

Note: This plug-in is located in: Plugins -> Container plug-ins -> Maps
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Height: Defines the height value that the NavFade plug-in uses as the show/hide point of the 
object when Visibility Range parameter is set to Below or Above.
Set Height: Inserts the current camera height into the height field when clicked.

Range

When Visibility Range parameter is set to Range:

Low/High: Sets the lowest/highest value of the height range that the object is visible in. If 
the current Navigator height is between the low and high values, the object is visible.
Set Range High/Low: Copies the current Navigator height value to the High/Low parameter.

Hops
The object fades in or out depending on the defined hop point and the animation time to/from the 
selected hop point.

Fade Invert: Fades starting at 100% alpha to 0% alpha, instead of from 0% alpha to 100% 

when set to  On .

Fade Time (fields): Defines the fade transition duration in fields.
Time to Hop (%): Sets the point in which the object appears/disappears. The time is set as a 
percentage of the hop duration.
Hop Mode: Defines whether the NavFade plug-in affects the manually selected hop or if the 
hop is auto selected when the designs copied by CWMClient.
Hop to Link: Sets the number of the hop points that NavFade uses as a reference. When 
animating to and from the selected hop, the object appears/disappears.
Hop and Above: Considers all hops with a higher number than the selected hop when 
enabled. When enabled, all hops which number is higher than the selected hop is considered 
as the selected hop. Defines whether the NavFade plug-in affects the manually selected hop 
or if the hop is selected by the NavFade plug-in. The Constant option causes the object to 
fade on at Hop to Link and stay on from that point onwards. The Related option allows you 
to relate hops to a set of containers. You can for example use the NavFinder plug-in to 
define three hops, and then add three text containers as sub-containers of a container 
holding the NavFade plug-in. Setting NavFade to Related allows the NavFinder hops to relate 
to the text containers found under the NavFade container and fade them in and out as part 
of the hop animation.

Distance
The object fades in or out depending on the distance from the map.

Fade Time: Defines the fade transition duration in fields.
Visibility Range: Defines how the fade point is calculated. Available options are Below, Above 
and Range.

Below: Makes the object visible when the defined distance is higher than the 
current Navigator distance from the map.
Above: Makes the object visible when the defined distance is lower than the 
current Navigator distance from the map.
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Range: Makes the object visible when the defined distance is between the defined low 
and high values.

Below Or Above

When Visibility Range parameter is set to Below or Above:

Distance: Defines the distance value that the .NavFade vmaps plug-in uses as the show/hide 
point of the object.
Set Distance: Copies the current Navigator distance value to the Distance parameter.

Range

When Visibility Range parameter is set to Range:

Low/High: Sets the lower/higher value of the distance range that the object is visible in. If 
the current Navigator distance is between the low and high values, the object is visible.
Set Range High/Low: Copies the current Navigator height value to the High/Low parameter.

Angle
The object fades in or out depending on the angle between the camera and the map.

Fade Invert: Fades starting at 100% alpha to 0% alpha, instead of from 0% alpha to 100% 

when set to  On .

Fade Time: Defines the fade transition duration in fields.
Visibility Range: Defines how the fade point is calculated. Available options are Below, Above 
and Range.

Below: Makes the object visible when the defined angle is higher than the 
current Navigator angle between the camera and the map.
Above: Makes the object visible when the defined angle is lower than the 
current Navigator angle between the camera and the map.
Range: Makes the object visible when the defined angle is between the defined low 
and high values.

Below And Above

When Visibility Range parameter is set to Below or Above:

Angle: Defines the angle value that the .NavFade vmaps plug-in uses as the show/hide point 
of the object.
Set Angle: Copies the current Navigator angle value to the angle parameter.

Range

When Visibility Range parameter is set to Range:

Low/High: Sets the lowest/highest value of the angle range that the object is visible in. If the 
current Navigator angle is between the low and high values, the object is visible.
Set Range High/Low: Copies the current Navigator height value to the High/Low parameter.
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Movement
Alpha values fade on/off based on if Navigator is currently moving or stationary.

7.4.30 NavFinder

The NavFinder plug-in sets hop points over a given map. The NavFinder must reside under a 
Navigator plug-in container and a map.

NavFinder Properties

Common Properties
Hop Point: Sets the hop point in the hop sequence. Note that the animation is built in the 
same sequential order as the list of Hop Points (Map-Start, Destination-1, Destination-2, and 
so on). If two hops use the same Hop Point, the animation does not work properly.
Position Source: Defines how the hop location is set. Available options are Map, Absolute, 
Geometry and Link.

Buttons

Goto Map: Jumps to the defined hop point on the map.
Take Current Values: Takes the current position and uses that as the hop position. This 
option is normally used with interactive mode in the Navigator plug-in. The user moves the 
object to the required position and sets the values for the NavFinder.
Fly to Map: Creates an instant animation and run from the current map location to the 
current hop point defined by the NavFinder plug-in. This feature is active only if 

the Interactive Anim parameter in the Navigator plug-in is enabled ( On ).

Get Map: The user can navigate manually to any destination and by pressing the Get Map 
button, the currently viewed map is used. CWMClient must be on the same container and if a 
pyramid plug-in is used, the pyramid layers are built.
Add Linked Hop: Adds a hop (container with NavFinder set to Link) under the current 
NavFinder container. See Link tab description for more information.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Maps

Tip: Take Current Values can be used in interactive mode. The user can position 
itself using the mouse and then tell NavFinder to use the current values.
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Map
The Position Source Map uses the current location from the map (center of the screen values) and 
adds offsets for fine tuning.

Fit To Screen By: Defines what the end frame of the animation (hop) is. When the hop is 
defined as a 3D Region object on the map, the animation ends when the bounding box of 
the object fills the frame. Available parameters for defining how the bounding box is 
calculated are Width, Height, Min, Max and Average.

Width: Uses the width of the object’s bounding box to calculate the last frame of the 
hop animation.
Height: Uses the height of the object’s bounding box to calculate the last frame of the 
hop animation.
Min: Uses the minimum value between the width and the height of the object to 
calculate the last frame of the hop animation.
Max: Uses the maximum value between the width and the height of the object to 
calculate the last frame of the hop animation.
Average: Uses the average value between the width and the height of the object to 
calculate the last frame of the hop animation.

Longitude offset: Defines Longitude offset based on the current position.
Latitude offset: Defines Latitude offset based on the current position.
Distance offset (%): Changes the distance zoom from the map (zoom in or out).
Pan: Sets a pan value for the camera.
Tilt: Sets a tilt value for the camera.

Absolute
Absolute sets the Longitude and Latitude values of the hop point location. Changes the Distance 
and Distance Zoom parameters:

Longitude: Defines the longitude for the hop position.
Latitude: Defines the latitude for the hop position.
Distance Offset (%): Sets an offset to the distance of the camera from the destination.
Distance: Changes the distance from the map.
Diameter: Sets the desired view as diameter (and not distance)
Pan: Sets a pan value for the camera.
Tilt: Sets a tilt value for the camera.

Note: Pan and Tilt parameters are disabled unless the Pan and Tilt Animation

parameter in the Navigator plug-in is enabled ( On ).


Note: Pan and Tilt parameters are disabled unless the Pan and Tilt Animation

parameter in the Navigator plug-in is enabled ( On ).
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Geometry
Geometry uses the current location from the 3D Region plug-in (center of the region values). Add 
offsets for fine tuning. See the Map and Absolute sections for descriptions of the parameters.

Link
The Link mode is used when one hop resides as a child of another hop. the child hop is set to link. 
When changing the top hop, the child hop changes accordingly, maintaining the same animation 
that was created during the design. 

In Country and Region mode the navigator position is based on the country or region where the 
destination (link source) is, whereas in Level up mode the navigator position is one administration 
level (e.g. Place is leveled up to Town) above the destination (link source). In Country, Region and 
Level Up mode you have the following settings:

Distance Offset: Sets an offset from the calculated distance after the top hop was changed.
Pan Offset: Sets an offset from the calculated pan after the top hop was changed.
Tilt Offset: Sets an offset from the calculated tilt after the top hop was changed.

Interpolation mode has the following setting:

Interpolation:Interpolates navigator position between the gap above and below (useful for a 
drill down with a pause in the middle)

Offset mode has the following settings:

Longitude Offset: Sets an offset from the calculated hop longitude location after the top hop 
was changed.
Latitude Offset: Sets an offset from the calculated hop latitude location after the top hop was 
changed.
Min Distance/Max Distance: Sets the minimum and maximum distance from the map. Using 
the same parameters for both settings gives you a fixed distance. See the Map and Absolute 
sections for descriptions of the other parameters.

Frame
Source <#>:
Source <#> Active:

7.4.31 Navigator

Note: Pan and Tilt parameters are disabled unless the Pan and Tilt Animation parameter in 

the Navigator plug-in is enabled ( On ).
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The Navigator plug-in enables the user to create realistic animations from one point to another on 
the map (for example fly over a flat map or globe). It is also used for navigating on a map (moving 
the camera) to a defined location using pan and tilt values.

Navigator Properties

Camera

Position

The Position button displays the camera position parameters.

Camera: Defines the camera that is affected by the position parameters.
Longitude: Defines the Longitude camera position on the map/globe.
Latitude: Defines the Latitude camera position on the map/globe.
View: Defines the Camera’s view distance from the map.
Pan: Defines the Camera’s pan value.
Tilt: Defines the Camera’s tilt value.

Advanced

The Advanced button displays the advanced camera parameters.

Roll: Sets the roll value of the camera. This parameter is enabled only if the Keep The 

Horizon Horizontal parameter is set Off .

Keep The Horizon Horizontal: Maintains the horizon and disables roll movement when set to 

On .

View Units: Sets the way the number entered in the View field (see Navigator) is 
treated. Distance defines the number of Viz units from the camera to the map. Visible 
View is based on the view (i.e. how many km/miles and so on) you see in units defined by 
the 3D Map Setting plug-in.
Clipping Plane Control: Defines the distance range that is drawn by the camera. Objects 
located closer to the camera than the _Near _parameter and objects located farther that the 
_Far _parameter is not drawn.

Static (Viz): Draws the objects within the clipping plane values defined in Viz. For Viz 
2.x see Setup > Camera > Camera Clipping Plane. For Viz 3.x see Scene Settings >
Renderer > Camera Clipping Plane.

Note: Only containers with a NavFinder plug-in are refreshed.

Note: Orthographic cameras are not currently supported by Viz World.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Maps
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Navigator: Adjusts the clipping plane values according to the camera position. This is 
automatically done by the Navigator plug-in based on the Near Distance and Far 
Distance parameters.

Near Distance (%): Defines the percentage of the camera distance from the map, which is 
used as the Near distance of the clipping plane.
Far Distance (%): Defines the percentage of the camera distance from the map, which is used 
as the Far distance of the clipping plane.
Navigation Method: Allows you to select whether the camera or the container should also 
move when a map changes position. 

Camera: Moves the camera when the map is repositioned, potentially moving other 
objects out of frame. 
Container: Moves the container instead of the camera, keeping other objects in view 
as the camera is still. In other words, moving the base map instead of the camera to 
see other parts of the map. This setting also means you do not have to use the front 
layer using two cameras to achieve the same effect as when moving the container. 
Borders and other elements on the map can be preloaded once for the base map, but 
this can only be done with a flat map (not a globe).

Update from Container Transformations: Updates the values (lat, long, distance) in the 
Navigator plug-in when the navigator container is moved or scaled when enabled. Used in 
interactive mode. 

Animation
The Animation button displays the camera animation parameters. There are two parameter tabs: 
Basic and Advanced.

Basic

Number of Hop Points: Sets the number of key frames (hops) used in the animation.
Hop Duration Mode: Defines the time gap between two key frames.

Fixed: Uses the same duration as set in the Hop Duration parameter for all hops.
Auto: Calculates the duration of the animation between hops automatically. minimum 
hop duration is based on the Hop Duration parameter and the Hop Min Time 
parameter.
Manual: Disables the Hop Duration parameter. Enables the user to set hop duration 
manually in the stage editor.

Hop Duration: Sets the animation length, between one hop to another, in seconds.
Hop Min Duration (%): Sets a minimum time for each hop when Hop Time Mode is set to 
Auto.
Stop Type: Defines the animation behavior at each hop.

Disabled: Enables the animation to only use stage properties.
Stop Points: Enables the animation to stop at each hop point and wait for a continue 
command.
Pause Points: Adds a pause point to each hop. An additional parameter, Pause Time, is 
added to define the pause length in seconds.
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Flyover: Simulates a flight pass over the hop points in a spline path, using the Flyover 
minimum Height parameter. When selected, additional parameters are enabled.
Per Hop: Sets the hop stop type in the NavFinder plug-in. Different stop types can be 
set for each hop.

Stop at First Hop: Defines whether a stop point is added to the first hop (the beginning of 
the animation). The parameter is enabled only when using Stop Points or Pause Points as the 
Stop Type value.
Pan and Tilt Animation: Enables or disables the pan and tilt values of the camera of each hop 

in the animation. When set to  On , this setting enables the Pan and Tilt values for 

the NavFinder plug-in.
Progress Profile: Defines timing profile between stop points of animation. Smooth option 
causes the animation to ease in and out of hop points.

Basic - Flyover

Flyover Path Profile (Stop Type is set to Flyover): Defines flying curve profile (curvature) of 
animation path.
Lag On Point: Defines timing profile of the flyover animation (similar to Flyover Path 
Profile button).
Flyover Min Height: Sets the minimum flyover height in centimeters.

Advanced

Preferred Flight Height: Defines the camera height that is used in the animation between the 
hops.
Preferred Flight Style: Defines the camera movement between the hops.

Zoom: Enables linear movement from hop point to the high point and back into the 
next hop point.
Auto: Calculates the movement according to distance, height, and so on.
Flyover: Enables a smooth movement from one hop to another.

Preferred Landing: Defines the animation behavior when approaching the hop points.
Helicopter: Uses a steeper approach to the hop point.
Auto: Calculates the approach according to distance, height, and so on.
Airplane: Uses a flatter approach to the hop point.

Pan/Tilt Drifting (deg): Defines the amount of pan/tilt change for each cycle. The cycle is 
defined by the parameters Drifting Pan Time (Frames) and Drifting Tilt Time (Frames).
Drifting Pan Time (frames): Defines the time to complete a full turn of the pan.
Drifting Tilt Time (frames): Defines the time to complete a full turn of the tilt.
Drift Phase Shift (%): Defines the offset between the pan movement and the tilt movement.
Drifting Pause: Defines whether the drifting should stop at the start point or during stop 
points. If Never is selected, drifting does not stop.

Note: The drifting options allow camera pan and tilt drifting during the 
animation. This option is used to give the animation movement a kind of 
satiate feeling.
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Flight Direction: Forces the direction of the flight. Default is the shortest route to the next 
hop. If East or West is selected, flight route is set according to the selected option.

Miscellaneous
The Miscellaneous button displays the editor view for setting interactivity and label related 
parameters.

Interactive

Interactive Mode: Defines the interactive behavior of Viz. Available modes are None, Editor, 
On-Air, Always Fly To and On 'i'.

None: Disables interactive mode.
Editor: Enables interactive mode during scene editing.
On Air: Enables interactive mode when Viz Engine is in On Air mode.
Always: Enables interactive mode during scene editing and when Viz Engine is in On 
Air mode.
Fly to: Defines destination properties. Available Fly To options in Interactive mode are 
Country, Region, Sub Region and Home. Country makes the camera animate to the 
country in which the mouse was clicked. Animation stops when the camera reaches a 
distance from the country as defined by the Extra Zoom 
Country parameter. Region makes the camera animate to the region in which the 
mouse was clicked. Animation stops when the camera reaches a distance from the 
region as defined by the Extra Zoom Region parameter. Sub Region makes the camera 
animate to the sub region in which the mouse was clicked. Animation stops when the 
camera reaches a distance from the sub region as defined by the Extra Zoom Sub 
Region parameter. Home makes the camera animate to the position defined by 
the Home Lan, Home Lat and Home Distance parameters.
On 'i': Enables interactive mode during scene editing and when Viz Engine is in On Air 
mode, when pressing the i key while using the mouse to navigate.

Interactive Animation: Enables user activated animation from the current map position to the 

current selected hop when set to On . This animation is triggered by the user in 

the NavFinder plug-in, by pressing the Fly To Map button. The Fly To option enables the user 
to select a point on the map, by clicking the mouse, and the animation runs from the current 
camera position to the selected point.
Extra Zoom Country: Defines the extra zoom value added to the camera animation when 
animation destination is a country. The camera zooms in to the selected country until the 
bounding box of the country fills the render window. The extra zoom defines an additional 
zoom value to the final camera position calculations.
Extra Zoom Region: Defines the extra zoom value added to the camera animation when 
animation destination is a region. The camera zooms in to the selected region until the 
bounding box of the region fills the render window. The extra zoom defines an additional 
zoom value to the final camera position calculations.
Extra Zoom Sub Region: Defines the extra zoom value added to the camera animation when 
animation destination is a sub region. The camera zooms in to the selected region until the 
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bounding box of the sub region fills the render window. The extra zoom defines an 
additional zoom value to the final camera position calculations.
Home Lon: Defines a longitude value for a home point.
Home Lat: Defines a latitude value for a home point.
Home Distance: Defines a distance from a home point.

Labels

Labels: Defines the label behavior. The Labels setting overrides all labels (in all levels of the 
hierarchy) under the navigator container.

Overlay: Places labels on a plane in front of the map (see Label It for description). 
When this mode is selected an additional parameter is enabled, Label Camera, which 
defines the camera to be used for the labels.
On Map: Places labels on the map.
On Map Scaling:

Advanced
The Advanced button displays additional animation parameters.

Helicopter Lift Duration: Sets the time, in seconds, for the helicopter to go out from a hop 
point to the high point in the middle.
Helicopter Smooth Level: Sets the animation smoothness between one hop to another. This 
parameter affects the animation path when a helicopter flight is simulated.
Airplane Smooth Level: Sets the animation smoothness between one hop to another. This 
parameter affects the animation path when a Airplane flight is simulated.
Tilt Smoothing: Sets the required smoothing value for the tilt animation. This parameter is 

enabled when the Pan and Tilt parameter in the animation tab is enabled. When set to On , 

an additional parameter, Tilt Smoothing Rate, is enabled. 
Distance Mode: Defines how the camera distance from the map during the animation and at 
the hop points are calculated:

Regular: Sets the distance that is calculated by the Navigator plug-in based on the hop 
locations and distance from map as set by the user.
Fixed: Sets a fixed distance for the camera while animating between the hops and at 
the hop point. When set to fixed, User selected distance at the hop point is ignored.
minimum: Sets the minimum distance to which the camera descends at the hop points 
and during the animation. If the calculated distance is larger than the minimum value, 
the camera uses the calculated distance.
Boundaries: Enables you to define a minimum and maximum distance.

Min Distance: Sets the minimum distance value.
Max Distance: Sets the maximum distance value.
Face North: Faces the camera towards the map’s north.
Update Stage in On Air: Defines whether the stage jumps to the hop position when updating 
a map in On Air mode.
World Center Mode: Offsets the world center to use the values entered instead of the center 
of the base map.
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World Center Longitude/Latitude: Sets the world center at the values provided.
Update World Center: Updates all plug-ins when pressed after values are changed.
Use Current Values: Takes the current values from current camera position and use 
them.

Common Buttons
Calculate Animation: Re-builds the animation between the hops using the parameters 
defined in the plug-in.
Center Map: Aligns the center of the map with the center of the screen.
Refresh All Maps: Makes the Navigator plug-in search its sub-tree for containers with 
CWMClient and NavFinder and refreshes the CWMClient maps.

Known issues
Rotation, scaling and translation above the Navigator container might affect the plug-in 
behavior. Do not apply any rotations above the container in the hierarchy and use only the 
pan/tilt parameters of the plug-in to control the orientation of the camera.

7.4.32 NavScale

The NavScale plug-in maintains the scale of an object, related to the screen, during 
the Navigator animation. The plug-in is placed on a child container under the Navigator plug-in, 
and it maintains the defined scaling throughout the animation.

NavScale Properties
Scale on Distance Factor: Sets the value to the required number by modifying the scale 
factor and checking the result in the renderer. 

7.4.33 NavSlave

Note: This plug-in is located in: Plugins -> Container plug-ins -> Maps

Note: This factor does not use any measurement units, but it calculates the object’s scaling 
using a number of parameters from the Navigator plug-in.
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The NavSlave plug-in creates a relation between its container and a Navigator plug-in container in 
the scene. This plug-in locks the NavSlave container to the longitude and latitude values of 
the Navigator plug-in. The plug-in searches the hierarchy above it for the navigator container.

NavSlave Properties
Altitude: Defines the altitude of the object in relation to the Navigator container.

Tangent to Globe: Sets the object to move over the globe surface when set to  On .

7.4.34 Place Finder

The Place Finder plug-in generates a map or map animation without having to actually select the 
map, but uses rules to define what map is generated. There are two ways of selecting a map 
location. The first is simply by entering longitude and latitude values, the second is based on 
searching the map database for the location and using the first value (that was ranked the 
highest). Since a user cannot select the final location from a list, it is important to enter more 
information to make sure the correct location is found.

If you are looking for Paris, Texas in USA, entering Paris  results in Paris, France because the 

capital of France is ranked the highest. Searching for Paris USA  provides results for towns 

named Paris in the USA; however, searching for Paris TX USA  or Paris Texas  provides a more 

specific result.

Place Finder Properties

Location
Longitude: Provides map center Longitude. Changing the value does not affect the map until 
you hit Take.
Latitude: Provides map center Latitude. Changing the value does not affect the map until you 
hit Take.
Long/Lat Format: Sets the format of the incoming data as either Long/Lat or Lat/Long.
Longitude/ Latitude: Provides the map center Longitude and Latitude as one field (very 
useful for external control). Changing the value does not affect the map unless the last 
character is a semi-colon (;).

Note: This plug-in is located in: Plugins -> Container plug-ins -> Maps_Adv

Note: This plug-in is located in: Plugins -> Container plug-ins -> Maps
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Search: Determines the map location to search for. Click the Take button to perform the 
search.

Frame by Search Result: Frames the location from the result of the search when set to On .

Zoom level: Determines how the map should be framed. This option is relevant if the map 
center is based on longitude and latitude values (and not a search location), or if the Frame 
by Search Result is disabled.

Default Size frames the map based on Default Map Size.
Country, Admin1, Admin2 is first trying to find the relevant information (e.g. country 
and so on) and fails for example if map center is in the sea. Next it uses the bounding 
box of the user selection (please read about the Texas example in the Place 
Finder introduction section).
If the user selects Admin2 the map’s frames are based on Lamer County which is 
Admin2 in that specific Longitude and Latitude.
If user selects Admin1 the map’s frames are based on Texas which is Admin1 in that 
specific Longitude and Latitude.
If user selects Country1 the map’s frames are based on USA which is the country for 
that specific Longitude and Latitude

Map Center: Centers the map based on a point or a frame. If you search for Beijing, 

China , the map can be centered around the point identified as Beijing. This may, depending 

on your zoom level, leave parts of Beijing out of the frame. Alternatively, you can center your 
map based on the frame that captures the entire Beijing area in view.
Default Map Size (deg): Defines a default map size for those areas that cannot be framed 
using predefined administration levels (e.g. international waters).

Extra Zoom: Adds an extra zoom to the map in percentage ( 0.001-100% ).

Labels
Add Search Result Label: Adds a label based on the search result.
Add Region Label: Adds a region label based on the selected zoom level.

Add Event Label: Adds event based labels (e.g. floods, fire, festival). To use different 
designs, a pipe symbol (|) can be used as separator (for example, Fire|Fire in LA uses a 
design named Fire and the text is Fire in LA. Changing the value does not affect the map 
unless the last character is a semi-colon (;).
Label Designs: Determines the location for Label designs. Normally, the plug-in resides next 
to the CWMClient plug-in and it uses its designs, or the global designs.
Label Holder: Determines the location for Label holder. Normally, the plug-in resides next to 
the CWMClient plug-in and it uses its holders, or the global holders.
Auto Labels Holder: Defines the location of the Automatic Labels Holder. Automatic labels 
are labels generated based on the boundaries of the map.

Note: Short only adds the location name, while Long adds more information (e.g. 
country and so on).
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Regions
3DRegions: Determines whether 3D Regions are added. Relevant only when Zoom level is set 
to one of the region types (i.e. Region/Country/Admin1/Admin2/Sub_region).
3DRegion Designs: Determines the location for 3D Region designs. Normally, the plug-in 
resides next to CWMClient plug-in and it uses its designs, or the global designs.
3DRegions Holder: Determines the location for 3D Region holder. Normally, the plug-in 
resides next to CWMClient plug-in and it uses its holders, or the global holders.

Advanced
Search: Defines which server data to search in (i.e. map data base, street data (map data 
base + street data), or Web) This works the same way as in the Classic client.
Immediate Response

Disabled: Needs a user action to initiate the search: Either type the term with a semi-
colon (;) at the end or press the Take button. Disabled is the default setting.
Enabled: Changes the search so that every letter typed initiates a search.

Status: Provides the status of the search.

7.4.35 Publish To Design

The Publish To Design plug-in enables updated parameters to be set directly to the design they 
came from (either container hierarchy or object pool) by pressing Publish To Design or create a 
new design out of modified data by assigning a new name under the New Design tab.

Publish To Design Properties
Publishing Target: Publishes using the original design or creates a new design.
Design Name: Sets the new name for the new design or selects a design from the Designs 
list.
Publish to Design: Sends the label back to where it came from, but it does not refresh the 
scene.
Publish and Refresh: Sends the label back to where it came from and refreshes the scene.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Maps_Adv
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7.4.36 Region To Texture

The Region To Texture plug-in simulates shadow effects for 3D Regions. This is achieved by 
creating a texture of a region’s contour. The plug-in works in two modes: By creating a single 
texture that applies to all regions in the scene or by creating multiple textures that applies to each 
individual region.

To work with a single texture, the plug-in must be placed on the Region Holder container.

To work with multiple textures, the plug-in must be placed on a container above the 3D 
Region container.

Note: This plug-in is located in: Plugins -> Container plug-ins -> Maps
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Region To Texture Properties
Dynamic Shift: Shifts shadow texture more when Navigator is farther away. This could be 
used to better see the shadow from farther distances.
Dynamic Shift Amount: Sets the extent of the Dynamic Shift.
Attach to Light: Considers light direction according to the positioning of the shadow texture 

when set to On . When set to Off , Shift Direction allows you to manually set the direction 

of the shadow.
Light ID: Sets the ID of the light to be considered.
Texture Size: Sets the size of the shadow texture. The larger the texture, the better is the 
visible quality; however, it also requires more rendering time.
Blur Amount: Determines the extent to which the texture is blurred to resemble the 
appearance of a shadow.
Shift Direction: Sets the shift direction of the shadow manually and according to the region. 

This setting can only be used if the Attach To Light setting is disabled ( Off ).

Shift Amount: Sets the amount of shift.

Working with Region to Texture

To Create a Simple Region to Texture Scene
Add the Map Builder plug-in to the Scene Settings.
Save the scene.
Open the Map Builder editor and click Launch Wizard. This opens the Map Builder. Note that 
it may open behind Viz Artist.
From the Choose Scene Type dialog box select Navigator.
Click the Base Map. This opens the Viz World Maps Editor.
Select a stylesheet for your map and click OK.
Click the map for Destination 01. This opens the Viz World Maps Editor.
Click the Browse Map button (see Map Tool Bar) and select two regions (e.g. Trentino-Alto 
Adige and Lombardia in Italy) and click OK.
Click Build.

Save the map template file to your desired location (e.g.  C:\Temp\Maps ). Once saved, the 

map scene is generated.
For creating a single texture do the following:

Navigate the scene tree to the Region-Holder container found under Object > 
MapAndHops > GeoReferenceMap > Holders.
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Add the Region to Texture plug-in to the Region-Holder container.
For creating multiple textures do the following:

Navigate the scene tree and split the Region__<name> container found under Object > 
MapAndHops > GeoReferenceMap > Holders > Region-Holder > Destination-n.
Add a new group as a sub-container of the Region__<name> container.
Add the Region to Texture plug-in to the new group container.

Open the Publish To Design editor and click the Publish and Refresh button.
To adjust the textures, split the merged region containers and adjust the settings available 
in the Region to Texture editor.

7.4.37 Trace It

The Trace It plug-in places the 3D object it is attached to over a line, created with the 3D 
Line or Shape to Spline plug-in, and follows the line’s end point. The object follows the line 
animation as the object with the Trace It plug-in move with the 3D Line/Shape to Spline end point.

Trace It Properties

General
Progress: Indicates the animation position of the 3D Line/Shape to Spline object. When 
using Shape to Spline, Trace It uses the ShapeToSpline field Trim End to control the 

Note: This plug-in is located in: Plugins -> Container plug-ins -> Maps
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progress. Trim Start and Trim Offset must be 0 . If the data originates from a KML file, the 

progress is calculated in geographic units, otherwise viz units.
Smooth Direction (%): Defines the object’s motion behavior when changing direction. When 
set to a low value, the direction changes faster.
Quality: Tells the plug-in which resolution to track when tracing a border that by default has 
three levels of detail (LOD). Available options are High, Medium and Low.
3DLine: Defines the 3D Line/Shape to Spline container that the Trace It plug-in follows.

Previous: Follows the animation of the 3D Line/Shape to Spline plug-in in the previous 
container.
Above: Follows the animation of the 3D Line/Shape to Spline plug-in in the above 
container.
Container: Follows the animation of the 3D Line/Shape to Spline plug-in in the 
container dragged to its container place holder.

Progress Control: Defines how the object’s progress is controlled:
None: Uses the progress ID manually created by the user (stage animation).
Navigator: Follows the animation of the Navigator plug-in.
Slave: Follows the source of the trace from the 3Dline plug-in.
Master: Controls the 3D line plug-in progress, which is the source of the trace.

Camera
The Camera tab defines the mode for camera tracking.

Progress: Indicates the animation position of the 3D Line/Shape to Spline object.
Trace Camera: Controls a navigator’s animation between a specified hop and the 
corresponding one, or manually driven (standalone). Available options are Off, Navigator, 
Standalone, General and Locks.

Off: Does not trace camera animation.
Navigator: Traces the camera animation between the selected hop and the following 
hop.
Standalone: Traces the camera animation between the selected hop and the following 
hop.

General: Defines the tracing parameters.
Smooth Camera Position (%): Smoothens camera position path.
Smooth Camera Direction (%): Smoothens camera direction path.
Start Hop: Selects a hop in the Navigator animation. The camera trace is inserted 
between the selected hop and the next one.
Update Hop Data: Updates data in NavFinder plug-ins where the camera trace is 
inserted (actually sets start and end values of the tracing route to insert camera trace 
smoothly to the Navigator animation).

Locks: Enables the user to lock camera animation parameters:

Note: When using Shape to Spline, no tracing is possible in non-geo mode, either 
with camera or without.
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Lock Pan: Makes the camera pan to follow the path direction when set to  On . When 

set Off , pan animation uses the Navigator parameters.

Pan Offset: Sets the pan offset to path directions.

Lock Tilt:  Makes the camera tilt follow the path direction when set to  On . When set 

Off , tilt animation uses the Navigator parameters.

Tilt Offset: Sets the tilt offset to path directions.
Lock Distance: Uses the Distance parameter value to set the camera distance from the 

map during the animation when set to On . When set to  Off , the distance during the 

animation uses the Navigator parameters.
Distance: Sets the distance to use during the animation.

Advanced
Segmentation: Tells the Trace It plug-in what segment to track when a line is split into 
different segments (for example a region might have several islands) when tracking. 
Available options are Auto, Largest, Sectioned and All.

Overlay: Transfers the object from a position on the actual map to a position in a different 
camera (similar to the Label It plug-in’s Overlay options).

7.4.38 World Position

The World Position plug-in places an object over a geographically referenced map by setting the 
Longitude, Latitude and Altitude parameters. When the object is moved over the map, the current 
values of Longitude, Latitude and Altitude are updated in the World Position plug-in. The object 
with the World Position plug-in must be placed under a map in the hierarchy.

IMPORTANT! Maximum number of line segments are 10000 . Shape files that exceed 

this limit results in lines not being drawn.


Note: Shape to Spline has no button for controlling splitting dateline (whereas 3D 
Line uses Enable World Periodicity).



Note: This plug-in is located in: Plugins -> Container plug-ins -> Maps
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World Position Properties

Simple
Longitude: Sets the parameter to the requested longitude. The object moves over the map to 
the requested location. Another option is to move the object and read its longitude value 
from this field.
Latitude: Sets the parameter to the requested latitude. The object moves over the map to the 
requested location. Another option is to move the object and read its latitude value from this 
field.
Altitude Units: Selects the units that the altitude parameter uses.
Altitude: Sets the parameter to the requested altitude. The object moves over the map to the 
requested location. Another option is to move the object and read its altitude value from this 
field.
Move to Map Center: Moves the object to the center of the parent map when clicked.
Update Lat/Long From Container Position: Updates the latitude and longitude position 
parameters when clicked.

Advanced
In addition to the fields in the World Position tab, the Advanced tab has the following fields:

Tangent to Globe: Keeps the object parallel to the globe surface when set to On . The 

parameter is enabled when the World Position plug-in is placed in a child container of a 
container with a Globe plug-in.
Update Long/Lat from Position: Gets the current container location and updates the 
longitude, latitude and altitude parameters:

Auto: Updates the longitude and latitude values once when a new position is dragged 
over the container and never again.
Never: Updates the longitude and latitude values, but never updates the object's 
position.
Always: Updates the World Position when it changes and always checks the object's 
position.

Follow Terrain: Reads the height (Altitude) from the terrain in case of a terrain geometry.
Longitude/Latitude: Determines the position in degrees:minutes:seconds format.
Long/Lat Format (Long/Lat)(Lat/Long): Sets the format of incoming data.
Lat/Long (+/-dd:mm:ss.xx): Sets both latitude and longitude values in a single string.
Offset/Fine Tuning

Longitude/Latitude Offset: Positions the object at a given offset from the actual 
longitude/latitude when Offset is selected. 
Longitude/Latitude Seconds: Provides fine tuning values in seconds when Fine 
Tuning is selected.
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7.5 Scene Plug-Ins
This chapter describes all scene plug-ins. The container plug-ins are found in five plug-in folders:

Maps: Contains standard plug-ins.
Maps-Adv: Contains advanced plug-ins.

See the following sections for more information:

3D Map Setting
Label Manager
Light On Globe
Map Builder
Traffic Manager

7.5.1 3D Map Setting

The 3D Map Setting plug-in manages border data from the server. The border data is retrieved 
from the Viz World Server (WoS), according to the setting in the 3D Map Setting plug-in, and is 
used for applying a graphic design to the borders in the map, drawn by the 2D Label plug-ins.

This section contains information on the 3D Map Setting plug-in properties:

3D Map Setting Properties
General
Border Data
Window
GUI
Advanced

Buttons

3D Map Setting Properties

General
Geographic Container: Draws the border of the selected map. Drag the CWMClient container 
that defines the map area to the container place holder.
3D Global Designs Path: Sets the path to a Viz folder containing the global designs.
3D Global Designs: Holds the place for global designs container.

Note: This plug-in is located in: Plugins -> Scene plug-ins -> Maps
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3D Global Holder: Defines the container that holds all the global 3D objects created from the 
global designs.
On Screen Global Holder: Defines the container that holds all of the on-screen global 3D 
objects created from the global designs.
Units: Defines the type of units used to measure how many degrees, kilometers, miles or 
nautical miles are seen. The selection made here affects Navigator’s Height Units setting and 
the label appearance Units in the Label Manager plug-in (see Definitions section).

Border Data
World: Defines whether the border data is fetched for the entire world (country borders) or 
other data as defined in the Additional Region Data parameter.

None: Retrieves the border data as defined in the Additional Region Data parameter.
Full: Retrieves the country borders data for the entire world (country borders only).

Additional Region Data: Defines additional border data that is retrieved from the server with 
the data defined in the World parameter. The additional data is limited to the selected region 
in the Region List parameter. This parameter cannot be changed without an instance of Viz 
World Server (WoS).

None: Does not use additional data.
Country: Uses country border data in the selected region.
Region: Uses region border data in the selected region.
Sub Region: Uses sub-region border data in the selected region.

Region List: Defines an area of the world for which the additional region data is retrieved 
from the server. The parameter limits the data size retrieved from the server.
Country Borders: Creates country borders for the selected region in the region list property.
Rebuild: Retrieves the information from the Viz World Server (WoS).
Rebuild (Force New): Recreates the data on the Viz World Server (WoS) and saves it to the 
cache folder, even if cached data already exists.

Window
Window Active: Enables user definition of an area in the renderer as an active window. All 
maps data created by the Viz World Client is redrawn to fit into the defined window. When 

set to On  additional parameters are enabled:

Effect Culling: Defines whether the window affects the culling of the vector data (streets, 
borders, etc.).
Effect Position: Offsets the map either by (1) Using the window width and height and window 

center X and Y properties, or (2) By turning On  container mode and dragging a container to 

the Window Container parameter, which is used to track the size and position for offsetting 
the map camera.
Window Mode: Defines the source of the window aspect: Manual sets the window aspect to 
be user defined, Camera sets the window aspect to be the same as the render window, and 
Image sets the window aspect to be the same as the image aspect of the map.
Window Units: Defines the units used to set the window size and position. When set to 
Percents, the window size is calculated as the defined percentage of the Viz render window 
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size. The window position is calculated as the defined offset percentage of the render 
window.
Window Container: Allows tracking a container from the scene tree that affects the size and 
position of the window.
Window Width: Defines the width of the window in percents or pixels.
Window Height: Defines the height of the window in percents or pixels. This parameter is 
enabled only if window mode is set to Manual.
Window Center Offset X: Defines the X position (percents or pixels) of the window in relation 
to the render window (center to center).
Window Center Offset Y: Defines the Y position (percents or pixels) of the window in relation 
to the render window (center to center).
Control Win Mask: Defines whether a WindowMask plug-in (added to the map) is controlled 
by the 3D Map Settings plug-in to mask the defined window.
Window Mask Scale: Defines the scale of the mask over the defined window.
Show Debug Window Mask: Displays a red rectangle around the defined window when set to 

On .

GUI
GUI defines general parameters for controlling container names and container colors in the Viz GUI 
(effecting the Viz scene tree display), and the creation of Control Channels from added Viz World 
Client objects. The Control Channels in Viz are displayed under the Control tab and serve as an 
index for the scene tree. For additional information about Control Channels please refer to the Viz 
Artist User Guide.

Hops: Defines GUI parameters for hop containers in the scene tree:
None: Does not apply control channel or name conversion to the hop containers.
Control: Adds only a control channel for the hop containers.
Name: Names the created hop containers Hop-1, Hop-2, etc., according to the hop 
point selected in the NavFinder plug-in. No control channel is added.
Full: Adds a control channel for every hop container and the hop containers are 
renamed Hop1, Hop2, etc.

Designs: Defines GUI parameters for any design containers (region designs, road designs, 
label designs, and so on) in the scene tree:

None: Does not apply control channel or name conversion to the design containers.
Control: Adds only a control channel for the design containers used in the scene. The 
containers are not renamed.
Name: Renames the design containers (dragged to the CWMClient plug-in) Label-
Designs, Region-Designs, and so on. No control channel is added.
Full: Adds a control channel for every design container and the design containers are 
renamed.

Holders: Defines GUI parameters for any object holder containers (regions, roads, labels , 
and so on) in the scene tree:

None: Does not apply control channel or name conversion to the holder containers.
Control: Adds only a control channel for the holder containers used in the scene. The 
containers are not renamed.

http://docs.vizrt.com/viz-artist
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Name: Renames the holder containers (dragged to the CWMClient plug-in) Label-
Holder, Region-Holder, and so on. No control channel is added. If the holder container 
is dragged to a hop CWMClient, it is suffixed indicating the hop number: Label-Holder-
H1, Label-Holder-H2, and so on.
Full: Adds a control channel for every design container and the Holder containers are 
renamed.

Hops Color: Sets the color index, as defined in the User Interface parameter in Viz Config 
that is used for the Hop containers in the scene tree.
Design Color: Sets the color index, as defined in the User Interface parameter in Viz Config 
that is used for the design containers in the scene tree.
Holder Color: Sets the color index, as defined in the User Interface parameter in Viz Config 
that is used for the generated objects holder container in the scene tree.

Advanced
Culling Threshold: Sets the size of polygons to be culled (not rendered). It is generally better 
to cull small polygons, as they may not look good when rendered.
Polygon Quality: Defines the quality of the drawn border lines. The higher the quality, the 
smoother the line is.
Polygon Quality Factor (%): Enables the user to change the automatic polygon quality levels 

by setting a factor that changes the border quality. Values under 100%  decrease the quality 

of the lines. Values above 100%  increase the quality of the lines.

Language: Allows the user to set the language of labels for the scene. 

Buttons
Reset Design Holders: Cleans up all design holders (labels, regions, borders and so on).
Update Project List: Updates the list of Viz World map projects available to the designer. By 
default, Viz Artist always checks the Viz World Server for a list of projects and if a a scene is 
opened and its project does not exist an error message is displayed. However, if a project is 
added after Viz Artist is started you can click the Update Project List button in order to 
update Viz Artist and to avoid the error message.
Update All Map Elements: Checks all map elements in the scene (CWMClients, Place Finder
and so on) and refresh them.
Sync Local Cache Folders: Synchronizes the local cache folder with the primary cache folder. 
Start Logging: Logs all map related activities into a file.

End Logging: Saves the log file under  C:\Program Files 

(x86)\vizrt\Common\Maps\logs .

Tip: For more information about Viz Config and its configuration options, see the Viz 
Engine Administrator Guide.



http://docs.vizrt.com/viz-engine
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7.5.2 Label Manager

The Label Manager plug-in retrieves label information from Viz World Server and control the label’s 
appearance when working in an automatic label mode. The Label Manager generates labels, based 
on the defined label designs, according to parameters defined in the Navigator plug-in, Label 
It objects and 2D Label objects in the label designs.

For the Label Manager to resolve conflicts, it needs different presets to work with. The more 
presets and the bigger difference between them, the better chance overlaps are resolved. When 
working with Label Manager, pay attention to and check all presets it uses to make sure that they 
are acceptable for the plug-in. Do not create a preset where the label is under the marker if you do 
not want to see it. Labels without markers (e.g. country) can have presets as well, which means 
their position can change slightly.

Label Manger basically has two ways of detecting conflicts:

Based on the marker (zero size) labels (bounding box) and the line between them. You set 
this for the 2DLabel (see Special section, Collision Mode = Tip Based) and when used with 
good and different presets it solves almost any problem, but if a you have a big marker 
there is always a chance of a marker overlap.
Based on the bounding box, the entire (square) bounding box is calculated and used. In this 
case, there is less chance of resolving conflicts, but it has no overlaps.

This section contains information on the Label Manager plug-in properties:

Label Manager Properties
Map Data
Auto Labels

Examples
Definitions
Shadows

Label Manager Properties

Map Data
The Map Data tab defines settings for the label types received from the Viz World Server (WoS). 
These settings are used when calculating label appearance in automatic mode. For every type of 
label selected in the list, set the required parameters.

Type: Sets the type of labels data to display.

Note: This plug-in is located in: Plugins -> Scene plug-ins -> Maps
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Start View: Defines the map size from which the labels of the selected type appears during 
the Navigator animation. Parameter units are defined in the Definitions tab’s Units
parameter.
Life Span: Defines the duration of the label appearance on screen. Note that this setting is 
most useful for country and region types.

Full: Displays the label at the defined Start View and remains on screen throughout the 
entire animation.
Long: Displays the label on screen for a long period of time.
Regular: Displays the label on screen for a medium period of time.
Short: Displays the label on screen for a short period of time.
Manual: Displays the label on screen until the defined End View value is reached.

End View: Defines the map size at which the labels of the selected type disappears. This 
parameter is only enabled if the Life Span is set to Manual. Parameter units are defined in 
the Definitions tab’s Units parameter.

Auto Labels
The Auto Labels tab defines whether automatic labeling is enabled and the label designs used for 
automatic labeling.

Auto Labels: Sets the auto labels mode to disabled, enabled or interactive.
Disabled: Does not use automatic labeling in the scene.
Enabled: Uses automatic labeling in the scene based on the defined designs and labels 
holder container.
Interactive: Enables the Auto Labels Quantity.

Auto Labels Quantity: Allows you to set the amount of labels that should be shown. Few 
show approximately 75 labels (or less), Average 100 labels (or less) and Many 150 labels (or 
less). Manual sets the distance where the labels should appear (see Start View under Map 
Data) providing a consistent behavior (e.g. Town 1K always appears/disappears at the same 
distance).
Manual Labels: Defines whether manual labels, defined for the map, are displayed with the 
auto labels. When Enabled is set, the Select Manual Labels button appear at the bottom of 
the editor. When clicked, WME opens, enabling the user to set manual labels.
Road Labels: Defines the level (number) of road labels that are displayed. Select the required 

option, ranging from  0-None  to  5-All .

Street Labels Style: Defines the label style of the scene. Options are Viz Design and Internal 
(Open GL) labels.

Viz Design: Allows user definition of Viz labels. Note that this limits the number of 
labels that can be used in Viz. Depending on your system, 300-500 labels may cause 
Viz Engine to not render in real time. Using Viz Design also gives the option to set 

Note: The Label Manager plug-in controls and manages the automatic labels 
appearance, using various parameters from different plug-ins. The Life span and 
Auto Label parameters vary between labels during the animation (hop), to optimize 
labels display.
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other parameters such as the visibility of the label and local and global placeholders 
for the label design (see 3D Designs & Holder).
Internal (Open GL): Allows using up to 100.000 labels; however, this limits design 
options to the font used and relative position and scale. When used with the Street 
Labels plug-in, this setting only works for Navigator scenes.

Labels Visibility (%): Used when calculating size of street labels for the final map.
Gap for Same Street Name (%): Used when calculating the minimum distance between two 
street labels of the same name.
3D Designs and Holder:

Designs (text field): Defines a path in Viz’s objects database that contains label 
designs. Automatic label designs are based on 2D Label and Label It plug-ins.
Designs (place holder): Displays the selected (drag and drop) top container holding 
the label designs.
Holder (place holder): Displays the selected (drag and drop) container that resides 
under the map. This container is used by the Label Manager plug-in to store the 
scene’s generated labels.

Limit Auto Labels: Defines whether the auto labels are limited to a defined region/s or not. 
When enabled, the Limit To Region text field is enabled.
Limit to Region: Defines the region to which the auto labels are generated.

Auto Labels can be limited to specified countries and/or regions. The format of valid input is:

A semi-colon (;) between locations.
A backslash (/) or slash (\) to specify the path to the regions.

Examples

USA;Mexico
USA\TX;Mexico;Canada
United States of America\Florida;United States of America\Georgia;USA\NY

Definitions
The Definitions tab is used to set general parameters for Label Manager behavior.

Intersection Mode:
Full: Selects the best preset for each label and when labels intersect, one of them is 
turned off.
Offsets: Selects the best preset for each label.
None: Creates auto labels only. No intersections are calculated.

Screen Culling Mode: Defines whether a label is drawn when it is outside the Viz renderer’s 
scope/view.

Center: Fades out the label object when the center of the object is outside the Viz 
renderer’s scope/view.

Note: Abbreviations can be used (after defining such list in the WoS)
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Anything: Fades out the label object when any part of the object is outside the Viz 
renderer’s scope/view.
Complete: Fades out the label object when the entire object is outside the Viz 
renderer’s scope/view.
None: Does not use culling. The labels are drawn according to the map data 
parameters only.

Map Culling Mode: Defines whether a label is drawn when it is outside the map area but 
inside Viz renderer’s scope/view.
User Labels Ignore Distance Rules: Ignores the distance rules that apply to labels associated 
with a hop when enabled.
Intersection Distance: Determines the distance to be used when calculating the best label 
setup to be used to avoid collision:

Max distance: Calculates labels at the max distance defined for the label type.
Distance: Uses the final hop position.
2/4/8* Distance: Uses the hop position area multiplied by the selected value.

Scene Type: Determines which algorithm to use for a scene. Label Manager uses different 
algorithms for an interactive scene or a regular one. User should declare the scene type to 
get best results.
Units: Defines the units used to calculate map size for the Start View and End View 
parameters. Available options are Degrees, Kilometers, Miles and Nautical Miles, where the 
default measurement unit is Kilometer. Note that this setting is also affected by the Units 
option in the 3D Map Setting plug-in (see Label Manager).
Fade Time (fields): Defines the label’s fade duration in fields.
Labels Draw Style: Determines where labels are drawn.

On map: Draws on the map layer.
Overlay: Draws on a different layer (dynamic image/layer).
On map scaling: Draws on the map layer, but maintains the same size (avoid NavScale 
plug-in).

Label Camera: Defines the camera that is used to draw the labels (normally camera two).
Debug Info Mode: Shows different levels of debug information regarding the auto layout.

Shadows
Cast Shadows: Turns option to cast label shadows on/off.
Light Type: Simulates different light types to cast the shadows.
Horizontal Angle: Defines the horizontal angle position of the light.
Vertical Angle: Defines the vertical angle position of the light.
Distance: Defines light distance.
Shadow Plane: Casts planar shadows on an imaginary plane and this option defines the 
spatial rotation of such a plane. Select one of the options:

Straight: Casts the plane parallel to the screen.
Up Tilt: Tilts the casted plane 45 degrees up from the screen.
Down Tilt: Tilts the casted plane 45 degrees down from the screen.
Manual: Allows the pan and tilt values of the casted plane to be set manually.
World: Casts the plane tangent to the world.
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Tangent Point: Sets the pivot point for connection shadow to the object.
Shadow Pan: Determines a manual Shadow Pan.
Shadow Tilt: Determines a manual Shadow Tilt.
Shadow Distance: Determines the distance of the shadow plane from the object.
Shadows Camera: Selects a camera for rendering the shadows. Since shadows are done by 
first rendering objects in a distant place and then overlaying their black silhouettes on the 
screen, this option defines the camera that looks at such distant place where objects are 
rendered. (Actually this camera is used for overlay).
Show Light Direction: Visualizes light direction on screen. The light direction is visualized by 
showing a lit ball or an arrow.

7.5.3 Light On Globe

The Light On Globe plug-in applies light sources to a globe object. The plug-in is required when 
designing a hops scene and the animation is going from the lighted area of the globe to the dark 
area of the globe. When using the Light On Globe plug-in, the lights follow the camera animation. 
The light sources are Viz lights, and the lighting parameters should be adjusted in the Viz light 
editor. The Light On Globe plug-in locks the light sources to the selected camera in the plug-in 
parameters.

Light On Globe Properties
Camera: Sets the camera number for setting the light sources. The light sources are locked 
to the selected camera number.
Key Light Type: Sets the main light source type. Available types are Local, Spot, Infinite or 
None.

Note: This plug-in is located in: Plugins -> Scene plug-ins -> Maps
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Key Light Angle: Sets the angle of the key light source, which is the longitude value for the 
center of the light projected on the globe.
Key Light Elevation: Sets the elevation of the key light source, which is the latitude value for 
the center of the light projected on the globe.
Distance Scale: Sets a scale value on the globe distance so the light can be closer or further 
away.
Attenuation: Sets the level of light attenuation.
Back Light Type: Sets the back light source type. Available types are Local, Spot, Infinite or 
None.
Back Light Angle: Sets the angle of the back light source, which is the longitude value for the 
center of the light projected on the globe.
Back Light Elevation: Sets the elevation of the back light source, which is the latitude value 
for the center of the light projected on the globe.
Distance Scale: Sets a scale value on the globe distance so the light can be closer or further 
away.
Fill Light Type: Sets the fill light source type. Available types are Local, Spot, Infinite or None.
Fill Light Angle: Sets the angle of the fill light source, which is the longitude value for the 
center of the light projected on the globe.
Fill Light Elevation: Sets the elevation of the fill light source, which is the latitude value for 
the center of the light projected on the globe.
Distance Scale: Sets a scale value on the globe distance so the light can be closer or further 
away.
Camera Light Type: Sets the camera light source type. Available types are Local, Spot, 
Infinite or Off. The camera light follows the camera movements.
Camera Light Horizontal Shift: Sets the horizontal shift of the light source in relation to the 
camera location.
Camera Light Vertical Shift: Sets the vertical shift of the light source in relation to the camera 
location.
Toggle Mode: Sets the lights behavior mode during camera movement:

Static: All light sources, except for the camera light, remain in a fixed location in 
relation to the globe.
Dynamic: All light sources maintain a fixed location in relation to the defined camera 
(that is it moves with the camera).

7.5.4 Map Builder

The Map Builder plug-in builds a scene from a map template (*.mtpl) file, and saves the map scene 
changes to the map template file.

Note: This plug-in is located in: Plugins -> Scene plug-ins -> Maps
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Map Builder Properties
Map Template Filename: Sets the name of the scene template file or click the browse (...) 
button to select a file.
Rebuild Scene: Updates the scene tree with changes from the Map Builder.
Launch Wizard: Runs the Map Builder application.
Clean Scene: Cleans the scene hierarchy.
Build Scene from Scratch: Cleans the scene tree and rebuilds the scene hierarchy using the 
defined map template file.

7.5.5 Traffic Manager

The Traffic Manager plug-in connects to DataHub for traffic flow and routing information.

Traffic Manager Properties
DataHub Host: Sets the hostname of the DataHub to use.
DataHub Port: Sets the port number to use.
Source Name: Defines the name of the source.
Update from DataHub: Updates from DataHub.
Flow Data: Defines the location of the traffic flow data.
Flow and Routing Shape File: Defines the location of the traffic flow and routing shape file.
Build Flows Data and Update Flows: Builds flows data and updates traffic flows (calls 3D Line 
Manager).
Update Flows: Updates the traffic flows.

7.6 Shader Plug-Ins
This chapter describes shader plug-ins. The shader plug-ins are found in two plug-in folders:

Default: Contains the Rebound plug-in.
Maps: Contains standard plug-ins.
Maps-Adv: Contains advanced plug-ins.
Maps-Lab: Contains experimental plug-ins. Since these plug-ins are experimental and not 
supported, they are not documented here.
Maps-Obs: Contains obsolete plug-ins, installed only for backward compatibility. These plug-
ins should not be used when designing new scenes. Since these plug-ins are obsolete and 
not supported, they are not documented here.

Note: This plug-in is located in: Plugins -> Scene plug-ins -> Maps_Adv
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Texture: Contains the FadeTexture plug-in.

See the following sections for more information:

3D Line Shader
C3D Terrain Shader
FadeTexture
GeoChart Shader
Rebound

7.6.1 3D Line Shader

The 3D Line Shader plug-in is used by the 3D Map Setting plug-in to draw the borders using the 
parameters set in the various 2D Label plug-ins. It is added automatically when adding a 2D 
Label object to the scene tree.

3D Line Shader Properties
This plug-in has no editable parameters.

7.6.2 C3D Terrain Shader

The C3D Terrain Shader plug-in is added automatically when using the Atlas plug-in.

C3D Terrain Shader Properties
This plug-in has no editable parameters.

Note: This plug-in is located in: Plugins -> Shader plug-ins -> Maps

Note: This plug-in is located in: Plugins -> Shader plug-ins -> Maps
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7.6.3 FadeTexture

The FadeTexture plug-in applies soft edges to a texture and to crops the texture.

FadeTexture Properties
Curve: The plugin has three plug-in editor views that enable different curve control options.

Constant: Controls texture edges separately, but no softness is applied to the texture 
edges.

Crop Top: Sets the crop value for the top of the texture.
Crop Bottom: Sets the crop value for the bottom of the texture.
Crop Left: Sets the crop value from the left of the texture.
Crop Right: Sets the crop value for the right of the texture.

Spline : Controls texture edges separately and a common softness value is applied to 
all edges. Spline has the same parameters as Constant.

Fade: Sets the softness value for the edges of the texture.
Uniform : Controls all texture edges together with a fixed softness value applied.

Uniform Crop: Sets the crop value for all edges of the texture (fixed softness is added 
to all edges).

7.6.4 GeoChart Shader

The GeoChart Shader plug-in is the shader for the GeoChart plug-in.

GeoChart Shader Properties
This plug-in has no editable parameters.

Note: This plug-in is located in: Plugins -> Shader plug-ins -> Texture

Note:  If an edge is not cropped, the softness affects the edge.

Note: This plug-in is located in: Plugins -> Shader plug-ins -> Maps_Adv
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7.6.5 Rebound

The Rebound Shader plug-in stops shader inheritance. By default, all shader behavior is shared by 
all siblings of the container where the shader resides. The Rebound shader stops this inheritance. 
It should be placed below the shader you would like to avoid inheriting from.

Rebound Properties
This plug-in has no editable parameters.

Note: This plug-in is located in: Plugins -> Shader plug-ins -> Default
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8 PixelFX Plug-Ins
The PixelFX Plug-ins provide details about settings available through its configuration user 
interface within Viz Artist. 

8.1 Related Documents
Viz Artist User Guide: Contains information on how to install Viz Engine and create graphics 
scenes in Viz Artist.

8.2 Feedback And Suggestions
We encourage suggestions and feedback about our products and documentation. To give feedback 
and/or suggestions, please contact your local Vizrt customer support team at www.vizrt.com.

8.3 Geometry Plug-Ins
The default path for the Geometry plug-ins is: <viz install folder>\plugin\<plug-in name.vip>

8.3.1 PixelFX
The Lens Flare plug-ins, which are part of the PixelFX plug-ins set, simulate the effect of streaks 
and spots of light, caused in real cameras when light enters and bounces inside a camera lens. 
This plug-in set contains geometries that simulate different shapes, which can be used for lens 
flare or simple flare effects. Each plug-in can take on very different appearance depending on how 
the parameters are adjusted. The best advice for working with these plug-ins is to simply play 
around with the parameter configurations.

The Flare draws itself as a combination of a geometry shader and a pixel shader. When a Flare 
Container is created a non-editable pixel shader is added to the created Flare container.

In addition, the Expert Container plug-in is automatically added and configured in such a way as to 
cause the shape used to always be seen in front of all other objects, blending with the rest of the 
scene to resemble the effect of light bouncing off the lens.

http://documentation.vizrt.com/viz-artist
http://www.vizrt.com/
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The baseline plug-in within this set is the pxLensMulti plug-in, which is a container plug-in, whose 
purpose is to manage other geometry plug-ins. The one exception in this set is the 
pxLensEnergyBolt, which does not simulate lens flare, but rather the effect of electricity or 
lightning and it is not managed by pxLensMulti.

The following Geometry plug-ins are located in the PixelFX folder:

pxLensEnergyBolt
pxLensGlowBall
pxLensGlowSpikes
pxLensPolyElement
pxLensRandomPoly
pxLensRays
pxLensSpark
pxLensStripes

See Also

PixelFXLensFlare

pxLensEnergyBolt

The pxLensEnergyBolt plug-in produces the effect of electricity-like lightning between two points in 
space. These points may be defined manually by entering positions, or by tracking the positions of 
other containers.

Note: Lens flare plug-ins reside in their own containers. Applying these plug-ins to a 
container with geometry overwrites the geometry and disable any shaders in child 
containers.
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pxLensEnergyBolt Properties
Use LOD: Enables level of detail.
Glow Color: Determines the color of the glow.
Radius: Determines the glow size.
Core Color: Determines the color of the core of the bolt.
Core: Determines the size of the core of the bolt.

From X: Determines the starting x position.
From Y: Determines the starting y position.
From Container: Uses a container as a starting position.
To X: Determines the ending x position.
To Y: Determines the ending y position.

End Caps: Applies a cap at the end of the energy bolt when set to On .

Distortion: Determines the average distance of the line distortion, where 0  is straight and 

larger or smaller values create a zigzag effect.
Speed: Determines the change rate of the effect.
N: Determines the number of distortions.
Seed: Applies a randomization value to the effect.

See Also

PixelFXLensFlare

Note: This plug-in is located in: Plugins -> Geom plug-ins -> PixelFX

Note: If Core is a larger value than Radius, it creates a spillover of the color.
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pxLensGlowBall

The pxLensGlowBall plug-in produces the effect of a glowing ball.

pxLensGlowBall Properties
Use LOD: Enables level of detail.
Glow Color: Determines the color of the glow.
Radius: Determines the glow size.
Ring Color: Determines the color of the ring.
Ring Radius: Determines the radius of the ring.
Ring Width: Determines the size of the ring.
Ring Softness: Determines the blurriness of the ring.
Size: Determines the size of the entire glowball. 

pxLensGlowSpikes

The pxLensGlowSpikes plug-in produces the effect of a glowing star of spikes.

Note: This plug-in is located in: Plugins -> Geom plug-ins -> PixelFX

Note: This plug-in is located in: Plugins -> Geom plug-ins -> PixelFX
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pxLensGlowSpikes Properties
Color: Determines the color of the spikes.
Sides: Determines the number of spikes.
Size: Determines the size of the effect.
Angle: Rotates the resulting spikes.

pxLensPolyElement

The pxLensPolyElement plug-in creates a polygon shape. 

Note: This plug-in is located in: Plugins -> Geom plug-ins -> PixelFX
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pxLensPolyElement Properties
Use LOD: Enables level of detail.
Color: Determines the color of the polygon.
Sides: Determines the number polygon sides.
Size: Determines the size of the effect.
Softness: Determines the blurriness of the polygon.
Angle: Rotates the resulting spikes.

pxLensRandomPoly

The pxLensRandomPoly plug-in creates a polygon shape with random angles. 

pxLensRandomPoly Properties
Use LOD: Enables level of detail.
Ray Color: Determines the color of the polygon.
Sides: Determines the number polygon sides.
Angle Randomness: Randomizes the angles.
Radius Randomness: Randomizes the distance between the center and the angles.
Warp: Pulls the non-angle edges towards the center of the polygon.
Warp Softness: Determines the blurriness at the edges of the polygon.
Size: Determines the size of the effect.
Angle: Rotates the resulting polygon.
Seed: Applies a randomization value to the effect.

Note: This plug-in is located in: Plugins -> Geom plug-ins -> PixelFX
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pxLensRays

The pxLensRays plug-in can be used to produce the effect of rays. The rays can be static or move 
randomly based on the Speed parameter.

pxLensRays Properties
Ray Color: Determines the base color of the ray.
Presets: Selects user-defined (Custom) or predefined (Rainbow or Red→Green) gradient
ramp.
Color Ramp: Modifies the color of user-defined portions of each ray.
Image: Uses a gradient ramp from the image dropped into the Image box.
Rays: Determines the number or density of rays.
Size: Determines the length of rays.
Inner Radius: Sets the size of the inner radius.
Angle: Sets the angle value between the first and last ray.
Width: Determines the thickness of rays.
Speed: Determines the change rate of the effect.

See Also

PixelFXLensFlare

Note: This plug-in is located in: Plugins -> Geom plug-ins -> PixelFX
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pxLensSpark

The pxLensSpark plug-in creates a spark effect. 

pxLensSpark Properties
Use LOD: Enables level of detail.
Ray Color: Determines the color of the effect.
Rays: Determines the number of sparks.
Size: Determines the size of the effect.
Seed: Applies a randomization value to the effect.

pxLensStripes

The pxLensStripes plug-in produces a symmetric stripe effect.

Note: This plug-in is located in: Plugins -> Geom plug-ins -> PixelFX

Note: This plug-in is located in: Plugins -> Geom plug-ins -> PixelFX
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pxLensStripes Properties
Use LOD: Enables level of detail.
Symmetry: Determines the number of axes of symmetry.
Length: Determines the length of the stripe.
Width: Determines the width of the stripe.
Size: Determines the size of the stripes.
Angle: Rotates the resulting effect.
Pinch: Makes the ends of the stripes narrower than the set Width.

8.4 Container Plug-Ins
The default path for Container plug-ins is: <viz install folder>\plugin.

8.4.1 pxColorWorks
The color correction plug-ins, which are part of the PixelFX plug-ins set, are generally fast and 
efficient, however there is a certain performance penalty when animating them in a stacked 
scenario.

The following Container plug-ins are located in the pxColorWorks folder:

PixelFX plug-ins set
pxAddSubtract
pxBlackAndWhite
pxBrightContrast
pxColorMatch
pxGamma

Note: The PixelFX plug-ins are a separate package from the standard Viz Artist installation, 
but function within the Viz Artist environment.





Plug-ins User Guide -  5.0

Copyright © 2022  Vizrt Page  773

•
•
•
•
•

•
•

•
•
•

•

•

•

pxHueRotate
pxMask
pxSaturation
pxStack
pxTint

See Also

PixelFX in Shader Plug-ins
PixelFX in Geometry Plug-ins

PixelFX plug-ins set
The PixelFX plug-ins affect pixels and geometry, and produce various special effects. They do three 
main things:

Color correction
Lens flares
Other pixel-based effects, such as noise, gradients, various distortion effects, transitions, 
and similar effects.
The icon for each of the plug-ins have mini icons that show certain properties of the 
particular plug-in.

At the bottom left, there is a performance bar, with three blocks (like a cellphone battery 
indicator). One block means the plug-in does not have a drastic performance effect, and 
three means the plug-in is taxing and should therefore be used with caution.
At the bottom right the orange stack shows if the plug-in is stackable, meaning it can be 
used in conjunction with color correction plug-ins.
Some plug-in icons themselves are divided in half with one side showing the visual effect 
with the plug-in and the other without it.

Some of the PixelFX plug-ins work only when applied to a Container that also has a Texture. The 
rest however, function on the Renderer’s pixel buffer. For example, you may apply color correction 
to the root Container in a Scene, therefore perform a color correction to the whole scene. Another 
example is pxNoise- apply it to the root level container of a scene or a whole tree branch to add a 
kind of film-grain effect.

One of the parameters that feature in a number of the PixelFX plug-ins is Seed. This defines the 
pseudo-random rule for changed parameters. Once a value is chosen, although the original state 
is random, the effect actually looks the same on other computers as well.
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pxAddSubtract

The pxAddSubtract plug-in allows you to add or subtract a constant color value to each pixel. It 
can be applied to Everything, Shadows, Mid tones and Highlights.

pxBlackAndWhite

The pxBlackAndWhite plug-in allows you to gray scale an RGB image or a tree branch holding 
geometry. It can be applied to Everything, Shadows, Mid tones and Highlights.

pxBrightContrast

The pXBrightContrast plug-in allows you to adjust the brightness and the contrast on each of R, G 
and B on a given image or a tree branch holding geometry. It can be applied to Everything, 
Shadows, Mid tones and Highlights.

pxColorMatch

The pxColorMatch plug-in lets you replace one color with another. It works on images and tree 
branches holding geometry alike.

Note: This plug-in is located in: Plugins -> Container plug-ins -> pxColorWorks

Note: This plug-in is located in: Plugins -> Container plug-ins -> pxColorWorks

Note: This plug-in is located in: Plugins -> Container plug-ins -> pxColorWorks

Note: This plug-in is located in: Plugins -> Container plug-ins -> pxColorWorks
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pxColorMatch Properties
Weighting: Defines the color range proximity to the selected color.
Inertia: Defines the smoothness of the range proximity graph.
Count: Defines the number of color replace pairs you wish to use.

pxGamma

The pXGamma plug-in allows you to adjust the gamma correction on each of R, G and B on a given 
image. It can be applied to Everything, Shadows, Mid tones and Highlights.

pxHueRotate

The pxHueRotate plug-in allows you to adjust the hue rotation on an image. It can be applied to 
Everything, Shadows, Mid tones and Highlights.

pxMask

The pxMask plug-in allows you to supply a mask for the color correction operation. The mask is 
defined by a black and white image that is dragged into the pxMask plug-in parameters. pxMask, 
as indicated by the stackable icon, can function in conjunction with a mask.

Note: This plug-in is located in: Plugins -> Container plug-ins -> pxColorWorks

Note: This plug-in is located in: Plugins -> Container plug-ins -> pxColorWorks

Note: This plug-in is located in: Plugins -> Container plug-ins -> pxColorWorks
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pxSaturation

The pxSaturation plug-in allows you to adjust the color saturation on an image. It can be applied to 
Everything, Shadows, Mid tones and Highlights. You also have the option to preserve highlights, or 
not.

pxStack

To Apply the pxStack Plug-in
Add the pxStack plug-in to the required Container in the Scene Tree (1).

Click the pxStack icon in the Container. The plug-in editor (2) shows a list of color correction 
filters.
Click on a color correction filter.

Note: This plug-in is located in: Plugins -> Container plug-ins -> pxColorWorks

Note: This plug-in is located in: Plugins -> Container plug-ins -> pxColorWorks

Note: When the pxStack plug-in is added to a Container, it automatically adds the 
pxCCBase plug-in to the same Container. Also, it automatically generates a child 
Container to host the color correction nodes you define later.
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Click Add Filter. The color correction filter is added as a new Container under the ‘noname’ 
Container in the Scene Tree (3). This termed as a ‘Color Correction Node’.
Repeat to add more color correction filters. Each color correction filter applied is added 
(stacked) as a new Color Correction Node under the ‘noname’ Container in the Scene Tree.
Click on a Color Correction Node to open its editor. Modify the effect properties as required.
Change the order of the stacked properties, as required.

pxTint

The pxTint plug-in allows you to add a color tint and apply it to an image in the required amount. 
It can be applied to Everything, Shadows, Mid tones and Highlights. You also have the option to 
preserve highlights, or not.

8.4.2 PixelFX
The PixelFX plug-ins are part of the PixelFX Plug-ins set.

The following Container plug-ins are located in the PixelFX folder:

pxLensMulti

pxLensMulti

pxLensMulti serves as a parent container for all the other PixelFX Geometry plug-ins. It simplifies 
the process of animating lens flares so that they resemble realistic behavior. In the child 
containers any number of lens flare shapes can be placed. pxLensMulti positions, colors, governs 
the opacity of all according to the configurable parameters.

IMPORTANT! Selected properties act in the sequence in which they are ordered in the scene 
tree.



Note: To disable or enable a Color Correction Node click the Locked/Unlock icon in the top 
left of the Container.



Note: To remove a color correction function, delete the plug-in.

Note: This plug-in is located in: Plugins -> Container plug-ins -> pxColorWorks
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The lens flare shapes at origin are a flat geometry. pxLensMulti makes sure that all the shapes it 
handles are constantly facing the camera.

pxLensMulti Properties
Under the Spread tab, the following parameters can be configured to handle shapes’ position:

Mode: Defines options for positioning of the multiple lens flares:
Polar: Places lens flares on a screen space and controls their positions using Pos 
Radius and Pos Angle parameters (the notional line is defined by the angle and radius 
originating from the screen’s center).
Cartesian: Places lens flares on a screen space and controls their positions using Pos 
X and Pos Y parameters (the notional line is created between the screen’s center and 
given an x-y location in the screen’s coordinates).
Container: Uses a container to imitate the light position so that the notional line starts 
from that position and goes through the screen’s center. If the container is visible, 
lens flares are positioned on an axis that goes from light source through the middle of 
the screen plane (Note that in these mode lens flares positions changed with camera 
or light movement). In Container mode, you need to drag a container from the scene 
tree into the Container box.

Distance: Defines the notional line that passes through the screen’s center. The distance of 
this center point from the camera is defined by the this parameter’s value.
Count: Multiplies the quantity of each shape in each child container by the value entered for 
this parameter.
Radius Scale: Scales the notional line from the origin onward.
Radius Rand: Scales the notional line’s length, regardless of origin.
Single Seed: Allows only one seed to be used for each shape in the child containers when set 

to On . When set to Off , a different seed is used for each shape in the child containers.

Seed: Defines the pseudo-random rule for randomly changed parameters. Once a value is 
chosen, although the original statement is random, the effect looks the same on other 
computers as well.

Under the Attributes tab, the following can be configured to handle non-positional parameters:

Note: pxLensMulti creates a notional line along which all shapes are scattered.

Note: This plug-in is located in: Plugins -> Container plug-ins -> PixelFX

Note: In Container mode, one point of the notional line is in the coordinates 
and the second point, through which the notional line passes, is defined in the 
screen coordinates. As such, camera movement in Container mode actually 
defines the shapes’ movement.
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Amount: Determines the amount of light used in lens flares.
Amount Rand: Randomizes the amount parameter between different flares.
Size Rand: Randomizes the light.
Color Rand: Randomizes the color.

See Also

pxColorWorks
PixelFX Plug-ins in Geom plug-ins
PixelFXLensFlare in Shader plug-ins

8.5 Shader Plug-Ins
The default path for the Geometry plug-ins is: <viz install folder>\plug-in\<plug-in name.vip>

8.5.1 PixelFX
The Pixel Shader plug-ins are part of the PixelFX plug-ins set.

Viz Artist does not support more than one general shader on a Container, or in a nested fashion. 
However, in some cases, PixelFX, by its nature, does support multiple shaders per Container.

Some have high cautionary indications. Some are very light. Some are stackable, and others are 
not.

The following Shader plug-ins are located in the PixelFX folder:

PixelFXLensFlare
pxBCubic
pxCCBase
pxEqualize
pxGradient
pxInvert
pxLensDistort
pxMotionBlur
pxNoise
pxPixelate
pxPosterize
pxRecolor
pxRipple
pxSparkle
pxTurbDissolve and pxTurbWipe
pxTurbulence
pxTwirl
pxWaves
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Common Properties

Most of the plug-in icons have mini icons that show certain properties of the particular plug-
in:

At the bottom left, there is a performance bar, with three blocks (like a cellphone battery 
indicator). One block means the plug-in does not have a drastic performance effect, and 
three means the plug-in is taxing and should therefore be used with caution.
At the bottom right, the orange stack shows if the plug-in is stackable, meaning it can be 
used in conjunction with color correction plug-ins.
Some plug-in icons themselves are divided in half with one side showing the visual effect 
with the plug-in and the other without it.

PixelFXLensFlare
The Lens Flare plug-ins, which are part of the PixelFX plug-ins set, simulate the effect of streaks 
and spots of light caused in real cameras when light enters and bounces inside a camera lens. This 
plug-in set contains geometries that simulate different shapes, which can be used for lens flare or 
simple flare effects.

The Flare draws itself as a combination of geometry shader and pixel shader.

When a Flare Container is created (1) a non-editable pixel shader (2) is automatically added to the 
created Flair Container.

The non editable shaders are needed to do more (detailed, on a per pixel basis) graphical effects 
on the GPU (manipulating colors, textures, lighting, etc.), which cannot be done with Geometries 
only.
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See Also

PixelFX in Geometry Plug-ins

pxBCubic

When dealing with images that contain line art or lines of high contrast, you may want to protect 
yourself from the less than the desirable effect of pixelation when an image is over scaled. The 
BCubic plug-in introduces three bi-cubic algorithms. Each is useful in different contexts of its 
respective type. It is very easy to find the best adjustment to your specific scenario.

pxCCBase

The pxCCBase (Color Correction) applies a cumulative set of color corrections using 
the pxStack plug-in.

Note: This plug-in is located in: Plugins -> Shader -> PixelFX

Note: This plug-in is located in: Plugins -> Shader -> PixelFX
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pxEqualize

pxEqualize allows you to adjust the black, mid-range and white color levels in an image.

pxGradient

The pxGradient plug-in has a similar functionality to the gradient function in Photoshop. It can be 
applied on a container that holds a geometry, an image, or even an empty container. You can 
define as many gradient stops as you wish, as well as their origin points, angles, and extent. You 
can also define the gradient on the alpha channel (256 levels) and introduce turbulence noise 
that complies with the defined gradient.

At the top of the plug-in parameters, you see the controls that let you define the direction, radius 
and origin of the gradient. Below that you see a two radio button sets. The first lets you set the 
gradient type, followed by three Repeat types

Below that, you see the color slider, the color values and alpha ramp settings.

Below the RGB and Alpha area of the editor, you find the option of adding Turbulence to the 
gradient. The turbulence has three simple parameters. Amount determines how aggressive the 
turbulence looks. Wavelength determines how big or small the turbulence increments are. Progress 
(similar to that in TextFX plug-ins) allows you to breathe life into the turbulence, providing 
interesting an effect when animated.

At the very bottom, it is important to make sure that you turn off the Show GUI button, whose 

default is On ; if shown On Air, the effect is more embarrassing than dramatic.

Best Practices
It is important to understand that the Gradient plug-in is actually drawing pixels. Therefore if this 
plug-in is applied to an empty group or if it is applied to a geometry object that does not contain a 
texture, the gradient plug-in generates the texture into which it draws its pixels. So if you have a 

Note: This plug-in is located in: Plugins -> Shader -> PixelFX

Note: This plug-in is located in: Plugins -> Shader -> PixelFX

Note: This plug-in is located in: Plugins -> Shader -> PixelFX

Note: Under the title Color Ramp and Alpha Ramp, you have an active/inactive option, 
should you want to have an RGB ramp and no alpha ramp, or vice versa.
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cube and add the Gradient to it, it behaves exactly as a texture. However it can also work in 
conjunction with a texture. If you then take an image and drop it on the cube, you give a color 
wash to the image that works in a gradient-like fashion. The gradient-generated texture can also 
be edited via the texture editor as any other texture would be.

The biggest benefit of using the Gradient is conservation of texture memory. Instead of storing 
very many different alpha and color ramps in your image pool, you can simply achieve the 
overwhelming majority of these effects by well thought out and judicious use of the Gradient plug-
in. It has a minimum performance penalty and it can be animated. If you use ramps often in your 
designs, the Gradient is one of your handiest tools.

Tips and Tricks
Often you put reflection maps on a translucent geometry to create a glass-like reflection (think of a 
light box or an aquarium). For the reflection texture, one often uses an image of static noise or 
ramps of sorts. Since the texture is mapped on the object using a reflection mapping mode, it is 
very difficult to create the right intensity of noise in your texture so that the resulting reflection 
looks good. The Gradient turbulence functionality allows you to set the intensity of the noise of 
the texture “on the fly”, minimizing the round-trips to Photoshop.

pxInvert

Often you create an image with an alpha channel in Photoshop, import it to Viz Artist/Engine and 
only then realize that your alpha channel is inverted. Or you find an image in the Viz Artist/Engine 
pool that you want to use, but the way you want to use it is where the RGB is actually the alpha 
channel.

pxInvert allows you to perform these operations without adding yet another image to your image 
pool, or overloading your scenes with a few versions of the same image, where the difference is 
simple flips of the channels.

This plug-in allows you to invert each of the color channels RGB and Alpha individually, and to use 
the RGB as alpha and the alpha as RGB.

pxLensDistort

pxLensDistort creates a “fish eye” lens distortion effect on an image. It can also be used to create 
the effect of an old television with a curved screen.

The amount of the effect can be configured using the following parameters:

Amount
2nd Order

Note: This plug-in is located in: Plugins -> Shader -> PixelFX
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Scale

The center around which the distortion goes can be configured by using the X Center and Y Center 
parameters.

pxMotionBlur

pxMotionBlur applies motion blur to the texture. Supports pxColorWorks and pxStack plug-ins.

Adjust the following parameters as required to achieve the required effect:

X Center
Y Center
Rotate
Zoom
X Shift
Y Shift
Fix Edges (on/off)
Samples (enter a value)

pxNoise

pxNoise is a white noise generator. It deploys the same turbulence as seen in other PixelFX plug-
ins. Similarly to the pxGradient, it generates its own texture if applied to a container without an 
image, or blends with the existing texture if the container has an image applied.

Adjust the following parameters as required to achieve the required effect:

Size
Amplitude: Intensity/contrast of grains
Color
Speed: Turbulence noise
Stretch: Stretches the grain to achieve a rain look of noise
Stretch Angle
Movement: Transforms the generation of noise
Transform as Texture

On: Conforms to texture coordinates. 

Note: This plug-in is located in: Plugins -> Shader -> PixelFX

Note: This plug-in is located in: Plugins -> Shader -> PixelFX
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Off: Ignores texture coordinates and behave as stencil mapping.
Apply to: RGB, RGBA, Alpha: Determines the channels in which the noise is generated.

pxPixelate

Similar to the pixelate function in Photoshop, the pxPixelate effect appears as if you reduce the 
resolution of your image. You may work in a proportional (locked) or disproportional mode.

To achieve a nice animated transition, tweak the Smoothness parameter so that the change 
between the different pixelation levels are smoother or harsher.

Adjust the following parameters as required to achieve the required effect:

Lock X/Y (on/off)
X Size
Y Size
Smoothness
Supports pxColorWorks and pxStack plug-ins.

pxPosterize

pxPosterize recolors an image using only a limited number of colors for a posterize effect. You can 
adjust the number of levels and set the transition to one of Off, Fade or Glow.

pxRecolor

pxRecolor ‘false-colors’ an image by using either Red, Green, Blue or Luma as the input to a color 
ramp.

Note: This plug-in is located in: Plugins -> Shader -> PixelFX

Note: This plug-in is located in: Plugins -> Shader -> PixelFX

Note: This plug-in is located in: Plugins -> Shader -> PixelFX
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pxRipple

pxRipple creates a pond ripple effect. Supports pxColorWorks and pxStack plug-ins.

Adjust the following parameters as required to achieve the required effect:

X Center
Y Center
Radius
Amount
Wavelength
Progress 

pxSparkle

The pxSparkle plug-in generates a sparkle pattern as a ray emitting from a point. The plug-in 
editor provides options to control the density of the rays, the x,y position from where they are 
emitted, the brightness (Amount) of rays, as well as other parameters, which is covered specifically 
in context. Before delving into these parameters however, it is important to understand the 
pxSparkle, like other PixelFX shaders (pxGradient, pxNoise) generates its own pixels. As well, it 
has the ability to be applied on top of an image and can blend with the image’s pixels.

When the pxSparkle plug-in is applied to a container without an image, it creates sparkle results. 
However you can also apply it on a container with an image. In this case, you need to decide 
whether the sparkle pattern should blend on top of the image or whether it cuts the image. If the 
Cut Image option is on, the host image is seen only in areas that are brighter than zero. The 
brighter the sparkle, the more apparent the host image is.

The pxSparkle plug-in can be used as a flare to achieve its effect in a radius (the size of the hot 
spot). The inner Amount (the brightness of the hot spot) and the radius crops or fades the sparkle 
radially. You can also so the Speed parameter to set the sparkle in motion.

Transform as texture: This option forces the rendering of the sparkle to ignore the 
viewmatics - the sparkle is always facing the eye-point. This option is handy when applying 
the sparkle on top of a hierarchy.
Aspect: This option allows you to set the proportion of the sparkle independently of the 
texture transformation. Often you stretch textures to get what you want. However when 
applying the pxSparkle plug-in to a distorted texture, you may want to maintain its 

Note: This plug-in is located in: Plugins -> Shader -> PixelFX

Note: This plug-in is located in: Plugins -> Shader -> PixelFX



Plug-ins User Guide -  5.0

Copyright © 2022  Vizrt Page  787

•

1.

2.

3.

4.

5.
6.

•

roundness. Therefore you can use the Aspect parameter to compensate for the texture 
distortion.
Angle: This lets you rotate the sparkle without manipulating the texture coordinates. This 
option is handy when you have a static image on top of which you want to apply a rotating 
sparkle.

pxTurbDissolve and pxTurbWipe

Both pxTurbDissolve and pxTurbWipe utilize the native multi-texturing support of Viz Artist.

pxTurbWipe includes the parameters of Angle and Softness.

To Apply TurbDissolve and/or TurbWipe
Insert an image into the scene tree.

Go to the image’s texture editor and make sure that the texture Unit is set to 1  and the 

Inheritable option is active . This is your Image A in an A-B transition paradigm.

Place a child image underneath the first one. This is Image B.

In Image B’s texture editor, set the Unit to 2  and make sure that the Inheritable option is 

inactive .

Apply the Dissolve plug-in to the Image A (the parent image).
In the plug-in editor, first adjust the Transition, followed by the other parameters, as per 
your liking.

See Also

pxGradient

pxTurbulence

pxTurbulence creates a distortion effect using a Perlin turbulence function. 
Supports pxColorWorks and pxStack plug-ins. Adjust the wavelength, amplitude and speed to 
achieve the required effect.

Note: This plug-in is located in: Plugins -> Shader -> PixelFX

Note: This plug-in is located in: Plugins -> Shader -> PixelFX

Note: This plug-in is located in: Plugins -> Shader -> PixelFX



Plug-ins User Guide -  5.0

Copyright © 2022  Vizrt Page  788

•
•
•
•
•

•
•
•
•
•
•

pxTwirl

pxTwirl creates a distortion effect that twists an image around a central point. 
Supports pxColorWorks plug-ins and pxStack plug-ins.

Adjust the following parameters as required to achieve the required effect:

X Center
Y Center
Radius
Amount
Edge Softness

pxWaves

pxWaves creates a distortion effect that makes an image look wavy. Supports pxColorWorks plug-
ins and pxStack.

Adjust the following parameters as required to achieve the required effect:

Type: Sine, Noise, Triangle, Square
Angle
Amount
Wavelength
Progress
Seed

Note: This plug-in is located in: Plugins -> Shader -> PixelFX

Note: This plug-in is located in: Plugins -> Shader -> PixelFX
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9 Viz Social Plug-Ins

The Viz Social Plug-ins provide details about settings available through its configuration user 
interface within Viz Artist. 

9.1 Related Documents
Viz Artist User Guide: Contains information on how to create graphics scenes in Viz Artist.
Viz Engine Administrator Guide: Contains information on how to install the Viz Engine 
software and supported hardware.
Viz Ticker User Guide: How to install, configure and use the Viz Ticker client, and configure 
the output channels.
Viz Trio User Guide: How to install, configure and use the Viz Trio client, and configure the 
output channels.
Viz Pilot User Guide: How to install, configure and use Viz Pilot.
Viz Multichannel User Guide: How to install, configure and use Viz Multichannel.
Feed Streamer User Guide: Contains information on including information and graphics from 
various sources into scenes in Viz Artist.

9.2 Feedback And Suggestions
We encourage suggestions and feedback about our products and documentation. To give feedback 
and/or suggestions, please contact your local Vizrt customer support team at www.vizrt.com.

9.3 Container Plug-Ins
Social TV offers a set of plug-ins that are bundled with the Social TV installer. Most of the Social TV 
plug-ins work in combination with the DataPool plug-ins.

The following Social TV plug-ins are located in the Container Plugin tab (CP), under the SocialTV 
folder:

http://docs.vizrt.com/viz-artist.html
http://docs.vizrt.com/viz-engine.html
http://docs.vizrt.com/viz-ticker.html
http://docs.vizrt.com/viz-trio.html
http://docs.vizrt.com/viz-pilot.html
http://docs.vizrt.com/viz-multichannel.html
http://docs.vizrt.com/social-tv
http://www.vizrt.com/
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HTTP Recognizer
Playlist Reader
Split Author
Text Highlight
WordCloud

9.3.1 HTTP Recognizer

The STV_HTTP Recognizer plug-in recognizes a HTTP link in text geometry when placed on a text 
container.

In some cases, messages coming from social media networks such as Twitter or Facebook contain 
links to other sites. This plug-in hides the link from the message as these links provide no 
meaningful information for broadcasts. The plug-in can additionally store the value of this HTTP 
link in a DataPool or shared memory variable.

HTTP Recognizer Properties
Work On Text Changes:
Hide Links: Specifies whether or not discovered links are to be hidden.
Target:

DataPool: 
Shared Memory:

Variable: Sets the name of the variable in which the URLs of discovered links are to be 
stored.
Use Object Container:  Allows one container to affect another container, or allows another 
instance of the same plug-in to be used on the same container. DataPool container plug-ins 
affect the containers they are attached to, and cannot affect other containers directly. When 
enabled, additional options are also enabled:

Which:
PARENT: The DataPool plug-in affects the parent container (i.e. the container 
residing above the current container in the scene hierarchy).
GrParent: The DataPool plug-in affects the grandparent container (i.e. the 
container residing two levels above the current container in the scene 
hierarchy).
GrGrParent: The DataPool plug-in affects the great grandparent container (i.e. 
the container residing three levels above the current container in the scene 
hierarchy).

Note: This plug-in is located in: Plugins -> Container plug-ins -> SocialTV
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REMOTE: When remote is selected another parameter, Remote Container, is 
enabled. Drag the container to be effected to the container place holder.

Shared Memory Variable Type: Selects the shared memory area to update. Can be either 
Global, Scene or Distributed.
Apply:
Init:

9.3.2 Playlist Reader

The STV_PlaylistReader plug-in is used to read the list of pages inside a playlist, the playlist can be 
either from a Viz Trio Show or Content Pilot/MOS Playlist. STV_PlaylistReader is used in interactive 
applications to control and read all the pages that are in the Media Sequencer from the given 
Group of pages. The information retrieved from Media Sequencer is sent to a DataPool Array. 

Playlist Reader Properties
MSE Host: Determines which Media Sequencer to connect to.
DP Field Name: Defines where to send the information.
Mode: Determines which mode to run in.

Trio:

Note: This plug-in is located in: Plugins -> Container plug-ins -> SocialTV



Plug-ins User Guide -  5.0

Copyright © 2022  Vizrt Page  792

•

•
•
•
•

•
•
•
•
•

•
•
•

•

•

•
•
•

•
•
•
•
•

•
•
•

Show Name: Name of the Viz Trio Show (if not provided, it assumes the playlist 
is a Content Pilot or MOS playlist).
Playlist: Name of the Playlist.
Group Name: Name of the group of pages to retrieve.
Page to take: Index of page to control, starting from 0. 
Profile: Name of the profile to use, profile must be defined in profile 
configuration in the Media Sequencer. 

Pilot/MOS:
Playlist: Name of the Playlist.
Group Name: Name of the group of pages to retrieve.
Page to take: Index of page to control, starting from 0. 
Profile: Name of the profile to use, profile must be defined in profile 
configuration in the Media Sequencer. 

Ticker:
CarouselIndex:
Channel Name:

Post Update Action: Specifies commands (either DataPool or Viz commands) to be executed 
right after the data is read and sent to the target. Multiple commands should be separated 
by semicolon. To distinguish between Viz Commands and DataPool commands, Viz 
Commands need to be prefixed with a zero and a space. 
Show Data: Dumps the data the plug-in reads to a DataPool variable called defined in 

Console Field Name when set to On . This is extremely useful for development and 

debugging purposes. This dump includes error messages too.
Console Field Name: Determines which DataPool field to send to.
Number of Read Records Field:
Log Level: Selects the log level:

Fatal: Displays only fatal errors. This is the lowest level.
Error: Displays Fatal and Error messages.
Warning: Displays Fatal, Error and Warning messages.
Information: Displays Fatal, Error, Warning and Information messages.
Debug: Displays Fatal, Error, Warning, Information and Debug messages. This is the 
highest level.

Control buttons: 
Read Playlist: Reads the items based on the properties defined in the plug-in.
Take, Take Out and continue: Performs the given action to the page defined in 
the Page to Take property.

This is an example of a playlist in Viz Trio:
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Using the STV_Playlist plug-in in the Scene:
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Configuration File
The Social TV package installs a config-SocialTV file located at: C:\Program Files 
(x86)\vizrt\VizArtist. The Config DP file includes a base type of a STV_MSE_Page:

STV_MSE_Page = {
string Name;
string Description;
string Template;
string Path;

}

Name: Returns the value of the page name.
Description: Returns the value of the description in the Playlist. The Description is defined in 
the ControlObjectPlugin on the top of the Scene template.
Template: Returns the value of the Description from the template.

9.3.3 Split Author

The STV_SplitAuthor plug-in recognizes the at (@) character from text and allows hiding either the 
user ID or user name of the author when placed on a text container.

Note: You must send text to the author property of this plug-in using ControlParameter.

Note: This plug-in is located in: Plugins -> Container plug-ins -> SocialTV
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Split Author Properties
Author:
Display:

Example

9.3.4 Text Highlight

The STV_TextHighlight plug-in recognizes certain characters and allows color changes to any word 
containing that character (for example: #tags @User http://) when placed on a text container the 
plug-in.
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Text Highlight Properties

Coloring
When Text Highlight is placed on a text container, the plug-in recognizes certain characters and 
lets you change the color of any word containing that character (e.g., #tags, @User, http://).

Emoji
Emoji: Toggles whether to highlight emoji content.
Images: Default/Custom.

When using default the plug-in uses the images located in C:\Program 
Files\Vizrt\VizArtist\plugin\data\TextHighlight\72x72.
When using custom the user defines a path to their own images.

Characters Folder:
Word Folder: Defines a folder of images containing words that should be replaced by emojis.
Size:
Ignore List: Defines a list of characters that should be ignored when replacing with emojis.
Word List Separator: Sets the character to be used as a separator of the list of words to 
replace by emoji.
Word List: Defines a list of words to be replaced by emojis.
Print Codes:
Scan Folders:
Update Word List:

Text FX
The Text FX option allows users to apply similar effects as Text FX plug-ins when using emojis. For 
more information please refer to section TextFX.

Note: You must send text to the text property of this plug-in using ControlParameter.

Note: This plug-in is located in: Plugins -> Container plug-ins -> SocialTV

Note: The custom path should be accessible to all machines running Viz 
Engine, including Trio and Preview Engines.
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Example

9.3.5 WordCloud

The STV_WordCloud plug-in reads an XML file to create wordcloud type visualizations. This plug-in 
allows users to read items from the DataHub that are compatible with the plug-in. 

Examples are feeds from Dizplai World Cloud, Spredfast Top Terms, etc. The plug-in then 
visualizes the data in the form of a Word Cloud.

The plug-in is compatible with Dizplai’s XML format, but it can read any XML in the following 
structure:

<datasource>
<entry>
<field name="text">This</field>
<field name="count">967</field>
</entry>

Note: This plug-in is located in: Plugins -> Container plug-ins -> SocialTV

Note: This plug-in must be placed on top of a text geometry.

https://dizplai.com/
https://dizplai.com/
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<entry>
<field name="text">is</field>
<field name="count">772</field>
</entry>
<entry>
<field name="text">a</field>
<field name="count">150</field>
</entry>
<entry>
<field name="text">sample</field>
<field name="count">144</field>
</entry>
<entry>
<field name="text">XML</field>
<field name="count">119</field>
</entry>
<entry>
<field name="text">file</field>
<field name="count">106</field>
</entry>
</datasource>

WordCloud Properties
Font Type: Regular Complex
DataHub Host: (Deprecated) Defines the hostname of the DataHub to communicate with. 

DataHub Port: (Deprecated) Sets the port for connecting to DataHub. The default is  8089 . 

DP Field Name: Returns data to this field.
Load Automatically: Retrieves data automatically from Viz DataHub at determined intervals.
Group Name: Includes messages that come from specific groups.
Source Name: Includes messages that come from specific sources.
Provider Name: Includes messages that come from a specific provider (for example 
Facebook, Twitter etc.).
Free Text Search: Searches messages for text included in this parameter.
Disable Sort:
Custom Sort: Sorts retrieved data by the selected parameter.

All: Loads all messages.
Approved: Loads approved messages.
Rejected: Loads the rejected messages.

Filter Rejected:
Favorites: Includes the messages from the Favorites group.
Area Width: Determines the width of the wordcloud text region.
Area Height: Determines the height of the wordcloud text region.
Margin: Determines the margin around the wordcloud text region.
Layout: Creates either a square or round wordcloud layout.

Note: This plug-in is located in: Plugins -> Container plug-ins -> SocialTV
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Seed: Applies some randomization value to the layout of words.
Number of Words: Limits the number of words to use in the Word Cloud visualization (uses 
the highest volume words).

Color: Applies an image for coloring each word in the cloud when set to Image .

Shared Memory: Scene, Global, Distributed.
Scale Ranks: Allows scaling words based on ranking.
Clip Ranks: Allows clipping words with a value lower or higher than what is defined in the 
plug-in.
Render Bounding Boxes: Renders the bounding box.
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