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1 Graphic Hub Administrator Guide

This is the Graphic Hub Administrator Guide, it covers the information needed to configure and
operate the Graphic Hub and its related components:

Graphic Hub Administrator Guide
Graphic Hub Deploy Agent
Graphic Hub ImEx Agent

Graphic Hub Manager

Graphic Hub REST

Graphic Hub Terminal

1.1 Introduction

This is the Graphic Hub Administrator Guide, which provides the information needed to configure
and operate the Graphic Hub.

This page contains the following topics:

Conventions

Customer Feedback and Suggestions
Customer Support Request

Before Submitting a Support Request

- Submitting a Support Request

Content of a Support Request
- To submit a Support Request
Graphic Hub Log Files
Graphic Hub Component Logs
Graphic Hub REST Log files
Graphic Hub ImEx Log files

1.1.1 Conventions

The following typographic conventions are used in this document:

1.

Italic is used for non-hyperlink external references, such as related documents, books, or
Internet pages. ltalic is also used to emphasize words.

- The color blue is used for hyperlinked external references, and also internal references to

sections or document elements (such as tables or figures) in the current document.
Bold refers to User Interface components.

Numbered paragraphs are used to show tasks that must be performed in a numbered order.

1.1.2 Customer Feedback and Suggestions

We encourage suggestions and feedback about our products and documentation. To give feedback
and/or suggestions, please identify your local Vizrt customer support team at www.vizrt.com.
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f—

. Go to www.vizrt.com.

. Click on Contact.

3. The Vizrt office which is nearest to your location will automatically be displayed. You can
also select from the list of Vizrt offices.

4. Click on Contact.

5. Complete the required details in the window that opens.

N

Note: If this message is for Customer Support, and their is a Support Contract in
place, then click on the ‘For support requests, please visit our support portal’ link in
the message window.

6. Click on CONTACT ME.
A Vizrt representative will contact you as soon as possible.

1.1.3 Customer Support Request

Support Requests are supported by Vizrt if Customers have a valid Service Agreement in operation.
Customers who do not have a Service Agreement and would like to set up a Service Agreement
should contact their regional sales representative.

When submitting a Support Request relevant and correct information should be given to Vizrt
Support, to make sure that Vizrt Support can give the quickest and best solution to your Support
Request.

1.1.4 Before Submitting a Support Request

Before a Support Request is submitted make sure that you have read the documentation and
release notes for your version. Then check that the system is configured correctly, and that you
have the specified hardware, tested and recommended versions.

Always refer to your Vizrt Service Level Agreement document.

1.1.5 Submitting a Support Request

When completing a Support Request, add as much information as possible.

Content of a Support Request
The report should contain information about these topics:

- General:
Problem description: Include a good description of what the problem is and how to
reproduce it. Remember to use simple English.
- Screen shots and illustrations: Use to simplify the message.
- System network: Add a description of how the network, bandwidth, routers, and
switches are configured.
- System setup: Describe differences in the installation, if any, from the recommended
setup.
- Graphic Hub:

Copyright © 2018 Vizrt Page 11
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- System Reports: Export System Report files through the Graphic Hub Terminal. If a
Graphic Hub is running as a Graphic Hub cluster, the reports from Graphic Hub Main
and Graphic Hub Replication servers must be exported.

- System Dump Files: If Graphic Hub crashed the dump files can be found in the Graphic
Hub temporary directory (VizGH.exe_crashtime.dmp)

- Graphic Hub Terminal:

- System Reports and Dump Files: Export the System Reports and Dump Files through
the Graphic Hub Terminal on the tasks source and destination server.

. Graphlc Hub Deploy Agent:

- System Reports: Export the System Reports through the Graphic Hub Terminal on all
source and destination servers which the current Graphic Hub Deploy agent has tasks
deploying from and to).

- System Dump Files: If the Graphic Hub Deploy Agent crashed the dump files can be
found in the Graphic Hub Deploy Agent temporary directory
(VizGHDeployAgentService.exe_crashtime.dmp).

If there is no Graphic Hub terminal running on the workstation where the Graphic Hub
Deploy Agent is running, also attach the information detailed below:
Event logs: Send the system, application and Vizrt event logs.
- Graphic Hub Connection log: Send the Graphic Hub connection log files.
- Software configuration: Add exact versions of software (-build) used.
Hardware configuration: Add exact versions of hardware (-build) used.

. Graphlc Hub Manager:

- System Reports: Export the reports through the Graphic Hub Terminal on the
workstation where the Graphic Hub Manager was running.

- System Dump files: If the Graphic Hub Manager crashed the dump files can be found
in the Graphic Hub Manager installation directory (vizGHManager_crashtime_.dmp).

If there is no Graphic Hub Terminal running on the workstation where the Graphic Hub
Manager is running also attach the information detailed below:
Event logs: Send the system and application event logs.
- Graphic Hub Connection log: Send the Graphic Hub connection log files.
- Software configuration: Add exact versions of software (-build) used.
Hardware configuration: Add exact versions of hardware (-build) used.

. Graphlc Hub REST:

- System Reports and Dump files: Export the System Reports and Dump files through
the Graphic Hub REST web interface in the Reports section.
Event logs: Send the system and application event logs.

- Graphic Hub Connection log: Send the Graphic Hub connection log files.

- Graphic Hub REST logs: Send all Graphic Hub REST log files.

- Software configuration: Add exact versions of software (-build) used.

Hardware configuration: Add exact versions of hardware (-build) used.

. Graphlc Hub ImEx:

- System Reports and Dump files: Export the System Reports and Dump files through
the Graphic Hub ImEx web interface in the Reports section.
Event logs: Send the system and application event logs.

- Graphic Hub Connection log: Send the Graphic Hub connection log files.
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- Graphic Hub REST logs: Send all Graphic Hub REST log files.

- Graphic Hub ImEx logs: Send all Graphic Hub ImEx log files.

- Software configuration: Add exact versions of software (-build) used.
Hardware configuration: Add exact versions of hardware (-build) used.

To submit a Support Request

Go to Vizrt.com.

Click on Support.

Click on Report a case.

Click on LOG IN.

Login to the Customer and Partner portal.

Click on Report a Case.

In the online form complete the required minimum information (shown by a red asterisk):
- Contact: Your name

- Account: Your account
Product: The product the support request refers to.
- Case Type: The type of support request required
8. Click SAVE.
9. In the saved Support Case that opens, complete the various text boxes and upload any
required documents, files, etc. (see Content of a Support Request).

NoOuvihh WN —

Note: The entered text or uploaded documents / files are automatically added.

To track the status of open support tickets, login to the Customer and Partner portal. Add
information or communicate about the cases directly with the support team.

1.1.6 Graphic Hub Log Files

A Graphic Hub overall report, which contains all Graphic Hub log files and additional system
information, can be generated in the Graphic Hub Terminal.

All services installed on the same machine will be included in the export.

If there is no Graphic Hub terminal running on the workstation where the Graphic Hub Deploy
Agent is running select and generate these log files:

- Graphic Hub Log files
Location: <current Graphic Hub data directory>/LogFiles
Purpose: Graphic Hub runtime and error information.
- System Event Log
Location: Start > Run... > eventvwr.exe > Event Viewer > Windows Logs
Name: System
Purpose: Information from the current windows system.
- To create: Right click on System and select Save all Events as...
- Application Event Log
Location: Start > Run... > eventvwr.exe > Event Viewer > Windows Logs
Name: Application
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Purpose: Windows crash information of programs

- To create: Right click on Application and select Save all Events as...

- Vizrt Event Log
Graphlc Hub Deploy Agent system log (only exists if Graphic Hub Deploy Agent is installed).

Location: Start > Run... > eventvwr.exe > Event Viewer > Applications and Services
Logs
Name: Vizrt
Purpose: Deploy agent event log.

- To create: Right click on Vizrt and select Save all Events as...

Graphic Hub Component Logs
In general, all Graphic Hub Components log files containing important information:

Location: %$PROGRAMDATA%\vizrt\COMPONENTNAME
Purpose: Configuration and logs of the Graphic Hub component

Graphic Hub REST Log files

A Graphic Hub REST report, which contains all relevant log files and additional system information
according to GH REST, can be generated in the Graphic Hub REST web interface.

If this is not possible select and generate these log files:

Location: %ProgramData%\vizrt\Viz GH Rest\logs
Purpose: Connection, error and event logs of the Graphic Hub REST.

Graphic Hub ImEx Log files

A Graphic Hub ImEx Report, which contains all relevant log files and additional system information
according to GH ImEx, can be generated in the Graphic Hub ImEx web interface.

If this is not possible select and generate these log files:

Location: %ProgramData%\vizrt\Viz GH ImEx Agent\logs
Purpose: Connection, error and event logs of the Graphic Hub ImEx Agent.

1.2 System Installation

The Graphic Hub can be installed in a Cluster, a Multi User (see Server Requirements) or a Single
installation mode (see Workstation Requirements). For more information on the different
installation options, see Which Graphic Hub Mode. The initial mode selection is performed during
installation. The Graphic Hub mode can also be changed and configured, once the Graphic Hub
Terminal has been started (see Graphic Hub Modes).

All Graphic Hub configurations are installed from one installation bundle, which includes the
Graphic Hub and the Graphic Hub Terminal.

This section contains information on the following topics:

Installation Prerequisites
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Server Requirements
Installing Graphic Hub Applications
Licensing the Graphic Hub

1.2.1 Installation Prerequisites

Before installing, upgrading or removing the Graphic Hub, make sure that you have gone through
this check-list:

Shut down the Graphic Hub, and stop the GH Terminal service.

Optional: When upgrading create a backup of the data directory by copying it.

The cluster solution is the only server setup with real-time data replication capabilities. For
all other system configurations, backup procedures must be executed manually.

Note: Backup operations can only be done when the server is shut down.

When upgrading Graphic Hub, make sure that there are no open transactions on either of
the existing systems (see Check There are no Open Transactions)

Note: The Open Transactions setting is only available for servers in a Cluster
environment.

In a Cluster configuration, the Graphic Hub version number must be identical on the Main
and Replication machines. Mixed versions of Graphic Hub are not supported. Failure to heed
this can lead to serious system failure and data loss.
In a Cluster configuration, the Main and Replication machines must be started in mode Main
or Replication. Mixed Graphic Hub modes in a cluster are not supported. Failure to heed this
can lead to serious system failure and data loss.
Make sure that the data directories of the main and replication servers are exclusive, so that
no other Graphic Hub or process uses these directories.
Do not use Windows Remote Desktop to install and/or work with Graphic Hub on versions
below 3.0.0. Instead, use another remote tool, for example VNC.
Make sure that no other applications on the server workstations can cause performance
problems. Some examples of situations when databases should not be installed are:

The general CPU usage is above normal.

Viz Artist is used on the same machine.

Other databases run on the same machine.

The network traffic is extensive.

Also note that running a virus scanner on the Graphic Hub machine can decrease the

performance of the database.

The performance of the database depends upon the performance of the physical machine the
database runs on. As system performance increases, so does the database performance. This is
why it is highly recommended to use a server with high performance.
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Check Open Transactions

From Graphic Hub 3.0, the status of open transactions is shown in the GH Terminal main screen:

—

/\ Warning: Do not proceed with an upgrade if there are any open transactions!

If required, the Graphic Hub Console can also be opened to check for open transactions. In the
Graphic Hub Terminal, click Report > Graphic Hub Console.

For all previous Graphic Hub versions, use the following procedure:

1. Open Graphic Hub Manager on both the machines (Main and Replication).
2. From the main menu, select Tools > Monitor Servers.
3. Check that Open Transactions are at zero.

1.2.2 Server Requirements

This section details the requirements for multiple clients to access a Graphic Hub (installations
with more than one server), which includes Multi User, Main Server and Replication Server
configurations, as described in the Graphic Hub Modes section.

& Note: Support for any specific operating system or service pack version will only be
provided by Vizrt as long as it is officially supported by Microsoft. Support end dates will
be announced in the release notes for new versions of all Graphic Hub components. Other
Vizrt products may be supported on other platforms and the documentation and release
notes for the product in question should be consulted separately.

This page contains the following topics:

Graphic Hub Requirements

Graphic Hub as Viz Pilot back end system
Small installations:
Medium installations:
Large installations:

Deploy Agent Requirements

Graphic Hub REST Requirements

ImEx Agent Requirements

- Workstation Requirements

Hardware Requirements
Deploy Agent Requirements
Graphic Hub REST Requirements
Graphic Hub ImEx Agent Requirements

Service Dependencies
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Graphic Hub Requirements

These are the minimum requirements for the Graphic Hub:

Compo Minimum Requirement
nent

System - Microsoft Windows Server™ 2008 R2 (64 Bit)
- Microsoft Windows Server™ 2012 R2 (64 Bit)
Microsoft Windows Server™ 2016 (64 Bit)
- The above operating systems as virtual machine on ESXi 6.0 Update 2 (build
3620759).
No other applications may be installed on the server machine.
- Anti-virus software without endpoint protection and excluding the following
Graphic Hub processes:
- VizGH.exe
- VizGHNamingservice.exe
- VizGHTerminalService.exe

A IMPORTANT! All data directories must be excluded from anti-virus scan
operations and monitoring.

Browser Browser requirements (minimum and recommended versions):

- Google Chrome™ (recommended): 28, 39+
Mozilla Firefox™: 25, 35+

- Microsoft Internet Explorer™: 9, 10+

- Apple Safari™: 5, 7+

- Opera™: 15, 26+

CPU 8 cores with 2.4 GHz base frequency

RAM 8 GB DDR4-1866
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Compo Minimum Requirement
nent

HDD Hard disk performance has a noticeable impact on the overall performance of the
Graphic Hub. Therefore, the recommended hard disk setup is a RAID 10 configuration
over all disks, with indexing service disabled for the directory containing the Graphic
Hub data:

Expand priority: medium
Rebuild priority: high
Cache Usage: 50 % Read, 50 % Write

The amount of disk space depends on the amount of data that will be stored, but
should be at least 400 GB for data.

In addition, 40 GB is required as a separate Operating System partition.

/\ Warning: Running the Graphic Hub on a system without enough available hard
disk space can cause warnings, unexpected behavior, and data loss. Make sure
to stay well within the limits as described in Warning and Error Thresholds.

Networ A redundant (teamed) setup with two Gigabit network adapters is recommended.
k

Power A redundant power supply is highly recommended.
Supply

Graphic Hub as Viz Pilot back end system

When the Graphic Hub is used as the data back end for Viz Pilot, the following requirements need
to be considered in addition to the Graphic Hub Requirements. In general, the CPU, RAM and hard
disk requirements are highly dependent on the amount of graphics, Pilot data (VCP data elements,
templates, variants and concepts) the database contains, and how many parallel clients (Viz Artist/
Engine, VCP/ActiveX, Story, Pilot Edge) are active.

For a the list of compatible versions, see Viz Pilot Database Management

Small installations:

Small setups run on a single machine with all the necessary components installed: Graphic Hub
5/4 Free, Graphic Hub REST, Data Server and Media Sequencer. Such an installation can serve up to
five Viz Artist/Engine clients based on IP, and up to three VCP/ActiveX clients. Depending on the
hardware specifications, performance is limited by the amount of VCP data elements, templates,
variants and concepts.
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Component Minimum Requirement

CPU 8 cores with 3 GHz base frequency
RAM 16 GB DDR4-1866
HDD The amount of disk space depends on the amount of data that will be stored.

Graphic Hub (5/4 Free)
Graphic Hub REST
Data Server

Media Sequencer

Viz Pilot Viz Pilot ActiveX Viz Artist/Engine

Medium installations:

Medium Installations run Graphic Hub in Multiuser mode and Graphic Hub REST on one physical
server.

Component Minimum Requirement

CPU 12 cores with 3 GHz base frequency
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Component Minimum Requirement
RAM 16 GB DDR4-1866

HDD The amount of disk space depends on the amount of data that will be stored.

Graphic Hub (Multiuser)
Graphic Hub REST

Data Server

Viz Artist/Engine
Media Sequencer

Viz Pilot Viz Pilot ActiveX

Copyright © 2018 Vizrt Page 20



Graphic Hub Administrator Guide - 3.2

Large installations:

For customers with larger installations, it is required to run Graphic Hub and Graphic Hub REST on
separate and more powerful hardware. If performance issues occur, the Graphics and VCP content
should also be separated. For an optional failsafe system, at least two instances of Graphic Hub
REST and an HTTP Proxy are required.

/\ IMPORTANT! The hardware configuration for a large installation need to be defined in
collaboration with Vizrt based on the individual customer’s requirements.

Minimum suggested configuration:

Component Minimum Requirement

CPU 16 cores with 3 GHz base frequency
RAM 32 GB DDR4-1866
HDD The amount of disk space depends on the amount of data that will be stored.

This is an illustration of an example installation scenario, of a Graphic Hub cluster with redundant
Graphic HUB REST service. The HTTP proxies are optional, and only needed for complete
redundancy of the Graphic Hub REST service.

Graphic Hub REST

Data Server
Optianal: HTTP presy and 2nd REST/Data Server

Graphic Hub Cluster
{Main and Replication)

Viz Artist/Engine

iz Pilot Wiz Pilot ActiveX
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/\ Note: This illustration covers redundancy of Graphic Hub and Graphic Hub REST only. It
does not cover redundancy for Viz Pilot or Media Sequencer.

Deploy Agent Requirements

This section details the requirements for the Deploy Agent:

Component Minimum Requirement

System - Microsoft Windows Server™ 2008 R2 (64 Bit)

Microsoft Windows Server™ 2012 R2 (64 Bit)
Microsoft Windows Server™ 2016 (64 Bit)

- The above operating systems as virtual machine on ESXi 6.0 Update 2 (build
3620759).

- Anti-virus software without endpoint protection and excluding the Deploy
Agent process:
VizGHDeployAgentService.exe.

CPU 4 cores with 2.4 GHz base frequency
RAM 4 GB DDR4-1866
HDD 80 GB of free disk space for data.

In addition, 40 GB is required as a separate Operating System partition.

/\ Note: Support for any specific operating system or service pack version will only be
provided by Vizrt as long as it is officially supported by Microsoft. Support end dates will
be announced in the release notes for new versions of Graphic Hub. Other Vizrt products
may be supported on other platforms, however, and the documentation and release notes
for the product in question should be consulted separately.

Graphic Hub REST Requirements
This section details the requirements for the Graphic Hub REST:
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Compon Minimum Requirement
ent

System - Microsoft Windows Server™ 2008 R2 (64 Bit)

Microsoft Windows Server™ 2012 R2 (64 Bit)
Microsoft Windows Server™ 2016 (64 Bit)

- The above operating systems as virtual machine on ESXi 6.0 Update 2 (build
3620759).

- Anti-virus software without endpoint protection and excluding the Graphic Hub
REST process:
VizGHRESTService.exe.

No other applications, except the Graphic Hub in 5/4 Free or Localhost
configurations, may be installed on the server machine.

Browser Browser requirements (minimum and recommended versions):

- Google Chrome™ (recommended): 28, 39+
Mozilla Firefox™: 25, 35+

- Microsoft Internet Explorer™: 9, 10+

- Apple Safari™: 5, 7+

- Opera™: 15, 26+

CPU 8 cores with 2.4 GHz base frequency
RAM 4 GB DDR4-1866

HDD 400 GB of free disk space for data.

In addition, 40 GB is required as a separate Operating System partition.

/\ Note: If you also want to run this machine as your general web server, Vizrt cannot make
specific recommendations regarding hardware requirements.

ImEx Agent Requirements

This section details the requirements for the ImEx Agent:
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Component Minimum Requirement

System - Microsoft Windows Server™ 2008 R2 (64 Bit)
Microsoft Windows Server™ 2012 R2 (64 Bit)
Microsoft Windows Server™ 2016 (64 Bit)
- The above operating systems as virtual machine on ESXi 6.0 Update 2 (build
3620759).

+ Anti-virus software without endpoint protection and excluding the ImEx
Agent process:
VizGHImExAgentService.exe.

CPU 4 cores with 2.4 GHz base frequency
RAM 4 GB DDR4-1866
HDD 5 GB of free disk space for temporary data on the operating system partition.

Workstation Requirements

This section details the requirements for installations on laptops and desktop workstations
running the Graphic Hub in Localhost or 5/4 Free mode or for demonstration purposes.

Hardware Requirements

The following hardware is required:

Component Minimum Requirement

System - Microsoft Windows® 7 (64 Bit)
Microsoft Windows® 10 (64 Bit)

/\ GH 3.1.0 and above do not support 32 bit operating systems any longer.

Browser Browser requirements (minimum and recommended versions):

- Google Chrome™ (recommended): 28, 39+
Mozilla Firefox™: 25, 35+

- Microsoft Internet Explorer™: 9, 10+

- Apple Safari™: 5, 7+

- Opera™: 15, 26+
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Component Minimum Requirement

CPU 2 cores with 2.4 GHz base frequency
RAM 4 GB DDR4-1866
HDD The amount of disk space depends on the amount of data that will be stored, but

should be at least 50 GB for data.

In addition, 40 GB is required as a separate Operating System partition.

Deploy Agent Requirements
The following hardware is required for the Deploy Agent:

Component Minimum Requirement

System - Microsoft Windows® 7 (64 Bit)
Microsoft Windows® 10 (64 Bit)

/\ GH 3.1.0 and above do not support 32 bit operating systems any longer.

CPU 2 cores with 2.4 GHz base frequency
RAM 4 GB DDR4-1866
HDD The amount of disk space depends on the amount of data that will be stored, but

should be at least 5 GB for data.

In addition, 40 GB is required as a separate Operating System partition.

Graphic Hub REST Requirements
The following are required for the Graphic Hub REST:
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Component Minimum Requirement

System - Microsoft Windows® 7 (64 Bit)
Microsoft Windows® 10 (64 Bit)

/\ GH 3.1.0 and above do not support 32 bit operating systems any longer.

Browser Browser requirements (minimum and recommended versions):

- Google Chrome™ (recommended): 28, 39+
Mozilla Firefox™: 25, 35+

- Microsoft Internet Explorer™: 9, 10+

- Apple Safari™: 5, 7+

- Opera™: 15, 26+

CPU 2 cores with 2.4 GHz base frequency
RAM 4 GB DDR4-1866
HDD 200 GB of free disk space for data.

In addition, 40 GB is required as a separate Operating System partition.

Graphic Hub ImEx Agent Requirements
The following are required for the Graphic Hub ImEx Agent:

Component Minimum Requirement

System - Microsoft Windows® 7 (64 Bit)
Microsoft Windows® 10 (64 Bit)

/\ GH 3.1.0 and above do not support 32 bit operating systems any longer.

Browser Browser requirements (minimum and recommended versions):

- Google Chrome™ (recommended): 28, 39+
Mozilla Firefox™: 25, 35+
Microsoft Internet Explorer™: 9, 10+

- Apple Safari™: 5, 7+

- Opera™: 15, 26+
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CPU 2 cores with 2.4 GHz base frequency
RAM 4 GB DDR4-1866
HDD 5 GB of free disk space for temporary data on the operating system partition.

Service Dependencies

The different components of the Graphic Hub depend on certain system services. If the services
are not running during installation, a notification appears with information about the required
services. The services are enabled by default on pre-configured systems, but may have been
disabled to comply with your organizations IT policy.

The following table lists the service dependencies for each Graphic Hub component:

Graphic Hub component Service Name Service Display Name

Graphic Hub Terminal LanmanServer
HTTP
RpcSS
Graphic Hub Deploy Agent LanmanServer
RpcSS
Graphic Hub REST LanmanServer
RpcSS
Graphic Hub ImEx Agent LanmanServer
HTTP

RpcSS

Server

HTTP

Remote Procedure Call (RPC)

Server

Remote Procedure Call (RPC)

Server

Remote Procedure Call (RPC)

Server

HTTP

Remote Procedure Call (RPC)

1.2.3 Installing Graphic Hub Applications

This page contains the following topics and procedures:

- To Install a Graphic Hub
Graphic Hub REST Installation
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GH Deploy Agent Installation
Graphic Hub Manager Installation
Graphic Hub ImEx Agent Installation

This section details the installation of the Graphic Hub, including a Cluster configuration, which
installs a Main and a Replication server.

Please be aware that:

Multiuser, Main and Replication modes require a license dongle.

- To setup a cluster configuration capable of handling failover situations, a combination of

Main and Replication servers must be configured.

To Install a Graphic Hub

To install the Graphic Hub with the MSI installer use in the following installation order:

1.

v h WN

Microsoft .NET Framework 4.5.2 (or newer): https://www.microsoft.com/net/download/
framework

vcredist_x64.exe Visual C++ 2015 Redistributable (x64)

openslp_2.0.0_0_x64.msi Service location protocol daemon
VizGraphicHub_64bit.3.1.0.XX.msi

HASPUserSetup.exe Dongle driver (optional, required for GH Multiuser, Main and Replication
modes)

To install the Graphic Hub with the bundle installer (will install 2-5 listed above) use in the
following installation order:

1.

Microsoft .NET Framework 4.5.2 (or newer): https://www.microsoft.com/net/download/
framework

2. VizGraphicHubBundle-x64-3.1.0.XX.exe

&

- The installation wizard reports the version and build number of the bundle about to
be installed. If an existing Graphic Hub installation is located, the installer will report
the version and build number of the existing installation as well.

Note: During upgrade installations, the currently installed mode and data directory will
be suggested automatically by the installer.

Select the mode and data directory for the Graphic Hub installation.
If required, click Additional Settings to install the Graphic Hub to a custom location or
with a custom HTTP port for the Graphic Hub Terminal.

Additional Settings

Install Folder

CA\Program Fileshwizrt\VizGHY,

Termimal HTTP Port
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For first time installations, the OpenSLP, Sentinel Runtime and CodeMeter
Runtime checkboxes will automatically be checked. In the event that any of these
packages have been installed on the system previously, it will not be possible to select
them for installation.

- The installation wizard also automatically installs the Microsoft C++ Redistributable
Package.
After the installation has completed successfully, the Graphic Hub Terminal opens in
the default web browser. The contents of the Graphic Hub Terminal window will
depend on the selected Graphic Hub configuration.

< Graphic Hub Terminal - GHServer

Optional: Silent installation
- The -s or -silent option means that there is no user interaction necessary. The
Bundle window is still displayed.

Cluster Server Installation

To use a Graphic Hub in a Cluster configuration (Main and Replication servers), two separate
servers must be available and a Graphic Hub dongle must be applied to each machine.

The Main server will be installed and configured on one machine. The Replication server will be
installed and configured on the other.

/\ IMPORTANT! When the Graphic Hub is upgraded from a different mode the same content
must be used (data directory). As such, the underlying data directory must be copied first
to both machines (see also Graphic Hub Mode Configurations).
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To Install And Configure A Graphic Hub Cluster

1. Install the Graphic Hub on both servers as described above in To Install a Graphic Hub.
Select Main Server as mode for the server which is intended to run as Main, and Replication
Server for the other one.

2. When the installation finishes, the Graphic Hub Terminal will automatically open on both
servers. Select the servers that will act as GH Main Server and GH Replication Server from the

respective drop-down lists, and click Create.

Main server F.Ep“l:atibﬁ Lenver

GH-REPLICATION

JA Note: If the Graphic Hub has been installed previously, the new installation will
default to the same data directory, unless a new one is selected during
installation or configuration.

3. Enter the configuration for the Main Server:

Data directory®

S
w
&
w
il
L

Step 1/2

Graphic Hub: Enter the Server name and set the Data directory.
Connections settings: Select the Port, Network Adapter and Server Port.
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uration for the replication server, then click Finish.

If required, click Configuration to change any settings.

If required, click Automatically start of partner server to automatically start the
Replication server.

5. Click Start Server for both the Main and Replication servers.

Graphic Hub Cluster Upgrade

/\ IMPORTANT! When upgrading a Graphic Hub cluster, make sure that all connections to the

uTh WN —

o

Graphic Hub are closed by checking active sessions and that there are no open
transactions.

Note: Graphic Hub clients and servers are designed to be inter-operable between versions,
but may lack new features. This means old clients work on older and newer Graphic Hub
versions and there is usually no need to upgrade clients when upgrading the Graphic Hub,
except when certain features are required or critical bugs have been fixed.

. Shut down Deploy Agent or Agents.
. Shut down the Graphic Hub Cluster.

Remove Deploy Agent or Agents.

Install new version of the Deploy Agent or Agents (see GH Deploy Agent Installation).
Install new version of Graphic Hub on the Main and Replication Server (see Graphic Hub
Installations).

Optional: Remove all occurrences of the Graphic Hub Manager. Install new version of the
Graphic Hub Manager (see Graphic Hub Manager Installation).

Start the Graphic Hub Cluster.

Start any Deploy Agents.
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Graphic Hub REST Installation
This section details the installation of the Graphic Hub REST.

The Graphic Hub REST is a web-service for Graphic Hub. It is an interface to retrieve and send data
to and from Graphic Hub via HTTP requests.

Important Before Installation

- Graphic Hub REST requires Graphic Hub 2.3.1 or higher.
- Graphic Hub REST requires Graphic Hub 3.0.0 (recommended 3.0.2) or higher for Pilot data

access (see Viz Pilot Database Management for details).
For performance reasons, do not install Graphic Hub REST on a Main server in a Graphic Hub
cluster environment.

For best performance and compatibility, use Google Chrome version 28 or higher to configure
Graphic Hub REST. The Graphic Hub REST Web-Ul also works with:

Browser Version Requirement (minimum and recommended)
Google Chrome™ (Recommended) 28, 45+

Mozilla Firefox™ 25,41+

Microsoft Internet Explorer™ 9, 10+

Apple Safari™ 56

Opera™ 15, 36+

/\ IMPORTANT! Any other web browser or versions older than the ones listed above are not

officially supported.

To Install the Graphic Hub REST
Follow this installation order to install Graphic Hub REST:

1.

2.
3.

Microsoft .NET Framework 4.5.2 (or newer): https://www.microsoft.com/net/download/
framework
vcredist_x64.exe Visual C++ 2015 Redistributable (x64)
openslp_2.0.0_0_x64.msi Service location protocol daemon
VizGHREST_64bit.2.1.0.XX.msi
- Optional: Check the details for:
- Graphic Hub Naming Service
- Graphic Hub Server Name
- Graphic Hub Port
- Graphic Hub REST HTTP Port
- Optional: Silent installation
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- The -s or -silent option means that there is no user interaction necessary. The
Bundle window is still displayed.
- Optional: Enable the SSL configuration:
- Check the Enable SSL Encryption checkbox.
Enter the location of the Certificate and Private Key files.
Enter the password.

IMPORTANT! The certificate files must be configured during the installation of
GH REST.

- After the installation has completed successfully, the Graphic Hub REST Web-Ul opens
in the default web browser.

Note: Make sure that the browser type and version is supported by Graphic
Hub REST (see Important Before Installation).

GH Deploy Agent Installation

This section details the installation of the Graphic Hub Deploy Agent. The Deploy Agent is required
to run scheduled Deploy Tasks. This is useful to replicate data for safekeeping or distribution on a

regular basis.
To install the Graphic Hub Deploy Agent use in the following installation order:

1. Microsoft .NET Framework 4.5.2 (or newer): https://www.microsoft.com/net/download/

framework
2. vcredist_x64.exe Visual C++ 2015 Redistributable (x64)
3. VizGHDeployAgent_64bit.2.1.0.XX.msi

This will create two Deploy Agent icons in the Start menu, under Programs > Vizrt > Viz Graphic
Hub > Deploy Agent.

The Deploy Agent is now configurable with the Graphic Hub Manager.

Graphic Hub Manager Installation

This section details the installation of the Graphic Hub Manager.

To Install the Graphic Hub Manager
To install the Graphic Hub Manager use in the following installation order:

1. Microsoft .NET Framework 4.5.2 (or newer): https://www.microsoft.com/net/download/
framework

2. vcredist_x64.exe Visual C++ 2015 Redistributable (x64)

3. VizGHManager_64bit.5.1.0.XX.msi

Graphic Hub ImEx Agent Installation

This section details the installation of the Graphic Hub ImEx Agent.
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The Graphic Hub ImEx Agent is a media asset (image) import service from HTTP sources for the
Graphic Hub.

Important Before Installation

Before installing the Graphic Hub ImEx Agent, make sure to familiarize yourself with the Service
Dependencies. Also, observe the following requirements:

Dependencies Required components

Graphic Hub 3.0.1 or newer

GH REST 2.0.1 or newer

Browser Version Requirement (minimum and recommended)
Google Chrome™ (Recommended) 28, 45+

Mozilla Firefox™ 25,41+

Microsoft Internet Explorer™ 9, 10+

Apple Safari™ 5,6

Opera™ 15, 36+

/\ IMPORTANT! Any other web browser or versions older than the ones listed above are not
supported.

To Install the Graphic Hub ImEx Agent
To install the Graphic Hub ImEx Agent use in the following installation order:

1. Microsoft .NET Framework 4.5.2 (or newer): https://www.microsoft.com/net/download/
framework

2. vcredist_x64.exe Visual C++ 2015 Redistributable (x64)

3. VizGHImexAgent_64bit.1.1.0.XX.msi

- Optional: Configure IMEX HTTP port. The default port number is 19396. The port
number can also be changed in the configuration of the Graphic Hub ImEx Agent after
installation.

- When the installation completes, the web-based user interface opens in the default
browser, for initial Graphic Hub ImEx Agent configuration.
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Browser Version Requirement (minimum and
recommended)

Google Chrome™ (Recommended) 28, 45+

Mozilla Firefox™ 25,41+

Microsoft Internet Explorer™ 9, 10+
Apple Safari™ 56

Opera™ 15, 36+

1.2.4 Licensing the Graphic Hub

This section describes how to license Graphic Hub using a Graphic Hub Sentinel license dongle or
WiBu License, which is required for Graphic Hubs running in Multiuser, Main or Replication mode.

For more information on how to apply licenses, check the Vizrt Licensing Guide in the Vizrt
documentation center. For details on how to setup which licensing system will be used by the
Graphic Hub.

This page contains the following topics and procedures:

Using a Graphic Hub Sentinel license dongle on physical machines

Using a Graphic Hub Sentinel license dongle on an ESXi Virtual Machine

Using a Graphic Hub Sentinel license dongle on a Virtual Machine workstation
Using WiBu Licensing of Graphic Hub version 3.1.0 on physical machines or virtual
environments

Using a Graphic Hub Sentinel license dongle on physical machines

1.
2.
3.

Connect the USB dongle to the machine.

Install the Graphic Hub with the dongle driver.

Choose the Sentinel system in GH Terminal Configuration > ADVANCED SETTINGS > License
Settings.

Using a Graphic Hub Sentinel license dongle on an ESXi Virtual Machine

f—

. Connect the USB dongle to the machine where the ESXI is running.

From vSphere client, right click on the virtual machine where Graphic Hub is going to be
installed.

Click on edit settings, in Hardware tab click add, another window will popup, choose USB
controller and click next, click next in the next window and finally click finish in the window
after.

From Hardware tab click add, another window will popup, choose USB device and click next,
the USB dongle will appear in the next window, choose it and click next, then click finish in
the next window.

. Install the Graphic Hub with the dongle driver.
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6. Choose the Sentinel system in GH Terminal Configuration > ADVANCED SETTINGS > License
Settings.

Using a Graphic Hub Sentinel license dongle on a Virtual Machine workstation

1. Connect the USB dongle to the machine where the virtual machine workstation is running.

2. Once the dongle is connected, a window will popup in the VMware workstation window
stating that the connected dongle can be connected to the virtual machine, click OK

3. Install the Graphic Hub with the dongle driver.

4. Choose the Sentinel system in GH Terminal Configuration > ADVANCED SETTINGS > License
Settings.

Using WiBu Licensing of Graphic Hub version 3.1.0 on physical machines or virtual
environments

Graphic Hubs can be licensed with a special WiBu License. The required WiBu Runtime Software
(CodeMeter Runtime 6.60a) comes with the Graphic Hub Bundle installer and is mandatory for the
modes Multiuser, Main and Replication.

If a WiBu License is found and bound it sticks to this license container and can only be changed by
a restart of the Graphic Hub. The same applies for switching to the Sentinel dongle, which also can
only be done by restarting the Graphic Hub.

License expiration messages are logged to the Graphic Hub Journal as usual (alerts, expiration
warning 30 days prior to expiration and if license is expired or invalid). The WiBu license
information (license id, license server, container id) is logged to the Graphic Hub log file upon
status changes and the Graphic Hub WiBu license application ID is 1300000.

1. Setup a WiBu license container as described in the Vizrt Licensing Guide in the Vizrt
documentation center.

2. Install the Graphic Hub with the CodeMeter Runtime.

3. Choose the WIBU system and the appropriate location of the license container in GH
Terminal Configuration > ADVANCED SETTINGS > License Settings.

To verify if the license is applied correctly, please check either the

GH Terminal Graphic Hub license information (reached via About > Graphic Hub License in GH
Terminal):
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< Graphic Hub Terminal - GHDemo

Backup Report Options

About:  Graphic Hub license

GRAPHIC HUE LICENSE DETAILS (GHDEMO) server: | Multiuser (GHDEMO)
Serial Number: 11 00 00 00 00 00 00 00
Key Number. 0
5in 24 days )
Feature expiry dat: 30/ 12:00-00 AM (expires in 24 days.)
Features:

User Manage
Expiry - 11/30/2017, 12-00-00 AM (expires in 24 days )

SET LICENSE

License string

4 11/07 14:49552:108 - Server: Started Graphic Hub (server name: VizDbServer, data directory: C\VizGHData\, pid: 4196)

GH Terminal Graphic Hub log file (reached via Show GH Log in GH Terminal):

< Graphic Hub Terminal - GHDemo

Backup Report Options About

Status:  Server and naming service are up and running.

Server - | GHDEMO

GRAPHIC HUB SERVER LOG Show last completeﬁle

Nov 7.11.2817 14:49:51.264800: Viz Graphic Hub version 3.8.3.71142
Nov 7.11.20817 14:49:51.274800: (Made in Austria)
Nov 7.11.2017 14:49:51.283800:
Nov 7.11.2017 14:49:51.283000: License information:
7
7

Tue Nov 7.11.2817 14:49:51.283000:
Tue Mov 7.11.2817 14:49:51.292008: Multiuser (88@ concurrent sessions)
Tue Nov 7.11.2017 14:49:51.382800: License information:
GraphicHub in VM released on 28171181 is licensed.
License status at 2017-11-87 13:49:5@ GMT
Tue Nov 7.11.2017 14:49:51.311000: License
id = 1166660
server = QAT-THREE.vizrt.internal
container = 3-3695088/2
quantity use = 4
quantity total = 5
license period = [1970-01-81 90:00:00 GMT - 2017-11-30 12:00:88 GMT]
maintenance period = [2017-81-81 12:80:00 GMT - 2808-12-31 12:00:00 GMT]
expires 22 days
Tue Nov 7 .2017 14:49:51.321000:
Tue Nov 7.11.2017 14:49:51.322000: Data location:
Tue Nov 7.11.2817 :49:51.322000:
Tue Nov 7.11.2017 :49:51.381000: C:\VizGHData\
7
7
7

Tue Nov -2017 :49:51.391008:
Tue Nov .2017 :49:51.391000: Max. open files in total:
Tue Nov -2017 :49:51.391808:

C Refresn

= 11/07 14:4952: - Server: Started Graphic Hub (server name: VizDbServer, data directory: C:\VizGHData\, pid: 4196).

GH Manager license information (reached via Info > License info... in GH Manager):
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¥t License info for server 'VizDbServer@GHDEMO' — O >
Server: VizDbServer @GHDEMO(Admin)

License details:

The license info shown below is that of a non server dongle!

Serial Mumber: 11 00 00 00 00 00 00 00

Key Mumber: 0

Product expiry date: 30,11, 2017 (expires in 24 days!)
Feature expiry date: 30.11.2017 (expires in 24 days!)
Features:

|User Management: Expiry date: 30.11.2017 (expires in 24 days!)

License string: |License cannot be set, because the connected dongle is not a server dongle!

)
o
0
[=]

[
m

GH Manager monitor (reached via Tools > Monitor servers... in GH Manager):

Bt Monitor servers — O x
& VizDbServer @GHDEMO
Overview Disk
@ Disk Total: 58,00 GB Total: 8,00 GB
@ Memory Used: 37,59 GB Free: 6,24 GB
@ Llicense Free: 20,41GE Used: 1,75 GB
@ Health Free %: 35,19 % Used % 21,54 %
Limit: 1 000,00 MB
License & Health Activity
Expires: Deadlocks: 1} Calls: 221
In 22 days. Active sessions: 6 Calls/sec: 0,10
File opens: 1} Peak: 0,20
Files: 1} 0 calsfsec: 0,59
: Files in memory: 0 @ peak: 0,60

License changes (e.g. setting a new license key) are not supported for WiBu License. Setting
a new license string does not work in GH Terminal and GH Manager, since these changes
must be performed in the CodeMeter Runtime.

1.3 Overview

The Graphic Hub is a database solution where all Viz Artist elements are stored. Files can be
Scenes, Geometries, Images, Materials, Fonts, and so on.

To start Viz Artist successfully, a Graphic Hub must be running. The Graphic Hub can either be a
local instance, where only one User can log in, or it can be a Multi-User database as described in
Graphic Hub Modes.

This section contains the following topics:

Graphic Hub Applications
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Graphic Hub Modes

- Which Graphic Hub Mode
General Database Information
Graphic Hub Naming Service

1.3.1 Graphic Hub Applications

The Graphic Hub solution consists of these applications:

Graphic Hub

Graphic Hub Terminal
Graphic Hub Manager
Graphic Hub REST

Graphic Hub Deploy Agent
Graphic Hub Naming Service

Graphic Hub

The physical back end server where the database content is stored (see General Database
Information).

The Graphic Hub makes the database available to clients in a network. To log in and work with Viz
Artist, a User must connect to a running Graphic Hub, on a machine in the network. In normal
circumstances a Graphic Hub is started through the Graphic Hub Terminal, and shut down, logged
in to or logged out of, from the Graphic Hub Manager.

Various parameters can be defined in the Graphic Hub Terminal before a Graphic Hub is started,
for example the name and the data directory to where the database should have its root folder.

Graphic Hub Terminal

The Graphic Hub Terminal is the user interface used to configure, start, stop and restart both the
Graphic Hub Naming Service and the Graphic Hub Server.

See Graphic Hub Terminal.

Graphic Hub Manager

The Graphic Hub Manager is used to administer one or more Graphic Hubs. For example, the
server files and access levels for users and groups can be managed from this application.

See Graphic Hub Manager.

Graphic Hub REST

The Graphic Hub REST is a web-service for a Graphic Hub. It is an interface to retrieve and send
data to and from a Graphic Hub through HTTP requests.

See Graphic Hub REST.
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It provides the access to all data on a Graphic Hub. A client is able to retrieve any kind of data like
Scenes, Images, etc., and its metadata like Owner, Creation Date, etc. Also, all metadata, like
Users, Types, Keywords, can be retrieved.

Any skilled web developer and designer can build an application based upon the Graphic Hub
Interface Agent.

For example, if a scene from the Super Bowl contains an image of the quarterback, this image can
be retrieved by an external application, like a blog, by a search on the Graphic Hub Interface
Agent. The blogger is also able to insert this in an article and publish to the web.

Graphic Hub Deploy Agent

Upgrades the Graphic Hub solution with a powerful service to copy directories/projects/files with
all necessary data (referenced directories/projects/files) from one server to another.

See Graphic Hub Deploy Agent.

Graphic Hub Naming Service

The Graphic Hub Naming Service monitors all applied servers in the network.
See Graphic Hub Naming Service.

See Also

Graphic Hub Modes
General Database Information
Graphic Hub Naming Service

1.3.2 Graphic Hub Modes

Graphic Hub Terminal can operate in these modes:

Localhost

5/4 Free
Multiuser

Main Server
Replication Server

Localhost
Localhost is a single connection to a Graphic Hub (no dongle required).

See Localhost, 5/4 Free, and Multiuser Configuration.

5/4 Free

The 5/4 Free configuration provides five concurrent TCP/IP connections to a Graphic Hub (no
dongle required, five TCP/IP connections excluding GH Terminal, GH Manager, GH Deploy Agent
connections).

Copyright © 2018 Vizrt Page 40



Graphic Hub Administrator Guide - 3.2

See Localhost, 5/4 Free, and Multiuser Configuration.

Multiuser

The Multiuser configuration provides multiple concurrent connections to a Graphic Hub (dongle
required).

See Localhost, 5/4 Free, and Multiuser Configuration.

Main Server

The Main Server, as with the Multiuser configuration, provides multiple concurrent connections to
a Graphic Hub. The difference is that the Main Server provides a mirror service to a running a
Replication Server.

In a failover situation, the system automatically redirects all clients from the Main server to a
Replication server (dongle required).

See Cluster Configuration.

Replication Server

The Replication Server is use with the installation of a Main Server. A Replication Server is a
duplication of the Main server.

See Cluster Configuration.

Replications in a Graphic Hub mean that every transaction on the primary server is immediately
mirrored on a Replication Server. In a failover situation, where the main server becomes
unavailable, the system automatically redirects all clients from the Main Server to the Replication
Server.

A failover situation occurs when one of the servers become unavailable due to hardware failure,
software errors, power loss, etc. A Main server crash results in a failover situation, where the Main
server switches to a Replication Server, in real-time.

On the Main server machine, the Graphic Hub Terminal will show Cluster Not Connected, and if the
E-mail functionality is enabled, one or more error E-mails will be sent.

Usually a Graphic Hub in a Cluster configuration runs in real-time replication. In cases of a network
overload, loss of another server in the Cluster, or other serious system instabilities, the Graphic
Hub automatically switches to Recovery Mode. This means that one server will buffer all necessary
transactions, for example, saving files. The Graphic Hub then deploys these files to the other
server in the Cluster when the resources are available again. After 15 seconds of no incoming
transactions, the Graphic Hub switches to real-time replication again, and the data structure is
updated, so that it is reflected on both servers.

If clients were directed to another server than the primary, during the down-time, the clients will
be re-directed to the primary server again.

See Also

Graphic Hub Applications
Which Graphic Hub Mode
General Database Information
Graphic Hub Naming Service
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1.3.3 Which Graphic Hub Mode

When a Graphic Hub is installed a mode must be selected. This section details information on the
different modes, to help with the selection.

Depending on the mode which is to be installed, a Graphic Hub license dongle may be required.

The Graphic Hub can be installed for a Cluster, Multi User or Single User:

Cluster
Multi User
Single User

Cluster

A Cluster installation is an installation with multiple servers for multiple clients to access a Graphic
Hub. To install a Graphic Hub as a Cluster, use the Main Server and Replication Server modes.

Multi User

The 5/4 Free and Multiuser configurations give access to multiple concurrent TCP/IP connections
to a Graphic Hub.

The 5/4 Free provides up to five connections and is recommended for sharing content in small Viz
Artist work-groups. For example, installations on laptops and single workstations. This mode does
not require a license dongle.

The Multiuser provides up to 800 (if required) connections (dongle required) and is recommended
for all scalable Viz Artist work-groups. This mode requires a license dongle.

Single User

A Localhost configuration is a single connection to a Graphic Hub. This mode is for local Viz Artist
installations, without a permanent network connection, and without the requirement of a license
dongle. For example, installations on laptops and single workstations.

See Also

Graphic Hub Terminal
Graphic Hub Applications
Graphic Hub Modes

General Database Information
Graphic Hub Naming Service

1.3.4 General Database Information

Viz Artist uses a database to store Elements that clients work with. The Elements can be of these
types, among others:

Scenes
Geometries
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Materials

- Advanced materials
Images

- Fonts

- Audio files

Note: For more information about the various element types, see the Viz Artist User
Guide.

The individual elements are stored in the Graphic Hub data directory as files.

The database manages the files in terms of properties and Universally Unique Identifiers (UUIDs).
These are visualized in Graphic Hub Manager as folders and projects. These folders and projects
are only virtual, and cannot be treated in the same way as folders in Microsoft Windows.

Clients can work with and organize files through Viz Artist in a logical project and folder structure
provided by the database. Although each file can be listed in/referenced from more than one
folder, it will reside in the database in a single instance. A checksum will be calculated for each
file, so that duplicate files can be easily found (see Locate duplicate files).

This page contains the following topics:

File Properties
File properties
Projects and Folders
Links and References
Folder Links
File References
File Links
Keywords
Data Locking
Session Lock
Check Out

- Access Rights

File Properties

Various properties are associated to each individual file in the database, for example:
File properties

Properties Properties (continued)

NamePathFile typeFile sizeChecksum UUIDRightsKeywordsFile-linksReferences

For more information about the properties, see Working with Files.
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Projects and Folders

The database is able to maintain a logical structure composed of projects and folders. This helps
Viz Artist users to keep an overview of the files they work on. The tree of folders is only virtual, the
files are not actually stored on the hard disk with such a structure. All the folders a file is shown
in, are stored in the properties of the file. The main benefit of this virtual structure is that the file
itself is stored only once in the database, with links to it. The hard disk space is then kept low and
the administration of files is much easier.

Links and References

In the database, files are linked and referenced. Every file knows which folder it is placed in, which
other files it uses, and also by which other files it is used. For example, in a scene, fonts and
images are used. If one of the files that are used in the scene changes, the scene will use the file in
its new state. Every file holds a list of links and references in its properties.

Three types of links and references are handled by the database: folder-links, file-references, and
file-links.

Folder Links

[ T

Every file in the database holds information about the folders it is placed in. These entries are
called folder-links. Each file can hold as many folder-links as necessary. The file is physically stored
in the database only once, but it can be virtually available in various folders. The UUID of the file
will be identical in all folders.

If a file is deleted within a folder, only the folder-link to this folder will be removed. The file will
remain in the database, unless every folder-link is removed. When the last folder-link is removed,
the file will be deleted from the database.

In the Explorer, a file that holds more than one folder-link will be shown as an icon with an arrow.

File References

In everyday use, it is necessary for a file to reference other files. For example, a scene can contain
images. The root file must be linked to all the files it uses. The file-reference feature keeps track of
all other files being used by this file.

File Links

In everyday use, it is also necessary for a file to be referenced by other files. The root file must be
linked to all the files it is used by. The file-links feature keeps track of all other files the file is used
by.

Keywords

To help users organize their work, keywords can be applied to files. Up to 20 keywords can be
applied to each file. Every file holds a list of keywords in its properties.
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/\ Tip: Keywords can be used as a database search criteria.

Data Locking

Three different types of data locking exist within the database: session lock, check out, and access
rights.

Session Lock

As long as the session lock is active, only the user who has locked the file is able to save it in the
database. Other users can only view the file.

A locked file is marked in Viz Artist and Graphic Hub Manager (if the files view type is set to icons)
with a keyhole icon.

A session lock is automatically applied to a file when a user opens it in Viz Artist. The session lock
is removed once the file is closed. A session lock is valid as long as the user who has locked the
file is connected to the server. When the user disconnects, the lock is opened. To end a session
lock, the user who locked it, or the administrator, can manually unlock it.

Check Out

As long as the check out is active, only the user who has checked out the file is able to save it in
the database. Other users can just view the file.

A checked out file is marked in Viz Artist and Graphic Hub Manager (if the files view type is set to
icons) with a stop icon.

Every file in the database can be checked out. The check out of a file is valid until it is checked in
again. Check in can be performed by the user who checked out the file, or the check out can be
canceled by the administrator.

Access Rights

The database is able to maintain rights on files and folders. Individual rights for user, group, and
world can be set either to allow or disallow reading and/or writing rights.

/\ IMPORTANT! Viz Artist 3.3.x cannot handle access rights. It is strongly inadvisable to make
changes in the server that may impact work on the clients.

User: Sets the rights for the owner of a file or folder.
Group: Sets the rights for all the members of the group the owner belongs to.
- World: Sets the rights for all database users.

See Also

User and Group management
Graphic Hub Applications
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Graphic Hub Modes
Graphic Hub Naming Service

1.3.5 Graphic Hub Naming Service

There can be many Graphic Hubs running on the same network. A Graphic Hub Naming Service is
used to monitor and keep track of all servers on the network. The Graphic Hub server cannot run
without a Naming Service.

A Naming Service can be started together with a server, or the Graphic Hub server can connect to a
naming service on the network. When a server configured with this naming server is started, the
remote Naming Service is informed. The Naming Service will then be aware that the Graphic Hub
server is available for client connections.

The Naming Service application is started and shut down from the Graphic Hub Terminal. The port
used for the communication between the Naming Service and the clients can be defined in the
terminal before startup.

When a Graphic Hub server is bound to an already running Naming Service, the server name must
be unique. If a server with the same name is already running, the Graphic Hub will exit with an
error. The exit code and error message will be written to the log file.

/\ Note: Server names are case sensitive.

To avoid having a single point of failure for Main and Replication server configurations, each
instance must have its own separate Naming Service.

/\ IMPORTANT! While the Graphic Hub and/or the Naming Service are running, the server's
network adapter status(es) and IP adress(es) may NOT be changed.

Supported Configurations

Both the Graphic Hub Naming Service and a Graphic Hub can run independently of each other,
even on separate physical machines. The following two configuration scenarios are supported:

Each Server Connected to its own Naming Service
Multiple Servers Connected to one Naming Service

Each Server Connected to its own Naming Service

In this type of configuration, the clients are able to connect to only one server. Such a
configuration is used when working in single-user mode. In single-user mode, the server, Naming
Service, and all other Viz 3 products that connect to the database must be installed on the same
physical machine. As the server is working on the “localhost” in this configuration, other clients
cannot see the Naming Service or server.
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/\ IMPORTANT! Although a localhost can never be accessed from client applications such as
Viz Artist, it is possible to monitor and start/stop localhost servers/naming services by
enabling this in the Graphic Hub Manager.

This type of configuration is typically used when working on a stand-alone computer.

Multiple Servers Connected to one Naming Service

In this type of configuration, the clients are able to connect to all servers managed by the defined
Naming Service. In multi-user mode, the server and Naming Service will be available to all clients in
the network. The Naming Service will use the host name of the computer it runs on as its name. By
default, the name of the server will be Graphic Hub, but this can be modified in Graphic Hub
Terminal before startup (see Graphic Hub Terminal).

See Also

Graphic Hub Applications
Graphic Hub Modes
General Database Information

1.4 Startup And Shutdown

This section details the startup and shutdown procedures for the Graphic Hub, the Graphic Hub
Manager and servers.

This section contains information on the following topics:

Graphic Hub Startup
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- Graphic Hub Shut Down
- Graphic Hub Emergency Shutdown

1.4.1 Graphic Hub Startup

This section details the procedures to start and shutdown the Graphic Hub.

This section details the startup of a configured Graphic Hub database. All Graphic Hub
configurations are started through the Graphic Hub Terminal.

To log in and use a Graphic Hub see Graphic Hub Login and Log Out.

To Start a Graphic Hub

1. Open the Graphic Hub Terminal:
- Click Start > All Programs > Vizrt > Graphic Hub > GH Terminal, or

Double-click the Graphic Hub Terminal desktop icon. The Graphic Hub Terminal opens

in the default web browser.

/\ Note: Each time the Viz GH Terminal desktop icon is double-clicked a new
Graphic Hub Terminal instance is opened.

2. Start a Graphic Hub Server:

a.
b.

. Click Load and run config

The last used server configuration will be available.

Click Start Server.

or

Click Mode.

Select the required Graphic Hub mode (see Graphic Hub Modes and Which Graphic
Hub Mode).

uration > Select configuration.

Localhost
5/4 free
Multiuser Load and run configuration  »  VizDbServ erver: 19396 ic
Cluster —_— GHDem
Create new configuration

Maming service anly

Directory Agent only

/\ Note: From the same menu, select Load Configuration to load and modify a
configuration. Then start that configuration.
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Localhost, 5/4 Free and Multiuser Startup Screen

< Graphic Hub Terminal - GHServer

Cluster Startup Screen

= Graphic Hub Terminal - GH-MAIMN
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1.4.2 Graphic Hub Shut Down

This section details the options for shut down of one or more Graphic Hubs, without the
requirement to log off completely or exit the Graphic Hub Manager.

Shutdown options are:

- A normal shutdown: Through the Graphic Hub Manager.
- A scheduled normal shutdown: A scheduled shutdown can be configured in the Graphic Hub

Terminal or the Graphic Hub Manager.

- A Cluster configuration shutdown: For system maintenance or network configuration work in

a Cluster system, the best type of shutdown operation is to shut down the Cluster, through
the Graphic Hub Manager.
It is also possible to Limit and Shut Down Sessions.

A Graphic Hub is shut down from the Graphic Hub Manager.

/\ Note: In emergency situations, you can shut down the Graphic Hub using the Graphic Hub

Terminal (see Graphic Hub Emergency Shutdown).

A normal shutdown operation takes much longer than an Emergency Shutdown, but is far safer for
data retention.

This page contains the following topics and procedures:

- To do a normal shutdown

- To schedule a server shutdown using Graphic Hub Terminal
- To schedule a server shutdown using Graphic Hub Manager
- To shut down a cluster

Limit and Shut Down Sessions
- To limit the number of sessions
- To disconnect a selected session

To do a normal shutdown

1.

N

(9]

In the Graphic Hub Manager open the Server Shutdown panel:
- Click Server > Shutdown..., or press Ctrl+W or F10.

In the Server drop-down box, select the server to shutdown.
Option: Send a message to all users of the server:

a. In the Message field write a message to all users of this server to inform them that the

server is about to be shut down.

b. Click Send.
Click Shutdown.
Click Yes.
Click Close.
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To schedule a server shutdown using Graphic Hub Terminal

Open Graphic Hub Terminal and go to Options > Scheduled Tasks.
Select the Shutdown task.

Check the Schedule shutdown box.
Select a Mode:

Once.
Recurring.
Recurring forever.
5. Select a Start at and End after date.

A WN—

/\ Note: A shutdown task cannot be started in the past.

If Mode is set to Recurring or Recurring forever, set the interval in Each.
Set a Notification time. Options are:

Do not notify at all.

- Just notify five minutes before shutdown.
Notify 15 minutes before - every five minutes.
Notify 30 minutes before - every 10 minutes (but at least five minutes before).
Notify 60 minutes before - every 15 minutes (but at least five minutes before).
The Info line confirms the next scheduled shutdown time.

N

To schedule a server shutdown using Graphic Hub Manager

1. In the Graphic Hub Manager open the Server Shutdown panel:
Click Server > Shutdown, or
Press Ctrl+W, or
Press F10.
2. Click Schedule...
Shutdown task for server ‘GHMainServer@GH-MAIN' i x|

IREI:urring j

|E.r 7/2016 10:32:00 AM | Endafien: [10/ 1/2016 10:32:00 AM ]|

Each: I 1 Iday (=) j

Motification: INl:uﬁf'y 30 minutes before - every 10 minutes (and 5 min. before) j

Info:  21h, 2im, 34s (Thursday, September 08, 2016 10:32:00 AM)

3. In the Mode drop down box, select one of these options:
Once.

Recurring.
Recurring forever.
4. In the Start at drop down box, click to select a date from the calendar.
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5. If required, adjust the time.

/\ Note: Schedule tasks can not begin the past.

6. If Recurring is selected:
a. In the End after drop down box, click to select a date from the calendar.

b. If required set a time.

7. Select a Notification option. Options are:

Do not notify at all.

- Just notify five minutes before shutdown.

Notify 15 minutes before - every five minutes.

Notify 30 minutes before - every 10 minutes (but at least five minutes before).

Notify 60 minutes before - every 15 minutes (but at least five minutes before).
8. Click OK.

To shut down a cluster

1. In the Graphic Hub Manager, log in to the Main server.
2. Open the Server Shutdown panel:

Click Server > Shutdown, or

Press Ctrl+W, or

Press F10.
3. Click Shutdown Cluster.

Limit and Shut Down Sessions

Active sessions on the server can be limited by the limitation of the number and/or shut down of
individual sessions.

If a Graphic Hub is to be shutdown, clients can be notified (message, email, walk-in, etc.) and then
not allow them to reconnect (no new connections = nobody is removed, but nobody new can come

in).
A limit of one connection can be set, if just a Deploy Agent is to be used.

A disconnect stops a client access immediately.

To limit the number of sessions

1. In the Graphic Hub Manager open the Server Shutdown panel:
Click Server > Shutdown, or
Press Ctrl+W, or

Press F10.
2. Select a server in the Server drop-down box.
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3. Click Modify...
Session limit for server 'GHMainServer@GH-MA

Limit: «System default>

4. Select one of the following options:

System default

User defined (and enter a numerical value)

No new connections

No new connections (except Graphic Hub Deploy)
5. Click OK.

To disconnect a selected session

1. In the Graphic Hub Manager open the Server Shutdown panel:
Click Server > Shutdown, or
Press Ctrl+W, or
Press F10.

Select a session, or sessions, in the Sessions list.

Right-click and select Disconnect selected sessions...

Click Disconnect.

Click Close.

uTh WN

1.4.3 Graphic Hub Emergency Shutdown

A Graphic Hub emergency shutdown will terminate a Graphic Hub almost immediately. If the
Graphic Hub server is a Main server in a Replication environment, the emergency shutdown will
cause a failover to the Replication server.

/\ Warning: Index re-organization and vacuum of tables is skipped when performing an
emergency shutdown. Please perform a normal shutdown through GH Manager to avoid
performance reduction and to free disk space.

Emergency shutdowns can only be executed from the Graphic Hub Terminal, and should be used
sparingly.
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To do an Emergency Shutdown

1. In the Graphic Hub Terminal main window, click Emergency Shutdown.

5/4 Free
Version: 3.0.0

Maming service status: Running
SErver status Running

Data path:

Journal level: Warnings

Emergency Shutdown
Show Configuration

Show GH Log

2. To continue with the emergency shutdown, click Yes.

Emergency Shutdown

ﬂ Are you sure you want to perform an emergency
shutdown?

Mote: An automatic backup after shutdown is configured!

Termnpaorar sable backup after shutdown

Note: If an automatic backup has been configured this warning message will show.
Check the checkbox to disable an automatic backup on this emergency shutdown.

See Also
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Graphic Hub Startup
Graphic Hub Shut Down
Backup and Restore

1.5 Database Management

Important regarding Pilot data back end systems
Because the Deploy Agent does not deploy Pilot data, Failover systems are not supported for
Pilot data.
Backup of Pilot data must be performed manually. See Resolve Pilot Data Differences
Between Graphic Hubs.

This section contains information on the following topics:

Main and Replication servers with failover
User and Group management
- Test a Replication server
Data Errors
Import external images
- Locate duplicate files
- Add Metadata
Replace file references
Direct Deploy Copy
Graphic Hub search
Server information
Daily backup using second Graphic Hub
Detect and solve server differences

1.5.1 Main and Replication servers with failover

Adding failover servers adds another level of redundancy to the Graphic Hub cluster. This is useful
in situations in which the cluster becomes unavailable, for example due to maintenance or
hardware failure. This section describes how to configure a Graphic Hub cluster with an arbitrary
number of failover servers in multiuser mode, and contains the following information:

To configure a cluster with failover servers

Perform a Cluster Server Installation, setting up both the Main and Replication server.
Install the number of Graphic Hubs to act as failover server in Multiuser mode. The failover
server has to be able to handle the number of clients connected to the cluster, in case the
cluster becomes unavailable.

Set up one or more Deploy Agents with real time deployment from the Main server to the
failover server(s).

Create a corresponding amount of real time deploy tasks from the cluster to the failover
servers to keep them in sync. In setups using multiple failover servers, the recommended
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configuration is to deploy from the Main server in the cluster to the first failover server, then

from the first failover server to the second failover server, etc.

In the Deploy Agent Properties, open the Configuration Panel and configure enable

emergency pause of real time tasks in the case of deletion of 1% of all objects or 1 item. This
will prevent the deploy task on the cluster from accidentally deleting content created while

the cluster has been unavailable, in case the cluster becomes available again.

Tip: Shut down the Deploy Agent service on the cluster before restarting the cluster. This
will make sure nothing gets deleted or overwritten when the cluster is brought back up.

Configure the clients, such as Viz Artist or GH REST, to use one or multiple of the failover
multiuser servers. If the cluster becomes available, the clients will only connect to the
failover servers if the client is configured correctly. For details on configuring the client for

failover, refer to the respective product documentation.

Graphic Hub (Main) Graphic Hub (Replication)

GH Deploy Agent
with real-time deploy task

Graphic Hub (Multiuser)
as failover server

Viz Artist/Engine

GH Deploy Agent
with real-tirme deploy task

Graphic Hub (Multiuser)
as failover server 2

To check client connections

1. Log on to the cluster and the failover server(s) with Graphic Hub Manager.
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2. Open the Active sessions window. This will provide an overview of all logged in users and
active sessions, and to which host they are connected.

Resume normal operation after failure of Main or whole cluster

After a failure of the main server, all clients are automatically redirected to the replication server.
When the cluster has returned to real time replication mode, the clients are automatically returned
to the Main server.

After a failure of the cluster, all clients are automatically redirected to the failover server(s).
However, they will not automatically return to the cluster once the cluster has been brought back
online. Before bringing the clients back to the cluster, a manual merge of the data from the
failover server is needed to re-synchronize the cluster. This is required in order to avoid possible
loss of data created by the clients during the cluster downtime period.

Before restarting the Deploy Agent service after the cluster is back up, make sure that the server
differences have been successfully merged, and that all clients are back on the cluster again.

See Also

System Installation
Graphic Hub Terminal
Graphic Hub Manager
Graphic Hub Deploy Agent

1.5.2 User and Group management

From the Administer Users and Administer Groups windows it is possible to manage all the users
and groups in Graphic Hub.

Every user that works with the Graphic Hub, either directly or from a client application, must:

Have their own user profile
Belong to a Group
The User and Group management system monitors who creates files, who owns files, and
who has rights to modify the various files in the Graphic Hub.
The permission settings on group level are the default settings for all assigned users, but it is
possible to change the permission on user level afterwards. It is possible that one specific user has

more or less permissions as the original defined base permission settings of the underlying group
(like a super-user or restricted user).

User and Group permission settings are always related to a folder or file permission setting.

/\ Example: User 1 of Group A has, on User and Group level, ‘no world write rights’ activated.
This means that it is not possible to override or delete a file or folder which is owned by
another User from a different Group.
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/\ Example: User 2 of Group A has, on Group level, 'group write rights' activated but not on
User level (restricted user). This means that User 2 is only permitted to overwrite or delete

their own files in their own folder structure.

Groups
To open the Administer Groups window
Click Tools > Administer Users and Groups > Administer groups.

/\ Note: All Graphic Hub Manager users can view Users and Groups. Only an
administrator can create new Users or Groups, or modify existing ones

Croops N = Y

VizDb5Server@GHSERVER{AdmIN) o MHew... View, Delete...
Server | Mame ~ | active | Access rights {UI@E}J D |
VizDbServer@®GHSERVER Adrninistr ator Yes WO W 1
VizDbServer@GHSERYER Guesk Yes W W 9909

2 groups on senver VizDbServer@ GHSERVER'

To create a new group
1. Open the Administer Groups window.
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2. Select New... or right click and select Create new group... from the context menu.

New group ‘NewGroup® on server "¥izDbS x|

SErvEr: I'-.-'izDI:uSErver@GHSERVER(.ﬁ.dmin} j
1D I [autogenerated]

Ackive: ¥ active group

Marme: I Mewisroup

Arccess rights:
Iser rights: ¥ Read W irite
aroup rights: ¥ Read W irite
World rights: ¥ Read W irite

K I Zancel |

P
3. Select the destination server from the Server drop down box.

& Note: If the group-list is filtered, the server cannot be changed.

4. The new group ID value is automatically generated.
5. Check or uncheck the Active box to make the new group active or inactive.

& Note: If a group is inactive, no members can be added.

6. In the Name box give the new group a unique name.
7. Specify the user account access rights:
User rights: User may overwrite their files and create files.
Group rights: User can overwrite files which belong to the group, of which they are a
member of.
World rights: User may overwrite files which belong to anyone.
8. Click OK.

To edit a group

/\ Note: Only available with administrator privileges and with a single server selected.

1. Open the Administer Groups window.
2. Right click and select Edit selected group... from the context menu.
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Check the Active box to make the new group active, if required. If changed from active to
inactive or inactive to active the modified check box is checked. If the modified check box is
unchecked, the change will be ignored.

/\ Note: You cannot add members to inactive groups.

In the Name box enter a new unique group name, if required. If changes are made in the
text box the modified check box is checked. If the modified check box is unchecked, the
change will be ignored.

. Specify the user account access rights, if required:

User rights: User may overwrite their files and create files.

- Group rights: User can overwrite files which belong to the group, of which they are a
member of.

- World rights: User may overwrite files which belong to anyone.

Click the View member button to see all the group members
Click OK.

To delete one or multiple groups

Administrators can delete groups that do not contain members.

1.
2.

Open the Administer Groups window.
Select the Group or Groups to be delete:
- Select a Group, or hold Ctrl to select multiple groups.
Press Delete.
Click OK.

To view a group

Note: Only available if logged in with no Administration rights or if there are multiple users,
over different servers.

1. Open the Administer Groups window.
2. Click on the group or groups to be viewed.
3. Right click and select View selected group... from the context menu.
4. The Group window opens. No files can be edited.
5. Click the View member button to see all the group members
6. Click Close.
Users

To open the Administer Users window

- Click Tools > Administer Users and Groups > Administer users..., or

Press Ctrl+F9, or
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Press Ctrl+U.
The Users window shows all available users on all active servers.

/\ Note: To narrow the users list first select a Server then select a Group from the Server and
Group drop down boxes.

BTz
Vido ServenS GHIERVER[Adman] "'I all gicupd | MHew. VsEY elete

Sarver [ hck runme [ Full nevme [ rop | sctvn | mccmssrightaquparey | < ]
VDb SaraiDGHIERYER Bdkian Feckriristy otod At Ve W 1
WizDbServer (PGHEERYER Guest Dot it -Lbpar Gusesk Wes W ]

2 wsers on senver VizDbSerrenG GHSERVER"

Create a new user account

1. Open the Administer Users window.
2. Select either:
New...
Right click, and click Create new user... from the context menu,

Press F6 or Insert.

MNew user 'Newlser” on server 'YizDbServerinr x|
SErvEr: I'-.-'izDI:uServer@GHSER'-.-'ER(P.dmin]l j
I0: I [autogensrated]

Active: ¥ activate account

Group: I.ﬁ.dministratnr j
Mickname: I Mewllser

Fullname: I Mew Lser

Passwiord: | TTIIIL]

Re-enter password: I TTITIY

Arccess rights:
Ilser rights: ¥ Read W irite

Group rights: ¥ Read W irite
warld rights: ¥ Read W wrike

Ik I Zancel

4
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Select the destination server from the Server drop down box.

/\ Note: If the user list shows users of one server only, the server will be preset and
cannot be changed.

The new group ID value is automatically generated.

. Check or uncheck the Active box to make the new user account active or inactive.

Note: If the user account is inactive, the user cannot log in or work with the files in
the database.

In the Group box select which group the new user belong too.

/\ Note: If user list is filtered to show only users of a specific group, this group will be
preset and cannot be changed.

In the Nickname box, give the new user a unique nickname.
In the Full name box, enter the new user’s full name.
Enter a user Password. Repeat the password in the Re-enter the password box.

/\ Note: Leave both the Password and Re-enter password boxes empty if no password is
required.

Specify the new user account access rights:
User rights: User may overwrite their files and create files.
Group rights: User can overwrite files which belong to the group, of which they are a
member of.

World rights: User may overwrite files which belong to anyone.
Click OK.

To edit a User account

/\ Note: Only available with administrator privileges.

1.

Open the Administer Users window.
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Select Edit... or right click and select Edit selected user... from the context menu.
@ X

SErvEr: I'u'izDI:uServer@GHSERVER(.ﬁ.dmin} j

ID: | 1697

User 'MewUserl' on server "VizDbServ

Active: I ¥ activate account
GEroup: = |Guest |
Mickname: v I Mewlserl
Fullname: v I Mew Userl
Password: =il | (TTTYY T
Re-enter password: I

fccess rights: W

Iser rights: ¥ Read W irite

aroup rights: ¥ Read [~ irite
World rights: ¥ Read [ irite

Wiz user sethings:  [none] Delete viz user settings.. . |

Ik I Zancel |

4

The user account Server cannot be changed.

The user account ID value cannot be changed.

Check or uncheck the Active box to make the new user account active or inactive, if
required.

Note: If user account is inactive, the user cannot log in or work with the files in the
database.

In the Group box select the group the user account belongs too, if required.

In the Nickname box give the user a new unique nickname, if required.

In the Full name box change the user’s full name, if required.

Enter a new user Password, if required. Repeat the password in the Re-enter the password
box.

/\ Note: Leave both the Password and Re-enter password boxes empty if no password is
required.

Change the user account access rights, if required:
User rights: User may overwrite their files and create files.
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Group rights: User can overwrite files which belong to the group, of which they are a
member of.

- World rights: User may overwrite files which belong to anyone.

11. If required, click the Delete viz user settings button to delete the user account settings
which are, by default, saved together with the user profile.

/\ Note: Delete viz user settings is only available if one user is to be edited. If more
than one user is selected, this button will not show.

12. Click OK.

To Delete a User Account

/\ Note: Only available with administrator privileges.

A Note: The built-in administrator cannot be deleted.

1. Open the Administer Users window.
2. Click the User(s) to be deleted (press Ctrl and click to multi select).

/\ Note: Users on multiple servers cannot be deleted in one step.

3. Select either:
Delete... or
Right-click on the selection and click Delete selected users..., or
Press Del.

4. Click OK.

A User cannot be deleted if they own an object(s) in the Graphic Hub. If a User to be deleted
owns any objects the Choose user... window will open when OK is clicked on. Use this
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window to transfer object ownership to another User.

The user "Guest’ still owns objects (projects folders|files) on
-~ server WizDbServer@EHSERYER'.
_l_\. Before wou can delete "Guest', wou must change the
ownership of those objecks to another user!

Select the user, who will gain ownership of all objects, belonging to
user 'Guest’,

zer:  |Admin j

Mote: an action-log window will open to perform this owner change.

IMPORTAMT: ¥ou need ko execute and close the set-owner action-log
before vou can proceed with deleting the user 'Guest']

(] 4 I Cancel

5. In the Choose user... window select the User to be assigned the object(s), from the drop

down box.
6. Click OK to open the Setting owner... window.

Setting owner... {on server 'VizDbServer@GHSERVER") 1 =1 Dlﬂ

File | ownertoset | Info

eas IMAYEZ Admin Nt yet processed!

wes IMaged Admin Mot vet processed!

1 | =l
I™ Close this window automatically I no problems ocourred rf}\ I Gk v I Cancel I
¥ Reuse this window For same actions -
¥ Do not insert entries that are slready inthe sl [V Warn me about nok inserbed

i2 eniries bo be processed, | | /,:

& IMPORTANT! The Choose user... window puts all objects, of the selected User, in an
Action Log window (Setting owner...), where ownership changes.

7. Click Set owner.
8. Click Close.

/\ IMPORTANT! The owner change must be done before delete can continue. If the User
still owns an object(s), the delete will fail.
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To view a user account

/\ Note: Only available if logged in with no Administration rights or if there are multiple users,
over different servers.

p—

. Open the Administer Users window.

Click on the user or user’s accounts to be viewed.
3. Select either:

- View... or

N

Right click and select View selected user... from the context menu, or
Click on a user account and press F4.
4. The User window opens. No files can be edited.

1.5.3 Test a Replication server

This section details how to check a running replication server, including failover. It is strongly
recommended that the replication server is tested in a production environment.

/\ IMPORTANT! Before a test, make sure that no clients are working on any of the servers in

the Cluster. Also, check that the Graphic Hub solution is a fresh setup of a Replication
Cluster.
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To test a Replication server

1. From a third computer, start the Graphic Hub Manager and log on to both the Main and
Replication server as administrator.

| General [

W Add-Ons B

data

Prapect
-

(7E0AE09-45E7CEE - SC2944BE040 BE0AT

data

- Gues! ~
Tuesday, August 25 2008120113 FM

[#] "Wirite
[#] Wirite
[#] white

| oc |[ cece |

2. Open the properties of the data directory on both machines (right-click the data folder, and
then from the menu that shows, select Properties), and make sure that the UUIDs on both
machines are identical. If they are not identical, shut down the servers.

a. If the data directories on both the Main and Replication servers are empty, delete both
data directories. Use the Graphic Hub Terminal to create new data directories on both
servers, then start the cluster.

b. If the data directory is not empty, delete the data directory on the Replication server
only. Copy the data directory from the Main server to the Replication server. Use the
Graphic Hub Terminal to configure the copied data directory as a new data directory
for the Replication server, then start the server. To use the data directory on the
Replication server as data directory for the cluster, repeat the above steps copying the
data directory from the Replication server to the Main server, and configure the main
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server with the copied data directory.

Monitor servers

(=W GHIMainServer@GH-MATN Dverview of server 'GHMainServer@GH-MAIN' {M
—Owverview — [ Disk
@ Disk Tatal: 53,00 GB
@ Memory Ilsed: 36.03 GB
@ License Free: 21,92 5h
@ Health Free %: 37.79 %
i@ Cluster Lirnit: 9,77 &B
~License ~Health
Expires: Deadlocks: n
In 176 days. Ackive sessions: &
File opens: 1]
Files: n
I—I_ Files in mernary; 1]
Details... Open transactions: 1]

In Graphic Hub Manager, select Tools > Monitor Servers. Check that the Health LED is green.
From the main menu, select View > Messages (Chat).

. Unplug the network cable on the main machine, and then wait for a few seconds.

et
l{'!fﬁj?ﬂlé 11:34:54 A [Vie GH Managér | 'GHManSererBGH-MAIN it down! Rsconnactad bo replcstion server 'GHRaplc stionSarvwsn@aH-REPLICATION |

The Graphic Hub Manager chat panel should show that the main server is down and that the
replication server has automatically taken over.

/l:l?g Servers and fnlders\(:'-q_‘{ SEarch\
= m. 1 - GHMainSeryer@EH-MATMN Admind
e data

The main server name in the Servers and Folders should also be colored red.

Plug the network cable in on the main machine again. To prevent data loss and
configuration corruptions in the cluster environment, the main server should shut down.
Wait for the shutdown to complete, and then start the main server from the Graphic Hub
Terminal.

. If no users have been working with the system while the main server was down, proceed to

the next step. Otherwise, wait a minute or two for the system to refresh.
The Graphic Hub Manager chat panel should now show that the main server is up and
running again, and that the main server has automatically taken over as the primary server

in the cluster.

Messages:
| <S{BIZ016 11:34:54 AM> [Viz 54 Manager]: 'GHManServer GH-MAIN s downi! Reconnected bo reploation sarver ‘SRephcationServerfaH-REPLICATION'| .
| RIS L3554 AP [Viz GH Manapger |: GHManServer JGH-MAIY i e b Reconneched Back from Faplcation server GHIDM stonSerotr @ GH-REFLICATION |

If the steps above have been carried through correctly, the cluster configuration has been
tested sufficiently and is ready to work in a real production environment.
Query the Journal log for replication-related errors.

1.5.4 Data Errors

Like the Check Disk feature in Windows, Graphic Hub Manager allows the database administrator
to search for and repair data errors in the Graphic Hub.
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The Server Check menu is used to scan for errors and inconsistencies in the server’s internal
structure. Various checks are available, and can be set on or 0ff as required. Any errors discovered
during the check are displayed with a description of the errors and how they possibly can be

resolved. Some types of errors must be fixed manually, while others can be fixed automatically.
This is displayed in the list of errors.

After finishing or canceling a server check, results can be exported to a file or copied to the
clipboard from the error list context menu. If the process is paused, it is not be possible to check
the file properties, or to copy or export the results.

/\ Note: Server Check requires Administrator user rights.

To Find Data Errors

1. Open the Check Server window:

In the Servers and Folder panel, right-click the server to be checked and select Check

server <server name>
[ |
Vo Open

Collapse
Expand completely
Collapse completely

Mew 2

Rerianme Chri+f [F2

Search in 'VizDbServer @GHSERVER. .. Ciri+5 [ Ctrl+F [F3

MARrs Haie i r
[ = Brpp s

I':"':'. e e s Ciri=0
I Chedk server "VizDbServer @GHSERVER'... I
& Import from archive. .. Shaft+Ctrl +4

Enable server "VizDbServer @GHSERVER' for Auto login...
Set text color for server "VizDbServer @GHSERVER'. ..

Logout from server VizDbServer @GHSERVER...
) Properties. ..

2. In the left panel, choose the options to check for.

& Note: If this window was open with Server > Check, select the server to be checked
from the Server drop-down box.

Options are:
Check folder links
Check file links
Check references
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Check folders

B b=
Sorven o chack: Fo ot ot |
ik
5 Pk i ity
F hedifdderinis & Chech okder
¥ Check 1 ks I lgrors chackem 11

F edrdewos [ Tyl apen
e i cowwand Pl

I cheach ien v

ﬂ

1 J B

P

3. Click the Check button.
You are advised that checking for data errors can be time consuming and resource heavy,
and should not be done at peak hours.

Server check: Server load and time consumpkion _ =]

3 ! Mote:

Checking the database stresses the server and therefore should
not be performed at crikical times.

Also be aware that the check routine may take a long time
(depending on the database size and the check options wou
selected,)

¥ou may though pause or cancel the server check at any time,

Are wau sure you wank to check this server now?

Yes Mo

4. Click Yes to proceed.
Any errors found are shown in the right panel. Clicking on an error shows more detailed
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information in the bottom panel.

" 1]

:: T —- F Type G Bwnot g Erwomie Rl At o
e o WANEE Plriegty  Chasimnind LT Sckeratdy e L
WL20 caten_chedk I WIIE Menkgte  Cedunid LD Suiprotcdy W W,
Cud [TECT e - ASANE Plnigety  Checmnm 15 BEBS -ln. o
D Ml e W12 b e WEE HANE Fenmply  Oetmams1n LTy 0 wa
res P bk ek AR [ TRIEEIT ST = o MY Fernegrty  Checounm 1D [FNAT] Pl ol e WA,
e Pl b Chaeh Gk Wil HACEEDE b WE HBIE Fenegre  Checdmnid Pl Roivraccaly i [
p— e _mrg e JLMER Parieydy  Cheshmnin 13 (LT ib W
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To Fix Data Errors

1. If you do not require a log of errors that have been fixed, check Automatically remove fixed

entries.
By 1 chech
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2. Click the Fix all! button.
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Note: You also have the option of selecting only certain errors in the right panel,
right-clicking, and fixing only the selected entries or trying to Verify and Restore

files.
K3s_2_all_del SCENE 0.00 KB Fileint
Eiimg_2_del TMARF nNNkKR  Filaint
Fix 1 entry
Verify/restore...
Copy to clipboard
Export to file...
£
File integrity error(s) 6 : Fold Froperties...

3. Any errors that cannot be fixed will remain in the right panel. Click the entry and follow the
instructions in the bottom panel.
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/\ Note: Checksum 11 means that a client failed (disconnected/crashed) during a Save
operation. The Graphic Hub still has the old content and clients can load this old content,
but to indicate that the scene was not saved correctly the checksum is set to 11. To “reset”
this state and clean up temporary data of the failed Save operation, open the affected file in
Viz Artist and save it.

1.5.5 Import external images

External images can be imported from Windows Explorer directly into a connected Graphic Hub
using Graphic Hub Manager.

It is recommended that imported images are of sufficient quality to be worked on in Viz Artist.
However, you do have the option to compress images when they are imported.
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1. Select one or more images in Windows Explorer.
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2. Drag the selected images to a folder or the explore panel.
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3. Select the irlll'-l'r;af“settings:

Import images

Image compression:

¥ Import bilevel matke bype images as RGEA

Select automatically

x|

V¥ Cwerwrite existing images {with same name}

1 ikern ko impork

Irnport. .. I

Cancel

i

Image Compression: Set the default image compression during import. The following

options are available:
None: No compression.

Select automatically: If the source image has an alpha channel, DXT5 will be used. If
the source image does not have an alpha channel, DXT1 will be used.

DXT1: Works best on images without an alpha channel.

DXT5: Works best on images with an alpha channel.

Import bilevel matte type images as RGBA: Applies to monochrome images only. When
set, the luminance of monochrome images is treated as an alpha channel. When
disabled, the alpha channel will be treated as RGBA, while images without alpha
channel will be treated as RGB.
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Overwrite existing images: Check this checkbox to overwrite images with duplicate file
names in the target directory during import. Otherwise, an extension to the file name
will be added to the newly imported images.

4. Click Import. This opens the Import external files window:

Import external files... {on server "VizDbServer@GHSERVER") - Dlﬂ
Path | Hame | Type
oas DELOQOS Wizrt ]
.| | 2
[ Close this window automatically I no problems ocourred - I Import I Cancel I
¥ Reuse this window For same actions
¥ Do not insert entries that are slready inthe sl ¥ Warn me about nok inserbed
1 entry ko be processed. ' | y

5. Set the desired options for the import by checking the appropriate checkboxes, and click
Import to perform the operation.

6. After the import process has finished, the results can be investigated in the main section of
the import window. Any files that failed to import will be marked with a red cross next to the
path. If an image fails to import, verify that it is among the supported image formats for
import.

/\ Tip: Importing images to the Graphic Hub using Viz Artist support a wider range of
file formats.

7. Click Close to close the import window.

Graphic Hub Manager supported image formats for import

The following image formats are supported for direct import using the Graphic Hub Manager and
GH REST upload:

File Type Note

.bmp
.gif
Jpg
.png

.tga No alpha 32
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File Type Note

tiff No CMYK and LAB

1.5.6 Locate duplicate files

When files are copied from one folder to another, such as when creating linked or duplicate files,
the copy will exist as a duplicate of the original file. As long as neither the original file nor the
copy is modified, they will remain duplicates, since the checksum of both objects is the same.

/\ Tip: The files can be renamed, and still remain duplicates.

To locate duplicates in a Graphic Hub

1. Click View > Duplicates, or press Ctrl+N, or Ctrl+F5.
The duplicates window is shown.

Duplicates on server "VizDbServer@GHSER = |EI|5|

—Selected Server

Server: |vizDbServer@GHSERVER(Admin) ]

—Duplicates
= i
Bl 5 Image (2)
E 4 Image4 (01)
MY Images (data/Projectl)
E 4 Image4(1) (0/1)
M Image(1) (datafProjectl)

Fause | Close I

|D|_||:|Iin:ates: 2 ...done! o

The duplicates window lists all the duplicates in the selected server, sorted by the names of
the files. If duplicates carry different names, this will also be shown.
2. Right-click a duplicate for more information about it. This will open a menu with the
following options:
Open Containing Folder in Explorer: Jumps to the folder in the Servers and Folders,
where the selected file is placed.

Properties: Opens the File Properties window, which shows detailed information about
the selected file.
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1.5.7 Add Metadata

Graphic Hub supports keywords and add-ons that work like metadata, to help you to dynamically
organize your files better and enhance search capabilities.

Keywords
Up to 20 keywords can be assigned to any file, to enhance search capabilities.

- Select Tools > Administer Keywords to open the Administer Keywords window.

-l X
[~ Server 1
| veDbserver@GHSERVER (Mdmin) ¥ | [ (et fibes containing the sslected keyword(s) I
Keyweords: Filbers containing the selscted keyword(s):
Keyword Ho. of obj. | Hewi Harms | Type |
New_Eeyword_1 k4 Imagel IMAGE
Mew_Keyword_2 2 Rrenarhe Image2 DMAGE
Refresh
I
Eeywords: 2 =

To view files which use a selected Keyword

Open the Administer Keywords... window.

Click on a keyword(s).

Double click a keyword to view files assigned to it.

All files assigned with the selected keywords show in the right side panel.

A WN —

To create a Keyword
1. Open the Administer Keywords window.
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2. Click the New button. In the left panel, a new keyword is created

3.

Administer keywords on server VieDbServer@GHSERVER' Amﬂ
[~ Server

I VizDhServer PGHSERVER (A dmin) "’! (et Files cortaining the selpcted keasmard!c) I

Files containing the selected keyword(s):
med—l_nbd_l [ mew || [name [Type ]
Mew_Keyword_1
MNew_Keyword_2

E w

Keywords: 2 s
Enter a name for the new keyword, and press Enter.

To delete a Keyword

A keyword can only be deleted if it is not assigned to a file or folder. Look in the No. of Obj. field
to verify how many files or folders the keyword(s) are assigned to.

/\ Note: If multiple keywords are selected, only the keywords with no assigned files or folders

A WN —

will be deleted.

Open the Administer keywords window.

In the left panel, click on the keyword(s) to delete.
Click the Delete button.

Click Yes in the delete confirm window.

To assign a Keyword to a file

1.

Right-click a file in the File panel and select Properties from the context menu.
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2. Click on Keywords in the Properties for <file name> window that opens.

Properties for ‘Tmaged’ on server "izDbServer@GHSERYER" L x|
0] General B Keywords

[ Keywords
i Refersnces and links Mame: Imnaged 5||
[ Boae Type: IMAGE \vizrt
L size
[ Advanced LUID: G2FTAB4E -FCCO-4ACF-4174C7E0IISDCOF [ 1]
Bl History
EH Awvailabiiy II— Show Al
B Add-Ons
Kewmwords: 1 Assignable keywords:
Name ¢ | | Mame - I
Mew_Keyword 2

3. Select/find a keyword(s) to assign to the file:
a. Enter a keyword name in the search box.
b. Click on Search, or Show All to see all available keywords

/\ Tip: Wildcards such as * or ? are allowed in the keywords search string.

4. Click a keyword, in the Assignable keywords panel, to select it.
5. Click the < Add button.

/\ Note: Up to 20 keywords can be assigned to one file.

6. Click OK.

To assign a Keyword with the file context menu

To assign a keyword(s) with the file context menu is better for on-the-fly keyword additions, but
does not show any other data about the keyword(s) which are assigned.

1. Right-click a file in the File panel to open the file context menu and select Add keywords...
2. Search for available keywords by entering the name of a specific keyword, or asterisk (*) to
show all available keywords.

Select the required keyword(s).

Click Add...

Click Add in the Add keywords... window.

Click Close.

ok w
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To remove a Keyword from a file

With this procedure a keyword(s) is first selected then the file(s). The advantage to that method is
greater visibility of information regarding each keyword and where it is used.

1. Open the Administer Keywords... window.
2. Click on a keyword(s) in the list of available keywords.
3. Double click a keyword to view the files assigned to the selected keyword.
- All files assigned with the selected keyword(s) show in the right side panel.

4. Right-click on the file(s) from which the keyword is to be removed.

5. Click Remove keyword(s).

6. Click Remove.... in the Remove keywords from <file name>... window.
7. Click Remove in the Remove keywords... window.

8. Click Close.

To remove a Keyword with the file context menu

To remove a keyword(s) with the file context menu is better for on-the-fly keyword removal, but
does not show any other data about the keyword(s) which are to be deleted.

1. Right-click a file in the File panel to open the file context menu, and select Remove

Keywords...
Remove keywords from 'Imaged’... x|
O Mew_Kewword_z Seleck the
keywords
that should
be removed

Remove...

=

Select the keyword(s) to be removed.

Click Remove....

Click Remove in the Remove keywords... window
Click Close

uTh WN

Add-ons

Add-ons are a solution for creating templates to assign custom metadata to objects in the Graphic
Hub. This provides another dimension for searching, tagging and organizing objects. Add-ons
work similarly to Keywords, but are actually more extensible.

Simple add-on use case and conceptional workflow
Images of people need to be tagged with the first name, last name, gender, and age.

1. Addon template with corresponding fields is created and published. Only published add-ons
can be assigned to files.
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2. The addon is assigned to a file and the values wanted are entered.
3. Afterwards, the search grants the ability to view this information, for example, all files with a
specific addon or gender male assigned are retrieved.

/\ Tip: Add-ons assigned to files are exportable and importable through Archives and are
deployed with Graphic Hub Manager and the Deploy Agent.

A typical add-on assigned on a specific file could look like:
Add-On: Vizrt Meta Data

Title: My Metadata Element 01
Alternative title: Add-on Example 01
Synopsis: Add-on use case
Rights: Rights reserved and held by creator and contributors
Date: 20-02-2018
Language Code: ENGLISH
Media Type: Production Element

Creators: various

Add-ons are administered from the Add-ons window. They are assigned from the Add-ons Panel.
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Add-ons 'VizDb5erver@GHSERVER'

1\wzrt‘1l
1]

Imaged

1 object | O selected

Marme: Imaged

Type:  IMAGE -,\'u‘lzrt\
ULID:  62F7AS4E-FCCO-4ACF-9A174C7E0335DC0F 5

T Text | @ ede | @ o |

Search: I On | Up |

[ Match case [ Match whole word

Each add-on can have several entries. Entries can be numbers, strings, UUID, date and XML (for use
by external applications). Each entry also has a Proposal, which will set out the options for the add-
on in an eventual drop down box. You can also add informational text for a tool tip, which will be
shown when you mouse over the region of its name in the add-ons window.

One use case for add-ons is approval states. You can create an add-on with the parameters of
Draft, Pending, and Approved. If an art director does not want any scene on the design cluster to
be make it to the playout engine, he can use the Import external images functionality to take all
new scenes, assign the add-on, and then only deploy scenes that he has personally approved to
the playout engine.

To create a New Add-on

1. Open the Graphic Hub Manager
2. Open the Administer add-ons window:
Click Tools > Administer add-ons..., or

Copyright © 2018 Vizrt Page 81



Graphic Hub Administrator Guide - 3.2

Press Ctrl+Shift+F8.
3. Open the Create add-on window:

From the Administer add-ons window, click the Create new add-on... button E] , or
right-click in the Add-ons quadrant and select Create new add-on...

|
Mame: ||
GEroup: I{l.nqrouped:‘» j
[T allows transfer via DDC ™ Allow tramsFer via archive export/import
Mame | pata type | Defailt | Mandatory? | Tockin | pactricked? |
Remio
Info;
e Cancel
p

4. In the Name field, enter a name for the add-on.
5. From the Group drop down box, select from:
ungrouped: The new add-on will not be in a group.
- <group name>: Select a group to put the new add-on.
6. Check the Allow transfer via DDC, if required (when checked, the add-on will be transferred
through DDC (Direct Deploy Copy)).
7. Check the Allow transfer via archive export/import, if required (when checked, the add-on
may be transferred via Archives (exported/imported)).

Copyright © 2018 Vizrt Page 82



Graphic Hub Administrator Guide - 3.2

8. Click the Add... button. The Create entry of add-on window is shown.

11.

12.

13.

14.

15.

x
Mame:! ||
Data type: Istring j [ Mandatory
Proposals; Imanual j
Add | |
Hemaoye = |
g I Top I
™ Restrick D, | Bat
Defaulk value: | <none = j
Info:
(84 Cancel
b

In the Name field, enter a name for the add-on entry.

. From the Data Type drop down box, select one of the following options:

Number: Only manual proposals supported.
String: Supports manual proposals and having all registered users as a proposal
option.
Date: No proposals supported, namely selecting a date from a calendar.
UUID: No proposals supported.
XML: No proposals supported.
Check the Mandatory check box for it to be mandatory for this entry to have a value.

Uncheck it for the entry to be optional.
From Proposal drop down box, make sure Manual is selected.

Note: If the Data Type is String, the option of selecting <all users> as the Proposal is
available. In this case, no further Proposal configuration is required.

In the Add field, enter an option that will be available for selection and click the Add button.
Repeat for as many options as you want to have in your proposal.
You can also remove options by clicking the Remove button, as well as changing the order in
which options will appear by clicking the Up, Down, Top and Bottom buttons.
Check the Restrict check box to restrict the proposal entries to what you have added above.
Uncheck it to allow user-defined entries in addition to your proposal options.
From the Default value drop down box, select one of the following options:
<none>: There will be no default value assigned. Not available if the entry is restricted.
<user defined>: The value will be defined when assigning the add-on. Not available if

the entry is restricted.
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- <current user>: The logged-in user will be the default value. The other proposal values
will also be available.

- <current time>: The current date and time will be the default value. Only valid if the
Data Type is Date.
Any of the other proposals you have defined above.

16. In the Info field, enter any text that you wish to appear as a tool tip when mousing over the
add-on once it has been published.

/\ Caution: Any text you enter in this field will be exposed to end users.

17. Click OK.

To create an Add-on group

1. Open the Graphic Hub Manager.
2. Open the Administer add-ons window:

- Click Tools > Administer add-ons...
3. Open the Create add-on group window:

In the Administer add-ons window click the Create new add-on group... button ,
or right-click in the Add-ons quadrant and select Create new add-on group...

Create add-on group x|

Mame: I |

Ik | Cancel |
S

4. In the Name field, enter a name for the add-on group

/\ Note: Make sure that the new Group name is unique.

5. Click the OK button. The new Add-on group will show in the Add-ons quadrant.

/\ Note: Add-ons can be dragged from group to group as required.

To publish an Add-on

/\ IMPORTANT! Add-ons are automatically saved during the creation process and can be
modified as required. But the Add-on cannot be assigned until it has been published. As
long as the Add-on is assigned to any file on the server, it cannot be deleted. If the Add-on
is not (no longer) assigned to any file on the server, it can be deleted.
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. In the Add-ons quadrant of the Add-ons window, right-click the add-on and select Publish
add-on.

You are queried if you are sure you want to publish this add-on.

. If the add-on is ready for use, click Yes.

To filter add-ons by type

In the Add-ons quadrant of the Add-ons window, from the Filter by type drop down box,
select one of the following options:

- All: All add-ons

- User-defined: All add-ons created by any users

- Viz: External metadata created by another Viz application

- System: All Graphic Hub server-delivered add-ons

To filter add-ons by stage

In the Add-ons quadrant of the Add-ons window, from the Filter by stage drop down box,
select one of the following options:
- All: All add-ons
Draft: Unpublished add-ons
Published: Published add-ons
Retired: Add-ons retired from active use (because they can be withdrawn from service
but not deleted from the system).
Imported: Metadata exported to Graphic Hub by other Viz applications.
- Copied: Transferred in a deploy operation.
From archive: Add-ons exported by Viz Engine and re-imported from a Viz Artist
archive to the Graphic Hub.

To sort Add-ons and Add-on groups

1. Click Tools > Administer add-ons... to open the Administer add-ons window.

. In the Add-ons panel, select on an Add-on or an Add-on Group.

3. Drag the Add-on or an Add-on Group to its new location.

To assign an add-on

. Enable the Add-ons Panel.

2. Select one or more files and drag them into the add-ons header.

- To remove a file from the add-ons header, click it and press Delete.
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3. Click the Edit tab.
Add-ons available for assignment are shown.

Add-Ons
I ame; |maged \
Type: IMAGE szrt
D B2F 7A84E -FCCO-44CF-941 74CFE 03350 COF [ 1]
B Text W Edt | |
;l “ungrouped =
;l ¥ status
Current_Skakus: I Approved j i ﬂ
Modified by: I Adriniskrator j i ﬂ
Modified at: | 9 82016 9:12:49 AM |
;l ¥ Information
Person_Mame: I Administrator # ﬂ
[ Lock editing Discard | apply |

4. Click the button to the left of an add-on to expand it.
5. Check the check box beside the add-on to select it.
6. Do one of the following:
Select a value from the proposals drop down box.
Enter a value in the field (allowed only if the add-on is unrestricted).
Click the E button to the right of the add-on to edit the proposals (allowed only if the
add-on is unrestricted).
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Select a date (allowed only if the add-on is for the Date data type).

Add-ons 'VizDb5Server@GHSERVER'

-
B

Image_1 Image_2

Z objects | 2 selected

Marne:

Twpe:
IJUID:

B Tt @ Ede @ |

J <ungrouped =

;I ¥ status
Current_Stakus: I <mixed valugs! = j i ﬂ
Modified bry; I <mixed valugs! = j & ﬂ
Modified at: [T sitzizote tinaite am =]
ﬂ ™ Infarmation

Note: With multiple files selected, where some have add-ons with different
values, the entries that have different values will display <mixed values!>.

7. Click Apply.

To retire an add-on
1. In the Add-ons quadrant of the Add-ons window, right-click the add-on and select Retire add-

on.
You are queried if you are sure you want to publish this add-on.

2. If the add-on is ready for use, click Yes.
The add-on is no longer available for use.

1.5.8 Replace file references

By replacing references it is possible to replace, for example, Images or Fonts referenced by
Scenes or Geometries, with different Images or Fonts. It is only possible to replace an Image with

an Image, or a Font with a Font.
To replace references is practical, for example, when rebranding a corporate identity.
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/\ Caution: Do not replace references at random. Make sure that the replacement files are
compatible in terms of size, scale, color, and other Viz Artist properties used for playout.
Research and test before replacing references.

/\ Caution: Use the replace file references feature with care, as it can potentially be harmful.
For example, if the image to be replaced is in a Scene which is currently on-air.

/\ Warning: There is no UNDO to this procedure. Be very careful, and try this procedure first
on one or two Scenes only.

To replace references

1. In the Graphic Hub Manger, right-click the required file or files and select Replace
References...
The Replace References wizard opens.

Replace references wizard 1 N E[

Wwelcome to the wizard that will guide you through the process of replacing an object in the
abjects you have selected.

— Owverview — Filter

Surmmarization of your selection. Select below the type of object you

Depending on your previous selection, it iz want to replace in the objects dizplayed

pozzible that not all objects are dizplayed here. in the overview on the left;

E.g. objects that may not contain references [as

imagesz] are not dizplayed here. I,-’.'-.LL j

= TOTAL () Specifiv below if on the following page
= SCENE (1) af the wizard you want to only see
Sample_Scene objecs that are referenced by all the

objects dizplaved in the overview an
the left:
™| Commman

¢ Back I M et = I Carnicel

2. Optional: In the Filter panel select which type of object to replace from the drop down box.
Options are:
All
Image
Font
Geometry
Audio
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3. Click Next.
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4. Drag replacement files onto the listed files of the same type.
5. Click Finish. The Action Log for replacing references is shown.
6. Click Replace.

1.5.9 Direct Deploy Copy
The Direct Deploy Copy (DDC) function deploys one or more folders/projects/files:

Multi Server Deploy: Deploys one or more folders/projects/files in exactly the same folder
structure to two or more selected servers.

Server to Server Deploy: Deploys one or more folders/projects/files to another server using
one of three methods:

Rebuild the original structure.

Copy the folders/projects/files to the target folder.

Rebuild the structure under the target folder.

For Multi server deploy, rebuilding the original structure is the only available method.

Direct Deploy Copy (DDC) tasks can also be scheduled and run, as and when required (see Graphic
Hub Deploy Agent).
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Multi server deploy

Multi Server Deploy deploys one or more folders/projects/files in exactly the same folder structure
to two or more selected servers.

To replicate on multiple servers

1. In Graphic Hub Manager, log on to two or more servers.

2. Right-click a folder, project, or file, in the Servers and Folders or Files panel, and
select Deploy.
The Deploy Direct Copy window opens and the analysis process begins.

Deploy Direct Copy - Options for multi-server deploy ] - |I:I|ﬂ

—Servers to deploy ko (check the ones you wish to deploy to)
1d | Name | Type | Free disk space |
[l 2 vizDbServerl@GHSERVERI Standard 104,76 GB
E 3 GHMainServer@GH-MAIN Mair 21.83GE
Top I g | Doy | Bottonm I
~ Preparation progress | info
Infas, warnings & errors |
Retrieving Folder contents from the source server: Finished
“Behavior options
IP‘-el:nuiId ariginal skructure j
¥ Owerwrite existing objects (Does not apply to referanced objects)
I Overwrite existing references
¥ Keep original owner
Mulkti-server processing options
% Deploy all files to the first server, then ko the second, and <0 on
" Deploy one file to all servers, then another file, and 50 on

™ | Buta continue (Deploy will automatically start after preparation step)| Continue.. . Cancel I
£
3. In the list, select the target servers where the folders/projects/files should be deployed.

/\ Tip: The servers can be sorted by clicking the Top, Up, Down, or Bottom buttons.
This will increase/decrease the priority level of a specific server.

4. Enable/disable the following options:
Overwrite existing objects (does not apply to referenced files).
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Overwrite existing references.
Keep original owner.
5. Select one of the following processing options:
Deploy all files to the first target server, then the next server in the queue, and so on.
Deploy one file to all target servers, then the next file in the queue, and so on.

/\ Tip: You can predefine the options in Steps 4 and 5 by clicking Tools > Edit
Preferences > Deploy Direct Copy . Once defined, these preferences will be set
as defaults for every deploy operation you configure. Note, however, that
Rebuild original structure cannot be redefined for Multi server deploy.

6. Click the Continue button.
The Action Log for deploying files is activated.

Deploy Direct Copy... {from "¥izDbServer@GHSERYER') =100
File | Fram | To | CIyE
.os IMage_4 dakajFolder1 WizDbServer L@GEHSE, . ¥
ves IMage_3 dakajFolder1 WizDbServer L@GHSE, . ¥
ees iMA0E_2 datajFolder1 VizDbServer L@GHSE, . Y

. Image_1 data/Folderl WizDbServer Li@mizHSE. . i
ees IMage_4 data/Folderl GHMainServer@aH-M. .. ‘
wes IMage_3 data/Folderl GHMainServer@aH-M, .. 1
ess imange_z dakajFolder1 GHMain3erver@iaH-M, ., "

L Imane_1 dakajFolder1 GHMain3erer@icH-M, .. Y
1] | na

[T Close this window automatically i no problems occurred | Deploy I Cancel |
V¥ Reuse this window for same actions

W Do not insert entries that are already inthe lisl W Warn me about nok inserted

|8 entrigs to be processed, | | 4

7. Click Deploy.
The folders/projects/files will then be deployed.
When the deploy process is finished, check the Action Log for possible errors, and if
necessary, attempt to redeploy any unsuccessful files

Server to server deploy

Server to Server Deploy deploys one or more folders, projects, and files, to another server using
one of three methods:

Rebuild the original structure.
Copy the folders/projects/files to the target folder.
Rebuild the structure under the target folder.

To replicate on one target server

1. In Graphic Hub Manager, log in to two servers.
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2. In the Explorer panel, select source files/folders/files, and then drag them to the target
folder in the required server.

/\ Tip: For single folder or project deployment, the Servers and Folders panel can also
be used.
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Server Wiew Tools Extra Pilok  Info

i & | Address: 1n\data\Folderl -

/U'E‘gSer'uers and folders { L} Search\ EiImage_t
= W) 1 - vizDbServer@GHSERYER Admin) i Image_4
= G data BiImage_3
= @ Projectt Biimage_2
.. SubFolderl
.. SubFolderz
& Projectz
|| Folder1
.. Folderz
= B 2 - WizDbServer I@GHSERYER 1{Admin)

— I:Iata Faolder1 _
= B 3 - GHMainServermaH-MAINAdming
w data

The Deploy Direct Copy window opens and the analysis process begins.
Deploy Direct Copy - Analysis & Options i = I Dlil

H WizDbServer DGHSERVER L :/data
Available disk space on server 104. 76 GE

Selscted objects: q 8.70 MB 8.70 MB
I_?.ufmadohjaﬂs: 0 0.00 K& 0.00 KB
All objects: 4 &. 70 ME &.70 ME

[T)image_4 (IMAGE - 1,96 ME)
B Image_3 (IMAGE - 2.47 ME)
B image_2 (IMAGE - 2.18 ME)
B Image_1 (IMAGE - 2.09 ME)

Infios, warnings & errors |
Infig: Analysis finished without ary warnings or erroes!

Step S - Anahyzing objects on Ehe barget sarver: 4 af 4
- Befhavior oplions
ICup-\" to target Folder only ﬂ

W Crverwrite existing objects (Does not apply bo referenced objects)
¥ Orvervrite existing references
¥ Keep original owner

(o] _coon |

L

3. Select one of these options:
Rebuild Original Structure: Copies an exact replicate of all selected folders/projects/
files and its references from source to destination server.
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Copy to Target Folder Only: Copies all selected folders/projects/files and its
references from the source server to the destination folder on the destination server.
Rebuild structure under target folder: Copies an exact replicate of all selected folders/
projects/files and its references from the source server to the destination folder on

the destination server.
4. Enable/disable these options:
Overwrite existing objects (does not apply to referenced files).
Overwrite existing references.
Keep original owner.

/\ Tip: You can predefine the options in Steps 3 and 4 by clicking Tools > Edit
Preferences > Deploy Direct Copy . Once defined, these preferences will be set

as defaults for every deploy operation you configure.

5. Click the Continue button. The Action Log for deploying files is activated.

Deploy Direct Copy... {from "¥izDbServer@GHSER¥YER") ;lglil
File | From | To I e
ees IMage_4 data/Folderl WizDbServer Li@misHSE., . :
ees IMage_3 data/Folderl WizDbSeryer Li@iaHSE, ., i
eas iMmane_z dakajFolder1 VizDbServer L@GHSE, . Y
e IMage_1 dakajFolder1 WizDbServer L@GHSE, . ¥
ves IMage_4 dakajFolder1 GHMaingerermEH-M, .. ¥
ves IMage_3 dakajFolder1 GHMainZervermicH-M, ., ¥
es iMa0E_2 datajFolder1 GHMainSeryver@iEH-M, ., ¥

. Image_1 data/Folderl GHMainServer@aH-M. .. i
| | A

™ Close this window automatically if no problems occurred | Deplay I el |

¥ Reuse this window for same ackions

¥ Do not inserk entries that are already in the lisl v Warn me about not inserted

|E entries ko be processed., | | o

6. Click Deploy. The folders/projects/files will then be deployed.

7. When the deploy process is finished, check the Action Log for possible errors, and if

necessary, attempt to redeploy any unsuccessful files.

1.5.10 Graphic Hub search

The Graphic Hub Manager’s search functions can search for files, folders, and projects, on one or

more servers.
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Seve Vew Took Exva Plot Info
Agdrers  LOasts Folderl = 0y | Tpes [a - fd G Seandui L
|, Sia | Tupe ¢ Lok s P ec) Colfwc By | L
(¥ Servers and Tolders) ), Searcn e 195 ME  IMAGE HAIE086 113903 Addrrar i
B Eimag=_1 TATME IMAGE 006 LiFHOIFH  Admn o
[rrecten: 2] T Bee: 1ISMD MAGE SIAF0I6 104 BH  Admin of
- 1 ZO9ME IMAGE GPAMIE L0 PH  Adwn o
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hera [Everpwhers icbiects and add-or =]
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There are two primary types of searches available in the Graphic Hub Manager: Free text search
(which includes a Quick search), and Standard search. In addition, it is possible to search for files
in the available databases by universally unique identifiers (UUIDs).

If the search panel is not open, enable it under View > Panels > Search. Search results are shown in
the Results panel and results can be filtered per server, if the search included more than one
server.

Free text search

The free text search searches for files, folders or projects and can include any or all of these
search strings:

File names

Folder names

File owners

File UUID (on Graphic Hub versions 2.3.2 and higher)
File type (geometry, font, images, etc.)

Assigned keywords

Created time

Modified time

Add-ons (metadata)
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1.

Search * 0 X
/U‘E Servers and fnlders}’(x:‘\ Search\
IFreete:{t: vI ek

Freetext:
| Any type

Where: IEverywhere (objects and add-ons) j
p'_::';':---':-' on checked servers only —F
Mame I Type I
VizDbServer @GHSERVER Standard
D GHMainServer @GH-MAIM Main

< I

[~ Searchin spedified folder

I Search by advanced properties
L

I~ Search by selected kevivords

I~ Search b referenced referencing files
L

™ Searchin add-ons (metadata)

1l e e e (2

Graphic Hub Administrator Guide - 3.2

In the Search panel, select Freetext in the Name / Freetext drop-down list:

2. Enter the search parameters in the Freetext field. To achieve the best search results, refer to

the Search string syntax.

3. The Type drop-down list is used to narrow the search to a specified set of file types only.
The type field can be used to include or exclude one or more of the following types:

- Any type- the default mode, all elements are included.

- AUDIO_CLIP
BASE_FONT
- FONT
- GEOM
IMAGE
MATERIAL
- MATERIAL_ADVANCED
- SCENE
- SHARED_MEMORY_MAP
- SUBSTANCE
- VIDEO_CLIP

Right clicking the type will exclude it from the search, identified by a dimmed check
mark. For example, here the BASE_FONT type is explicitly excluded, while the FONT
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type is included in the search:

; IBASE_FONT, FONT [~
Where: I~ any type

[T auDIo_CLIP

IV Search ond [7 gase_FouT

[arne

VizDbse] I SEOM
o [T mMacE

[T MATERIAL

[ MATERIAL_ADVAMCED

[T scEME

[T SHARED_MEMORY _MAP

| [~ SUBSTANCE

[T vIDEO CLIP

I|_ Search in specified Folder +

[ Search by advanced properties il
L

I Search by selected keviwords il

. Select where to search in the Where drop-down list:
Everywhere (objects and Add-ons)
In objects (files and folders only)
In add-ons (metadata only)
. If the GH Manager is logged on to more than one server, the Search on checked servers only
box can be used to specify which server(s) the search will be performed on. If checked, at
least one server needs to be selected for the search to run.
. If the GH Manager is logged on to only one server, or if multiple servers are logged on to
and only one is selected in Search on checked servers only, the folder which is to be
searched can be specified as required:

a. Check the Search in specified folder check box.

b. Select the folder to be searched.

¢. Check the Search in Sub-folders check box to run a recursive search.
. To search by last modified date or date of creation, check the Search by advanced properties
check box. The search by date approach can be narrowed further by specifying from date,
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until date, and between dates:

I¥ Search by advanced properties —l_
Size f(in KE): |a.-..r- zize = 0
Created: between jl g/ 72016

EII'I'!.I'tiITIE I gllu' ?,I'IED 16
from
Modified:  |unti [/ 712016
Esepiration: [/ 72016

[Cilse aroups inst, of users

Coamed by |en'-r'l:|ne

MModified by Ian'fu:une

Checked out by Ian-r'l:une

Search by access-riahts

[T Search by seleched keywards

[T Search by referencedreferencing files
L

e e el i i

™ Searchin add-ons (metadata)

8. Press Enter or click on the search icon “* to run the search.

/\ Note: Click on the icon to expand or collapse the search criteria selection for each
category.

Search using all available search criteria can only be performed on one server at a time.

Quick search

The Quick Search function gives a quick means to search for a file, folder or project.

To view the Quick search bar

1. In the main tool bar click on View > Toolbars > Quick search .
2. Click on Quick search to open or close the Quick search toolbar.

To use the Quick search function

1. In the Quick search tool bar click in the Servers drop down list and select the server or all
servers to be searched.
2. In the text field enter the search string.

3. Press Enter or click on the search icon “* .
Search in: IAII Servers j = LLe

Deploy search results

The Freetext search results can be used to create a deploy task. This can be useful for creating
deploy tasks for daily additions or modifications, for example.
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f—

. Perform a Free text search.

2. In the search results, select the result that matches the requirements for the deploy task and
press Ctrl+D, or right click and select Deploy.

3. Proceed to Create a New File Based Deploy Task.

Standard search

The Standard search searches for files with more detailed search options. Search by one or a
combination of different search criteria.

To search with Standard search

1. In the Search panel, select Name in the Name / Freetext field.

Search 0 X

/G‘El; Servers and folders}”xl Search\

IFreete:d:: 'I
Freetext:

e Ll

-y

[ any type =]
Where: IEverywherE (objects and add-ons) j
2. In the Name field enter name search parameters, if required.
3. From the Type drop down box, select the file type to be searched for.

4. Click on the check boxes to add search criteria as required.

/\ Note: If more than one server is open or selected, only the Advanced Properties
criteria is available.

To search by specified folder

To search by Advanced Properties
To search by selected keywords
To search by references

5. Press Enter or click on the search icon = .

& Note: To open or hide search criteria, click on the icon to the right of each search
Criteria.

If Search on checked servers only is checked, at least one server must be selected.

To Search By Specified Folder

Check the Search in specified folder check box.
Select a folder to search in.

If required, check the Search in subfolders check box.
If required, add more search criteria.

Press Enter or click on the search icon “* to search.

v hWN —
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To Search By Advanced Properties

1.
2.

3.
4.

Check the Search by Advanced Properties check box.
Enter search parameters as required:

- Size: Searches for files that are either at least, at most, or between the defined size(s)
in KB.

- Created: Searches for files created either after, before, or between the defined date(s).
Modified: Searches for files modified either after, before, or between the defined
date(s).

Expiration: Search for files expired either after, before, or between the defined date(s).

Use group instead of users: If selected, the next four options will apply to groups
instead of users.

/\ Note: Only registered users/groups will be available from the lists.

- Owned by: Searches for files owned by user.
Modified by: Searches for files that was last modified by the defined user.
- Checked out by: Searches for files checked out by the defined user.
- Search by access rights: If selected, searches for files that have write permission either
on user (UW), group (GW), or world (WW) level.
If required, add more search criteria.

Press Enter or click on the search icon % to search.

To Search By Selected Keywords

1.
2.

Check the Search by selected keywords check box.
In the upper field enter the first characters of the keyword, or enter *** to list all available
keywords.

3. Alist of available keywords that match the characters will then show in the keywords list.
4,
5. Check or uncheck the All checkbox:

Select one or more keywords that match the search criteria.

- Checked: Search for Scenes or Geometries which contain all search files.
Not checked: Search for Scenes and Geometries which contain at least one of the
search files.

If required, add more search criteria.
Press Enter or click on the magnifying glass to search.
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To Search By References

1. Check the Search by Referenced/Referencing Files check box.
¥ TSEATLIT Ly TEl BT ILE0 Tl BTENLg | e :'-
Info |
Drag files From Explorer-Details ar from
Search-Result and drop them here!

Iv &l ¥ Referenced Remove all I

2. Drag and drop a file or files into the drop area.

[ wzonmansger =2 x|
Server View Tooks Edra Pt Info
P | Address:  1AdstaProjectl » 0§ Type [an © Sean Layo
| | Marne I sue [Type ¢ | Date modime
05 Servers and folders | L), Search :deﬂ? it
[uame =] TMAGE ATI0E T3
] TMAGE SR04 12
Tvpe: {2y tyoe IMAGE 372006
MAGE SIT/2006 4:0n
| e
[ VebhSarverdGHEERVER
[ aresniservengsH-Mam
L1 [—|
™ Sanrch in spcifind foder
I Search by advanced properties
I Search by selected kenywords
LCi
frmagal
= 4] | Ll |
7 abjects (2 dalders, 5 files) |11 abject selected | ]

3. Make sure that the Reference check box is checked.
4. Check or uncheck the All check box:

Checked: Search for Scenes or Geometries which contain all search files.

Not checked: Search for Scenes and Geometries which contain at least one of the
search files.
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5. If required, add more search criteria.
6. Press Enter or click on the search icon ~* to search.

/\ Tip: Use Search by References to search and replace Images or Fonts referenced by
several Scenes or Geometries, with different Images or Fonts. For example, if a
company logo changes, search for the image references, select each required Scene
and replace the image (see Replace file references).

Search by UUID

The Graphic Hub keeps track of all items in the database by assigning Universally Unique
Identifiers (UUIDs). This also applies to deployed items, which means that if an item is deployed
from one server to another, it will have the same UUID on both servers. When the UUID of an item
is known, it can be looked up very quickly using the Search UUID on server.

To search by UUID on server

1. Open Graphic Hub Manager, and log on to the server(s) that is to be searched.

2. From the Tools menu, select Search by UUID.... This opens the Search by UUID on server
window.

-ﬁI— Search by UUID on server ‘Main@TUTORIAL >

Server

Main @TLUTORIAL{Admin) Cancel

Enter the UUID of an item in the following format

where each ¥ must be '0-9' or 'AF" (or 'a-):

| Properties...

3. If you have logged on to more than one server, select the server to perform the search on in
the Server drop-down list.

4. Enter the UUID in the editable text field. This text field accepts valid alphanumeric
characters only. Valid input are digits in the range 0-9, and letters in the range A-F. The
search is not case sensitive, and dashes are added automatically:

-IEI- Search by UUID on server ‘Main@TUTORIAL >

Server

Main @TLUTORIAL{Admin) Cancel

Enter the UUID of an item in the following format

where each ¥ must be '0-2' or 'AF" (or 'a-):
8201af30-8d10-4639-8437-3e7412c3f320

5. Click Properties... to perform the search.
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If an item with the provided UUID is found, its Properties page opens.
If no item on the database matches the provided UUID, you will be alerted by a popup
window.

Search string syntax

Free text search string syntax is very similar to the search string syntax of other comparable web
search engines.

Example 1: zebra scene -project -folder

In example 1, the search will be conducted on any file names, file owners, UUIDs, file types, and
keywords that include the string zebra and scene. This search excludes projects and folders, plus
any of the other searched files that include the words project and folder.

Example 2: giraffe -image -geometry

In example 2, the search will be conducted on any file names, file owners, UUIDs, file types and
keywords that include the string giraffe. This search excludes images and geometries, plus any of
the other searched files that include the words image and geometry.

Wildcard text description
If the full Name is not known then text Wildcards can be used to make a search:

x: Match any characters. For example: Element
?: Match any single character. For example: E1?me?t
[ 1: Match a range or a list of characters. For example:
Elem[b-glnt
Elem[shje]lnt
< > or {{{ }}}: Match a specific project, folder or file:
Searching for a specific UUID, for example <6E6D3467-0A37-4D35-B80683B3A929772D> Or
{6E6D3467-0A37-4D35-B80683B3A929772D}, will return the specific UUID.
Searching for a partial UUID, for example <6E6D, will also include the underlying UUID.

Best practices for searches

The Graphic Hub Manager search capabilities are powerful enough to replace the need to browse
for files in the server tree. This is meant to make your Graphic Hub work faster and easier.

Example 1: If a Scene has been created on the design cluster, and saved as soccer, search for
scene soccer. From the search results, drag the scene to deploy it to a Graphic Hub for the Viz
Engine.

Example 2: Use the search feature to clean up a server. If the tree structure is complex, it can be
cumbersome to find all the correct scenes. In this case, create a new and elegant tree structure
and then find all the scenes in the old tree structure with a search by date and size. In this way,
the new structure can be populated with relevant objects, in a logical order, and files that are too
old or too large, etc., can be removed.
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1.5.11 Server information

This page details the different methods to monitor a sever and its details.

Terminals monitor
Active sessions
Monitor servers
Server properties
Chat with Artists
Object types

Terminals monitor

The Terminals monitor window provides an interface to view all on line terminals within the
network. A terminal is the physical machine where the Graphic Hub Terminal application is
running.

_loi

Auvailable ¥iz GH Terminals {servers and naming services): [~ Show single-user servers on okther computers

| Terminal _+ [ Serverinfo | Mamingservice info_| Connection | server [ 5. b
LVAUTCA-552... MizDbServen@... 10.211.1.222:1... Connected! VizDbServer 10.2
GMWI-HF... VizDbServer@,., M3IB0OVI-VFIOS... Connected! VizDbServer Mg
U QAT-TWO VizDbServer@... QAT-TWO:19396  Connected! VizDbServer QAT
l.:}'u'IDEO'I.-'I.-'P.LL VizDbServer@.., VIDECWALL:1959% Connected! VizDbServer YIDE
4] | i3

11 Wiz GH Terminals (Found by using UDP-port 19394 with a broadcast recefve timeout of 0.50 seconds)

Refresh | Login... | SEartien'erl Start namings. A:Ivancadnpthws...l Close I
4

To open the Terminals window

Click Server > Terminals.
The following columns are available:

Terminal: Shows the hostname of the physical machine where the Naming Service and/or
server are installed. An icon represents the status of the server and Naming Service:

4 Both the Naming Service and server are down.

L The Naming Service is running, but the server is down.

= The Naming Service is down, but the server is running.

Both the Naming Service and server are running.

Server info: Shows <Graphic Hub Server>@<Graphic Hub Naming Service>:<port the naming
service is listening to>. A plus sign is added if you are logged on to the displayed server.
Naming Service info: Shows <Graphic Hub Naming Service>:<port the naming service is
listening to>.
Connection: Shows if Graphic Hub Manager has a valid connection to the Graphic Hub
Terminal.
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Server: Shows the name of the server.

S. host: Shows the hostname of the physical machine where the server is installed.

S. port: Shows the port number the server communicates through.

S. up: Shows if the server is running. This is also indicated by the icon in the Terminal
column.

S. in: Shows if you are logged into this server.

Naming Service: Shows the name of the Naming Service.

Ns. port: Shows the port number the Naming Service communicates through.

Ns. up: Shows if the Naming Service is running. This is also indicated by the icon in the
Terminal column.

- T. TCP-port: Shows the TCP port number, which can be used to start the server remotely
from Graphic Hub Manager.

- Terminal host network IP: Shows the IP address of the Terminal machine.

The following additional options are available:

Show single user servers on other computers: If selected, also shows servers/naming
services in the network that are running in single-user mode (localhost).
- Advanced options: Open the Terminals Advanced Options window. Alternatively, press

Alt+A.
UDP-Port: Set the UDP port where Graphic Hub Manager searches for Terminals
(default: 19394).

3.2

/\ Note: The terminals window can only be used with pre-web-based Graphic Hub

Terminal (version 2.4.2 or older). The UDP port must be the same as the port
that the Graphic Hub Terminal listens to. To check the port number, go to the
Graphic Hub Terminal and check in Naming Service, which UDP port is set.

- Timeout: Define how long the Graphic Hub Manager should listen for Terminals before

timing out. The value is set in milliseconds.
LUDP port (for finding available Viz GH Terminals): 19394 Set Default

Timeout (in miliseconds): 500

[ QK ] | Cancel

Refresh: Updates the list. Alternatively, press Alt+R.

Login: To log in to a server, select the required server from the list, and then click the Login

button. Alternatively, press Alt+L. This will open the Login window.

Note: It is not possible to log into a Graphic Hub installation by remote in single-user

mode (localhost) from other physical machines.

Start server: If the server on a listed Terminal is not running, it is possible to start the server

from this window. To do so, select the required server from the list, and click the Start
Server button. Alternatively, press Alt+S.
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Start Naming Service: If the Naming Service on a listed Terminal is not running, it is possible
to start the Naming Service from this window. To do so, select the required server from the
list, and click the Start Naming Service button. Alternatively, press Alt+N.

Active sessions

From the Active Sessions window it is possible to monitor all logged in users and active sessions.
When faced with network or connection problems, checking active sessions can provide important
clues. Likewise, performance problems in general are easy to spot in the Active Sessions window,
since you can see hosts and servers. In sum, for a good clue as to where to find connection,
network and performance problems, look in the Active Sessions window.

Aitie sessin o served VieDbServerSGHSIRVIR' 2101 x|
Server] eDberop DEHEERVER [Adma | Runming since: 4h, &m, s Refresh nerva: J
Sumrned st 0820 36 104105 AM Dmer. {i:]
Seppang! i
Lier | Fent marme | phenton {41 | Loggedinmrce._. ¢ | Laat sctry befors | ho. of cpen Ses | o, oflecied £ | Lagn sme Ju
A PERVIR Vo G heduier h, b, s , e, M a 0 MR ETT AM (SR8 6] I
Al GHEERVER Wi G4 Termiral #h, b, Mg 5 a 0 L0417 AM (5E015) z
Ader GHEERVER Wiz CH Termral Fus. . o, b, M4 1] a 0 LA =3T AM RS 15) 2
admn - Wi 5+ Manager 3, ¥, 1 s, 18 a 0 1E:aicaT AM E0E) z
Aprrani AN W 3 Msnager W, &, P, s its Q 0 VAT AM z
] i AT Wi GH Manager v 2, e, iba I, e, 1B L] 0 LT AN {SE005] !
Admn . GHEA Wiz GH Manager wer ... th, fim, 35 M, Tid [ 0 L0 Pea (/0 08 1
i x|
Fermon imb W00 connectong (Syviem defmil]. Hodfy,,,
e et (o= ]
¥ BN PTG

To open the Active Sessions window

Click View > Active Sessions.
The following options are available:

Server: If logged in to more than one server, select which server to monitor from the Server

list.

Running since: Shows how long the selected server has been running, counting upwards in
hours, minutes, and seconds.

/\ Tip: The time relates to the system time on the server machine.

Started at: Shows the time and date when the server was started.
Refresh interval: Defines the interval for when information should be refreshed. It can be set
to a value between one and ten seconds.
Message: To send a message to all clients that are logged in to the selected server, type a
text in the Message box, and then click the Send button.
The Sessions list shows detailed information about the sessions that are active on the
selected server. The following columns are available in the Sessions list:

User: Shows the name of the user that activated the session.

Host: Shows the host name of the machine that the session was started from.
Application: Describes the application and operation that the session belongs to.

Logged in since: Shows how long the user has been logged in to the server, counting
upwards in hours, minutes, and seconds.
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Last activity before: Shows the last time an operation was performed in the session.

No. of open files: Shows the number of files that are open in the system.

No. of locked files: Shows the number of files that are session locked.

Login time: Shows the time and date when the user logged in to the server.

Last activity: Shows the time and date of the last time an operation was performed in the
session.

Priority: Set the priority of the sessions for the correct load balancing.

Session rights: Shows the access (read/write) rights for the session.

Notifications: Description used by the clients, for example to inform that files have been
created.

Monitor servers

From the Monitor servers window it is possible to view and analyze all servers that are currently
logged in to.

To open the Monitor servers window

Click Tools > Monitor Servers.
The left part of the Monitor Servers window lists all available servers.

[ mommerseven =101 x|
8 GHeplcstoniermr BOH-REFLICATION | B T - =l
§ ieDbiServenfaHIENER Zrens L pener A — "=
QT LR P TR YT ) Crenavien (- Mesmary

& ek - Toitah TR0 GE Total &00GH
& Memary F Lhed:  IEATGE Free .7 GH
& Lo | Froe: 25348 Lkl 2GR
& Healih " Free % MW e % 2T %
& Ohuster Lissak: IR
Licgros @ Ml Hutpeiy
Akeady Deadocks: ] s 41,840
ergwed Bt SeiONG: 12 ol 180
File opersl ] Paak 4.0
Fles: @ @ calptie 345
m il iy o [:] 0 paah: EE -
- O transactions: L] EI

The right part of the window shows details about one or more selected servers. If all the available
servers are working within the required parameters, this overview is hidden. If one or more servers
are in warning state, the overview for these servers will open automatically.

To view server details

Double-click the server in the Overview panel, or
Alternatively, right-click the server, and select Open Overview
Select Open All Overviews to show details of all available servers.

Overview

The Overview frame shows a quick overview of all the parameters. A green light next to the
parameter indicates that all systems are normal. A yellow light indicates that there are non-critical
problems. A red light indicates that system limitations have been reached or there are serious
errors.
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—Overview
Disk,
Memoary
License
Health
Clusker

]

The overview shows this basic information for the following parameters:

License
Disk
Memory
Health
Cluster
Activity

License

The License frame shows the status of the Graphic Hub license.

License
Expires:
In 176 days,

The status shows license limitations or remaining number of days until the license expires. If your
license expires, you will receive instant chat messages with increasing frequency to that effect.

Disk

The Disk frame shows the status of the currently used partition where the data directory is located
on the hard disk of the physical machine.

— Disk,
Tokal; 58.00 GB
sed: 36,17 GE
Free: 21,83 GB
Free %% 37,63 %
Lirnik: Q.77 5B

The status shows total, used, and free disk space, and also the warning limit. If the free disk space
reaches this limit, you will receive an Alerts to this effect. The warning will also be logged in the
Journal Panel.

The warning limit is defined in the Preferences window.
Memory

The Memory frame shows an overview of the physical memory of the server both in numeric values
and over time.
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— Mermnory
100 3 Tokal: 8.00 GE
Free: 6,82 GB
I=ed: 1.18 GE
=ed %a: 14.77 %

Health
The Health frame shows various Graphic Hub status parameters.
—Health

Deadlocks: 1]

Ackive sessions: 10

File opens: 262

Files: 42

Files in memaory: 0

Deadlocks: Shows the number of deadlocks in the system. Any deadlocks will necessitate the
restarting of Graphic Hub.
Active sessions: Shows the number of current sessions.
File opens: Shows the total number of opened files.
Files: Shows the total number of files stored in the system.
Files in memory: Shows the number of currently open files. If it remains greater than 1 for an
extended period of time, this may indicate locked files. In such cases, refer to the following
procedures:

Restoring Corrupted Files

Graphic Hub Manager and Viz Artist Troubleshooting
Open transactions: These are transactions that need to be deployed to the other server in
the replication environment. If the number is too high, stop working until it is back to zero.

Cluster

If you are logged into both main and replication servers, you are presented with a Monitor Servers
screen that reflects this.
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=101 x|
Creprview [k
& Dk . Todal ER00G8 Tosl SO0 G
@ Memery & Lk EATE Frie: LHGE
B Lerda I Froe: 225308 Lkt 22168
& Health % Free%h: M5 % L] % 2B
& Chster Lt LTY R
Liogros @ ity
Aheady Drepebonchs: l: Cally 41,481
Bt i 12 Cilbiie: 380
Fil Dpee] i Paah e
Fili [ & cobifie 345
il iy ey -] 0 paak: EE -
e bt | -]
|Dvervie o server T 5
Cretrvice [k
@ Dk . Tital: 00008 Tital: [0 vl ]
& Meomory Fa Lk M. 470 Froe LA Fd- ]
& Lowse L Free 183 Lied i B Gh
@ Heath : Fren%h: TE3% L] o FaL LY
& Chater Lok wITan
LEsfria Hsalts:
Fopart Eonmchocks: @ Cally #0541
B 17 ey, Bactive O k. Cal 1.5
Fille Sper: -] Paah: 350
Filos: -] @ callyfins 145
Filles: i oy ] O paah 145
O trangactio v

Title bar: Each server’s title bar shows its current status.
Cluster: Shows if the cluster is connected and healthy.
Open transactions: These are transactions that need to be deployed to the other server in
the replication environment. If the number is too high, stop working until it is back to zero.

Activity

The Activity frame shows an overview of the server activity both in numeric values and over time.

— Ackivity

Zalls:
Calls/sec:
Peak:

@ callsfsec:
7 peak:

41,692

.40
3.90
3.45
3.45

Calls: Shows the total number of calls made by any application to the Graphic Hub Server.

Calls/sec: Shows the average number of calls per second.

Peak: Shows the highest amount of calls during one second.
calls/sec: Shows the average number of calls during one second for the total run time of

the server.

peak: Shows the highest amount of calls during one second for the total run time of the

server.

Server details

This window shows information about the folders and files stored in the Graphic Hub and loaded

into the memory.
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To view server details

In the Monitor servers window, click the Details button.

ICAT]
Mavnry
Tatal B00GR
Froe: ETHGR
(E220 22
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Fles @ calie 145
Fhei iy @ peah: 45
B | | ogentransactions: 5

From the Refresh Rate drop down box it is possible to set the interval of when the

information should be updated.
Selecting the Show Functions check box will show additional information used for debugging
purposes.

/\ Note: Only users with administrator rights can access this window.

Copyright © 2018 Vizrt Page 111



Graphic Hub Administrator Guide - 3.2

Monitor details of server "VizDbSe =10l x|
—Preferences
Refresh rate: |60 seconds j Shows Functions [
—Toatal
Projects: 5 Folders: 4
Files: 42 Size: 18.97 MB
Twpe £ | Counk | Size |
lﬂ.ﬁ.LIDID_CLIF' ] 0.00 KB
EEF\SE_FC'NT 7 403.00 KB
B FONT 7 1.27 ME
e cEom 0 0.00KB
ﬁIM.ﬁ.GE 27 16.53 MB
I:]M.QTERIF'.L ] 0.00 kB
EIMF'.TERIF'.L_F'.D'-.-'ANCED ] 0.00 KB
ESCENE 1 452,00 kKB
EE.SHP.RED_MEMOR'\"_MP.P ] 0.00 KB
@SUBSTF&NCE ] 0.00 KB
ﬁ'-.-'IDEO_CLIF‘ ] 0.00 KB
— Memary
Files: 0
FileType £ | Count |
FAauDIo_CLIP 0
NBASE_FONT 1]
E3ronT 0
e cEom 0
BimacE 0
KOmaTERIAL 0
mM.ﬁ.TERIAL_ﬁ.DVANCED ]
S 5cEnE o
EY SHARED_MEMORY_MAP 0
B2 SUBSTANCE 0
K vIDES_CLIP 0
Close
&

The Total frame shows the following information:

Projects: Shows the total number of projects in the Graphic Hub.

Folders: Shows the total number of folders in the Graphic Hub.

Files: Shows the total number of files in the Graphic Hub.

Size: Shows the amount of storage space used by the data.

Memory: The memory pane displays the currently open files, counted per type.
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Warning and Error thresholds

Certain conditions that may cause problems or lead to errors, will be signaled by the Graphic Hub
when certain thresholds are crossed. An orange or red signal in the Overview indicates an issue
that should be investigated by the administrator as soon as possible. In addition, the Graphic Hub
will provide a warning on shutdown, if one or more of the following conditions apply:

Less than 1,600 MB hard disk space is available.
More than 99 % physical memory is used.
Less than 100 MB virtual memory is available.

/\ IMPORTANT! If less than 50 MB disk space is available, Graphic Hub does not allow
any write operations, such as file create, truncate, or copy.

In the Overview, Warning level issues are indicated by an orange parameter light, and
suggests that a restart is recommended. Critical level issues are indicated by a red
parameter light, and suggests that a restart is necessary. Check the log files for further
details. The following table lists the most critical limits and warnings:

Hardware Limit Mode Usage Limit, Journal Warning
Less than 1,000 MB free disk space Localhost, 5/4 Critical disk space error. Only read
Free, Multiuser access, no write operations
permitted
Less than 10,000 MB free disk space Main/ Critical disk space error. Only read
Replication access, ho write operations
permitted
Less than 2 % free disk space, or less All Journal warning: Hard disk limit
than 5 % free disk space if 1 % of total almost reached

disk space is less than 10,000 MB

95 % or more physical memory used All Journal Warning: Suggests a restart
is recommended

100 % Physical memory used All Journal Fatal Error: Suggests a
restart is necessary

250 MB or less virtual memory available All Journal Warning: Suggests a restart
is recommended

100 MB or less virtual memory available All Journal Fatal Error: Suggests a
restart is necessary

In addition to the situations described in the above table, the following conditions will produce a
journal warning:
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25 or more main/replication server switchbacks have occurred.

250,000 or more total open transactions have been processed.

7,500,000 or more critical calls have occurred (file created, truncated, written, replaced,
copied, references changed).

9,000 or more total number of files (index information) in memory

48,000,000 or more total file opens.

2,000,000,000 or more total calls.

Main, folder, keyword or file index data file size exceeds 1,536 MB.

The following conditions will produce a journal critical error:

30 or more main/replication server switchbacks have occurred
500,000 or more total open transactions have been processed
8,000,000 or more critical calls occurred (file created, truncated, written, replaced, copied,
references changed).
10,000 or more total number of file (index information) in memory.
50,000,000 or more total file opens.
2,100,000,000 or more total calls.
- A deadlock has been detected.
Main, folder, keyword or file index data file size exceeds 1,740 MB.

Server properties
The Server Properties window shows the following types of information:

General server information

Checksum information

To view Server Properties, right-click the server and select Properties from the Servers and
Folders panel.
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Properties for server "GHMainServer@GH-MAIN' B x|
5 G S Generat
EH Checksum

MName: GHManServer@GH-MAIN Heath &
- Main Disk -]

P Memory &
Wersion: 30060032 Licenze &
File inficc Cluster ndo Chuster &
Progects: 1 Patner. GHRepheationServer@GH-REPLICATION
Folders; 0 Twpe:  Replication
Files: NA
Size: 000 KB

Details... Properties...

. ) Runining sce: 3h, 21m, 57
License: Expltes: In 178 days Started at: 9/8/2016 11:36:43 M
Digk;
Total 5R.00GE Refresh
Uszed HB17GE Q
Fres: 218368 :
Free %: rlizek 4 e
Limik 977 GB Mondkor...
M et
Total 200 GE
Frese: E11 GE
Lzed 1.89GB
Used - XAAT %

0k | canca |
e

In addition to the server’s name, type and version, general server information includes:

License

Disk

Memory
Health

Server details

Checksum information

View the checksum when you want to compare two or more Graphic Hub servers to see how
identical they are. This is useful after having performed replication operations or when you have a
real-time Deploy Agent. Empty servers will have a checksum of 00.
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I ame; GHM ain5 erventeiE H-bddb Health &
: Disk. i

Type: bd ain Memory. &

W erzion; 30060132 Licenze @&

T otal zerver checksaum; BED4423938494E 4

Folder structure anly: 10DDOECAT 2E 743863

Falder structure incl. file data:  BACAB1BAFSAFEAE3

File data only: E956E 80120 84CBOD

File references only: BI31EFR4EZB0ERACE

Pilat tables: 018071 EZ71093783

Checkzums of the other server|z] where logged in: Refresh |

The o

Use th
Check

= B GHReplcationServer@EH-REPLICATION

B Total server checksum [EBD 44239334934 4]

wm Folder stucture only [T1DDOECATZE7ABSET)

. Folder stucture incl. filedata [BACABTEAFSAFE B8]
W3 File data only [E356B3M1 2D 34CE0D)

File references only [B316FE4E 2B0ERALCE]

B Filot tables [D15071E271093783)

heckzum calculation may take a long time depending on the databaze sizel

e Refresh button to update the checksum information for the servers currently logged on to.
sum information includes:

Total server checksum

Folder structure (including file data)

File data only

File references only

Pilot tables

Empty servers will have a checksum of 00. When logged on to more than one server, right-
clicking in the checksum information window will bring up the contextual menu, which gives
access to:

Open differences...: Opens the Server Diff window. From this window, it is possible to detect

differences between the servers (see Detect and solve server differences).
Open differences and execute...: Opens the Server Diff window and executes the Diff all
operation.

/\ Note: Execution time of Diff all varies depending on the database size and the
amount of differences between the servers being compared.

Open Pilot differences...: Opens the Pilot data differences window. See Resolve Pilot Data
Differences Between Graphic Hubs. This option only appears when connected to a server
that contains Pilot data.
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Properties: Opens the General server information window for the selected server.

Chat with Artists

Users can communicate with each other while logged in to Graphic Hub. This chat functionality is
also used to receive global messages from Graphic Hub, such as information about a system
shutdown. The messages that are sent and received are saved throughout the session.

If your dongle expires or is otherwise invalid, you will receive messages in the chat panel with
increasing frequency until you renew it.

/\ Tip: The chat feature is available from both Graphic Hub Manager and Viz Artist.

S 1] S5ages {Chat)
Servers, groups and users: Mesrages:
&, Global Message <9fBLA016 2:56:29 PM> [VizDbServen@GHSERYER- »Sarver]: Viz Graphic Hub is running
2 (B GHMairServenGH-MATNAdmin)

= (7 Administrator

5 () GHReplcationServen@GH-REPLICATION(A
= () Administrstor
by Acmin

To sand a message bo bthe selected sarver, group, o user, bype a message in the box,

To open the Chat panel
Click View > Messages (Chat).

/\ Note: If receiving a message while the Chat panel is hidden, the panel will
automatically open.

To send an instant message

1. Open the Chat panel.
Select the recipient from the left side of the panel.
3. Type a message text in the text box, and press Enter.
The message will be sent to the selected Graphic Hub Manager and/or Viz Artist user(s).

N

& Tip: Messages sent to Global Message are delivered to everyone. Messages sent to a
group are delivered to every group member currently logged in.
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From this window you can view all the folders and file types on a selected server.

To view objects

Click Vie

w > Object Types .

Object types on server ‘Wiz

Server: |VizDbServer@GHSERVER(Admir ¥ |

Chijeck

=101 %]

Id | Mame

=¥
—

[ mEH
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Bl
K=o
st
[ gjLE
B¥ 167
AL

Falder

Project

MATERIAL

SCEME

IMAGE

GEOM

FOMT

BASE_FOMT

SHARED _MEMORY_MaP
AUDIO_CLIP

(212 MATERIAL_ADVANCED
K248 VIDEQ_CLIP
Efz5e SUBSTANCE

Close

|ObjectTypes: 13

4

p—

. If logged in to more than one server, select which database to monitor from the Server list.

2. Each folder or file type is shown with its corresponding ID.
Once an object is in the database, its type will be added to the object types list. The type will
remain in the list even if all files of that type is deleted later on.

1.5.12 Daily backup using second Graphic Hub

Adding a backup server adds another level of redundancy to the Graphic Hub server. This section
describes how to configure and restore from a Graphic Hub backup server in running in 5/4

Free mode.

To configure a Graphic Hub backup server

1. Install a Graphic Hub server in 5/4 Free mode on an extra machine.

2. Open Backup Configuration in the Graphic Hub Terminal, by clicking Backup and
selecting Show configuration from the Backup and Restore menu.

3. Configure the server To Do an Internal Backup or To Do an External Backup.
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. Make sure to check both the Automatic backup after successful shutdown and Start after

backup checkboxes.

. Start the backup server.
. Using Graphic Hub Terminal, Graphic Hub Manager or Graphic Hub REST, configure a shut

down task to shutdown the Graphic Hub periodically, for example once per day or once per
week, depending on the requirement.

. Install a Graphic Hub Deploy Agent on the failover system. If there is no failover system in

place, the replication server should be used.

. Create a real time deploy task from the cluster towards the backup server, without

emergency pausing.

Caution: Because of the resource requirements for the Deploy Agent, it is not
recommended to install the Deploy Agent on a cluster’s main server.

To restore from Graphic Hub backup server

1.
2.

Pause the deploy task on the cluster.
Perform an emergency shut down of the backup system. Make sure to check the Temporary
disable backup after shutdown checkbox:

/\ Warning: If the backup after shutdown task is not disabled, the backup task will run
and restart the server afterwards, which can result in possible loss of data.

To go back to a specific backup, create a restore data directory from the Graphic Hub
Terminal restore points. Then configure the Graphic Hub backup server to start using that
data directory.

Log on to the cluster and backup servers with Graphic Hub Manager.

Click Server in the main menu and select Differences... to open the Server diff window.
Deploy all differences from the backup server to the cluster.

/\ Tip: Use the Manager to search for specific files and copy them from the backup
server to the cluster, if not all differences are to be restored.

1.5.13 Detect and solve server differences

If a Graphic Hub in a Cluster environment switches from real-time replication to recovery mode, or
the replication server has been performing a cluster rebuild, the data on the servers may differ.

In such situations, the Graphic Hub may be unable to do an automatic rebuild.

To detect and solve server differences

1.

Make sure that the Main and Replication servers are up and running.
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2. Open Graphic Hub Manager on a third machine, and log on to the Main and Replication
servers. The user account on the Replication server must be an administrator user. Check
the As system administrator checkbox in the Login window when logging on to the server:

3. From the main menu, select Server > Differences.

4. In the Server Diff window, click Diff All.
This will scan all files on the selected servers.

5. Sort the entries on both servers by size (click the Size columns), and then delete all files with
a size of 0.00 KB.

6. Click Diff All again.
7. Now sort the entries by type, and then select all entries of type Scene, where the row on the
opposite side is labeled missing.
Files {15) I Folders (12) I Keywords () ] Deploy tasks (0) ] Wiz uger settings (0) ] Viz VR Studio Setups (0) ] Add-ons (0) ] Assigned add-ons (0) }
Mame Size  Type Date modified Mame Size Type Date modified
5 s_onlydeldata_ok 6,293 SCENE 11/19/2015 L:40:... |3 missing! MfA
B missing! NJA 4 uffizi_cross_hdr 4,688,138 IMAGE 2/13/2018 1:01:0...
Elimg_5_deldata 1,302,921 IMAGE 11/19/2015 1:29:... [ missing! N/A
Edimg_1 ok 1,302,921 [IMAGE 11/19/2015 1:28:... | missing! MfA
B missing! NjA B4 bg-douds 12,886,487 IMAGE 2/13/2018 1:01:0...
Es_3_al_upd 6,585 SCENE 11/19/2015 1:30:... I3 missing! N/A
535 _onlyupd_upd 6,239 SCENE 11/19/2015 1:41:... |3 missing! N/A
s 1 al ok 6,585 SCENE 11/19/2015 1:2%:... |5 missing! MfA
[ missing! /A B4 88ER _TEST - Copy_- C... 3,447,352 IMAGE 1/26/2018 9:47:1...
= s_onlyupd_ok 6,239 SCEMNE 11/19/2015 1:41:... |5 missing! MNfA
Es_5_all_deldata 6,585 SCENE 11/19/2015 1:39:... 3 missing! N/A
E5s_4_al_empty 6,585 SCENE 11/19/2015 1:38:... |3 missing! MfA
Eiimg_4_empty 1,302,921 IMAGE 11/19/2015 1:28:... 1 missing! N/A
=l s_onlydeldata_deldata 6,293 SCENE 11/19/2015 1:41:... |5 missing! MNfA
Y —— ———— = missing! A
Bdimg_2_del DDC to server 'VizDbServer@Z422-DRU'... § missing! NJA
[ missing! Verify/restore... ) ABER_TEST_-_Copy_png 3,447,351 IMAGE 1/26/2018 9:47:1...
Eiimg_3_upd § missing! MNfA
i missing! Delete... Del Hinter 4,687,705 IMAGE 2/13/2018 L:0L:0...
Properties...
8. Right-click the scene entries, and then from the menu that appears, select DDC To or Verify/
restore... .

9. In the Deploy Direct Copy window that opens, click Continue. Or analog to this click Verify in
the Verify/restore... window.
10. The Action Log for deploying files is activated. In the resulting window that opens, click
the Move button.
The entries are deployed from one server to the other.

11. Repeat steps 7-10, and this time sort the entries by type Geom.
12. Repeat steps 8-10 for all other entry types.

1.6 Viz Pilot Database Management

This chapter describes management of Viz Pilot databases when the Graphic Hub is used as a Pilot
data back end server.

In this section, you find the following information:

Important Pre-installation Information
Schema Changes
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1.6.1 Important Pre-installation Information
Before setting up Graphic Hub as a back end database for Viz Pilot, observe the following:

- The server must meet the minimum hardware requirements for Graphic Hub as Viz Pilot
back end system which may vary depending on the size of the installation.
- Viz Pilot requires Graphic Hub REST. The server running the GH REST service needs to meet
the Graphic Hub REST Requirements.
- The schema version is bound to the Graphic Hub version:
- On Graphic Hub 3.2.0, Pilot schema 8.3.0 can be imported using Graphic Hub
Manager version 5.2.0.
- On Graphic Hub versions 3.0.2 through 3.1.1, Pilot schema 6, 7 and 8 can be
imported using Graphic Hub Manager versions 5.0.2 through 5.1.1.
- On Graphic Hub versions 3.0.0 and 3.0.1, Pilot schema 6 and 7 can be imported
using Graphic Hub Manager 5.0.1.
- Graphic Hub versions 3.0.2 through 3.1.0 require Graphic Hub Manager 5.1.0 or 5.0.2
to clean the schema.
- Graphic Hub versions 3.0.0 and 3.0.1 require Graphic Hub Manager 5.0.1 to clean the
schema.
Media Sequencer 4 is required for Pilot 7, 7.1, and 7.2.
- All Pilot data is stored in the configured data directory. It is included in the Graphic Hub
Terminal internal backup, and when the data directory is copied.
- The schema is automatically upgraded when the Graphic Hub is started on a data directory.
- Graphic Hub 3.2.0 automatically upgrades the data directory to schema version 8.3.0.
- Graphic Hub versions 3.0.2 through 3.1.0 automatically upgrade the data directory to
schema version 8.
- Graphic Hub versions 3.0.0 and 3.0.1 automatically upgrade the data directory to
schema version 7.
- Old Pilot clients can work on newer Graphic Hub and Graphic Hub REST versions, but newer
Pilot clients cannot work on older versions.
- Schema 7 clients (VCP 7, 7.1, 7.2) and 8 clients (VCP 8, Pilot Edge) can work on GH
REST 2.0.2, GH 3.0.2 and higher.
- Schema 8 clients (VCP 8, Pilot Edge) can not work on GH REST 2.0.1/GH 3.0.1 and
lower.
- Schema 8.3.0 clients can work on GH REST 2.2.0, GH 3.2.0 and higher.

/\ Important!

Make sure to have the documentation for Graphic Hub and Viz Pilot at hand before
proceeding with the installation. The latest documentation is always available
at www.vizrt.com.
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Version requirement summary

Pilot schema version Graphic Hub GH REST GH Manager version
Pilot client version version version to import / clean schema
8.3.0, Pilot 8.3.0, Pilot Edge using  3.2.0 2.2.0 5.2.0
8.3.0 schema
8.0.0, Pilot 8, Pilot Edge using 3.0.2 through 2.0.2 5.1.1 or 5.0.2, can import
8.0.0 schema 3.1.1 through schema 6, 7, 8
2.1.1
7.0.0, Pilot 7, Pilot 7.1, 7.2 3.0.0 or 3.0.1 2.0.0 or 5.0.1, can import schema 6,
2.0.1 7

/\ Important: Always use the correct versions as listed above. Do not import Pilot data or
clean the schema on Graphic Hub 3.0.2 or higher with GH Manager 5.0.1 or 5.0.0, as this
will write the wrong schema version to the Graphic Hub.

Manager 5.0.0 with Graphic Hub 3.0.2 or higher:

- Clean: Sets schema version number to 7.0.0.
Import: Sets schema version number to 6.0.0.

Manager 5.0.1 with Graphic Hub 3.0.2 or higher:

- Clean: Sets schema version number to 7.0.0.
Import: Does not overwrite present schema version.

1.6.2 Schema Changes

The following schema changes are performed automatically on Graphic Hub startup.

7.0.0 (Graphic Hub 3.0.0, 3.0.1) to 8.0.0 (Graphic Hub 3.0.2 or higher)

Adds three additional columns to the templates table:

- authored_model STRING NULL WITH DEFAULT NULL
- master_template_modified DATE NULL WITH DEFAULT NULL
- authored_model_modified DATE NULL WITH DEFAULT NULL

8.0.0 (Graphic Hub 3.0.2 to 3.1.1) to 8.3.0 (Graphic Hub 3.2.0 or higher)

Adds an additional column to the templates table:
- template_kind SHORT NOT NULL WITH DEFAULT =0

See Also
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- Viz Pilot official documentation
Pilot Clients have no database connection

1.6.3 Key features and workflow of Graphic Hub 3 as Viz Pilot back
end system

Key features and workflow of Graphic Hub 3 as Viz Pilot back end system

- Centralized storage for both Viz Engine graphics and Viz Pilot data.
Easy setup of main and replication in terms of redundancy and fail-over.
Easy installation without any extensive database knowledge or upgrade procedures.
Easy import of data from Oracle to Graphic Hub using GH Manager.

- Cloud-ready back end based on REST. Note regarding security: GH REST supports SSL. Key
creation and certificate distribution is not handled by the Graphic Hub, and is the
responsibility of the customer.

Easy Ul-driven import from a running Oracle database on Viz Pilot schema version 6, 7 or 8
to the Graphic Hub via the Graphic Hub Manager. The import only has to be done one time
in the transition phase. Note that re-import will delete all previously imported data and all
changes.

- The feel of working with data on a Graphic Hub is exactly the same as using the back end
database on Oracle.

Notable limitations

- Graphic Hub as pilot back end requires Graphic Hub REST and specific versions (see Viz Pilot
Database Management).

- One schema per Graphic Hub instance. Graphic Hub can run a single Pilot schema on same
instance as graphics data, as opposed to Oracle, which can run multiple.

- The schema version is bound to the Graphic Hub version.
No support for master-to-master replication through Graphic Hub Deploy Agent. A manual
backup solution is possible with Graphic Hub manager (see Data backup solution). Since
Deploy Agent 2.2.0, it is possible to schedule deploy tasks which automatically backup Pilot
data to other Graphic Hub instances.

- VOS (Viz Object Store) is not supported in Graphic Hub.

Basic setup

These are the steps to set up Viz Pilot with Graphic Hub as back end with existing Pilot data
schema version 6, 7 or 8:

1. Install Graphic Hub (see To Install a Graphic Hub.
a. You may configure a new and empty data directory or use an existing one.
2. Install Graphic Hub REST (see To Install the Graphic Hub REST.
3. When both installations are complete, the configuration windows for Graphic Hub Terminal
and Graphic Hub REST open automatically in the browser.
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4. In the Graphic Hub Terminal window, click Start Server to start the Graphic Hub server.
5. Switch to the Graphic Hub REST configuration window. Select the local Graphic Hub (if
gesired) as Graphic Hub server, and click Apply:

"I

Please select: Graphic Hub server

. Log on to the Graphic Hub as Admin. The default password is vizDb:

Authentication required

Please login to Graphic Hub:

VizDb5Server@LOCALHOS5T-19396

GH username : Admin

GH password : T

7. Install the Graphic Hub Manager and start the application from the Start menu when the
installation has finished.
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8. Log on to the Graphic Hub server running on LOCALHOST as Admin:

Bt Login e
Preferences...

Connection

Host: LOCALHOST et

Hub: VizDbServer

Hub type: Standard server

User
Mame: Adrmin =
Password: | 2111

[ ]Enable for Auto logini

Viz Graphic Hub version: 3.0.0.59212

Client version: 3.0.0.59184
Status: Connected to server 'VizDbServer@LOCALHOST'.
9. Go to Pilot > Import...

#t Viz GH Manager - using Layout 'System-Clean (locked)'
Server View Toels BExtra  Pilot  Info

IE' S0 Addres Differences...

Servers and folders Import...

/U‘ESEn.rers and folders Ll'. SEEFCH\'._" -
~ [ 1-VizDbServer @LOCALHOST{Admin)
 data
10. Proceed to Import Viz Pilot Data Schema.

& Note: Requires that the Pilot data schema is at least version 6, 7 or 8, depending on
the software versions in use.

11. All data from Oracle is now in the Graphic Hub. Click Finish.

12. Install Viz Pilot Data Server.
13. In the installer select Graphic Hub as database connection and enter the connection details

of GH REST.

/\ Note: The specified User ID must be a Graphic Hub user without a password, and
minimum Write user rights.
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ﬁ! Vizrt Pilot Data Server 7.0.0.764 Setup = 28

Setup Database Connection

The Pilot Data Server service must be configured to connect to a
Graphic Hub or Orace database.

Connection method

[Graphic Hub

Haost name

|||:u:a|h|:-st

Port number

|19398

User ID

|Guest

[ Back ][ Mext ] [ Cancel

14. Add Grap-hiﬁub REST as search provider in the Data server settings.

VCP parameters Search Providers Tag settings

Azset search providers

Actrve Sernice Docurment URL Short name Descripbion [fﬂth!d from server)

kttp:/flocalhost: 193598 VizDbServer@Z420-MNE2 Search File and Folder search for VizDbServer@2420-MNE2

Add Delete

Pre-authenticated hosts

Hast URL UserMame  Password
hitp:/lecalhost: 19398 Admin VizDb
Add Delete

15. Set disable_built_in_vos_search.

VCP parameters Search Provide
Save eset A Filter: | VOS5
Mame WValue

disable_built_in_wvos_search

This will enable the Director to search the Graphic Hub for media.
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16. Install Viz Pilot 7 or newer. When the installation finishes, the Pilot configuration opens.
Select GH as Database and enter the connection details for the Graphic Hub REST.

k Viz Pilot Configuration

General Preview MNewsroom Wizard
F§1 Database
Connection Type
SID
Hostname
localhost

Port
19398

U=ername
Guest

G Media Sequencer

Media Sequencer Host
localhost

17. Configure the other options, such as Preview, as required.

18. Install Media Sequencer 4 or newer.

19. Install Preview Server 3 or newer.

20. Start Director, then go to Tools > Media Sequencer Configuration.
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21. In the Database tab, Select Pilot Data server.
Media Sequencer Configurati

Database Viz One MOS

© Pilot Data Server
Host
Port :

® Oracle

Immediately remove deleted elements

1. Restart Director. The following icon should appear in the bottom right: S

- Director has already had a status icon in the bottom right corner that told the user
about the status of the database connection of the Media Sequencer. It is still there
and works regardless of the configured back end system. It uses a new icon, but
works the same way. When green, it means the Sequencer is connected to a Pilot
database. However, the icon will be green also when the connected database is
different from the one that Director connects to. For example, Director may connect to
Graphic Hub, while the Sequencer connects to Oracle. In this case, the configuration
needs to be changed. If the icon is not green, there is a problem with the Media
Sequencer's database connection. Check the Sequencer logs for further
troubleshooting details.
If the Media Sequencer Configuration's Database tab in Director looks the same as
prior to upgrading to Pilot 7 or newer, it is because it is connected to an older Media
Sequencer that does not support connecting to a Pilot Data Server. Media Sequencer 4
or newer is required for Pilot 7 or newer.

Notes

With the Graphic Hub setup, the Media Sequencer, clients, and Pilot Data Server need to be
able to Graphic Hub REST across the network.
Media Sequencer needs access to the Pilot Data Server.
The Graphic Hub database connection needs to be configured in three locations:
For client applications by using the Pilot Configuration tool, as outlined above.
For Pilot Data Server by using the installer, as outlined above.
For the Media Sequencer by using Director configuration, formerly known as External
Interfaces.
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When started, Director and Template Wizard will now use Graphic Hub as the back end
system.

1.6.4 Main and Replication Servers

Pilot Data High Availability Cluster Solution (Main/Replication):

As with previous Graphic Hub versions, each modifying statement in a cluster environment will be
replicated towards the Replication server to guarantee real-time redundancy. This means that all
items, including the Pilot data on the main instance, will be replicated to a second Graphic Hub
instance in real-time. In case of a fail-over situation, all connected clients on the main instance will
be automatically redirected to the replication server. As soon as the main server resumes
operation, all items created or modified in the meantime will be automatically transferred from the
replication server to the main server.

To check if main and replication are in sync, connect to both Graphic Hubs as an administrator
user using the Graphic Hub Manager, then proceed to check for Pilot Server Differences.
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Graphic Hub (Main) Graphic Hub (Replication)

Graphic Hub REST

Data Server

Viz Artist/Engine

Media Sequencer

Viz Pilot Viz Pilot ActiveX

1.6.5 Import Viz Pilot Data Schema
This section details the import of an Oracle Viz Pilot Schema to the Graphic Hub.

For information on the use of the imported Oracle Viz Pilot Schemas, refer to the Viz Pilot
documentation.
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/\ IMPORTANT! You must be logged on to the Graphic Hub as an administrator to import Pilot

data.

/\ IMPORTANT! Always use the correct software versions as listed in Viz Pilot Database

Management. Do not use GH Manager 5.0.1 or 5.0.0 to im
schema on Graphic Hub 3.0.2, as this will write the wrong

Hub.

To Import a Viz Pilot Schema from Oracle
1. Click Pilot > Import to open the Import Pilot data window:

Trport Pilot data B

1 Ciacke dalisbate connection iing Imgeit histeey

IHm!_Hﬁ

Hoat
Frteed  [TCP
Part B

Serdce  [VIZRTDE

|u rertlame

LIE

Eatowond Ii seansns

Watly corrachon

[ Bmpont peltieg
" Diplete Pilot dats
% Disete and import Pt dats
™ Ordimpoet Bbaary dats slements

port Pilot data or clean the
schema version to the Graphic

Het > Cwesd | o |

/\ Tip: The Import History shows a log of previously imported Viz Pilot schema.
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2. Enter the parameters to access a Viz Pilot schema on an Oracle database:

— Oracle database connection string [ —
Host IHDst_N ame
Protacal ITEP
Fart I'I 521

st |v|zF=TDE=

I zer ILlserN ame

Pazsword I“'""""‘"""

Host: Enter hostname or IP address for the Oracle database. IP address is
recommended.

Protocol: Select the connection protocol: TCP or UDP.

Port: Enter the port number of the Oracle database.

Service: Enter the database name of the Oracle instance.

User/Password: The user credentials required for the schema to be imported.
Connection string: (Optional) Check the connection string checkbox and enter an

Oracle database string to connect to the Oracle database:
Oracle databaze conreat

Connect I

& Example: Data Source=(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)
(HOST=10.211.2.11) (PORT=1521))
(CONNECT_DATA=(SERVICE_NAME=VIZRTDB))) ;User
Id=pilotdb;Password=pilotdb;

3. In the Server to import to drop-down menu, select the Graphic Hub to import to. A dimmed
drop-down menu means the menu is unavailable because the Manager is logged on to only
one Graphic Hub.

Server to impart to

| GHM ainS erver@EH-MAIN (A dmir) =l

4. Click Verify Connection... to verify the connection details and check if an import can be
done. If the connection details are verified, this will connect the Manager to the Oracle
database.

/\ Note: An import will not work if the schema version does not match the Graphic Hub
version, or the Graphic Hub version is below 3.0.0.

5. Select the Import Settings:
Delete Pilot data: Erase all data and sets up a clean Viz Pilot schema.

Delete and import Pilot data: Clean all and import new data.
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Only import library data elements: When checked, only Data Elements marked as

Library Element will be imported.
6. Click Next to view the elements marked for import to or deletion from the Graphic Hub
database:

rmipodt pilot data - | *

Impod to sanver Wit b Sermen@LOCALHOST

Progress

TOT,

Searted: WA Finishecd m: MR

Wiz GH Ceanup Imgecat From Oracle Progress log

Tl Crides Proom Tatde Erires  Proces = Tima e i-]
chargeiag 1] lrmept 4 10:85:37 Creating connection to GraphicHub
VIR _param L conirel_sos 4 105538 . Genersting kst of 1abies and the rumber of ther
Frobe_planyieit ] (-] ] 10:56:04 Settings Upiaiad
panch_pes o E_piriph_uris 1 10:56:26 Settrgs Lpdaiad
e _ e o oeraraend_ 135 10:56:26 Denerating kst of {abias and tha rumber of ther
dhament_th o plakeat_irfis 157
mhmmenis 1] bemplate o 195
varant_oon i bamplate U ]
varants 2 plakcat_wari 170
CAlBgones i bemplate_c 150
oulpul_chas i} bemplate U i
\ng_bempiat o £ _templabe 1
Inepinle_y ] Eag_template 0
lnmplaln_u o w cutput_cha ] ~

L4 * € *

Open log deschony...
<o e

The Pilot data import progress window displays the number of entries that will be cleaned or
imported from the database tables, as well as a progress log.
Depending on the selected Import settings, this stage will have an Import or Clean button:

If Delete Pilot data was selected, the button is labeled Clean....

If Delete and import Pilot data was selected, the button is labeled Import....

7. Click Import or Clean depending on the selected task. The time to completion of this task

depends on the number of tables and elements to be cleaned or imported. The progress bar
will provide a quick overview of the process, as well as the start and estimated end times.
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8. When the import is finished, an alert window will pop up with information about any errors
encountered during the import:

9.

Viz GH Manager

1 warning cccurred during import:

*lrvalid UTF & char found in table plakat_data! Check log file for
column infermation

ot

OK

lmpoert piliot dats

Impod o sarver VizDb Sermer@UOCALHOST

Presgres
TOTAL

?l

-ﬂﬂﬂuuﬂﬂﬂﬂﬂﬂ”ﬂg

- (m]

Seavtecd: 220l 16 1056 AM  Finisied md: 22016 11:00 AM

' by pemplate
w' oulput_cha...
v ealegony

w wariart

W warisrt_con
' plakcat_disia
" plokcat_dlain
' placat_daia
v plabcat_dlata
' Ere_suthen
" sewch_pro
' E_maa_plml
o VR pans

En

7.3

738

<tock [ Mets ] [ ance

Sentinga Updaied”

Generpting st of (nbies and the rumber of ther
MEW IMPORT JOB_

Sopping sl notficatons

Lecking pdof tables

Importing From: [DESCRIFTIONs(ADDRESSs(,

Importing To- MzDbServer@LOCALHOST 1305

Megrating tables fom Oracie D48 to Wiz Geaphic .

Dleaning tables in Wz Graphic Hub

Cleaning table changeing

Cleanireg table wvop_parsmetens

Cleanineg table e _playkats i

Cleanineg table search_providen

Cleanirsg table pr_putherticated_hasts B
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Click OK to return to the import Pilot data window. If any errors were reported, click the
Open log directory... button to access the import log files.
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10. Click Next to open the Delete old Pilot elements window:

Diedete old Pilot elernents = |
Surmmarny
Bementsciderthan 1year | goaq| botel slements o lorary slemerts
Eerants clder than 1 mongh Taog| Ininl samerts 433 levary slemires
Bamants clder than 1 week Tiog lolal slemerts 433 | lorary slements
Cleanip ol Pt dats slemants
Delete smerts clderthin [§ = [wmekils) (] sty ey ebomants Diesere Horw
[ ety choanus
98 cutciabed slements can ba deleted
Hmmwuamwmmmmum
Shpt o 9% 4d 16 POOD0AI - | Dwslels sements clderthan |2 * ) [[] Dt biwmey ebemenrcs
Each 1% | dala) - [ rtocrty et
info 16, 12n Thursday, A & A
Qearug Pict changeiog (Seeciy when this task should be pedomed|
Sata:  [230d 16 ZOO00AN o | Delese changelog ennes clderthan |0 = dayla)
Each T | dayla) bt
info P8, 12m, 14a (Thuresday, Auguat 4. 2018 2:00:00 AM
<o il [

The Summary pane provides an overview of the total number of elements older than 1
year, 1 month and 1 week, respectively. It also lists the number of library elements in
each age category.

The Cleanup of old Pilot data elements pane can be used to run a cleanup task on the
Graphic Hub to delete elements older than a specified number of weeks, months, or
years. Library elements will not be deleted unless the delete library elements checkbox
is checked. Check the integrity cleanup checkbox to perform an integrity cleanup
operation during the deletion.

/\ Tip: The number of elements that can be deleted is displayed in red text. The
number is updated depending on the older than setting.

Use the Schedule Pilot data cleanup and Cleanup Pilot changelog panes to create

scheduled cleanup tasks.
11. Click Finish to return to the Manager. A popup window will remind the user to enable the

Pilot cleanup tasks.
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Wiz GH Manager o

o Important!

Make sure Pilot cleanup tasks are enabled!

To enable Pilot cleanup tasks:

- open Graphic Hub Terminal

- go to options, advanced settings and select
[+] Enable cleanup of Pilot data elements
[+] Enable cleanup of Pilot changelog

0K

These may be configured at any time in the Advanced Settings of the Graphic Hub Terminal.

/\ IMPORTANT: Graphic Hub Versions below 3.0.3: Using the Thumbnail generator with Pilot
Datasets larger than 5000 elements generates many requests for retrieving all data
elements. This will cause performance instability in form of timeouts and blocking Pilot
calls. Be sure to limit the Datasets to a maximum of 5000 elements or upgrade Graphic
Hub Version to at least 3.0.3 to grant performance stability and non-blocking calls.

1.6.6 Resolve Pilot Data Differences Between Graphic Hubs

The Pilot differences window in the Graphic Hub Manager is used to view and resolve differences in
Pilot data between two or more Graphic Hub servers. This can be the main and replication servers
in a cluster environment, or other Graphic Hub servers that contain Pilot data, such as a backup
server.

To Check for Pilot Data Differences

1. In Graphic Hub Manager, log on to the servers that you want to compare.

2. Click Pilot > Differences... to open the Pilot data differences window.

3. Select the servers to compare in the Overview section, then click Check for differences. This
compares the Pilot content on the selected servers, and you can now perform a manual
backup or resolve potential cluster differences.
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Understanding the Pilot Data Differences window

=
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]
p——
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1 21=" 1
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[P P s = |
e - 0
e = - .= L
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- Tables left/right (1): The two panes Tables left and Tables right show a listing of all

database tables that are compared between the two servers.

Overview (2): The Overview pane provides a quick overview of the differences between two

servers:
Drop-down menu: If the Manager is logged on to more than two servers, all servers
are selectable from the drop-down menus to the left and right of the Check for
differences button.
Check for differences: Click to compare the selected servers. This will initiate a
checksum-based comparison of the table data between the servers. In the left and
right panes, identical tables will be marked with a green check mark icon. Tables that
differ will be marked with an orange warning icon. The Overview is populated with a
summary of the differences. Any changes made after the last click will be indicated by
a counter, and a timer will indicate the time passed since the latest change.
Lock/Unlock database: Click to lock or unlock the databases. When the database is
locked, read operations are permitted, while write operations are not. Locking the

databases will start a timer that shows how long the database has been locked, and
the button changes to Unlock database.

/\ Caution: Lock & deploy overwrites content on the destination server and
cannot be undone. Make sure to double check the direction of the deployment
with the selected servers.

Lock & deploy << | >>: Use lock and deploy to lock the databases for changes and
deploy any elements required to bring the two servers into identical states. The arrows
indicate if the deployment will be from the right server to the left server (<<), or from
left to right (>>). When clicked, a confirmation dialog appears, where you must
confirm the deployment direction. A progress bar with an estimated time for the
deployment is displayed during the process.

- Table Details (3): Double click a table in the Left or Right table panes to open a detailed view

of the selected table in the Details pane. Multiple tables can be opened, and will be added as
separate tabs within the pane. Right clicking a table in either pane will open a context menu
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from which data can be loaded. Select Show differences to load only the entries that differ in
the Details pane, or Show all to load all entries in the selected table. Select Lock & deploy all
to lock the database on both servers, and deploy all tables from the selected server.

Scheduled Tasks

All Pilot cleanup tasks can be configured and activated via Graphic Hub Terminal. Open the
Graphic Hub Terminal, then select Options -> Scheduled tasks. Scroll down the task list to find the
Pilot related tasks.

/\ Tip: In addition to the tasks described here, it is highly recommended to periodically
perform a normal shutdown when using Graphic Hub as Pilot data back end. The
recommended interval is once monthly.

1 Dayls)

To enable the tasks, click Options -> Advanced settings in the Terminal and go to the CLEANUP
SETTINGS pane. Check the checkboxes to enable each task:

Cleanup of Pilot data elements

Click on the task to open the configuration properties for the task:
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The following properties can be specified:

Start time: Define the first execution of the task.

Interval: Define the interval on which the task will be executed.

Older than: Will cleanup all elements older than the specified time span.

Cleanup of library elements: Check the checkbox to also include library elements during
deletion.

Integrity cleanup: Check the checkbox to delete all rows that violates Pilot data integrity to
provide data consistency.

Cleanup of Pilot data elements can also be configured using the Graphic Hub Manager.
However, it needs to be activated using the Graphic Hub Terminal. The Wizard will appear
after a successful schema import. Refer to Key features and workflow of Graphic Hub 3 as
Viz Pilot back end system for further details.

Cleanup of Pilot Changelog

Click on the task to open the configuration properties for the task:

The following properties can be specified:

Start time: Define the first execution of the task.
Interval: Define the interval on which the task will be executed.
Older than: Will cleanup all elements older than the specified time span.

Graphic Hub Manager Integrity Cleanup

The Graphic Hub Manager provides a tool to perform an integrity check of Pilot data and clean
data integrity violations:

1. Click Server > Check to open the Check Server window.
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2. In the Check section, check the Check Pilot tables checkbox:
Checdk

Chedk file integrity

Check folder links Check folders
Chedk file links [ ]1gnore checksum 11

Check references []Try file open
to find corrupt files

.........................................

This will include a check for data consistency in the pilot tables during server check. If any
violations are found, these will be listed in the Pilot Data tab:
Files Filot data

Info:

3. If any violations are found, click the Fix all button in the Fix panel to delete those violations:
Fix

Automatically remowve fixed entries

Fix: all
Remove fixed

The integrity cleanup can also be included during the execution of the data element deletion
task (see Pilot Tasks on how to include it) If it is included all integrity violations will be
cleared during task execution.

See Also

Key features and workflow of Graphic Hub 3 as Viz Pilot back end system
Graphic Hub Manager

Graphic Hub Terminal

Graphic Hub Deploy Agent
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Multiple Graphic Hubs and Pilot Data

The Pilot differences dialog in the Graphic Hub Manager can be used to perform a manual backup
of one server to another. However, merging the database content is not possible. The data will
always be overwritten on the destination server, to ensure that the content is identical to the
source.

1. Log on to both the active and backup Graphic Hub servers.

2. Open the Pilot differences dialog and select these servers in the overview section.

3. Check for differences and deploy in the correct direction for backing up the data. Only the
Pilot data that has been changed after the latest backup will be deployed.

Since GH Manager 5.2.0 and Deploy Agent 2.2.0, it is possible to automate Pilot data backups via
time-steered deploy tasks. Create a Pilot deploy task via one of the following workflows in GH
Manager:

- either navigate to Pilot > Create Pilot deploy task... to configure a deploy task which only
deploys Pilot data.
or create a file-based deploy task as usual and check the Sync Pilot data option in the
task's Schedule configuration window.

/\ The following restrictions apply:

- As with Pilot differences, the used databases only allow read-operations while Pilot
data is actively being deployed. No Pilot data can be created or changed in the
meantime.

- Also, while actively deploying Pilot data, the task cannot be paused, cancelled or
restarted.

Be sure to check if the correct source and destination Graphic Hubs are selected for
deploy. All Pilot data on the destination Graphic Hub will be overwritten.

- The database schema versions of source and destination Graphic Hubs need to
match.

- To periodically backup Pilot data, configure a recurring task which deploys changes
at desired intervals. It is currently not possible to deploy Pilot data via real-time
tasks.

Pilot Data Backup Solution

Using Graphic Hub Manager in Graphic Hub 3, Pilot data can be backed up manually to a Graphic
Hub server in 5/4 Free or Multiuser mode. Using Graphic Hub Manager and Graphic Hub Deploy
Agent in Graphic Hub 3.2, Pilot data can also be backed up automatically via Pilot deploy tasks as
outlined in the previous section. On the backup server, the Graphic Hub Terminal can then be used
as a tool for creating full or incremental backups of the underlying data directory on Graphic Hub,
using a scheduled shutdown task with backup after shutdown and server restart.
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Graphic Hub (Multiuser)
Graphic Hub REST

Pilot Data Server

Media Sequencer r:)

Graphic Hub (5/4 Free)
with periodic backup

Graphic Hub (5/4 Free)
with periodic backup

Viz Pilot Viz Pilot ActiveX

1.7 Graphic Hub Archives

This section contains details about the archive functionality of the Graphic Hub Manager.

In the Archives Panel, archives can be imported and exported with drag and drop. It also offers
other functionality:
- An archive search function
- View the contents of an archive
Import single files from an archive
- View archive details
In the Tool bar click on View > Archives to open the Archive panel.
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The Archives panel consist of:

- Archives View (1): Shows archives in folders (User selected (see Archives View)
Search View (2): Search in all or selected archives

- Archive Contents View (3): Shows the content of the selected archive

- Archive Details View (4): Shows the details of a selected archive

This section contains the following topics:

- Archives View
Search View
Contents View
Details View
- Archive Folders
Import Archives
Export Archives
Import Viz 2.x Data and Archives

/\ IMPORTANT: Graphic Hub Manager Versions earlier than 5.1.0 may produce corrupted
archives. This happens if the Archive was created by Viz Artist and content was added
dfterwards using Graphic Hub Manager. Importing such an Archive displays an error: File
seems to be corrupted: invalid checksum (-32642) archive error. Be sure to update your
Graphic Hub Manager to at least version 5.1.0 as there is no way to restore this kind of
corrupted archive.

1.7.1 Archives View

The Archives view shows added folders, both watched and not watched (see Archive Folders), and
all archives inside those folders. Three different views are available for each archive.
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.-"'rCE‘ Archiues\{(‘a_;'_ Sea rch\
=l D\ Archives '1]
Archive 1 2
EE Content vigw
~{>E Enkry poink view
[:ﬁ Faolder view

3 Archive 2

Archive folder location (1): Shows the archive folders where the archives are located. The
folder can be watched or not watched.
The Archive (2): Click on the archive to show the archive details, in the Details View
Archive View Options: Expand the tree node to access the following:
Content View: Shows all files contained within an archive (without any additional folder
information).
Entry Point View: Shows the archive content structured in a way that reflects how it
was exported
Folder View: Shows the archive content with its folder structure from the Graphic Hub.

/\ Tip: The archive icon color provides key information about the archive.
A red icon indicates a corrupted archive.
An orange icon indicates that the archive is Read only on the Windows file
system.
(A lock overlay icon @ indicates that the archive is Password protected)

To Add a New Empty Archive

1. Right-click anywhere in the Archives panel.
2. In the context menu select New Archive

Create new empty archive -10| x|
Faolder: ID:'I,.ﬁ.rchives j Browise... |

Templates: I <MICK ='s-Archive-from- <GH=- <y - <MM=-<dd =-<hh bj

eme: | from-GH@Host-2016-09-08-032403PM | via

(a4 I Zancel |

4

3. Select a folder where the new archive is to be created.

4. Select an archive template for automatic naming of the archive, or manually enter a name for
the new archive.

5. Click OK.
The new, empty, archive will show in the archives panel in the selected folder. If a new folder
location was selected it will show as a not watched folder.
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To Add an Archive

uiThWN —

Highlight a folder where the archive is to be added.

Right-click any where in the archive panel

In the context menu select Add Archive

Click the archive to import.

Click Open.

The archive will show in the archives panel in the selected folder. If the archive was selected
from a new folder location, the new folder will show as a Not Watched folder.

To Set a Folder as Watched or Not Watched

1.
2.

3.

Right-click the folder.
In the context menu, select Add or Remove <folder location>, respectively.
The folder will show “# when it is set as a watched folder, and == when it is not watched.

To Add a Watched Folder

A WN—

Right-click anywhere in the Archives panel.

In the context menu select Add watched folder

Select an archive folder to be watched.

Click Select Folder.

The folder is added to the Archives panel as a watched folder (see Archive Folders)

To Remove a Watched Folder

uTh WN —

Select the watched folder to be removed.

Right-click the folder.

Select Remove <folder location> from watched folders.
Right-click the folder again.

Select Remove <folder location> and all its archives from view.
See Archive Folders

To Apply a Password protection on Archive

1.
2.

Navigate to View > Archives to display Archives Panel
Right-click the Archive
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3. Apply password

pe: i
3 Archives 1 L ‘\ Search
v Lm D:\VizGHDataTemp
v 3 Admin's-Archive-from-VizDbSenwer @7477-DR11-90"

88 Content view Mew archive... Ctrl+N

<>§ Entry point view

E., Folder view Add archive... Ctrl+A
Search in archive 'Admin's-Archive-from-VizDbServer@Z422-DRU-2018-02-02-103339AM.via' Ctrl+S/ F3
Search in all archives Shift+Ctrl+5 / Shift+F3
Open in Windows explorer Ctrl+O
Cut Cirl+X
Copy Ctrl+C
Delete... Del / Shift+Del
Rename Ctrl+R / F2
Apply password %
Reset password
Add watched folder... Ctrl+F
Sorting & Display y
Edit preferences... Ctrl+P
Properties...

Password protection is indicated by the archive lock overlay icon: &

/\ Tip: If password protection is applied to an archive, the archive must be unlocked by
entering the correct password to import or modify it. To remove password-protection, just
apply an empty password.

To Remove Content from an Archive

/\ Tip: Deletion of single items, folders or projects from an archive is possible.

Delete selected folder-link

Navigate to Archives Panel
Select file in folder in archive
Right-click

Select Delete.

A WN—
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v L Cilorchives

v O Admin's-archive-from-VizDbServen@GH
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' EE Content view
H v <>E Enkry poink view
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E v 0l
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'
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'

'

fe Folder view

Only the selected folder-link of the file is deleted (if the deleted file is under a folder).
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Mame Size  Type Date modified Date created
Wiimage 17 o e e S

4

Show as icohs

Show projects/folders

Open
Copy Ctrl+C
Delete.., Del

Delete everywhere else.,

Properties...

Hide search Shift+Chrl+E
Hide archives Shift+Chrl+F
Hide details Shift+Ctrl+D
Hide toolbar Shift+Ctrl+T
Hide statusbar Shift+Chrl+5

If this is the only link name of the file, or if the file does not have a folder the file is deleted with
ALL link names from the archive.

Delete Everywhere

Navigate to Archives panel
. Select file in folder in archive

1
2
3. Right-click
4

. Select Delete everywhere else

Size  Type

Date rmodified

Date created

Type: ALL
=] Archi\res. "*-‘\ Search Mame
1 <
4 Ciarchives
- iMgImage 1
v 3 Admin's-Archive-from-YizDbServer@GH Lol
85 Contertt view
v 4>E Entry point view i
~ w Example
v - 01
- A
- 0z
f= Folder view 0
v
v
v
L
L

1.7.2 Search View

The Search Tab provides options to search in the archives. The following file types can be

searched:

Scenes

S3.25ME TMAGE
Showy as icons

Show projects/folders

Open
Copy Ctrl+C
Delete.., Cel

Delete evenynhere else..,

Properties...

Hide search Shift+Ctrl +E
Hide archives Shift+Ctrl +F
Hide details Shift+Ctrl+D
Hide toolbar Shift+Ctrl+T
Hide statushar Shift +Ctrl+5
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Geometries
Materials

Advanced materials
Images

Fonts

Audio files

When the search tab is selected, by default all folders and archives are selected as search

areas. Deselect folders and archives as required to narrow a search.

/CE ﬁrchives}’(h.‘{ Search\

Freetext: i

= . Di\Archives
[FlcE Archive
[ Archive 2

To Search for a File in an Archive Folder

1. Click on the Search tab.
2. In the Freetext box, type text to search for.
3. Search results are shown in the Search result panel.

Archinees

I —
E: _ - Tope: | :I.-d R =S

"' &) Archives ' ), Search , Mame ¢ size | Type | Date modified
Freetext: image -

L Folder Lachivenane @) /| size
D:hArchives Archive 1.via
Daharcheves Archive 1.via
D:\Archives frchive 1.via
D:\Archives Archive 1.via
D:\Archives Archive 1.via

[5 fites I
4. Double-click a file in the Search results list to see the file properties.

/\ Tip: Or right-click the selected file and select Properties.
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1.7.3 Contents View

The Archive Contents Panel shows the content of the selected archive in three views. Select which
view in the Archives View.

& Caution: If a file or files are deleted in the archives view the file or files will be deleted from
the archive completely. This includes the file itself as well as all its folder links.

el :l:u AT 5=

[ size | Tpe Dzt modited | St created | cwmar | aoosss righ.. Fie... | Reterenes | bo. obkeswords
B sem= TALSLEH  Fodls ANLEDIE 1eiteds CRERE0IE 1231 Guesl AL 5 1

B o _cindle Lasi0 TaEc MATENE IEIR N © (=14 LT ] i) L l: o
B oy i3 1050 MaiS W7AE028 151540 O Cauzal WU E il L}

B e FLET TGS AAENIE NI OSEI001 1S5 1 Guart Ww s 1 [

- VE 1IPME MaGE 202012 1445 55 J.D.L'l.;{l:" dfidnd  Guest WY z i L}

Bl pra bage SAEMH  FALs Ane 3 Gasenl AR 5 1 (]

Bl cxph=l P C2K0 TVaET 20001 14557 sk LA z L q

Bl Caace_Akras LLEME MALS MIAE0LE 15155 Cacal W iE 1 q

Bl canrofunte Coior THLIGEN TGS AN 1 et WNw 1= 1 (]

B Cerchiani L370E M&GE 070 1535 3 & Guzst WY iE 1 L}

Blishrore oh MELFH  MaL= LT AT A 1 D L T Gl [YRYRC 145 1 u

B crrorve_spathg 52 ADLFLED TeAGT 00 IS IRIE O 31 ouast LA g L q

mduud 8.55FE THALS 2TAC04 163528 L Hodree...  WWW 7 L q

Blrel hae? IMLFEEN TGS AR 14 II'|, 0T 1G0T Guert WNw H 1 il

B col_beee ZITEZLKE MAGE TR0 144700 10NIDVEOOT 1L 10T Guest (AR ] z 1 L}

L L P AH MR- R, | P - 2 T 11Ul ot L {1 s Pl Y| G - 10 (LR - 1 it :I
Al

Files listed in the archive Content View can be imported to a Graphic Hub by drag and drop (see
Import external images).

1.7.4 Details View

The Details view displays all available data for the archive selected in the Archives View.
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Details to archive "Archive 1.via'

Cu\ArchivesiArchive 1.via
af5/2016 2:51:09 AM
Adrmin

Q712016 4;09:50 PM

6.35 MB (6,663,115 bytes)
9/5/2016 9:51:32 AM
9/5/2016 10:51:09 AM

B

5

3AB17ELA4570C199
Yes (Intern)

0,30 KB (312 bykes)
A4-bit

Mo

YizDbServer@aHSERVER: 19396
Jdata

M8

Wiz GH Manager work 1

5.0.0,0

30060132

4.0.0,60132

30060132

1.7.5 Archive Folders

The folders listed in the Archives view can be Watched or Not Watched folders:
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Watched Folders: All changes to watched folders are monitored and reflected in the Archive

view.

/\ Note: Once added, folders can be set to not watched if required.

Not Watched Folders: Folders added to the archives, but not monitored.

1.7.6 Import Archives

Viz archive files (*.via), containing folders and/or files, can be imported to the Graphic Hub
through the Archives Panel.
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To Import All or Selected Folders and Files from an Archive

Archived files and or folders can be imported from the Archive panel or the Search result panel.

/\ Tip: Any file or folder that can be seen in the Archive panel or Search result panel can be
imported with drag and drop.

1. Select Archive or Search view.

2. Select a folder or a file:
In the Archive view: Select an Archive and select the required folder(s) or file(s) from
the view panel. Multiple selections are possible.
In the Search result view: Select a folder or file, or multi-select.

3. Drag a selected Archive folder or file to a Graphic Hub folder in the Servers and Folders.

/\ Note: The Archive or file can be dragged to the Explorer panel as well. Make sure the
correct folder is selected first in the Servers and Folders.

Server Yiew Tools Extra Fiot Info

Address: 1@ -» Root of GHMainSemnver@ GH-MAIMN = [_11.: Type: |;_|_|_
| Name |
/D% Servers and folders | L) Search w—ca
= W 1 - GHMainServen@EH-MAIN Admin)

= & data

& Projectl

1 project

/€2 Archives ' L), Seareh',
B & Dodrchives

= @ Archive 1
2 Contertt view

EEPESREEIE
| Size | Type | Date

Project
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4. Complete the Import from Archive window as required.
 Import from archive - Analysis & Options — O ot

Summary

Archive: Mick's-Archive-from-GH@Host-2018-02-20-093925AM. via
Destination path: % VizDbServer @Z420-+KL: /data /GLOBALS IMAGE
Available disk space on server 97.21GB
Selected objects: 5 21.25MB 449 MB
Referenced objects: 1.24MB 0.00 KB
All objects: 7 22,49 ME 4.49 MB

[

Analysis
> 8 s_onlydeldata_ok (SCENE - 6. 15KE)

. P
i q E
g_1 oK {IMALE)

> 8 s_1_all_ok (SCENE - 5.43 KE)

» 8 s_onlyupd_ok (SCENE - .09 KE)
bg-clouds (IMAGE - 12,29 ME)
uffizi_cross_hdr (IMAGE - 4.47 MB)
inter {IMAGE - 4,47 ME)

Infos, warnings & errors

Info: Analysis finished without any warnings or errors!

Step 5 - Analyzing objects on the target server... Tof 7

Behavior options

Import mode: Rebuild original structure e

Cwverwrite mode: | Overwrite e
Owverwrite owner Civerwrite create date Force link name creation

[ ] overwrite name Cwverwrite access rights Impart add-ons Import keywords

5. Click Continue
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6. Click Import.

'ﬁ' Import from archive 'Nick's-Archive-from-GH@Host-2018-02-20-093925AM.via'... (to server ... — O b

File Objects Size To Importmode  Owerwrite ...  Overy

.. 5_onlydeldata_ok 2 1.25MB [data/GLOBALS/IMAGE  Rebuild ori...  Qverwrite Mo
ess img_1_ok 1 1.74MB [data/GLOBALS/IMAGE  Rebuid ori...  Owverwrite Mo
w5 1 all_ok 2 1.25MB [data/GLOBALS/IMAGE  Rebuild ori...  Owerwrite Mo
ves 5_onlyupd_ok 2 1.25MB [dats/GLOBALS/IMAGE  Rebuid ori...  Owerwrite Mo

.. bg-douds 1 12.29MB [dataf/GLOBALS/IMAGE  Rebuild ori...  Owerwrite Mo

o Uffizi_cross_hdr 1 4.47MB [data/GLOBALS/IMAGE  Rebuild ori...  Owverwrite Mo

1

oo inter 447 MB [datafGLOBALS/IMAGE  Rebuild ori...  Owerwrite Mo

< >

[] Close this window automatically if no problems occurred (:E Cancel

Reuse this window for same actions
Do not insert entries that are already in the list Warn me about not inserted

7 entries to be processed.

/\ Tip: If a password protected archive is imported, the password must first be entered.

3% Please enter the password to unlock the .. X

Password: Y1111

Cancel

Context Menu Import

- Use Import from the context menu to import an archive directly to the selected server.
To Import an Archive

1. In the Servers and Folders panel, right-click the target server.
2. Select Import from archive
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3. Click Browse to select a source folder.

Import archive to server "GHMainSers =10 x|
Falder: ID:'I,.ﬁ.rchives j Browse. .. |
Marme: I.ﬁ.rchive 2.via j

™ Determine existing objects by same name instead of UUID

[ overwrite existing objects

Import I Zancel

&

4. Select the archive.
5. To check for objects that exist with the same name (but a different UUID), check Determine

existing objects by same name instead of UUID.
To overwrite objects that exist with the same UUID, check Overwrite existing objects.

Click Import.

N

1.7.7 Export Archives

Folders and/or files can be exported out of the Graphic Hub as Viz archive files (*.via) through the
Archives Panel.

To Export a Folder or a Single File
/\ Note: Folders and files can be multi selected in the Explorer panel.

1. Select the folder or file to be exported as an archive:
In the Servers and folders panel select a folder, or
In the Explorer panel select a file or folder
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2. Drag the selected folder or file to an archive in the Archives panel.
Servers and folders | e e
/ﬂ%senrers and falder-.t\{kl Searr.n\ : -

=l 1 - GHMainServer@GH-MATN| Ad

Ar
/@ Arch Msx\{kl har:h\

EH WIS
B ¢ Entry point view
& B Folder view
3§ Archive 2

{1 project
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3. Fill-in the Export to Archive panel, as required.

Tt Export to archive - Snalysis e [l X
aurnrmary
archive: &dmin's-Archive-from-vizDbServer@EHSERYER-2018-02-02-. ..
A ailable free disk space 40,19 GEB
SourceEntrypoint: YizDbServer@GHSERVER \ datalInmage _1
Selected objects: 1 33.25 MB 33,25 MB
Referenced objects: 1] 0,00 KB 0.00 KB
all objects: 1 33.25 ME 33,25 MB
Analvsis

B Image_1 (IMAGE - 33.25 MB)

Infos, warnings & errors

Info: Analysis finished withouk aney warnings ar errors!

Skep & - Analvzing objects in the archive: 1ofl

Export all linknames to the archive

Zonkinue. .. Cancel

/\ Export all linknames to the archive: All link names are exported (default). When
unchecked, only link names from the folder/project from where the file was dragged,
are exported to the archive. Link names in sub-folders are also added.

4. Click Continue
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FE Export to archive 'Sdmin's-Archive-from-WizDbServer@GHSERVER-2018-02..  — O Xk

File COhjecks Size
ees IMage_1 1 33.25 MB

L4

Progress  Info

Mok et processed!

[Jclose this window autamatically if na problems occurred
Reuse this window for same actions
Do not insert entries that are already in the lisk

1 entry to be processed.

= Cancel

Warn me about not inserted

Context Menu Export

To Export a Folder or a Single File

1. Right-click the folder, project, or file to be exported.

2. Select Export to archive
3. Click Browse to select a destination folder.

B Exportd
Folder: Ciiarchives g ||
Templates: w
Marme: | Irmage_1 | via

Apply password Export all linknames to the archive Expork Cancel
4. Enter a name for the archive.
5. Click Apply password to generate a password-protected archive
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6. Click Export.

/\ Note: If password protection is enabled, the archive must be unlocked by entering the
correct password to import or modify it. The user is automatically asked to enter the

password during at import or modification.
Password protection can also be added on an existing archive by context-menu View >

Archives > Apply password
To remove password-protection, leave an empty password.

1.7.8 Import Viz 2.x Data and Archives

To use files from other data directories, they must be imported into the Graphic Hub. In Graphic
Hub Manager either data directories or archives created with Viz Artist 2.x. can be imported.

/\ Tip: When single files are imported from a data directory or an archive, referenced files will
also be imported.

Expert Settings
In the Import Window, there are a number of optional Expert Settings that can be used for import
operations.
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Innport wle GH-lanSoryer@GH-MATY B ‘.Imﬁl
Fie
1 Sarver o import ba |1 tions 1 Expart sattings |
| ET———rre| Iregueet I waofraterces: o 7] resetstte: [ 200 ooy |
- I™ Shew intances [0 oo I
Poepin (= I I Crverorite existinn fies ; ok 2 [ Y
[Memtompert 1 Comugt fled Anstyoe progras
2 O liststjeommongend | | | Tms [mpe  [Fie ,Elv'
® O fot ] 000 1]
B O peom Haberialy
® [ mage —
Qi mabesial o 000 1]
B O sene Fonts: .
o 000 a
Gaomatiies.
I |
| o 0.00% o
1] I Fl | Soenes |
H : —— [
Conrl: 0 St N B sine: ML [ Cpen fog il | 0 B— ul
[+ Process kg Losg probenn enly | ¢
Timee: | Type Fie ] 0.00% [}
TOTAL
| |
] 0.00% 0|
Clmgoetprogress |
| I o s |
Counks O Tirvee lefit Bl Fineshed: Mjt Cpen o e m'—
e ] 0.00% 0
Tires. Fis T
o L o 0.00% 0
I'il!.ﬂ.ll_!'_
o 000 [}
Soenes
I
o 000 0
4] | ¥ [
Conrks 0 @ durstion: WA @ sim: MR Cpenioghie | | | o 00 o
[Feeacly ko seleck direchories Fles bo mport, | &

/\ IMPORTANT! Expert Settings must only be used by experienced and qualified personnel.

Viz GH Manager El

Changing the settings in this area is really for experts anly!
It may lead to undesired results.

Are you really sure you want to do any modifications in the expert
settings area?

Yes Mo

Expert Settings Properties
Expert settings V-

Mo. of instances: |4 "I stmrtaf‘ta':l 200 .ﬂ.ppl-;.-l

[T sShow instances
Timeout (in sec.): I &00 Appl
[T Overwrite existing files ﬂl

Expert settings: Tick the tick box to enable Expert Settings.
No. of instances: Number of import threads allows to run asynchronously.
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Show instances: Select to show all currently configured import threads.

Overwrite existing files: Select this option before starting the import operation if you want
imported files to overwrite Viz 2.x files on the Graphic Hub.

Restart after: Enter a value representing the number of objects after which the import
executable will restart.

Timeout: If the import executable takes longer than the value specified here, the import
operation will restart.

Import Viz 2.x Data Directories

To Import a Viz 2.x Data Directory

1. Click Server > Import > Viz 2.x data.

2. Select a Viz 2.x data folder to import from, and click Open.

3. In the Import Window select the files to be imported, in the left panel.
—Ikems boimport ————————————

[¢] . flautlet/commonyViz-Data

.. font

B geom

. image

.. material

L. SCEnE

4. Click Import.
Specify import folder {+ additional o il

The data will be imparted inko the Folder shown below,
You must not change the name of this folder as long as wou
wankt ko run external control in 2.x mode.,

| Yiz 2 Modify |

¥ Convert all ohiects to lowercase

W Import external references (if accessible)

K I Zancel |

5. Click Modify and select a directory.

6. Select the Convert all objects to lower case check box. This gives full Viz 3.x compatibility
with Viz Artist and Viz Trio.

7. Click OK.

/\ Note: If the directory is big, the import process can take some time. The import
window show the import status.
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Viz Artist 2.x archive files (x.eva) can be imported into a Viz 3.x system with the Graphic Hub

Manager.

To Import a Viz 2.x Archive or Selected Items

1. Click:

For complete archives: Server > Import > Viz 2.x archive(s)
For selected items from one or more archives: Server > Import > Manually selected Viz

2.x archive(s)

2. Open the selected archive or files:
For complete archives: Select a folder housing archives to import, and click Open.
For selected items from one or more archives: Select an .eva archive file, and click

Open.
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3. Select the required files from the left panel.
—Items toimpork ——————————

¥l fautlet/commonyviz-Data

[¥] . font

[¥].. geom

O image
O material
O scene

4. Click Import.

The data wil be mported into the folder shown below.
foul must not chamge the name of this folder as long as you
want torun external contral in 2,% mode,

I Wiz_2x rlbﬁﬁ'
I Corvert 2l shjects o lawercase
W Import external references (if accessile)

o | concel |

5. Click Modify and select a directory.

/\ IMPORTANT! A warning will show to make sure that it is correct to modify the file.

Viz GH Manager ]

h ATTEMTIOM!
— Viz 2.x data imported to a folder named other than "Viz_2x'
cannot be externally controlled with 2.x mode,
unless you specify a different folder in the appropriate setting

in artist's configuration!

Are you really sure you want to change the name of the impart
folder?

Yes Mo

6. Select, if required:
Convert all objects to lower case check box (this gives full Viz 3.x compatibility with
Viz Artist and Viz Trio).

Import external references (if accessible)
7. Click OK.

/\ Note: If the directory is big, the import process can take some time. The import
window show the import status.
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Resume a Canceled/Crashed Import Operation

If an error occurs and the import procedure crashes, or the import is canceled, it is possible to
resume from where the import ended.

When an import operation does not complete, an import backup file is automatically created. This
backup file is used to resume the import procedure.

/\ Note: As the log file for an import is created on the hard disk of the physical machine, the
import can only be resumed on the machine it has been canceled on.

To Resume a Canceled/Crashed Import Operation

1. Click Server > Import > Resume from canceled or crashed import.
2. Select a backup file to import

3. Click Open.

4. Click Import.

5. Click OK.

/\ Note: If the directory is big, the import process can take some time. The import
window show the import status.

/\ Tip: If resuming from a crashed import, check the selection of files to prevent the
crash from happening again. Also, it is possible to automatically start the import
when resuming, by enabling the Import option in the Preferences window.

1.8 Troubleshooting

This section contains information on the following topics:

Drivers for HASP Runtime Installation Fails
- Troubleshooting Networks and Virtual Adapters
Restoring Corrupted Files
Graphic Hub Manager and Viz Artist Troubleshooting
Replication Troubleshooting
Deploy Troubleshooting
Graphic Hub Terminal Server Startup Issues
Pilot Clients have no database connection
- Troubleshooting Graphic Hub REST
Dongle Troubleshooting
Browser Troubleshooting
List of ports used for Graphic Hub network connectivity
Frequently Asked Questions
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1.8.1 Drivers for HASP Runtime Installation Fails

Installation fails with a warning that says Drivers for HASP runtime cannot be installed.

To start Sentinel HASP License Manager

1. On your Windows desktop, right-click My Computer and select Manage.
The Computer Management window appears.
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In the left panel, expand the node Service and Applications.

Click Services.

In the right panel, right-click Sentinel HASP License Manager and select Start.
Install Graphic Hub again.

uTh WN

1.8.2 Troubleshooting Networks and Virtual Adapters

Some network settings can prevent the Graphic Hub applications from finding other running
Graphic Hub Terminals on the network. To locate a machine which is running the Graphic Hub
Terminal, try pinging that machine. If the host is not reachable across the network, the Graphic
Hub Terminal will not be reachable either.

It is necessary to run Graphic Hub Terminal in a local network where the settings shown below are
identical on every workstation running the terminal application.

/\ IMPORTANT! While the Graphic Hub and/or the Naming Service are running, the server's
network adapter status(es) and IP adress(es) may NOT be changed.

To check network settings

1. On the server machine, go to Start > Run > cmd.
2. In the console, enter ipconfig /all and press Enter.
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Browse to the current connected network adapter.

Check Subnet Mask and Default Gateway.

. Repeat steps 1-3 on the client machine, and see that the Subnet Mask and Default Gateway
are identical between client and server.

v

To solve network and firewall problems

1. Make sure that the client can broadcast to other clients and to the Graphic Hub Server. This
means all firewalls between server and clients need to allow broadcast.
2. Make sure the following port settings for the Graphic Hub Terminal are open to firewall
traffic in between all clients and servers:
- TCP Port
UDP Port
Graphic Hub Server Port
3. Make sure that local firewall applications allow traffic for all Viz products.

Server unreachable in dual network setup

If installed on a server with two network cards, the Graphic Hub will normally be operating on both
networks. However, in certain hardware configurations, Graphic Hub versions 2.4.0, 2.4.1 and
2.4.2 may become unavailable or unresponsive on one of the networks. If this is the case, please
submit a Support Request, making sure to include all the required information.

1.8.3 Restoring Corrupted Files

Any save operation from a client (e.g. Viz Artist) via Viz Engine triggers Graphic Hub to back up the
old file and create a new one. The new file is streamed to the server until the client informs the
server that the operation is complete. After that, Graphic Hub Server deletes the backup file.

A file will be corrupted if Graphic Hub does not get the message from the client indicating that the
save operation is done. For example, this can occur if the client application crashes during the
save operation.

To restore corrupted files

1. In Graphic Hub Manager, log into the server where the corrupted file is located.

2. Perform a search with filters in the Journal Panel for Alert numbers 810 and 910.

3. Browse through all the results and click the P button in the Details panel.
If a file has been corrupted, you will be prompted to restore it.

4. Click Restore.

Repeat steps 3 and 4 until all corrupted files have been restored.

6. To make sure that the file has been completely restored, you can do a search to check that
the restored file’s checksum is not o.

(9]

See also

Import external images
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1.8.4 Graphic Hub Manager and Viz Artist Troubleshooting

This page contains the following topics:

- Viz Artist Does Not Respond
- To restore a locked or corrupt file after Viz Artist stopped responding
Graphic Hub Manager and/or Viz Artist Cannot Find Servers
Solution
Graphic Hub Manager or Viz Artist Does Not React In Server Tree

Viz Artist Does Not Respond

If Viz Artist stops responding, files that were open keep their locks. Graphic Hub usually releases
the session within a certain interval, but you should check if Viz Artist is responding to the session
release attempt.

To restore a locked or corrupt file after Viz Artist stopped responding

1. In Graphic Hub Manager, log into the server where the corrupted file is located.

2. Check the Active Session to see how long it takes for the server to clean up the session.

3. Check the Application Name and IP address in the Server information's Active Sessions
window.

4. Once all processes are complete, all related files are unlocked and checked in, and you can
continue with Restoring Corrupted Files.

Graphic Hub Manager and/or Viz Artist Cannot Find Servers

When searching for servers, the system cannot detect any.

Solution

1. Disable all network blocking applications, like firewalls, anti-virus software, VPNs, virtual
network adapters, etc.

2. Ask your system administrator to open necessary ports on the company’s firewall between
the Graphic Hub Server, Graphic Hub Manager and/or Viz Artist.

Graphic Hub Manager or Viz Artist Does Not React In Server Tree

Sometimes you cannot get into the server tree. This is mostly due to a lost server connection. If
you suspect the server connection is lost, a good first step is to click around the server tree. If it
does not update, exit the application and log back in.

See Also

- Troubleshooting Networks and Virtual Adapters
Replication Troubleshooting
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1.8.5 Replication Troubleshooting

Most problems with replications can be solved by having a stable network environment. This
means that applications which are causing drag on network performance, like global network
updates or global virus scans, should not be performed in a replication environment.

To prevent data loss or conflicts between the main and replication servers, the server checks the
network card for timeouts. If the timeout is too long, the server shuts down.

This page contains information on the following topics:

Main Server is Not Available
To solve cluster timeouts
Cluster Not Up and Running
To restore a healthy cluster environment
Cluster Configuration on Graphic Hub Terminal
To refresh the connection settings
- Journal Log Flooded with Replication Error Messages
To synchronize data directories
Both Main and Replication Servers have Open Transactions
Both running as main Shutdown Error
Port already used Startup Error

Main Server is Not Available

The main server often shuts down because network connections become unavailable. If this is a
common occurrence, perform the procedure below.

To solve cluster timeouts

1. Open Graphic Hub Terminal and open the Advanced Settings.
2. Configure the Additional Advanced Settings for Cluster Configurations, enabling the timeout
settings and setting the cluster timeout to a higher value.

/\ Caution: Consult a Vizrt CA professional before enabling this functionality.

Cluster Not Up and Running
A server can become unavailable due to hardware problems, network problems, and so on.

To restore a healthy cluster environment

1. Open Graphic Hub Terminal on one of the cluster servers.
2. Check the status field. If the status does not say Cluster is up and running, start the
server(s) that is shut down.

Copyright © 2018 Vizrt Page 167



Graphic Hub Administrator Guide - 3.2

3. Wait until the server resumes its former role. If it was the main server, this may take some
time while all open transactions are deployed and the server switches back to its original
state.

4. The status field should now state Cluster is up and running, and Open transactions should
be o.

5. Open the Graphic Hub Manager and Detect and solve server differences.

Cluster Configuration on Graphic Hub Terminal

In Graphic Hub Terminal, the message You are already connected to a cluster appears, even
though the other server in the cluster is not running anymore. Graphic Hub Terminal has most
likely not received an automatic update from the other Terminal.

To refresh the connection settings

1. In Graphic Hub Terminal, click Refresh.

2. Start the cluster. If it still does not work, exit Graphic Hub Terminal and restart it. To start or
stop the Graphic Hub Terminal, use the Start Terminal Service and Stop Terminal Service
shortcuts located in the Start menu’s Vizrt folder, or by using the Windows Service Control
Manager.

Journal Log Flooded with Replication Error Messages

This may occur if your data directories are not properly synchronized.

To synchronize data directories

Shut down the replication server (see Graphic Hub Shut Down).

Back up, then delete the replication server’s data directory.

Shut down the main server.

Copy the main server’s data directory to the replication server’s (now empty) directory.
Start up the replication server.

Check the Journal for error messages.

ooV h WN —

Both Main and Replication Servers have Open Transactions

1. Open the Graphic Hub Terminal and start the main and replication servers. The Terminal will
detect if both have open transactions when the second server starts, and present a dialog
where the transactions can be backed up or deleted. Select backup or delete. The Terminal
will then try to restart.

2. If the above does not work, rename the VizDbRecover directory inside the data directory on
the server that has the least number of open transactions.

/\ Caution: The server must not be running while renaming the directory!

3. Start both servers.

4. Wait until both servers report no open transactions, has switched back to real time
replication status, and returned to their original modes.

5. Bring servers in sync again using the Graphic Hub Manager server differences tool.
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Both running as main Shutdown Error

When a running main server shuts down with this message when starting the replication server,
the problem may be caused by the replication server being unable to reach the main server, even
though the main server is able to reach the replication server.

1.
2.
3.

Check that both servers can reach each other on the network.
Check the network environment.
Try to log in from replication/main to the other machine using Graphic Hub Manager.

Port already used Startup Error

1.

2.

3.

Open Task Manager (Start > Run > Task Manager) and check if vizGHNamingService.exe or
VizGH.exe is running.

Restart the Terminal service using the Stop and Start Terminal Service shortcuts from Start >
Vizrt > Graphic Hub.

If still not working check for conhost.exe or cmd.exe processes and terminate them. These
are the console processes that can linger in some cases and keep ports bound.

1.8.6 Deploy Troubleshooting

This page contains information on the following topics:

DDC Data Does Not Transfer Correctly
Deploy Agent Does Not Transfer All Data
Deploy Agent Does Not Run

- To maintain the Deploy Agent service
Deploy Task Runs for Too Long

- To release a hanging deploy task
Deploy Task Floods Journal with Corrupt File Detected Message
Some files cannot be processed Deploy Task Error
Deploy Agent Service Cannot be Started During Installation
Deploy Agent Service Cannot be Started After Installation
Deploy Agent is Not Reachable from Graphic Hub Manager
Real-time Deploy Task Does Not Start

DDC Data Does Not Transfer Correctly

DDC data may not be transferred correctly in the following cases, which are also visible in the DDC
Action Log:

- The connection between servers is lost
- A file is locked or checked in

In other cases, it is necessary to file a bug report. Make sure that you include the exact error
code and messages.
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Deploy Agent Does Not Transfer All Data

A Deploy Agent task may not transfer all data correctly in the following cases:

A file is locked or checked in.
In other cases, review the unsuccessful task details and check all affected files.

Deploy Agent Does Not Run

To maintain the Deploy Agent service

1.

2.

11.
12.
13.
14.
15.
16.

17.
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Click Start > Vizrt > Graphic Hub > Deploy Agent > Stop Viz GH Deploy Service to stop the

Deploy Agent Service, then Start Viz GH Deploy Service to start the service back up.

On your Windows desktop of the machine where the Deploy Agent is installed, right-click My

Computer and select Manage. The Computer Management window appears:
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In the left panel, expand the node Service and Applications.

Click Services.

In the right panel, right-click GH Deploy Agent and select Properties.

Click the General tab and then click the Start button.

If the Deploy Agent service still does not run, continue with the following steps.
Click the Log On tab.

Click the This account radio button.

Click Browse.

In the field Enter the object name to select, enter Administrator and click OK.
Enter and confirm the valid password for Administrator.

Click OK.

Start the Graphic Hub Deploy Agent again.

If it still does not run, make sure the Deploy Agents have been stopped.
Browse to the Deploy Agent directory and delete the folder Open Tasks and the
deployagent.cfg file.

Start the Graphic Hub Deploy Agent again.
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Deploy Task Runs for Too Long

To release a hanging deploy task

1. In Graphic Hub Manager, log into the source server and open the Active Sessions window.
2. Check the Graphic Hub Deploy session for locked files.
3. If there are locked files, cancel the affected deploy task. The task should restart on its own.

Deploy Task Floods Journal with Corrupt File Detected Message

If the Deploy Agent encounters corrupted files during operation, it will try to restore these files on
the source server. This will cause the Deploy Agent to log Corrupt file detected to the Journal.

Some files cannot be processed Deploy Task Error

If the Deploy Task fails to start or pauses with an error stating that some files cannot be
processed:

1. Investigate the journals and finished deploy task messages for files with identical names,
but with different UUIDs on the destination server.

Deploy Agent Service Cannot be Started During Installation

Check if Service Control Manager is open and close it.

Deploy Agent Service Cannot be Started After Installation

Use the Service Control Manager to restart the Deploy Agent service. If the service cannot be
restarted this way, contact Vizrt CA.

Deploy Agent is Not Reachable from Graphic Hub Manager

- Check all network blocking applications, such as firewalls, anti-virus software, VPNs, virtual
network adapters, etc.
Request from the system administrator that necessary ports on the company’s firewall are
opened. Refer to the List of ports used for Graphic Hub network connectivity.

Real-time Deploy Task Does Not Start

- Check the target server for duplicate folders and projects with identical names with different
UuIDS.
- Check if there are non-UTF-8 characters in folder or project names.
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1.8.7 Graphic Hub Terminal Server Startup Issues

Graphic Hub Terminal Does Not Start the Server

This may occur if Graphic Hub is installed as a service but not started as a service.

To start Graphic Hub as a service

1. Exit Graphic Hub Terminal.
2. Wait until Graphic Hub Terminal starts itself automatically.

Graphic Hub Terminal Service Does Not Start

To start the Graphic Hub service

1. On your Windows desktop of the machine where the Deploy Agent is installed, right-click My
Computer and select Manage.

The Computer Management window appears.
:"J. M B Een Eetama delp [T
= mmEgEmE Fa ] -

Scnbiee | HES Lianes Fansyer R Farmanm Hedon by s Loy o
‘;;Pln wr By TeEtarmg,. Thmcas rabnrode P IR AT
-.Inn-'l‘.jv-r*- At Vi o Wl S PLITILTN IR IS Lo sl
L e AR Enbrink "rovar et Hiae abarote P —
Aol Srap: rrsdzegan... cadan vi, Ll
Twerirn Ly 170 CR— Yam enl Ry
o= Suet .'.","_.'_:,M' s by safial Aty Avuo Aulu IR Haes AT T TarE L Emien
R vnis ncwen Connacion Maroager Creshes L., TimeEs Vamw ey,
AP erots Cuokiog Mk Serean Manag F e Loma St
EnRievate Proscecu Ol FFC) takoruti Uit 5
Rarcts Procechow Cal (APC] Lacalor wama “dabac 5
%Rev ot Ry i Loaz
RaRevcvebis Forags amn Lewn Satew
SR LG e Poreols S E s
JaR T M Tl Sarvien R TH oenl Tt
'E 23l v i r—pr—e . T PLE SRk -
Eywweroriary | nopn RETCT faborue P
'ﬂ;}l.'l..':_n Al e = an 1
i;"ﬂ v ek ' L
rmaiand AL Luvac B g Etee  Mes Lond i
Enunrrar Tommmeme .. Temews fnberoll FroE—
L st s Emien
ol (Lrhusrs Nustaction, L L R T Y rnl i
At Land Fiatagas a... FrTeT IE .
T Dy arde Tmummg-g Va- m o A
Fhathna aezez Ll St
Fonorasntes: Ervdouind, Frotedion Sgezmre,, Dimecas taboruic Lparnl ey, v
4 F ez A Smes 7

2. In the left panel, expand the node Service and Applications.

3. Click Services.

4. In the right panel, right-click GH Terminal Service Properties and select Start.

5. Wait for the Graphic Hub Terminal to start up. If this does not occur, contact Vizrt CA.

1.8.8 Pilot Clients have no database connection

. Check if Graphic Hub REST is running and configured.

. Check if the Graphic Hub is Running.

. Check all network blocking applications, such as firewalls, anti-virus software, VPNs, virtual
network adapters, etc.

wnN ==
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4. Request from the system administrator that necessary ports on the company’s firewall are
opened. Refer to the List of ports used for Graphic Hub network connectivity.

1.8.9 Troubleshooting Graphic Hub REST

This page contains the following topics:

Service cannot be started during installation

Service cannot be started after installation

REST is not reachable or REST cannot connect to Graphic Hub
REST is returning unexpected Data

REST is unresponsive to requests or requests are timing out

/\ Tip: If having trouble with the configuration page, please try to upgrade the web browser.
For optimal performance, the Chrome browser is recommended.

Service cannot be started during installation

Check if Service Control Manager is open. If it is, close it.

Service cannot be started after installation

If the REST agent is installed on a machine that is already hosting an application on port 80,
the agent fails to startup and terminates. To fix this issue, manually change the port in the
Web Server Configuration Settings. The GH REST web server configuration file can be found
in the REST agent installation directory at .\config\rest.conf. After changing the value of
server.port = [new_port], open the configuration page http://127.0.0.1: [new_port]/
config.html to configure Graphic Hub REST.

If the standard browser login appears, please close it. Click logout and login with your
Graphic Hub administrator account. Check the user name and password (case sensitive)
through a login to your configured Graphic Hub via Graphic Hub REST.

Use the Service Control Manager to restart the REST service. If the service cannot be
restarted this way, contact Vizrt CA.

REST is not reachable or REST cannot connect to Graphic Hub

- Check all network blocking applications, such as firewalls, anti-virus software, VPNs, virtual
network adapters, etc.

Request from the system administrator that necessary ports on the company’s firewall are
opened. Refer to the List of ports used for Graphic Hub network connectivity.

REST is returning unexpected Data
1. Open the REST configuration page.
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2. Check which Graphic Hub server the REST service is bound to. If REST is bound to the wrong
Graphic Hub server, change the binding.

REST is unresponsive to requests or requests are timing out

Use the Service Control Manager to restart the REST service.

1.8.10 Dongle Troubleshooting

Apparently Valid Dongle/License Does Not Work

- Close all time-sync programs, like NTP

- Shut down your anti-virus applications
Make sure your dongle is properly connected and the HASP driver is installed and running.
See Drivers for HASP Runtime Installation Fails.

General Viz Artist and Graphic Hub Dongle Issues

- A Viz Artist dongle does not work with Graphic Hub.

- A Graphic Hub dongle does not work with Viz Artist.
Make sure you have only one Viz dongle connected to a machine running Viz applications.
5/4 Free and Localhost modes can operate without a dongle.

1.8.11 Browser Troubleshooting

This page contains information on the following topics:

Safari with authentication enabled on Windows
Internet Explorer issues with default security settings
Internet Explorer IP issues with default security settings

Safari with authentication enabled on Windows

Safari on Windows cannot be used for cluster configurations with authentication enabled on
Windows. This is because Safari since version 5.1.7 does not support the Access-Control-Expose-
Header, which is required for the Web Interface to access the Authentication header. Authentication
is solely handled by the GUI itself, without the browser being involved.

As development of Safari on Windows has been discontinued by Apple, a newer version will not be
available anytime soon.

Internet Explorer issues with default security settings

The Web Interface has issues with cross-origin HTTP requests (CORS) to multiple hosts when using
the default security settings.
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Known issues:

- GH Terminal does not show information of the partner server of a cluster configuration,
because the Web-Ul is not able to retrieve the status of the partner server and therefore
reporting it as ‘not reachable’ or 'Unable to connect to Graphic Hub Terminal on host XXX:
19399".

- GH REST reports the GH status as ‘not reachable’ or 'Unable to connect to Graphic Hub
Terminal on host XXX:19399"

- GH ImEx Agent is unable to show proper status of configured GH RESTs.

For most cases, enabling Access data sources across domains should resolve the issue:

p—

. In Internet Explorer, click Tools and then click Internet Options.

. In the Internet Options dialog box, on the Security tab, click Custom Level.

. In the Security Settings dialog box, do the following:
a. Select Enable for Miscellaneous > Access data sources across domains.
b. Click OK.

4. In the Confirmation dialog box, click Yes.

w N

This needs to be done for both the Internet and Local intranet zone. Internet Explorer will always
use the settings of the Internet zone if a site is opened using an IP address no matter if the site is
actually a local one or not!

Internet Explorer IP issues with default security settings

If the Web-Ul is opened using the IP address and the requests are based on hostnames, then this
violates Zone Policies.

The reason is the Cross-Domain and Zone Policy (see https://msdn.microsoft.com/en-us/library/
ms537505(v=vs.85).aspx#xdomain), which blocks cross-origin HTTP requests (CORS) requests to a
different host using a hostname, while the Web-Ul is opened with an IP address as these requests
violate the Zone Policy settings.

Known issues:

In GH Terminal when the Web-Ul is opened with IP, but the loaded cluster configuration is
based on hostnames, then the status is ‘not reachable’ or 'Unable to connect to Graphic Hub
Terminal on host XXX:19399".

A workaround for this issue is to add the Web-UI URL to the Trusted Sites:

1. In the Internet Options dialog box, on the Security tab, select Trusted sites.

2. Click Sites.

3. Disable Require server verification (https:) for all sites in this zone and click Add.
4. Click Close.

Make sure Miscellaneous > Access data sources across domains is also set to Enabled for the
Trusted Sites zone.

1.8.12 List of ports used for Graphic Hub network connectivity

Since Graphic Hub 3, the server requires a limited number of open network ports. The following
table lists the ports used for Graphic Hub server connectivity:
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Port Number Protocol Used for

427 TCP, UDP OpenSLP

19390 TCP ImEx Agent (HTTP)
19391 TCP, UDP Deploy Agent High Availability
19392 ubDP Deploy Agent

19393 TCP Deploy Agent

19394 UDP Manager for Terminal 2
19395 TCP Terminal 2

19396 TCP, UDP Naming service

19397 TCP, UDP Graphic Hub

19398 TCP REST (HTTP)

19399 TCP Terminal 3 (HTTP)
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Since GH Deploy Agent 2, Graphic Hub Manager 5, GH REST 2, and Viz Artist 3.8.2, these clients
do not require any port exemption rules on the client side firewall configuration. However, for
earlier versions, all ports must be open on the client side.

1.8.13 Frequently Asked Questions

- Question: Can a Graphic Hub Deploy Agent deploy outside local network boundaries, for

example, different subnets and gateways?
- Answer: Yes. Log Graphic Hub Manager on with the IP address instead of the host
name. Then schedule a deploy task.
- Question: Can a replication cluster work outside local network boundaries, if the main and
replication servers are not in the same local network?
- Answer: No. Use the Deploy Agent instead.
- Question: Can | share a single data directory over multiple servers?
- Answer: No.

- Question: Can deleting or creating files within a data directory solve problems?

- Answer: No.
- Question: Can | do a backup of the data directory while the server is still running?
- Answer: No. The server must be shut down before copying the data directory.

- Question: Can a localhost database be accessed from another machine?
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Answer: From Viz Artist, no. A single-user database is only available on the machine it
runs on.

Question: Do all Graphic Hub Naming Services on the network contain information about all

servers? Why is there a need for more than one Naming Service on the network?
Answer: A Graphic Hub Naming Service only contains information about the servers
that have been applied to it. Before a Graphic Hub Server is started, a Graphic Hub
Naming Service must be applied to it. Either a local Naming Service that is started
together with the server can be applied, or another available Naming Service in the
network is applied. A server cannot be started without connecting to a running
Naming Service.

Question: Can | terminate the VizDb.exe process?
Answer: No, never. Only use Graphic Hub Terminal or Graphic Hub Manager to shut
down a server.

Question: Can | shut down Windows while VizDb.exe is still running?
Answer: No. Use Graphic Hub Terminal or Graphic Hub Manager to shut down a server
before exiting Windows.

Question: Why is the content of the selected folder not listed in the Graphic Hub Manager’s

File panel?
Answer: First, make sure that the selected folder contains files. Next, make sure that
All or the correct file type is selected from the Show drop-down list in the Toolbar.
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2 Graphic Hub Deploy Agent

The method to copy and synchronize a database is the Direct Deploy Copy (DDC) functionality.

The Graphic Hub deploy solution makes it possible to copy folders/projects/files with all necessary
data (referenced folders/projects/files) and all Pilot data from one server to another. For example,
if a scene is to be deployed, all files that are referenced by this scene (images, materials, and so
on) will also be deployed.

The Deploy Agent enables the configuration of scheduled deploy tasks, and is run from the
Graphic Hub Manager.

This section contains information on the following topics:

Deploy Agent Modes
Deploy Agent Properties
Rebuild Original Structure
- Copy to Target Folder Only
- Schedule a Deploy Task
Maintain Deploy Agents and Tasks

2.1 Deploy Agent Modes
The Deploy Agent supports two modes:

- Standard Mode: Creates only folders on the destination server which contain files that have
to be copied by the task. This mode ensures that the folders on the source and destination
servers have the same UUID if possible. l.e. folders outside of the original structure which
contain references and/or folder links of files inside the structure have new UUIDs assigned
if their original UUIDs are present on the destination server.

Direct Deploy Copy Mode: Also creates only folders on the destination server which contain
files that have to be copied by the task. This mode ignores the UUID of folders and makes
sure that all folders have the correct name in the structure

This page contains the following topics:

- Standard Mode Supported Options

Direct Deploy Copy Mode Supported Options
- Additional Information on Data Modes
- Standard and DDC Supported Options

2.1.1 Standard Mode Supported Options

The standard mode supports these options:
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Schedule
Options

Data Mode
Options

Real-time
Options

Time Steered
Options

User Triggered
Options
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Supported Item

Real-time
Time steered
User triggered

Folder based (Only a single folder can be selected per task)

File based: in ‘Copy to target folder only’ mode (Multiple files can be selected
per task, folders are not allowed)

Search criteria based: in ‘Copy to target folder only’ mode (Copies all files that
result from executing the search criteria, folders are ignored)

Rebuild original structure

Rebuild structure under target folder

Support for: Removal of deleted objects on target server(s), Synchronization
users, groups, keywords, add-on templates, etc.

Copy to target folder only
Rebuild original structure
Rebuild structure under target folder

Copy to target folder only
Rebuild original structure
Rebuild structure under target folder

2.1.2 Direct Deploy Copy Mode Supported Options
The Direct Deploy Copy Mode (DDC) mode supported these options:

/\ Note: Real-time is not supported in this mode.

Options

Schedule Options

Supported Item

Time steered
User triggered

Data Mode Options  Folder based (Only a single folder can be selected per task)

Time Steered
Options

File based (Multiple files can be selected per task, folders are not allowed)
Search criteria based (Copies all files that result from executing the search
criteria, folders are ignored)

Copy to target folder only
Rebuild original structure
Rebuild structure under target folder
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Options Supported Item
User Triggered Copy to target folder only
Options Rebuild original structure

Rebuild structure under target folder

2.1.3 Additional Information on Data Modes

File based: The task will not be able to execute if the objects to deploy contain folders
- Search criteria based: The task will ignore all folders that are contained in the result of the
search.

2.1.4 Standard and DDC Supported Options

Data Mode Options Standard DDC
Mode Mode
Folder based  Copy to target folder only X X X X
Rebuild original structure X X X X X
Rebuild structure under X X X X X

target folder

File based Copy to target folder only X X X X
Rebuild original structure X X
Rebuild structure under X X

target folder

Search criteria Copy to target folder only X X X X
based
Rebuild original structure X X
Rebuild structure under X X

target folder
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Data Mode Options Standard DDC
Mode Mode
X = Supported Options Real-time Ti Us Realtime Ti Us
m er m er
e tri e tri
st g st g
ee ge ee ge
re re re re
d d d d
Scheduling

2.2 Deploy Agent Properties

The Deploy Agent properties panel shows the properties and configuration settings for the Deploy
agent.

This page contains the following topics and procedures:

Properties of a Deploy Agent
- Configuration Panel
- Version info Panel

High Availability Panel

2.2.1 Properties of a Deploy Agent
To access the properties of a Deploy Agent:

1. Navigate to Tools > Administer tasks > Running deploy tasks to show Running deploy tasks
tab.
2. Right click a Deploy Agent.
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3. Click Properties of deploy agent
‘unning deploy tasks

% [
DEEDI agent $
e ————" i GHMAIN

Pause deploy agent 'GH-MAIN'. ..
Stop deploy agent 'GH-MAIM'. ..

Properties of deploy agent 'GH-MAIN ...

al |

Deploy agent preferences. .. |

1 rivmmina Aamlooe

Statistics Panel

In the Statistics panel, Graphic Hubs currently in use shows Graphic Hubs currently used as Deploy
Agents. These Graphic Hubs are the source servers of one or more deploy tasks. The Graphic Hub
Deploy Agent automatically removes all unused Graphic Hub source servers.

In some cases a Graphic Hub can be lost or cannot be contacted by a Graphic Hub Deploy Agent. If
this happens the add and remove can be done manually.

/\ Note: A Graphic Hub Deploy Agent, which is configured as High Availability Partner
originally, cannot remove or add Graphic Hubs.

To Add a Graphic Hub

(Which is not registered in the Deploy Agent)

1. Open the Properties of Deploy Agent window.
2. Open the Select Graphic Hub to add window.
- Click Add, or
Right click in the Graphic Hubs currently in use box, and click Add.
3. Select a Graphic Hub to be added, from the drop down box.
4. Click OK or Apply.

Note: The added Graphic Hub status will be ‘to be added’ until OK or Apply has been
clicked (when not highlighted, the ‘to be added’ Graphic Hub will show purple).
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/\ Note: If an added Graphic Hub does not contain a valid task for the current Graphic
Hub Deploy Agent, the Graphic Hub will be automatically removed again. It is not
possible to add or remove multiple Graphic Hubs at once.

= Statistics .

—General

Started at: 9/8/2016 3:56:29 PM
Rurning since: 4m, 475

— Tasks

Mo. of tasks executed since start: 1
Successfully processed: 0 files with 0.00 KB
Unsuccessfully processed: Ofiles with 0.00 KB

— Memary Diske
Total: 800GB Tatal: 58.00GE
Free: 6.06 GB Used: 36.36 GB
zed: 1594 GB Free: 2163 GE
Used %: 2428 % Free % 3730%
— Wiz Graphic Hubs cumently in use
Server | MamingService | Status | TCP part |
VizDbServer GHSERVER in use 19396
Hemowe Add...

To Remove a Graphic Hub

1. Open the Properties of Deploy Agent window.
2. Click the Graphic Hub to be removed.
3. Remove the Graphic Hub:

Click Remove, or
Right click the selected Graphic Hub and click Remove selected from the context

menu.

4. Click OK or Apply.

/\ Note: The selected Graphic Hub status will be ‘to be removed’ until OK or Apply has
been clicked (when not highlighted, the ‘to be removed’ Graphic Hub will show red).

/\ Note: If a Graphic Hub to be removed contains any running tasks, the remove will not
be successful. Either click Cancel or undo the change via the context menu. If a
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removed Graphic Hub is not reachable by Graphic Hub Deploy Agent, a message will
displayed where it is possible to select a forced remove or cancel the action. It is not
possible to add or remove multiple Graphic Hubs at once.

/=~ Statistics

—(General
Started at: 9/8/2016 3:56:27 PM

Rurning since: 6m, 3s

~ Tasks
MNo. of tasks executed since start: 1
Successfully processed: [files with 0.00 KB

Unsuccessfully processed: 0 files with 0.00 KB

— Memory Diskc
Total: 8.00 GB Total: h8.00GB
Free: 6.06 GB |Used: JE3I6GE
|Jsed: 1.53 GB Free: 2163GB
Used % 2419 % Free % 3730%
— Wiz Graphic Hubs cumenthy in use
Server MamingService Status TEE
Hemowve Add...
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2.2.2 Configuration Panel

Bt Properties of Deploy Agent 'GHEERVER' x
B2 Statistics 5 Configuration
Canfiguration _ . o .

o r iy Logging of additional/advanced runtime information

=]

High availability Log additional information to EventLog
[ Log additional information to journal on dedicated Log-Server

Deploy agent work, dirgctany
Folder: | C:\FrogramD atahvizithiiz GH Deploy Agent

Timeouts and Tranzfer buffer settings

E stablizhing communication timeout [in secondsz] ;

Communication round tip timeout [in seconds);

Cluster failover timeout [in seconds];

=[] —
[ R =]

Transfer buffer zize: [1.000.00 KB

=
[}
4]k

Defaultz

E=pert settings

Ma. of attempts ta reconnect b Yiz Graphic Hubs:

—_
L ) e

Time [in secondz] between attempts to reconnect; 3

[ Do 'emergency’ pausing of realtime tasks
if 0% of all objects or if 0 objects
would be deleted on any destination server

[JUsze original DDC behavior
[] Do nat averwrite if destination file is newer Defaults

Communication ports

TCF part: 19353 IDP port: 19352 Defaultz
Cancel Apply

Logging of additional/advanced runtime information:
Log additional information to EventLog: Configures the Deploy Agent to log warnings
and errors to the event log of the source server of the task that caused the issues.
Log additional information to journal on dedicated Log-Server: Configures the Deploy
Agent to log warnings and errors of all tasks to the event log of a specified server.
Deploy agent work directory:
Folder: Shows where the Deploy Agent keeps its configuration file and temporary data.
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Timeouts (related to communication with Graphic Hubs): Changing the values of the timeout
settings may have a significant impact on how Deploy Agent works. The default values have
been tested in a LAN setting as well as for long range deploy tasks and should only be
changed if the Deploy Agent has problems with servers that are connected via a slow /
congested network or have a high server load. Increasing the timeout values may solve the
problems in this case, decreasing will not improve the general performance of the agent and
is not recommended.
Establishing communication timeout (in seconds): Specifies the maximum amount of
time for a Deploy Agent is allowed to connect to a server. If the server does not
respond in this period due to network characteristics or server load, it will be
considered as offline.
Communication round trip timeout (in seconds): Specifies the maximum amount of
time for the Deploy Agent to wait for a reply from the server. If the server does not
respond in this period due to network characteristics or server load, the affected task
may be paused by the agent.
Cluster failover timeout (in seconds): This option is relevant for agents that operate in
a setting with a failover server. If a main server becomes unavailable, this timeout
specifies the period that a task is waiting for a notification from the failover server to
switch over. If this time exceeds, the agent will manually try to connect to the failover
server.
Transfer Buffer Size: Adjusts the buffer size used by the Deploy Agent for
communicating with the Graphic Hub.
Expert settings:
- No. of attempts to reconnect to Graphic Hubs: Set the number of times the agent is to
attempt to connect to Graphic Hubs
Time (in seconds) between attempts to reconnect: Set the time between each attempt
to reconnect to Graphic Hubs
Do emergency pausing of real-time tasks: Click in the box to do emergency pausing of
real-time tasks. Set the % of all objects or the number of objects.
Use original DDC behavior for non real-time tasks: This option is set globally for the
Deploy Agent and affects all tasks. The major difference to the normal mode is that
the “deploy under target folder” restriction of having no folder on source and
destination that has the same UUID but an incompatible path does not apply. If the
Deploy Agent discovers a folder with the same UUID but different path, a new folder
with a new UUID is created in the expected path. This feature has a significant impact
on the performance of the Deploy Agent, and should be chosen wisely as it will affect
all non-real-time tasks that are executed by the agent
Do not overwrite if destination file is newer: If set, the file on the destination server
will not be overwritten, if it has a modification date/time newer than the source file.
The default setting (=option is not checked) will always overwrite the file with the
source-file.
Communications ports:
TCP port: Sets the TCP port number.
UDP port: Sets the UDP port number.
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2.2.3 Version info Panel
The Version info panel shows the version information for:

- The Deploy Agent
- The Tasks scheduler
- The Graphic Hub interface

¥ Version info

— Deploy agent (VizGHDeployAgent Service exe)
Version: 2.0.0.60132

— Tasks scheduler (vdbSchedulerU dli)
Version: 2.0.0.60132

Wiz GH Inteface (MizDhbl.dll)
Version: 3.0.0.60132

2.2.4 High Availability Panel

When a new High Availability Partner is configured, the configuration of these values will
automatically transfer to the High Availability Partner:

- Timeouts:
Establishing communication timeout (in seconds)
- Communication round trip timeout (in seconds)
- Cluster failover timeout (in seconds)
Expert settings:
Do emergency pausing of real time tasks
Use the original DDC behavior for non real time tasks.

/\ IMPORTANT! When disabling the High Availability partner, the configuration values
return to their default values.

/\ Note: Since Deploy Agent version 1.4.1, it is possible to configure high availability
partners using host names or IP addresses.
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— v Configure high availability partner —

2=Nias Sl (o deploy agent configured yet

TCP port: I 15391 Set defaul |

[T Usze [F address instead of host name

Attention:
Please select a partner deploy agent.

To Configure a High Availability Partner

p—

. Click in the Configure high availability partner check box.
. Select the Deploy agent from the Partner drop down box.
Click the Use IP address instead of host name box, if required.

w N

/\ Note: If the High Availability partner configuration is set to use IP addresses, the
clients need to have static IP addresses.

4. Click OK or Apply.

2.3 Rebuild Original Structure

This page details how to rebuild a database structure.

- Create a New File Based Deploy Task
Behavior

2.3.1 Create a New File Based Deploy Task

The Options panel shows a deploy task configuration where folder B of Server 1 is deployed to
folder U of Server 2.
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»" Options

— Source server

VizDbServer@GHSERVER
— Tanget servers (check the onels) you wish to deploy tol)
Id | MName | Type | Version | Free disk space |
.. GHMain5erver@GH-MAIN Main 300.. 2163 GE
Tiap | [ | [amwr I E-:uttu:uml
— Behavior options

IHel:uuilu:I structure under target folder j IU

¥ Owerwrite existing objects {Does not apply to referenced objects)
W Overwrte existing references
¥ Keep original owner

— Multi-server processing options
" Parllel
¥ Deploy 2l files to the first server, then to the second, and o on

™ Deploy one file to all servers, then ancther file, and so on

The Options panel offers various settings to configure the deploy task:

Behavior options:
Rebuild original structure: The original folder structure and any folder links for the
selected folder or project will be recreated at the root level of the target server,
including any parent folders. The selected folder or project will be rebuilt including all
sub-folders, sub-projects and objects contained therein.
Rebuild structure under target folder: The original folder structure will be recreated
using the target folder as root level.
Copy to target folder only: Recursively copies files only from the selected source folder
to the selected target folder. See also Copy to Target Folder Only.
Overwrite existing objects: If there is a file in folder [B] or any of its sub-folders and
the same file exists on the destination server (a file with the same UUID), then the file
will be overwritten on the destination if the content is different.
Overwrite existing references: If there is a file [F] in folder [B] or any of its sub-folders
with a reference to file R and file R exists on the destination server (a file with the
same UUID), then file R will be overwritten on the destination if the content is
different.
Keep original owner: If there is a file in folder [B] or any of its sub-folders and the
same file exists on the destination server (a file with the same UUID), then the owner
of the destination file won’t be changed if it differs from the source file.

Multi-server Processing options:
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Parallel: If multiple destinations are selected, the destinations will be synchronized in

parallel.

Deploy all files to first server, then to the second, and so on: If multiple destinations

are selected, the destinations will be fully synchronized one at a time.

Deploy one file to all servers, then another file, and so on: If multiple destinations are

selected, missing files will be copied to all destinations one at a time.

The Schedule panel shows the settings that are available to schedule the new deploy

task.

Apart from the general settings, Rebuild original structure/ Rebuild Structure Under Target Folder
tasks also support the deletion of files on the target server. Files will only be deleted if they are

removed from the source folder [B] or any of its sub-folders and the file also exists on the

destination server in folder [U] or any of its sub-folders. If the file on the destination also has
folder links outside folder U, then only the folder links inside the target structure are removed.

— Deploy agent (Choose the ane which should execute the task!)
Deploy agent: |GH-MAIN v|  Refresh
Version: 2.0.060132 Deploy behavior: Standard

— Task {Give it a name and a meaningful description!)

MName: IDEpl-:r'_.r Task 2

Description:

¥ Schedule this task

— Schedule (Specify when this task should be performed)

Mode: I Recuming forever j
Start at: | 9/ 872016 418:00Pm ¥| Endafter forver =]
 Each | 1 |dayE) =l
% Realtime
— Realtime options
[T Remove deleted objects on target servenls) as well
Synchronize
™ Users and groups ™| Object bypes
™| Keywords [T Alerts
[ Wiz VR Studio setups [T iz user settings

[T Add-onz (lemplates]

Synchronize options are not available, because onby ‘data’ under root must be in objects!

Deploy agent: Select the Deploy Agent to be used. The version number and deploy mode of

the selected Deploy Agent is shown below the drop down box.
Task: Enter a name and description for the new deploy task.
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Schedule this task: Click to enable or disable the Schedule field.

Schedule: Create a schedule for the new deploy task:
Mode: Select either, Once, Recurring or Recurring forever
Start at/End after: Options depend on the set Mode. Set the start and finish of a new
deploy task
Each: Select how often the task should start from the drop down box.
Real-time: Click to enable or disable the Real-time options field.

Real-time options:
Remove deleted objects on target server(s) as well: If ticked then not only newly
created files or modified files will be deployed to the target server (Graphic Hub), but
also files that get deleted on the source server (Graphic hub) will also get removed/
deleted on the target server.
Synchronize: Synchronize options can be chosen separately. Check each box as
required.
The Data panel shows that folder [B] will be used as source for the new deploy task.

4] Data
Obiects 1o deplay (Hint: Use drag n'drop 1o add and the context menu to remove them)
Name Sze Type Diate modfied
= Vit Project

2.3.2 Behavior

The image below shows the before and after condition of the deploy task.
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/'L:I‘E:g Servers and fnlders\(:x A Search\
= W) 1 - vizDbServeri@iEHSERYER Admin)
B w data
B - A
- b
-
= B8 2 - vizDbServer L@GHSERYER 1{Admin)
B w data
—
-
i

Bz

Servers and folders w [

/U‘E'g servers and fnlders\(:a.-‘.‘ Search\
= W 1 - VizDbServer@GHSERYER  Adrmin
B & data
=N

| — R

- C
= B 2 - VizDbServer L@EHSERVER 1{Adrmin]
= & data
B - U
E - A
R
[
-
- Y

—

To create a consistent deployment, not only folder B and its sub-folders but the whole relevant
folder structure of the source server is created under the target folder on the destination server.
This means that there must not exist any folder or project on either server, apart from already
synchronized folders with the correct path. The deploy task will go out of sync if such a
configuration is discovered. This restriction does not apply to files, but one needs to pay attention
that content of files outside the target structure may be changed by this task by this task.

The image, below, shows an example deployment of the same deploy task setup as described
before, but the option Use original DDC behavior for non-real-time tasks has been enabled and the
schedule has been changed from real-time to a recurring task (see Expert settings in the
Configuration Panel).
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= = AR
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This has the effect that only folders that are needed for deployment will be created, in this case
the task creates all folders on the path to folder [B] and additionally folder [C] as it contains either

a reference or a folder link from a file that is deployed. Folders [AB] and [ABC] are skipped and not
deployed to the destination server. Furthermore, folder [X] on the destination server already

contained folders LAA, [A] and B, which means that the Deploy Agent had to create new folders

with new UUIDs under folder [U].
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() Changed in Viz GH Deploy Agent 2.1.0:

This behavior now also applies to deploy tasks using standard mode. In contrast to DDC
mode, UUIDs of folders are retained if no clash occurs.

2.4 Copy To Target Folder Only

The image below shows the settings to deploy a folder from the source server to folder T on the
destination server in Copy to target folder only mode.

 Source server
VizDbServer@GHSERVER

— Target servers (check the onels) you wish to deploy tal)

Id| MName | Type | Version | Free disk space|
.. GHMainServer@GH-MAIMN Main 300.. 2163 GE
Tiop | e} I [Tt | Eh:uttu:uml
— Behavior options
ICup'_.rtD target folder only j IT

¥ (Orvenwrite existing objects (Does not apply to referenced objects)
¥ Overwrite existing references
¥ Keep original owner

— Multi-server processing options
" Parallel
" Deploy all files to the first server, then to the second, and so on

£+ Deploy one file to all servers, then another file, and s0 on

In this case the structure of the source server is ignored and all files from the source folder, and
its sub-folders, are copied directly into folder T.

The image, below, shows that only files were deployed to folder T, and no sub-folders were
created.
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Viz GH Manager

Server View Tools Extra Pilot Info
& | Address:  2:\data\T

Servers and folders LA Rl [Mame T |

/U"E'gien.rers and folders { ) Search\ Eiimage_6
= il 1 - VizDbServer @GHSERVER (Admin) EdImage 5
i data B Image_4
= ;’ LAA “Image_3
- A Bilmage 2
W AB ‘]Image_l
E B 2 - GHMainServer @GH-MAIN(Admin)
B & datz
& Mew_Projectl
i Projectl
0
-

Note: Referenced files outside the source structure will also be deployed into the target
folder. Since there might be files from multiple folders deployed into a single folder, it is
possible that the target folder will contain multiple files with the same name.

2.5 Schedule A Deploy Task

Deploy tasks can be scheduled to run on a regular basis. This is useful to replicate data for
safekeeping on a regular basis.

To run scheduled Deploy Tasks the Viz Deploy Agent must be installed.

/\ IMPORTANT! To configure a scheduled deploy task when the servers or the Deploy Agent
are on different subnets, each server must be logged on to with its IP address, not its host
name. Sign out of all servers and log back on using the servers IP address (see Graphic Hub
Login and Log Out).

2.5.1 To Add a Deploy Agent for Use

/\ IMPORTANT! Deploy Agents not reachable via UDP broadcast and / or for use in Login
profiles need to be added manually.

1. Open Tools > Edit preferences.
2. Navigate to Agents > Deploy.
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3. Press Add.

4.
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'ﬁ!’ Preferences

&® General

«2 Login

w2 Timeouts and buffer
»2 Deploy Direct Copy
w2 Startup

2 Look

= Import

Meonitor servers

w1 Warnings

& Agents

&7 Deploy

o3l Archives

€& General

&4 Import

& Export

a

1 Deploy

Settings to use for searching for running deploy agents
Search for deploy agents on those UDF ports:

193532

=

Uo || Teop
Remove = On. | Bot.

Uge this timeout for receiving answers from deploy agents:

(miliseconds)

Deploy agents not reachable via UDP broadcast

and/or for use in Login profiles:

IP address Name

UDF port  Receive timeout {in E < Add.. i

Intervals {in seconds)

Interval to get updated info for running tasks:
Interval to try to reconnect to Tost’ agents:

IILT‘ II—L [¥]

Remowve =

Modify...

Up || Too
Dn. || Bat.

Set defaults

Aoply

Insert hostname or IP address.
5. Provide UDP port (default: 19392).
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6. Press OK.
$#t Deploy agent x
IP address: | GHSERVER |
UDP part: | 19392 | F Chedk

Receive timeout: (milliseconds)
Transferbuffer size: 1 == (50.00 KE)

Marne: GHSERVER

QK Cancel

Viz GH Manager >

Check successful!

The deploy agent could be contacted.

0K

7. Confirm all open windows.

%t Deploy agent *

IF address: | GHSERVER

UDP port: 19392 Checdk
Receive timeout: (milliseconds)
Transferbuffer size: 1 = | (50.00 KB)

Mame: GHSERVER.

Cancel

The Deploy Agent has been added to current configuration and can be found although not
reachable via UDP broadcast.

2.5.2 To Schedule a Deploy Task

1. In Graphic Hub Manager, log-in to two or more servers.
2. Right-click a folder/project/file in the Servers and Folders panel or Files panel, and then from
the menu that appears, select Create Deploy Task...
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3. Select one or more target servers.

& ootrs

(3] Schedule
8 Data - Sowrce serves 1
GHMainS esver@GH-MAIN |
~ Tasget servers [check the onefs] you wish to deploy tof]
Id| Mame | Type | Version | Free disk zpace |
[ . VeDbSewver®GHSERVER Standard 200 10621 GB
T op ] p I Cr e ] En'-‘rf.'l
- Behavior oplions

Flebwsld onginal shuchse ID 'n'd Folder/Progect from checked Server |
¥ Ovamrite existing obects [Does not apply to referenced objects)

W Ovemwribe sdasting references
W Keep criginal owner

[~ Multi-zerver processing options:
I Pacalsl
% Deploy all fles bo the frst server, then bo the second, and 50 on
™ Deploy one file to o servers, then another fls. and 50 on

QK Lancel
| |

]

4. Select one of the Behavior options:
Rebuild original structure: Copies an exact replicate of all selected folders/projects/
files and its references from source to destination server.
Rebuild structure under target folder: Copies an exact replicate of all selected folders/
projects/files and its references from the source server to the destination folder on
the destination server.

Copy to target folder only: Copies all selected folders/projects/files and its references
from the source server to the destination folder on the destination server.

/\ Tip: For Copy to target folder only and Rebuilt structure under target folder,
you can also drag folders or projects into the field beside the Behavior options
drop down menu.
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& Options «" Options
] Schedue
] Data Souice server
GHManServenEihH -MalN
— Tanget servers [check the one(s) pou wizh to deploy tol]
1d]_Mame | Type | Version | Free disk space
B .. ViDbServer@GHSERVER Standad 3.00.. 10621 GB
oo I Up I [ o I -'_-ﬂ-:-!r':u'nI
~ Behavior oplions

Rebuld shuchue under taget foldes ID'n'd Folder/Project from checked Serve |
¥ Dveswite existing objects [Does not apply Lo referenced objects)
¥ Oweswibe exsting references
W Keep ongnal o
 Multi-zerves processng options
™ Parallel

(+ Deploy all fles bo the first sarver, then bo the second, and 20 on
" Deploy one file to all servers, then another file, and 30 on

| (1]4 I Cancel

P

5. Enable/disable the following Behavior options:
Overwrite existing objects (does not apply to referenced files)
Overwrite existing references
Keep original owner
6. Select one of the following Processing options:
Deploy all files to the first target server, then the next server in the queue, and so on.
Deploy one file to all target servers, then the next file in the queue, and so on.
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7. In the left panel, click Schedule.

£1 Schedule

— Deploy agent [Choose the one which zhould execute the tazkl]

Yerzion: 2.2.0 Deploy behavior: Standard

Deploy agent: IGH-MAIN j Refresh |

— Tazk [Give it a name and a meaningful description!]

Mame; IDED|D_'.-' Tazk 2

Description:

¥ Schedule this task

— Schedule [Specify when this tazk should be performed]

Mode: I Recurring forewer j

Start at: ||35.na.2ma13:25:nn ~| Endater. fforever
C Each | 1 |dayls) =]

£+ Fealtime

— Pilot data options
[T Syne pilot data

— Realtime optiohz
[~ Remove deleted objects on target serverfz] az well

Synchronize

™| Users and groups [T Object wpes
™| Kewwords ™| dlerts

I viz wE Studio setups [T iz user zettings

[T &dd-onz (lemplates]

Syhchronize options are nat available, becauze only 'data’ under raat rust be in objectzl

8. From the Deploy agent drop down box, select a Deploy Agent.

/\ Tip: If you have several Deploy Agents installed on various machines, and you intend
to schedule many tasks, use a different Deploy Agent for each task for the purpose

of load balancing.

9. Name and describe the task in the fields provided.
10. Check the Schedule this task check box.
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11.

12.

13.

14.

15.

16.
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/\ Note: If you uncheck this box, the deploy task will execute right away, rather than
wait for a scheduled time.

From the Mode drop down menu, select one of the following options:
Once.
Recurring.
Recurring forever.

In the Start at drop down menu, click to select a date from the calendar, and if necessary,
adjust the time.

/\ Note: You cannot schedule tasks to begin in the past.

If your mode is Recurring, in the End after drop down menu, click to select a date from the
calendar, and if necessary, adjust the time.
Select one of the following radio button options:
Each: Select an interval.
Realtime: The deploy task will occur every time there is a change in the database. With
this selection, you can optionally Remove deleted objects on the target server as well.

A Note: Real-time tasks cannot be modified later.

In the left panel, click Data and drag any additional folders or files into the right panel, as
necessary.

& oo
& Scheduls
] Data - Oiyects to deploy [Hink Use drag'n'drop to add and the contest menu bo remove themd]

Mame Size | Type Date modified
B Image_6 9. 24KE  IMAGE SYBS20N6 426 PM
B Image_5 N2H4EE  IMAGE QB2NE 425 PM
EBilmage 4 9.24FKE  IMAGE 9/8/2016 426 FM
B Irnage_1 91.24 KB IMAGE Q82006 4:26 PM
B Image_3 .24 KB IMAGE S/BS20N6 4: 26 PM
B Image_2 N HEE  IMAGE SB2NE 426 PM
4] | |

I 14 I Cancel

/\ Caution: Do not drag sub-folders of any folders that are already in the right panel.

/\ Note: You cannot drag files into the right panel for Real-time tasks.

Click OK to create the deploy task.
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2.6 Maintain Deploy Agents And Tasks

This page details the maintenance of Deploy Agents and configured Deploy Tasks in the following
procedures:

- To View Deploy Tasks

- To Modify a Deploy Task

- To Search Scheduled Deploy Tasks
- To Search Finished Deploy Tasks

- To Maintain Deploy Agents

2.6.

1 To View Deploy Tasks

- Click Tools > Administer Tasks > Running deploy tasks
- Click Tools > Administer Tasks > Scheduled deploy tasks
- Click Tools > Administer Tasks > Finished deploy tasks

2.6.

A

1.

2.

All selected deploy tasks are shown in the Journal.

2 To Modify a Deploy Task

Note: Modifications will not affect tasks that are currently running. If you modify such a
task, the changes will only take place at the next interval. Realtime tasks can NOT be
modified.

Make sure you are logged into the source server for which you wish to modify the deploy
task.
Show the deploy tasks in the Journal, in accordance with one of the procedures above.
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3. Right-click the task and select Properties.
The Schedule Deploy Task window is shown.

$1 Schedule

GH-tAIN R

Deploy Tazk 2

Recuing 7]

B/ 852018 2:16:00 PM |_ B/ 752019 2:16:00 PM |_
dayls)

4. Continue to schedule a Deploy Task from step 3 onward.
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2.6.3 To Search Scheduled Deploy Tasks

1. Click Tools > Administer Tasks > Scheduled deploy tasks.
The Journal is enabled for searching scheduled deploy tasks.

Schrdabid deaky tarks
B Aniwe sy deakn Lath: S be o vepd oy Rohs Familend depbny Lasks | 0 Mesiaged K el
Moy oy rihedhilod deploy ki L E :-.- 0 3 Bac il B VLOGH A0 H Msades vl -: " I v :.I:l Dita iy ot hed b copbar Lick, a E
wawE | VimGrapscHUSNIZEH-MOTHE Ry = | D4pky sgard Hara Chrar Pamack Tiggareine-fai]|  merd
Cowuia \ & = Hars
i NIZ0E HOT-ER. NIIGAMOTHER: .. el B [ ——

SasTa e

D

Dwcripian:

LY |

Schadue
Baade:
Farfiaric
Smpwuny vy
Lonling wen:

1 Vb il Bef Ky ALK PRSI TR

2. From the Filter, using the Server drop down box, select a server.

3. In the Details like field, enter free text like name of the task, name of the agent, or any
description that may figure in the task.

4. In the Journal, click the Search button.
The search results are shown in the panel below. The Triggers in column shows when the
scheduled deploy task is set to run next.

When one is selected, the deploy task’s details are shown in the panel to the right.
LY |

Schedubd deakoy tarks
o Auiwe fy deakn Lath: S he o) vepd oy Rohs Familend depboy Lasks | = Mesiaged K el
Moy o shedeied deploy koo L E 'l.l 0 Bl I VLOOH A0 T e FE e v =| 5 I W :.I:l Dicda i of :ohed whed copbay Lick, £l E
el |VinGrapscHUBMIZGH MOTHERSy = | Dapicy ngard Hara Chvrar Pamack Tigreine- (as-]  redl
Dk NIZOE HOT-ER, NIDGHMOTHER . feln B [

Sasanersen

e

Dwcriphizn:

Schadue
Farfoaric
Bpwungvllly
onding woin:

5. To modify the deploy task, do one of the following:
Right-click the deploy task in the results panel and select Properties.
In the details panel, click the Properties button.

6. Continue to schedule a Deploy Task from step 3 onward.
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2.6.4 To Search Finished Deploy Tasks

1. Click Tools > Administer Tasks > Finished deploy tasks.
The Journal is enabled for searching deploy tasks.

Tiritkes dipics ek LR+
I deplay bmia | S0 Mheol od depler fnin Frosted gopbaylacks | o0 In'rm-nnlchlll
Fifar For S b el depley Ik -3 [ Y P =| h —l—l :|Z| Cwla b of firied deplep dmt T e
PR rp— | | Goance sarver [ Cmakesy sk - G
T T—— SPGLRERGHI LI RS W x o
Cky meransul PG LRI ZMILIOLS IR0 WErs et et
o Furh SAPRIEEETHI SRS 1R EEE W fo—
gttt L Fe IR E R R W v
Duai ey © ARG LR SRLE T HSE WD g
2 1214 TP LpEER AL IXREE  WED
llf’*' AP LR ALY IXHET WS SEe—
: TP LEEETHI TMILILI XA warE e
ol e AP URERETHI ERILELE LRSS Wi = T5a Casanation
Hink: You mary dreg and drep e SUPIIETARRHL A S A TRE Wk
cioct onda e 2 hokh dbows 1 AP SATATI RIS WED
Farsm i LA ek, PG LRI AL LIRSS WD
PG LPEREGHI TALLY XS W
TG LBEECHI TALICLS 1200 Wers
PGLEEETHI ZHALIILS 1258 W
SR IEPEH| ERAL AT DA WO
AP LRI FRALID R WD
T RE T FRALIL I=REE WD
PG LR TRALLY =M W
TG LBEECHI TALILS IZ235 Wers
PG LPETH ZHALINLS 12218 W
SRR ERLAE LTI W
AP UEEEEHI FRALII DS W
AP LRI SRALILD IR WD

= et D LAY TN e wTe
- -

2. From the Filter, using the Server drop down box, select a server.
3. Select a task Status. Your options are:
Only unsuccessful
Only successful
Both
4. From the Date drop down box, select one of the following options:
Anytime
From: Selecting this option will prompt you to also enter a beginning date and time.
Until: Selecting this option will prompt you to also enter an ending date and time.
Between: Selecting this option will prompt you to also enter a beginning and ending
date and time.
5. In the Details like field, enter free text like name of the task, name of the agent, or any
description that may figure in the task.
6. In the Details not like field, enter free text like name of the task, name of the agent, or any
description that you want to exclude from the task search.
7. In the Journal, click the Search button.
The search results are listed in the main panel. When a result is selected, the finished deploy
task’s details are shown in the Details of finished deploy task panel to the right. There are
general details as well as any errors and warnings.

If the Deploy Agent encounters corrupted files, it will try to restore files on the source server. In
such cases, an error message will be logged in the journal if the restoration fails. If the log level is
set to All, successful restore operations will also be logged.

2.6.5 To Maintain Deploy Agents

1. Launch the Graphic Hub Manager on the machine where the Deploy Agent is to run.
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2. Log into the source server(s) and view the deploy tasks.

Fusaring degeen 11k L3 ]
“ Ranning dmake taike | = nedubd :lpiq'htl <, Tiriihac deaky ik | T hsimages e |
Fiawler running depl ey mee Ly o I E@ [rersdiv o ruraniray B phy bk TCina A
Gearserd
Dapicy sgard TPemwracdon  Pi.. ‘aron Dby s Hara L L Tetd . S
4 e extabinined W Lacome | RERG Ll L o L Daphry sgare:  APGEE
AR THER o A, RN R L] =L ] L. L] L] Spoh Fee TES_CLLEASH SRR {1
7 HERHITHER: et W Laigmy  REE =15 Terl.. Swhop.. [] ]
WS 0UEIR 7 rossdeaksr.. WM M reas O od Tmi. Swhep.. . Swiedel:  TZILIITIRE
[T CLEIA S remsdeankac.. WA MR VIDE METHER. NIDGAHMOTHER. -3 VIZDEMOTHER. L I L] Faureing srwes:  Oh, 43, 2
SFIET T ™ Tar T TS ]
Ll g Puiitr i pleg scent "SIPGHE.. T F—
Hrik Saop dephog njest SURGHD,
e k —
g Peapar thei il gl agens "SUPGHT ... S e
I 1S T TESR SR AW K N [ [
D sl poigevecs. (e sha0irsd
TEST_CLUSTER_$TEST_CLLETER 4
Thea laft: Fick: woainke
. ¥
Tiapicy Bgard Fasfarmaces ..

% nunning deploy s

3. In the left panel, right-click the relevant Deploy Agent and select Properties.
The Deploy Agent properties window is shown (Statistics is selected by default). The data
shown here is for information purposes only.

E M /= Statistics )

.@ Configuration

' Version info General
@ High availability Started at: 5/8/2016 3:56:28 PM

Rurning since: 35m, 55s
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4. Click Configuration.

5 Configuration

Logging af additional/advanced runtime infarmatian
Log additional information ta EventLiog

[ ] Log additional infarmation ta journal on dedicated Log-Server

Deploy agent work, directony
Folder: | C:\ProgramD atahwizitiz GH Deploy Agent

Timeouts and Transfer buffer zettings

E stablizhing communication bmeout [in secondsz] ; 15
Communication round tnp tmeout [in seconds); 30
Cluster Fallowver timeout [in seconds]: 15
Tranzfer buffer size: (1.000.00 EB) 2012
D efaults

E=pert zettings

Mo, of attemptz to reconnect toViz Graphic Hubs: 10

Time [in seconds] bebween attemptz o reconnect; 30

[ ] Do 'emergency’ pausing of realtime tasks
if 0% of all objects ar if U abjects

would be deleted on any destination server

[ ] Use original DDC behaviar

[ ] Do not avenwnite if destination file is newer Defaults

Communication ports
TCP port: 19393 UDP port: 19397 Defaulks

5. Configure the following parameters as necessary:
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Log additional information to EventLog: Select this option to include debugging
information, as well as records of the start of tasks, in the Windows event log.
Log additional information to journal on dedicated log server: Select this option to
include debugging information, as well as records of the start of tasks, in the Graphic
Hub server log, on one of the servers available in the Dedicated Log Server drop down
box.
Deploy agent work directory: The path and folder which acts as the temporary buffer
for the Deploy Agent. The Deploy Agent process must have full access rights on the
selected directory. This directory location can not be changed.

- Timeouts: Set the timeouts times for each file as required.
Expert settings: Consult your Vizrt CA representative before changing any of these
settings:
Do ‘emergency’ pausing of realtime tasks: In the event that there is a risk of too many
files being deleting on the destination server, select this option and assign a threshold
as a percentage or number of files beyond which the Deploy Agent will pause the task.
If such a task is paused, you will find it when searching for finished Deploy tasks. You
are always able to resume the task.

- TCP port: Default is 19393. Change only after consultation with your network

administrator, if there are firewall issues.
UDP port: Default is 19392. Change only after consultation with your network
administrator, if there are firewall issues.

/\ Note: Changing TCP or UDP setting will require changes to the Graphic Hub
Manager preferences: click Tools > Edit preferences and in the left panel select
Deploy.

6. Click Version Info.

5 statistics
Configuration

B \/ersion info ~ Deploy agent (VizGHDeployAgent Service exe)
High availability Version: 2.0.0.60132

— Tasks scheduler {vdbSchedulerl dll)
Version: 2.0.0 60132

—Wiz GH Intefface {VizDbl.dll)
Version: 3.0.0 60132

7. When reporting a problem, make sure to include this version information.
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8. Click High Availability.

£ statistics +” High availability

& Configuration

' Version info ~I Corfigure high availability partner ==
Il High availability

Partner: I j
TCP port: I 15351 Set default |

I Use P address instead of host name

9. To configure a high availability partner, select the respective check box.

£ statistics +” High availability
& Configuration
') Version info ~[¥ Configure high availability partner
& High availability
Partner: INn deploy agent configured yet j

TCF paort: I 15391 Set default |

[T Use |F address instead of host name

10. From the Partner drop down box, select the alternative to take over in case of failover.

& Note: In general, it is recommended that you use the default TCP port.

11. Click OK.
12. Click Close.
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3 Graphic Hub ImEx Agent

The Graphic Hub ImEx Agent (Import / Export agent) is a service that imports image media assets
from file-system folders or HTTP sources to the Graphic Hub.

The Media Sequencer uses the ImEx Agent to stage image media assets for play-out, from HTTP
sources. This reduces the load on Viz Engine as images are already available on the Graphic Hub
with pre-computed mip-map levels, and must not be loaded through HTTP on actual play-out. The
service depends on the Graphic Hub REST, which is used to import the images into the Graphic
Hub. In addition file-system folders can be watched for image media assets to be imported.

The ImEx Agent uses projects or folders on the Graphic Hub to upload content, called destination
directories. They are configured and managed by UUID. The destination directory path must be
below the /data root folder, for example e.g. /data/imex/MyDestinationDirectory or /data/
imexDestinationDirectory.

The ImEx Agent can be used in two ways:

1. The Media Sequencer triggers activity in the ImEx Agent by creation of Distribution
Plans based on playlists.

2. Importing images from a configured Watchfolder into the Graphic Hub. This also creates so
called watchfolder distribution plans.
A Watchfolder is an ordinary folder on the file-system which is watched by the ImEx Agent
and actively monitored. Image media assets are imported into the Graphic Hub on creation
or overwritten when changed.

A Distribution Plan represents a set of image media assets that should be available on a number of
destination directories during a specified period of time (1) or until they are cleaned up manually

(2).

Availability Reports contain the content of an import operation, including additional information
about the state and location of the media asset.

Housekeeping for uploads triggered by the MSE is done by setting expiration dates on the
imported image assets on the Graphic Hub (watchfolder imports currently lack this feature).
During the Cleanup of Expired Items Task, which must be enabled and configured in the Graphic
Hub Terminal, all expired files are deleted.

HTTP sources ImEx Agent .
Viz One Manages/monitors .
g import schedule GH REST Graphic Hub

a0
/
>

Media Sequencer
c:j Creates/Deletes Distribution plans
Schedules assets for import

Contents of file
system folders
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Note: The import configuration for MSE based imports (distribution plans, asset import
schedules, availability report) is not persistent, and is thus lost when you stop or restart the
ImEx Agent service.

3.1

Supported Import Media Types

The following category and mime-types are supported by the ImEx Agent:

image/jpeg
image/gif
image/png
image/bmp
image/tiff
image/tga

3.2

Notable Limitations

- GH REST version 2.0.1 and Graphic Hub version 3.0.1 or later are required.
- The number of publishing points specifically used for media staging via Media Sequencer is

limited to 1 per Viz Engine (Graphic Hub the Engine is connected to).

- Currently, a maximum of 5000 assets is recommended for a single watchfolder based

import.
Folders on a network share can be used as watchfolders if it is mounted as drive with the
SYSTEM user, because the ImEx Agent service is running under the SYSTEM user.

- Currently, cleaning up images uploaded from a watchfolder must be done manually.

Resolving file name conflicts between the watchfolder(s) and the destination directory on the
Graphic Hub must be done manually.

- The watchfolder may NOT be renamed.

3.3

User Interface

The Graphic Hub ImEx Agent user interface consists of:
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&) Graphic Hub ImEx - 127.0.0.1

- ~ " A
(5] Import Options Report Apour J],

Status:  No configured distributionplans available 2

L3

&

The Menu Bar (1):
Import
Options
Report
Help and About
The System Status Panel (2):
System Status Panel

The Status bar beneath the menu bar displays concrete information about the current status and
page displayed.

The Status page displays information of the overall status of the ImEx Agent service. The Status
icon can be either of the following:

. @ Running: Everything is OK.
Warning: There are warnings which may require user interaction.
Error: There are errors which require user interaction.

The main menu has the following sections:, and a status panel that provides a quick overview of
the system status:

Import
Destination directories: Manage configured destination directories that can be used by
the ImEx Agent and the Media Sequencer for imports.
Watchfolders: Manage watchfolders that can be used to import images from the file-
system.

Options
Configuration: Manage the ImEx options (webserver, connection, import and log
settings).
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- GH REST hosts: Manage configured GH REST services (and Graphic Hubs) the ImEx
Agent can use for imports.

Pre-Authenticated Hosts: Manage configured credential information for external

import sources (e.g. Viz One) the ImEx Agent uses for authentication.

- Change ImEx password: Change the ImEx Agent specific password that is required
when "Use authentication” in enabled in the Configuration under Webserver
Configuration.

Report

- Logs: Displays searchable ImEx log content.

Distribution plans: Displays the active and expired Distribution plans with current
status information.

- Availability report: Displays search and filterable information of assets to import.
Export: Possibility to generate reports which contain all relevant log files and state
information.

Help: Opens the Graphic hub manual.
- About

- Versions: Displays information of the currently installed ImEx version and connected

GH RESTS and Graphic Hubs.

3.4 Initial Setup

When installation of the ImEx Agent is complete, the default web browser opens http://
127.0.0.1:19390/index.html for initial configuration.

3.4.1 Quick Start

1. Install the ImEx Agent.
2. View web interface on http://127.0.0.1:19390/index.html.
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3. The initial configuration wizard displays if no destination directories exist.

©) Graphic Hub ImEx - 127.0.0.1

®

Status:  Select GH REST to use for import
Select: GH REST
VizDbServer@GH-Host:19396

Login: Graphic Hub

Select: Destination directory

4. Select a Graphic Hub REST host to use for importing assets.
You can also enter the host manually, in the format http://resthost:port/. The GH REST
must be bound and connected to a running Graphic Hub.

/\ Note: GH REST version 2.0.1 and Graphic Hub version 3.0.1 are required.
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) Graphic Hub ImEx - 127.0.0.1

©

Status:  Select GH REST to use for import

Select: GH REST

Login: Graphic Hu.

Select: Destination directory

Providing a valid GH REST host enables the Login panel.
Provide a valid GH username and password from the Graphic Hub you are connecting to.

& Graphic Hub ImEx - 127.0.0.1

©

Status:  Select GH REST to use for import

Select: GH REST

VizDbServer@TUTORIALO1:19396

Login: Graphic Hub

GH username : Admin

GH password :

Select: Destination directory
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6. Select a destination directory (folder or project), by clicking the browse icon (...) on the
right side. You can also create new projects or folders using the directory browser.

[ Graphic Hupt=S-45anin

Choose import directory on GraphicHub: VizDbServer@TUTORIALO1:19396 -

= data

(5]

Status:  Select GH REST tc Project01

ImportDirectory01

Cancel

7. Save the selected destination directory by pressing OK, then Add.

Success

Successfully configured ImEx.

A

Copyright © 2018 Vizrt Page 216



Graphic Hub Administrator Guide - 3.2

After successful configuration, the ImEx status page opens.

) Graphic Hub ImEx - 127.0.0.1

@ Import Options Report About

Status:  No configured distributionplans available

GH IMEX version: 1.0.0.66551
stribution plans: 0

Import queue: 0

Configuration: 1 REST, 1 GH

Status:

3.4.2 Basic Media Sequencer Configuration

The following list describes how to setup Media Sequencer for media staging via ImEx Agent.

1. Setup Viz Pilot and Media Sequencer, see Basic Viz Pilot and Media Sequencer setup using,
for example, a Viz One as search provider.

2. Open the Media Sequencer configuration file named default.xml in an editor of your choice.
By default, this file is located in C:\ProgramData\vizrt\Media Sequencer.

3. Disable the http_resource_poller by adding

mode="disabled"

to it.
4. In the scheduler section of the configuration file, add the following node:

<handler type="vme" name="imex_image_staging">
<entry name="service_document">http://my-imex-host:my-imex-port/</entry>
<entry name="log_level">50</entry>
<publish_media_type>image</publish_media_type>

</handler>

Here, my-imex-host and my-imex-port need to be set to the relevant ImEx host name in
lowercase format (e.g. imex-host) and the relevant port that ImEx uses (e.g. 19390),
respectively.
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5. When using a single Graphic Hub/Viz Artist: Add a single publishing point to Media

Sequencer by adding/configuring the following node in the config section of the
configuration file:

<entry name="global_publishing_points">
<entry name="image">
<entry name="uri">http://my-imex-host:my-imex-port/publishingpoint/my-pp-uuid</entry>
<entry name="atom_id">MY-PP-UUID</entry>
</entry>
</entry>

Here, my-imex-host, my-imex-port, my-pp-uuid and MY-PP-UUID need to be set to the host
name in lowercase format used in bullet 3, the port used in bullet 3, the UUID of the relevant
publishing point in lowercase formatted as XXXXXXXX-XXXX-XXXX-XXXXXXXXXXXX

(e.g. c94a50d8-867b-11e7-bb31-be2e44b06b34) and the used publishing point UUID in
uppercase format (e.g. C94A50D8-867B-11E7-BB31-BE2E44B06B34).

When using multiple Graphic Hubs/Viz Artists: To distribute images used for media staging
to several Graphic Hubs, first remove the global_publishing_points node from the config
section of the configuration file.

Then, add a distinct publishing point for each Viz Engine by adding the following nodes to
the handler sections of type viz in the configuration file:

<entry name="image_publishing_point_uri">http://my-imex-host:my-imex-port/publishingpoint/my-pp-
uuid</entry>
<entry name="image_publishing_point_atom_id">MY-PP-UUID</entry>

The Viz handlers can be configured in Director, see the Profile Configuration page in
the Director Configuration section of the Viz Pilot User Guide.
Again, set my-imex-host, my-imex-port, my-pp-uuid and MY-PP-UUID (see bullet 4).

/\ Note: For each Viz handler, add a publishing point on the Graphic Hub connected to
the Viz Artist/Engine which corresponds to the currently relevant Viz handler.
Adding an image publishing point to a solely configured Viz handler achieves the
same effect as adding a global publishing point.

Again, the global_publishing_points node has to be removed from the config section
to enable publishing points bound to Viz handlers.

Examples:

1.

When using a single Graphic Hub/Viz Artist:
Add the following node to the scheduler section to enable the ImEx Agent on host imex-
host and port 19390 for media staging:

<handler type="vme" name="imex_image_staging">
<entry name="service_document">http://imex-host:19390/</entry>
<entry name="log_level">50</entry>
<publish_media_type>image</publish_media_type>

</handler>
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Then, add the following node to the config section to enable a publishing point with
UUID c94a50d8-867b-11e7-bb31-be2e44b06b34:

<entry name="global_publishing_points">
<entry name="image">
<entry name="uri">http://imex-host:19390/publishingpoint/c94a50d8-867b-11e7-bb31-
be2e44b06b34</entry>
<entry name="atom_id">C94A50D8-867B-11E7-BB31-BE2E44B06B34</entry>
</entry>
</entry>

Also, disable the htttp_resource_poller.
. When using multiple Graphic Hubs/Viz Artists:

(D Info: This example demonstrates how to add two publishing points respectively
residing on distinct Graphic Hubs. For other numbers of publishing points/Graphic
Hubs proceed analogously.

Add the following node to the scheduler section to enable the ImEx Agent on host imex-
host and port 19390 for media staging:

<handler type="vme" name="imex_image_staging">
<entry name="service_document">http://imex-host:19390/</entry>
<entry name="log_level">50</entry>
<publish_media_type>image</publish_media_type>

</handler>

Next, navigate to each handler node of type viz and respectively add the corresponding
image publishing points. In this example, two entities of Viz Artist (respectively connected to
Graphic Hubs on gh-host1 and gh-host2) have been configured in Director. The Media
Sequencer configuration reads:

<handler name="viz_background_ai" connected="yes" mode="enabled" type="viz">
<entry name="encoding">UTF-8</entry>
<entry name="state"/>
<entry name='"renderer">
<entry name="gh-host1l">
<entry name="active"/>
</entry>
</entry>
<entry name="publishing_point_uri"/>
<entry name="publishing_point_atom_id"/>
<entry name="1info"/>
<command_timeout>20.</command_timeout>
</handler>

and

<handler name="viz_background_e" connected="yes" mode="enabled" type="viz">
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<entry name="encoding">UTF-8</entry>
<entry name="state"/>
<entry name="renderer'">

<entry name="gh-host2">

<entry name="active"/>

</entry>
</entry>
<entry name="publishing_point_uri"/>
<entry name="publishing_point_atom_id"/>
<entry name="info"/>
<command_timeout>20.</command_timeout>

</handler>

Then, enable the publishing points with UUIDs b02cbb8e-87d6-11e7-bb31-be2e44b06b34
and d0053030-87d6-11e7-bb31-be2e44b06b34, which respectively reside on gh-host]1
and gh-host2, by adding them to their correpsonding Viz handler. The configuration file
should then read:

<handler name="viz_background_ai" connected="yes" mode="enabled" type="viz">
<entry name="encoding">UTF-8</entry>
<entry name="state"/>
<entry name="renderer">
<entry name="gh-host1l">
<entry name="active"/>
</entry>
</entry>
<entry name="publishing_point_uri"/>
<entry name="publishing_point_atom_id"/>
<entry name="image_publishing_point_uri">http://imex-host:19390/publishingpoint/
b02cbb8e-87d6-11e7-bb31-be2e44b06b34</entry>
<entry name="image_publishing_point_atom_id">B02CBB8E-87D6-11E7-BB31-BE2E44B06B34</entry>
<entry name="info"/>
<command_timeout>20.</command_timeout>
</handler>

and

<handler name="viz_background_e" connected="yes" mode="enabled" type="viz">
<entry name="encoding">UTF-8</entry>
<entry name="state"/>
<entry name="renderer">
<entry name="gh-host2">
<entry name="active"/>
</entry>
</entry>
<entry name="publishing_point_uri"/>
<entry name="publishing_point_atom_id"/>
<entry name="image_publishing_point_uri">http://imex-host:19390/publishingpoint/
d0053030-87d6-11e7-bb31-be2e44b06b34</entry>
<entry name="dimage_publishing_point_atom_id">D0053030-87D6-11E7-BB31-BE2E44B06B34</entry>
<entry name="info"/>

<command_timeout>20.</command_timeout>
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</handler>

Last, check if the global_publishing_points in the config section exists. If it does, it needs to
be removed to enable the newly configured publishing points. Also, disable
the http_resource_poller.

3.5 Configuration

Use the Configuration page to make changes to the web server, connection, import, or log
settings. This section provides information on the different configuration settings available, and
describes how to perform the initial Graphic Hub ImEx Agent Configuration.

3.5.1 Webserver configuration

WEBSERVER COMFIGURATION

Port : 19390

Thread pool size : 80

Enable access log

Use authentication

Port: Set the HTTP port number the ImEx web server should listen to. The default port
number is 19390.

- Thread pool size: Set the maximum number of concurrent threads for the ImEx Agent web
server to handle requests. The default value is 8o.
Enable access log: Check the box to log information about connections and requests to the
ImEx web server.
Use authentication: Check the box to enable HTTP basic authentication on ImEx Agent web
server with ImEx Agent specific credentials. This makes a Login button appear in the top
right corner.

- The default username is Admin , and the default password is vizbb . You can change
this in Options -> Change ImEx password.

3.5.2 Connection settings

COMMECTION SETTINGS

General request timeout (ms) 10000

GH REST request timeout (ms) - 10000

General request timeout (ms): Set the default timeout in milliseconds for HTTP requests
performed. The default timeout value is 16000.
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GH REST request timeout (ms): Set the timeout for Graphic Hub REST requests in
milliseconds. The default timeout value is 10000.

3.5.3 Import settings

IMPORT SETTINGS

Maximum RAM usage (ME) :

Maximum parallel uploads :

Maximum parallel downloads :

Monitoring interval assets (ms) 10000

Monitoring interval REST agents (ms) : 10000

4k 4k AP Ap Ap 4A)p

Monitoring interval staged sources (ms) : 10000

Maximum RAM usage (Mb): Define the maximum amount of RAM allocated for caching
temporary images in megabytes. The default value is 1500.

Maximum parallel uploads: Set the maximum number of simultaneous uploads. The default
value is 32.

Maximum parallel downloads: Set the maximum number of simultaneous downloads. The
default value is 32.

Monitoring interval assets (ms): Set the interval in which the ImEx Agent checks the
availability of all non-expired assets. In case an asset is accidentally deleted, the ImEx Agent
will automatically fetch the asset again. The default value is 10000.

Monitoring interval REST agents (ms): Set the interval in which the ImEx Agent checks the
availability of all configured GH REST agents. The default value is 10000.

Monitoring interval staged assets (ms): Set the interval in which the ImEx Agent checks
unavailable assets that have been staged. When the asset becomes available, the ImEx Agent
will automatically fetch the asset. The default value is 10000.

3.5.4 Log settings

LOG SETTINGS

Maximum size (all logs) (MB) :

Log lifetime in days :

Information

G Warning
Error

Critical

Maximum size (all logs)(MB): The default value is 60.
Log lifetime in days: The default value is 2s.
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Log level: Select which log messages should be reported.

3.6 Manage Imports

This page contains information on import behavior and how to manage Destination
directories, Watchfolders, GH REST hosts and Pre-Authenticated hosts.

Import behavior

Manage destination directories
Manage watchfolders

Manage GH REST hosts

Manage Pre-Authenticated hosts

The ImEx Agent can only upload content to the configured Graphic Hub’s destination directories.

3.6.1 Import behavior

During import, handling of destination directories and images differs depending on the import

variant.

- When

importing via media staging (MSE triggered):

- A child folder with the title and id of the Distribution Plan is created in the destination

directories. If the folder already exists, the existing folder will be used.

- The expiration date defined in the Distribution Plan will be set as the expiration date

for the project/folder on the Graphic Hub.

- When an expired items cleanup task is enabled and configured in the Graphic Hub

- When

Terminal, the project/folder and its contents will be deleted automatically when
expired as soon as the expired items cleanup task is executed.

Files are always imported with a unique name (file name with asset ID). Files are never
overwritten during import.

importing via watchfolder:

- The images are saved directly in the destination directories.

Corresponding distribution plans do NOT expire. Images uploaded from a watchfolder
have to be cleaned up manually.

Images which are deleted from a destination directory are automatically re-uploaded.
To clean them up, first delete the corresponding file from the watchfolder and then
delete it from the destination directory.

Importing different but identically named files from different watchfolders into the
same destination directory leads to conflicts. These need to be resolved manually.
Overwriting images in the watchfolder leads to overwriting on the Graphic Hub if the
checksums are different.

Renaming images in the watchfolder leads to upload of the renamed images. The
image with the old name is not automatically deleted on the Graphic Hub.

Renaming or overwriting images in the destination directories re-uploads the versions
in the watchfolder. The renamed file is not automatically deleted on the Graphic Hub.
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Overwriting or deleting images from the watchfolder updates the corresponding
distribution plan with the new information.

By default, Add file extension is enabled. Images are named by appending their
original names with an underscore and their respective file extension, e.g. image.bmp
> image_bmp.

It is not advised to disable this option, see Add watchfolder for details.

3.6.2 Manage destination directories

Use the Import -> Destination directories page to configure the destination directories used by
the GH ImEx Agent.

& Graphic Hub ImEx - TUTORIALO1

-
(5] Import Options Report About

Import:  Destination directories

Jestinatio aisly] Graphic Hub GH REST
J/data/importDirectory01 VizDbServer@TUTORIALO1-... http//TUTORIALO1:-19398/

ADD DESTINATION

= Ado gestination

Status: The current status of the configured destination directory. If a warning or an error is
shown, hovering over the icon will display additional information.

Destination directory: The absolute path of the currently configured destination directory
(project or folder on the Graphic Hub).

Graphic Hub: The configured Graphic Hub of the destination directory to which the GH REST

is connected to.
GH REST: The GH REST service(s) used for importing assets to the destination directory.
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/\ Note: Click the copy icon to open a dialog containing the import directory link to copy it
for the Media Sequencer configuration.

Add destination directory

1. Open Import > Destination directories.
2. Click Add destination at the bottom left (1). This shows the Add Destination dialog (2).

&) Graphic Hub ImEx - TUTORIALO1

- P A
(5] Import Options About

Import:  Destination directorie

Jestination directory Graphic Hub GH REST
J/data/ImportDirectory01 VizDbServer@TUTORIALOT:... hutp/TUTORIALO1:19398/

ADD DESTINATION

Select- GH REST Login: Graphic Hub

C’ http//TUTOR

Select: Destination directory
VizDbServer@TUTORIALO1:19396

.

3. Select a Graphic Hub REST host to use for importing assets.
You can also enter the host manually, in the format http://resthost:port/. The GH REST
must be bound and connected to a running Graphic Hub.

/\ Note: GH REST version 2.0.1 and Graphic Hub version 3.0.1 are required.

4. Provide a valid GH username and password from the Graphic Hub you are connecting to.
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5. Select a destination directory (folder or project), by clicking the browse icon (...) on the
right side. You can also create new projects or folders using the directory browser.

ADD DESTINATION
Select: GH REST Login: Graphic Hub

GH username :

// htep://TUTO

GH password :

_ _ Select: Destination directory
VizDbServer@TUTORIAL04:19396

© Add

6. Click Add to add the destination directory.
The new Destination directory appears in the Default directories list:

$&) Graphic Hub ImEx - TUTORIALO1

- —~
© Import Options Report About

Import:  Destination directories

Graphic Hub GH REST
r@TUTORIALO4:... hutp://TUTORIALO4:19308/
/data/iImportDirectory01 VizDbServer@TUTORIALOT:... hitpfTUTORIALO1-19398/

ADD DESTINATION

g Add destination

Remove destination directory
You can remove destination directories that are not in use .

1. Open Import > Destination directories.
2. Remove the desired destination directory by clicking the trash can icon at the far right of the
watchfolder's destination directory.
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3.6.3 Manage watchfolders

Use the Import > Watchfolders page to configure watchfolders which the ImEx Agent can use to
import images from.

&) Graphic Hub ImEx - TUTORIALO1

- —~ . A
(5] Import Options Report About

Status:  Running

Jestination dire Watchfolder path Interval
fdata/iImportDirectory01 E\MyWatchfolder01 10

ADD WATCHFOLDER

& Adawatchfolder

Status: The current watchfolder status. If a warning or an error is shown, a hover over the
icon will display additional information.

Destination directories: The absolute path of the destination directory. This is a project or
folder in a Graphic Hub.

Watchfolder path: The absolute path of the watchfolder. This is a folder in the local file
system or on a network share drive.

Interval: The scan interval in minutes. Determines in which intervals the watchfolder is
scanned.

Extension: Shows if files have their file extension appended to their name.

Add a watchfolder
1. Open Import > Watchfolders.
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2. Click Add watchfolder at the bottom left (1) to show the Add watchfolder dialog
& Graphic Hub ImEx - TUTORIALO1

(2).

= . -
(] Import Options Report About

Running

ination directories Watchfolder path Interval Extension
/data/importDirectory01 E:\MyWatchfolder01 10

ADD WATCHFOLDER

Path of local watchfolder :

Scan interval - 10 Add file extension

Destination directory:

3. Select a watchfolder by clicking the browse icon (. ..) on the right side and choosing a
folder. The folder list consists of folders on all local drives and correctly mounted network
share drives.

& Note: For a network share drive to appear in the folder list, it needs to be mounted
as the SYSTEM user, because the imEx Agent servic eus running under the SYSTEM
user.

Alternatively, manually enter the absolute path of the folder.

4. Choose the length of the additional scan interval in minutes by either entering a value
manually or increasing/decreasing it using the up/down arrow buttons.

5. Choose if files have their file extension (i.e. file type) appended to their name by checking/
unchecking the Add file extension checkbox.
E.g. the files imagel.jpg, imagel.png and image2.bmp are imported as imagel_jpg,
imagel_png and image2_bmp if the box is checked.

/\ Note: It is not advised to deactivate file extension adding as files with identical
nhames overwrite each other on upload.
Which of these persists depends on its position in the upload queue i.e., the last one
that gets uploaded is then the file on the Graphic Hub.

6. Select a destination directory from the drop-down menu by checking the directory. By
checking multiple destination directories, images are imported to multiple destinations.
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More details regarding the destination directories is listed in the drop-down
menu: Destination reads the absolute path of the destination directory on the
specified Graphic Hub.

ADD WATCHFOLDER

EMAnotherWatchfolder

Scan interval 20 b Add file extension

Destination directory:

7. Click Add to add the watchfolder.
The new watchfolder appears in the Watchfolders list:

&) Graphic Hub ImEx - TUTORIALO1

-
(5] Import Options Report About

Status:  Running

Destination d tories Watchfolder path Interval Extension
Jdata/ImportDirectoryA
J/data/ImportDirectory01
Jdata/ImportDirectory01 EAMyWatchfolder01 10

E:\AnotherWatchfolder 20

ADD WATCHFOLDER

= Adawatchfolder

Change watchfolder scan interval

You can change scan intervals of your watchfolders. The ImEx Agent periodically scans the content
in teh watchfolder in addition to the monitored update notifications from the file system.

1. Open Import > Watchfolders.
2. Click on the watchfolder you want to re-configure the scan interval for.
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3. Change the length of the scan interval in minutes by either entering a new value manually or
increasing/decreasing it using the up/down arrow buttons.

4. Click Apply to apply the change.
The new scan interval is applied to the watchfolder and is shown in the Interval column.

Remove a watchfolder

1. Open Import > Watchfolders.
2. Remove the desired watchfolder by clicking the trash can icon at the far right of the
watchfolder's entry.

3.6.4 Manage GH REST hosts

Use the Options > GH REST hosts page to configure the Graphic Hub REST hosts used by the GH
ImEx Agent.

&) Graphic Hub ImEx - 127.0.0.1

@ Import Options Report About

Options:  GH REST hosts

GH REST HOSTS
Status | GH REST Graphic Hub Username Authentication| Imports
http://TUTORIALO1:19398/ VizDbServer@TUTORIALO1:19... Admin Basic 0

ADD GH REST HOST

& Add GH REST host

- Status: The current GH REST host status. If a warning or an error is shown, a hover over the
icon will display additional information.

- GH REST: The GH REST host URL.

- Graphic Hub: The Graphic Hub to which the GH REST is connected.
Username: Graphic Hub username that is used.

- Authentication: Authentication method (Basic means HTTP basic authentication).
Imports: The number of imports that are currently performed on this GH REST (refresh
interval is five seconds).
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Add GH REST host

1. Open Options > GH REST hosts.
2. Click Add GH REST host at the bottom left (1) to show the Add GH REST host dialog.

& Graphic Hub ImEx - 127.0.0.1

-
() Import Options Report About

Options:  GH REST hosts

Graphic Hub Username Authentication| Imports

http//TUTORIALO1:19398/ VizDbServer@TUTORIALO1:19.. Admin Basic 0

ADD GH REST HOST

Select: GH REST Login: Graphic Hub

0 GH username

GH password -

VizDbServer@GH-Host:193%6

> Cancel

3. Select a Graphic Hub REST host to use for importing assets. A GH REST host can only be
added once. Already configured hosts are disabled in the selection drop-down. (A)
You can also enter the host manually, in the format http://resthost:port/. The GH REST
must be bound and connected to a running Graphic Hub.

/\ Note: GH REST version 2.0.1 and Graphic Hub version 3.0.1 are required.
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Status | GH REST Graphic Hub Username Authentication| Imports

http://TUTORIALO1:19398/ VizDbServer@TUTORIALO1:15... Admin Basic 0

ADD GH REST HOST
Select: GH REST Login: Graphic Hub

f T GH username :
/ =

GH password :
REST Graphic Hub

TUTORIALO1:19398  VizDbServer@TUTORIALIMWAN
TUTC AL

» Cancel

Provide a valid GH username and password from the Graphic Hub you are connecting to.
Click Add to add the destination directory.
The new GH REST appears in the list.

ADD GH REST HOST
Select: GH REST Login: Graphic Hub

GH username :

GH password :

VizDbServer@TUTORIALD4:19396
X Cancel

GH REST HOSTS

Status | GH REST Graphic Hub Username Authentication, Imports
http://TUTORIALO1:19398/ VizDbServer@TUTORIALO1:19...  Admin Basic 0
http://TUTORIAL04:19398/ VizDbServer@TUTORIALO4:19... Admin Basic 0

Copyright © 2018 Vizrt Page 232



Graphic Hub Administrator Guide - 3.2

Remove GH REST host

You can remove GH REST hosts that are not referenced/used by any of the configured import
directories. You can view a list of GH REST hosts in use under Import -> Destination directories.

1. Open Options > GH REST hosts.
2. Remove the desired host by clicking the trash can icon at the far right of the host's entry.

& Graphic Hub ImEx - 127.0.0.1

@ Import Options Report About

Options:  GH REST hosts

GH REST Graphic Hub Username Authentication| Imports
http//TUTORIALO1:19398/ VizDbServer@TUTORIALO1:19.. Admin Basic 0
http://TUTORIALO4:19398/ VizDbServer@TUTORIALO4:19... Admin Basic 0

ADD GH REST HOST

& Add GH REST host

3.6.5 Manage Pre-Authenticated hosts

Go to Options > Pre-Authenticated Hosts to view a list of configured pre-authenticated hosts that
are used by the ImEx Agent to authenticate at external HTTP image sources.
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& Graphic Hub ImEx - 127.0.0.1

(O] Import Options About

Options:  Pre-Authenticated Hosts

AUTHENTICATED HOSTS
Host Username Password Authentication

https://example.org/ ExampleUser XX Basic [ ]

ADD PRE AUTHENTICATED HOST

& Add Pre-Auth host

Status: The current Pre-Authenticated host status.

Host: The url of the configured Pre-Authenticated host.
Username: Pre-Authenticated host username.

Password: Pre-Authenticated host password.

Authentication: Pre-Authenticated host authentication method.

uTh WN —

Add Pre-Authenticated host
1. Open Options > Pre-Authenticated Hosts.
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2. Click Add Pre-Auth host at the bottom left. This enables the Add Pre-Authenticated Host
pane:

& Graphic Hub ImEx - 127.0.0.1

(O] Import Options Report About

Options:  Pre-Authenticated Hosts

PRE-AUTHENTICATED HOSTS
Hos Username P rd Authentication

https://example.org/ ExampleUser XX Basic [ ]

ADD PRE AUTHENTICATED HOST
Provide: Pre-authenticated host

Login: Credentials
Username :

Password

X Cancel

Enter the URL for the host you are pre-authenticating, as well as the Username and
Password.

ADD PRE AUTHENTICATED HOST
Provide: Pre-authenticated host

https://vizOneHost:80/

Login: Credentials

Admin

X Cancel
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4. Click Add. This adds the Pre-Authenticated host to the list view.

PRE-AUTHENTICATED HOSTS

Status | Host Username Password Authentication

https://example.org/ ExampleUser R Basic

https://vizonehost:80/ Admin ARk Basic

ADD PRE AUTHENTICATED HOST

€ Add Pre-Auth host

Remove Pre-Authenticated hosts
You can remove pre-authenticated hosts that are not in use.

1. Open Options > Pre-Authenticated Hosts.
2. Remove the desired host by clicking the trash can icon at the far right of the host's entry.

3.7 Monitor The Asset Import

You can view current import progress, asset availability and status from the Report menu.

/\ Note: The import configuration (distribution plans, asset import schedules, availability
report) is not persistent and lost when the ImEx Agent service is stopped/re-started.

3.7.1 Monitor distribution plans

A distribution plan describes the content, the storage location(s) (multiple destination directories)
and the timeline of an import operation. A distribution plan represents a set of assets that should
be available on a number of destination directories during a certain period of time.

Select Distribution plans from the Report menu, to display an overview of current distribution
plans.
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©) Graphic Hub ImEx - 127.0.0.1

- . A
(] Import Options Report About

Report:  Distribution plans

DISTRIBUTION PLANS

Status

The overview contains the following information:

Column

Status

Type

Distribution
plan

Earliest use

tion plan r Destination Availability
DistributionPlan03 | W /data/ImportDirectory01 0of 24
DistributionPlan02 B/0 03 A J 11 A /data/importDirectoryA 0 of 438

/data/ImportDire 4 5 of 702

DistributionPlan01 /data/importDir 376 of 702
/data/importDirectoryA 11 of 44
Jdata/ImportDirectory0i
E-\MyWatchfolder01 /data/importDirectory01

E:\AnotherWatchfolder

Details

Displays the current status of the distribution plan.

@ Green check mark: Everything is okay.

~~ Two arrows in a circle: The ImEx Agent is currently working.
Hourglass icon: The distribution plan is waiting to start work.
Orange warning icon: Asset upload has warnings or errors.

Red error sign: Destination directory error.

" Inactive symbol: For expired items.

Displays the type of the distribution plan.

Calendar icon: Media staging (MSE triggered).
Folder icon: Watchfolder.

The name of the current distribution plan (if set) or watchfolder location.

Denotes the start time of this distribution plan. All assets should be available at
this point in time.

Also used to prioritize imports. Does not apply to watchfolders.
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Column
Expires
Destination

Availability

3.7.2

Details

Monitor availability report

Graphic Hub Administrator Guide - 3.2

The destination directories this distribution plan imports the assets to.

Current progress / availability of all assets on all destination directories.

Denotes the end time of this distribution plan. Does not apply to watchfolders.

An availability report contains the content of an import, including additional information about the

state and location.

Select Availability report from the Report menu to display an overview of all assets that are
scheduled for import.

AVAILABILITY REPORT

Status Asset
C:\Users\admin...
C\Users\admin.
C\Users\admin...
C\Users\admin.
C\Users\admin...
C\Users\admin...
C\Users\admin._
C\Users\admin...
C:\Users\admin...
C:\Users\admin...
C\Users\admin...
C\Users\admi r@
C\Users\admin...
C:\Users\admin...

2

Destination

/data/ImportDir..
/data/ImportDir..
/data/lmportDir..
/data/ImportDir..
/data/ImportDir..
/data/ImportDir..
/data/ImportDir..
/data/lmportDir..
/data/ImportDir..
/data/lmpor-_r.
/dat~"importDir..
/data/ImportDir.
/data/lmportDir..
/data/ImportDir..

Uploaded

18/04/2017, 11:40__

18/04/7" ., 11:40...

18/04/2017, 11:40_

18/04/2017. 11:41..

Distribution plan

\DistributionPla...
\DistributionPla...
\DistributionPla...
\DistributionPla...
\DistributionPla...
\DistributionPla...
\DistributionPla._.
\DistributionPla...
\DistributionPla...
\DistributionPla...
\DistributionPla...
\DistributionPla...
\DistributionPla...

\DistributionPla...

Graphic hub

VizDbServer@T...
VizDbServer@T._..
VizDbServer@T...
VizDbServer@T._..
VizDbServer@T...
VizDbServer@T...
VizDbServer@T...
VizDbServer@T...
VizDbServer@T...
VizDbServer@T...
VizDbServer@T...
VizDbServer@T._..
VizDbServer@T...
VizDbServer@T...

C Refresh

The overview provides the following functionality:

Area Details

1 Filter by asset status. Only assets with the selected states will be displayed.
2 Filter by custom text, date, destination directory, title of distribution plan.
3 Grid view of assets.
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Details

Media asset upl...
Media asset upl..
Media asset upl...
Media asset ava..
Media asset upl...
Media asset upl...
Media asset upl..
Media asset ava..
Media asset upl...
Media asset upl...
Media asset upl...
Media asset ava..
Media asset upl...

Media asset ava..

&«
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Monitor Availability Report for a specific Distribution plan

1. Go to Report > Distribution plans.
2. Click the Availability column to View availability reports for a specific distribution plan.

& Graphic Hub ImEx - 127.0.0.1

A ~ A
& Import Options t About

Report:  Distribution plans

DISTRIEU
Status ributi rliest u Destination
utionPlan03 /data/lmportDirectory01 Do
DistributionPlan02 fdata/importDirectoryA 0 of 488
fdata/importDirectoryA 376 of 702
/data/importDirectory01
Jdata/ImportDirectoryA 110f a4
J/data/lmportDirectory01
/data/ImportDirectory01

DistributionPlan01

CLICK

E:\AnotherWatchfolder

E:AMyWatchfolder01

3. All assets for this specific distribution plan are shown:

OR DISTRIBUTION PLAN "\DISTRIBUTIONPLANO3" 0 2 Ao
.
v

Destination

Uploaded Graphic hub Details

C:\Users\admin\Des...
C:\Users\admin\Des...
C:\Users\admin\Des...
C:\Users\admin\Des__
C:\Users\admin\Des...
C:\Users\admin\Des...
C:\Users\admin\Des...
C:\Users\admin\Des...
C:\Users\admin\Des__
C:\Users\admin\Des...
C:\Users\admin\Des...
C:\Users\admin\Des...
C:\Users\admin\Des...

C\Users\admin\Des__

/data/lmportDirecto...
/data/lmportDirecto...
/data/lmportDirecto...
/data/lmportDirecto...
/data/lmportDirecto...
/data/lmportDirecto...
/data/lmportDirecto...
/data/lmportDirecto...
/data/lmportDirecto...
/data/lmportDirecto...
/data/lmportDirecto...
/data/lmportDirecto...
/data/lmportDirecto...

/data/ImportDirecto...

VizDbServer@TUTO...
VizDbServer@TUTO...

VizDbServe|

VizDbServer@TUTO.

VizDbServe

VizDbServe|

VizDbServer@TUTO...
VizDbServer@TUTO...
VizDbServer@TUTO..
VizDbServer@TUTO...

VizDbServer@

VizDbServer@TU

VizDbServer@TUTO..

C Refresh
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Media asset downlo...
Media asset downlo...
Media asset downlo...
Media asset downlo..
Media asset downlo...
Media asset downlo...
Media asset downlo...
Media asset downlo...
Media asset downlo...
Media asset downlo...
Media asset downlo...
Media asset downlo...
Media asset downlo...

Media asset downlo...

« b
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4. To investigate asset errors from this view, look at the Details column, which contains
information about why an asset was not uploaded in case of an error.
Use the filter buttons to display only assets in the desired state, as for example, errors or
warnings.

AVAILABILITY REPORT FOR DISTRIBUTION PLAN \DISTRIBUTIONPLANO3'

Asset

C:\Users\admin\Des...
C:\Users\admin\Des...
C:\Users\admin\Des...
C:\Users\admin\Des...
C:\Users\admin\Des_
C:\Users\admin\Des...
C:\Users\admin\Des...
C:\Users\admin\Des...
C:\Users\admin\Des...
C:\Users\admin\Des..
C:\Users\admin\Des...
C:\Users\admin\Des...
C:\Users\admin\Des...

C:\Users\admin\Des...

Y
e

Destination

/data/lmportDirecto...
fdata/ImportDirecto...
/data/lmportDirecto...
Idata/ImportDirecto...
/data/ImportDirecto...
/data/ImportDirecto...
/data/ImportDirecto...
/data/ImportDirecto...
Idata/ImportDirecto...
fdata/ImportDirecto...
/data/lmportDirecto...
fdata/ImportDirecto...
/data/ImportDirecto...

/data/ImportDirecto...

o
Uploade.. Graphic hub

VizDbServer..
VizDbServer..
VizDbServer..
VizDbServer..
VizDbServer..
VizDbServer..
VizDbServer..
VizDbServer..
VizDbServer..
VizDbServer..
VizDbServer..
VizDbServer..
VizDbServer..
VizDbServer..

C Refresh

2 Ao

Details

Media asset upload failed, all rests busy
Media asset upload failed, all rests busy
Media asset upload failed, all rests busy
Media asset upload failed, all rests busy
Media asset upload failed, all rests busy
Media asset upload failed, all rests busy
Media asset upload failed, all rests busy
Media asset upload failed, all rests busy
Media asset upload failed, all rests busy
Media asset upload failed, all rests busy
Media asset upload failed, all rests busy
Media asset upload failed, all rests busy
Media asset upload failed, all rests busy

Media asset upload failed, all rests busy

& Back

3.8 Log And Report

A general GH ImEx Agent related log can be viewed under Report > Logs.
You configure the log level under Options > Configuration.
- Furthermore, you can download an archive of all log and configuration files from Report >

Export.

This is particularly useful when troubleshooting and for support requests.

3.8.1 View ImEx Agent logs

1.
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Navigate to Report > Logs to display the logs section.
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2. Search with custom text using the text field in the top right hand corner.

{LOG 1= DistributionPlan01
Uploading progress: 60.5495856329906
4/18/2017 11:23:35AM  Debug [C__Users_admin_Desktop_huge_DistributionPlan01_city - Copy_-_Copy (5)_-
_Copy_-_Copy_jpg_ 47B9B2F3D0D649E3AB347A95F082EFT7]
Uploading progrt 50.2747928164953
4/18/2017 11:23:35 AM Debug [C__Users_admin_Desktop_huge_DistributionPlan01_city_-_Copy_-_Copy_(5)_-

_Copy - Copy - Copy jpg 6074ED7877934424873FF1E0576C6671]

Uploading progress: 70.8243784494859
4/18/2017 11:23:35 AM Debug [C__Users_admin_Desktop_huge_DistributionPlan01_city_-
_Copy_(2)_jpg_1E01C211160248B2A1B0787489395D27]

3.8.2 Manage Reports
1. Navigate to Report > Export.
2. The Export section displays all previously created report exports.

Date

ImEx-Agent Export 04/18/2017 13:28

C Refresh

3. Select one or multiple exports
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4. Click Download to download a .zip file containing information about ImEx Agent settings
and current configuration.

Export Date
ImEx-Agent Export 04/18/2017 13:28
ImEx-Agent Export 04/18/2017 13:29
ImEx-Agent Export 04/18/2017 13:29

¥ Download

/\ Note: The report archives are stored in a temporary directory of the operating system, not
persistent, and are lost when you stop or restart the ImEx Agent service.

3.8.3 Create Report

Click Create (1) to immediately generate an report export. The newly generated report is
added to the list (2).

EXPORT LIST
Export r Date
ImEx-Agent Export 04/18/2017 13:28
ImEx-Agent Export 04/18/2017 13:29
ImEx-Agent Export 04/18/2017 13:29
ImEx-Agent Export 04/18/2017 13:31

[ Creare
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3.9 Load Balancing

It is possible to bind multiple REST services to the same Graphic Hub. This can increase
performance and decrease the workload of each GH REST by utilizing multiple GH RESTs.
Furthermore, multiple GH RESTs ensure a higher degree of redundancy and fault tolerance.

The ImEx Agent automatically uses each configured GH REST that is available based on the
connected Graphic Hub. It i possible to add GH REST services at any time and remove them if it is
not utilized.

/\ Note: It is recommended to configure the bound REST services to have identical content
size limits. The ImEx Agent does not automatically distribute assets to RESTs with
appropriate content size limits.

If multiple GH RESTs are used for an destination directory can be seen in:

Import > Media staging in column GH REST, which contains multiple values.
Options> GH REST hosts when the Graphic Hub column contains the same value.

The ImEx Agent detects if e.g. a GH REST is bound to a different Graphic Hub and operates with
the currently available GH REST connections. If connection to a Graphic Hub is completely lost that
has currently used destination directories on it then a proper error is reported.

3.9.1 ImEx Agent related configuration

There are certain configuration options in the GH ImEx Agent that influence the import behavior.

1. Navigate to the ImEx Agent configuration interface, for example, http://127.0.0.1:19390/
index.html

2. Go to Options > Configuration.
3. Look at the Import settings section.

IMPORT SETTINGS

Maximum RAM usage (MB) -
Maximum parallel uploads :
Maximum parallel downloads :
Monitoring interval assets (ms) :

Monitoring interval REST agents (ms) -

F
v
F
h 4
F
v
F
b4
F
v
F
b4

Monitoring interval staged sources (ms) :

The Maximum RAM usage in Megabyte defines the amount of RAM the ImEx Agent is
allowed to use for caching downloaded files. If there is not enough RAM available, it uses the
hard drive to cache files.
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/\ Warning: The default settings ensure a properly working ImEx Agent. Changing these
values may decrease ImEx Agent performance.

3.9.2 GH REST related configuration

There are certain configuration options in the GH REST that influence the GH ImEx Agent import
behavior.

/\ Warning: Please be aware that a mis-configured Graphic Hub REST service may cause the
system to not work properly.

1. Navigate to the GH REST configuration interface, for example, http://127.0.0.1:19398/
config/index.html.
2. Go to Configuration > Viz GH Rest.

INFIGURATION

Viz GH Rest Settings Log Level
Request timeout {ms) : Debug

Trace

s Information

warning

£ error

Crititcal
ACE

Max. sessions per user
Default max search results : 20
Max journals :

Max journals days -

T TR ST S [ S

Content size limit in MB : 200
VIZ GH REST IMAGE UPLOAD CONFIGURATION

iz GH Rest image upload Settings

Max. used system Memory __
in % B

Default compression :

Max. number of parallel
uploads :

REVERSE SETTINGS

/\ Warning: Keep the default values, and only reduce them if resource demand is too
high. Increasing these values is not recommended, as this can cause system
instability.

3.10 Troubleshooting GH ImEx Agent

This page provides help for troubleshooting the following scenarios:

Unable to connect to GH ImEx Agent service
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- Status box displays an error

- Status box displays a warning
Media staging status shows an error
Media staging status shows a warning

3.10.1 Unable to connect to GH ImEx Agent service

This indicates that the GH ImEx Agent HTTP server is not accessible or that the service is not
running.

& Graphic Hub ImEx - 127.0.0.1

-

(5] Import Options Report About

Status: GH ImEx agent not reachable

Retry to connect

Press Windows+R.

A Run window opens in the bottom left corner.

Enter services.msc and click OK. An overview of services opens.
Check whether the Viz GH ImEx Agent service is in Running status.

A WN —
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select Start or Restart.
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right click the Viz GH ImEx Agent service and

% Services - m} e
File Action View Help
e |@HEGE Hml »mnw
. Services (Local) :é Services (Local)
Viz GH ImEx Agent Name - Description Ststus  StatupType  Log OnAs "
&}, Volume Shadow Copy Manages and implements Volume... Manual Local System
othesance '-.”:!;VMware USE Arbitration Service Arbitration and enumeration of U...  Running  Automatic Local System
'-.S‘:)}VizrtThumbnail Generator Service for Thumbnail Generation Running  Automatic Local System
Description: &} Vizrt Script Runner Server for running scripts on temp... Running  Automatic Local System
This agent imports data to Viz &) Viart Pilot Data Server Application server for accessing Vi...  Running  Automatic Local System
S;Zf:;; Hub from multiple data '-%!;Vlzrt Media Sequencer System for automating playout, cr..  Running  Automatic Local System
54 Viz GH Terminal Service Wiz GH Terminal Service Running  Automatic Local System
GH ImEx Agent This agent imports data to Viz Gra, Manual Local System
&}, Viz GH Deploy Agent Sen Start his agent performs task triggered... Running  Automatic Network Service
&} Visual Studio Standard Ce Stop isual Studio Data Collection Servi.. Running  Manual Local System
'-.’-_:!;\Flsualstudlo Standard Ct T=rEn isual Studie Data Collection Servi... Manual Local System
'-.S:‘)}Virtua\ Disk Resume rovides management services for.., Manual Local System
'-.‘?}U;er Profile Service T his service is responsible for load... Running  Automatic Local System
&} User Manager ser Manager provides the runtim... Running  Automatic (T... Local System
&} User Experience Virtualiza All Tasks rovides support for application a... Disabled Local System
'-.”:!;User Data Storage_3eabl andles storage of structured user...  Running  Manual Local System
'-.’_.:)} User Data Access_3eabl e rovides apps access to structured... Running  Manual Local System
Q.S.:!,UPHP Device Host Properties llows UPnP devices to be hosted ... Manual Local Service
£} Update Orchestrator Serv saSvc Manual Local System
'-.C:!;Touch Keyboard and Har RED nables Touch Keyboard and Han... Manual (Trig...  Local System
RS:P;Tlme Broker Coordinates execution of backgro.. Running  Manual (Trig...  Local Service
£} Tile Data model server Tile Server for tile updates. Running  Automatic Local System
&) Themes Provides user experience theme m... Running  Automatic Local System
&} Telephony Provides Telephony API (TAPI) sup... Manual Network Service
LC?;TEamV\ewar11 TeamViewer Remote Software Running  Automatic Local System
".':,;TE‘SEI'\(ICE Manual Local System
1), TCP/IP NetBIOS Helper Provides support forthe NetBIOS ... Running  Manual (Trig...  Local Service
&} Task Scheduler Enables a user to configureand sc... Running  Automatic Local System
&} System Events Broker Coordinates execution of backgro... Running  Automatic (T... Local System
'-.C:!; System Event Notification Service Monitors system events and notifi.. Running  Automatic Local System
'-.’_.:)} Sync Host_3eabl This service synchronizes mail, co..  Running  Automatic (D,  Local System
) Superfetch Maintains and improves system p.. Running  Automatic Local System
&} Starage Tiers Management Optimizes the placement of data i.. Manual Local System
£k Storage Service Provides enabling services for stor...  Running  Manual (Trig... Local System
'-.”:!;Stwll Image Acquisition Events Launches applications associated ... Manual Local System
'-.S‘:)}State Repository Service Provides required infrastructure su.. Running  Manual Local System
£}, 5SDP Discovery Discovers networked devices and ...  Running  Manual Local Service
0,501 Server VSS Writer Pravides the interface to hackun/r...  Runnina  Automatic | ocal Swstem he

Extended /(Standard/

Start service Viz GH ImEx Agent on Local Computer

6. In the ImEx Agent web interface, click Retry to connect or refresh the page in the browser.

3.10.2 Status box displays an error

1. Click on the error icon to get forwarded the page where you can investigate the error.

GH IMEX version:

Distribution plans:

Import gueue:

Configuration:

Status:

Copyright © 2018 Vizrt

2 RESTs, 2 GHs

CLICKS

Page 246



Graphic Hub Administrator Guide - 3.2

2. In this example, we are taken to the GH REST hosts overview page. Hover the mouse over the
error to display more information, as for example, Request failed: Status='502".

GH REST HOSTS

Status | GH REST Graphic Hub Username Authentication| Imports

e http://TUTORIALO1:19398/ VizDbServer@TUTORIALD1:19... Guest Basic 0

Reque r@TUTORIALO4:19... Guest Basic ]

3. The status code 502 Bad Gateway is returned because the Graphic Hub or REST host used in
a Distribution plan is either not running or reachable.

3.10.3 Status box displays a warning

1. Click on the warning icon to get forwarded the page where you can investigate the warning.

GH IMEX version: 1.0.0.66551
Distribution plans: 3

Import queue: 1036
Configuration: 3 RESTs, 3 GHs

Status: A\

2. In this example we are taken to the GH REST hosts overview page. Hover the mouse over the
error to display more information, for example, GH-Rest not reachable.
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GH REST HOSTS
Status | GH REST
http://TUTORIALO1:19398/
http://TUTORIAL04:19398/

/ http://TUTORIALO2:19398/

nable

Graphic Hub

VizDbServer@TUTORIALO1:19...

VizDbServer@TUTORIALO4:19....
VizDbServer@TUTORIALO2:19...

Graphic Hub Administrator Guide - 3.2

Username
Admin
Admin
Admin

Authentication Imports
Basic 1
Basic 13

Basic 0]

() Note: ImEx displays a warning although GH REST is not reachable. This is proper behavior,

because the given host (here, http://TUTORIALG2:19398) is not referenced by any import
jobs, as you can tell from the enabled trash can icon.

3.10.4 Media staging status shows an error

tion directory Graphic Hub GH REST
. /data/lmportDirectory01 VizDbServer@TUTORIALOT:.  htp://TUTORIALO1:19398/

= Add destination
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1. Hover over the error icon to get further information:

S Destination directory Graphic Hub GH REST
7 /data/lmporiDirectory01 e VizDbServer@TUTORIALOT:.  htup://TUTORIALO1:19398/

€ Add destination

2. In this example, the destination directory /data/ImportDirectory®l has been deleted. To
resolve the error, select an existing folder by clicking the browse (...) icon.

Status | Destination directory Graphic Hub GH REST
/ /data/ImportDirectory01 e VizDbServer@TUTORIALO1:... http://TUTORIALO1:19398/

CLICKS
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3. Selecting an existing folder/project will resolve the error:

Choose directo ry

— data

MyNewProject

Cancel
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tination directory Graphic Hub GH REST

/data/MyNewProject VizDbServer@TUTORIALO1:... http://TUTORIALO1:19398/

3.10.5 Media staging status shows a warning

1. Hover over the warning icon to get further information:

Status | Destination directory Graphic Hub GH REST
A /data/MyRenamedProject VizDbServer@TUTORIALO4: .. http://TUTORIALO4:19398/
ZDbServer@TUTORIALO1:..  http://TUTORIALO1:19398/

2. In this example, the current folder has been renamed.
3. To remove the warning, click the warning icon and Acknowledge to remove the warning.

Status | Destination directory Graphic Hub GH REST
ﬂ /data/MyRenamedProject VizDbServer@TUTORIALO4: . http://TUTORIALO4:19398/
~ta/MyNewProject VizDbServer@ TUTORIALO1:..  http://TUTORIALO1:19398/

(CLICK
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Destination change

ﬂ Destination /data/MyRenamedProject has been moved or
renamed.

Acknowledge

Status | Destination directory Graphic Hub GH REST
/data/MyRenamedProject VizDbServer@TUTORIALO4:...  http://TUTORIALO4:19398/
/data/MyNewProject VizDbServer@ TUTORIALO1:..  http://TUTORIALO1:19398/
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4 Graphic Hub Manager

The Graphic Hub Manager is the administrative tool for the Graphic Hub. It enables the

administration of files and folders over multiple Graphic Hubs, for such tasks as searching, and

working with Deploy Agents.

Server Wew | Tock Edtra Pt Info

4o Address:  Lhdats - O i W-IJ.U_ rI E S G Seandwinc [ViDbSerme @ GHE  Layo |.
[ | tiwme | seelmpe | = .]
O Servers and folders | L, Search -
= Il 1 - VeDbServerpa-SERVERLAdmin
B ass
data
1 abvpect [ plecied
Matee: data
e e %
WD T LEGT: L0 -SEC LT | TIEEFC AR
et |3 g | gy o | |
Saweh: [ e s
I Phskehs case [T ateh wheke s
ol | i |
0 otjedts I

This section contains information on the following topics:

Main Menu
Preferences
Explorer
Servers and Folders
- Graphic Hub Login and Log Out
- Add-ons Panel
- Journal Panel
- Alerts
- Archives Panel
- Action Log
Graphic Hub License
Graphic Hub Manager Customization
Enable a Graphic Hub for a Virtual Studio

4.1 Main Menu

The main menu contains the following items:

Server Menu
- View Menu
- Tools Menu
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Extra Menu
Pilot Menu
Info Menu

4.1.1 Server Menu

Viz GH Manager
Server View Tools Extra Pilot Info

Login... Cirl+G /F7 SERVER
Logout... Ctrl+0 [F&

Terminals... Ctrl+T fF2

Shutdown... Ctrl+w /F10

Chedk....

Import L4
Differences. .. ShifthChrlH-FS

Administer journal entries... Shift+Ctrl+Fa
Configure alerts... Shift+Cirl+F7

Exit Ctrl+Q

Login...: Opens the Login window, used to log on to one or more Graphic Hubs.
Logout: Opens the Log out window used to log out from a Graphic Hub.

Terminals...: Opens the Terminals Window. The Terminals monitor window can be used to
monitor available terminals on the network.

/\ Note: Terminal monitoring is only supported for Graphic Hub Terminal versions prior
to version 3. For Terminal 3, connect to the Terminal’s web interface.

Shutdown...: Opens the Shutdown window, used to remotely shut down servers (see Graphic
Hub Shut Down ).
Check...: Opens the Check Server window where a search for Data Errors in the internal
structure can be performed. Requires the user to be logged on as an Administrator.
Import:
Viz 2.x data: Opens the Import window. From this window it is possible to import a
Viz 2.x data folder to the selected database.
Viz 2.x archive(s): Opens the Import window. From this window it is possible to import
one or more Viz 2.x archives from a folder to the selected database.
Manually selected Viz 2.x archive(s): Opens the Import window. From this window it is
possible to import one or more Viz 2.x archives to the selected database.
Resume from canceled or crashed import: Opens the Import window. From this
window it is possible to resume from a failed import by using an automatically created
import backup file.
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Edit preferences: Opens the import Preferences window. From this window it is
possible to define various preferences for the import operation, for example the root
directory for import log files.
Differences: Opens the Server Diff window. From this window it is possible to detect
differences between two servers, or the servers in a cluster environment (see Detect and
solve server differences).
Administer journal entries: Shows/hides the Administer Journal Entries panel in the Main
window (see Journal Panel ).
Configure Alerts: Opens the Alerts panel, where e-mail notifications and recipients can be
configured for an event where errors occur in the system (see Alerts ).
Exit: Automatically logs out from all connected Graphic Hubs, and closes the Graphic Hub
Manager.

4.1.2 View Menu

Viz GH Manager
Server | View Tools Extra Pilot Info

Toolbars » EERVER
Panels b

SEIVers

fu.f.g ce Archives

= . Messages (Chat) Ctrl+H /F&
Logging panel

—

Duplicates. .. Ctrl+N [ Ctrl+F5
Object types...  Cirl+B / Ctrl+F6

Artive sessions... Cirl+E [ Cirl4F7

Layouts F

Refresh explorer F5

Toolbars: Select which tool bars to view:
Main
Servers and Folders
Folders and Files
Quick Search
- Layout
Panels: Select which Panels to view:
Servers and Folders
Search Panel (see Import external images)
Add-ons Panel
Archives: Open the Archives Panel
Messages (Chat): Show/hide the chat panel in the main window.
Logging panel: Opens the Logging Panel, which shows logged messages, which includes:
Error messages
Warning messages
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Info
Update messages
Tick the Write to log-file to write the selected messages to the Graphic Hub log file, if
required.
Duplicates: Open the duplicates window. From this window it is possible to locate duplicate
server files (see Locate duplicate files ).
Object types: Opens the Object Types window.
Active sessions: Opens the Active Sessions window. From this window it is possible to
monitor all active sessions.
Layouts: Select, save and maintain layouts:
Load layout: Select a layout to load.
Save current layout:
Save current layout as...: Save the current layout as a new layout.
Lock/Unlock current layout ‘xxx’: Lock or Unlock the current layout.
- Maintain layouts: Opens the Maintenance of layouts window.
Refresh explorer: Refreshes the Explorer.

4.1.3 Tools Menu

Server \iew | Tools Extra PFilot Info

: Addres  Monitor servers... Cirl+M / F4
1
Administer users and groups (]
/D% Servers a1 Administer keywords... Ctrl+ /ctrl+F0 |
= Administer add-ons... shift-+Ctrl+78
sy Administer tasks k
— l:IElt
Search by UUID. .. Ctrl+F11

Expart settings (ind. layouts) to file...
Import settings (ind. layouts) from file...

Edit preferences. .. Ctrl+P / Cirl+F8

Monitor servers: Opens the Monitor Servers window. This window shows an overview of all
the servers Graphic Hub Manager is logged in to.
Administer users and groups: Opens the Administer Users and Groups window. From this
window it is possible to manage users and groups on the various servers (see User and
Group management ).
Administer keywords: Opens the Keywords window. From this window it is possible to
manage the Keywords in the database.
Administer add-ons: Opens the Add-ons Panel.
Administer tasks:
Running deploy tasks: Shows/hides the Running Deploy Tasks panel in the Main
window.
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Scheduled deploy tasks: Shows/hides the Scheduled Deploy Tasks panel in the Main
window.
Finished deploy tasks: Shows/hides the Finished Deploy Tasks panel in the Main
window.
Search by UUID: Opens the Search by UUID on server window, used to search for files in the
connected databases using universally unique identifiers.
Configure deploy agent: Opens the Properties of Deploy Agent dialog box. From this dialog
box it is possible to define various Graphic Hub Deploy agent settings (see Deploy Agent
Modes). This menu-option is only available in setups with an installed Graphic Hub Deploy
agent.
Export settings (incl. layouts) to file: Opens a window from where it is possible to export all
the workstation-based customizations to the Graphic Hub Manager, such as changes to any
of the panels, column layout and visibility, as well as the user interface in general.
Import settings (incl. layouts) from file: Opens a window, from where it is possible to import
all the workstation-based customizations to a Graphic Hub Manager, such as changes to any
of the panels, column layout and visibility, as well as the user interface in general.
Edit preferences: Opens the Preferences window. From this window it is possible to define
various system preferences.

4.1.4 Extra Menu

Server View Tuullextra Pilot Info

. Address:  1: - Viz VR Studio Setup... ER'I.JI'ER

Servers and folders * O X

/U"E‘gﬂenrers and folders M-‘LSEErch

=R §1 - VizDbServer @GHSERVER (Admin)
i data

- Viz VR Studio Setup: Allows you to import the enabling XML file so that Graphic Hub can
support a virtual set environment (see Enable a Graphic Hub for a Virtual Studio).
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¥iz GH Manager

Server Wiew Tools  Extra | Pilok  Info

Address: 1: -= Root Differences..,

- Zreate Pilat deplay task...
Servers and folders

/U‘E'gSler-.rersandfolders (W il

=N Fl- '-.-'ithn'E-Er"-.-'er'[EL'"EH'E-EF!.'-.-'EF!.l{Fu:Irriin]l
e data

Differences...: Open the Pilot data differences panel.
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Create Pilot deploy task...: Open the create Pilot data deploy task panel.
Import...: Open the import Pilot data panel (see Main and Replication Servers).

4.1.6 Info Menu

Server View Tools Extra Pilot | Info
Address: 1:-> Root of Wiz Licenseinfo... Cirl+

Viz GH Manager

Servers and folders About...

/G"E‘;Svanrersandfnlders L), searc Help F1

= . 1 - VizDbServer @GHSERVER (Admin;

i data

License info: Opens the License Info window. From this window it is possible to monitor the

license information for the available servers.

About: Shows the software version and build number of the Graphic Hub Manager.

Help: Opens the Graphic Hub online help file.

4.2 Preferences

The Preferences window, located under Tools > Edit Preferences, shows all the system preferences

and is divided into the following panes:

General

Import

Viz

Monitor Servers
Agents
Archives
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4.2.1 General

The General preferences consist of:

Login

Login Profiles

Timeouts and Buffer Settings
Deploy Direct Copy

Startup

Look

Login

In the Login panel, set the Start-up and Login preferences.

|

— General

TCP Port used for Logins: 1939 St default |
— Auto login

[T Use Auto login

™| Brotect &uto lagin with passward Set passwond... |

™| Confim Auta login
En-/disable servers for Auto login and change Auto login order:

Mame | Type | |ser | Sysh |
O VvizDbServer@GHSERVER Standard Admin @ No
O GHMainServer@GH-MAIN Mair Admin Mo

Up | Top | Mote: Use buttons to the left to change Auto login order. Use context
5 5 menu in the list of servers for more options!
. it

¥ | Frecheck availabiliiof semvers before login

I™ | Enable'Login to multiple servers using Aute [ogin at any time

[T Enable ‘Logout from all servers’

0K I Cancel Smply
i

TCP Port used for Logins: Sets a TCP port to be used for Log-ins. Click Set default to set the
TCP Port back to its default value (19396).
Auto Login:
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Use Auto Login: Enables Auto Login when box is checked.
Protect Auto Login with Password: Sets a master password for auto Login.

Confirm Auto Login: Checks to require login confirmation for the Graphic Hubs which
are part of the Auto Log-in list.

Note: This option is not available if Protect Auto Login with Password is
enabled. When Protect Auto Login with Password is checked, automatic login is
disabled.

En-/disable servers for Auto login and change Auto login order: Selects which servers to use
Auto Login.

Up/Dn./Top/Bot.: Changes the Auto login order of available servers.

Pre-check availability of servers before login: Contacts servers designated for Auto login
before actual login when selected. If they cannot be contacted, they will automatically be
unchecked for Login and diagnostic info will show in the according line of the server in the
login window.

Enable 'Login to multiple servers' using Auto login at any time: Provides the option Login >
to multiple servers in the main menu, under Server when selected.

Enable 'Logout for all Servers': Provides the option Logout > from all servers in the main
menu, under Server when selected.

/\ Note: Complete automatic login to Graphic Hubs will only be available if Auto login is
not protected with a (master) password, if a Login profile does not exist and if
Confirm Auto log-in is not checked. And even if all those conditions apply, automatic
login will not be started if Precheck availability of servers before login is ticked and
not all of the servers seem to be available for some reason.

Login Profiles

Click this tab to configure different Login Profiles for use with Auto Login. Use Login Profiles to
configure which servers and associated Deploy Agents should be logged onto by Auto Login.
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* Login profiles

- Logity prafiles (Mate: Thewwill anly be wsed if Auto g @ enabled)

[Login profie 1 =] New | Dekte |
Choose servers for use in login profile ‘Login profile 17
MName | Type | Version | |zer |
VizDbServer@GHSERVER Standard 300... Admin
GHMainServer@GH-MAIM Main 3.0.0... Admin

l | H

2 servers in login profile “Login profile 1°

Chioose deploy agents for use in login profile "Login profile 1%
IP address | Name | UDF port | Re

1| | i

(' deploy agents in login profile "Login profile 1°

Revert. ..

Login profiles: Selects, creates or deletes login profiles.

Choose servers for use in login profile <login profile>: Selects which servers to include with
the login profile.

Choose deploy agents for use in login profile <login profile>: Selects which Deploy Agents to
include with the login profile. If no Deploy Agents are selected for the Login Profile, Deploy
Agent configuration and deploy tasks will be unavailable for the duration of session. If no
Deploy Agent is configured in the Agents section, this list will be empty.

Revert: Reverts settings before Apply or OK is clicked, if required.

Timeouts and Buffer Settings

From this panel it is possible to define various timeout values related to communication with
Graphic Hubs. Changing the values of the timeout settings may have a significant impact on how
the Deploy Agent works. The default values should only be changed if the Deploy Agent has
problems with servers connected through a slow or congested network, or that have an unusually
high server load. Increasing the timeout values may solve the problems in such cases. Decreasing
the values will not improve the general performance of the agent, and is not recommended.
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'ﬁl’ Preferences

General
w 8 Login
+2 Log

2 Timeou
w2 Deploy
w2 Startup
2 Look

= Import

Viz

%3 General

a

& .
as Monitor servers
& Warnings

€l Agents
o Deploy
Archives
% General
&3 Import
& Export

+# Timeouts and buffer settings

. . Related to communication with Viz Graphic Hubs
in profiles

ts and buffer Establishing communication timeout {in seconds)
Direct Copy Communication round trip timeout in seconds):
Cluster failover timeout {in seconds):

Transfer buffer size: (50.00 KB) 1

— —
n n

LS

t defaults

[%p]
a1}

Cancel Apply

Related to communication with Graphic Hubs:

Establishing communication timeout (in seconds): Sets the maximum amount of time
for a Deploy Agent to connect to a server. If the server does not respond in this set
time, due to network characteristics or server load, it will be considered as offline.
Communication round trip timeout (in seconds): Sets the maximum amount of time
for the Deploy Agent to wait for a reply from the server. If the server does not respond
in this set time, due to network characteristics or server load, the affected task may be
paused by the Deploy Agent.

Cluster failover timeout (in seconds): Specifies the period that a task is waiting for a
notification from the failover server to switch over if a main server becomes
unavailable. If this time exceeds, the agent will manually try to connect to the failover
server. This option is relevant for Deploy Agents that operate in a setting with a
failover server.
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Deploy Direct Copy
In the Deploy Direct Copy panel set the Direct Deploy Copy defaults.
# Deploy Di

— Default "Behavior options'
IHEI::uiIu:I onginal structure j

¥ Overwrite existing objects
¥ Overwrite existing references
¥ Keep original owner

— Default "Multiserver processing options”

{* Deploy all files to the first server, then to the second, and so on

" Deploy one file to all servers, then ancther file, and 20 on

Default Behavior options: Set the defaults for Deploy Direct Copy:

Rebuilds original structure,

Rebuilds structure under target folder,

Copies to target folder only.
Overwrite existing objects: Overwrites files with the same name existing in the target folder.
Overwrite existing references: Overwrites the file references if the same file name exists in
the target folder.
Keep original owner: Keeps the original owner of deployed files when selected. If the file
existed already on the server, the owner of the pre-existing file will be kept.
Default Multi-server processing options:

Deploys all files to the first server, then to the second, and so on.

Deploys one file to all servers, then another file and so on.

Startup

In the Startup panel, specify if the listed windows should automatically open on a new start of the
Graphic Hub Manager. Also, specify if this should depend on if those windows were open when the
Graphic Hub Manager was last exited.
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— Automatically open windows

¥ Automatically open windows that were visible on last exit
Mote: This affects only the windows mentioned below.

™| Automatically open 't onitar senvers!
¥ Bt only, ifit was open the last time
™| sutomatically open Hetive sessions!
¥ | But only, if it was open the (st tme
[T Automatically open 'Teminals!
¥ Bt only, ifit was open the last time

- Automatically open windows that were visible on last exit: Opens all windows listed below, if

they were open on the last exit when selected. If not ticked select which windows to open
from the list below:

Automatically open 'Monitor servers' / 'Active sessions' / "Terminals': Opens a window on
start-up when selected.

But only if it was open the last time: Opens the window at start up only if it was open
on last exit.

Look
In Look panel set the style of the User interface.

Wisual appearance

Wisual style: I‘.".u'inu:h:uws 7 j

[T Docking Tab Colors

Visual Style: Sets the user interface style from the drop-down list
Docking Tab Colors: Assigns tab colors in the GUI

4.2.2 Import

In the Import panel, set the data directory for log files and temporary files used for the import of
Viz 2.x data and archives (see Import Viz 2.x Data and Archives).

It is also possible to disable the auto-import when an import resumes after a canceled or crashed
import procedure.
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— Directories
See below the root directary for log files written by
imports; Press "Browse.."to change it.

I Browse. .. |

See below the root directony for temporany files
used by imports; Press ‘Browse..."to change it.

IC:\Users\danpData\Lccal\Temp Browse. .

U

— Behavior
¥ Sutomatically start import in case of ‘Resume’

— Troubleshooting
Below you may set the complete path for the
import executable. Use only in case of troubles!

Clear it to have regular import conditions. Clear

Browse. ..

Il

Directories: Shows the root directories for log and temporary files. Select Browse to change
the directories if required.
Behavior: Starts import automatically if the system is resumed when selected.

Troubleshooting: Shows the location of an alternate import executable (viz_import.exe) if
there are problems with the Graphic Hub Manager. This field normally should be empty.

/\ Note: This alternate import executable could either be an older one than the one that
came with the installation or a newer/updated one sent out by Vizrt.

4.2.3 Viz

General

In the Viz panel, define the TCP port and Viz executable to use within the "Re-save with viz..."
dialogue in the files, folder or search results view. This enables Graphic Hub Manager to send
transfer control protocol commands to the viz executable to re-save files and folders.
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'ﬁ!’ Preferences

&® General
w 8 Login
»# Login profiles
w2 Timeouts and buffer
»2 Deploy Direct Copy
w2 Startup
2 Look
= Import
Viz
=3 General
&, Monitor servers
w1 Warnings
€l Agents
o Deploy
Archives
% General
&3 Import
& Export

a

=1 General

Communication
TCP Port: | 6200|

Wiz executable
Wiz |Defau|t (C:"Program Hles\\ﬁzﬂ\\ﬁz,?-\\riz.exe| Browse

Mote: set to default, f the cument installed viz exe should be used.

Set default

Defautt

Apply

4.2.4 Monitor Servers

In the Monitor Servers panel, define various disk and memory warnings, related to free disk space/
memory. It is also possible to define warnings when the license expiration date approaches.
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Warnings

— Digk wamings
Wam me, if free disk space falls below 10% -
of total disk space.
Serious waming, if free disk space falls below [ -
of total disk space.
Wam me, if free disk space falls below 150% -
of server's disk limit.
Serious waming, if free disk space falls below I 1255 = I
of server's disk limit.

— Memary wamings
Wam me, if used memary exceeds o0 -
of total memary.
Serious waming, if used memory exceeds R -
of total memary.

— License wamings
Wam me, if license expires in less than: dwesks ™
Serious waming, if license expires in less than: Fweeks T

4.2.5 Agents

The Agents panel is used to set the preferences for automatic updates on running Deploy Agents.
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Deploy

= Deploy

— Settings to use for searching for running deploy agents
Search for deploy agents on those LUDP ports:

13392 < Add I

g |l Top
Bemove > | on | Bt

Use this timeout for receiving answers from deploy agents:

I 100 (miliseconds)

Deploy agents not reachable via UDP broadcast
and./or for use in Login profiles:

IP address | MName | UDPport | Receiv < Add... |

Hemove

Fdmdifi.. |

g | Top

1] | _*I Dr. | Bok

~ Intervals (in seconds)
Interval to get updated info for running tasks:

]
Interval to try to reconnect to lost' agents: I 5

Search for deploy agents on these UDP ports: Enter the UDP port where to search for
available Deploy Agents. Deploy agents are configured to listen on port 19392, by default. If
they are configured to listen on another port, this port should be added here

/\ Note: With a UDP search, the Graphic Hub Manager will only find Deploy Agents
which listen on the ports which are added here, and only those which are running on
machines within the same subnet as the machine running the Graphic Hub Manager
itself.

Use this timeout for receiving answers from deploy agents: Sets the timeout (milliseconds)
for a Deploy Agent search. Default is 100 ms.

/\ Tip: If there are problems with the network condition, try to increase the default
value.

Deploy agents not reachable via UDP broadcast and/or for use in Login Profiles: Manages
Deploy Agents (Add, Remove, Modify or change the order of listed Agents) that are running
on a machine, which is outside the subnet of the machine on which the Graphic Hub
Manager is running.

If Deploy Agents are to be used in Login Profiles, they must be added here even if they are
on the same subnet.

Copyright © 2018 Vizrt Page 268



Graphic Hub Administrator Guide - 3.2

When Add or Modify is clicked it opens the Deploy Agent window:

x
IP address: I |
LIDP port: W Zheck |
Receive timeouk; I—IEIIZI (milliseconds)
TransfFerbuffer size: Iﬁl_l (50,00 KB)
Marme: I

(] 4 Cancel

IP address: Enter an IP address or host name.
UDP port: Enter the UDP port number.
Received timeout: If the Deploy Agent does not answer in the given timeout or does so
only sometimes, you may increase this timeout value here to make sure that the
Graphic Hub Manager can always contact the Deploy Agent.
- Name: Name of the host/machine (auto filled).
Intervals (in seconds): Timeouts for answers from Deploy Agents:
Interval to get updated info for running tasks: Sets the interval, in seconds, in which updated
information about tasks executed by the Deploy Agents should be requested.
Interval to try to reconnect to lost agents: Sets the interval, in seconds, in which the Graphic
Hub Manager should try to recontact Deploy Agents for which communication with them was
broken.

4.2.6 Archives

In the Archives panel set the preferences for the import and export of Archives as well as some
general preferences.

General Preferences

= General Bl

' atched folder(z]

Path
C:hArchive
C:Marchive\Manager

1| | H

Add... | Hemove selected

Copyright © 2018 Vizrt Page 269



Watched folders: Lists all Watched folders.

Graphic Hub Administrator Guide - 3.2

Note: The Archives view will automatically list all (Viz 3.x) archives (extension 'via')
which it finds in any of the given watched folders. Sub-folders of watched folders are
not automatically watched, make sure to specify each single folder, as required.

Add...: Adds a new Watched folder.

/\ Tip: If a folder shows as yellow, there are no Viz Archives in that folder. If a folder

shows as red, it currently is not accessible or does not exist.

Remove selected: Removes a Watched Folder (this removes the folder as a Watched folder,

but the folder will stay in the Graphic Hub Manager Customization).

Import Preferences

£33 Import

Default settings...

Import mode: Rebuild original structure

Overwrite mode: | Overwrite

Farce link name creation

Impaort...

Overwrite owner
] overwrite name

Import add-ons

Default settings...

Overwrite create date
COverwrite access rights

Import keywords

Set defaults
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Import mode: Sets the import mode:
Rebuilds original structure.
Rebuilds structure under target folder.
Copies to target folder only.
Overwrite mode: Sets the overwrite mode:
Overwrite: Overwrites all files on import. Files will not be overwritten if the destination
file has exactly the same content.
Duplicate: Imports with a new file name if a file with the same name exists.
Skip: Does not import if a file already exists.
Force link name creation: Creates links to all links from the original and imported file
if the file to be imported has the same data, but has different file links.

A Overwrite options (Overwrite owner, name, create date, access rights). Defining whether
the previous owner, name, create date or access rights of the file should be overwritten
with the current owner, name, create date, access rights after a successful import. If the file
already existed on the target server the parameters of the existing file are kept and not
overwritten. The file parameters on the target server are overwritten if a successful import
did happen and the file was newly created on this server.

Select which data from the source file will be applied at import:
Overwrite owner.
Overwrite name.
Overwrite create date.
Overwrite access rights.
Import add-ons.
Import keywords.

/\ As these settings are under the import section, they change the parameters of the file
being imported.

For example, if a file has a Owner = Owner] and Creation Date = yesterday and you import
it to another server today, then:

If the settings Overwrite Owner and Overwrite Creation Date are set, the Owner is
changed to Owner?2 and Creation Date is changed to today at successful import.
The overwrite is not file-based, it is based on the file parameters selected at import.

Export Preferences

In the Archives Export panel, create new and view Archive export Templates.
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& Export

Templates for creating name of new archives:

Template Preview

<MNICK>"s-Archivefrom-<GHz-gyyyye-<MM=-<dd >-chh > <mmz<ss=<T 1> Admin's

L4 >
FRemove Add
MNew template:
Addtoken -
Preview:

Default template for creating name of new archive:
«NICK>"s-Archive-from-<GHz-cyyyy>—<MMz-<dd >-chh=<cmm><g82<TT> st

Export all linknames
{uncheck to include only linknames in curent tree)

Settings incompatible with pre 3.0 versions...
[] AMllow extended header

Set defaults

Templates for creating name of new archives: Selects a template from the list.

Remove: Removes a selected template.

Add: Adds a new template. First create the new template in New Template.
New template: Creates a new template. Select tokens to add from the Add token drop-down
(use separators as required between the tokens).
Preview: Shows a preview of the new template.
Default template for creating name of new archive: Selects a default Template from the list
of Templates.
Export all linknames: Enables an export of all linknames when checked. Unchecking this
exports only the linknames from the folder/project, the file is dragged from.
Allow extended header: Enables / disables extended header functionality for archive
creation.

/\ IMPORTANT: Enable this for a system with all clients at least version 3.0.0. The
extended header flag generates incompatible archives for pre 3.0.0 versions.

See Also
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Graphic Hub Deploy Agent
- Archive Folders
Graphic Hub Archives

4.3 Explorer

Below the main menu is the Explorer of the Graphic Hub Manager.

i
i I
H
i

aan
HH =
2
I
LELyig

/\ Tip: The panels in the Explorer are resizable, and they can be dragged around. Also, it is
possible to navigate through the trees in the Explorer with the mouse pointer, arrow keys,
or by typing the first character of the required folder/file.

The Explorer is automatically updated immediately after changes made to files and/or folders, but
a manual refresh of the Explorer is sometimes necessary, for example after re-enabling columns.
To refresh the Explorer, select View > Refresh Explorer or press F5.

This page contains information on the following topics:

Explorer Columns
Column Headings
- To Hide, View, Remove or Add Columns
Explorer Icons
- Tool Bar
Main
Servers and Folders
Folders and Files
Quick Search
Layout
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Display Files as Icons

4.3.1 Explorer Columns

When server files are shown in the Explorer view, columns are used to show information about the
files.

There are two mandatory columns, Name and UUID (these can be hidden if required), and then
additional columns which can be added or removed as required. Each column can be moved to a
new position as required.

Column customizations works for:

Explorer
Search results
- Journal
- Server differences
- Scheduled tasks
- Action Logs
Running tasks
Finished tasks

4.3.2 Column Headings

e | Szw | Pppw | Dt maceched | Mo by | uatw crmabud | s | Becomm wgh . | Chascimm | e

W i=ap LIikEE PG IO R 0 P A ST & 2h 53 P [a = W A0 SRR b e | T ke T BT
W = LOREE pAALE SR TN P A MR AR e el W FISAR N ARH BT FAT L R R T
[ B 1.5 P MALE SO TAEAL P Adean Lt LS Tl e L SURADTRA T THET TCND-TEOA SR SRR A LT | SO

Name: Shows the name of the file.
- Size: Shows the size of the file.
- Type: Shows the file type, for example material.
Date Modified: Shows the date and time when the file was modified the last time.
Modified by: Shows the name of the user that modified the file the last time.
Date Created: Shows the date and time when the file was created.
- Owner: Shows the name of the user that owns the file.
- Checked out by: If the file is checked out, shows the name of the user that has checked it
out.
Locked by: If the file is session locked, shows the name of the user that is working on it.
- Access rights (U/G/W): Shows the access rights for user, group, and world (see User and
Group management ).
Folder links: Shows the number of folder-links (number of folders the file is placed in).
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To Hide, View, Remove or Add Columns

1. Right-click on the column bar.
[|

v 7
e Hide this column &I Da_'t? e I M:?c
mlg Remove column lame
;g Hide column F  Type
g Display column r Size
Femove ALL non-mandatory columns Date modified
Display ALL columns Modified by
z = Date created
Size ALL visible columns
Owner
Checked out by
Locked by
Access rights (U/G/W)
Folder links

2. Add, remove, hide or show columns, as required.

/\ Note: In Remove Column, UUID and Name are grayed out. They cannot be removed,
but they can be hidden.

To customize the column order, drag the column to the required location.

4.3.3 Explorer Icons

The following icons are used in the Explorer:

Description Icon Description
Regular Folder n Image
Project Folder Material

E
—

Audio Material advanced

Base font Scene

. )
o
l. ’
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Icon Description Icon Description

Video
s

Font

n Geometry

4.3.4 Tool Bar

At the top of the Explorer is the Tool Bar.

iz L st
S Wew Teok Dibve Mot i

.ZI':- B & | ssde Vasmebeem = iy g
Main
B

D% Show Servers and folders: Show/hide the Servers and Folders, or click View > Servers and

Folders.

Q Show search: Show/hide the Preferences.
# Show add-ons: Show/hide the Add-ons Panel.

= [P r—— = - Layout: [Syrtam-Dotmat o et 0. =

Lawm Sewr

Servers and Folders

Address:  1hdata\Projectl

*

&1 One level up: Jump one level up in the Servers and Folders tree structure.
- Address: Shows the current folder path.

From the drop-down list, it is possible to see the history of all folders that have been used

within this session. To re-open to one of these folders, select it from the list. The format in
which the history is shown is <ServerNumber>:\data\<path>.

The history of a server that has been disconnected will no longer be available.

Folders and Files

Type: IALL j |

- Type: Filter file types. Click the arrow to the right to toggle between the options

£ Show/Hide project and folders: If enabled, the subprojects/sub-folders of the selected
folder will show in the Explorer list

o Display icons/Details: Toggles between showing files in the Explorer with details or as
icons

Copyright © 2018 Vizrt Page 276



Graphic Hub Administrator Guide - 3.2

Quick Search

Search in: I';'i:I:IJS-‘::'-.-‘-‘:i'ilGHSEF“'."E!-'!!;-:Imin; j o4

Search in: Graphic Hub Quick search function. Select a server to search in, enter a search
string and press <Enter> or click on “A to start a Free text search on the selected server

Layout

Layout: ISystem-CIean (locked) j Save Save as..

Layout: Click to load a saved layout. Options:
System Clean (Locked): (Basic standard layout)
System Default: (as last saved (default layout)

Save: Click to save the current layout.

Save as...: Click to save as a new layout.

/\ Note: A Layout is local for the current machine in use.

4.3.5 Display Files as Icons

By default, the files in the Explorer are presented with detailed information. To view the files as
icons, toggle the "4 (As Icons) button in the Tool Bar.

/\ Note: The icons can also be enabled from the shortcut menu of the Explorer.

B"*"B % £Y & B
1“ A st e A
Schalke_04  Wfb_Stutkgart Borussia_... Eintrachtfr... Baver_Lew... Fc_cologne  Foenmergie  Bawern_M... Dsc_armlnl... Hannover _96

When files are viewed as icons, in the lower right corner of the icon characters will show the file
type:

Icon Description Icon Description
| A Audio | 1] Image
| B Base font | M) Material

]  Default {2  Material advanced
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Icon Description Icon Description
| F| Font B Scene
| G Geometry K Video
Additional information may also be shown on the icon:
Icon Description Icon Description

[  File holds more than one folder-link [=]  File is checked out

|I| File is session locked (L) File is both session locked and checked out
See Also

Graphic Hub Manager Customization

4.4 Servers And Folders

The Servers and Folders panel displays folders, and the servers they are on, in a tree structure.

= B 1 - VizDbServer@EHSERYER Adrmin)
E W data
= & Projectl
.. SubFoldert
.. SubFolderz
= & Projectz
W SubProjectl
W SubProjectz
... Folder1
... Folderz

Right-click a server folder in the tree to open a context menu. From this menu, the folder tree can
be expanded or collapsed, and, for example, new folders created or access rights set.

The server tree order can be changed by drag and drop. The server order changes, but server
numbers stay the same.
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=
o Collapse

Expand completely
Collapse completely

MNew

Rename

Search in 'VizOpus'...
Maovwe this

Deploy...

Create deploy task...

& Export to archive...

Set owner...
Set access...

e 2

Set expiration date...
Set creation/modification date...

Re-zave with viz...

Compress images...

0 Delete...

Properties...

This page contains information on the following topics:

Folders
- Tree Structure
- To View the Content of a Folder
- Working with Folders
- To Expand Folders
- To Collapse Folders
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- To Create a New Folder
- To Rename a Folder
- To Move a folder
- To Change the Owner of a Folder
- To Set Rights for a Folder
- To Delete a Folder
Folder Properties
- To View the Properties of a Folder
- To View the Properties of Multi-selected Folders
General Properties
- Add-Ons Properties
- Working with Files
- Overwrite Files
- To Create Linked Files
- To Create Duplicate Files
- To Create Duplicate Files including Referenced Objects
- To Move Files
- To Overwrite Files
- To Re-save with viz executable
File Properties
- To View the Properties Assigned to a File
General Properties
Keyword Properties
References and Link Properties
Duplicates
- Total Size Properties
- Advanced Properties
File History
File Availability
- File Add-ons
Folder and File Expiration Dates
- To Set an Expiration Date
Illegal Characters

4.4.1 Folders

The server tree can contain two types of folders:

Project folders, displayed with a blue folder icon.

Regular folders, displayed with a yellow folder icon.

Project folders cannot be created inside a regular folder, but can contain regular folders.
Both types of folders can be dragged around after being added to the server tree. Also,
project names must be unique and in compliance with the list of illegal characters.
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=l | Quiz
@__,, @ Performer
W shows
@_* . Shadertest-1-0
. Shadertest-1-0-

In Viz Artist, the difference between a regular folder (2) and a project folder (1) is that by defining
a working project, the tree can be collapsed so that only the currently selected project and its sub-
folders and sub-projects folders are shown.

4.4.2 Tree Structure

Within the database, files are organized in a virtual structure of project and regular folders. This
structure is shown as a tree in the Servers and Folders panel.

= B 1 - VizDbServer@GHSERYERABdmin)
B & data
= & Projectl
.. SubFoldert
.. SubFolderz
= & Projectz
e SubProjectl
e SubProjectz
... Folder1
... Folderz

In this panel, all connected servers are shown as root entries. These entries show the name of the
Graphic Hub Server, the Graphic Hub Naming Service the server is registered on, and the current
user name.

The level below the root entry contains the data project, which other clients refer to. New projects
or regular folders/files can be added under the data project.

/\ Tip: Itis possible to create folders on the same hierarchy level as data, but these folders
will not be accessible from client applications such as Viz Artist. In these folders, it is
practical to move data that should not be worked on anymore, yet is not ready to be
deleted.

The data directory holds folders that the server files are stored in.

To View the Content of a Folder

Click the folder in the tree, or

Double-click a subfolder in the Explorer, or

Right-click the folder, and select Open.

The server files in the selected folder will then be shown in the Explorer.
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4.4.3 Working with Folders

To Expand Folders

After logging in, the branch representing this database will be collapsed. To expand the branches,
use one of the following options:

- Click to the left of the branch.
Double-click the branch to be expanded.
Right-click the required branch and select Expand.
Right-click the required branch and select Expand Completely to expand the branch and all
its subbranches.

To Collapse Folders

Use one of the following options:
- Click to the left of the branch.
Double-click the branch to be collapsed.
Right-click the required branch and select Collapse.

Right-click the required branch and select Collapse Completely to collapse the branch
and all its subbranches.

To Create a New Folder

Use to create new Regular or Project Folders.

/\ Note: A new project folder cannot be created in a regular folder.

1. Right-click on a folder, or select the folder and right-click in the Explorer.
2. Select New > Project or Folder.

To Rename a Folder
Right-click the folder and select Rename.

/\ Note: The data project below the server root entry cannot be renamed. Folder names
must be unique, and in compliance with the list of illegal characters below.

To Move a folder

1. Drag the folder from either the servers and folder or the Explorer onto the target
destination.
The Action Log for moving folders is shown.
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2. Click Duplicate.
You can also use standard Windows functions Ctrl+X, Ctrl+V and Right-click > Cut/Paste.

/\ Note: This procedure only applies to moving a folder within a single server. For information
about moving folders between multiple servers, see Schedule a Deploy Task.

To Change the Owner of a Folder

1. Right-click the folder.
2. Select Set Owner.

Set owner of 'Projectl’... x|

"Owner ko set

Adrnin hd

I™ | apply anly to objects which arent in ather falders
[ apply ta all subfalders and ohjects

Seb,.. Cancel

Select the new owner from the drop down list.
Select the Apply to all subfolders and objects check box, if required.
. Click Set.
The Action Log opens.
6. Click Set owner.
7. Click Close.
The owner of a folder can also be assigned from the folder Properties window.

SEEY

To Set Rights for a Folder

1. Right-click the folder.
2. Select Set access.

Set access rights of ‘Projeckl’.. x|

User rights: v Write
iaroup rights: v Write
World rights: v ‘Write

™| fpply anly to objects which arent in ather falders
[ apply ta all subfalders and ohjects

Seb,.. Cancel

User: The owner of the folder.
Group: All the members of the group the owner belongs to.
- World: All database users.
3. Define the new rights.
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4. Click Set.
The Action Log for changing the rights is shown.

5. Click Set access.
The rights for a folder can also be assigned from the folder Properties window.

To Delete a Folder

1. Select the folder.

2. Delete the folder:
Press Delete, or right-click the folder and select Delete...
The Action Log opens.

3. Click Delete.

4. Click Close.

Note: Only empty projects or folders can be deleted. Also, by deleting a folder from
the Graphic Hub, the respective folder-links in the properties of the files will be
deleted too.

4.4.4 Folder Properties

The Folder Properties window lists available properties of each folder.

To View the Properties of a Folder

1. Right-click a folder.
2. Select Properties.

To View the Properties of Multi-selected Folders

1. Multi-select the required folders (1).
Right-click folders with Ctrl pressed, or
- Select a range of folders with right-click with Shift pressed
Right-click on one of the selected folders.

3. Select Properties.
The Properties window shows the Generally combined contents of all selected folder (2) and

is for information only.

N

Add-ons are not available.
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General Properties

Mame: Default

bee e .

LD S50555B55-A34F-4550-53F5 7D 82IFCO323

Path: data

Name: IDefauh

Chwner: I Admin j

Created: 11 June 2014 10:12:27

Expires: r Never |

Cortains: 162 projects, 139 folders, 71 files. 25.53 ME
Type ¢ | Count] Size |
& Project 162
.. Folder 139
W FONT 1 301 53 KB
B GEOM 7 13663 KB
B IMAGE &2 2237 MB
&) SCENE 1 273MB

Lzer rights: ¥ Fead v Wiite
Group rights: ¥ Fead W Wiite
World rights: ¥ Fead v Wiite

Name: Shows the name of the folder. Folder names must comply with the list of Illegal
Characters.

- Type: Shows if the folder is a regular folder or a project folder.
UUID: Shows the automatically generated UUID of the folder.
Path: Shows the path of the folder within the data directory of the database.
Name: Shows the name of the folder. To rename the folder, type a new name in the box.
Owner: Shows owner of the folder. To reassign the folder to a new user, select a user from
the list.
Created: Shows the date and time when the folder was created.
Expires: Set an expiration date for the selected folder or file.
Contains: Shows a summary of all folders and files contained in the selected folders.

- Access Rights: Shows the access rights for the folder. To change the rights, enable/disable
one or more check boxes (see User and Group management).
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Add-Ons Properties

Add-Ons

Mame: Default :ﬁ
b e -_
LD S50555B55-A34F-4550-53F5 7D 82IFCO323

B Text | @ edit| B o |

Search: I Dnl U|:||

[~ Match case [~ Match whole word

-
| | b

The following folder properties are available in the Add-ons panel:

Name: Folder name.
- Type: Project or Regular Folder.
UUID: Automatically generated UUID of the folder.
- Text tab: Assigned add-ons as text.
- Edit tab: Enables editing and assignment of add-ons.
- XML tab: Assigned add-ons as XML.
Search: Search text within assigned add-ons.

Copyright © 2018 Vizrt Page 287



Graphic Hub Administrator Guide - 3.2

4.4.5 Working with Files

Overwrite Files

When a file type is to be linked or duplicated in another folder, and the same file type with the
same name already exists in the destination folder, the Overwrite Existing File dialog menu opens.

Select an option from the window:

A MATERIAL with the name "Vellow' already exists,
Do you want to ovenwrite the existing file?

| ves || vestoan || N0 || motomn || Ccancel

Yes: Overwrites the existing file.

Yes to All: Overwrites all existing files.

No: Does not overwrite the existing file, and create a new file.

No to All: Does not overwrite all existing files and create new files.
Cancel: Cancels the action.

To Create Linked Files
A link to the file is created in the destination folder.

Linked files have the benefit of saving disk space and enhancing system performance. It is
especially useful when a file is referenced in many places. For example, a station logo is best to be
referenced as a link rather than duplicated in many locations.

1. Select the required file.

/\ Note: Multiple files can be selected.

2. Drag the file to the target folder and release.
3. In the Action Log click Link.

Duplicate, Link or Move... (on server "YizDbServer@GHSERYER') =10] x|
File | action [ From | To
ans IMagel Link, datajProject] datafProject2/SubProject]
sas IMaQE3 Link. datajiProject] datafProject2/SubProject 1
sas IMAQEE Link, datajProject] datajProject2/SubProject 1
1| | i
[ Close this window automaticaly if no problems occurred I Link I Cancel I

¥ Reuse this window for same actions
¥ Do nat insert enkries that are already in the ksl [ Warn me about not inserted

3 entries to be processed. _ | -
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4. If the same file type, with the same name, already exists in the destination folder select to
overwrite, or not overwrite, the existing file.

5. Click Close.
or

1. Select the required file.

/\ Note: Multiple files can be selected.

2. Create a linked shortcut:
Right-click and select Link (create shortcut), or
Press Ctrl+Y.

3. Select the target folder.
4. Link the file:
Right-click on the target folder and select Link here, or
Right-click in the folder area and select Paste
5. In the Action Log click Link.
6. If the same file type with the same name already exists in the destination folder select to

overwrite, or not overwrite, the existing file.
7. Click Close.

To Create Duplicate Files
1. Select the required file.

/\ Note: Multiple files can be selected.

2. Press Ctrl and drag the file to the target folder and release.
3. In the Action Log click Duplicate.

Duplicate, Link or Move... (on server “¥izDbServer@GHSERYER') =10] x|
File | action | From | 10
ves IMagel Duplicate datafProject] datajProject2/SubProject 1
ves IM3QES Duplicate datajProject] datajProject2/SubProject 1
ves IMEQEZ Duplicate datajProject] datajProject2/SubProject 1
1] | >
[™ Close this window automatically if no problems occurred I Duplicate I Cancel |

¥ Reuse this window for same actions
¥ Do not insert entries that are already in the ksl [+ Warn me about not inserbed

E‘Saﬂtri&s ko be processed, | -

4. If the same file type, with the same name, already exists in the destination folder select to
overwrite, or not overwrite, the existing file.

5. Click Close.
or

1. Select the required file(s).
Copy the selected file(s).
3. Select the target folder.

N
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Right-click on the target folder and select Duplicate here, or
Right-click in the folder area and select Paste

5. In the Action Log click Duplicate.
6. If the same file type with the same name already exists in the destination folder select to

overwrite, or not overwrite, the existing file.

7. Click Close.

To Create Duplicate Files including Referenced Objects

1. Select the required files. Right-click and drag files to target servers folder.

2. Select Copy here (DDC!).

[ 1_ Mame Size Date expirat
D‘E'g servers and folders 'u.:'. Search i8] douds1 = —i2E29MB  none
v W) 1-VizDbServer @7420-KKL (Admin e ngh‘t—cllckq? VB none
- B inter ==TME none
v il 2- Link here... |1 11363623_899730536757198_20545... 889.13KB none
- Move here... & alu_normal 431.03KB none
L - | .
E ] 2 Copy here (DDCY)... &4 Carbon-Fibre_BLACK 387.30KE none
[% K3 Oswald-Light-Outline-1 254.76KB  none
Cancel A3 Oswald-Light-Blur-1 193.20KE  none
L
Copyright © 2018 Vizrt Page 290



Graphic Hub Administrator Guide - 3.2

3. In the Deploy Direct Copy dialog after Analyzing and checking Behavior
options, Click Continue.

$#F Deploy Direct Copy - Analysis & Options — O * 0
Summary :
Destination path: VizDbServer@Z420+KL: /data 1

Available disk space on server “VizDbServer@Z420-KKL" 9749GE |

Selected objects: 3 21.23MB 21.23 MB 4

Referenced objects: ] 0.00 KB OOOKE |

All objects: 3 21.23MB 21.23 MB [

Analysis !
bg-douds {IMAGE - 12,29 ME)
uffizi_cross_hdr (IMAGE - 4,47 ME)
inter (IMAGE - 4.47 ME)

Infos, warnings & errors

Info: Analysis finished without any warnings or errors!

Step 5 - Analyzing objects on the target server: Jof3

Behavior options

Rebuild original structure o

Owerwrite existing objects (Does not apply to referenced objects)
Owerwrite existing references
Crwverwrite owner

cacl
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4. Click Deploy.

3 Deploy Direct Copy... (from 'DEMO-GH@DEMO-GH) — m] *
File From To Over... Owverwrit... Sourc... Progress  Progress info Info
s doudsl data/Vizrt/VizOpusfsc...  VizDbServer @Z420-KKL: (Build ... fes fes Yes Mot yet processed!
s Uffizi_cross_hdr dataVizrt/VizOpus/fsc...  VizDbServer @Z420-KKL: (Build ... fes fes Yes Mot yet processed!
s iNtET data/Vizrt/VizOpusfsc...  VizDbServer @7420-KKL: (Build ... fes fes Yes Mot yet processed!
< >

[ Close this window automatically if no problems occurred Cancel

Reuse this window for same actions

[[JDo not insert entries that are already in the list ‘Warn me about not inserted

3 entries to be processed.

5. The selected files are being deployed including all references.

To Move Files

If a the same file type, with the same name, exists in the destination folder, the moved file will be
set a new name (for example: Yellow would be renamed Yellow(1)).

1. Select the required file(s).
2. Hold Shift and drag the selection to the target folder.
3. In the Action Log click Move.

Duplicate, Link or Move... {on server "¥izDbServer@GHSERVER") = 10| x|
Fie | action | From | To
ves IMagel Move datajProject] datajProject2/SubProject 1
ves IMEQE3 Move datajProject] datajProject2iSubProject 1
ves IMEQEZ Move datajProject] datajProject2/SubProject 1
1| | i
[ Close this window automatically iF no problems ocounred | Mo I Cancel I

[+ Reuse this window For same actions
¥ Do nat insert entries that are already in the kst [ Warn me about not inserted

'3 entries to be processed. , | -

4. Click Close.
or

Select the required file(s).

Cut the selected file(s).

Select the target folder.

Move the file(s):
Right-click on the target folder and select Move here, or
Right-click in the folder area and select Paste

In the Action Log click Move.
6. Click Close.

A WN—

(95 ]
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To Overwrite Files

A file can only be overwritten if it is in the same folder and of the same type.
1. Select the required file.
2. Drag the file to the file to be overwritten and release.

/\ Note: Source and target file must be of the same type.

3. In the Action Log click Overwrite.

Overwrite... (on server "VizDbServer@GHSERYER) X =10 x|
File | overwrit... | To | info
+ss IMm3QE3 Image1 datafProject] Mot yet processed!

< I i

[T Close this window automatically if no problems accurred % Overwrite Canicel |
IV Reuse this window for same actions

[¥ Do not insert entries that are aready inthe lisl [ ‘Warn me about not inserted

|1ai:nrl:uhepm|:essed. | [
4. Click Close.

To Re-save with viz executable
The menu action Re-save with viz... execution will start viz.exe (if not already running) and re-save

the selected files through Viz Engine. Be sure to define a proper Viz executable path in Tools >
Edit preferences > Viz > General.
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v o Vizrt
L VizOpus
rl
> L. GLOE S
Expand
Expand completely

Collapse completely

MNew »
Rename Ctrl+R / F2
Search in 'scenes'... Ctrl+5S / Ctrl+F / F3
Move this Ctrl+ X
Deploy... Ctrl+D
Create deploy task... Ctrl+Z

& Export to archive... Shift+Ctrl+A

€% Set owner..,

& Set access...

Set expiration date...
Set creation/modification date...

Re-save with viz... L\s

Compress images...

Delete... Del

sages [Chat) Properties...
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¥t Re-save with viz... >

[]Force re-save if same newer version

[ Search in subfolders [\
L4%
Filter filetypes: | Any type o
Scan subfolder(s) progress
[ ] Auto continue Set... Cancel

Click Set..., Continue... and Re-save to initiate the viz.exe re-save.

Pt Re-save with viz... 'VizDbServer@Z420-KKL") — O =
File Type Version before ... Version after save  Info
e s ViZOpUS Project A M Mot yetp
«ss Uffizi_cross_hdr IMAGE A M Mot yetp
+e. bg-clouds IMAGE 3.99.0.52637 N/A Mot yet p
.o iNter IMAGGE 3.6.3.35632 M Mot yet p

< >

[] close this window automatically if no problems occurred Cancel

Reuse this window for same actions
Do not insert entries that are already in the list Warn me about not inserted

4 entries to be processed.
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4.4.6 File Properties

This section describes the available properties of each file.
To View the Properties Assigned to a File

Double-click a file in the Explorer, or
Right-click a file and select Properties.

General Properties

Mame: Image4 \
Type: IMAGE ,'»,r'ii-‘f?‘{"
LIiC: B2F7A84E -FCCO-44CF-341 74C7E 03350 COF : E
Criginal name: IImage4

Dwner; I Guest ;I

Checked out by Check out I

Locked by Lok I

Size: B3.27 KB [64.786 bytes)

Created: Wednezday, September 07, 2016 4:06:03 Prd

b odified: Wednezday, September 07, 2016 4:06:03 Prd

t odified by Guest

E xpires: r M ever ;I

Falder link.s: 1

e data‘Froject] [Imaged]

Link. narme; IImaged

Llzer rights; [¥ Fead W 'wiie
Grouprights: [ Fead W wiite
wiord rights: ¥ Fead W wiite

Name: Shows the name of the file. File names must comply with the list of lllegal Characters.

- Type: Shows the file type, for example material.
UUID: Shows the UUID of the file.
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Original name: Shows the name of the file. To rename the file, type a new name in the box.
If changing the name of a file that has more than one folder-link, only the name of this link
will be altered. In other folders, the name will not be changed.
Owner: Shows the name of the user that owns the file. To reassign the file to a new user,
select a user from the list.
Checked out by: If the file is checked out, shows the name of the user that has checked it
out. To check out the file, click the Check Out button. To check in the file, click the Check In
button.
Locked by: If the file is session locked, shows the name of the user that is working on it. To
session lock the file, click the Lock button. To unlock the file, click the Unlock button.
Size: Shows the size of the file.
Created: Shows the date and time when the file was created.
Modified: Shows the date and time when the file was modified the last time.
Modified by: Shows the name of the user that modified the file the last time.
Expires: Set a date for the select file to expire.
Folder links: Shows the number of folder-links (number of folders the file is placed in). The
box below shows the paths to folders where the file is linked.
Link name: Shows the name of the folder-link. By default, the folder-link name automatically
equals the file name.

- Access rights: Shows the access rights for user, group, and world. User refers to the owner
of the file, group refers to all the members of the group the owner belongs to, and world
refers to all database users.

Keyword Properties

I ame; |mage4 Y
Type: IMAGE K‘q’i?ﬁff“
o B2F 7A84E -FCCO-44CF-941 74CFEN3350 COF i
Shiows Al |
K.emwords: ] Azzignable keywords:
Mame | Mame ¢ |

Hemove

i

Bemove all #»

Name: Shows the name of the file.
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UUID: Shows the UUID of the file.
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There is a search field for locating keywords and you can assign and remove keywords from

the selected file.

References and Link Properties

E References and li

M ame; |maged \
Type: IMAGE szrt
11D B2F FAS4E -FCCO-4ACF-941 FACTE 03350 COF [ 1
= 3 Imaged
Rieferences (0]
B File linkz [0]

Name: Shows the name of the file.

- Type: Shows the file type, for example material.

UUID: Shows the UUID of the file.

References: Shows the files which are contained in the current file. For example, if you check
the references for a scene, you will variously see images, geometries, etc., that are used in
this scene. Drilling down, the references of the images show the images used in that file.

And so on.

File links: Shows the files where the current file is referenced. For example, with an image
used in different scenes, all those scene will appear as file links.

Folder links: Shows all folders where the same file is linked (all shortcuts).

Duplicates

% Duplicates
Mame: Image4

Type: [MAGE
LILHD: B2F FABME -FCCO-44CF-941 74CFE 03350 COF

]\mzrt\l
1]

= B4 Imaged
= g IMAGE(T)
v Imaged(1)

Name: The name of the selected item.

- Type: Shows the item type, for example, BASE_FONT.
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UUID: Shows the item’s UUID.

Total Size Properties

Total size i

I ame: |maged \
Type: IMAGE -\‘u‘lzrt
o B2F 7A84E -FCCO-44CF-941 74CFE03350 COF [ 1]
I‘Jiew by references j
Total size: E3.27 KB | Satt by name =

1 Imaged IMAGE - 63.27 KE]

Name: Shows the name of the file.
- Type: Shows the file type, for example material.
UUID: Shows the UUID of the file.
Filters:
- View by Reference or View by Size.

Sort by Name, Size, Type and Name, Type and Size.
The file’s total size in KB, MB or GB is shown. Using the tree, you can see all the
component parts and their respective sizes.
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nced Properties

IMAGE K'v' 1Zrk
: E2F7A84E FCCO-4ACF-941 74C7E 02350 COF B

Checksum: B26E YESATI2FR0F 4
Original file caum: M A4
W Ersion: wiz=3.7.0.39276, DEI=2.0.1.39276, Windows 7=6.1.1.7601

ik

5

=B

=B

Init 1: 1 fragment with a gize of 2.00 KB [2,043 bytes]
lzonSmall

Idnit 2: 1 fragment with a size of 2.00 KB [2,043 bytes]

lzon

Idnit 3: 2 fragmentz with a total size of 58,98 KB [B0,396 bytes]
Data

Init 4: O fragmentz with a total zsize of 0.00 KB [0 bytes)
Original

Irit 5: 1 fragment with a size of 0.30 KB [304 bytes)
VERSIOM

E wport |

Name: Shows the name of the file.

- Type: Shows the file type, for example material.

UUID: Shows the UUID of the file.

Checksum: A server-generated value to detect duplicates and differences between similar
files. Useful for importing and replicating and deploying files; when two files are very
similar, you can use the checksum to determine whether to overwrite or allow a parallel
instance.

Original file csum: The file’s original checksum from before it was imported to the Graphic
Hub. This is used to determine if a specific file has already been imported, and to improve
duplicates discovery.

- Version: Version is the last client application version that changed the file/wrote to the file.

This should be the same as the last entry in the history.
Units: The component units of a file. A file consists of multiple units that form part of the
internal data. Used in troubleshooting.

- Attributes: Each unit has specific attributes describing it. Used in troubleshooting.
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File History
Mame: Imaged
Type: IMAGE ,\vlzrt\
Lo B2F7A84E-FCCO0-4ACF-341 74CFE03350 COF Ei
Date © | |1zer | Changes | Sernial nurmber | bl
972016 4:06:03 P Guest E sternalCopy Wi

8/13/2014 11:11:23 AM <6.553> Created

Name: Shows the name of the file.
- Type: Shows the file type, for example material.
UUID: Shows the UUID of the file.

COCEEVSIAE RN E3F wi:

The file’s transaction history is shown with columns for date, user, changes and serial

number.

File Availability

If you are logged into multiple servers, you are able to check whether a file exists and is identical

among instances.

M ame; |maged

Type: IMAGE kvlzrt\
Lo B2F 7484E -FCCO-4ACF-341 7ACTE 03350 COF | 1]
todified: 94772016 4:06:03 P

todified by: st

Checkzun: 526B 7BRATIZFROFA

Axailability on the other server(z] where logged in;

Refrezh |

Server T | [rate modified | b, b | Checkzum

Name: Shows the name of the file.
- Type: Shows the file type, for example material.
UUID: Shows the UUID of the file.
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Modified at: Displays last date and time modified.
Modified by: Displays last user to modify the file.

- Checksum: Indicates whether the file is the identical on every server.

- Availability on other servers where logged in: The availability of the same file on other
servers where you are logged in. Even if the file name is different, if the UUID and checksum
are the same, the file will figure in this panel, shown as OK.

File Add-ons

I ame; |mage4 \'5
Type: IMAGE k‘v’t;{rt
o B2F 7A84E -FCCO-44CF-941 74CFEN3350 COF 1

B Text | @ et | @y |

Search: I Dnl LI|:||

™ Match case ™ Match whole word

Name: Shows the name of the file.
- Type: Shows the file type, for example material.
UUID: Shows the UUID of the file.
- Text tab: Assigns add-ons as text.
- Edit tab: Enables editing and assignment of add-ons.
- XML tab: Assigns add-ons as XML.
- Search: Searches text within assigned add-ons.

4.4.7 Folder and File Expiration Dates

Each folder (and its contents) and files can be set an expiration date.

When a Clean-up of Expired items Scheduled Tasks is performed, folders and files with an
expiration date on or before the date configured in the task will be deleted. The following

exceptions apply:

/\ Note: Folders are deleted recursively.
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If a folder, which has expiration date before a due Clean-up operation, contains a folder or
files that have an expiration date set after a due Clean-up operation, it will be ignored in the
delete operation. The expired folder will not be deleted, although it is expired.

- The deletion of a folder will only happen when all folder contents, and any linked content,

have reached their expiration date.

- Any files and folders, in an expired folder, that do not have a set expiration date will get

deleted.

- An expired folder or files, with file links, can only be deleted if all linked files are inside the

expired folder.

/\ Example: If a scene, which includes an image that is inside of an expired folder, is
not included in the expired directory, the image cannot be deleted because it has file
links to the scene which has not expired.

After a clean-up task has completed, a log file is created: %Programbata%\Vizrt\Viz GH
Terminal\CleanupExpired.log. The log file contains:

- Timestamp for when the task was performed.

Expired items that were found.

Number of deleted items (folders/projects/file links).

Duration of cleanup operation.

Number of physically deleted files grouped by file type.

List of errors that occurred during the cleanup operation.

List of UUIDs that got physically deleted by file type

If an expiration date is removed before running the Cleanup of Expired Items task, the folder
and its contents, or files, will not be deleted.

To Set an Expiration Date

1.

Right-click the folder or file.

2. Select Properties...
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B General |
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MName: Project 1 -
Type: Project =
Jui: 4AD579353-9AD2-6547-BB5644580636718B

Path: data

MName: IF'rojer;t'I

Owner: IFu:.Imin j

Created: Wednesday, September 07, 2016 3:31:23 PM

Expires: [F o 72006 41837FPM  [+]

Type * | Sun Mon Tue Wed Thu Fi Sat Size |

wfolder | "3 25 33 31 1 2 3

BIMAGE | 4 5 ol 5 9 10 6.35 MB

158 12 13

£

18 19 20 21 22 23 XM
2 X% X 23 B W 1

[ Today: 9/7/2016

14 15 16 17

E r

[==]

User rights: ¥ Fead v Wite
Group rights: [ Fead W Wiite
Word rights: [¥ Fead v Wiite

4. Click on the drop-down arrow and set an expiration date and time.

Note: Click the drop-down or highlight a date number and change it, to set the date.
Click on the hour or minutes to change the time.

5. Click OK.

4.4.8 lllegal Characters

The following list of characters are not allowed in folder or file names:

Colon: (2)
Semicolon: (;)
Period: (.)
Comma: (,)
Question mark: (?)
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- Asterisk: (%)

- Quotation marks: (¢« ?)

- Angle brackets: (< >)
Braces: ({{{ }D

- Tab key escape character: (\t)
Newline key escape character: (\n)
Blank space: ()

See Also

- Graphic Hub Manager Customization
User and Group management

4.5 Graphic Hub Login And Log Out

To log in or logout from a Graphic Hub Server the Graphic Hub Manager must be running.

Before the Graphic Hub Manager is started make sure that the a Graphic Hub is started first (see
Graphic Hub Startup).

This page contains information on the following topics:
- Single Server Login Start Up
- Multiple Server Login Start-up
Replication Server Login

- Auto Login
Logout

4.5.1 Single Server Login Start Up

When the Graphic Hub Manager starts up a User Login window opens. Use this to log on to a single
server.

/\ Note: For start up with a single server login, Auto Login must be disabled. If Auto Login is
enabled, the start up login window will be for Multiple Server Login Start-up.

Once the Graphic Hub Manager has started, more servers can be logged on to.

To Start the Graphic Hub Manager with a Single Server Login

1. Open the Graphic Hub Manager:
- Click Start > All Programs > Vizrt > Graphic Hub > Graphic Hub Manager > Graphic
Hub Manager, or
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Double-click the Graphic Hub Manager desktop icon

citogin x|
Preferences. .,
— Conneckion
Hast: | GHSERYER. R
Hub: I'-.-'izDI:uServer j
Hub type: Standard server
~User
Narme: I.ﬁ.dmin j
Password: I senesl

™ Enable For Auta login

Wiz Graphic Hub wersion: 3.0.0,60132 _

Client version: 3.0.0,60132
|Statu5: Connecked to server YizDbServern@EHSERNER',

2. From the Host drop down box, select the host name of the machine where the Naming
Service is running.

/\ Note: Available Graphic Hub servers are shown in white. Unavailable Graphic Hub
servers (available servers on a different sub-net), which are configured for auto-login,
are shown in yellow.

3. If the Naming Service host is configured for more than one Graphic Hub server, select the
server to connect to from the Hub drop down box.

4. If Auto Login is required, check the Enable for Auto login check box.

5. From the Name drop down box, select a user from the list of users registered in the
database, on the selected server.

6. In the Password field, enter the correct password.

/\ Note: The default password for administrators is VizDb.

7. Click LOGIN.

To Login to More Servers
After the Graphic Hub Manager Start Up, login to more servers, if required.

Click Server > Login...

4.5.2 Multiple Server Login Start-up

When the Graphic Hub Manager starts up a User Login window opens. Use this to login to a single
server or multiple servers.

Copyright © 2018 Vizrt Page 306



Graphic Hub Administrator Guide - 3.2

Note: For start up with multiple servers (or a single server) login, Auto Login must be
enabled (see Login in Preferences). If Auto Login is disabled the start up login window will
be for Single Server Login Start Up.

When there are several Graphic Hub servers configured in the Graphic Hub Manager, it is possible
to login to:

A single Graphic Hub Server, or

Several Graphic Hub Servers at the same time

If there are Login Profiles defined, select a profile to have a defined subset of servers and
Deploy Agents to login to.

To Start Graphic Hub Manager with a Multiple Server Login

1. Open the Graphic Hub Manager:
Click Start > All Programs > Vizrt > Graphic Hub > Graphic Hub Manager > Graphic
Hub Manager, or
Double-click the Graphic Hub Manager desktop icon.

Auto login N X

[ Use Login prl:nfilel Login Profile 1 j
Marne | Twpe | Mersion | LIzer | Sl | Infa
O ... vizDhServer@GHSERVER Standard  3.0.0... iGuest Mo Mote: AL
D s« BHMaINServen@EH-MAIN ain 3.0.0... Admin Mo Moke: AL
... GHReplicationServer@GH-REFLICATION  Replication  3.0.0...  Admin Mo Moke: AL

|.C'.\-'ailaI:|Iit';.f check: 0 of 3 available, | i

/\ Note: Available Graphic Hub servers are shown in white. Unavailable Graphic
Hub servers (available servers on a different sub-net), which are configured for
auto-login, are shown in yellow.

2. Select the servers to log on to, or check the Use Login profile box and select a login profile.
3. Click Login.

To Login to More Servers

Click Server > Login > to one server... or to multiple servers...
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4.5.3 Replication Server Login

When logged to the Replication server, the administrator has rights to login to the Main server in
the Cluster and to change the content of the host.

This is helpful to manually deal with synchronization issues in a Main/Replication server (Cluster).
But this can also create risks for synchronization between the servers in a Cluster.

Caution: To avoid unwanted synchronization errors, leave the As system administrator
check box unchecked. Login as system administrator only when absolutely necessary.

To Start Graphic Hub Manager in a Cluster on a Replication Server

1. Open the Graphic Hub Manager:
Click Start > All Programs > Vizrt > Graphic Hub > Graphic Hub Manager > Graphic
Hub Manager, or
Double-click the Graphic Hub Manager desktop icon

Ltogin x|

Preferences. .,

— Conneckion
Host: | GH-REPLICATICON |
Hub: IGHRepIicatiDnServer j
Hub type: Replication server

~User
Mame: I.ﬁ.dmin j
Password; I sssss

¥ as system adminiskrator

™ Enable For suta login

Wiz Graphic Hub wersion: 3.0.0,60132

Client version: 3.0.0.60132
|Statu5: Connecked to server 'GHReplicationServer@GH-REPLICATION',

2. In the Host drop down box, select the host name of the machine where the server or Naming
Service is up and running.

3. In the Hub drop down box, select the name of the running server.

4. In the Name drop down box, select your user from the list of users registered in the
database on the selected server.

5. Enter the password in the Password field.

/\ Note: The default password for administrators is VizDb.

6. To log in as system administrator, check the As system administrator check box.
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/\ IMPORTANT! Use this feature sparingly and with caution.

7. If Auto Login is required, check the Enable for Auto login check box.
8. Click LOGIN.

4.5.4 Auto Login

Auto login allows an automatic login to one or more Graphic Hubs, with the option of bypassing
the credentials, as well as requiring a password for each and every server in the network.

A global password can be set for all registered servers as well.

To Enable Auto Login

1. Click Server > Login.
2. Click Preferences... in the main Login window,

ETEE——— X
Preferences. ..
— Conneckion
Host: | GHSERVER |
Hub: I'u'izDI:nServer j
Hub type: Standard server
~User
Mame: I.ﬁ.u:lmin j
Password; I LLLL L

v Enable For Auto logind
Wiz Graphic Hub version: 3.0.0.60132 .
Client version: 3.0.0.60132

Status: Connecked to server WizDbServern@GHSERVER,
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3. Click the Use Auto login box in the Login panel of the Preferences window that opens.

Preferences 5'
(& Gorrs
= & Login
»2 Login profiles ~ General

+2 Timeouts and buffer se TCP F"ultuw:lfall.o;i'KI 19336 Set defaulf |

+& Deploy Direct Copy ; -
w & Startup [~ At login

+& Look W Use Auto bogn
£ Import I Protect Auto kogin with password
 Monibor servers [v Conffirrn Aubo kogin
o “Warnings
& Agents En-/dizable servers for Auto login and change Auto login onder:
&) Deploy | Type [ User | Spsa |
D Archives WizDbServer@GHSERVER Standard  Guest Mo
% General B GHManS erves@GH-MAIN Main Admin Mo
&2 Import GHRephcationServes@GH-REP.. Replicstion Admin Mo
& Export
Up | Top | Mote: Use buttons b the left to changs Auto login oider, Use context
e menL in the Bt of servers for more option:!
D || Bt I
[ Precheck avalabilty of servers before login
[¥ Enable Login to multiple servers' wusing Auto login at any time
[+ Enable Logoiust from all servers'
4 | o

|r.1|:||:a-m||nm,-|

o
4. To set a global password, select the Protect Auto login with password box, and click the Set
password button. In the dialog box that opens, enter a password, and then click the OK
button.

Marne | Twpe | Version | Izer | Shesd, | Infa
O ... vizDhServer@GHSERVER Standard  3.0.0... iGuest Mo Mote: AL
oo« BHMaINServen@GH-MAIN Main 3.0.0... Admin Mo Moke: AL
««« GHREplicationServer@GH-REPLICATION  Replication  3.0.0...  &dmin Mo Moke: AL
Jl | i
Password: I sens | Login I Close |
|.ﬁ.vaila|:||it~;.-' check: 0 of 3 available. | i

5. Alternatively, with no global password set, select the Confirm Auto login box, and then
select the servers to include in the auto-login process.
When logging in, you will be prompted to confirm each server to be logged into. To remove
a server from the auto login process, right-click the server, and then from the list that
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appears, select Remove selected.

Marne | Twpe | Mersion | Llzer | Shesd | Infa
O.. '-.ﬂzDI:-Server@GHSER'-.-‘ER Standard  3.0.0... iGuest Mo Mote: AL
. PO (5 H ] 2 S Ll 3.0.0... Admin Mo Mote: A

M ... GHReplic. Remove SE'E“EE' Dl 3,0.0.., Admin Mo MNote: AL

Text calar in explarer,..  Shift+CEr+C

Password: | sess | Login I Close |

|.C'.\-'ailaI:|Iit';.f check: 0 of 3 available, | ,?:
6. Click the OK button.

To Disable Auto Login

1. Click Server > Login > to one server...
2. Open the Login preferences window:
Click Tools > Edit Preferences...

x
=

+© Login
»5 Login profiles ~ General
w2 Timeouts and buffer se TCF Port used for Logins: | 13356 Sel defaull |

+& Deploy Direct Copy ‘1

& Startup Sy Pt lagin
+& Look ¥ Use Auto bogn
-8 Irport T Protect Auto legn with passwaord
w Monitor servers ¥ Condiim Auto lgin
o Warnings
& Agents Ern-/dizable servers for Auba login and change Auto login onder:
&) Deploy | Type | User | Syea |
I Archives WizDbServer@GHSERVER Standard  Guest Mo
£ General [ GHManServen@GH-MAIN Main Admin Mo
S0 Import GHReplicationSenvei®GH-REP.. Repicstion  Admin Mo
& Export
Up | I Maote: Uize buttons to the laft to change Auto kogin order, Uze contiext
mien in the: st of servers for more oplions!
D | Hat I
[~ Frecheck avalabilty of servers before login
¥ Enable Login to mulliple servers’ wsng duta login at any time
[¥ Enable Logout from all servers'
a | o

ok, Cancel | apeh |

Note: The Login preferences window can also be opened in the main Login
window. Click Preferences...
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Lotogin X

Preferences. .,

— Conneckion
Hast: | ZHSERVER

=]
Hub: I'u'izDI:uServer j

Hub type: Standard serwver

~User
Marne: |.ﬁ.dmin j
Password; I (L LY

Iv Enable For Auto logind

Wiz Graphic Hub wersion: 3.0.0,60132 .

Clignt wersion: 3.0.0,60132
|Statu5: Connecked to server WizDbServern@EHIERVER

3. Clear the Use Auto login box (1), in the Login panel of the Preferences window that opens.
4. Click OK.

4.5.5 Logout

This section describes how to logout of one or all servers from Graphic Hub Manager.

/\ Note: Click Server > Exit, to logout of all servers and exit Graphic Hub Manager at the same
time.

To Logout of One Server

1. Open the logout window:
Click Server > Logout > from one server... or
Press F8, or
Press Ctrl+O.

Logout {disconnect from server) ] E[

(o] 4 | Cancel I

&

2. Select the server from the drop down box.
3. Click OK.
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To Logout of All Servers
If Enable Logout from all servers is configured under Tools > Edit preferences > Login:

1. Click Server > Logout > from all servers...

| Are you sure you want to logout from all servers?

(e [

2. Click Yes.

4.6 Add-Ons Panel

The add-ons panel shows the following properties for all published Add-ons.

Add-Ons B

M ame: |maged \
Type: IMAGE -.\'u‘lzrt
o B2F 7A84E -FCCO-44CF-941 74CFEN3350 COF [ 1]

T Text | @ o | B o |

Search: I Dnl LI|:||

[ Match case [ Match whole waord

F
—
—

In the Text Tab, you can search for text within published add-ons. This search facility includes
matching case and whole words. Text found is highlighted.
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Add-Ons

vizrt
A\

ppoed 7] E
e
| of gjz0te miziagaM v

]
_ Discard | __ aoply |

From the Edit Tab, you can assign, unassaign and edit published add-ons for currently selected
and multiple files.
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I ame: |maged \
Type: IMAGE vizrt
\
LD G2F 7a84E -FCCO-44CF-941 FACTE D3350 COF E
B Text| B opdr o |

Search: I

[™ Match case ™ Match whole word

DnlLIpl

<Addon ID="37B9FBES-E2AD-4730-A2 19ESESSRE0S1 44" Version="1.0.0.0"=
<Entries:=

<Entry ID="74741F43-FD42-4501-9FEBA0046F09BEEA" =
<Entries |=
<Malue=<I[CDATA[Approved]]==Malue =

<JEntry =

<Entry ID="B4503667-210B-4E72-AE 1 C48EC95279A1F" =
<Enkries | =
<ialue =<1 [COATALADmIniskr ator]] = < value =

</Entry =

<Enkry ID="BCSFO630-D0C9-45F3-585463F45EACESADE" =
<Entries |=

<JEntry =
</Entries =
<lhddon =

1

<Value=<I[COATA[2016-09-05T07: 12:492]]= </Value:

5

In the XML tab, you can search for text within published add-ons. This search facility includes

matching case and whole words. Text found is highlighted.

4.7 Journal Panel

From the Journal panel it is possible to search for journal entries and view their details. Journal

entries are log files created according to various alert levels.

| | [vicobserver@GHSERVER Admin] =] | O [ | =N E RN = =
Dute  / | Applcakion | Lrl\ﬂlls‘-brd
Server: |vuDbServeraHsERVER(dmn) 2| <o e 0 Ackion Log: Server Runtime Statistic
Apckeat. oy =] apEmsinzesIAM  sysTEM 0 Action Log: Server Runkime Statistic
Gf7/2016 11:28:54 AM  SYSTEM B2 ‘Waming: Chent connesction kst
Lt I WTED6 11:29:25 AN SYSTEM 0 Action Log: Sereer Runtimes Shatistc
Ciska: Iwm j ] 3 A _'J WT2006 11:30:43 AN SYSTEM 0 Ackion Log: Server Funtis Statistic
- — TFANG 113052 AM SYSTEH 0 Ackion Log: Sereer Runbis 5tatistic
et ads: d = - :|' WIA0N6 11:31:10 AN SYSTES 0 duckion Log: Serwer Runtimes Statistic
Lika: I STA008 11:32:26 AN SYSTEM 0 Muckion Log: Serwar Punlins Statishc
GETFA0LE 113404 AW SYSTEM) 0 Ackion Log: Server Funtims Statistic
Leie: | SfT/2006 11 A2 AN SYSTEM 0 Action Log: Server Runkime Statistic
Mleats: [ Filter ey sedoctod shwts SFIA006 11:38-50 AM SYSTEM O Action Log: Serwer Runbime Statishc
S7/2006 114100 &M SYSTEM 0 Action Log: Server Runkime Statistic

GITIMNA 1 1 A0 AW

CWETIR

n

Bt | e Casncss Dinkirves. Skl

The Journal is a good place to start for troubleshooting problems encountered in Graphic Hub.

The Journal records all server activities. When faced with troubleshooting scenarios, the journal is
a good place to search for clues. The activities logged in the journal are the creation, modification
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and deletion of objects in Viz Artist, as well as other information messages, warnings, errors and
deploy task information.

This page contains the following topics:

- Journal Tool Bar
Search the Journal
To View the Journal
To Search the Journal with Filter Settings
To View a Live Feed of Server Activities
Automatic Journal Backup
To Schedule Automatic Journal Backup
Export and Import of Journal Entries
To Export Selected Journal Entries
To Import Journal Entries

4.7.1 Journal Tool Bar

| |vizbbServerSGHSERVER Admin) __‘LEQJ_ | @ [[2]:
Date | ppiustion | Level | Subject

Server: |VuDbServer@GHERVERIAdvn) 7|

GIT[Z006 112049 AN SYSTEM 0 Ackion Log: Server Runtime Statistic
Apphcat, Jary 7| G 1ESIAM  SYSTEM 0 Ackion Log: Server Runtime Statistic
ATI2006 11:2854 AM SYSTEM BOZ  ‘Waming: Cherk connection lost.
LA I WTIANG 11:29:26 AM  SYOTEM 0 Ackion Log: Sidwsr Runtived: Statiehe
Data: IW"" jl 3] Bi2016 300 ;I W06 11:30:43 AN 5YSTEM 0 Ackion Log: Server Runtires Statistic
WTIANG 11:30:52 AWM SYSTEM 0 dckion Log: Serwer Runtime Statistic
Detads: s SFIAN6 11:30:00 AM  SYSTEM 0 Ackion Log: Serwer Runtimes Statistc
Lika: | HTIA006 103226 AW SYSTEM 0 duckion Log: Server Runtime Statistic
QP06 113434 AW SYSTEM 0 Ackion Liog: Server Funbime Statistic
Lrida: | GIT[2005 1134042 AN SYSTEM 0 Ackion Log: Server Runbime Statistic
Meats: [ Fiter by sedected mieits SITIA006 11:38-50 AM  SYSTEM 0 Action Log: Serser Runtime Statistic
[
n

GPIANG 11:41:00 AM  SYSTEM
GITEHVA 1 10 A SYSTIFR

Huckion Lo Server Rundines Shatistc
Lk | rev Sssnuas D nkives Shatictie

The Journal tool bar (1) has these options:
|vizDbServer@GHSERVER(Admin) 7] | O R | 48 2| [ ,'{,"

= Search: Search for journal entries based on the preferences defined in the Journal Filter
frame

= Optimize search for faster export: If enabled, backup files with a huge number of
journal entries will be optimized for export, by not containing all available information about
these entries

=l Import journal entries: Opens a dialog box, from where it is possible to select an XML
journal backup file to import

¥ Export selected entries: Allows you to export only the entries that you choose
£ Backup task: Opens the Configure Journal Backup Task window

Q Switch to feed mode: Allows you to receive journal updates in real time

_'"ﬁ"b" i | Show/hide entry properties: Shows/hides the Journal Properties frame
_|§|E|. Show filter: Shows/hides the Journal Filter frame
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4.7.2 Search the Journal

To View the Journal

Click Server > Administer journal entries.

| | | VizDbSerser & GHIERVERAdmin) L B ® | E ||:| Eil=

Date | pophcation | Level | Subject

SITI2006 11: 2049 AM SYSTEM 0 Ackion Log: Server Runtimes Statistic

m.iw j STIZ006 11:28-53 AM  SYSTEM 0 Action Log: Server Runbimes Statistic

SITIZ006 11:28-54 AM  SYSTEM BOZ  'Warrang: Cherd conneschion bosk.

we: | G7/2006 11:29:26 AM  S¥STEM 0 Aqtion Log: Serr Runkime Statistic

Dats:  [anytienn =] [ AV =] BTII0U6 113043 AM  SYSTEM 0 Ackion Log: Servr Auntime Statistic
0
0
0
o
]
0
]
n

Server: [VioDbServerdGHERVER Admin) =]

WTIION6 11:30:52 AWM SYSTEM Suckion Lo Seaver Runbins Sttistic

! 10:00 4 - 9T2006 11:31:10 M SYSTEM

et ads: duckion Loy Sereer Runlins Statitic
Lika: I QETIA0NE 11: 3206 AM SYSTIEM Buekion L Serwar Bunlims Stathtic

GETFA0LE 113404 AW SYSTEM) duckion Lo Serwer Funkimes S5atistic
Leis: | G700 11042 AN SYSTEM Mickion Log: Server Runtime Statistic

Mleats: [ Filter ey sedoctod shwts SFIA006 11:38-50 AM SYSTEM
TG 114100 AN SYSTEM
GITIMNA 1 1 A0 AW CWETIR

duckion Loy Server Rundimes Shatistc
Aikion Log: Server Runtines Shatistc
Bt | e Casncss Dinkirves. Skl

To Search the Journal with Filter Settings

f—

. Open the Journal panel.

In the Journal filter, from the Server drop down box, select a server.
Select an application. Your options are:
- Any: Searches System and GH Deploy.
System: Graphic Hub Server. Any work done on Graphic Hub will be logged in the
system.
GH Deploy: All Graphic Hub Deploy Agent tasks, successful or failed, plus warnings
and other pertinent information, are logged in the journal.
Optionally, enter a UUID of a folder or file.

/\ Note: Adding a UUID to the search criteria may provide hints toward finding and
resolving corrupted files.

. From the Date drop down box, select one of the following options:

Anytime
From: Selecting this option will prompt you to also enter a beginning date and time
Until: Selecting this option will prompt you to also enter an ending date and time
Between: Selecting this option will prompt you to also enter a beginning and ending
date and time
In the Details Like field, enter free text like name of the task, name of the agent, or any
description that may figure in the task.
In the Details Unlike field, enter free text like name of the task, name of the agent, or any
description that you want to exclude from the task search.
Check the Alerts check box if you wish to filter by selected alerts.
There are various Action Logs, information messages, warnings and errors to choose from.
Optionally, click Optimize Search (2) for Faster Export button.
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urnal il L [vizDbServer@ GHSERVER Admin) 1 m 2 ® | @ E
Server: [vobserverGHsERVER(Mdmn) =] <o 0 Action Log: Server Auntime Statistc
Appleat. {ary || wrrmeinzEsI M SYSTEM 0 Ackion Log: Server Runkime Statistc

e | HT/ANE 112854 AM  SYSTEM BOZ 'Waming: Chent connection lost.

: WTIHNE 112926 AM  FYSTEM 0 Ackion Log: Serwer Runtims: Statistic
Dusta: Iwﬂ ﬂl af Af20ié 00 n:-;l WTIANG 113043 AM  SYSTEM 0 Ackion Lag: Serwsr Runtaes SEatishe
- - WTIE016 11:30:52 A SYSTEM 0 Ackion Log: Server Runlines Statistic
Dt ads: 1 TG 11300 4AM  SYSTEH 0 ckion Log: Serwer Funtims Statistic
Lika: I STIA006 11: 3226 AW SYSTEM 0 Ackion Log: Serwer Runtime Statishe
STI2006 1M AW SYSTEH 0 Ackion Log: Server Funtime Statistic
el | GYT2006 11042 AM  SYSTEM 0 fuchion Log: Server Bunkime Statistic
Meats: [ Fiter by sedected mierts SITIA006 11:38-51 AM  SYSTEM 0 Ackion Log: Server Runbime Statistic
SI7f2016 11:41:00 AM  SYSTEM 0 Action Log: Server Buntime Statiste
ST PMVIA 11 B0 AN CVETFM M Ak | e Sasosr Dndives Shadiche

The search results are shown in the panel below. When one is selected, the details are shown
in the panel to the right.

To View a Live Feed of Server Activities

1. Search in the Journal with Filter Settings.
2. In the Journal tool bar, click the Feed button (1).

. J T :- e
r Dade | igikie e
Al i
ms |
o e | S
we
wite [
et [T Pl by melnchnd i pelale
1| ] il |
A eaiad palvats | L 14) |

The journal is now updated in real time.

Green: New journal entries

Yellow: Warnings

Red: Errors

Only the Level and Subject columns are colored in red or yellow when there are warnings
and errors to report

4.7.3 Automatic Journal Backup

To automatically backup all Journal entries, Enable journal backup must be enabled in Journal/
Logging Settings.

/\ IMPORTANT! Once an automatic backup task has completed, all journal entries are deleted.
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To Schedule Automatic Journal Backup

1. Open the Journal panel:
Click Server > Administer journal entries.

Journal

| [viembserverecrserveriaaminy ) ““1'1,"-5& D
Date ' | pophcation | Level | Subject -

Server: |VeDbGerverGHIERVER[Admn) ] GfT[2006 1112849 AM  SYSTEM

Appleat. {ary || wrrmeinzEsI M SYSTEM
9f7[2016 11:28-54 AM  SYSTEM
TG 1 1:T926 AN SYGTEM
WTING 11:30:43 AN SYSTEM
WTIION6 11:30:52 AWM SYSTEM
TG 11:F10 AN SYSTEM
TG 11:32:-26 AW SYSTEM
TG LM AN SYETEM
GITS2006 11: 342 AM  SYSTEM
Meats: [ Fiter by sedected mieits SITIA006 11:38-51 AM  5YSTEM

7[20016 11:41:00 AM  SYSTEM

GITIMNA 11 A0 A CWETIE

2. Click the backup task (1) button.

Aution Log: Sereer Runbimes Shatistc
Hution Logy: Server Runbimes Shatichc
Warmang: Cherd, connechion bost.

Ackion Log: St Runtins Statistc
Bukion Livg: Server Runtine Sttt
Sekion Loy Sereer Runtines Shatistic
Suckion Lo Serwer Runlins SEatitic
duckion Lo Server Bunkines Shatistc
duckion Lo Serwer Funimes Statistic
Action Log: Servar Funbims Statishe
Hution Log: Sereer Runtimes Shatistc
HArtion Log: Server Runtines Shatistc
Brkinr | reve Ssns Sk Shabche

ﬁﬂﬂdbﬁ-l&avbbﬁﬂﬂ

x
Stark time: | yzoor vooam  +f
Inkeral: Iweek]y j
Mext run: Monday, September 12, 2016 2:00 AM

(]34 | Cancel |

3. Set the Start time.

/\ Tip: Click the drop-down or highlight a date number and change it, to set the date.
Click on the hour or minutes to change the time.

4. Set a frequency Interval.

5. In the Graphic Hub Terminal, check that Enable journal backup is enabled under Options ->
Journal/Logging settings. This option is enabled by default.

6. Click OK.

4.7.4 Export and Import of Journal Entries

With the export of journal entries select one, or as many as required, entries to be exported.

Exported journal entries can be imported by other users for help with troubleshooting.

To Export Selected Journal Entries

1. Search in the Journal with Filter Settings.
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2. In the journal, select the entries to be exported.

|vizDbServer@ GHSERVERIADmIn Tl QR RS

Action Log: Server Runtime Statistic

640 journal entris found | viaDbserver @ GHSERVERIAmin)

/\ Tip: Press Ctrl+A to select all entries.

3. Export the selected entries by clicking the export button “# | or by right-clicking the
selection and select Export Selected.

/\ Note: From the context menu, Export and Delete Selected can also be selected. This
will free up disk space and increase performance.

4. Select a location, optionally enter a file name.
5. Click Save.

To Import Journal Entries

1. Open the Journal panel:
Click Server > Administer journal entries.

Copyright © 2018 Vizrt Page 320



2. Click the . (Import Journal Entries) button.
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Server: [voDbServerpGHEERVER{AdTn) 7|
Appkcat. s =

T |

[vizDbsenerg GHSERVER A dmIn]

Date | ippkestion

Level | Subject

=l am

UTIIOLG =240 AM  SYSTEM
TI0LE 1I=2EEIAM  SYSTEM
AFTEOLE 11Dt AM  SYSTEM
UTIIOLG QU=TRD6 AM  SYSTEM
TIZ0LE 11343 AM  SYSTEM
fFE0LE RS2 AM  SYSTEM
UTIIOLE 1310 AM  SYSTEM
QTIZ0LE DI=IZDE AM  SYSTEM
ATE0LE =334 AM SYSTEM
AUTIIOLE 11=M642 AM  SYSTEM
TIZOLE 1U=3E50 AM  SYSTEM
fF{E0LE LE4100 AM  SYSTEM
AUTZOL6 1I4K07 AM  SYSTEM
UTIZOLE 1IAS1T AM SYSTEM
YFE0LE LTS AM SYSTEM
AUTIZOLE 14T AM  SYSTEM
TZOLE DIS140 AM  SYSTEM
ATZ0LE 1 ISE43 AM  SYSTEM
ATIZ0LG 11TEET AM SYSTEM
WTIOLE 115505 AM  SYSTEM
72016 1200013 P SYSTEM
AYTI20L6 120220 PH SYSTEM

]
o

nwﬁqﬂ@ﬂwﬁ¢=¢ﬂw=¢-qnﬂﬂ

fction Log: Serer fy ¥ Impdrt jounal entries...

Acthon Loge Saresr Runbime Satistic
‘arreng: Chent conrection lost.

Aaction Loge Server Ryrtrn Satistic
Acthon Loge Saresr Runbimes Satistic
daction Loge Server Runbime Statestic
Aaction Lege Server Runtime Satistic
Action Loge Saresd Runbing Satitic
daction Loge Server Runbime Statistic
faction Loge Servar Funtime Statistic
Action Loge Sareer Busties Statistic
daction Loge Server Runbime Statistic
action Loge Servar Funkime Statistic
Bction Loge Saroer Bustie Shatistic
dacthon Loge Server Runbime Statistic
action Loge Server Funtime Statistic
Action Loge Saroer Pusties Shatistic
Hiction Loge Server Runbime Statistic
daction Loge Sereer Funtime Statistic
Aaction Lodge Sareer Purtirns Satistic
Acton Loge Server Runbime Satistic
daction Loge Server Runbimes Ratistic

Fé

2|6 21 [SE]
=

i

641 pournal enbries Tound

_|[VizDbierrenB GHSERVER|Adminy

3. Select the required file.

4. Click Open. The file is loaded into the journal.

4.8 Alerts

Email can be sent about specific types of Journal entries. This section details how to define email
notifications that should be sent when errors occur in the system.

To send email, email must first be enabled in the Graphic Hub Terminal. Then use the Graphic Hub
Manager to configure which and when messages are to be sent. Configured alert settings can also

be exported and imported.

4.8.1 Server Alerts

The Graphic Hub Server issues alert messages in the following scenarios:

GH needs administrative attention
License errors or expiration

Low memory
Low disk space

Refer to Monitor Servers for details on how to monitor such situations.

4.8.2 To Configure Send E-mail

1. Open the Alerts panel:

Click Server > Configure alerts... or Shift+Ctrl+F7.
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=10} x|
[ GrMainG enoer @ GH-MAINAdmIn] =] | fary =] | configure.. | < | 5
| hpphc... ¢ [Leveliz) - | Subject | Collect For | serd e-mailza -
SYSTEM o Sution Log: Server Pimtime Stabitic 1 vk
YETEM 10 Action Log: Create Object 1 wenk
SYSTEM 20 Aution Log: Lpdsts Object 1 wrdek
SYSTEM EH Action Log: Delete Object 1 vk
TYETEM el Information: Clent connaction skabe has been changad. 1 howr diocumant stioranizrt .com
SYSTEM 753 Irdormation: Transmissbon of fadower bo dient successful, 1 o
SYSTEM 754 Information: Fadover confirmed from cient. 1 mirate
SYSTEM B0 WErrang: Hardwars rescurcs nd slnost resdhed. 1 bhour
SYSTEM 802 ‘warning: Cherk connaction kst, 1 honsr
T 1] Warning: System resource lmit almost reachsd. 1 o
SYSTEM gl0 ‘Warning: Possble cormupbed File detected! 1 hinwr
SYSTEM 820 ‘Warning: License will sapire. 1 dary
SYSTEM 850 Warning: Server to server connsction stats has been changed. 1| hour
SYSTEM 85z ‘wiarming: Possible replcation violstion detectsd. HL T
SYSTEM SO0 FATAL ERROR: Mardware resourcs bmit reached| 1 o
SYSTEM 02 FATAL ERRUOR: Sysham comuplion detacted| S iUt 1
SHSTEM 05 FATAL ERFLOR: System resource bmit resched! 1 honr
SYSTEM S10 FATAL ERROR: Corrupbed File detected) 1 hour
SYSTEM azn FATAL ERROR: Licanss has expansd! 1 o
YETEM SE0 FATAL ERSOR: Conneschion bo Server kost? 1 o —
1| | _’J_J

24 alets on server "GHMuinServe rd GH-MAIN

2. Select one or more subjects to receive e-mails from.
3. Click Configure.

Configure "Warning: Hardware resource limit almost reached-= x|

Subject: o I ‘Warning: Hardware resource limit almost reached,

Description: I [The syskem will now check the hardware resource permanently to present
Consequence; Loss of performance.

l | i
Send e-mail to: [ documentation@ izrt . com =  Add | I j
Remove = |

U | Top
[, | Bat,

Collect Far: I_I &0 min. |1I-u:|ur j (a4 I Cancel

4. Edit the Subject and Description fields as required.

5. From the drop down box in the lower-right corner, enter or select the address or addresses
to which the e-mail alerts are to be sent.

6. At the bottom left, if you wish to override the default, enter an interval in minutes or select a
predefined interval from the drop down box. Data will be collected and messages will be
sent at this frequency.

4
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7. Click OK.
Messages to be sent appear in the Alerts window.
E e -
e e 8 -LAD A ey *| Jury *| Conlwgpar.. =% &
[hgphe - Tiwesiity - Toubect | Colet b [ sord e madiz: I
TYIH [] KetonLog: berver Burtes Saoete [
Trine 1] Aty L Crnal Obieet 1 v
Srinim ] i i Wbl il [
by ] : ] et L Sl ST 1 v
s ™ b et B P o d L A LR T
SrIne ™ Irformatere Tramamasce. of ek b dert mrcsshd 1 B
TYsme . Informters sz corfrmed From ere 1 srtn
rinm L] Warrarey Hadsee revourcn bl gl resched I b
Frinim L5 Wt T O el 1 i
Frin. L] WO ot e el O T e HLST
s [i1] Waraney Fosubls osv.pbed M Sebectedd | o dorumentatoraiieo com
e i ] [~} Warnine Losres will aogre. Uy
e i) L] Wararey Jerve bo v corredion itate bes bees charged. | tour
Friaim L5 Wrrarey Fpbsbin ol volaton deleded. 1 b
Frinm e Fliti, R s riinr 4 Il Pt b £
e e FATA, BERCE frata mofrplan: detated R T
S e [ —— thar b L U e
TYSe L1 FATAL ERFOR: Camuted Fil detecied 1k -
rrmm " [ P — 1 d T
Frinim e P, Bl ottt 1 Serve lnel! 1 B WL e e vl b L)
i " AT, Pl Chend oannation et § b
Fram -y FATAL ES5o8: Fiophcston wolaton detactads § o
TrIne w3 FATAL ER5:06- Falover rurammuce |o et rof mecesshF § mradn ] I 3l
] A FATAL ERE08- Cherd. recorrsct ok scressh 1 srndn
i Ll Fr=reerrr——p— 2 | =
o
Fipmcn
IE |
o | Ben.
st e fier =] o arind |
A e et G asens TS

4.8.3 Importing and Exporting Alert Settings

E-mail alert settings can be imported or exported in the Alerts window. To import previously
configured settings, click the Import button or the keyboard shortcut F6. To export such settings,
select the settings to be exported from the list in the Alert window, and click the Export button or
F7.

[GHanSemr@GH-hwmﬂdmm; j Iany :I Configure... [ =5 | =
| Applic... 7 | Level(2) - | Subject | Collect for
See Also

Email Configuration Options in Graphic Hub Terminal.

4.9 Archives Panel

This section contains details about the archive panel of the Graphic Hub Manager.

In the Archives Panel, archives can be imported and exported with drag and drop. It also offers
other functionality:

An archive search function

View the contents of an archive

Import single files from an archive

View archive details

In the Tool bar click on View > Archives to open the Archive panel.
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The Archives panel consist of:

- Archives View (1): Shows archives in folders (User selected (see Graphic Hub Manager
Customization)
Search View (2): Search in all or selected archives

- Archive Contents View (3): Shows the content of the selected archive

- Archive Details View (4): Shows the details of a selected archive

Go to Graphic Hub Archives for detailed information about:

- Archives View
Search View
Contents View
Details View
- Archive Folders
Import Archives
Export Archives
Import Viz 2.x Data and Archives

4.10 Action Log

The Action Log is automatically activated when certain operations are done in the Graphic Hub
Manager, for example, the duplication and /deletion of files and folders, or when user rights are
modified.
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loix]
Fie | path | info
oee ISGRT dataProject] Mot et processed)|
— k] data/Project ] Mot yet processed|
— data/Project ] Hot ek processed|
wns ITREGES data/Project] Mok veb processed|
aes IMEOEH{1) data/Project Mot vet processed|
« | 2
[ Close this window subomaticaly F no problems ccoured ﬁ Delate I Canesl
¥ Reuse this windos for same actions
¥ Do not insest entries that are akeady inthe sl ¥ Warn me sbout not inserted
E'iertrle-smbepn:amd. | | &

The action to be done will be shown in the window title, and an icon which symbolizes the action
will show below the file list. For example, a trash can icon is used if files or folders should be

deleted.
This page contains information on the following topic and procedures:

Action Log Parameters
To Add Additional Files
To Action the Operation

4.10.1 Action Log Parameters

™ Closa this window automaticaly if no problems ocoured E Delste I Canveel
[+ Reuse this window for same actions
¥ Do not insest entries that are skeady inthe il [ Wamn me sbout not inserted

5 enitries ko be processad, [ [ =

Close this window automatically if no problem occurred: If enabled, the Action Log will be
closed when the required operation finishes successfully.
Reuse this window for same actions: By dragging files or projects/folder onto the Action

Log, the action will be completed on these elements too.
Do not insert entries that are already in the list: Prevents the addition of duplicate entries.

/\ Note: This option is only available if Reuse this Window for Same Actions is enabled.

- Warn me about not inserted: Enable to notify when duplicate entries have been detected.

/\ Note: This option is only available if both Reuse this Window for same Actions and
Do not Insert Entries that are Already in the List are enabled.

4.10.2 To Add Additional Files

Add additional files that the same action should be completed on.

Drag files from the Explorer or the search results onto the list of elements in the Action Log.
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4.10.3 To Action the Operation

1. Add the required to the Action Log.

2. Click the button corresponding to the operation that should be done.
When the operation has completed, the Action Log will provide feedback. If the operation
has been successful, a check mark, is shown to the left of the file name. If the operation has
failed, an X will show. Status information in text form will also be shown in the Info column.

File | path | 1rfa
v Image$(1) data)Project1 File deleted successfully

4.11 Graphic Hub License

This section details how to apply a new Sentinel Hardlock Dongle license. A new license can also
be applied in the Graphic Hub Terminal.

For some Graphic Hub modes a license is required. A license is normally acquired when the
product is purchased. To get additional or updated licenses contact your local Vizrt representative.

/\ Note: To apply a license using the WIBU licensing system, please consult the Vizrt Licensing
Guide in the Vizrt documentation center.

4.11.1 To Apply a License

Use this procedure to apply a first time license, apply a new license after a license expiry, or apply
a new license before a license expires.

1. Log into a server in Graphic Hub Manager.
2. From the main menu, click Info > License info...

License info for server "¥izDbServer@GHSERYER" 10O x|

Server: I'u'izDI:uServer@GHSERVER(.ﬁ.dmin} j

License details:
Serial Mumber: 3c 13 0b 4e bl ec F4 3

ey Mumber; 4
Product expiry date; 312/2017
Feature expiry dake: 31212017

Features:
User Management: Expiry date: 322017

License skring; Sef | Close I

| 4
3. In License string enter the new license string for the connected Sentinel Hardlock Dongle.
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4. Click Set.

4.12 Graphic Hub Manager Customization

The GUI has two default layouts but it can be customized with different layouts in the workspace.

In addition to the Layouts function, the look and feel of the Graphic Hub interface can also be
customized.

The Graphic Hub GUI has several options to modify its look and feel. In the Look panel of the
system Preferences change the overall look from the drop down list.

Also the color of the text for a selected server can be modified as required.

This page contains the following topics:

Default Layouts
System-Clean (locked)
- System-Default
Locked/Not Locked Layouts
Layout Maintenance
- To View the Layout Maintenance Window
Layouts Maintenance Properties
Layout Procedures
- To Save a Layout
- To Save a New Layout
- To Load a Layout
- To Drag and Drop Layout Panels
- To Load a new Look
- To Change the Color of a Server Text
Import and Export Custom Settings
- To Export Local Graphic Hub Manager Settings
- To Import Local Graphic Hub Manager Settings

4.12.1 Default Layouts

System-Clean (locked)

The System Clean layout is always identical to the presented layout when the Graphic Hub Manager
is opened after a fresh install.
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System-Default

System-Default is the default layout if a User does not create or save layouts.

This layout is, by default, not locked, which means, that if a User e.g. open the archives pane and
then close the Graphic Hub Manager then on next startup the archives pane will be shown.

Locked/Not Locked Layouts

Each layout can be set to locked or unlocked:

Not locked: When the Graphic Hub Manager is closed the last used layout will be stored and
when the Graphic Hub Manager is started this last stored layout will be used.

Locked: If a User modifies a locked layout, the layout must be saved or the modifications will
not be saved.
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4.12.2 Layout Maintenance

To View the Layout Maintenance Window

#t Viz GH Manager - using Layout 'System-Clean (locked)'
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Type
Project

vu%

Server  Miew Tools Extra Info
los|d T e r@LOCALHOST
m Panels ame ¢ Size
; 0% ser Archives data
~
i Messages (Chat) Ctrl+H / Fo
Legging panel
Duplicates... Ctrl+M / Ctrl+F3
Object types... Ctrl+B / Ctrl+F&
Active sessions... Ctrl+E / Ctrl+F7
Layouts Load layout
Refresh explorer F5 Save current layout ‘System-Clean'
Save current layout "System-Clean’ as...
Unlock current layout 'System-Clean'
Maintain layouts...
Layouts Maintenance Properties
%t Maintenance of layouts >
Mame Locked? Load selected layout
System-Clean Save selected layout as...
System-Default Mo

Toagale lock of selected layouts
Remove selected layouts. ..

Initialize selected layouts. ..

Close

Load selected layout: Opens the selected layout
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Save selected layout as...: Create a new layout from the selected layout

Lock/Unlock selected layout: See Locked/Not Locked Layouts (not available for System-
Clean)

Remove selected layout: Delete the layout (not available for System-Clean and System-
Default)

Initialize selected layout: Set the selected layout to the same layout as System-Clean (not
available for System-Clean

4.12.3 Layout Procedures

To Save a Layout

Click View > Layouts > Save current layout < layout name >, or
Click the Save button in the Layout bar

To Save a New Layout

1. Open the Save as window:
Click View > Layouts > Save current layout < layout name > as..., or
Click the Save as button in the Layout bar

$#F Save current layout 'System-Clean’ as x

Save it under the following name:

| Vizrt GH layout| w

Save it as locked

Save Cancel

2. Type a new layout name.

/\ Tip: Also save a new layout to an existing layout, if required. Existing layouts are
listed in the drop down menu.

3. Tick the Save it as locked box, if required.
4. Click Save.

To Load a Layout

Click View > Layouts > Load layout > <layout name>, or
In the Tool Bar, click the Layout button and select a previously saved layout.

To Drag and Drop Layout Panels

1. Click and hold the title bar of the element to be moved.
2. Drag and drop the panel in a new position. Options are:

3.2
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Drag the panel to a symbol which shows possible target positions. When a valid place

is reached, that area is highlighted:
b Sre Tyoe Cane raiifed Mo by L
- Progect 2-d| . | DRl e

cesprgh..,  Fol

pace meated ey Preied aut by aded By
W

Search ®
Freelet: e
o
Tvpe: Ll -
Wharp: Evprymhere {biects arad add-org

[ tanvch o bbb dervirs sy
[ siearch i spented Foider
[l sarch by avbemruiedi e ogeries
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Drag the panel to the title bar of another panel. When a valid place is reached, that
area is highlighted:
¥ Viz GH Manager - using Layout 'System-Clean (locked)’

Server View Tools BEdra Pilot  Info

1i -» Root of VizDbServer@LOCALE

1 project

/E Search result [All servers) \
/03 Archives

/\ Note: When a series of elements are docked together, they show as tabs.
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Drag to white space. When released the panel becomes a floating panel:

*

Server View Tools Extra Pilot Info

EI'UE]OJ (& | & | Address: :-> Root of VizDbServer@LOCALHOST v 0%
| | Mame Size Type

Freetexi: ~ T Ly iEdata Project

Type: | Arvy type - |

Where: Everywhere (objects and add-ons) | Servers and folders x
[] search on checked servers only 4 v [l 1 - VizDbServer BLOCALHOST(Admin)

v i data
[ search in specified folder - Vit
== Documentation_graphics
[ search by advanced properties +

To Load a new Look

1. Click Tools > Edit Preferences > Look .
* Look

Visual appearance

Visual style: I"u"l.ﬁnduws 7 j

[T Docking Tab Colors

2. Select a visual style from the drop-down.
3. If colored tabs are required, tick the Docking Tab Colors box.
4. Click Apply or OK.

To Change the Color of a Server Text

Change the color of the text for the selected server, in the Server Tree.

3.2

/\ Tip: A right-click on a server in the Servers and Folders will also open the Color window - go

to step 3.
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1. Click Tools > Edit Preferences > Login .
En-/dizable servers for Auto login and change Auta login order:

M ame I Type | |zer | Sysd,
O “izhbServer==GHSERVER Standard Admin - Mo
GHM ainS erver@GH-b A M

b ain Admin Mo

GHiFepicas Remove selected el
Remowve all Shift-+CErl4+-4
Mowve to bop Chrl+1
Mowve up Chrl+2
[Mowe down CErl+3
M ave boboktam Zhrl+-

Texk color in explarer...  Shift+Ckrl+C

Up | Top I Mate: Use buttons to the left to change Auta lagin order. U
menu in the list of servers for more options!
D | | Bat. |

2. Right-click a server and select Text color in Explorer...
3. Select a color (Standard or Custom) from the color picker.
4. Click OK.

Standard I Custom |
Colors: -

Cancel

o< |
_ oned |
A Select.. |

Mew

5. In the Preferences window, click Apply or OK.

Current

& Note: All folders and files in the Server will show the selected text color in the
Graphic Hub GUL.

4.12.4 Import and Export Custom Settings

All workstation-based customizations to the Graphic Hub Manager, such as changes to any of the

panels, column layout and visibility, as well as the user interface in general can be exported (and
subsequently re-imported on another machine).
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To Export Local Graphic Hub Manager Settings
1. Click Tools > Export settings (incl. layouts) to file .
2. Select a file name and location, and click Save.

/\ Note: The settings are saved with a file extension of .vghms.

To Import Local Graphic Hub Manager Settings

1. Click Tools > Import settings (incl. layouts) from file.
2. Select a settings file with the .vghms extension, and click Open.

4.13 Enable A Graphic Hub For A Virtual Studio

The XML necessary to support a virtual set environment is generally obtained from Vizrt Support.
The following procedure indicates how to import or export such an XML file.

4.13.1 To Import or Export a Virtual Studio Settings File

1. From the main menu, select Extra > Viz VR Studio Setup.
The Viz VR Studio Setup window opens.

o]

Shudo I ¢ | ComeraID(2) ¢ | Walue |

0 Viz VR Studio Setups on senver VizDbServer@ GHSERVER

2. On the tool bar, click the Import or Export button.
3. Select the XML file and click Open or Save.
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5 Graphic Hub REST

The Graphic Hub REST is a web-service for Graphic Hub. It is an interface to retrieve and send data
to and from Graphic Hub via HTTP requests. The Graphic Hub REST configuration page is loaded
automatically after installation:

% Graphic Hub REST configuration - 127.0.0.1

o

/\ Tip: The configuration page can be opened manually by navigating a browser to http://
127.0.0.1:19398/config.html.

Select the Graphic Hub the REST service should connect to from the drop-down list, and click
Apply. This will open an authentication window:

Copyright © 2018 Vizrt Page 336



Graphic Hub Administrator Guide - 3.2

Authentication required

Please login to Graphic Hub:

VizDbServer@LOCALHOST:19396

GH username :

GH password :

In the GH username and GH password fields, enter a user name and password for the Graphic Hub,
then click OK.

A Tip: User names and passwords are case sensitive.

A popup window should appear, informing about the successful configuration of the Graphic Hub
REST service:

Suc

I ] Successfully configured Graphic Hub server.

Click OK. This opens the REST status page:
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% Graphic Hub REST configuration - 127.0.0.1

7

The GH REST Configuration Settings and Web Server Configuration Settings is accessible from this
page. However, the default settings can in most cases be left unchanged.

The following topics are covered in this section:

- Graphic Hub REST APl Documentation

- Web Server Configuration Settings

- Graphic Hub Failover servers

- Change Graphic Hub server
Maintain Graphic Hub REST Bindings
Report

- Failover/Load Balancing

- SSL in REST

5.1 Graphic Hub REST APl Documentation

The Graphic Hub REST API documentation provides a programmer with the necessary information
to use the Graphic Hub REST API. The APl documentation can be accessed by selecting Viz GH REST
API from the Help menu, or entering http://127.0.0.1:19398/doc/documentation.html in the
web browser address bar.

5.1.1 GH REST Configuration Settings

To make changes to the default REST configuration settings, select Viz GH REST from the
Configuration menu. Any changes made will be highlighted by the parameter name changing
color. Click Apply to apply any changes, or Back to go back to the main configuration page.

Note: Any changes to the GH REST configuration will not take effect until the Graphic Hub
REST service has been restarted.
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VIZ GH REST CONFIGURATION

Viz GH Rest Settings Log Level
Request timeout (ms) - Debug

Trace

G Information
G Warning
G Error

% crititcal

ACE

Mao Ns per user :
Default earch results
Max journals :

Max journals days :

4p 4Ap 4 4 40 1)

Content size limit in MB -

VIZ GH REST IMAGE UPLOAD CONFIGURATION

Viz GH Rest image upload Settings

Max. used system Memory __
- , - ia
in %

Default com n:

parallel

REVERSE PROXY SETTINGS

Enable URL rewriting*
URL protocol® : hittp

URL base-path* :

VIZ GH REST CONFIGURATION
Request timeout (ms): If the defined timeout is exceeded, the http daemon
disconnects the request. The default value is 120000.
Max. sessions per user: Set the maximum number of sessions per user connecting to
the Graphic Hub. The default value is 10.
Default max search results: Set the default number of maximum search results. The
default value is 20.
Max journals: Sets the maximum number of buffered journals. By setting the value to
0, buffered journals are disabled. The default value is 500.
Max journals days: Defines the maximum days to retrieve journals, subtracted from
the current date. The minimum value is 1. The default value is 2.
Content size limit in MB: Defines the upper limit of the amount of memory in MB the
REST service can allocate for processing content. The default value is 200.
Log Levels Check the box to include the required logs:
Debug: Prints and logs debug messages. off by default.
Trace: Prints and logs trace messages (needs trace enabled). off by default.
Information: Prints and logs informational messages. on by default.
Warning: Prints and logs warnings messages. on by default.
Error: Prints and logs error messages. on by default.
Critical: Prints and logs critical messages. on by default.
ACE: Prints and logs Viz GH Interface ACE messages. 0ff by default.
VIZ GH REST IMAGE UPLOAD CONFIGURATION
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Max. used system Memory in %: The maximal memory (as a percentage) VizGHRest
will allocate for processing parallel image and archive uploads.

Default compression: Select the default compression for imported images:

AUTO, NONE, DXT1, or DXT5. The default setting is AuTO .

Max. number of parallel uploads: Maximal number of images that can be uploaded in
parallel. If the value exceeds 12, a performance loss can occur.

REVERSE PROXY SETTINGS

Enable URL rewriting: When enabled, URLs in responses are rewritten with the
configured protocol and base-path, where the requested URL contains the configured
base-path. Disabled by default.

URL protocol: Select which protocol to use in responses where a requested URL
contains the configured base-path. Valid values are http and https. The default value
is http.

URL base-path: Define the URL base-path (prefix) to use in responses when the
requested URL contains the configured base-path (as, for example, when requested
from a proxy). When URL rewriting is enabled, this field cannot be empty. The path

must be an absolute path, excluding protocol, host and port, as this information is
read from the HTTP Host header field. The base-path cannot be ‘/’. The base-path

format is /base-path/path.

é Example: /my-media-base-path/content

5.2 Web Server Configuration Settings

This window is used to customize certain settings for the Graphic Hub REST service web server.
Any changes made will be highlighted by the parameter name changing color. Click Apply to apply
any changes, or Back to go back to the main configuration page.

Port: The port of the web server. The default value is 19398.
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/\ Note: Changing the port to 1 or 65535 causes the web user interface to cease
functioning in Chrome, UC Broswer, Opera and Firefox, as these browsers block
requests on these ports.

- Configuration directory: The directory where the web server configuration files are located.
Upload directory: Set the directory where uploaded files will be stored temporarily.
Document root: The web server document root directory, where the html files reside.

Error log: Set the location of the error log files for the web server.

Default index: Set the default index file name for directory requests. The default value is
index.*.

Local endpoint: The local endpoint defines which IP address(es) the web server will listen to.
The default value is 6.0.0.0, which means that it will listen on all installed adapters.

Log directory: The directory for Viz GH REST and web server log files.

- Thread pool size: Set the maximum simultaneous connections (threads) the web server can
process.

Use keep-alive: Enable or disable keep-alive header handling on the web server. This is
enabled by default.

Use SSL https connection: Enable or disable SSL handling of incoming requests. This is
disabled by default. See also SSL in REST.

Note: When activating SSL, the user will be automatically redirected to the new site.
When disabling SSL, automatic redirects are not possible due to requirements in the
HTTPS protocol.

- Socket timeout (ms): When handling keep-alive requests, this timeout closes the socket after
the defined number of milliseconds. A value of 6 disables timeout, and leaves the socket
open forever. The default value is 15000.

/\ Note: Any changes to the web server configuration will not take effect until the
Graphic Hub REST service has been restarted.

5.3 Graphic Hub Failover Servers

A Graphic Hub failover server can be added in addition to the currently connected Graphic Hub.
Graphic Hub failover servers must have fully synchronized content with the currently configured
Graphic Hub. Synchronizing the content between multiple Graphic Hubs can be achieved by using
the Graphic Hub Deploy Agent.
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To add a new failover server, click the Add failover server button, and enter the Naming Service,
Server and Port details:

Naming Service: Failover Graphic Hub Naming Service.
- Server: Failover Graphic Hub server
Port: Failover Graphic Hub port.
To remove a failover server from the list, select the trashcan icon. Click Apply to apply any
changes, or Back to go back to the main configuration page.

5.3.1 Methods to Test Failover Servers

1. Perform a request to Graphic Hub REST, for example by navigating a browser to http://
127.0.0.1:19398/users/.

2. Shut down the configured Graphic Hub.

3. Perform the same request to Graphic Hub REST again.
If the first failover server is configured correctly, the response (error code and content)
should match.

5.4 Change Graphic Hub Server

You can change the binding between the Graphic Hub REST and Graphic Hub server.
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Navigate to Configuration > Change Graphic Hub server

s

COMNFIGURATIC Web Server ABOUT
Viz GH Rest

Viz GH Failover Servers

Report: Export

Change Graphic Hub server),

2. Select a Graphic Hub server from drop-down menu or enter the address manually in form of
VizDbServer@GHServer:19396 to bind to Graphic Hub server

Please select: Graphic Hub server

VizDbServer@GHServer:1939¢
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3. Confirm with Apply.

Please select: Graphic Hub server

VizDbServer@GHServer:19396

4. The server has been successfully changed and the binding to the previous server is removed.

I Successfully changed server.

Binding to previous server deleted.

5.5 Maintain Graphic Hub REST Bindings

Select Maintenance from the main menu to show information about the currently configured

Graphic Hub connection, its bindings, and failover Graphic Hubs. Graphic Hub REST is
automatically registered and the configuration is stored when connecting to a Graphic Hub for the

first time.
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application/atomswc+xmi '

The Graphic Hub REST to Graphic Hub bindings enable third party applications to discover the
currently connected Graphic Hub REST servers on a Graphic Hub.

Protocol: The protocol used to connect to the specified Graphic Hub REST.
Hostname: The host name or IP address for the specified Graphic Hub REST.
Port: The port of the specified Graphic Hub REST web server.

- Service doc path: The path where the service doc is configured on the specified Graphic Hub
REST.

- Service doc accept type: Defines the http request headers accept type used to retrieve the
service document on the configured service document path.
Click Apply to apply any changes, or Back to go back to the main configuration page. If
Graphic Hub REST runs as a replication cluster (failover or load balanced), you must also
change the configuration of the proxy.

Click the trashcan icon to remove a Graphic Hub REST binding from the list. Accidentally deleted
Graphic Hub REST bindings can be re-applied by configuring the deleted Graphic Hub REST again.

5.6 Report
= DMNC

CONFIGURATION MAINTENANCE  REPORT HELP ABOUT

Status:  REST is connected to running Graphic Hub.

Use the Report menu to access the Export functionality of Graphic Hub REST. This feature creation
and download of a system export file, as well as the possibility to view log files.
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5.6.1 Manage Reports

1. Click Report.
The Export panel displays all previously created report exports, as well as the error.log and
latest log files.

2. Click Create to

EXPORT LIST

generate a new export.

Export Date
error.log 01/31/2018 15:43
gh_rest_2018-01-30T08-07-10Z.log 01/31/2018 15:43
Export_20180131-144342 zip 01/31/2018 15:43

C Refresh

3. Select one or multiple exports, then click Download to download a .zip file containing
information about REST settings and current coinfiguration (or click Delete to remove all
selected exports).

EXPORT LIST

Export_20180131-144523 zip

error.log

gh_rest_2018-01-30T08-07-10Z log 2 2018 08-:47
Export_20180131-144342 zip 01/31/2018 15:43
Export_20180131-144525 zip 01/31/2018 15:45

]« 0 O«

4. To view the desired file
a. Click the Eye icon next to error.log
or
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b. gh_rest_YYYY-MM-DDThh-mm-ssZ.log.

EXPORT LIST

Export_2018

error.log

gh_rest_2018-01-30T08-07-10Z log 02/01/2018 08:47
Export_20180131-144342 zip 01/31/2018 15:43
Export_20180131-144525.zip 01/31/2018 15:45

|¢le © O |«

GRAPHIC HUB REST LOG

ERROR: 2018-01-30112:20:5/4: 16980: [465] 1939b) talled to open serve
ERROR: 2018-01-30T12:2] : 16980: [507] pen: Res / /er@LOCALHOST : 1
ERROR: 2018-01-3¢ RZhale : : [4@5] open )ST:19396) failed to open
ERROR: 2018-@ OT12:2] : 16 : [587] cvizDb pen: ResolveV /er@LOCALHOST : 1
ERROR: 2018-©1-30T12:21: : 1698@: [485] open (vizDbServer@LOCALHOST: ) failed to
ERROR: 201 : 169 [507] cvizpb pen: v ZG D rer@LOCALHOS
ERROR: 201f AT12:21:097 58 [4@5] op (VizDbServer@LOCALHOST: 19 ) failed to
ERROR: 30T12: 2! 5Z: 16980: [507] CvizDb pen: ResolveVizGH "V DS

ERROR: 2018 30T12:21:157 58 [4@5] open (VizDb er@_.0CALHOST:19 ) f

ERROR: 2018 30T12:21: : 16 : [587] cvizDb pen: ‘ V G ; ver@LOCALHOST : 1
ERROR: 2018 30T12:21:217: 16986: [405] open (vizDbs @ :1¢ ) failed to op
ERROR: 201¢ 30T12:21: : 1698@: [507] CVizDbI pen: Res / sk ver@LOCALHOST: 1
ERROR: 201 30T12:21:27Z: 16980: [405] (vizDbs @ E ) failed to op
ERROR: 2018-01-306T12:21: : 16 : [507] :open: Resolv G Server@LOCALHOST: 1
ERROR: 201¢ 30T12:21 o : [485] open (vizDbs @ : ) failed to op
ERROR: 201 307T12:21:39Z: [587] cvizDbI::open: ResolveV ver@LOCALHOST : 1.
ERROR: 201¢ 30T12:21: 16980: [485] (vizDbser ) failed to op
ERROR: 201 2:21: : 16980: [507] ropen: ResolveV ver@LOCALHOST : 1.
ERROR: 2018-81-30T12:21:457: 16980: [405] openServer(VizDb @Lc 96) failed to open
ERROR: 2018-01-30T12:21:507: client connected to : i : 05T:19396"° (othe
ERROR: 2018-@ eT12: : 16 : Client ected to

ERROR: 2018-01-3€ 1227: 16980: Client connected to server 'VvizDbServer@LOCALHOS

ERROR: 2018-01 - BRI Client connected to server 'VizDbServer@LOCALHO 6"

C Refresh

5.7 Failover/Load Balancing

It is possible to configure Graphic Hub REST to support failover and load balancing. Graphic Hub
REST is a standard HTTP server, so there is no need for integrated failover or load balancing logic.
This requires setting up a failover and load balancing cluster. A network professional must
configure a proxy and the DNS failover.
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The proxy covers only the redundancy of Graphic Hub REST. It does not cover redundancy for Pilot
or the Media Sequencer.

5.7.1 Important Notes

Never call the configuration site through the proxy URL. Always use the direct server
configuration URL instead.
In a failover/load balancing proxy setup, always configure all Graphic Hub REST nodes to
connect to the same Graphic Hub.
For very large installations only: Use multiple automatically synchronized Graphic
Hubs to increase the performance of big Graphic Hub REST clusters. You achieve this
by utilizing the Graphic Hub Deploy Agent.
Do not run a proxy on the same server as any Graphic Hub REST node.
- Add all IP addresses to the proxy configuration on servers with multiple network adapters.
- Some API calls do not work with a cluster configuration or multiple Graphic Hubs in a
cluster:
- The REST resource monitoring and statistics do not work in a cluster.
- The Graphic Hub statistics, journals, and sessions, do not work in a cluster with
clustered Graphic Hub RESTs connected to multiple Graphic Hubs.
- The APl documentation states proxy cluster compatibility information for every endpoint.

5.8 SSL In REST

SSL can be activated in GH REST by enabling Use SSL https connection in Web Server Configuration
Settings. This will encrypt connections to the REST interface using the HTTPS protocol. If the HTTPS
page includes content retrieved through a regular HTTP connection, the connection is only partially
encrypted. Most popular browsers block mixed content by default.

/\ IMPORTANT! The certificate files must be configured during Graphic Hub REST Installation.

While the GH REST interface can run with SSL encryption, the Graphic Hub Terminal cannot.
Because of this, the connection between them is considered mixed content and hence blocked.
This may cause an Unable to connect error message:
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Maming service:  loading...

Server name: loading...

This issue can be resolved by adding a security exemption. The steps to do this depend on the
browser in use:

Google Chrome:

Click the shield icon in the right of the address bar, or

Start Chrome from the command line using the additional flag --allow-running-
insecure-content.
Internet Explorer:

Scroll to the bottom of the screen and click Show all content.
Mozilla Firefox:

Click the shield icon to the left of the address bar.

Click the arrow next to the Connection is Not Secure warning, and select Disable
protection for now.

For details on how to show mixed content in other browsers, please refer to the
documentation for the browser in question.
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6 Graphic Hub Terminal

Graphic Hub Terminal is the web based user interface used to configure, start, stop, or restart The
Graphic Hub server and the Graphic Hub Naming Service. This chapter describes the Terminal’s
user interface, and how to use the Graphic Hub Terminal to configure and run the Graphic Hub.

The Graphic Hub Terminal User Interface consists of:

- The Menu Bar (1):
- Graphic Hub Modes
Backup and Restore
Reports
- Options
- Help and About
- The System Status Panel (2):
- System Status Panel
- The Event Log (3):
Event Log Panel

= Graphic Hub Terminal - GHServer

The Menu Bar provides access to the configuration of the Graphic Hub server and
Naming Service, backup and restore, reports, and settings. The icon on the left hand
side of the menu lets the viewer know in a glance if both of, one of, or none of the
Graphic Hub server and Naming Service are running:

-

U Both the Graphic Hub server and Naming Service are running.
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-w

U Only the Graphic Hub server is running.
-

U Only the Naming Service is running.

-w
U Neither Graphic Hub nor Naming Service are running.

- Directory Agent only mode active.

6.1 Graphic Hub Mode Configuration

The Mode menu is used to show information about the current configuration, create a new
configuration, or revert to a previous configuration. As the Graphic Hub server cannot be
configured or reconfigured while running, the Mode menu is inactive while the Graphic Hub server
is running. Shut down the server to access the configuration settings.

This page details the configuration of all the Graphic Hub Modes, and is divided in the following
sections:

Localhost, 5/4 Free, and Multiuser Configuration
Cluster Configuration
- Graphic Hub Configuration Parameters
Naming Service Only Modes
Directory Agent Only Configuration

6.1.1 Localhost, 5/4 Free, and Multiuser Configuration

1. From the Mode menu, select the desired configuration mode and click Create new
configuration.

2. Click the Configuration button.

3. Enter the Server name as it should be registered with the Naming Service. Click the reload

™y
button B to reset to the default name, vizDbServer.
. Enter the Data directory path where the Graphic Hub should store the data elements:

Server name® : VizDbServer

Data directory™ - CAViZGHData

5. Enter the parameters for a Naming Service:
In 5/4 Free and Multiuser modes, the Naming Service host name must be entered
unless Connect to local Viz GH Naming service is checked. For Graphic Hubs in
Localhost mode, this parameter cannot be changed.
Enter the Naming Service Port number. The default port is 19396.

6. Uncheck the Connect to local GH Naming Service if only a server start is required.
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7. Select a Network Adapter if the system has more than one adapter installed, or choose to
run the Graphic Hub on all adapters (default).
8. Enter the Server Port number on which the Graphic Hub listens to. The default port is 19397.

9. Click Apply.

6.1.2 Cluster Configuration

1. From the Mode menu, select Cluster and click Create new configuration.
2. Select the Main and Replication server from the drop-down list.

Main server Replication server

GH-REPLICATION

3. If Graphic Hub Terminal HTTP authentication is enabled, log on to the servers:

Log in to terminal: GHSERVER:19399

Mickname -

Password :

A IMPORTANT! If HTTP authentication is enabled, it must be enabled on both servers,
and the user name and password must be identical on both servers.

4. Click Create. This will enter a two-step process, where the Step 1 is setting the parameters
for the Main server. Step 2 is setting the parameters for the Replication server.
a. Set the parameters for the Main Server. The parameters are described in the Localhost,
5/4 Free, and Multiuser Configuration section. Click Next.
b. Set the parameters for the Replication server.
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5. Click Finish to return to the System Status panel, which should show the status for both
servers. The currently logged on to server will be signified by it’s panel casting a shadow:

6.1.3 Graphic Hub Configuration Parameters

This section details the configuration parameters for running the Graphic Hub server in Localhost,
5/4 Free, Multiuser, and Cluster (Main and Replication) modes.

The Graphic Hub configuration parameters can only be changed when the Graphic Hub server is
not running. In the Graphic Hub Terminal, click the Configuration button in the System Status
panel to open the configuration window:

GRAFPHIC HUB
Server name* :
Data directory* :

COMMNECTION SETTINGS

Connect to local Viz GH Naming service

Naming Service Port -
Metwork Adapter :
Server Port :

ADVANCED SETTINGS

Performance Settings Graphic Hub Timeout Settings

Search instances - 121 5 Server to Client timeout
(sec/10):
Process priority -

License Settings

Log Settings
Log server state

Journal level :

WIBU license location -

Graphic Hub

Server Name: Set the Graphic Hub server name.
Data Directory: Set the path to the Graphic Hub data directory.
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Connection Settings

Connect to local Viz GH Naming Service: Check the checkbox to start a Naming Service on
the local machine. When disabled, the Graphic Hub starts in server only mode when started.
However, this is only available for servers running in 5/4 free or multiuser mode. In such a
case, the hostname or IP address of a Naming Service server must be provided.

Naming Service Hostname: The host name or IP address of the server running the Naming
Service to connect to. Can only be edited when not connecting to a local Naming Service.
Naming Service Port: Set the port the Naming Service uses to directly communicate with the
other applications in the network. The default port is 19396.

Network Adapter: Select which network adapter the Graphic Hub should use. For maximum
performance, always choose the fastest network card available. Virtual connections tend to
be the slowest. When the network adapter is restricted, any connecting Viz Artist client must
connect to the IP address, not the host name.

Server Port: Set the port the Graphic Hub server listens to. The default port is 19397.

/\ Tip: Make sure that the selected port is not in use by any other applications.

Advanced Settings

In most cases, there is no need to change the advanced settings. Click the Advanced Settings title
bar to open the Advanced settings panel.

Performance Settings:
Search instances: The number of search threads that will be generated, limited by the
number of CPUs. The number of threads available for the Graphic Hub to execute a
search (the range is 1 to the number of CPU cores in the system). The default value
corresponds to the number of CPU cores in the system. Applies only to Graphic Hub
servers running in Multiuser, Main or Replication mode.

Process priority: Set the Graphic Hub process priority level (Low, Below Normal,
Normal, Above Normal, High, Realtime)

/\ Caution: Increasing the process priority level may cause system instability.

Log Settings:
Log server state: Check to enable logging of additional call information on the Graphic
Hub.
- Journal level: Set the system journal entry level.
Available journal levels:
No Logging: Disables all logs.
- All: Logs all the entries listed below.
Errors: Log Fatal Errors, Replication Errors, and so on.
- Warnings: Log Errors and Warnings.
File news: Log Errors, Warnings, and new file entries.
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File updates: Log Errors, Warnings, and updated file entries.
File deletes: Log Errors, Warnings, and deleted file entries.
Graphic Hub Timeout Settings:
Server to Client timeout (sec/10): The recommended setting is 2.
License Settings:
License system: Set the license system to use as the Graphic Hub license source.
Available choices:

Sentinel + WIBU: Prioritizes licenses from a Sentinel dongle. If no dongle is
found, the WiBu system is used instead.

& Note: Even if the Sentinel license is expired or invalid, it remains tied to
the dongle.

Sentinel: Sets the Sentinel dongle as the license source.

WIBU: Sets the WiBu licensing system. To use this system, the CodeMeter

Runtime needs to be installed, running and configured on all affected systems.
WIBU license location: Set the WiBu license container location.

/\ Note: Details regarding the types of containers are listed in the Local and
Network descriptions below.

Local/Network: Prioritizes WiBu system licenses from a local license container. If
no valid license is found locally, the system switches to a network container.
Network/Local: Prioritizes WiBu system licenses from a license server on the
network. If no valid license is found on the network, the system switches to
licenses to a local container.
Local: Sets a local license container as the license location. This container may
be:

a file-based container on the local system,

or a WiBu dongle-based container connected/bound to the local system.
Network: Sets a network license container as the license location. This container
may be:

a file-based container on a configured license server on the network,

or a WiBu dongle-based container connected/bound to the license server

on the network.

Additional Advanced Settings for Cluster Configurations

These settings apply to Main Server and Replication Server modes only.
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Performance Seaings
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Graphic Hub Timeout Settings:

- Server to Client timeout (sec/10): The recommended setting is 2, which is 0.2 seconds.
Cluster timeout (sec/10): The recommended setting is 300, which is 30 seconds.
Cluster idle switchback time (sec): Defines how long the Graphic Hub waits for no
activity from clients to return from a failover or switchback. The range is 1 to 30
seconds. The default value is 15 seconds.

Naming Service Timeout Settings:
Timeout Responsiveness (s): Sets the timeout responsiveness. Must be 1 or greater.
Check frequency (s): Sets how often to check for unresponsive Naming Service servers.
Unbinding Time (s): Sets the delay after which unresponsive servers will be unbound.
No. of Loops Used: Determines the number of loops for unresponsive server
recognition. Must be 1 or greater.
Performance Settings: Sets the number of Search instances and the Process priority
level, as described for Localhost, 5/4 Free and Multiuser above.

6.1.4 Naming Service Only Modes

The Naming Service is a discovery service that provides client applications with the location of one
or more Graphic Hubs on the network. The most common configuration involves each Graphic Hub
server running its own Naming Service, a configuration option which is valid for all Graphic Hub
Modes. It is also possible to configure one Naming Service for Multiple Servers. However, this
configuration is only valid for 5/4 Free and Multiuser modes.
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To Start in Naming Service Only Mode

1. Open the Graphic Hub Terminal.
2. Go to Mode > GH Naming Service onl

uration.

> Create new confi

Mode Backup Report Options

Localhost .
tings

5/4 free b

erminal

Multiuser 3

Cluster 3

Maming service c:nrrl:.' Load Eanﬁ'gu ration ¥

Directory Agent only Load and run configuration k

Create new configuration

3. In the Graphic Hub Naming Service configuration screen, Enter the port number for the
Naming Service to communicate through. The default port number is 19396. The host name
is the name of the local machine, and cannot be changed:

GRAPHIC HUB NAMING SERVICE

Maming Service Port :
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Click Apply, then Start Naming Service when the Terminal has returned to the main page to
Service Only mode.

start in Naming

Maming service: GHServer:193%6

Mode: Maming Service Only

Maming service status: Running

Naming Service for Multiple Servers

Two or more Graphic Hubs running in different modes can be connected to one Naming Service.
The following example configuration utilizes three machines: one as Naming Service server, and

the other two as Graphic Hub servers.

To Configure One Naming Service for All Servers

1. On the Naming Service server, start the Graphic Hub Terminal in Naming Service only mode.
2. Open the Graphic Hub Terminal on the servers that are intended to connect to the Naming

Service.
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3. Create a new 5/4 Free or Multiuser configuration.

Mode Backup Report Options

Terminal | LGt ¥ tines
[«  Sidfree 3 Load configuration
Multiuser 3 Load and run configuration
Cluster 3
Create new configuration

Maming senvice only

Directory Agent only

Report Options
= - k Fines
Terminal Lings

Multiuser , Load configuration

Cluster Load and run cc-r'lﬁguraﬁr:nn

Maming service only Create new configuration

Directory Agent only

4. Click Config

Naming servi
Serve tus

Data path:

Automatic backup:

|ou

Snow GH Log
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5. Uncheck the Connect to local Graphic Hub Naming Service checkbox.

COMNMECTION SETTINGS

Connect to local Viz GH Naming service

Maming Service Port :

Metwork Adapter :

Server Port :

6. In the Naming Service Hosthame field, enter the IP address of the server running the Naming
Service.

Graphic Hub

Server name* ; VizDbServer

Data directory® : CAVizGHData

/\ IMPORTANT! Unique names are required for each Graphic Hub server on the network.
This means it is not possible to start two Graphic Hubs configured with identical
Naming Service and Graphic Hub server names.

7. Click Apply.
8. Click Start to start in Server Only mode.

6.1.5 Directory Agent Only Configuration

When the Graphic Hub is in Directory Agent only mode, the Service Location Protocol (SLP) service
is configured to run as a Directory Agent. The Directory Agent collects information from other
Graphic Hub Terminals on the network, configured as SLP Service Agents, and presents this
information when asked. A correctly configured SLP service presents Graphic Hubs available on the
network or other networks to client applications on the same subnet without performing multicast
or broadcasting.

A Graphic Hub Terminal configured in Directory Agent only mode cannot simultaneously be used
as a Graphic Hub. However, Directory Agent functionality can be enabled in parallel when a
Graphic Hub is running, under the Service Discovery Settings of the Terminal.

6.2 Backup And Restore

The Backup menu shows the backup, restore and data recovery options. As the Graphic Hub server
cannot be backed up or restored while running, the server must be shut down to enable changes
to the configuration settings.
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Backup Report Options

= Back
Status: Server and nal .

Show last backup

Data recovery (Safe Mode) : Configuration

The internal backup and restore operations of the Graphic Hub is an incremental process. If one
backup or restore operation succeeds, all subsequent operations copy the difference from the
successful backup/restore to the current operation. Restore points are created to accomplish this
process.

- The first restore point holds information about the original data directory.

- The second point holds information about changes from the startup to the first backup.

- The third point holds information from the first to second backup, and so on. If no changes
have been made since the previous backup, the Graphic Hub will not create a new restore
point.

/\ Example: The first backup finished successfully at 01.01.2009 00:00:10 and the
second at 01.01.2009 12:00:00. Between the backups, one scene was modified;
“MyScene”. The latest restore point would then only contain data regarding this
scene. If restoring to the previous point, only “MyScene” will reset to its status at
01.01.2009 00:00:10.

There are two kinds of backup, internal and external, both of which are configured in the
Graphic Hub Terminal. Make sure to shut down the Graphic Hub before performing backup
configuration.

6.2.1 Internal Backup

Internal Backups are incremental backups as described above. It is possible to limit the number of
restore points after a backup. Reducing the amount of restore points vastly reduces the amount of
disk space required on the server.

6.2.2 External Backup

External backups are executed via a command line call of the Graphic Hub Terminal. It is a full
backup, and requires the creation of a batch file for execution. Output from the batch file to the
console is visible in the Terminal logging window.

This example batch file copies the data directory to C:\COPY:
external-backup-example.bat
@ECHO off
echo Starting copy of data dir: "%~1"

IF [%1] == [] (
echo ERROR: NO DATADIR SET
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EXIT 1
)
robocopy "%~1." "C:\COPY" /MIR /COPY:DAT /DCOPY:T
echo "robocopy exit code: %ERRORLEVEL%"
IF %ERRORLEVEL% LEQ 7 (
echo FINISHED SUCCESSFULLY
EXIT ©
) else (
echo ERROR DETECTED
EXIT 1

Backup Configuration

This section details the parameters and configuration of the backup and restore system.

/\ Tip: Backup can only be configured when the Graphic Hub server is not running.

Go to Backup > Backup > Configuration to open the Backup configuration window:

COMAGURATION

) Dpisabled

Internal Backup

External Backup

AUTOMATIC BACKLP SETTINGS (MUST BE SET BE E GRAPHIC HUE SERVER S5TART)

Backup Configuration

Disabled: Backup disabled.

Internal Backup: Click to make internal backup active.
Backup Directory: Enter a backup directory path. Only local drives are allowed as
backup directory path.
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Cleanup restore points: Check this checkbox to enable limits to the number of stored
restore points. All restore points beyond the maximum will be deleted. This can save
considerable hard disk space.
- Maximum restore points: Set the maximum number of restore points.
External Backup: Click to activate external backup.
Batch file path: Set the path to and name of the batch file to execute.

/\ Note: As Graphic Hub Terminal runs as a service under the SYSTEM account, it
cannot access network drives mapped by another user. Make sure that the
destination path for the external backup is a local drive.

Automatic Backup Settings

This is used in combination with a shut down task to do periodic automated backups:

- Automatic backup after successful shutdown: When checked, an automatic backup on server

shutdown is performed.

Start after backup: When checked, the server is automatically started upon completion of the
automatic backup.

/\ Note: Start after backup is only applicable when shutting down the server through
the Graphic Hub Manager or when the server is shut down by Scheduled Tasks.

To Configure Backup

1.

uTh WN

Shutdown the Graphic Hub server if it is running, in accordance with the Graphic Hub Shut
Down procedure.

Open the Graphic Hub Terminal.
Go to Backup > Show Configuration.
Select the required backup type, Internal or External.
For Internal Backup:
a. Select Internal Backup.
b. Enter the Backup Directory path.
c. If required, check the Cleanup restore points checkbox and set the maximum number
of restore points.
For External Backup:
a. Select External Backup.
b. Enter the Batch file path.
Select as required:
- Automatic backup after successful shutdown
Start after backup.
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8. Click Apply to perform the backup operation.
BACKUP COMAGLURATION

Disabled
g Internal Backup
Backup directony® :
% Cleanup restore points

Maximum restore points :

External Backup

AUTOMATIC BACKUP SETTINGS (MUST BE SET BEFORE GRAPHIC HUB SERVER 5TART)

” : ; - I
Ed Automatic backup after successful shutdown

ﬁ Start after backup

6.2.3 Perform Database Backup

This section details the backup of a Graphic Hub database. The procedure depends on whether an
internal or an external backup has been configured.

To Do an Internal Backup

1. Shutdown the Graphic Hub server if it is running, in accordance with the Graphic Hub Shut
Down procedure.

2. Open the Graphic Hub Terminal.

3. Select Backup > Create backup now.
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4. The backup is created in the directory specified in the backup configuration, as indicated by
the Create backup now link.

Backup mode: Intern Started:
Backup sounce: K Ended:
Data directory:  C G Total duration:
Backup directony: | L Finish state:
Starting
Scan Backup Directony
Scan Data Directory
Calculate Operations
Create Rest

Perform Backup

To Do an External Backup

1. Shutdown the Graphic Hub server if it is running, in accordance with the Graphic Hub Shut
Down procedure.

Make sure that the a batch file has been created and is available.

Open the Graphic Hub Terminal.

Select Backup > Create backup now (External Backup).

w N

Backup mode: External Backup Started:

Backup source: Manual backup Ended:

Data directory; C: iData Total duration; 0
Batch file: CA \Desktop\External Backup. bat Finish state: Succes

1} Starting

2) Perform Backu p

3) Finished

6.2.4 Restore Files

To open the Restore Points panel, open the Graphic Hub Terminal and select Restore from the
Backup menu. The panel contains information about the restore points available according to the
current backup configuration, such as the date and time the restore point was created, how many
files it contains, and the location.
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Size Path

1M1.04 KB C\Backup Folder\RP_1\

Hestore directony™ :

The Restore Points panel is accessible when the Graphic Hub is running. However, it is not possible
to perform a restore task while the Graphic Hub is running.

Restoring Files: Best Practices

When files are restored, observe these best practices:

Data directories: It is not recommended to restore files to an already existing data directory.
Create a new directory and restore the files there. Then start a new configuration of the
Graphic Hub Server using the location of the restored files as data directory.

To Restore Backup Files

1.

2.

3.
4.

Shutdown the Graphic Hub server if it is running, in accordance with the Graphic Hub Shut
Down procedure.
In the Graphic Hub Terminal, go to Backup > Restore.

Date A Files De & Size

09/0772016 13:58 77 77 0 111.04 KB C\Backup Folder\RP_1\

Restore directony® CAResiore Folder

Select which restore point to restore.
In the Restore directory field, enter the location which the files should be restored to, or
press the browse button to browse to the desired location. New directories can be created
either by typing in a non-existing path in the Restore directory field, or by right clicking the
directory tree while browsing and selecting New folder.
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/\ Caution: Do not restore files to an existing data directory, as this will overwrite any
existing data. Instead, create a new directory and restore the files there.

5. Click Restore. The Restore progress window appears, providing information about the
restore process.

RESTORE PROGRESS

Backup directory: C\Backup Folder Started:
Restore directory: C\Restore Folder Ended: g 016, 2:25224 PM

Restore point 1 Total duration: Os
Finish state: Success
Starting
5can Restore Points
Scan Backup Directory
5can Restore Directory
Calculate Operations
Copy Backup
Apply Restore Points

Finished

6.2.5 Safe Mode

The Graphic Hub Terminal should be started in Safe Mode if the database has crashed and needs
to be restarted.

Rebuilding the database in Safe Mode can take several hours, depending on the amount of data
that needs to be reconstructed. The recovered directory cannot be accessed by clients such as Viz
Artist. It can only be accessed by a system administrator using the Graphic Hub Manager.

A Caution: Do not use Safe Mode for valid data directories.

To Prepare for Database Repair

Back up the current data directory.

Close all Graphic Hub Deploy Agent connections to the server.

Close all Graphic Hub Rest Agent connections to the server.

Make sure that the instance is not part of a Graphic Hub Cluster environment.
Make sure that the latest version of Graphic Hub is installed.

uTh WN —
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To Start Graphic Hub Terminal in Safe Mode

1. Prepare the repair procedure as described above.
2. In the Graphic Hub Terminal, go to Backup > Data recovery (Safe Mode):

jl You are about to start Viz Graphic Hub in SAFE MO

Please reaq following comm

data (Sample: Amo

3. Carefully read the information, then click Start to proceed.
SAFE MODE

A Are you sure you want to start Viz Graphic Hub in
SAFE MODE?

Host: GHSERVER-19399
GH server name: VizDbServer

GH server mode: 5/4 Free

Data directory:  C:WizGHData

4. Check the configuration settings, then click Start.
This begins the rebuild process. Rebuilding a large database may take several hours to
complete.
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Running in SAFE MODE! b

GRAPHIC HUB COMSOLE: 5/4 FREE - GHSERVER

When the data has been rebuilt, the Graphic Hub Manager will contain a folder called
RECOVERED_AT_YYYY-MM-DD_HH_MM_SS. The date and time in the folder name serves as a
timestamp for the last modification.

Viz GH Manager

Server View Tools Extra Pilot Info
Address: 1. -» Root of VizDb5erver@GHSERVER

Servers and folders w 0 X

/U% Servers and folders x_;" Search

1 - VizDbServer @GHSERVER (Admin)
i data

IEl i RECOVERED_AT_2016-03-07_14-28-07 |

& AUDIO CLIP -

BASE_FONT

FONT

GEOM

IMAGE

MATERIAL

MATERIAL_ADVANCED

SCEME

SHARED_MEMORY_MAP

SUBSTAMNCE

VIDEO_CLIP

Successful Restore Operation
The database has been successfully restored when:

The red console panel shows that the server is up and running.
All processed files are listed in Reports.
Files can be viewed in the Graphic Hub Manager.
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/\ IMPORTANT! A Graphic Hub server in a production environment must never run in
safe mode. Safe Mode is only for restoring a corrupted database. This instance can
now serve as a source for rebuilding an empty destination database through the DDC
functionality (see Graphic Hub Deploy Agent).

6.3 Reports

Mode Backup Report Options

System information
Graphic Hub log

Graphic Hub console

Use the Report menu to access system information, the Graphic Hub log, or Graphic Hub console.
In addition, the Export menu item allows the creation of a system export file, and shows all
previous created report export files.

System information: View the Process List and System information panels.
Graphic Hub Log: View the current Graphic Hub Server log.

Graphic Hub console: View the Graphic Hub Console.

Export: Create, download or delete system export files.
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6.3.1 System information

—
0
0
363 MB 3.68 MB
6.67 ME
10.23 MB
952 MBE

7.02 MBE

Graphic Hub Configuration 32

Graphic HMub Confipuration 64 bi

18.211.181.113; 8-58-5

The Process List panel provides an overview of the processes running on the machine and their
resource use. If required, the CPU usage can also be measured, by checking the Measure CPU
Usage check box in the upper right corner. The Process list lists the following information:

The process identifier (PID) and name of the process executable.

The number of handles and threads used by the process.

The current and peak Working Set (WS) size in bytes.

The number of input/output (I0) operations performed in read (RO), write (WO) and other
(O0) operations.

The number of input/output (I0) bytes read (RT), written (WT) and other (OT) transfers.
The number of page faults.

The current and peak pagefile usage.

Estimated CPU usage (if enabled).

The system information panel lists details regarding the current system’s hardware and
software configuration. This includes:

The system architecture (32- or 64-bit).

Other installed Graphic Hub applications, such as the Graphic Hub Manager and Graphic Hub
Deploy Agent.

The amount and usage of system RAM.

The installed network adapters and their IP addresses and connectivity status.

Information about the installed hard disk drives.

Information about the system CPU(s).

Further information about the workstation configuration, the configured network, operating
system and installed software.
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6.3.2 Export File Parameters

Reports are essential troubleshooting tools when there is any kind of system error. The generation
of a report should be one of the first actions performed when a system problem occurs, as it can
provide valuable information and help to find a solution. Reports can also be generated
automatically in case of an unexpected server shutdown.

& IMPORTANT! In the reports folder, there is a file called Systemlnfo.txt. Before this file is
sent anywhere, make sure to read it and remove any information that could compromise
Company security policies and interests.

/\ Tip: On a cluster setup, exporting the report from the Main server will automatically
generate and download two reports, one for each of Main and Replication servers. Both
reports are required for troubleshooting.

The Export file panel shows all report files created for export:

GHSERVER

Click the download icon (1) to download the selected export file.
Click the trashcan icon (2) to delete the selected export file.

To Manually Generate a Report
1. Click Report > Export.
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. Click Create.

EXPORT CREATION PROGRESS

1)  Create export (Report export finished successfully.)

2}  Download export

3. Select to Open or Save the created file.

To Automatically Create Reports of Unexpected Shutdown
1. Click Options > Journal/Logging settings.

2. In Report Settings, check the Report on unexpected Graphic Hub shutdown checkbox.
REPORT SETTINGS
Report Export directory & rambDat Wiz GH Terminal? H_Reporish  [ses
ﬂ Report on unexpected Graphic Hub shutdown
3. Click Apply.

The report will be exported to the directory selected as Report Export directory.

6.3.3 Report Content

A report consists of the following files and information:

Graphic Hub version information (VersionInfo.txt).
- Windows event logs (vizrt.evt, system.evt, application.evt).
Graphic Hub log files (LogFiles directory in export).
Graphic Hub HQL tables with journals (x.dat, *.idx, *.idx.fid).
- Terminal log files (Terminal directory in export).
OpenSLP configuration.

- Terminal configuration (Terminal/Configuration Files directory).
Naming Service and Graphic Hub configuration (x.cfg).
Configuration backup files (x.reg).

- Terminal log files (x.log, Terminal/Log Files directory).

- Journal backup files (vizGHJournalBackup.xml).

System information (SystemInfo.txt), containing:
Graphic Hub Applications registry settings.
Network adapters.
Drives.
CPU, Workstation, Operating System.
Installed Programs and Updates.

Running processes information (ProcessInfo.txt).

Crash dump files if available (Crash Dumps directory in export).
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- Timestamps when report export was generated (timeinfo.txt).
Current data directory (datadirectory.txt).
Graphic Hub Application related firewall information (Firewall. txt).

6.4 Options

Backup Report Options

Status Service discovery settings
Journal/Logging settings
Email settings

Scheduled tasks

Advanced settings

Change Terminal password

Use the Options menu to access a range of configurations and settings, as well as schedule tasks
in the Graphic Hub Terminal:

Service Discovery Settings
Directory Agent Only Configuration
Service Location Protocol (SLP)
Basic Explanation
How to configure multiple isolated subnets
Proposal for performance improvement
- Journal/Logging Settings
Email Configuration
Email Settings
- To Enable E-mail
Scheduled Tasks
Scheduled Tasks Parameters
- Task types
- To Schedule a Journal Backup Task
- To Schedule a Cleanup of Expired Items Task
- Advanced Settings
Change Terminal Password

6.4.1 Service Discovery Settings

The Graphic Hub Terminal publishes a service through the Service Location Protocol (SLP) on the
network. This enables clients to find Graphic Hubs running on the local network or other
connected networks without knowing their host names or IPs.

The Graphic Hub Terminal can be used to configure the SLP service, letting it act as a Service
Agent. Configuring the SLP service as a Directory Agent will speed up searching, because the
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server will act as a service cache on its own subnet, responding to requests from clients without
broadcasting (multicast).

Registration check interval
{s):

Lifetime (s) :

m Directory Agent

Directory Agent Addresses © Enter
Interfaces

Client request timeout ()

G Re-initialize

Registration check interval (s): Interval in which to check for Graphic Hub Terminal service
registration status.
The Graphic Hub Terminal periodically checks that the Service Location Protocol service
(slpd) is running and will try to restart the service if it has stopped. The Terminal re-registers
a previously registered service if:
- The slpd service is restarted.
The registration is about to time out, based on lifetime provided at registration and
registration time.
The slpd service process start time is after the registration time, meaning the slpd has
been restarted between re-registration checks.
Lifetime (s): The initial Graphic Hub service lifetime until the service registration expires.
If set to immediate (65535, Maximum), the service will remain registered for the
lifetime of the Graphic Hub Terminal service process and is immediately unregistered
when the Terminal process ends.
Directory Agent: Enable or disable the Service Location Protocol service to function as a
Directory Agent. It is recommended to read the OpenSLP Users Guide before enabling this
setting. Consider the following:
Only a few Directory Agents should exist per subnet.
Do not add any local IP addresses or the hostname to the list of Directory Agent
addresses.
When enabled, the Directory Agent sets the slpd configuration file tag (net.slp.1isDA).
It automatically creates a slpd configuration file if one does not previously exist,
however, it will not change an existing configuration file or restart the slpd service if
nothing is changed.
Directory Agent Addresses: Define a list of IP addresses with the location of one or more
Directory Agents. Click the list button to display a list of all Directory Agents discovered on
the network.
This is useful if the Directory Agent cannot be discovered via multicast or broadcast.
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When empty, no predefined Directory Agent is used and automated discovery is
performed. Forces local User Agents and Service Agent to use the specific Directory
Agents and disables dynamic Directory Agent discovery.
Creates a slpd configuration file if it does not exist yet.
Sets the slpd configuration file tag net.slp.DAAddresses.
Does not change the configuration file or restart the slpd service if nothing has been
changed.
Interfaces: List of IP addresses to listen for Service Discovery requests. This is useful on a
system with multiple interfaces.
When empty, all interfaces are used to advertise the Graphic Hub Terminal service.
If set, the slpd service listens for unicast and multicast or broadcast SLP requests on
the interfaces that are listed, rather than on the default interface or all interfaces.
Sets the slpd configuration file tag net.slp.interfaces.
Creates a slpd configuration file if it does not exist yet.

Does not change the configuration file or restart the slpd service if nothing has been
changed.

/\ Note: The Graphic Hub Terminal service is advertised on all interfaces by
default.

Client request timeout(s): Set the maximum combined timeout allowed for SLP client

requests in seconds. Adjusts multiple timeout values: Unicast, multicast and Directory Agent
discovery timeout.

Re-initialize: Re-start the Service Location Protocol service.
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Directory Agent Only Configuration

1. From the Mode menu, select Directory Agent only.

Directory Agent Only

Running
only status: Stopped

2. The System automatically configures the SLP service to run as Directory Agent.
3. Press Start.

Service Location Protocol (SLP)

SLP is used by devices to announce services on a local network using "service URLs". In addition
there may be attributes set, basically key-value pairs.

Example

URL: service:terminal.vizrt:http://GHSERVER:19399/terminal.svc
Attributes: x-version=3.0.3.71516, x-ip-addresses=10.211.2.150, x-operation=SERVER, x-ns-name=GHSERVER, x-

server—name=GHSERVER

Basic Explanation
SLP has three different roles for devices. They can also have two or more roles at the same time.

User Agents (UA): search for services
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Service Agents (SA): announce one or more services
Optional: Directory Agents (DA): cache services information, therefore they are used in larger
networks to reduce traffic

APPLICATION SERVICE

we want this info

SERVICE SERVICE AGENT
USER AGENT AGENT which does not reply
4 to UA requests

Fy
Y

]
-

Y

DIRECTORY AGENT

Many other SA's

Possible operation of SLP:

1. UA obtained the location of DA: UA unicasts a request to DA to resolve a particular request.
DA will unicast a reply to UA. If DA cannot service the request (e.g. no information) it returns
a response with zero values, possibly with an error code set.

2. UA does not have knowledge of DA or no DA's available: UA multicasts a request to the
service-specific multicast address, service responds. All the SA's which are listening to this
multicast address will respond, provided they can satisfy UAs request. SAs which have no
information for the UA must not respond.

How to configure multiple isolated subnets

Routing of multicast packets across subnet boundaries is by default disabled or more accurate
blocked.

Therefore when SAs and UAs are on different subnets steps need to be initiated:
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SA

Subnet 1

DA

SA

UA

Subnet 2

DA

SA

SA

UA

Proposal for performance improvement

Use of DAs has several Advantages:

UAs receive faster responses.
Less network bandwidth used.
Minimum multicast messages are issued.

Improve performance in Large Networks:

Use more DAs to enhance Service Location Protocol performance.

Creates roughly duplicate repositories of service information without requiring any formal
database synchronization between them.
UAs can choose any available DA to issue requests to, the load will be shared among DAs.
Provide robustness in cases where one fails or becomes overloaded.

6.4.2 Journal/Logging Settings

This section details the parameters and configuration of the Graphic Hub Journal.
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[} Enable journal backup* Mextr 85 (7 16, 2:00:00 AM)

- Journal Backup Settings:
Enable Journal Backup: Check the box to enable scheduled journal backup tasks. By
default, the journal backup interval is set to once a week, starting one week from
01.01.2007 at 00:00:00.
Directory: Set the directory where the journal backup file (vizGHJournalBackup.xml)
will be created.

- Truncate: Check the box to create one backup file only, which will be truncated and
overwritten on each backup. If not checked, every journal backup task will create a
new backup file, with the date and time of the backup in the file name.

Report Settings:

Report Export Directory: Set the directory where the exported reports should be
stored.
Report on unexpected Graphic Hub shutdown: Check the box to enable automatically
generated reports in the event of an unexpected shutdown of the Graphic Hub server.

- Graphic Hub Terminal Log Settings:
Log event history length: Sets the maximum event history log length.
Log file history count: Sets the maximum number of logged operations per log file.
Log file log event count: Maximum of log events per log file to keep

6.4.3 Email Configuration

The Graphic Hub can be configured to send notifications about specific types of journal entries via
email. The type of journal information that can be sent as an email includes:

- Action Log
Information
- Warnings
Errors
Deploy task information
The Graphic Hub Terminal is used to enable and configure the email settings for the Graphic
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Hub. Go to Options > Email settings to configure the outgoing email server settings. Then
use the Graphic Hub Manager to configure which alerts should trigger an email notification.

Email Settings

E-MAIL SETTINGS

Enable mail sending*

Enable mail sending: Send an email to defined recipients when unexpected server shutdowns
occur, or if the license is not valid or about to expire. The system will also send email
according to the defined log level.

Mail server host: Enter the hostname or IP address of the SMTP server. This field is required.
Mail server port: Enter the SMTP server port.

Use SSL: Check the box to enable Secure Sockets Layer (SSL) encryption when connecting to
the specified SMTP server.

/\ Note: Supports only the SMTP Service Extension for Secure SMTP over Transport
Layer Security as defined in RFC 320 with STARTTLS.

Username/Password: Set the username and password used to authenticate the sender on the
outgoing email server, if required.
From: Enter the email sender address. Required field.

- To: Enter the email address(es) that the messages should be sent to, one per line. Press
enter to store an entry. Required field.
Send mail after successful server start: Check the box to send notifications when the server
is successfully started. This is in addition to the default and log level emails.
Send mail after server emergency shutdown: Check the box to send an email when the
Graphic Hub server is shut down through the Terminal. This is in addition to the default and
log level emails.
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Send Test Mail: Click the button to send an email to the defined recipients for testing
purposes.

To Enable E-mail

1. In the Graphic Hub Terminal, click Options -> Email settings.

Mode Backup Report Options

= Service discovery settings
Terminal Options:  Email settings Senvice discovery seuing

journal/Logging settings

Email settings

=Cheduled tasks

Advanced settings

Change Terminal password

Check the Enable mail checkbox.
In Mail Server host, enter the SMTP server hostname or IP address.
Enter the Mail Server port.
Check the Use SSL checkbox if SSL encrypted connection is required.
In From, enter the sender email address.
In To, enter one or more recipient addresses.
Click OK.
If required, check the boxes to include:
Send mail after successful server start
Send mail after server emergency shutdown
10. Click Apply.
11. Optional. To check the email settings, click Send Test Email.
12. Go to Alerts in the Graphic Hub Manager and configure email alerts.

WoONOUVNRAWN

6.4.4 Scheduled Tasks

This section details how to create scheduled tasks for Shutdown, Journal backup, and Cleanup of
expired items.
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Scheduled Tasks Parameters

Shutdawn - g : . found

- 272016
Journal back up i 'I|'|-'I_='E'k_|"-|' ),

Cleanup of expired iterms

The ACTIVE panel contains rows of defined scheduled tasks, and provides an easy overview of the
configured settings for each task specified in each column:

Active: A green check mark indicates that the task is active.

Task: The task type.

Mode: The task mode can be Once, Recurring or Recurring forever.

Start at: Contains the time and date for the first instance of the task.

End after: Defines the number of repetitions or the end date and time. Only applicable when
task mode is set to Recurring.

Each/Interval: Defines the time between each instance of a recurring task, in hours, days or
weeks. Only applicable when task mode is set to Recurring or Recurring forever.

Detail: Provides additional information about the task, such as the next scheduled
occurrence.

Click on a task to open it in the EDITOR panel and to configure its settings. The available
settings depend on the task selected. The Mode, Start at, End after and Each parameter all
correspond to the columns in the ACTIVE panel. In addition, the following settings can be
edited:

Checkbox: Check the box to activate the scheduled task. Applies only to the Shutdown task
type.
Info: Provides information about the selected task, such as the next scheduled run or if the
task has expired.
Cleanup of Pilot data elements task type only:
Cleanup of data elements older than: Sets the time range of kept Pilot elements and
library elements of Cleanup of library elements are also checked. All entries older than
this setting will be deleted upon execution of the task.
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- Cleanup of library elements: Checking this box enables cleanup of the Pilot library
elements in addition to the cleanup of data elements.

- Cleanup of invalid elements (integrity cleanup): Checking this box enables cleanup of
invalid Pilot data elements with broken integrity.

Task types

- Shutdown: View scheduled server shutdowns.
- Journal Backup: View scheduled Journal backups (see Journal Panel).
- Cleanup of expired Items: Tick the box to enable a cleanup of expired items after a journal

backup (see General Properties in Servers and Folders). This task can only be enabled or
disabled in the Advanced Settings.

- Cleanup of Pilot data elements: This task deletes all data elements that are older than the

configured timespan when the task is executed. Optionally, deletion of library elements and
invalid elements can be enabled in the task settings. This task can only be enabled or
disabled in the Advanced Settings.

- Cleanup of pilot changelog: This task deletes all Pilot changelog entries that are older than

the configured timespan when the task is executed. This task can only be enabled or
disabled in the Advanced Settings.

/\ Note: The cleanup tasks do not run on a Replication server, except when it is running
in the Main mode and the tasks are enabled in the Graphic Hub Terminal.

To Schedule a Journal Backup Task

N

. Make sure that the Enable journal backup checkbox in Journal/Logging Settings is checked.

Go to Options > Scheduled tasks > Journal backup.

Set a Start Time and select an Interval for the backup.

The Info displays information about the next scheduled journal backup.
Click Apply to commit the changes.

To Schedule a Cleanup of Expired Items Task

A WN —

Go to Options > Advanced settings.

Make sure that the Enable cleanup checkbox is checked for the selected cleanup task.
Go to Options > Scheduled tasks > Cleanup of expired items.

Set a Start Time and select an Interval for the cleanup task.

The Info displays information about the next scheduled cleanup task.
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6.4.5 Advanced Settings

Start server on Terminal Sservice start

tart Graphic Hub Server on unexpectad e mination

s

Enable cleanup of expired items
Enable cleanup of Pilot data elements

Mo 1ask scheduled.

Global tmeout (s)

Connection timeout [5)

Start and Shutdown Settings:
- Start server on Terminal service start: Automatically start the last successful server

configuration when the Terminal service starts
Automatic restart Graphic Hub server on unexpected termination: Automatically start
the last successful configuration if the Graphic Hub terminates unexpectedly. If the
Graphic Hub has been restarted three times and an unexpected shutdown occurs
within 30 minutes after the last startup, the automatic restart will be skipped. An entry
will be added to the event log of the Graphic Hub Terminal, as well as to the Graphic
Hub server log file.

GH Terminal HTTP Connection Settings: The web server is restarted after applying any

changes to the HTTP connection settings, which may take some time.
HTTP port: Set the Graphic Hub Terminal port. The default port is 19399. The port can
only be changed while the Graphic Hub server is not running, or during installation of
the Graphic Hub.
HTTP authentication: Enable or disable authentication for the Graphic Hub Terminal.
The username is Admin and the default password is vizDb (case sensitive). The
password can be changed after applying changes, by selecting Options -> Change
Terminal password.

Cleanup Settings:

- Cleanup of expired Items: Check the box to enable scheduled cleanup of expired

items.
Cleanup of Pilot data elements: Enable cleanup of old Pilot data elements by the
Graphic Hub Terminal. In addition, a cleanup task for Pilot data elements must be
configured. When the cleanup of Pilot data elements task is performed by the
Terminal, it deletes all data elements that are older than the configured timespan
when the task is executed (for example, all data elements older than one week are
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deleted when the task is run). Optionally, deletion of library elements can be enabled
in the task settings. After the cleanup task, a log is written to the file
CleanupPilotDataelements.log. If e-mail notifications are enabled in the Terminal
options, this operation triggers a notification.
Cleanup of Pilot changelog: Enable cleanup of old Pilot changelog by the Graphic Hub
Terminal. In addition, a cleanup task for the Pilot changelog must be configured. When
the cleanup of Pilot changelog task is performed by the Terminal, it deletes all Pilot
changelog entries that are older than the configured timespan when the task is
executed (for example, all changes older than one day are deleted when the task is
run). After the cleanup task, a log is written to the file CleanupPilotChangelog. log. If
e-mail notifications are enabled in the Terminal options, this operation triggers a
notification.

GH Terminal Connection Settings:
Global timeout (s): Global timeout for Graphic Hub Terminal’s connection to Graphic
Hub. Default: 36 seconds.
Connect timeout (s): Global timeout for Graphic Hub Terminal to initialize the
Connection to Graphic Hub. Default: 15 seconds.

6.4.6 Change Terminal Password

Change terminal patswornd

Confirrm mew password

Change Terminal password is used to change the password of the Terminal’s Admin user. HTTP
authentication must be enabled in the Advanced Settings to change the Terminal password. On a
cluster, both Terminals must have the same user names and passwords. If the passwords are not
identical, automatic start of the partner server will not work.

6.5 Help And About

About

Versions

Graphic Hub license

Third party licenses

Help: Opens the Graphic Hub documentation in a new window.
- About:
- Versions: Opens the Versions window, which lists the version numbers for the core
components of the Graphic Hub. It also displays the number of emails that have been
sent or failed to send since the Graphic Hub was started.
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Graphic Hub License: Opens the Graphic Hub License information window, which
displays information about the license and expiry date, and can be used to update the
license string.

- Third party licenses: Opens the Graphic Hub third party license information window,
which displays the Graphic Hub copyright information as well as the copyright and
licensing information for any third party material.

6.5.1 Graphic Hub License

For all Graphic Hub modes except Localhost and 5/4 Free, a license is required. A license is
normally acquired when the product is purchased. To get additional or updated licenses, contact
the local Vizrt representative. The Graphic Hub Terminal License window is used to register a
license for the Graphic Hub server, whether it is the first or a renewed license. A new license can
also be applied using the Graphic Hub Manager.

/\ Tip: To avoid service interruptions, make sure to update the license before it expires.

To Apply a New or Renewed License

1. Make sure that the correct license USB dongle is inserted in the machine.
2. In the Graphic Hub Terminal, go to About > Graphic Hub License.

About

Versions

Graphic Hub license

Third party licenses

Note: If this is the first time a license is registered, or if the previously registered
license has expired, the license details will display Expired! instead of an expiration
date.

License st Timg -
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. Check that:

a. The Dongle ID in the License Information file matches the Serial Number in the License
details window.

b. The license string has 32 pairs of characters, separated by a single space.

¢. No empty spaces have been added at the end of the license string.

. Copy the license string from the License Information text file.

. Paste the license string in the License string field of the License window.

a. Make sure that the license key has not been entered twice.

b. Check that the whole string is pasted.

. Click Set.

. Setting Authenticate with a Graphic Hub Administrator account, check the details again and
confirm that you want to apply the new license.
Authentication required (GHSERYER)

You are about to set a new license for the server'VizDbhServer!
on host 'GH5ERVER' currently running in ‘Multiuser’ mode.

Setting a new license key requires authentication.
Fleaze provide the Graphic Hub username and password
below.

The license string you are about to set is;

GH usernarme :

Cancel

Set license

n Do you really want to set this license string for the server
“WizDbServer' on host 'GHSERVER'Y
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8. If the license is successfully set, a dialog will be displayed:

If there is an error in setting the license, an appropriate message will be displayed.
9. The updated license information is displayed in the Graphic Hub

License Details window.

10. If the updated license information does not display immediately, try to refresh the license

information by clicking the Refresh button.

c Refresn

6.6 System Status Panel

The System Status screen shows the current mode configuration and its menu options.

o Graphic Hub Terminal - GHServer

Mode panel (1): Shows the current status of the configured mode:
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Panel Border Color: The color of the panel border may indicate a warning state when
orange. The shadow around the panel indicates the machine the web interface is
currently opened on, allowing for quick identification on cluster setups.

Naming Service/Server Name/Mode/Version: Information on the current configuration.
If the hostname exceeds 20 characters, it will be truncated. However, the tooltip will
display the name in its entirety.

Naming Service/Server Status: Displays current server status.

Data Path: Displays the path to the Graphic Hub data directory.

Shutdown Task: Displays the status of configured shutdown tasks.

- Automatic Backup: Displays the status of automatic backup tasks.
- Journal Level: Displays the current journal level.

Start Server / Emergency Shutdown (2): The button label and function changes depending on
if the Graphic Hub server is running or not. When the server is not running, click the button

to start it. When the server is running, a Graphic Hub Emergency Shutdown can be executed

by clicking the button.

/\ Warning: An Emergency shutdown will shutdown the server almost immediately. For

a controlled shutdown of the server, use the Graphic Hub Manager to shut it down.

Show Configuration (2): Open the Graphic Hub Mode Configuration panel.
Show GH Log (2): Open the Graphic Hub Server Log panel, which displays the contents of the
server log file.

See Also

Graphic Hub Manager
Graphic Hub Shut Down
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6.7 Event Log Panel

< Graphic Hub Terminal - GHServer

]

]

DHEEOEO

The Event Log panel contains messages, warnings, and error messages from the Graphic Hub
server. To view the event log panel, click the double arrow icon in the lower left corner of the
Terminal window. When the event log panel is minimized, it displays the last entry in the log only.

The event log panel view can be customized by clicking the Messages, Warnings and Errors
buttons. A pressed button means log messages of that type will be included in the event log
listing.

Copyright © 2018 Vizrt Page 391



	Graphic Hub Administrator Guide
	Introduction
	Conventions
	Customer Feedback and Suggestions
	Customer Support Request
	Before Submitting a Support Request
	Submitting a Support Request
	Graphic Hub Log Files

	System Installation
	Installation Prerequisites
	Server Requirements
	Installing Graphic Hub Applications
	Licensing the Graphic Hub

	Overview
	Graphic Hub Applications
	Graphic Hub Modes
	Which Graphic Hub Mode
	General Database Information
	Graphic Hub Naming Service

	Startup and Shutdown
	Graphic Hub Startup
	Graphic Hub Shut Down
	Graphic Hub Emergency Shutdown

	Database Management
	Main and Replication servers with failover
	User and Group management
	Test a Replication server
	Data Errors
	Import external images
	Locate duplicate files
	Add Metadata
	Replace file references
	Direct Deploy Copy
	Graphic Hub search
	Server information
	Daily backup using second Graphic Hub
	Detect and solve server differences

	Viz Pilot Database Management
	Important Pre-installation Information
	Schema Changes
	Key features and workflow of Graphic Hub 3 as Viz Pilot back end system
	Main and Replication Servers
	Import Viz Pilot Data Schema
	Resolve Pilot Data Differences Between Graphic Hubs

	Graphic Hub Archives
	Archives View
	Search View
	Contents View
	Details View
	Archive Folders
	Import Archives
	Export Archives
	Import Viz 2.x Data and Archives

	Troubleshooting
	Drivers for HASP Runtime Installation Fails
	Troubleshooting Networks and Virtual Adapters
	Restoring Corrupted Files
	Graphic Hub Manager and Viz Artist Troubleshooting
	Replication Troubleshooting
	Deploy Troubleshooting
	Graphic Hub Terminal Server Startup Issues
	Pilot Clients have no database connection
	Troubleshooting Graphic Hub REST
	Dongle Troubleshooting
	Browser Troubleshooting
	List of ports used for Graphic Hub network connectivity
	Frequently Asked Questions


	Graphic Hub Deploy Agent
	Deploy Agent Modes
	Standard Mode Supported Options
	Direct Deploy Copy Mode Supported Options
	Additional Information on Data Modes
	Standard and DDC Supported Options

	Deploy Agent Properties
	Properties of a Deploy Agent
	Configuration Panel
	Version info Panel
	High Availability Panel

	Rebuild Original Structure
	Create a New File Based Deploy Task
	Behavior

	Copy to Target Folder Only
	Schedule a Deploy Task
	To Add a Deploy Agent for Use 
	To Schedule a Deploy Task

	Maintain Deploy Agents and Tasks
	To View Deploy Tasks
	To Modify a Deploy Task
	To Search Scheduled Deploy Tasks
	To Search Finished Deploy Tasks
	To Maintain Deploy Agents


	Graphic Hub ImEx Agent
	Supported Import Media Types
	Notable limitations
	User Interface
	Initial Setup
	Quick Start
	Basic Media Sequencer Configuration

	Configuration
	Webserver configuration
	Connection settings
	Import settings
	Log settings

	Manage imports
	Import behavior
	Manage destination directories
	Manage watchfolders
	Manage GH REST hosts
	Manage Pre-Authenticated hosts

	Monitor the asset import
	Monitor distribution plans
	Monitor availability report

	Log and Report
	View ImEx Agent logs
	Manage Reports
	Create Report

	Load balancing
	ImEx Agent related configuration
	GH REST related configuration

	Troubleshooting GH ImEx Agent
	Unable to connect to GH ImEx Agent service
	Status box displays an error
	Status box displays a warning
	Media staging status shows an error
	Media staging status shows a warning


	Graphic Hub Manager
	Main Menu
	Server Menu
	View Menu
	Tools Menu
	Extra Menu
	Pilot Menu
	Info Menu

	Preferences
	General
	Import
	Viz
	Monitor Servers
	Agents
	Archives

	Explorer
	Explorer Columns
	Column Headings
	Explorer Icons
	Tool Bar
	Display Files as Icons

	Servers and Folders
	Folders
	Tree Structure
	Working with Folders
	Folder Properties
	Working with Files
	File Properties
	Folder and File Expiration Dates
	Illegal Characters

	Graphic Hub Login and Log Out
	Single Server Login Start Up
	Multiple Server Login Start-up
	Replication Server Login
	Auto Login
	Logout

	Add-ons Panel
	Journal Panel
	Journal Tool Bar
	Search the Journal
	Automatic Journal Backup
	Export and Import of Journal Entries

	Alerts
	Server Alerts
	To Configure Send E-mail
	Importing and Exporting Alert Settings

	Archives Panel
	Action Log
	Action Log Parameters
	To Add Additional Files
	To Action the Operation

	Graphic Hub License
	To Apply a License

	Graphic Hub Manager Customization
	Default Layouts
	Layout Maintenance
	Layout Procedures
	Import and Export Custom Settings

	Enable a Graphic Hub for a Virtual Studio
	To Import or Export a Virtual Studio Settings File


	Graphic Hub REST
	Graphic Hub REST API Documentation
	GH REST Configuration Settings

	Web Server Configuration Settings
	Graphic Hub Failover servers
	Methods to Test Failover Servers

	Change Graphic Hub server
	Maintain Graphic Hub REST Bindings
	Report
	Manage Reports

	Failover/Load Balancing
	Important Notes

	SSL in REST

	Graphic Hub Terminal
	Graphic Hub Mode Configuration
	Localhost, 5/4 Free, and Multiuser Configuration
	Cluster Configuration
	Graphic Hub Configuration Parameters
	Naming Service Only Modes
	Directory Agent Only Configuration

	Backup and Restore
	Internal Backup
	External Backup
	Perform Database Backup
	Restore Files
	Safe Mode

	Reports
	System information
	Export File Parameters
	Report Content

	Options
	Service Discovery Settings
	Journal/Logging Settings
	Email Configuration
	Scheduled Tasks
	Advanced Settings
	Change Terminal Password

	Help and About
	Graphic Hub License

	System Status Panel
	Event Log Panel


